MANUALE DELLA PROCEDURA AziendaPC

è l'evoluzione in ambiente windows di AziendaPc, un pacchetto gestionale che è stato sul mercato nazionale per oltre 20 anni e che contava oltre un migliaio di installazioni in aziende di piccole e medie dimensioni, in studi professionali, in negozi.

Il nostro obiettivo principale è quello di dare una interfaccia nuova alle procedure, che sia in linea con tutto il resto del software che l'utente utilizza, mantenendo la facilità d'uso e la semplicità delle funzioni che hanno sempre caratterizzato AziendaPc

Le procedure sono scritte in Visual Basic con database Access.

La distribuzione avviene attraverso una rete di concessionari .

Il software gestionale AziendaPc si compone dei seguenti moduli indipendenti o integrabili tra loro:

Contabilità Generale (Semplificata), Cespiti, Magazzino, Tracciabilità, Distinta Base, Preventivi e Ordini di vendita, Vendite (Fatturazione), Ordini di Acquisto, Preparazione e invio all'HUB Zucchetti della Fattura Elettronica,
Comunicazione Liquidazione Periodica Iva, Comunicazione Dati Fatture Emesse e Ricevute, Tessera Sanitaria

La Contabilità può essere installata nella forma 'Ridotta'. In questo caso verranno abilitate tutte le funzioni tranne le stampe fiscali (giornale bollato, registri iva e chiusure iva).

La contabilità ridotta, che ha un costo inferiore a quella completa, è utile agli utenti che emettono fatture con il computer mentre fanno tenere la contabilità al commercialista. Installando questo pacchetto, insieme alla fatturazione, potranno consultare le schede e gli scadenzari dei clienti, controllare le entrate e le uscite, pur continuando a demandare al commercialista le stampe fiscali.

Tra le caratteristiche generali della procedura ricordiamo:

  • E' multi aziendale, multi utente e sullo stesso database è possibile tenere in linea più esercizi.
  • Possibilità di fare registrazioni e di emettere documenti in euro o valute estere con memorizzazione della valuta e del cambio
  • Bilanci in formato XBRL
  • Documentazione in linea su ogni maschera
  • Semplicità nella ricerca di un codice (ricerca parziale, anche su caratteri interni a codice e descrizione)
  • Possibilità di creare o variare anagrafiche ogni volta che viene chiesto il codice di una tabella
  • Possibilità di impostare e memorizzare stampe/visualizzazioni personalizzate scegliendo i campi tra quelli messi a disposizione (listini, partitari di magazzino)
  • Parametrizzazione delle stampe su modulo (ordini, ddt, fatture), stampa documenti in formato pdf, invio fatture per email
  • Possibilità, in fase di stampa, di scegliere la stampante tra quelle messe a disposizione da windows o di modificare la destinazione della stampa portandola sul video o su file in formato caricabile da excel. Se la stampante ha più cassetti, si può scegliere il cassetto su cui stampare
  • Possibilità di abilitare un utente solo a determinate funzioni o alla sola consultazione dei dati

Prima di utilizzare i vari programmi di Gestione si consiglia di leggere i paragrafi relativi ai metodi di Ricerca di un codice (Lista di aiuto), ai pulsanti nella gestione di pagina, ai pulsanti nella gestione di linea, pulsante lista all'interno delle gestioni.

Con la funzione di personalizzazione tasti per avvio programma è possibile attivare, in ogni programma, quando si è posizionati su un campo, funzioni particolari quali ad esempio:
la calcolatrice con Ctrl F1
la calcolatrice per date con Ctrl F2

All'utente che è posizionato sulla pagina del menu, è possibile accedere ad alcune funzioni particolari descritte nel paragrafo: Menu procedure

Per la manutenzione dei database sono state inserite nel menu le funzioni:
Compatta database
Recupera database
Confronta database

NOTE

  • Si consiglia di configurare il menu di avvio in modo che scompaia la barra delle applicazioni in esecuzione dei programmi altrimenti potrebbe sovrapporsi alla parte inferiore delle maschere.
  • Se richiamando un programma o una funzione particolare, questo non viene caricato, verificare se è in esecuzione in un'altra finestra (fermo con un messaggio a video) accedendovi con i tasti ALT TAB.

Gestione utenti (PassWord)

E' possibile configurare la procedura in modo tale che ogni volta che si entra nel menu venga chiesta una Login e una PassWord.

Se viene impostato, nella tabella delle personalizzazioni generali, il parametro PwdTerminale, il menu controllerà che un utente non acceda, con la stessa login, da più terminali.

Si possono inoltre definire dei gruppi di utenti che abbiano un certo tipo di permissioni sulle varie funzioni del menu (es. entrano nei programmi di magazzino e non in quelli di contabilità) e anche la possibilità di lavorare o meno su una o più aziende in linea.
Vedi Gestione Utenti , Gestione Menu , Gestione Aziende.

Creazione del file di LOG

Vedi Gestione utenti

Il diversi moduli di cui si compone la procedura sono integrabili fra loro e, a seconda di quello che si desidera utilizzare, al momento dell'installazione, verranno copiati su disco fisso i programmi necessari.

Lo schema seguente riporta, per ogni procedura principale installata, l'elenco delle directory (contenenti i programmi) che vengono copiate.

 | Contabilità | Fatturazione | Magazzino | Ordini Cli/For | Cespiti
Comuni | X | X | X | X | X
Util | X | X | X | X | X
Coge | X |  |  |  |
CogeCom | X | X | X | X | X
MagaCom |  | X | X | X |
Maga |  |  | X |  |
FattCom |  | X |  | X |
Fatt |  | X |  |  |
Ordini |  |  |  | X |
Cespiti |  |  |  |  | X


NOTE DI INSTALLAZIONE

Condizione minima necessaria per l’installazione è che sul computer sia installato WINDOWS 98 con almeno 256 Mega di Ram,
Processore: Pentium III
Monitor: 800x600

I programmi non funzionano su versioni di NT precedenti alla 3.51.
Con NT vers.3.51 deve essere presente il service pac 5.
Si consiglia NT 4.

Note sulla configurazione di Windows:

  • Impostare la data nel formato: gg/mm/aaaa cioè con l'anno a quattro cifre
  • L'impostazione dei Numeri e Valuta non devono essere in contrasto.
  • Impostazione italiana: simbolo raggruppamento cifre: "." (punto).
  • Separatore decimale: "," (virgola)

Dalla versione 2.0 i programmi gestiscono database sia Access 97 sia Access 2000.
In particolare è stato aggiornato il DAO alla versione 3.6.

Dalla versione 2.01 potrebbe essere necessario intervenire per abilitare la lettura del manuale in linea.

Dalla versione 3.04 del Gennaio 2013, l'installazione installa automaticamente anche i due file vbsendmail.dll e mswinsck.ocx che servono per l'invio stampe per email.
Se si disinstalla la vecchia versione, esse NON vengono disinstallate.
Se si reinstalla , e la directory di installazione è la stessa, verrà dato un messaggio che la Dll esiste e chiede se si vuole sovrascrivere.
E' bene perciò o re installare nella stessa directory di prima o, ancora meglio, disinstallarle prima di ripetere l'installazione.

Sul Server 2008 l’installazione mette già mswinsck.ocx ( e anche tutte le altre DLL) direttamente in Syswow64 così come va in windows7 a 64 bit
In windows7 a 64 bit le DLL le mette sia in System32 sia in Syswow64

PROTEZIONE

Sulle procedure è attiva una protezione che consiste in una password da inserire al termine della prima installazione.
Il concessionario dovrà perciò chiedere a Zucchetti sede di Ravenna la PassWord, una volta terminata l'installazione dei programmi, prima di procedere alla configurazione dei dati.
Infatti la prima volta che si entra nel menu verrà presentata la maschera Dati Licenza che dovrà essere compilata in modo opportuno per consentire un corretto avvio delle procedure.
Per conoscere, prima dell’installazione, il numero dell’ hard disk, si deve eseguire, sul computer sul quale si farà la configurazione e l’inserimento della PassWord il programma: PWDLocal.exe che è disponibile sul sito internet di Azienda, sul CD della procedura nella directory BASEDOC oppure che potrà essere inviato a richiesta.

INSTALLAZIONE

Nota per installazioni su S.O. Windows 98 o ME dalle versioni 2.00 e successive
(dove il DAO è stato aggiornato alla versione 3.6).

Su Sistemi Operativi diversi da Windows 98 o Me, il DAO è già presente sul computer mentre per i due S.O. suddetti occorre installarlo a mano.
Per farlo, entrare nella cartella \DLL\jetSetup del cd che a sua volta contiene altre cartelle, una per ogni S.O.
Si entra nella cartella corrispondente al S.O. installato sul computer in uso e si deve eseguire l'EXE in essa contenuto.

In presenza di S.O. Vista, è altamente consigliato installare come Administrator.
Inoltre l’installazione su un computer con S.O. Vista provoca sempre un errore su un file Dao, errore che deve essere ignorato.
Se invece si verifica un errore anche sul file msvbvm50.dll è indispensabile rieseguire l’installazione lanciando manualmente il Setup invece di lasciarla partire in automatico.

Se si sta installando un Client in ambienti Vista, Windows 7 e Windows 8 si consiglia di vedere le note riportate di seguito.

Se si rende necessario reinstallare la procedura su un computer nel quale è già stata fatta una installazione, è indispensabile disinstallarla da Impostazioni - Pannello di controllo - Installazione applicazioni, prima di procedere alla nuova installazione.

Se si utilizza un lettore CD Rom condiviso, occorre, prima di proseguire assegnargli una lettera (es. Z:)

Una volta inserito su un computer il CD contenente la procedura, parte automaticamente l' installazione o l'aggiornamento a seconda che il programma senta che è presente o meno una precedente installazione.

Se si rendesse necessario lanciare manualmente l'esecuzione, si dovrà lanciare dalla directory principale del Cd-Rom:

  • SetUp.exe
    per una nuova installazione
  • Aggiorna.exe
    per un aggiornamento

A seconda del tipo di installazione che ci si appresta a fare, dovrà essere fatta la scelta opportuna. Se si installa in rete, l’installazione dovrà essere eseguita su ogni postazione di lavoro, seguendo quanto specificato in seguito.

DESCRIZIONE DELLE FASI ESEGUITE DAL SETUP PER L'INSTALLAZIONE

Il programma di SETUP preparerà il sistema e poi lancerà l'INSTALLAZIONE.
Verrà presentata la seguente videata di avvertimento con il testo informativo,
nella quale è possibile proseguire o annullare l'installazione:

[OK] CONFERMA L'INSTALLAZIONE

[ESCI] ANNULLA L'INSTALLAZIONE
A seguito dell'interruzione dell'INSTALLAZIONE, si avranno le seguenti videate di messaggi:

1) Programma interrotto prima dell'installazione.
E' possibile rieseguirlo in un secondo momento - [premere OK]

2) Verrà eseguita l'utilità di disinstallazione dell'applicazione
per la rimozione dei file temporanei - [premere OK]

3) Videata di avanzamento stato disinstallazione
- Rimozione in corso dei file temporanei

4) Il programma è stato disinstallato - [premere OK]
A seconda delle situazioni si potrà presentare anche la richiesta di conferma per deregistrare le DLL registrate dal SETUP; su questa richiesta è possibile proseguire premendo MANTIENI o DISINSTALLA.

A seguito della conferma dell'INSTALLAZIONE, si avranno le seguenti videate di selezione:

TIPO DI INSTALLAZIONE

Installazione Postazione singola

Viene proposta la cartella "c:\aziwin" in cui installare i programmi
E' possibile cambiarla con "Cambia directory" e sceglierne un'altra già esistente o scriverne direttamente una che verrà creata in automatico.
Con un click sull'icona si inizia l'installazione.

Nella maschera di configurazione iniziale si può modificare la directory principale (directory in cui verranno installati i programmi), è obbligatorio inserire il nome del terminale (testo libero), la cartella in cui si trovano i programmi da copiare e infine spuntare i pacchetti da installare.
 Non è necessario che siano gli stessi per cui è stata chiesta la licenza, quelli diversi potranno essere utilizzati in archivi dimostrativi
(Per Azienda si intendono i tre pacchetti Contabilità completa, Magazzino e Fatturazione)

Installazione RETE postazione SERVER
 Deve essere eseguita per l’installazione della procedura sul Server di reti NT o Windows (computer che dovrà contenere programmi e dati).
Viene presentata la maschera come per l'installazione Monoutente e proposta la cartella "f:\aziwin" in cui installare i programmi
E' possibile cambiarla con "Cambia directory" e sceglierne un'altra già esistente o scriverne direttamente una che verrà creata in automatico.
Con un click sull'icona si inizia l'installazione.
Anche la seconda maschera proposta è uguale a quella per la monoutenza.

Installazione RETE postazione CLIENT

Deve essere eseguita per l’installazione della procedura su tutti i Client di reti NT o Windows sul Server di reti Novell o NT (nel caso su tale server non venga utilizzato il programma).

Il programma cerca se l’installazione server è stata fatta in una delle cartelle standard f:\aziwin, f:\programmi\aziwin o f:\sira\aziwin e, se la trova, la propone come directory di installazione.
Se non la trova viene data la segnalazione:
"Impossibile determinare una directory di installazione predefinita valida. Sarà necessario specificare una directory di destinazione"
occorre indicare sempre la cartella del SERVER su cui sono stati installati i programmi (es. z:\aziwin)

Se non si vede il disco del server:
 in presenza di SO Vista o Windows 7, occorre disabilitare l’UAC , sul client:
* Vista: pannello di controllo, Gestione utenti, Opzione Disattiva controllo accesso utenti
* Windows7: Start poi in Cerca programma o file scrivere UAC e si posizionerà nella maschera da modificare (oppure: pannello di controllo, Account utente e protezione famiglia, Account utente)
Modifica le impostazioni di controllo dell'account utente: "non notificare mai"

In presenza di SO Windows 8 - Windows 10 - Windows 7 (alcune versioni):
occorre aprire una finestra Dos come amministratore (su win 10: pulsante dx su Start poi Prompt dei Comandi poi Amministratore, altri: pulsante DX sull'icona per accedere al Dos (Prompt dei comandi) poi selezionare: Esegui come amministratore):
- poi scrivere ad esempio:
net use F: \\172.16.0.227\Gestionale password /USER:172.16.0.227\nome_login
dove dopo F: ci va uno spazio e 172.16.0.227 è l'indirizzo IP del server
Gestionale ad esempio, è il nome della connessione (Si vede da risorse del computer andando sulla riga che ha la lettera data alla condivisione ed è la prima parola che si incontra e non quella tra le parentesi)
e password è la password legata alla login (se non è stata messa la password, l'istruzione finisce qui!)
supponendo di dover condividere con F la directory Gestionale.
Se nel nome login ci sono spazi, l'utente si dovrà mettere tra apici: "172.16.0.227\nome_login"
Al posto dell'IP e login, si può mettere il percorso UNC del server oppure, se si tratta di un Server vero e proprio, il nome del dominio.
Anche in caso di necessità di disinstallare il gestionale occorre procedere allo stesso modo perchè il programma di disinstallazione possa vedere il disco condiviso.

Successivamente
- Inserire il nome del terminale (è obbligatorio dare un nome diverso per ogni postazione)
- Non barrare la casella aggiornamento e scegliere quali pacchetti installare (con l’opzione: Avanzate) SOLO SE si sta installando su un Server Novell o NT(nel caso su tale server non venga utilizzato il programma).
E' OBBLIGATORIO indicare, come directory di installazione, la directory del server sulla quale sono stati installati i programmi.
Segue la maschera di configurazione iniziale:

Sul primo client si deve SEMPRE dire di "aggiornare il file ini condiviso" , sui successivi invece NON spuntare mai l'opzione.
Indicare in "directory principale" la cartella del server su cui sono stati installati i programmi.
Scrivere il nome del terminale.
Indicare la cartella in cui si trovano i programmi da installare.

SOLO se Server Novell o NT ‘da non utilizzare’, occorre anche scegliere i pacchetti da installare premendo il pulsante "Avanzate - personalizzate"
Alla fine di questa installazione questo client è già completamente installato.

N.B.

  • Se si ricevono messaggi:
    - "Uno o più file esistenti verranno sostituiti. Annulla l'installazione rispondere?" Rispondere: NO
    - "Se si installa una applicazione esistente, questa potrebbe venire danneggiata ... Si
    desidera continuare? "
    Rispondere: SI
  • In ogni programma della procedura si può accedere al manuale in linea premendo il tasto F1.

Terminata l’installazione, entrando nella procedura, il programma si posiziona sull’archivio dimostrativo. Questo archivio verrà sovrapposto, con quello contenuto sul cd di installazione, ad ogni nuovo aggiornamento per cui è indispensabile creare dei nuovi database per ogni azienda da gestire.
Tali database dovranno essere creati con il pulsante [image] (E) Crea azienda che si trova nella funzione Gestione database aziende

PROBLEMA DI MASCHERA RICHIAMATA E NON VISIBILE

MA CHE LAMPEGGIA NELLA TASKBAR

Con i sistemi operativi Windows XP, Windows 2000, Vista e Windows 7 ci sono dei casi in cui, quando si cerca di aprire una maschera, questa non diventa immediatamente visibile ma lampeggia la sua icona nella taskbar.
Questo può accadere quando si apre un programma da menù o quando si torna al menù chiudendo un programma se nel frattempo era stata lanciato un altro programma che quindi diventerebbe attivo al posto del menù.
Per rimediare a questo problema si può intervenire manualmente nel REGEDIT
N.B. Poichè l'operazione è molto delicata si raccomanda di fare la massima attenzione.

Una volta caricato il Regedit cercare il parametro:
HKEY_CURRENT_USER/Control Panel/Desktop
variabile: ForeGroundLockTimeout
lo si dovrebbe trovare con il valore DWORD: esadecimale 30d40 (200000 decimale).
Modificarlo con pulsante destro, Modifica, Modifica valore DWORD e mettere 0 (decimale)
quindi uscire.

Con windows2000 e XP è possibile, in alternativa, utilizzare uno strumento chiamato Powertoys noto anche come Tweak-Ui nelle versioni dei precedenti sistemi operativi, programma che serve per configurare varie opzioni di windows.
Per Windows Xp può essere scaricato all'indirizzo:
" http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx"
mentre per i sistemi operativi precedenti si trova all'indirizzo:
"http://www.microsoft.com/ntworkstation/downloads/PowerToys/Networking/NTTweakUI.asp"

Dopo averlo installato in windows xp viene messo nel menù programmi mentre in windows 2000 viene messo nel pannello di controllo.

La maschera che si presenta, e le relative opzioni, sono diverse a seconda del sistema operativo che si sta usando.

Con Windows XP bisogna espandere la voce "Generale" cliccando sul + che si trova alla sua sinistra e selezionare la voce "Focus". Deselezionando o selezionando la voce:
"Prevent applications from stealing focus"
si modificherà questa funzionalità, in particolare deselezionandola i programmi che richiedono il focus potranno ottenerlo senza far lampeggiare la loro icona nel taskbar.

Con Windows 2000 selezionare il folder General. Anche qui deselezionando o selezionando la voce:
"Prevent applications from stealing focus"
si otterrà la funzionalità voluta.

Vista la delicatezza dell'uso di questi programmi si consiglia di farlo utilizzare soltanto a personale esperto.

COME ELIMINARE L'EVENTUALE MESSAGGIO DI AUTORE SCONOSCIUTO CHE COMPARE AL LANCIO DEL MENU:

Entrare in "Internet explorer" poi scegliere Strumenti, Opzioni internet, Protezione
Posizionarsi su Intranet Locale poi fare un click sul pulsante Siti e togliere la spunta in Rileva automaticamente rete intranet
(automaticamente verranno spuntate tutte e tre le opzioni successive)
Confermare con OK

Se non bastasse questo si può fare un click sul pulsante "Livello Personalizzato" poi cercare
in Impostazioni di protezione, tra le Varie: Avvio di applicazioni e file non sicuri e togliere la spunta su Attiva

Se questo non basta, occorre eseguire quanto indicato nelle note per abilitare l'Help in linea.


AGGIORNAMENTO PROCEDURA (NOTE)

L'elenco delle modifiche contenute nell'aggiornamento si può consultare al paragrafo: Note nuove release.

Se si scarica il file ZIP dell'aggiornamento dal sito internet www.aziendapc.it è assolutamente necessario NON utilizzare lo scompattatore di windows per scompattarlo ma winzip o 7zip al fine di mantenere le date originali dei file e in particolare delle DLL.

Il file zip dovrà essere scompattato in una nuova cartella dalla quale si potrà eseguire il programma Autorun_guida.bat (o il programma Aggiorna) per lanciare l'aggiornamento.

Dalla versione 2.0 i programmi gestiscono database sia Access 97 sia Access 2000. In particolare è stato aggiornato il DAO alla versione 3.6.

In presenza di sistema operativo Vista, se sorgono problemi con l’aggiornamento, si consiglia di lanciare manualmente il programma Aggiorna dal CD, come amministratore (Risorse del computer, pulsante Dx, Esegui come amministratore).

Quando si inserisce il CD di installazione della procedura su un computer nel quale essa è già stata installata, viene visualizzata una maschera che propone l'Aggiornamento.
La procedura di aggiornamento può essere eseguita anche lanciando il programma Autorun_guida.bat (o il programma Aggiorna) dal CD o da una cartella in cui è stato copiato precedentemente tutto il contenuto del CD.

Dalla versione 2.01 potrebbe essere necessario intervenire per abilitare la lettura del manuale in linea.

Prima di inserire eseguire l'aggiornamento è indispensabile:

  • V erificare che il database AziwDemo non sia un DB di lavoro in quanto verrebbe sovrapposto dal nuovo DB aggiornato (pertanto se fosse così, occorre innanzitutto duplicare tale DB con un nuovo nome e agganciarlo nella gestione delle aziende di lavoro)

  • Copiare in un’area di appoggio
    - il database del menu (....\aziwin\azimenu.mdb)
    (es. c:\programmi\aziwin o c:\aziwin)
    - i database degli archivi delle varie aziende (.....\aziwin\database\…)
    - il file aziwin.ini (in ....\aziwin).

Eseguire il programma Autorun_guida.bat (o il programma Aggiorna) da una cartella o Inserire il CD della procedura

Questa operazione va fatta sul computer dove risiedono gli EXE oppure sul primo client, in modo da aggiornare anche gli exe sul server.

Se si aggiorna una versione precedente alla 2.00, potrebbe esserci un problema di aggiornamento del DAO.

In presenza di sistemi operativi windows 98 o Me, quando si lancia l’aggiornamento della procedura, viene visualizzata una maschera che consente di eseguire, oltre all’aggiornamento delle Dll, l’installazione del DAO 3.6.
Come suggerito a video, è necessario premere il pulsante:
‘Premere qui per installarlo’ per eseguire l’installazione
poi, premere ‘Aggiorna’ per verificare se essa è andata buon fine.

Con i sistemi operativi windows XP, 2000, Vista il DAO in oggetto dovrebbe essere già installato per cui nella maschera verrà chiesto di aggiornare solo le DLL.

Se si rendesse necessario lanciare a mano l’installazione del DAO, si può entrare nella cartella \DLL\JetSetup del cd. Essa contiene tante cartelle, una per ogni sistema operativo. Si può entrare nella cartella corrispondente al sistema operativo installato sul computer in uso ed eseguire l’exe in essa contenuto.

Se è necessario l'aggiornamento delle DLL, viene visualizzata una maschera "Allineamento DLL Azienda" che presenta già spuntato il flag "Esegui aggiornamento programmi" (se si toglie la spunta, verranno aggiornate solo le DLL senza procedere all'aggiornamento del programma) e chiede la conferma per proseguire l'elaborazione.

Verrà poi presentata una maschera in cui viene chiesto all'utente di scegliere il tipo di aggiornamento:

  • Client

  • Server / Monoutente

Aggiornamento Server / Monoutente

Viene presentata una maschera già compilata, predisposta per copiare dal CD le Dll aggiornate, il file menu.exe, gli eseguibili delle procedure installate e lanciare l’aggiornamento dei database per l’aggiunta dei nuovi campi (occorre non deselezionare nessuna di queste opzioni!).
Si chiede di controllare:

  • La directory del disco fisso contenente attualmente la directory delle Dll da aggiornare (programmi\aziwin o sira\aziwin o \aziwin)

  • La directory principale della procedura (c:\programmi\aziwin o c:\sira\aziwin o c:\aziwin) Quella proposta viene letta dal file aziwin.ini

  • La directory da cui estrarre i file (directory principale del CD o cartella in cui è stato copiato il contenuto del CD)

Viene poi presentato un elenco dei moduli da aggiornare in base ai pacchetti che risultano installati nel menu attuale. Se serve si può, in questa fase, aggiungere un nuovo modulo spuntando la casella corrispondente (es. una ditta che non aveva la procedura Cespiti, la può aggiungere in questa fase, poi dovrà chiedere la passWord per abilitarla).

Premendo il tasto AGGIORNA, inizia l’aggiornamento.

NOTA: Saranno eseguiti gli aggiornamenti successivi alla data indicata nella tabella "Config" del Menu.

Ad eventuali richieste rispondere OK (sono dovute a registrazioni di DLL).
Al termine della copia degli EXE e DLL parte l’aggiornamento dei database.
Prima di confermare l'elaborazione con OK è possibile scegliere, spuntando o meno l'opzione:
Dare segnalazioni su errori di aggiornamento
se il programma deve interrompere l'elaborazione ogni volta che trova un errore da segnalare (es. un campo già presente sul Db) oppure se deve elaborare tutte le aziende senza interruzioni.

Se si sceglie di "dare segnalazioni" e il programma trova qualche campo che esiste già sui DB, pone la domanda: Continui l’elaborazione su questo DB? Alla quale si può rispondere in tre modi diversi: Si, No (abbandona il DB corrente e passa a quello successivo, se c’è), Sì e non chiedere più se proseguire (se si fa questa scelta chiede se si vogliono avere o meno gli eventuali messaggi di errore).
Log dettagliato
Al fine di tenere traccia dei vari passi dell'aggiornamento, il programma scrive un file di log (Aggiornalog.txt) nella directory aziwin dove, per ogni database, viene riportata la data contenuta inizialmente nella tabella Config, il numero delle modifiche, l'avvenuto compattamento e la data finale impostata dall'aggiornamento.
Se si conferma il log dettagliato, verranno elencati tutti i campi aggiornati e, per ciascuno, il risultato dell'aggiornamento.

DESCRIZIONE DELLE FASI PRELIMINARI ESEGUITE DALL'AGGIORNAMENTO

Il programma di AGGIORNAMENTO preparerà il sistema con le DLL e poi lancerà l'AGGIORNAMENTO di AziendaPC vero e proprio.

Se viene rilevata (automaticamente) la necessità di aggiornare anche le DLL,

viene visualizzata una videata "Allineamento DLL Azienda" che presenta già spuntato il flag "Esegui aggiornamento programmi" (togliendo tale spunta, vengono aggiornate solo le DLL senza procedere all'aggiornamento del programma) e chiede la conferma per proseguire l'elaborazione:

- Premendo [OK]
1) vengono AGGIORNATE LE DLL
2) prosegue come se si fosse premuto [ESCI] (vedi sotto)

- Premendo [ESCI]
1) in base al flag "Esegui aggiornamento programmi", avviene:
- se non è spuntato - ESCE dal programma di aggiornamento;
- se è spuntato - viene presentata la videata dell'AGGIORNAMENTO
(da cui si può uscire senza eseguirlo).

Il programma d'AGGIORNAMENTO di AziendaPC, presenta una maschera in cui si chiede all'utente di scegliere il "tipo di aggiornamento":

- Client
- Server / Monoutente

e dalla quale è possibile annullare o proseguire l'aggiornamento tramite i tasti:

[ANNULLA] ANNULLA L'AGGIORNAMENTO, ritornando alla videata di lancio

[PROSEGUI] Lancia la procedura di aggiornamento dei programmi.

Aggiornamento Client

Sui singoli client le DLL si aggiorneranno automaticamente la prima volta che si accede alla procedura, dopo che questa è stata aggiornata sul server.

Solo per aggiornare alla versione 2.00 o successive, da una versione precedente alla 2.00,
è indispensabile inserire il Cd e seguire le istruzioni a video. Inserire, come richiesto:
la directory del disco fisso contenente attualmente la directory delle Dll da aggiornare (programmi\aziwin) e la directory da cui estrarre i file (directory principale del CD).

Confermare per aggiornare. Ad eventuali richieste rispondere OK
(sono dovute a registrazioni di DLL).
Lanciando direttamente il programma senza aver fatto l’aggiornamento non sarebbe possibile aggiornare tutte le DLL.

Registratore di Cassa

Per la versione 2.00B
Per l’aggiornamento di un client collegato al registratore di cassa è necessario copiare il file Rcassa.exe o RcassaRch.exe a seconda del tipo di registratore, dalla directory Rcassa del CD nella directory dov’è attualmente installato.

Inoltre occorre verificare la versione della libreria di comunicazione con le porte seriali: a tale scopo è sufficiente posizionarsi nella directory Rcassa del Cd ed eseguire il programma AggCommOcx.exe e premere sul pulsante Aggiorna.


NOTE PER L'ABILITAZIONE DELL'HELP IN LINEA

Possibili problemi per l'utilizzo del Manuale in linea

Con il sistema operativo Windows XP e VISTA, potrebbe capitare che, lanciando l'Help da AziendaWin (dalla versione 2.01 e successive), venga segnalato che la pagina non esiste o non è stata trovata. Questo è dovuto ad un fatto di protezione delle ultime versioni di Windows.

Per risolvere il problema n elle installazioni monoutente cercare il file AziWin.chm (che si trova nella cartella ….\aziwin\Help), cliccare su di esso con il tasto di destra, selezionare "Proprietà" e annullare il Blocco della protezione.

Se l’installazione è in rete:
 nelle versioni successive alla 3.05C, quando si fa partire il menu da un client, il programma copia il file di Help in locale, nella cartella aziwin\DLL (se la sua data è diversa da quello in rete) in modo da rendere sempre visibile l'Help.

Per le vecchie versioni si può adottare una delle diverse soluzioni descritte in seguito:

  1. Mettere il chm (file dell’help) in una directory locale e mettere il percorso nella riga PathHelp=C:\…. dell'Aziwin.INI di ogni computer (Soluzione non consigliata)
  2. Modificare il regedit dei vari terminali in 2 modi diversi
    cercare o creare la chiave:
    per i sistemi a 32 bit
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions]
    mentre per i sistemi a 64 bit
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Microsoft    \HTMLHelp\1.x\ItssRestrictions]

  • Soluzione 1 (Abilitazione su tutta la rete locale):
    Inserire un nuovo (pulsante DX) Valore dword e dargli il nome: MaxAllowedZone
    Assegnare un valore 1 per abilitare la lettura dei file chm su tutta la rete locale

    Nel caso che questa soluzione non risolva il problema, si deve     verificare se è stata fatta la connessione al disco 'server' usando l'indirizzo IP piuttosto che un UNC
     In tal caso si utilizza la soluzione 2 indicata di seguito
    oppure si modifica la Protezione di Internet Esplorer come descritto in soluzione 3.

  • Soluzione 2 (Abilitazione su percorsi specifici):
    Inserire un nuovo (pulsante DX) Valore stringa e dargli il nome: UrlAllowList e assegnargli il valore:
    percorso da abilitare seguito da ;
    scritta fissa:     file://
    poi ripetere il percorso
    (esempio: f:\aziwin\;file://f:\aziwin)
    è possibile inserire nel parametro più percorsi da abilitare;
    è possibile infine, identificare i percorsi sia usando la nomenclatura UNC, (ad esempio \\nome_server\condivisione\nome_dir) sia l’eventuale lettera assegnata alla condivisione.

  • Soluzione 3

Entrare in Esplorer, Strumenti, Opzioni Internet, Protezione:

Selezionare Intranet locale e cliccare sul pulsante SITI poi sul pulsante: AVANZATE
Nel campo Aggiungi sito web all’area scrivere l’indirizzo IP a cui ci si collega (leggerlo da Esplora Risorse) e premere il pulsante ‘aggiungi’

Poi chiudere e confermare tutte le maschere.


CREAZIONE NUOVA AZIENDA

Come procedere per preparare gli archivi per una nuova azienda.

Quando parte, il menu si posiziona sull'archivio dimostrativo, per creare un nuovo database occorre andare nel menu 'Parametri e utilità' ed eseguire la funzione Gestione database aziende. Come specificato nel manuale della suddetta funzione, è possibile creare il nuovo database a partire da un database vuoto o dallo stesso dimostrativo.

Successivamente, dopo aver fatto il 'Cambio azienda' per posizionarsi sulla nuova azienda creata, è necessario eseguire la funzione Dati Generali Azienda (parametri) per verificare, tabella per tabella, la correttezza dei dati inseriti e inserire tutti i codici obbligatori.

La creazione, nelle singole tabelle, dei codici obbligatori, può essere fatta direttamente dalla maschera della richiesta parametri aprendo la lista di aiuto sui codici e premendo il pulsante [image] (X) Gestione archivio

Per la manutenzione dei database sono state inserite le funzioni:
Compatta database
Recupera database
Confronta database


GESTIONE DATABASE AZIENDE

Percorso: Parametri e utilità - Dati azienda e parametri

Questa funzione consente di creare gli archivi delle varie aziende da gestire. Viene presentato l'elenco di quelle già presenti su disco.
La creazione di una nuova si fa premendo il pulsante [image] (E) Crea azienda dopo essersi posizionati su una riga di un'azienda già in uso (per duplicare i suoi archivi) oppure su una riga nuova (per duplicare il database 'vuoto' fornito con i programmi).
Vedi 'Come creare una nuova ditta' per le istruzioni di pulizia del database duplicato.

In alternativa si può collegare un'azienda il cui database è già presente su disco, compilando manualmente i dati della riga.
ATTENZIONE: nel percorso e nome del file NON devono esserci spazi bianchi

Per facilitare l'installazione, il database definito 'vuoto' non lo è completamente ma sono stati inseriti alcuni dati fondamentali che potranno poi essere confermati o variati dall'installatore.

In creazione, verrà chiesto il codice, l'identificativo e la descrizione da dare alla nuova ditta.

Codice e descrizione verranno visualizzati alla richiesta dell'elenco delle ditte esistenti.

La descrizione che compare qui, non è la Ragione Sociale della ditta che invece dovrà essere inserita successivamente ma è quella 'descrizione' scritta sul video in ogni maschera di gestione ad indicare qual è l'azienda in uso (questo consente di duplicare un archivio 'buono' su uno di 'prova' cambiando semplicemente codice e descrizione senza rischiare di confondersi quando si utilizza l'uno o l'altro)

L'identificativo azienda viene utilizzato, dalle funzioni che usano o generano file diversi per le varie aziende (es. generazione file riba), per costruire il nome di tali file (es.Riba001 etc.) . E' perciò indispensabile che i caratteri o i numeri che compaiono in questo campo siano diversi per ogni azienda.
Seguono la richiesta della path completa del Database di base (cioè quello da duplicare) e del Database da creare (se del database da creare si mette solo il nome, esso verrà creato nell'area prevista all'installazione come area archivi).
Nel percorso e nome del file NON devono esserci spazi bianchi

Permissioni
Una volta creata l'azienda si possono definire delle permissioni per l'accesso ad essa. Sarà possibile inibire l'accesso o consentire la sola visualizzazione dei dati a uno o più utenti (login).
Le login (gruppi) non autorizzate non vedranno più quell'azienda nella lista del 'Cambio azienda', le altre vedranno poi solo le funzioni per le quali, eventualmente, sono state abilitate nella Gestione menu.
Premendo il pulsante [image] (U) Mostra autorizzazioni verrà chiesta una login e una password per accedere. Dovranno essere digitate login e password del supervisor che, se ancora non sono state definite nella Gestione Utenti, sono quelle di default
Si rendono così disponibili i campi in cui scrivere le login (gruppi, terminali) abilitate o disabilitate separate da ; (punto e virgola).
Per i campi che indicano abilitazioni in lettura e scrittura, valgono le stesse regole dell'abilitazione Menu Dettagli e, queste ultime 'abilitazioni' si aggiungono a quelle messe nel Menu.
Al fine di un corretto funzionamento, è indispensabile che Login e Gruppi siano stati definiti in precedenza con la Gestione Utenti e i terminali siano quelli definiti al momento dell'installazione e scritti nei vari AziWin.INI.
Una ulteriore pressione del tasto suddetto consentirà di nascondere i campi.
Un'azienda ottenuta come duplicazione di un'altra manterrà le permissioni dell'originale.

Password sul database
Se si crea un'azienda a partire da un database su cui è stata messa la password, anche il nuovo avrà la stessa password
Per gestire tale password si può utilizzare il pulsante [image] (W) PassWord database
Verrà chiesta Login e Password del Supervisor (che dovranno essere state precedentemente impostate in Gestione Utenti) poi viene presentata una maschera con il campo password bianco e si consente di digitare la password

Eseguo caricamento automatico dati da file ascii
Per importare gli archivi da un'azienda gestita con AziendaPc in Dos.

Dopo la creazione degli archivi è indispensabile compilare tutte le tabelle dei parametri per le varie procedure con la funzione: Dati Generali Azienda.
Dall' elenco delle aziende è possibile accedere a questa funzione con:
(Alt Z) Definizione Azienda.
Il pulsante [image] (N) Nuovo consente di compilare una nuova riga con i dati di un'azienda il cui database è già presente su disco.
Gli altri pulsanti disponibili in questa Gestione sono quelli descritti in Pulsanti nella gestione di linea.

La cancellazione di un'azienda dall'elenco non provoca la cancellazione del database dal disco, che, se necessario dovrà essere cancellato manualmente.

Eseguo caricamento automatico dati da file ascii
IMPORTANTE: perché questa opzione venga eseguita correttamente occorre aver precedentemente compilato attentamente l'elenco dei file da caricare da Menu Parametri e utilità, utilità: Selezione File caricamento batch. Le caratteristiche (campi da caricare etc.) del caricamento di ogni tabella sono gestibili dal programma: Parametri e utilità, utilità Gestione caratteristiche caricamento dati.

Se è stata scelta l'opzione, verrà proposta una videata nella quale si consente di scegliere la directory dalla quale leggere i file ascii da caricare (es. \ARCAZ001- tali file saranno stati precedentemente scaricati dalla procedura Dos con l'apposita funzione) e si chiede di inserire alcuni codici conto e causali, nel caso si intendano caricare le registrazioni di prima nota (movimenti contabili e iva).

I codici dei conti chiesti, da inserire nella forma 04 / 03 / 0003, sono i conti iva (vendite, acquisti, corrispettivi e sospesa, acquisti e vendite intra cee).
Inoltre si chiede di inserire i codici delle causali Note di Credito emessa e ricevuta (es. 02 e 04).

L'inserimento di tali codici è fondamentale per ottenere un caricamento corretto delle registrazioni.

Se in dos sono state inserite fatture di Trasportatori (ai trasportatori abituali è data facoltà di rimandare l'iva delle vendite al periodo successivo a quello di fatturazione), si chiede di digitare i codici delle causali utilizzate a tale scopo e se la ditta è mensile o trimestrale, in modo da poter scrivere sulle registrazioni, il periodo di competenza Iva.

Infine, per il caricamento dei clienti e dei fornitori, si chiede se è stato gestito il secondo campo 'Codice Fiscale' che dovrà contenere il codice fiscale delle ditte. Se è stato gestito, occorre avere selezionato in fase di Selezione files caricamento batch (dal Menu: Parametri e utilità, Utilità, dove si scelgono le tabelle da importare dal dos) le righe Clienti_2CF (Fornitori_2CF) piuttosto che quelle in corrispondenza a Clienti (Fornitori).

In questo caso i 2 campi del dos verranno trattati come segue: il contenuto del vecchio campo: Cod.Fiscale/P.Iva verrà scritto sul cliente aziwin, in Partita iva se lungo 11 , viceversa in codice fiscale. Il secondo cod. fiscale viene scritto in Aziwin nel campo Cod.fiscale SOLO se questo è vuoto.

Se al termine del caricamento vengono segnalati degli errori, occorre andare nel programma Visualizza errori di caricamento per vedere il motivo degli errori.
Se si rende necessario ripetere il caricamento, occorre cancellare la riga che riguarda l'azienda in oggetto dall'elenco aziende, cancellare con Windows il database collegato (in aziwin\database) poi ripetere la creazione e l'import dei dati.
Se si duplicano archivi di un'altra azienda, occorre che questi non siano in uso. Una volta creati i nuovi archivi si chiede di compilare i dati anagrafici della ditta e l'elenco delle procedure installate.


NOTE NUOVE RELEASE

Dalla versione 2.0, i programmi gestiscono database sia Access 97 sia Access 2000.
In particolare è stato aggiornato il DAO alla versione 3.6.

Per quanto riguarda le note di installazione di un aggiornamento, si rimanda al capitolo dedicato.

Versione 4,05 del 21/10/2020
Versione 4.04 del 18/11/2019
Versione 4.03C del 14/03/2019
Versione 4.03B del 16/01/2019
Versione 4.03 del 03/12/2018
Versione 4.02B del 04/07/2018
Versione 4.02 del 18/12/2017
Versione 4.01D del 28/08/2017
Versione 4.01C del 24/05/2017
Versione 4.01B del 06/03/2017
Versione 4.01 19/12/2016
Versione 4.00b 25/07/2016
Versione 4.00 del 14/04/2016
Versione 3.06 del 26/01/2015
Versione 3.05c del 14/07/2014
Versione 3.05b del 20/03/2014
Versione 3.05 del 30/10/2013
Versione 3.04 del 30/01/2013
Versione 3.03b del 03/09/2012
Versione 3.03a del 04/04/2012
Versione 3.03 del 16/11/2011
Versione 3.02a del 05/05/2011
Versione 3.02 del 20/01/2011
Versione 3.01a del 15/11/2010
Versione 3.01 del 07/06/2010
Versione 3.00 del 01/03/2010
Versione 2.02 del 30/11/2009
Versione 2.01 del 27/11/2008
Versione 2.00 B del 10/07/2008
Versione 2.00 del 19/12/2007
Versione 1.14D del 15/09/2007
Versione 1.14C del 04/06/2007


NOTE SULLA VERSIONE 4.04 DEL 11/11/2019

NOTE SULLA VERSIONE 4.05 DEL 21/10/2020

Principali novità della release

MODIFICHE PER FATTURA ELETTRONICA

L’agenzia delle entrate ha predisposto delle modifiche nel tracciato della fattura elettronica che saranno opzionali a partire dal 1 Ottobre 2020 e obbligatori dal 1 Gennaio 2021; riportiamo qui le principali novità e le operazioni da eseguire.

1. Aggiunto nuovi Tipi Documento

TD16 | integrazione fattura reverse charge interno
TD17 | integrazione/autofattura per acquisto servizi dall'estero
TD18 | integrazione per acquisto di beni intracomunitari
TD19 | integrazione/autofattura per acquisto di beni ex art.17 c.2 DPR 633/72
TD20 | autofattura per regolarizzazione e integrazione delle fatture (ex art.6 c.8 d.lgs. 471/97 o art.46 c.5 D.L. 331/93)
TD21 | autofattura per splafonamento
TD22 | estrazione beni da Deposito IVA
TD23 | estrazione beni da Deposito IVA con versamento dell'IVA
TD24 | fattura differita di cui all'art. 21, comma 4, lett. a)
TD25 | fattura differita di cui all'art. 21, comma 4, terzo periodo lett. b)
TD26 | cessione di beni ammortizzabili e per passaggi interni (ex art.36 DPR 633/72)
TD27 | fattura per autoconsumo o per cessioni gratuite senza rivalsa

(TD20 è in realtà una modifica di quello già esistente)
In particolare TD24 – fattura differita – art 21, 4 comma, lett. a), del Dpr 633/72 vale a dire fattura differita di beni e servizi collegata a DDT per i beni, ovvero da idonea documentazione di prova dell’effettuazione per le prestazioni di servizio; TD 25 fattura differita di cui all’art. 21, 4 comma, lett. b), del Dpr 633/72, vale a dire fattura differita per triangolari interne. Con questi codici si dà rilevanza in modo immediato che si tratta di una fattura differita a prescindere dalle evidenziazioni che devono essere poi gestite all’interno del formato.

Per gestire correttamente questi nuovi tipi documento bisogna andare in Archivi Comuni / Tabelle di vendita / Tipi Documento e creare un nuovo tipo documento per ognuno di quelli che si devono utilizzare e compilare il campo “Tipo doc.x Fatt. Elettr” mettendo il valore corrispondente. Si ricorda che la corretta compilazione di questa tabella è necessaria anche per il riconoscimento dei dati in caso di contabilizzazione automatica delle fatture ricevute.

1. Modifica dei valori disponibili per la Natura della partita Iva.
Si ricorda che in tutti i casi in cui l’aliquota iva sia pari a 0 è necessario indicare il codice Natura dell’operazione: con questa variazione sono stati eleminati i codici N2 – N3 – N6 che vengono sostituiti da dei codici più specifici

N2.1 | non soggette ad IVA ai sensi degli artt. da 7 a 7-septies del DPR 633/72
N2.2 | non soggette - altri casi
N3.1 | non imponibili - esportazioni
N3.2 | non imponibili - cessioni intracomunitarie
N3.3 | non imponibili - cessioni verso San Marino
N3.4 | non imponibili - operazioni assimilate alle cessioni all'esportazione
N3.5 | non imponibili - a seguito di dichiarazioni d'intento
N3.6 | non imponibili - altre operazioni che non concorrono alla formazione del plafond
N6.1 | inversione contabile - cessione di rottami e altri materiali di recupero
N6.2 | inversione contabile - cessione di oro e argento puro
N6.3 | inversione contabile - subappalto nel settore edile
N6.4 | inversione contabile - cessione di fabbricati
N6.5 | inversione contabile - cessione di telefoni cellulari
N6.6 | inversione contabile - cessione di prodotti elettronici
N6.7 | inversione contabile - prestazioni comparto edile e settori connessi
N6.8 | inversione contabile - operazioni settore energetico
N6.9 | inversione contabile - altri casi

In particolare:

per l’N3: le esportazioni (- N3.1 – art. 8 Dpr 633/72 – rigo della dichiarazione – VE30 col 2 ); le cessioni intracomunitarie (N3.2 – art. 41 Dl 3311/93 – rigo della dichiarazione – VE30 col 3 ); le cessioni verso San Marino (N3.3 – art. 71 Dpr 633/72 – rigo della dichiarazione – VE30 col 4); le operazioni assimilate alle cessioni all’esportazione (N3.4 – art. 8 bis del Dpr 633/72 rigo della dichiarazione – VE30 col 5); cessioni non imponibili con lettere d’intento (N3.5 – art. 8, 1 comma, lett. c) del Dpr 633/72 – rigo della dichiarazione – VE31); altre operazioni che non concorrono alla formazione del plafond – (N3.6 art. 21comma 6 bis ovvero cessioni verso depositi Iva art. 50 bis del Dl 331/93 – rigo della dichiarazione – VE32)

Per N6: nella particolare classe di operazioni vi rientrano le operazioni ad inversione contabile di cui all’art. 17 5 e 6 comma, del Dpr 633/72 e inoltre sono ricomprese anche in casi di autofatturazione di acquisti di servizi extra-ue ovvero le operazioni di importazione. Quindi il codice non ricomprende solo le operazioni attive ma anche alcune operazioni passive. In particolare, i codici specifici comprendono: cessione di rottami e altri materiali di recupero (N6.1 – art. 74 Dpr 633/72 – rigo della dichiarazione VE35 col. 2); cessioni di oro e argento puro (N6.2– art. 17, 5 comma Dpr 633/72 – rigo della dichiarazione VE35 col. 3); subappalto nel settore edile (N6.3 – art. 17, 6 comma Dpr 633/72 – rigo della dichiarazione VE35 col. 4); cessione di fabbricati (N6.4 – art. 17, 6 comma lett. a bis), Dpr 633/72 – rigo della dichiarazione VE35 col. 5); cessione telefoni cellulari (N6.5 – art. 17, 6 comma lett. b), Dpr 633/72 – rigo della dichiarazione VE35 col. 6); cessione di prodotti elettronici (N6.6– art. 17, 6 comma lett. c), Dpr 633/72 – rigo della dichiarazione VE35 col. 7); prestazioni comparto edile e settori connessi (N6.7 – art. 17, 6 comma lett. a ter), Dpr 633/72 – rigo della dichiarazione VE35 col. 8); operazioni settore energetico (N6.8 – art. 17, 6 comma lettera da d bis a d quater), Dpr 633/72 – rigo della dichiarazione VE35 col. 9); altri casi (N6.9).

Per gestire correttamente questi valori è necessario andare in Archivi Comuni / Tabelle Contabilità / Codici Iva ed eventualmente modificare il campo Natura (Comun. Fatt-F.Elettr.) per codici iva esistenti contenenti i valori N2 o N3 o N6 ed eventualmente sdoppiare il codice iva nel caso si debbano fare registrazioni con tipologie diverse che prima rientravano in casi con valore analogo: ad es. in presenza di cessioni di telefoni cellulari e di prodotti elettronici che prima utilizzavano la stessa Natura N6 ora si dovranno impiegare codici diversi e cioè N6.5 per la prima categoria e N6.6 per la seconda.

ATTENZIONE: questa modifica della Natura riguarda anche la trasmissione dati fattura (ora esterometro) nella quale fra l’altro non è più possibile utilizzare la natura N6; quindi anche l’aggiornamento del programma per questa comunicazione è obbligatoria a partire dal gennaio 2021.

Chi contabilizza automaticamente le fatture passive deve eseguire la stessa operazione con le causali di contabilità (Contabilità / Gestioni / Causali) creando nuove causali per ogni nuovo tipo documento che prevede di poter ricevere.

2. Modifiche per la ritenuta per le casse di previdenza per cui l’importo non va in aggiunta in fattura (es. ENASARCO vedere parametro CassaPrevNoImpon)

In precedenza non c’era un metodo specifico per indicare questi dati e si usavano righe descrittive mentre ora vengono messe nella sezione DatiRitenuta

Nel caso si emettano fatture con cassa previdenza di questo tipo bisogna andare nella gestione dei Dati Generali Azienda e nella maschera “Fatt Elett” compilare il campo Tipo Ritenuta (per fatt. elettronica); per i calcoli rimane come era in precedenza e quindi non sono necessarie altre operazioni.

Sono state inoltre aggiunte due possibili valori per la causale pagamento:

· M2 (in precedenza in presenza di questo valore andava indicato M)

· ZO (in precedenza in presenza di questo valore andava indicato Z)

Per la contabilizzazione delle fatture ricevute per avere in automatico la contropartita da utilizzare bisogna creare delle voci di spesa che abbiano nella descrizione quel valore di tipo ritenuta (ad es. mettere nella descrizione RT04 per identificare spesa con dati enasarco).

3. Aggiunta una nuova modalità di pagamento: MP23

Questa modalità è stata prevista per il PagoPA che è il sistema dei pagamenti a favore delle pubbliche amministrazioni e dei gestori di pubblici servizi in Italia

4. Modifiche di minore importanza:

· Campo ScontoMaggiorazione/Importo: messa lunghezza massima a 21 che permette di indicare fino a 8 decimali

· ImportoBollo non più obbligatorio

· Il codice articolo non è limitato ai caratteri latini

· Introdotto nello SDI un controllo di validità sui caratteri messi nelle email oltre ad una serie di nuovi messaggi di errore legati alle modifiche qui introdotte.

ATTENZIONE: queste modifiche richiedono una nuova versione delle dllNet di collegamento con l’Hub, è quindi necessario eseguire le seguenti operazioni:

1. Aprire una fine stra Dos come amministratore

2. Andare nella cartella dllNet

3. Deregistrare la dll usando il batch presente nella directory (Deregistra_localnet.bat)

4. Copiare i file aggionati (se si è scaricati lo zip copiare tutto il suo contenuto oppure se si è scaricato il pacchetto completo copiare il contenuto della cartella dllNet)

5. Riregistrare la dll usando il batch presente nella directory (Registra_localnet.bat)

ALTRE MODIFICHE

  1. Dichiarazione d’intenti

Aggiunto campo per contenere il protocollo di invio allo SDI e sua stampa

  2. Aggiunto parametro per importazione fattura passiva di nota di credito

Aggiunto parametro di personalizzazione (gruppo Fatel – parametro InvNotaCredNeg) che se vale S durante l’importazione di una fattura passiva di una nota di credito con totale documento inverte il segno degli importi nelle righe di dettaglio, nel riepilogo iva e nei pagamenti. La stampa non è cambiata e stamperà nei dettagli gli importi col segno originario mentre il riquadro iva ha già i segni modificati; la contabilizzazione viene fatta con gli importi col segno cambiato.

  3. Cancellazione progressivi magazzino

Se nel campo Anno Da si mette il valore 1 cancella tutti i progressivi fino all’anno messo nel campo Anno A per gli articoli che hanno a 0 tutte le quantità nell’anno indicato in Anno A

  4. Stampe margini e statistiche ordini e preventivi

Aggiunto un flag che nelle stampe ordinate per cliente permettere di stampare dati aggiuntivi del cliente: numero fatture, totale documento nelle fatture, saldo, fido, pagamento.

  5. Contabilizzazione fatture

Aggiunto parametro: Gruppo: Contabil - Parametro: CigCupDaFe
se vale S in contabilizzazione di una fattura se compilati CUP e CIG in altri dati per fattura elettronica nel riquadro degli ordini d’acquisto (campi 2.1.2.6 e 2.1.2.7) vengono portati in prima nota al posto di quelli che si trovano nella testata della fattura

  6. Stampa distinta

Messa opzione che chiede se si vuole stampare, nella riga dove compare la partita iva, i valori di CUP e CIG; aggiunto parametro di personalizzazione Gruppo: Distinta - Parametro: StaCUPCIG che se contiene il valore S lo preimposta a selezionato

  7. Aggiunto campo ritenuta d’acconto per fattura elettronica

Per chi emette fatture con particolari ritenute d’acconto il cui importo non va aggiunto in fattura (es. ENASARCO) ò stato messo nella tabella dati generali il tipo di ritenuta da riportare nella fattura elettronica

  8. Stampa Scadenze e Stampa Scaduto

Aggiunta opzione a video se stampare, quando previsto, CIG e Cup oppure Agente
Messo parametri di personalizzazione per preimpostarlo (se vale S preimposta opzione stampa Agente):
per scadenze:
Gruppo: Scadenze Parametro: StaAgente
Per scaduto
Gruppo: StScaduto Parametro: StaAgente

9. Evasione Ordini e Preventivi

Aggiunti parametri di personalizzazione che se impostato a S mette i dati di riferimento dell'ordine nel DDt o nella fattura di evasione nella nota sopra delle righe di dettaglio evase e non crea una riga di dettaglio:
per ordini:

Gruppo EvasioneOrd Parametro DdtRifOrdNota

Gruppo EvasioneOrd Parametro FatRifOrdNota

Per i preventivi

Gruppo EvasionePre Parametro DdtRifOrdNota

Gruppo EvasionePre Parametro FatRifOrdNota

Vedi anche:
Note installazione
Note aggiornamento


NOTE SULLA VERSIONE 4.04 DEL 11/11/2019

NOTE SULLA VERSIONE 4.04 DEL 18/11/2019

Nuove funzioni

Completata la gestione delle fatture passive:
In particolar modo può essere utile controllare la causale preimpostata e andare nella gestione dettagli ed eventualmente modificare la contropartita, in modo che la contabilizzazione automatica calcoli gli importi corretti per le singole contropartite, e controllare i codici IVA.
Da questa funzione è possibile stampare e contabilizzare le singole fatture ricevute.

Nel programma Hub Lista Fatture Attive aggiunto il pulsante Dati ric. SDI
Serve per importare nei dati aggiuntivi per fattura elettronica delle fatture emesse, la data e il numero di ricezione dello SDI delle righe che sono state selezionate. Questi dati possono venire usati per la stampa del registro IVA.

Aggiunti nella stampa del Registro IVA i valori della data e ricezione SDI
Vengono riportati i dati indicati nella registrazione di prima nota; nel caso in cui siano vuoti vengono prelevati dalle fatture emesse per le fatture attive e dall'archivio fatture ricevute per le fatture passive.

Effettuate varie modifiche nel caricamento fatture passive e la loro contabilizzazione, ad esempio aggiunto il parametro di personalizzazione Gruppo: Fatel Parametro: FatPassDataReg che se vale R viene messa data registrazione = data ricezione, altrimenti (default) = data protocollo

Effettuate varie modifiche nella creazione del File XML delle fatture attive, ad esempio messi nomi cointestatari nel campo causale; se una fattura viene scartata perché già in stato CO o IC viene messo in stato di Inviata in modo da non dare false segnalazioni negli invii successivi. Se all'inizio della descrizione lunga c'è la scritta NOXML non verrà messa nel file XML.

Modificata nella gestione degli articoli la duplicazione che ora duplica le descrizioni lunghe e chiede se si vogliono copiare anche i listini.

Vedi anche:
Note installazione
Note aggiornamento


NOTE SULLA VERSIONE 4.03C DEL 14/03/2019

Nuove funzioni

  • Gestione fatture elettroniche ricevute
    Consente di visualizzare e modificare le fatture elettroniche ricevute, dopo che sono state scaricate dall’ hub Zucchetti e caricate sulla tabella di appoggio.

  • Contabilizzazione Fatture Elettroniche Passive
    Percorso: Vendite - Fatture - Fattura Elettronica
    Questa funzione consente di registrare in contabilità le fatture passive presenti nella tabella di appoggio.
    Tali fatture sono state memorizzate nella tabella nel momento in cui sono state scaricate dall'Hub con il campo Importa Xml scaricati spuntato oppure caricate manualmente con la funzione: Caricamento xml fatture passive.
    N.B.
    1) Sulla maschera è presente un'opzione per segnare in automatico come contabilizzate le fatture già caricate in precedenza sulle tabelle d'appoggio. E' importante eseguire la funzione spuntando questa opzione per tutte le fatture presenti sulla tabella di appoggio e già registrate in prima nota.
    2) Prima di procedere alla contabilizzazione delle rimaste è necessario riscaricarle dall’Hub con la funzione HUB–Lista fatture passive

  • La registrazione risulterà più completa e corretta se saranno stati compilati:
    Nelle causali di acquisto: Il Tipo Documento, il flag reverse charge, la priorità
    Nei codici IVA: La natura N6 per i codici IVA di Reverse Charge; in tutti i codici con aliquota 0 (esenti,non imponibili, esclusi..) mettere la natura e spuntare la priorità nel codice più utilizzato per quella natura.
    Nei fornitori: L'eventuale conto di contro partita da usare normalmente per quel fornitore.
    Nei tipi pagamento: Modalità pagamento per fattura elettronica.
    I Codici Assosoftware sulle tabelle (usati se ci saranno i giusti riferimenti sul file XML caricato) : dei codici IVA , dei codici Tipo Pagamento, delle Spese.

  • Cancellazione tabella di transito fatture elettroniche passive
    Percorso: Vendite - Servizio
    Funzione che consente di cancellare le fatture passive presenti nella tabella di appoggio.

Note sulla compilazione automatica della registrazione:

Data registrazione
Come data di registrazione della fattura viene messa la data ricezione. Se non è presente il programma utilizza come data registrazione la data della fattura.
N.B. La data ricezione assume una importanza fondamentale quando la fattura emessa in un determinato mese viene ricevuta dallo SDI entro il 15 del mese successivo. In questo caso la data registrazione della fattura dovrà essere quella di ricezione e nella registrazione verranno impostati i campi Mese/Anno Iva. Il campo Mese iva sarà posto uguale al mese della data fattura.
Questa regola non vale a fine anno.
Le fatture con questa caratteristica verranno stampate sul registro iva del mese di registrazione (data ricezione) mentre finiranno nella liquidazione dell'iva del mese della data fattura.
Al fine di ottenere un elenco delle fatture che concorrono al calcolo dell'iva di un determinato mese o trimestre si può chiedere una stampa del Brogliaccio di Prima Nota, con scelta Movimenti iva su una riga, compilando SOLO i campi Anno contabile , anno Iva e Mese iva da ... a ... e scegliendo il Tipo Registro Acquisti (non va compilata la data di registrazione!)
Sulla stampa del registro iva acquisti si consiglia di stampare data registrazione e data documento, al posto della data protocollo che non viene ad avere più nessuna importanza.

Causale:
In fase di scarico della fattura dal digital hub e relativo caricamento sulle tabella d'appoggio, sarà possibile digitare il codice della causale contabile da attribuire alla registrazione del documento ma non è obbligatorio farlo tranne nei casi in cui si vuole attribuire al documento una causale particolare (es. fattura reverse charge).
Se si lascia bianca il programma cercherà sulla tabella Causali una causale con il campo 'Tipo documento per FE' uguale a quello letto sul file xml della fattura. Se da questa ricerca si trova più di una causale, verrà presa la prima nella quale il campo 'Ft.ric.prior.' è spuntato.
Per cui diventa fondamentale aver spuntato sulla causale utilizzata più comunemente come Fattura di acquisto e su quella Nota di Credito ricevuta il campo 'Ft.ric.prior.'

Codice Iva / Natura
In fase di scarico della fattura dal digital hub e relativo caricamento sulle tabella d'appoggio si possono impostare fino a 3 codici iva, specificando per ognuno l'eventuale Natura diversa (N1-N2)
E' possibile digitare un codice iva e, in corrispondenza, un codice Natura (questo per il caricamento ad esempio, di una fattura emessa in Reverse Charge che conterrà la Natura N6 ma va caricata con codice iva)
Se sull'anagrafica del fornitore è impostato un codice iva, verrà utilizzato quello, altrimenti il programma cerca nella tabella dei Codici Iva, il primo con stessa aliquota e il campo 'Fatt.ric. codiva prior.' spuntato. Se non lo trova mette il codice presente in fattura

Conto di costo per le righe di dettaglio
In Gestione fornitori, maschera (4)Contabilità, è possibile definire quale conto di costo utilizzare per il caricamento delle fatture: quello scritto sul fornitore o quello sull'articolo. In mancanza di entrambi verrà utilizzato il codice del Merci c/acquisti scritto nella tabella dei conti comuni: Parametri e Utilità - Dati generali azienda (parametri) . Si può impostare un default col parametro di personalizzazione: ContoPrior

Condizione di pagamento / Scadenze
Poichè non è possibile ricostruire la condizione di pagamento da scrivere sulla registrazione di prima nota della fattura, questa verrà lasciata bianca pur creando le scadenze.
Si consiglia pertanto di controllare che, sulle causali utilizzate per la registrazione delle fatture non sia spuntato il campo 'Condizioni di pagamento obbligatorie'
Per NON creare mai le scadenze, creare il parametro di personalizzazione:
ScadNoData (Gruppo: FatEl) e mettere in Valore la lettera A

Creazione automatica della registrazione del pagamento
Se in una fattura risulta, dalle righe di pagamento, che c'è stato un pagamento immediato, verrà creato, al momento della sua contabilizzazione, anche la registrazione del pagamento. La creazione di tale registrazione verrà fatta secondo quanto specificato nel parametro di personalizzazione: CreaPagAut Gruppo: FatEl
A (valore di default) automatica
crea la registrazione per gli importi delle eventuali scadenze con data minore o uguale alla data fattura, oppure se il totale fattura è maggiore della somma delle scadenze
N non crea registrazioni
S crea la registrazione con importo delle eventuali scadenze con data minore o uguale alla data fattura

Se invece NON si vogliono MAI generare le scadenze oppure in fattura non sono state riportate le condizioni di pagamento o manca la data scadenza, il programma si comporta come indicato dal parametro di personalizzazione: ScadNoData Gruppo: FatEl
N non crea registrazioni (default)
A non crea nessuna scadenza
 D crea una scadenza con data Scadenza uguale a Data fattura
F crea una scadenza con data scadenza a Fine anno in base a data fattura
NNN dove NNN è il numero dei giorni da sommare alla data fattura per ottenere la data scadenza

Per ulteriori informazioni si rimanda ai capitoli Contabilizzazione fatture passive e Caricamento xml fatture passive del manuale in linea

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.03B


NOTE SULLA VERSIONE 4.03B DEL 16/01/2019

Per le installazioni nelle quali viene emessa fattura da più aziende:

E' consigliato differenziare, all'interno delle directory DirPdf, DirFe , DirFeScar , DirFatPas le cartelle nelle quali verranno salvate i documenti delle varie aziende .
Occorre creare, per ogni azienda, più parametri di personalizzazione con Gruppo: DirPerAzie
Parametri: DirPdf , DirFe , DirFeScar , DirFatPas oppure il Parametro: Tutte (in alternativa ai precedenti) e mettere nel campo Valore il nome della directory dove scaricare. Per differenziare questo nome per le varie aziende è possibile mettere:
§IdAzienda§ che verrà sostituito con l'identificativo dell'azienda
§CodiceAzie§ che verrà sostituito col codice azienda

Esempio: Gruppo: DirPerAzie Parametro:Tutte Valore: §CodiceAzie§
Prima di inserire questi parametri occorre creare nella cartella C:\Aziwin\FatturePassive una cartella con il codice dell’azienda gestita reperibile da : Parametri Utilità -> Gestione Database Aziende. Quindi se l’azienda ha codice AZ01 dovrete creare una cartella AZ01.
Attenzione, il paragrafo precedente è da considerare come esempio, nella vs. installazione non è detto che il disco usato sia C: e che la cartella 'fatture passive' si chiami FatturePassive, potrebbe avere un altro nome.
Dovrete creare le cartelle delle ditte nella cartella usata per memorizzare le fatture passive.

Clienti e fornitori

Gestione CAP
Sulla tabella Comuni è stato sbiancato il Cap in corrispondenza ai Comuni che prevedono più cap. In gestione clienti e fornitori quando si digita uno di questi comuni, non verrà riportato in automatico il Cap e, se il cap era già impostato, non verrà modificato.

Se nella provincia si mette 99 oppure EE il campo Comune non verrà controllato e si può compilare a piacere (Per SEDE clienti esteri in fattura ellettronica)

Cliente appartiene ad un gruppo
Se un cliente appartiene ad un gruppo di aziende che ai soli fini iva viene visto come un unico soggetto passivo (legge 2006/112/CE) occorre mettere nella Partita Iva quella principale (cioè quella che viene utilizzata ai fini iva) e nel codice fiscale la partita Iva della singola azienda.
Se si hanno rapporti con più aziende del gruppo occorre creare un cliente per ogni singola azienda differenziandoli per codice fiscale (NB il programma segnalerà Partita Iva doppia)

Gestione Note in Fattura elettronica
Il contenuto dei campi Note Cliente, Note Fisse e Note di testata fattura vengono inserite, sul file XML della fattura, come righe descrittive del corpo.
Al fine di variare questa impostazione, si possono impostare i seguenti parametri di personalizzazione che possono assumere i valori:
0 – Non va da nessuna parte
1 – Copia nel campo Causale
2 – Mette in una riga descrittiva (Valore di default)

Parametro: NoteClie (Gruppo: XML)
Indica dove inserire, sul file XML della fattura, l'eventuale contenuto del campo 'Note per fatture' presente sulla maschera 6 dell'anagrafica clienti
Parametro: NoteFisse (Gruppo: XML)
Indica dove inserire, sul file XML della fattura, le eventuali Note Fisse presenti in fattura se non hanno il campo: 'NON riportare su Fattura Elettronica' impostato a No
Parametro: NoteFat
Indica dove inserire, sul file XML della fattura, le eventuali Note di testata inserite in fattura

Se su una fattura, nel campo Note Testata si scrive: NOXML , NON verrà riportata nessuna riga descrittiva e nessuna nota a meno che non siano stati messi i parametri di personalizzazione per mettere le note nel campo causale

E’ possibile inserire il parametro: AssoInfoDoc (Gruppo: XML)
Se vale S mette sul file XML una riga fittizia descrittiva con i dati aggiuntivi come da specifiche AssoSoftware (Versione del software,etc)
E' necessario impostare questo parametro nel caso il cliente richieda queste informazioni aggiuntive, in tal caso si consiglia di compilare sulle varie tabelle i campi Assosoftware.

Cassa Previdenza
Per ottenere un calcolo corretto in fattura dei diversi tipi di Cassa Previdenza
I programmi sommano l’importo della Cassa previdenza all'imponibile della fattura.
Per prevedere l' ENASARCO e tutte le altre casse che non prevedono un aumento dell'imponibile ma solo una diminuzione occorre creare il parametro di personalizzazione CassaPrevNoImpon (Gruppo: Tutti) impostato a S. In questo modo l’importo relativo NON verrà sommato all'imponibile ma sottratto dall'importo a pagare.

Applicazione del Bollo in fattura elettronica

La marca da bollo di 2€ è un tributo alternativo all’IVA e va applicata esclusivamente per le fatture emesse senza l’addebito dell’iva con importi superiori ad € 77.47
Se le fatture presentano contemporaneamente importi soggetti ad IVA ed importi non soggetti, la marca da bollo va applicata solo qualora gli importi non soggetti ad IVA siano superiori a € 77.47.

Dal punto di vista del programma l'applicazione del bollo su fattura continua a funzionare alle stesse condizioni di prima.
Per verificare che il bollo finisca correttamente sulla fattura elettronica, cliccare sull'icona 'Altri dati per fattura elettronica' presente sulla testata fattura, andare nel quadro (7) Altri dati.

Qui deve essere presente l'importo corretto del bollo e la scritta SI in Numero bollo.

In questo modo sul file XML verrà riportata in automatico la riga:
<RiferimentoNormativo>NOTA BOLLO VIRTUALE</RiferimentoNormativo>

Destinatario della Fattura Elettronica

Il Codice Destinatario è un campo della fattura elettronica in cui viene inserito il codice identificativo di 7 cifre alfanumerico del ricevente della fattura e definisce l'indirizzo telematico a cui vengono inviate le fatture, serve quindi per indicare al Sistema di Interscambio (SDI) a chi recapitare le fatture. Per ricevere le fatture Passive/Fornitori direttamente al Digital HUB Zucchetti bisogna comunicare ai propri fornitori il Codice Destinatario SUBM70N. Questo codice è stato assegnato dall’Agenzia delle Entrate e che identifica Zucchetti come intermediario per vedersi recapitate le fatture passive e/o fornitori direttamente al Digital Hub Zucchetti ed è predominante sull’indirizzo PEC.

Quando si deve usare la PEC per inviare le fatture elettroniche?

Nel caso in cui il destinatario sia un titolare di partita IVA, questi può comunicare l’indirizzo PEC nel caso in cui ne disponga uno, così che possa inserirlo nel campo PEC destinatario e le fatture vengano spedite a questo indirizzo. Il campo Codice Destinatario deve essere compilato con il codice "0000000" (7 zeri) che indica che non si deve considerare questo dato ai fini dell'identificazione del ricevente e l'invio. In alternativa, i tuoi clienti possono comunicarti il loro Codice Destinatario per esempio SUBM70N se il ricevente ha il Digital HUB Zucchetti.

Quando si deve usare il Codice Destinatario ‘0000000’ (7 zeri)?
Nel caso in cui si ha un cliente che opera in una di queste categorie:
1. regime di vantaggio o forfettario
2. piccoli agricoltori
3. privati
si deve inserire il codice ‘0000000’ (7 zeri) nel campo del Codice Destinatario, in quanto queste categorie di soggetti non sono dotati di un codice di identificazione di questo tipo.

L’inserimento di questo codice rende però impossibile per il Sistema di Interscambio recapitare le fatture elettroniche, la cui copia originale viene messa a disposizione del cliente nella sezione di consultazione delle fatture elettroniche nella sezione “Fatture e Corrispettivi” dell’Agenzia delle Entrate grazie all’identificazione tramite codice fiscale. Per poter accedere a questi documenti è necessario collegarsi al portale dell’Agenzia delle Entrate “Fatture e Corrispettivi” all’indirizzo https://ivaservizi.agenziaentrate.gov.it/portale/ e poi andare nell’area “Consultazione” e poi “Dati rilevanti ai fini IVA”. In questo caso, devi comunque consegnare al tuo cliente una copia (anche cartacea) della fattura emessa specificando dove è possibile visualizzare la fattura elettronica originale, che ha valenza ai fini fiscali.

Quando si deve usare il Codice Destinatario ‘XXXXXXX’ (7 X)

Il codice destinatario ‘XXXXXXX’ è usato nel caso di operazioni di cessioni di beni e di prestazioni di servizi effettuati verso soggetti non residenti, non stabiliti e non identificati nel territorio dello Stato, è possibile evitare la comunicazione dei dati delle fatture emesse di cui all’art.1 comma 3 bis del decreto legislativo 127/2015 (i.e. spesometro) trasmettendo al SdI le fatture elettroniche ed inserendo il codice convenzionale “XXXXXXX”.

Come controllare se una fattura è stata spedita al Digital HUB.

Per fare questo controllo, oltre ai programmi di lista fatture, è possibile andare in gestione fatture emesse (dirette e accompagnatorie), richiamare la fattura e cliccare nella barra degli strumenti sul tasto [image] (Altri dati per fattura elettronica), verrà presentata una videata con varie etichette. Cliccate su (7) Altri Dati. Se la fattura è stata inviata, in basso saranno riportati i parametri di invio.

Ricezione e archiviazione delle fatture ricevute via PEC o scaricate dal cassetto fiscale

Nel caso riceviate delle fatture per PEC o tramite cassetto fiscale, vi consigliamo di inviarle in conservazione sostitutiva caricandole nel Digital Hub Zucchetti.

Per fare questo dovrete creare una cartella che conterrà le fatture di cui sopra. Vi suggeriamo di chiamare la cartella FatturePEC e crearla all’interno della directory AZIWIN. Vi ricordiamo che le fatture sono costituite da 2 file, entrambi con estensione XML, uno di questi avrà all’interno del nome i caratteri _MT_.

Una volta copiati i due file indicati sopra nell’apposita cartella, entrate nel Digital Hub Zucchetti, sezione Fatture Passive, e cliccare sulla maschera in alto a destra su NUOVO

Vi apparirà una nuova videata sulla quale dovrete:
1) Cliccare su Aggiungi File
2) Selezionare i 2 file XML della fattura da inviare all’HUB dalla cartella FatturePEC (se l’avete chiamata così).
3) Quando i 2 file vi appariranno sotto “SELEZIONARE UN FILE DA IMPORTARE” cliccate su START UPLOAD.
4) Scrivete un codice esterno nell’apposita casella. Nel ns. caso abbiamo messo la sigla del gestionale + la parola PEC (per capire che sono arrivate per PEC) + l’anno di riferimento+ un numero. E’ una codifica libera quindi potrete mettere i riferimenti che vorrete.
5) Cliccare su IMPOSTA DOCUMENTO presente in basso a destra.

A procedura ultimata troverete la fattura nel Digital Hub.

NB Se le fatture sono state scaricate dal cassetto fiscale, il file delle notifiche potrebbe avere un nome non corretto è andrà rinominato al momento del salvataggio.
Il nome corretto deve essere simile al seguente:
IT00527700397_000Hy_MT001.xml

Esempio:
IT00527700397_000Hy.xml (file XML della fattura elettronica)
IT00527700397_000Hy_MT001.xml (file XML della notifica)
Per caricarlo nel Digital Hub è indispensabile che nel nome della notifica sia presente la partita Iva e la sequenza MT_001.
Gli altri caratteri non sono importanti.

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.03


NOTE SULLA VERSIONE 4.03 DEL 03/12/2018

Dal 1 gennaio 2019 l'obbligo dell'emissione in formato elettronico viene esteso a tutte le fatture (escluso regimi particolari).

Per supportare le Aziende nella gestione di questa importante scadenza, proponiamo un nuovo modulo, collegato ad aziendapc, che prevede un insieme di funzioni per la gestione delle fatture elettroniche attive e passive (Connettore) e un servizio di invio all'SDI e Conservazione Sostitutiva a norma di Legge
Il modulo in oggetto dovrà essere acquistato per ogni soggetto emittente fattura.

Per attivare le nuove funzioni a menu occorre acquistare il ‘Connettore’ per Digital Hub delle Fatture Elettroniche. Verrà fornita una nuova chiave di attivazione che va inserita in Licenza concessa A, dopo aver scritto: XMZ nel campo Moduli aggiuntivi.

ATTENZIONE: Se si installa la versione dei programmi che prevedono la fatturazione elettronica che si avvale dell'HUB Zucchetti, NON sarà più possibile accedere alla preparazione del file XML della Fattura Elettronica (da inviare tramite Arthur Informatica) dal pulsante presente nel programma di Gestione Fattura.

Per mantenere attiva questa possibilità (per le fatture emesse per l’anno 2018) è stato messo a menu, nella maschera VENDITE - FATTURE un pulsante ‘Fattura Elettronica vecchia versione’.

Si raccomanda di leggere attentamente le note operative scritte sul manuale in linea (raggiungibile dal menu premendo il Tasto F1), capitolo Fattura Elettronica, al fine di una corretta configurazione del sistema e compilazione del file XML della fattura.

Scadenze in fattura: al fine di scrivere sulla fattura elettronica le scadenze corrette, eventualmente diverse da quelle generate in automatico in base alla condizione di pagamento, si possono impostare direttamente in testata fattura nella maschera accessibile dal pulsante: Quadro scadenze [image] (Z) Gestione scadenzario

FUNZIONI PER L'INVIO DELLA FATTURA ELETTRONICA
 (per informazioni più dettagliate, si rimanda al manuale in linea raggiungibile premendo il tasto F1 una volta posizionati all’interno del singolo programma)

  1. Creazione Fatture Elettronica
    Una volta compilate le fatture, sia diretta sia riepilogative (con evasione dei ddt), si dovranno preparare i file XML per l'invio automatico all'Hub Zucchetti.
    La preparazione può avvenire per una singola fattura utilizzando il pulsante [image] (FattElettronica) oppure con l'apposita funzione a menu: Creazione Fattura Elettronica
    Il programma di preparazione esegue un primo controllo del file XML ma, almeno per i primi tempi, si raccomanda di non modificare il campo: 'Stato iniziale di caricamento sull'Hub' impostato come 'Da Validare' in modo da far fare un ulteriore controllo prima dell'invio.
    Una volta eseguita questa funzione occorre andare nel programma: Hub – Lista fatture attive
  2. Hub Lista Fatture Attive
    Se le fatture sono state caricate come Da Validare, dovrà essere utilizzata questa funzione per Validarle poi inviarle allo SDI.
    Selezionare la/le fatture che si intende Validare (controllare) poi , in fondo al video, vicino all'etichetta 'Tipi cambio stato': scegliere Validazione e premere il pulsante: Cambio stato
    Se la validazione segnala degli errori, occorre correggere la fattura con la Gestione Fatture e ripetere la sequenza dal punto 1)
    Viceversa, se la/le fatture superano i controlli della validazione si dovrà procedere in questo modo: selezionare i documenti validati, vicino all'etichetta 'Tipi cambio stato': scegliere Firma e Conferma poi premere il pulsante Cambio stato
    A questo punto la fattura si considera spedita

FUNZIONI PER IL RICEVIMENTO DELLE FATTURE ELETTRONICHE PASSIVE

  1. Hub Lista Fatture Passive
    Consente di visualizzare e scaricare l'elenco delle fatture fornitori che arrivano sull'HUB
    Per fare in modo che i file xml scaricati vengano immediatamente caricati nel file d'appoggio per poi poter essere stampati occorre spuntare il campo ‘Importa Xml scaricati’
  2. Caricamento XML Fatture Passive
    Consente di caricare su una tabella di appoggio i file XML delle fatture passive in modo da poterle integrare, stampare e registrarle in automatico in contabilità
  3. Gestione Fatture Passive (in fase di sviluppo)
  4. Stampa Fatture Passive
    Consente la Stampa in un formato 'interno' delle fatture passive che sono state scaricate in precedenza tramite la funzione al punto 1 e caricate nella tabella d'appoggio al fine di effettuare la registrazione in prima nota

FUNZIONI DI UTILITA’

Dati Accesso HUB
Se la password per l'accesso all'HUB Zucchetti è uguale per tutte le aziende, con questa funzione dovranno essere fornite login e password forniti al momento dell'acquisto

Informazioni fatture Elettroniche
Per conoscere il numero delle fatture elettroniche acquistate (in entrata e in uscita) e quante ne sono state utilizzate.

Sono inoltre stati aggiunti nuovi campi nelle varie tabelle che dovranno essere compilati per una corretta compilazione delle fatture elettroniche come descritto nel capitolo Fattura Elettronica del manuale in linea (raggiungibile dal Tasto F1 sul menu)

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.02B


NOTE SULLA VERSIONE 4.02B DEL 04/07/2018

Comunicazione:
In seguito all'introduzione del Regolamento europeo in materia di Protezione dei Dati Personali (GDPR), entrato pienamente in vigore il 25 maggio 2018, è stato pubblicato sul sito www.aziendapc.it il documento REGISTRO PRIVACY GDPR PER SOFTWARE CONTABILE

Elenco modifiche contenute nella versione:

  • sono state introdotte nuove regole per la creazione delle Password all’interno della Gestione utenti
  • è stata introdotta la possibilità di proteggere con una password i database delle aziende, inserendola in fase di Compattazione del DB

Per il dettaglio delle modifiche si rimanda al manuale in linea (Tasto F1 dal menu procedure), paragrafi: Password e Gestione Utenti

Il manuale aggiornato può essere scaricato dal sito www.aziendapc.it nella pagina degli aggiornamenti oltre a poter essere consultato on line sul medesimo sito.

Per creare gli utenti che utilizzeranno il gestionale occorre utilizzare la funzione Gestione Utenti scegliendola tra quelle proposte nella maschera ‘Esegui programma’ , raggiungibile dal menu principale premendo i tasti Ctrl Alt Shift L

Nota Bene: Quando si entrerà in Gestione Utenti verrà chiesta la login e password del Supervisor.
Se non sono mai state impostate Login e Password del Supervisor occorre inserire:
Login: Supervisor e Password xxxx (dove xxx è una stringa che dovrà essere richiesta, per ogni installazione, al concessionario o, per i clienti diretti, a Zucchetti Ravenna (ex CSS))
Una volta fatto il primo accesso sarà obbligatoria cambiarla.
Per chi ha già inserita la password del supervisor dovrà digitare la password attuale MAIUSCOLA e si consiglia di cambiarla in base alle nuove regole.

Se era già stata attivata la richiesta di login e password per accedere, ogni utente già esistente dovrà entrare digitando la password attuale MAIUSCOLA e gli verrà chiesto di impostare la nuova password secondo le nuove regole suddette.
Verrà presentata una nuova maschera nella quale verrà chiesto di impostare di nuovo:

  • la login (digitare la login data in precedenza)

  • la password attuale (che va scritta MAIUSCOLA)

  • la nuova password (che va impostata secondo le nuove regole)

  • campo ‘suggerimento’ nel quale si deve scrivere una frase che consenta di ricordare la password inserita

Nuove REGOLE per la costruzione della PassWord
** Minimo 8 caratteri (regola non modificabile)
** E’ obbligatorio inserire almeno una maiuscola e una minuscola (il programma fa distinzione tra maiuscole e minuscole) (regola modificabile)
** Si possono mettere caratteri speciali (regola modificabile)
** Deve esserci almeno un numero (regola modificabile)

Se si desidera cambiare le regole si dovrà eseguire la gestione utenti (Ctrl Alt Shift L) , digitare login e password del supervisor e cambiare le regole di impostazione password che sono modificabili cliccando sull'ultima icona a destra in alto ’Regole Password’

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.02


NOTE SULLA VERSIONE 4.02 DEL 18/12/2017

Elenco modifiche

  • Stampa parametrica clienti e fornitori
    Inserita la selezione per stampare solo le anagrafiche movimentate in un determinato periodo
  • Gestione Clienti e Fornitori
    Sulla maschera dell’anagrafica Clienti e Fornitori sono stati aggiunti due nuovi campi: Cognome e Nome che, all’occorrenza, potranno essere compilati dall’operatore e, se presenti, verranno riportati sul file XML della Comunicazione dati fatture.
    Inoltre, vicino ai dati di persona fisica, viene presentato un pulsante che consente, se impostati i campi necessari, di calcolare il codice fiscale.
    Una volta compilati Cognome e Nome, essi verranno riportati sul campo Ragione Sociale Contabile se questo era stato lasciato bianco.
    E’ possibile impostare il parametro di personalizzazione: CognomePersFisica
    Gruppo: Clienti con valore: S in modo che se si compilano Cognome e Nome, il programma imposti in automatico lo Stato Giuridico come Persona Fisica e abiliti i campi ‘data di nascita’, ‘sesso’ etc.
  • Modificata la ricerca dei Clienti e Fornitori
    Oltre ai tasti standard F2 e F3, sul campo codice, sono stati attivati i tasti F11 e F12
    F11 cerca sulla prima parte della Ragione Sociale, F12 sul campo ottenuto con l’unione delle due parti.
    E’ possibile creare due parametri di personalizzazione (Gruppo: Tutti ) per definire, per i due tasti, campi diversi di ricerca:
    CFHelpRic11 (Per ricerca con F11) (Valore es: Indirizzo & Localita) e
    CFHelpRic12 (Per ricerca con F12)
  • Comunicazione dati fatture
    Aggiunto parametro di personalizzazione che permette di aggiungere ai dati della prima nota quelli memorizzati nella prima nota fittizia (gruppo: DatiFat - parametro: UsaFittizio Valore: S)
    Aggiunto parametro di personalizzazione che permette di estrarre anche il codice fiscale per clienti/fornitori forniti di partita iva (gruppo: DatiFat - parametro: EstraiCodFisc - Valore: S)
    Se in anagrafica sono compilati i campi Cognome e Nome essi verranno sempre riportati sul file.
  • Programmi che generano ed elaborano lo scadenzario: Prima nota, Stampa fatture, Distinta, Saldaconto
    E’ stata introdotta l’opzione, attivando il parametro di personalizzazione NotaCredInvSegno, per gestire le scadenze delle note di credito come entrate negative (se Cliente) e uscite negative (se Fornitori)
    Il parametro dovrà avere Gruppo: Scadenze e potrà assumere il valore:
    S: si oppure T: oltre a creare le scadenze come detto sopra, il programma metterà su tutte le scadenze create il campo Raggruppa Scadenze a S (Il raggruppo scadenze è la condizione necessaria perchè in distinta le due scadenze si compensino)
  • Articoli di magazzino
    Un articolo definito inattivo e quindi escluso dalla lista di aiuto, può comunque essere inserito in un documento se lo si richiama digitando il codice esatto. Per escluderlo anche in questo caso, occorre impostare a S il parametro di personalizzazione: NoDecInattivi
  • Gestione scontrini
    Aggiunta la gestione sulla riga articolo, di due campi Nota: Nota Sopra e Nota Sotto, per chi ha necessità di stampare, oltre allo scontrino, anche un modulo come pro memoria.

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.01D


NOTE SULLA VERSIONE 4.01D DEL 28/08/2017

Nuove funzioni

COMUNICAZIONE dei DATI delle FATTURE EMESSE e RICEVUTE
In adempimento alla nuova normativa 2017 che prevede la Comunicazione dei dati delle Fatture Emesse e Ricevute, sono state implementate le nuove funzioni nel Menu Contabilità – Iva:

  • Preparazione dati fatture
    Verranno estratte, su una tabella d’appoggio, tutte le fatture del periodo richiesto
  • Gestione dati fatture
    Consente di variare i dati preparati con la funzione precedente
  • Estrazione file e stampa dati fatture
    Verrà preparato il file XML per la trasmissione delle stesse, con possibilità di stampa dell'elenco dei dati

Con l’occasione segnaliamo che, come già comunicato a Maggio, per una corretta preparazione della Comunicazione della Liquidazione Iva del 2' trimestre , è indispensabile aver eseguito TUTTE del Chiusure Iva (liquidazioni) del 2017 con i programmi forniti per l'invio dei dati del primo trimestre.
A quanti non lo avessero già fatto in quell'occasione , SI RACCOMANDA di ripeterle ora, prima della nuova comunicazione di settembre, anche se le stesse sono già state stampate come definitive.
In questo caso basta andare nella funzione Dati Iniziali Iva (dal menu: Contabilità – Iva), sbiancare i campi: ‘data’ e ‘ultimo periodo chiusura’ e ripetere le liquidazioni in ‘Stampa definitiva’ facendo attenzione a impostare il numero di pagina corretto e al risultato del periodo che devono coincidere con quelli della stampa fatta in precedenza.

Comunicazione dei dati delle fatture emesse e ricevute

Fatture cointestate
Verranno riportati i dati di uno solo dei soggetti, il cliente 'principale' della fattura.

NON vanno comunicate:

  • le registrazioni delle schede carburante per cui, in tutti i fornitori utilizzati per tali registrazioni , il campo suddetto, va impostato a ESCLUSO
  • le registrazioni di documenti fittizi di vendita fatte a fronte di acquisti Reverse Charge , acquisti IntaCee o Extra Cee. Se non sono state utilizzate causali particolari per fare tali registrazioni di acquisto, tali da creare in automatico quelle di vendita, occorre ESCLUDERE i clienti utilizzati

Resteranno comunque attivi i campi sulla testata delle registrazioni di prima nota e quello sulle causali per consentire di escludere forzatamente una registrazione.

E’ INDISPENSABILE , prima di procedere con la preparazione del file, completare alcune tabelle:

Causali: compilare, in tutte le causali utilizzate per la registrazione di fatture di vendita e acquisto, il campo: Tipo documento, nel quadro: Comunicazione dati fatture. Se il campo non verrà compilato, il programma di preparazione del file XML delle fatture, lo compilerà in base all'impostazione della Causale.
Nel caso di fattura di acquisto intracomunitaria, dovrà essere valorizzato in modo diverso a seconda che si tratti di beni (TD10) o di servizi (TD11); se non sono già state create causali diverse per i due casi, si può lasciare bianco il campo 'Tipo documento' e il programma di estrazione assegnerà l'uno o l'altro valore a seconda che sui conti di costo utilizzati nella registrazione sia stato spuntato il campo Beni o Servizi (in caso di presenza di conti dell'uno e dell'altro tipo, si terrà conto di quello che ha l'imponibile più alto)
Fare attenzione inoltre a come è stato impostato il campo 'Inclusione forzata'
Per il controllo di quali causali sono state già impostate con inclusione forzata si consiglia di entrare in gestione causali, spuntare il campo in oggetto e premere il tasto di Ricerca (binocolo). Verrà visualizzato un elenco.

Anagrafiche Clienti e Fornitori
Se durante l'anno vi sono state una o pi variazioni riguardo i dati anagrafici del cliente o del fornitore, è stata data indicazione di riportare i dati pi recenti.
- Segnale di Persona Fisica / Giuridica E' assolutamente indispensabile che sia compilato correttamente questo segnale al fine di scaricare sul file xml i campi Ragione Sociale oppure Cognome e Nome. In caso di Persona fisica si dovrà compilare la Ragione sociale contabile con Cognome-Nome o Cognome_Nome o Cognome 'spazio' Nome
- Partita Iva e/o Codice Fiscale Controllare la correttezza con l' apposita funzione nel menu: Contabilità - Servizio)
Per ogni documento trasmesso verrà comunicata la Partita Iva o il Codice Fiscale del cliente/fornitore a seconda che il soggetto sia o meno titolare di Partita Iva. In caso di straniero , per l'anno 2017 si accetta anche la mancata compilazione di questi dati, successivamente verranno considerati obbligatori.
- sono obbligatori i dati Indirizzo, Comune e Stato
Si consiglia di compilare il campo 'Comune'. In mancanza del Comune verrà scaricata la località.
- Stato: deve essere compilato correttamente, se straniero, altrimenti lasciato bianco o IT se italiano
Accertarsi che nella tabella Stati, in ogni Stato sia stato compilato il codice ISO corretto (Per la Grecia: EL)
- Campo: Comunic.dati fattura (maschera dati di Contabilità)
La normativa prevede che, in generale, vengano trasmessi tutti i documenti emessi e ricevuti per cui è bene accertarsi che in TUTTE le anagrafiche tale campo sia impostato correttamente in quanto negli anni precedenti alcuni fornitori venivano esclusi dallo spesometro.
Per il controllo: dalla Gestione clienti e/o fornitori , per la ricerca degli Esclusi: sbiancare il codice cliente/fornitore, posizionarsi sulla maschera 'Coge' , scegliere sul campo Comunic. dati fatture 'Escluso' e premere il tasto di Ricerca (binocolo), in questo modo verrà visualizzato l'elenco di tutti gli esclusi.

Codici IVA
- Com. rilev. ai fini iva
Questo campo dovrà essere impostato a Si su tutti i codici iva che dovranno essere comunicati
- NATURA
Si raccomanda, se già non è stato fatto, di creare codici iva diversi per registrazioni ‘diverse’ es. uno per il 22% normale, uno per il 22% utilizzato per integrare l’acquisto RevCharge etc.
Su ogni codice utilizzato per le registrazioni, con Tipo Iva diverso da ‘Normale’ e ‘Non detraibile’ occorre obbligatoriamente compilare il campo Natura (come da tabella riportata in seguito) che identifica la Natura delle operazioni ovvero il "motivo" specifico per il quale il cedente/prestatore [FORNITORE] non deve indicare l'imposta in fattura

TABELLA NATURA

N1 - escluse ex art. 15

N2 - non soggette:
- Prestazioni di servizi extra ue
- Acquisto fuori campo IVA ex articolo 74 del d.P.R. n 633/1972 commi 1 e 2
- Fatture ricevute da contribuenti che si sono avvalsi dei regimi agevolati, di cui all’articolo 27, commi 1 e 2

N3 - non imponibile
- Fatture emesse relative ad operazioni non imponibili (ad esempio una esportazione ovvero una cessione di beni intraUE), anche se effettuate da un soggetto in regime del margine
- Con riferimento agli acquisti intracomunitari effettuati ai sensi dell’articolo 42 del decreto legge n. 331/1993, occorre riportare la natura N3 nel caso di operazione non imponibile

N4 - esenti
Operazioni esenti. Es. una prestazione sanitaria
Con riferimento agli acquisti intracomunitari effettuati ai sensi dell’articolo 42 del decreto legge n. 331/1993, occorre riportare la natura N4 nel caso di operazione esente

N5 - regime del margine / IVA non esposta in fattura
- Fatture relative alle operazioni per le quali si applica il regime speciale dei beni usati (decreto-legge 23 febbraio 1995, n. 41, articolo 36 e seguenti), come ad esempio una cessione di una utovettura usata, o quello dell’editoria.
- Fatture emesse senza separata indicazione dell’imposta (articolo74-ter del d.P.R. n. 633/1972) dalle agenzie di viaggio e turismo

N6 - inversione contabile
- per le operazioni in reverse charge (es. cessione di rottami)
- fattura d'acquisto in reverse charge
- nei casi di autofatturazione per acquisti extra UE di servizi
- per importazioni di beni nei soli casi previsti

N7 - IVA assolta in altro stato UE
- vendite a distanza ex art. 40 c. 3 e 4 e art. 41 c. 1 lett. b, DL 331/93
- prestazione di servizi di telecomunicazioni, tele-radiodiffusione ed elettronici ex art. 7-sexies lett. f, g, art. 74-sexies DPR 633/72)

NOTA BENE:
Se per gli acquisti Reverse Charge, INTRA CEE ed EXTRA UE sono stati utilizzati codici iva particolari consigliamo di mettere N6 direttamente sul codice iva, diversamente il programma assegnerà il valore ‘Natura' come descritto in seguito:

  • Reverse Charge - Natura N6
  • Acquisti ExtraUE - Acquisto di beni tramite Bolla doganale: la causale deve avere il campo 'Import NoCee' =S e il campo 'Causale collegata', bianco o contenente una causale di tipo giroconto, il fornitore avrà stato = IT o bianco. Nella registrazione PN dovrà essere compilato il campo fornitore straniero/Black list. In automatico il programma assegnerà la Natura come codificato sui codici Iva - Acquisto di beni senza Bolla doganale, di servizi che richiedono l'autofattura di acquisto, di beni per i casi previsti dalla legge: la causale dovrà il campo Import.NoCee=S , se NON c’è la causale collegata di tipo Vendite (quindi il programma non ha creato in automatico la fattura di vendita) occorre fare attenzione quando si crea la fattura di vendita collegata usare una causale con flag autofattura a Si o mettere nel cliente fittizio di NON comunicare. Nel caso di autofattura di acquisto compilando, in testata nell’inserimento della registrazione in prima nota, il campo fornitore straniero/Black list verrà riportato questo nell'anagrafica del cedente. In automatico il programma assegnerà la Natura N6 a meno che non sia compilato il codice Natura sulla tabella Iva
Acquisto INTRA CEE - Natura N6 . Inoltre per queste registrazioni, diventa indispensabile aver compilato correttamente sui conti di costo utilizzati, il campo: Beni o Servizi in quanto va scaricatoi un codice ‘Tipo documento’ diverso a seconda dell’uno o l’altro tipo. Se già sono state utilizzate causali diverse, si potrà impostare, con i programmi aggiornati, direttamente il tipo documento sulla causale, altrimenti sarà il programma a decidere in base ai conti

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.01C


NOTE SULLA VERSIONE 4.01C DEL 24/05/2017

Nuove funzioni

COMUNICAZIONE LIQUIDAZIONI PERIODICHE IVA
In adempimento alla nuova normativa 2017 la Comunicazione trimestrale delle Liquidazioni Periodiche Iva all’Agenzia delle Entrate, sono state implementate tre nuove funzioni nel Menu Contabilità – Iva:

  • Preparazione dati
    Verranno elaborati i dati risultanti dalla Chiusura Iva per preparare una tabella contenente tutti i campi da comunicare

  • Gestione dati
    Consente di variare i dati preparati con la funzione precedente

  • Preparazione file e Stampa modulo
    Consente di Stampare i dati sul modulo dell’Agenzia delle Entrate e di preparare un file contenente i dati stessi

NOTA IMPORTANTE
E’ INDISPENSABILE ripetere le Chiusure iva dei primi 3 mesi, per le ditte mensili, o del primo trimestre per le trimestrali, prima di procedere all’estrazione dei dati da trasmettere.
Prima di ripetere le Chiusure accertarsi che, per il calcolo corretto degli importi: Totale delle operazioni attive e passive, sia stato compilato sui codici iva che indicano un'esenzione o un non imponibile, il campo : "Comunicazione ann. Iva: Op.attive/passive" nel modo opportuno.
Nel caso di presenza di più attività iva è indispensabile eseguire le Chiusure iva di tutte le attività, seguite dalla Chiusura Iva Riepilogativa eseguita per ogni periodo (mese o trimestre).
Se le Chiusure iva sono state già eseguite come ‘definitive’, per poterle ripetere occorre riportare indietro Data ultima chiusura e ultimo periodo Chiusura in Contabilità – Iva – Dati iniziali Iva

Altre modifiche

Dichiarazioni di intento in emissione documenti - Calcolo Totale già erogato
Sono stati introdotti due parametri di personalizzazione
DichIntentiQualeTot Consente di indicare quale importo usare per il calcolo: D(default) = totale Documento, M=totale Merce con calcolo sconto pagamento, E=totale documento - totale imponibile e totale iva (in pratica totale esente)
DicIntentiCalcRes Indica come calcolare residuo per dichiarazione d'intenti: F = solo fattura, D = fattura + DDT, O = fattura + DDT + ordini

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.01B


NOTE SULLA VERSIONE 4.01B DEL 06/03/2017

Nuove funzioni

  • Controllo plafond delle Dichiarazioni di intento ricevute dai clienti
    Una volta inseriti gli estremi delle dichiarazioni d’ intento ricevute dai clienti (maschera (0) Dich.Int. della gestione clienti) , al momento dell’inserimento di un documento (ordine, ddt , fattura), se c’è sul cliente una sola dichiarazione di intento attiva , viene portato il codice sul documento. Inoltre, sui documenti, vengono visualizzati gli importi di fatture, ddt e ordini, ottenuti sommando il totale dei documenti con lo stesso Codice Dich. Intenti. Nel calcolo vengono considerate: tutte le fatture, i Ddt stampati e/o appena inseriti, gli ordini NON evasi (non si considerano i parzialmente evasi)
    Vedere il manuale in linea capitoli Gestione Clienti – Dich.intenti e Fatture Dati Cliente

  • Adeguamento modulo per la comunicazione DICHIARAZIONE D’INTENTO
    Dal 1° marzo 2017 gli esportatori abituali devono utilizzare il nuovo modello di dichiarazione d’intento per effettuare acquisti o importazioni in regime di non imponibilità IVA: nel modello non è più prevista la possibilità di riferire le dichiarazioni ad acquisti da effettuare in un determinato arco temporale. Si deve, invece, fare riferimento ad una o più operazioni entro un importo prefissato.
    E’ stata adeguata la stampa del modulo e la preparazione del file per l’invio telematico.

Altre modifiche

  • Chiusura Iva
    In fase di Ristampa vengono letti gli importi memorizzati al momento della stampa e vengono compilati automaticamente i campi della maschera a video, senza possibilità di variarli.
    Messa la richiesta se stampare o no il dettaglio dei codici iva Reverse Charge, San Marino, Iva Agricola, piuttosto che raggruppare solo per aliquota (per agevolare chiusura annuale)
  • Stampa documenti in formato Pdf
    Introdotta la possibilità di differenziare, per ogni tipo di documento, la cartella dove memorizzare i pdf , mettendo la riga DirPdf=cartella di destinazione
    nelle rispettive sezioni [staFATSFAT] - [StaDDTsDdt] - [ScontrinX] indicando in ciascuna una cartella diversa
    Fattura Elettronica
  • Introdotto gestione del campo ‘Codice Tipo’ per ogni articolo presente in fattura.
    Indica la tipologia di codice articolo (per esempio, TARIC, CPV, EAN, SSC, ...). Es. per le fatture della CARTADELDOCENTE nel codice articolo va messo il codice del buono
    Vedere manuale in linea capitolo Fattura Elettronica PA
  • Preparazione file XML per Tessera Sanitaria
    Aggiunta la scelta del ‘Tipo Operazione da Estrarre: Inserimento - Variazione - Rimborso – Cancellazione’ per consentire di preparare un file con le sole Variazioni o Cancellazioni
    Scelta se scaricare o meno le righe con importo a 0.

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.01


NOTE SULLA VERSIONE 4.01 DEL 19/12/2016

Nuove funzioni

  • Adeguamento tracciato Fattura Elettronica
    Per consentire la fatturazione elettronica tra privati, oltre a quella verso la PA, a partire dal 1° gennaio 2017, è stato adeguato il formato per la trasmissione delle fatture elettroniche in modo che possa essere utilizzato l’unico tracciato XML, sempre usufruendo del Sistema di interscambio (SdI), come previsto dal Dlgs 127/2015.
    L’Agenzia delle Entrate spiega che fino al 31 dicembre 2016 le fatture elettroniche dovranno essere trasmesse nel vecchio formato mentre, dal 9 gennaio, saranno accettate esclusivamente quelle inviate secondo le regole aggiornate.
    Per quanto riguarda la preparazione del file XML verso la Pubblica Amministrazione non è necessario apportare nessuna modifica ai dati ma solo adeguare il programma per lo scarico nel nuovo formato 1.2
    Fattura elettronica tra privati:
    E’ stato aggiunto il campo PEC sull’anagrafica clienti (scheda 9-Email) che indica quale degli indirizzi email scritti sul cliente contiene la PEC (Default è la principale)
    Per le note di preparazione della fattura elettronica tra privati si rimanda al manuale in linea, capitolo ‘Fattura elettronica’

  • Ulteriori Codici a barre articoli
    Con questa nuova funzione è possibile associare ad ogni articolo ulteriori codici a barre oltre a quello messo in anagrafica. Quando si effettua la ricerca di un articolo per codice a barre, il programma prima lo cerca in tabella Articoli poi su questa tabella.

    NOTA IMPORTANTE
    Nella versione 4.00b è stata abilitata la possibilità di memorizzare i dati anagrafici precedenti di un cliente o un fornitore, in caso di cambio es. dell’ indirizzo. Abbiamo verificato che troppo spesso si conferma la ‘storicizzazione’ anche quando si sta correggendo un errore nell’anagrafica provocando in questo modo una stampa errata sui documenti precedenti alla correzione.
    Si invita perciò, prima di confermare la storicizzazione, a verificare se ha senso o meno farla.

Altre modifiche

  • Stampa bilancio di Verifica
    Aggiunta una opzione di stampa per Gruppi, Mastri e Conti
  • Gestione documenti (Preventivi, Ordini, Ddt, Fatture)
    Le scelte possibili impostate nel campo ‘Stampa prezzi’ in testata documento, sono state uniformate per tutti i documenti
  • Help Articoli
    Se sui documenti è impostata la ricerca per Codice a barre e si digita il codice articolo seguito da Invio (o F2) per un articolo che NON ha il Codice a barre: prima lo trovava ma lasciava vuoto il campo codice (dove metteva il codice a barre che per quell’articolo non esiste) e quindi non lasciava proseguire, ora imposta nel campo il codice articolo e si può proseguire
  • Inserimento articolo in documento - ricerca per codice a barre
    Parametro CodBarSalva Programmi: Ddt, fatture, ordini, preventivi (scontrini,caricamento movimenti di magazzino, ordini di acquisto) Se vale S, una volta digitato o letto da penna il barcode dell'articolo, il programma passa alla richiesta di un nuovo articolo, dopo aver salvato la riga precedente (in pratica esegue in automatico F10)
  • Inserimento articolo in documento - ricerca per codice a barre con Taglia/Colore
    Si rimanda al manuale in linea, capito Gestione Livelli a tabella e Parametri di personalizzazione CodIniLiv e CodBarLunArt

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.00b


NOTE SULLA VERSIONE 4.00b DEL 25/07/2016

Nuove funzioni

  • Fattura Elettronica alla Pubblica Amministrazione
    Dal 9 maggio 2016 il Sistema di Interscambio (SDI) ha introdotto nuovi controlli sulle fatture emesse. Dal 1 agosto 2016 il mancato superamento di uno o più di questi nuovi controlli comporterà lo scarto del file.
    In particolare il totale di riga (eventualmente scorporando l’iva se ivato) deve coincidere col prodotto della quantità * prezzo unitario scontato (compreso eventuale sconto pagamento).
    Poiché nella fattura standard lo sconto pagamento viene invece calcolato sul totale imponibile, si è reso necessario introdurre un nuovo campo sulla testata dei documenti (ordini, ddt e fatture) che indica se applicare lo sconto Pagamento sul dettaglio, campo che dovrà essere impostato obbligatoriamente a SI nel caso di fattura PA. Questo nuovo campo può essere gestito manualmente sulla testata dei documenti oppure è possibile impostare dei parametri di personalizzazione ScontoPagInDet (gruppo Fatture , Ordini o Ddt) dove in Valore si scriverà l’elenco tipi documento utilizzati per ottenere fatture elettroniche nei quali lo sconto pagamento dovrà essere aggiunto agli sconti sulle singole righe.
    Se il tipo documento è in elenco , il campo, sul documento, che indica se applicare lo sconto Pagamento sul dettaglio verrà impostato a Si e lo sconto pagamento verrà applicato come ultimo sconto di riga. In modo analogo, se c’è uno sconto pagamento, questo verrà applicato sulle singole spese che lo prevedono.

    Inoltre, per far quadrare il totale, l’importo unitario viene scaricato, sul file XML, sempre con un numero di decimali pari al più grande tra 5 e il numero di decimali che c’è nella tabella ‘monete’ in moneta di gestione.

Altre modifiche

  • Scadenze
    Gestione Condizioni di Pagamento - Generazione scadenze in fattura e input prima nota
    In caso di decorrenza ‘Data Fattura’ e periodicità ‘Mensile Tabellare’ con giorno fisso, se si vuole che la prima scadenza cada nel mese di emissione della fattura si potrà mettere 0 nel campo ‘Scadenza’ sulla riga 1 della tabella che si va a creare.
  • Stampa Sconti a quantità
    Inserita richiesta se stampare ‘Sfondo grigio alternato nelle righe di stampa’
  • Ritenuta d'acconto
    Introdotto parametro di personalizzazione RitaccDescr che consente di personalizzare la frase scritta in fattura in corrispondenza dell'importo della ritenuta.
    Possibilità di applicare una percentuale ritenuta non sull'intero imponibile ritenuta ma solo su una parte (Es. 20% applicata sul 50% dell'imponibile)
  • Gestione livelli (Taglia/Colore)
    E’ stata aggiunta la possibilità di leggere un codice a barre che identifica oltre all’articolo anche taglia e colore e di inserire taglia/colore direttamente sulla riga del documento
  • Tasto F10
    Riabilitato in tutte le gestioni per salvare i dati a video

Vedi anche:
Note installazione
Note aggiornamento

Note release 4.00


NOTE SULLA VERSIONE 4.00 DEL 14/04/2016

Nuove funzioni

  • Tessera Sanitaria
    Il modulo Tessera Sanitaria è un pacchetto aggiuntivo di AziendaPC che consente di eseguire l'estrazione delle fatture al fine di poter preparare il file in formato XML per la trasmissione dei dati di spesa sanitaria, a cura dei medici e delle strutture sanitarie, al sistema Tessera Sanitaria per per il 730 precompilato, come previsto dall’articolo 3 comma 3 del D.Lgs. 175/2014.
  • Gestione STORICO anagrafiche clienti e fornitori
    Al fine di consentire di stampare sui documenti, registri iva e giornale, i dati anagrafici con lo stesso valore che avevano al momento in cui è stato prodotto il documento.
    I dati storicizzati sono: Ragione Sociale, Indirizzo, Cap, Località , Provincia, Comune, Stato
    Nel momento in cui, in Gestione clienti e fornitori, si va a variare uno di questi dati, il programma chiede se storicizzare i precedenti.
    Per coerenza con questa modifica, anche il codice dell’indirizzo amministrativo del cliente viene memorizzato sulla fattura mentre prima veniva letto fisso dall’anagrafica del cliente stesso.
  • Gestione Livelli
    Aggiunta nuova modalità, impostata come predefinita, per l’inserimento nei documenti di articoli con livelli (Taglia/Colore)
  • Predisposizione per Sql Server
  • Aggiornata tabella dei Comuni sul AziMenu.mdb

Altre modifiche

  • Gestione clienti e fornitori
    Sono stati aggiunti nuovi campi stringa sul database per utilizzo libero da parte dell’utente.
    E' possibile impostare i parametri di personalizzazione: DescDescPers1, DescDescPers2, DescDescPers3 con il titolo dei nuovi campi che verranno gestiti nella maschera dei dati anagrafici. Cambiata da 12 a 14 la lunghezza del campo Partita Iva per poter contenere P.I. di stati esteri es. Macedonia
  • Stampa e visualizzazione partitari
    Nuova richiesta a video: Tot.reg. Cli/For per consentire di ottiene una riga con il totale incassato da un cliente che ha pagato contemporaneamente più fatture. Per impostare a Si questa opzione si può impostare il parametro di personalizzazione TotReg (Gruppo: PartVis e StPart)
  • Sistemazione partite
    Inserita una scelta che Consente di impostare come Chiuse le righe relative a incassi/pagamenti per i quali non esistono più in archivio le registrazioni delle relative fatture (ad esempio perchè è stata fatta la Cancellazione completa dei movimenti di anni vecchi)
  • Stampa lettera e Segnalazione saldo Estratto Conto
    Inserito pulsante: ‘Stampe separate per ogni cliente’; se si seleziona e si sceglie creazione del file pdf e invio per email, verrà fatto un pdf diverso per ogni cliente
  • Invio Email
    Possibilità di inserire una immagine o un cambio di font nel testo delle email inviate
  • Caricamento movimenti di magazzino (carico merce) ed Evasione Ordini di acquisto
    Possibilità di inserire un importo o una percentuale di spese sostenute per l’acquisto e di calcolare il Costo Ultimo dell’articolo tenendo conto anche di tali spese.
    Vedi parametro di personalizzazione: RipartSpesePercVal e Gestione Causali di magazzino campo ‘Ripartizione spese’.
  • Gestione articoli
    E’ stato aggiunto il campo ‘Data variazione’ , campo da gestire manualmente. Se valorizzato può essere utilizzato, in selezioni, es. in Stampa Listini
    Inoltre sono stati aggiunti dei nuovi campi sul database, numerici e stringa, per utilizzo libero da parte dell’utente. Questi ultimi sono attivabili con i parametri di personalizzazione: ArtAggNum0-3 e ArtAggStringa0 e gestiti nella maschera (3) Attr/Pers
    Nel campo ‘File per Immagine’ è possibile, oltre al nome di un file, mettere un URL e il programma, se è attiva la connessione ad internet, farà vedere l’immagine corrispondente.
  • Gestione Spese – Ddt – Fattura Accompagnatoria
    Aggiunto tipo Spesa a Importo per unità di Peso
    La spesa finale addebitata sul documento verrà calcolata moltiplicando l'importo della 'spesa' per il peso riportato nel campo Peso dei dati di Accompagnamento (Il calcolo viene fatto sui Ddt e sulle Fatture accompagnatorie e dirette/riepilogative)
  • Ddt e Fatture (Preventivi e Ordini)
    Per caricare in automatico sul documento la spesa il cui codice è stato impostato sull’anagrafica del cliente: Parametro: SpesaClieAutom Gruppo: Fatture
  • Inserimento Fatture
    E' stato inserita la possibilità di creare il parametro di personalizzazione SegnRicClie per far si che, se si varia su una fattura il codice del cliente e il nuovo cliente ha il conto di ricavo compilato, venga data una segnalazione per consentire all'utente di variare i conti di ricavo sui dettagli in quanto il programma non lo farà automaticamente
  • Provvigioni
    Inserita la gestione di una % di deducibilità Provvigioni anche su sconti
  • Stampa provvigioni sull’incassato
    Aggiunta la scelta: ‘In prestampa stampa anche con pagamenti successivi’ con la quale si ottiene la stampa di una situazione a una certa data senza tener conto degli eventuali incassi successivi a tale data

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.06


NOTE SULLA VERSIONE 3.06 DEL 26/01/2015

Nuove funzioni

  • SPLIT PAYMENT per FATTURAZIONE alla Pubblica Amministrazione
    La Legge di Stabilità per il 2015 ha introdotto nel D.P.R. 633/1972 l'articolo 17-ter, che disciplina il nuovo meccanismo del cosidetto "Split Payment" per le operazioni effettuate nei confronti degli enti pubblici, i quali dovranno versare l'IVA relativa alle fatture ricevute dai loro fornitori, al posto del fornitore stesso Saranno interessati allo split payment tutti i fornitori della pubblica amministrazione che dal 1 gennaio 2015 pur avendo emesso regolare fattura con addebito di Iva, incasseranno solo l’imponibile. Saranno invece esclusi quei fornitori che sulle proprie prestazioni sono soggetti a ritenuta alla fonte sulle prestazioni (i professionisti) e coloro che già applicano il reverse charge.
    Vedere note (**) per i dettagli sui codici da configurare.
  • Fattura Elettronica PA
    Adeguato il tracciato del file XML secondo il nuovo formato 1.1 in vigore dall’1 febbraio 2015.
    Una volta fatto l’aggiornamento, si ricorda di copiare nell’area in cui si memorizzano le fatture elettroniche pronte all’invio, il file ‘fatturapa_v1.1.xsl’ , che consente la visualizzazione delle fatture nel nuovo formato.
    Tale file si trova nella cartella PRG\BaseDati\FatturaPA dell’area di installazione o in Aziwin\FatturaPa, una volta fatto l’aggiornamento.

    Possibilità di mettere un allegato nel file XML.
  • Invio email
    La funzione consente l’invio di una email a un gruppo di clienti o fornitori selezionabili con vari criteri, con possibilità di allegare un file.

Altre modifiche

  • Generazione movimenti di chiusura conti
    Inserito controllo su saldo totale dei conti d’ordine. Se questo è 0 , vengono chiusi come i Patrimoniali poi vengono riaperti con la Generazione movimenti di apertura.
    Prima occorreva chiudere a mano prima della chiusura, uno per uno, i conti d’ordine con saldo diverso da 0.
  • Descrizione aggiuntiva e Descrizione testata di prima nota
    La lunghezza dei due campi è stata portata da 30 a 200 caratteri per consentire l’inserimento di commenti più lunghi. Variate stampe Giornale e Registri Iva.
  • Preparazione file RID
    Adeguato il formato del file RID secondo il tracciato SEPA
  • Generazione, Stampa e Contabilizzazione distinta, Generazione del file delle Ri.ba
    Possibilità di inserire in distinta , se attivo il parametro di personalizzazione: RaggFtNc=S Gruppo Distinta, anche le scadenze di Note di Credito. Condizione necessaria è che tutte le scadenze del cliente interessato che hanno la stessa data di scadenza della Nota di Credito abbiano il campo ‘raggruppo scadenza’ impostato a SI
  • Statistiche Ordini e Preventivi
    Inserita selezione per Centro di Costo e ordinamento per CDC/Articolo
  • Stampa fatture
    Inserita selezione per agente
  • Stampe su file Excell
    Mette come estensione, al nome di file assegnato alla stampa, XLS o XLSX a seconda della versione di Office che è installato
  • Funzione che consente di eseguire una Query dal menu (Tasti Ctrl Alt Shift Q)
    Inserita opzione di stampa dei dati estratti dalla query eseguita
  • Configurazione Menu (Tasti Ctrl Alt Shift L)
    Aggiunta la maschera per personalizzare i colori del menu e delle maschere dei programmi
  • Aggiornamento campi del database (Tasti Ctrl Alt Shift L)
    Introdotta la richiesta della data iniziale per aggiornamento. Se si lascia vuota, verrà aggiornato il database a cominciare dalla data che è scritta sulla tabella ‘Config’ del database stesso, altrimenti si comincia dalla data più vecchia tra quella che trova in Config e quella digitata
    Può servire per allineare, cioè caricare le nuove tabelle e nuovi campi, un database che in qualche aggiornamento precedente ha avuto dei problemi.

(**) Note su Split Payment

Se sono già state registrate, nel 2015, delle fatture alla pubblica amministrazione che seguono il meccanismo dello Split Payment , PRIMA DI FARE LE MODIFICHE descritte nel capitolo 'Fatture Split Payment' accertarsi che:

  • non sia stato fatto l’aggiornamento iva di gennaio (se è stato fatto occorre disaggiornare)
  • non siano già state contabilizzate (se lo sono state, occorre decontabilizzarle)
  • siano state inserite con un tipo documento creato appositamente e collegato ad una causale contabile ‘nuova’

Se ci si pone in queste condizioni, poi si apportano le modifiche descritte nel capitolo 'Fatture Split Payment'.
Successivamente i programmi saranno in grado di registrare correttamente in contabilità le fatture emesse con causali 'Split' e di gestire correttamente i registri iva e la chiusura iva, compresa quella di gennaio 2015.

Per le modifiche da apportare alle tabelle si rimanda al capitolo 'Split Payment'

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.05c


NOTE SULLA VERSIONE 3.05c DEL 14/07/2014

Nuove funzioni

  • FATTURA ELETTRONICA
    Preparazione del file XML della fattura

  • Stampa margini Preventivi

  • Gestione fatture: Quadro scadenze
    Pulsante che consente di variare, in fase di inserimento fattura, le scadenze della stessa se si vogliono diverse da quelle generate automaticamente in base alle caratteristiche della condizione di pagamento.

Altre modifiche

  • Gestione tabella Ditta
    Ampliato il campo Cognome_Nome persona fisica da 30 a 50 caratteri
  • Stampa Preventivi – Ordini – Fatture
    Estesa la possibilità che prima era solo per i Ddt, di stampare un documento WORD dopo la stampa (vedi parametro di personalizzazione: StDocFine Gruppo: StFatture e Ordini)
  • Per integrazione dati per fattura elettronica:
    Aggiunti campi nelle gestioni: Anagrafica Ditta, Monete, Clienti, Codici Iva, Tipi Pagamento, Tipo documenti, Testata e dettagli fattura
  • AGGIORNAMENTO Database e Compattamento archivi
    Al fine di rendere più sicuro l'esito del compattamento (aggiornamento) è possibile scegliere a video di fare:
    Verifica dimensioni tabelle e Copia archivio prima di compattare/aggiornare
    Per settare a Si in automatico queste due opzioni si possono impostare i parametro di personalizzazione: CompattaAvvioCopiaDb e CompattaAvvioVerif
    Si consiglia di eseguire periodicamente il compattamento attivando anche queste due opzioni aggiuntive.
  • Stampe parametriche
    Inserita richiesta, in alcune stampe parametriche (es. articoli, clienti e fornitori), se stampare o meno l’intestazione (sempre - mai - solo intestazioni di colonne) per quanti stampano su file e non vogliono righe di intestazione in testa.

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.05b


NOTE SULLA VERSIONE 3.05b DEL 20/03/2014

Nuove funzioni

  • Comunicazione Black List (operazioni effettuate con controparti residenti in Paesi a fiscalità privilegiata)
    Dal 2014 anche tale comunicazione dovrà essere presentata con il modello della Comunicazione Polivalente (lo stesso dello spesometro)
    (Menu contabilità - Iva - Prep.file per invio telem. e stampe - Black List-Spesometro dal 2014)

  • Stampa situazione fatture Iva per Cassa - Regime iva per cassa
     Consente di ottenere un elenco delle fatture non ancora incassate/pagate
    (Menu contabilità - Iva - Stampe)

  • Distinta Base gestita in Ordini – Ddt - Fatture
    Se è installato il modulo della Distinta Base, sul tipo documento utilizzato per registrare Ordini, Ddt e Fatture è stata codificata in modo opportuno la ‘Causale che aggiorna il magazzino’ e nel documento ci sono articoli con distinta base, al momento dell’inserimento (Ordini) o della stampa (Ddt e Fatture), oltre a movimentare gli articoli presenti, il programma movimenterà anche i relativi componenti.
    N.B. controllare, in Gestione causali di magazzino, le caratteristiche della causale scritta sui Tipi documento in uso nel campo ‘Causale che aggiorna il magazzino’.
    In particolare se è compilato il campo 'Causale collegata per DiBa', mentre prima NON aveva effetto per la stampa dei documenti, ora creerà dei movimenti

NOTA BENE - E’ stato aggiunto sulla tabella Banche un indice ABI e CAB.
In fase di aggiornamento del database, se il programma incontrerà 2 o più banche con stesso Abi e Cab darà una segnalazione di errore, occorre scegliere di continuare l’aggiornamento ignorando questa segnalazione.

Altre modifiche

  • Spesometro - Clienti Cointestatari
    Viene gestito un nuovo campo in tabella Cointestatari, dove si può inserire la percentuale di ‘cointestazione’. Questa servirà per suddividere adeguatamente il totale delle fatture intestate al 'cliente principale' sui vari cointestatari, in fase di preparazione dello Spesometro.
    Se tale percentuale non viene compilata, si intende che tutti i cointestatari possiedono parti uguali della proprietà, se viene impostata solo per qualcuno, il resto verrà diviso in parti uguali sugli altri.
  • Stampa distinta effetti
    Possibilità di ordinare le scadenze per Cliente
  • Gestione Riepiloghi Movimenti Iva per Cassa
    Messo il pulsante per gestire anche i movimenti generati dall’aggiornamento per fatture non incassate dopo un anno
  • Tabella Comuni (inserita nell’AziMenu.mdb)
    E’ stata aggiornata con nuovi comuni. Al fine di consentire anche in seguito l’aggiornamento automatico di tale tabella, si chiede di inserire eventuali nuovi comuni con codice maggiore di 100000.
  • Magazzino – Stampa Etichette
    Aggiunta la possibilità di stampare le etichette degli articoli presenti in uno o più ordini
  • Ordini e Vendite
    Nei documenti, la descrizione articolo potrà essere modificata rispetto a quella scritta sull'articolo stesso. In questo caso essa verrà memorizzata sul documento per la stampa e l'evasione. In gestione documenti, la riga verrà evidenziata con la nota: 'descrizione modificata'.
  • Vendite - Gestione e stampe documenti
    Introdotta la possibilità di variare la descrizione dell’articolo su un documento e di stamparla così com’è stata variata
  • Vendite - Stampa cointestatari in fattura
    Inserito parametro di personalizzazione CointStaDet. Consente di stampare una nota sulla fattura con l'elenco dei dati dei cointestatari.
    Il testo della nota va impostato nel Parametro: CointDetBase
  • Vendite – Calcolo e stampa importo Cassa Previdenza
    In Dati generali azienda – Causali comuni, si può inserire un codice SPESA (appositamente creata in tabella Spese con il campo ‘Cassa previdenza’ barrato) su cui calcolare l’importo della Cassa Previdenza. In ogni cliente c’è un flag di abilitazione alla Cassa Previdenza. Se verrà compilato il codice Spesa, i programmi di emissione ordini, ddt e fatture calcoleranno in automatico tale spesa

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.05


NOTE SULLA VERSIONE 3.05 DEL 30/10/2013

Nuove funzioni

  • Spesometro (Comunicazione Operazioni rilevanti ai fini Iva)
    Nuova funzione per la preparazione del file delle operazioni da comunicare e stampa.
    (Menu contabilità - Iva - Spesometro)

    L'installazione copierà dentro la cartella AziWin\Immagini le immagini necessarie alla stampa Spesometro: Spesometro01.gif e Spesometro14.gif

    Togliere, se già non è stato fatto, allo stato SM – Repubblica di San Marino, il Flag Black List (fare lo stesso con eventuali altri stati che sono stati tolti dall’elenco dei paesi black list e con i quali si hanno rapporti commerciali)
    (Parametri e Utilità – Dati azienda parametri – Elenco Stati)

    Se si renderà necessario modificare il campo 'Operaz.rilevante ai fini Iva' su qualche registrazione del 2012 per escluderla o includerla forzatamente, se l'anno è chiuso, occorre riaprirlo temporaneamente con la funzione Contabilità - Annuali - Chiusura definitiva anno precedente. Questa operazione consentirà di variare il suddetto campo anche se le registrazioni sono già stampate.
    Per richiuderlo, una volta fatte le modifiche, rieseguire la stessa funzione.
    Per ulteriori informazioni leggere i capitoli Spesometro e Spesometro -Preparazione file per invio telematico

    All' indirizzo http://www.aziendapc.it/documenti e nella cartella \BaseDoc\Spesometro\ dell'area di installazione sono disponibili i file prelevati dal sito dell’Agenzia delle Entrate, contenenti istruzioni e tracciati.
    Si consiglia vivamente di leggerli e far riferimento ad essi per comprendere meglio quanto esposto in seguito.

  • Invio fatture per email
    - utilizzo di SEE in alternativa a Sendmail
    L'utilizzo di SEE è obbligatorio per i server di posta che utilizzano SSL (in particolare per la casella di posta certificata)
    - Gestione, in testata fattura, di due campi che indicano la data e il risultato dell'eventuale invio del documento via email:
    Parametro di personalizzazione: AggdataInvioEmail per indicare quando aggiornare la data di invio
    Campo 'Stato invio email': R Riuscito F Fallito N mai inviato

  • Iva per Cassa
    Nuova funzione Incasso/Pagamenti effetti in distinta
    Consente di selezionare gli effetti di una distinta già contabilizzata (senza la chiusura dei clienti) in modo da registrare l'incasso effettivo in automatico.

  • Personalizzazione campi delle liste (Prima nota, Preventivi, Ordini, Ddt, Fatture)
    Nel parametro ListaOrdin si può inserire l'elenco dei campi per l'ordinamento della lista dei documenti gestiti nei programmi suddetti.
    Se compilato sostituisce la order by di default della lista.

  • Distinta Base
    Nuova funzione per Sostituire e/o Cancellare articoli in una distinta .

  • Stampa parametrica articoli
    Nuova funzione

  • Stampe parametriche (clienti/fornitori, articoli etc.)
    Possibilità di impostare la stampa su più righe.
    Inserite, nella maschera di definizione delle stampe, i pulsanti: Collega altre tabelle, Test di selezione dati, Personalizzazione intestazione

Altre modifiche

  • Stampe - Maschera selezione destinazione stampa
    E' stata aggiunto un pulsante che da la possibilità di scegliere il Tipo di carta su cui stampare. Una volta selezionata la stampante, la pressione di tale pulsante, produrrà un elenco dei formati di carta disponibili su di essa.
    E' possibile, ad esempio, scegliere di stampare su foglio A3, là dove la stampante lo consente.
    Può essere utile per eseguire una stampa parametrica. Si può memorizzare, per una determinata stampa, la stampante e il tipo carta in modo da eseguirla sempre con quelle caratteristiche.
  • Stampa Comunicazione dichiarazione di intenti
    Aggiornata con lettura degli estremi delle dichiarazioni 'attive' dalla lista delle dichiarazioni di intenti di ogni cliente (maschera 'Dati Dich.Intenti').
    Nelle versioni precedenti i dati della dichiarazione di intenti venivano letti dalla maschera dei dati di 'Contabilità' del cliente. La stampa continuerà a prendere i dati da questa maschera se non sono stati impostati nella nuova.
  • Stampa fattura in pdf
    Introdotto parametro: PdfNomeData se vale S e non c’è nessun altro parametro che definisca il nome, il file verrà chiamato:
    AAAAMMGG +Pref+num.pdf
    Nel parametro PdfNomeDoc è stato aggiunta la variabile 'Anno'.

    Possibilità di definire, nel parametro DirPdf, un nome di cartella variabile per la destinazione del file pdf (es. cartelle diverse per fatture e ddt).
  • Cancellazione progressivi e costi articoli
    Aggiunto la selezione per articolo, solo costi o solo progressivi, SOLO progressivi con tutte le quantità a 0 per chi, dopo aver sdoppiato gli archivi e cancellato i movimenti degli anni precedenti, vorrà poi cancellare in automatico tutti gli articoli non movimentati nell'ultimo anno.
  • Stampa Confronto saldo contabile e saldo scadenze
    inserita opzione per stampare, per ogni anagrafica, un ulteriore importo con il saldo delle scadenze che sono in distinte contabilizzate ma non sono ancora state incassate e/o pagate (utile a chi gestisce l'iva per cassa).
    Parametro di personalizzazione StSaldoDist per impostare il valore di default dell'opzione proposta a video.
  • Cespiti - Prospetto manutenzioni eccedenti il 5%
    Nel calcolo relativo all'anno 2012 non si deve più tener conto degli acquisti e vendite dell’anno. A qualche cliente è tuttavia stato richiesto il calcolo comprensivo di tali importi. Pertanto è stata messa a video la richiesta se considerare o meno gli acquisti e vendite dell’anno da elaborare.
  • Brogliaccio movimenti di Prima Nota
    Inserita opzione per stampa completa articoli anche quando si sceglie di stampare i movimenti di un conto in particolare.
    Inserita stampa della descrizione testata della registrazione, oltre alla descrizione aggiuntiva.
  • Scadenze e Distinta
    Se sul cliente non è stato compilato il codice banca ma l'Iban, Abi e Cab verranno estratti da questo codice. In distinta verrà visualizzato l'Iban al posto del codice banca. In questo caso però, sul file delle Ri.Ba. , non verrà compilato il campo 'opzionale' con la descrizione della banca.
  • Segnalazione saldo estratto conto
    Aggiunta una opzione per stampare una lettera con l'elenco delle partite aperte, ciascuna con il suo saldo.
  • Caricamento movimenti di produzione
    Tramite l'attivazione del parametro di personalizzazione DettDibaAutom è ora possibile precompilare in automatico i dettagli con i componenti di base dell'articolo da produrre, inserito nella prima maschera.
    Sulla riga dei componenti è possibile indicare un lotto di provenienza, se ce n'è uno unico altrimenti si potranno inserire più lotti tramite la maschera di Gestione Lotti
  • Stampa e Visualizzazione partite:
    possibilità di includere, nel calcolo del saldo, anche le scadenze che sono in distinte contabilizzate ma non sono ancora state incassate e/o pagate.
    La contabilizzazione della distinta NON deve aver chiuso il cliente/fornitore. Utile a chi gestisce l'iva per cassa per capire quel' è l'effettivo saldo del cliente/fornitore.
    Parametro di personalizzazione IncludScad per impostare il valore di default dell'opzione proposta a video.
  • Gestione articoli
    Inserito un pulsante che consente la Generazione automatica del codice articolo
    Parametri di personalizzazione: Chiave Base e ChiaveBaseLun
  • Stampa e Visualizzazione parametriche
    Nella maschera in cui si definisce il nome della stampa personalizzata che si sta impostando, sono stati aggiunti i pulsanti:
    "Collega altre tabelle", "Test di selezione dati" e, solo nei programmi dove può essere significativo, "Personalizza intestazione".
    E' possibile, ad esempio nella Visualizzazione Partitari, inserire un Test di selezione dei movimenti, in modo da includere SOLO quelli con causale fattura e nota di credito.

  • Registrazione di vbsendmail.dll e mswinsck.ocx per invio stampe per email.
    Dalla versione 3.04 di AziendaPc (Gennaio 2013) l'installazione installa automaticamente anche i due file vbsendmail.dll e mswinsck.ocx.
    Se si disinstalla la vecchia versione, esse NON vengono disinstallate.
    Se si reinstalla , e la directory di installazione è la stessa, verrà dato un messaggio che la Dll esiste e chiede se si vuole sovrascrivere.
    E' bene perciò o reinstallare nella stessa directory di prima o, ancora meglio, disinstallarle prima di ripetere l'installazione.

    Sul Server 2008 l’installazione mette già mswinsck.ocx (e anche tutte le altre DLL) direttamente in Syswow64 così come va in windows7 a 64 bit
    In windows7 a 64 bit le DLL le mette sia in System32 sia in Syswow64

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.04


NOTE SULLA VERSIONE 3.04 DEL 31/01/2013

Nuove funzioni

  • Gestione dell' IVA per CASSA

  • Invio Telematico dei Corrispettivi mensili
    Gestione Punti Vendita
    Estrazione
    Gestione
    Preparazione File telematico

  • Calcolo provvigioni sull'incassato

  • Per motivi tecnici nell'installazione su terminal server, per utilizzarlo su un client, è necessario attivare un campo apposito sulla maschera 'Licenza concessa a' il che comporta il cambio del codice di attivazione da richiedere a CSS.

Altre modifiche

  • Clienti - Gestione estremi dichiarazione di intenti
    Inserita la possibilità di memorizzare più comunicazioni. Questo consentirà di non perdere traccia delle comunicazioni dei periodi precedenti e di stampare in fattura gli estremi di quelle attive alla data della fattura.
  • Campo numero documento in Prima Nota
    Il campo è stato portato da 6 a 12 caratteri.
  • Stampa registri Iva e Giornale
    Al fine di poter stampare il /anno a fianco del numero documento delle fatture emesse in registri e giornale, per quanti l'hanno stampato sulle fatture modificando il filtro, a seguito dell' indicazione del dicembre 2012 di attribuire alle fatture una numerazione 'univoca', è possibile attivare un parametro di personalizzazione StaAnnoDoc - Gruppo: Fiscali
    Dovrà essere impostato a /yyyy o /yy ad indicare il formato dell'anno così come lo si vuole stampare dopo il numero documento (in stampa verrà: /2013 oppure /13)
  • Condizione di pagamento sul Tipo documento e aggiunta di una seconda condizione di pagamento sui clienti
    Al fine di automatizzare l'applicazione di una determinata condizione di pagamento per tutti i documenti di un certo tipo, è stato inserito il campo 'Condizione di pagamento' sui Tipi documento delle vendite. In questo campo potrà essere inserita direttamente la condizione di pagamento particolare, che sarà prevalente su quella del cliente, oppure si potrà dire di applicare sempre la prima o la seconda condizione letta dal cliente.
  • Stampa partite
     Inserita opzione per stampa pagina con totali generali
  • Campo Ragione Sociale ditta (dati Generali Azienda)
    La dimensione del campo è di 50 caratteri. Se serve averla più lunga, per le intestazioni delle stampe etc. si può aumentare la lunghezza del campo manualmente sul database access (tabella Ditta campo RagSoc).
  • Nota sulla tabella dei codici iva
    Se nella stampa delle fatture, in presenza di un codice iva in cui è stato compilato questo campo, serve stampare una nota descrittiva più lunga della descrizione, il suo contenuto verrà stampato alla fine del corpo a meno che non sia presente nella testata o nel piede un riferimento al campo stesso (T_Iva01Memo )

  • Registrazione di vbsendmail.dll e mswinsck.ocx per invio stampe per email.
    Da questa lla versione 3.04 di AziendaPc (Gennaio 2013) l'installazione installa automaticamente anche i due file vbsendmail.dll e mswinsck.ocx.
    Se si disinstalla la vecchia versione, esse NON vengono disinstallate.
    Se si reinstalla , e la directory di installazione è la stessa, verrà dato un messaggio che la Dll esiste e chiede se si vuole sovrascrivere.
    E' bene perciò o reinstallare nella stessa directory di prima o, ancora meglio, disinstallarle prima di ripetere l'installazione.

    Sul Server 2008 l’installazione mette già mswinsck.ocx (e anche tutte le altre DLL) direttamente in Syswow64 così come va in windows7 a 64 bit
    In windows7 a 64 bit le DLL le mette sia in System32 sia in Syswow64

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.03b


NOTE SULLA VERSIONE 3.03b DEL 03/09/2012

Nuove funzioni

  • Stampa su file pdf e invio per email
    Possibilità di stampare direttamente qualsiasi stampa su pdf (spuntando semplicemente un campo a video e assegnando il nome del file in modo parametrico) e di inviarla per email a un indirizzo fisso (scelto tra tre possibili) o a uno inserito al momento.

  • Gestione testi per invio email
    Funzione per l’impostazione di testi (se ne possono predisporre fino a 5) da utilizzare per l’invio di un pdf per email.

  • Gestione di più indirizzi email sui clienti e fornitori

  • Preparazione file RID per la banca

Altre modifiche

  • Input Prima Nota - Per velocizzare la fase di compilazione dell’elenco dei dettagli nella maschera principale.
    Con l’aumentare del numero delle registrazioni i tempi di risposta del programma di Prima Nota risultano rallentati. Si può impostare il parametro di personalizzazione MostraDettTmp=S che consentirà, lavorando su tabelle di appoggio, di velocizzare.
  • Input Prima Nota - attivati i tasti F4 e F5 per fare la ricerca dei Cli/For per Partita Iva e Codice Fiscale
  • Visualizzazione Partitari e Partite
    Possibilità di stampare direttamente i movimenti selezionati e presenti a video tramite il pulsante di Stampa, presente sul video, in alto a sinistra.
  • Stampa partite
    Nell’ ultima pagina della maschera di personalizzazione della stampa, è possibile inserire una parametrizzazione dell’ intestazione della stampa
  • Visualizzazione partitari
    Nell’ ultima pagina della maschera di personalizzazione della visualizzazione, è possibile inserire una query che verrà aggiunta a quella di estrazione dei dati
  • Gestione Clienti e Fornitori
    A fianco all'indirizzo viene visualizzato un pulsante 'Mappa' con il quale è possibile visualizzare la pagina di Google Maps relativa all'indirizzo stesso.
  • Spese Tratte
    E’ stato implementato un modo più completo per l’addebito dei bolli sulle tratte.
    Dovrà essere creato un codice Spese Tratte (di tipo % per rata) da collegare alla condizione di pagamento. Preparate per la stampa le variabili: T_TotEsenteNoBolli e T_TotMerceNoBolli. Vedere manuale tabella Spese.
  • Scontrini (Registratore di cassa)
    Inserita opzione di incasso tramite bancomat per differenziare l’importo da quello incassato con ‘carta di credito’ nella stampa del totale giornaliero e nella registrazione del corrispettivo
  • AziWin.ini - sezione [Menu]
    Introdotto il parametro Uscita=PrgDaEseguire (percorso completo)
    Consente di eseguire un programma all'uscita del menu.
    Come default esegue sempre FineAziWin.bat (se lo trova nella cartella dove si trova il Menu.exe) dove si possono mettere le istruzioni volute.

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.03a


NOTE SULLA VERSIONE 3.03 DEL 16/11/2011

NOTE SULLA VERSIONE 3.03a DEL 04/04/2012

Operazioni rilevanti ai fini iva - Spesometro

Secondo le ultime indicazioni, le modifiche che il decreto-legge n. 16 del 2012 ha apportato allo “spesometro” riguardano le operazioni effettuate dal 1° gennaio 2012, per cui le operazioni del 2011 dovranno essere comunicate entro il prossimo 30 aprile secondo la precedente disciplina.
Inoltre si permetterà (scelta discrezionale) la comunicazione di operazioni anche al di sotto dei 3 mila (o 3.600) euro, con importi "non frazionati"

Si ricorda che, per la preparazione della comunicazione, sono state predisposte le seguenti funzioni:

  • Verifica - (Menu Contabilità - Utilità)
    Consente di visualizzare/stampare un elenco delle fatture con importo maggiore di 3000€ e, in particolare, evidenzia le eventuali note di credito sulle quali dovrà essere impostato il numero e la data della fattura cui si riferiscono; in caso di impossibilità ad associarle ad una fattura, si metterà solo la data impostata a 31/12/2011.
    Il programma è stato modificato per velocizzarlo. Di default ignora il codice contratto eventualmente inserito nelle registrazioni, nel calcolare il totale dei documenti visualizzati. Eventualmente si può variare l’operatività togliendo la spunta all’apposito campo a video.

  • Estrazione dati Operazioni Rilevanti ai fini Iva (Menu Contabilità - Iva)
    Elabora le registrazioni dell’anno e memorizza nella tabella apposita, quelle che ‘devono essere comunicate’ (perché di importo maggiore di 3000€ oppure appartenenti ad un cliente, fornitore o contratto con l’obbligo di comunicazione)

  • Elenco delle operazioni estratte (Menu Contabilità - Iva)
    Consente di visualizzare, variare e stampare le operazioni che poi verranno comunicate

  • Preparazione del file per l'invio telematico (Menu Contabilità - Iva)
    Consente di stampare l’elenco delle operazioni da comunicare e di preparare il file per la comunicazione.

Campi: Impegno a trasmettere e data impegno
Sono stati gestiti, nella tabella Dati per Comunicazione Annuale, unica per tutte le ditte (Menu Contabilità – Iva), nuovi campi per Impegno a trasmettere e data impegno che verranno considerati se si trovano non compilati i campi corrispondenti sulle singole ditte (Menu Contabilità – Iva – Dati generali per Iva annuale)

Nell' esaminare l'importo della registrazione per valutare se va trasmessa o meno verrà utilizzato il valore di riferimento di 3000€ se si tratta di fattura (obbligo di fattura) o 3600€ se si tratta di corrispettivo o fattura dettaglianti. Il valore di confronto sarà l'imponibile se 'obbligo di fattura' o il totale fattura se 'non obbligo di fattura'. E’ possibile impostare il parametro NoIvaNoFat per considerare 'senza obbligo di fattura' tutte le anagrafiche senza Partita Iva e per stabilire come comportarsi con i codici fiscali che iniziano per 8 e 9

Nuove funzioni

  • Preparazione di un file con i movimenti contabili delle fatture per passare i dati alla Contabilità Team System

Altre modifiche

  • Gestione Clienti e Fornitori
    Abilitazione della ricerca del campo Comune. Sul campo è abilitata la ricerca con F3, se si digita il comune, in automatico il programma compilerà provincia e cap. Se la provincia è compilata, la ricerca del comune avverrà all’interno dei comuni di quella provincia. La tabella dei Comuni è sul database del Menu (azimenu.mdb)
  • Magazzino
    Possibilità di generare un codice a barre interno con particolari caratteristiche: es. un EAN13 che inizi per 020 in modo da non sovrapporsi a nessun altro codice di prodotti acquistati. Vedi parametro di personalizzazione: CodIniAut13
  • Ordini – Ddt – Fatture
    E’ stata introdotta la possibilità di ottenere fatture diverse a fronte di ordini diversi. Cioè, dato un ordine, se nel mese si fanno più consegne, a fine mese i ddt che hanno evaso un ordine potranno essere fatturati tutti e soli in un’ unica fattura. Per ottenere ciò si può impostare il campo Raggruppo Ordini sul cliente oppure sull’ordine stesso.
    Possibilità di raggruppare anche per codice contratto.

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.03


NOTE SULLA VERSIONE 3.03 DEL 16/11/2011

Nuove funzioni

  • Gestione contratti
    Introdotti per una corretta compilazione della Comunicazione delle Operazioni rilevanti ai fini Iva

  • Operazioni Rilevanti ai fini Iva: (Menu Contabilità - Iva)
    Estrazione delle operazioni da comunicare
    Elenco delle operazioni estratte
    Preparazione del file per l'invio telematico
    Verifica - (Menu Contabilità - Utilità)

  • Inserimento di fatture di acquisto 'miste' con righe con iva 'normale' e altre in regime di Reverse Charge (vedi manuale Reverse Charge)
    Se impostati i codici iva in modo opportuno, il programma provvederà a creare la fattura di vendita e il giroconto SOLO per la parte in R.C.

  • Permissioni a livello di database
    Una volta creata un'azienda sarà possibile definire delle permissioni per l'accesso ad essa, inibire l'accesso o consentire la sola visualizzazione dei dati a uno o più utenti (login).
    Le login (gruppi) non autorizzate non vedranno più quell'azienda nella lista del 'Cambio azienda', le altre vedranno solo le funzioni per le quali, eventualmente, sono state abilitate con la gestione menu.

  • Terminal server
    Modificati i programmi per gestire la stampa su stampanti locali quando si è collegati in terminal server

Operazioni rilevanti ai fini iva - Sistemazione delle registrazioni già esistenti

Il programma di aggiornamento dei database, che deve essere eseguito, come al solito, all'installazione della versione, cercherà di apportare, in automatico, le modifiche descritte in seguito:
Registrazioni di prima nota:
1) Imposta a Normale il contenuto 'Operaz.rilevante ai fini Iva' che nella versione precedente era impostato a Si/No ed ora è stato sostituito con Normale - da Ignorare - Forzata
2) Note di variazione (Note di Credito o fatture che completano fatture precedenti)
Sono stati aggiunti i campi Pref.-Numero e data Fattura di riferimento al fine di creare il collegamento necessario. Il programma cercherà di compilare in automatico i suddetti campi per le note di credito emesse. La compilazione tuttavia verrà fatta SOLO se si trova che, sulla registrazione di prima nota, la data documento è diversa dalla data protocollo. Se ad essere diverso fosse solo il numero documento e non la data, non si aggiorneranno i dati di riferimento.
Al momento dell'aggiornamento le note di credito registrate nelle vendite devono essere TUTTE contabilizzate.
Causali: è stato aggiunto un campo 'nota di variazione' che l'aggiornamento imposterà a Si in corrispondenza delle Note di Credito.

E' tuttavia indispensabile, una volta terminato l'aggiornamento:
1 - controllare se ci sono altre causali utilizzate per la registrazione di Note di Variazione nelle quali questo campo vada impostato a Si
2 - compilare, sulle registrazioni di prima nota di note di credito, i riferimenti alla fattura corrispondente (se non c'è prefisso occorre mettere il . 'punto') in particolare se riferite a fatture da comunicare.
Al fine di agevolare la verifica delle registrazioni interessate alla comunicazione e di consentire di variare eventuali campi (codice contratto, fattura di riferimento, flag con obbligo e esclusione da comunicazione) su registrazioni già stampate sui Registri Iva e Giornale, è stato predisposta la funzione 'Verifica operazioni rilevanti ai fini iva'
3 - leggere attentamente il capitolo Operazioni Rilevanti ai fini Iva e sistemare i dati secondo quanto indicato in esso.

Altre modifiche

  • Input prima nota
    Modifiche alla maschera di Testata per inserimento/variazioni documenti
  • Gestione Causali e Gestione Codici Iva (Reverse Charge misto)
    Causali: il campo 'documento in Reverse Charge' Si/No ha assunto anche un altro valore, ora può essere Si - No - Misto
    Codici Iva: è stato aggiunto un campo 'Reverse Charge' Si/No
    questo per poter riconoscere le fatture di acquisto che contengono articoli normali e altri in regime di Reverse Charge.
    Le fatture 'miste' dovranno essere inserite con causali di tipo 'Reverse C.' misto e per le righe di costo R.C. si useranno dei codici iva con campo 'Reverse Charge' a Si
  • Brogliaccio movimenti
    Inserita stampa del Contratto
  • Stampa lettera Estratto Conto
    Possibilità di impostare a video un importo fisso da addebitare sul totale delle scadenze, in alternativa alla percentuale di interessi.
  • Stampa partitari, partite, situazione contabile clienti e fornitori
    Parametro di personalizzazione FidoBudget per consentire di stampare il Fido impostato in anagrafica clienti e fornitori e il Budget sui conti
    Possibilità di stampare il Saldo progressivo di riga (partite e partitari). A tal proposito è stato inserito un nuovo campo (il 20) tra quelli messi a disposizione dalle rispettive stampe 'parametriche'. Per averlo in stampa occorre andare sui programmi in oggetto, posizionarsi sul formato di stampa desiderato, premere il pulsante: 'Personalizza la stampa' e aggiungere il nuovo campo nella stampa della riga.
  • Inserimento Prima Nota - Gestione Ordini, Ddt e Fatture
    Sono stati aggiunti i due campi CIG (Codice Identificativo di Gara) e CUP (Codice Unico di Progetto) che, se inseriti, verranno poi riportati sul record 50 del file delle Ri.Ba come richiesto D.L. 187/2010 per le transazioni relative a lavori, servizi e forniture pubbliche.
  • Stampa scadenze - scaduto
    Se si stampano le scadenze per data o con formato foglio 'orizzontale' verranno stampati anche i codici CIG e CUP eventualmente inseriti nelle registrazioni.
  • Stampa Registro Iva Corrispettivi
    Introdotto il parametro di personalizzazione CorriRaggGio che, se impostato a S, consente di sommare tutti i corrispettivi di un giorno e stamparli su un'unica riga.
  • Gestione Preventivi, Ordini, Ddt e Fatture
    Sul campo codice articolo sono stati abilitati i tasti Shift F2 - F3 -F4 che, oltre a fare la ricerca rispettivamente per codice, descrizione, barcode articolo, consentono di visualizzare, per ogni articolo, nella lista di aiuto:
    - l' ultimo prezzo fatto al cliente estraendolo dall’ ultima fattura inserita e calcolato come valore totale di riga diviso quantità
    - il prezzo di listino (dal listino del documento e, se questo non c’è, da quello inserito in tabella di Magazzino)
    - in Ordini e Preventivi (SOLO se ci sono le permissioni di scrittura in PN) mostra anche l'ultimo costo (Non vengono considerati i livelli)
  • Stampa fatture
    Introdotto il parametro di personalizzazione DichIntentiTesto per impostare la stampa di numero e data dichiarazione d'intenti inseriti sul cliente.
  • Stampa Ddt
    Introdotto il parametro StDocFine per consentire di stampare un documento al termine della stampa di un ddt
  • Magazzino - Creazione movimenti da inventario manuale
    Nei movimenti creati per sistemare l'inventario, viene impostato come valore unitario, il costo ultimo degli articoli.

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.02a


NOTE SULLA VERSIONE 3.02a DEL 05/05/2011

Nuove funzioni

  • Verifica delle 'Operazioni rilevanti ai fini iva' (art. 21 del DL n.78/2010) (Contabilità – Utilità)
    Consente di visualizzare un elenco delle fatture emesse e ricevute registrate in Prima Nota dopo aver impostato le selezioni opportune e di impostare eventualmente il flag di 'Operazioni rilevante ai fini iva' là dove serve, indipendentemente dal fatto che la registrazione sia già stata stampata in modo definitivo su Registro Iva o Giornale.

  • Bilancio XBRL
    Aggiornate le tabelle CeeXbrlElementi, CeeXbrlProspetti e CeeXbrlImpost secondo le nuove disposizioni 2011. L’adeguamento avviene in automatico eseguendo l’aggiornamento dei database. Se il programma non è in grado di aggiornare, verrà data una segnalazione al termine dell’elaborazione, in questo caso si dovrà procedere all’aggiornamento manuale confrontando le tabelle del proprio AziMenu.mdb con quelle del AziMenu.mdb fornito con la nuova versione dei programmi.
    In ‘Parametri e Utiltà’ – Dati Generali azienda (parametri) è stato inserito una nuova maschera con alcune informazioni aggiuntive dell’azienda, richieste nell’ xbrl che dovranno essere opportunamente compilate.
    Nella cartella Xbrl del CD di installazione vengono inoltre forniti i nuovi file ‘stylesheet’ per la visualizzazione del file del bilancio xbrl generato dal programma.

Altre modifiche

  • 'Operazioni rilevanti ai fini iva' di importo non inferiore a € 3000
    Inserito nuovo campo sulle anagrafiche clienti e fornitori dove si può impostare che le fatture relative sono ‘sempre’ del tipo in oggetto (utile se c’è un contratto che prevede un importo annuale totale superiore a 3000€ pur essendo inferiori le singole fatture)
  • Prima Nota, Visualizzazione Partitari e Partite
    In corrispondenza alle registrazioni di fatture emesse direttamente dalla procedura di Fatturazione, viene visualizzato un pulsante "Apri fattura" che consente di entrare direttamente sulla maschera della fattura.
  • Stampa partite
    Possibilità di stampare il Saldo progressivo. E’ stato inserito un nuovo campo (il 20) tra quelli messi a disposizione dalla stampa.
  • Gestione scadenze e preparazione file Ri.Ba.
    Sono stati aggiunti sulle scadenze i due campi CIG (Codice Identificativo di Gara) e CUP (Codice Unico di Progetto) che verranno poi riportati sul record 50 del file delle Ri.Ba come richiesto D.L. 187/2010 per le transazioni relative a lavori, servizi e forniture pubbliche.
  • Stampa Comunicazione Dichiarazioni di Intento ricevute
    Tra i dati Ditta viene stampato il contenuto del campo “Codice natura giuridica” al posto di quello della “Natura giuridica” (dai dati generali ditta).
  • Controllo Partita Iva clienti e fornitori
    Per gli stati appartenenti alla Comunità Europea, il programma controlla la correttezza della partita iva inserite nelle anagrafiche, secondo le specifiche date dall'Agenzia delle Entrate. La condizione è che sia stato impostato correttamente il codice ISO dello stato.
    Per gli stati Cee si consiglia pertanto di lasciare bianchi i 2 campi 'lunghezza P.Iva'.
  • Ricerca movimenti per importo
    Possibilità di entrare in variazione della registrazione su cui si è posizionati
  • Stampa ddt e fattura accompagnatoria
    Introdotto il parametro di personalizzazione “StessoDest” in cui si può impostare una scritta
    da stampare in corrispondenza all'indirizzo del destinatario, al posto di 'stesso', quando, per il documento, non c'è un destinatario diverso dal cliente.
  • Stampa Ordini, Ddt e Fatture
    E’ stato messo a disposizione della stampa il campo: C_DettAttuale per intercettare il tipo di dettaglio che si sta stampando e stamparlo in modo diverso da quello stabilito. Vedi manuale.
  • Gestione Ddt
    Nella maschera (6) Documenti di origine e di evasione è stato inserito un pulsante "Apri fattura" che consente di entrare direttamente sulla maschera della fattura in cui quel ddt è stato evaso.
  • Magazzino – Caricamento movimenti di trasformazione
    Introdotta la possibilità di inserire a video il codice dell’articolo trasformato durante l’inserimento di un movimento di trasformazione (attualmente era indispensabile scrivere tale codice sull’articolo di partenza). Utile per trasferire la giacenza di un articolo ad un altro nel caso di cambio codice.
  • Emissione scontrini
    Implementato il collegamento con registratore di cassa RCH modello SWING con protocollo XON XOFF
  • Utilizzo del cassetto di stampa
    E’ stato introdotto il parametro di personalizzazione StampantiNoCassetti per indicare per quali stampanti non vanno considerati i cassetti. Contenuto: TUTTE oppure l’elenco dei nomi dei device delle stampanti separati da virgola.
  • Nuova funzione per passaggio dei movimenti di fatture ed eventuali incassi alla contabilità Pragma

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.02


NOTE SULLA VERSIONE 3.02 DEL 20/01/2011

Nuove funzioni

  • Importazioni extra cee
    Possibilità di impostare causali apposite per la registrazione di Bolle doganali e acquisti da RSM in modo da automatizzare la creazione delle registrazioni ‘accessorie’
    (vedi capitolo ‘Importazioni’ del manuale)

  • Predisposizione per l'identificazione delle 'Operazioni rilevanti ai fini iva' di importo non inferiore a € 3000,00 (art. 21 del DL n.78/2010)

  • Completamento della gestione delle operazioni con soggetti aventi sede, residenza o domicilio in paesi a fiscalità privilegiata (Black List)

  • Comunicazione annuale dati iva
    E’ stato predisposta, sul programma di ‘Chiusura iva’, una scelta per effettuare il ricalcolo, a fine anno degli importi relativi alle sezioni ‘ Operazioni attive’ e ‘Operazioni passive’, simulando le liquidazioni periodiche. Questo per tener conto nel calcolo delle eventuali variazioni fatte sulle caratteristiche di codici iva e causali utilizzati nelle registrazioni. (Ad esempio per escludere dal calcolo le autofatture, dopo aver settato, sulle causali, il flag che le identifica).

Altre modifiche

  • Visualizzazione partitario
    Possibilità di entrare nella registrazione di prima nota sui cui si è posizionati anche quando il programma di Prima Nota è già aperto (sulla maschera di testata).
  • Stampa fatture
    Sono state fatte le modifiche per consentire l’utilizzo di PdfCreator per la stampa su Pdf.
    Nella preparazione dei campi T_ScadTutte e TScad00Data etc., che consentono la stampa delle scadenze, sono stati inseriti dei parametri per personalizzare eventuali scritte fisse a completamento di date e importi (TestoScadTutte)
    E’ stato inoltre aggiunto un campo, sulla tabella Monete, dove poter inserire il simbolo della moneta. Questo può essere stampato sulle fatture utilizzando nel filtro le variabili: T_SimbMon o T.SimbMon per stampa in testata e/o piede e C_SimbMon per il corpo.
  • Vendite - stampa Elenco articoli consegnati con Ddt
    Se si sceglie di stampare: “anche no-articoli”, verranno stampati anche gli articoli manuali inseriti nei ddt.
  • Preventivi, Ordini, Ddt e Fatture
    Se una spesa (in tabella Spese) ha il flag 'Standard' verrà automaticamente inserita nel quadro spese del documento.
    NB: verificare, sulle spese inserite in tabella , il valore attuale di tale campo.
  • Preventivi - Ordini
    Esteso il significato del campo ‘Stampa Riferimento Ordine’ nella anagrafica del cliente, in modo da poter scegliere se stampare il riferimento del documento di provenienza solo quando questo sia un preventivo o un ordine (oltre a non stamparlo mai o a stamparlo sempre, uniche scelte possibili in precedenza)
  • Magazzino - Caricamento movimenti di acquisto
    Possibilità di aggiornare un listino di vendita in corrispondenza al carico merce applicando una maggiorazione sul costo del carico (vedi parametro ListVenDaAgg)
  • Stampa documenti (Preventivi, Ordini, Ddt, Fatture)
    Possibilità di identificare sul filtro il numero di copia che si sta stampando. Introdotte le variabili: T_NumCopieTot e T_NumCopieCor per utilizzo nel filtro.
    (Questa modifica consente di inserire nel filtro le istruzioni per stampare frasi diverse sulle varie copie di un documento (es. Copia per il cliente, Copia per il Corriere, Copia ½ - Copia 2/2)
  • Funzione di aiuto nella ricerca dei codici (parametro DecodHelpAbil)
    Consente di mostrare la maschera di help (ricerca codice) quando, uscendo da un campo dopo aver inserito un codice parziale, questo non viene identificato in maniera univoca.
    Permette di inserire più rapidamente i codici, scrivendoli parzialmente, senza dover premere i tasti F2 o F3

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.01a


NOTE SULLA VERSIONE 3.01A DEL 15/11/2010

Nuove funzioni

  • Preparazione del file per l’invio telematico della Comunicazione delle operazioni con soggetti aventi sede, residenza o domicilio in paesi a fiscalità privilegiata (Black List)

  • Modifica stato partite
    Utility per la chiusura/riapertura manuale delle partite dei clienti e/o fornitori

Dettaglio Modifiche

  • Sistemazione partite
    La funzione corrisponde a quella che prima era: Eliminazione partite chiuse. Sono state implementate alcune opzioni per la selezioni delle partite da elaborare
  • Abilitata la possibilità di stampare una Nota fissa in testata o nel piede, oltre che nel corpo del documento.
  • Chiusura Iva
    E' possibile abilitare il parametro CogeTerzi per consentire alle aziende Mensili     che esercitano l’opzione della tenuta della contabilità presso terzi, di far riferimento, nelle liquidazioni, alle registrazioni non del mese precedente ma di 2 mesi precedenti.
  • Comunicazione annuale dati iva
    Inserita richiesta a video se presente o meno l'intermediario

NOTA BENE

  • Per un corretto funzionamento della funzione di preparazione del file per la Comunicazione delle operazioni con soggetti aventi sede, residenza o domicilio in paesi a fiscalità privilegiata è indispensabile eseguire quanto descritto nel capitolo Black List

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.01


NOTE SULLA VERSIONE 3.01 DEL 01/06/2010

NOTE SULLA VERSIONE 3.01 DEL 07/06/2010

Nuove funzioni

Bilancio XBRL

  • Struttura bilancio cee

  • Preparazione file XBRL

  • Stampa bilancio su Excel

  • Gestione tabelle Elementi, Prospetti e Pesi

Clona tabelle

Possibilità di variare la grafica del menu della procedura

Dettaglio Modifiche

  • Inseriti, nella maschera dei dati anagrafici dell'azienda, i nuovi campi necessari per la compilazione del bilancio in formato Xbrl (codice CCIAA, capitale interamente versato etc.)
  • Gestione Conti
    Possibilità di agganciare un conto alla struttura del Bilancio Cee, al posto di farlo dal programma di Gestione tabelle Bilancio Cee.
  • Compilazione automatica, a fine anno, degli importi di Acquisti e Vendita di beni strumentali sulla Comunicazione Iva Annuale
    sono previste due possibilità per ottenerli:
    • sommare gli importi in corrispondenza ai codici iva nei quali è stato spuntato il campo: "Acquisti e Cessioni Beni strumentali" (modalità di default)
    • sommare gli importi delle registrazioni fatte utilizzando particolari conti nei quali è stato spuntato il campo "Beni Strumentali" Acquisto o Cessione.
      Per utilizzare questo secondo metodo occorre attivare il       parametro di personalizzazione: IvaBeniStrum
  • Stampa distinta
    Se sul cliente è stato inserito il codice Iban, esso verrà stampato nella stessa riga del codice fiscale/partita iva
  • Stampa elenco cespiti
    Possibilità, nella stampa dettagliata, di stampare SOLO i movimenti provvisori
  • La nuova funzione Clona tabelle, raggiungibile dal menu con i tasti Ctrl-Alt-Shif L, consente di copiare una tabella da un database di origine a uno o più database di destinazione, con tutto il suo contenuto.
  • Il "menu di servizio" di Contabilità è stato diviso in due parti: Servizio e Utilità in quanto la pagina non conteneva più le funzioni
  • Quando si è posizionati sul menu principale, premendo i tasti Shift Ctrl Alt I , il programma mostrerà il percorso del file AziWin.ini principale (quello del computer che si sta utilizzando) e del secondario (quello contenuto nella cartella ..\Aziwin\)

NOTA BENE

  • Bilancio XBRL
    Sono state apportate modifiche alla struttura del Bilancio Cee (tabelle Bilancio Cee) fornita sul database vuoto (cd di installazione) al fine di poter presentare il bilancio in formato xbrl e sono state introdotte nuove tabelle.
    Per la preparazione del bilancio su un'azienda preesistente, si raccomanda di seguire le istruzioni scritte nel paragrafo Note su bilancio XBRL
  • Al fine di poter compilare a fine anno gli importi Acquisti e Cessioni Beni strumentali sulla Comunicazione Iva Annuale si potrà procedere in due modi diversi:
    a) creare uno o più codici iva, che dovranno essere SOLO per queste registrazioni. Sui codici iva spuntare il campo: "Acquisti e Cessioni Beni strumentali". Se sono già state fatte delle registrazioni di questo tipo, utilizzando i codici iva soliti, si consiglia di modificarle sostituendo i codici utilizzati con i nuovi.
    b) specificare nei singoli conti se verranno utilizzati per le registrazioni di Acquisti o di Cessioni di beni strumentali.

Vedi anche:
Note installazione
Note aggiornamento

Note release 3.00


NOTE SULLA VERSIONE 3.00 DEL 01/03/2010

Dettaglio Modifiche

  • Inserito in Gestione codici Iva il campo: Acquisti-Cessioni Beni strumentali
    Campo da impostare a Si nei codici iva che dovranno poi essere utilizzati per la registrazione di Acquisti e Vendita di beni strumentali al fine di poter compilare a fine anno gli importi corrispondenti della Comunicazione Iva Annuale.
  • Brogliaccio movimenti di acquisto
    E' stato introdotto il parametro di personalizzazione: Dettagliata, Gruppo: BroAcq     che se impostato a S propone sempre la stampa Dettagliata, al posto della Sintetica, sulla maschera delle scelte di stampa.
  • Stampa Ordini di Acquisto
    Messo a disposizione per la stampa il codice articolo fornitore: C_RigCodArtFor
  • Gestione lotti
    Introdotta la possibilità, nella cancellazione di un lotto, di cancellare anche tutti i riferimenti a quel lotto sugli archivi collegati.
  • Evasione Preventivi e Ordini
    Tramite la definizione del parametro di personalizzazione EvaLisCampiAgg è possibile specificare una     lista di campi aggiuntivi da visualizzare nella griglia degli articoli durante l'evasione di un documento (es. nota sotto)
  • Nelle stampe dei documenti con "filtro" è possibile stampare, nel corpo, uno o più campi "memo" (es. descrizione lunga articolo, nota sopra/sotto) mettendo sulla riga corrispondente del filtro l'indicazione di multiriga. Questi campi verranno stampati su più righe lasciando in bianco, sulle righe successive alla prima, campi come quantità e prezzo che saranno solo sulla prima riga.
  • In una nuova installazione viene proposta come directory di default: C:\aziwin

NOTA BENE
Al fine di poter compilare a fine anno gli importi Acquisti e Cessioni Beni strumentali sulla Comunicazione Iva Annuale è indispensabile creare uno o più codici iva, che dovranno essere SOLO per queste registrazioni. Sui codici iva spuntare il campo: "Acquisti e Cessioni Beni strumentali". Se sono già state fatte delle registrazioni di questo tipo, utilizzando i codici iva soliti, si consiglia di modificarle sostituendo i codici utilizzati con i nuovi.

Vedi anche:
Note installazione
Note aggiornamento

Note release 2.02


NOTE SULLA VERSIONE 2.02 DEL 30/11/2009

Nuove funzioni

  • Nuova funzione per la stampa del modello F24 e preparazione del file per l’invio telematico
  • Nuova funzione per la stampa del riepilogo dei risultati delle Chiusure periodiche iva
  • Possibilità di inviare le fatture via email
  • Gestione di nuovi campi sui Vettori al fine di poterli stampare sui Ddt e Fatture accompagnatorie (D.M. 30/06/2009)
  • Distinta base: nuova funzione di stampa Implosione distinta
  • Collegamento con registratore di cassa NIXDORF Butterfly Plus

Dettaglio Modifiche

  • Input prima nota e Visualizzazione partitari
    Possibilità di collegare un documento a una registrazione. Tale documento potrà essere visualizzato quando ci si posiziona su di esso in Visualizzazione partitari.
  • Stampa riepilogo chiusure iva
    Stampa di utilità che, a fine anno, riepiloga i risultati delle Chiusure iva periodiche.
  • Stampa Chiusura iva
    Completata la stampa del 4’ trimestre con tutti i dati dell’eventuale iva da versare, anche se il versamento avverrà in sede di liquidazione annuale.
  • Stampa F24 e preparazione del file per invio telematico
    Per la preparazione corretta dell’F24 con i soli dati Iva, sono stati gestiti dei nuovi campi per i dati anagrafici ditta sulla tabella dei Dati generali per Iva annuali e per i dati dello studio (telefono ed email) nella tabella Dati per comunicazione annuale Iva.
    Per una corretta esecuzione della stampa occorre copiare, dopo l’installazione dell’aggiornamento dei programmi, il file F24.gif dalla cartella BaseDati\Immagini del CD alla cartella Aziwin\Immagini del disco fisso.
  • Stampa Bilancio di verifica
    Quando si stampa il bilancio a inizio anno prima di aver fatto la chiusura dell’anno precedente, si può chiedere di riprendere i saldi dei conti patrimoniali dell’anno precedente. In queste condizioni però manca la registrazione dell' utile o della perdita e il bilancio non risultava corretto. Ora viene calcolato il risultato dell’esercizio precedente e viene stampato, nella sezione apposita, con un codice conto fittizio: "Z*Z*****"
  • Gestione articoli
    Se è installata la distinta base, in duplicazione di un articolo con distinta, si chiede se duplicare anche quest’ultima.
  • Stampa distinta base
    Possibilità, se è abilitato il parametro per l’utilizzo delle dimensioni, di digitare il numero pezzi e calcolare le quantità da produrre in base alle dimensioni degli articoli.
    Possibilità di stampare l’immagine collegata all’articolo se si stampa un articolo per pagina.
  • Vettori
    E’ stata implementata con nuovi campi l’anagrafica dei vettori, in ottemperanza del D.M. del 30/06/2009 divenuto obbligatorio a partire dal 19/07/2009. In esso si indica che, per i trasporti con obbligo di compilazione e conservazione della scheda di trasporto o documenti equipollenti, il documento che accompagna la merce deve contenere, oltre a Ragione sociale e indirizzo del vettore che effettua il trasporto anche: riferimenti telefonici, eventuale email, Partita Iva e numero di iscrizione all’ albo dei trasportatori.
    I nuovi campi sono stati resi disponibili per essere stampati dai filtri di stampa ddt e fatture (vedi manuale in linea, paragrafi: Ddt (campi per filtri) e Fatture (campi per filtri)
  • Invio fatture via email
    Se si stampa la fattura su file pdf è possibile scegliere di inviarla via email all’indirizzo memorizzato sul cliente intestatario della fattura stessa (vedi manuale in linea, capitolo: “Note su argomenti particolari” , paragrafo “Invio fatture per email”)
  • Evasione ordini
    Introdotto il parametro di personalizzazione StDesLunDaDoc per far si che la descrizione lunga dell’articolo sul documento in cui l’ordine viene evaso possa essere stampata in modo diverso rispetto quanto stabilito sull’ ordine stesso (vedi manuale in linea)
  • Stampa etichette
    In Caricamento movimenti di magazzino, su ogni dettaglio è stato inserito un nuovo campo: “Numero di etichette” in cui l'utente può digitare il numero di etichette da stampare in corrispondenza a questa riga di movimento. Verrà utilizzato dalla stampa etichette se si sceglie di stampare le etichette degli articoli presenti in un determinato movimento di magazzino. Se si lascia bianco questo campo, il numero di etichette stampato per ogni articolo sarà pari alla quantità della riga
  • Cespiti
    Generazione     movimenti in contabilità (contabilizzazione).
    Introdotto il parametro di personalizzazione DescrAgg per consentire di personalizzare la compilazione     della descrizione aggiuntiva delle registrazioni. Al posto della descrizione inserita a video seguita dalla descrizione del cespite (default) si può avere, a seconda del valore assegnato al parametro:
    - solo la descrizione a digitata a video
    - l'eventuale descrizione a video seguita dal codice o dal codice e descrizione del cespite

Elenco correzioni

· Stampa partitari
Corretto salto pagina per casi particolari

· Stampe cespiti
Correzioni su segnalazioni di casi particolari

· Stampa bilancio di verifica in formato “uso bollo”
Sistemato salto pagina in condizio

· Stampa Preventivi e Ordini
L'importo delle eventuali spese (es. Trasporto) calcolate in percentuale sul totale documento veniva stampato sempre a 0.

Vedi anche:
Note installazione
Note aggiornamento

Note release 2.00B


NOTE SULLA VERSIONE 2.01 DEL 27/01/2008

NOTE SULLA VERSIONE 2.01 DEL 27/11/2008

Nuove funzioni

  • Nuovo programma di visualizzazione dell’Help on line (tasto F1)
  • Creazione file di log
    Al fine di tenere traccia dei vari passi dell'aggiornamento, il programma scrive un file di log (Aggiornalog.txt) nella directory aziwin dove, per ogni database, viene riportata la data contenuta inizialmente nella tabella Config, il numero delle modifiche, l'avvenuto compattamento e la data finale impostata dall'aggiornamento.
    L’utente può scegliere se creare un “log ‘breve” , contenente le informazioni suddette o un “log dettagliato” con l’elenco di tutti i campi aggiornati e, per ciascuno, il risultato dell'aggiornamento.
  • Introduzione del flag “Estrazione provvigione” per il secondo agente
  • Duplicazione articolo di magazzino
    Se l'articolo originale ha una distinta base, viene chiesto se duplicare anche quest'ultima.
  • Pn, Ordini Acquisto, Preventivi, Ordini, Ddt, Fatture, Movimenti di magazzino
    Possibilità di definire dei parametri di personalizzazione (DettOrdIns etc.) per cambiare l’ordine di inserimento dei campi nella maschera di inserimento dettagli e l’ordine di visualizzazione dei campi delle righe degli articoli presentate in testata e nel corpo delle registrazioni (DettOrdCol etc.)
  • Stampa Comunicazione Annuale Iva
    Possibilità di stampare, a seguito del modulo di Comunicazione, una lettera con testo compilato dall'utente.

Dettaglio Modifiche

  • Stampa bilancio per registro inventario
    Inserita opzione per NON stampare il Bilancio Economico (necessità delle Soc. di Capitale)
  • Stampa partite
    Introdotta a video la possibilità di selezione sul prefisso documento.
  • Saldaconto
    Aggiunti, nella lista delle scadenze, numero e data protocollo.
  • Stampa elenco cespiti
    Inserita scelta per escludere o meno dalla stampa i cespiti venduti.
  • Stampa etichette Clienti/Fornitori
    Inseriti, sulla maschera di selezione, quando si stampano le etichette da fatture clienti, i campi: Codice articolo e Gruppo/Sottogruppo articolo, in modo da stampare le etichette dei soli clienti ai quali sono stati fatturati certi articoli (per invio di materiale promozionale, informativo etc.)
  • Stampa Preventivi, Ordini, Ddt e Fatture
    Possibilità di impostare sulla tabella Tipi documento (nel campo “Personalizzazione Fine Corpo”) uno o più codici sottosezione da stampare sui documenti relativi (anche se nel filtro fosse prevista la stampa di più sottosezioni, verranno stampate SOLO quelle previste sul tipo documento del documento da stampare).
  • Stampa Preventivi, Ordini, Ordini di Acquisto
    Introdotta la gestione del parametro di personalizzazione UsaFlagPrezziOrd=S per stampare o meno i prezzi sul corpo dei documenti a seconda di quanto specificato in testata documento nel campo: “Prezzi in stampa”.
  • Stampa fatture
    Introdotto il parametro di personalizzazione NoDescPrezziIvati, per non stampare la scritta: "I prezzi sono ivati" nel corpo fattura, in presenza di un listino ivato.
  • Ordini, Ddt e Fatture
    Se attivo il parametro QtaDaDimen (che consente di calcolare in automatico le quantità, date le dimensioni degli articoli e il numero pezzi da consegnare) è stato introdotto un nuovo parametro QtaDimenRapp che consente di esprimere le misure dell’articolo in unità di misura diverse da millimetri.
  • Provvigioni
    E’ stato inserito il campo “Estrazione provvigione” anche per il secondo agente, sui clienti e sulle testate documento. In questo modo si rende possibile applicare al secondo agente una percentuale particolare.
    NOTA:
    A tal proposito è stato modificato     il fatto che:
    "se la percentuale di provvigione viene presa dall'articolo, viene attribuita solo al primo agente"
    in quanto, ora, per decidere la provvigione di ciascun agente, si va a vedere sempre il rispettivo campo: "Estrazione provvigione" (l’aggiornamento pone il campo “Estrazione provvigione” relativo all’agente 2 uguale a quello dell’agente 1)
  • Caricamento movimenti di magazzino, ddt, fatture
    Al fine di non generare la riga di articolo con l’importo del Raee quando si fanno certi movimenti di magazzino particolari su articoli che prevedono il contributo Raee (es. uno scarico per rottamazione), è stato introdotto il parametro di personalizzazione NoRaeeAutom.
    In esso dovrà essere scritto l’elenco delle causali di magazzino che non devono generare la riga Raee.
  • Caricamento movimenti di magazzino (acquisti) ed Evasione ordini di acquisto
    Inserito un parametro di personalizzazione ListAcqDaAgg che consente di aggiornare un listino di acquisto per gli articoli caricati.
  • Ricalcolo progressivi e costi articoli
    Messa la scelta di ricalcolare SOLO i costi. Se l’articolo non è stato movimentato nell’anno, il costo ultimo verrà impostato con il valore che aveva nell’anno precedente (da ArticoliCosti).

Elenco correzioni

· Input prima nota:
Riporto del saldo partita corretto sul campo importo della riga di incasso/pagamento, quando si clicca sulla riga di saldo della lista partite di un cliente o di un fornitore.

· Evasioni Preventivi, Ordini
Non veniva settato sul documento di arrivo il flag: Raggruppa RB

Vedi anche:
Note installazione
Note aggiornamento

Note release 2.00B


NOTE SULLA VERSIONE 2.00 B DEL 10/07/2008

Nuove funzioni

  • Modifica dell’installazione
    Nelle nuove installazioni verrà presentata come directory di default su cui installare: C:\Sira\AziWin, le DLL verranno sempre installate in C:\Sira\AziWin\Dll e il file aziwin.ini di ogni computer, invece che sotto c:\windows, verrà creato in C:\Sira\AziWin\Main
  • Stampa Bilancio per Registro Inventari
    Menu Contabilità – Prima Nota
  • Brogliaccio Movimenti Pn
    Aggiunta scelta per stampare i movimenti iva su una riga, con foglio orizzontale, in modo che siano leggibili ed elaborabili se stampati su file excel. Introdotta inoltre una selezione sui codici iva. In questo modo si può ottenere una stampa utile alla compilazione dei modelli Intra.

Dettaglio Modifiche

  • Gestione clienti - Input prima nota
    Generazione automatica della riga/registrazione della ritenuta d’acconto anche per i clienti per i quali verrà attivato il flag Ritenuta in anagrafica.
  • Variazione veloce conti
    Aggiunta la possibilità di variare un campo generico.
  • Creazione file RiBa
    E’ stato introdotto un parametro di personalizzazione: CCDitta=S Gruppo: RiBa per scaricare, come qualcuno ha richiesto, il numero di Conto Corrente, letto dalla banca su cui è appoggiata la distinta sul record 14.
  • Calcolo Bilancio Cee
    Possibilità, se sono stati creati due codici (testate) diversi in corrispondenza di certi conti (es. le banche) nei quali mettere gli importi a seconda che si tratti di attività o di passività (saldo >0 o <0), di ottenere, tramite il parametro di personalizzazione SeparaAP, 2 righe separate per lo stesso conto, una con l’importo dell’anno in corso e una con quello dell’anno precedente se i saldi corrispondenti non hanno lo stesso segno.
  • Stampa fatture
    Inserita la selezione su Classi/Attributi clienti per consentire di stampare su Pdf SOLO le fatture dei clienti che lo richiedono, dopo aver assegnato loro un certo attributo per identificarli.

    Modificata la stampa della riga di default che segnala la presenza di una Ritenuta d’acconto in fattura. Viene stampata la frase: : Ritenuta d’acconto x% seguita dall’importo della Ritenuta.
  • Magazzino: Inventario manuale
    Abilitata la possibilità di inserire ‘inventari’ con codici diversi e stessa data. In questo caso, nel programma di Creazione movimenti da inventario manuale, si può digitare SOLO la data. Verranno prese in considerazione tutte le righe inserite in quella data (anche con codici di inventario diverse), verranno sommate tutte le quantità a parità di codice articolo e considerata questa come quantità di inventario. Serve a che, in sede di inventario, può trovare lo stesso articolo in zone diverse del magazzino.
  • Stampe.DLL
    In tutte le stampe, quando si sceglie di eseguirle su excel, compare, nella maschera di selezione delle stampanti, un pulsante: Tolgo il formato nei campi numerici (che si abilita appena di mette il nome del file da scaricare). Questo per consentire, una volta caricato il file su excel, di poter sommare una colonna di numeri (altrimenti li trattava come stringhe)
  • Aggiornamento database
    Inserito pulsante per abilitare una opzione che consente di non avere messaggi a video in sede di aggiornamento dei DB (serve a chi ha tanti DB e li aggiorna di notte, il programma andrà avanti anche in presenza di errore. Sarà poi cura dell’operatore controllare sui vari DB che la trascodifica sia avvenuta correttamente.

Elenco delle correzioni

  • Input prima nota
    Registrazione pagamento automatico con F9 di una fattura con ritenuta, l’importo non veniva decrementato dell’importo della ritenuta.
    Fattura con Rit.d’acconto: se veniva data qualche segnalazione di registrazione non corretta, poi in seguito venivano memorizzate 2 registrazioni per la ritenuta.
    Digitato F10 su una riga di dettaglio con Centro di Costo obbligatorio, tale campo rimaneva settato come obbligatorio e non si usciva più dalla registrazione.

  • Aggiornamento Iva, Chiusura iva e Prima nota
    Corretto errore nel caso di aggiornamento di una fattura di un cliente/fornitore nuovo.

  • Gestione clienti
    Nella maschera ‘Progressivi’ non venivano più visualizzate le righe con i progressivi

  • Stampa ddt e Fatture
    In casi particolari dava errore la stampa delle descrizioni in lingua.

  • Decontabilizzazione fattura
    Corretto errore in fase di cancellazione dei movimenti, se generati su file di appoggio.

  • Evasione Ddt
    Se si evadeva per indirizzo di spedizione non si attivava la lista di aiuto sul codice Indirizzo di spedizione.

  • Variazioni articoli di magazzino
    Se non si eseguiva scegliendo l’intervallo degli articoli da elaborare, andava in errore la Rigenerazione del codice a barre.

  • Stampa localizzazioni
    Corretta la stampa per articolo

  • Stampa etichette clienti
    Andava in errore se si stampavano le etichette dalle anagrafiche e non da fatture, dopo aver spuntato il flag su Indirizzi di spedizione.

  • Gestione filtri stampanti ad aghi ed etichette
    Errori in inizializzazione campi

  • Contabilizzazione cespiti
    Corretta la cancellazione dei movimenti provvisori, prima della creazione di quelli definitivi.

  • Stampa Riepilogo ammortamenti
    Corretto calcolo

  • Generazione movimenti di ammortamento
    Corretto calcolo per anno bisestile

Vedi anche:
Note installazione
Note aggiornamento

Note release 2.00


NOTE SULLA VERSIONE 2.00 DEL 19/12/2007

Nuove funzioni

  • I programmi gestiscono database sia Access 97 sia Access 2000
    In particolare è stato aggiornato il DAO alla versione 3.6.

  • Fatture cointestate
    Possibilità di riportare i dati negli Elenchi Clienti

  • Gestione IBAN su anagrafiche fornitori , clienti e banche

  • Gestione RAEE (Rifiuti apparecchiature elettriche ed elettroniche)
    La gestione (smaltimento) di questo tipo di rifiuti è regolamentata dal decreto RAEE (DL n.151 del 25 Luglio 2005).
    La "Direttiva RAEE" è basata sul principio secondo il quale chi inquina paga. Per ottemperare questo principio, il finanziamento e l'organizzazione della raccolta e del trattamento dei RAEE sono posti in capo ai fabbricanti di apparecchiature elettriche ed elettroniche, a partire dalla data di entrata in vigore in Italia del "Decreto RAEE", il 1° gennaio 2008. Per sostenere questi nuovi costi, i fabbricanti saranno liberi di far pagare un eco-contributo al momento dell'acquisto di un'apparecchiatura nuova.
    Tale contributo, il cui importo varia per tipologia di merce, graverà sul costo del prodotto fino ad arrivare al consumatore finale.
    Tale contributo può, a discrezione del produttore, diventare parte integrante del prezzo di vendita del prodotto oppure può essere evidenziato a parte e sommato al ‘vecchio’ prezzo di vendita.
    La procedura consente di associare ad ogni articolo di magazzino un codice Raee al quale dovrà essere attribuito un prezzo sul listino base.
    Ogni volta che si movimenterà in Caricamento movimenti, Ordini, Ddt e Fatture un articolo con codice Raee associato, verrà creata in automatico una nuova riga con il codice articolo Raee, quantità uguale a quella dell’articolo movimentato, prezzo unitario uguale al valore del listino base dell’ articolo Raee /senza sconti).

  • Gestione vuoti
    Calcolo automatico, in fattura accompagnatoria, delle righe di ‘cauzioni’ consegnate. Possibilità di stampa del prospetto delle cauzioni e dei litri di vino consegnati in fattura.

  • Lista di aiuto degli articoli di magazzino
    Inserita la visualizzazione del prezzo di listino ed eventualmente del prezzo Raee

  • Inventario manuale
    Introduzione di un codice, al posto della data, che identifica l’inventario inserito. In questo modo si possono inserire più righe sulla tabella inventari, con codice diverso e stessa data inventario.

  • Variazione margini di stampa

  • Stampa di campi memo utilizzando font diversi all’interno del campo

Dettaglio Modifiche

  • Gestione fornitori e clienti
    Inseriti nella maschera dei dati di Contabilità, i campi IBAN e BIC necessari per i bonifici.

  • Gestione banche
    Inseriti i campi Codice di controllo IBAN, Cin. Questo rende possibile, se sono stati compilati anche abi, cab e conto corrente, comporre il codice IBAN.
    Se si impostano questi campi sulle banche dell’azienda e, nelle fatture emesse con pagamento Bonifico, si inserisce il codice della banca nella quale il cliente farà il bonifico, si potrà stampare sulla fattura l’ Iban (modificando in modo opportuno il filtro di stampa)
    Il Codice di controllo IBAN per l’ Italia è IT seguito da 2 cifre. E’ stato inserito anche il codice B.I.C. per eventuali utilizzi futuri.

  • Elenco clienti e fornitori
    E’ possibile eseguire una stampa di controllo, comprensiva di tutte le anagrafiche, anche di quelle che non verranno inserite nell’Elenco definitivo. Tali righe verranno evidenziate con un –N dopo il numero progressivo e i rispettivi importi verranno totalizzati a parte in modo da consentire una verifica.

  • Fatture cointestate
    Negli Elenchi clienti, in caso di fatture contestate a più soggetti, devono essere riportate le informazioni contabili distinte per ciascun soggetto senza ripartizione degli importi.
    Al fine di consentire di adempiere a questa regola, è possibile collegare al cliente al quale si emette la fattura contestata, i codici degli altri clienti contestatari
    In questo modo tutti i dati anagrafici dei contestatari si renderanno disponibili per la stampa fattura e per gli Elenchi. (Vedi manuale in linea: fatture contestate)

  • Gestione e stampa vuoti in Fattura accompagnatoria
    Questa gestione si attiva inserendo il parametro di personalizzazione GestVuotiCauz con valore S e Gruppo: Fatture. Vedi manuale in linea: Vuoti – Gestione

  • Brogliaccio movimenti
    Stampa movimenti IVA. Aggiunta stampa totali separati per registri acquisti , vendite, corrispettivi
    Aggiunta selezione clienti da estrarre per Elenchi Cli/For (allegati)e codici iva da estrarre
  • Stampa Progressivi Iva clienti e fornitori
    Possibilità di stampare i progressivi iva calcolati dal Ricalcalo progressivi per Elenchi clienti e fornitori.
  • Chiusura Iva
    Credito utilizzato in compensazione con modello F24: visualizzato l’importo disponibile e azzerato il valore proposto nel campo in modo che sia l’utente a digitare l’importo desiderato.
  • Generazione movimenti di apertura
    Inserita la possibilità di leggere la Chiusura anche da un database non collegato al menu (scrivendo il percorso direttamente nell’apposito campo della maschera)
  • Stampa Fattura diretta
    Possibilità di invertire indirizzo principale con indirizzo di destinazione merce (per stampare quest’ultimo nella finestra della busta, cioè al posto di quello principale)
    Se si inserisce il Parametro di personalizzazione: IndSpedInv (Gruppo: StFatture) con valore S,
    se     sull’indirizzo di spedizione del cliente è stato detto che nella fattura sostituisce l’indirizzo principale e se sul filtro sono state messe le istruzioni opportune per stampare l'indirizzo di destinazione merce, anche per le fatture dirette, come per le accompagnatorie, verranno invertiti gli indirizzi e stampati.
    Se si attiva il parametro: IndSpedNoStesso con valore S, in stampa fattura, se l’indirizzo di spedizione coincide con l’indirizzo del cliente, non viene scritta la parola STESSO in destinazione.
    Se si attiva parametro IndSpedInv e non si attiva IndSpedNoStesso è possibile mettere delle istruzioni sul filtro della fattura diretta, in modo da invertire anche le scritte "Destinatario merce" e "Intestatario fattura" oltre ai due indirizzi e/o di non stampare il riquadro destinato alla destinazione merce se non è presente un destinatario diverso.
  • Tracciabilità
    E’ possibile impostare il parametro di personalizza: ChiaveGenSempre con valore S, per avere la possibilità di generare il codice lotto in automatico anche nei movimenti di carico merce da fornitore (dove in generale il lotto dovrebbe essere quello del fornitore).
  • Lista di aiuto degli articoli di magazzino
    Possibilità di visualizzare anche il prezzo di listino in uso in quel momento per gli articoli. In mancanza di un listino, viene visualizzato il prezzo del listino base.
    Se si desidera visualizzare anche l’importo Raee associato all’articolo, occorre entrare nel programma di Gestione Personalizzazioni, cercare se già esiste, una riga con Gruppo: Help, Parametro: ArticoloCampi , Valore: un elenco di campi dell’articolo. Se la riga non c’è la si può creare e, in Valore, si metterà o si aggiungerà a quanto già presente, la scritta: ,RAEE
  • Stampa modulo per inventario (magazzino)
    Aggiunte scelte per stampare tutti gli articoli creati e non solo quelli movimentati e per non stampare la giacenza.
  • Possibilità di spostare i margini sinistro e alto delle stampe su modulo (ordini, ddt, fatture), su stampanti ‘laser’.
    Scrivendo le istruzioni che seguono nel file aziwin.ini, si consente di spostare i margini solo su una particolare stampante.
    [nome_stampante]
    ModMrSin=X
    ModMrAlt=Z Dove X e Z possono assumere valori positivi (o Neg.)
    Per dettagli vedere manuale in linea al capitolo: Parametri di AziWin.ini nella parte: Modifica margini di stampa
  • Possibilità di spostare i margini sinistro e alto di qualsiasi stampa , su stampanti ‘laser’
    Scrivendo le istruzioni che seguono nel file aziwin.ini, si consente di spostare i margini solo su una particolare stampante.
    [nome_stampante]
    MrSin=X
    MrAlt=Z
    Dove X e Z possono assumere valori positivi (o Neg.). Tali valori vengono sommati o sottratti
    dai valori eventualmente già impostati per la stessa stampa (sezione dell’aziwin.ini con il nome del programma di stampa).
    Vedi manuale in linea capitolo Parametri del file aziwin.ini e Stampe - Modifiche
  • Stampa di campi memo utilizzando font diversi all’interno del campo
    E’ stata predisposta la gestione di una tabella contenente l’elenco dei font personalizzati (dal menu: tasti Ctrl Alt Shift L) da utilizzare. Vedi manuale in linea capitolo Font personalizzati
    Al fine di una corretta gestione di questa variazione nelle stampe che utilizzano ‘filtri’ di stampa (stampe fatture etc.), è stato inserito un controllo su alcuni campi (Italico, grassetto, fontsize) della della Gestione filtri, in modo che non possono essere lasciati vuoti quando sulla riga il campo Linea è diverso da S
  • Maschera di creazione delle Stampe parametriche (Es. Elenco Cli/for parametrico)
    Aggiunta richiesta: “Ultimo campo riempie fino al bordo destro”, nell’ ultima maschera per l’impostazione di una nuova stampa. Questo consente di stampare in modo più leggibile, un campo note come ultimo campo della riga, ad esempio le note impostate in anagrafica, nella stampa parametrica dei Clienti e fornitori.
  • Possibilità di stampare le liste a video (vedi lista clienti in gestione clienti)

Elenco correzioni

  • Controllo partita iva. Accettava anche alcune partite iva con 12 cifre.

  • Input prima nota:
    Corretta generazione scadenze per fatt. intra cee e Reverse Charge (l’importo delle scadenze era comprensivo dell’iva)
    Corretto in modo che non si possa variare il cli/for su una fatt. di un anno chiuso

Vedi anche:
Note installazione
Note aggiornamento

Note release 1_14D


NOTE SULLA VERSIONE 1.14 C DEL 04/06/2007

Le principali novità

  • Registrazioni di fatture d’acquisto in Reverse Charge
    Al fine di tenere separati ai fini iva questo tipo di documenti per evidenziare in chiusura iva imponibile e imposta derivate dalla registrazione di fatture in regime di Reverse Charge, l’aggiornamento iva è stato modificato in modo da sommare in progressivi appositi, imponibile e imposta di queste fatture.
    Per quanto riguarda la sistemazione delle registrazioni di questo tipo, fatte e aggiornate nei mesi precedenti, è stata predisposta una funzione per la loro sistemazione nel menu di servizio di contabilità.
  • Ritenuta d’acconto fornitori
    Viene gestito un campo su ogni conto in modo da poter calcolare, in prima nota, la ritenuta d’acconto solo sulla soma degli imponibili di quei conti che hanno questo campo a Si.
    E’ stato a questo proposito gestito un parametro di personalizzazione:
    Gruppo: Pn Parametro:     DetSoggRitAcc Valore: S o N. In mancanza di questo parametro, tutti i conti accumulano imponibile. Se si crea il parametro con valore N, nessun conto creerà imponibile, tranne quelli per i quali è stato impostato a Si il campo: Soggetto a Rit.d’acconto in Gestione dei conti.
  • Prima nota fittizia
    Possibilità di:
    - cancellare una registrazione appartenente ad un anno ‘Chiuso’.
    - duplicare una registrazione
    - rendere definitiva una registrazione passandola sulla prima nota definitiva (Vedi manuale in linea)
    Tale trasferimento è consentito SOLO per i movimenti diversi da fattura.


NOTE SULLA VERSIONE 1.14 D DEL 15/09/2007

Le principali novità

  • Elenco clienti e fornitori
    Gestione nuovi dati anagrafici ditta, gestione e aggiornamento progressivi iva clienti e fornitori, preparazione file per invio telematico.

  • Cespiti
    Introdotta la possibilità che una causale di Incremento o decremento (del bene o del fondo) agisca solo su ammortamento Civile, solo su ammortamento Fiscale o su entrambi.

  • Stampe
    Possibilità di spostare i margini sinistro e alto delle stampe su stampanti ‘laser’ indicando una stampante in particolare.
    Possibilità di stampare campi ‘memo’ (note lunghe) utilizzando font diversi all’interno del campo

  • Aggiornamento Database
    Il programma di aggiornamento, alla partenza, presenta l’elenco delle aziende in linea e consente di selezionare quale azienda aggiornare.

  • Query di aggiornamento su più database
    Consente di eseguire un gruppo di istruzioni (query) per aggiornare uno o più campi, non solo sul database su cui si è posizionati ma su un gruppo di database da selezionare tra quelli in linea. Utile per assegnare ‘a tappeto’ un valore ad un certo campo. Funzione raggiungibile dal menu premendo i tasti Ctrl-Alt-Shift L

Dettaglio modifiche

  • Elenco clienti e fornitori
    Vedere note dettagliate nel manuale.

  • Magazzino – Gestione articoli
    E’ stato inserita, all’interno della maschera dell’articolo, le gestione articolo-fornitore per consentire un inserimento veloce dei dati relativi (nuovo folder).
    Nella maschera di inserimento dei componenti di un prodotto finito o semilavorato (distinta base), è stata implementata la ricerca dell’articolo per codice a barre (oltre che per codice e descrizione)

  • Stampa giornale
    Inversione della posizione di stampa della descrizione aggiuntiva di testata con la descrizione testata (spesso lasciata vuota dagli utenti). La prima è stata stampata a fianco della descrizione causale, mentre la seconda, se presente, viene stampata nella riga successiva.

  • Gestione attività
    E’ stato inserito un controllo nella cancellazione di una attività. Non si consente di cancellare una attività se esistono delle registrazioni di Prima Nota collegate ad essa (tramite prefisso del protocollo) o anche solo se esiste, nella tabella dei Prefissi e numeratori documenti, un prefisso collegato ad essa.

  • Cespiti – calcoli, gestione e stampe
    In gestione causali cespiti, in particolare sulle causali di incremento o decremento del fondo o del bene, è stato aggiunto un campo nuovo: Dove si applica. Esso viene impostato in modo che quella causale agisca sia sull’ammortamento civile sia sul fiscale, l’utente può però modificarlo, facendo sì che i movimenti fatti con quella particolare causale agiscano solo sull’ammortamento civile o solo su quello fiscale.

  • Utility cespiti
    Aggiunta opzione per cancellazione automatica dei cespiti venduti

  • Aggiornamento Database
    Prima di iniziare l’aggiornamento dei database, il programma presenta l’elenco completo delle aziende in linea e consente di selezionare/deselezionare quelle da aggiornare. In questo modo, in presenza di molte aziende, si potranno aggiornare gruppi di aziende e, in particolare, se si mette in linea da una copia, un’azienda non aggiornata, essa potrà essere aggiornata separatamente.

NOTE SULLA VERSIONE 1.14C (04/06/2007)

Le principali novità

  • Registrazioni di fatture d’acquisto in Reverse Charge
    Al fine di tenere separati ai fini iva questo tipo di documenti per evidenziare in chiusura iva imponibile e imposta derivate dalla registrazione di fatture in regime di Reverse Charge, l’aggiornamento iva è stato modificato in modo da sommare in progressivi appositi, imponibile e imposta di queste fatture.
    Per quanto riguarda la sistemazione delle registrazioni di questo tipo, fatte e aggiornate nei mesi precedenti, è stata predisposta una funzione per la loro sistemazione nel menu di servizio di contabilità.
  • Ritenuta d’acconto fornitori
    Viene gestito un campo su ogni conto in modo da poter calcolare, in prima nota, la ritenuta d’acconto solo sulla soma degli imponibili di quei conti che hanno questo campo a Si.
    E’ stato a questo proposito gestito un parametro di personalizzazione:
    Gruppo: Pn Parametro:     DetSoggRitAcc Valore: S o N. In mancanza di questo parametro, tutti i conti accumulano imponibile. Se si crea il parametro con valore N, nessun conto creerà imponibile, tranne quelli per i quali è stato impostato a Si il campo: Soggetto a Rit.d’acconto in Gestione dei conti.
  • Prima nota fittizia
    Possibilità di:
    - cancellare una registrazione appartenente ad un anno ‘Chiuso’.
    - duplicare una registrazione
    - rendere definitiva una registrazione passandola sulla prima nota definitiva (Vedi manuale in linea)
    Tale trasferimento è consentito SOLO per i movimenti diversi da fattura.

Vedi anche:
Note installazione
Note aggiornamento

Note release 1.14C


PULSANTI NELLA GESTIONE DI PAGINA

Al caricamento della maschera, nella barra degli strumenti, sono abilitati i seguenti pulsanti (la lettera posta tra parentesi è il tasto di scelta rapida, cioè il pulsante si attiva anche premendo quella lettera insieme al tasto Alt):

(R) Ricerca
In generale può essere premuto solo se è stato compilato il campo 'codice'. Consente di visualizzare i dati relativi a quel codice, se esiste o, in caso contrario, di andare in inserimento.

Perciò per inserire un nuovo codice, basta scriverlo e premere Ricerca, il programma entrerà nello stato di Inserimento.

Per accedere a un codice esistente si può digitarlo per intero e premere Ricerca oppure andare in ricerca secondo le modalità spiegate in lista di aiuto (tasti F2 e F3).

In alcuni programmi (es. gestione articoli di magazzino, clienti, fornitori, banche) è stata abilitata la ricerca su tutti i campi della maschera e cioè: se si cerca un articolo con il gruppo 'MO' e il sottogruppo 'PH' questi ultimi potranno essere digitati in corrispondenza ai rispettivi campi poi si può premere il tasto di Ricerca; verrà visualizzata la lista, se ci sono più articoli che soddisfano questa caratteristica, oppure si entrerà in variazione dell'unico articolo trovato o, infine, verrà dato un messaggio di campo errato se non verrà trovato nemmeno un articolo con le caratteristiche richieste.

Allo stesso modo, in gestione clienti, si può cercare il cliente per partita iva, sbiancando il codice del gruppo e del mastro, digitando la partita iva e premendo il pulsante di ricerca.

Nei campi testo è abilitata la ricerca parziale.

La ricerca su tutti i campi è abilitata là dove si consente di accedere, in ricerca, ai campi della maschera diversi da quelli chiave.

(L) Lista
Con lista si ottiene un elenco dei dati già inseriti (vedi Pulsante lista all'interno delle gestioni)
Se si esce dalla lista senza chiuderla, vengono attivati i pulsanti:
(-) Precedente nella Lista e [image] (+) Successivo nella lista. Consentono di visualizzare e gestire rispettivamente l'elemento della lista precedente o successivo a quello in gestione.

(I) Inizio archivio [image] (F) Fine Archivio
Consentono di posizionarsi rispettivamente sul primo elemento e sull'ultimo dell'archivio

(H) Chiudi
Chiude la il programma e torna al menu. Equivale a chiudere la maschera con Alt F4 o facendo un clic sull'angolo a destra in alto. Se si chiude avendo in gestione un codice e non si è precedentemente salvato, verrà segnalata l'eventuale variazione di campi e chiesto se si vuole Salvare, Non salvare o Annullare la chiusura.

(M) Menu
Consente accedere al menu lasciando aperto il programma di gestione

Una volta entrati in inserimento o in variazione vengono attivati anche gli altri pulsanti:

(S) SALVA
Consente di salvare le modifiche fatte

( C) Cancella
Consente di eliminare dall'archivio il codice visualizzato (è disabilitato in Inserimento)

(A) Annulla
Consente di uscire dalla gestione di un codice annullando le variazioni o la creazione

(D) Duplica
Consente la duplicazione di un codice. Una volta premuto viene chiesto un nuovo codice; per confermare la duplicazione occorre scegliere di nuovo Duplica, per annullare, Annulla. La duplicazione non è consentita in tutte le gestioni e comunque il pulsante è disabilitato in Inserimento.

Per quanto riguarda i documenti, questo tasto è abilitato solo su Preventivi ed Ordini.

(P) Precedente [image] (U) Successivo
Consentono di posizionarsi rispettivamente sul codice precedente a quello in gestione o sul successivo


RICERCA

Per ricercare un'anagrafica (o in generale una tabella) esistente, la si può richiamare digitando completamente il codice poi premendo il pulsante [image] (R) Ricerca dati oppure digitando qualche carattere del codice, seguito dal tasto F2, o infine, qualche carattere della descrizione, seguito dal tasto F3. In questi due casi verranno visualizzati direttamente i dati relativi al codice digitato, se è unico, oppure verrà proposta una lista con l'elenco dei dati trovati vedi Lista di aiuto.

Si può attivare il parametro di personalizzazione DecodHelpAbil che consente di mostrare la maschera di help (ricerca codice) quando, uscendo da un campo dopo aver inserito un codice parziale, questo non viene identificato in maniera univoca.
E' infine possibile la ricerca tramite la lista dei dati contenuti nella tabella in oggetto, con il pulsante: (L) lista vedi Pulsante lista.

In alcune gestioni (Clienti, Fornitori, Articoli, Banche) e nei documenti (ordini, ddt e fatture) è possibile cercare per qualsiasi combinazione di campi presenti a video. Basta compilare i campi desiderati e premere il pulsante di Ricerca

Ricerca di una stringa su un campo testo (es. sulla descrizione aggiuntiva dell'articolo):

Nelle combinazioni che seguono, la pressione dei tasti Ctrl e Alt è equivalente al tasto Alt Gr

Ctrl Alt + F poi digitare la stringa da cercare e invio. Viene presentata la prima occorrenza.
Shift Ctrl Alt + F poi digitare la stringa da cercare e invio. Viene presentata l'ultima occorrenza.
Per cercare le successive premere: Ctrl Alt + PgUp
Per cercare le precedenti premere: Ctrl Alt + PgDown

Per sostituire il contenuto di una stringa: Ctrl Alt S poi digitare la stringa da cercare e quella con cui sostituirla.
All' OK viene fatta la sostituzione sulla prima occorrenza.

Con Ctrl Alt Shift PgDown cerca e sostituisce le ricorrenze successive


CREAZIONE

Per creare una nuova anagrafica occorre compilare il(i) campo(i) codice poi premere il tasto Invio oppure il pulsante [image] (R) Ricerca dati. Se il codice corrisponde a uno già inserito in precedenza, verranno visualizzati i dati e il programma entra in modalità Variazione, altrimenti si predispone alla Creazione.

Una volta terminato l'inserimento dei dati è necessario salvare con il pulsante [image] (S) SALVA

Vedere anche Pulsanti nella gestione di pagina.

Ogni volta che nella procedura viene chiesto un codice è possibile, premendo il quadratino posto al suo fianco, accedere alla lista dei codici già inseriti e successivamente, tramite il pulsante [image] (X) Gestione archivio, mandare in esecuzione il programma di gestione della tabella in oggetto e quindi anche creare una nuova anagrafica in questo momento.

Per creare un nuovo movimento (caricamento movimenti di magazzino) o documento (ordini, ddt,fatture) occorre invece compilare con 0 il campo Numero (movimento o riferimento) e automaticamente il programma si predispone per l'inserimento.


VARIAZIONE

Per variare un'anagrafica (o in generale una tabella) esistente, la si può richiamare digitando completamente il codice poi premendo il pulsante [image] (R) Ricerca dati oppure digitando qualche carattere del codice, seguito dal tasto F2, o infine, qualche carattere della descrizione, seguito dal tasto F3. In questi due casi verranno visualizzati direttamente i dati relativi al codice digitato, se è unico, oppure verrà proposta una lista con l'elenco dei dati trovati vedi Lista di aiuto.

E' infine possibile la ricerca tramite la lista dei dati contenuti nella tabella in oggetto, con il pulsante: (L) lista vedi Pulsante lista.


CANCELLAZIONE

Una volta individuato, con la Ricerca, il codice da cancellare, si può ottenere la Cancellazione premendo il pulsante [image] ( C) Cancella


DUPLICAZIONE

Consente di creare un'anagrafica, un ordine o un preventivo, a partire da uno già esistente, duplicando tutte le informazioni e assegnando semplicemente un nuovo codice. Posizionarsi sul codice da duplicare e premere il pulsante [image] (D) Duplica, verrà chiesto di digitare un nuovo codice; per confermare la duplicazione occorre scegliere di nuovo Duplica, per annullare, Annulla.

La duplicazione non è consentita in tutte le gestioni e comunque il pulsante è disabilitato in Inserimento.


PULSANTE LISTA ALL'INTERNO DELLE GESTIONI

Nelle gestioni di pagina è possibile ottenere, tramite il pulsante: (L) lista, un elenco del contenuto di una tabella, con possibilità di impostare qualche parametro per la selezione dei dati. Si consiglia di chiudere la lista, una volta consultata, prima di tornare al programma chiamante.

E' possibile personalizzare i campi da inserire nella lista utilizzando i parametri ListaAggEle , ListaHideCol , ListaOrdin

Entrati nella lista è possibile compilare qualche campo di selezione, al fine di restringere l'intervallo di elementi da visualizzare, oppure si procede subito premendo il pulsante [image] (R) Ricerca dati, verranno visualizzate tutte le righe della tabella di cui si chiede la lista, eventualmente filtrate attraverso i campi di selezione.

Nelle liste per le quali è stato ritenuto opportuno, è stata inserita una funzione che consente la ricerca di un testo all'interno di una delle colonne visualizzate (contenenti un campo stringa).

A video viene presentato uno spazio nel quale scrivere il testo da cercare, poi occorre scegliere in quale campo cercare quel testo e come eseguire la ricerca: Primo cioè cercare la prima ricorrenza, Successivo, Precedente, Ultimo.

Per iniziare la ricerca dall'inizio dell'elenco occorre premere il pulsante: Cerca in, accertarsi che sia spuntato: Inizio.

Una volta trovata una riga contenente quel testo, per continuare la ricerca, occorre impostare Successivo e premere di nuovo il pulsante: Cerca in.

Per andare in gestione di una riga della lista basta selezionarla e fare click oppure premere il pulsante:
(E) Seleziona il dato cercato dopo essersi posizionati sulla riga.

Altri pulsanti disponibili nella lista:
(Z) Azzera selezioni
Serve per pulire i campi di selezione eventualmente impostati.

(O) Torna alla maschera chiamante
Serve per tornare sul programma di gestione, senza aver selezionato niente e lasciando compilata la lista.

(I) Inizio archivio [image] (F) Fine Archivio
Consentono di posizionarsi rispettivamente all'inizio e alla fine della lista

(G) Aggiorna
Consente di aggiornare la lista nel caso che i dati siano stati modificati da altri dal momento della prima visualizzazione.

(T) sTampa
Consente di stampare la lista visualizzata.
Se la larghezza di alcune colonne in stampa non fosse sufficiente a contenere il campo corrispondente, occorre che l'operatore, prima di dare il comando di stampa, intervenga manualmente sul video allargando in modo opportuno le colonne interessate (trascinando cioè a destra, con il mouse, il margine destro della colonna, sulla riga del titolo).
Se può scegliere l'orientamento della stampa e si può cambiare il font.

(H) Chiudi
Chiude la lista e torna alla maschera chiamante

(M) Menu
Visualizza la pagina del menu lasciando aperta la lista e il programma da cui è stata richiamata.


LISTA DI AIUTO (Ricerca di un codice con F2 - F3)

Ogni volta che viene chiesto un codice per l'accesso ad una tabella è possibile digitarlo completo oppure andare in ricerca. La ricerca (anche parziale), in generale, può essere fatta sul codice o sulla descrizione e si attiva rispettivamente con i tasti F2 (o col pulsante con i 3 puntini (…) posto a fianco al codice) ed F3.

Se si desidera invece cercare qualcosa di particolare si possono digitare le prime lettere del codice o della descrizione (sempre sul campo codice), (oppure * seguito da qualche lettera per fare ricerche interne a codice o descrizione) seguite rispettivamente da F2 o F3.

Oltre all'asterisco si possono utilizzare altri caratteri jolly per la ricerca, anche combinati tra loro (vedere note che seguono)

Per gli articoli è abilitata la ricerca anche per il codice a barre e si utilizza il tasto F4.
Il Codice a barre viene cercato sulla tabella degli articoli e anche sulla tabella 'ArticoliBarCode' dove si possono memorizzare gli eventuali ulteriori BarCode che fanno riferimento ad uno stesso articolo.
Se vale S in ogni punto nel quale si chiede la decodifica del codice articolo ignora articoli inattivi.
Nella lista di aiuto, non vengono elencati gli articoli sui quali è stato impostato a Si il campo 'Inattivo', tuttavia se si digita il codice esatto è possibile inserirli nei documenti. Per escluderli completamente si può attivare il parametro di personalizzazione: NoDecInattivi

Per i Clienti e i Fornitori è abilitata la ricerca, anche parziale, posizionandosi sul campo Cod.Cliente/Fornitore e premendo uno dei tasti descritti in seguito:

  • F2 sul codice
    se il campo codice è vuoto verrà presentato un elenco di tutte le anagrafiche ordinate per codice
  • F3 sulla Ragione sociale contabile
    se il campo codice è vuoto verrà presentato un elenco di tutte le anagrafiche ordinate per Ragione sociale contabile
  • F4 sulla Partita Iva
  • F5 sul Codice Fiscale
  • F11 sulla prima parte della Ragione Sociale
  • F12 sulla Ragione sociale completa (unione della prima e seconda parte)

Vedi parametro di personalizzazione CFHelpRicF11 per estendere ulteriormente i campi di ricerca

E' possibile abilitare il parametro di personalizzazione DecodHelpAbil per personalizzare la ricerca (es. digitare qualche carattere e premere invio: in generale cercherà sul codice poi se non trova niente sulla descrizione)

Se nella lista, si desidera visualizzare altri dati, oltre a quelli previsti dal programma, si può impostare il parametro di personalizzazione Help dove si dovranno impostare i nomi dei campi.

E' stato abilitato, per alcune funzioni quali Prima Nota, Ordini, Preventivi, Ddt e Fatture, la possibilità di personalizzare l'ordinamento della lista ottenuta, tramite il parametro di personalizzazione ListaOrdin

Per far si che non avvenga lo spostamento della riga sulla lista con il passaggio del mouse, si può personalizzare il parametro HlpSpost

Casi particolari:

Per velocizzare la ricerca (ad esempio sugli articoli di magazzino), è possibile digitare la parte iniziale del codice, il carattere ç e parte della descrizione (anche parte interna cioè preceduta da un *), il tutto seguito da F2. Questa ricerca ha senso nel caso degli articoli di magazzino, dove i primi caratteri del codice individuano ad esempio il fornitore e si vogliono cercare gli articoli di un fornitore, per descrizione.

Sul codice articolo è attivata anche un altro tipo di ricerca: per gruppo e sottogruppo. Questa ricerca si ottiene digitando il 'gruppo' seguito dal carattere ç, ed eventualmente dal sottogruppo, poi dal tasto F3.

Es. grç F3 cerca gli articoli con gruppo gr

Banche: In qualsiasi punto delle procedure in cui venga richiesto un codice banca, la ricerca può essere fatta, oltre che per codice e descrizione, anche per ABI oppure ABI e CAB digitando l' ABI (completo o incompleto con * finale, seguito dal carattere ç) oppure ABIçCAB (il carattere ç deve dividere i due campi, scritti anche parzialmente) e premendo rispettivamente i tasti F2 (lista per codice) o F3 (lista per descrizione).

Se esiste un solo elemento in archivio con le caratteristiche richieste, questo viene immediatamente portato in gestione, altrimenti viene visualizzata la lista degli elementi della tabella che soddisfano le richieste.

Alla fine del paragrafo viene riportato un Riepilogo dei tasti funzione abilitati nei vari programmi

Sulla lista è inoltre possibile:

spostare una o più colonne consecutive. Per fare ciò occorre evidenziare la prima colonna da spostare poi, spostando il mouse, tenendo sempre premuto il pulsante sinistro, evidenziare le altre. Spostarsi poi col mouse nel punto in cui si desidera inserirle (senza cliccare!) e premere CTRL e il tasto Destro del mouse. Le colonne selezionate verranno inserite come colonne successive a quella in cui ci si è posizionati

ordinare una qualsiasi colonna della lista facendo un click con il mouse sul titolo della colonna interessata.

ordinare più colonne consecutive. Per fare ciò occorre evidenziare la prima colonna da ordinare poi, spostando il mouse, tenendo sempre premuto il pulsante sinistro, evidenziare le altre. Infine, premere ALT e tasto destro del mouse

Nelle liste per le quali è stato ritenuto opportuno, è stata inserita una funzione che consente la ricerca di un testo all'interno di un campo stringa, scelto nella lista dei campi della tabella in oggetto.

A video viene presentato uno spazio nel quale scrivere il testo da cercare, poi occorre scegliere in quale campo della tabella cercare quel testo e come eseguire la ricerca: Primo cioè cercare la prima ricorrenza, Successivo, Precedente, Ultimo.

Per iniziare la ricerca dall'inizio della tabella occorre premere il pulsante: Cerca in, accertarsi che sia spuntato: Inizio.

Una volta trovata una riga contenente quel testo, per continuare la ricerca, occorre impostare Successivo e premere di nuovo il pulsante: Cerca in.

Sulla barra degli strumenti della lista sono disponibili altri pulsanti:

(I) Inizio archivio [image] (F) Fine Archivio
Consentono di posizionarsi rispettivamente sul primo e sull'ultimo elemento della lista

(G) Aggiorna
Consente di aggiornare la lista nel caso che i dati siano stati modificati da altri dal momento della prima visualizzazione.

(T) Trova
Viene richiesto di impostare il Valore da cercare (è il codice).
Alla conferma [image] il programma estrae gli elementi della lista con il codice uguale al richiesto (o maggiore-uguale etc. a seconda di quanto impostato in Valore cercato) procedendo nella ricerca a seconda di quanto indicato in Direzione ricerca.
Per uscire dalla ricerca premere il pulsante [image] Annulla

(H) Chiudi
Chiude la lista di aiuto e torna alla maschera chiamante. Anche il tasto Esc consente di chiudere la lista di aiuto senza selezionare nulla

(O) Annulla selezione dati
Consente di annullare una selezione fatta in precedenza con il pulsante Trova

(E) Seleziona il dato cercato
Una volta posizionati su una riga con questo pulsante è possibile selezionare il codice corrispondente a quella riga e portarlo direttamente nel campo della gestione. Lo stesso effetto lo si ottiene premendo invio dopo aver selezionato la riga oppure facendo un clic in corrispondenza al margine sinistro della riga stessa

(X) Gestione archivio
Manda in esecuzione il programma di gestione della tabella in oggetto. Questo pulsante consente di creare un'anagrafica nel momento in cui la si vuole utilizzare per cui è presente in corrispondenza alle tabelle più complesse.

Per le tabelle più semplici invece si consente la variazione nella stessa maschera di aiuto. In questo caso al posto del pulsante precedente, compare il pulsante:

(V) Abilita variazione dati
con il quale si accede alla creazione/variazione (l'annullamento non è possibile) dei dati della lista visualizzata con le modalità della gestione di linea.

Note sulla ricerca parziale:

Caratteri in criterio Corrispondenze in espressione:

? Qualsiasi carattere singolo
* Zero o più caratteri
# Qualsiasi cifra singola (0-9)
[elencocaratteri] Qualsiasi carattere singolo in elencocaratteri
[!elencocaratteri] Qualsiasi carattere singolo non in elencocaratteri

È possibile utilizzare un gruppo di uno o più caratteri (elencocaratteri) racchiuso tra parentesi quadre ([ ]) per trovare una corrispondenza con qualsiasi carattere singolo in espressione. In elencocaratteri è possibile specificare quasi tutti i caratteri del set di caratteri ANSI comprese le cifre. I caratteri speciali parentesi quadra aperta, ([ ), punto interrogativo (?), simbolo di numero (#) e asterisco (*) possono essere utilizzati per trovarne la corrispondenza solo se vengono racchiusi tra parentesi quadre. Per trovare una corrispondenza con la parentesi quadra chiusa ( ]), è necessario specificarla all'esterno di un gruppo come carattere singolo.

Il segnaposto elencocaratteri può essere rappresentato sia da un semplice elenco di caratteri racchiusi tra parentesi quadre che da un intervallo di caratteri. Nel secondo caso viene utilizzato il trattino (-) per separare il limite superiore dell'intervallo dal limite inferiore. Se, ad esempio, per criterio si specifica [A-Z] verrà individuata una corrispondenza se nella posizione corrispondente in espressione è presente una qualsiasi lettera maiuscola compresa nell'intervallo da A a Z. All'interno delle parentesi quadre è possibile specificare più intervalli senza carattere di separazione. Il criterio di ricerca [a-zA-Z0-9] consente ad esempio di individuare una corrispondenza con qualsiasi carattere alfanumerico.

Di seguito vengono elencate alcune importanti regole da seguire per l'impostazione dei criteri di ricerca:

Il punto esclamativo (!) all'inizio di elencocaratteri indica che la ricerca della corrispondenza avrà esito positivo solo se in espressione non vengono individuati i caratteri specificati in elencocaratteri. Se il punto esclamativo viene utilizzato all'esterno delle parentesi quadre, verrà cercata la corrispondenza con il punto esclamativo stesso.

Il trattino (-) può essere utilizzato all'inizio (dopo un punto esclamativo se specificato) o alla fine di elencocaratteri per trovare una corrispondenza con il trattino stesso. In qualsiasi altra posizione il trattino viene utilizzato per identificare un intervallo di caratteri ANSI.

Se si specifica un intervallo di caratteri, è necessario che venga indicato in ordine crescente (A-Z o 0-100). [A-Z] è un criterio di ricerca valido, mentre [Z-A] non lo è.

La sequenza di caratteri [ ] viene ignorata in quanto viene considerata come una stringa di lunghezza zero ("").

Riepilogo dei tasti funzione abilitati nei vari programmi

  • Distinta effetti : F2 , F3 , F4 , F5 , F6 per la ricerca di una distinta
  • Gestione ddt, se non è ancora stato inserito il tipo documento: Campo codice cli/for: Con i tasti F2 ed F3 si consente di cercare rispettivamente per codice o ragione sociale cliente, con F4 e F5 per fornitore
  • Gestione Prima Nota, Preventivi, Ordini, Ddt e Fatture
    Si può cercare un cliente/fornitore per partita iva o codice fiscale digitando qualche carattere poi premendo rispettivamente i tasti F4 o F5.
  • Gestione Ordini: su una riga evasa è attivo il tasto F11 che consente di aggiornare la quantità ordinata.
  • Lotti: tasti F4 ed F5, fanno una ricerca tipo l' F2 e l' F3 però senza le selezioni su articolo e fornitore
  • Preventivi, Ordini, Ddt e Fatture
    sul campo codice articolo sono stati abilitati i tasti Shift F2 - F3 - F4 che, oltre a fare la ricerca rispettivamente per codice, descrizione, barcode articolo, consentono di visualizzare, per ogni articolo, nella lista di aiuto:
    - l' ultimo prezzo fatto al cliente estraendolo dall’ ultima fattura inserita e calcolato come valore totale di riga diviso quantità
    - il prezzo di listino (dal listino del documento e, se questo non c’è, da quello inserito in tabella di Magazzino)
    - in Ordini e Preventivi ( SOLO se ci sono le permissioni di scrittura in PN) mostra anche l'ultimo costo (Non vengono considerati i livelli)
    - se attivo il Parametro: NotaLinguaDove viene attivato, sulle righe 'articolo' dei documenti, il tasto funzione F11 (F5 sugli Ordini).
  • In generale in tutti gli altri programmi, in corrispondenza del codice Articolo, premendo i tasti F5 - F6 - F7 si genera una lista ordinata rispettivamente come F2 - F3 - F4 ma che contiene il prezzo del listino base e il costo ultimo


PULSANTI NELLA GESTIONE DI LINEA

(N) Nuovo
Consente di aggiungere (creare) una nuova linea di dati in fondo alla lista. Lo stesso scopo lo si può ottenere posizionandosi in fondo alla lista e scrivendo lì

(S) SALVA
Consente di salvare la riga su cui si è posizionati. Il salvataggio di una riga avviene comunque ogni volta che ci si sposta da essa dopo averla modificata. Se un altro utente ha modificato gli stessi dati e tenta di salvare, viene dato un messaggio 'Dati modificati da altri' e si consente: di salvare ugualmente (annullando la variazione fatta dagli altri), di rileggere la tabella o di Annullare l'operazione di salvataggio. La scelta più giusta da fare è quella di rileggere la tabella. Se si annulla e si ripete l'operazione di salvataggio, esso verrà effettuato sovrapponendo i dati modificati dall'altro utente.

( C) Cancella
Consente di eliminare dalla lista, con richiesta di conferma, la linea su cui si è posizionati

(A) Annulla
Consente di uscire da una riga su cui è stata fatta una variazione, annullando la variazione (viene chiesta conferma)

(B) PUNTATORE
Consente di fissare una riga sulla lista, spostarsi da questa riga e ritornare ad essa premendo il pulsante

(K) Vai a
(I) Inizio archivio [image] (F) Fine Archivio
Consentono di posizionarsi rispettivamente all'inizio e alla fine della lista

(G) Aggiorna
Consente di aggiornare la lista nel caso che i dati siano stati modificati da altri dal momento della prima visualizzazione

(T) Trova
Viene richiesto di impostare il Valore da cercare (è il codice).
Alla conferma [image] il programma estrae gli elementi della lista con il codice uguale al richiesto (o maggiore-uguale etc. a seconda di quanto impostato in Valore cercato) procedendo nella ricerca a seconda di quanto indicato in Direzione ricerca.
Per uscire dalla ricerca premere il pulsante [image] Annulla

(P) Stampa
Consente di fare la stampa della lista. Viene visualizzata una maschera tramite la quale possono essere variati l'orientamento, i font e la destinazione di stampa (vedi Stampa)

(H) Chiudi
Chiude la il programma e torna al menu. La chiusura salva l'ultima variazione. Uscire con questo pulsante è equivalente a chiudere la maschera con un click sull'angolo alto a destra o a premere Alt F4

(M) Menu
Va al menu lasciando aperto il programma di gestione


PULSANTI IN GESTIONE MOVIMENTI E DOCUMENTI

Questo tipo di gestione viene utilizzata dove esiste una parte di dati iniziali (testata) e un elenco di righe ripetitive (dettagli).

La creazione di un nuovo documento avviene scrivendo uno 0 sul campo 'numero'.

La gestione della prima parte dei dati (testata) rende disponibili gli stessi pulsanti descritti in Gestione di pagina

Una volta inserita o variata la testata, per passare ai dettagli occorre premere il tasto F10 oppure il pulsante [image] (E) Gestione Dettagli oppure [image] (S) SALVA

GESTIONE DETTAGLI

Se si sta inserendo un documento nuovo, si chiede di inserire un codice articolo, mentre se esistono già dei dettagli, viene proposto il primo e, spostandosi sui vari dettagli della lista si può accedere alla loro rispettiva variazione.

Creazione di una nuova riga di dettaglio:
(N) Nuovo
La nuova riga verrà inserita sempre in fondo al documento.
(F10) Inserisci riga
L'inserimento verrà fatto sopra la riga in cui si è posizionati.

Se dall'inserimento si esce con Salva il programma resta posizionato sulla riga inserita, se si esce con (F10) rimane in inserimento. In questo caso, per uscire dallo stato di inserimento, occorre premere il tasto ESC o il pulsante: Annulla.

Nella gestione dei dettagli, per le operazioni di Cancella, Annulla, Puntatore, Vai A, Aggiorna e Trova, sono disponibili i pulsanti descritti in pulsanti per la gestione di linea.

Se lo stato del documento è bianco (cioè non è stato stampato o evaso), sono presenti alcuni pulsanti aggiuntivi che consentono di spostare o duplicare gruppi di righe:
(X) Taglia [image] (W) Incolla
Una volta selezionate una o più righe, se si preme il pulsante (X) Taglia, si porta il cursore nella posizione in cui si vogliono trasferire le righe e si preme (W) Incolla, si ottiene lo spostamento di tali righe dalla posizione originale alla nuova posizione.

Le righe selezionate e 'tagliate' vengono incollate sopra alla riga in cui si è posizionati. Se si esegue la funzione Incolla sull'ultima riga, viene chiesto se incollare sopra o sotto.
(O) Copia [image] (W) Incolla
Consentono, una volta selezionate una o più righe, di Copiarle in un'altra posizione su cui si dovrà portare il cursore prima di premere Incolla.

La funzione incolla inserisce la riga 'da copiare' prima di quella su cui si è posizionati. Se si è posizionati sull'ultima, viene chiesto se inserirla Sopra o Sotto.

Su un documento già esistente, si può passare da un dettaglio all'altro scorrendoli con le frecce in alto e in basso.
(E) Esci annullando
Consente di uscire dalla gestione dei dettagli senza salvare nessun inserimento o modifica, viene chiesta un'ulteriore conferma.
L'uscita con questo pulsante, da utilizzarsi in particolare quando si entra in consultazione dei dettagli e non si fanno variazioni, consente di evitare il disaggiornamento e riaggiornamento dei dettagli (che potrebbe portare ad alterazioni del Medio Ponderale) ed è più veloce.
(H) Chiudi
Consente di uscire confermando tutte le variazioni.

Sui documenti: Ordini, Ddt, Fatture sono inoltre disponibili i pulsanti:

(X) Spese per l'inserimento e la variazione delle righe di spesa
(T) sTampa per la stampa diretta
(N) Annulla la stampa per il ripristino allo stato di non stampato di un documento già stampato in precedenza


GESTIONE LIVELLI

Percorso: Maschera gestione dettagli di Movimenti di Magazzino, Ordini, Ddt e Fatture

Nuova maschera di Gestione Livelli a Tabella (parametro GestTab)

Se è abilitata, da installazione, la gestione dei livelli, verranno resi disponibili altri due pulsanti posti in alto a destra sulla maschera della gestione dettagli: (L) Gestione Livelli e [image] (K) Gestione Livelli con Creazione

Se si sta inserendo un dettaglio con un articolo che non ha i livelli, è abilitato solo il primo che premuto, ha lo stesso effetto del Salva riga.

Se invece si sta inserendo una riga con articolo con livelli, una volta digitato il codice dell'articolo, per passare alla richiesta delle quantità 'per livello' si può procedere premendo [image] (S) SALVA o F10 o [image] (L) (si entrerà così in gestione dei dettagli dei livelli e verrà chiesto di digitare riga per riga i codici livello, le quantità ed eventualmente il prezzo) mentre con [image] (K) Gestione Livelli con Creazione (verranno generate in automatico TUTTE le righe dei livelli di quell'articolo con le quantità a 0 e si dovrà compilare quelle interessate).

Dall'inserimento dei livelli non si può uscire senza aver compilato almeno una riga.

In variazione di una riga di dettaglio con articolo con livelli, le due frecce Rossa e Azzurra consentono rispettivamente, l'una, di entrare in Gestione dei SOLI Livelli creati in precedenza ed eventualmente aggiungerne manualmente, l'altra, di entrare nei livelli trovando già compilate tutte le combinazioni e di completare con quantità e valore le righe opportune.


NOTE SU STAMPE

La procedura consente, oltre alla stampa su video e stampante, stampe su Pdf, su file excel o testo e la stampa su Pdf con successivo invio automatico per email.

In ogni programma di stampa viene sempre visualizzata una riga che indica su quale stampante si sta stampando e tre pulsanti:

  • Stampa: esegue la stampa sulla stampante già selezionata
  • Stampa a video: esegue la stampa a video
    le caratteristiche di stampa vengono prese dalla stampante selezionata
  • Selezione destinazione stampa
    Premendo questo pulsante, si apre la finestra: Scelta della modalità di stampa che si presenta diversa a seconda che si stia eseguendo una stampa 'comune' o la stampa di un documento (es. ddt, fattura)

    Può succedere che la stampante su cui si vuole stampare, pur essendo nell'elenco, non sia in quel momento selezionabile dal programma, in tal caso viene segnalato di uscire da quel programma e rientrare per poterla selezionare.

Vedi anche note per la gestione delle stampanti in Terminal Server


SELEZIONE DESTINAZIONE STAMPE

Questo pulsante, presente in tutte le funzioni che prevedono la stampa, consente di cambiare la destinazione della stampa e di impostare dei parametri. Vedi anche: Note generali su stampe
Premendolo, si apre la finestra: Scelta della modalità di stampa che si presenta diversa a seconda che si stia eseguendo una stampa 'normale' o la stampa di un documento (es. ddt, fattura)

Elenco dei parametri di stampa

Parametri INI Pdf ed Email

Stampa 'normale'
 Si può scegliere di fare la stampa su Stampante, su Video, su File o su File/Stampante a lunghezza fissa, su file pdf con l'eventuale invio via email.

  • Stampante: viene visualizzato l'elenco delle stampanti abilitate ed è possibile cambiare la stampante scegliendone una dell'elenco (spostandosi col cursore avanti e indietro sulla lista delle stampanti e premendo invio su quella desiderata, oppure selezionandola col mouse).
    SOLO SE si vuole utilizzare l'intera larghezza del foglio di una stampante a 132 colonne o con fogli A3, in stampe progettate per un A4 orizzontale, è possibile forzare la stampa in verticale, cliccando col mouse sull'apposita casella.
    Viene data inoltre la possibilità di stampare SOLO alcune pagine specificate dall'utente nella richiesta: Stampa pagine da .. a ...
  • Video: consente di fare la stampa a video.
    Le caratteristiche di stampa vengono prese dalla stampante selezionata
    Verranno successivamente visualizzate le opzioni di visualizzazione con possibilità di variarle:
    fattore di visualizzazione    : indica la dimensione dei caratteri in visualizzazione, il valore proposto è 100 e può essere aumentato o diminuito con la barra di scorrimento verticale.
    memorizzazione pagine    : consente di memorizzare la stampa su disco e quindi di poterla scorrere avanti e indietro in visualizzazione. Poiché la memorizzazione rallenta la stampa, la modalità standard non la prevede.
    Normalmente la stampa a video mostra sequenzialmente le varie pagine una dopo l'altra con possibilità di uscire al termine della visualizzazione di ogni pagina.
    Viene data inoltre la possibilità di stampare SOLO alcune pagine specificate dall'utente nella richiesta: Stampa pagine da .. a ...
  • File: Consente di mandare la stampa su file invece che su stampante.
    Occorre specificare, premendo il pulsante CAMBIA, dove salvare il file generato e con quale nome e inoltre scegliere il formato. (Se dopo aver premuto Cambia non viene visualizzata la maschera successiva, occorre cercare tra le maschere aperte, a fondo video, e aprire: Nome del file di stampa).

    In 'Salva come (Formato )' si può scegliere tra Caricabile da excell (o Compatibile excell) e Testo. Uscendo con Salva da questa maschera si conferma nome e formato. Solo nel caso di formato Testo, si potrà decidere, successivamente, il Separatore dei campi tra: Tabulatore, Punto e Virgola, Virgola, Spazio, il Qualificatore testo (cioè come vengono memorizzati sul file i campi testo) tra: doppio apice, singolo apice, nessuno e se si deve togliere o no il formato dai campi numerici.
  • File/Stampante a lunghezza fissa: Scegliendo questo tipo di stampa vengono usati i caratteri e i codici di controllo della stampante, ignorando la gestione delle stampanti di windows (da utilizzarsi in particolare per le stampanti ad aghi).
    Se viene selezionata una stampante è possibile variare le colonne di stampa, il numero di righe per pagina, quante lasciarne vuote in testa e, in caso di stampa in compresso, le sequenza di inizio e fine compresso proprie della stampante selezionata.

    Nel caso non fosse disponibile una porta parallela ma il collegamento avvenisse tramite una porta usb o su una stampante collegata in rete, si può utilizzare il comando net use per redirigere la porta LPT1 sulla stampante voluta, es.
    NET USE LPT1: \\nome_host\nome_stampante oppure NET USE LPT1: \\indirizzo_ip\nome_stampante
    Aggiungendo al comando il parametro /persistent:yes il comando verrà memorizzato in maniera permanente e non sarà necessario ripeterlo. Infine potrebbe essere necessario eseguire il comando da una finestra dos aperta come administrator

    Per fare la stampa su file occorre premere il pulsante: Nome del File e digitare il nome.

Scelta della stampante
Viene visualizzato l'elenco delle stampanti collegate e l'utente può, con un click sulla riga di una di esse, selezionare quella da utilizzare. Se si utilizza sempre la stampante Predefinita (di default), si consiglia di premere il pulsante Stampante Predefinita (nelle Opzioni di stampa viene sbiancato il nome stampante) poi Salvare le opzioni di stampa una volta sola, valida per tutte le stampe, scegliendo di farlo Per il terminale e Nei valori di default.

Se si utilizzerà, da un terminale, sempre la stampante predefinita, si consiglia di premere il pulsante Stampante Predefinita e salvare le Opzioni di Stampa deselezionando tutto e cliccando SOLO su Nome Stampante, in questo modo, nelle Opzioni di stampa sul file AziWin.ini, verrà sbiancato il nome stampante.

Mess. numero pagine
Se si desidera sapere quante pagine occuperà una stampa, senza stampare effettivamente, occorre aver preventivamente installato una stampante fittizia che utilizza lo stesso driver di quella in uso ma stampa su file. Poi si può quindi stampare dopo aver spuntato l'opzione "Mess.numero pagine" e selezionare come stampante quella 'fittizia' suddetta.
Al termine della stampa su file, a video verrà visualizzato il numero di pagine occupate dalla stampa.
Attenzione: Le stampe che prevedono una prova e una stampa effettiva, andranno fatte esclusivamente in Prova, quando si setta questo flag!

Forza la stampa in verticale (solo per formati maggiori dell'A4)
Se spuntato si stamperà sempre in verticale, anche quando il programma è stato predisposto per la stampa orizzontale perchè i dati da stampare sono tanti. Ovviamente, stampando su carta A4, la stampa troncherà i dati più a destra.

Cassetto
Se la stampante selezionata ha più cassetti per la carta, è possibile selezionare il cassetto da utilizzare. Vedi parametro di personalizzazione: StampantiNoCassetti

Tipo Carta
 Una volta selezionata una stampante, la pressione di questo tasto produrrà un elenco dei formati di carta disponibili su tale stampante.
E' possibile, ad esempio, scegliere di stampare su foglio A3, là dove la stampante lo consente.
Può essere utile per eseguire una stampa parametrica. Si può memorizzare, per una determinata stampa, la stampante e il tipo carta in modo da eseguirla sempre con quelle caratteristiche.

Stampa pagine da ... a ...
Consente di stampare solo un gruppo di pagine di una determinata stampa.

Opzioni che consentono di stampare in automatico su file Pdf e di spedire il file a un indirizzo email.

Sulla maschera che viene presentata premendo il pulsante: 'Seleziona destinazione stampa', che è su ogni della maschera di stampa, occorre spuntare 'Usa PdfCreator' e, se serve, 'Abilitare Opzione richiesta invio per email' poi salvare

Nome del file PDF automatico ( PdfNomeAutom )
Questa opzione consente di ottenere la stampa in automatico su file pdf. Viene proposta già spuntata quando nell' Aziwin.ini nel gruppo [Opzioni Stampa] (o nel gruppo che identifica una funzione particolare es [StafatSFat] ) è stata creata la riga: PdfNomeAutom = S
La condizione fondamentale, per poter poi eseguire la stampa su pdf, è che sia stato installato PdfCreator o Pdf995 e che nella sezione [StampaPdf] sia stata creata la riga: UsaPdfCreator=S (o UsaPdf995=S)

Invia per email
Questa opzione viene proposta SOLO se è spuntato il campo precedente e se, nell'aziwin.ini, nel gruppo [Email] è presente l'opzione StampeEmail=S

Pulsante: Parametri INI Pdf ed Email
Consente di impostare/modificare i parametri relativi a stampe su Pdf e successivo invio per email, sul file AziWin.INI

Salva - Cancella Opzioni di stampa
Entrambi i pulsanti provocano la visualizzazione dell' elenco dei parametri di stampa attivi per questo programma, parametri che possono essere validi SOLO per questa funzione o per tutte le stampe fatte dal terminale oppure per tutte le stampe. Tali parametri sono memorizzati, in gran parte, nel file AziWin.ini nella sezione [Opzioni Stampa]

  • Salva opzioni stampa
    Con questo pulsante è possibile, una volta fatte le opportune scelte di configurazione di stampa, nella maschera che presenta l'elenco dei parametri, memorizzare quella configurazione
    Questa opzione può essere utile in particolare, per definire una modalità di stampa particolare SOLO per determinate funzioni (es. la stampa del bollato su stampante ad aghi con certi parametri di lunghezza foglio etc.)
  • Cancella opzioni di stampa
    Consente di scegliere, nella maschera che presenta l'elenco dei parametri di stampa, quelli da cancellare e, alla conferma, li toglie dall'aziwin.ini comune o del terminale a seconda di quanto viene specificato.

Vedi Stampe - Modifiche per trovare le possibilità di intervento dell'utente sulle stampe in generale.

Elenco dei parametri di stampa

Dove Stampare |  | Forza verticale |
Nome stampante | Se bianco si stampa su stampante di default | Porta stampante |
File di stampa per st.su file | Path e Nome file | Formato di stampa per stampa su file | Excel o Testo
Path di default per stampe su file |  | Separatore campi per stampa su file | Tabulatore, Virgola, Punto e Virgola
Qualificatore testo per stampa su file |  | Tolgo il formato nei campi numerici per stampa su file |
Fattore di visualizzazione | per stampa a video | Memorizza pagine per stampa a video |
Nome file per stampa fissa |  | Stampa fissa su: |
Righe vuote in alto per stampa fissa |  | Righe vuote in basso per stampa fissa |
Numero di colonne per stampa fissa |  | Righe per pagina per stampa fissa |
Sequenza inizio compresso |  | Sequenza fine compresso |
Stampa in compresso per stampante fissa |  | Cassetto | Default o cassetto scelto
Nome file PDF automatico (PdfAutom=S) |  | Invia per Email (InviaEmail=S) | L'opzione è visibile se è stato scelto, nella maschera dei par.ini per pdf/email di abilitare la richiesta di invio per email ed è gestibile se si spunta 'Nome file pdf automatico'

Verranno salvati o cancellati i parametri che risultano 'spuntati'

Dove Salvare

  • Parametri di questo terminale
    I parametri verranno salvati nell' AziWin.ini del terminale (locale)

  • Parametri comuni a tutti i terminali
    I parametri verranno salvati nell' AziWin.ini comune (cartella AziWin)

In quale zona parametri

  • Solo per questa stampa
    Verranno memorizzati sull'INI in una sezione [NomeProgramma]

  • Nei valori di default
    Verranno memorizzati sull'INI nella sezione [Opzioni Stampa]

Parametri INI per Pdf ed Email

Anche questi parametri possono essere salvati solo per questo terminale o nei Parametri comuni a tutti i terminali.
Verranno memorizzati o cancellati SOLO i parametri che risultano 'spuntati'

Nome Parametro su file INI
Usa PdfCreator: Indica se verrà utilizzato il PdfCreator come generatore dei file Pdf | UsaPdfCreator ( in [StampaPdf])
Usa Pdf995: indica se verrà utilizzato il Pdf995 come generatore dei file Pdf | UsaPdf995 ( in [StampaPdf])
Nome e Percorso file per Pdf: indica percorso e nome del file che dovrà contenere il pdf della stampa. Il nome può essere parametrizzato (**) e deve avere estensione .pdf OBBLIGATORIO se invio per email
In stampa documenti, non viene chiesto questo parametro ma il file viene salvato nella cartella indicata dal parametro DirPdf scritto manualmente nell'AziWin.ini 		PdfNomeFile ( in [StampaPdf])
DirPdf (in [Base] per stampe documenti)
Apertura automatica file Pdf: Se impostato a S dopo la stampa verrà visualizzato il file Pdf
         AutosaveStartStandardProgram
( In [StampaPdf])
Configurazione di invio email ATTIVA (Possibili fino a tre configurazioni per ciascuna delle quali si ripeteranno i parametri seguenti) | TipoNum=1 (o 2 o 3)

Programma che verrà utilizzato per l'invio della email

  • S=Sendmail (default) - Controllare la configurazione

  • E=See - Controllare la configurazione Scelta consigliata
    Da utilizzare, in alternativa a Sendmail, in particolare per i server che utilizzano SSL (es. posta certificata e GMail)

  • O=Outlook
    chiede conferma ad ogni invio e memorizza tutti i messaggi spediti

  • C=Cdo
    solo per chi ha un server di posta con Cdo

 TipoInvio

In [Email]
Numero porta SMTP (se non compilato si attribuisce, normalmente il valore 25. Se usa SSL invece si attribuisce 465) | NumPorta (NumPorta2 ,3)
Numero testo da usare come testo dell'Email (non viene utilizzato per l'invio di documenti ma solo di stampe generiche) | NumTesto (NumTesto2 ,3)

Server SMTP di invio email

ServerSMTP (2,3)
Tipo del server SMTP (Solo per Cdo) | SMTPtipo (in genere vale 2)
Login per accedere al server SMTP di posta (SOLO per SendMail) | Login (2,3)
Password per accedere al server SMTP di posta. Viene memorizzata criptata e Viene tenuta in memoria fino a quando non si esce dal Menu) (SOLO per SendMail e See) | Pwd
Indirizzo email di chi sta inviando le email | IndEmail (2,3)

Indirizzo opzionale da segnalare per la email di risposta (impostare solo se si vuole che l'eventuale email di risposta arrivi ad un altro indirizzo) (SOLO per SendMail, See e Cdo)

Replay (2,3)
Indirizzo email a cui si invia (possibile memorizzare un max. 3 indirizzi). L'email verrà inviato all'indirizzo che compare nella maschera

Per fatture e documenti in genere: Sui clienti/fornitori sono presenti più indirizzi email utilizzabili. Vedi 'indirizzi email'

 EmailToNum (Numero che indica l'indirizzo email da utilizzare: 1 o 2 o 3)
EmailTo
EmailTo2 - EmailTo3
Indirizzo di email temporaneo valido SOLO per la stampa attuale.
Si può scrivere direttamente o cercare tra gli indirizzi dei clienti con F2 o col pulsante di Aiuto [..]. Se si preme F3 si ottiene un elenco, ordinato per descrizione, di Clienti e Fornitori
Per avere solo i Clienti: C poi F3 , solo i Fornitori: F poi F3
Con F4 si cerca per partita iva - Con F5 per Codice Fiscale
Vedi 'indirizzi email' 		(non viene memorizzato)
Descrizione opzionale dell' email di invio (Centro) - Chi riceve la vedrà precedere l'indirizzo di chi ha spedito la email
(per Sendmail e Cdo) 		Centro (2,3)

Descrizione per l'oggetto dell'email ( SOLO per Sendmail e See)
Può essere una frase 'fissa' o costruita con dei parametri (vedi testo da usare come testo dell'Email)

EmailPersOggetto
Usa SSL per l'invio dell'email
Usa SSL=S se il Server di posta usa SSL (es. Gmail o posta certificata)
(Solo se SEE) 		UsaSSL (2,3)
Directory TUNNEL (obbligatorio se usa SSL, indica dove è stata messa la cartella \Stunnel.
Es. DirTunnel=C:\Stunnel) 		DirTunnel (2,3)
Percorso e Nome del file su cui scrivere il LOG delle email inviate.
Se manca NON viene fatto il LOG (es. c:\LogEmail.txt)
OBBLIGATORIO se invio per email

Solo se necessario, in caso di malfunzionamento con utilizzo di SEE, si può abilitare il parametro: LogSee =S col quale si ottiene il file di log del funzionamento di SEE, il file viene creato nella stessa cartella in cui si è richiesto il file di log delle email: FileLog

FileLog

Se posto a SI, indica se richiedere notifica email ricevuta (default N) (per Sendmail, See e Cdo)

Notifica (2,3)
Abilitare opzione richiesta invio email sulla maschera dei parametri delle stampe | StampeEmail
Descrizione opzionale dell' email a cui si invia; se contiene §Cliente§ viene sostituito con la ragione sociale del cliente
(chi riceve il documento, la vedrà precedere il suo indirizzo di email)
(SOLO per Sendmail - SOLO stampe con modello) 		ToName

Una volta impostati i parametri si possono Confermare con OK e quindi utilizzare finchè non viene chiusa la maschera principale del Menu, oppure:

  • Salva si file INI - Cancella da file INI
    Consente, una volta fatte le opportune scelte di configurazione, di memorizzare/cancellare i parametri spuntati, sull'aziwin.ini del terminale o generale a seconda di quanto specificato in alto nella maschera.
  • Rileggi dati correnti
    Consente, una volta modificati i parametri a video ma non confermati, di rileggere quelli correnti
  • Rileggi da file INI
    Consente di rileggere i parametri dal file ini

Esempio di sezione [Email] dell'aziwin.ini:

[Email]
# Con SenMail
EmailTo=info@aziendapc.it
TipoInvio=S
FileLog=C:\Pippo\LOGFile.txt
IndEmail=bianchi@xxxxxx.com
Centro=Nome_Azienda
SMTPtipo=
ServerSMTP=xxxxxx.it
Replay=
Notifica=N
Login=rossi.mario@xxxxxx.com
StampeEmail=S
NumTesto=0
EmailPersOggetto=
ToName=§Cliente§

#I parametri che finiscono con 2 riguardano la 2’ Configurazione di invio
email
# SEE con SSL (TipoInvio=E)
TipoInvio2=E
IndEmail2=axxx.wwwww@legalmail.it
Centro2=Nome_Azienda
ServerSMTP2=sendm.cert.legalmail.it
Replay2=info@aziendapc.it
Login2=PIPPO
UsaSSL2=S
DirStunnel2=F:\stunnel
EmailTo2=ravagli@xxxxxx.com

#I parametri che finiscono con 3 riguardano la 3’ Configurazione di invio
email
# SEE senza SSL (Tipo Invio=E)
TipoInvio3=E
IndEmail3=info@aziendapc.it
Centro3=Azienda
ServerSMTP3=sira.it
Login3=azienda
EmailTo3=xxx@rrrr.com

Parametrizzazione nome file pdf

Per quanto riguarda il nome dei file Pdf di fatture e documenti in genere vedi parametri per stampa documenti su pdf

Per parametrizzare il nome del file generato da una stampa qualsiasi, si possono utilizzare i seguenti 'parametri' preceduti e seguiti dal carattere: § (Es. §Terminale§). Essi verranno sostituiti rispettivamente come specificato in seguito:

Terminale | Nome del terminale che ha prodotto la stampa
Login | Login di chi ha prodotto la stampa, se definita
Gruppo | Gruppo di chi ha prodotto la stampa, se definito
DescAzie | Descrizione Azienda (Tab.Aziende-Gestione Database aziende)
CodiceAzie | Codice Azienda (Tab.Aziende-Gestione Database aziende)
IdAzienda | Identificativo Azienda (Tab.Aziende-Gestione Database aziende)

Sono inoltre disponibili altri parametri, quale data, ora etc. descritti in Parametri per Testi email.
Nella formazione del nome del file NON vengono messi i separatori nelle date e nell'ora.

Stampa documenti

Vedi anche: Note generali su stampe , Stampe su Modulo , Parametri INI per Pdf ed Email
In questo tipo di stampe, quando si preme il pulsante Selezione destinazione stampa , si può scegliere se fare la stampa su Stampante Laser (a getto) o su File/Stampante ad aghi.

E' possibile personalizzare la stampa di documenti quali Ordini, Preventivi, Ddt, Fatture, Scontrini ed etichette in modo da ottenere moduli con le caratteristiche desiderate dall'utente (inserire loghi, marchi, fincature etc.).
Per impostare i vari modelli (filtri) di stampa occorre eseguire una delle funzioni: Gestione filtri richiamandole dal menu generale premendo i tasti Shift Ctrl Alt L e scegliendole tra quelle proposte.

Qualunque sia il tipo di stampante scelta, è obbligatorio selezionare il modello di stampa.

  • Laser
    Si consente di scegliere se tra stampa a video o su stampante.
    Scelta a video: si consente di variare la dimensione del carattere ed, eventualmente, di memorizzare la stampa.
    Normalmente la stampa a video mostra sequenzialmente le varie pagine una dopo l'altra con possibilità di uscire al termine della visualizzazione di ogni pagina. Se si vogliono rivedere le pagine già visualizzate, cioè si vuole scorrere il testo anche all'indietro, occorre dire di memorizzare la stampa.
  • File/Stampante ad aghi
    Questa scelta consente di stampare, oltre che su stampante, anche su file in formato testo o formato excel.
    Anche per la stampa su file, occorre selezionare un modello di stampa che dovrà essere stato preparato ad hoc tra quelli per stampante ad aghi al fine di rendere leggibile il file generato.

    Inoltre occorre specificare, premendo il pulsante CAMBIA, dove salvare il file generato, con quale nome e scegliere il formato. In 'Salva come (Formato )' si può scegliere tra Caricabile da excel e Testo. Uscendo con Salva da questa maschera si conferma nome e formato. Solo nel caso di formato Testo, si potrà decidere, successivamente, il Separatore dei campi tra: Tabulatore, Punto e Virgola, Virgola, Spazio, il Qualificatore testo (cioè come vengono memorizzati sul file i campi testo) tra: doppio apice, singolo apice, nessuno e se si deve togliere o no il formato dai campi numerici.

Scelta della stampante
Viene visualizzato l'elenco delle stampanti collegate e l'utente può, con un click sulla riga di una di esse, selezionare quella da utilizzare.

Se si utilizzerà, da un terminale, sempre la stampante predefinita, si consiglia di premere il pulsante Stampante Predefinita (nelle Opzioni di stampa verrà sbiancato il nome stampante)

Scelta del modello
Viene visualizzato l'elenco dei modelli(filtri) di stampa predisposti per la stampa e il tipo di stampante selezionato. L'utente può, con un click sulla riga di un modello, selezionare quello da utilizzare.

Cassetto
Se la stampante selezionata ha più cassetti per la carta, è possibile selezionare il cassetto da utilizzare. Vedi parametro di personalizzazione: StampantiNoCassetti

Al fine di mantenere le modalità di stampa selezionate anche per le prossime stampe del documento in oggetto, occorre premere il pulsante: Salva modello.


STAMPE - MODIFICHE

Note sulla possibilità di intervenire sulle stampe standard per:

  • Eliminazione, dall'intestazione standard, la scritta:
    AziendaPc 2.xx
    Si può settare tra i parametri di personalizzazione, il parametro StampaVersione
    Se questo parametro viene impostato a N, la suddetta scritta verrà eliminata dalle stampe.
  • Modifica dei margini di stampa
    Se si vogliono modificare il margine alto, basso, sinistro o destro di una stampa, occorre scrivere nel file aziwin.ini generale (directory aziwin) o del terminale (directory c:\aziwin\main o c:\sira\aziwin\main o c:\windows) una sezione con:
    'nome stampa' e inserire in essa i nuovi 'parametri'.
    Per 'nome stampa' si intende [Chiave+ChiaveSec] (sono i campi della tabella MenuDett in Azimenu.mdb che fanno riferimento alla stampa su cui si vuole intervenire)
    I 'parametri' modificabili sono: MrAlt (margine alto), MrBas (margine basso), MrSin (margine sinistro), MrDes (margine destro).
    Le dimensioni vanno date in millimetri (per separare i decimali occorre mettere la , (virgola)) .
    Esempio per ridurre di 3 cm il margine destro nella stampa del bilancio occorre inserire le righe:
    [CogeStaSbiV]
    MrDes=-30

    Per le stampe con filtro (Ordini, Ddt, Fatture ..) i parametri sono:
    ModMrSin e ModMrDes

    E' possibile inoltre modificare i margini SOLO per le stampe fatte su una stampante particolare (di tipo Laser o a getto), questo si ottiene inserendo, sempre in aziwin.ini un paragrafo:
    [nome_stampante] (Es. [PdfCreator])
    MrSin=x o ModMrSin (se stampa con filtro)
    MrAlt=y
    Dove x e y possono assumere valori positivi o negativi.
    Il 'nome stampante' può essere letto nell'elenco delle stampanti visualizzato premendo, in un qualsiasi programma di stampa, il pulsante "selezione destinazione stampa" (Es.\\PS10DBE9\Printer1)
    Se è presente la sezione di cui sopra e, per una certa stampa anche la sezione precedente (con il nome della stampa) i valori dello spostamento si sommano o si sottraggono.

    Se si vogliono modificare i margini delle stampe documenti, per tutte le stampanti, si possono mettere i parametri ModMrSin, ModMrDes, direttamente nel paragrafo [Opzioni stampa]
  • Modifica del font di stampa
    E' stato implementata la possibilità variare il font di stampa e la sua dimensione e di stampare in bold (grassetto)
    Le informazioni che consentono di fare ciò, vanno scritte nel file aziwin.ini generale (directory aziwin) o del terminale (directory c:\aziwin\main c:\sira\aziwin\main o c:\windows)
    Si possono i font relativi all' intestazione standard (Ragione sociale ditta e versione ed ai campi, in molte stampe.
    Le personalizzazioni possono venire messe:
    • come parametri della singola stampa (creare una sezione [Chiave+ChiaveSec] (sono i campi della tabella MenuDett in Azimenu.mdb che fanno riferimento alla stampa che si vuole modificare)
    • oppure nella sezione [Opzioni Stampa] nel qual caso valgono per quel font per tutte le stampe tranne quelle per le quali è stata inserita la sezione specifica di cui sopra.

Modifica font dell'intestazione standard
L'intestazione standard è costituita dalla scritta: AziendaPc 1.xx (che si può decidere di non stampare) e dalla ragione sociale della ditta.
Nella sezione col nome del programma, scrivere una riga con il parametro FontPersTes, posto uguale al numero totale di fonts che si vogliono personalizzare.
I nomi interni dei font attualmente personalizzabili per l'intestazione sono:
TestaAzienda, TestaData, TestaTitolo, Titolo
Impostare poi le righe per le proprietà:
CodiceFontTesXX=al nome interno del font da personalizzare
dove XX è un numero crescente da 1 fino al valore scritto in FontPersTes
Infine impostare i tre parametri relativi al font scrivendo i parametri ottenuti col nome interno del font seguito dal carattere underline "_" e dalle proprietà Name, Size e Bold.
Se una di queste proprietà non viene inserita rimane il valore predefinito.
Per quanto riguarda la proprietà Bold i valori che si possono inserire sono: true oppure vero oppure S, per indicare che si vuole il grassetto, qualsiasi altro valore indica che il font non è in grassetto.
Es.:
FontPersTes=2
CodiceFontTes1= TestaAzienda
CodiceFontTes2= TestaTitolo
TestaTitolo_Name = Comic Sans Ms
TestaTitolo_Size = 10
TestaTitolo_Bold = true
TestaAzienda _Name = Courier New
TestaAzienda _Size = 8
TestaAzienda _Bold = true

Modifica font del corpo della stampa:
usare le proprietà FontPersCor per indicare il numero di font
CodiceFontCorXX per i nomi interni dei font
I nomi interni dei font attualmente personalizzabili per il corpo, sono:
CorpoLab, CorpoLab2, CorpoCampo, CorpoLabComp, CorpoCampoComp, FontLargFix
Esempio di personalizzazione dei font in Stampa Listino articoli
[stmgco1List]
FontPersCor=1
CodiceFontCor1=CorpoCampo
CorpoCampo_Name=Comic Sans Ms
CorpoCampo_Size=10
CorpoCampo_bold=Vero

Es. di person. della stampa: Segnalazione saldo estratto conto
[CogeStaSEsC]
FontPersCor=1
CodiceFontCor1=CorpoCampo
CorpoCampo_Size=12

Nella versione 1.14C della procedura è stata inserita nel database del menu, la tabella dei font personalizzati per cui si possono sostituire le 3 righe: CorpoCampo_Name , .._Size, .._Bold con un'unica riga: CorpoCampo_Progr=ZZ dove ZZ è il numero contenuto nella campo 'progressivo' della riga corrispondente al font desiderato, presente nella suddetta tabella. (La tabella è gestibile dal menu premendo i tasti Ctrl Alt Shift L e scegliendo la funzione: Font personalizzati).


STAMPE SU MODULO

Nelle stampe fatte su un modulo particolare cioè diverso dal foglio bianco standard (Ddt, Fatture etc.) è obbligatorio far riferimento a un 'modello o filtro' di stampa. Ci saranno uno o più filtri per la stampa DdT, per la stampa fattura etc.
I filtri cambiano al cambiare del tipo di stampante, ad esempio, per la stessa stampa, ci saranno filtri predisposti per le stampanti laser, altri per quelle ad aghi.

Alcuni di questi modelli vengono forniti con i programmi ma possono essere modificati dall'installatore o ne possono essere creati di nuovi tramite la funzione di Gestione Filtri (Shift-Ctrl-Alt L dal Menu)

I vari 'filtri' di stampa creati, vengono memorizzati sul Data Base del menu e sono individuati da un nome e una descrizione.

Nella maschera di richiesta di stampa di un programma che prevede la stampa su modulo particolare, si può notare che in basso a sinistra oltre ad essere evidenziata quale stampante si sta utilizzando, viene specificato anche il 'modello' utilizzato.

E' possibile definire dei parametri per postare i margini sinistro e alto, nelle stampe dei moduli, su una stampante laser (o a getto) particolare.
Se c'è questa necessità, occorre creare nel file AziWin.ini (quello del terminale o il principale) una sezione con il nome della stampante e i nuovi margini.

Premendo il pulsante Seleziona destinazione di stampa, si apre una maschera con le seguenti richieste:

Tipo stampa doc: è possibile scegliere se stampare su:

  • Laser (o a getto d'inchiostro) utilizzando caratteri proporzionali
  • File/Stampante ad Aghi, utilizzando caratteri a lunghezza fissa

La prima volta che si entra in un programma di stampa che prevede l'utilizzo di un modello particolare, verrà chiesto di selezionare la stampante e il filtro (modello).

Qualsiasi sia il tipo di stampa scelto, verranno visualizzati, in alto, la stampante e l'eventuale modello attivi in quel momento. Segue un elenco delle stampanti collegate e dei 'modelli' disponibili per quel tipo di stampa. Si potrà scegliere una stampante e un modello con un semplice click sulla riga corrispondente.

Prima di chiudere la maschera si può premere il pulsante, in basso a sinistra: SALVA MODELLO per salvare la configurazione scelta e renderla 'predefinita' in modo che rientrando nel programma venga proposta direttamente.

Se invece si sceglie CANCELLA MODELLO, verrà cancellato dall'INI il nome del modello precedentemente salvato come 'predefinito' e se si esce e rientra nella stampa sarà obbligatorio scegliere di nuovo il modello.

Note su come il programma come cerca il nome del modello da utilizzare:

Se il nome del Modello è sul 'Tipo documento' del documento da stampare: si controlla che esista il modello sul DataBase del menu e si stampa sulla stampante di default se non specificata sull' aziwin.INI altrimenti si usa quella dell'INI

Se non c'è il nome del Modello sul 'Tipo documento' del documento da stampare e .INI vuoto: alla scelta Stampa viene dato un messaggio di scegliere il modello e memorizzarlo all'uscita in modo che venga scritto nell' .ini del terminale

Quando si stampano più documenti insieme, occorre che essi abbiano lo stesso modello di stampa.
Se non si imposta niente in DA .. viene mantenuto il modello predefinito, se si lascia vuoto il campo Tipo documento A: esso viene posto uguale al Tipo documento DA

Se il programma da un messaggio del tipo: 'Modello … non esiste' e sul DataBase sono stati messi dei modelli di stampa e ne è stato già selezionato uno, si dove controllare cosa c'è scritto sul campo 'con modello' sul Tipo documento da stampare (potrebbe esserci finito un carattere strano!)


FILTRI DI STAMPA

Tramite i 'filtri o modelli' è possibile definire dei tracciati di stampa personalizzati per i documenti quali conferme d'ordine, preventivi, ddt, fatture, ricevute fiscali e anche per le etichette.

I filtri cambiano al cambiare del tipo di stampante ed è per questo che, per la stessa stampa, ci saranno filtri diversi per le stampanti laser e stampanti ad aghi, predisposti da due programmi di gestione diversi ai quali si accede dal menu premendo contemporaneamente i tasti CTRL ALT SHIFT L e scegliendo, tra quelli proposti, rispettivamente:
Gestione filtri stampanti Laser
Gestione filtri stampanti Aghi

Alcuni di questi modelli vengono forniti con i programmi e possono essere modificati dall'installatore, oppure ne possono essere creati di nuovi tramite le funzioni suddette.

I filtri di stampa vengono memorizzati nel database del menu: azimenu.mdb (presente nella cartella ....\aziwin) in particolare nelle tabelle StaLasTes e StaLasCampi (per le stampanti Laser) e StaModTes e StaModCampi (per le stampanti ad aghi).
Sono perciò utilizzabili da tutte le aziende gestite. Se si creano o si modificano dei filtri di stampa, si raccomanda di fare sempre la copia del database del menu per poter riprendere i filtri nell'eventualità ci siano problemi sul database originale.

Per quanto riguarda le stampe dei documenti delle Vendite (Ddt, Ricevute Fiscali, Fatture) il modulo di stampa viene diviso idealmente in tre parti: testa (contiene in particolare i dati anagrafici del destinatario), Corpo (contiene in particolare le righe con articoli o le prestazioni) e Piede (contiene i dati finali es. Totali).

Per come utilizzare nei programmi di stampa, un filtro esistente, fare riferimento a Stampe su modulo.

Per consultare l'elenco dei campi disponibili per realizzare un modello per le stampe dei documenti si rimanda a:
Preventivi, Ordini Acquisto - Vendita (filtri di stampa)
Ddt (filtri di stampa)
Fatture (filtri di stampa)

Vedere anche:
Database di personalizzazione codice SottoSezione
Sintassi ammesse in "campo"

NOTE VARIE

In caso di mancata stampa del simbolo dell’Euro su stampante laser si può provare a modificare l’impostazione della stampante in modo da inviare i tipi di carattere TrueType come caratteri bitmap trasferibili, come si vede nell’esempio :


FILTRI PER STAMPANTI LASER

Percorso: dal menu principale: Shift-Ctrl-Alt L

Vedi anche Filtri e Stampe su modulo

Per la compilazione di un filtro occorre impostare prima alcune caratteristiche generali poi elencare, nel particolare, tutti i campi, le immagini, le fincature che si vogliono stampare nelle tre sezioni in cui un modulo si compone: Testa, Corpo e Piede.
Inoltre, con il pulsante [image] (Y) Trasferimento Filtri, è possibile 'importare' un filtro da un altro Data Base, purchè esso non esista già, sul DB di destinazione, come nome programma e modello.
Se si vuole cambiare nome al filtro da caricare, possono scrivere, prima di confermare il trasferimento, il nuovo nome di Programma e Modello.

Il tipo di font utilizzato di default è l’Arial mentre l’altezza del carattere si può personalizzare per ogni campo.
Tutti i valori, salvo dov’è specificato diversamente, sono in millimetri.

Nel modello per Laser: nella testa, per la stampa del logo si fa riferimento, nel campo ‘campo’ a aziendapc.jpg, questo file viene installato in ….\aziwin\immagini e dovrà essere sostituito con il nome del file gif (o .bmp) contenente il logo del cliente.

Elenco campi generali del documento

Programma
Nome del programma di stampa

  • StaDdtSDdt (Ddt),
  • StaFatSFaa (Fattura accompagnatoria),
  • StaFATSFat (Fattura diretta e riepilogativa),
  • StaOrdSAcq (Conferma d'ordine di Acquisto),
  • StaOrdSOrd (Conferma d'ordine di Vendita),
  • StaOrdSpre (Preventivo)

Modello
descrizione libera che individua i vari modelli di stampa impostati per lo stesso programma

Descrizione
Descrizione della stampa.

Spazio vuoto da lasciare in Testa
Sposta tutta la stampa in basso.

Spazio a disposizione per il corpo.
(SpzCorpo)
Si consiglia di inserire un multiplo del numero inserito in altezza riga di dettaglio (AltDettaglio) Posizione verticale in cui si inizia a stampare il corpo del documento. Lo spazio posto sopra a questa posizione è tutto riservato alla testata.

Spazio a disposizione per il corpo per le pagine successive alla prima.
(SpzCorpo2)
Se non specificato si assume uguale a quello della prima pagina (SpzCorpo).
YiniCorpo2 Posizione verticale in cui s’inizia a stampare il corpo del documento per le pagine successive alla prima. Se non specificato si assume uguale a quello della prima pagina (YiniCorpo)

Valore utilizzato per sfondi grigi (da 0 a 255)
 0= Nero, 255=Bianco. Valore predefinito: 220.

Valore utilizzato per le ombre dei rettangoli (da 0 a 255)
(ValNero)
0= Nero, 255=Bianco. Valore predefinito: 0.

Barrare il corpo
(BarroCorpo)
Se = "S" La parte del corpo non utilizzata viene barrata.

Margine sinistro del corpo da cui far partire la barratura
(BarroX1)
Punto in cui inizia la "barratura".

Margine destro del corpo da cui far partire la barratura
(BarroX2)
Punto in cui finisce la "barratura".

Altezza della "riga di dettaglio"
(AltDettaglio)
Per "riga di dettaglio" si intendono le righe contenute nel corpo del documento: righe articolo e note.

Orientamento
Orientamento del foglio:

  • Verticale (vbPRORPortrait)

  • Orizzontale (vbPRORLandscape)

Altezza delle altre righe di dettaglio
(AltDettaglioAltri)
Altezza della riga di dettaglio da usare per le righe diverse dai dettagli "articolo" (es. note) Se bianco viene usato AltDettaglio.

Una volta confermati i dati della testata, si possono gestire le tre parti del modello accedendo tramite uno dei seguenti pulsanti:

  • Testa [image] (T)
  • Corpo [image] (E)
  • Piede [image] (X).
Sotto sezione
(SottoSez)
Normalmente =0 Nella definizione della riga del corpo del documento viene utilizzato per distinguere una riga normale contenente un articolo (0 = corpo normale) da una descrittiva (1 = corpo per riga descrittiva).
Il piede con sottosezione = 0 è il piede normale alla fine del documento mentre con sottosezione =1 si individua il piede delle pagine intermedie.
E’ possibile definire un parametro di personalizzazione: FineCorpo che contiene una lista di sottosezioni del corpo documento (Es. M0,M1,M2) da stampare alla fine della stampa dei dettagli per righe con contenuto particolare.
Sul filtro, si dovranno creare righe opportune con sottosezione rispettivamente M0,M1 etc.).
Vedi Sottosezioni

PosY
Distanza verticale in millimetri dalla riga precedente, della posizione in cui verrà stampato il campo.
Per le testate, dal margine superiore del foglio,
per i dettagli, dal margine superiore della riga attuale in stampa,
per il piede, dalla fine del corpo.
Questo campo insieme con PosX stabilisce l’ordine con cui vengono elaborati i campi di stampa. Si può mettere anche valori negativi per eseguire dei calcoli prima di una sezione.

PosX
Distanza in mm dal margine sinistro del foglio, della posizione in cui verrà stampato il campo. Questo valore insieme con PosY stabilisce l’ordine con cui vengono elaborati i campi di stampa.
Il programma calcola le coordinate del campo da stampare sottraendo al valore di PosX e PosY rispettivamente il valore di LinX e LinY (che nelle righe non grafiche hanno, solitamente, valore 0).
Questo poiché i due campi PosX e PosY sono indici e non possono essere inserite nel filtro più righe con gli stessi valori. Se si rende necessario avere due o più campi da stampare nella stessa posizione, in alternativa, si possono inserire, ad esempio, con valori progressivi di PosY e in uno dei due mettere in LinY quel valore che, sottratto al PosY da il PosY giusto.

Opzione
Indica il tipo di riga

  • 0 : campo normale
  • 1 : da non stampare (utilizzato per righe che contengono calcoli che vanno ad assegnare una variabile).
  • 2 : riga di commento (il campo non verrà né elaborato né stampato)

Larghezza
Larghezza, in millimetri, a disposizione per la stampa del campo. Se la larghezza è uguale a zero il campo non viene stampato, ma la riga del modello rimane valida per qualsiasi elaborazione. (Al contrario che opzione = 2 che esclude la riga del modello da qualsiasi elaborazione).

Campo
Riferimento al campo di stampa. Per consultare l'elenco dei campi disponibili consultare:
Preventivi, Ordini Acquisto - Vendita (filtri di stampa)
Ddt (filtri di stampa)
Fatture (filtri di stampa)

Oltre al nome di un campo, in questa casella si può inserire anche un test etc. Vedi “Sintassi ammesse in CAMPO”

Multiriga
Da utilizzare per la stampa dei campi Memo
Se viene posto ad "S" e lo spazio a disposizione non è sufficiente per la stampa del campo, la parte rimanente del campo viene stampata nella prossima occorrenza dello stesso Campo con Multiriga = “S”. Il campo nel filtro, va ripetuto per tante righe quante se ne voglio stampare, sempre con multiriga=S
Se il campo con Multiriga = “S” è nel dettaglio, la stampa del campo prosegue nel dettaglio successivo, fino alla stampa completa del campo (es.: una ‘descrizione lunga articolo’ che non si riesce a stampare nello spazio ad essa assegnato perché più lunga).

NoStaVuoto
Se è ="S", non stampa i campi vuoti. (se data = null o data = 1/1/100 o numerico = 0) Attenzione, se si mette questo campo =S in righe che stampano delle linee, queste linee non verranno stampate (se il campo è vuoto viene saltata tutta la fase di stampa del campo).

Fisso
Stringa fissa in alternativa al campo.

Formato
Espressione stringa che rappresenta il formato di stampa in alternativa a quello standard del campo. Nel caso in cui si metta direttamente il formato esso va messo tra virgolette e la notazione dei separatori dei decimali e delle migliaia è quella anglosassone ( . = separatore dei decimali ; , = separatore delle migliaia)
Si può utilizzare anche una variabile messa a disposizione dal programma:

  • Feuro per il formato di un importo in Euro (x,xx)
  • FLire, per il formato di un importo in Lire
  • FQua per il formato delle quantità (FquaG stampa tutti i decim. Es. 1,10 – 2,00)
  • FEuroG per il formato dell’ Euro utilizzando il numero di decimali che sono stati impostati sulla moneta in "nr.decimali gestione"
  • FLireG, per il formato delle Lire utilizzando il numero di decimali di gestione
  • FMon per il formato della moneta del documento
  • FMonG per il formato della moneta utilizzando il numero di decimali di gestione

Esempi di formati:

  • con separatore di migliaia e un decimale da stampare sempre anche se a 0: “#,##0.0”
  • con separatore di migliaia ma senza la stampa delle cifre decimali che sono a 0: "#,##0.##"
  • con separatore di migliaia ma senza la stampa, oltre che delle cifre decimali che sono a 0, anche della parte intera se vale 0: #,###.##
  • per riempire di zeri a sinistra un campo: “00000” (Es. colli nei Ddt)
  • per utilizzare il formato dell’Euro con un decimale in più: Union(FEuro;”0”)

In alternativa si può utilizzare un formato multiplo es. "#,##0.00;;#" che contiene 3 formati diversi separati da ;
I tre formati sono rispettivamente quello per i positivi, quello per i negativi, quello per gli importi a 0. Se si omette quello per i negativi, essi verranno stampati con lo stesso formato dei positivi.

Per i campi di tipo "Ora", nei filtri consegnati come esempio, è stata messa la \ davanti ai : che separano le ore dai minuti ("hh\:nn"), in modo da forzare sempre la stampa dei : anche se nelle impostazioni del computer tale separatore fosse stato lasciato a . (punto).

Allineamento
S = Sinistra, D = Destra, C = Centrato. Al campo in stampa vengono tolti i caratteri bianchi iniziali, se si vogliono lasciare, si può inserire F in questo campo.

FontSize
Grandezza Font.

Grassetto
Se è = "S", stampa in grassetto.

Italico
Se è = "S", stampa in Italico.

Linea
Dovrà essere impostato = "S" per la stampa di un elemento grafico (linee o rettangoli con caratteristiche specificate in LinX, LinX1 etc).
In questo caso i valori precedenti, da larghezza a italico, verranno ignorati
altrimenti, verranno ignorati, i valori seguenti.

Se è impostato = “C” serve per impostare i colori da usare da quel momento in poi, finchè non viene cambiato o ripristinato al valore di default usando un'altra riga con valore Linea = “C”.
Il colore da usare, espresso in modalità RGB cioe’ Rosso/Verde/Blu viene messo in Campo con le seguenti possibilità:

  • Valore esadecimale corrispondente al colore da impostare (es. &HFF00 = verde)
  • Valore numerico da 0 a 16.277.215 indicante il colore da usare (es. 255 = rosso)
    Per ottenere questo valore dal codice RGB (X Y Z) si procede come segue:
    X + (Y*256) + (Z*256*256)
  • Stringa costante identificante uno degli otto colori di base.
    I valori riconosciuti sono: Azzurro, Bianco, Blu, Giallo, Magenta, Nero, Rosso, Verde

Per ripristinare il colore di default, cioè il colore impostato automaticamente nella stampante all’inizio della stampa, dovrà essere inserita un'altra riga con il campo "Linea" valorizzato a C e il campo "Campo" impostato con uno dei seguenti valori: default, def, standard, std.

Se è impostato = “G”, la riga riguarda la stampa di una immagine grafica da file, il cui nome, ed eventualmente il percorso, è specificato in "Campo" come stringa.
Utilizzato per la stampa del logo della ditta (es. il contenuto del campo "Campo" può essere: =$”aziendapc.jpg”) o la stampa dell'immagine collegata all'articolo sui documenti.
La posizione di stampa è specificata dalle coppie LinX , LinY e LinX1 , LinY1.

Con LinX1 e LinY1 negativi, l’immagine verrà stampata con le dimensioni originali.
I formati grafici supportati sono: bmp, gif, jpg.
Se in "Campo" non è scritto, oltre al nome del file dell'immagine anche il percorso in cui esso si trova, il programma lo cerca là dove specificato nel file aziwin.ini in DirImmagini (di default: ....\aziwin\immagini):
[Base]
DriveDb= ………
DirImmagini=…………

LinDrawWidth
Larghezza della linea in pixel. (Dipende dalla risoluzione della stampante)

LinX , LinY
Vanno valorizzate nelle righe in cui è a S il campo Linea. Se linea =N si può mettere un valore e il programma sottrae dal contenuto di POSX e POSY questo valore (serve per inserire nel filtro campi diversi che vanno stampati, su condizione, nello stesso posto ma mettendo PosX e PosY uguali da errore di indice doppio)

Coordinate di partenza della linea.
Per testate sono relative al margine superiore del foglio.
Per i dettagli sono relative margine superiore della riga attuale in stampa.
Per il piede sono relative alla fine del corpo.

LinX1 , LinY1
Coordinate d’arrivo della riga.

LinBox
Se = "S" la stampa è di un rettangolo. Si possono stampare rettangoli anche nel corpo e anche "con ombra".

LinGrigio
Se = "S" stampa lo sfondo Grigio (Solo se linBox = "S")

LinOmbra
Se = "S" stampa l'ombra (Solo se linBox = "S")


FILTRI PER STAMPANTI AD AGHI

Percorso: dal menu principale: Shift-Ctrl-Alt L

Vedi anche Filtri e Stampe su modulo

Per la compilazione di un filtro occorre impostare prima alcune caratteristiche generali poi elencare, nel particolare, tutti i campi, le immagini, le fincature che si vogliono stampare nelle tre sezioni in cui un modulo si compone: Testa, Corpo e Piede.
Inoltre, con il pulsante [image] (Y) Trasferimento Filtri, è possibile 'importare' un filtro da un altro Data Base, purchè esso non esista già, sul DB di destinazione, come nome programma e modello.
Se si vuole cambiare nome al filtro da caricare, possono scrivere, prima di confermare il trasferimento, il nuovo nome di Programma e Modello.

Tutti i valori, salvo dov’è specificato diversamente, sono in Righe e Colonne (caratteri)

Elenco campi generali del documento

Programma
Nome del programma di stampa

  • StaDdtSDdt (Ddt),
  • StaFatSFaa (Fattura accompagnatoria),
  • StaFATSFat (Fattura diretta e riepilogativa),
  • StaOrdSAcq (Conferma d'ordine di Acquisto),
  • StaOrdSOrd (Conferma d'ordine di Vendita),
  • StaOrdSpre (Preventivo)

Modello
descrizione libera che individua i vari modelli di stampa impostati per lo stesso programma (es. SiraStd,)

Descrizione
Descrizione della stampa.

Righe per pagina
Numero di righe della pagina di stampa

Righe vuote prima di stampare la testata
Numero righe lasciate vuote prima di iniziare a stampare il documento

Riga inizio stampa del corpo
Riga in cui iniziare la stampa del corpo del documento. (Lo spazio sopra è a disposizione per la testata)

Righe per il Corpo
Numero di righe a disposizione per il corpo

Riga inizio stampa corpo (per pagine successiva alla prima)
Riga in cui s’inizia a stampare il corpo del documento nelle pagine successive alla prima. Se non specificato prende la posizione specificata per la prima pagina.

Righe Corpo pagina successiva alla prima
Numero di righe a disposizione per il corpo per pagine successive alla prima. Se non viene specificato si prende il parametro assegnato per la prima pagina

Righe occupate dal Dettaglio
Indica quante righe occupa un unico dettaglio nel corpo. In generale una riga del corpo (riga articolo o riga manuale) occupa ‘una riga’ di stampa, volendo stampare una riga sì e l’altra no (quindi i dettagli spaziati) si può mettere che ne occupa due.

Righe occupate da altri tipi di dettaglio
Se impostato, serve a stampare le righe di dettaglio diverse dagli articoli, note etc, con un numero di righe diverse rispetto il dettaglio normale.

E' possibile impostare fino ad un massimo di 10 righe contenenti i codici di attivazione e disattivazione per la stampa in grassetto, compressa etc.
Nelle righe di definizione dei campi di Testa, Corpo, Piede si potrà stampare uno o più campi, ad esempio in grassetto, facendo riferimento, in opportune caselle, al numero di riga in cui sono stati scritti, sulla testata, i caratteri per abilitazione e disabilitazione del grassetto.

Per ogni riga si chiede di specificare:

  • Descrizione (DesCodConxx) della sequenze di codici di controllo (Es. grassetto, compresso)

  • Sequenza di codici di controllo (Attivazione)
    In forma decimale separati dalla virgola (CodConInixx)
    eseguita prima della stampa del campo in cui verrà richiamata.
    Es. per grassetto: 27,69 Es. per compresso: 15

  • Sequenza di codici di controllo (Disattivazione). In forma decimale separati dalla virgola. (CodConFinxx)
    eseguita dopo la stampa del campo in cui verrà richiamata
    Es. per grassetto: 27,70 Es. per compresso: 27,70

Barrare parte corpo non utilizzata
Se = "S" la parte del corpo non utilizzata viene barrata (da utilizzare per barrare i Ddt) e si chiede di specificare:
Margine sinistro dal quale iniziare a barrare
Colonna di margine sinistro del corpo dalla quale iniziare a barrare.
Margine destro fino alla quale barrare
Colonna di margine destro del corpo fino a cui barrare.

Una volta confermati i dati della testata, si possono gestire le tre parti del modello accedendo tramite uno dei seguenti pulsanti:

  • Testa [image] (T)
  • Corpo [image] (E)
  • Piede [image] (X)

SottoSez
Sotto sezione. Normalmente = 0. Nella definizione della riga del corpo del documento viene utilizzato per distinguere una riga normale contenente un articolo (0 = corpo normale) da una descrittiva (1 = corpo per riga descrittiva).
Il piede con sottosezione = 0 è il piede normale alla fine del documento mentre con sottosezione =1 si individua il piede delle pagine intermedie.
E’ possibile definire un parametro di personalizzazione: FineCorpo che contiene una lista di sottosezioni del corpo documento (Es. M0,M1,M2) da stampare alla fine della stampa dei dettagli per righe con contenuto particolare.
Sul filtro, si dovranno creare righe opportune con sottosezione rispettivamente M0,M1 etc.).
Vedi Sottosezioni

PosY
Riga per per testate, dal margine superiore del foglio, per i dettagli, dalla riga attuale in stampa, per il piede, dalla fine del corpo, in cui viene stampato il campo.
Questo campo insieme con PosX stabilisce l’ordine con cui vengono elaborati i campi di stampa. Si può mettere anche valori negativi per eseguire dei calcoli prima di una sezione.

PosX
Colonna in cui viene stampato il campo.
Questo campo insieme con PosY stabilisce l’ordine con cui vengono elaborati i campi di stampa.

Opzione
Indica il tipo di riga.
0 = campo normale.
1 = da non stampare (utilizzato per righe che contengono calcoli che vanno ad assegnare una variabile).
2 = riga di commento. Il suo contenuto verrà completamente ignorato.

Larghezza Numero dei caratteri da stampare nel campo.
Se la larghezza è uguale a zero il campo non viene stampato, ma la riga del modello rimane valida per qualsiasi elaborazione. (Al contrario che opzione = 2 che esclude la riga del modello da qualsiasi elaborazione).

Campo
Riferimento al campo di stampa. Per consultare l'elenco dei campi disponibili consultare:
Preventivi, Ordini Acquisto - Vendita (filtri di stampa)
Ddt (filtri di stampa)
Fatture (filtri di stampa)

Oltre al nome di un campo, in questa casella si può inserire anche un test etc. Vedi “Sintassi ammesse in CAMPO”

MultiRiga
Se è = "S" e lo spazio a disposizione non è sufficiente per la stampa del campo, la parte rimanente del campo viene stampata nella prossima occorrenza dello stesso Campo con Multiriga = “S”. Il campo nel filtro, va ripetuto per tante righe quante se ne voglio stampare, sempre con multiriga=S
Solo se il campo con Multiriga = “S” è nel dettaglio, la stampa del campo prosegue nel dettaglio successivo, fino alla stampa completa del campo. Da utilizzare per la stampa dei campi Memo

NoStaVuoto
Se è ="S", non stampa i campi vuoti. (es.data = null o data = 1/1/100 o numerico = 0 )
Attenzione: se si mette questo campo =S in righe che stampano delle linee, queste linee non vengono stampate (se il campo è vuoto viene saltata tutta la fase di stampa del campo).

Fisso
Stringa con un contenuto fisso (una parola o una frase). Da compilare In alternativa al campo "campo".

Formato
Espressione stringa che rappresenta il formato di stampa in alternativa a quello standard del campo. Nel caso in cui si metta direttamente il formato esso va messo tra virgolette e la notazione dei separatori dei decimali e delle migliaia è quella anglosassone ( . = separatore dei decimali ; , = separatore delle migliaia)
Si può utilizzare anche una variabile messa a disposizione dal programma:
Feuro, per il formato di un importo in Euro
FLire, per il formato di un importo in Lire
FQua, per il formato delle quantità
FEuroG, per il formato dell’ Euro utilizzando il numero di decimali di gestione
FLireG, per il formato delle Lire utilizzando il numero di decimali di gestione
FMon, per il formato della moneta del documento
FMonG, per il formato della moneta utilizzando il numero di decimali di gestione

Es. formato con separatore di migliaia e un decimale: “#,##0.0”
oppure per riempire di zeri a sinistra un campo es. colli nei Ddt: “00000”
oppure per utilizzare il formato dell’Euro: FEuro
oppure per utilizzare il formato dell’Euro con un decimale in più: Union(FEuro;”0”)

Allineamento
S = Sinistra, D = Destra, C = Centrato.

CodConPri
Sequenza di codici di controllo da stampare prima del campo

CodConDop
Sequenza di codici di controllo da stampare dopo il campo

Nel caso che alcuni campi del dettaglio vengano stampati in compresso (es. la descrizione articolo) la PosX dei campi successivi non rappresenta la posizione in assoluto della colonna di stampa. (Come invece avviene nel caso in cui si usi sempre la stessa dimensione di carattere). Nel caso in cui si voglia ottenere lo stesso posizionamento in righe che non hanno il campo in compresso, bisogna inserire la stampa di un campo vuoto al posto di quello compresso, con le stesse caratteristiche di quello inserito nei dettagli normali.


PREVENTIVI - ORDINI ACQUISTO E VENDITA (CAMPI PER FILTRI DI STAMPA)

ATTENZIONE

Nei formati di stampa il dettaglio per riga di fine corpo è obbligatorio nel caso in cui si stampino documenti con importi ivati e/o con dichiarazione d’intenti; per consentire di stampare rispettivamente la frase:
"Gli importi del corpo sono comprensivi di Iva" e/o
gli estremi della lettera di intenti.
Se non si vuole stampare la frase riguardante i prezzi ivati, si può creare il parametro di personalizzazione NoDescPrezziIvati.

Nel formato per Dettaglio per riga di fine corpo, (sottosezione 1 o 7) il campo C_RigDesArt deve essere multiriga per permettere la stampa completa di importanti informazioni. Per evitare lo spreco di spazio nel documento è consigliabile che il campo C_RigDesArt sia il più largo possibile cioè, su questa riga del filtro, la "Larghezza" dovrà contenere un numero che consenta di occupare l'intera larghezza del modulo.
(Vedere anche (**) in fondo al paragrafo).

Per riferirsi all’interno di "Campo" o all’interno di formule, direttamente ai campi del database si deve osservare la seguente sintassi:

sez.tabella.campo
Per sez si intende di quale sezione (recordset) si vuole leggere il valore:
T = Testata (recordset che contiene tutti i campi relativi alla testata)
C = Corpo (recordset che contiene tutti i campi relativi al dettaglio)
S = Spese (recordset che contiene tutti i campi relativi alle righe di spese)
D = Decodifiche (recordset che contiene tutte le decodifiche della testata)
M = Campi letti dalle tabelle del menù (vedi ggMenCli.ovMenuParam() )

Coge. | TabCoGe
Mag. | TabMagazzino
Fat. | TabFatt
Cla. | ArtClassi
PdcCla. | PdcClassi
RegCassa. | TabReg
CauCon. | TabCauCon
Ditta. | Ditta
Demo | Flag interno procedura (Se è in demo)
Descazie | Descrizione della azienda in gestione
osVersion |
osBild |
osPlatform |

Per tabella si intende il nome della tabella da cui vogliamo leggere il valore (che deve essere tra quelle estratte nella sezione).

Per campo si intende il campo della tabella del quale si vuole leggere il valore.
Es. T.DdtTest.PreDoc per stampare il prefisso documento
T.Banche.Agenzia per stampare l’agenzia della banca d’appoggio

In pratica con:
T. (C. o P.)
si indicano i campi della testata (del Corpo o del Piede) del documento (così come vengono memorizzati in tabella: DdtTes, FatTest , DdtDett …etc.)

I campi di tipo T. vanno seguiti dal nome della tabella dalla quale prendere i dati e dal nome del campo:
es. per stampare il codice iva nel dettaglio del Ddt si deve scrivere in nome campo: C.DdtDett.Iva

Con T_ (C_ o P_) si indicano le variabili della testata (del Corpo o del Piede), elaborate (preparate) dal programma.

E’ possibile impostare il parametro di personalizzazione CampiStAggDec
per aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa.

Campi (variabili) elaborati dal programma:

Per la testata / piede:

T_NumDoc | Numero documento
T_Descrizione | (Solo per gli acquisti) è la descrizione dell acquisto. Se non viene messa nel singolo acquisto viene letta dalla tabella acquisti.
T_CodCli | Codice cliente
T_CliRagSoc | Ragione sociale del cliente o dell’indirizzo di spedizione.(Quando nell’indirizzo di spedizione c’è il flag IndSped.IndPrincDdt = “S” l’indirizzo di spedizione prende posto di quello del cliente e viceversa. Ciò è valido anche per tutti i campi del cliente o dell’indirizzo di spedizione che seguono.
T_RagSoc2 | Seconda parte della ragione sociale del cliente o dell’indirizzo di spedizione
T_CAP | Cap del cliente (o dell’indirizzo di spedizione)
T_Localita | Località del cliente (o dell’indirizzo di spedizione)
T_Pr | Provincia del cliente (o dell’indirizzo di spedizione)
T_Comune | Comune del cliente (o dell’indirizzo di spedizione)
T_Stato | Stato del cliente (o dell’indirizzo di spedizione)
T_CapLocPr | Cap, Località e Provincia insieme
T_Stato | Stato del cliente (o dell’indirizzo di spedizione)
T_SpedRagSoc | Ragione sociale di spedizione
T_SpedRagSoc2 | Seconda ragione sociale di spedizione
T_SpedIndir | Indirizzo di spedizione
T_SpedCAP | Cap di spedizione
T_SpedLocalita | Località di spedizione
T_SpedPr | Provincia di spedizione
T_SpedComune | Comune di spedizione
T_SpedStato | Stato di spedizione
T_SpedCompleto | Tutto l’indirizzo di spedizione in un unico campo
T_AmmIndir | Indirizzo amministrativo
T_Nota | Note di testata del documento
T_IsoPIva | Partita I.V.A. con eventuale codice ISO. Se la partita Iva è vuota contiene il codice fiscale
T_PariEuroLireDes | Restituisce “Pari euro: ” se fattura in lire, “Pari lire:” se fattura in euro, niente se fattura in valuta.
T_PariEuroLire | Restituisce il totale fattura in euro se fattura in lire, il totale fattura in lire se fattura in euro, niente se fattura in valuta
T_NumCopieTot | Numero copie totali richieste in stampa
T_NumCopieCor | Numero della copia corrente in stampa

Campi relativi del piede

T.TotMerce | Totale merce
T_TotImponibile | Totale imponibile
T_TotEsente | Totale esente
T_TotEsenteNoBolli | Totale esente senza l'event. importo dei bolli tratta
T_TotSpese | Totale spese
T_TotImpOmaggi | Totale imponibile omaggi su cui si paga l'iva
T_TotDoc | Totale documento Se nel filtro non esiste nessuna riga del piede che stampa questo totale, verrà scritta a fine corpo una riga con il Totale documento. Se NON si vuole stampare il totale MAI, basta mettere nel piede una riga con la stampa del Totale e con il campo Larghezza posto a 0.
T_TotIva | Totale Iva
T_TotBolli | Totale Bolli
T_Abbuono | Totale abbuono
T_Acconto | Totale acconto
T_RitAcc | Importo della Ritenuta d’acconto (se si vuole stampare questo importo nel corpo occorre inserire nel filtro una riga con sottosezione 30, 'Campo' : T_RitAcc e 'Fisso': Ritenuta d'acconto in base alla legge ...) stampata nello spazio della descrizione poi un'altra riga con questa variabile in Campo, da stampare nello spazio dell'importo
T_RitAccS | Importo della Ritenuta d’acconto formattato (xxx.xxx,xx)
T_ImponRitAcc | Imponibile per il calcolo della Ritenuta d’acconto
T_ImponRitAccS | Imponibile per il calcolo della Ritenuta d’acconto formattato (xxx.xxx,xx)
T_TotPagare | Totale pagare (tot documento – abbuono – acconto)
T_RagSocVett | Ragione sociale del vettore
T_IndirizzoVett | Indirizzo vettore
T_LocalitaVett | Località vettore
T_Spese_XX | Cassa Previdenza. Si può stampare nel corpo oppure nel piede mettendo in campo T_Spese_XX dove XX è il carattere definito nella tabella spese in 'identificativo per stampa'. Si possono inoltre usare le variabili:
T_PercCassaPrev | Percentuale della spesa Cassa Previdenza (T_PercCassaPrevS campo formattato)
T_TotCassaPrev | Importo della cassa previdenza (T_TotCassaPrevS campo formattato)

Dati per l’I.V.A.
Nel nome campo al posto di 00 si mette da 01 a 99.

T_Iva00Iva | Codice iva
T_Iva00Descrizione | Descrizione dell’ iva (o dell'esenzione)
T_Iva00Aliquota | Aliquota
T_Iva00Impon | Imponibile
T_Iva00Impos | Imposta
T_Iva00AliqODesc | Restituisce l’aliquota e, in caso di esenzione, restituisce la descrizione
T_Spesa_A | Totale delle spese per le quali il campo "Identificativo per stampa" (Spese.RifStampa) è stato impostato ad “A”. Cioè nella Tabella spese si mette nel campo: Identificativo per stampa, la stessa lettera per tipologie si spese uguali. Ad esempio si utilizza il codice A per tutte le spese di imballo. Nel caso in cui non si voglia stampare le spese di imballo all’interno del corpo della fattura ma in un campo della testata o del piede è sufficiente mettere il codice campo T_Spesa_A in testata o nel piede del documento, e automaticamente, le righe di spesa per imballo non verranno stampate nel corpo ma nell’altra sezione
T_PercScoPag | Stringa che contiene lo sconto pagamento. Se viene utilizzato questo codice campo viene disabilitata la stampa della tabella degli sconti pagamento nel corpo della fattura, in questo caso si può stampare la tabella degli sconti pagamento nel piede. Per stampare lo sconto pagamento sulla testata senza inibire la stampa della tabella nel corpo si può sempre utilizzare T.ScontoPag
T_ApplScoPag | Contiene “S” se è stato applicato uno sconto pagamento, altrimenti contiene “N”

In caso di sconto pagamento è possibile stampare quanto lo sconto ha inciso sui vari imponibili. Nel nome campo al posto di 00 si mette da 01 a 99.

T_ScPa00Iva | Codice I.V.A
T_ScPa00Aliquota | Aliquota
T_ScPa00ImponSco | Imponibile che viene scontato
T_ScPa00Sconto | Importo dello sconto

Scadenze:
Nel nome campo al posto di 00 si mette da 01 a 99.

T_ScadTutte | Stringa che contiene tutte le scadenze nel formato “01/03/1999 1.234,78 01/04/1999 1234,78”
T_ScadNumero | Numero di scadenze del singolo documento
T_Scad00Data | Data scadenza
T_Scad00Importo | Importo della scadenza

Per il corpo:

Campi che sono sulla riga del documento o, in caso di gestione delle taglie, anche su ogni singolo livello:

C_Um | Unità di misura
C_FatCom | Fattore di conversione
C_Qta | Quantità
C_ValUnitario | Valore unitario
C_ValUnitarioScorp | Valore unitario sempre scorporato dall’I.V.A
C_ValTotale | Valore totale (di riga) (già scontato)
C_ValEuro | Valore in euro
C_ValLire | Valore in lire

Campi che rappresentano la riga standard di stampa del dettaglio
(compilato o meno a seconda del tipo di riga ed altri flag):

C_RigCodArt | Codice articolo
C_RigCodArtFor | Codice articolo fornitore
C_RigDesArtFor | Descrizione articolo fornitore
C_RigDesArt | Descrizione articolo
C_RigUm | Unità di misura
C_RigQta | Quantità (Formato: FquaG , opp. es. "#,##0.000" per avere 3 zeri decimali)
C_RigPrz | Prezzo unitario
C_RigSco | % Sconto (in formato stringa)
C_PrzTot | Totale di riga
C_Iva | Codice Iva
Se attivo il parametro di personalizzazione StFlagGiacDisp si rendono disponibili i 4 campi seguenti: |
C_DispNeg | * se Disponibilità negativa
C_DispSottoscorta | * se Disponibilità inferiore alla sottoscorta
C_GiacNeg | * se Giacenza negativa
C_GiacInsuff | * se Giacenza-Qta Riga Ordine è negativo
C_GiacSottoscorta | * se Giacenza inferiore alla sottoscorta

Righe di Sconto pagamento

C_ScPaAliquota | Aliquota
C_ScPaImponibile | Imponibile che viene scontato
C_ScPaSconto | Importo dello sconto

Riga per importo Cassa Previdenza

C_TotCassaPrev(*)C_TotCassaPrevS(stringa formattata) | Importo della Cassa Previdenza. Se si vuole stampare questo importo nel corpo occorre inserire nel filtro una riga con sottosezione 31, mettere questa variabile in 'Campo' e in 'Fisso' la descrizione che si vuole stampare: Cassa Previdenza ....
C_ImpCassaPrev C_ImpCassaPrevS (stringa formattata) | Importo sul quale viene calcolata la percentuale Cassa Previdenza (è lo stesso usato per il calcolo della ritenuta d’acconto)
C_SpesePerc C_SpesePercS(stringa formattata) | Percentuale della spesa – usabile anche per le altre spese che siano in percentuale

Riga per Ritenuta d'acconto

T_RitAcc Importo della Ritenuta d’acconto . Se si vuole stampare questo importo nel corpo occorre inserire nel filtro una riga con sottosezione 30, in 'Campo': T_RitAcc e in 'Fisso': Ritenuta d'acconto in base alla legge ...) stampata nello spazio della descrizione
poi un'altra riga, con la stessa sottosezione, con la variabile T_RitAcc in Campo, da stampare nello spazio dell'importo. Sono inoltre disponibili per la stampa: la percentuale etc.

Righe SS (Banca, modalità di pagamento , ecc. )

C_SSDescr | Descrizione (es. Banca: )
C_SSValore | Valore (es. Banca Di Roma …..)

Totali (parziali e finali)

C_TotParz | Totale nella valuta del documento
C_DescTot | Descrizione del totale

(**)Per non stampare nel corpo : i dati della Banca, Pagamento, Data consegna, Validità offerta, Resa, Descrizione trasporto, occorre mettere delle righe in testata o nel piede a lunghezza 0 con le variabili:
D.Banche. Descrizione, T.Pagamento, T.DataCons, T.ValOfferta, T.DescResa, T.DescTrasporto

Per stampare questi campi in altra zona del documento che non sia il corpo, si usano le variabili:
D.Banche.Descrizione, D.Pagamenti.Descrizione, T.DataCons, T_DescResa, T_DescAspetto, T_DescTrasporto

Sono inoltre disponibili alcuni campi della tabella Pianoconti ai quali si può far riferimento con D. seguito da nome campo, in particolare D.Pianoconti.NoteOrdini che è un memo (Vedi note Campi particolari)

E' possibile testare il valore della variabile C_DettAttuale per intercettare il tipo di dettaglio che si sta stampando e stamparlo in modo diverso da quello stabilito.


DDT (CAMPI PER FILTRI DI STAMPA)

Per riferirsi all’interno di "Campo" o all’interno di formule, direttamente ai campi del database si deve osservare la seguente sintassi:

sez.tabella.campo
Per sez si intende di quale sezione (recordset) si vuole leggere il valore:
T = Testata (recordset che contiene tutti i campi relativi alla testata)
C = Corpo (recordset che contiene tutti i campi relativi al dettaglio)
S = Spese (recordset che contiene tutti i campi relativi alle righe di spese)
D = Decodifiche (recordset che contiene tutte le decodifiche della testata)
M = Campi letti dalle tabelle del menù (vedi ggMenCli.ovMenuParam() )

Coge. | TabCoGe
Mag. | TabMagazzino
Fat. | TabFatt
Cla. | ArtClassi
PdcCla. | PdcClassi
RegCassa. | TabReg
CauCon. | TabCauCon
Ditta. | Ditta
Demo | Flag interno procedura (Se è in demo)
Descazie | Descrizione della azienda in gestione
osVersion |
osBild |
osPlatform |

Per tabella si intende il nome della tabella da cui vogliamo leggere il valore (che deve essere tra quelle estratte nella sezione).

Per campo si intende il campo della tabella del quale si vuole leggere il valore.
Es. T.DdtTest.PreDoc per stampare il prefisso documento
T.Banche.Agenzia per stampare l’agenzia della banca d’appoggio

In pratica con:
T. (C. o P.)
si indicano i campi della testata (del Corpo o del Piede) del documento (così come vengono memorizzati in tabella: DdtTes, FatTest , DdtDett …etc.)

I campi di tipo T. vanno seguiti dal nome della tabella dalla quale prendere i dati e dal nome del campo:
es. per stampare il codice iva nel dettaglio del Ddt si deve scrivere in nome campo: C.DdtDett.Iva

Con T_ (C_ o P_) si indicano le variabili della testata (del Corpo o del Piede), elaborate (preparate) dal programma.

E’ possibile impostare il parametro di personalizzazione CampiStAggDec
per aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa.

Campi (variabili) elaborati dal programma:

Per la testata / piede:

T_NumDoc | Numero documento
T_CodCli | Codice cliente
T_CliRagSoc | Ragione sociale del cliente o dell’indirizzo di spedizione.(Quando nell’indirizzo di spedizione c’è il flag IndSped.IndPrincDdt = “S” l’indirizzo di spedizione prende posto di quello del cliente e viceversa. Ciò è valido anche per tutti i campi del cliente o dell’indirizzo di spedizione che seguono.
T_RagSoc2 | Seconda parte della ragione sociale del cliente o dell’indirizzo di spedizione
T_CAP | Cap del cliente (o dell’indirizzo di spedizione)
T_Localita | Località del cliente (o dell’indirizzo di spedizione)
T_Pr | Provincia del cliente (o dell’indirizzo di spedizione)
T_Comune | Comune del cliente (o dell’indirizzo di spedizione)
T_Stato | Stato del cliente (o dell’indirizzo di spedizione)
T_SpedRagSoc | Ragione sociale di spedizione
T_SpedRagSoc2 | Seconda ragione sociale di spedizione
T_SpedIndir | Indirizzo di spedizione
T_SpedCAP | Cap di spedizione
T_SpedLocalita | Località di spedizione
T_SpedPr | Provincia di spedizione
T_SpedComune | Comune di spedizione
T_SpedStato | Stato di spedizione
T_Nota | Note di testata del documento
T_IsoPIva | Partita I.V.A. con eventuale codice ISO. Se la partita Iva è vuota contiene il codice fiscale
T_RifCli | Riferimento all’ordine del cliente. Viene valorizzato solo se nel cliente è attivato il flag di stampa riferimento cliente
T_NumCopieTot | Numero copie totali richieste in stampa
T_NumCopieCor | Numero della copia corrente in stampa
T_PrezzoDdt | Campo della testata che indica se stampare o meno i prezzi in ddt

Campi relativi del piede

T_RagSocVett | Ragione sociale del vettore
T_IndirizzoVett | Indirizzo vettore
T_CAPVett | CAP. vettore
T_LocalitaVett | Località vettore
T_PrVett | Provincia vettore
D.Vettori.PartIva | Partita Iva del vettore
D.Vettori.NrIscriz | Nr.iscrizione Albo Trasport. del vettore
D.Vettori.Telefono | Telefono del vettore
D.Vettori.Fax | Fax del vettore
D.Vettori.Email | Email del vettore
T_TargaVett | Targa vettore
T_DescResa | Resa (o porto)
T_DescAspetto | Aspetto dei beni
T_DescTrasporto | Trasporto a cura ..
T_DescCauTrasporto | Causale di trasporto
T_DataRitiro | ata ritiro merce (se inserita nel documento o al momento della stampa)
T_OraRitiro | Ora ritiro merce (se inserita nel documento o al momento della stampa)
T_DataInizio | Data inizio trasporto (se inserita nel documento o al momento della stampa)
T_OraInizio | Ora inizio trasporto (se inserita nel documento o al momento della stampa)
T_DataRitIni | Data inizio trasporto o data ritiro merce a seconda di cosa è stato valorizzato sul documento o al momento della stampa. Questi campi serviranno nei moduli in cui c’è un unico spazio riservato a Data e Ora inizio trasporto/ritiro merce, indipendentemente dal fatto che il trasporto sia fatto dal vettore o no
T_OraRitIni | Ora inizio trasporto o ora ritiro merce a seconda di cosa è stato valorizzato
T.TotDocum | Totale ddt
T.TotMerce | Totale merce
T_TotDdt | Totale ddt che è a 0 se non si stampano i prezzi in ddt altrimenti è valorizzato
T_TotMerce | Totale merce che è a 0 se non si stampano i prezzi in ddt altrimenti è valorizzato

Per il corpo:

Campi che potrebbero essere sia sulla riga del Ddt sia sul dettaglio di livello (Vengono messi sempre a disposizione):

C_Um | Unità di misura
C_FatCom | Fattore di conversione
C_Qta | Quantità
C_ValUnitario | Valore unitario
C_ValUnitarioScorp | Valore unitario sempre scorporato dall’I.V.A
C_ValTotale | Valore totale (di riga) (già scontato)
C_ValEuro | Valore in euro
C_ValLire | Valore in lire
C_ValUniScontNoIvato | Valore unitario scontato senza iva
C_ValUniScontIvato | Valore unitario scontato con iva
C_ValUniIvato | Valore unitario scontato con iva
C_ValUniScont | Valore unitario scontato con o senza iva a seconda del listino
C_ValTotScorp | Totale di riga scontato senza iva
C_ValTotaleIvato | Totale di riga scontato con iva

Campi che rappresentano la riga standard di stampa del dettaglio
(compilato o meno a seconda del tipo di riga ed altri flag):

T_PrezzoDdt Campo della testata che indica se stampare o meno i prezzi in ddt
C_RigCodArt | Codice articolo
C_RigDesArt | Descrizione articolo
C_RigUm | Unità di misura
C_RigQta | Quantità (Formato: FquaG , opp. es. "#,##0.000" per avere 3 zeri decimali)
C_RigPrz | Prezzo unitario
C_RigSco | % Sconto (in formato stringa)
C_PrzTot | Totale di riga
C_RigDesArtLiv | Descrizione articolo-Descr.Liv1-Descr.Liv2
C.DescAttr1 a C.DescAttr5 | Desc. degli attributi delle classi da 1 a 5
C.DdtDett.Iva | Codice Iva dei dettagli

Per chi utilizza Taglia/Colore e vuole stampare le descrizioni dei livelli nella nota sotto di ogni articolo, deve attivare il parametro: DescLivNotaSot con Gruppo: Ddt o StFatture Il valore del parametro dovrà contenere il/i carattere/i di separazione tra le due descrizioni (Es. spazio - spazio)

Stampa riga Lotti:

La stampa può avvenire in modi diversi a seconda di come vengono impostati alcuni parametri di personalizzazione, vedere Personalizzazione lotti/tracciabilità

Elenco campi da introdurre con la sottosezione L per ottenere delle ulteriori righe di dettaglio, per ogni lotto
L_CodLotto
L_RigDesLotto
L_Categoria
L_RigQtaStrG
L_DataScad

Sono disponibili anche:
L_CodForn
L_DescForn
L_NrProgLotto
L_Articolo
L_DescArt
L_Trattamento
L_Confezione
L_Specie

Se non si stampano i lotti con una apposita sottosezione, viene comunque preparata una variabile:
C_Lotto che contiene l’elenco dei lotti separati da un carattere definito nel parametro di personalizzazione: StLottoSepar, che può essere stampata sulla stessa riga dell’articolo, una volta inserita nel filtro.

In particolare viene usata questa variabile se, in presenza di un solo lotto prevalente per ogni articolo, l’utente ha scelto, tramite i param.di personalizzazione di stampare le righe con sottosezione L solo se ci sono più lotti, altrimenti di stampare l’unico lotto, sulla riga dell’articolo.

Nei ddt Interni sono disponibili tutti i campi del magazzino di destinazione:
D.MagazziniDest.Codice
D.MagazziniDest.Descrizione
D.MagazziniDest.Indirizz
etc.

Sono inoltre disponibili alcuni campi della tabella Pianoconti ai quali si può far riferimento con D. seguito da nome campo, in particolare D.Pianoconti.NoteDdt che è un memo (Vedi note Campi particolari)

E' possibile testare il valore della variabile C_DettAttuale per intercettare il tipo di dettaglio che si sta stampando e stamparlo in modo diverso da quello stabilito.


FATTURE (CAMPI PER FILTRI DI STAMPA)

ATTENZIONE

Nei formati di stampa delle fatture il dettaglio per riga di fine corpo è obbligatorio nel caso in cui si stampino fatture con importi ivati e/o fatture di clienti con dichiarazione d’intenti; per consentire di stampare rispettivamente la frase:
"Gli importi del corpo sono comprensivi di Iva" e/o gli estremi della lettera di intenti.
Se non si vuole stampare la frase riguardante i prezzi ivati, si può creare il parametro di personalizzazione NoDescPrezziIvati.

Nel formato per Dettaglio per riga di fine corpo (sottosezione 1 o 7), il campo C_RigDesArt deve essere multiriga per permettere la stampa completa di importanti informazioni. Per evitare lo spreco di spazio nella fattura è consigliabile che il campo C_RigDesArt sia il più largo possibile cioè, su questa riga del filtro, la "Larghezza" dovrà contenere un numero che consenta di occupare l'intera larghezza del modulo.

Per riferirsi all’interno di Campo o all’interno di formule, direttamente ai campi del database si deve osservare la seguente sintassi:

sez.tabella.campo
Per sez si intende di quale sezione (recordset) si vuole leggere il valore:
T = Testata (recordset che contiene tutti i campi relativi alla testata)
C = Corpo (recordset che contiene tutti i campi relativi al dettaglio)
S = Spese (recordset che contiene tutti i campi relativi alle righe di spese)
D = Decodifiche (recordset che contiene tutte le decodifiche della testata)
M = Campi letti dalle tabelle del menù (vedi ggMenCli.ovMenuParam() )

Coge. | TabCoGe
Mag. | TabMagazzino
Fat. | TabFatt
Cla. | ArtClassi
PdcCla. | PdcClassi
RegCassa. | TabReg
CauCon. | TabCauCon
Ditta. | Ditta
Demo | Flag interno procedura (Se è in demo)
Descazie | Descrizione della azienda in gestione
osVersion |
osBild |
osPlatform |

Per tabella si intende il nome della tabella da cui si vuole leggere il valore (che deve essere tra quelle estratte nella sezione).

Per campo si intende il campo della tabella suddetta, che si vuole stampare.
Esempio:
T.DdtTest.PreDoc per stampare il prefisso documento
T.Banche.Agenzia per stampare l’agenzia della banca d’appoggio

In pratica con:
T. (C. o P.)
si indicano i campi della testata (del Corpo o del Piede) del documento (così come vengono memorizzati in tabella: DdtTes, FatTest , DdtDett …etc.)

I campi di tipo T. vanno seguiti dal nome della tabella dalla quale prendere i dati e dal nome del campo:
es. per stampare il codice iva nel dettaglio del Ddt si deve scrivere in nome campo: C.DdtDett.Iva

Con T_ (C_ o P_) si indicano le variabili della testata (del Corpo o del Piede), elaborate (preparate) dal programma.

E’ possibile impostare il parametro di personalizzazione CampiStAggDec
per aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa
e CampiStDecDef per eliminare qualche tabella dalla query di stampa se si verifica un errore di troppi campi.

Campi (variabili) elaborati dal programma:

Per la testata / piede:

T_NumDoc | Numero documento
T_CodCli | Codice cliente
T_CliRagSoc | Ragione sociale del cliente (o dell’indirizzo amministrativo). Se presente quello amministrativo è prioritario. Ciò è valido per tutti i campi anagrafici successivi.
T_RagSoc2 | Seconda parte della ragione sociale del cliente (o dell’indirizzo amministrativo)
T_Cognome | Cognome del cliente
T_Nome | Nome del cliente
T_Indir | Indirizzo del cliente (o dell’indirizzo amministrativo)
T_CAP | Cap del cliente (o dell’indirizzo amministrativo)
T_Localita | Località del cliente (o dell’indirizzo amministrativo)
T_Pr | Provincia del cliente (o dell’indirizzo amministrativo)
T_Comune | Comune del cliente (o dell’indirizzo amministrativo)
T_Stato | Stato del cliente (o dell’indirizzo amministrativo)
T_StatoGiurid | Stato giuridico del cliente (F pers. fisica, G pers. giuridica))
 | Indirizzo di Spedizione elaborato dal programma
T_SpedRagSoc | Ragione sociale di spedizione
T_SpedRagSoc2 | Seconda ragione sociale di spedizione
T_SpedIndir | Indirizzo di spedizione
T_SpedCAP | Cap di spedizione
T_SpedLocalita | Località di spedizione
T_SpedPr | Provincia di spedizione
T_SpedComune | Comune di spedizione
T_SpedStato | Stato di spedizione
 | Indirizzo dall'anagrafica Cliente
T_CliCliRagSoc | Ragione sociale del cliente
T_CliRagSoc2 | Seconda parte della ragione sociale del cliente
T_CliIndir | Indirizzo del cliente
T_CliCAP | Cap del cliente
T_CliLocalita | Località del cliente
T_CliPr | Provincia del cliente
T_CliComune | Comune del cliente
T_CliStato | Stato del cliente
 | Indirizzo Amministrativo collegato al cliente (vedi param.pers . IndAmmSep)
T_AmmCliRagSoc | Ragione sociale dell’indirizzo amministrativo
T_AmmRagSoc2 | Seconda parte della ragione sociale
T_AmmIndir | Indirizzo
T_AmmCAP | Cap
T_AmmLocalita | Località
T_AmmPr | Provincia
T_AmmComune | Comune
T_AmmStato | Stato
 | Indirizzo di Spedizione della fattura (vedi param.pers. IndSpedNoStesso e IndSpedInv)
T_FSpedCliRagSoc | Ragione sociale dell’indirizzo di spedizione della testata della fattura
T_FSpedRagSoc2 | Seconda parte della ragione sociale
T_FSpedIndir | Indirizzo
T_FSpedCAP | Cap
T_FSpedLocalita | Località
T_FSpedPr | Provincia
T_FSpedComune | Comune
T_FSpedStato | Stato
T_MancaSped | Vale S se i campi dell'indirizzo di spedizione sono tutti bianchi (si può testare nel filtro, vedi esempio)
T_SpedCompleto | Tutto l’indirizzo di spedizione in un unico campo (generato SOLO se fattura riepilogativa con Ddt raggrupp. Per indirizzo di spedizione)
T_AmmIndir | Indirizzo amministrativo
T_Nota | Note di testata del documento
T_IsoPIva | Partita I.V.A. con eventuale codice ISO. Se la partita Iva è vuota contiene il codice fiscale
T_PariEuroLireDes | Restituisce “Pari euro: ” se fattura in lire, “Pari lire:” se fattura in euro, niente se fattura in valuta.
T_PariEuroLire | Restituisce il totale fattura in euro se fattura in lire, il totale fattura in lire se fattura in euro, niente se fattura in valuta
T_SimbMon | Simbolo della moneta del documento (dalla tabella Monete)
T_NumCopieTot | Numero copie totali richieste in stampa
T_NumCopieCor | Numero della copia corrente in stampa

Fatture cointestate:

Se non si mettono parametri, il programma stampa, se hanno % diverse, una stringa di default con Rag.sociale, codFisc e %

E' possibile stampare, nel piede, un elenco dei cointestatari con la percentuale e l'importo relativo a ciascuno.
Questo si può ottenere mettendo nel filtro una riga dove in Campo si imposta la variabile: T_CointDetStr
In alternativa si può decidere di stampare, a fine corpo della fattura, una scritta personalizzabile con i parametri CointDetBase e CointStaDet

Se invece si vogliono stampare in testata o nel piede i dati dei cointestatari, impostando nel filtro tutte le righe, le variabili disponibili sono:

T_CointDescr | Descrizione, dalla tabella cointestatari
 | Per ogni cointestatario, fino ad un massimo di 20, sono disponibili i campi elencati di seguito. Il numero finale indica il progressivo del cointestatario: 1, 2 ,… 20.
T_CointRagSocX | Con X = numero cointestatario (Max.20). Ragione sociale cointestatario
T_CointCognome | Cognome
T_CointNome | Nome
T_CointIndirX | Indirizzo
T_CointCAPX | Cap
T_CointLocalitaX | Località
T_CointPrX | Provincia
T_CointStatoX | Stato
T_CointCodFiscX | Codice Fiscale (o Part.Iva se manca il Cod.Fiscale)
T_CointPIvaX | Partita Iva
T_CointPercX | Con X = numero cointestatario. E' la percentuale di conproprietà
T_CointImportoX | Proporzione del totale fattura
T_CointTipo | Vale 0 se non ci sono cointestatari, 1 se ci sono ma nessuno ha la % sulla PdcCointestatari, 2 se hanno una % impostata
T_CointNum | Numero dei cointestatari

Campi relativi del piede

T_RagSocVett | Ragione sociale del vettore
T_IndirizzoVett | Indirizzo vettore
T_CAPVett | CAP. vettore
T_LocalitaVett | Località vettore
T_PrVett | Provincia vettore
T_TargaVett | Targa vettore
T_DescResa | Resa (o porto)
T_DescAspetto | Aspetto dei beni
T_DescTrasporto | Trasporto a cura ..
T_DescCauTrasporto | Causale di trasporto
T_DataRitiro | ata ritiro merce (se inserita nel documento o al momento della stampa)
T_OraRitiro | Ora ritiro merce (se inserita nel documento o al momento della stampa)
T_DataInizio | Data inizio trasporto (se inserita nel documento o al momento della stampa)
T_OraInizio | Ora inizio trasporto (se inserita nel documento o al momento della stampa)
T_DataRitIni | Data inizio trasporto o data ritiro merce a seconda di cosa è stato valorizzato sul documento o al momento della stampa. Questi campi serviranno nei moduli in cui c’è un unico spazio riservato a Data e Ora inizio trasporto/ritiro merce, indipendentemente dal fatto che il trasporto sia fatto dal vettore o no
T_OraRitIni | Ora inizio trasporto o ora ritiro merce a seconda di cosa è stato valorizzato
T.TotMerce | Totale merce
T_TotImponibile | Totale imponibile
T_TotEsente | Totale esente
T_TotEsenteNoBolli | Tot. esente senza l'importo dei bolli Tratta
T_TotSpese | Totale spese
T_TotImpOmaggi | Totale imponibile omaggi su cui si paga l'iva
T_TotFattura | Totale fattura
T_TotIva | Totale Iva
T_TotBolli | Totale Bolli
T_Abbuono | Totale abbuono
T_Acconto | Totale acconto
T_RitAcc (*) | Importo della Ritenuta d’acconto (se si vuole stampare questo importo nel corpo occorre inserire nel filtro una riga con sottosezione 30 e in 'campo' scrivere la variabile T_RitaccDescr (oppure in 'Fisso' scrivere direttamente la frase: Ritenuta d'acconto in base alla legge ...) poi un'altra riga con in Campo: T_RitAcc, per stampare l'importo della ritenuta nella colonna importo
T_RitaccDescr | Frase da scrivere sulla fattura per evidenziare la Ritenuta d'acconto
T_RitAccS | Importo della Ritenuta d’acconto formattato (xxx.xxx,xx)
T_ImponRitAcc | Imponibile per il calcolo della Ritenuta d’acconto
T.PercRitAcc | % Ritenuta d’acconto
T_ImponRitAccS | Imponibile per il calcolo della Ritenuta d’acconto formattato (xxx.xxx,xx)
T_Omaggio (*) | Totale degli Omaggi (se presente nel piede o in testata inibisce la stampa della relativa riga di dettaglio)
T_DesOmaggio1 (*) | Contiene la scritta "** = Merce omaggio con addebito di IVA" se c’è almeno una riga omaggio con addebito di iva
T_DesOmaggio2 (*) | Contiene la scritta "* = Merce omaggio" se c’è almeno una riga omaggio
T_IvaperCassa (*) | Contenuto della nota che indica che la fattura segue il Regime dell'Iva per Cassa.
T_Spese_XX | Cassa Previdenza. Si può stampare nel corpo oppure nel piede mettendo in campo T_Spese_XX dove XX è il carattere definito nella tabella spese in 'identificativo per stampa'. Si possono inoltre usare le variabili:
T_PercCassaPrev | Percentuale della spesa Cassa Previdenza (T_PercCassaPrevS campo formattato)
T_TotCassaPrev | Importo della cassa previdenza (T_TotCassaPrevS campo formattato)

T_TotPagare Totale pagare (tot fattura – abbuono – acconto - eventuale ritenuta d'acconto - Iva Split payment)
Param.di personalizz. TotPagareSplit per sottrarre o meno Iva Split payment

Dati per l’I.V.A. Nel nome campo al posto di 00 si mette da 01 a 99.

T_Iva00Iva | Codice iva
T_Iva00Descrizione | Descrizione breve dell’ iva (o dell'esenzione)
T_Iva00Aliquota | Aliquota
T_Iva00Impon | Imponibile
T_Iva00Impos | Imposta
T_Iva00AliqODesc | Restituisce l’aliquota e, in caso di esenzione, restituisce la descrizione
T_Iva00DescLunga | Restituisce la descrizione lunga dell’ iva (o dell'esenzione)
T_Iva00Memo (*) | Restituisce il contenuto del campo 'Memo' in cui è possibile descrivere ampiamente il motivo dell'esenzione. Il programma, se trova un codice iva con questo campo valorizzato, stamperà comunque sempre il suo contenuto a fine corpo della fattura a meno che nel filtro non ci sia una riga con la quale si voglia stampare T_Iva01Memo in un punto preciso della testata o del piede
T_Spesa_A (*) | Totale delle spese per le quali il campo "Identificativo per stampa" (Spese.RifStampa) è stato impostato ad “A”. Cioè nella Tabella spese si mette nel campo: Identificativo per stampa, la stessa lettera per tipologie si spese uguali. Ad esempio si utilizza il codice A per tutte le spese di imballo. Nel caso in cui non si voglia stampare le spese di imballo all’interno del corpo della fattura ma in un campo della testata o del piede è sufficiente mettere il codice campo T_Spesa_A in testata o nel piede del documento, e automaticamente, le righe di spesa per imballo non verranno stampate nel corpo ma nell’altra sezione
T_PercScoPag (*) | Stringa che contiene lo sconto pagamento. Se viene utilizzato questo codice campo viene disabilitata la stampa della tabella degli sconti pagamento nel corpo della fattura, in questo caso si può stampare la tabella degli sconti pagamento nel piede. Per stampare lo sconto pagamento sulla testata senza inibire la stampa della tabella nel corpo si può sempre utilizzare T.ScontoPag
T_ApplScoPag | Contiene “S” se è stato applicato uno sconto pagamento, altrimenti contiene “N”

(*) Campi per i quali il programma si comporta in modo particolare:
stampa, in automatico, una riga nel corpo del documento con la descrizione relativa (Es. Ritenuta d'acconto xxx, Spesa xx, Operazione con Iva per Cassa etc.)
E' però possibile inserire il campo in una riga del filtro per stampare in un punto ben preciso, l'importo o la frase corrispondente.
Se invece si mettono nel filtro questi campi impostando sulla riga 'larghezza' = 0, essi NON verranno stampati.

In caso di sconto pagamento è possibile stampare quanto lo sconto ha inciso sui vari imponibili. Nel nome campo al posto di 00 si mette da 01 a 99.

T_ScPa00Iva | Codice I.V.A
T_ScPa00Aliquota | Aliquota
T_ScPa00ImponSco | Imponibile che viene scontato
T_ScPa00Sconto | Importo dello sconto

Scadenze:
Nel nome campo al posto di 00 si mette da 01 a 99.
E' possibile personalizzare la stampa delle scadenze impostando appositi parametri di personalizzazione

T_ScadTutte | Stringa che contiene tutte le scadenze nel formato “01/03/1999 1.234,78 01/04/1999 1234,78”
T_ScadNumero | Numero di scadenze del singolo documento
T_Scad00Data | Data scadenza
T_Scad00Importo | Importo della scadenza
T_Scad00ImpStr | Importo della scadenza formattato
T_Scad00ImpTrat | Importo del bollo 'Tratta' per una determinata scadenza
T_Scad00ImpNoTrat | Importo della scadenza comprensivo del bollo Tratta
T_NumSpeseScad | Vale 0 se condizione di pagamento non è Tratta

Fatture accompagnatorie – campi per stampa prospetto cauzioni

T_TotLitri Totale litri di vino (calcolato utilizzando il numero di litri per bottiglia scritto sugli articoli)

Per ogni ‘articolo cauzione’ , fino a un massimo di 20 articoli:

T_CauzDescr N (N=1-20) | Descrizione articolo cauzione (Es. T_CauzDescr1)
T_CauzQta N | Quantità consegnata in fattura
T_CauzUni N | Valore unitario
T_CauzRig N | Valore totale di riga
T_CauzQtaNeg N | Quantità resa
T_CauzUniNeg N | Valore unitario del reso
T_CauzRigNeg N | Valore totale di riga
T_CauzTot | Valore totale delle cauzioni consegnate al cliente
T_CauzTotNeg | Valore totale delle cauzioni rese dal cliente

I campi relativi alle cauzioni Rese, saranno disponibili solo una volta che saranno state inserite manualmente le righe dei resi.

Per il corpo:

Campi che sono sulla riga del documento o, in caso di gestione delle taglie, anche su ogni singolo livello. Vengono messi sempre a disposizione:

C_Um | Unità di misura
C_FatCom | Fattore di conversione
C_Qta | Quantità
C_ValUnitario | Valore unitario
C_ValUnitarioScorp | Valore unitario sempre scorporato dall’I.V.A
C_ValTotale | Valore totale (di riga) (già scontato)
C_ValEuro | Valore in euro
C_ValLire | Valore in lire
C_SimbMon | Simbolo della moneta del documento (dalla tabella Monete)

Campi che rappresentano la riga standard di stampa del dettaglio
(compilato o meno a seconda del tipo di riga ed altri flag):

C_RigCodArt | Codice articolo
C_RigDesArt | Descrizione articolo
C_RigDesArtLiv | Descrizione articolo-Descr.Liv1-Descr.Liv2
C_RigUm | Unità di misura
C_RigQta | Quantità (Formato: FquaG , opp. es. "#,##0.000" per avere 3 zeri decimali)
C_RigPrz | Prezzo unitario
C_RigPrzNetto | Prezzo unitario scontato
C_RigSco | % Sconto (in formato stringa)
C_RigScoOma | % Sconto (in formato stringa) o le Scritte “Omaggio *” per omaggio totale, o “Omaggio **” per omaggio con addebito d’iva
C_PrzTot | Totale di riga
C.Iva | Codice Iva
C_TotMerceSc | Importi degli sconti (sc.1, sc.2 etc) o dei totali merce, scontati ai vari livelli
T_TotMerceSc_N | Totale merce scontato ai vari livelli

Per righe di Sconto pagamento:

C_ScPaAliquota | Aliquota
C_ScPaImponibile | Imponibile che viene scontato
C_ScPaSconto | Importo dello sconto

Per chi utilizza Taglia/Colore e vuole stampare le descrizioni dei livelli nella nota sotto di ogni articolo, deve attivare il parametro: DescLivNotaSot con Gruppo: Ddt o StFatture Il valore del parametro dovrà contenere il/i carattere/i di separazione tra le due descrizioni (Es. spazio - spazio)

Riga per la ritenuta d'acconto:

T_RitAcc Importo della Ritenuta d’acconto . Se si vuole stampare questo importo nel corpo occorre inserire nel filtro una riga con sottosezione 30, in 'Campo': T_RitAccDescr (oppure in 'Fisso' la frase che si vuole stampata nel corpo in corrispondenza all'importo della ritenuta)
poi un'altra riga, con la stessa sottosezione, con la variabile T_RitAcc in Campo, da stampare nello spazio dell'importo. Sono inoltre disponibili per la stampa: la percentuale etc.

Riga per importo Cassa Previdenza:

C_TotCassaPrev(*)C_TotCassaPrevS(stringa formattata) | Importo della Cassa Previdenza. Se si vuole stampare questo importo nel corpo occorre inserire nel filtro una riga con sottosezione 31, mettere questa variabile in 'Campo' e in 'Fisso' la descrizione che si vuole stampare: Cassa Previdenza ....
C_ImpCassaPrev C_ImpCassaPrevS (stringa formattata) | Importo sul quale viene calcolata la percentuale Cassa Previdenza (è lo stesso usato per il calcolo della ritenuta d’acconto)
C_SpesePerc C_SpesePercS(stringa formattata) | Percentuale della spesa – usabile anche per le altre spese che siano in percentuale

Campi della testata fattura letti direttamente dal database:

Nome del campo | Tipo | Lung. | Descrizione
T.Anno | Integer | 2 | riferimento
T.NumRif | Long | 4 | Codice riferimento Fattura
T.DataRif | Date/Time | 8 | riferimento
T.AnnoMovim | Integer | 2 | Anno Numero del mov.di mag. generato (solo se NON riepilog)
T.NumMovim | Long | 4 | Numero del mov.di mag. generato (solo se NON riepilog)
T.AnnoCont | Integer | 2 | Serve se coge 1/6- 31/5 Una fatt.del 1999 Febb. va in coge con anno 1998
T.NumCont | Long | 4 | Numero del mov.di Co.Ge. generato
T.FattDocumento | Text | 2 |
T.PreDoc | Text | 1 | Prefisso Documento
T.NumDoc | Long | 4 | Numero Documento
T.DataDoc | Date/Time | 8 |
T.Stato | Text | 1 | bianco=stato iniziale, S=Stampato,C=Contabilizzato
T.Trasferito | Text | 1 | S indica già trasferito su file per passarlo ad altre contabilità, altrimenti deve valere null
T.PeriodoIva | Integer | 2 | E' il mese di competenza iva (sempre mese anche per i trimestrali)
T.AnnoIva | Integer | 2 | E' l'anno di competenza iva
T.PreDocOrig | Text | 1 | Prefisso Documento Originale (oppure tutto nel numero!!!)
T.NumDocOrig | Long | 4 | Numero Documento (Se si fa alfanumerico ci sta anche il prefisso!!)
T.DataDocOrig | Date/Time | 8 | Data Doc.Originale (solo per Nota Credito! è il rif.alla fattura)
T.Riepilogativa | Text | 1 | S/N
T.FattAccomp | Text | 1 | S/N Si se fattura accompagnatoria
T.GruppoCli | Text | 2 | \
T.MastroCli | Text | 2 | Codice Cliente
T.ContoCli | Text | 4 | /
T.Tipo | Text | 1 | 3=Clienti
T.RifCli | Text | 20 | Rif.all'ord.del cliente. In Fatt da Ordine lo porta sui dett. l'evasione (se il cliente lo prevede)
T.Iva | Text | 4 |
T.IvaSosp | Text | 1 | S/N
T.Listino | Text | 2 |
T.PrezziIvati | Text | 1 | S/N
T.Moneta | Text | 4 |
T.SimbMon | Text | 4 | Simbolo della moneta
T.Cambio | Double | 8 |
T.Pagamento | Text | 6 | Cod.Condizione di Pagamento
T.RagRB | Text | 1 | Raggruppo Ric.Bancarie in distinta : "S" o "N"
T.RagOrd | Text | 1 | Raggr.Ordini in evasione : S/N
T.RagDDT | Text | 1 | Raggr. DDT in fattura : S-Si N-No A-1 riga x art.D-1 fatt.per dest. (E=A+D)Serve in evasione e per la stampa fatt.
T.Bolli | Text | 1 | Addebito bolli : "S" o "N"
T.SpeseBan | Text | 1 | Addebito spese bancarie : "S" o "N"
T.Banca | Text | 6 |
T.ScontoCli | Text | 15 | Sconto del cliente da scriversi 10+3+2
T.ScontoPag | Text | 15 |
T.MagazzProv | Text | 8 | Magazzino di scarico
T.Agente1 | Text | 4 | Codice agente principale
T.Agente2 | Text | 4 | Codice 2' agente
T.TipoProvv | Text | 1 | Prelievo % Provv. : N-No provv A-da articolo C-da cliente G-da agente (era 0-3)
T.PercProvv1 | Double | 8 | % prov.: ci sarà quella degli agenti, o solo quella del cliente a sec.del flag
T.PercProvv2 | Double | 8 |
T.Acconto | Double | 8 |
T.Abbuono | Double | 8 |
T.Nota | Memo |  | Nota di Testata
T.StampoNota | Text | 1 | S/N
T.NumNota1 | Text | 2 | Nota fissa da stampare sul documento
T.NumNota2 | Text | 2 | Nota fissa da stampare sul documento
T.NumNota3 | Text | 2 | Nota fissa da stampare sul documento
T.IndSped | Text | 3 | Se bianco i dati dell'ind.di spedizione sono contenuti nei campi che seguono, altrimenti sono nella tabella IndSped
T.RagSoc | Text | 40 |
T.RagSoc2 | Text | 30 |
T.IndirizzoSped | Text | 30 |
T.CAPSped | Text | 5 |
T.LocalitaSped | Text | 40 |
T.ComuneSped | Text | 2 |
T.PrSped | Text | 2 |
T.StatoSped | Text | 4 | Decodifica da tabella stati
T.AspettoBene | Text | 3 |
T.DescAspetto | Text | 30 | Per DDT/fatt.Acc. Es. Scatole, Pacchi etc.
T.CauTrasporto | Text | 3 |
T.DescCauTrasporto | Text | 30 | Per Ddt/Fatt.Acc. Es.Vendita, c/to demo etc.
T.Resa | Text | 3 |
T.DescResa | Text | 30 | Es. Porto Franco - Porto Assegnato
T.Trasporto | Text | 3 |
T.DescTrasporto | Text | 30 | Per DDT : Posta, Corriere, Destinatario etc.
T.Vettore | Text | 4 |
T.RagSocVett | Text | 30 |
T.IndirizzoVett | Text | 30 |
T.CAPVett | Text | 5 |
T.LocalitaVett | Text | 40 |
T.PrVett | Text | 2 |
T.DataRitiroMerce | Date/Time | 8 |
T.OraRitiroMerce | Date/Time | 8 | Il formato dell’ora, nel filtro, deve essere vuoto
T.DataInizioTrasp | Date/Time | 8 |
T.OraInizioTrasp | Date/Time | 8 | Il formato dell’ora, nel filtro, deve essere vuoto
T.Colli | Long | 4 |
T.Peso | Double | 8 |
T.TotMerce | Double | 8 |
T.TotSpese | Double | 8 |
T.TotIva | Double | 8 |
T.TotDocum | Double | 8 |
T.TotImpon | Double | 8 |
T.LiberoTest1 | Text | 20 | CampoLibero 1
T.LiberoTest2 | Text | 20 | CampoLibero 2
T.LiberoTest3 | Text | 20 | CampoLibero 3
T.LiberoTest4 | Text | 20 | CampoLibero 4
T.Contratto | Text | 15 |
T.CIG e T.CUP | Text | 10 - 15 |
T.Lingua | Text | 3 |
T.Provenienza | Text | 1 | Documento di provenienza della fattura: O=Ordine, P=Preventivo, D=DDT, bianco = Nessuno
T.DescPers1 - 3 | Text | 50 | Campi liberi con descrizione personalizzabile da parametro di personalizzazione: DescPersTest1-3

Campi della testata fattura (decodifiche)

Nome del campo | Tipo | Lung. | Descrizione
D.FattDocumento | Text | 2 | Cod. tipo documento utilizzato in fattura
D.FattDocumenti.Descrizione | Text | 30 |
D.FattDocumenti.Tipo | Text | 1 | Preventivo, Ordine, Bolla(ddt), Fattura, D=Fatt.dettaglianti, A=ordine acq., C=bolla di acquisto
D.Interno | Text | 1 | S/N (Se N è normale)
D.FattDocumenti.Segno | Text | 1 | "+" positiva " -" negativa
D.FattAccomp | Text | 1 | S/N Si se fattura accompagnatoria
D.AFornitore | Text | 1 | 3 Clienti; 2 Fornitori
D.Listino | Text | 2 | Listino solo se è particolare per questo doc. altrimenti lo prende dal Cliente
D.MagProposto | Text | 8 | Magazzino proposto sul documento (se bianco prende il default dal Tabmag)
D.TabSconti | Text | 1 | Indica se è prioritaria la tabSconti: 1-Categoria/Articolo o 2- Cliente/Gruppo articolo
D.PrezzoDDT | Text | 1 | 0-NO,1prezzi e sconti,2 prezzo, 3 netto,4 prezzi,sconti e totale finale+iva,5 Prezzi eTotale Ivati
D.PrefBolle | Text | 1 | Prefisso per numeratore bolle
D.FattDocumenti.MagCausale | Text | 2 | Causale del mov.di magazzino
D.MagCausaleRientro | Text | 2 | Da MagCausali - SOLO su DDT da non evad.(per reso da Demo) o su ORDINI per evasione con Corrispettivo
D.FattDocumenti.Causale | Text | 2 | Cod.causale per la reg. di prima nota
D.CausaleSosp | Text | 2 | Cod.causale per la reg. di prima nota (se fatt.iva sospesa)
D.PrefRegIva | Text | 1 | Prefisso per numeratore fatture (registro iva)
D.FattDocEvasione | Text | 2 |
D.RiepDoc | Text | 20 | Descrizione, sulla fatt.riepilogativa, dei doc.che raggruppa (Es. ddt nr' )
D.GgScadCli | Integer | 2 | Giorni per pagamenti scaduti (Se >0 automatico, se <0 attivato da pulsante)
D.Rischio | Text | 1 | S/N Da considerare a Rischio
D.InFatturato | Text | 1 | S/N Da considerare nella stampa del Fatturato
D.NumNota1-3 | Text | 1 | Note fisse da stampare sul documento (1,2,3)
D.DoveStampoDesLung | Text | 1 | 0-No 1-Sopra 2-Sotto 3-copio su nota sopra 4-copio su nota sotto
D.StIntestModulo | Text | 1 | S/N Stampa Logo della ditta sul modulo(non utilizzato)
D.Dovestampo | Text | 1 | L=Laser - M=modulo continuo
D.Modello | Text | 8 | Nome modello (filtro) di stampa Solo se tipico di questo FattDoc
D.PersFineCorpo | Text | 50 | Stringa con elenco sottosezioni da stampare a fine corpo
D.Causali.Causale | Text | 2 | Codice causale Co.Ge.
D.Causali.Descrizione | Text | 20 |
D.DescrAgg | Text | 30 | Descrizione aggiuntiva per movimenti
D.PartGruppo | Text | 2 | \
D.PartMastro | Text | 2 | Codice Partita
D.PartConto | Text | 4 | /
D.PartTipo | Text | 1 | 1=Conto 2=Fornitori,3=Clienti
D.CoPartGruppo | Text | 2 | \
D.CoPartMastro | Text | 2 | Codice Contro-Partita
D.CoPartConto | Text | 4 | /
D.CoPartTipo | Text | 1 | 1=Conto 2=Fornitori,3=Clienti
D.Ritardo | Text | 1 | S/N S se fatt. registr. in ritardo (non gestito)
D.InValuta | Text | 1 | Se impostato a SI l'articolo verrà mantenuto anche in valuta
D.FattDett | Text | 1 | S = fattura dettaglianti
D.Trasportatori | Text | 1 | S = Per fatt./NC Trasportatori
D.IntraCee | Text | 1 | S= fatture d'acquisto/Vendita INTRA-CEE
D.IvaGruppo | Text | 2 | \
D.IvaMastro | Text | 2 | Conto Iva
D.IvaConto | Text | 4 | /
D.TipoReg | Text | 1 | A-Acq V-Ven C-Corr
D.TipoCausale | Text | 2 | G-Generica,AP-Ap. conti,V-Vend., A-Acqu.,C-Corr,CV-CorrDaVent,VS-IvaAdEsigib.diff.Cli,IS-Incasso Iva Sosp,AS-IvaAdEsigib.diff.For,PS-Pagam. Iva Sosp,CH-Chiusura Bilancio
D.SegnoPrinc | Text | 1 | Indica il segno della prima riga dell'articolo (D/A)
D.Prefisso | Text | 1 | Prefisso da cui prendere il protocollo
D.ObbProtocollo | Text | 1 | S=obbligatori nr e data protocollo
D.ObbDocumento | Text | 1 | S=obbligatori nr e data documento
D.ObbCondPag | Text | 1 | S=obbligatoria la cond.pagamento
D.TipoPartita | Text | 1 | 0-Non interessa 1-Apre 2-Si riferisce
D.PagInc | Text | 1 | Se S deve agganciare le scad. o le partite (Va Si se caus. di pagam. o incasso)
D.CausConcatenata | Text | 2 | Causale per creare una registrazione concatenata
D.RitAcc | Text | 1 | Per aggancio Rit.acc 0-No 1-.. 2-..
D.CausRit | Text | 2 | Causale collegata per la ritenuta d'acconto
D.MagCausali.MagCausale | Text | 2 |
D.MagCausali.Descrizione | Text | 25 |
D.Fiscale | Text | 1 | Il movimento và stampato nel giornale di magazzino "S" o "N"
D.TipoMov | Text | 1 | N-normale,I-interno,V-inventario,T trasform,O-Ordine,D-Ordine Interno
D.MagCausali.Segno | Text | 1 | + -
D.CarScar | Text | 1 | C=Carico S=Scarico Null o N=niente
D.AcqVen | Text | 1 | A=Acquisto V=Vendita Null=niente
D.AggCostoUlt | Text | 1 | S/N Aggiorno il costo ultimo
D.AggMedioPon | Text | 1 | S/N Aggiorno il costo Medio Ponderale
D.AggMedioCar | Text | 1 | S/N Aggiorno il Medio di Carico
D.ValorizzScarico | Text | 1 | N-Non Gestito CON: C-Medio di Carico P-Medio Ponder U-Ultimo Costo
D.QualeImporto | Text | 1 | imp da proporre nell'input mov: "M" CM, "U" = CU, "L" Listino
D.MagCausaleTrasf | Text | 2 | Causale collegata per trasformazione
D.MagCausaleDiBa | Text | 2 | Causale collegata per la dist.base
D.Prov | Text | 1 | Provenienza della merce : "C" clienti, "F" fornitori, "M" magazzino
D.Dest | Text | 1 | Destinazione della merce : "C" clienti, "F" fornitori, "M" magazzino
D.QualeProgrQta | Text | 1 | Indica se e quale Quantità aggiornare sulla sintesi del prodotto
D.PianoConti.Descrizione | Text | 40 | Descrizione del cliente
D.PianoConti.RagSoc | Text | 30 | Ragione sociale cliente
D.PianoConti.RagSoc2 | Text | 30 | Seconda parte della Rag.Sociale
D.PianoConti.Indirizzo | Text | 30 | Indirizzo cliente
D.PianoConti.CAP | Text | 5 |
D.PianoConti.Localita | Text | 40 |
D.PianoConti.Pr | Text | 2 |
D.PianoConti.Stato | Text | 4 |
D.PianoConti.PartIva | Text | 12 |
D.PianoConti.CodFisc | Text | 16 |
D.PianoConti.Lingua | Text | 3 |
D.PianoConti.DicIntenti | Text | 30 | Numero e Data della Dich.di Intenti da stampare in fattura
D.PianoConti.IndAmm | Text | 3 | Cod. indirizzo Amm.del cliente Fatture
D.PianoConti.Fax | Text | 1 |
D.PianoConti.Telefono | Text | 20 |
D.PianoConti.Telefono1 | Text | 30 |
D.PianoConti.NoteFattura | Memo |  | Vedi note Campi particolari
D.PianoConti.NoteFatacc | Memo |  | Vedi note Campi particolari
D.Listini.Descrizione | Text | 30 |
D.Pagamenti.Descrizione | Text | 40 |
D.Banca | Text | 6 |
D.Banche.Descrizione | Text | 40 |
D.Agenzia | Text | 40 |
D.Banche.Indirizzo | Text | 30 |
D.Banche.Localita | Text | 50 | Cap-località.Pr
D.Banche.ABI | Text | 5 |
D.Banche.CAB | Text | 5 |
D.Banche.SIA | Text | 5 |
D.Banche.Gruppo | Text | 2 | \
D.Banche.Mastro | Text | 2 | Conto associato alla Banca
D.Banche.Conto | Text | 4 | /
D.Persona | Text | 20 | Pers.di Riferimento
D.Banche.Telefono | Text | 25 |
D.Banche.Fax | Text | 20 |
D.Banche.AzzContaEff | Text | 1 | S/N : utilizzato in RIBA. Se S si numera a partire da 1 x ogni distinta.
D.Banche.CCorrente | Text | 20 |
D.Iva | Text | 4 |
D.TabIva.Descrizione | Text | 30 |
D.DescrizioneBreve | Text | 10 |
D.TipoIva | Text | 1 | 0-Normale,1=Iva non detraib,2=Esente,3=non impon.,4=non imp.art.8 c.2,5=iva esclusa(art.15)
D.Aliquota | Double | 8 | Aliquota iva
D.PercNonDetr | Double | 8 |
D.Scorporo | Text | 1 | "S" = da scorporare "N" = iva normale (Vale per Tipo iva=0)
D.CodSostScorp | Text | 4 |
D.CodVentSpec | Text | 4 |
D.ProRata | Text | 1 | S/N (non gestito)
D.AggPlafond | Text | 1 | S/N - S in corr.ai codici di esenzione che devono aggiornare il plafond utilizzato
D.ApplBolloEse | Text | 1 | S/N Indica se addebitare o no il bollo Esente se cliente esente cioè tutta la fattura è esente
D.EsclBollat | Text | 1 | S/N Esclusione da bollato (non gestito)
D.PercDetrIvaAgri | Double | 8 | % di detraibilità per iva agricola da applicare sulle vendite in liquidazione
D.ServCee | Text | 1 | S=Registra Servizi Intra Cee (importi da utilizz.per dich. annuale)
D.VolAffari | Text | 1 | S/N se Si concorre alla determinazione del volume d'affari
D.OpAttPass | Text | 1 | S/N (Per Dich.Periodica/Annuale Iva
D.CessIntraCee | Text | 1 | S/N Serve per il campo VP1 della Dich.Periodica
D.A74InterCee | Text | 1 | S/N Per liquid. ART.74Ter: Viaggi interamente nella Cee
D.A74InterFuoriCee | Text | 1 | S/N Viaggi interamente fuori Cee
D.A74InterMisti | Text | 1 | S/N Misti - Costi parte Cee e corrispettivi
D.A74InterMistiNoCee | Text | 1 | S/N Misti - Costi parte No Cee
D.A74IvaArt74Ter | Text | 1 | S/N Cod.Iva ordinario per IVA 74Ter
D.Magazzino | Text | 8 |
D.Magazzini.Descrizione | Text | 30 |
D.Magazzini.Indirizzo | Text | 30 |
D.Magazzini.CAP | Text | 5 |
D.Magazzini.Localita | Text | 40 |
D.Magazzini.Pr | Text | 2 |
D.Vero | Text | 1 | S/N S se magazzino per cui gestire le quantità N se altro
D.Agenti1.RagSoc | Text | 30 |
D.Agenti2.RagSoc | Text | 30 |
D.Moneta | Text | 4 |
D.Monete.Descrizione | Text | 20 |
D.NumDec | Integer | 2 | Numero Decimali
D.NumDecGest | Integer | 2 | Numero Decimali in Prezzo unitario (max 4)
D.Operatore | Text | 1 | OP (moltiplicazione o divisione): importo in moneta OP cambio=importo in euro
D.Cee | Text | 1 | S=Moneta Cee
D.NoteFn.TestoNota (n=1,2,3) | Memo |  | Se in una nota fissa il flag NotaDove è impostato a N, è possibile stamparla nel piede o in testata mettendo nel filtro la riga per stamparla
D.NoteFn.NotaDove(n=1,2,3) | Text | 1 | I=Inizio Corpo F=Fine Corpo N=non stampo nel corpo(Pos.di stampa della Nota)
D.IndSped.Gruppo | Text | 2 |
D.IndSped.Mastro | Text | 2 |
D.IndSped.Conto | Text | 4 |
D.IndSped.IndSped | Text | 3 |
D.IndSped.Tipo | Text | 1 | 1 = Coge, 2=Fornitori,3=Clienti
D.IndSped.RagSoc | Text | 40 |
D.IndSped.RagSoc2 | Text | 30 |
D.IndSped.Indirizzo | Text | 30 |
D.IndSped.CAP | Text | 5 |
D.IndSped.Localita | Text | 40 |
D.IndSped.Pr | Text | 2 |
D.IndSped.Stato | Text | 4 |
D.IndSped.NoteSped | Text | 25 |
D.IndSped.IndPrincDdt | Text | 1 |
D.IndSped.IndPrincFatt | Text | 1 |
D.Ammistr.Gruppo | Text | 2 | \
D.Ammistr.Mastro | Text | 2 | Cod.Conto ind.amministrativo
D.Ammistr.Conto | Text | 4 | /
D.Ammistr.IndSped | Text | 3 | Codice Indirizzo amministrativo
D.Ammistr.Tipo | Text | 1 | 2=Fornitori,3=Clienti
D.Ammistr.RagSoc | Text | 40 |
D.Ammistr.RagSoc2 | Text | 30 |
D.Ammistr.Indirizzo | Text | 30 |
D.Ammistr.CAP | Text | 5 |
D.Ammistr.Localita | Text | 40 |
D.Ammistr.Pr | Text | 2 |
D.Ammistr.Stato | Text | 4 |
D.Ammistr.NoteSped | Text | 1 |
D.Ammistr.IndPrincDdt | Text | 1 | S/N se S e si trova nell'ind di destinazione di un Ddt verrà stamp.come ind.principale
D.Ammistr.IndPrincFatt | Text | 1 | S/N se S e si trova nell'ind di destinazione di una fatt viene stamp.come indir.princ.
D.Vettore | Text | 4 |
D.Vettori.RagSoc | Text | 30 |
D.Vettori.Indirizzo | Text | 30 |
D.Vettori.CAP | Text | 5 |
D.Vettori.Localita | Text | 40 |
D.Vettori.Pr | Text | 2 |
D.Vettori.Telefono | Text | 20 |
D.Vettori.Fax | Text | 20 |
D.Vettori.PartIva | Text | 16 |
D.Vettori.NrIscriz | Text | 20 |
D.Vettori.Email | Text | 50 |
D.Targa | Text | 15 |
D.Iso | Text | 2 |
D.CauTrasporto | Text | 3 |
D.CauTrasporti.Descrizione | Text | 30 |
D.AspettoBene | Text | 3 |
D.AspettoBeni.Descrizione | Text | 30 |
D.Resa | Text | 3 |
D.Rese.Descrizione | Text | 30 | Es. Porto Franco - Porto Assegnato
D.Trasporto | Text | 3 |
D.Trasporti.Descrizione | Text | 30 | Per DDT : Posta, Corriere, Destinatario etc.
D.DescPers1 / D.DescPers2 | Text | 2 |

Campi del Corpo fattura

Nome del campo | Tipo | Lung. | Descrizione
C.FatDett.Anno | Integer | 2 |
C.FatDett.NumRif | Long | 4 |
C.RigDet | Long | 4 | Progressivo di Riga all' interno del documento
C.FatDett.RigLiv | Long | 4 | Progressivo di collegamento con la riga del mov
C.TipoRiga | Text | 1 | Articolo, D=Riga descrittiva,Manuale, Comandi
C.FormatoRiga | Text | 8 | Formato normbianco, se compilato è da usare per la stampa di questa riga
C.Riepilogativa | Text | 1 | S/N Riga Inserita manualmente o viene da evasione bolla
C.FatDett.Articolo | Text | 20 | Codice articolo
C.FatDett.Descrizione | Text | 40 | Valorizzato solo per articoli manuali
C.DoveStampoDesLung | Text | 1 | 0-No 1-Sopra 2-Sotto (default come FattDocumenti)
C.FatDett.UM | Text | 2 |
C.FatDett.Qta | Double | 8 |
C.FatDett.FatCon | Double | 8 | Fattore di conversione
C.Colli | Integer | 2 |
C.FatDett.ValUnitario | Double | 8 |
C.ScontoTab | Text | 15 | Sconto da tabella sconti
C.ScontoCli | Text | 15 | Sconto cliente
C.ScontoArt | Text | 15 | Sconto articolo
C.ScontoQuant | Text | 15 | Sconto Quantà
C.FatDett.ScontoTot | Text | 15 | Sconto cliente
C.FlScontoPag | Text | 1 | S/N se S questa riga è soggetta a sconto pagamento
C.Promozione | Text | 1 | S/N se S riga con prezzo in promozione
C.FatDett.ValTotale | Double | 8 | Importo totale scontato
C.FatDett.Iva | Text | 4 |
C.GruppoVe | Text | 2 | \
C.MastroVe | Text | 2 | Conto ricavo della riga articolo
C.ContoVe | Text | 4 | /
C.StatoRiga | Text | 1 | Evaso Non evaso
C.Omaggio | Text | 1 | N=NO, S=Omaggio totale, I=omaggio al cliente si addebita l'iva
C.PercProvv1 -2 | Double | 8 | % provvigione della riga (1' e 2' agente)
C.TipoProv | Text | 1 | Provenienza: P=Prev, O=Ord, D=DDT, Vuoto=da nessuno
C.FattDocumentoProv | Text | 2 | Cod. tipo doc.di provenienza
C.AnnoRifProv | Integer | 2 | Anno Rif del doc.di provenienza
C.NumRifProv | Long | 4 |
C.RigaRifProv | Long | 4 | RigaLiv del Doc di provenienza
C.FatDett.QtaProv | Double | 8 | Quantità per cui è stato evaso l'ordine (è la qta originale della riga) da utilizzare per stornare l'ordinato
C.FatDett.Lunghezza | Double | 8 | Per personalizzazione (determinano la quantità)
C.FatDett.Larghezza | Double | 8 |
C.FatDett.Altezza | Double | 8 |
C.NotaSopra | Memo |  |
C.NotaSopraStamp | Text | 1 | N=No stampa- A=st.solo su doc.attuale, S=St.anche sul doc.di evasione, E=St.solo sul documento di evasione
C.NotaSotto | Memo |  |
C.NotaSottoStamp | Text | 1 | N=No stampa- A=st.solo su doc.attuale, S=St.anche sul doc.di evasione, E=St.solo sul documento di evasione
C.FatDett.ValLire | Double | 8 | Valore in Lire
C.FatDett.ValEuro | Double | 8 | Valore in Euro
C.FatDett.FlagStato | Text | 1 | Se vario la testata: 0 = normale,4 = in modifica
C.DescPers1 - 2 | Text | 50 | Per stampare il contenuto di eventuali campi aggiuntivi liberi dell'articolo inseriti con l'uso dei parametri di personalizzazione DescPersDett1-4
C.FatDett.CostoVen | Double | 8 | Costo del venduto
C.FatLiv.Anno | Integer | 2 |
C.FatLiv.NumRif | Long | 4 | Numero Riferimento
C.FatLiv.RigLiv | Long | 4 | Progressivo di collegamento con la riga del mov.
C.Livello1 - 2 | Text | 4 | Da Livelli Per inserire elenco Tagli, colori etc.
C.DescLiv1 - 2 | Text | 20 | Descrizione livello 1 e 2
C.RigLivOrig | Long | 4 | Riga del documento (livello corrispondente) da cui è stata generata questa riga di livello, se art.manuale è vuoto
C.FatLiv.UM | Text | 2 |
C.FatLiv.FatCon | Double | 8 | Fattore di conversione: Vale 1 se si è usata l'UM princ.
C.FatLiv.Qta | Double | 8 | quantità del movimento
C.FatLiv.ValUnitario | Double | 8 |
C.FatLiv.ValTotale | Double | 8 |
C.FatLiv.ScontoTot | Text | 15 | Sconto tot calcolato o digitato
C.FatLiv.FlagStato | Text | 1 | Flag ad uso programmazione: se in variazione testata: 0 = normale,2 = in disaggiornamento
C.FatLiv.ValEuro | Double | 8 | Valore in Euro
C.FatLiv.ValLire | Double | 8 | Valore in Lire
C.FatLiv.QtaProv | Double | 8 | Quantità per cui è stato evaso l'ordine (è la qta originale della riga) da utilizzare per stornare l'ordinato
C.FatLiv.CostoVen | Double | 8 | Costo del venduto
C.Articoli.Articolo | Text | 20 | Cod.articolo
C.BarCode | Text | 14 | Codice a Barre
C.Articoli.Descrizione | Text | 40 |
C.DesLunga | Memo |  | Descrizione aggiuntiva da stampare nei documenti
C.ArtMag | Text | 1 | Se No, non verranno gest.giacenze e movimenti
C.ArtGruppo | Text | 3 |
C.ArtSottoGru | Text | 3 |
C.ArtCatFiscale | Text | 4 |
C.ArtClasseAttr1 - 5 | Text | 3 | Cod.Attributi delle classi 1 - 5
C.ArtUM | Text | 2 | UM principale (Cioè quella con cui vengono gestite le quantità dell'art.)
C.ArtUMVen | Text | 2 | Unità di misura per le vendite
C.FatConVen | Double | 8 | Fattore di conversione: 1 UM = 1 UMCorr * FatCon
C.ArtUMAcq | Text | 2 | Unità di misura correlata per gli acquisti
C.FatConAcq | Double | 8 | Fattore di conversione: 1 UM = 1 UMCorr * FatCon
C.MagFisc | Text | 1 | In magazzino fiscale "S" o "N"
C.Reparto | Integer | 2 | Se c'è il reg.di cassa non si può inserire un num magg.del max.rep.gestiti
C.Inattivo | Text | 1 | Articolo Inattivo (S/N)
C.Segnalazione | Text | 1 | Segnalazione se va sottoscorta : N Mai "S"=sempre, B=Solo ddt/bolla "F"=solo fattura
C.Sconto | Text | 15 | % da calcolare in cascata 10+12+...
C.Maggior | Double | 8 | % Maggiorazione
C.Provvigione | Double | 8 | % Provvigione
C.IvaVendite | Text | 4 | Codice Iva per Vendite
C.IvaAcquisti | Text | 4 | Codice Iva per Acquisti
C.GruppoForAb | Text | 2 | \
C.MastroForAb | Text | 2 | Forn.abituale (per generare in autom.ordini acq.)
C.ContoForAb | Text | 4 | /
C.GruppoMerVen | Text | 2 | \
C.MastroMerVen | Text | 2 | Conto Ricavi Merce
C.ContoMerVen | Text | 4 | /
C.GruppoMerAcq | Text | 2 | \
C.MastroMerAcq | Text | 2 | Conto Conto Acquisto Merce (uso futuro per reg contabile da acquisti)
C.ContoMerAcq | Text | 4 | /
C.PezziPerConf | Long | 4 |
C.ScortaMassima | Double | 8 | Scorta mass.dell'articolo
C.ScortaMinima | Double | 8 | Scorta minima dell'articolo
C.LottoDiRiordino | Double | 8 |
C.PuntoDiRiordino | Double | 8 |
C.Settore | Text | 10 | per localizzazione articolo
C.Scaffale | Text | 10 |
C.Posizione | Text | 10 |
C.Articoli.Lunghezza | Double | 8 |
C.Articoli.Larghezza | Double | 8 |
C.Articoli.Altezza | Double | 8 |
C.PercRiduzione | Double | 8 |
C.PesoLordo | Double | 8 |
C.PesoNetto | Double | 8 |
C.ArticoloTrasf | Text | 20 | Codice articolo che deriva da quello principale per trasformazione
C.CoeffTras | Double | 8 | Coefficente con cui calcolare la quantità dell'articolo trasformato
C.OperTrasf | Text | 1 | Operatore per la trasformazione: * oppure /
C.ArticoloSost | Text | 20 | Codice articolo sostitutivo (non gestito, solo x informazione)
C.DataCrea | Date/Time | 8 | Data Creazione
C.DistBase | Text | 1 | Indica 0-NO 1=Pfinito, 2 =Intermedio , 3=Materiale di Base
C.LivGruppo1 - 2 | Text | 2 | Per Taglie/Colori (indicare il Gruppo di livelli da gest.Es.Taglie)
C.FlagLivLis | Text | 1 | Se abilitato Taglia/Colore, indica come gestire i prezzi. 0-solo per prodotto 1-sul primo livello 2-su entrambi i livelli
C.NumEtic | Integer | 2 | Num di etichette da stamp.x questo art. (il defaul è sulla tabmag)
C.TempoConsegna | Text | 15 |
C.Cauzione | Text | 1 | Si se l'articolo è una cauzione
C.TabIva.Iva | Text | 4 |
C.TabIva.Descrizione | Text | 30 |
C.DescrizioneBreve | Text | 10 |
C.TipoIva | Text | 1 | 0-Normale,1=Iva non detraib,2=Esente,3=non impon.,4=non imp.art.8 c.2,5=iva esclusa(art.15)
C.Aliquota | Double | 8 | da NON valorizzare se TipoIva =2,3,4,5
C.PercNonDetr | Double | 8 | Se tipo iva=1, qui ci va la % di indetraib. (50% o 100% o...)
C.Scorporo | Text | 1 | "S" = da scorporare "N" = iva normale (Vale per Tipo iva=0)
C.CodSostScorp | Text | 4 | (NON UTILIZZATO)
C.CodVentSpec | Text | 4 | Cod.iva per ventil speciale (deve essere di tipo 0 e con scorporo="N")
C.ProRata | Text | 1 | (non gest.)
C.AggPlafond | Text | 2 | S/N - S in corr.ai codici di esenzione che devono aggiornare il plafond utilizzato
C.ApplBolloEse | Text | 1 | S/N Indica se addebitare o no il bollo Esente se cliente esente cioè tutta la fattura è esente
C.EsclBollato | Text | 1 | S/N Esclusione da bollato (non gestito)
C.PercDetrIvaAgri | Double | 8 | % di detraibilità per iva agricola da applicare sulle vendite in liquidazione
C.ServCee | Text | 1 | S=Registra Servizi Intra Cee (importi da utilizz.per dich. annuale)
C.VolAffari | Text | 1 | S/N se Si concorre alla determinazione del volume d'affari
C.OpAttPass | Text | 1 | S/N Se Si in Dich.Periodica e annuale si somma in VP1 o VP2
C.CessIntraCee | Text | 1 | S/N Serve per il campo VP1 della Dich.Periodica
C.A74InterCee | Text | 1 | S/N Per liquid. ART.74Ter: Viaggi interamente nella Cee
C.A74InterFuoriCee | Text | 1 | S/N Viaggi interamente fuori Cee
C.A74InterMisti | Text | 1 | S/N Misti - Costi parte Cee e corrispettivi
C.A74InterMistiNoCee | Text | 1 | S/N Misti - Costi parte No Cee
C.A74IvaArt74Ter | Text | 1 | S/N Cod.Iva ordinario per IVA 74Ter
C.DescAttr1 - 5 | Text | 30 |

Per campi riga Lotto vedi Ddt

Campi delle SPESE

Nome del campo | Tipo | Lung. | Descrizione
S.Anno | Integer | 2 |
S.NumRif | Long | 4 |
S.Riga | Integer | 2 | N. Riga di spesa
S.FatSpese.Spesa | Text | 4 |
S.FatSpese.Iva | Text | 4 |
S.FatSpese.Percentuale | Double | 8 | % di add.spesa (se flag prec.=0)
S.FatSpese.Importo | Double | 8 | Importo Spesa (se flag prec.=1 o 2)
S.FatSpese.ImportoMax | Double | 8 | Importo max per applicab.spese in %
S.FatSpese.Iva | Double | 8 | Importo min per applicab.spese in %
S.Spese.Spesa | Text | 4 |
S.Spese.Descrizione | Text | 30 |
S.Spese.Iva | Text | 4 |
S.Gruppo | Text | 2 | \
S.Mastro | Text | 2 | codice della c/partita per scarichi contabili da fatt.
S.Conto | Text | 4 | /
S.AddebitoIva | Text | 1 | R=ripartita P=Propria (Se R la spesa va ripartita proporzionalmente sugli imponibili della fattura
S.TipoEvasione | Text | 1 | 1=Singola 2=Multipla 3=Somma
S.TipoAddebito | Text | 1 | P=%, I=a importo,R=importo x rata(per spese Bancarie)
S.Spese.Percentuale | Double | 8 |
S.Moneta | Text | 2 | Moneta della spesa
S.Spese.Importo | Double | 8 |
S.Spese.ImportoMax | Double | 8 | Importo max per applicab.spese in %
S.Spese.ImportoMin | Double | 8 | Importo min per applicab.spese in %
S.ImportoLire | Double | 8 |
S.ImportoMaxLire | Double | 8 |
S.ImportoMinLire | Double | 8 |
S.SoggScontoPagam | Text | 1 | S/N Indica se la spesa è soggetta allo sconto pagamento
S.Standard | Text | 1 | S/N Se si è da caricare nel doc.
S.RifStampa | Text | 1 | Un carattere libero per ident.la spesa nel filtro delle stampe
S.TabIva.Iva | Text | 4 |
S.TabIva.Descrizione | Text | 30 |
S.DescrizioneBreve | Text | 10 |
S.TipoIva | Text | 1 | 0-Normale,1=Iva non detraib,2=Esente,3=non impon.,4=non imp.art.8 c.2,5=iva esclusa(art.15)
S.Aliquota | Double | 8 | da NON valorizzare se TipoIva =2,3,4,5
S.PercNonDetr | Double | 8 |
S.Scorporo | Text | 1 | "S" = da scorporare "N" = iva normale (Vale per Tipo iva=0)
S.CodSostScorp | Text | 4 | Cod.iva sost.in caso di scorporo (NON UTILIZZATO)
S.CodVentSpec | Text | 4 | Cod.iva per ventil speciale (deve essere di tipo 0 e con scorporo="N")
S.ProRata | Text | 1 | Indica se e come è utilizzata a fine anno per il calcolo della % di Pro-Rata (non gest.)
S.AggPlafond | Text | 1 | S/N S nei cod.esenzione che aggiornano il plafond
S.ApplBolloEse | Text | 1 | S/N Indica se addebitare o no il bollo Esente se cliente esente cioè tutta la fattura è esente
S.EsclBollato | Text | 1 | S/N Esclusione da bollato (non gestito)
S.PercDetrIvaAgri | Double | 8 | % di detraibilità per iva agricola da applicare sulle vendite in liquidazione
S.ServCee | Text | 1 | S=Registra Servizi Intra Cee (importi da utilizz.per dich. annuale)
S.VolAffari | Text | 1 | S/N se Si concorre alla determinazione del volume d'affari
S.OpAttPass | Text | 1 | S/N Se Si in Dich.Periodica si somma in VP1 o VP2
S.CessIntraCee | Text | 1 | S/N Serve per il campo VP1 della Dich.Periodica
S.A74InterCee | Text | 1 | S/N Per liquid. ART.74Ter: Viaggi interamente nella Cee
S.A74InterFuoriCee | Text | 1 | S/N Viaggi interamente fuori Cee
S.A74InterMisti | Text | 1 | S/N Misti - Costi parte Cee e corrispettivi
S.A74InterMistiNoCee | Text | 1 | S/N Misti - Costi parte No Cee
S.A74IvaArt74Ter | Text | 1 | S/N Cod.Iva ordinario per IVA 74Ter

E' possibile testare il valore della variabile C_DettAttuale per intercettare il tipo di dettaglio che si sta stampando e stamparlo in modo diverso da quello stabilito.

NOTE VARIE

1) Esempio di filtro per poter stampare sempre l’indirizzo del cliente seguito dall’indirizzo di spedizione, quando c’è altrimenti stampa di nuovo quello del cliente (testando la variabile T_MancaSped=”S”).
Nota: nelle righe con PosY 62-74, che stampano di nuovo l’indirizzo cliente in mancanza di quello di accompagnamento, ci va un valore in LinY per far si che la stampa venga fatta comunque alle righe 48-60,
In pratica, in linY di queste righe si deve mettere la differenza tra il valore di PosY di queste 4 righe, 62-74 e quello delle righe 48-60 cioè 14 (cioè 62-48 ; 66-52 ;70-56 ; 74-60)

Per questa modalità NON serve attivare particolari parametri di personalizzazione

2) Stampa nel corpo fattura degli importi corrispondenti all'applicazione dello sconto1, sconto2 etc. sul totale merce

Gli sconti applicati sono quelli scritti sulla riga del documento, nel campo 'Sconto totale' nella forma 2+5+7+.. (2 è il primo sconto, 5 è il secondo, 7 il terzo etc.)
Per ottenere la stampa è necessario compilare una riga nella tabella StaLasPer dell'AziMenu.mdb per ogni filtro che si intende modificare (il filtro è individuato da Programma: 'StaFatSFat' e Modello), indicando il TipoSez: 53 e SottoSez: S1

poi inserire, nel Corpo del filtro interessato, 2 righe con Sottosezione: S1

Sottoz. | PosY | PosX | Opz | Larg | Campo
S1 | 0,5 | 26 | 0 | 61 | =$union("Totale Sconto: ";C_IndSconto)
S1 | 0,5 | 165 | 0 | 22 | C_TotMerceSc

Dove C_IndSconto indica il livello di sconto
E C_TotMerceSc l’importo dello sconto corrispondente

Nell’esempio le scritte Totale sconto 1/2/3 ..n vengono nella colonna ‘Descrizione articolo’ e gli importi corrispondenti nella colonna ‘Importo’ della riga

E’ disponibile anche la variabile C_IndSconto_Str che provoca la scritta:
Totale sconto 1/2/ ..n e non servirebbe farla precedere dalla scritta fissa “Totale sconto”

3) Stampa nel corpo fattura del totale merce scontata del primo sconto, scontata anche del secondo sconto, . etc.

Gli sconti applicati sono quelli scritti sulla riga del documento, nel campo 'Sconto totale' nella forma 2+5+7+.. (2 è il primo sconto, 5 è il secondo, 7 il terzo etc.)
Per ottenere la stampa è necessario compilare una riga nella tabella StaLasPer dell'AziMenu.mdb per ogni filtro che si intende modificare (il filtro è individuato da Programma: 'StaFatSFat' e Modello), indicando il TipoSez: 52 e SottoSez: S2
poi inserire, nel Corpo dei filtri interessati, 2 righe con Sottosezione: S2 simili a quelle descritte in precedenza, differiranno solo per la prima delle due, dove in 'campo' si scriverà: =$union("Tot.merce con sconto: ";C_InsSconto)

Se invece gli importi della merce scontata per i vari livelli di sconto si vogliono scrivere nel piede, potranno essere utilizzate le seguenti variabili, inserendo righe opportune nel filtro (piede), senza introdurre particolari sottosezioni:

T_TotMerce_Ind indica quanti livelli di sconti ci sono
T_TotMerceSc_N (N=1-10 con 1 con sconto 1, 2 con sconto 2)

T_TotMerceStrSc_N Come sopra ma variabile stringa


FILTRI - SINTASSI AMMESSE IN 'CAMPO'

In sintassi le parentesi quadre racchiudono degli elementi opzionali.

Sintassi:

Descrizione:

NomeCampo

Stampa nella posizione il contenuto della variabile. La variabile può essere messa a disposizione dal programma di stampa o essere un campo calcolato.

[variabile]=[@@]FormulaNumerica

oppure

[variabile]=[££]FormulaNumerica

Esegue dei calcoli tra valori numerici.

Se variabile viene omessa viene stampato nella posizione il risultato di FormulaNumerica altrimenti il risultato della formula viene memorizzato in Variabile (in questo caso la riga deve avere come Opzione = 1 non stampare).

In formula si possono usare + - * / ( ) NomiCampi, Variabili, valori numerici costanti.

Se i primi due caratteri di una formula sono @@ tutti i calcoli vengono fatti con dei currency (calcoli vengono arrotondati alla quarta cifra decimale). Quando il risultato è 0 viene trasformato in “”.

Se invece si usano ££ il risultato 0 rimane 0
Es.X= ££(X+(C_RigPrz*C_RigQta)-C_PrzTot)

Le funzioni utilizzabili sono:

Len( arg)

Restituisce la lunghezza in caratteri di Arg

Arrot( Val [;Tipo] [;Varr] [;Ndec])
Campo=Arrot(X)

Arrotonda valori numerici.

Val è il valore da arrotondare.
Tipo è il tipo di arrotondamento:
T = troncamento
S = valore superiore
A = Arrotondamento (anche una lettera diversa da S o da T)

Si può usare:

Varr, indica il valore a cui arrotondare (può ad es. essere 500)

Ndec, lo usa per calcolare il valore di arrotondamento.
Se negativo rappresenta il numero di decimali.
Se positivo, potenze di 10
Es. -2 arrotonda a 0,01
3 arrotonda a 1000

Instr( [start];Par1;Par2)

Restituisce la posizione di Par2 all’interno di Par1, eventualmente facendo partire la ricerca dal carattere numero Start

Perc( Par1;Perc)

Calcola il valore percentuale.

Es. Perc(200,10) rest. 20

PercS( Par1;Perc)

Calcola la maggiorazione o lo sconto.
Es PercS(200,10) rest. 220

PercS(200,-10) rest. 180

Scorp( Par1;Perc[;Dec])

Calcola lo scorporo

Se Dec è specificato l’importo viene troncato a Dec decimali (Dec è positivo).

ScorpS( Par1;Perc;[;Dec])

Calcola il valore scorporato.

Se Dec è specificato l’importo dello scorporo viene troncato a Dec decimali. (Dec è positivo)

Iva( Par1;Perc;Dec)

Calcola l’I.V.A. e arrotonda a Dec decimali (Dec è positivo) (arrotonda all’ importo superiore).

IvaS( Par1;Perc;Dec)

Calcola l’importo ivato e arrotonda a Dec decimali (Dec è positivo) (arrotonda all’ importo superiore).

Cvdate( Par1)

Trasforma la stringa Par1 in data

DateDif( Data1;Data2)

Restituisce i giorni tra le due date

DateSom( Data;Par1[;Tipo])

Data. data di partenza per il calcolo.

Par1. Espressione numerica corrispondente al numero di intervalli da aggiungere. Può essere positiva, per ottenere date future, oppure negativa, per ottenere date passate.

Tipo. Espressione stringa corrispondente all'intervallo di tempo che si desidera aggiungere.

Le possibili impostazioni dell’argomento
Tipo sono:
Impostazione Descrizione
Yyyy Anno
q Trimestre
m Mese
y Giorno
d Giorno (Predef.)
w Giorno della settimana
ww Settimana
h Ora
n Minuti
s Secondi

Giorno( Par1)

Restituisce il giorno del mese.

Par1 Espressione Data

WGiorno( Par1[;Par2])

Restituisce un numero corrispondente ad un giorno della settimana.
Domenica = 1
Par1 Espressione Data
Par2 Costante numerica (1-7) si può impostare per variare il primo giorno della settimana che di default è 1 cioè domenica.

Mese( Par1)

Restituisce il mese.

Par1 Espressione Data

Anno( Par1)

Restituisce L’anno.

Par1 Espressione Data

Val( Par1)

Restituisce il valore numerico del parametro passato.

Par1 Espressione stringa.

FunzVaria( par1;par2,……)

E’ possibile utilizzare altre funzioni messe a disposizione dal programma di stampa.

Es. incremento la variabile d’appoggio Sqta con Quantita:
Sqta=Sqta+Quantita
TotDoc=TotDoc+(Prezzo * Quantita)

Es. Stampo nella posizione definita: prezzo per quantità
=Prezzo * Quantita

Per azzerare la variabile a fine pagina occorre mettere una riga nel piede dove si azzera la variabile: Sqta=0

[variabile]=$ FormulaStringa

 Esegue delle elaborazioni con stringhe.

Se variabile viene omessa, viene stampato nella posizione, il risultato di FormulaStringa, il risultato della formula viene memorizzato in Variabile (in questo caso la riga deve avere come Opzione = 1 non stampare).
In formula si possono usare NomiCampi, Variabili, Costanti Stringa
E i seguenti comandi:

Union( par1;par2[;par3,…..])

Unisce le stringhe Par1,par2…
Il numero di parametri è variabile.

Mid( Par1;posP[;Lung])

Estrae un gruppo di caratteri della stringa Par1 a partire da posP per Lung caratteri. Se Lung viene omesso, estrae fino alla fine di Par1

Left( Par1;Lung)
(Se$ Left(xx;2) = "rb")

Estrae i primi Lung caratteri dalla stringa Par1

Right( Par1;Lung)

Estrae Lung caratteri alla destra di Par1

Ucase( Par1)

Converte in maiuscolo Par1

Lcase( Par1)

Converte in minuscolo Par1

Riempi( Par1;Num)

Restituisce una stringa formata da Num ripetizioni di Par1

Format( Par1;Par2)

Trasforma un valore numerico in una stringa.
Par1. Espressione numerica che rappresenta il valore da convertire in stringa.
Par2. Espressione stringa che rappresenta la modalità di trasformazione. (può essere anche Feuro, FLire, FQua, FEuroG, FLireG, FMon, FMonG).

RTrim( Par1)

Toglie gli eventuali spazi a destra da Par1

LTrim( Par1)

Toglie gli eventuali spazi a sinistra da Par1

Trim( Par1)

Esegue RTrim e LTrim da Par1

Esempi:
Metto in IndirCom tutti gli elementi di un indirizzo
IndirCom =$union(CliIndir;" ";CliCap;" ";CliLocalita;" (";CliProvincia;")")
Stampo il nome con la prima lettera maiuscola e le seguenti minuscole:
=$union(ucase(left(nome;1));lcase(mid(nome;2)))

Se si vogliono stampare i doppi apici si dovranno mettere, come costante, tra apici singoli (es. ‘”’)

Si possono stampare dei caratteri di controllo mettendo nella stringa chr$(X) con X =numero es. chr$(13) per inserire un ‘andare a capo’

Es. =$union(mid("pippo";3);chr$(65);"s";chr$(13);"fine") produrrà la stampa della stringa ppoAs poi va a capo e scrive fine

:NomeEtichetta

Definisco un’etichetta a cui posso fare riferimento nei comandi Se e Vai

Vai [:]NomeEtichetta

La stampa salta tutti i campi tra questo campo e il campo che contiene :NomeEtichetta.
I due punti prima del NomeEtichetta sono opzionali.
N.B. il campo che contiene l’etichetta a cui saltare deve essere successivo (in ordine di PosY e PosX) (non si può saltare a campi precedenti).

Se Ar1 Op Ar2 [;vai NomEt]

Oppure

Se$ Ar1 Op Ar2 [;vai NomEt]

Salto condizionale.
Ar1 e Ar2 sono formule numeriche in caso si utilizzi Se, sono formule stringa se si utilizza Se$.

Op è un operatore di confronto. Gli operatori ammessi sono: >,<,>=,<=,=,<>

Se il nome NomEt (nome dell’etichetta a cui saltare) non è specificato e il test è verificato, la riga successiva del Modello viene eseguita altrimenti viene saltata.
Se si è specificato NomEt e il test è verificato vengono saltate tutte le righe fino all’etichetta NomEt.
N.B. il campo che contiene l’etichetta a cui saltare deve essere successivo (in ordine di PosY e PosX) (non si può saltare a campi precedenti).

=IIF(Test;Val1;Val2)

I Test possibili sono: >,<,>=,<=,=,<>
Se Test è vero restituisce Val1 altrimenti Val2
Val1 e Val2 sono variabili considerate sempre entrambe dello stesso tipo. Per definirle stringa occorre far precedere la prima da $$
Esempio:
=$iif($$T.Sesso = "M";$$"Maschio";$$"Femmina")
oppure:
=iif(anno(cvdate(Dt))<2000;giorno(cvdate(Dt));mese(cvdate(Dt)))

In caso di stampa di Variabili che potrebbero non essere mai inizializzate (non essere mai state assegnate) occorre inizializzarle nel seguente modo:
Variabili numeriche: Var = Var + 0
Variabili stringa : Var =$ union(Var ; “”)
Per azzerare una variabile
Var = $""

‘Nome campo’ particolari:
RigaPari
Restituisce –1 quando si sta stampando una riga di dettaglio pari.

Durante la stampa nel corpo di alcune righe particolari , ad esempio le spese, il formato controlla che il codice relativo (alle spese) non sia coinvolto direttamente nella stampa della testata o del piede. Se il codice relativo alle spese si trova dentro una formula il cui risultato viene memorizzato in una variabile d’appoggio le spese continuano ad essere stampate nel corpo del documento.
Il programma controlla se il campo è contenuto in una riga di testata o di piede con "opzione" = 0. Per non far stampare il campo nè nel corpo nè in testata/piede, basta inserire una riga in testata o piede con il nome del campo e "lunghezza" = 0.

Stampa immagini

Si possono stampare sui documenti delle immagini es. il logo della ditta o le immagini collegate agli articoli.
Per fare questo occorre predisporre sul filtro righe opportunamente compilate Vedi "Linea".


FILTRI - NOTE SU 'SOTTOSEZIONI'

Database di personalizzazione codice SottoSezione

Per sezioni s’intendono La testa, il corpo ed il piede del documento. Le sottosezioni servono per identificare all’interno di ogni sezione delle varianti.

Varianti principali e rispettivi codici sottosezione.

Nome Costante | Val. della costante | Sottosezione a cui ci si riferisce | Codice Sottosezione standard
KSMsotTesNorm | = 0 | testata normale | 0
KSMsotTes2 | = 1 | testate successive alla prima | 1
KSMsotTesPari | = 2 | testate Pari (non si usa kSMsotTes2) | 2
KSMsotTesDisp | = 3 | testate Dispari (non si usa kSMsotTes2) | 3
KSMsotTesFincatura | = 9 | testate Fincatura | Z
KSMsotPieNorm | = 10 | piede normale | 0
KSMSotPieCont | = 11 | piede Continua | 1
KSMSotPieCont | = 19 | Piede Fincatura | Z
KSMsotDetNorm | = 20 | Dettaglio normale | 0
KSMsotDetDes | = 21 | Dettaglio per riga descrittiva | 1
KSMsotDetDesArt | = 22 | Dettaglio per descrizione articolo (lunga)(*) | 2
KSMsotDetNote | = 23 | Dettaglio per le note fisse e note sopra | 3
KSMsotDetSpese | = 24 | Dettaglio per le spese | 4
KSMsotDetScoPag | = 25 | Dettaglio per lo sconto pagamento | 5
KSMsotDetScoPag1 | = 26 | Prima riga del dettaglio per lo sconto pagamento | 6
KSMsotDetFineCorpo | = 27 | Dettaglio per riga di fine corpo | 7
KSMsotDetFincatura | = 28 | Dettaglio Fincatura | Z
KSMsotDetSS | = 29 | Dettaglio generico per i cod. da 30 a 36 | 9
KSMsotDetBanca | = 30 | Dett. Ord./Prev./Acq: Banca di appoggio | 10
KSMsotDetModPag | = 31 | Dett. Ord./Prev./Acq: Modalità di pagamento | 11
KSMsotDetDataCon | = 32 | Dett. Ord./Prev./Acq: Data consegna | 12
KSMsotDetValOff | = 33 | Dett. Ord./Prev.: Durata validità offerta | 13
KSMsotDetResa | = 34 | Dett. Ord./Prev.: Resa | 14
KSMsotDetConsMez | = 35 | Dett. Ord./Prev./Acq: Consegna a mezzo | 15
KSMsotDetDescrPreiv | = 36 | Descrizioni prezzi ivati | 16
KSMsotDetIntDet | = 37 | Intestazione dettaglio | 17
KSMsotDetTotali | = 38 | Totale prev/ord/ddt/Fatt finale/ parziale | 18
KSMsotDetTotOmaggio | = 39 | Totale omaggi | 19
KSMsotDetPriLib KSMsotDetUltLib | 40 -> 49 | Dettaglio libero (1 -> 10 ) | 20 -> 29
 | = 12 | Dettagli per lotti | L
KSMsotDetRitAcc | = 50 | Dett. per Ritenuta d’acconto (T_RitAcc) | 30
 |  | Dett. per Cassa Previdenza (C_TotCassaPrev) | 31
 | = 52 | Nel Corpo: stampa il 'Totale Merce' senza sconto, con sconto 1, con sconto 2 etc. (T_TotMerceSc_N n=1..10) | S2
 | = 53 | Nel Corpo: stampa i totali SCONTO (importi) | S1
 |  | Nel fine Corpo stampa riepilogo raggruppato per descrizione attributi, unità di misura e quantità (Es.Riepilogo ADR) Parametri di personalizzazione : SezStaTotAttr e StTotAttrTit | AD (default)

Queste sono le assegnazioni standard fatte da programma.

Se si vuole modificare quest’assegnazione lo si può fare modificando la tabella StaLasPer o StaModPer nel seguente modo:

Programma = Nome del programma di stampa
Es. StaDdt Stampa doc. di trasp.

Modello= Nome del modello di stampa
Es. Prova Modello di prova

TipoSez = Nome del tipo sezione Es. 20 (kSMsotDetNorm )
La stampa del dettaglio normale

SottoSez = Il nuovo codice sottosezione da utilizzare
Es. A La stampa utilizzerà le righe del formato di stampa che hanno SottoSez= “A”

La testata normale e il dettaglio normale devono essere sempre definiti.

Per ogni Sezione (Testata, Corpo e Piede) c’è la sottosezione “Z” che contiene la fincatura che, se è stata definita, viene stampata prima della stampa della sottosezione (per stamparla dopo, vedere i parametri di personalizzazione: FincPrecDatiPieE / FincPrecDatiTest per i gruppi: StFatture / StDdt).

Per inibire la stampa di una sottosezione è sufficiente inserire nel formato una riga con quel codice sottosezione e nella definizione del campo non mettere niente oppure disabilitarla mettere il campo Opzione a 2.

(Es. se non si vogliono stampare le Note, sottosez.3, nemmeno con il formato della sottosez.1, si crea una riga di filtro con sottosezione 3 e campo da stampare vuoto)

(*) Se si mette nel filtro una riga con sottosezione 2, il programma stamperà sempre la descrizione aggiuntiva dell’articolo anche se il Tipo documento dice di non stamparlo. Il nome della variabile può essere anche RigDesart e non necessariamente C.DesLunga. Se non la metto fa quanto definito sul tipo documento.

Se alcune sottosezioni non sono definite, verranno utilizzate sottosezioni alternative secondo il seguente schema:

Testate:

Se Manca | Utilizza
Testata standard | OBBLIGATORIA
Testate successive alla prima | Testata standard
Testate Pari | Testata standard
Testate Dispari | Testata standard

Corpo:

Se Manca | Utilizza
Dettaglio normale | OBBLIGATORIO
Dettaglio per riga descrittiva | Dettaglio normale
Dettaglio per descrizione articolo | Dettaglio per riga descrittiva
Dettaglio per le note | Dettaglio per riga descrittiva
Dettaglio per le spese | Dettaglio normale
Dettaglio per lo sconto pagamento | Dettaglio normale
Prima riga del dettaglio per lo sconto pagamento | Dettaglio normale
Dettaglio per riga di fine corpo | Dettaglio per riga descrittiva
Tutti i Dett. Ord./Prev./Acq Generico (29) | Dettaglio per riga descrittiva
Tutti i Dett. Ord./Prev./Acq Specifico (30-36) | Tutti i Dett. Ord./Prev./Acq Generico
Dett. per Totale omaggi | Dettaglio normale
Tot.Finale/Parziale | Dettaglio normale
Dettagli per Ritenuta d’acconto | Dettaglio normale

Piede:

Se Manca | Utilizza
Piede standard | OBBLIGATORIO
Piede continua | Piede standard

Nota:
Nel corpo è possibile stampare sottosezioni particolari, inserite nel filtro, che vengono stampate solo se è attivo il parametro di personalizzazione: FineCorpo oppure se vengono inserite nel campo 'Sequenza sottosezioni' del Tipo documento.

Altra possibilità è quella di stampare a fine Corpo, un riepilogo raggruppato per descrizione attributi, unità di misura e quantità (Es.Riepilogo ADR) La sottosezione si può definire nel parametro di personalizzazione: SezStaTotAttr (sottosezione di default per questo riepilogo è AD) (Vedi anche parametro : StTotAttrTit)

Se, nel parametro SezStaTotAttr , dopo la Sottosezione si mette |C|20 , si intende di voler utilizzare la sottosezione 20 in caso di mancanza nel filtro della sottosezione indicata. (Cioe’ pipe , C per dire che è una sottosezione del Corpo, pipe , 20 è la sottosezione da usare in alternativa)

Sul database del menu c'è una tabella "StaLasPer" nella quale si può indicare quali sottosezioni utilizzare al posto di quelle predefinite. In corrispondenza ad un modello (filtro) si può indicare che un 'TipoSez' individuato dalle costanti (KSMsot ....) descritte sopra va stampato con la 'SottoSez' N dove N è il nuovo codice sottosezione, piuttosto che con quello standard.

E' possibile testare, nel 'corpo' di un filtro, il valore della variabile C_DettAttuale per intercettare il tipo di dettaglio che si sta stampando e stamparlo in modo diverso da quello stabilito.
I valori che può assumere C_DettAttuale sono i seguenti:

Nome Costante | Val. della costante | Tipo dettaglio da stampare
kDetNotaSopra | 0 | nota sopra
kDetNormale | 1 | dettaglio standard (articolo)
kDetNotaSotto | 2 | nota sotto
kDetDescrArt | 3 | descrizione lunga articoli
kDetSpese | 4 | spese
kDetScoPag | 5 | sconto pagamento nel dettaglio
kDetNotaFissa | 6 | note fisse
kDetMessaggioInProva | 7 | Se stampa in prova scrive **Prova ** Rif. Nr. Data
kDetFineCorpo | 8 | dettaglio standard (articolo)
kDetDettaglioBolle | 9 F | Elenco bolle (num. e data)
kDetTotOmaggio | 10 F 21 O | riga: Totale omaggio
kDetDesOmaggio | 11 F 22 O | riga: **=Merce omaggio con addebito Iva oppure *=Merce Omaggio
kDetDataCon | 12 O B |
kDetValOff | 13 O B |
kDetResa | 14 |
kDetConsMez | 15 |
kDetDescrPreIv | 16 | Descrizione: prezzi ivati
kDetIntDet | 17 | Per righe commando: stampa intestazione dettagli
kDetTotaleParz | 18 | Per righe commando: stampa totale parziale
kDetTotaleFin | 19 | Per righe commando: stampa totale finale
kDetBanca | 20 F 10 O B |
kDetModPag | 21 F 11 O B |
kDetRitAcc | 22 F 20 O | riga: Ritenuta d’acconto: x%
kDetLotti | 30 F B | Elenco lotti
kDetFiniti | 99 | sottosezioni elencate nel parametro FineCorpo o nel tipo documento

F indica il valore che la costante ha in stampa Fattura, D in stampa Ddt e O in stampa Ordine.
Dove è indicato solo il valore della costante, si intende che è lo stesso per tutte le stampe.
Es. per stampare all'interno del corpo, le note fisse con un formato diverso dalle note sopra e sotto, si possono mettere nel filtro delle righe nella sottosezione 3 (dettaglio per note fisse e note sopra) col test: se C_DettAttuale = 6;Vai xxx dove tipo dettaglio 6 è note fisse.


FILTRI PER STAMPA ETICHETTE

Tramite i 'filtri o modelli' è possibile definire dei tracciati di stampa personalizzati per stampare etichette con i dati di clienti e fornitori e degli articoli di magazzino.

I filtri cambiano al cambiare del tipo di stampante ed è per questo che, per la stessa stampa, ci saranno filtri diversi per le stampanti laser e stampanti ad aghi, predisposti da due programmi di gestione diversi ai quali si accede dal menu premendo contemporaneamente i tasti CTRL ALT SHIFT L e scegliendo, tra quelli proposti, rispettivamente:
Gestione filtri etichette Laser
Gestione filtri etichette Aghi

I filtri di stampa vengono memorizzati nel database del menu: azimenu.mdb (presente nella cartella ....\aziwin) in particolare nelle tabelle StEtLasTes e StEtCampi (per le stampanti Laser) e StEtModTes e StEtModCampi (per le stampanti ad aghi).
Sono perciò utilizzabili da tutte le aziende gestite. Se si creano o si modificano dei filtri di stampa, si raccomanda di fare sempre la copia del database del menu per poter riprendere i filtri nell'eventualità ci siano problemi sul database originale.


FILTRI ETICHETTE SU STAMPANTI LASER

Vedi anche Filtri etichette

Per la compilazione di un filtro occorre impostare prima alcune caratteristiche generali poi elencare, nel particolare, tutti i campi, le immagini, le fincature che si vogliono stampare nel corpo dell'etichetta.
Inoltre, con il pulsante [image] (Y) Trasferimento Filtri, è possibile 'importare' un filtro da un altro Data Base, purchè esso non esista già, sul DB di destinazione, come nome programma e modello.
Se si vuole cambiare nome al filtro da caricare, possono scrivere, prima di confermare il trasferimento, il nuovo nome di Programma e Modello.

Il tipo di font utilizzato di default è l’Arial mentre l’altezza del carattere si può personalizzare per ogni campo.
Tutti i valori, salvo dov’è specificato diversamente, sono in millimetri.

Nel modello per Laser: nell’etichetta degli articoli di magazzino, per la stampa del logo si fa riferimento, nel campo ‘campo’ a aziendapc.jpg, questo file viene installato in ….\aziwin\immagini e dovrà essere sostituito con il nome del file bmp contenente il logo del cliente.

Elenco campi generali del documento

Programma
Nome del programma di stampa

  • StaEtiCFetcf - Etichette clienti e fornitori
  • StaEtiMgetmg - Etichette articoli di magazzino

Modello
descrizione libera che individua i vari modelli di stampa impostati per lo stesso programma (es. EtiBarCo)

Descrizione
Descrizione della stampa.

Spazio vuoto da lasciare in testa (SpzAlt)
Consente di spostare in alto o in basso tutta la stampa.

Spazio tra le colonne di etichette (SpzTraCol)

Margine sinistro (SpzSin)

Margine destro (SpzDes)

Spazio tra righe di etichette (SpzTraRig)

Larghezza dell'etichetta (EtiLarg)

Altezza dell'etichetta (EtiAlt)

Valore utilizzato per sfondi grigi (ValGrigio)
 0= Nero, 255=Bianco. Valore predefinito: 220.

Valore utilizzato per le ombre dei rettangoli (ValNero)
 0= Nero, 255=Bianco. Valore predefinito: 0.

Numero di colonne di etichette (NColEti)

Numero di righe di etichette (NRigEti)

Orientamento del foglio (Orientamento)
1 = Verticale (vbPRORPortrait)
2 = Orizzontale (vbPRORLandscape)

Una volta confermati i dati della testata, si dovrà specificare l'elenco dei campi da inserire nell'etichetta.

  • Gestione dettaglio [image] (E)

PosY
Distanza verticale in millimetri dalla riga precedente, della posizione in cui verrà stampato il campo.
Per le testate, dal margine superiore del foglio,
per i dettagli, dal margine superiore della riga attuale in stampa,
per il piede, dalla fine del corpo.
Questo campo insieme con PosX stabilisce l’ordine con cui vengono elaborati i campi di stampa. Si può mettere anche valori negativi per eseguire dei calcoli prima di una sezione.

PosX
Distanza in mm dal margine sinistro del foglio, della posizione in cui verrà stampato il campo. Questo valore insieme con PosY stabilisce l’ordine con cui vengono elaborati i campi di stampa.
Il programma calcola le coordinate del campo da stampare sottraendo al valore di PosX e PosY rispettivamente il valore di LinX e LinY (che nelle righe non grafiche hanno, solitamente, valore 0).
Questo poiché i due campi PosX e PosY sono indici e non possono essere inserite nel filtro più righe con gli stessi valori. Se si rende necessario avere due o più campi da stampare nella stessa posizione, in alternativa, si possono inserire, ad esempio, con valori progressivi di PosY e in uno dei due mettere in LinY quel valore che, sottratto al PosY da il PosY giusto.

Opzione
Indica il tipo di riga

  • 0 : campo normale
  • 1 : da non stampare (utilizzato per righe che contengono calcoli che vanno ad assegnare una variabile).
  • 2 : riga di commento (il campo non verrà né elaborato né stampato)

Larghezza
Larghezza, in millimetri, a disposizione per la stampa del campo. Se la larghezza è uguale a zero il campo non viene stampato, ma la riga del modello rimane valida per qualsiasi elaborazione. (Al contrario che opzione = 2 che esclude la riga del modello da qualsiasi elaborazione).

Campo
Riferimento al campo di stampa. Per consultare l'elenco dei campi disponibili consultare:
Campi disponibili per etichette
Oltre al nome di un campo, in questa casella si può inserire anche un test etc. Vedi “Sintassi ammesse in CAMPO”

Multiriga
Da utilizzare per la stampa dei campi Memo
Se viene posto ad "S" e lo spazio a disposizione non è sufficiente per la stampa del campo, la parte rimanente del campo viene stampata nella prossima occorrenza dello stesso Campo con Multiriga = “S”. Il campo nel filtro, va ripetuto per tante righe quante se ne voglio stampare, sempre con multiriga=S
Se il campo con Multiriga = “S” è nel dettaglio, la stampa del campo prosegue nel dettaglio successivo, fino alla stampa completa del campo (es.: una ‘descrizione lunga articolo’ che non si riesce a stampare nello spazio ad essa assegnato perché più lunga).

NoStaVuoto
Se è ="S", non stampa i campi vuoti. (se data = null o data = 1/1/100 o numerico = 0) Attenzione, se si mette questo campo =S in righe che stampano delle linee, queste linee non verranno stampate (se il campo è vuoto viene saltata tutta la fase di stampa del campo).

Fisso
Stringa fissa in alternativa al campo.

Formato
Espressione stringa che rappresenta il formato di stampa in alternativa a quello standard del campo. Nel caso in cui si metta direttamente il formato esso va messo tra virgolette e la notazione dei separatori dei decimali e delle migliaia è quella anglosassone ( . = separatore dei decimali ; , = separatore delle migliaia)
Si può utilizzare anche una variabile messa a disposizione dal programma:

  • Feuro per il formato di un importo in Euro
  • FLire, per il formato di un importo in Lire
  • FQua per il formato delle quantità (FquaG stampa tutti i decim. Es. 1,10 – 2,00)
  • FEuroG per il formato dell’ Euro utilizzando il numero di decimali che sono stati impostati sulla moneta in "nr.decimali gestione"
  • FLireG, per il formato delle Lire utilizzando il numero di decimali di gestione
  • FMon per il formato della moneta del documento
  • FMonG per il formato della moneta utilizzando il numero di decimali di gestione

Es. formato con separatore di migliaia e un decimale: “#,##0.0”
oppure per riempire di zeri a sinistra un campo: “00000”
es. colli nei Ddt
oppure per utilizzare il formato dell’Euro: FEuro
oppure per utilizzare il formato dell’Euro con un decimale in più:
Union(FEuro;”0”)
In alternativa si può utilizzare un formato multiplo es. "#,##0.00;;#" che contiene 3 formati diversi separati da ;
I tre formati sono rispettivamente quello per i positivi, quello per i negativi, quello per gli importi a 0. Se si omette quello per i negativi, essi verranno stampati con lo stesso formato dei positivi.

Allineamento
S = Sinistra, D = Destra, C = Centrato. Al campo in stampa vengono tolti i caratteri bianchi iniziali, se si vogliono lasciare, si può inserire F in questo campo.

FontSize
Grandezza Font.

Grassetto
Se è = "S", stampa in grassetto.

Italico
Se è = "S", stampa in Italico.

Linea
Dovrà essere impostato = "S" per la stampa di un elemento grafico (linee o rettangoli con caratteristiche specificate in LinX, LinX1 etc).
In questo caso i valori precedenti, da larghezza a italico, verranno ignorati
altrimenti, verranno ignorati, i valori seguenti.

Se è impostato = “C” serve per impostare i colori da usare da quel momento in poi, finchè non viene cambiato o ripristinato al valore di default usando un'altra riga con valore Linea = “C”.
Il colore da usare, espresso in modalità RGB cioe’ Rosso/Verde/Blu viene messo in Campo con le seguenti possibilità:

  • Valore esadecimale corrispondente al colore da impostare (es. &HFF00 = verde)
  • Valore numerico da 0 a 16.277.215 indicante il colore da usare (es. 255 = rosso)
    Per ottenere questo valore dal codice RGB (X Y Z) si procede come segue:
    X + (Y*256) + (Z*256*256)
  • Stringa costante identificante uno degli otto colori di base.
    I valori riconosciuti sono: Azzurro, Bianco, Blu, Giallo, Magenta, Nero, Rosso, Verde

Per ripristinare il colore di default, cioè il colore impostato automaticamente nella stampante all’inizio della stampa, dovrà essere inserita un'altra riga con il campo "Linea" valorizzato a C e il campo "Campo" impostato con uno dei seguenti valori: default, def, standard, std.

Se è impostato = “G”, la riga riguarda la stampa di una immagine grafica da file, il cui nome, ed eventualmente il percorso, è specificato in "Campo" come stringa.
Utilizzato per la stampa del logo della ditta (es. il contenuto del campo "Campo" può essere: =$”sira.bmp”) o la stampa dell'immagine collegata all'articolo sui documenti.
La posizione di stampa è specificata dalle coppie LinX , LinY e LinX1 , LinY1.
Con LinX1 e LinY1 negativi, l’immagine viene stampata con le dimensioni originali.
I formati grafici supportati sono: bmp, gif, jpg.
Se in "Campo" non è scritto, oltre al nome del file dell'immagine anche il percorso in cui esso si trova, il programma lo cerca là dove specificato nel file aziwin.ini in DirImmagini (di default: ....\aziwin\immagini):
[Base]
DriveDb= ………
DirImmagini=…………

LinDrawWidth
Larghezza della linea in pixel. (Dipende dalla risoluzione della stampante)

LinX , LinY
Vanno valorizzate nelle righe in cui è a S il campo Linea. Se linea =N si può mettere un valore e il programma sottrae dal contenuto di POSX e POSY questo valore (serve per inserire nel filtro campi diversi che vanno stampati, su condizione, nello stesso posto ma mettendo PosX e PosY uguali da errore di indice doppio)

Coordinate di partenza della linea.
Per testate sono relative al margine superiore del foglio.
Per i dettagli sono relative margine superiore della riga attuale in stampa.
Per il piede sono relative alla fine del corpo.

LinX1 , LinY1
Coordinate d’arrivo della riga.

LinBox
Se = "S" la stampa è di un rettangolo

LinGrigio
Se = "S" stampa lo sfondo Grigio (Solo se linBox = "S")

LinOmbra
Se = "S" stampa l'ombra (Solo se linBox = "S")

STAMPA DEL CODICE A BARRE

Nella stampa di etichette articoli, sia che venga fatta con stampanti laser sia a getto d’inchiostro, è possibile stampare i codici a barre.
(Non è prevista invece la stampa di codici a barre con le stampanti ad aghi)
I codici a barre gestiti dalla procedura sono quelli più comuni e vengono identificati da un "Tipo codice a barre" che assumerà valori diversi a seconda del tipo di codice che si sta utilizzando, come specificato nella tabella che segue. Ogni articolo ha il suo "tipo codice a barre" e il suo codice a barre.

  • 12 Per utilizzare il codice 128 il quale permettere di utilizzare tutti i caratteri ascii e nel codice non viene memorizzato il check digit.
    Attenzione ad utilizzare simboli che non siano lettere o numeri. Prima di utilizzarli verificate che vengono stampati e riconosciuti correttamente.
  • 39 Per utilizzare il codice 39 il quale permettere di utilizzare codici alfanumerici con solo lettere maiuscole con check digit
  • 13 Per utilizzare il codice EAN 13
  • E8 Per utilizzare il codice EAN 8
  • UA Per UPC A (codice di 12 caratteri)

Se nel campo ‘Formato’ di StEtLasCampi non si scrive niente, il programma prenderà per ogni articolo il formato specificato sull’articolo. Se sull’articolo non è specificato il formato del codice a barre, il programma utilizzerà quello inserito in Tabella di magazzino.
Viceversa se i codici a barre sono tutti dello stesso tipo, sul filtro, nel campo formato, si può scrivere:
Tb=xx con xx=12 opp. Xx=39 opp. xx=13 etc. A seconda del tipo di codice a barre adottato per gli articoli.
Si può poi aggiungere la scritta NoCod per non veder stampato il codice in chiaro.
Es. Tb=12,NoCod

Nel filtro occorre inoltre compilare, sulla riga in cui si stampa il codice a barre, le colonne: Font, Grassetto e Italico con valori già impostati in una qualsiasi riga precedente.
Es. Allineamento = non valorizzato Font=8 Grassetto=N Italico=N
La mancanza di questi provoca la stampa del codice a barre in chiaro , con caratteri grandissimi.

Nel dimensionamento dei codici a barre bisogna anche tenere conto della densità delle barre, un codice di tipo 128,che richiede un numero elevato di barre, deve avere una larghezza di 3, 4 centimetri a seconda della lunghezza del codice da stampare.


FILTRI ETICHETTE SU STAMPANTI AD AGHI

Vedi anche Filtri etichette

Per la compilazione di un filtro occorre impostare prima alcune caratteristiche generali poi elencare, nel particolare, tutti i campi, le immagini, le fincature che si vogliono stampare nel corpo dell'etichetta.

Inoltre, con il pulsante [image] (Y) Trasferimento Filtri, è possibile 'importare' un filtro da un altro Data Base, purchè esso non esista già, sul DB di destinazione, come nome programma e modello.
Se si vuole cambiare nome al filtro da caricare, possono scrivere, prima di confermare il trasferimento, il nuovo nome di Programma e Modello.

Tutti i valori, salvo dov’è specificato diversamente, sono in Righe e Colonne (caratteri)

Elenco campi generali del documento

Programma
Nome del programma di stampa

  • StaEtiCFetcf - Etichette clienti e fornitori
  • StaEtiMgetmg - Etichette articoli di magazzino

Modello
descrizione libera che individua i vari modelli di stampa impostati per lo stesso programma (es. EtiBarCo)

Descrizione
Descrizione della stampa.

Righe per pagina (RigheTot)

Righe vuote prima di stampare la testata (RigheAlt)

Colonne margine sinistro (ColSin)

Colonne tra le etichette (ColTraCol)

Margine destro (ColDes)

Linee tra righe di Etichette (LinTraRig)

Larghezza dell'etichetta (EtiLarg)

Altezza dell'etichetta (EtiAlt)

Numero di colonne di etichette (NColEti)

Numero di righe di etichette (NRigEti)

Non è possibile cambiare tipo di carattere durante la stampa di una singola etichetta. Tutta l’etichetta va stampata con lo stesso carattere per problemi di posizionamento tra un’etichetta e l’altra
E' però possibile definire una sequenza di attivazione e una di disattivazione per stampare tutta l'etichetta con un carattere diverso da quello standard.
Sequenza di codici di controllo inizio stampa (CodConPri)
Sequenza di codici di controllo (Attivazione), che verrà eseguita all'inizio della stampa. In forma decimale separati dalla virgola
Es. per grassetto: 27,69 Es. per compresso: 15
Sequenza di codici di controllo fine stampa (CodConUlt)
Sequenza di codici di controllo (Disattivazione), che verrà eseguita alla fine della stampa. In forma decimale separati dalla virgola
Es. per grassetto: 27,70 Es. per compresso: 27,70

Una volta confermati i dati della testata, si possono gestire le righe dell'etichetta tramite il pulsante:

  • Gestione dettaglio [image] (E)

PosY
Riga per per testate, dal margine superiore del foglio, per i dettagli, dalla riga attuale in stampa, per il piede, dalla fine del corpo, in cui viene stampato il campo.
Questo campo insieme con PosX stabilisce l’ordine con cui vengono elaborati i campi di stampa. Si può mettere anche valori negativi per eseguire dei calcoli prima di una sezione.

PosX
Colonna in cui viene stampato il campo.
Questo campo insieme con PosY stabilisce l’ordine con cui vengono elaborati i campi di stampa.

Opzione
Indica il tipo di riga.
0 = campo normale.
1 = da non stampare (utilizzato per righe che contengono calcoli che vanno ad assegnare una variabile).
2 = riga di commento. Il suo contenuto verrà completamente ignorato.

Larghezza Numero dei caratteri da stampare nel campo.
Se la larghezza è uguale a zero il campo non viene stampato, ma la riga del modello rimane valida per qualsiasi elaborazione. (Al contrario che opzione = 2 che esclude la riga del modello da qualsiasi elaborazione).

Campo
Riferimento al campo di stampa. Per consultare l'elenco dei campi disponibili consultare:
Campi disponibili per etichette
Oltre al nome di un campo, in questa casella si può inserire anche un test etc. Vedi “Sintassi ammesse in CAMPO”

MultiRiga
Se è = "S" e lo spazio a disposizione non è sufficiente per la stampa del campo, la parte rimanente del campo viene stampata nella prossima occorrenza dello stesso Campo con Multiriga = “S”. Il campo nel filtro, va ripetuto per tante righe quante se ne voglio stampare, sempre con multiriga=S
Solo se il campo con Multiriga = “S” è nel dettaglio, la stampa del campo prosegue nel dettaglio successivo, fino alla stampa completa del campo. Da utilizzare per la stampa dei campi Memo

NoStaVuoto
Se è ="S", non stampa i campi vuoti. (es.data = null o data = 1/1/100 o numerico = 0 )
Attenzione: se si mette questo campo =S in righe che stampano delle linee, queste linee non vengono stampate (se il campo è vuoto viene saltata tutta la fase di stampa del campo).

Fisso
Stringa con un contenuto fisso (una parola o una frase). Da compilare In alternativa al campo "campo".

Formato
Espressione stringa che rappresenta il formato di stampa in alternativa a quello standard del campo. Nel caso in cui si metta direttamente il formato esso va messo tra virgolette e la notazione dei separatori dei decimali e delle migliaia è quella anglosassone ( . = separatore dei decimali ; , = separatore delle migliaia)
Si può utilizzare anche una variabile messa a disposizione dal programma:
Feuro, per il formato di un importo in Euro
FLire, per il formato di un importo in Lire
FQua, per il formato delle quantità
FEuroG, per il formato dell’ Euro utilizzando il numero di decimali di gestione
FLireG, per il formato delle Lire utilizzando il numero di decimali di gestione
FMon, per il formato della moneta del documento
FMonG, per il formato della moneta utilizzando il numero di decimali di gestione

Es. formato con separatore di migliaia e un decimale: “#,##0.0”
oppure per riempire di zeri a sinistra un campo es. colli nei Ddt: “00000”
oppure per utilizzare il formato dell’Euro: FEuro
oppure per utilizzare il formato dell’Euro con un decimale in più: Union(FEuro;”0”)

Allineamento
S = Sinistra, D = Destra, C = Centrato.

Non è possibile cambiare tipo di carattere durante la stampa di una singola etichetta.
Tutta l’etichetta va stampata con lo stesso carattere per problemi di posizionamento tra un’etichetta e l’altra


CAMPI DISPONIBILI PER ETICHETTE (FILTRI DI STAMPA)

Campi messi a disposizione per la stampa etichette di magazzino

Nome variabile |
E_CodArt |
E_PrezzoLire |
E_Prezzo |
E_PrezzoLireIvato | prezzo lire ivato o scorporato a seconda di com’è il listino (cod.iva vendite)
E_PrezzoIvato | prezzo ivato o scorporato a seconda di com’è il listino (cod.iva vendite)
E_PrezzoConIva | prezzo ivato (se il listino è al netto dell'iva, si utilizza il cod.iva vendite o acquisto dell'articolo a seconda che il listino sia di vendita o di acquisto)
E_PrezzoSenzaIva | prezzo senza iva

E inoltre tutti i campi della tabella Articoli, ArtListini con la sintassi: A.NomeTabella.NomeCampo
(es. A.Articoli.Descrizione, A. ArtListini.Listino etc.)

Vedi Stampa codice a barre

Campi messi a disposizione per la stampa etichette Clienti e Fornitori

Nome variabile |
E_Gruppo | \
E_Mastro | > Codice cliente/fornitore
E_Conto | /
E_Codice | Codice completo
E_RagSoc | Ragione sociale del cliente
E_RagSoc2 | Seconda parte della ragione sociale
E_Indirizzo | Indirizzo
E_CAP | Cap
E_Localita | Località
E_Pr | Provincia
E_CapLocPr | CAP + Località + Provincia
E_Stato | Stato

E’ inoltre possibile riferirsi ai seguenti campi facendoli precedere da P. ad es. P.Pianoconti.Telefono
Pianoconti.*
Zone.Descrizione
Categorie.Descrizione
Banche.Descrizione
Listini.Descrizione
Agenti.RagSoc
Agen2.RagSoc
Vettori.RagSoc
Rese.Descrizione
Lingue.Descrizione
Pagamenti.Descrizione
Categorie.Descrizione
Tabiva.Descrizione
Spese.Descrizione
IndSped.*
Merci.descrizione

Se si stampano etichette settando il flag “Stampa Indirizzo di spediz.collegato” sono disponibili anche:
Ammistr.* (dati indirizzo spedizione collegato a Pianoconti.IndAmm)

Se si stampano etichette con tipo stampa “Fatture clienti” sono disponibili anche:
FatTest.PreDoc
FatTest.NumDoc
FatTest.Anno
Ammistr.* (dati indirizzo spedizione collegato a Pianoconti.IndAmm)

Non è possibile stampare le Note Fisse nel piede perché verrebbero stampate 2 volte


STAMPA SU PDF

La procedura consente di produrre il Pdf di qualsiasi stampa e in particolare di Preventivi, Ordini, Ddt, Fatture, Scontrini.
Il file Pdf generato viene memorizzato nella cartella indicata dal parametro DirPdf che va inserito manualmente nel paragrafo [BASE] del file aziwin.ini generale (cartella aziwin) o del terminale (cartella aziwin\main) (Es. DirPdf=c:\FatturePdf)

Per differenziare le cartelle dove memorizzare i file (es. cartelle diverse per fatture , ddt , scontrini) si dovrà mettere questo parametro nelle rispettive sezioni [staFATSFAT] - [StaDDTsDdt] - [ScontrinX] indicando in ciascuna una cartella diversa

Se non si imposta DirPdf, il file verrà salvato nella cartella 'aziwin\carica' (quella indicata dal parametro DirCarica di Aziwin.ini).

Per fare in modo che il programma possa assegnare in automatico nome e destinazione del file pdf, è necessario attivare alcuni parametri e utilizzare applicativi per la stampa su pdf, ben precisi.

  • PdfCreator
  • PDF995

L'impostazione dei parametri sul file INI, si può fare manualmente o da qualsiasi programma di stampa, premendo il pulsante 'Selezione destinazione stampa' poi 'Par. INI Pdf ed Email'.

Per la stampa dei documenti su pdf, sono disponibili inoltre dei parametri di personalizzazione che consentono di impostare il nome del file etc.

PdfCreator
Si può scaricare dal sito www.aziendapc.it
(le versioni presenti sui siti: http://pdfcreator.softonic.it/ o http://sourceforge.net/projects/pdfcreator/ potrebbero non essere compatibili)
Per utilizzarlo occorre inserire nella sezione [StampaPdf] del file AziWin.ini generale o del terminale, la riga: UsaPdfCreator =S

Si ricorda che il software Pdf995 è shareware.
Per utilizzarlo occorre inserire nell' aziwin.ini il parametro UsaPdf995

Una alternativa alla modifica del file aziwin.ini è inserire un parametro di personalizzazione UsaPdfCreator impostato a S (oppure UsaPdf995).
Gruppo: Pdf
Resta comunque il fatto che, indipendentemente dal parametro di personalizzazione, se nel file INI c'è la riga di cui sopra, il programma si comporta di conseguenza.

PROGRAMMI NON PIU' IN USO:
Ghostscript e RedMon
Nota: Se si lavora con Windows7 a 64 bit, utilizzare Redmon17x64.
Seguono le note per predisporre l'installazione di una stampante postscript che consenta la stampa su Pdf.

Se si lavora su un computer con S.O. Vista o Windows7, seguire le note: SO Vista

Vedere anche Parametri per stampa fattura su Pdf

  • Installare ghostscript (nella cartella: c:\programmi\gs)
  • Installare RedMon
  • Copiare file pdfwrite.rsp nella directory dove è stato installato ghostscript
  • Se ghostscript è stato installato in una directory diversa da C:\programmi\gs\ correggere le righe di pdfwrite.rsp che fanno riferimento al suo caricamento, mettendo la directory giusta.
  • Installare una nuova stampante:
  • Aggiungere nuova porta selezionando Redirected Port: verrà aggiunta la porta RPT1 (questa operazione va fatta una volta sola anche se in seguito si aggiungeranno altri tipi di stampanti)
  • Come nuova stampante selezionare Apple Color LaserWriter 12/600 (installando una stampante postscript non a colori si avranno stampe in scale di grigio)
  • Andare in configura porta e scrivere:
    in Redirect this port to the program:
    C:\Programmi\gs\gs8.00\bin\gswin32c.exe
    in Argument for this program are:
    @c:\Programmi\gs\pdfwrite.rsp -sOutputFile="%1" -c save pop -f -
    (ricordarsi di mettere in fondo uno spazio seguito dal meno che è l'ultimo carattere dell'argomento)
  • in Output
    Prompt for filename
  • in Run selezionare:
    Hidden se non si vuole compaia la finestra DOS quando ghostscript elabora i dati
  • Spuntare il flag: RUN AS USER.

Se si usa windows98 ricordarsi di togliere la bidirezionalità: andare nei dettagli del driver della stampante, cliccare su "Imposta spooler" e poi selezionare "Disattiva il supporto bidirezionale per la stampante"

Se ci sono dei problemi, abilitare il log e vedere cosa scrive sul file di log.

Per SO Vista o Windows7

  • Installare ghostscript premendo col pulsante destro e selezionando esegui come amministratore
    (Si consiglia di installare nella directory proposta, cioe' c:\gs )
  • Installare RedMon premendo col pulsante destro e selezionando esegui come amministratore
  • Copiare il file pdfwritevista.rsp nella directory dove è stato installato ghostscript
  • Se ghostscript è stato installato in una directory diversa da C:\gs\ correggere le righe di pdfwrite.rsp che fanno riferimento al suo caricamento, mettendo la directory giusta. Fare la stessa cosa anche in pdfwritevista.rsp
  • ATTENZIONE: occorre entrare come Amministratore
  • Installare nuova stampante e, selezionando esegui come amministratore, selezionare Una stampante postscript (installando una stampante postscript non a colori si avranno stampe in scale di grigio)
  • Creare una nuova porta selezionando Redirected Port: verrà aggiunta la porta RPT1 (questa operazione va fatta una volta sola anche se in seguito si aggiungeranno altri tipi di stampanti)
  • Andare in configura porta
    quindi andare nelle impostazioni/stampanti e premere col pulsante destro sul nome e selezionare esegui come amministratore mettere:
    Redirect this port to the program: C:\gs\gs8.00\bin\gswin32c.exe
    Argument for this program are:
    @c:\gs\pdfWriteVista.rsp -sOutputFile="%1" -c save pop -f -
    (ricordarsi di mettere in fondo uno spazio seguito dal meno che è l'ultimo carattere dell'argomento)
    Output: Prompt for filename
    Run: mettere "Hidden"
    se non si vuole compaia la finestra DOS quando ghostscript elabora i dati


Pers.Parametri Stampa fatture su PDF

Pers.Parametri per Stampa documenti su PDF

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

La procedura consente di stampare i documenti (preventivi, ordini, ddt, fatture) in formato Pdf dopo aver installato uno degli applicativi consigliati per la Stampa su Pdf

L'impostazione dei parametri sul file INI, si può fare manualmente o da qualsiasi programma di stampa, premendo il pulsante 'Selezione destinazione stampa' poi 'Par. INI Pdf ed Email'.

Il file Pdf generato viene memorizzato nella cartella indicata dal parametro DirPdf che va inserito manualmente nel paragrafo [BASE] del nel file aziwin.ini generale (cartella aziwin) o del terminale (cartella aziwin\main).

Per differenziare le cartelle dove memorizzare i file (es. cartelle diverse per fatture , ddt , scontrini) si dovrà mettere questo parametro nelle rispettive sezioni [staFATSFAT] - [StaDDTsDdt] - [ScontrinX] indicando in ciascuna una cartella diversa

Se non si imposta DirPdf, il file verrà salvato nella cartella 'aziwin\carica' (quella indicata dal parametro DirCarica di Aziwin.ini).
Se il nome del file è definito dal parametro di personalizzazione PdfNomeDoc (descritto in seguito), il parametro DirPdf potrà contenere parti fisse e parti variabili. Le parti variabili dovranno essere precedute e seguite dal carattere §
(Esempio: c:\DocPdf\§TipoDoc§§IdAzienda§\ per mettere i file in cartelle diverse a seconda del documento (fattura, ddt, ordine) e del codice ID ditta)
Per la costruzione del parametro DirPdf Possono essere utilizzate le seguenti variabili:

Terminale | Nome del terminale che ha prodotto la stampa
Login | Login di chi ha prodotto la stampa, se definita
Gruppo | Gruppo di chi ha prodotto la stampa, se definito
DescAzie | Descrizione Azienda (Tab.Aziende-Gestione Database aziende)
CodiceAzie | Codice Azienda (Tab.Aziende-Gestione Database aziende)
IdAzienda | Identificativo Azienda (Tab.Aziende-Gestione Database aziende)
TipoDoc | Verrà impostato FAT per fattura, Ddt per Ddt, Ord e Pre

Segue l'elenco dei Parametri di personalizzazione possibili.

Programmi: Stampa fatture (Preventivi, Ordini, Ddt)
Gruppo: StFatture (StPreventivi, StOrdAcq, StOrdini, StDdt, Scontrini)

I due parametri che seguono servono per impostare il valore di default da assegnare, al caricamento della maschera di stampa fatture, alle rispettive richieste. L'operatore potrà poi variare tali impostazioni a piacere.

Parametro: PdfNomeAutom
Se verrà impostato a S, verrà spuntato, sulla maschera di stampa dei vari documenti, il campo che propone di assegnare in automatico il nome al file Pdf.

Se questo flag non viene spuntato, il nome del file e il posto dove salvarlo, verranno chiesti di volta in volta.

Parametro: PdfUno
Se vale S viene impostato a Si, in fase di stampa documenti, il flag che propone di stampare tutti i documenti di una sessione di stampa su un unico file pdf.

Per far sì che, nel caso di installazioni con più terminali, si possano impostare i flag suddetti a Si, solo per i terminali che effettivamente useranno la stampa su pdf, è possibile mettere nella sezione [Opzioni Stampa] dell'aziwin.ini di ogni terminale i due parametri con il valore da assumere per quel terminale e saranno prioritari rispetto a quelli scritti nelle personalizzazioni:
PdfNomeAutom=S
PdfUno=S

Parametrizzazione del nome da assegnare al file PDF

Se si genera un file per ogni documento il programma assegnerà come nome in automatico Anno+Pref_NumFattura.pdf
In caso di prestampa di Preventivi, Ordini, Ddt il nome verrà costruito:
Anno+PR (OR o DDT)+NumRif
Per gli scontrini il nome sarà: data del giorno+ora

Nella stampa fattura se, nel nome assegnato in automatico, si vuole la data al posto dell'anno, occorre impostare ad S il parametro di personalizzazione PdfNomeData

In alternativa si possono definire i seguenti parametri di personalizzazione
Per personalizzare il Nome file:

  • creare due parametri di personalizzazione:
    PdfNomeIni
    Caratteri che vengono messi nel nome file prima del nome assegnato
    PdfNomeFin
    Caratteri aggiunti nel nome file dopo il nome assegnato
  • In alternativa si può 'costruire' il nome del file, impostando il parametro di personalizzazione:
    PdfNomeDoc
    Il valore del parametro potrà contenere parti fisse e parti variabili. Le parti variabili dovranno essere precedute e seguite dal carattere §.
    Variabili disponibili:
    NumDoc

    Prefisso e numero documento

    Data

    Data documento stampa nella forma ggmmaaaa (Es. 10072012)

    DataLong

    Data nella forma giorno-mese per esteso-anno (10 Luglio 2012)

    DataAbb

    Data nella forma giorno-mese abbreviato-anno (10 Lug 2012)

    DataRov

    Data nella forma Anno-mese-giorno (Es.20120710)

    CodCli

    Codice cliente del documento nella forma xxyyzzzz

    Anno | Anno del documento
    Ora | Ora del documento (per scontrino)

    Esempio: FT§Numdoc§_§Data§_CL§CodCli§
    dove FT , _ e _CL sono scritte fisse mentre Numdoc, Data e CodCli sono variabili per cui vanno precedute e seguite dal simbolo §

    Se le stampe vengono fatte in prestampa, numero e data saranno rispettivamente:
    per le fatture: il numero che comunque assumerebbe la fattura e la data di stampa
    per gli altri documenti: il numero di riferimento e la data di stampa.

    Per avere la Descrizione o Ragione Sociale o altro del cliente nel nome file occorre prima definire il parametro :
    Fatture CampiStAggDec Valore: ,left(PianoConti.Descrizione,10) as IniRagSoc

    poi definire PdfNomeDoc con valore: FT§NumDoc§§çD.Pianoconti.Ragsoc§

Se invece si genera un file Pdf unico è obbligatorio definire il parametro
PdfNomeRiep (Es. Fatture) con il nome da assegnare al file.
Se si definisce anche PdfRiepData con valore S, al nome specificato sopra verrà aggiunta la data di stampa (Es. Fatture20120731)

Se, al momento della stampa, esiste già un file con lo stesso nome (cosa che accade certamente se si esegue una ristampa di una fattura) il programma sovrappone il nuovo al vecchio.

Parametro: PdfNomeMostra
Se impostato ad S e si chiede di assegnare in automatico il nome del file, il programma, in fase di stampa, mostra il nome del file su cui sta scrivendo.

Se si utilizzano gli applicativi PdfCreator o Pdf995 è possibile creare un ulteriore parametro per indicare quale applicativo utilizzare se che si spunta il campo: 'Nome file automatico per pdf'.
In questo caso, se durante la sua installazione è stato lasciato alla stampante il nome di default (PdfCreator o PDF995), non servirà fare la scelta stampante perché questa verrà automaticamente selezionata.
Gruppo: Pdf
Parametro: UsaPdfCreator (oppure UsaPdf995)
Valore: S
In alternativa alla creazione di questo parametro si può inserire nell'aziwin.ini la sezione [StampaPdf]
che, se presente, prevale su questo.

Per quanto riguarda la personalizzazione del nome del file PDF delle fatture passive si può fare con gli stessi parametri descritti sopra, impostando il gruppo: StFatPas


STAMPE (e VISUALIZZAZIONI) PARAMETRICHE

In alcune stampe (e visualizzazioni) dove i campi stampabili sono tanti e possono essere combinati in modo diverso a seconda delle esigenze degli utenti (es. listini e partitari di magazzino) è possibile 'costruirsi' stampe/visualizzazioni diverse premendo, nella maschera del programma, il pulsante:

Personalizza la stampa/visualizzazione.

Le stampe personalizzate vengono memorizzate, possono poi essere utilizzate scegliendo quella desiderata al momento della stampa e, quando non servono più, cancellate con il pulsante Cancella stampa/visualizzazione.

Con la funzione accessibile premendo i tasti Ctrl-Shift-Alt L dal menu è possibile accedere al programma di gestione della tabella dei campi disponibile alle varie stampe e aggiungere nuovi campi.

La sequenza di preparazione di una nuova stampa è la seguente:

dalla maschera principale del programma, dove viene presentata la stampa da eseguire, scegliere:
Nuova stampa e premere il pulsante: Personalizza la stampa

Verranno presentate una serie di maschere, in sequenza. All'interno di ogni maschera si può decidere, tramite appositi pulsanti, di tornare alla precedente (Indietro), di uscire (Esci) abbandonando quanto è stato fatto fino a quel momento o di proseguire (Avanti).

Sull'ultima maschera si conferma il tutto uscendo con Fine mentre l'uscita con Esci equivale ad annullare.

Gruppi: viene presentata una lista di campi tra i quali scegliere quelli per cui si vogliono raggruppare i dati in stampa: es. Gruppo/Sottogruppo. Una volta selezionato un campo, per portarlo nella maschera di destra basta fare due click sul campo oppure premere il pulsante centrale col simbolo >

Per deselezionare un campo (portarlo da destra a sinistra), basta selezionarlo e premere click 2 volte o il pulsante centrale <

Se non si devono fare dei raggruppi si può procedere premendo il pulsante: Avanti >>>

Selezione ultimo livello per salto pagina: se sono stati scelti dei raggruppi, si chiede di dire qual è l'ultimo livello di raggruppo per fare il salto pagina. La stampa farà un salto pagina anche per ogni raggruppo di livello superiore. Se non si vogliono salti pagina si può lasciare vuota la selezione

Selezione campi: consente di selezionare, tra tutti i campi resi disponibili alla stampa, quelli da stampare su una riga. Ad ogni campo scelto vengono aggiornate la larghezza utilizzata e la residua in mm e in caratteri (rispettivamente per le stampa proporzionali e per quelle a caratteri fissi), facendo riferimento all'orientamento della stampa, che può essere variato, e alla dimensione del foglio della stampante attiva.
Nella maschera è presente il pulsante [image] (Salto Riga) che consente di selezionare il/i campi in corrispondenza dei quali si deve fare una riga nuova e quindi poter ottenere la stampa su più righe. Con un ulteriore click sul pulsante, verrà tolta la selezione.
Se si imposta la stampa su più righe, le dimensioni della stampa visualizzate a fondo pagina, sono quelle relative ai campi da stampare sulla riga cui appartiene il campo su cui si è posizionati.

Ordinamento dei campi: consente di decidere su quali, tra i campi da stampare, fare l'ordinamento (es. in una stampa di magazzino si può decidere di ordinare per codice o descrizione articolo)

In ogni maschera, a destra nel video, sono state inserite una freccia in su e una in giù, esse consentono di spostare in su o in giù i campi della colonna di destra. Per spostare in su un campo, basta selezionarlo e premere la freccia in su fino ad arrivare alla posizione in cui lo si vuole inserire.

Prima di uscire occorre assegnare un Codice e una descrizione alla stampa, in modo da poterla poi richiamare in futuro. Si può inoltre decidere se, quella stampa, deve essere quella proposta dal programma come predefinita. Per salvare le caratteristiche di una stampa già impostata, con un altro codice e descrizione, basta scegliere 'Imposta un altro codice', la stampa originale rimarrà invariata.

Pulsante Test di selezione dati
Questo pulsante, abilitato SOLO nei programmi dove è stata inserita la sua gestione (es. visualizzazione partitari), consente di scrivere una 'query' cioè una serie di istruzioni per :

  • aggiungere una condizione all' estrazione dei dati fatta dal programma
  • estrarre i dati con le condizioni previste dal programma OR quelle scritte qui (in questo caso si dovrà far precedere la condizione da OR)
  • escludere le selezioni fatte dal programma ed eseguire solo quella scritta qui
    Per ottenere quest'ultimo obiettivo, basta far precedere il test scritto in questa maschera con la scritta: SOLO
    Nei programmi è stata comunque impostata una condizione 'minima' fissa.

Esempi: OR movpntes.numreg >= 20 oppure AND importo > 100

Se il programma (Vedi Elenco) ha al suo interno due query, una successiva all'altra, è possibile dire a quale delle due aggiungere la condizione che si vuole, utilizzando la sintassi: §1 Test§1 §2 Test§2 Se non si mettono § si intende che la condizione sia per entrambe le query

Partitario di prima nota: per estrarre SOLO le anagrafiche con movimenti con una determinata causale, la condizione da inserire è:
§2 and movpntes.causale = "21" §2 §1 and exists(select causale from movpntes as MT1 INNER JOIN movpndett as MD1 ON MT1.anno=MD1.anno AND MT1.NumReg=MD1.NumReg where MT1.causale="21" and MD1.GruppoPartita=Pianoconti.gruppo and MD1.MastroPartita=Pianoconti.mastro AND MD1.ContoPartita=Pianoconti.conto) §1
dove al posto di "21" dovrà essere inserito il codice della causale da stampare

Partitario di magazzino: §2and articolicosti.costoUltimo > 100 §2 stamperà tutti gli articoli selezionati il cui costo ultimo è maggiore di 100€

Pulsante Collega altre tabelle
Viene caricata una maschera dove si può inserire la query (parte che sostituisce la FROM) sulla tabella della quale si vogliono estrarre i campi. In questo modo si consente di aggiungere una o più tabelle alla query di lettura dei dati impostata nel programma.
Utile quando si rende necessario estrarre ulteriori campi, non presenti tra quelli proposti dal programma, che si trovano su tabelle collegate a quella da stampare: si dovranno aggiungere i campi con la funzione gestione della tabella dei campi (codice negativo) poi scrivere qui la query per estrarli.
Esempi: per stampare la descrizione della moneta del cliente, nella stampa parametrica clienti, occorre aggiungere in gestione campi il campo: Monete.Descrizione con numero campo negativo, poi inserirlo tra i campi da stampare con la personalizzazione della stampa e scrivere in Collega altre tabelle:
left join Monete on (Pianoconti.Moneta = Monete.Moneta))
oppure
per stampare le Ragioni Sociali dell'agente 1 e 2 collegati al cliente, occorre aggiungere in gestione campi, i campi : Agenti.RagSoc e A2.RagSoc poi scrivere la query:
left join Agenti on Pianoconti.Agente1 = Agenti.Agente) left join Agenti as A2 on Pianoconti.Agente2 = A2.Agente)
Nota: per ogni tabella aggiunta va chiusa una parentesi ')'
Normalmente la query viene aggiunta , se inizia con §§ invece sostituirà la query iniziale

Se il programma (Vedi Elenco) ha al suo interno due query, una successiva all'altra, è possibile dire a quale delle due aggiungere le tabelle da cui estrarre dati, utilizzando la sintassi: §1 Query§1 §2 Query§2 . Se non si mettono § si intende che le tabelle vadano aggiunte ad entrambe le query

In pratica i campi nuovi si aggiungono con il codice campo meno ' -' in tabella, si estraggono con questa query aggiuntiva e si Selezionano (WHERE) con la condizione che si può scrivere in ‘Test di Selezione’

Se in 'Tabelle collegate' il programma trova il nome di uno o più campi, separati da virgola , dove ciascun campo è preceduto da ç- e seguito da -ç stamperà l'intestazione come scritto in 'Personalizza intestazione'.
(es. in Stampa Articoli parametrica:
In Person. intestazione:
§67Reparto §T.67§ (con iva §T.Reparti.Iva§)§67 e in Collega altre tabelle: ç-Reparti.Iva-ç
 o anche
§-9Tipo iva §T.-9§ (§T.IvaVen.Descrizione§)§-9 e in Collega altre tabelle: ç-Ivaven.Descrizione-ç

Pulsante Personalizzazione intestazione
Abilitato SOLO nei programmi dove è stata inserita la sua gestione (es. stampa partite). Consente di aggiungere campi all'intestazione della visualizzazione / stampa.
La sintassi con cui scrivere quello che si vuole sia il contenuto della nuova intestazione è:
§T.nn§§T.nn§ etc. dove nn è il numero campo che si può rilevare dalla gestione della tabella dei campi raggiungibile dal menu con i tasti Ctrl-Shift-Alt L
Esempio: Stampa partite: si vuole ottenere nell'intestazione delle partite:
Rag.sociale cliente (Codice) - Rag. sociale agente
Occorre verificare che i campi desiderati siano presenti tra i campi disponibili con la gestione suddetta, eventualmente inserirli con numeri negativi, purchè appartenenti a tabelle lette dal programma. Si inserirà, ad esempio, la Rag.Sociale agente con Nr. Campo '-1' poi come stringa di personalizzazione si metterà: §T.2§ (§T.1§) - §T.-1§ Dove 2 corrisponde alla Rag.Sociale cliente, 1 al codice, -1 alla ragione sociale agente.
Il campo interessato DEVE essere inserito anche nell'elenco dei campi del corpo della stampa.
In questo modo però, i campi aggiunti cioè quelli definiti con Num.Campo negativo, verrebbero stampati anche nel corpo; per evitare questo, quando si inseriscono, si dovranno compilare:
Stringa per Larghezza: con un . (punto)
e Numero caratteri: 1

Con Salva si esce confermando, con Esci si Annulla.

Elenco opzioni abilitate per ogni stampa:

  • Parametrica clienti/fornitori e Parametrica articoli
    Abilitata stampa su più righe
  • Visualizzazione partitario e partite di contabilità
    E' possibile inserire una condizione e una join
  • Visualizzazione partitario parametrico articoli
    E' possibile inserire 2 condizioni di selezione e 2 Join
  • Stampa partitario di contabilità
    E' possibile inserire 2 Test di selezione e 2 Join
  • Stampa partite di contabilità
    1 sola join
  • Stampa partitario parametrico articoli
    E' possibile inserire 2 Test di selezione e 2 Join
  • Stampa statistiche di fatturazione
    E' possibile inserire 2 Test di selezione e 2Join
  • Stampa situazione articoli
    E' possibile inserire una condizione e una join
  • Stampa Listini
    E' possibile inserire una condizione e una join


GEST.CAMPI STAMPE E VISUAL. PARAMETRIZZATE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di accedere alla tabella del menu che contiene l'elenco dei campi disponibili alle stampe e visualizzazioni parametrizzabili dall'utente (es. partitari di contabilità e di magazzino, listini etc.).

Inoltre, con il pulsante [image] (Y) Trasferimento Stampe, è possibile 'importare' un 'tracciato' di stampa da un altro Data Base, purchè esso non esista già, sul DB di destinazione.

La variazione di dati in questa tabella si deve fare con MOLTA attenzione in quanto si rischia poi di compromettere il corretto funzionamento dei programmi.

Ogni campo è individuato da Nome programma e numero campo. Il nome programma corrisponde, in generale, al contenuto dei campi: Chiave+ChiaveSec della riga di menu che richiama quel programma, il numero del campo è progressivo all'interno del Nome programma.

Questa gestione può essere utilizzata per:

  • variare la larghezza, in stampa, di un campo, modificando la colonna Larghezza
  • aggiungere nuovi campi alla lista dei campi da stampare.
    In questo caso i campi devono appartenere alle tabelle già lette dalla stampa, essere delle stringhe fisse oppure valori calcolati (vedi 'nome campo' e dovranno essere inseriti con Numero Campo negativo (es.-1, -2)
    Supponiamo di voler aggiungere nella stampa del listino il campo data creazione dell'articolo che ora non compare nella lista dei campi del programma: Stmgco1List (stampa listino):
    si aggiungerà una riga con nome programma: Stmgco1List , numero campo: -1, descrizione: data creaz. , Nome campo: Articoli.DataCrea etc.

Descrizione
corrisponde a quanto verrà stampato come intestazione per quel campo.
Stringa per larghezza: 99/99/9999 opp. 99/99/99 (individua lo spazio in mm. Occupato dal campo sulle stampanti laser)
Se si sta inserendo un campo personalizzato (Num.Campo negativo) che si vuole utilizzare SOLO per l'intestazione della stampa (es. Rag.Sociale agente in visualizzazione partite) si dovrà mettere in Larghezza un . (punto). Se si mette una larghezza accettabile, il campo verrà stampato anche nel corpo della stampa.
Invece di ripetere tante volte un carattere per definire lo spazio occupato dal campo (es. MMMMM), si può usare la sintassi: §§M30 per intendere trenta volte M.

Numero caratteri: 10 (indica il numero di caratteri occupati dal campo su stampante ad aghi)

I campi abilita ordinamento, abilita rottura non vanno modificati per quanto riguarda i campi già esistenti. Per i nuovi campi, impostando 'abilita ordinamento' a Si, il programma eseguirà automaticamente, per quel campo, anche la rottura.

Nome campo: Articoli.DataCrea (è il nome esatto della tabella e del campo sul Database)
E' possibile inserire nella stampa degli ulteriori campi (calcolati) che dovranno però essere stati preparati in modo opportuno dal singolo programma di stampa.
Tali campi vanno inseriti in questa gestione con Numero campo negativo, Nome campo fisso da programma e con caratteri iniziali: P_
(Es. P_Nome e P_Cognome nella stampa parametrica clienti e fornitori: il programma estrae il Cognome e il Nome delle persone fisiche dal campo ragione sociale contabile se è stato scritto Cognome-Nome Oppure Cognome Nome oppure Cognome_Nome)
Questo consente di aggiungere campi personalizzati nella tabella SOLO per gli utenti che hanno esigenze particolari.
Per stampare il contenuto dei campi delle tabelle dei Parametri Comuni (ggmencli) si deve utilizzare: P_M_NomeCampo
(Es. P_M_ditta.ragsoc)

Se nel nome campo c'è TabStati. o Stati. il programma è in grado di leggere dalla tabella TabStati del menu (Stampa par. cli/for)
Per i campi il cui nome è fisso da programma (in generale, quelli con numero campo positivo) è possibile inserire in 'Nome campo' i caratteri che dovranno essere utilizzati in stampa come intestazione del campo in oggetto al posto di quanto scritto in 'Descrizione'.

Per inserire un campo a contenuto fisso, basta mettere in 'Nome campo' la stringa desiderata scritta tra apici (es. si vuole stampare in un campo la scritta fissa PROVA, si metterà in 'nome campo' . "PROVA")

Per inserire un gruppo di campi a contenuto fisso (da scaricare su un file) basta mettere in 'Nome campo' i caratteri \§ (per indicare che durante l'estrazione non deve mettere gli " all'inizio e alla fine) e la stringa con i campi fissi separati dal carattere di separazione che i campi devono avere sul file
Esempio con separatore 'punto e virgola'
\§0;0;1;230
Se il separatore non è un carattere stampabile mettere all'inizio i caratteri \ç e il separatore va scritto mettendo il carattere \ seguito dai 3 caratteri contenenti il codice ascii (es. con separatore TAB
\ç\§0\0090\0091\009230

Formato: è l'eventuale formato che si vuol dare al campo in stampa (es. per una data dd/mm/yy)
Per un numero si può utilizzare:
#,##0.00 che produrrà: 0,00 2,00 2,30 2,31.
Mentre con #,##0.## non verranno stampate le cifre decimali quando sono a 0 (cioè si otterrà: 0 , 2 , 2,3 , 2,31)
Infine se si utilizza #,###.## si otterrà lo stesso risultato precedente però in corrispondenza di importi a 0 verrà stampato un campo bianco.

Se si vuole stampare un conto che sul database è formato da 3 campi: gruppo, mastro, conto si potrà mettere in Nome campo i tre campi es. GruppoPartita & MastroPartita & ContoPartita, in Formato si può scrivere semplicemente Conto così il programma capisce che deve stampare il campo nel formato: xx-xx-xxxx

Nei campi personalizzati se si mette il simbolo > nel formato, il programma convertirà il contenuto in lettere maiuscole.

Infine nel formato si può mettere una espressione calcolata (Sql) con la quale si rielabora il campo da stampare.

Fino alla release 2.01 e SOLO per alcuni programmi personalizzati: Se si fa precedere la stringa del formato da Tx (es. Tx#,##0.00), il programma stamperà i totali di colonna per il campo in oggetto (per ogni rottura e finale). Attualmente viene usato del campo: "Esegui totali"

Allineamento
D=Destra S=Sinistra C=Centrato M=Memo
Indica l'allineamento con cui va stampato il campo. Valido solo per i campi aggiunti con numero campo negativo.
Se bianco il programma allinea i numerici a destra e il resto a sinistra.
Se Memo deve essere l' ultimo campo della stampa e deve essere un campo aggiunto cioè con numero campo negativo.

Esegui totali
Si, No, Solo formati che iniziano con Tx
Indica se, per il campo in oggetto, andrà stampato un totale. Dovrà essere impostato a Si per stampare i totali di una colonna di importi relativi a campi aggiunti (con codice negativo). I programmi stampano già i totali per i campi numerici già presenti nell'elenco campi.

Note per stampa campi particolari:

Codice a barre
(Stampa articoli parametrica, etichette articoli, listini)
Se in tabella, si crea una riga personalizzata (con numero campo negativo) compilando i campi:
Nome campo con i doppi apici: "
Formato con la parola CodBarre
verrà stampato il codice a barre nello spazio messo a disposizione in Stringa per larghezza, nel campo Numero caratteri ci va il numero di righe da saltare dopo aver stampato la riga dell'articolo (per far spazio al codice a barre)
Se invece si vuole che il codice a barre occupi un determinato spazio si può impostare: CodBarreH/L (Altezza/Larghezza).
Se manca la larghezza, verrà utilizzata quella a disposizione.
Per far sì che il codice a barre occupi sempre lo stesso spazio, si può mettere una delle due coordinate negative (Es. CodBarre-40/7,06)
Nella definizione standard del campo cod. barre per la stampa (numero campo 86) è stato messo 2 come numero di righe da saltare.
Se si vuole stampare su più righe con il codice a barre all'inizio, occorre definire, per le righe successive, dei campi vuoti (con numero campo negativo, Stringa per larghezza definita e Nome campo compilato con doppi apici (")) che dovranno essere inseriti nella definizione della stampa per evitare che i campi si sovrappongano.

Immagine
(Stampa articoli parametrica, listini)
Vale quanto scritto per il codice a barre. Il campo viene riconosciuto dal fatto che
Formato sia stato compilato con Img:
E' possibile forzare l'allineamento a Destra (o a Sinistra), facendo seguire una D (o una S) (Es. Img:D)
Spazio a disposizione per la stampa dell'immagine: in assenza di parametri la larghezza è quella impostata in Stringa per larghezza mentre l'altezza si può mettere come parametro dopo Img:D
Il programma controlla se la dimensione dell'immagine è minore dello spazio messo a disposizione per la stampa e se è maggiore la ridimensiona per non deformarla. Se ci sono immagini più piccole dello spazio messo a disposizione, queste rimarranno più piccole.
Per far sì che le immagini occupino sempre lo stesso spazio, si può mettere una delle due coordinate negative (Es. Img:D-20/40)

Data variazione
(Stampa articoli parametrica, Stampa Listini)
P_DataMod campo preparato dal programma per la stampa della data ultima variazione.
Se sull'articolo, tale data è bianca prende data creazione.

Giacenza e Disponibilità articoli
(Stampa articoli parametrica, Stampa Listini)
P_Giac e P_Disp sono Giacenza e Disponibilità totale (su tutti i magazzini)
P_GiacX e P_DispX con X=Codice Magazzino calcola i valori di quel magazzino
P_Giac§D e P_Disp§D §D indica il Magazzino di default scritto in Tabella di Magazzino

Se il programma trova, dopo le variabili suddette, i simboli: -# (- (meno) seguito da #)
quello che segue è un elenco di codici magazzini, separati da virgola, la cui Giac/disp deve essere sottratta da quella calcolata prima

Stampa campi Memo
(Stampa articoli parametrica, Stampa Listini)
Parametro di personalizzazione: SostCRLF per sostituire il Carriage Return nel caso sia Stampa su File

Per stampare dei campi MEMO non presenti sulla tabella Articoli (es. descrizioni in lingua), si può usare la Tabella ArtLingue e mettere nella definizione della Stampa Personalizzata la Join in Tabelle Collegate:
left join (Select Articolo, DesLunga from ArtLingue Where Lingua = "ING") as DesIng on Articoli.Articolo = DesIng.Articolo)

Nella definizione dei campi per la stampa parametrica (oggetto di questo capitolo) si dovrà aggiungere il campo con codice negativo (personalizzato) , assegnare una Descrizione libera e impostare 'numero caratteri' a 9999 , e 'NomeCampo' con il nome del campo estratto nella query (esempio: DesIng.DesLunga)

Trasferimento Stampe
Occorre avere a disposizione un database con le tabelle

  • Stampe
    contenente la riga della nuova stampa da caricare

  • StampeCampi
    contenente i campi da aggiungere all'elenco dei campi disponibili per la stampa. Devono avere tutti un codice negativo

  • StampeDett
    con le righe di configurazione della nuova stampa

Questo pulsante consente di importare sul menu in uso il nuovo tracciato di stampa
Viene chiesto all'operatore il database di origine (indicare quello su cui sono state messe le tabelle da caricare) e il nome della stampa da caricare da scegliere tra quelle presenti sul database suddetto. Inoltre occorre specificare cosa fare
In caso di campi di dettaglio già esistenti:

  • Saltare

  • Sovrascrivere

  • Aggiungere un campo nuovo
    In questo caso verranno aggiunti i nuovi campi e rinumerati


FONT PERSONALIZZATI

Percorso: dal menu principale: Shift-Ctrl-Alt L

La tabella che viene gestita da questa funzione, viene fornita già compilata, e contiene un elenco di font utilizzabili dai programmi, in particolare nei campi di tipo memo (es. note fisse dei documenti ddt, fatture, ordini)

Ogni riga è individuata da un numero progressivo.

Per ogni font è possibile definire la dimensione(size) e alcune caratteristiche: il grassetto (Bold), l'italico (Italic), il barrato (Strike), il sottolineato (Underline).

Il font utilizzato in generale nelle stampe è l' Arial. Nelle stampe dei moduli di ordini, ddt e fatture è possibile per ogni riga definire un font diverso e una dimensione del carattere.

Questa tabella verrà utilizzata nella compilazione di testi 'memo' se si vuole cambiare il font di stampa, così come descritto nelle righe che seguono:

Per cambiare un font in stampa occorre inserire , nel testo da stampare, <FNomeFont> dove NomeFont è il nome del font definito all'interno dei programmi (es. CorpoLab, TestaTitolo etc. chiedere a Zucchetti Filiale di Ravenna (ex CSS) se si rende necessario utilizzarlo).

In alternativa, al posto della scritta NomeFont si puo' mettere:

- un numero N corrispondente al font: i font personalizzati (esistenti in tabella) vengono caricati per primi nell'ordine con cui vengono letti, cioe' in ordine crescente del numero progressivo. (Questo numero può non corrispondere al contenuto del campo 'Progressivo' in tabella, se sono state cancellate delle righe di font. Es. se cancello il font con progressivo = 1, l'attuale font con progressivo 2 diventerebbe il primo caricato per cui per far riferimento ad esso si dovrebbe mettere <F01>

- se si usano font personalizzati, facendo seguire a F la lettera P seguita da un numero (Progressivo) viene usato il font personalizzato corrispondente a quel progressivo (cioè quello che nel campo Progressivo ha quel numero)

per ripristinare il font base del testo 'memo' si deve inserire la scritta </F>

E' possibile invertire il grassetto di un font inserendo la scritta <B> dove si vuole iniziare il grassetto e </B> dove si vuole terminare. Invertire significa che se il font corrente e' normale si passa allo stesso font in grassetto, se era gia' in grassetto viene cambiato in quello non grassetto.

Se si incontra una fine font, cioe' </F> viene terminato anche il cambio grassetto.

E' possibile anche cambiare l'allineamento del testo; per questa operazione bisogna mettere il comando corrispondente all'inizio della riga (prima anche di eventuali spazi bianchi) di cui si vuole cambiare l'allineamento.

I comandi possibili sono:

  • <C> allineamento al centro
  • <D> allineamento a destra
  • <S> allineamento a sinistra
  • <G> allineamento giustificato
  • <R> allineamento giustificato ma nella prima riga vengono lasciati eventuali spazi a sinistra
  • <N> allineamento a sinistra ma non vengono tolti gli spazi ne' all'inizio della stringa ne' alla fine

Il nuovo allineamento rimane attivo fino a quando non si incontra o un nuovo allineamento o la fine allineamento che si ha mettendo la scritta </A> alla fine della riga (anche in questo caso dopo eventuali spazi bianchi e comunque come ultimi caratteri della riga da stampare)

Esempio di testo con allineamento e cambio di font:

<D>Prova di testo allineato a
destra: in un giorno di pioggia e vento
alcuni turisti si aggiravano per Ravenna
con <F03> impermeabili e ombrelli colorati
in cerca di un posto dove ripararsi </A>
Un passante suggerisce di visitare <B> la tomba di Dante
e la chiesa di Sant'Apollinare </B> ma è già troppo tardi!.


STAMPA DATI DELLA GRIGLIA

Questa funzione consente di stampare i dati presenti in una griglia a video.

E' possibile stampare SOLO le colonne visibili oppure tutte le colonne previste dalla visualizzazione, cioè anche quelle che si possono vedere facendo scorrere a destra la barra di scorrimento.

La stampa può essere fatta in orizzontale o in verticale. Il programma fa in modo di riempire il foglio e assegna ad ogni colonna uno spazio in proporzione al numero delle colonne ed allo spazio da esse occupato.
Se si vuole ottenere una colonna più larga rispetto a quella stampata, basta allargarla a video.

Funzione abilitata in Visualizzazione Partitari, Partite e Verifica Operazioni rilevanti ai fini iva.
Nei partitari e partite è bene costruirsi un modello di visualizzazione apposito, con i campi essenziali per poter essere stampati.


PARAMETRI PROCEDURE

In questo capitolo verranno descritti tutti i parametri che si possono impostare per 'personalizzare' l'installazione.

  • Dati generali azienda
    Funzione in cui vengono definiti i dati anagrafici delle singole aziende da gestire, i conti e le causali per gli automatismi e altre caratteristiche che riguardano il modo di operare su ogni singola ditta (es. elenco registri iva utilizzati, anno contabile corrente, procedure utilizzate etc.)
  • Gestione personalizzazioni
    Si possono inserire dei parametri di personalizzazione, per modificare/caratterizzare l'operatività delle varie funzioni, a livello generale (cioè validi per tutte le ditte gestite) o a livello di singola ditta.
  • Parametri per il lancio del menu
  • Parametri del file aziwin.ini
  • Personalizzazione tasti per avvio programmi
  • Licenza concessa A
  • Menu procedure


DATI GENERALI AZIENDA (parametri)

Percorso: Parametri e utilità - Dati generali azienda

Con questa funzione si consente di inserire e variare alcuni dati e parametri su cui si basa l'operatività delle procedure per l'azienda in gestione. E' perciò indispensabile, prima di utilizzare le procedure, compilare con attenzione i vari codici e parametri descritti in seguito.

In ogni maschera, prima di uscire, occorre, se sono state fatte delle variazioni, salvare i dati inseriti con il pulsante CONFERMA DATI altrimenti non verranno memorizzati.

Se si variano, durante l'utilizzo delle procedure, i parametri gestiti con questa funzione e si lavora in multiutenza, occorre, per avere disponibili le variazioni, eseguire la funzione Rileggi parametri (dal menu Parametri e utilità) da ogni terminale diverso da quello che ha fatto la variazione oppure uscire e rientrare nel menu.

ATTENZIONE: in un'azienda già avviata, occorre fare molta attenzione alla variazione dei dati gestiti da questa funzione in quanto, in particolare alcuni quali ad esempio la moneta principale, caratterizzano il tipo di memorizzazione delle registrazioni e, se variati, comporterebbero la non validità delle registrazioni già fatte.

I parametri sono divisi per argomento:

Dati anagrafici , dati Cee Xbrl
Procedure installate
Parametri comuni
Conti comuni
Causali comuni
Contabilità Generale
Dati Ri.Ba.
Magazzino
Fatturazione
Ordini - Preventivi
Registratore di Cassa
Dati per Fattura Elettronica

Si può accedere ai vari argomenti selezionando con il mouse la tabella voluta o premendo il tasto ALT seguito dalla lettera sottolineata, presente nella etichetta che individua la tabella.


DATI ANAGRAFICI DITTA

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Una volta creati gli archivi di una nuova azienda, occorre definire una serie di parametri e codici che indicano alle procedure le caratteristiche di quell'azienda, primi tra tutti i dati anagrafici che vanno compilati con attenzione in modo completo in quanto verranno riportati anche su documenti fiscali quali giornale bollato, registri iva, fatture, etc.

Azienda è persona fisica:
nel campo Cognome e Nome occorre scrivere nell'ordine Cognome e Nome
Se nella compilazione del campo c'è la presenza di un solo spazio, il programma provvederà a separare il Cognome dal Nome, mentre nel caso di più spazi (Es. Ricci Bitti Bob) è indispensabile inserire un carattere - (meno) per separare il cognome da nome.
Questo carattere è indispensabile per la corretta compilazione dei campi nella preparazione dei file per l'invio telematico delle comunicazioni (Iva annuale, Spesometro etc.)
Vanno compilati inoltre i dati di nascita.
Nota: i numeri di telefono devono contenere solo delle cifre

Registro Imprese (per fatturazione Elettronica):
obbligatoriamente valorizzati nei soli casi di società soggette al vincolo dell’iscrizione nel registro delle imprese ai sensi dell’art. 2250 del
codice civile
Ufficio: sigla della provincia ove ha sede l'Ufficio del Registro delle Imprese presso il quale è registrata la società.
NumeroREA: numero di repertorio con il quale la società è iscritta nel Registro delle Imprese

Dati per fattura Elettronica

Dati per Tessera Sanitaria

Codice Natura Giuridica
Vedi Tabella

TABELLA NATURA GIURIDICA

Percorso: Parametri e utilità - Dati azienda e parametri - Tabelle comuni

La funzione gestisce tutte i codici e le descrizioni contenuti nella "Tabella generale di classificazione Natura Giuridica".
Tale tabella è memorizzata sul database del menu e viene fornita già compilata.
Il codice della Natura Giuridica viene richiesto, ad esempio, nella stampa della Comunicazione dei dati contenuti nelle dichiarazioni di intento ricevute e nella compilazione del modulo per la "Comunicazione delle operazioni con soggetti aventi sede, residenza o domicilio in paesi a fiscalità privilegiata" (Black list, versione pre-2013)

Il campo Comune Fiscale, se compilato, viene utilizzato nella stampa della Comunicazione dei dati contenuti nelle dichiarazioni di intento ricevute e nell'Xbrl delle Fatt.Elettroniche.
La Comunicazione delle dich. di intento prevede il comune e la frazione, per cui se il comune è compilato, verrà stampato nello spazio apposito mentre la località verrà stampata in Frazione, via e numero civico.

Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

A completare i dati della ditta sono i due gruppi: Cee Xbrl e Dati per Fattura Elettronica
In particolare per chi deve emettere fattura elettronica andranno compilate entrambe le maschere

CEE Xbrl

Questi campi 'capitale sociale' , 'cap.soc. interamente versato' S/N, 'codice CCIAA', 'numero iscrizione reg. imprese (REA)', forma giuridica (descrizione), appartenente a gruppo, denominazione della società capogruppo, paese della capogruppo, num. iscrizione all'albo delle cooperative, società in liquidazione, società con socio unico, società sottoposta ad altrui attività ..., denominazione della società o ente che esercita l'attività di direzione e coordinamento"
servono in particolare per essere inseriti nel bilancio in formato Xbrl e nella preparazione del file Xml della Fattura Elettronica

Dati per Fattura Elettronica

Questi campi dovranno essere compilati, quando necessario, per la preparazione del file XML della Fattura Elettronica, OLTRE a
- tutti quelli della maschera 'Anagrafica ditta', in particolare: indirizzo legale (Cap - Località - Prov., Stato e Comune Legale),
IscrizioneREA (gli elementi indicati di seguito devono essere obbligatoriamente valorizzati nei soli casi di società soggette al vincolo
dell’iscrizione nel registro delle imprese ai sensi dell’art. 2250 del codice civile)
Ufficio: sigla della provincia ove ha sede l'Ufficio del Registro
delle Imprese presso il quale è registrata la società.
NumeroREA: numero di repertorio con il quale la società è
iscritta nel Registro delle Imprese

Nr. Iscrizione Registro Imprese (REA)
- e a 'capitale sociale' , 'Ditta con socio unico' , 'Ditta in liquidazione' presenti nella maschera 'Cee xbrl'.

Cedente Prestatore campi obbligatori:
Regime Fiscale
Inserire uno dei codici elencati nella tabella in documentazione XML fattura PA (RF01 - Ordinario etc.)
Tipo Cassa previdenza
Cassa previdenza della categoria professionale di appartenenza (compilare se si utilizza la Cassa Previdenza)
Causale pagamento 770
Codice della causale utilizzata per il pagamento, nella compilazione del modello 770S
Tipo ritenuta
Se si emettono fatture con particolari ritenute d’acconto il cui importo non va aggiunto in fattura (es. ENASARCO) contiene il valore che identifica la tipologia da riportare nella fattura elettronica

Campi non obbligatori:
Titolo
E' il onorifico
Codice EORI
numero del Codice EORI (Economic Operator Registration and Identification)
Albo professionale
Nome dell'albo professionale
Provincia Albo
Provincia di competenza dell'albo professionale
Data Iscrizione all'Albo

Soggetto Emittente

Tipo Soggetto Emittente
Da valorizzare in tutti i casi in cui la fattura è emessa (firmata da un soggetto diverso dal cedente/prestatore; indica se la fattura è emessa dal cessionario/committente (CC) oppure da un terzo per conto del cedente/prestatore(TZ)

  • Cessionario/Committente (CC)
    indica se la fattura è emessa dal cessionario/committente
  • Terzo (TZ)
    Indica che il file è firmato da chi farà l'invio a SDI
    Il programma, di default, predispone il file mettendo sia in <IdTrasmittente> sia in <TerzoIntermediarioOSoggettoEmittente> , i dati del trasmittente proposto da Zucchetti filiale di Ravenna
  • Diretto (DI)
    La ditta che emette la fattura, appone sulla stessa anche la FIRMA elettronica poi delega qualcun altro alla trasmissione. In questo caso sul file non verrà compilato il blocco <TerzoIntermediarioOSoggettoEmittente> nè <SoggettoEmittente> e come <IdTrasmittente> verrà messa la Partita Iva del trasmittente proposto da Zucchetti filiale di Ravenna

Rappresentante Fiscale
Da compilare qualora il cedente/prestatore si avvalga di un rappresentante fiscale in Italia, ai sensi del DPR 633 del 1972 e successive modifiche ed integrazioni.
Non sono obbligatori i campi: Titolo e Codice EORI

Dati per Tessera Sanitaria
Questi 3 campi potranno essere compilati per gli utenti (Strutture Sanitarie) che dovranno preparare il file XML delle fatture per la trasmissione dei dati della Tessera Sanitaria

Se il soggetto che emette i documenti fiscali è Farmacia o Struttura inserire
Codice Regione (3 caratteri)
Codice ASL di appartenenza (3 caratteri)
Codice SSA
altrimenti basta il Codice Fiscale del Medico/odontoiatra


PARAMETRI COMUNI

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

In questa tabella, come nelle successive, verranno chiesti dei codici. Alcuni di essi sono obbligatori e se non sono ancora stati creati nelle rispettive tabelle, si potrà fare l'inserimento al momento accedendo ai rispettivi programmi di gestione direttamente dal tasto messo a disposizione con l'aiuto in linea.

Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Moneta principale
E' il codice della moneta di riferimento per la gestione di tutti gli importi. In generale sarà Lira o Euro.

Anno cambio moneta
Indica l'anno in cui la ditta comincia ad utilizzare l'Euro come moneta principale. Se viene lasciato bianco si intende che tutti i movimenti inseriti sono nella moneta principale.

Codice per la LIRA e Codice per l' EURO
Sono rispettivamente i codici assegnati in tabella monete alle monete Lire ed Euro.
La necessità di avere questi codici moneta è determinata dal fatto di dover gestire i progressivi sia in EURO che in LIRE almeno fino al 2002.

Tasso di Conversione Lira/Euro e Operatore (*/)
E' il Tasso di conversione Lira/Euro fissato al 31/12/98. Verrà utilizzato in tutte le conversioni tra le due monete.
L'operatore indica come utilizzare il tasso impostato, se come moltiplicatore o come divisore.
Dovrà essere impostato ad esempio a 1990,23 e l'operatore a /.
Nella conversione da lira ad euro si fa: Valore in Euro(E)=Valore in Lire(L) <operatore> Cambio(C) e cioè: E=L*C oppure E=L/C

Elenco prefissi e Prefisso principale
In questi campi va inserito rispettivamente l'elenco dei caratteri 'prefissi' da utilizzare per individuare registri iva Vendite (o Acquisti o Corrispettivi) diversi e il 'prefisso' principale, cioè quello più utilizzato.
Se la ditta ha un unico registro iva Vendite (Acquisti o Corrispettivi), questo potrà non avere prefisso ovvero avere un . 'punto' come prefisso per esigenze di procedura.

Numerazione automatica fatture
Consente di abilitare o disabilitare il fatto che, durante la registrazione delle fatture da Input di Prima Nota, il numero documento (protocollo) venga incrementato automaticamente.

Numeratore separato per note di credito
Se il campo è spuntato (cioè impostato a Si), le note di credito prenderanno una numerazione separata rispetto le fatture (questo vale sia per clienti sia per fornitori).
Se si desidera separare la numerazione SOLO per le note di credito clienti e NON per quelle fornitori, basta inserire nei parametri di personalizzazione una riga con il parametro: NcAcqSepar con gruppo: PN e valore: N

Percentuale Ritenuta d'acconto (Vendite)
Se sulla fattura che si emette al cliente (con il programma di emissione fatture), va calcolata e contabilizzata la Ritenuta d'acconto e la percentuale è uguale per tutti i clienti, la si può inserire qui. Essa verrà poi portata in automatico su tutti i clienti creati. Se i clienti NON hanno tutti la ritenuta, occorre lasciare bianco questo campo e inserire la % solo sui clienti interessati
Vedi Ritenuta d'acconto.

Percentuale Ritenuta d'acconto (Acquisti)
Utilizzata dal programma di input prima nota per calcolare e registrare la Ritenuta d'acconto, nel momento in cui si registra la fattura di acquisto di un fornitore che ha questa percentuale valorizzata. Se la percentuale è uguale per tutti i fornitori questa può essere inserita una volta per tutte in questo campo. Se i fornitori NON hanno tutti la ritenuta, occorre lasciare bianco questo campo e inserire la % solo sui fornitori interessati.
Vedi Ritenuta d'acconto.


PROCEDURE INSTALLATE

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Si chiede di specificare quali delle procedure utilizzerà l'azienda in oggetto.

Per quanto riguarda la Contabilità, sono possibili due opzioni, Contabilità generale (completa) e Ridotta.

La differenza tra le due consiste nel fatto che la Ridotta non consente i fare nessuna stampa fiscale (giornale, registri iva, chiusura iva); può essere utile, ad esempio, a chi vuole consultare le schede e gli scadenzari dei clienti avendo la fatturazione mentre la parte fiscale della Contabilità la tiene il consulente.

Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

In generale il menu presenta tutte le funzioni relative alle procedure installate, per tutte le aziende. E' possibile fare in modo che per ogni azienda vengano abilitate solo le procedure che verranno effettivamente utilizzate, in base a quanto scritto su questa tabella.
Occorre creare il parametro di personalizzazione: VerifAbil (in Parametri e utilità - Gestione Personalizzazioni)


CONTI COMUNI

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Questa tabella contiene tutti i conti che verranno poi proposti per essere utilizzati nelle varie elaborazioni o , a volte, utilizzati automaticamente.
E' indispensabile compilare tutti i campi, anche quelli che apparentemente sembrano non servire, al fine di ottenere in seguito registrazioni corrette.
Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Gruppo-Mastro Clienti e Fornitori
Verranno proposti in Gestione Clienti e Fornitori come Gruppo e Mastro di appartenenza di ogni nuovo codice.

Merci C/Vendite - Acquisto
I codici dei conti impostati in questi campi verranno proposti automaticamente in ogni articolo di magazzino e lì potranno essere variati all'occorrenza. Verranno poi utilizzati dalla contabilizzazione delle fatture per la generazione del movimento di ricavo.

Conti Iva (Vendite, Acquisti, Corrispettivi, Intra Cee, Iva ad esigibilità differita,Iva per Cassa)
Sono i codici dei conti utilizzati in automatico dai programmi di inserimento della Prima Nota e della contabilizzazione delle fatture, per la generazione della riga iva della registrazione. Verrà utilizzato un conto o un altro a seconda del tipo di registrazione che si sta facendo.
Se sulla causale è valorizzato il conto iva, verrà utilizzato quello e non questi.

Conto Iva Split Payment
Conto utilizzato in automatico nelle registrazioni delle fatture emesse alla Pubblica Amministrazione per le quali vige la regola dello split payment

Anticipi
Utilizzato per la registrazione automatica degli anticipi su fattura.

Arrotondamenti
Viene utilizzato dalla contabilizzazione fatture, per generare la riga di arrotondamento derivata dalla trasformazione in moneta corrente di una fattura in valuta.

Omaggi
Per la registrazione in contabilità di eventuali omaggi in fattura.

Abbuoni attivi - passivi
Utilizzati dal saldaconto per la registrazione automatica degli abbuoni derivati da incassi o pagamenti parziali di scadenze.

Profitti e Perdite
Utilizzato nella chiusura di fine anno come conto transitorio per chiudere i costi e i ricavi dell'esercizio.

Utile - Perdita su cambi
Utilizzato dal saldaconto in caso di generazione automatica di incassi/pagamenti di scadenze in valuta.
(Se non si registrano movimenti in valuta, si possono non impostare)

Utile - Perdita d'esercizio
Utilizzato dalla generazione della chiusura del bilancio per rilevare l'utile o la perdita dell'esercizio.

Bilancio di chiusura - apertura
Conti transitori utilizzati dalla chiusura e apertura di bilancio per chiudere i conti patrimoniali.

Cliente corrispettivo
E' il codice di un cliente 'fittizio' da creare nella tabella clienti, utilizzato dal programma di emissione scontrino (Reg.di cassa) e nella generazione dei movimenti di Prima Nota fatta alla chiusura serale della cassa.

Cassa contante
Utilizzato dalla Prima Nota per la registrazione automatica dei pagamenti-incassi per cassa.

Cassa assegni - carta di credito - bancomat
Conti utilizzati dal programma di chiusura serale del registratore di cassa per differenziare gli importi nella registrazione in prima nota degli incassi, a seconda di quanto indicato, come modalità di incasso, in ogni scontrino.

Cliente per documenti interni
Cliente fittizio. Verrà utilizzato per l'inserimento di ordini, ddt interni (cioè per spostamenti di merci tra magazzini della stessa ditta)

Ritenuta d'acconto (Vendite) / Ritenuta d'acconto (Acquisti)
Conti utilizzati per la registrazione della ritenuta d'acconto in fase di Contabilizzazione fatture di vendita o registrazione in prima nota di fatture di acquisto con ritenuta di acconto.


CAUSALI COMUNI

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Questa tabella contiene tutti i codici causali che verranno utilizzate nelle varie elaborazioni automatiche, cioè dove si devono generare in automatico dei movimenti di prima nota. E' indispensabile compilare tutti i campi, anche quelli che apparentemente sembrano non servire, al fine di ottenere in seguito registrazioni corrette.
Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Causale fattura emessa e nota di credito a clienti
Sono i codici delle causali che verranno utilizzate per la registrazione contabile delle fatture emesse se non né è stata indicata una diversa sul Tipo documento.

Causale fattura emessa e nota di credito con iva ad esigibilità differita
Sono i codici delle causali che verranno utilizzate, dalla contabilizzazione delle fatture, per la registrazione contabile delle fatture/note emesse con iva ad esigibilità differita, salvo non ne sia stata indicata una diversa sul Tipo documento.

Anticipi
Serve per la registrazione dell'articolo dell'eventuale anticipo durante la contabilizzazione fattura.

Arrotondamenti
Omaggi
Incassi
Serve per l'articolo di incasso automatico di una fattura generato da prima nota (F9)

Incassi e pagamenti per saldaconto e prima nota
Verranno proposte nel saldaconto come causali per gli articoli di incasso o pagamento.
La causale di pagamento sarà quella proposta anche in prima nota quando, al termine della registrazione di una fattura, si vuole registrare il pagamento in automatico (F9)

Causale per Ritenuta d'Acconto
E' il codice della causale che verrà utilizzata, in mancanza di quella specificata sulla causale della fattura, dalla contabilizzazione fatture, per l'eventuale registrazione del movimento della Ritenuta d'acconto.

Giroconti IVA
Codice causale che verrà utilizzato dall'aggiornamento IVA per le registrazioni di Giroconto degli importi incassati/pagati nel periodo di IVA per Cassa (vendite e acquisti) a Iva Vendite o Acquisti

Codice Spesa per Cassa Previdenza
Si accetta il codice di una spesa nella quale il campo 'Cassa previdenza' è impostato a Si
Se la ditta deve calcolare, in emissione fattura, la Cassa previdenza, occorre aver creato una Spesa in percentuale nella tabella Spese e impostare qui il codice in modo che, tale spesa, possa essere caricata in automatico sulla fattura in corrispondenza ai clienti per i quali è prevista l'applicazione.


PARAMETRI di CONTABILITA' GENERALE

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Anno
E' l'anno contabile corrente

Data inizio (fine) esercizio
Generalmente questa data coincide con il 1' Gennaio.

Ci sono però alcune aziende per le quali l'anno fiscale non coincide con l'anno solare. In questo caso occorre che l'anno (campo precedente) coincida con l'anno della data inizio esercizio. (Es. anno 1999 - Inizio 01/06/99 fine 30/05/99).

La data di fine esercizio viene impostata automaticamente ma si consente all'operatore di variarla per casi particolari che possono presentarsi.
(es. la contabilità di una ditta che non inizia al 1' gennaio ma finisce regolarmente al 31 dicembre).
Queste date interessano solo la parte contabile mentre 'l'anno iva' va sempre dall'1/1 al 31/12.

Anno precedente aperto
Indica se, all'inizio di un nuovo anno, sono già state generate le operazioni di chiusura dell'anno precedente e la riapertura dei conti. Fino a quando l'anno precedente risulta aperto, sarà possibile effettuare registrazioni in entrambi gli anni.
Non possono esistere più di due anni aperti contemporaneamente.

Azzera numero registrazione ogni anno
Con questo campo si consente all'operatore di decidere se azzerare o no, all'inizio di ogni nuovo anno contabile, il numeratore degli articoli di prima nota.

Anno inizio numerazione
Questo campo non viene preso in considerazione se si è scelto di azzerare il numeratore delle registrazioni di prima nota all'inizio di ogni nuovo anno.
Se invece si sceglie una numerazione continua ma da un certo anno si vuole ricominciare da uno, basta mettere qui l'anno.

Anagrafica completa sui registri iva
Indica se in stampa dei registri iva per ogni cliente o fornitore si deve stampare solo la Ragione Sociale e la Partita Iva oppure tutti i dati anagrafici.

Iva per Cassa
Indica se la ditta ha adottato il regime dell'iva per cassa
Valori ammessi: No - Si - Si ma dipende dalle attività Iva

Data inizio e fine regime iva per cassa
Nel caso sia impostato a 'Si' il campo precedente dovrà essere impostata la data in cui si inizia ad applicare il regime in oggetto. La data di fine è anch'essa obbligatoria e se è sconosciuta dovrà essere impostata a 31/12/9999.
Se 'Si ma dipende dalle attività Iva' , le date DEVONO essere impostate sulle singole attività che lo applicano con la Gestione Dati Iniziali Iva.

Data inizio e fine procedura concorsuale (Regime iva per cassa)
Se è stato scelto il Regime dell'Iva per cassa e la ditta è assoggettata a procedura concorsuale, occorre impostare qui almeno la data di inizio per evitare che l'aggiornamento iva consideri da detrarre l'iva delle fatture ricevute da oltre un anno e non ancora pagate.

Gestione di più attività iva
Indica se la ditta gestisce più attività dal punto di vista dell'Iva per cui dovrà fare liquidazioni separate poi una riepilogativa. In caso di più attività occorre poi compilare la tabella Attività Ditta.

Importi di riferimento per selezionare i documenti da trasmettere nella Comunicazione Operazioni rilevanti ai fini IVA:
il primo riguarda le operazioni fatte con fattura, il secondo quelle con rilascio di Ricevuta Fiscale, Scontrino (registrazioni fatte con causale di tipo corrispettivo), Fattura Dettaglianti.
Se questi due campi non vengono compilati, i programmi assegneranno loro i valori di default rispettivamente di 3,000,00 e 3.600,00

Conto Crediti Sospesi
Utilizzato in registrazione veloce corrispettivi per registrare l'eventuale riga di corrispettivo non incassato.

Giorni di chiusura
Utilizzato in registrazione veloce corrispettivi per evitare di chiedere l'importo del corrispettivo anche per i giorni di chiusura dell'esercizio.


PARAMETRI per Ri.Ba. ELETTRONICHE

PARAMETRI per Ri.Ba. ELETTRONICHE (Rid)

In questa tabella vengono impostati alcune informazioni generali che servono per generare il flusso delle Ricevute Bancarie in modo da fornirle alla banca su supporto magnetico.
Le stesse informazioni verranno utilizzate anche per la preparazione del file Rid.

Prima di uscire dalla maschera occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Se, in questa maschera, non viene valorizzato il campo Cod.Fiscale/P.Iva, sui file Ri.Ba./Rid e sulla distinta verrà stampato quello letto dall'anagrafica ditta.
Oltre ai dati anagrafici si consente di personalizzare il nome del file delle Ri.Ba/Rid
Vengono date due possibilità:

  • R + codice azienda (codice univoco che identifica l'azienda, inserito in Gestione Database Aziende) seguito da numero distinta
    Es. R0010004 distinta 4 dell'azienda con ID 1
    Per il file Rid verrà utilizzata la lettera D
  • Riba+ codice azienda (codice univoco che identifica l'azienda, inserito in Gestione Database Aziende)
    Es. Riba001
    Per il file Rid verrà utilizzata la parola Rid

Con la prima scelta si consente di preparare file relativi a distinte diverse e di passarli successivamente alla banca, con la seconda ogni volta che si ripete la preparazione del file di una distinta lo si sovrappone al precedente (che quindi dovrà già essere stato spedito).

La cartella nella quale viene scaricato il file è impostata in aziwin.ini tra i parametri generali:
DirRiBa= ….
e può essere variata dall'installatore (in generale è \database); l'utente può tuttavia decidere di volta in volta, di variare la destinazione e nome del file, tramite il pulsante Cambia.

Tipo pagamento per distinta clienti-fornitori
Se impostati verranno proposti in automatico al momento della compilazione della distinta.


PARAMETRI di MAGAZZINO

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

In questa pagina si chiede di impostare alcune caratteristiche della procedura di magazzino.
Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Anno
Questo campo va impostato la prima volta al momento dell'installazione poi viene variato automaticamente, di anno in anno, quando si esegue la funzione:
Cambio anno di magazzino.
Indica l'anno di lavoro. E' l'anno di riferimento per l'inserimento dei movimenti di magazzino e per l'aggiornamento dei progressivi.

Data inizio (fine) periodo
Indica l'inizio dell'anno 'fiscale' del magazzino. Generalmente questa data coincide con il 1' Gennaio ma per alcune aziende l'anno fiscale non coincide con l'anno solare. Poiché i progressivi di magazzino vengono incrementati 'per anno' è importante che tale data sia corretta al fine di ottenere la giacenza calcolata correttamente.

La data di fine periodo viene impostata automaticamente.

Data ultima stampa giornale
Questa data viene aggiornata dalla stampa del giornale in modalità 'fiscale' e serve per evidenziare all'operatore fino a quale data è stata fatta la stampa.

Uso codice a barre
Se impostato a si, in gestione articolo verrà reso obbligatorio l'inserimento del codice a barre.

Codice tasto per attivazione decodifica del codice a barre
Uso futuro

Tipo codice a barre
Utilizzato nelle stampe etichette e per la generazione bit di controllo codice a barre.

Questo campo viene utilizzato in alternativa a quello scritto su ogni articolo o a quanto scritto sul filtro di stampa se tutti gli articoli hanno lo stesso codice a barre.

Può assumere i seguenti valori:

  • 12 Per utilizzare il codice 128 il quale permettere di utilizzare tutti i caratteri ascii e nel codice non viene memorizzato il check digit.
  • 39 Per utilizzare il codice 39 il quale permettere di utilizzare codici alfanumerici con solo lettere maiuscole con check digit
  • 13 Per utilizzare il codice EAN 13
  • E8 Per utilizzare il codice EAN 8
  • UA Per UPC A (codice di 12 caratteri)

Lunghezza codice a barre articolo
La lunghezza massima del codice a barre è di 128 caratteri. Se si compila questo campo e il tipo codice a barre è diverso da Ean 8 e Ean 13, in gestione articoli di magazzino e in variazione automatica articoli, il codice a barre verrà sempre allineato alla lunghezza qui definita con degli zeri a sinistra.

Generazione automatica del codice a barre
Se impostato a SI ogni volta che si crea un nuovo articolo in magazzino verrà generato automaticamente il codice a barre a seconda del Tipo codice a barre impostato.
Per il codice 128, se si preme il pulsante di generazione automatica, viene messo il codice a barre uguale al codice articolo (è indifferente che sia numerico o alfanumerico) prendendo tanti caratteri quanti indicati in Lunghezza codice a barre,

Generazione bit di controllo codice a barre
Se impostato a si, in gestione articolo, una volta inserito il codice a barre (senza bit di controllo) sarà il programma a generare quest'ultimo.

Magazzino principale
E' il codice che verrà proposto ad ogni richiesta di codice magazzino.

Listino principale
E' il codice che verrà proposto ad ogni richiesta di listino.

Gestione data inizio validità listino
Questo campo consente di gestire o meno la data di inizio validità di un listino.
Gestire la data inizio validità significa che per un determinato listino si vogliono avere in linea simultaneamente i prezzi di periodi diversi (es. dal 1' gennaio al 31 marzo l'articolo costa 100, dal 1 aprile al 30 giugno costa 200); in questo modo si può preparare il listino di un periodo successivo, pur utilizzando il precedente in quanto il programma cerca il prezzo corrispondente alla data del documento.

Se non c'è questa necessità, basta non spuntare il campo, dire che la data inizio listino è Predefinita e digitare tale data che non dovrà più essere variata. In questo caso, i programmi non chiederanno nè visualizzeranno mai la data inizio listino.

Quale data per inizio listino
Ogni listino deve avere una 'data inizio validità' obbligatoria.
In questa fase è possibile stabilire come deve essere questa data:

  • Predefinita
    Scelta obbligatoria se il campo precedente non è stato spuntato.
    La data sarà uguale per tutti i listini e dovrà essere digitata nel campo successivo.
  • Data del giorno
    nel momento della creazione del listino, il programma assegna come data di inizio, la data del giorno.
  • Manuale
    nel momento della creazione del listino verrà chiesto di digitare la data

Data predefinita di inizio validità listino
Questa data è da compilare se precedentemente si è dichiarato di volere una data Predefinita come inizio listino. Verrà proposta come data di inizio validità di ogni listino inserito.

Segnalazione giacenza negativa/sottoscorta
Consente di impostare un segnale, che poi verrà riportato in ogni articolo e quindi potrà essere modificato per ogni articolo, per ottenere o meno una segnalazione acustica in fase di inserimento movimenti, documento di trasporto e fattura, se l'articolo va sottoscorta o se la giacenza diventa negativa.

Numero decimali in quantità
Indica il numero massimo di decimali da gestire nei campi quantità degli articoli.

Numero etichette da stampare
Questo numero indica quante etichette stampare, per ogni articolo, in stampa etichette. Se ci sono articoli per i quali ne serve un numero diverso occorre specificare tale numero nell'anagrafica articoli.

Ricerca articolo
Indicano qual' è il campo di ricerca per l'articolo, durante l'inserimento di movimenti di magazzino, DdT, Fatture e Scontrini. L'articolo si può cercare per codice/descrizione o per codice a barre.
Nei singoli programmi sarà comunque possibile passare da una modalità all'altra.

Nomi quantità aggiuntive (1-3)
Sono i nomi da dare a 3 campi facoltativi nei quali è possibile memorizzare delle quantità particolari, movimentate in parallelo alle quantità di carico e scarico. Questi nomi compariranno nelle stampe come titoli di tali quantità (es. c/dimostrazione, Uso interno).
Sono posizionali per cui occorre che utilizzarle in sequenza, la 1, la 2 e la 3 e non solo la 3.

Aggiorno fornitore abituale
Se SI ad ogni carico si aggiorna il codice fornitore sull'articolo di magazzino altrimenti rimane fisso quello inserito dall'operatore.

Gestione archivio articoli fornitore
Se impostato a SI consente di gestire, per ogni articolo e fornitore dal quale esso viene acquistato, il codice articolo fornitore e l'ultimo costo. Questo archivio verrà aggiornato ad ogni acquisto, generato da un movimento di magazzino con causale che prevede l'aggiornamento di almeno un costo.
Questi dati potranno essere utilizzati per statistiche (ES. da chi è stato acquistato l'ultima volta un certo prodotto e a che costo) e negli ordini al fornitore.

Gestione Taglie
Consente di abilitare la gestione di Taglie/Colori o comunque di uno o due sottolivelli per ogni prodotto, per i quali tenere separato quantità e prezzi.

Gestione Cauzioni
Consente, se impostato a Si, di gestire le cauzioni per i vuoti.

Codice fornitore per produzione
Questo campo dovrà essere compilato con un codice fornitore fittizio (che rappresenta la ditta stessa). Verrà utilizzato nella generazione del lotto per gli articoli che non vengono acquistati ma vengono caricati a magazzino da un movimento di produzione.

Percentuale maggiorazione automatica per creazione listino di vendita
Al momento del caricamento in magazzino di un movimento di acquisto è possibile, attivando il parametro di personalizzazione: ListVenDaAgg, aggiornare un listino di vendita degli articoli acquistati, con un valore pari al costo inserito sulla riga maggiorato di una percentuale che può essere derivata dal fornitore (o dalla tabella di magazzino se è uguale per tutti i fornitori) o dall'articolo. Se la percentuale sul fornitore è a 0, viene presa quella della tabella di magazzino. Se si vuole non operare la maggiorazione in corrispondenza ad alcuni fornitori, occorre mettere le percentuali su tutti i fornitori, lasciare a 0 quelli desiderati e lasciare vuoto il campo in tabella di magazzino.


PARAMETRI di FATTURAZIONE

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Uso sconto quantità
Indica se nei documenti di vendita viene applicato uno sconto quantità sugli articoli. Se impostato a No i programmi non gestiranno tale sconto anche se le rispettive tabelle sono compilate.

Numero copie Ddt
Indica il numero di copie che dovranno essere stampate per ogni Ddt. Il numero verrà proposto ad ogni stampa.

Tipo documento Ddt
E' il codice del tipo documento che verrà proposto nel programma di inserimento dei documenti di trasporto.

Tipo documento per Ddt interni
E' il codice di un tipo documento che verrà utilizzato nel programma di inserimento dei documenti di trasporto per movimenti di merce tra magazzini della stessa ditta.

Elenco prefissi Ddt
E' l'elenco dei 'prefissi' utili ad individuare gli eventuali bollettari utilizzati. Se si utilizza un unico bollettario, questo campo verrà compilato automaticamente con un '.' (punto). Servirà per stabilire da quale numeratore prendere il numero da assegnare al Ddt in fase di stampa.

Prefisso principale per Ddt
E' il prefisso che verrà proposto nel programma di inserimento dei documenti di trasporto.

Raggruppamento Ddt
Indica come devono essere raggruppate le bolle/ddt in fattura riepilogativa.

  • S - tutte le bolle/ddt del cliente vengono riepilogate in un'unica fattura.
  • N - verrà emessa una fattura per ogni bolla.
  • A - gli articoli verranno raggruppati, in evasione, per codice per cui compariranno una sola volta in fattura con una quantità che sarà la somma delle quantità dei vari ddt. Verrà inoltre stampato l'elenco (numero e data) delle bolle/ddt alle quali tali articoli appartengono.
    Questo metodo viene utilizzato da chi fa consegne ripetitive agli stessi clienti per gli stessi prodotti, ad esempio i panifici.
  • D - le bolle verranno riepilogate per destinazione.
  • E - Come A + D
  • C - Contratto

Dove stampo elenco Ddt
Questo campo ha senso solo se nel campo precedente si è deciso di stampare raggruppando gli articoli. In questo caso si può scegliere se stampare l'elenco dei Ddt (numero e data) a inizio corpo (cioè prima degli articoli) o a fine corpo (dopo).

Raggruppamento Ddt per Magazzino e per Vettore
Indicano se in fase di evasione dei Ddt, due Ddt con magazzino diverso o vettore diverso possono essere riepilogati nella stessa fattura. Se questi campi non sono spuntati, una stessa fattura potrà contenere DdT la cui merce è uscita da magazzini diversi e/o spedita con vettori diversi.

Numero copie Fatture
Indica il numero di copie che dovranno essere stampate per ogni fattura. Il numero verrà proposto nella maschera di stampa.

Modalità di generazione movimenti da fatture in contabilità
Una volta stampate le fatture è possibile eseguire un programma che genera in automatico i movimenti per la contabilità. Si può decidere tra

  • generare i movimenti in un'area di parcheggio (per poterli controllare, eventualmente correggerli e passarli in contabilità in un secondo tempo)
  • generarli e mandarli direttamente in contabilità (aggiornando i progressivi contabili e creando eventuali scadenze).

Dalle fatture crea SOLO le scadenze
Se non è installata la procedura di Contabilità, è comunque possibile generare le scadenze per le fatture emesse allo scopo di poter gestire uno scadenzario attivo e di trasmettere le Ri.Ba. alla banca.

Se si generano i movimenti di fatturazione sugli archivi di appoggio o non si generano affatto ma si desidera gestire le scadenze occorre barrare questo campo.

Se invece i movimenti della contabilizzazione delle fatture vanno direttamente sugli archivi di Contabilità, la generazione delle scadenze avverrà sempre, purchè sulla fattura ci sia una condizione di pagamento.

Pertanto ha senso porre a Si questo flag se il campo Modalità di generazione movimenti da fatture in contabilità è stato posto a No o ad A-Archivi di parcheggio.

Stampa sconto pagamento nel corpo fattura
Indica se, in caso di presenza di sconto pagamento sulla fattura, questo va evidenziato nel corpo oppure in un campo apposito predisposto sul modulo.

Tipo documento per fattura
E' il codice del tipo documento che verrà proposto nel programma di inserimento fattura.

Tipo documento per fattura accompagnatoria
E' il codice del tipo documento che verrà proposto nel programma di inserimento fattura accompagnatoria.

Testo per dichiarazione di intenti
Attualmente NON si deve più compilare più questo campo ma utilizzare il parametro di personalizzazione DichIntentiTab e i dati della dichiarazione di intenti scritti sull'anagrafica del cliente nella maschera 'Dich.Intenti', questo consentirà di poter ristampare le fatture vecchie con gli estremi della lettera di intento attiva al momento dell'emissione della fattura.

Questo campo è stato utilizzato in particolare fino alla versione 3.03B della procedura.
Contiene la parte fissa del testo da riportare su fattura se il cliente ha la lettera di intenti: Es. Oper.non imp.ai sensi degli art.8/8 bis-9 del DPR 633/72 Vs dich.di intententi
Questa scritta verrà stampata a piede fattura prima del contenuto del campo Dichiarazione di intenti del cliente (che dovrà contenere N' … del xx/xx/xxx).

Ditta ONLUS, Testo ONLUS
Indica se l'azienda è una Onlus (Organizzazione senza scopo di lucro).
In questo caso, in ottemperanza all'articolo 17 del D.L. 460/97 che riguarda la disciplina fiscale delle Onlus, se si emette fattura a clienti esenti, non si deve MAI applicare il bollo e si deve stampare nel corpo fattura una scritta della quale si consente di inserire il testo
(es. Esente da bollo per Art.17 D.L. 460/97 Disciplina fiscale delle ONLUS)

Causale trasporto, Aspetto dei beni, Trasporto
E' il prefisso che verrà proposto nel programma di inserimento dei documenti di trasporto.

Stampa Riferimento Cliente
Indica se si deve stampare sui documenti (ordini, Ddt, fatture) il campo Riferimento Cliente impostato nella testata. Per i documenti generati da una evasione sarà la fase di evasione a portare o meno il campo sul documento a seconda di questo flag.
Qui è possibile indicare un modo generale di operare, su ogni cliente tuttavia si potrà personalizzare di nuovo questo campo.

Stampa Riferimento Ordine
Indica se sui documenti che evadono un ordine o un preventivo dovrà essere scritto numero e data del documento di provenienza. Qui è possibile indicare un modo generale di operare, su ogni cliente tuttavia si potrà personalizzare di nuovo questo campo.

  • No
  • Si
  • Preventivo
    Solo sui documenti che evadono un preventivo verrà stampato il riferimento ad esso
  • Ordine
    Solo sui documenti che evadono un ordine verrà stampato il riferimento ad esso

Formato di stampa per riga Riferimento Cliente
Non utilizzato. Serviranno per stampare la riga che contiene il Rif.Cliente in un formato diverso dalla riga descrittiva. Saranno uno o più caratteri che dovranno poi ripetersi 'uguali' all'interno dei filtri di stampa in corrispondenza alla riga che dice come stampare il 'Rif.Cliente'.

Formato di stampa per riga Riferimento Ordine
Non utilizzato. Come Sopra.

Formato di stampa per riga Riferimento Ddt
Non utilizzato

Descrizioni campi liberi per testata docum. (1-4) e relativi flag Da evadere (1-4)
E' possibile inserire fino a quattro descrizioni di campi aggiuntivi da gestire sulle testate dei documenti di vendita esempio: Modello, Targa etc. Se compilati verranno richiesti in testata documenti nella maschera 'Note Cliente'
Per ogni campo nuovo introdotto occorre specificare se, in caso di evasione del documento (es. da Ddt a fattura), deve essere copiato sul documento di evasione.

Come evadere
Indica come vanno portati sul documento di evasione i campi suddetti

  • No I campi suddetti non vengono riportati sul documento di evasione
  • SI Genera sul documento di evasione una riga descrittiva con i campi uno sotto l'altro: es.
    TARGA: RA5555
    MODELLO: UNO 55S
  • Unica riga descrittiva:
    TARGA: RA5555 MODELLO: UNO 55S

Formato di stampa per campi liberi
Non utilizzato

Fattura Elettronica
Progressivo HUB invio
E' una sigla che fornisce l'HUB Zucchetti da utilizzare all'interno del file XML per costruire il progressivo invio.
Nella funzione 'Informazioni fattura elettronica' c'è un pulsante per salvarla

Accesso Hub: Login e Password
Vanno inserite quelle fornite al momento dell'acquisto del pacchetto delle fatture


PARAMETRI PREVENTIVI, ORDINI (ACQUISTI-VENDITE)

Percorso: Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri)

Questa tabella contiene tutti i dati di base per l'utilizzo della procedura Ordini (Vendita-Acquisto) e Preventivi.
Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Tipo documento per Ordine e per Preventivi
E' il codice del tipo documento che verrà proposto nel programma di inserimento degli Ordini (o Preventivi).

Tipo documento per Ordini interni
E' il codice del tipo documento che verrà proposto nel programma di inserimento degli ordini interni cioè relativi a movimenti di merce tra magazzini della stessa ditta.

Numero copie Ordini e Preventivi
Indica il numero di copie di conferma d'ordine (o preventivo) da stampare. Il numero verrà proposto ad ogni stampa e potrà essere variato di volta in volta.

Ordini di Acquisto:

Tipo documento
E' il codice del tipo documento Ordine di Acquisto che verrà proposto nel programma di inserimento degli Ordini.

Listino
E' il codice del listino che verrà proposto in inserimento di un nuovo ordine di acquisto, in assenza di un codice di listino specifico sul fornitore.

Vettore
(non utilizzato) E' il codice del vettore con il quale si chiede sia consegnata la merce. Se impostato, viene automaticamente proposto nei dati di accompagnamento dell'ordine.

Stampa sull'ordine il codice articolo fornitore
Consente di stampare sulla conferma d'ordine, il codice articolo del fornitore letto dalla tabella Articoli-Fornitore.

Oggetto ordine
Se si scrive una frase in questo campo, essa verrà stampata, come Oggetto, sugli ordini nei quali il campo oggetto non è stato compilato.

Copie ordini
Indica il numero di copie di conferma d'ordine da stampare. Il numero verrà proposto ad ogni stampa e potrà essere variato di volta in volta.


PARAMETRI REGISTRATORE DI CASSA

L'inserimento di questi parametri è indispensabile se è stato installato il modulo di emissione scontrino anche se non in collegamento con un registratore di cassa ma semplicemente per utilizzarlo per fare lo scarico della merce venduta al banco.
Prima di uscire occorre salvare i dati inseriti altrimenti non verranno memorizzati.

Stampa righe scontrino
Indica cosa stampare sullo scontrino come descrizione della merce consegnata. E' possibile scegliere, compatibilmente con le caratteristiche del registratore di cassa, di stampare la descrizione del reparto di appartenenza di ogni articolo oppure la descrizione dell'articolo o, infine, un riepilogo per reparto con a fianco il totale della merce consegnata da quel reparto.

Tipo corrispettivi
Serve per caratterizzare lo scarico del movimento di corrispettivo generato automaticamente in Prima Nota quando si esegue la stampa della chiusura della cassa dal computer.

Ricerca articolo in emissione scontrino
Consente di impostare la modalità di base per la ricerca dell'articolo. Si può scegliere tra Codice o Codice a Barre.

Numero reparti attivi
Indica il numero di reparti attivi sul registratore di cassa. Potranno essere creati, nella tabella Reparti, reparti con codice minore o uguale a questo numero.

Reparto per fatturazione
Indica il reparto in cui verranno battuti dal registratore, gli scontrini ai quali segue fattura. Affinchè la chiusura serale generi il movimento del corrispettivo corretto in contabilità, occorre scegliere, per gli scontrini di questo tipo, la modalità di pagamento 'per cassa'.

Assegni - Carta di Credito
Se selezionati indicano che il programma di emissione scontrini deve accettare come modalità di pagamento anche questi oltre alla Cassa contante.

Segnalazione sottoscorta in scontrino
Indica se dare o no la segnalazione a video di articolo sottoscorta durante la compilazione dello scontrino.

Causale corrispettivi da scorporare e da ventilare
Sono i codici delle causali da utilizzare per la generazione, in contabilità, dell'articolo del corrispettivo giornaliero. Verrà scelta l'una o l'altra a seconda di quanto inserito in Tipo corrispettivi.

Causale per giroconto
E' il codice della causale di contabilità per la registrazione, a fine giornata, dei giroconti da Cliente corrispettivo ai vari conti di contabilità: cassa contante, cassa assegni etc.

Causale per scarico articoli
E' il codice della causale di magazzino con la quale verrà creato il movimento di scarico dei vari articoli.

Merci c/Vendite
E' il codice del conto che verrà utilizzato per la registrazione dei ricavo dalla vendita con registratore, se sul reparto non c'è un conto particolare.

Conto sospesi
E' il codice del conto utilizzato per lo scarico contabile del totale Sospeso giornaliero (gestito se il registratore da la possibilità di gestirlo)

Listino
E' il codice del listino da cui prendere il prezzo per la vendita con emissione scontrino. In generale i prezzi dovranno essere comprensivi di iva, se si utilizza un listino non ivato, sarà il programma a calcolare l' iva e a impostare il prezzo corretto.

Sconto prioritario
Indica quale sconto tabellare considerare prioritario nel determinare il prezzo finale di ogni articolo inserito nello scontrino, le possibilità sono: categoria/articolo o cliente/gruppo

Registratore attivo
Indica se il registratore è in linea o meno. Se impostato a No consente di utilizzare il programma di emissione scontrino, totalizzando i corrispettivi per la movimentazione giornaliera, senza emettere effettivamente lo scontrino.

Numero registratori collegati
Indica il numero di registratori collegati con il sistema informativo e utilizzati come stampanti fiscali.


GESTIONE PERSONALIZZAZIONI

Percorso: Parametri e utilità - Dati azienda e parametri

Questa funzione consente di inserire delle righe, scritte in modo opportuno, per impostare dei parametri al fine di attivare o disattivare comportamenti particolari nei vari programmi.

I vari programmi, nei punti in cui è previsto un comportamento diverso a seconda del valore assunto da un certo parametro, controllano se tale parametro è presente nella Tabella di Personalizzazione dell'azienda in elaborazione (gestita nella parte bassa del video) e, se non lo trovano lì, lo cercano in quella principale (parte alta del video).

Se il parametro non viene trovato, il programma opera nel modo standard altrimenti si comporta come specificato dal parametro.

La gestione delle due tabelle viene fatta con le modalità della gestione di linea e il contenuto dei campi: gruppo, chiave, valore deve essere quello gestito all'interno dei vari programmi, altrimenti non verrà preso in considerazione.

Sintassi per l'inserimento delle righe di parametri:

Gruppo
Indica dove il parametro è utilizzato (non inserire mai in questo campo i caratteri . (punto) e §)

Parametro
Nome del parametro

Valore
Valore da assegnare al parametro per ottenere l'attivazione della personalizzazione. Se non è presente la riga con il parametro o c'è e, in valore è stato scritto il valore descritto come Valore di default, il programma si comporterà in modo standard.

Questo campo può contenere una costante, cioè il valore assunto dal parametro, oppure può fare riferimento al valore assunto da un altro parametro inserito in un'altra riga.

Es.
Se per impostare una quantità di default in ogni riga nel programma di caricamento movimenti di magazzino si imposta la riga:
Gruppo: magazzino , Chiave: QtaDef , Valore: 1

Per impostare la quantità di default in inserimento Ordini si può fare:
Gruppo: ordini , Chiave: QtaDef , Valore: 1
oppure
Gruppo: ordini , Chiave: QtaDef , Valore: Personalizz.Magazzino.§QtaDef (cioè utilizza il valore del parametro impostato per il caricamento movimenti) in questo caso dovendo variare il valore 1 in altro valore basta farlo sulla riga del Gruppo: magazzino. (non si possono fare più di cinque 'rimandi')

Descrizione
Campo libero che descrive come opera il parametro in oggetto

Segue un elenco dei parametri suddivisi per area di applicazione.

Parametri comuni a tutte le procedure
Parametri contabilità
Parametri cespiti
Parametri magazzino
Parameri ordini, ddt, fatture
Parametri preventivi, ordini (acquisti/vendite)
Pers. parametri scontrino
Pers. parametri distinta base
Pers. parametri tracciabilità/lotti
Pers. Parametri matricole
Pers. parametri stampa fatt. su Pdf


Pers. parametri comuni

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Parametro: AggiornaVerifica
Gruppo: Menu
Valore: default impostato ad S
Se si imposta a N, nella maschera dell' Aggiornamento database verranno tolte le spunte alle due opzioni: Verifica dimensioni tabelle e Copia archivio prima di compattare (Queste opzioni servono a ottimizzare il compattamento in modo che venga segnalato l'eventuale eliminazioni di record per anomalie)

Parametro: ArrotIvaEuro
Gruppo: Tutti
Valore default: N
se vale S, calcolando l'iva in corrispondenza dell'euro si arrotonda per eccesso l'imposta invece che applicare l'arrotondamento matematica (regola di arrotondamento per l'Euro)

Parametro: ArrUnitIntermedio
Gruppo: Tutti
Programmi: Tutti quelli in cui c'è un calcolo dell' iva.
Valore default: N
Normalmente, per calcolare il totale di riga, si applica lo sconto al prezzo unitario e si moltiplica il risultato per la quantità della riga. Se però serve avere un prezzo unitario da stampare sul documento insieme all'importo di riga, affinchè quest'ultimo risulti esattamente uguale a prezzo unitario per quantità, occorre arrotondare l'unitario prima della moltiplicazione. Per far fare l'arrotondamento dell'unitario occorre impostare ad S questo parametro.

Parametro: BackupCompatta
Gruppo: Menu
Programma: Salvataggio archivi
Se vale S propone di default di fare il compattamento durante il salvataggio archivi
(Vedi anche CompattaVerifica )

Parametro: CFHelpRic11 e anche CFHelpRic12
Gruppo: Tutti
Programmi: Gest. Clienti e Fornitori, Pn, Preventivi , Ordini, ddt, Fatture, Caric. mov. di magazzino
Valore default: bianco. In questo caso, col tasto F11, si effettua la ricerca sulla prima parte del campo Ragione Sociale, con F12 invece sulla Ragione sociale completa (unione della prima e seconda parte)
Valore: se si scrive il nome di uno o più campi della tabella Pianoconti , premendo rispettivamente F11 e F12 la ricerca verrà fatta per tale campo
(es. cap & Pr cerca per cap e provincia , email cerca per indirizzo email)

Parametro: CognomePersFisica
Gruppo: Clienti
Programma: Gestione Clienti
Se vale S compilando Cognome o Nome viene impostato in automatico lo Stato Giuridico a 'persona Fisica' e si consente di inserire data di nascita etc. per la compilazione automatica del Codice Fiscale

Parametro: ColBackForm
 Gruppo: Tutti
Colore da usare come sfondo delle maschere (Es. &H00FF0000& è il blu).

Parametro: ColBackMenu
Gruppo: Tutti
Colore da usare come sfondo dei comandi del menù (Es. &H00FF0000& è il blu).

Parametro: CompattaAvvioTerm
Gruppo: Menu
E' il parametro che, se impostato, consente di eseguire il compattamento in base ai tempi stabiliti nel parametro CompattaAvvioGiorni. Deve contenere il nome del terminale che all'avvio lancia automaticamente il compatta. Se al posto del nome del terminale, si mette la parola TUTTI, qualsiasi postazione, quando entra, eseguirà il compattamento. (Per nome di terminale si intende il nome assegnato al momento dell'installazione di AziWin e che è scritto nel file aziwin,ini di ogni terminale)

Parametro: CompattaAvvioCopiaDb
Gruppo: Menu
Valore: S fa la copia del database prima di compattare

Parametro: CompattaAvvioVerif
Gruppo: Menu
Valore: S fa la verifica del database durante il compattamento

Parametro: CompattaVerifica
Gruppo: Menu
Valore: impostato ad S, nella maschera del Compattamento e del Salvataggio archivi presenta già spuntate alle due opzioni: Verifica dimensioni tabelle e Copia archivio prima di compattare (Questo per ottimizzare il compattamento in modo che venga segnalato l'eventuale eliminazioni di record per anomalie)

Parametro: CompattaAvvioGiorni
Gruppo: Menu
Va valorizzato con il numero di giorni che devono passare tra un compattamento e l'altro. La data di riferimento è quella del computer. Una volta eseguito il compattamento, il programma scrive nei parametri di personalizzazione una riga con il parametro: CompattaAvvioUltData nella quale mette la data in cui ha effettuato il compattamento. Tale data può, al bisogno, essere impostata anche manualmente dall'utente.

Parametro: CompattaAvvioUltData
Gruppo: Menu
Data in cui è stato effettuato l'ultimo compattamento. Vedi parametro precedente

Parametro: DataMinima
Gruppo: Tutti
Di default tutti i programmi accettano, nei campi data, date successive a: 01/01/1990
Impostando il Valore di questo parametro, con una certa data, questa risulterà essere la nuova data minima.

Parametro: DecodHelpAbil
Gruppo: Tutti
Consente di mostrare la maschera di help (ricerca codice) quando, uscendo da un campo dopo aver inserito un codice parziale, questo non viene identificato in maniera univoca.
Valori che può assumere

  • N (default) Funzione disabilitata
  • C - fa sempre, per prima, una ricerca simulando il tasto F2 (ricerca per codice) e, se non trova nessun dato, esegue la ricerca simulando il tasto F3 (ricerca per descrizione)
  • D - fa sempre, per prima, una ricerca simulando il tasto F3 (ricerca per descrizione) e, se non trova nessun dato, esegue la ricerca simulando il tasto F2 (ricerca per codice)
  • A - fa sempre la ricerca simulando il tasto F3 tranne per alcune tabelle nelle quali, da programma, è impostata la ricerca col tasto F2. Se non trova niente, ripete la ricerca simulando F2.
  • NN con NN numerico - esegue per prima, una ricerca simulando il tasto F3 (ricerca per descrizione) per codici di lunghezza minore o uguale a NN

Parametri: DecodHelpPersKey , Hlp+NomeHelp (vedi tabella)
Gruppo: Tutti
(Se DecodHelpAbil è diverso da N, sostituiscono il suo valore per le tabelle espressamente indicate)

  • N (default)
  • S abilita la gestione della ricerca del parametro Hlp+NomeHelp
    Hlp+NomeHelp può assumere il Valore x=2,3,4,etc.
    È il numero di Fx che si vuole utilizzare in modo che l’invio faccia la ricerca
    (quest’ultimo parametro quindi indica, per ogni singolo help, quale Fx utilizzare di default dopo il return, per cercare)
    Se questo secondo parametro non c' è o vale 0 viene utilizzata l'impostazione di DecodHelpAbil

Parametro: HlpSpost
Gruppo: Help
Valore: 0 sempre, 1 lista, 2 variazione, 3 mai
Per cambiare l'impostazione di default "spostamento riga in help con passaggio mouse". Il valore di default è 1. Con valore 3 si può fare un click sulla riga

Parametro: ListaAggEle
 Gruppo: Ordini, Preventivi, Ddt, Fatture, Pn
L'introduzione di questo parametro consente di personalizzare l'elenco dei campi che vengono visualizzati quando si esegue il pulsante Lista [image] nelle gestioni indicate dal 'gruppo'.
Valore: elenco delle colonne(campi) aggiuntive. Ogni colonna va separata dalla precedente dal simbolo §. All'interno di ogni colonna da aggiungere, vanno specificati, separati da virgola ',':

  • nome campo (obbligatorio) - E' il nome che il campo da ha nel database, se ambiguo va preceduto dal nome della tabella.
    I campi che si possono aggiungere devono essere stati estratti nella query all'interno del programma. In generale sono quelli della tabella principale (Testata ordini, ddt, pn etc.); per ordini, ddt e fatture sono disponibili anche i campi dei clienti (tabella PianoConti).
  • nr.colonna in cui quel campo dovrà comparire nella lista (obbligatorio). Se si inserisce un campo in mezzo (es. in 3 colonna) le altre colonne si sposteranno di un numero.
  • larghezza (se non si mette si dovrà scrivere ,,)
  • intestazione (se non si mette si dovrà scrivere ,,)

Il numero delle colonne standard sono:
- per la fattura 13 campi. Le colonne 1 (Anno), 12 e 13 sono nascoste.
- per i ddt 12. Le colonne 1 (Anno) e 12 sono nascoste.
- per i gli Ordini/preventivi 14. Le colonne 1 (Anno) e 13 sono nascoste.
- per i gli Ordini Fornitori 13. Le colonne 1 (Anno) e 13 sono nascoste.
- per la Pn 14. La colonna 1 (Anno) è nascosta.

Parametro: ListaHideCol
E' collegato al precedente nel senso che consente di nascondere eventuali colonne della lista
Parametro: lista, separata da virgola (,) dei campi che si vogliono nascondere.

Parametro: ListaOrdin
Gruppo: Pn (e anche Preventivi, Ordini, Fatture, Ddt, Magazzino, Acquisti)
Programmi: Input Prima Nota, Preventivi, Ordini, Fatture, Ddt, Movim. di Magazzino, Ordini di Acquisto
Valore: Elenco campi per ordinamento della lista , separati da virgola. Se compilato sostituisce la order by di default della lista.
(Es. per PN Predoc, DataDoc desc, NumDoc desc, Datareg, NumReg - ordina per prefisso, data documento dalla più recente alla più vecchia,numero documento dal più alto al più basso, data e numero registrazione
Per Fatture, se il valore è: iif(isnull(DataDoc),1,0),Predoc, DataDoc, NumDoc, DataRif, NumRif
mette in testa le fatture stampate ordinate per prefisso, data, numero documento, poi quelle non stampate che non hanno data documento.

Parametro: Massimizzato
Gruppo: Tutti
Valore: Tutti oppure =lista nomi di terminale(separati da virgola)
Programmi: Tutti
Le maschere verranno mostrate sempre massimizzate.

Parametro: NomeHelpSQLPass
Gruppo: HELP
Valore: se vale S usa passthrough per fare la query
(Per NomeHelp vedere tabella che segue)
E' necessario per velocizzare l'Help degli articoli che visualizza anche il prezzo di listino e sarebbe molto lento (in questo caso i parametri da abilitare sono: ArticoloCodSQLPass e ArticoloSQLPass)

Parametro: NomeHelpCampi (*)
 Gruppo: HELP
Valore: ,Nomecampo1,Nomecampo2,Nomecampo3 (importante la virgola in prima posizione!)
(i vari Nomecampo sono i nomi dei campi contenuti nelle tabelle)
Si può inserire anche una query.
Programmi: Tutti
L'inserimento di parametri così fatti consente di aggiungere dei campi a quelli già visualizzati nelle varie liste di Aiuto (F2, F3 sui codici)

Ad esempio volendo aggiungere all'Help degli articoli il contenuto del campo 'scaffale' e 'ArtUm' si dovrà creare una riga nei parametri:
Gruppo: Help
Parametro: ArticoloCampi
Valore: ,scaffale,ArtUm
In particolare per visualizzare anche l'eventuale importo del Raee, nella maschera di aiuto dell'articolo, inserire una riga con questo parametro e scrivere in 'valore' la scritta: ,RAEE
Per visualizzare, per ogni articolo, la giacenza per l'anno corrente e sul magazzino principale, inserire la query:
,(SELECT sum(QtaIniziale+ iif(isNull(QtaCarico), 0,QtaCarico) + iif(isNull(QtaSCarico), 0,QtaScarico)) FROM ArticoliProg as ap, TabMagazzino as Tm WHERE Anno=Tm.AnnoCorr AND ap.Magazzino=Tm.MagPrincipale AND Articolo=articoli.articolo) AS GIAC

(*) NomeHelpCampi :

La parola Campi è fissa e DEVE sempre seguire il nome dell'Help.

Fanno eccezione Pianoconti, Clienti e Fornitori dove il parametro è rispettivamte: ContoCampi1, ContoCampi3, ContoCampi2.

Per quanto riguarda quest'ultimo, segue l'elenco di 'NomeHelp' per le tabelle principali:

Tabella | NomeHelp
AcqDocumenti | AcqDocumento
Agenti | Agente
ArtCatFiscali | ArtCatFiscale
ArtGruppi | ArtGruppo
Articoli | Articolo (ArticoloCod in DDt)
ArticoliFor | ArticoloFor
ArtListini | ArtListino
ArtUnitaMisura | ArtUm
AspettoBeni | AspettoBene
Banche | Banca
Causali | Causale
CauTrasporti | CauTrasporto
CentriDiCosto | CentroDiCosto
Cespiti | Cespite
CespitiCausali | CespitiCausale
Pianoconti: Conti | ContoCampi1 (o solo ContoCampi)
Pianoconti: Clienti | ContoCampi3
Pianoconti: Fornitori | ContoCampi2
FattDocumenti | FattDocumento
Gruppi | Gruppo
IndSped | IndSped
Tabiva | Iva
Listini | Listino
Lotti | Lotti
Magazzini | Magazzino
MagCausali | MagCausale
Mastri | Mastro
Monete | Moneta
NotaFisse | NotaFissa
Pagamenti | Pagamento
PagTipi | PagTipo
Reparti | Reparto
Rese | Resa
Scadenze | Scadenze
Spese | Spesa
Stati | Stato
Trasporti | Trasporto
Vettori | Vettore

Parametro: NoCopieSta
Gruppo: Tutti
Valore default: N
Programmi: stampe documenti (ordini, ddt, fatture) Serve per disabilitare la stampa di copie multiple gestita da stampante, nei casi in cui la prima copia del documento venga bene ma le successive no.

Con 'Valore' = "tutti", si disabilita la funzione su tutti i terminali.
Per disabilitare la funzione solo su alcuni terminali è sufficiente sostituire "tutti" con l'elenco dei terminali separati da una virgola.

Parametro: NoStampa
Gruppo: StaEtiCF
Valore: Elenco tabelle (es. Agenti,Agen2)
Programmi: Stampa etichette clienti e fornitori. In alcune situazioni il programma si è rivelato estremamente lento per il numero di tabelle da leggere. Si può impostare l'elenco delle tabelle che non servono all'utente particolare es. gli agenti per chi non li utilizza, in questo modo si velocizza l'elaborazione.

Parametro: NumerCodDef
Gruppo: Tutti
Valore: Nome numeratore (Utilizzato per numeratori in personalizzazioni)
Se, prima del codice numeratore, si mette il carattere ~ ,si intende che quello è un numeratore fisso, cioè in gestione si può gestire solo quel numeratore, altrimenti si potranno gestire tutti quelli con nome costituito da una parte fissa (primi 6 caratteri) e da 1 carattere variabile (carattere del prefisso)

Sul menu, la riga di chiamata della Gestione numeratori (programma personalizzato a seconda delle esigenze) avrà colonna Parametri, la scritta:
$ParamIni$ /f: FrmNumeratori /Num: param
Potrebbe anche avere /Num: Codice Dove per Codice si intende il Codice completo di un numeratore, in questo caso, la gestione , consentirebbe di gestire SOLO quel numeratore.

Parametro: PrimoCampo
Gruppo: Clienti (Fornitori)
Valore: N con N = numero del TabIndex del campo nella maschera (es. per Cognome: N=25)
Modifica il campo su cui si posiziona il cursore in inserimento di una nuova anagrafica. Utile per posizionarsi sul Cognome nel caso di azienda con clienti con prevalenza 'persone fisiche'
In alternativa, per impostare questa condizione solo per un terminale, si può mettere una riga nell'AziWin.INI del terminale interessato, nella sezione [Configurazioni] :
ClientiPrimo=N (FornitoriPrimo=N) con N = nr.tabIndex
In questo caso, per quel terminale, è prioritario rispetto al parametro di personalizzazione.

Parametro: PwdTerminale
Gruppo: Tutti
Valore default: S
Programmi: Menu
Il menu controlla che un utente non acceda, con la stessa login, da più terminali.

Parametro: SoloAsci
Gruppo: Carica
Valore default: N
Programmi: Tabella di caricamento file ASCII
Non caricare caratteri non stampabili.

Parametro: SostCRLF
Gruppo: Stampe
Valore default: <BR>
Programmi: Stampa parametrica Listini e Articoli su File
Sostituisce, nei campi Memo, il Carriage Return nel caso sia Stampa su File
Se vale NO lascia il CRLF
Se si mette \ si può mettere un codice ascii (es. \009 è il TAB)

Parametro: StampaVersione
Gruppo: Stampe
Valore default: S
Programmi: tutte le stampe
Se impostato a N , NON verrà stampata in nessuna stampa la scritta iniziale: AziendaPc 1.xx

Parametro: StampantiNoCassetti
Gruppo: Tutti
Programmi: tutte le stampe
Può essere impostato per indicare per quali stampanti non vanno considerati i cassetti.
Contenuto: TUTTE oppure l’elenco dei nomi dei device delle stampanti separati da virgola
(i nomi sono quelli scritti nell’elenco delle stampanti nei programmi di stampa)
E' stato introdotto perchè, per alcune stampanti, il programma andava in errore nella maschera di seleziona stampanti, quando eseguiva le istruzioni per esaminare i cassetti.

Parametro: StatoMonetaObb
Gruppo: Comuni
Valore default: S
Programmi: Gestione stati
Se impostato a N il campo moneta non verrà chiesto come obbligatorio

Parametro: TabTrascod
Gruppo: Tutti
Programmi: Gestione tabella trascodifiche - Caricamento Ordini da file esterno , Caricamenti personalizzati
Valore default: tutte le tabelle del DataBase corrente
Con questo parametro è possibile definire un elenco di tabelle del database, per le quali si dovranno impostare dei codici di trascodifica per l'export dati verso un'altra procedura (o import) velocizzando l'eleborazione
I nomi delle tabelle dovranno essere separati l'uno dall'altro dal ; (punto e virgola)
Se si dovranno impostare dei valori di trascodifica di dati che non sono codici di determinate tabelle si dovrà mettere §NomeParticolare-Descrizione
dove NomeParticolare verrà comunicato da Zucchetti Filiale di Ravenna (ex CSS) a seconda delle esigenze.
(es. per indicare che al Prefisso del registro iva X di AziendaPc corrisponde il carattere Y di un'altra procedura, poichè non c'è una tabella in AziendaPc che contiene l'elenco dei prefissi, si dovrà inserire una riga di questo tipo)
Se un nome tabella inizia con § vuol dire che è una tabella manuale (non è una tabella del db,
per cui non si fa il controllo dell’esistenza del codice).

Parametro: TermSessAggNome
Gruppo: Stampanti
Utilizzato nei collegamenti in Terminal server
Valore: stringa %§
Dove in stringa si deve impostare la stringa che windows aggiunge alle stampanti per fare la redirezione (per vederla si va, quando si è in collegamento in terminal server, nel Pannello di controllo - stampanti - nome della stampante, questo termina con una scritta messa tra parentesi tonde es.: (rediretto 1) o (redirect 1) a seconda della lingua)
Se la sessione è maggiore di 1 ed è stato impostato il parametro, il programma sostituirà al % il numero sessione e, se l'utente salva la stampante e il nome stampante è questo, esso viene sostituito con (rediretto+nr.sessione attuale)

Parametro: TastierinoVirgola
Gruppo: Tutti
Valore default: Bianco
Programmi: Tutti.
Se impostato a S, alla pressione del tasto '.' (punto) del tastierino numerico inserisce una ',' (virgola) utile per inserimento numeri con decimali (di default non è attivo). Attenzione: se questo flag è abilitato, anche nei campi meno il punto del tastierino numerico viene trasformato in virgola!

Parametro:VerifAbil
Gruppo: Menu
Valore default: N
Programmi: menu generale
Se vale S per ogni azienda viene verificato quali programmi mostrare a menù in base alle procedure che risultano installate nei parametri generali.


Pers. parametri contabilità

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Parametro: AccProtInf
Gruppo: Pn
Programmi: Se compilato, indica il codice della causale in corrispondenza della quale in prima nota si accetta la data protocollo inferiore alla data documento

Parametro: AbbSommaSup
Gruppo: BilCee
Programmi: Estrazione dati per bilancio Cee
Se per una ditta si deve stampare il Bilancio anche in forma abbreviata occorre collegare i conti opportuni anche alle testate con il campo "Forma di stampa": in forma abbreviata (oltre che a quelle normali). Impostando questo parametro a S, si dovranno collegare i conti opportuni solo alle testate con il campo "Forma di stampa": in forma abbreviata (evitando di collegarle anche in quelle "in forma normale")

Parametro: ArrotPercInc
Gruppo: PN
Programmi: Aggiornamento Iva per Cassa - Calcolo Iva per Cassa incassata/pagata
Default N. Se valorizzato con un numero, questo indica il numero di decimali a cui arrotondare la % per il calcolo di imponibile e imposta corrispondente all'incasso/pagamento.

Parametro: ArrotIvaPerCassa
Gruppo: PN
Programmi: Aggiornamento Iva per Cassa - Calcolo dell'imponibile e imposta corrispondenti a un incasso/pagamento ft. con iva per cassa
Valore: Default A=arrotondamento
Altrimenti S=Superiore. Indica come arrotondare gli importi

Parametro: CampiPersInfo
Gruppo: xbrl
Programmi: Bilancio Cee in formato Xbrl
Può essere utilizzato per creare una stringa, da inserire nei dati anagrafici del bilancio xbrl, che contiene una combinazione di campi estratti dalle tabelle: Ditta e DitAttivita
Il Valore se compilato deve:
- iniziare con la virgola
- contenere la lista delle espressioni sql da aggiungere all'sql del programma, separate da virgola,
- terminare con l’alias (as nome campo) da assegnargli
Tale "alias" dovrà essere inserito nel campo: "CampoAnag” della tabella Elementi Xbrl.
Es.:
, Ditta.IndirOp & ‘ ‘ & Ditta.LocalitaOp & ‘ ‘ & Ditta.PrOp as SedeOp

Parametro: CcDitta
Gruppo: Riba
Programmi: Generazione del file delle Ri.Ba./ Rid
Se questo parametro viene impostato a S, nel record 14 del file Ri.Ba. (record 10 Rid) verrà scaricato, nelle posizioni 58-69, il numero di C/Corrente letto dalla banca di presentazione della riba/rid. Diversamente queste posizioni sono occupate da caratteri bianchi.

Parametro: CdC
Gruppo: StMovCdc
Programmi: Stampa movimenti per centro di costo
Impostato ad S fa si che, nella stampa sintetica, venga stampato il centro di costo su ogni riga (pur essendo già nell'intestazione). E' stato inserito per chi deve portate in excel questa stampa e fare rielaborazioni, altrimenti non aveva una colonna con il centro di costo.

Parametro: ChiaveBaseLun
 Gruppo: Contratti
 Programmi: gestione contratti
Indica la lunghezza (il numero di cifre) del codice contratto 'numerico' e progressivo da generare in automatico dopo che l'utente avrà premuto il pulsante 'Crea codice automatico'.
Es. se il parametro vale 4, la generazione automatica dei codici produrrà 0001, 0002, 0003 etc.
Se questo parametro viene impostato a -1, a video viene tolto il pulsante che consente questo automatismo.

Parametro: ChiaveBase
 Gruppo: Contratti
 Programmi: gestione contratti
Si possono impostare alcuni caratteri di 'Prefisso' da usare come base per la creazione automatica del codice contratto

Parametro: CodStatoPers
Gruppo: Clienti o Fornitori
Si può inserire nel valore del parametro un codice che corrisponderà allo Stato da impostare di default nei dati anagrafici (Es. IT per Italia)

Parametro: CogeTerzi
Gruppo: ChiuIva
Se impostato a S e l'azienda è mensile consente a chi esercita l'opzione di tenuta della contabilità presso terzi di far riferimento, nelle liquidazioni iva periodiche, ai dati di due mesi precedenti, piuttosto che del precedente. In pratica la liquidazione di febbraio, stampata in marzo, conterrà i dati delle fatture di gennaio e non di quelle di febbraio come succede normalmente.
L'operatore dovrà indicare, nella maschera di stampa della liquidazione, il periodo delle fatture da considerare e il programma stamperà, nel titolo, il mese corretto di liquidazione che sarà quello successivo al mese richiesto.
(Es. in marzo si indicherà Periodo 1; in stampa si avrà: Chiusura Iva Febbraio xxxx e l'iva sarà quella delle fatture di Gennaio).
Per quanto riguarda la Chiusura e la Comunicazione iva annuale rimane tutto invariato in quanto si deve considerare comunque l'iva delle fatture di tutto l'anno per cui quella delle liquidazioni da febbraio xxxx a gennaio xxxx+1 che, per quanto riguarda il programma, hanno già aggiornato i dati da gennaio a dicembre.
Per quanto invece riguarda il quadro H della liquidazione iva annuale (che il programma non compila ma del quale stampiamo un riepilogo, con l'elenco dei debiti/crediti delle varie liquidazioni) si dovrà riportare nella riga di gennaio dell'anno xxxx, il risultato della liquidazione di gennaio dell'anno xxxx, quella che contiene le fatture di dicembre dell'anno xxxx-1, in febbraio il risultato della liquidazione di marzo e così via

Parametro: ContoNegN
Gruppo: PN
Programmi: Input prima nota
Si possono creare più righe (N=0,1,2 etc) con questo parametro e mettere in ogni riga, nel campo Valore, il codice di un conto nel formato: xx-yy-zzzz oppure xxyyzzzz oppure xxyyz (verrà interpretato come xxyy000z).

Durante l'inserimento di articoli in prima nota verrà dato un messaggio se il saldo di uno dei conti in elenco diventa negativo. Oltre a questi conti, il programma controlla comunque sempre il saldo del conto Cassa Contante il cui codice è inserito nella tabella dei conti comuni.

Parametro: CopiaDescrAgg
Gruppo: Vpartite
Programmi: Prima nota
Se viene impostato a S, durante la registrazione da input prima nota di un incasso (o pagamento), se si chiede la lista delle partite del cliente (o del fornitore) e sulla fattura che si va a incassare c'è una descrizione aggiuntiva, questa viene copiata sulla riga stessa.

Parametro: CorriRaggGio
Gruppo: Fiscali
Programmi: stampa Registri Iva Corrispettivi
Se viene impostato a S, tutti i corrispettivi di un giorno verranno sommati e stampati in un'unica riga.
Si stampano righe separate se ci sono, nello stesso giorno, corrispettivi da ventilare e normali.
La condizione per cui la stampa risulti corretta è che non venga chiesta la stampa del numero documento e che non ci siano, nelle registrazioni, note particolari da stampare. Se la ditta è in semplificata, per cui viene stampata la descrizione della c/partita della registrazione, tenere presente che, in questo modo, si stampa l'ultima c/partita del giorno.

Parametro: DataOp
Gruppo: PartVis
Se impostato a S, in Visualizzazione e stampa partitario e nella Stampa Giornale, i movimenti verranno ordinati per data protocollo piuttosto che per data registrazione.
ATTENZIONE: se manca la data protocollo il movimento non verrà considerato!
Per questo motivo, se questo flag è impostato ad S, in Gestione Causali di contabilità viene reso SEMPRE obbligatorio il Protocollo in quanto in tutte le registrazioni dovrà essere inserito numero e data protocollo.
Nei programmi in cui si genera in automatico una registrazione quali Saldaconto e Contabilizzazione Cespiti verrà chiesto di digitare obbligatoriamente numero e data protocollo.

Programmi: Gestione clienti e fornitori.
Gruppo: Clienti o Fornitori
Parametro: DescDataPers1, DescDataPers2, DescDataPers3
E' possibile impostare fino a 3 righe con questi parametri, in cui mettere il titolo di nuovi campi 'data' personalizzati, gestibili nella maschera dei dati anagrafici.

Parametro: DescDescPers1, DescDescPers2, DescDescPers3
E' possibile impostare fino a 3 righe con questi parametri, in cui mettere il titolo di nuovi campi 'data' personalizzati, gestibili nella maschera dei dati anagrafici.

Parametro: DescAgg
Gruppo: Saldac
Programmi: Saldaconto
Questo parametro può contenere una scritta (es. Scadenza del: ) alla quale verrà aggiunta la data scadenza, il tutto verrà memorizzato sulle righe, relative al cliente, dell'articolo di prima nota generato dal saldaconto.

Parametro: DescEmailPri (DescEmailAmm, DescEmailComm, DescEmailSped)
Gruppo: Clienti (Fornitori)
Programmi: Gestione Clienti e Fornitori, maschera 'Email'
Consentono di inserire, nel Valore, una descrizione per i campi 'email' delle anagrafiche, diversa rispetto a quella scritta a video dal programma.
Es. se si vuole cambiare la descrizione: 'Spedizioni' in 'Uff.spedizioni' si scriverà nel valore del parametro: Uff.Spedizioni
Vedi anche parametri: EmailPreDef EmailPec

Gruppo: PN
Programmi: Prima nota
Parametri per fissare una sequenza particolare di campi in inserimento/variazione nella maschera dei dettagli e nella visualizzazione dell'elenco dei dettagli.
Parametro: DettOrdInsDiv (DettOrdInsDiFat)
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di inserimento dei campi nella maschera di dettaglio delle registrazioni (valori dell'indice del controllo).
Ordinamento dei campi: se c’è un solo numero serve per dire che quello è il primo campo. Seguono gli altri in modo standard. Se si vuole un campo particolare per primo, poi il primo campo, si mette il particolare, poi il primo.
 Parametro: DettOrdInsTabDiv (DettOrdInsTabFat)
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di visualizzazione campi del dettaglio documenti (valori del tabindex corrente)
Parametro: DettOrdColDiv (DettOrdColFat)
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in gestione dettagli dei documenti.
Può contenere nomi di campi o anche espressioni
I nomi, separati da 'virgola' sono quelli delle variabili del database nella tabella MovPnDett, Pianoconti
Colonne con nomi personalizzati:
grid testata: Conto, Dare, Avere, ImpMonCorr, Protocollo, Documento
grid dettaglio fatture: Conto, Dare, Avere
grid dettaglio diversi: Conto, Dare, Avere, Protocollo, Documento, ControPartita

Dopo il campo si può mettere:
§ seguito da un numero per indicare le larghezza della colonna,
^ seguito da un nome che sarà l’etichetta da dare alla colonna (solo per i campi aggiuntivi , NON per campi usati dal programma)
 (es. Qta§900,_Descrizione,Articolo,ValUnitario+valtotale as sommaImp §1000)
Parametro: DettOrdColTestDiv (DettOrdColTestFat)
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in testata.
Stessa sintassi del parametro precedente.
Se il parametro non c’è o è vuoto viene assunto = al precedente.
Se si vuole che venga lasciato l’ordinamento previsto dal programma, pur avendo usato il parametro precedente, si valorizzi uguale a “-“ (meno)

Parametro: DetSoggRitAcc
 Gruppo: PN
Valore default: S
Programmi: Input prima nota (reg. fatture d'acquisto con Ritenuta d'acconto)
Questo parametro consente di abilitare solo qualche conto al calcolo dell'imponibile per ritenuta d'acconto, durante l'inserimento di una fattura con fornitore che ha la ritenuta d'acconto.

Se il parametro manca o è impostato a Si, tutti i conti inseriti nella fattura concorrono a formare l'imponibile su cui calcolare la ritenuta (salvo che sul singolo conto, o sulla singola riga in Pn, ci sia No ritenuta).

Viceversa si può impostare il parametro a N in modo che, in generale, nessun conto accumuli imponibile. Poi, andare su quei conti che generano imponibile e mettere il flag di Soggetto.
Vedere anche parametro: RitAccFornAutom

Parametro: DirDocCollegato
Gruppo: PN
Valore: percorso in cui vengono memorizzati gli eventuali documenti collegati alle registrazioni di prima nota e visualizzabili dall'interno dei partitari.
E' possibile scrivere nell'aziwin.ini il percorso (Es. DirCollegato=X/XXX) e nel valore del parametro:
§DirCollegato§NomeFile

Gruppo: Distinta
Parametro: StaCUPCIG
Se contiene il valore S preimposta a selezionato l'opzione per la stampa dei valori CIG e CUP

Parametro: DtRifPag
Gruppo: PN
Valore default: 0
Programmi: Input prima nota
Se vale 1 il programma mette nella data di registrazione dell'articolo di pagamento per cassa la data del documento e non la data registrazione della fattura di cui si sta registrando l'incasso o il pagamento.

Parametro: Estensione
Gruppo: Riba, RID
Valore default: SEQ
E' l'estensione che verrà assegnata rispettivamente ai file delle Ri.Ba. / RID per la presentazione alla banca

Parametri: FattCorri - NotaCorri - PreFattCorri
Gruppo: Corri
Programmi: Estrazione corrispettivi e Preparazione file per invio telematico dei corrispettivi
Se si utilizzano le suddette funzioni, è obbligatorio creare questi parametri quando si emettono fatture per corrispettivi in quanto dovranno essere sommate nel calcolo degli importi giornalieri.
In FattCorri si deve impostare il codice della causale utilizzata per la registrazione delle fatture/corrispettivi e in NoteCorri quella delle note di credito corrispondenti.
Questo perchè il programma le possa individuare e differenziare dalle fatture/note 'normali'.
In PreFattCorri dovrà essere impostato il prefisso/i utilizzato/i per la registrazione dei suddetti documenti (prefissi che dovranno essere presenti nella tabella dei Prefissi e numeratori , possono essere gli stessi utilizzati per le fatture normali ma dovranno essere diversi per ogni Punto Vendita).

Gruppo: Corrispettivi
Parametro: EleTelemCod
Valore di default: 22,21,10,04,NI,ES,RP
Rappresenta l'elenco delle 'aliquote iva' che il file telematico accetta nel campo 'Aliquota iva'.
Parametro da attivare se si rende necessario aggiungere delle 'aliquote iva' da scaricare oltre a quelle previste attualmente dal modello per l'invio telematico nel campo 'Aliquota iva' (già inserite come valore di default)
(Es. per aggiungere un'eventuale aliquota del 23% occorre valorizzare il parametro con tutte le aliquote di default più il 23 o sostituire una esistente che non verrà più utilizzata: 23,22,21,10,04,NI,ES,RP oppure 22,23,10,04,NI,ES,RP )
Se si attiva questo parametro è obbligatorio attivare anche i due successivi che rappresentano rispettivamente le descrizioni delle aliquote nel programma di gestione dei corrispettivi estratti e nella stampa.
Parametro:EleTelemDesc
Valore di default: 22%,21%,10%,04%,NI-Non Imp.,ES-Esente,RP-Reg.Part.
Rappresenta l'elenco delle 'aliquote iva' che il file telematico accetta nel campo 'Aliquota iva'.
Parametro:EleTelemSta
Valore di default: 22%,21%,10%,4%,Non Imponibile,Esente,Regimi partic.

Parametro: FattDescrAgg
Gruppo: PN
Valore default: bianco
Programmi: Input prima nota
L' introduzione di questo parametro consente di compilare automaticamente la descrizione aggiuntiva. Se il parametro viene impostato a F il programma mette in descrizione aggiuntiva Numero e data documento, a C mette anche codice cliente/fornitore, a D mette la ragione sociale del cliente/fornitore

Parametro: FidoBudGet
Gruppo: Partit
Valore default: bianco
Programmi: Stampa partitari e partite
L' introduzione di questo parametro consente di ottenere in stampa, a piede foglio, il fido (per i clienti e fornitori) il budget per i conti.
Valori ammessi: S stampa Fido se Cli/For e Budget se conto, F stampa solo il Fido, B stampa solo il Budget

Parametro: IncludScad
Gruppo: Partite
Valore default: N
Se impostato a S in Stampa / Visualizzazione partite e Situazione contabile Clienti e Fornitori, verrà impostato a Si il campo a video in cui si chiede se includere nella partita anche le scadenze appartenenti a distinte contabilizzate (su conti di appoggio in modo da non chiudere i clienti/fornitori) e non ancora effettivamente incassate/pagate.
(Utile nel caso di applicazione dell'iva per Cassa). In questo modo la partita risulterà chiusa se tutte le sue scadenze sono in distinte già contabilizzate nel modo suddetto.

Parametro: IndirRiba
 Gruppo: Riba
Programmi: Stampa distinta - Preparazione file delle Ri.Ba.
Valore: XXX dove XXX è il codice indirizzo Ri.Ba. da codificare in Gestione indirizzi per quei clienti per i quali le Ri.Ba vanno spedite ad un indirizzo diverso da quello scritto sull'anagrafica clienti.
Il programma, per ogni cliente da stampare, cerca se esiste per quel cliente, un indirizzo con codice personalizzato (XXX) in indirizzi clienti, se lo trova, stampa quello altrimenti stampa quello dell'anagrafica del cliente.

Parametro: Interessi
Gruppo: EstrattoConto
Programmi: Stampa estratto conto - lettera
Valore: X dove X è un numero es. 3 per 3% che rappresenta gli interessi su base annua

Parametro: Intermediario
Gruppo: PrepF24 e/o PrepIvaAnn e/o PrepBlackList
Programmi: Preparazione file per invio telematico F24 e/o Preparazione file per invio telematico Comunicazione annuale dati iva e/o prep. file Black List
Valore: N
Serve per impostare automaticamente a No il campo "Elaborazione fatta da intermediario" in fase di preparazione del file.
Da utilizzare quando l'invio telematico dell'F24, e/o la Comunicazione annuale Iva, viene fatto dalla ditta stessa e non da un intermediario.

Parametro: Intest
Gruppo: Giornale
Programmi: Stampa giornale bollato
Valore: eventuale testo da stampare come intestazione in alternativa a quella standard.

Parametro: IvaBeniStrum
Gruppo: IvaAnn
Programmi: Calcolo importi Cessioni e Acquisti Beni strumentali in Comunicazione Iva Annuale
Se valorizzato a C, gli importi suddetti verranno calcolati sommando i saldi (dare-avere se acquisto, AvereDare se vendita) dei conti con flag di Acquisto/Cessione beni strumentali.
Se il parametro non è valorizzato, oppure è posto a I, il programma di calcolo sommerà gli imponibili dei codici iva con flag di Acquisto/Cessione beni strumentali.

Parametro: MantieniNumero
Gruppo: Coge
Programmi: Caricamento movimenti da file esterno, in contabilità (mov.di prima nota o di fatture)
Se impostato a S il programma carica i movimenti con il loro numero di registrazione originale invece di predisporsi ad accodarli agli esistenti. Se il numero che si trova ad inserire è però già presente, viene assegnato un numero nuovo, progressivo all'ultimo memorizzato in archivio. E' cura dell'utente fare attenzione alla sequenza!

Parametro: MostraDettTmp
Gruppo: Pn
Da utilizzare per velocizzare la visualizzazione della prima maschera delle registrazioni in Prima Nota in presenza di molte registrazioni.
Se vale S, il programma userà una tabella d'appoggio per mostrare i dettagli di prima nota nella maschera della testata.
Si può mettere anche una sezione sull'aziwin.ini:
[PN]
MostraDettTmp=S (o N)
Verrà considerato come prioritario quello messo come parametro di personalizzazione. Si può ad esempio, mettere a S sull'aziwin.ini di un terminale e a N, su un'azienda 'piccola', come parametro di personalizzazione.

Parametro: MostraDocColl
Gruppo: PartVis
Programmi: Visualizzazione partitario
Se vale N non mostra pulsante per aprire documenti eventualmente collegati alla riga su cui si è posizionati.

Parametro: NcAcqSepar
 Gruppo: PN
Programmi: Prima Nota
Se è stata scelta la numerazione separata per le Note di Credito ma la si desidera SOLO per le note di credito clienti e NON per quelle fornitori, basta inserire nei parametri di personalizzazione questo flag impostato = N

Parametro: NoAccorri
Gruppo: PN
Programmi: Input prima nota
Se impostato ad S, in corrispondenza di registrazioni di corrispettivi con conti diversi di ricavo ma con la stessa aliquota, verranno generati movimenti iva diversi. Se la ditta è in semplificata, il programma si comporta come se il flag fosse sempre ad S cioè non accorpa mai movimenti con la stessa aliquota.

Parametro: NoInsAutom
Gruppo: PN
Valore default: N
Programmi: Gestione Prima Nota
Se vale S dopo un inserimento non propone un altro inserimento.

Parametro: NoRiporti
Gruppo: Giornale
Valore default: N
Programmi: Giornale Bollato
Se S non stampa i riporti sul giornale di contabilità

Parametro: NoUsaPreDoc
Gruppo: VPartite
Programmi: Gestione Prima Nota - Sistemazione partite - Stampa Partite - Visualizzazione Partite
Se S non verrà utilizzato il prefisso documento per individuare i dati di una stessa partita (oltre al numero e data)

Parametro: NoStampa
Gruppo: StaEtiCF
Valore: Elenco tabelle (es. Agenti,Agen2)
Programmi: Stampa etichette clienti e fornitori. In alcune situazioni il programma si è rivelato estremamente lento per il numero di tabelle da leggere. Si può impostare l'elenco delle tabelle che non servono all'utente particolare es. gli agenti per chi non li utilizza, in questo modo si velocizza l'elaborazione.

Parametro: NotaCredInvSegno
Gruppo: Scadenze
Valore di default N ; con valore S le scadenze delle note di credito Clienti verranno create in Entrata con importo negativo (quelle fornitori in Uscita negativa). Se si assegna al parametro il valore T , oltre a creare le scadenze come appena detto, si metterà su tutte le scadenze create il campo Raggruppa Scadenze a S (Il raggruppo scadenze è la condizione necessaria perchè in distinta le due scadenze si compensino)

Parametro: NotaVarDataObblig
Gruppo: Pn
Programma: Input prima nota (inserimento fatture)
Valore di default S. Ogni altro valore fa si che in corrispondenza alla registrazione di Note di Variazione il programma NON controlli che siano stati inseriti Pref/Numero e data della 'fattura di riferimento'. Se si imposta a N questo parametro è indispensabile impostare anche il successivo (NotaVarVerEsiste) altrimenti i campi interessati non dovranno mai essere lasciati vuoti.

Parametro: NotaVarVerEsiste
Gruppo: Pn
Programma: Input prima nota (inserimento fatture)
Valore di default S. Per altro valore il programma di inserimento Prima Nota, in corrispondenza ad una Nota di variazione, NON controlla l’esistenza di un altro documento dello stesso cliente/fornitore con prefisso, numero e data documento uguali a Pref/Numero e data della 'fattura di riferimento' inseriti sulla Nota.

Parametro: NumPagChiuIvaPref
Gruppo: Fiscali
Valore default: bianco
Programmi: Stampa registri e chiusura iva
Nel caso si voglia far stampare il numero di pagina contestualmente alla stampa della Chiusura iva, indicare il prefisso del registro Vendite (o corrispettivi) che contiene il numero pagina per la stampa della chiusura Iva - se vuoto usa il pref. di default dalla tabella dei dati generali.

Parametro: NumPagDaRegV , NumPagDaRegA, NumPagDaRegC
Gruppo: Fiscali
Valore default: bianco
Programmi: Stampa registri e chiusura iva
Nel caso si voglia far stampare il numero di pagina contestualmente alla stampa dei Registri iva e, pur avendo più registri, si vuole che il numero di pagina non sia progressivo per registro ma unico, si può impostare qui il prefisso da cui prendere il numeratore (Es. il prefisso . 'punto').
Ci sono 3 parametri, uno per ogni registro: Vendite, Acquisti, Corrispettivi.

Parametro: NumRegImm
Gruppo: Pn
Valore default: bianco
Programmi: Input prima nota
Questo flag può essere impostato a S SOLO in una INSTALLAZIONE MONOUTENTE altrimenti se si registra contemporaneamente da più terminali si crea confusione nei numeri di registrazione

Se si setta il flag, in inserimento di nuove registrazioni, verrà assegnato il numero di registrazione subito e non solo quando si entra nel dettaglio come avviene in generale.

Parametro: NumReg
Gruppo: PartVis
Valore default: bianco
Programmi: Visualizzazione partitari
Questo flag può essere impostato a S per ottenere l'ordinamento per:
data registrazione (o protocollo) + numero registrazione + data documento (o protocollo)
piuttosto che per data registrazione (o protocollo) + data docum. (protocollo) + numero registrazione

Parametro: PlafPeriodoDa
Gruppo: PN
Programmi: Gestione Prima Nota
Data da usare per calcolare il periodo per il plafond: se vale D è la data documento altrimenti la data registrazione.

Parametro: PnDesagg
Gruppo: Scadenze
Programmi: Stampa scadenze
Valore default: N
Se viene impostato a S il programma di stampa scadenze, dopo ogni scadenza stampa una riga con l'elenco delle descrizioni aggiuntive dell'articolo che ha generato la scadenza. Serve per avere ad esempio, sullo scadenzario, la descrizione del tipo di costo o ricavo che ha generato una scadenza. Ovviamente queste descrizioni vanno inserite, in prima nota, su ogni dettaglio della fattura.

Parametro: ProtUltRiga
Gruppo: Tutti
Valore default: 0
Programmi: Stampe fiscali coge, ordini, ddt, fatture se è abilitata la protezione sulla licenza e non sull'hard disk e si stampa con stampante ad aghi
È un numero <=10 che indica a quante righe dalla fine stampare la scritta: licenza concessa a
Se vale 0 lo stampa sulla riga 66

Parametro: QualeEmail
Gruppo: StScaduto
Valore: da 0 a 4 - Default 2 (indirizzo email amministrativo)
Indica quale indirizzo email stampare nella stampa scaduto se eseguita ordinata per codice o per ragione sociale cliente/fornitore. Per non stampare nessun indirizzo impostare a 0 il valore del parametro

Parametro: RaggFtNc
Gruppo: Distinta
Valore default: bianco
Programmi: Creazione distinta
Se impostato a S , nel caso di coincidenza della scadenza di una fattura e di una nota credito nella stessa data, è possibile compensare in distinta i due importi e addebitare la differenza. Affinchè il programma 'sommi' le scadenze sudbdette è inoltre indispensabile impostare a Si il campo 'Raggruppa Ric.Ban. in distinta' sulle scadenze interessate. Vedi anche NotaCredInvSegno

Parametro: RitAccFornAutom
Gruppo: Pn
Valore default: 0
Programmi: Input prima nota, registrazione di una fattura d'acquisto/vendita con Ritenuta d'acconto

  • Se manca il parametro, o vale 0, non viene creata la registrazione.
  • Impostando questo parametro a 1 si ottiene la registrazione automatica di una riga, per l'importo della ritenuta d'acconto, nella stessa fattura d'acquisto.
  • Impostando questo parametro a 2 si ottiene la generazione automatica di una seconda registrazione con la Ritenuta d'Acconto.

Vedere, sul paragrafo Ritenuta d'acconto, i campi da impostare per ottenere gli automatismi e il parametro DetSoggRitAcc

Parametro: RottDopo10
Gruppo: Riba
Programmi: Stampa distinta - Preparazione file delle Ri.Ba.
Valore: Se vale S, quando si raggruppano le scadenze, non si esegue rottura dopo aver raggruppato 10 fatture. Nel campo di 80 caratteri, dove vanno scritti i numeri delle fatture, ne vengono messi fino ad occuparlo per intero (potrebbe succedere che non vengono scritti i numeri delle ultime fatture).

Parametro: SaldPortaf
Gruppo: Distinta
Valore default: N
Programmi: Gestione Distinta - Contabilizzazione Distinta
Se S gli effetti vengono chiusi col saldaconto poi la distinta deve prendere SOLO quelli già chiusi (ma non ancora in distinta). E' usato inoltre in contabilizzazione distinta (non deve mettere la data e num.pagam.sulla scadenza)

Parametro: SegnAnnoPrec
Gruppo: Pn
Programmi: Prima Nota
Se posto uguale a S, nel momento in cui si salva la testata di una registrazione in inserimento, viene chiesta conferma se l'anno della data di registrazione è maggiore dell'anno contabile.

Parametro: SeparaAP
Gruppo: BilCee
Valore default: N o bianco
Programmi: Calcolo importi per stampa bilancio Cee
Il parametro riguarda i saldi della colonna: Anno Precedente. Essi vengono stampati, di default, con segno, sulla riga dove si stampa il saldo corrispondente per l'anno corrente.

Se si imposta questo parametro a S, verranno stampati su una riga quando sono di segno opposto al saldo dell'anno corrente. In questo caso ci saranno perciò due righe per lo stesso conto, in due sezioni diverse del bilancio, una con il saldo dell'anno in corso e una con quello dell'anno precedente.

Per ottenere ciò occorre anche creare due testate diverse nella tabella principale Cee che prevedano una, la stampa dei conti se saldo >0 e l' altra, la stampa degli stessi conti con saldo <0
(Es. per le banche che possono avere saldo >0 o <0)

Parametro: StaAliquota
Gruppo: Fiscali
Valore default: N
Programmi: Stampa Registri Iva
Se impostato a S verrà stampata, in corrispondenza ad ogni riga delle registrazioni, l'aliquota Iva nella colonna 'Note'

Parametro: StaAncheMov
Gruppo: Cdc
Valore default: N
Programmi: Stampa movimenti per Centro di Costo
Se impostato a S, viene spuntato in automatico, nella maschera delle scelte di stampa, l'opzione per includere nella stampa anche i movimenti extracontabili dei Centri di Costo, inseriti con l'apposita gestione.

Parametro: StaAnnoDoc
Gruppo: Fiscali
Programmi: Giornale bollato, Registro Iva vendite
Valore: /yyyy o /yy ad indicare il formato dell'anno del documento così come lo si vuole stampare dopo il numero documento sul registro vendite e sul giornale.
Questo per consentire di stampare /2012 o /12 o quant'altro a seguito dell' indicazione del dicembre 2012 di attribuire alle fatture una numerazione 'univoca'.
Se la stampa fattura è stata modificata in modo da forzare, dopo il numero, la stampa fissa dell'anno, occorre attivare questo flag per riportare lo stesso numero sui bollati.

Parametro: Arrot
Gruppo: Spesometro (Comunic. dati dal 2012)
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA (Spesometro)
Sul file e in stampa gli importi vengono troncati
Valore default: T - Troncamento
Consente, se impostato a A di arrotondare i valori calcolati piuttosto che troncare

Parametro: StaConto
Gruppo: Spesometro (Comunic. dati dal 2012)
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA (Spesometro)
Valore default: S
Per non avere la stampa del codice del cliente/fornitore oltre alla Descrizione, in corrispondenza a partita iva o codice fiscale, basta impostarlo a N

Parametro: FornCodFisc
Gruppo: Spesometro (Comunic. dati dal 2012)
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA (Spesometro)
Se vale S (default N) mostra il pulsante che permette di scaricare in aggregato fatture di fornitori che hanno solo codice fiscale

Vedi anche parametri: OrdStampa Arrot e ScartaZero

Parametro: OrdStampa
Gruppo: Spesometro (Comunic. dati dal 2012)
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA (Spesometro)
Si può impostare a C per ordinare la stampa per codice cliente/fornitore, F ordinato come il file
Valore di default D - per Descrizione
Vedi anche StaConto

Parametro: FattDettSempre
Gruppo: Spesometro (Comunic. dati dal 2012)
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA (Spesometro)
Le fatture dettaglianti vengono inviate Sempre indipendentemente dall'importo. Per inviare Solo quelle maggiori di 3600€, impostare questo parametro a N

Gruppo: Scadenze
Parametro: StaAgente

Parametro: ScartaZero
Gruppo: Spesometro (Comunic. dati dal 2012)
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA (Spesometro)
Se impostato a S e si sceglie di preparare il file dello Spesometro in modalità: Analitica, il programma scarterà i documenti nei quali gli importi di imponibile e imposta, una volta arrotondati, sono a 0.
Se si sceglie la preparazione in forma Aggregata, eventuali righe a 0, verranno segnalate a video. Per escluderle occorrerà andare a mettere sulle singole registrazioni di prima nota il campo 'Op.Ril. iva' a 'Da ignorare'

Parametro: UsaPNFittizia
Da impostare a S se si rende necessario , per casi estremi, includere, nella comunicazione dello Spesometro, operazioni che non sono state registrate nell’anno. In questo modo si possono fare le registrazioni utilizzando il programma di inserimento Prima Nota extracontabile mettendo il flag di 'Op.Ril.ai fini iva' a Forzato sulla registrazione stessa o sulle causali utilizzate e l'estrazione terrà conto anche di queste.

Parametro: StaAgente
Gruppo: Scadenze
Programmi: Stampa Scadenze
Valore: Se impostato a S preimposta ad Agente l'opzione se stampare CIG e Cup oppure Agente

Parametro: StaAgente
Gruppo: StScaduto
Programmi: Stampa Scaduto
Valore: Se impostato a S preimposta ad Agente l'opzione se stampare CIG e Cup oppure Agente

Parametro: StaIndir
Gruppo: Giornale
Programmi: Stampa giornale bollato
Valore: Se impostato a S verrà stampato anche l'indirizzo per ogni cliente/ fornitore stampato. (Per simulare il registro professionisti)

Parametro: StaPagFisc
Gruppo: Fiscali
Valore default: S
Programmi: Giornale bollato, Registri e chiusura iva
Nelle stampe fiscali di giornale bollato, registri iva e chiusura iva viene stampato SEMPRE il numero di pagina. Se non lo si vuole stampare occorre impostare a N questo parametro

Gruppo: StScaduto
Parametro: StaAgente
Serve per scegliere se stampare CIG e CUP oppure Agente, se vale S preimposta opzione stampa Agente

Parametro: StSaldoDist
Gruppo: StaScadenze
Valore default: bianco
Programmi: Stampa confronto scadenze
Se viene impostato il parametro con un qualsiasi valore (es. S) nel programma in oggetto verrà preimpostata la scelta del tipo di stampa a: 'Saldo Contabile e S.do Scad.in distinte contabilizzate ma non incassate'

Parametro: TotReg
Gruppo: PartVis (per Visualizzazione partitari )
Gruppo: StPart (per Stampa Partitari)
Valore default: bianco
Se impostato a S consente di impostare automaticamente a SI, a video, la richiesta 'Tot.Reg. cli/for' rispettivamente in visualizzazione e stampa partitari. L'opzione consente di visualizzare/stampare nei partitari clienti/fornitori, in corrispondenza a una registrazione dove il cliente compaia in più righe, una riga con l'importo totale (es. un cliente che paga contemporaneamente più fatture, per esigenza di chiusura partite verranno fatte più righe per il cliente, ciascuna con i riferimenti alla fattura che paga e non è visibile l'importo totale versato dal cliente. Attivando questo parametro si ottiene una riga con tale totale)

Parametro: UsaMonetaInPartite
Gruppo: Coge
Valore default: N
Programmi: Prima Nota in Lista partite
Se vale S viene utilizzata anche la moneta della registrazione per l'estrazione delle partite. E' utile SOLO se si memorizzano fatture e incassi/pagamenti in divisa

Parametri per la Comunic. operaz. rilevanti ai fini Iva PRECEDENTI dei dati del 2012
Gruppo: Spesometro
Parametro: EsclIvaNoEsp
Valore default: N - se c'è fattura la considera obbligatoria
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA
Se impostato a S le registrazioni con iva non esposta in fattura (es. art74) vengono scartate fino al 30 giugno 2011
Parametro: NoIvaNoFat
Programmi: Preparazione file per invio telematico Operazioni Ril. ai fini IVA
Valore default: N
Nell' esaminare l'importo della registrazione per valutare se va trasmessa o meno verrà utilizzato il valore di riferimento di 3000€ se si tratta di fattura (obbligo di fattura) o 3600€ se si tratta di corrispettivo o fattura dettaglianti. Il valore di confronto sarà l'imponibile se 'obbligo di fattura' o il totale fattura se 'non obbligo di fattura'.
Impostando a S questo parametro verranno utilizzati i valori di riferimento:
3000€ se si tratta di fattura e di anagrafica con partita iva (obbligo di fattura)
3600€ se si tratta di corrispettivo o fattura dettaglianti ma anche di fattura di cli/for SENZA partita iva o con cod. fiscale che inizia per 8 e per 9
Se impostato a V
confronta con 3000€, l'imponibile delle fatture di cli/for con codici fiscali che iniziano per 8 e 9
mentre confronta con 3600€ (considera senza obbligo di fattura) le fatture di cli/for SENZA partita iva (oltre a corrispettivi e fatture dettaglianti)Parametro: RiempiZeri
Valore default: N
Generazione file per invio telematico delle Operazioni Rilevanti ai fini Iva
Se impostato a S, gli importi presenti nel file generato verranno allineati con zeri a sinistra (es. 003245) piuttosto che con spazi (es. 1245) per esigenza di alcuni programmi di controllo.


Pers. parametri cespiti

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Parametro: ChiaveBaseLun
 Gruppo: Cespiti
 Programmi: gestione cespiti
Indica la lunghezza (il numero di cifre) del codice cespite 'numerico' e progressivo da generare in automatico dopo che l'utente avrà premuto il pulsante 'Crea codice automatico'.

Es. se il parametro vale 4, la generazione automatica dei codici produrrà 0001, 0002, 0003 etc.
Se questo parametro viene impostato a -1, a video viene tolto il pulsante che consente questo automatismo.

Parametro: ChiaveBase
 Gruppo: Cespiti
 Programmi: gestione cespiti
Si possono impostare alcuni caratteri di 'Prefisso' da usare come base per la creazione automatica del codice cespite.

Es. se si vogliono numerare progressivamente i cespiti: macchinari, automezzi, mobili, si potrebbe mettere in questo parametro la sigla dei cespiti del gruppo più numeroso es. MACC per macchinari

Quando si andrà a creare i cespiti, se si preme subito il pulsante di generazione automatica del codice, il programma assegnerà un codice MACC0001, poi MACC002 etc. se invece l'operatore scriverà alcuni caratteri poi premerà il pulsante (es. AUTO), il codice generato sarà AUTO0001, AUTO0002 etc.

Parametro: DescrAgg
Gruppo: Cespiti
 Programmi: contabilizzazione cespiti
Questo parametro è valido SOLO se si sceglie di generare in contabilità una registrazione diversa per ogni cespite.
Normalmente il programma compila la descrizione aggiuntiva dei movimenti con la descrizione aggiuntiva compilata a video (se valorizzata) più la descrizione del cespite.
A seconda del valore assegnato a questo parametro (A, C, E), la descrizione aggiuntiva dei movimenti potrà contenere:

  • A
    Solo descrizione aggiuntiva compilata a video
  • C
    Il codice cespite (preceduto dalla descrizione aggiuntiva a video, se compilata)
  • E
    Codice e descrizione cespite (preceduto dalla descrizione aggiuntiva a video, se compilata)

Parametro: LanCespiti
 Gruppo: Pn
 Valore default: N
 Programmi: input prima nota
Se impostato a S, al termine di una registrazione di prima nota nella cui causale è stata impostata la causale collegata ai cespiti, viene lanciata la gestione cespiti in automatico.

Parametro: RaggrDef
Gruppo: Cespiti
 Programmi: contabilizzazione cespiti
Si può valorizzare questo parametro con i valori R o C, per variare il valore iniziale della modalità di creazione dei movimenti (di ammortamento, cessione etc.) in contabilità che viene presentato al caricamento del programma.
Il default è: una registrazione per causale.
In alternativa il programma può creare registrazioni diverse:

  • R
    a parità di causale e codice raccordo
  • C
    movimenti distinti per ogni cespite

Tale modalità potrà poi essere variata sulla maschera iniziale del programma di contabilizzazione.


Pers. parametri magazzino

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Programma: Gestione Articoli
I parametri: ArtAggStringa(0-3) e ArtAggNum(0-3) servono per abilitare nuovi campi gestibili in Gestione Articoli. La loro gestione viene fatta nella maschera (3) Attr/Pers
Gruppo: Articoli

Parametro: ArtAggStringaX (con X da 0 a 3)
Valore: titolo del nuovo campo STRINGA che si vuole aggiungere alla Gestione Articoli

Parametro: ArtAggNumX (con X da 0 a 3)
 Valore default: titolo del nuovo campo NUMERICO che si vuole aggiungere alla Gestione Articoli

Parametro: ArtAggNumLungX (con X da 0 a 3)
Gruppo: Articoli
Valore default: -14.3
Serve a definire il numero di cifre e di decimali che si potranno inserire nel campo.
Può contenere xx,yy , dove xx definisce la dimensione del campo e yy il numero di decimali
Se xx e’ negativo, verranno accettati anche numeri negativi

Parametro: ArtAggNumFormX (con X da 0 a 3)
Valore default: #,###.^^^
Formato da dare al campo numerico

Parametro: AutomLiraEuro
 Gruppo: Listini
Valore default: S
 Programmi: Gestione Listini - Gest. Articoli (quadro listini) - Gestione LIFO
Al variare del Prezzo o PrezzoLire (se listino in Lire o in Euro) ricalcola sempre l'altro. Con N ricalcola solo se l'altro è bianco.

Parametro: CalcValIniDaCosti
 Gruppo: Articoli
 Programmi: Ricalcolo costo ultimo da listino
Se vale S il programma aggiorna il valore iniziale dell'anno ricalcolandolo come segue:
G.Iniziale * listino di riferimento, indicato a video, eventualmente scontato

Parametro: CarMovFiles
Gruppo: Magazzino
Programmi: Caricamento movimenti di magazzino da file Esterno.
Se valorizzato consente di preimpostare il nome del file da caricare.

Parametro: CarNoObblParam
 Gruppo: Magazzino
Valore default: N
 Programmi: Caricamento movimenti di magazzino da file Esterno.
Impostato ad S fa si che i parametri chiesti nella maschera di caricamento NON siano obbligatori. Questo significa che devono però essere presenti sul file dei movimenti da caricare.

Parametro: CausVerif
 Gruppo: Magazzino
Valore default: Bianco
 Programmi: Caricamento movimenti di magazzino
Si può mettere l'elenco delle causali di magazzino, separate da ; per le quali gestire il flag Verificato. Flag che viene visualizzato in gestione movimenti e assume valore Si / No

Parametro: CercaListBase
 Gruppo: Tutti
Valore default: N
 Programmi: Caric. Movimenti (Ordini, ddt, fatture,scontrini)
Se viene impostato a S, i programmi se non trovano il prezzo di un articolo sul listino del documento, lo cercano sul listino base (quello indicato sulla tabella di Magazzino)

Parametro: ChiaveBase
 Gruppo: Articoli
 Programmi: gestione Articoli
Si possono impostare alcuni caratteri di 'Prefisso' da usare come base per la creazione automatica del codice articolo.

Es. Se si impostano qui i caratteri: ART e in fase di creazione di un nuovo articolo, si preme il pulsante di generazione automatica del codice, il programma assegnerà un codice ART0001, poi ART002 etc. se invece l'operatore scriverà alcuni caratteri (es. XXX) poi premerà il pulsante, il codice generato sarà XXX0001, XXX0002 etc.

Parametro: ChiaveBaseLun
 Gruppo: Articoli
 Programmi: gestione Articoli
Indica la lunghezza (il numero di cifre) del codice articolo 'numerico' e progressivo da generare in automatico dopo che l'utente avrà premuto il pulsante 'Crea codice automatico'.
Es. se il parametro vale 4, la generazione automatica dei codici produrrà 0001, 0002, 0003 etc.
Se questo parametro viene impostato a -1, a video verrà tolto il pulsante che consente questo automatismo.

Parametro: CodBarSalva
Gruppo: CodBar (Magazzino, Ordini, Ddt, Fatture,Preventivi,Scontrini,Acquisti)
Valore default: N
 Programmi: Ddt, fatture, ordini, preventivi (scontrini,caricamento movimenti di magazzino, ordini di acquisto) in inserimento righe di dettaglio con ricerca per codice a barre.
Se vale S, una volta digitato o letto da penna il barcode dell'articolo, il programma passa alla richiesta di un nuovo articolo , dopo aver salvato la riga precedente.
Si può abilitare o disabilitare questa modalità solo su ddt o fatture o ordini creando lo stesso parametro di personalizzazione con valore S o N e gruppo il nome della gestione interessata.
Con i tasti: Ctrl Alt S, premuti sulla richiesta del codice a barre, si attiva o disattiva la suddetta modalità.
La scritta 'Articolo' verrà visualizzata in rosso ad indicare che è attiva la modalità di salvataggio automatico.

Parametro: CodIniAut (CodIniAutXXX)
Dove XXX dovrà essere posto uguale a 13 se si vuole applicare il parametro ai codici EAN13, a E8 se EAN8)
 Gruppo: BarCode
 Programmi: Gestione articoli - Variazione automatica articoli
Valore: Impostare la stringa iniziale per codici a barre calcolati automaticamente (no articoli con taglia/colore)
(Es. se si vogliono generare in automatico dei codice a barre interni che iniziano per 020, si imposterà il parametro a 020).
In tabella di magazzino devono essere impostati a SI i flags: 'Generazione automatica del codice a barre' e 'Genero bit di controllo'.

Parametro: CodIniLiv (CodIniLiv13 - per EAN 13, CodIniLivE8 - per EAN 8)
Gruppo: BarCode
Parte iniziale del BarCode di tipo EAN 13 o EAN 8 da utilizzare per la ricerca di articoli con livelli
Necessario solo se, per gli articoli con livelli, si vogliono fare dei codici a barre che iniziano in modo particolare
In ricerca prende i primi X caratteri FISSI scritti in questo parametro, aggiunge i primi X caratteri del codice a barre dell’articolo (il numero X è scritto nel parametro di personalizzazione CodBarLunArt) in questo modo identifica l'articolo poi vengono aggiunti i codici a barre di ciascun livello. La parte fissa + la parte 'livelli' deve essere lunga 12 se Ean 13 o 7 se Ean 8 (Vedi codice a barre )

Parametro: CodIvaDef
Gruppo: Articoli (Acquisti, Ordini, Preventivi, Ddt, Fatture)
Valore default: bianco
Programmi: Articoli , Acquisti, Ordini, Preventivi, Ddt, Fatture
Permette di inserire un codice iva di default che verrà poi proposto in testata documento e in gestione articoli (Tale codice deve esistere nella tabella dei codici iva)

Parametro: CodUmDef
Gruppo: Articoli
Valore default: bianco
Permette di inserire una unità di misura di default che verrà poi proposta nella creazione di un nuovo articolo. (Tale codice deve esistere nella tabella delle unità di misura)

Parametro: CodRepDef
Gruppo: Articoli
Valore default: bianco
Programmi: Gestione articoli
Permette di inserire un codice reparto di default che verrà poi proposto in creazione di nuovi articoli. (Tale codice deve esistere nella tabella reparti)

Parametro: DesArt
Gruppo: MagPart
Valore default: Bianco
Programmi: Stampa partitario di magazzino (sintetica)
Se questo parametro viene impostato a S nella stampa sintetica verrà stampata la descrizione articolo invece del codice.

Parametro: DescPersDet1, DescPersDet2, DescPersDet3, DescPersDet4
Gruppo: Magazzino
Programmi: Caricamento movimenti
Sono campi a descrizione libera, disponibili per ogni riga articolo inserita in un movimento.
Per attivarli occorre scrivere, nella riga del parametro, in valore, la descrizione con la quale il campo verrà visualizzato in gestione movimenti (es. MATRICOLA). Poiché gli stessi campi possono essere attivati anche sui documenti, ordini, ddt e fatture, nei movimenti generati da tali documenti, il programma salverà automaticamente tali campi.

Parametro: DescPersTest1, DescPersTest2, DescPersTest3
Gruppo: Magazzino
Programmi: Caricamento movimenti
Sono campi a descrizione libera che possono essere inseriti nella testata di ogni movimento.
Nella riga del parametro, in valore, ci va la descrizione con la quale il campo verrà visualizzato in gestione movimenti (es. ZONA). Poiché gli stessi campi possono essere attivati anche sui documenti, ordini, ddt e fatture, nei movimenti generati da tali documenti, il programma salverà automaticamente tali campi.

Parametro: DettDibaAutom
Gruppo: MagaMovProd
Programma: Caricamento movimenti di produzione
Valore di default : N
Se impostato ad S, una volta confermata la maschera di testata con il codice articolo da produrre, verranno presentate le righe di dettaglio con l'elenco dei componenti (materiali di base). Nelle righe verrà preimpostata la quantità, in base alla quantità dell'articolo da produrre, e il valore.
Inoltre se esiste, per il componente, un unico lotto aperto, esso verrà inserito sulla riga.
Se attivo anche il parametro VerDispQtaProd il programma metterà il lotto SOLO SE, su quel lotto, c'è quantità disponibile.

Gruppo: Magazzino
Programmi: Gestione movimenti di magazzino
Parametri per fissare una sequenza particolare di campi nella maschera dei dettagli e nella visualizzazione dell'elenco dei dettagli.
Parametro: DettOrdIns
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di inserimento dei campi nella maschera di dettaglio delle registrazioni (valori dell'indice del controllo).
Valido SOLO in inserimento.
Ordinamento dei campi: se c’è un solo numero serve per dire che quello è il primo campo. Seguono gli altri in modo standard. Se si vuole un campo particolare per primo, poi il primo campo, si mette il particolare, poi il primo.
 Parametro: DettOrdInsTab
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di visualizzazione campi del dettaglio movimenti (valori del tabindex corrente).
Parametro: DettOrdCol
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in gestione dettagli dei movimenti.
Può contenere nomi di campi o anche espressioni
I nomi, separati da 'virgola' sono quelli delle variabili del database nelle tabelle MovMagDett oppure in Articoli (es. per mettere in testa la descrizione articolo invece del codice, si può scrivere nel parametro: articoli.descrizione)
Dopo il campo si può mettere:
§ seguito da un numero per indicare le larghezza della colonna,
^ seguito da un nome che sarà l’etichetta da dare alla colonna (solo per i campi aggiuntivi , NON per campi usati dal programma)
 (es. Qta§900,Descrizione,Articolo,ValUnitario+valtotale as sommaImp §1000)
Parametro: DettOrdColTest
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in testata.
Stessa sintassi del parametro precedente.
Se il parametro non c’è o è vuoto viene assunto = al precedente.
Se si vuole che venga lasciato l’ordinamento previsto dal programma, pur avendo usato il parametro precedente, si valorizzi uguale a “-“ (meno)
Nomi di campi particolari:
grid testata: Val_Mon_Corr
grid dettaglio: Val_Mon_Corr

Parametro: FineAnnoFaTrans
Gruppo: Magazzino
Programmi: Cambio anno magazzino
Default: S. Se è impostato ad N esegue il Cambio anno di magazzino senza fare transazioni. Si rende necessario quando il numero di articoli è molto alto e, ad esempio la copia dei Costi, va in errore per scoppio della transazione.

Gruppo: Livelli
Parametro: GestTab
Consente di attivare/disattivare la nuova maschera 'a tabella', quando si preme la Freccia Rossa dal dettaglio articolo, per l' inserimento Livelli (Taglia/Colore) in Movimenti di Magazzino , Ordini, Ddt, Fatture
Il valore di default del parametro è S (Si)
Parametro: NuovoGest
S default - In inserimento con livelli (con i tasti F10 o Salva) va direttamente nel nuovo sistema tabellare
Vedi anche parametro: Liv1VertOriz

Gruppo: Livelli
Parametro: PosPicLiv_X
Valore: Posizione nella quale visualizzare la maschera con richiesta livelli nel dettaglio:
X=1 alto sinistra, X=2 alto destra, X=3 basso sinistra, X=4 basso destra

Gruppo: Livelli
Parametro: CodBarLunArt
Valore: Lunghezza del codice a barre degli articoli con livelli (default=7)

Gruppo: Magazzino
Parametro: Gestab
Può assumere valore S (si) o N (no). Il valore di default è quello del parametro Gestab, descritto sopra, con gruppo: Livelli
Tale valore può essere variato, con questo parametro, per la sola funzione di Caricamento movimenti di magazzino.

Per gestione immagini degli articoli:
Gruppo: Articoli
Programmi: Gestione articoli, tutti gli help dell'articolo
Parametro: Immagini
Se impostato a S il programma si predispone per gestire, per ogni articolo (prodotto) di magazzino, una immagine collegata.
Le immagini dovranno essere memorizzate nella directory indicata nel parametro DirImgArt dell'aziwin.ini oppure, se questo manca, in quella indicata nel parametro: DirImmagini
Tali immagini potranno essere anche stampate sui moduli Ordini, ddt e fatture modificando opportunamente i filtri di stampa.
Parametro: ImgDove
Indica dove visualizzare, nell'help dell'articolo, l'immagine memorizzata. Può valere A,B,S,D (Alto, Basso, Sinistra, Destra).
Parametro: ImgDimReali
Se vale N le immagini vengono ridimensionate in modo da riempire lo spazio disponibile, viceversa vengono mostrate così come sono.
Parametro: ImgRapVertOriz
Indica il rapporto Verticale/Orizzontale da rispettare nel display dell'immagine dell'articolo. Se impostato a 0 l'immagine viene mostrata utilizzando tutto lo spazio disponibile. Es. se si imposta il parametro = a 0,5 significa che la dimensione verticale dell'immagine è metà di quella orizzontale.
Ha senso impostare questo parametro se le immagini memorizzate sono tutte verticali o orizzontali.
Parametro: ImgSpazio
Indica il numero di pixel da utilizzare nell'help dell'articolo per la visualizzazione dell'immagine.

Parametro: LabAlt (e anche LabLarg e LabLung)
Gruppo: Articoli
Valore: contiene la scritta che comparirà come label per il campo Altezza (e anche Larghezza e Lunghezza) in Gestione articoli (Folder Altri dati), dettagli Gestione movimenti di magazzino, Ddt e Fatture
 Questi 3 parametri sono stati inseriti per una personalizzazione che richiede la gestione di 3 campi numerici con 4 decimali sull'articolo. Questi campi vengono poi gestiti e memorizzati sui movimenti di magazzino e se richiesto, attivandoli anche con gruppo 'vendite', anche nei Ddt, nelle Fatture e negli Scontrini.
Questi campi verranno visualizzati nella prima maschera dell'articolo SOLO se è attivo il flag QtaDaDimen

Parametro: LettArtDaFile
Gruppo: carmov (acquisti, preventivi, ddt, ordini, fatture, scontrini)
Programmi: caricamento movimenti di magazzino, ordini di acquisto e vendita, preventivi, ddt e fatture
Se impostato a S verrà presentata, nei dettagli, una icona che consente di caricare da file gli articoli piuttosto che digitarli. (Vedere impostazione parametri in Caricamento dettagli documenti da file)

Parametro: ListAcqDaAgg
Gruppo: Magazzino
Programma: Caricamento movimenti di magazzino
Attivando questo parametro con il codice di un listino di acquisto, si consente di aggiornare tale listino in corrispondenza di ogni riga di movimento di acquisto.
Se abilitato viene visualizzata su ogni riga del movimento di acquisto un campo contenente il codice di listino indicato in questo parametro e al salvataggio del movimento, se tale campo non è stato sbiancato, viene aggiornato il listino con il valore unitario della riga.

Parametro: ListVenDaAgg
Gruppo: Magazzino
Programma: Caricamento movimenti di magazzino
Attivando questo parametro con il codice di un listino di vendita, si consente di aggiornare tale listino in corrispondenza di ogni riga di movimento di acquisto.
Se abilitato viene visualizzata su ogni riga del movimento di acquisto un campo contenente il codice di listino indicato in questo parametro e al salvataggio del movimento, se tale campo non è stato sbiancato, viene aggiornato il listino col valore unitario della riga aumentato di una percentuale di maggiorazione come descritto nel parametro (obbligatorio) ListVenDaAggOrd
Valori possibili per il parametro:

  • F - maggiorazione dall'anagrafica fornitore
  • A - maggiorazione dall' articolo
  • FA - si applica la maggiorazione del fornitore poi quella dell'articolo.
  • AF - si applica la maggiorazione dell'articolo poi quella del fornitore.

Se la percentuale di maggiorazione scritta sull'anagrafica del fornitore è a 0, viene presa quella della tabella di magazzino. Se si vuole non operare la maggiorazione in corrispondenza ad alcuni fornitori, occorre mettere le percentuali su tutti i fornitori, lasciare a 0 quelli desiderati e lasciare vuoto il campo in tabella di magazzino.
Se manca questo parametro, non verrà applicata alcuna maggiorazione.

Parametro: MagCancMov
Gruppo: Magazzino
Programma: cancellazione movimenti di magazzino
Valore di default: bianco. Si può impostare il codice del magazzino del quale si cancellano periodicamente i movimenti.

Parametro: NoDecInattivi
Gruppo: Articoli
Se vale S in ogni punto nel quale si chiede la decodifica del codice articolo ignora articoli inattivi.
In assenza di questo parametro tali articoli non vengono elencati nella lista di aiuto ma se si digita il codice esatto è possibile inserirli nei documenti.

Parametro: NoInsAutom
Gruppo: Magazzino
Valore default: bianco o S
Programmi: Caricamento movimenti di magazzino
Se impostato con un valore diverso da S, consente di rimanere in inserimento mentre si caricano i movimenti di magazzino.

Parametro: NoRaeeAutom
Gruppo: Magazzino
Programmi: Caricamento movimenti di magazzino
Può essere impostato con l'elenco delle causali di magazzino per le quali, anche se si movimenta un articolo che ha un 'articolo raee' collegato, non verrà generata la riga del Raee. Le causali dovranno essere separate da , 'virgola'.

Parametro: PrzIvatiCalcSuIvati
Gruppo: Carmov
 Valore default: bianco o N
Programmi: Caricamento movimenti di magazzino
Se vale S quando il programma calcola il prezzo totale, prima lo calcola ivato e poi scorpora.

Parametro: PulsLordoNetto
Gruppo: Magazzino
Valore default: N
Programmi: Caricamento movimenti di magazzino
Se viene impostato ad S si intende che il prezzo unitario digitato nei movimenti di magazzino è Lordo per cui, quando si esce dal campo, il programma applica lo sconto scritto sul listino del movimento e visualizza il prezzo scontato. Per un corretto funzionamento del parametro occorre che, per il listino del movimento, esista un prezzo inserito per l'articolo richiamato.
Verrà visualizzato un pulsante, vicino al prezzo, che consente di cambiare modalità cioè di digitare un prezzo netto.

Parametro: QtaDef
Gruppo: Ordini - DDT - Fatture - Magazzino - Acquisti - Preventivi (Scontrini)
Valore default: 0
Programmi: Gestione DDT - Gestione Fatture - Gestione movimenti di magazzino -Gestione Ordini di Acquisto e di Vendita - Gestione Preventivi (Scontrini)
Quantità proposta di default in ogni riga di dettaglio.

Parametro: RicArt
Gruppo: VisList
Programmi: Visualizzazione prezzi articoli
Se viene impostato a B, la ricerca dell'articolo verrà fatta di default per codice a barre piuttosto che per codice articolo.

Parametro: RidInv
Gruppo: Magazzino
Valore default: N
Programmi: Inventario LIFO - Inventario di magazzino
Se viene impostato a S, nella maschera di stampa verrà chiesta la % di riduzione. Se viene barrato il flag: applico la % di riduzione e la % inserita è diversa da 0, viene abbattuta la quantità di quella % (per tutti gli articoli) se la quantità <1 si pone quantità=1.
Se non è attivato questo parametro, l'eventuale % di riduzione da applicare viene letta da ogni articolo.

Parametro: RipartSpesePercVal
Gruppo: Magazzino
Valore default: V (Valore)
Programmi: Evasione Ordini di Acquisto - Inserimento movimenti di carico di magazzino
Indica se nel campo spese per il carico merce si metterà un importo (V) o una percentuale (P o altro) (al fine del calcolo Costo Ultimo)

Parametro: ScarMovCau
 Gruppo: Magazzino
Valore: contiene l'elenco dei codici delle causali di magazzino per le quali scaricare i movimenti su file. Ogni causale è separata dalla successiva da una virgola (es.be,bv).
 Programmi: Scaricamento movimenti di magazzino su file. Serve per scaricare movimenti da caricare su un altro database.

Parametro: SegnSottoScorta
Gruppo: MagaVen
Valore default: N
Programmi: caric. movimenti di magazzino, inserimento Ddt e Fatture
Viene data una segnalazione acustica e un messaggio a video se l'articolo richiamato ha giacenza <=0 o è sottoscorta (non abilitato per articoli con livelli). Nel calcolo della giacenza (o sottoscorta) si tiene conto anche della quantità digitata sulla riga)
Per ottenere la segnalazione acustica prodotta dalla scheda audio, si può attivare nell'AziWin.ini della singola stazione di lavoro (o nel principale) il parametro: BeepCome
Tale parametro si attiva inserendo nella sezione [Parametri generali] dell'ini la riga: BeepCome=NN;XX
Dove NN è la frequenza del suono e XX la durata. Occorre fare dei tentativi per valutare i numeri da mettere.
Esempio: BeepCome=2000;20
oppure per ottenere un effetto sonoro diverso (dal win 2000 in avanti) si può mettere un segno meno davanti: BeepCome=-2000;20
Oppure si può scegliere una musica a piacere (cioè un file .wav) dalla directory C:\windows\media\ e scrivere: BeepCome=c:\windows\media\nome.wav;20

Parametro: SfondoRigaGrigio
Gruppo: StaListini
Valore default: N
Programmi: Stampa listini
Se impostato a S, viene impostato a Si sulla stampa listini, l'opzione che consente di stampare alternativamente le righe con sfondo bianco e sfondo grigio.

Parametro: SommaGiacIniz
Gruppo: Magazzino
Valore default: N
Programmi: Caricamento movimenti di magazzino
Se viene impostato a S, nell' inserimento di un movimento di Giacenza iniziale, la giacenza inserita si va a sommare sulla Giacenza Iniziale precedente.

Parametro: StaTotQta
Gruppo: MagPart
Valore default: N
Programmi: Stampa partitario parametrico
Se viene impostato a S, verrà stampato il totale quantità a tutti i livelli piuttosto che solo a livello articolo.


Pers. parametri ordini, ddt, fatture

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Per quanto riguarda i parametri da inserire per la stampa delle matricole in ddt e fatture vedere:
parametri matricole.

Per quanto riguarda i parametri da impostare per fare la stampa fatture su Pdf, vedere :
parametri per stampa su pfd.

Parametro: AggDataInvioEmail
Gruppo: StFatture
Valore default: S
 Programmi: Stampa fattura con invio per email
Indica quando aggiornare il campo 'data invio fattura per email' visualizzato in gestione fatture.
E o blank (default) - aggiorna sempre, T - solo se stampa, N - non aggiorna mai, R - aggiorna se stampa o se data vuota

Parametro: AllegPdf
Gruppo: XML
Valore di default: N
Se si assegna il valore S a questo parametro, il campo 'Allegare pdf nel file XML' presente sulla maschera della preparazione del file XML per la fattura elettronica, verrà spuntato ad indicare che si vuole allegare il pdf . L'utente potrà comunque modificare al momento il valore del campo.

Parametro: BolleAccXml
Gruppo: EvasioneDDT
Valore default: SSN
Programma: Evasione ddt
Valore da assegnare ai campi presenti sulla maschera della riga descrittiva del corpo della fattura riepilogativa che contiene l'elenco dei numeri e date dei ddt riepilogati in fattura (per fatture che riepilogano le bolle per articolo es. forno) ai fini della corretta compilazione del file XML della fattura elettronica .
I rispettivi campi ai quali assegnare un valore S o N sono: 'In xml fatt.elettronica' 'su carta' 'altri dati articolo'

Parametro: CalcolaPeso
 Gruppo: Ddt o Fatture
 Valore default: N
 Programmi: Gestione DDt e Fattura accompagnatoria
Se impostato a S, il programma all'uscita dai dettagli (righe di articoli), calcola il peso totale e compila la casella Peso gestita nei dati di accompagnamento.

Valorizzando il parametro CalcolaPesoUM è possibile elencare le unità di misura che devono avere gli articoli per i quali sommare il peso.

Il peso può poi essere calcolato in due modi diversi a seconda di come è impostato il parametro: CalcolaPesoLordo

  • Se non è impostato CalcolaPesoLordo (o è impostato ad S):
    peso lordo letto sull'anagrafica di ogni articolo * quantità * Fattore di conversione
  • Se CalcolaPesoLordo=N il peso sarà calcolato sommando le quantità degli articoli

Se il parametro CalcolaPeso manca o non è impostato a S, per forzare il calcolo del peso occorrerà premere il pulsante con i puntini a fianco al campo peso nei dati di accompagnamento.
Per ottenere il peso in fattura come somma dei pesi dei ddt occorre attivare il parametro: SommaPesi

Parametro: CalcolaPesoFatt
Gruppo: Fatture
Programmi: Implementazione di CalcolaPeso in Fattura diretta
Valori: N (default) , S , M
Se vale N calcola il peso lordo SOLO se CalcolaPesoLordo=N (per compatibilità con il sistema precedente)
Se vale S lo calcola sempre
Se vale M non lo calcola anche se CalcolaPesoLordo=N

Parametro: CalcolaPesoLordo
(Attivo se CalcolaPeso=S)
Gruppo: Ddt o Fatture
Programmi: Gestione DDt, Fattura accompagnatoria
Valore default: S
Il campo Peso presente nei dati di Accompagnamento verrà compilato automaticamente moltiplicando il Peso lordo inserito sugli articoli per la quantità per il Fattore di conversione. Valorizzando a N questo parametro, tale peso verrà calcolato come somma delle quantità degli articoli per il Fattore di conversione

Parametro: CalcolaPesoUM
(Attivo se CalcolaPeso=S)
Gruppo: Ddt - Fatture
 Programmi: Gestione DDt, Fattura accompagnatoria, Fattura diretta
Contiene l'elenco delle unità di misura degli articoli (separate da ; ) da considerare per calcolare in automatico il Peso. Non verrà sommato il peso degli articoli con unità di misura diverse da quelle in elenco.

Parametro: CampiStAggCor
Gruppo: Preventivi - Ordini - Acquisti - Ddt - Fatture - FattureAcc
Valore default: bianco
Permette di aggiungere campi in decodifica del corpo dei documenti

Parametro: CampiStAggDec
 Gruppo: Preventivi - Ordini - Acquisti - Ddt - Fatture - FattureAcc
Valore default: bianco
Permette di aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa.

I campi possono iniziare con la virgola oppure no e vanno scritti mettendo: nome tabella punto "." nome campo es.: pianoconti.telefono
Se si mettono più campi, vanno separati da virgola.
Se è necessario estrarre un campo "calcolato", si può mettere una query come valore del parametro, purchè non contenga più di 255 caratteri.
Esempi:
- per estrarre il saldo contabile del cliente titolare della fattura si può scrivere la query:
(SELECT p2.SaldoIniziale+p2.ProgrDare-p2.ProgrAvere FROM PdcProg as p2 where PianoConti.Tipo=p2.PartTipo AND PianoConti.Conto=p2.CoPartConto AND PianoConti.Mastro=p2.CoPartMastro AND PianoConti.Gruppo=p2.CoPartGruppo and p2.anno=fattest.anno) as sa1
e utilizzare nel filtro il campo d.sa1

- per estrarre la Descrizione (o RagSoc) del cliente da mettere, ad esempio, nel nome del file pdf della fattura:
,left(PianoConti.Descrizione,10) as IniRagSoc

Se aggiungendo dei campi, il programma di stampa esce per errore di 'Troppi campi' , è possibile impostare il parametro TabNo* per escludere alcune tabelle (oppure può essere utilizzato: CampiStDecDef, come descritto sotto)

Parametro: CampiStDecDef
Gruppo: Fatture - FattureAcc
Valore di default: ,Vettori.*, CauTrasporti.*, AspettoBeni.*, Rese.*, Trasporti.*
Questo parametro dovrà essere creato nel caso che la stampa della fattura o della fattura accompagnatoria vadano in errore per ' troppi campi definiti'. Si dovrà impostare , nel valore, l'elenco di tabelle come nel valore di default però togliendo qualche tabella non utilizzata (es nella fattura diretta NON servono Vettori.* , AspettoBeni.* etc.)

Parametro: CausalePerRicavo
 Gruppo: Fatture
 Valore default: bianco
Programmi: Inserimento fatture
Se si mette nel campo Valore il codice di una causale di contabilità (o più codici separati da virgola es.01,03), il programma controlla se tale codice è uguale a quello inserito nel campo Causale Co.Ge. del tipo documento con il quale viene fatta la fattura. In questo caso il conto di ricavo che verrà messo nei vari dettagli della fattura sarà quello scritto sulla causale di contabilità (invece di quello eventualmente scritto sul cliente o sull'articolo di magazzino).

Parametro: CauzAttNoCalc
 Gruppo: Articoli
 Valore default: Bianco
 Programmi: Inserimento Ddt e Fatture
Se viene impostato a S, i programmi di inserimento ordini, ddt e fatture, mettono a N il flag dello sconto pagamento nelle righe degli articoli che hanno il flag Cauzione a Si.

0Parametro: CauzAttNoSconti
 Gruppo: Articoli
 Valore default: Bianco
 Programmi: Inserimento Preventivi, Ordini, Ddt e Fatture (Scontrini)
Se viene impostato a S, i programmi di cui sopra, azzerano lo sconto totale nelle righe degli articoli che hanno il flag Cauzione a Si.

Parametro: CercaListBase
 Gruppo: Tutti
 Valore default: N
 Programmi: Ordini, ddt, fatture (scontrini,caric. movimenti di magazzino)
Se viene impostato a S, i programmi se non trovano il prezzo di un articolo sul listino del documento, lo cercano sul listino base (quello indicato sulla tabella di Magazzino)

Parametro: CodBarSalva
Gruppo: CodBar (Ordini, Ddt, Fatture,Preventivi,Magazzino,Scontrini,Acquisti)
Valore default: N
 Programmi: Ddt, fatture, ordini, preventivi (scontrini,caricamento movimenti di magazzino, ordini di acquisto) in inserimento righe di dettaglio con ricerca per codice a barre.
Se vale S, una volta digitato o letto da penna il barcode dell'articolo, il programma passa alla richiesta di un nuovo articolo , dopo aver salvato la riga precedente.
Ovviamente per passare alla riga successiva, occorre che tutti i campi della riga siano compilati, in particolare la quantità. Per fare ciò si dovrà impostare il parametro di personalizzazione Qtadef dove si metterà la quantità da presentare sulla riga: es. 1.
Si può abilitare o disabilitare questa modalità solo su ddt o fatture o ordini creando lo stesso parametro di personalizzazione con valore S o N e gruppo il nome della gestione interessata.
Con i tasti: Ctrl Alt S, premuti sulla richiesta del codice a barre, si attiva o disattiva la suddetta modalità.
La scritta 'Articolo' verrà visualizzata in rosso ad indicare che è attiva la modalità di salvataggio automatico.

Parametro: CodiceDestinatario
Gruppo: XML
Programmi: Estrazione fatture formato XML
Deve contenere il codice destinatario della ditta da usare nelle autofatture TD20 per mancata ricezione fattura dal fornitore.

Parametro: CodIvaDef
 Gruppo: Acquisti - Ordini - Preventivi - Ddt - Fatture (Articoli)
 Valore default: bianco
 Programmi: Quelli specificati in Gruppo.
Permette di inserire un codice iva di default che verrà poi proposto in testata documento e in gestione articoli (Tale codice deve esistere nella tabella dei codici iva)

Parametro: CodPagVar
 Gruppo: EvasioneDDT
 Valore default: N
 Con "S" si abilita la variazione del codice pagamento a seconda dell'importo fattura (Vedi 0Rad_TabCliPag)
Controlla se esiste il file 0Rad_TabCliPag con un elenco di clienti e relativi importi e condizioni di pagamento e se trova una fattura di uno di quei clienti, le riassegna la relativa condizione.

Parametro: CointestCausale
Gruppo: XML
Valore: Se contiene un valore diverso da S (che è il default) nel file xml non mette in automatico i cointestatari nel campo causale

Parametro: CointStaDet
Gruppo: StFatture
Valore: N Non stampa, P (default) stampa se sono state impostate % personalizzate sulla tabella cointestatari, S Stampa sempre
Consente di stampare una nota sulla fattura con l'elenco dei dati dei cointestatari. Il testo della nota va impostato nel
Parametro: CointDetBase
può contenere parti fisse e parti personalizzate e verrà stampato tra i dettagli FINE CORPO. (Vedi anche testo per dich.intenti)
I campi che si possono mettere nel testo sono §RagSoc§ §PartIva§ §CodFisc§ §Perc§ §Imp§ §Cognome§ §Nome§
Esempio di testo da impostare nel valore del parametro:
Suddivisione percentuali:
§RigIni§§RagSoc§ (§CodFisc§) - §Perc§% imp: §Imp§€§M-UL§
§/M-UL§§RigFin§
Vedere anche Filtri per fatture

Parametro: ColliDec
Gruppo: Tutti
Valore: S
Se impostato, in gestione Ddt e Fatture il campo 'Colli' verrà gestito come campo decimale piuttosto che intero, come avviene di default.

Parametro: CopiaDatiDocDettagl
Gruppo: EvasioneDdt
Valore default: N
Se viene impostato a S, durante l'evasione di un DDt in una fattura dettaglianti (ogni ddt genera una fattura!) il programma imposta la data riferimento, il prefisso, il numero e la data documento della fattura generata uguali a quelli del ddt da cui essa proviene.

Parametro: CopiaOrigInDoc
Gruppo: Fatture
Valore default: N
Viene utilizzato nella Contabilizzazione fatture, in corrispondenza a Note di Variazione, per decidere come copiare, sui movimenti di prima nota, i riferimenti al documento di origine (numero e data).
Normalmente essi verranno copiati nei dati 'documento di Origine' e si imposteranno i dati Documento uguali a quelli Protocollo (come per le fatture).
Se il parametro è impostato a S verrà copiata data/num documento di origine anche su data/num Documento

Parametro: CreaOrdAcq
Gruppo: EvasionePrev
Valore default: N
Questo flag consente di assegnare un valore di default alla scelta che a video, in fase di evasione di un preventivo in un ordine, chiede, se e in quali condizioni creare anche l'ordine di acquisto per gli articoli interessati. I valori possibili sono: T=per tutti gli articoli, S=solo per gli articoli in sottoscorta, E=solo per gli articoli esauriti.

Parametro: CreaNotaAcq
Gruppo: EvasionePrev
Valore default: S
Questo flag, se posto ad N (No), consente di non scrivere, nella nota di testata dell'ordine di acquisto generato durante l'evasione di un preventivo, la frase: generato da prev. xx del gg/m/aa.

Parametro: CopiaRifCli
 Gruppo: EvasionePrev
 Valore default: N
 Se impostato ad S consente di copiare, nell'evasione da preventivo ad ordine, il contenuto del campo: riferimento cliente del preventivo sul corrispondente dell'ordine .

Parametro: DaOrdi
Gruppo: DDT - Scontrini
Valore default: N
Programmi: Gestione DDT - Scontrini
Crea file con articoli da Ordinare.
Controlla se esiste il file sul Db: 0Rad_FileDaOrdi e in base al contenuto genera un file diverso a seconda del fornitore dell'articolo.

I file vengono generati nella directory specificata dal parametro DIRDAORDI messo nell'ini, in Sezione [Base] se non lo trova li mette in quanto specificato nel parametro DIRCARICA

Parametro: DataDoc
Gruppo: StFatture
Valore default: N
Programmi: Stampa fatture
Se S, la data Fattura (documento), invece di venire posta uguale alla data di stampa , viene posta uguale alla data Riferimento. Se è attivo questo flag il programma ordina le fatture da stampare, sempre per Data Riferimento poi per numero o per cliente a seconda di quello che chiede l'utente.

Se il programma si trova a stampare una fattura con data riferimento minore dell'ultima fattura stampata, assegna come data documento la data dell'ultima fattura stampata (letta nella tabella dei numeratori fatture)

Parametro: DataPersonalizzata
Gruppo: Fatture
Programma: Fattura diretta
Valore: Data copia commissione: (o altra scritta che comparirà in test.fattura per l'inserimento manuale del contenuto 'data')
Tale data verrà memorizzata in testata fattura sul campo DataInizioTrasp e verrà utilizzata per la stampa provvigioni

Parametro: DdtEleXml
Gruppo: EvasioneDDT
Valore default: NSN
Programma: Evasione ddt
Valore da assegnare ai campi presenti sulla maschera della riga descrittiva del corpo della fattura riepilogativa che contiene il Numero e la Data del ddt
I rispettivi campi ai quali assegnare un valore S o N sono: 'In xml fattura elettronica' 'su carta' 'altri dati articolo'
Di default viene messo a N il flag che riguarda la compilazione dell'XML in quanto numero e data dei ddt viene già messo in automatico nel blocco <DatiDDT>

Parametro: DdtXmlGen
Gruppo: EvasioneDDT
Valore default: SSN
Programma: Evasione ddt
Valore da assegnare ai campi presenti sulla maschera della riga descrittiva del corpo della fattura riepilogativa ai fini della corretta compilazione del file XML della fattura elettronica
I rispettivi campi ai quali assegnare un valore S o N sono: 'In xml fattura elettronica' 'su carta' 'altri dati articolo'

Parametro: DescAgg
Gruppo: Fatture
Valore default: Bianco
Programmi: Contabilizzazione fatture
Se impostato a S, nella generazione dell'articolo di contabilità della fattura, verranno copiati sulla descrizione aggiuntiva di testata, i primi 30 caratteri del contenuto del campo Riferimento cliente.

Parametro: DescPersDet1 - DescPersDet2 - DescPersDet3 - DescPersDet4
Gruppo: Preventivi - Ordini - DDT - Fatture - Acquisti
Programmi: Gestione Preventivi, Ordini di Acquisto e di Vendita, ddt, fatture
Sono campi a descrizione libera che possono essere inseriti in ogni riga di dettaglio dei documenti suddetti e portati sui documenti di evasione.

Nella riga del parametro, in valore, ci va la descrizione con la quale il campo verrà visualizzato in gestione del documento (es. MATRICOLA). Nel passaggio da Ordine a Ddt o da Ddt a Fattura, vengono trasferiti anche questi campi.

Parametro: DescPersTest1 - DescPersTest2 - DescPersTest3
Gruppo: Preventivi - Ordini - DDT - Fatture - Acquisti
Programmi: Gestione Preventivi, Ordini di Acquisto e di Vendita, ddt, fatture
Sono campi a descrizione libera che possono essere inseriti nella testata dei documenti suddetti e portati sui documenti di evasione.

Nella riga del parametro, in valore, ci va la descrizione con la quale il campo verrà visualizzato in gestione del documento (es. ZONA). Nel passaggio da Ordine a Ddt o da Ddt a Fattura, si porta sul documento di evasione il contenuto che questi campi hanno sul primo dei documenti evasi.

Parametro: DescLivNotaSot
Gruppo: Ddt , StFatture, Ordini, Preventivi
Programmi: Stampa Ordini, Preventivi, Ddt, Fatture
Se viene impostato questo parametro con un carattere, questo consentirà di stampare sui documenti, nella nota sotto dell'articolo le descrizioni dei livelli (taglia/colore) separate da quel carattere. Viene tuttavia reso sempre disponibile il campo C_RigDesArtLiv che contiene Descrizione articolo + Descrizione livello 1 + Descrizione livello 2

Parametro: DescrIvaPerCassa
Gruppo: StFatture
Frase da riportare sulle fatture - note di variazione emesse in regime di Iva per Cassa
In mancanza del parametro il programma stamperà a fine corpo, la frase:
“Operazione effettuata in regime di IVA per cassa, ai sensi dell’art.32-bis del D.L. 83/2012”
Mentre se si inserisce la riga con il parametro ma si lascia bianco il 'valore' il programma non stamperà nessuna frase.

Parametro: DetraeSconPag
Gruppo: Provvigioni
Valore default: bianco
Programmi: Stampa fattura (calcolo provvigioni)
Se si imposta il parametro a S la provvigione, sulle singole righe della fattura, verrà calcolata sull'importo di riga al netto dello sconto pagamento. Se la provvigione viene calcolata in percentuale sul totale merce e questo parametro è impostato ad S, il totale merce verrà scontato dello sconto pagamento prima di calcolare le provvigioni.

Gruppo: Ddt - Preventivi - Ordini - Fatture
Programmi: Gestione preventivi, ordini, ddt, fatture
Parametri per fissare una sequenza particolare di campi nella maschera dei dettagli dei documenti e nella visualizzazione dell'elenco dei dettagli.
Parametro: DettOrdIns
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di inserimento dei campi nel dettaglio documenti (valori dell'indice del controllo).
Valido SOLO in inserimento.
Ordinamento dei campi: se c’è un solo numero serve per dire che quello è il primo campo. Seguono gli altri in modo standard. Se si vuole un campo particolare per primo, poi il primo campo, si mette il particolare, poi il primo.
 Parametro: DettOrdInsTab
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di visualizzazione campi del dettaglio documenti (valori del tabindex corrente)
Parametro: DettOrdCol
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in gestione dettagli dei documenti.
Può contenere nomi di campi o anche espressioni
I nomi, separati da 'virgola' sono quelli delle variabili del database nelle tabelle DdtDett, OrdVenDett etc.
Colonne con nomi personalizzati in DDT , Fatture, Preventivi, Ordini, Acquisti:
grid testata: _Descrizione, ContoRicavo
grid dettaglio: _Descrizione, ContoRicavo, Val_Mon_Corr

Dopo il campo si può mettere:
§ seguito da un numero per indicare le larghezza della colonna,
^ seguito da un nome che sarà l’etichetta da dare alla colonna (solo per i campi aggiuntivi , NON per campi usati dal programma)
 (es. Qta§900,_Descrizione,Articolo,ValUnitario+valtotale as sommaImp §1000)
Parametro: DettOrdColTest
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in testata.
Stessa sintassi del parametro precedente.
Se il parametro non c’è o è vuoto viene assunto = al precedente.
Se si vuole che venga lasciato l’ordinamento previsto dal programma, pur avendo usato il parametro precedente, si valorizzi uguale a “-“ (meno)

Parametro: DicIntentiCalcRes
Gruppo: legge quello con gruppo: Tutti se mancano i singoli: DDt , Ordini , Preventivi, Fatture
Indica quali documenti considerare nel calcolo del residuo per dichiarazione d'intenti: F = solo fattura, D = fattura + DDT, O = fattura + DDT + ordini

Parametro: DichIntentiQualeTot
Gruppo: Tutti
Indica quale importo usare per il calcolo: D(default) = totale Documento, M=totale Merce con calcolo sconto pagamento,
E=totale documento - totale imponibile e totale iva (in pratica totale esente)

Parametro: DichIntentiValDef
Gruppo: DDt , Ordini , Preventivi, Fatture
Default Si. In inserimento o al cambio del codice Cliente legge dall’anagrafica la riga della dichiarazione di intenti attiva (se sono più di una lancia l’Help) e la riporta sul documento
Per disattivare questo automatismo, impostare il parametro con valore diverso da S (esempio: N)

Parametro: DicIntentiVerif
Gruppo: EvasionePrev - EvasioneOrd – EvasioneDdt
Se vale V (default) lo raggruppa solo in documenti in cui il campo non è compilato (Vuoto)
Se vale S viene ignorato il campo come condizione di raggruppo

Parametro: DichIntentiDopo
Gruppo: Fatture
Programmi: stampa fatture, se non sono stati attivati i parametri DichIntentiTab (e DichIntentiTesto uso precedente)
Se viene impostata una scritta, questa viene stampata sulla fattura dopo il contenuto del campo 'Lettera d' intenti' presente nell'anagrafica cliente.

Parametro: DichIntentiTab
Gruppo: Fatture
Programmi: stampa fatture
Valore di default: Oper. non imponib.ai sensi ART.8/C DPR 633/72 e succ.mod.
Vostra dich. nr.xx del gg/mm/aaaa - Nostra Reg. yy del gg/mm/aaaa

Se viene impostato questo parametro e sull'anagrafica del cliente, nella maschera Dichiarazioni di intento , ci sono delle righe attive, al momento dell'inserimento di una fattura (o dalla creazione della fattura riepilogativa) verrà compilato il campo 'Lettera di intenti' con il contenuto descritto dal parametro stesso o nel campo Lett.intenti in maschera (5) Fatt della gestione Clienti

(Per scrivere questo testo 'lungo' in modo 'agevole' si consiglia di premere sul campo 'Valore' i tasti Ctrl F2; per andare a capo dopo la prima frase si devono premere i tasti: Ctrl Invio)
Nel valore del parametro possono essere scritte delle parti fisse di testo, alternate a parti variabili.
Le variabili che contengono i numeri e le date delle dichiarazioni sono:
§NrDich§ e §DtDich§ - Numero e data dichiarazione di intento
§NrRic§ e §DtRic§ - Numero progressivo assegnato dalla ditta e data di ricevimento.

Esempio di frase da scrivere in fattura:
Esente IVA ai sensi dell'art.8 D.P.R. 633/72 a seguito Vs.dichiarazione d'intento N° 46 del 12/12/2016 registrata al N° 2/2017 del registro prot.dich.esportatori
Nel valore del parametro dovrà essere scritto:
Oper.non imp.ai sensi dell' art.8 del D.P.R. 633/72
a seguito Vostra dichiarazione d'intenti N° §NrDich§ del §DtDich§ - registrata al N' §NrRic§ del §DtRic§ del registro prot.dich.esportatori

Se si ricevono dichiarazioni con esenzione 8 e 8-bis per cui la scritta va differenziata per il tipo di esenzione del cliente, si può impostare nel campo Lett.intenti in maschera (5) Fatt della gestione del singolo cliente, il suo articolo di esenzione con la sintassi: £art.8£ opp. £art.8-bis£ e scrivere il valore di questo parametro:
Oper.non imp.ai sensi degli £art.8£ del DPR 633/72
Vostra dichiarazione d'intenti N° §NrDich§ del §DtDich§ -registrata al N' §NrRic§ del §DtRic§ del registro prot.dich.esportatori
In questo caso il programma sostituirà art. 8 o art.8-bis a seconda di quanto letto sul cliente.

Se invece nel cliente il primo e l'ultimo carattere del campo Lett. Intenti sono § (paragrafo), il parametro di personalizzazione verrà ignorato e verrà sostituito integralmente con il contenuto di questo campo.

(Versione precedente: Se invece si prevede di avere, per qualche cliente anche più di una dichiarazione per volta, si può scrivere una frase più complessa del tipo:
Oper.non imp.ai sensi degli art.8/8 bis-9 del DPR 633/72
§RigIni§Vostra dich. nr.§NrDich§ del §DtDich§ - Nostra Reg. §NrRic§ del §DtRic§§M-UL§
§/M-UL§§RigFin§
oppure, a seconda di come si vuole la frase in fattura:
Oper.non imp.ai sensi degli art.8/8 bis-9 del DPR 633/72
§M0§Vostra dichiarazione§/M0§§Mn§Vostre dichiarazioni§/Mn§ d'intenti §RigIni§§M1§
§/m1§N° §NrDich§ del §DtDich§ - Nostra Reg. §NrRic§ del §DtRic§§M-UL§ / §/M-UL§§RigFin§ - fine prima parte

§M0§ indica che il testo che segue va stampato una volta sola per cui verrà utilizzato se c'è un'unica dichiarazione da stampare §/M0§ per indicare la fine del testo da stampare
Il testo che segue la scritta: §Mn§ è quello che verrà stampato, una volta sola, quando ci sono più dichiarazioni per lo stesso cliente §/Mn§ per indicare la fine del testo da stampare
Per indicare un testo che andrà ripetuto per tutte le dichiarazioni si userà:
§RigIni§ ; il programma ripeterà tutto quello compreso tra esso e §RigFin§
§M1§ indica qualcosa che va scritto SOLO sulla 1' riga (§/M1§ per chiudere)
Nell' esempio è stato introdotto, dopo §M1§ un ritorno a capo.
§M2§ indica qualcosa che va scritto dalla 2' riga in poi (§/M2§ per chiudere)
§MUL§ indica qualcosa che va scritto SOLO sull'ultima riga (§/MUL§ per chiudere)
§M-UL§ indica qualcosa che va scritto sempre TRANNE sull'ultima riga (§/M-UL§ per chiudere)

Sono inoltre disponibili:
§Importo§ (importo) , §DataDa§ (data validità da) , §Dataa§ (data validità a) che si possono stampare per indicare a cosa si riferisce l'operazione, preceduti rispettivamente da:
§Rif1§ ad indicare 'Una sola operazione per l'importo' (/§Rif1§ per chiudere)
§Rif2§ ad indicare 'Operazioni fino a' (/§Rif2§ per chiudere)
§Rif3§ ad indicare 'Operazioni comprese nel periodo' (/§Rif3§ per chiudere)
Esempio:
Elenco tipologie:
§RigIni§§M2§ | §/M2§§Rif1§importo tipo 1 §Importo§§/Rif1§§Rif2§importo tipo 2 §Importo§§/Rif2§§Rif3§Data da §DataDa§ a §Dataa§§/Rif3§§MUL§ Fine elenco§/MUL§§RigFin§ - fine testo

Parametro: DichIntentiTesto
Gruppo: Fatture
Valore default: bianco
Programmi: stampa fatture
Se sul cliente sono stati compilati numeri e date della dichiarazione d' intenti (nel quadro coge), la compilazione di questo parametro consente di stamparli in fattura (è alternativo alla stampa del contenuto del vecchio campo 'Lettera d'intenti' del cliente).
Esempio di testo:
Oper.non imp.ai sensi degli art.8/8 bis-9 del DPR 633/72
Vostra dichiarazione d'intenti N° §NrDich§ del §DtDich§ - Nostra Reg. §NrRic§ del §DtRic§
 (Per scrivere questo testo 'lungo' in modo 'agevole' si consiglia di premere sul campo 'Valore' i tasti Ctrl F2; per andare a capo dopo la prima frase si devono premere i tasti: Ctrl Invio

Parametro: DisabTermPrz
Gruppo: DDT - Fatture - Acquisti - Ordini - Preventivi
Programmi: Gestione DDT - Gestione Fatture - Scontrini
Valore: Lista terminali disabilitati per la gestione prezzi e sconti nei documenti DDT, Fatture etc. separati da punto e virgola ';'. Si accetta anche Pip* per indicare 'Tutti quelli che iniziano per Pip'
Occorre creare una riga per ogni programma in cui attivare la personalizzazione

Parametro: DisabTermVisPrz
Gruppo: DDT - Acquisti - Ordini - Preventivi
Valore: Lista terminali, separati da punto e virgola ';', per i quali non verranno visualizzati i prezzi e gli sconti in inserimento-variazione nei programmi specificati in Gruppo.
Occorre creare una riga per ogni programma in cui attivare la personalizzazione

Parametro: DivPezziConf
Gruppo: Articoli
Programmi: Preventivi, ordini acquisti e vendita, ddt e rispettive evasioni, fatture, scontrini
Valore: Il campo pezzi per confezione sugli articoli è intero. Per chi ha la necessità di gestirlo decimale, si può mettere in questo parametro il divisore (10, 100,1000). Nei programmi suddetti, il valore intero, letto sull'articolo verrà diviso per questo parametro.

Parametro: DoveStampoRigaDesc
Gruppo: Preventivi
Programmi: Gestione preventivi
Valore: nel campo può essere inserita una delle seguenti lettere:N , A, S, E . Il valore di default è A
Questo parametro serve a forzare, in fase di inserimento delle righe descrittive, il campo 'Dove stampo la nota': N = no stampa, A=solo su documento attuale, S=anche sul doc.di evasione, E=solo sul documento di evasione (vedere anche NotaSoSotAttEEva).

Parametro: DoveStampoSotto e/o DoveStampoSopra
Gruppo: Preventivi - Ordini - DDT
Programmi: Gestione preventivi, Ordini, DDT
Valore: nel campo può essere inserita una delle seguenti lettere:N , A, S, E . Il valore di default è A
Questo parametro serve a forzare, in fase di inserimento manuale della nota sopra o nota sotto dell'articolo (no di righe descrittive), il contenuto del campo 'Dove stampo la nota': N = no stampa, A=solo su documento attuale, S=anche sul doc.di evasione, E=solo sul documento di evasione (vedere anche NotaSoSotAttEEva)

Parametro: EmailPEC
Gruppo: StFatture
Programmi: preparazione file per fattura elettronica a privati
Indica quale dei quattro indirizzi email presenti sul cliente è da utilizzare come PEC.
Valore di default è 2 cioè l'indizzo email amministrativo. Valori possibili: 1,2,3,4

Parametro: EmailPreDef
Gruppo: StOrdini (vale per preventivi, ordini di acquisto e di vendita) (StDdt, StFatture, StAltro(per altre stampe))
Valore: N con N=1,2,3,4 ad indicare la posizione dell' email del Cliente/Fornitore da utilizzare per quella funzione.
In alternativa si possono usare i valori: PRI (principale), AMM (amministrazione), COMM (Commerciale), SPED (Spedizione)
Serve per impostare, ad esempio, che come standard si vuole mandare la fattura all'indirizzo email definito come 'Commerciale': si creerà un parametro con gruppo: StFatture e Valore: COMM
Vedi anche parametro: DescEmailXXX

Parametro: EsciDopoStampa
Gruppo: Fatture
Programmi: Gestione Fattura Accompagnatoria
Valore: Se impostato a S al termine della stampa della fattura accompagnatoria fatta da gestione, il programma torna al menu.

Parametro: EvaIndSped
Gruppo: EvasioneDdt
Programmi: Evasione ddt
Valore: il parametro deve contenere un numero da 1 a 5, una virgola (,) e 2 caratteri. (es: 1,IS)
Va impostato se si vuole stampare, in fattura, per i ddt di determinati clienti, la ragione sociale del destinatario del ddt stesso. Il numero indica una delle 5 classi/attributi che possono caratterizzare i clienti, i due caratteri indicano il contenuto del campo corrispondente (codice dell'attributo). Il programma di evasione ddt, in presenza di questo parametro, cerca sul cliente e sulla classe indicata, i 2 caratteri scritti nel parametro, se li trova e se la destinazione del ddt è diversa da quella del cliente stesso, crea una riga, a seguito di quella: ddt nr. … del … con scritto: 'Destinazione : rag.sociale destinazione'

Parametro: EvaManLivGruppo
Gruppo: Ordini
Programmi: Evasione ordini con livelli (Taglia-colore)
Valore: Se impostato a S, nell'evasione dell'ordine, non vengono elencati i livelli di ogni dettaglio ma viene presentata solo la riga di dettaglio. In questo modo, impostando la quantità da evadere, essa verrà copiata su ogni livello di quel dettaglio. In mancanza di questo flag verranno elencati, in evasione, tutte le righe dei livelli presenti nell'ordine.

Parametro: FincPrecDatiTest , FincPrecDatiPie
Gruppo: StFatture - StDdt
Programmi: Stampa ddt e fatture
Valore: Se vale S (default), il programma stampa nella testata e/o nel piede dei documenti, la fincatura prima dei dati. Per invertire quest'ordine, porre il/i flag a N.

Parametro: FineCorpo
Gruppo: Fatture - FattureAcc - Ddt - (Ordini - Acquisti - Preventivi)
Programmi: Stampe Fatture - Ddt etc.
Lista di sottosezioni del corpo documento da stampare alla fine della stampa dei dettagli.
Le varie sottosezioni dovranno essere separate da una virgola. (Es. M0,M1,M2 poi nel filtro, nel campo sottosezione delle righe interessate si dovrà mettere rispettivamente M0,M1 etc.)

Gruppo: Ddt - Preventivi - Ordini - Fatture
Programmi: Gestione preventivi, ordini, ddt, fatture
Parametri per fissare una sequenza particolare di campi in inserimento di un ddt (in caso di necessità, chiedere a Zucchetti Ravenna (ex CSS) i valori da assegnare)
Per quanto riguarda i dettagli vedere i parametri: DettOrdIns
Parametro: GestFoldIns
numero del folder da proporre ogni volta che si va in inserimento
Parametro: GestOrdIns
Elenco dei numeri dei campi da mettere in testa nell'ordinamento dei campi in inserimento (es. 50,60,70,80,960,1015)
Parametro: GestOrdInsTab
In alternativa al parametro precedente: elenco dei tabindex dei campi da mettere in testa nell'ordinamento dei campi in inserimento (Es. 230,231,5,52,53)

Parametro: GestVuotiCauz
Gruppo: Fatture (e/o Ddt)
 Programmi: Ddt e/o Fattura accompagnatoria
Valore:

  • S abilita la gestione dei vuoti. In pratica, nella maschera di inserimento dei ddt e/o delle fatture accompagnatorie, viene abilitato il pulsante per il calcolo dei vuoti/cauzioni in corrispondenza agli articoli del documento per i quali è valorizzato il campo: "codice imballo".
    In particolare il parametro inserito con Gruppo: fatture, fa sì che gli 'articoli cauzioni' non vengano stampati nel corpo della fattura ma vengano predisposti i campi per la stampa del prospetto delle cauzioni.
  • G (Gruppo: Fatture) in fattura accompagnatoria abilita il pulsante per la generazione automatica delle righe di cauzione ma tratta gli articoli cauzioni come fossero articoli normali e cioè: verranno stampati nel corpo e verranno conteggiati nel totale merce.

Parametro: GestTab
Gruppo: Ddt (e/o Fatture)
Può assumere valore S (si) o N (no). Il valore di default è quello del parametro Gestab con gruppo: Livelli
Tale valore può essere variato, impostando questo parametro, per singola funzione, in modo che il programma si comporti in modo diverso da funzione a funzione.

Parametro: GruppoScontoColli
(Non si può utilizzare se si emette fattura elettronica)
Gruppo: Fatture
Valore: ScC (o comunque un codice gruppo fittizio)
Se abilitato questo flag, a piede fattura verrà applicato, oltre all'eventuale sconto pagamento, anche lo sconto 'a quantità' che dipende dal numero totale dei colli inseriti in fattura.

Su ogni riga 'articolo' verrà digitato il numero dei colli (o confezioni) e a fine fattura il programma calcolerà il totale colli e verrà impostato lo sconto corrispondente cercando la percentuale sulla tabella Sconti quantità in corrispondenza al gruppo articolo indicato dal parametro.

Occorre creare questo gruppo articoli poi inserire nell'archivio sconti quantità una scaletta sconti per Gruppo/Sottogruppo articoli dove in gruppo si metterà la sigla di cui sopra e in sottogruppo niente

Dentro al programma vengono utilizzati i campi FatTest.LiberoTest1 e LiberoTest2 per memorizzare separatamente i due sconti pagamento e colli in modo da poterli stampare separatamente.

N.B.: la ditta che utilizza questo parametro non potrà utilizzare i parametri di personalizzazione: che abilitano i campi LiberoTest1-3 nella maschera delle note del cliente (per targa, modello) etc.

Parametro: IndAmmSep
Gruppo: StFatture
Programma: stampa fatture dirette/riepilogative
Se è stato associato al cliente un indirizzo amministrativo questo verrà stampato in fattura al posto dell'indirizzo del cliente.
Se invece si assegna al parametro uno qualsiasi dei valori U o B o S questo verrà copiato nell'indirizzo di spedizione.

Per quei clienti in cui non è stato compilato l'indirizzo amministrativo , valorizzando il parametro a:
U verrà posto l'indirizzo di spedizione uguale all'indirizzo cliente e verrà sempre ignorato l'indirizzo di spedizione della testata fattura
B l'indirizzo di spedizione verrà lasciato bianco.
S l'indirizzo di spedizione verrà compilato con l'indirizzo di spedizione della testata della fattura. Se però anche quest'ultimo è bianco, nei dati della spedizione verrà scritto 'stesso' oppure quanto previsto da StessoDest

Parametro: IndSpedInv
Gruppo: StFatture
Programmi: Stampa fatture dirette
Se impostato a S, se sulla fattura c'è un indirizzo di destinazione nel quale è stato detto che 'nella fattura sostituisce l'indirizzo principale' e se sul filtro sono state messe le istruzioni opportune per stampare l'indirizzo di destinazione, anche per le fatture dirette, come per le accompagnatorie, verranno invertiti gli indirizzi e stampati.

(Se si attiva questo parametro e non si attiva il successivo: IndSpedNoStesso è possibile mettere delle istruzioni sul filtro della fattura diretta, in modo da invertire anche le scritte "Destinatario merce" e "Intestatario fattura" oltre ai due indirizzi e/o di non stampare il riquadro destinato alla destinazione merce se non è presente un destinatario diverso).

Senza attivare parametri, se si vuole semplicemente replicare, nel caso manchi l'indirizzo di spedizione, l'indirizzo del cliente nello spazio riservato, nel filtro, all'indirizzo di spedizione, occorre testare nel filtro stesso, il parametro T_MancaSped e inserire le righe opportune come da esempio.

Parametro: IndSpedNoStesso
Gruppo: StFatture
Programmi: Stampa fatture dirette e accompagnatorie
Se impostato a S e nella fattura non c'è un indirizzo di destinazione diverso da quello del cliente, non scrive, nello spazio riservato alla destinazione, la scritta "STESSO".
In questo caso, se si vuole scrivere un'altra frase, si può impostare il parametro: StessoDest

Parametro: InibClienti
Gruppo: DDT o FatAcc
Programmi: Gestione DDT e Gestione Fatture accompagnatorie
Classe/Codice Attributo che identificherà i clienti ai quali non sarà possibile emettere DDT o fatture accompagnatorie (es: 1/xx)

Parametro: InizioAvvisoCliente
Gruppo: Note
Programmi: Gestione Ordini, DDT, Fatture
Se impostato con qualche carattere (es. $$), i programmi suddetti stamperanno un avviso sulla maschera del cliente se la nota in anagrafica cliente/fornitore inizia con questi caratteri.
Se nel valore si scrive Tutti , l'avviso verrà evidenziato ogni volta che si richiama un cliente con le note compilate.

Parametro: IntervDate (Personalizzazione)
Gruppo: ProvvigSt
Programmi: Stampa provvigioni
Valore: Data copia commissione: (o altra scritta). E' la descrizione di un campo che verrà visualizzato in stampa provvigioni e dove potrà essere inserita una data di selezione memorizzata in testata delle fatture da stampare (nel campo: data trasporto)(questo parametro ha senso se è stato impostato anche il parametro: DataPersonalizzata Gruppo: Fatture

Parametro: LettArtDaFile
Gruppo: acquisti, preventivi, ddt, ordini, fatture (scontrini, carmov)
Programmi: caricamento movimenti di magazzino, ordini di acquisto e vendita, preventivi, ddt e fatture
Se impostato a S verrà presentata, nei dettagli, una icona che consente di caricare da file gli articoli piuttosto che digitarli. (Vedere impostazione parametri in Caricamento dettagli documenti da file)

Parametro: Liv1VertOriz
Gruppo: Livelli
Programmi: Ordini, ddt, Fatture se si usano articoli con livelli (Es. taglia/colore)
Se vale V nella gestione livelli il primo livello viene mostrato in verticale altrimenti (default) in orizzontale

Parametro: MagaNoGiac
Gruppo: Tutti
Programmi: Gestione Ddt e fatture (Ordini acquisto- vendita, Preventivi, Caric.movimenti di magazzino)
In fase di inserimento degli articoli sul documento, vengono visualizzate giacenza e disponibilità dell'articolo stesso sul magazzino del documento. A fianco, se diverse, vengono riportate rispettivamente giacenza e disponibilità dell'articolo su tutti i magazzini codificati.
E' possibile escludere dal calcolo alcuni magazzini, attivando questo parametro con i codici dei magazzini (separati da virgola) che dovranno essere esclusi. Per escludere il magazzino del documento, si deve mettere *.

Parametro: MemTargaVet
Gruppo: Ddt e Fatture
Programmi: Gestione e stampa ddt e fatture
Se impostato ad S si consente di inserire/variare la targa del vettore (anche se il vettore è codificato) nella maschera dei dati di accompagnamento

Parametro: MessIvaSosp
Gruppo: Fatture
Programmi: Stampa fatture
Valore: Frase da scrivere alla fine del corpo fattura se la fattura è per un cliente con iva sospesa

Parametro: MostraCostoUltimo
Gruppo: Ddt e/o Fatture
Programmi: Inserimento Ddt e fatture
Valore: Se vale S, abilita, durante l'inserimento o variazione di una riga articolo, sul campo prezzo unitario il tasto F4 per mostrare costo ultimo dell'articolo.

Parametro: NoDecodSeProv
Gruppo: Fatture
Programmi: Inserimento Fatture
Se vale S, se si cambia il Tipo documento in una fattura proveniente da Ddt, da Ordine o da Preventivo, non verrà cambiata la condizione di pagamento nè il listino.

Parametro: NoDescPrezziIvati
Gruppo: OrdiniPre e StFatture
Valore default: N
Programmi: Stampa ordini e preventivi e stampa fatture
Il programma stampa automaticamente nel corpo degli ordini e dei preventivi la scritta: I prezzi si intendono al netto dell'iva (se listino non ivato) o I prezzi sono comprensivi di iva (se listino ivato).
Per eliminare la stampa di questa frase, occorre impostare a S il parametro di cui sopra.

Parametro: NonContrSucc
Gruppo: Ddt
Valore default: N
Programmi: inserimento ddt
Se impostato a S non verrà fatto nessun controllo sull'inserimento di numero e data ddt direttamente in gestione.
Utilizzabile da quanti inseriscono i Ddt numerandoli manualmente (sempre) e che prima dovevano impostare ad inizio anno un numeratore a 9999 con data 31/12/xxxx. Se si attiva questo parametro occorre CANCELLARE il numeratore dei ddt preimpostato con data 31/12/xxxx
Nota: questo parametro non interessa la stampa

Parametro: NonImportoZero
Gruppo: Fatture
Valore default: N o bianco
Programmi: Contabilizzazione fatture
Se vale S, non verrà scaricato nel movimento di prima nota un eventuale dettaglio con importo a 0 ovvero verranno creati i dettagli solo in corrispondenza ai conti di ricavo il cui importo è diverso da 0.

Parametro: NoRaeeAutom
Gruppo: Magazzino
Programmi: Ordini, Ddt e Fatture
Può essere impostato con l'elenco delle causali di magazzino per le quali, anche se si movimenta un articolo che ha un 'articolo raee' collegato, non verrà generata la riga del Raee. Le causali dovranno essere separate da , 'virgola'.
La causale che si controlla è quella collegata al tipo documento.

Parametro: NoRigDescr
Gruppo: EvasioneDDT
Valore default: N
Programmi: Evasione DDT
Se impostato ad S non verrà evasa nessuna riga descrittiva

Parametro: NoStampaLivelli
Gruppo: Fatture
Programmi: Stampa fatture (estrazione XML FE)
Valore default: N
In presenza di articoli con livelli (es. Taglia/colore), sia in stampa sia sul file XML della fattura elettronica verrà riportata una riga per ogni livello. Questo stesso parametro può essere impostato direttamente anche per ogni singola fattura sulla maschera 'Altri dati per fattura elettronica' e per ogni singolo cliente sulla maschera dei dati di fatturazione.
Valori che può assumere il parametro:

  • N - No articolo principale
    Verranno elencate tutte le righe dei livelli ciascuno con quantità e prezzi
  • S - Solo articolo principale
    Verrà riportata solo la riga dell'articolo principale con la somma delle quantità e dei prezzi delle singole righe dei livelli
    Ovviamente, in questo caso, il prezzo unitario riportato su questa riga non e' "affidabile" in quanto viene calcolato togliendo l'eventuale sconto dall'importo totale e dividendo per il numero di pezzi e poi arrotondando al numero di decimali di gestione
  • L - Prezzo sui livelli
    Verrà stampata la riga articolo senza prezzo seguita dalle righe dei livelli ciascuna col suo prezzo
  • F - Prezzo su riga articolo
    In stampa equivale a N mentre sul file XML verrà scritta la riga articolo con quantità e prezzo totale , seguita dalle righe dei livelli con prezzo a 0

Parametro: NotaLinguaDove
Gruppo: Vendite
Programmi: Gestione Preventivi, Ordini, Ddt, Fatture
Questo parametro consente di utilizzare la tabella delle descrizioni in lingua associate all'articolo per inserire delle descrizioni aggiuntive dell'articolo stesso
Se valorizzato, viene attivato, sulle righe 'articolo' dei documenti, il tasto funzione F11 (F5 sugli Ordini). Premendo questo tasto, se sono state compilate per l'articolo della riga, una o più descrizioni in lingua, in particolare la descrizione lunga in lingua, esse verranno visualizzate e si da la possibilità di sceglierne una. Questa verrà copiata nella "descrizione sotto" della riga (salvo diversa indicazione nel parametro) e verrà stampata secondo quanto specificato nel parametro.
Il parametro può assumere i valori: A (stampa solo su doc.attuale), S (attuale e in doc. evasione), E (solo in doc di evasione), N (non stampare)
Per copiare la descrizione nella 'nota sopra', occorre aggiungere al valore del parametro una S
(es.: AS copia in nota sopra)

Parametro: NotaSoSotAttEEva
Gruppo: EvasioneOrd - EvasionePrev
Programmi: Evasione preventivi e ordini
Se impostato a S fa si che il flag che indica che le righe descrittive (e note sopra e sotto) vanno stampate anche sul documento di evasione, mantenga lo stesso significato anche sul documento di destinazione.

Esempio: se non è attivo questo parametro e su una riga di un ordine c'è il flag di stampare la nota sul documento attuale e su quello di evasione, quando l'ordine viene evaso in DDt tale flag viene scritto sul ddt con 'stampo solo su documento attuale'. In questo modo quella nota non verrà mai stampata su fattura.

Viceversa, attivando questo parametro, sul ddt verrà impostato il flag a 'stampo su doc. attuale e doc. di evasione'.

Parametri:
OrdStampaDettByN (N=1-9)
OrdStampaDettDescN (N=1-9)
OrdStampaDettDef
Gruppo: Ddt / StFatture / Preventivi / Ordini / Acquisti
L'attivazione di questi parametri consente di ottenere la stampa del corpo di preventivi, ordini, ddt e fatture ordinata in modo diverso da quello che è il documento consultabile a video (nel quale gli articoli sono ordinati secondo la sequenza di inserimento).

L'introduzione di ordinamenti diversi dallo standard può creare problema in presenza di righe descrittive (note) o articoli manuali. Le note, in particolare, potrebbero finire tutte all'inizio o in fondo a seconda del tipo di ordinamento.

Nel valore del parametro OrdStampaDettByN dove N è un numero da 1 a 9 ci va l'elenco dei campi di ordinamento.
Es. se si vuole ordinare per descrizione articolo e quantità si metterà:
Articoli.descrizione,§dett§.qta dove §dett§ sta per DdtDett o FatDett o OrdAcqDett etc a seconda del gruppo scritto sulla riga.

Se si utilizzano Taglia e Colore, si può ordinare per livello: §liv§.Livello1, §liv§.Livello2 (§liv§ sta per DdtDettLiv o FatDettLiv etc)
oppure per Articolo e livello : §dett§.Articolo, §liv§.Livello1, §liv§.Livello2

Possono essere presenti più modalità di ordinamento in modo da poter scegliere, al momento della stampa, come ordinare. Ad ogni riga creata con il parametro: OrdStampaDettByN , ne deve corrispondere una con stesso gruppo e parametro: OrdStampaDettDescN dove, in valore, si deve mettere la descrizione dell'ordinamento, descrizione che verrà visualizzata nella maschera di stampa in modo da consentire la scelta dell'ordinamento. Nel box che elenca, al momento della stampa, le varie possibilità di ordinamento attivate, al primo posto si trova l'ordinamento standard cioè così come

Il parametro OrdStampaDettDef infine, dovrà contenere un numero da 1 o 9 che corrisponderà all'ordinamento proposto come default nella maschera di stampa (sarà uno di quelli definiti con i parametri precedenti) Nel box che elenca, al momento della stampa, le varie possibilità di ordinamento attivate, al primo posto si trova l'ordinamento standard, per avere questo come default occorre impostare il parametro OrdStampaDettDef a 0.

Per non avere in stampa la lista dei possibili ordinamenti, pur avendo definito un ordinamento personalizzato che si vuole utilizzare sempre, basta dare a questo parametro un valore negativo (es. -1)

Parametro: PartitaEnse (Person. per un cliente)
Gruppo: Ordini - DDT - Fatture - Acquisti - Preventivi
Valore default: S
Programmi: Gestione Preventivi, Ordini di Vendita e di acquisto, Ddt, Fatture Evasioni - Stampa Quantità Evasa - Stampa Quantità Inevasa
Gestisce nei dettagli il contenuto del campo 'tempo di consegna articolo' e visualizza con descrizione articolo le classi e attributi per trattamento etc.

Parametro: PrezAcqOCostoUlt
Gruppo: Acquisti
Programmi: Inserimento ordini di acquisto
Se la causale di magazzino prevede che il prezzo della riga articolo sia letto dal Costo Ultimo:
se il parametro è impostato a 0 , il programma propone, se valorizzati, dalla tabella Articolo/Fornitore il prezzo di acquisto e il relativo sconto
se è impostato a 1 , il programma propone, dalla tabella Articolo/Fornitore il prezzo di acquisto SOLO se è valorizzato il relativo sconto
se è impostato a 2 , il programma propone, dalla tabella Articolo/Fornitore il costo ultimo

Parametro: PropRitiro
Gruppo: DDT
Valore default: S
Programmi: Stampa DDT
Propone in stampa data e ora ritiro uguali a data e ora del momento di stampa.

Parametro: QtaDef
Gruppo: Ordini - DDT - Fatture - Magazzino - Acquisti - Preventivi (Scontrini)
Valore default: 0
Programmi: Gestione DDT - Gestione Fatture - Gestione movimenti di magazzino -Gestione Ordini di Acquisto e di Vendita - Gestione Preventivi (Scontrini)
Quantità proposta di default in ogni riga di dettaglio.

Parametro: QtaDaDimen (per legnami)
Gruppo: Vendite
Programmi: Gestione ordini, ddt, fatture
Se impostato a S, nella maschera di inserimento di un articolo nel dettaglio dei documenti, vengono chiesti i campi lunghezza, larghezza, altezza, impostati con i valori di default che sono stati messi nella gestione articoli e la label del campo colli viene cambiata in numero pezzi.
Le misure, di default, si intendono espresse in millimetri per ottenere poi la quantità espressa in metri o metri quadri o metri cubi.
Si può utilizzare un'altra unità di misura, attivando il parametro:
QtaDimenRapp. Esso andrà valorizzato a 100 se le misure verranno date in centimetri, a 10 se in decimetri e così via (il suo valore di defaut è 1000).
In pratica il valore X inserito in questo parametro servirà per il calcolo delle quantità nell'operazione:
Qta=(colli*lunghezza) / X (se una dimensione)
Qta=(colli*lunghezza*larghezza) / X * X (per due dimensioni)
etc.
Devono inoltre essere impostati i parametri:
QtaDaDimUML, QtaDaDimUMQ, QtaDaDimUMC
Il cui valore deve contenere rispettivamente : l'unità di misura degli articoli che si vendono a metri lineari (es. ml), quella per i metri quadri (Es.mq) e quella per i metri cubi (es. mc)
Se le unità di misura, per ogni tipo, sono più di una basta separarle da ; (punto e virgola)
Sull'articolo dovrà essere inserita un'unità di misura tra quelle messe nei parametri e le dimensioni, espresse in millimetri o in base al valore assegnato al parametro QtaDimenRapp.
(Per l'eventuale variazione delle descrizioni dei campi lunghezza, larghezza e altezza, vedere i parametri di personalizzazione: LabAlt, LabLarg e LabLung)
Nelle vendite, una volta richiamato l'articolo, l'utente inserirà il numero di pezzi, e il programma calcolerà la quantità facendo riferimento all'unità di misura dell'articolo (metro lineare, metro quadrato o metro cubo).
Nella 'descrizione sotto' dell'articolo verrà inoltre creata una riga con: nr.pezzi x lunghezza x altezza x larghezza da stampare sui documenti.

Per ottenere una riga descrittiva più comprensibile, si possono attivare i seguenti parametri (tutti con gruppo Vendite):
NotaDimensioni, NotaDimensioniUML, NotaDimensioniUMQ, NotaDimensioniUMC
Nel campo valore di ciascuno di questi parametri, si può mettere una parte fissa e una parte variabile preceduta e seguita dal carattere §
Se si vuol mettere solo una descrizione iniziale, o una per tutte le dimensioni, basta attivare NotaDimensioni,
altrimenti il contenuto del parametro NotaDimensioniUML, verrà stampato in corrispondenza ad articoli con l'unità di misura scritta in QtaDaDimUML cioè a una sola dimensione (es. metri lineari)
il contenuto del parametro NotaDimensioniUMQ, verrà stampato in corrispondenza ad articoli con l'unità di misura scritta in QtaDaDimUMQ cioè a due dimensioni (es. metri quadri)
il contenuto del parametro NotaDimensioniUMC, verrà stampato in corrispondenza ad articoli con l'unità di misura scritta in QtaDaDimUMC cioè a una sola dimensione (es. metri cubi)
Esempio:
NotaDimensioniValore: Pezzi §Colli§
Nella nota sotto verrà creata la scritta: Pezzi nn (con nn=numero pezzi digitati a video)
NotaDimensioniUML Valore: Pezzi §Colli§ x Lungh. §UM§: §Lun§
Nella nota sotto verrà creata la scritta: Pezzi nn x Lungh. M. zz (con M.= unità di misura e zz=lunghezza dell'articolo)
NotaDimensioniUMQ Valore: Pezzi §Colli§ x Lungh. §Lun§ e Lar §Lar§
Nella nota sotto verrà creata la scritta: Pezzi nn x Lungh. zz e Lar rr (con zz=lunghezza e rr larghezza dell'articolo)
NotaDimensioniUMC Valore:Pezzi §Colli§ con dim: §Lun§ x §Lar§ x §Alt§
Nella nota sotto verrà creata la scritta: Pezzi nn con dim: zz x rr x dd (con zz=lunghezza , rr larghezza e dd altezza dell'articolo)

Parametro: RaggrDestin
Gruppo: EvasioneDdt
Valore default: N
Programmi: Evasione Ddt
Se impostato ad S in evasione Ddt viene chiesto all'utente se, indipendentemente da quello che è stato impostato in testata dei Ddt, si vuole stampare una fattura per ogni destinazione e si chiede l'intervallo delle destinazioni da prendere in considerazione. (Utilizzato da chi emette Ddt per trasferire la merce ai cantieri poi la fattura)

Parametro: RicalcColli
Gruppo: Vendite
Valore default: bianco
Programmi: Ddt e Fatture accompagnatorie
Flag da impostare per ricalcolare automaticamente il totale colli, sul quadro di accompagnamento, all'uscita dai dettagli: se vale Q i colli verranno calcolati come somma delle quantità, se vale C come somma dei colli delle righe 'articolo' del documento. Con altri valori non si esegue il calcolo automatico. Dal calcolo dei colli vengono esclusi gli articoli con flag cauzione posto a Si.

Gruppo: Fatture
Parametro: RigaDescInXml
Valore default: S
Può assumere valore S o N
Viene utilizzato per impostare il valore del campo 'In Xml' presente sulla riga descrittiva del corpo fattura. Se impostato a Si il contenuto della riga descrittiva verrà riportato sul file XML
Parametro: RigaDescInStampa
Valore default: S
Può assumere valore S o N
Viene utilizzato per impostare il valore del campo 'Su carta' presente sulla riga descrittiva del corpo fattura. Se impostato a Si il contenuto della riga descrittiva verrà stampato sulla fattura
Parametro: RigaDescAltroXArt
Valore default: S
Se sulla riga di un articolo, , ai fini della compilazione della fattura elettronica, serve avere più di un elemento nella sezione ‘altri dati gestionali su XML’ si dovrà creare una o più righe descrittive prima della riga articolo, impostare a Si questo campo poi andare in ‘altri dati x fatt. elettronica’ con il pulsante apposito e inserire nel quadro (7) Altri dati, i dati necessari in Altri dati gestionali (esempio: identificativo scontrino)

Parametro: RigaDescrDef
Gruppo: EvasioneDdt
Valore default: S
Se impostato ad N e sulla tabella del Tipo documento corrispondente non c'è niente nel campo Descrizione su fattura riepilogativa non viene generata la riga DDT N' in fattura.

Parametro: RigaDescrTotale
Gruppo: EvasioneDdt
Programmi: Evasione ddt e Stampa fattura
Questo parametro serve per far sì che in fattura riepilogativa, invece di stampare l'elenco degli articoli di ogni ddt vengano stampate semplicemente le varie righe: DDT Nr. xx del xx/xx/xx e l'importo totale del ddt
Può assumere due valori diversi:

  • S in sede di evasione Dtt, verrà aggiunto il totale merce del ddt su ogni riga: DDT Nr. xx del xx/xx/xx della fattura riepilogativa.
  • P in evasione ddt verrà ugualmente calcolato l'importo del ddt ma invece di metterlo a seguito della scritta: ddt xx del viene messo nel campo C_ValEuro. Questo per consentire di stampare l'importo in una colonna apposita. In questo caso devono essere aggiunte al filtro 2 righe di corpo con sottosezione 1 e campi: C_RigDesArt e C_ValEuro (negli altri campi ci vanno gli stessi valori delle rispettive righe in sottosezione 0)

In fattura riepilogativa verranno comunque stampate le eventuali righe inserite manualmente, direttamente sulla fattura, sia con 'articolo' manuale sia descrittive.

Parametro: RigDescrEva
Gruppo: Ordini
Programmi: Evasione ordini
Se viene inserita una riga con questo parametro, il programma di evasione di un ordine in DDT crea, per ogni riga evasa, una riga descrittiva che indica lo stato della riga dell'ordine.
Il valore da assegnare al parametro si compone di 3 'parti', separate da un ;

  1. indica dove va generata la riga descrittiva: P = prima della riga articolo, D = dopo la riga articolo
  2. frase da scrivere in caso di evasione totale
  3. frase da scrivere in caso di evasione parziale

Esempio: P;Evasione totale;Evasione parziale

Parametro: RitAccDescr
Gruppo: StFatture
Nel 'Valore' si può impostare la descrizione da stampare per evidenziare la Ritenuta d'acconto in fattura, tale descrizione verrà assegnata alla variabile T_RitaccDescr da utilizzare nel filtro di stampa
Es. si può scrivere: Ritenuta Acconto del §PercRit§% §SuPercTesto§ pari a §RitAcc§ su §TotImpon§
Dove §PercRit§ è la % della Ritenuta , §SuPercTesto§ è l'eventuale % dell'imponibile su cui calcolare la ritenuta (se diversa dal 100%), §RitAcc§ è l'importo della Ritenuta, §TotImpon§ è l'imponibile ritenuta.
Se non si imposta niente verrà stampata una frase fissa da programma: Ritenuta d'acconto del xx% (se la ritenuta viene applicata non su tutto l'imponibile ma solo su una parte, verrà aggiunta la frase: sul yy% dove yy è la percentuale dell'imponibile su cui va applicata)

Parametro: SaltoPagClie
Gruppo: StaSconti
Valore default: bianco
Programmi: Stampa tabelle sconti
Se vale S, nella stampa degli sconti cliente/articolo, verrà stampato l'indirizzo completo del cliente (oltre alla ragione sociale) e fatto un salto pagina a cambio cliente

Parametro: ScarStatoDdt
Gruppo: Ddt
 Programmi: Scarico Ddt su file
Valore: contiene una cifra: 0, 1, 2 che indica l'impostazione del default che deve assumere il campo: Stato ddt per individuare lo stato che devono avere i ddt da scaricare su file.
Valori possibili: 0 -Tutti (default)1 - Solo stampati2 - Stampati ed Evasi

Parametro: ScarTipoDoc
Gruppo: Ddt
Valore: contiene l'elenco dei Tipi documento Ddt a fronte dei quali scaricare i Ddt su file. Ogni tipo documento è separato dal successivo da una virgola.
Programmi: Scarico Ddt su file. Serve per trasmettere a un altro database dei ddt caricati (es. BV,BD).

Parametro: ScarTSDitta e ScarTSSerie
Gruppo: Fatture
Valore: Contengono rispettivamente il codice ditta e il prefisso (registro iva) per la numerazione delle fatture, da scaricare sui campi appositi del file che viene preparato.
Programmi: Scarico movimenti di prima nota fatture su file in formato leggibile da procedura di contabilità Team System.

Parametro: ScontoPagInDet (attivo fino a data inserimento 31/12/2018)
Gruppo: Ddt - Fatture (Preventivi - Ordini)
Se impostato deve contenere l'elenco dei tipi documento, separati da virgola (,), per i quali, lo sconto pagamento, va sommato agli sconti delle singole righe, piuttosto che essere calcolato sull'imponibile/i alla fine della fattura.
Durante l'inserimento di un documento il campo 'Sconto pag.su dett' della testata, verrà impostato a Si se il tipo documento è nell'elenco.
Per le fatture elettroniche E' OBBLIGATORIO che lo sconto pagamento sia applicato sulle singole righe.

Non Utilizzato - Parametro: ScontoPagInPiede
Gruppo: Ddt - Fatture (Preventivi - Ordini)
Se impostato deve contenere l'elenco dei tipi documento, separati da virgola (,), per i quali, lo sconto pagamento verrà calcolato sull'imponibile/i alla fine della fattura piuttosto che venire sommato agli sconti delle singole righe.

Parametro: ScoZona
Gruppo: Ordini - DDT - Fatture - Acquisti - Preventivi
Valore default: N
Programmi: Gestione Zone - Gestione Fatture - Gestione Ordini di Acquisto - Gestione Ordini di Vendita - Gestione Preventivi
Se si imposta il valore a S, viene abilitato un campo sconto a importo sull'archivio zone in modo tale da poter applicare, sui documenti, tale sconto sugli articoli a seconda della zona di appartenenza del cliente.

Parametro: SegnSottoScorta
Gruppo: MagaVen
Valore default: N
Programmi: caricamento movimenti di magazzino, inserimento Ddt e Fatture
Viene data una segnalazione acustica e un messaggio a video se l'articolo richiamato ha giacenza <=0 o è sottoscorta (non abilitato per articoli con livelli). Nel calcolo della giacenza (o sottoscorta) si tiene conto anche della quantità digitata sulla riga)
Per ottenere la segnalazione acustica prodotta dalla scheda audio, si può attivare nell'AziWin.ini della singola stazione di lavoro (o nel principale) il parametro: BeepCome
Tale parametro si attiva inserendo nella sezione [Parametri generali] dell'ini la riga:
BeepCome=NN;XX
Dove NN è la frequenza del suono e XX la durata. Occorre fare dei tentativi per valutare i numeri da mettere; ad esempio BeepCome=2000;20
oppure per ottenere un effetto sonoro diverso (dal win 2000 in avanti) si può mettere un segno meno davanti: BeepCome=-2000;20
oppure si può scegliere una musica a piacere (cioè un file .wav) dalla directory C:\windows\media\ e scrivere: BeepCome=c:\windows\media\nome.wav;20

Parametro: SegnRicClie
Gruppo: Fatture
Valore default: N
Programmi: Gestione Fatture
Se si crea il parametro con valore S, in Gestione fatture, se si varia su una fattura il codice del cliente e il nuovo cliente ha il conto di ricavo compilato, viene data una segnalazione per consentire all'utente di variare i conti di ricavo sui dettagli in quanto il programma non lo farà automaticamente.

Parametro: SommaPesi
Gruppo: EvasioneDdt
Valore default: N
Se impostato a S indica che in evasione ddt il campo Peso dei dati di accompagnamento della fattura dovrà contenere la somma dei pesi dei vari Ddt.

Parametro: SpesaClieAutom
Gruppo: Fatture
Valore default: N
Programmi: Gestione DDt e Fatture (Gestione Preventivi e Ordini di Vendita)
Se si imposta il valore a S, verrà caricata in automatico sul documento la spesa il cui codice è stato impostato sul cliente.

Parametro: SplitPayment
Gruppo: Fatture
Valore: Operazione con 'scissione dei pagamenti' DM 23/01/2015
Nel valore dovrà essere impostata la scritta da riportare sulle fatture emesse alla Pubblica Amministrazione a partire dal gennaio 2015 (meccanismo Split Payment)

Parametro: StaCodFisc
Gruppo: Brofat
Valore default: N
Programmi: Stampa brogliaccio fatture
Se impostato a S, e si sceglie la 'stampa sintetica su una riga' , verrà spuntata a video la scelta 'stampa Cod.Fisc' e verrà stampata la P.Iva del cliente, se presente, oppure il codice fiscale (al posto di totale merce e totale spese..)

Parametro: StaCondPag
Gruppo: Brofat
Valore default: N
Programmi: Stampa brogliaccio fatture
Se impostato a S, nella scelta 'stampa sintetica su una riga' verrà stampata la condizione di pagamento di ogni fattura al posto di totale merce e totale spese.

Parametro: StampaEti
Gruppo: Ddt
Valore default: N
Se impostato a S, al termine della stampa (o ristampa) di un ddt verrà lanciato il programma di stampa etichette clienti
Il numero di etichette stampate è pari al numero colli impostato nella testata del Ddt

Parametro: StampaFattura
Gruppo: EvasioneDdt
Valore default: N
Se impostato a S, viene spuntato in automatico, in evasione ddt, il flag che dice di stampare le fatture generate

Parametro: StaNumDoc
Gruppo: Acquisti (Preventivi, Ordini)
Valore default: N
Se impostato a S, le rispettive stampe di Statistiche (Ordini di acquisto, di Vendita e Preventivi), stamperanno numero e data Documento invece di Riferimento.

Parametro: StatoCaricamento
 Gruppo: Ddt
Valore: F = Da File, S = Stampato, E = Evaso
Programmi: Caricamento Ddt da file
Serve per impostare il valore che viene proposto all'operatore nel campo: Stato da mettere sui ddt caricati

Parametro: StaTotMerce
Gruppo: Preventivi, Ordini, Acquisti
Valore default: N
Programmi: Stampa preventivi e ordini di acquisto e vendita
Questo flag può essere impostato a S per stampare nel corpo del documento il totale merce invece del totale documento (comprensivo di iva). Per stampare l'importo nel corpo occorre che il totale merce (T_TotMerce) non compaia nelle righe del piede del filtro

Parametro: StDescAttr
Gruppo: StTutti (oppure per le singole stampe: DDT , FattureAcc ,Fatture)
Valore: N (N=1,...,5)
Consente di stampare nel corpo , sotto ogni articolo, la descrizione dell' attributo della Classe N (Da Classi/Attributi articoli) Es. tabella ADR dell'articolo.
Altri parametri correlati con questo: StTotAttr

Parametri: StDocFine e StDocPrn
Consentono di stampare un documento Word al termine della stampa degli Ordini, Acquisti, Preventivi, Ddt, Fatture
(sia essa Prestampa - Stampa - Ristampa)
N.B. Condizione necessaria per la stampa del documento è che sul computer sia installato WORD. Viene dato a word il comando di stampare il testo selezionato, la stampa avviene SEMPRE sulla stampante preselezionata di Word
Parametro: StDocFine
Gruppo: Ddt (Ordini, Acquisti, Preventivi, StFattura)
Valore: Nome, completo di percorso, del file doc da stampare (Es. c:\css\testo.doc)
Se il file da stampare è memorizzato in un percorso diverso per i vari terminali (es. se è sul server: i terminali lo vedono come F mentre se stesso lo vede come C) è possibile scrivere nell'aziwin.ini del singolo terminale, nella sezione [Base] una riga del tipo:
DirDoc=percorso_per _arrivare_al_file (es. f:\aziwin\carica)
In questo caso nel valore del parametro StDocFine si scriverà: §DirDoc§NomeFile.doc
*
Parametro: StDocPrn
Gruppo: Ddt (Ordini, Acquisti, Preventivi, StFattura)
Valore: Nome della stampante su cui stampare (dalla maschera Seleziona destinazione stampa)
Se si vuole stampare sulla stessa stampante su cui si stampa il Ddt basta scrivere: Idem
Se non si mette questo parametro verrà utilizzata la stampante di default.
E' possibile, variando i parametri, stampare:
SOLO in Prestampa: StDocFinePre e StDocPrnPre
SOLO in Stampa: StDocFineSta e StDocPrnSta
SOLO in Ristampa: StDocFineRis e StDocPrnRis
Se si vuole stampare il documento SOLO quando si utilizza un particolare modello (filtro) di stampa occorre far seguire i parametri suddetti dal nome del modello (quello che compare nella colonna 'Codice' nella maschera Seleziona destinazione stampa.
(Es. StDocFineStaCssStd stamperà il documento indicato solo quando si stampa in modalità di Stampa definitiva utilizzando il filtro CssStd)
Se si attiva il primo dei parametri suddetti, il secondo va omesso, e si stamperà sulla stampante di default, oppure va attivato obbligatoriamente nella forma corrispondente (come descritto sopra)
-- Se è stato attivato il parametro di personalizzazione però, in qualche caso, non si vuole la stampa, si può togliere la spunta al campo: 'Stampa file doc. finale' che compare nella maschera di stampa.

Parametro: StessoDest
Gruppo: Vendite
Valore default: STESSO
Si può impostare una scritta che le stampe Ddt e Fattura accompagnatoria stamperanno in corrispondenza all'indirizzo del destinatario, al posto di 'stesso', quando, per il documento, non c'è un destinatario diverso dal cliente stesso.

Parametro: StDesLunDaDoc
Gruppo: EvasioneDdt (EvasioneOrd)
Programmi: Evasione ordini ed evasione ddt
Normalmente, in sede di evasione di un documento, il flag "Dove stampo descrizione lunga" sui dettagli articoli viene lasciato tale e quale è sul documento di origine.
Se questo parametro viene impostato a S invece, i programmi di evasione imposteranno tale flag prendendolo sempre dal tipo documento in cui si evade.
Se però sul tipo documento il campo "Stampa des.agg.articolo" è impostato a "Copio su nota sopra" o "Copio su Nota sotto", il flag verrà lasciato con lo stesso valore che aveva sul documento da evadere.

Parametro: StOraRitiro e StOraTrasporto
Gruppo: StFatture, Ddt
Programmi: Stampa fatture accompagnatorie e Ddt
Questo flag serve per impostare un valore di default sulle rispettive ore di ritiro merce e trasporto. A fianco al campo, sulla maschera dei dati di accompagnamento, c'è un pulsante per acquisire questi dati e mandare in stampa direttamente il ddt.

Parametro: StQtaSint
Gruppo: ProvvigSt
Valore default: S
Programmi: Stampa provvigioni
Nella stampa delle provvigioni in formato ridotto, se questo flag viene impostato a S, verrà stampato, per ogni fattura, il peso totale (memorizzato nel campo quantità sulla tabella provvigioni). Ha senso attivare questo flag per la stampa degli agenti le cui provvigioni sono calcolate a importo sul peso totale.

Parametro: StTotAttr
Gruppo: DDT , FattureAcc
Consente, al programma di stampa, di mandare in stampa, a fine Corpo, un elenco delle descrizioni degli attributi inseriti sull'anagrafica articoli, in una determinata classe (vedi parametro StDescAttr ). Tale elenco raggruppa gli attributi a parità di descrizione e unità di misura e riporta la quantità. (Es. Stampa riepilogo ADR)
Per stampare questo riepilogo è stata istituita una sottosezione particolare da inserire nel corpo dei filtri di ddt e fattura accompagnatoria (Il codice di tale sottosezione si può impostare nel parametro di personalizzazione: SezStaTotAttr , il default è AD)
Il titolo di questo riepilogo si può impostare in StTotAttrTit

Parametro: SezStaTotAttr
Gruppo: DDT , FattureAcc
Valore di default: AD
Sottosezione con cui stampare, nel corpo di ddt e fatt. Accompagnatorie il riepilogo descritto in StTotAttr (Es. Riepilogo ADR)
Se, nel valore del parametro, dopo la Sottosezione si mette |C|20 , si intende di voler utilizzare la sottosezione 20 in caso di mancanza nel filtro della sottosezione indicata. (Cioe’ pipe , C per dire che è una sottosezione del Corpo, pipe , 20 è la sottosezione da usare in alternativa)

Parametro: StTotAttrTit
Gruppo: DDT , FattureAcc
Valore: Si può impostare il titolo del riepilogo da stampare nel corpo di Ddt e fatture accompagnatorie.
Il default è: Riepilogo ADR

Parametro: TabFromCor
Gruppo: DDT , FattureAcc , Ordini , Preventivi , Acquisti
Valore: Join aggiuntive per decodifiche nel corpo documenti in Stampa
Esempio:
LEFT JOIN DdtTest ON FatDett.NumRifProv = DdtTest.NumRif AND FatDett.AnnoRifProv = DdtTest.Anno) LEFT JOIN OrdVenTest ON FatDett.NumRifProv = OrdVenTest.NumRif AND FatDett.AnnoRifProv = OrdVenTest.Anno)

Parametro: TabNo*
Gruppo: Fatture, FattureAcc
Si può impostare questo parametro per escludere, nella query di stampa, la lettura completa (con *) di tutti i campi delle tabelle M=Magazzino, B=Banche, I = Codici Iva , V = Vettori, C= CauTrasporti, T = Trasporti, R=Rese , A = Aspetto Beni qualora il programma vada in errore per 'Troppi campi'.
Il Valore del parametro potrà contenere l'elenco delle tabelle: Es.: M,B,I,V, ... per escluderle tutte, oppure solo qualcuna.
Verranno comunque letti i cambi necessari alla stampa come ad esempio la descrizione della banca o le aliquote iva degli articoli.

Parametri per la stampa delle scadenze in fatture
TestoScadTutte, SeparScad, TestoScadSing Gruppo: Tutti
Se si utilizzano nel filtro di stampa fatture le variabili: T_ScadTutte oppure T_Scad00Data, T_Scad00Importo, T_Scad00ImpStr per la stampa delle scadenze, si possono attivare i seguenti parametri per personalizzare eventuali scritte fisse a completamento di date e importi.
In assenza dei parametri, per ogni scadenza verrà stampata la data e l' importo.
Se il pagamento è di tipo tratta, verrà evidenziato separatamente l'importo della singola scadenza e il relativo bollo.

I codici che identificano i campi da stampare, da inserire nel valore del parametro, sono i seguenti:
§Data§ o §DataRid§ per data scadenza a seconda che si voglia la data completa o solo giorno/mese
§ImpScad§ - importo scadenza
§Simb§ - simbolo moneta
Se si utilizza la condizione di pagamento tratta e si addebitano i bolli, per avere una stampa dettagliata di questi ultimi si possono utilizzare:
§sctrat§ - importo bollo tratta (se 0 non viene stampato)
§sctrat0§ - importo bollo tratta (se 0 viene stampato 0)
§scnotr§ - importo scadenza senza bollo

Al fine di consentire di stampare l'elenco scadenze in modo diverso se la condizione di pagamento è tratta (evidenziando l'importo del bollo) è possibile utilizzare le sequenze:

  • §tri§ e §trf§
    il testo scritto tra queste viene sbiancato se la condizione di pagamento è diversa da tratta
  • §trn§ e §trno§
    il testo scritto tra queste viene sbiancato se la condizione di pagamento tratta
Se nel filtro è stato utilizzata la variabile T_ScadTutte per la stampa scadenze,
verrà utilizzato il parametro TestoScadTutte
In questo caso potrà essere valorizzato anche il parametro SeparScad dove si potrà indicare il/i caratteri da utilizzare per separare le varie scadenze.
Se inserendo il valore di SeparScad si preme Shift F2 poi si premono i tasti Ctrl e Invio e nel filtro si mettono più righe con T_ScadTutte con MultiRiga a S, le scadenze verranno stampate su righe diverse.

Se nel filtro sono state utilizzate le variabili T_Scad00Data, T_Scad00Importo, T_Scad00ImpStr per stampare le scadenze singolarmente, verrà utilizzato il parametro TestoScadSing
In questo caso, se si mette nel valore del parametro anche la stringa §Data§ o §DataRid§, nel filtro basterà mettere solo la riga per la stampa dell'importo (T_Scad00Importo, T_Scad00ImpStr) per ogni scadenza.

Esempi di valore da assegnare ai parametri TestoScadTutte o TestoScadSing:
Data: §DataRid§ Importo: §ImpScad§ €
Il programma stamperà: Data: gg/mm/aa Importo: xxxxx €
per ogni scadenza del documento

Se si prevede di stampare fatture nelle quali ci sia la cond.di pagamento tratte con addebito bolli:
Data: §DataRid§ Importo: §scnotr§ §tri§ Bollo: §sctrat§ §trf§
In questo modo SOLO se tratta stamperà: Bollo: xxx

Parametro: TotPagareSplit
Gruppo: StFatture
Default a S
Il totale a pagare stampato in fattura (T_TotPagare) , in presenza di Split Payment (Fattura agli enti pubblici) viene decrementato dell'importo dell'iva Se si imposta questo parametro con un valore diverso da S il totale a pagare non verrà decrementato.

Parametro: StMargOrizz
Gruppo: BroVen
Programma: Stampa margini fatture
Se impostato a S, nella maschera della stampa margini verrà impostata a Si la scelta 'St.quantità e val.unitario' che comporta la stampa aggiuntiva di tali valori, fatta su foglio orizzontale piuttosto che verticale.

Parametro: TotQtaEleArt
Gruppo: BroVen
Programma: Elenco articoli consegnati
Se impostato a S e si stampa 'solo quantità' e 'solo riepilogo articoli', verrà stampato in fondo il totale delle quantità.

Parametro: TraspVetSta
Gruppo: Vendite
Valore default: bianco
Programmi: Stampa Ddt e fatture accompagnatorie
Se si impostano, come valore del parametro, i codici, separati da una virgola,che nella tabella Tipo trasporto indicano il vettore, questo verrà stampato sul documento SOLO SE ha codice uguale a quelli scritti qui. Questo per far sì che, se il cliente ha un vettore in anagrafica ma una volta riceve la merce per posta, non venga scritto il vettore sul documento.

Parametro: UsaFlagPrezziOrd
Gruppo: Preventivi , Ordini , Acquisti
Valore default: No
Programmi: Stampa preventivi e ordini
Se impostato a S, le stampe Preventivi e Ordini stamperanno i prezzi e il totale in base a quanto stabilito dal campo: Prezzi in stampa sulla testata del documento. Se questo parametro non è settato, i prezzi verranno stampati sempre, se previsti dal filtro.

Parametro: UnireIndELoc
Gruppo: XML
Valore default: N
Programmi: Estrazione fatture formato XML
Se vale S o se l'ultimo carattere dell'indirizzo è uguale a quello inserito in questo parametro (ad es. _) nel file xml nell'indirizzo unisce il campo indirizzo alla località (default = "N" cioè non unire)
Ad esempio inserendo nel parametro il carattere _ se nell'anagrafica del clienti l'indirizzo contiene
Via Nome molto lungo _
e il campo località contiene
Frazione Vattelapesca
nel file XML nel campo indirizzo verrà messo:
Via Nome molto lungo Frazione Vattelapesca

Parametro: PragmaContoCli
Gruppo: Fatture
Valore default: bianco
Programmi: Scarico movimenti fatture AziendaPc per utilizzo in contabilità Pragma
E' il codice del conto contabile dei clienti C(12)

Parametri per provvigioni

Gruppo: ProvvigSt

Parametro: StSaldoPart
Valore default: N
Programmi: Stampa provvigioni
Nella stampa delle provvigioni in formato sintetico, se questo flag viene impostato a S e sono state gestite correttamente le partite, verrà stampato, per ogni fattura, il saldo della partita, se saldo 0 verrà scritto 'saldata'.

Parametro: StScontoCli
Valore default: N
Programmi: Stampa provvigioni
Nella stampa delle provvigioni in formato ridotto, se questo flag viene impostato a S, verrà stampato, per ogni fattura, lo sconto di testata.

Parametro: RidPercAgenti
Gruppo: Tutti
Valore default: -1
Programmi: Preventivi, Ordini, ddt, fatture (Calcolo % provvigioni)
Consente di attivare una riduzione della percentuale di provvigione in base allo sconto messo sulla riga articolo. Tale riduzione verrà letta dalle tabelle degli Sconti (articolo/cliente, cliente/gruppo articoli etc.) oppure dalla tabella % di abbattimento provvigioni per fasce di sconto, dove è possibile inserire varie fasce: Sconto A Partire Da e % di riduzione provvigione
Il numero impostato nel parametro indica il numero di decimali che deve avere la % risultante dalla riduzione.

Parametri per provvigioni in caso di Provvigioni sull'incassato

Gruppo: ProvvigSt

Parametri: ImpArrChiuso
Valore di default 1
Indica il delta di differenza tra importo pagato e totale fattura per considerare chiusa la fattura e liquidare le provvigioni all'agente.

Trattamento degli insoluti

Parametro: GioInsReg Valore di default: 0
giorni da aggiungere alla data di registrazione dell’insoluto per sapere se consideralo o no.
Per data registrazione dell'insoluto si intende la data in cui è fatta la registrazione dell'insoluto utilizzando una causale con flag insoluto.
Se vale -1 gli insoluti verranno ignorati
La registrazione di un insoluto viene considerata SOLO se la sua data di registrazione è precedente alla data di stampa.
Per fare in modo che vengano considerati anche quelli registrati dopo occorre creare il parametro di personalizzazione GioInsReg con valore negativo

Parametro: GioInsPag
giorni da aggiungere alla data di pagamento per fare il confronto con data di elaborazione. Valore di default: 0
La registrazione dell'incasso di un insoluto viene considerata SOLO se la sua data di registrazione è precedente o uguale alla data di stampa.
Per considerare una data maggiore creare il parametro con valore negativo


Pers. parametri preventivi, ordini

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Parametro: CampiStAggDec
 Gruppo: Preventivi - Ordini - Acquisti - Ddt - Fatture - FattureAcc
Valore default: bianco
Permette di aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa.
I campi possono iniziare con la virgola oppure no e vanno scritti mettendo: nome tabella punto "." nome campo es.: pianoconti.telefono
Se si mettono più campi, vanno separati da virgola.

Parametri per caricamento Ordini da file esterno
Gruppo: Ordini
Parametro: CarOrdGruppoDef
Codice del gruppo, esistente, da usare per creare nuovi conti/clienti nel caricamento ordini
Parametro: CarOrdMastroDef
Elenco dei codici dei mastri, esistenti, da usare per creare nuovi conti/clienti nel caricamento ordini separati da , (ES. 01,02)
Parametro: CarOrdOrdRic
Indica se tentare prima l'aggiornamento (A - default) o l'inserimento (I)
(solo per Pianoconti, se c’è il campo CodTrasc, 1' campo della riga contenete un codice che verrà cercato in CodTrascodifica, fa sempre prima l’aggiornamento)
Parametro: CarOrdContoDesSin
Nella creazione di codici pianoconti, se presente il campo CodTrasc e contiene un codice con più di 4 caratteri quindi troppo lungo per essere un codice conto, per costruire il conto prende i caratteri da destra (D - default) o da sinistra (S)
Parametro: CarOrdContoKeyBase
Carattere da usare per la costruzione del codice conto (conviene mettere sempre una lettera, in modo che se supererà 9999 poi ricomincia con questa)
Parametro: CarSpeseBan
Se vale S negli ordini carica e calcola le spese bancarie e anche i bolli.

Parametro: CauzAttNoSconti
 Gruppo: Articoli
 Valore default: Bianco
 Programmi: Inserimento Preventivi, Ordini, Ddt e Fatture (Scontrini)
Se viene impostato a S, i programmi di cui sopra, azzerano lo sconto totale nelle righe degli articoli che hanno il flag Cauzione a Si.
Nella stesse righe, viene inoltre messo a N il flag dello sconto pagamento.

Parametro: CercaListBase
 Gruppo: Tutti
 Valore default: N
 Programmi: Ordini, ddt, fatture (scontrini,caric. movimenti di magazzino)
Se viene impostato a S, i programmi se non trovano il prezzo di un articolo sul listino del documento, lo cercano sul listino base (quello indicato sulla tabella di Magazzino)

Parametro: CodIvaDef
 Gruppo: Acquisti - Ordini - Preventivi - Ddt - Fatture (Articoli)
 Valore default: bianco
 Programmi: Quelli specificati in Gruppo.
Permette di inserire un codice iva di default che verrà poi proposto in testata documento e in gestione articoli (Tale codice deve esistere nella tabella dei codici iva)

Parametro: CreaOrdAcq
Gruppo: EvasionePrev
Valore default: N
Questo flag consente di assegnare un valore di default alla scelta che a video, in fase di evasione di un preventivo in un ordine, chiede, se e in quali condizioni creare anche l'ordine di acquisto per gli articoli interessati. I valori possibili sono: T=per tutti gli articoli, S=solo per gli articoli in sottoscorta, E=solo per gli articoli esauriti.

Parametro: CreaNotaAcq
Gruppo: EvasionePrev
Valore default: S
Questo flag, se posto ad N (No), consente di non scrivere, nella nota di testata dell'ordine di acquisto generato durante l'evasione di un preventivo, la frase: generato da prev. xx del gg/m/aa.

Parametro: CopiaRifCli
 Gruppo: EvasionePrev
 Valore default: N
 Se impostato ad S consente di copiare, nell'evasione da preventivo ad ordine, il contenuto del campo: riferimento cliente del preventivo sul corrispondente dell'ordine .

Parametro: DescPersDet1 - DescPersDet2 - DescPersDet3 - DescPersDet4
Gruppo: Preventivi - Ordini - DDT - Fatture - Acquisti
Programmi: Gestione Preventivi, Ordini di Acquisto e di Vendita, ddt, fatture
Sono campi a descrizione libera che possono essere inseriti in ogni riga di dettaglio dei documenti suddetti e portati sui documenti di evasione.

Nella riga del parametro, in valore, ci va la descrizione con la quale il campo verrà visualizzato in gestione del documento (es. MATRICOLA). Nel passaggio da Ordine a Ddt o da Ddt a Fattura, vengono trasferiti anche questi campi.

Parametro: DescPersTest1 - DescPersTest2 - DescPersTest3
Gruppo: Preventivi - Ordini - DDT - Fatture - Acquisti
Programmi: Gestione Preventivi, Ordini di Acquisto e di Vendita, ddt, fatture
Sono campi a descrizione libera che possono essere inseriti nella testata dei documenti suddetti e portati sui documenti di evasione.

Nella riga del parametro, in valore, ci va la descrizione con la quale il campo verrà visualizzato in gestione del documento (es. ZONA). Nel passaggio da Ordine a Ddt o da Ddt a Fattura, si porta sul documento di evasione il contenuto che questi campi hanno sul primo dei documenti evasi.

Parametro: DescLivNotaSot
Gruppo: Ddt , StFatture, Ordini, Preventivi
Programmi: Stampa Ordini, Preventivi, Ddt, Fatture
Se viene impostato questo parametro con un carattere, questo consentirà di stampare sui documenti, nella nota sotto dell'articolo le descrizioni dei livelli (taglia/colore) separate da quel carattere. Viene tuttavia reso sempre disponibile il campo C_RigDesArtLiv che contiene Descrizione articolo + Descrizione livello 1 + Descrizione livello 2

Gruppo: Preventivi - Ordini - Ordini di Acquisto
Programmi: Gestione preventivi, ordini, ord.acquisto
Parametri per fissare una sequenza particolare di campi nella maschera dei dettagli dei documenti e nella visualizzazione dell'elenco dei dettagli.
Parametro: DettOrdIns
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di inserimento dei campi nel dettaglio documenti (valori dell'indice del controllo).
Valido SOLO in inserimento.
Ordinamento dei campi: se c’è un solo numero serve per dire che quello è il primo campo. Seguono gli altri in modo standard. Se si vuole un campo particolare per primo, poi il primo campo, si mette il particolare, poi il primo.
 Parametro: DettOrdInsTab
Sequenza di numeri, separati da 'virgola' (,) che indicano l' ordine di visualizzazione campi del dettaglio documenti (valori del tabindex corrente)
Parametro: DettOrdCol
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in gestione dettagli dei documenti.
Può contenere nomi di campi o anche espressioni
I nomi, separati da 'virgola' sono quelli delle variabili del database nelle tabelle OrdVenDett etc.
Colonne con nomi personalizzati in Preventivi, Ordini, Acquisti
grid testata: _Descrizione, ContoRicavo
grid dettaglio: _Descrizione, ContoRicavo, Val_Mon_Corr

Dopo il campo si può mettere:
§ seguito da un numero per indicare le larghezza della colonna,
^ seguito da un nome che sarà l’etichetta da dare alla colonna (solo per i campi aggiuntivi , NON per campi usati dal programma)
 (es. Qta§900,_Descrizione,Articolo,ValUnitario+valtotale as sommaImp §1000)
Parametro: DettOrdColTest
Nomi delle colonne da mostrare più a sinistra nella lista dei dettagli mostrati in testata.
Stessa sintassi del parametro precedente.
Se il parametro non c’è o è vuoto viene assunto = al precedente.
Se si vuole che venga lasciato l’ordinamento previsto dal programma, pur avendo usato il parametro precedente, si valorizzi uguale a “-“ (meno)

Parametro: Dettagliata
Gruppo: BroAcq
Programmi: Brogliaccio ordini di acquisto
Se impostato a S, nella maschera delle scelte di stampa, proporrà sempre la stampa Dettagliata piuttosto della Sintetica, con possibilità di variazione da parte dell'utente.

Parametro: DisabTermPrz
Gruppo: DDT - Fatture - Acquisti - Ordini - Preventivi
Programmi: Gestione DDT - Gestione Fatture - Scontrini
Valore: Lista terminali disabilitati per la gestione prezzi e sconti nei documenti DDT, Fatture etc. separati da punto e virgola ';'. Si accetta anche Pip* per indicare 'Tutti quelli che iniziano per Pip'
Occorre creare una riga per ogni programma in cui attivare la personalizzazione

Parametro: DisabTermVisPrz
Gruppo: DDT - Acquisti - Ordini - Preventivi
Valore: Lista terminali, separati da punto e virgola ';', per i quali non verranno visualizzati i prezzi e gli sconti in inserimento-variazione nei programmi specificati in Gruppo.
Occorre creare una riga per ogni programma in cui attivare la personalizzazione

Parametro: DivPezziConf
Gruppo: Articoli
Programmi: Preventivi, ordini acquisti e vendita, ddt e rispettive evasioni, fatture, scontrini
Valore: Il campo pezzi per confezione sugli articoli è intero. Per chi ha la necessità di gestirlo decimale, si può mettere in questo parametro il divisore (10, 100,1000). Nei programmi suddetti, il valore intero, letto sull'articolo verrà diviso per questo parametro.

Parametro: DoveStampoRigaDesc
Gruppo: Preventivi
Programmi: Gestione preventivi
Valore: nel campo può essere inserita una delle seguenti lettere:N , A, S, E . Il valore di default è A
Questo parametro serve a forzare, in fase di inserimento delle righe descrittive, il campo 'Dove stampo la nota': N = no stampa, A=solo su documento attuale, S=anche sul doc.di evasione, E=solo sul documento di evasione (vedere anche NotaSoSotAttEEva).

Parametro: DoveStampoSotto e/o DoveStampoSopra
Gruppo: Preventivi - Ordini - DDT
Programmi: Gestione preventivi, Ordini, DDT
Valore: nel campo può essere inserita una delle seguenti lettere:N , A, S, E . Il valore di default è A
Questo parametro serve a forzare, in fase di inserimento manuale della nota sopra o nota sotto dell'articolo (no di righe descrittive), il contenuto del campo 'Dove stampo la nota': N = no stampa, A=solo su documento attuale, S=anche sul doc.di evasione, E=solo sul documento di evasione (vedere anche NotaSoSotAttEEva)

Parametro: EvaLisCampiAggX (dove X può andare da 1 a 5)
Gruppo: Ordini (e/o Preventivi)
Valore: nome campo da aggiungere (obbligatorio), intestazione da dare alla colonna sul video, larghezza colonna e formato
Programma: Evasione Ordini e/o Preventivi
specifica la lista campi da aggiungere nella griglia che visualizza i dati degli articoli durante l'evasione di un documento.
L'ordine di visualizzazione è stabilito dal parametro: EvaOrdCampiCorpo
I parametri, nome campo, intestazione colonna, larghezza colonna e formato, scritti in Valore vanno separati da : e solo il primo, cioè il nome del campo, è obbligatorio
Esempi di contenuto del campo Valore:
In corrispondenza a EvaLisCampiAgg1: NotaSotto::3000
In corrispondenza a EvaLisCampiAgg2: Articoli.Barcode
In corrispondenza a EvaLisCampiAgg3: Articoli.PesoLordo:Pesoxx:1000
In corrispondenza a EvaLisCampiAgg4: Articoli.ArtUmVen:Um_Ven:500
In corrispondenza a EvaLisCampiAgg5: DataCons::900:dd/mm/yy

Parametro analogo per aggiungere campi alla griglia delle testate:
EvaLisCampiTeAggX
Esempio: GruppoCli & '-' & MastroCli & '-' & ContoCli:Codice:1000
o anche : (SELECT sum(OrdVenDett.Qta) FROM OrdVenTest as OT INNER JOIN OrdVenDett ON OT.Anno = OrdVenDett.Anno AND OT.NumRif = OrdVenDett.NumRif WHERE OT.Anno = OrdVenTest.Anno AND OT.NumRif = OrdVenTest.NumRif):SommaQta:1200:#,##0.00

Gruppo: Ordini (e/o Preventivi)
Parametro: EvaOrdCampiCorpo
Valore: Elenco delle prime colonne da mostrare in evasione ordini nella griglia del corpo
I valori da 1 a 11, o da 1 a 13 se vengono gestiti i livelli, si riferiscono ai campi standard, cioè quelli già visualizzati dal programma;
quelli da 101 in poi, a quelli aggiuntivi.
Esempio 101,103,3,104,5 dove 101 corrisponde al campo descritto nel parametro EvaLisCampiAgg1 , 103 al campo descritto nel parametro EvaLisCampiAgg3, 3 corrisponde alla terza colonna dell'elenco visualizzato dal programma iniziale (senza le personalizzazioni) che contiene il codice articolo, 104 al campo descritto nel parametro EvaLisCampiAgg4, 5 alla quinta colonna dell'elenco visualizzato dal programma iniziale (senza le personalizzazioni) che contiene la quantità ordinata.

Parametro: EvaOrdCampiTesta
Valore: Elenco delle prime colonne da mostrare in evasione ordini nella griglia delle Testate
Es. 26,27,3,4,5,6 dove 26 e 27 sono numero e data documento Ordine, diversamente i primi campi visualizzati sono numero e data riferimento

Parametro: EvaManLivGruppo
Gruppo: Ordini
Programmi: Evasione ordini con livelli (Taglia-colore)
Valore: Se impostato a S, nell'evasione dell'ordine, non vengono elencati i livelli di ogni dettaglio ma viene presentata solo la riga di dettaglio. In questo modo, impostando la quantità da evadere, essa verrà copiata su ogni livello di quel dettaglio. In mancanza di questo flag verranno elencati, in evasione, tutte le righe dei livelli presenti nell'ordine.

Parametro: FineCorpo
Gruppo: Ordini - Acquisti - Preventivi
Programmi: Stampe Ordini - Acquisti - Preventivi
Lista di sottosezioni del corpo documento da stampare alla fine della stampa dei dettagli.
Le varie sottosezioni dovranno essere separate da una virgola. (Es. M0,M1,M2 poi nel filtro, nel campo sottosezione delle righe interessate si dovrà mettere rispettivamente M0,M1 etc.)

Gruppo: Preventivi - Ordini - Acquisti
Programmi: Gestione preventivi, ordini, ddt, fatture
Parametri per fissare una sequenza particolare di campi in inserimento di un ddt (in caso di necessità, chiedere a Zucchetti sede di Ravenna i valori da assegnare)
Per quanto riguarda i dettagli vedere i parametri: DettOrdIns
Parametro: GestFoldIns
numero del folder da proporre ogni volta che si va in inserimento
Parametro: GestOrdIns
Elenco dei numeri dei campi da mettere in testa nell'ordinamento dei campi in inserimento (es. 50,60,70,80,960,1015)
Parametro: GestOrdInsTab
In alternativa al parametro precedente: elenco dei tabindex dei campi da mettere in testa nell'ordinamento dei campi in inserimento (Es. 230,231,5,52,53)

Parametro: GestTab
Gruppo: Ordini (e/o Preventivi e/o Acquisti)
Può assumere valore S (si) o N (no). Il valore di default è quello del parametro Gestab con gruppo: Livelli
Tale valore può essere variato, impostando questo parametro, per singola funzione, in modo che il programma si comporti in modo diverso da funzione a funzione.

Parametro: InizioAvvisoCliente
Gruppo: Note
Programmi: Gestione Ordini, DDT, Fatture
Se impostato con qualche carattere (es. $$), i programmi suddetti stamperanno un avviso sulla maschera del cliente se la nota in anagrafica cliente/fornitore inizia con questi caratteri.
Se nel valore si scrive Tutti , l'avviso verrà evidenziato ogni volta che si richiama un cliente con le note compilate.

Parametro: LettArtDaFile
Gruppo: acquisti, preventivi, ddt, ordini, fatture (scontrini, carmov)
Programmi: caricamento movimenti di magazzino, ordini di acquisto e vendita, preventivi, ddt e fatture
Se impostato a S verrà presentata, nei dettagli, una icona che consente di caricare da file gli articoli piuttosto che digitarli. (Vedere impostazione parametri in Caricamento dettagli documenti da file)

Parametro: ListAcqDaAgg
Gruppo: Acquisti
Programma: Evasione ordini di acquisto
Attivando questo parametro con il codice di un listino di acquisto, si consente di aggiornare tale listino in corrispondenza di ogni articolo evaso.

Parametro: MagaNoGiac
Gruppo: Tutti
Programmi: Ordini acquisto- vendita, Preventivi (Ddt e fatture, Caric.movimenti di magazzino)
In fase di inserimento degli articoli sul documento, vengono visualizzate giacenza e disponibilità dell'articolo stesso sul magazzino del documento. A fianco, se diverse, vengono riportate rispettivamente giacenza e disponibilità dell'articolo su tutti i magazzini codificati.
E' possibile escludere dal calcolo alcuni magazzini, attivando questo parametro con i codici dei magazzini (separati da virgola) che dovranno essere esclusi. Per escludere il magazzino del documento, si deve mettere *.

Parametro: NoDescPrezziIvati
Gruppo: OrdiniPre e StFatture
Valore default: N
Programmi: Stampa ordini e preventivi e stampa fatture
Il programma stampa automaticamente nel corpo degli ordini e dei preventivi la scritta: I prezzi si intendono al netto dell'iva (se listino non ivato) o I prezzi sono comprensivi di iva (se listino ivato).
Per eliminare la stampa di questa frase, occorre impostare a S il parametro di cui sopra.

Parametro: NoRaeeAutom
Gruppo: Magazzino
Programmi: Ordini, Ddt e Fatture
Può essere impostato con l'elenco delle causali di magazzino per le quali, anche se si movimenta un articolo che ha un 'articolo raee' collegato, non verrà generata la riga del Raee. Le causali dovranno essere separate da , 'virgola'.
La causale che si controlla è quella collegata al tipo documento.

Parametro: NotaLinguaDove
Gruppo: Vendite
Programmi: Gestione Preventivi, Ordini, Ddt, Fatture
Questo parametro consente di utilizzare la tabella delle descrizioni in lingua associate all'articolo per inserire delle descrizioni aggiuntive dell'articolo stesso
Se valorizzato, viene attivato, sulle righe 'articolo' dei documenti, il tasto funzione F11 (F5 sugli Ordini). Premendo questo tasto, se sono state compilate per l'articolo della riga, una o più descrizioni in lingua, in particolare la descrizione lunga in lingua, esse verranno visualizzate e si da la possibilità di sceglierne una. Questa verrà copiata nella "descrizione sotto" della riga (salvo diversa indicazione nel parametro) e verrà stampata secondo quanto specificato nel parametro.
Il parametro può assumere i valori: A (stampa solo su doc.attuale), S (attuale e in doc. evasione), E (solo in doc di evasione), N (non stampare)
Per copiare la descrizione nella 'nota sopra', occorre aggiungere al valore del parametro una S
(es.: AS copia in nota sopra)

Parametro: NotaSoSotAttEEva
Gruppo: EvasioneOrd - EvasionePrev
Programmi: Evasione preventivi e ordini
Se impostato a S fa si che il flag che indica che le righe descrittive (e note sopra e sotto) vanno stampate anche sul documento di evasione, mantenga lo stesso significato anche sul documento di destinazione.

Esempio: se non è attivo questo parametro e su una riga di un ordine c'è il flag di stampare la nota sul documento attuale e su quello di evasione, quando l'ordine viene evaso in DDt tale flag viene scritto sul ddt con 'stampo solo su documento attuale'. In questo modo quella nota non verrà mai stampata su fattura.

Viceversa, attivando questo parametro, sul ddt verrà impostato il flag a 'stampo su doc. attuale e doc. di evasione'.

Parametri:
OrdStampaDettByN (N=1-9)
OrdStampaDettDescN (N=1-9)
OrdStampaDettDef
Gruppo: Ddt / StFatture / Preventivi / Ordini / Acquisti
L'attivazione di questi parametri consente di ottenere la stampa del corpo di preventivi, ordini, ddt e fatture ordinata in modo diverso da quello che è il documento consultabile a video (nel quale gli articoli sono ordinati secondo la sequenza di inserimento).

L'introduzione di ordinamenti diversi dallo standard può creare problema in presenza di righe descrittive (note) o articoli manuali. Le note, in particolare, potrebbero finire tutte all'inizio o in fondo a seconda del tipo di ordinamento.

Nel valore del parametro OrdStampaDettByN dove N è un numero da 1 a 9 ci va l'elenco dei campi di ordinamento.
Es. se si vuole ordinare per descrizione articolo e quantità si metterà:
Articoli.descrizione,§dett§.qta dove §dett§ sta per DdtDett o FatDett o OrdAcqDett etc a seconda del gruppo scritto sulla riga.

Se si utilizzano Taglia e Colore, si può ordinare per livello: §liv§.Livello1, §liv§.Livello2 (§liv§ sta per DdtDettLiv o FatDettLiv etc)
oppure per Articolo e livello : §dett§.Articolo, §liv§.Livello1, §liv§.Livello2

Possono essere presenti più modalità di ordinamento in modo da poter scegliere, al momento della stampa, come ordinare. Ad ogni riga creata con il parametro: OrdStampaDettByN , ne deve corrispondere una con stesso gruppo e parametro: OrdStampaDettDescN dove, in valore, si deve mettere la descrizione dell'ordinamento, descrizione che verrà visualizzata nella maschera di stampa in modo da consentire la scelta dell'ordinamento. Nel box che elenca, al momento della stampa, le varie possibilità di ordinamento attivate, al primo posto si trova l'ordinamento standard cioè così come

Il parametro OrdStampaDettDef infine, dovrà contenere un numero da 1 o 9 che corrisponderà all'ordinamento proposto come default nella maschera di stampa (sarà uno di quelli definiti con i parametri precedenti) Nel box che elenca, al momento della stampa, le varie possibilità di ordinamento attivate, al primo posto si trova l'ordinamento standard, per avere questo come default occorre impostare il parametro OrdStampaDettDef a 0.

Per non avere in stampa la lista dei possibili ordinamenti, pur avendo definito un ordinamento personalizzato che si vuole utilizzare sempre, basta dare a questo parametro un valore negativo (es. -1)

Parametro: PartitaEnse (Person. per un cliente)
Gruppo: Ordini - DDT - Fatture - Acquisti - Preventivi
Valore default: S
Programmi: Gestione Preventivi, Ordini di Vendita e di acquisto, Ddt, Fatture Evasioni - Stampa Quantità Evasa - Stampa Quantità Inevasa
Gestisce nei dettagli il contenuto del campo 'tempo di consegna articolo' e visualizza con descrizione articolo le classi e attributi per trattamento etc.

Parametro: PrezAcqOCostoUlt
Gruppo: Acquisti
Programmi: Inserimento ordini di acquisto
Se la causale di magazzino prevede che il prezzo della riga articolo sia letto dal Costo Ultimo:
se il parametro è impostato a 0 , il programma propone, se valorizzati, dalla tabella Articolo/Fornitore il prezzo di acquisto e il relativo sconto
se è impostato a 1 , il programma propone, dalla tabella Articolo/Fornitore il prezzo di acquisto SOLO se è valorizzato il relativo sconto
se è impostato a 2 , il programma propone, dalla tabella Articolo/Fornitore il costo ultimo

Parametro: PreXmlGen , OrdXmlGen
Gruppo: EvasionePrev , EvasioneOrd
Valore default: SSN
Programma: Evasione preventivi
Valore da assegnare ai campi presenti sulla maschera delle righe descrittive del corpo del preventivo ai fini della corretta compilazione del file XML della fattura elettronica
I rispettivi campi ai quali assegnare un valore S o N sono: 'In xml fattura elettronica' 'su carta' 'altri dati articolo'

Parametro: QtaDef
Gruppo: Ordini - DDT - Fatture - Magazzino - Acquisti - Preventivi (Scontrini)
Valore default: 0
Programmi: Gestione DDT - Gestione Fatture - Gestione movimenti di magazzino -Gestione Ordini di Acquisto e di Vendita - Gestione Preventivi (Scontrini)
Quantità proposta di default in ogni riga di dettaglio.

Parametro: QtaDaDimen (per legnami)
Gruppo: Vendite
Programmi: Gestione ordini, ddt, fatture
Se impostato a S, nella maschera di inserimento di un articolo nel dettaglio dei documenti, vengono chiesti i campi lunghezza, larghezza, altezza, impostati con i valori di default che sono stati messi nella gestione articoli e la label del campo colli viene cambiata in numero pezzi.
Le misure, di default, si intendono espresse in millimetri per ottenere poi la quantità espressa in metri o metri quadri o metri cubi.
Si può utilizzare un'altra unità di misura, attivando il parametro:
QtaDimenRapp. Esso andrà valorizzato a 100 se le misure verranno date in centimetri, a 10 se in decimetri e così via (il suo valore di defaut è 1000).
In pratica il valore X inserito in questo parametro servirà per il calcolo delle quantità nell'operazione:
Qta=(colli*lunghezza) / X (se una dimensione)
Qta=(colli*lunghezza*larghezza) / X * X (per due dimensioni)
etc.
Devono inoltre essere impostati i parametri:
QtaDaDimUML, QtaDaDimUMQ, QtaDaDimUMC
Il cui valore deve contenere rispettivamente : l'unità di misura degli articoli che si vendono a metri lineari (es. ml), quella per i metri quadri (Es.mq) e quella per i metri cubi (es. mc)
Se le unità di misura, per ogni tipo, sono più di una basta separarle da ; (punto e virgola)
Sull'articolo dovrà essere inserita un'unità di misura tra quelle messe nei parametri e le dimensioni, espresse in millimetri o in base al valore assegnato al parametro QtaDimenRapp.
(Per l'eventuale variazione delle descrizioni dei campi lunghezza, larghezza e altezza, vedere i parametri di personalizzazione: LabAlt, LabLarg e LabLung)

In inserimento movimenti di magazzino o nelle vendite, una volta richiamato l'articolo, l'utente inserirà il numero di pezzi, e il programma calcolerà la quantità facendo riferimento all'unità di misura dell'articolo (metro lineare, metro quadrato o metro cubo).
Nella 'descrizione sotto' dell'articolo verrà inoltre creata una riga con: nr.pezzi x lunghezza x altezza x larghezza da stampare sui documenti.

Per ottenere una riga descrittiva più comprensibile, si possono attivare i seguenti parametri (tutti con gruppo Vendite):
NotaDimensioni, NotaDimensioniUML, NotaDimensioniUMQ, NotaDimensioniUMC
Nel campo valore di ciascuno di questi parametri, si può mettere una parte fissa e una parte variabile preceduta e seguita dal carattere §
Se si vuol mettere solo una descrizione iniziale, o una per tutte le dimensioni, basta attivare NotaDimensioni,
altrimenti il contenuto del parametro NotaDimensioniUML, verrà stampato in corrispondenza ad articoli con l'unità di misura scritta in QtaDaDimUML cioè a una sola dimensione (es. metri lineari)
il contenuto del parametro NotaDimensioniUMQ, verrà stampato in corrispondenza ad articoli con l'unità di misura scritta in QtaDaDimUMQ cioè a due dimensioni (es. metri quadri)
il contenuto del parametro NotaDimensioniUMC, verrà stampato in corrispondenza ad articoli con l'unità di misura scritta in QtaDaDimUMC cioè a una sola dimensione (es. metri cubi)
Esempio:
NotaDimensioniValore: Pezzi §Colli§
Nella nota sotto verrà creata la scritta: Pezzi nn (con nn=numero pezzi digitati a video)
NotaDimensioniUML Valore: Pezzi §Colli§ x Lungh. §UM§: §Lun§
Nella nota sotto verrà creata la scritta: Pezzi nn x Lungh. M. zz (con M.= unità di misura e zz=lunghezza dell'articolo)
NotaDimensioniUMQ Valore: Pezzi §Colli§ x Lungh. §Lun§ e Lar §Lar§
Nella nota sotto verrà creata la scritta: Pezzi nn x Lungh. zz e Lar rr (con zz=lunghezza e rr larghezza dell'articolo)
NotaDimensioniUMC Valore:Pezzi §Colli§ con dim: §Lun§ x §Lar§ x §Alt§
Nella nota sotto verrà creata la scritta: Pezzi nn con dim: zz x rr x dd (con zz=lunghezza , rr larghezza e dd altezza dell'articolo)

Parametro: QtaSaldo
Gruppo: StOrdini
Programmi: Stampa statistiche Ordini
Indica se escludere o no nella stampa delle quantità ordinate, le eventuali quantità evase a saldo.
Valore di default: N - Se impostato a S per una riga Evasa completamente, in corrispondenza al totale ordinato verrà riportata la quantità evasa effettivamente e non l'ordinata per cui mancherà quella, eventualmente, evasa a saldo.

Parametro: RidPercAgenti
Gruppo: Tutti
Valore default: -1
Programmi: Preventivi, Ordini, ddt, fatture
Consente di attivare una riduzione della percentuale di provvigione in base allo sconto messo sulla riga articolo. Tale riduzione verrà letta dalle tabelle degli Sconti (articolo/cliente, cliente/gruppo articoli etc.) oppure dalla tabella % di abbattimento provvigioni per fasce di sconto, dove è possibile inserire varie fasce: Sconto A Partire Da e % di riduzione provvigione
Il numero impostato nel parametro indica il numero di decimali che deve avere la % risultante dalla riduzione.

Parametro: RigDescrEva
Gruppo: Ordini
Programmi: Evasione ordini
Se viene inserita una riga con questo parametro, il programma di evasione di un ordine in DDT crea, per ogni riga evasa, una riga descrittiva che indica lo stato della riga dell'ordine.
Il valore da assegnare al parametro si compone di 3 'parti', separate da un ;

  1. indica dove va generata la riga descrittiva: P = prima della riga articolo, D = dopo la riga articolo
  2. frase da scrivere in caso di evasione totale
  3. frase da scrivere in caso di evasione parziale

Esempio: P;Evasione totale;Evasione parziale

Parametro: ScontoPagInDet
Gruppo: Preventivi - Ordini (Ddt - Fatture)
Se impostato deve contenere l'elenco dei tipi documento, separati da virgola (,), per i quali, lo sconto pagamento, va sommato agli sconti delle singole righe, piuttosto che essere calcolato sull'imponibile/i alla fine della fattura.
Durante l'inserimento di un documento il campo 'Sconto pag.su dett' della testata, verrà impostato a Si se il tipo documento è nell'elenco.
Per le fatture elettroniche E' OBBLIGATORIO che lo sconto pagamento sia applicato sulle singole righe.

Parametro: ScoZona
Gruppo: Ordini - DDT - Fatture - Acquisti - Preventivi
Valore default: N
Programmi: Gestione Zone - Gestione Fatture - Gestione Ordini di Acquisto - Gestione Ordini di Vendita - Gestione Preventivi
Se si imposta il valore a S, viene abilitato un campo sconto a importo sull'archivio zone in modo tale da poter applicare, sui documenti, tale sconto sugli articoli a seconda della zona di appartenenza del cliente.

Parametro: SegnDispNeg
Gruppo: Ordini
Valore default: N
Programmi: Gestione Ordini di Vendita
Se impostato, verrà data una segnalazione quando la Disponibilità dell'articolo è negativa: con valore M verrà controllata la disponibilità sul magazzino corrente, con valore T, su tutti i magazzini.

Parametro: StaCodArt
Gruppo: StaQuEva
Valore default: N
Se impostato a S, in Stampa Quantità Evase verrà stampato, oltre alla descrizione dell'articolo, anche il codice.

Parametro: StaNumDoc
Gruppo: Acquisti (Preventivi, Ordini)
Valore default: N
Se impostato a S, le rispettive stampe di Statistiche (Ordini di acquisto, di Vendita e Preventivi), stamperanno numero e data Documento invece di Riferimento.

Parametro: StaTotMerce
Gruppo: Preventivi, Ordini, Acquisti
Valore default: N
Programmi: Stampa preventivi e ordini di acquisto e vendita
Questo flag può essere impostato a S per stampare nel corpo del documento il totale merce invece del totale documento (comprensivo di iva). Per stampare l'importo nel corpo occorre che il totale merce (T_TotMerce) non compaia nelle righe del piede del filtro

Parametro: StDesLunDaDoc
Gruppo: EvasioneOrd (EvasioneDdt)
Programmi: Evasione ordini (evasione ddt)
Normalmente, in sede di evasione di un documento, il flag "Dove stampo descrizione lunga" sui dettagli articoli viene lasciato tale e quale è sul documento di origine.
Se questo parametro viene impostato a S invece, i programmi di evasione imposteranno tale flag prendendolo sempre dal tipo documento in cui si evade.
Se però sul tipo documento il campo "Stampa des.agg.articolo" è impostato a "Copio su nota sopra" o "Copio su Nota sotto", il flag verrà lasciato con lo stesso valore che aveva sul documento da evadere.

Parametro: StFlagGiacDisp
Gruppo: Ordini
Programmi: Stampa ordini
Se vale S il programma calcola la giacenza e la disponibilità degli articoli dell'ordine e compila, con un *, le seguenti variabili che potranno essere utilizzate nel filtro, come segnalazione.

  • C_DispNeg posto ad * se la disponibilità dell'articolo in stampa è negativa
  • C_DispSottoscorta posto ad * se la disponibilità dell'articolo in stampa è inferiore alla sottoscorta
  • C_GiacNeg posto ad * se la giacenza dell'articolo in stampa è negativa
  • C_GiacSottoscorta posto ad * se la giacenza dell'articolo in stampa è inferiore alla sottoscorta

N.B. Per il calcolo della sottoscorta si considera la "Scorta minima" scritta sull'anagrafica articolo.

Parametro: StRigaRifCli
Gruppo: EvasioneOrd, EvasionePre
Programma: Evasione ordini e preventivi
Definisce il valore da dare al campo che indica dove stampare la riga descrittiva:
Rif. Cliente: xxxxxx
che viene creata in evasione ordini se previsto dall'anagrafica cliente.
Default: A - Solo su doc.attuale
Può assumere i valori: N -Mai ; S - anche su documento di evasione ; E - Solo su doc.di evasione

Parametro: StRigaRifOrd
Gruppo: EvasioneOrd, EvasionePre
Programma: Evasione ordini e preventivi
Definisce il valore da dare al campo che indica dove stampare la riga descrittiva: Rif. Ordine xx del xx/xx/xxxx che viene creata in evasione ordini se previsto dall'anagrafica cliente.
Default: A - Solo su doc.attuale
Può assumere i valori: N -Mai ; S - anche su documento di evasione ; E - Solo su doc.di evasione

Parametro: StRigaRifLib
 Gruppo: EvasioneOrd, EvasionePre
Programma: Evasione ordini e preventivi
Definisce il valore da dare al campo che indica dove stampare la riga con i campi liberi della testata (definiti in Dati generali Azienda - Tab. Fatturazione)
Default: A - Solo su doc.attuale
Può assumere i valori: N -Mai ; S - anche su documento di evasione ; E - Solo su doc.di evasione

Parametro: UsaFlagPrezziOrd
Gruppo: Preventivi , Ordini , Acquisti
Valore default: No
Programmi: Stampa preventivi e ordini
Se impostato a S, le stampe Preventivi e Ordini stamperanno i prezzi e il totale in base a quanto stabilito dal campo: Prezzi in stampa sulla testata del documento. Se questo parametro non è settato, i prezzi verranno stampati sempre, se previsti dal filtro.

NOTA riguardante i parametri DettOrdColTest, DettOrdCol:
Colonne con nomi personalizzati

Preventivi
grid testata: _Descrizione, ContoRicavo
grid dettaglio: _Descrizione, ContoRicavo, Val_Mon_Corr

Ordini
grid testata: _Descrizione, ContoRicavo
grid dettaglio: _Descrizione, ContoRicavo, Val_Mon_Corr

Aggiunti parametri di personalizzazione che se impostato a S mette i dati di riferimento dell'ordine nel DDT o nella fattura di evasione nella nota sopra delle righe di dettaglio evase e non crea una riga di dettaglio.

Per ordini:

Parametro: DdtRifOrdNota
Gruppo: EvasioneOrd

Parametro: FatRifOrdNota
 Gruppo: EvasioneOrd

Per i preventivi

Parametro: DdtRifOrdNota
Gruppo: EvasionePre

Parametro: FatRifOrdNota
 Gruppo: EvasionePre


Pers. parametri scontrino

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Vedi anche Registratore di cassa (parametri e installazione)

Parametro: CampiStAggDec
 Gruppo: Scontrini (Ddt - Fatture - FattureAcc)
Valore default: bianco
permette di aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa.
I campi possono iniziare con la virgola oppure no e vanno scritti mettendo: nome tabella punto "." nome campo es.: pianoconti.telefono
Se si mettono più campi, vanno separati da virgola.

Parametro: CauzAttNoSconti
Gruppo: Articoli
Valore default: Bianco
Programmi: Scontrini (Inserimento Preventivi, Ordini, Ddt e Fatture)
Se viene impostato a S, i programmi di cui sopra, azzerano lo sconto totale nelle righe degli articoli che hanno il flag Cauzione a Si.
Nella stesse righe, viene inoltre messo a N il flag dello sconto pagamento.

Parametro: CercaListBase
 Gruppo: Tutti
Valore default: N
 Programmi: Scontrini
Se viene impostato a S, i programmi se non trovano il prezzo di un articolo sul listino del documento, lo cercano sul listino base (quello indicato sulla tabella di Magazzino)

Parametri: CodPrezInizio CodPrezLung CodPrezCarContr
Gruppo: Scontrini
Programmi: Emissione scontrino
Sono stati introdotti per l'interpretazione di un codice a barre proveniente ad esempio da una bilancia elettronica, che contiene sia il codice articolo sia il prezzo

  • CodPrezInizio: deve contenere i caratteri iniziali dei codici a barre che devono essere 'interpretati' come provenienti da bilancia e quindi contenenti codice articolo e prezzo. Se ci sono più prefissi da riconoscere, questi devono essere tutti della stessa lunghezza e separati da virgola.
  • CodPrezLung: lunghezza fissa dei codici a barre riconosciuti
  • CodPrezCarContr: se vale S indica che nei codici a barre del tipo di cui sopra, prima e dopo il prezzo c'è un carattere di controllo

Parametro: DivPezziConf
Gruppo: Articoli
Programmi: Scontrini
Valore: Il campo pezzi per confezione sugli articoli è intero. Per chi ha la necessità di gestirlo decimale, si può mettere in questo parametro il divisore (10, 100,1000). Nei programmi suddetti, il valore intero, letto sull'articolo verrà diviso per questo parametro.

Parametro: EstrRepDescr
Gruppo: Scontrini
Valido per RCH modello Swing. Va impostato a S se si vuole che quando si stampano scontrini per reparto nella descrizione metta la descrizione del reparto. Ovviamente bisogna compilare adeguatamente la descrizione del reparto tenendo presente che lo spazio a disposizione sugli scontrini e' all'incirca 10 caratteri.

Parametro: FineCorpo
Gruppo: Scontrini
Programmi: Scontrini (Ordini - Acquisti - Preventivi)
Lista di sottosezioni del corpo documento da stampare alla fine della stampa dei dettagli.
Le varie sottosezioni dovranno essere separate da una virgola. (Es. M0,M1,M2 poi nel filtro, nel campo sottosezione delle righe interessate si dovrà mettere rispettivamente M0,M1 etc.)

Parametro: LettArtDaFile
Gruppo: Scontrini
Programmi: caricamento movimenti di magazzino, ordini di acquisto e vendita, preventivi, ddt e fatture
Se impostato a S verrà presentata, nei dettagli, una icona che consente di caricare da file gli articoli piuttosto che digitarli. (Vedere impostazione parametri in Caricamento dettagli documenti da file)

Parametro: MostraAltraMoneta
Gruppo: Scontrini
Valore default: S
Se vale N il programma non consente, in uno scontrino in euro, di inserire l'importo pagato in Lire per fare il calcolo del resto.

Parametro: MostraCostoUltimo
 Gruppo: Scontrini
Valore: Se vale S, abilita, durante l'inserimento o variazione di una riga articolo, sul campo prezzo unitario il tasto F4 per mostrare costo ultimo dell'articolo.

Parametro: NoAbbuono
Gruppo: Scontrini
Se impostato ad S, non mostra nella maschera finale dello scontrino la richiesta dell'importo di Abbuono.

Parametro: NumDecValUni
Gruppo: Scontrini
Arrotondamento nel calcolo prezzo unitario scontato
ATTENZIONE: valido SOLO SE si stampa il totale scontrino e non il dettaglio articoli
Se non c'è o vale -1, nel calcolo del prezzo unitario utilizza il numero di decimali 'di gestione', se vale -2 non arrotonda, se c'è un numero N arrotonda a N decimali (consigliato 5).
L'utilizzo di N decimali nel calcolo fa si che, per importi unitari molto piccoli e quantità grandi, il valore totale scontato (calcolato moltiplicando il valore unitario scontato (e arrotondato) per la quantità) sia effettivamente quello reale.

Parametro: InvPIva
Gruppo: Scontrini
Emissione scontrino su registratore di cassa modello: KABEL (Winner) , Sarema e altri con protocollo XON XOFF che lo gestiscono.
Valore di default N o bianco. Se si crea il parametro , consente di mostrare, sulla maschera finale dello scontrino, il box 'Invio dati fiscali' con spuntata la scelta:
 'Non inviare' se parametro = "D"
 'Invia Partita Iva' se parametro = "A"
 'Invia Codice Fiscale' se parametro = "C"

Parametro: PrezziScontatiIvati
Gruppo: Scontrini
Valore default: S
Riguarda il prezzo degli articoli eventualmente impostato nell'archivio Sconti (cliente-articolo) quando viene utilizzato in emissione scontrini. Il programma degli scontrini lavora con prezzo ivato ma legge il prezzo dagli sconti (se c'è) così com'è.
Per far sì che il programma, leggendo un prezzo dagli sconti, lo presenti in gestione scontrino dopo averlo ivato, occorre impostare ad N questo parametro.

Parametro: QtaDef
 Gruppo: Scontrini
Valore default: 0
Quantità proposta di default in ogni riga di dettaglio

Parametro: RaggrArt
Gruppo: Scontrini
Valore di default: S
Stampa su modulo cartaceo dello scontrino. Se nel corpo scontrino ci sono due articoli consecutivi con lo stesso codice, in stampa vengono raggruppati. Per evitare questo occorre inserire questo parametro con valore N (o comunque diverso da S)

Parametro: RegPrzTotale
Gruppo: Scontrini
Aggiunto flag per registratore Olivetti e Indesit (Serena) al quale non possono essere mandate, in stampa sullo scontrino, le quantità:
Se vale "S" il programma manda al registratore di cassa l'importo totale al posto dell'importo unitario e la quantità viene posta a 1
Per il registratore Nixdorf (Butterfly) è obbligatorio se si utilizzano quantità decimali in quanto può stampare solo quantità intere.

Parametro: RegButterfly
Gruppo: Scontrini
Valore: S
Per abilitare la stampa dello scontrino sul registratore Nixdorf Batterfly

Parametro: RegSerena
Gruppo: Scontrini
Valore: S per abilitare la stampa dello scontrino sul registratore INDESIT Ditron Serena

Parametro: StAbil
Gruppo: Scontrini
Valore default: N
Se impostato a S viene abilitata la richiesta di stampa su stampante dello scontrino al termine dell'immissione

Parametro: StLanciaEsegui
Gruppo: Scontrini
Valore default: S
Viene preso in considerazione solo se è a S il parametro precedente. Se non è impostato o è impostato a S, al termine della stampa su stampante dello scontrino viene lanciata automaticamente la stampa sul registratore di cassa, viceversa se si imposta a N questo flag il programma aspetta un'ulteriore conferma per chiudere lo scontrino e mandarlo al registratore.

Parametro: StClieInBianco
Gruppo: Scontrini
Valore default: N
Viene preso in considerazione solo se è a S il parametro che consente la stampa scontrini su stampante (StAbil). Se impostato a S non stampa i dati del cliente quando il codice cliente corrisponde a quello del cliente corrispettivo.

Parametro: TabFromDec
Gruppo: Scontrini
Serve per aggiungere delle tabelle per decodificare campi mancanti

Parametri: VirgolaVirtuale
Gruppo: Scontrini
Valore default: S

  • Se vale N, i prezzi verranno passati al registratore di cassa con la virgola. Normalmente invece verranno passati interi e le ultime due cifre indicheranno la parte decimale. In pratica la virgola è virtuale.
  • Deve valere P con reg. Indesit-Serena, per fare in modo che il programma invii gli importi usando il . (punto) come separatore dei decimali e non metta nessuna virgola.

Parametri: VirgolaVirtQta
Gruppo: Scontrini
Valore default: N
In presenza di registratore Indesit-Serena deve valere P.
Introdotto per questo tipo di registratore, per fare in modo che il programma invii la quantità usando il . (punto) come separatore dei decimali e non la virgola.


Pers. parametri distinta base

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Parametro: ChiediMagScarico
Gruppo: DiBa
Valore default: N
Programmi: Caricamento movimenti di magazzino

Se vale S, in corrispondenza a un movimento di carico di un prodotto finito, viene chiesto da quale magazzino scaricare gli articoli componenti, altrimenti si utilizza lo stesso magazzino del movimento di origine.

Parametro: DettDibaAutom
Gruppo: MagaMovProd
Programmi: Caricamento movimenti di produzione


Pers. Parametri matricole

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Parametro: MatrGest
Gruppo: Tutti
Valore: Se vale S abilita gestione matricole in caricamento movimenti di magazzino, DDT e fatture.

Parametro: MatrUnica
Gruppo: Tutti
Valore: default N o vuoto, Altri valori: S o C
Con questo parametro si decide se la matricola deve essere univoca o meno, per ogni articolo:

  • S (Sì) e bloccante
  • N (No)
  • C si accetta anche una matricola doppia ma verrà data una segnalazione (poi sul file da caricare posso attribuire un valore particolare solo per quel caricamento)

Parametro: MatrSegnTipOpe
Gruppo: Tutti
Valore: Se viene impostato a S, il programma darà una segnalazione (nel momento in cui si inserisce una matricola) se il tipo movimento (carico/scarico) non è compatibile con l'ultimo movimento di quella matricola

Parametro: LettMatrDaFile
Gruppo: Carmov, Ddt, Fatture
Valore: S per abilitare il pulsante per lettura matricole da file (da un lettore ottico). In questo caso nei rispettivi programmi, sulla maschera dell'inserimento dettagli, comparirà l'icona: (Q) Lett.matricole da file

Parametro: MatrLungMin
Gruppo: Tutti
Valore: Questo parametro viene utilizzato dal momento che si leggono le matricole da un file (da un lettore ottico) per inserirle sulla registrazione.
Dovrà essere impostata la lunghezza minima per riconoscere se il codice che si sta leggendo è una matricola. Se viene letto un codice di lunghezza inferiore viene interpretato come codice barre

Parametro: MatrCausaliRientro
Gruppo: Tutti
Valore: elenco di causali che verranno riconosciute come rientro merce guasta o resa (nel caso di più causali, dovranno essere separate da virgola)

Parametro: MatrGuastoNoScar
Gruppo: Tutti
Valore: Se vale S (default) dopo il rientro per guasto non si può avere uno scarico

Parametro: MatrCausaliNoMovCar
Gruppo: Tutti
Valore: Elenco causali che non movimentano magazzino ma considerati carico per le matricole (per caricare le matricole sugli articoli in giacenza al momento della partenza del programma) Tali causali devono avere No MagFisc , Carico/Scarico= Niente e movimentare una quantità aggiuntiva (da impostare prima nei parametri di magazzino)

Parametri per stampa matricole in ddt / fatture

Gruppo: Ddt, Fatture, FattureAcc
Parametro: StDescMatr
Valore: Scritta fissa da mettere nella stampa prima dell'el. Matricole (se è compilato cerca di stampare le matricole) La stringa può avere \013\010 per andare a capo (Es. Matricole:\013\010)
Stampa la matricola nella Nota sotto e anche se la nota sotto è da non stampare, le matricole le stampa sempre.

Gruppo: Ddt, Fatture, FattureAcc
Parametro: StMatrSepar
Valore: Caratteri da mettere tra una matricola e l'altra nella stampa. Il campo accetta e riconosce lo \ seguito da 3 caratteri numerici come caratteri di controllo.
(es. \013\010 che fa un ritorno a capo , oppure spazio-spazio)


Pers.Parametri Tracciabilità (Lotti)

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Vedi anche Tracciabilità

E' possibile impostare il parametro ChiaveGenSempre per visualizzare un pulsante, a fianco al campo di richiesta del lotto, premendo il quale si otterrà l'impostazione automatica del codice lotto, calcolato come numero progressivo dei lotti per fornitore e articolo. Per far si che tale numero non dipenda dall'articolo si deve impostare il parametro ChiavePerArt con un valore diverso da N. Gli altri due parametri descritti in seguito: ChiaveBase, ChiaveBaseLun servono a dare un formato particolare al codice lotto.

Gruppo: Rintraccia
Parametro: ChiaveGenSempre
Dovrà essere impostato a S per avere la possibilità di generare il codice lotto in automatico anche nei movimenti di carico merce da fornitore (dove in generale il lotto dovrebbe essere quello del fornitore).

In assenza di questo parametro, si consente la generazione automatica del lotto solo nei movimenti di carico da produzione.

Parametro: ChiavePerArt
Il codice lotto generato in automatico è un progressivo per fornitore/articolo.
Per far sì che esso sia un progressivo indipendente dall'articolo, occorre impostare questo parametro a N.

Parametro: ChiaveBase
Prefisso da usare come base per calcolo automatico codice lotto. I caratteri impostati in questo parametro, verranno proposti come caratteri fissi iniziali di ogni nuovo lotto generato.

Parametro: ChiaveBaseLun
Lunghezza della parte numerica del codice lotto creato in automatico. Ad esempio, se il parametro vale 4, la parte numerica del codice lotto sarà: 0001 , 0002 etc.
Se viene impostato a -1, non verrà visualizzato il pulsante che consente la creazione automatica del codice lotto.

Altri parametri che si possono attivare per la tracciabilità:

Gruppo: Rintraccia
Parametro: DefParDaClassi
Elementi separati da 'virgola' (,) che indica da quali classi dell'articolo estrarre eventualmente categoria, trattamento, confezione e specie quando si crea un nuovo lotto: 1° contiene il valore della categoria, 2° del trattamento, 3° della confezione, 4° della specie. (Le classi dell'articolo si gestiscono in: Tabelle di magazzino , Classi e attributi articoli. Nel caso che un attributo debba essere trasferito sul lotto, come categoria o trattamento etc., occorrerà crearlo anche in tali tabelle con la gestione Tabelle decodifiche varie)

Gruppo: Rintraccia
Parametro: HlpLottoForn
Se vale S, nella maschera di richiesta del lotto (in movimenti di magazzino, ddt, fatture) viene presentato un pulsante [Dupl.], a sinistra del codice fornitore, che consente, una volta inserito il codice del fornitore, di aprire una maschera con l'elenco dei lotti di quel fornitore, indipendentemente dall'articolo.

Selezionando uno di questi lotti, verrà attribuito il lotto scelto all'articolo della riga, e quindi creato se ancora non esiste. In questo modo si consente di scaricare un articolo derivato dalla lavorazione o trasformazione di un altro (con lotto) attribuendo ad esso il lotto dell'articolo originale (Utilizzato per la lavorazione delle carni)

Gruppo: Rintraccia
Parametro: LottiCausaliNoMovCar
Dovrà essere posto uguale al codice della causale da utilizzare per caricare i lotti in giacenza al momento dell'attivazione della procedura, con il caricamento movimenti di magazzino.

Per non alterare la giacenza effettiva dell'articolo occorre creare questa causale in modo particolare. In Parametri di magazzino, abilitare una quantità aggiuntiva con descrizione: Lotto iniziale

La causale dovrà avere le seguenti caratteristiche: Non va in inventario/giornale, Carico/Scarico: Niente , Segno: positivo, Provenienza: fornitore, Destinazione: magazzino, Quantità aggiuntive: lotto iniziale

Gruppo: Rintraccia
Parametro: ModVisLotti
Indica la modalità di visualizzazione della maschera lotti in movimenti di magazzino, ddt, fatture.

Può assumere i valori: P, A, R, I

  • Pulsantesi entra nella gestione lotti con video vuoto e la ricerca è consentita con il pulsante di aiuto del codice lotto. La quantità viene impostata inizialmente uguale alla quantità del dettaglio.
  • Automaticovengono generate automaticamente le righe di lotto con la quantità già impostata. L'ordine con il quale si fanno uscire le quantità è stabilito dal parametro VisLottiOrd (data scadenza + quantità disponibile o viceversa)
  • R Listaviene visualizzata la lista per la scelta dei possibili lotti da inserire, con evidenza della quantità disponibile, e si consente di digitare la quantità desiderata in corrispondenza ad ogni lotto.
  • I Lista, come nel caso precedente, ma con le quantità già preimpostate con possibilità di selezionare le righe desiderate.

Gruppo: Rintraccia
Parametro: QtaDivBloc
Controllo quantità inserite: S=bloccante
Se bloccante, quando la somma delle quantità dei lotti è diversa dalla quantità della riga articolo, viene data una segnalazione e l'utente può decidere di confermare o meno la registrazione.

Gruppo: Rintraccia
Parametro: QtaVer
Indica se il programma deve controllare la disponibilità della quantità dei lotti in inserimento movimenti di magazzino, ddt e fatture. 1 (valore di default) controlla sia al momento del carico che allo scarico 2 solo in scarico, 3 solo in carico (nel caso modifichi la quantità ed abbia già fatto scarichi, quindi in carico non viene fatto se è in inserimento), 0 non esegue controlli.

Gruppo: Rintraccia
Parametro: VisLottiOrd
Valore: D = data scadenza, data movimento e quantità disponibile , Q = quantità disponibile, data scadenza e data movimento
Indica come si vuole l'ordinamento dei lotti dell'articolo in uso, in fase di scarico.

Gruppo: Rintraccia
Parametro: VisLottiScad
Indica se, in una registrazione di scarico di magazzino, nella ricerca dei lotti da scaricare, il programma deve presentare anche i lotti scaduti oppure no. Il valore di default è Si.

Gruppo: Rintraccia
Parametro: VerDispQtaProd
Valore default: N
Programmi: Caricamento movimenti di produzione
Se viene impostato a S, verrà controllata la disponibilità dei lotti dei componenti e il movimento non verrà trasferito il movimento sui movimenti di magazzino, confermando la produzione, se non c'è disponibilità.

I seguenti parametri interessano la stampa dei lotti in Ddt e Fatture

Gruppo: Ddt , Fatture, FattureAcc
Parametro: StampaLotti
Se vale N non viene stampato il lotto
Se vale S, i lotti di ogni riga di documento, vengono stampati sotto ad ogni articolo, come un elenco (vedi parametri successivi).

Se vale L dopo la riga articolo verrà stampata una riga per ogni lotto con evidenziate anche le quantità, utilizzando la sezione L (da inserire nel filtro).

Gruppo: Ddt , Fatture, FattureAcc
Parametri: StDescLotto e StLottoSepar
Se il parametro StampaLotti vale S, si può impostare in StDescLotto la descrizione che precederà, sulla riga del corpo del documento, il codice lotto e la quantità. La sintassi deve essere:

es. Lotto: §lt§ quantità: §qta§ dove §lt§ indica che in quel punto dovrà essere stampato il codice lotto e §qta§ , la quantità.

Ogni lotto verrà poi separato, in stampa, dal successivo, dai caratteri indicati nel parametro: StLottoSepar (Es. - vengono accettati anche gli spazi)

Gruppo: Ddt , Fatture, FattureAcc
Parametro: StLottoDet

  • Se il parametro vale S, il lotto verrà stampato SEMPRE nel dettaglio anche se ci sono più lotti.
    Occorre, in questo caso, che sia presente sulla riga uno spazio per il lotto (o i lotti).
    Mettere nel filtro di stampa una riga con la stampa della variabile: C_Lotto, sulla riga del corpo.
    Il programma mette in questa variabile i codici dei lotti separati dalla stringa indicata dal parametro di personalizzazione StLottoSepar che dovrà quindi essere impostato.
  • Se vale M (Mai) il lotto non verrà mai stampato nel dettaglio ma sempre sotto (o nella nota sotto o con la sottosezione del lotto) a seconda di come è impostato il flag: StampaLotti
  • Se vale U stampa il lotto nel dettaglio solo se ce n'è uno solo e c'è nel filtro la stampa di C_Lotto, se invece c'è più di un codice lotto, li stampa nella riga sotto con il formato indicato da StampaLotti


RILEGGI PARAMETRI DI PERSONALIZZAZIONE

Questa funzione consente di rileggere i parametri delle tabelle di base delle procedure nell'eventualità che siano state cambiate dopo che il terminale è entrato nel menu. Tali tabelle vengono lette all'entrata nel menu poi tenute in memoria per cui una loro variazione viene considerata solo se si esce e rientra nella procedura o se si esegue questa funzione.


PARAMETRI PER IL LANCIO DEL MENU

L'installazione della procedura predispone un file AziWin.ini comune nella cartella di installazione dei programmi (\aziwin) e uno particolare per ogni computer, nella cartella aziwin\main (o windows o winnt) del disco C.

Il menu generale della procedura, quando va in esecuzione, va a cercare i parametri di cui ha bisogno, prima nel file AziWin.ini del computer che l'ha lanciato, poi in quello generale.
Per variare l'aspetto grafico vedere: aziwin.ini.

E' possibile lanciare il menu con un parametro particolare, comando da mettere in Proprietà (destinazione) dell'icona che lancia il menu.

…\menu.exe /I:[pathIni]

Il parametro /I (è una i maiuscola!) consente di lanciare il menu e di utilizzare un particolare .ini personalizzato, diverso da quello che c'è nella directory Windows (o Winnt) del terminale.

In [pathIni] indicare il percorso e il nome dell'ini desiderato (Es. c:\prove\AziTerm.ini)

Questa opzione può essere utile per poter lavorare sullo stesso computer utilizzando ambienti diversi (es. programmi e archivi di diverse versioni) oppure per poter utilizzare un computer, sul quale è stata fatta un'installazione in locale, anche come terminale di rete.
In quest'ultimo caso si consiglia di installare le procedure localmente.
Una volta configurato il computer in modo da vedere il disco di rete su cui sono installati i programmi con la stessa lettera degli altri client, basterà

  • copiare su questo client l'aziwin.ini di un altro client (metterlo in una cartella a piacere e rinominarlo ad esempio AziTerm.ini)
  • cambiare, dentro questo .ini, il nome del terminale (parametro NomeTerm)
  • creare sul desktop un collegamento al menu.exe che è sul server e specificare il percorso dell'ini da utilizzare.

(di seguito si riporta un esempio di quest'ultimo caso, il .INI generale è quello comune dell'installazione in rete mentre alla partenza deve essere lanciato un .INI creato ad hoc perché su quel computer l'aziwin.ini della cartella aziwin punterebbe all'installazione locale e quindi anche agli archivi in locale)

Esempio di un AziTerm.INI

[Parametri Generali]
OrdIniDBase=F:\programmi\AziWin\AziWin.ini   (1)
NumIni=0
#DirImmagini=\programmi\AziWin\\Immagini\    (2)

[Connessioni]
NomeDB=F:\programmi\aziwin\database\Ditta.mdb (3)
Connect=
Exec_option=0
[Menu]
Terminale=Pippo
(nome del terminale)
Parametri=
CodiceAzie=Ditta01        (4)

(1) è il nome del .ini di riferimento
(2) è la cartella che contiene i loghi per i filtri di stampa se diversa da quella indicata in F:\programmi\AziWin\AziWin.ini va specificata qui altrimenti qui si può omettere
(3) E' il nome del DB di lavoro
(4) Viene compilato automaticamente una volta che si entra in un'azienda, è il contenuto del campo Azienda della Tabella del menu che contiene l'elenco delle aziende gestite

Qualsiasi altro parametro previsto nell'aziwin.ini e che si voglia personalizzare per il terminale in oggetto, va scritto in questo .INI (o, in una installazione standard, nell'INI del computer)

Tutti i parametri che non vengono specificati nel .INI locale (del computer) verranno letti dal .INI comune cioè quello indicato nel parametro: OrdIniDBase visto sopra.

Nelle proprietà dell'icona che lancia il menu si possono utilizzare anche altri parametri che rispondono a esigenze particolari.

…\menu.exe /chiudi consente di eseguire il menu, che setterà la password per tutti gli utenti e si chiuderà automaticamente (per installazioni multiutente, lancio automatico del menu sul server per settare la password giornalmente) (veniva utilizzato con SO precedenti a Windows XP)

…\menu.exe /prg:N(N=1, 2, ..) consente di mandare in esecuzione direttamente uno dei programmi di utilità che si lanciano premendo i tasti Shift Ctrl Alt L dal menu (Ad esempio se N=1, viene eseguito in automatico il programma di Aggiornamento dei database).

Tramite l'attivazione di opportuni parametri di personalizzazione è possibile eseguire il compattamento degli archivi dell'azienda corrente, appena si entra nel menu
(vedi parametro CompattaAvvioTerm)


PARAMETRI DEL FILE AZIWIN.INI

Il file Aziwin.ini viene letto dal menu al lancio della procedura e contiene i parametri per alla configurazione dell'ambiente di lavoro.
E' possibile utilizzare un .INI particolare, diverso da quello standard creato dall'installazione utilizzando il parametro /I nell'icona del lancio del menu, vedi parametri per il lancio del menu.

Tale file viene creato automaticamente dall'installazione con i parametri di default nella directory in cui vengono installati i programmi e può essere personalizzato successivamente dall'utente con tutta una serie di parametri.

Al momento dell'installazione server/monoutente della procedura AziWin, vengono creati in automatico 2 file AziWin.ini:

  • uno nella cartella che contiene l'installazione dei programmi
    (es. c:\aziwin o c:\sira\aziwin o c:\programmi\aziwin)
  • l'altro nella cartella c:\aziwin\main c:\sira\aziwin\main del computer stesso
    (o in windows / winnt per installazioni precedenti al luglio 2008) .

Allo stesso modo, l'installazione di ogni client, crea un aziwin.ini locale nella cartella c:\aziwin\main o c:\sira\aziwin\main del computer stesso
(o in windows / winnt per installazioni precedenti al luglio 2008)
che, a sua volta, fa riferimento all'aziwin del server.

Per i parametri fondamentali e casi particolari di .INI, vedere Parametri per il lancio del menu

  • Descrizione di alcuni parametri generali
  • Modificare il colore dello sfondo dei campi
  • Modificare i margini di una stampa
  • Modificare, su una particolare stampante, margine sinistro e alto in stampe con filtri (fatture, ordini, ddt)
  • Modificare i font di stampa
  • Modificare font e allineamenti in stampa di campi Memo
  • Personalizzazione menu (menu a tendina etc.)
  • Personalizzazione della maschera ABOUT del menu
  • Segnalazioni acustiche
  • Memorizzare le immagini degli articoli di magazzino
  • Registratore di cassa
  • Stampa fatture su Pdf
  • Stampa Pdf con Pdf995
  • Stampa Pdf con PdfCreator
  • Invio fatture per email
  • Per modificare la risoluzione del video
  • Liste - posizionamento su una riga e scroll
  • Percorso per ricerca DLL aggiornate
  • Per abilitare la lettura dall'esterno delle righe di dettaglio dei documenti
  • Percorso in cui si trovano i testi collegati alle anagrafiche Clienti e Fornitori, alle registrazioni di Prima Nota e testi da stampare al termine di un Ddt
  • Definire il primo campo su cui va il cursore in inserimento clienti e fornitori (ClientiPrimo)
  • Ridimensionamento della maschera del dettaglio dei documenti (Ordini , Ddt, Fatture)

Descrizione di alcuni parametri generali

Nella sezione [Menu]:

- Il parametro AttLetPar indica i secondi di attesa per sincronizzare una fase di lettura con una, precedente di scrittura. E' una temporizzazione per evitare che venga fatta la lettura prima che i dati siano stati scritti fisicamente sul disco.
Il valore impostato di default è 3.

- Il parametro Dominio=Nome_Dominio da la possibilità di gestire le login degli utenti con cui si è fatto l'accesso a windows (solo se si usa un server con dominio). Se è impostato questo parametro, ed è stato creata in aziwin (con gestione utenti) un utente con una login uguale ad una con cui si accede al computer all'accensione, il programma, in entrata in aziwin, controlla che la login di accesso sia di quel dominio e sia nella lista delle login abilitate da aziwin e non verrà più chiesta in aziwin né login , né password.

- Il parametro Uscita=PrgDaEseguire (percorso completo) consente di eseguire un programma all'uscita del menu.
Come default esegue sempre FineAziWin.bat (se lo trova nella cartella dove si trova il Menu.exe) dove si possono mettere le istruzioni volute.
Scopo immediato: fare il LOGOUT da un terminale collegato in terminal server

Nella sezione [Base]
Tutte le funzioni che prevedono la preparazione di file di testo (Riba, F24 etc.) o l'importazione di file, utilizzano come cartella di appoggio la cartella Database, cioè la stessa che contiene gli archivi.
E' tuttavia possibile, in fase di elaborazione, personalizzare, cioè indicare, per ciascuna funzione, in quale cartella scrivere (o leggere) i file in modo tale che, ripetendo lo scarico dallo stesso terminale, verrà proposta la destinazione scelta nell'elaborazione precedente.
Nel percorso è obbligatorio indicare anche il drive
DirCarica - indica la cartella in cui leggere i file contenenti i dati da caricare nei Caricamenti Tabelle da altre procedure.
DirRiBa - indica la cartella in cui viene scaricato il file delle Riba
(es. DirRiBa=F:\AZIWIN\DATABASE\Riba )
DirImmagini - indica la cartella che contiene i file delle immagini utilizzate dai filtri di stampa documenti (loghi), delle immagini dei modelli (F24, Comunicazione iva annuale)
DirPdf - indica la cartella in cui memorizzare i file derivati dalle stampe documenti in pdf
Per differenziare le cartelle dove memorizzare i file (es. cartelle diverse per fatture , ddt , scontrini) si dovrà mettere questo parametro nelle rispettive sezioni [staFATSFAT] - [StaDDTsDdt] - [ScontrinX] indicando in ciascuna una cartella diversa (le sezioni si possono creare nell'ini condiviso, oppure si può aggiungere la riga DirPdf= .... nelle sezioni degli INI di ogni terminale dove viene memorizzato il filtro da utilizzare

DirIvaTelematicaAnn - indica la cartella in cui viene scaricato il file delle Comunicazione iva annuale
DirF24Telematica - indica la cartella in cui viene scaricato il file degli F24
DirBlackList - indica la cartella in cui viene scaricato il file per la Comunicazione telematica delle BlackList
DirCorriTelem - indica la cartella in cui viene scaricato il file per l'invio telematico dei corrispettivi
DirFE - indica la cartella in cui memorizzare i file xml delle fatture elettroniche Attive eventualmente scaricati dall'HUB
DirFEScar - indica la cartella in cui memorizzare i file xml delle fatture elettroniche Passive scaricati dall'HUB
DirImgEmail - indica la cartella che contiene le immagini da inserire nei testi delle email da inviare con la funzione di Invio email o con le Stampe Fatture etc.

Per modificare il colore dello sfondo dei campi

Il parametro ColBackGotFocus, della sezione [Menu], indica il colore dello sfondo del campo su cui è posizionato il cursore.
Il valore scritto a fianco è un numero esadecimale, il default è &H0080FF80& che corrisponde al colore azzurro. Se si vuole cambiare il colore occorre variare tale valore.
E' possibile inoltre creare due parametri di personalizzazione:
ColBackForm per modificare il Colore da usare come sfondo delle maschere
ColBackMenu per modificare il Colore da usare come sfondo dei comandi del menù

L'intervallo di valori valido per un normale colore RGB è l'intervallo compreso tra 0 e 16.777.215 (&HFFFFFF) [Per esempio verrà indicato &HKKXXYYZZ].

Il byte più alto (KK) di un numero compreso in questo intervallo è uguale a 0; i 3 byte più bassi (XXYYZZ), determinano rispettivamente la quantità di blu (XX), verde(YY) e rosso(ZZ). Ciascuno di questi componenti è rappresentato da un numero compreso tra 0 e 255 (&HFF). Se il byte più alto (KK) non è uguale a 0, vengono utilizzati i colori del sistema definiti dalle impostazioni del Pannello di controllo e dalle costanti elencate nella libreria degli oggetti di Visual Basic (VB) nel Visualizzatore oggetti.

Per modificare i margini di una stampa

I parametri modificabili sono: MrAlt (margine alto), MrBas (margine basso), MrSin (margine sinistro), MrDes (margine destro), i numeri da mettere indicano dei millimetri (per separare i decimali, occorre mettere il . e non la ,)
Esempio:
[CogeStaSbiV]
MrDes=-30
E' possibile inoltre modificare i margini per le stampe fatte su una stampante particolare (di tipo Laser o a getto), questo si ottiene inserendo, sempre in aziwin.ini un paragrafo con il nome stampante
Per le stampe con filtro (Ordini, Ddt, Fatture ..) i parametri sono:
ModMrSin e ModMrDes e, se si devono impostare per tutte le stampanti, si possono mettere direttamente nel paragrafo [Opzioni stampa]
(vedi Stampe - Modifiche)

Per modificare i margini su una particolare stampante

Occorre creare nel file AziWin.ini (quello del terminale o il principale) una sezione con il nome della stampante (es.\\PS10DBE9\Printer1):
[nome_stampante] es: [PdfCreator]
MrSin=x
MrAlt=y

Per i margini di stampe con filtri (fatture, ddt etc.)
ModMrSin=x
ModMrAlt=y

Dove x e y possono assumere valori positivi o negativi.

Il nome stampante può essere letto nell'elenco delle stampanti visualizzato premendo, in un qualsiasi programma di stampa, il pulsante selezione destinazione stampa. Vedi Stampe su modulo

Per modificare i font di stampa

(vedi Stampe - Modifiche)

Per modificare font e allineamenti in stampa di campi Memo

(vedi Gestione font di stampa)

Per personalizzazione delle modalità di visualizzazione ed utilizzo del menu

Al fine variare l'aspetto grafico del menu, per ottenere ad esempio il menu a tendina o visualizzare alcune icone per l'accesso veloce ai programmi, si può utilizzare la funzione Configurazione menu accessibile dal menu premendo il tasti Ctrl Alt Shift L.
Di seguito vengono elencati i parametri che le varie configurazioni scriveranno sull'aziwin.ini (Sezione Menu) con relativo significato.

  • Abilitazione del Menu a tendina
    NB: L'introduzione di questo parametro rallenterà la visualizzazione del menu
    menutend= XYZ dove i caratteri x y z possono assumere valore S (Si) o N (No)
    X (maschera principale) posto a S, abilita il menu a tendina nella parte alta della maschera del menu.
    Y (nella tray bar) posto a S, abilita la visualizzazione dell'icona del menu nella Tray bar (cioè in basso a destra)
    Z (menu a scomparsa in alto) posto a S, consente, se ci si posiziona con il mouse nella primissima riga in alto del video, di aprire una maschera con un menu a tendina che sarà disponibile qualunque sia il programma corrente anche diverso da aziendapc (purché il menu sia in esecuzione).
    Ad esempio inserendo la riga:
    menutend=SSN
    abilita il menu a tendina nella primissima riga in alto del video
    visualizza l'icona del menu nella Tray bar (cioè in basso a destra)
    ma non apre la maschera per il menu a tendina che si sovrappone al menu standard, se ci si posiziona col mouse in alto sul video.
  • Modifica aspetto grafico del menu
         MenuVisible=S o N
    Se posto a N non verranno mostrati i pulsanti per l'accesso ai programmi (se il parametro menutend=sns e si sposta il mouse in alto si potranno scegliere ugualmente i programmi).
    E' possibile, in questo caso, mettere sullo sfondo un'immagine le cui caratteristiche dovranno essere definite dai seguenti parametri:
    ImgLogoDove
    Può assumere valori da 0 a 5
    0 non visualizza l'immagine
    1 l'immagine viene centrata a dimensioni naturali
    2 viene ingrandita al massimo ma in proporzione
    3 come sopra ma usa tutto lo spazio disponibile
    4 occupa tutto deformando l'immagine
    5 ripete l'immagine affiancandole sopra e sotto
    ImgLogoQuale
    di default contiene 1.
    E' disponibile l' immagine: logo AziendaPc (1)
    Se si vuole collegare un'altra immagine occorre indicare in questo parametro il percorso.
    PicBaseVis
    Può assumere valore S o N.
    Dice se la parte dove c'è la data, ditta etc. deve essere sempre visibile o no (compare quando il mouse si posiziona nella parte bassa della maschera del menu).
    Di default è Si, se c'è il menu visibile altrimenti è No
    Esempio:
    MenuVisible=N
    #PicBaseVis = "S"
    ImgLogoDove = 3
    ImgLogoQuale = f:\dati2\Aziwin\Immagini\aziendapc.jpg
  • Altri parametri
    SizeForm
    Il valore di default è T = a tutto schermo, in alternativa può assumere i valori:
    S     a fine sessione salva le coordinate
    F le coordinate vengono lette sempre dall' INI
    Seguono le coordinate:
    FormLeft
    FormTop
    FormWidth e FormHeight
    se queste ultime sono negativi entrambi, il menu si aprirà a tutto schermo
    Esempio:
    SizeForm=F
    FormLeft=75
    FormTop=285
    FormWidth=-14955
    FormHeight=-10155
  • Visualizzazione di icone per accesso veloce ai programmi (Abilitazione della barra dei comandi personalizzata)
    Consente di visualizzare in alto sul video una riga di icone per l'accesso rapido alle funzioni di uso più comune.
    La configurazione inserirà in automatico nell'aziwin.ini, sez. menu, i parametri:
    ComDescN (N=1-20)
    Se valorizzato dovrà contenere la "descrizione" che verrà scritta sotto l'icona.
    Se contiene la scritta fissa "separa" crea un separatore fra i pulsanti
    ComToolTipN contiene il testo da mostrare nel ToolTiptext
    ComRiferN contiene il programma da lanciare e deve essere compilato obbligatoriamente se nel parametro ComDescN corrispondente non c'è scritto "separa".
    E' composto da codice del menu seguito da frame, riga e colonna separati da § (ricavarli da Gestione menu)
    ComImgN Serve per indicare il numero dell'icona da mostrare. Sono disponibili 33 icone di default.
    Se non contiene un numero, deve contenere il percorso del file da utilizzare come immagine (per inserire una immagine diversa da quelle fornite).
    ComCarN Indica il tasto da usare per lanciare il programma corrispondente utilizzando la tastiera. Di default per attivare il comando si usa Ctrl + quel carattere
    Se non si vuole utilizzare Ctrl, si può attivare il parametro
    ComUsaCtrl: se vale C (default), si usa il Ctrl
    se vale N si usa Alt (è consigliato se si usano come tasti i numeri da 0 a 9)
    qualsiasi altro valore richiede la pressione contemporanea dei tasti Ctrl e Alt (oltre a quello scelto)
    Es.
    ComUsaCtrl=N
    ComDesc1="Mastri"
    ComToolTip1="(0) ToolTip1"
    ComRifer1="anagra§1§1§2"
    ComImg1=1
    ComCar1=0

Personalizzazione della maschera ABOUT del menu

Si può personalizzare la scritta nei campi 'assistenza' e 'email' sostituendo i nostri riferimenti con riferimenti del concessionario. Le nuove scritte personalizzate vanno inserite nel file ConcAzi.ini che dovrà essere creato nella directory Windows o nella directory corrente (programmi\aziwin o sira\aziwin).
Il contenuto di tale file dovrà avere la sintassi come nell'esempio che segue:
[Concessionario]
NumTel=Tel. 0544 408509
EMail=info@aziendapc.it

Al fine di consentire di far apparire il nome del concessionario nelle informazioni che vengono visualizzate in basso a sinistra sul menu principale dove compaiono le scritte: Realizzato da .. etc., è stata aggiunta la gestione delle seguenti righe :
Distribuito=
DistrRigaN= con N=1,..,5
Se il programma del menu incontra una di queste righe verranno scritte in sostituzione alle righe standard:
Realizzato da …..

Esempio:
Distribuito=Da me (se c'è questo parametro, la scritta compare nell' About, nella riga Distribuito da:)
DistrRiga1="Distributo da"
DistrRiga2="Nome distributore"
DistrRiga3="Via Roma xx"
DistrRiga4="48100 Ravenna"
DistrRiga5="Tel. 0544 408509"
DistrBmp="F:\dati\vb5\aziwin\Azienda.bmp" (in questa riga va l'eventuale file bmp con il logo da visualizzare)

Gli apici possono esserci o no.

Segnalazioni acustiche

Per ottenere in corrispondenza di alcuni messaggi di segnalazione, una segnalazione acustica prodotta dalla scheda audio, si può attivare nell'AziWin.ini della singola stazione di lavoro (o nel principale) il parametro:
BeepCome
Tale parametro si attiva inserendo nella sezione
[Parametri generali] dell'ini la riga:
BeepCome=NN;XX
Dove NN è la frequenza del suono e XX la durata. Occorre fare dei tentativi per valutare i numeri da mettere (Es. BeepCome=2000;20)

Per ottenere un effetto sonoro diverso (dal win 2000 in avanti) si può mettere un segno meno davanti: BeepCome=-2000;20
oppure si può scegliere una musica a piacere (cioè un file .wav) dalla directory C:\windows\media\
e scrivere: BeepCome=c:\windows\media\nome.wav;20

Per memorizzare le immagini degli articoli di magazzino

Se viene abilitata la gestione delle immagini con il parametro di personalizzazione: Articoli Immagine, si può inserire, nella sezione Base, il parametro DirImgArt=percorso completo della directory che le contiene (in mancanza di questo parametro, le immagini verranno cercate nella directory indicata in DirImmagini)

Registratore di cassa

Se il computer è collegato a un registratore di cassa (o deve comunque emettere scontrini), occorre aggiungere la seguente sezione nel file aziwin.ini
[RegCassa]
DriveInvia=F: (o C:)
DirInvia=\RCassa\
Per stabilire in quale AziWin.ini aggiungere i parametri si rimanda al paragrafo "Elenco possibili configurazioni".

Stampa documenti su Pdf

Nella maschera di Stampa dei documenti (preventivi, ordini, ddt e fatture) vengono visualizzati due flag che riguardano la stampa su pdf: nome file pdf in automatico e unico file per tutte le fatture.
Per settare il loro valore di default si possono introdurre i due parametri seguenti in:
[Opzioni Stampa] o ['Nome_Stampa']
PdfNomeAutom=S
PdfUno=S
Il parametro inserito qui è prioritario rispetto all' eventuale parametro di personalizzazione: PdfNomeAutom

Altro parametro da settare è DirPdf che va inserito nella sezione [Base] e indica la cartella in cui memorizzare i file derivati dalle stampe documenti in pdf (Es. DirPdf=c:\FatturePdf)

Stampa Pdf con Pdf995

Per utilizzarlo occorre inserire nell' aziwin.ini il paragrafo:
[StampaPdf]
UsaPdf995=S
Pdf995IniFile=C:\Programmi\pdf995\res\pdf995.ini
Pdf995SyncFile=C:\Documents and Settings\All Users\Dati applicazioni\pdf995\pdfsync.ini

Questi ultimi 2 sono opzionali e servono se si installa il PDF995 in directory diverse dalle standard che prende in automatico e che sono quelle scritte qui
Se si sceglie di utilizzare Pdf995 e durante la sua installazione è stato lasciato alla stampante il nome di default (PDF995) , in stampa fatture, quando si spunta il campo 'Nome file automatico per pdf', non servirà fare la scelta stampante perché questa verrà automaticamente selezionata.

Si ricorda che il software Pdf995 è shareware.

Stampa su Pdf con PdfCreator

Ogni stampa può essere fatta su pdf e inviata via email. Per impostare i parametri necessari occorre andare in un qualsiasi programma di stampa e, dalla maschera, 'Seleziona destinazione stampa', poi 'Par.Ini pdf/email' impostare e salvare.
In particolare occorre inserire nell' aziwin.ini il paragrafo:
[StampaPdf]
UsaPdfCreator=S
Se si sceglie di utilizzare PdfCreator e durante la sua installazione è stato lasciato alla stampante il nome di default (PDFCreator) , in stampa fatture, quando si spunta il campo 'Nome file automatico per pdf', non servirà fare la scelta stampante perché questa verrà automaticamente selezionata.

Invio documenti per email

Nelle maschere di stampa, dentro il pulsante 'Selezione destinazione stampa' , premendo il pulsante 'Parametri INI Pdf Email' si accede alla configurazione. Nella maschera di Stampa fattura, oltre alle due richieste che riguardano la stampa su pdf, c'è quella che consente, se stampata su pdf, di inviarla via email.
Per effettuare tale invio occorre, oltre a predisporre quanto descritto nel paragrafo Invio fatture per email, inserire nell'aziwin.ini (generale o del terminale) il paragrafo [Email] con i parametri descritti in seguito. L'inserimento di questi parametro può avvenire anche, all'interno di ogni maschera di stampa,

TipoInvio

  • S=Sendmail (default) Controllare la configurazione nelle note
     (Scelta consigliata)

  • O=Outlook
    chiede conferma ad ogni invio e memorizza tutti i messaggi spediti

  • C=Cdo
    solo per chi ha un server di posta con Cdo
FileLog Percorso e Nome del file su cui scrivere il log delle email inviate.
Se posto = No non viene fatto il log (es. c:\LogEmail.txt)

Parametri necessari per Sendmail e Cdo

IndEmail | indirizzo email di chi sta inviando le email
Centro | descrizione opzionale dell' email di invio (chi riceve la vedrà precedere l'indirizzo di chi ha spedito la email)
ServerSMTP | server SMTP di invio email
Replay | indirizzo opzionale da segnalare come email di risposta
Notifica | se posto = S, indica se richiedere notifica email ricevuta (default N)

Parametri necessari SOLO per Sendmail

Login | login per accedere al server SMTP di posta
Pwd | password per accedere al server SMTP di posta (si consiglia di non metterlo nel file ini e di inserirlo su richiesta al primo invio)
ToName | descrizione opzionale dell' email a cui si invia; se contiene §Cliente§ viene sostituito con la ragione sociale del cliente (chi riceve il documento, la vedrà precedere il suo indirizzo di email)

Parametri necessari SOLO per Cdo

SMTPtipo tipo del server SMTP (in genere vale 2)

Esempio:
[Email]
Centro=Nome_Ditta
ServerSMTP=serverX.it
IndEmail=xxxxx@wwwww.com
ToName=§cliente§
#SMTPtipo solo per uso con CDO
#SMTPtipo=2

Per modificare la risoluzione del video

Di norma, le maschere vengono visualizzate adattandosi in base alla risoluzione del video.
Se si vuole disabilitare questo comportamento in uno o più programmi, occorre impostare nel file AziWin.INI i seguenti parametri a seconda delle esigenze.
La modifica può essere fatta o direttamente editando il suddetto file oppure con la funzione Configurazione programma menu (dal menu - Ctrl Alt Shift L), maschera 'Grafica' poi 'Configurazione video'.

Il paragrafo interessato è:
[Risoluzione video]
Generale=0
è il valore di default, vale per tutti i programmi ed è prioritario sugli altri parametri (tranne che per la visualizzazione del menu, delle stampe a video e della lista di aiuto-help).
Generale=N
N>0 Ingrandisce n volte il carattere rispetto la risoluzione che avrebbe a 800x600

  • N= -1 o N =1 Lascia la risoluzione che la maschera avrebbe a 800x600
    (Es. con N=1,24 se la definizione è 1024x768 il carattere viene ingrandito come fosse 800x600)
  • N= -2 Significa che la risoluzione video può essere personalizzata a livello di programma.
    In questo caso ogni programma cercherà se c'è, nella stessa sezione, una riga con:
    chiave primaria-chiave secondaria    = N che fa riferimento a se stesso.
    (chiave primaria e chiave secondaria sono visibili a video dal menu, dopo aver lanciato un programma, premendo i tasti: Shift Ctrl Alt P, corrispondono rispettivamente al contenuto dei campi Chiave e ChiaveSec, della riga in cui è richiamato il programma, nella tabella MenuDett di Azimenu.mdb)
    Es. comlins-Vett=1
    Anche qui N è un numero che può essere 1 (o -1), 0, >0, -2
    A seconda del valore di N si avrà un comportamento come per il parametro: Generale
    Se non esiste la riga corrispondente al programma o esiste ma con valore -2, verrà utilizzato il valore del parametro:
    PersBase    =X dove X può essere: -1 , 0 , >0 (Se questo manca si assume il valore di default e cioè il programma si adatta in base alla risoluzione del video.

Per differenziare la visualizzazione del menu si può utilizzare il parametro:
Menu=Y (con Y= -1, 0, >0) , se manca questo parametro il menu verrà visualizzato come indicato in PersBase Se Menu=-2 (che è il suo valore di default) si va a vedere il parametro Generale e se questo, a sua volta, vale -2 si va a vedere PersBase.

Per differenziare la stampa a video:
StaVid=

Per il ridimensionamento della lista di aiuto (help):
Help=

Per i box dei messaggi a video:
MsgCom=
Il loro funzionamento è identico a quello del parametro Menu descritto in precedenza.

Liste: posizionamento su una riga e scroll

Nella sezione [Config]
LisClickNoSel=S
Per far sì che nelle liste, se si fa un click su una riga, non si entri automaticamente in gestione di quella riga ma si rimanga sulla lista posizionati su quella riga. Con doppio click si andrà in gestione.

LisSpostaCurs=S
Per far sì che nelle liste torni abilitato lo scroll, che è stato disabilitato perché estremamente scomodo.

Percorso per ricerca DLL aggiornate

La funzione di verifica della versione delle DLL etc. sui Client e il successivo aggiornamento automatico di quelle non aggiornate, lanciata automaticamente dal menu, consente, una volta aggiornata la procedura sul server, di aggiornare i client la prima volta che cercano di accedere ai programmi.
L'aggiornamento automatico richiede che sia disponibile su disco la Directory di installazione delle DLL e altri file di sistema.

Di default il programma cerca le DLL aggiornate nella cartella …\aziwin\DllInst nella path degli EXE (indicata nell'aziwin.ini dal parametro PathExe).
Si può però forzare la posizione delle dll con un parametro da inserire nel gruppo
[Menu]
PathDllInst=percorso completo

Per abilitare la lettura dall'esterno delle righe di dettaglio dei documenti in:

  • Caricamento movimenti di magazzino
  • Inserimento preventivi, ordini di vendita e di acquisto
  • Ddt e fatture
  • Inserimento inventario manuale

Paragrafo [LettArtDaFile]. Vedi Caricamento dettagli documenti da file.

Percorso in cui si trovano i testi da visualizzare e/o stampare

Sintassi del comando per consentire di accedere a uno stesso testo, visto da terminali diversi in indirizzi diversi, nelle anagrafiche Clienti e Fornitori, nelle registrazioni di Prima Nota e in stampa Ddt:
Possibilità di mettere nella sezione [Base] dell’aziwin.ini una riga del tipo:
NomeDir= percorso (dove NomeDir è libero)
poi nei parametri di personalizzazione DirDocCollegato (per Prima Nota) o StDocFine (per ddt) o alla richiesta del file in Gestione Clienti e Fornitori , si potrà mettere:
§NomeDir§NomeFile.xxx cioè far riferimento al parametro creato nell’ INI.

Parametro per indicare il primo campo su cui va il cursore in inserimento clienti e fornitori

Si può inserire la riga ClientiPrimo=Nr (FornitoriPrimo=Nr) nel Gruppo [Configurazioni] , al posto del parametro di personalizzazione: PrimoCampo per modificare il campo su cui si posiziona il cursore in inserimento di una nuova anagrafica cliente o fornitore, per ottenere la modifica SOLO su un terminale.
Nr = numero del TabIndex del campo nella maschera (es. per Cognome: N=25)
Questo è prioritario rispetto al parametro di personalizzazione

Ridimensionamento della maschera del dettaglio dei documenti (Ordini , Ddt, Fatture)

E' stato abilitato il ridimensionamento della maschera quando si è nei dettagli del documenti. Le modifiche fatte vengono mantenute finchè il programma è in memoria.
Per salvare le dimensioni della maschera in modo che rientrando nel programma vengano mantenute, occorre posizionandosi col mouse sulla toolbar in alto, premere i tasti Ctrl Alt poi pulsante Desto del mouse (verrà fuori la scritta ‘Dimensioni maschera salvate’)
Al salvataggio, nell’Aziwin.INI del terminale verranno scritte delle righe nella sezione [Configurazioni]:
PrgLarg=X oppure X;Z
PrgAlt=Y oppure Y;K
Dove Prg varierà in base al programma: DdtDett per Ddt , FatDett per fatture , OrdDett per Ordini, MovDett per Movimenti di magazzino
X e Y sono rispettivamente le dimensioni di Larghezza e Altezza in Pixel
X=-2 e Y=-2 significa 'a tutto schermo'
X=-1 e Y=-1 (si può mettere solo manualmente) indica che si vuole utilizzare tutta la larghezza disponibile o tutta l’altezza disponibile

Z e K sono opzionali e indicano rispettivamente Z il margine sinistro e K il Top

Esempi:
DdtDettLarg=16410;3495
DdtDettAlt=13320;135
FatDettLarg=19275
FatDettAlt=13155


Personalizzazione tasti per avvio programmi

Questa funzione può essere lanciata dal menu o premendo i tasti Ctrl-Alt-Shift L e lanciandola dopo averla selezionata nell'elenco delle funzioni oppure quando si è posizionati sul pulsante di una funzione, premendo Ctrl e il tasto destro del mouse.

Consente di impostare tasti particolari (F1- F12) per lanciare direttamente programmi interni al gestionale ma anche programmi esterni (es. VisData, utility di access). Il lancio avverrà premendo i tasti Ctrl + F1 (- F12)
Oltre a programmi, si può lanciare anche la lettura di TXT, funzione che può tornare utile per leggere, quando si è sul menu, ad esempio il file di log per capire l'esito della spedizione di un documento per email.

La maschera di inserimento si presenta con una prima riga in alto dove dovranno essere digitati i comandi per la funzione da lanciare, poi ci sono due aree di dati, una conterrà le righe relative a tasti impostati per l'utente corrente e l'altra per tutti gli utenti.

Una volta compilata la prima riga con i dati necessari, essa verrà assegnata a un gruppo o all'altro tramite il pulsante Assegna.

Se si è entrati nel programma dal menu con Ctrl e il tasto destro del mouse, la riga verrà compilata automaticamente con le informazioni relative alla funzione su cui si era posizionati, basterà completarla scegliendo il tasto che servirà a lanciarla poi salvarla.

I campi presenti sulla riga sono:

  • Funzione
  • Comando - si può trovare con sfoglia, è il programma da lanciare
  • Parametri/Directory di avvio - una volta scelta la funzione da lanciare, qui viene proposta la sua dir di avvio che, eventualmente, può essere modificata.
  • Chiave Primaria - Chiave secondaria servono solo per i programmi lanciati dal menu di AziWin, sono i corrispondenti campi sulla riga della funzione, nel database del menu
  • Tutti/Personalizzati
    Serve per decidere in quale gruppo di dati memorizzare la riga

Una volta compilata la riga, occorre inserirla in uno dei due gruppi sottostanti con il pulsante Assegna

Per modificare successivamente una riga già inserita in uno dei due gruppi, occorre premere il pulsante a sinistra della riga (Mod-Modifica), in questo modo il suo contenuto verrà portato in alto sulla prima riga dove potrà essere modificato e risalvato.

Esempi:
Per attivare la calcolatrice con Ctrl F2:
Tasto F2, Comando: calc.exe poi salvare la riga

Per attivare la calcolatrice per date con Ctrl F3:
Tasto F3, Comando: Calcolatrice per date Parametro/Dir.di avvio: $Default$
Chiave Prim.: CalcDate Chiave Sec.: Xpoi salvare la riga

Per leggere il file di LOG degli invii email con Ctrl F4:
Tasto F4, Comando: C:\AziWin\LogEmail\EmailLog.txt
Parametro/Dir di avvio: C:\AziWin\LogEmail
Campi: Chiave Prim. e Chiave Sec. lasciati vuote


LICENZA CONCESSA A

Questa funzione consente di abilitare l'utente all'utilizzo delle procedure. Se la chiave di attivazione che viene inserita non risulta corretta, le procedure potranno essere eseguite SOLO in modalità 'Demo' cioè con un numero limitato di anagrafiche e in particolare di registrazioni.

La chiave di attivazione dovrà essere inserita al momento dell'installazione delle procedure e dipende da:

  • anno di validità
  • data fine attivazione
    serve per attivare la procedura, in visione, per un breve periodo. Terminato il periodo di visione non sarà più possibile fare registrazioni nuove
  • pacchetti installati
  • tipo di installazione
    • monoutente
    • rete
  • Terminal Server
    questo campo dovrà essere spuntato in caso di utilizzo della procedura in terminal server
  • tipo di protezione
    • Solo licenza
    • HD
      in questo caso la licenza verrà legata anche al numero del disco su cui i programmi verranno installati o, se l'installazione è in rete, al disco del computer dal quale, ogni giorno, si entra per primo nella procedura.

  • Num. Hard Disk Server: è stata inserita anche la possibilità, in caso di installazione in rete, di attivare la chiave da qualsiasi computer, facendo riferimento a quello che contiene AziMenu.mdb e i programmi (comunicando il numero di Hard disk server scritto a video). In questo modo, da qualsiasi computer si acceda alla procedura, la chiave viene aggiornata automaticamente e non c'è più la necessità di entrare nella procedura, almeno una volta la settimana, dal computer su cui era stata richiesta la password.

  • Licenza concessa a: ragione sociale del proprietario della licenza
    Il contenuto di questo campo verrà visualizzato sullo schermo nella maschera del menu.

Nota: se non si utilizza la PassWord legata al disco, su ogni stampa fiscale di Contabilità e sui documenti delle Vendite (ordini, ddt, fatture), verrà stampata una riga fissa con la scritta: Licenza concessa a: xxxxxxxxxxxx (contenuto del campo licenza)

Se non si dispone momentaneamente della PassWord o per evitare che utilizzando la procedura in modo ‘demo’ venga chiesta l’inserimento dei dati della licenza ogni volta che si entra nel menu, si consiglia di compilare la maschera secondo le esigenze e in particolare di scrivere la parola ‘demo’ nel campo Chiave (dove compare la scritta ‘key’) poi di uscire con Salva ogni volta che viene richiesto.


MENU PROCEDURA

MENU PROCEDURE

Il menu principale della procedura si presenta con i vari pulsanti per la scelta della funzione da utilizzare.
Il cursore inizialmente è posizionato sulla data che può essere variata o confermata.
E' possibile personalizzare l' aspetto grafico inserendo particolari parametri nel file aziwin.ini.

Tramite l'attivazione di opportuni parametri di personalizzazione è possibile eseguire il compattamento degli archivi dell'azienda corrente, appena si entra nel menu
(vedi parametro CompattaAvvioTerm in Personalizz. parametri comuni)

Verifica versione delle DLL etc. sui Client e aggiornamento automatico di quelle non aggiornate
Se si accede alla procedura da un client e il programma trova delle dll non aggiornate, cercherà di aggiornarle prendendole dalla cartella aziwin\DllInst o da quella scritta in Aziwin.ini nel parametro:
gruppo [Menu]: PathDllInst=percorso completo (vedi Parametri di aziwin.ini)

Nello spazio AZIENDA viene visualizzata la ragione sociale dell'azienda in elaborazione. Per cambiare azienda occorre premere il pulsante Cambia Azienda (Alt C): verrà in questo modo visualizzato l'elenco delle aziende create e tra queste si deve scegliere quella da gestire (non è possibile uscire dalla lista se prima non si sceglie l'azienda).

Se l'azienda da gestire è nuova, occorre crearla sia nell'elenco delle aziende sia come database, questo si fa dal Menu Utilità poi Gestione Database Aziende

Programma (Alt R): la scelta del programma da eseguire può essere fatta attraverso i pulsanti del menu oppure con una ricerca, sul campo Programma, della sua descrizione con le modalità che seguono:
digitare G (se gestione) o S (se stampa), uno spazio e la descrizione, anche parziale) del programma da cercare (se si mette un * come primo carattere della descrizione, la ricerca dei caratteri che seguono verrà fatta all'interno delle descrizioni dei pulsanti)

Per 'descrizione' da cercare si intende la scritta che compare su ogni pulsante.
I caratteri digitati, perché il programma esegua la ricerca, dovranno essere seguiti da:
F2 - si posiziona nel menu della funzione richiamata e la esegue
F3 - esegue la funzione richiamata poi ritorna alla pagina di menu di partenza
F4 - si posiziona nel menu della funzione senza eseguirla
Se ci sono più funzioni che rispondono alla ricerca fatta, viene visualizzato l'elenco e si consente di scegliere.

Passa A (Alt P): consente, se ci sono più programmi in esecuzione, di ottenerne un elenco in modo da scegliere quello su cui tornare. (L' alternativa è quella di scegliere il programma dalla barra delle applicazioni, dove però vengono visualizzate tutte le maschere, es. anche le liste o i messaggi di stampa in esecuzione, o con Alt Tab)

Per posizionarsi sui pulsanti ed eseguire un programma, ci si può spostare col mouse oppure con ALT M ci si posiziona sul primo pulsante del menu. Con i tasti frecce (sinistra, destra, alto, basso) si possono scorrere i pulsanti per colonna all'interno dello stesso frame.
Spostandosi con il Tab o con PgUp PgDw, oltre a scorrere le funzioni per colonna si passa anche al frame successivo.
Con Ctrl PgUp si scorrono sequenzialmente le varie pagine individuate dalla prima riga di Menu.
Con Alt PgUp si scorrono sequenzialmente le varie pagine individuate dalla seconda riga di Menu.
I tasti Home ed End consentono di posizionarsi rispettivamente sul primo e sull'ultimo pulsante della pagina di menu su cui si è posizionati.

Altri tasti abilitati:

Shift Ctrl Alt E - Viene mostrato l'elenco dei terminali che stanno utilizzando le procedure. Per ciascuno viene visualizzato il nome del PC, l'azienda in uso, il gruppo e la login
Shift Ctrl Alt I - Fa vedere il percorso del file AziWin.ini principale (quello del computer che si sta utilizzando) e del secondario (quello contenuto nella cartella ..\Aziwin\).
Inoltre mostra il nome del terminale su cui si sta operando (scritto su aziwin.ini).
Shift Ctrl Alt L - Consente di accedere a un gruppo di programmi di utilità (Gestione dei filtri per la stampa fatture ed etichette etc.) Vedi Esegui programma
Shift Ctrl Alt M - Chiede un numero e dice se il menu è attivo
Shift Ctrl Alt P - Viene mostrato il nome del programma attualmente in esecuzione (chiave primaria e secondaria)
Shift Ctrl Alt Q - Consente di scrivere ed eseguire una query di visualizzazione o di aggiornamento dati (vedi Query)
Shift Ctrl Alt T - Visualizza i numeri dei menu attivi sul terminale

Altre possibilità di personalizzazioni:

  • Contenuto della maschera di ABOUT e delle scritte in basso a sinistra: Realizzato da
  • Modifica colore sfondo tramite parametri di personalizzazione:
    ColBackForm per modificare il Colore da usare come sfondo delle maschere
    ColBackMenu per modificare il Colore da usare come sfondo dei comandi del menù


GESTIONE TESTI PER INVIO EMAIL

Percorso: Parametri e Utilità - Dati azienda-parametri

Questa funzione consente di predisporre fino ad un massimo di 5 testi da utilizzare nell'invio per email di un pdf generato da una stampa qualsiasi (es. estratto conto). I testi gestiti (1,2,3,4,5) sono quelli che poi si possono indicare nella maschera Par.Pdf/Email in Num.testo da usare.

Per quanto riguarda invece i testi utilizzati per l'invio di documenti:
Nella maschera delle stampe documenti (ordini, ddt, fattura) ed etichette, è presente una opzione che, se spuntata, consente l'invio per email del/dei pdf delle fatture stesse e a fianco c'è il pulsante: "Cambia Testi" che manda in esecuzione questo stesso programma ma i testi che gestisce e che si possono memorizzare sono diversi per ogni documento da stampare.

Il programma visualizza automaticamente il primo testo presente, se l'utente vuole inserire/variare un'altro testo basta premere il pulsante corrispondente. Dopo la variazione il testo dovrà essere salvato con il pulsante corrispondente, in fondo alla maschera.

I testi vengono memorizzati nel database del menu (AziMenu.mdb, tabella Appoggio)

Segue un elenco 'parametri', personalizzabili all'interno dei campi oggetto e testo dell'email (devono essere racchiusi fra due §, es. §Data§ )

PersOgg | La descrizione scritta in 'oggetto' può essere fissa oppure il campo può contenere la scritta: §PersOgg§ ad indicare che deve prendere quanto scritto nel parametro EmailPersOgg dell'AziWin.INI sezione: [Email]
(***) | Parametri validi anche per Nome File Pdf
DescPrg | Descrizione della funzione (da tab. dettagli menu - MenuDett)
Titolo | Testo del pulsante del menu che lancia la funzione
CodSta | Chiave principale e secondaria della funzione (da tab. dettagli menu)
Data | Data in cui viene effettuata la stampa (Es. 20072012)
DataLong | Data nella forma giorno-mese per esteso-anno (20 Luglio 2012)
DataAbb | Data nella forma giorno-mese abbreviato-anno (20 Lug 2012)
DataRov | Data nella forma Anno-mese-giorno (Es.20120720)
Ora | Ora di stampa nella forma hh:mm:ss

Oltre a questi, sono disponibili altri 'parametri', quali terminale, login etc. descritti in Nome file per pdf

Utilizzando l' html, è possibile inserire nel testo dell' email font diversi (es. grassetto o corsivo) oppure una immagine
Nel primo caso la sintassi del testo dovrà essere esattamente:
<html> seguito da un ritorno a capo SENZA SPAZI
poi si scriverà il Testo dell' email e, per ottenere una parte di testo in grassetto o in corsivo si dovrà scrivere tale testo in html:
<b>Testo_Grassetto</b> e poi <i>Testo_Corsivo</i>

Per inserire una immagine invece, occorre scrivere:
<img src="path_immagine"> eventualmente preceduto e seguito dal testo desiderato.

Se nel testo si mette la scritta: <img src= non servirà mettere anche <html>

Col pulsante Cerca Img: è possibile cercare l'immagine da inserire nel testo e, una volta individuato, verrà scritta la frase completa:
<img src="path_immagine">

Nella sezione BASE dell'aziwin.ini è possibile inserire il parametro:
DirImgEmail=C:\.... in cui indicare la cartella che contiene le immagini.
In questo caso la ricerca e selezione delle immagini in quella cartella porterà alla scritta:
<img src="çDirImgEmailç\NomeImmagine.jpg">


TABELLE TRASCODIFICHE

Percorso: Parametri e utilità - Dati azienda e parametri - Gestioni varie

Questa funzione consente di impostare, per le tabelle definite nel parametro di personalizzazione TabTrascod, una corrispondenza di codici tra la procedura AziendaPc e un'altra procedura.

Viene utilizzata in particolare per il trasferimento delle fatture da AziendaPc
- a Pragma dove occorre definire la corrispondenza dei codici causali, codici iva, regioni, conti etc.
- a AGO Infinity di Zucchetti

Come specificato nella spiegazione del parametro TabTrascod, se la tabella per cui si devono inserire i codici è una tabella del database di lavoro, una volta digitato il codice il programma ne controlla l'esistenza e visualizza la descrizione corrispondente.
L'utente dovrà poi completare la riga inserendo il codice corrispondente sulla procedura che dovrà ricevere i dati.

Codice interno: codice utilizzato in AziendaPC
Codice esterno: codice corrispondente utilizzato dall'altra procedura

Esempio di valore da dare al parametro TabTrascod, per la preparazione delle tabelle per Pragma:
§Prefissi - Codici Registri Iva;Tabiva;Pianoconti;§Regioni;Causali


ARCHIVI COMUNI

Le funzioni descritte in questo capitolo consentono di inserire, variare e stampare i dati contenuti nelle tabelle di base delle varie procedure.

  • Gruppi
  • Mastri
  • Conti
  • Clienti e Fornitori
  • Articoli di magazzino
  • Tabelle di contabilità
  • Tabelle di magazzino
  • Tabelle vendite


GRUPPI CONTABILI

Percorso: Archivi Comuni - Anagrafiche

Il PIANO DEI CONTI è organizzato su tre livelli: Gruppi-Mastri-Conti.

Per poter creare un Conto occorre prima aver definito il Gruppo e il Mastro al quale il conto appartiene. Ogni conto viene identificato da un codice alfanumerico del tipo XX-YY-ZZZZ dove XX identifica il Gruppo e YY il Mastro.

Per i Clienti e Fornitori dovranno essere creati uno o più Mastri Clienti (Fornitori) (Es. Clienti Nazionali e Clienti Esteri) prima di procedere alla creazione delle singole anagrafiche.

La cancellazione di un Gruppo è consentita solo se non ha nessun mastro collegato.

Tipo gruppo
Indica la sezione di bilancio alla quale il gruppo e quindi tutti i conti ad esso collegati, appartiene: Patrimoniale, Economico, d'Ordine.


MASTRI

Percorso: Archivi Comuni - Anagrafiche

Il mastro è identificato da un codice alfanumerico del tipo XX-YY dove XX è il gruppo al quale esso è collegato. L'inserimento di un nuovo mastro è consentito solo se il gruppo è già stato codificato.

La cancellazione è consentita solo se il mastro non ha nessun conto ad esso collegato.

Tipo mastro
Specifica il fatto che il mastro raggruppi dei conti, dei clienti o dei fornitori. Non è possibile variare questo campo se esistono dei conti (clienti o fornitori) collegati al mastro.

  • Contabilità
  • Fornitori
  • Clienti

Natura
Definisce la posizione che dovranno avere i conti dipendenti dal mastro, all'interno della stampa del bilancio.
Un mastro Patrimoniale potrà avere come natura: A = Attività, P = Passività, S = a Saldo (cioè sarà una attività o una passività a seconda del saldo es. una Banca, i clienti, i fornitori)
Uno Economico: C = Costo, R = Ricavo, a Saldo.

Centro di Costo
Interessa solo i mastri di tipo 2 e 3 (clienti e fornitori). Viene utilizzato nella stampa conti per centro di costo. Non ha decodifica.


CONTI

Percorso: Archivi Comuni - Anagrafiche

Sono tutti i conti del piano dei conti da utilizzare nelle registrazioni contabili. Per inserirli occorre aver prima creato i rispettivi gruppi e mastri di appartenenza. I conti potranno essere collegati SOLO a mastri di Contabilità, le anagrafiche dei clienti e dei fornitori dovranno essere inserite con le apposite funzioni.

Il pulsante di cancellazione, consente di cancellare solo i conti mai movimentati, cioè quelli che non sono mai stati utilizzati nelle registrazioni di prima nota presenti in archivio, anche di anni precedenti all'attuale.

Il codice viene richiesto nella forma XX-YY-ZZZZ dove XX è il gruppo e YY il mastro di appartenenza. Si controlla l'esistenza del gruppo e del mastro e si stampano a video le rispettive descrizioni.

Data creazione
E' la data di creazione del conto. In creazione, viene posta uguale alla data del terminale, ed è obbligatoria.

Data chiusura
Questa data può essere inserita manualmente dall'operatore nel caso si vogliano sospendere le registrazioni su un conto. L'inserimento del conto con data di chiusura impostata, in una registrazione di prima nota, provocherà la segnalazione di 'conto chiuso' se la data di registrazione è superiore alla data di chiusura.

Codice centro di costo
Indica il centro di costo cui il conto eventualmente appartiene. Se valorizzato caratterizza la stampa della situazione conti ordinati per centro di costo.

Centro di costo obbligatorio
Indica se è obbligatorio o meno inserire, nei dettagli di prima nota che utilizzano questo conto, il codice del centro di costo. Se viene definito obbligatorio, in fase di inserimento di prima nota verrà presentato in automatico il codice del centro di costo letto sul conto stesso.

Utilizzato fino al 2017- Segnalazione Reverse Charge in Spesometro
Consente di individuare le registrazioni di acquisto Reverse Charge, relative ad acquisti per cui andrà barrata la casella Reverse Charge nella stampa/preparazione del file dello Spesometro, in corrispondenza a operazioni in cui questo conto è utilizzato.
Dovrà essere impostato a Si nei conti utilizzati per la registrazione di acquisti 1972 (acquisto di materiale d’oro e d’argento e le prestazioni di servizi rese nel settore edile da soggetti subappaltatori) e in quelle di cui all’articolo 74, commi 7 e 8 (acquisti di rottami e metalli non ferrosi)
Questo per differenziarli dalla registrazione di acquisti di apparecchi elettrici e telefonini che verranno considerati ma senza flag Reverse Charge

Budget
Indica la stima budgetaria fissata per quel conto. Viene stampato, a richiesta, nel bilancio a sezioni contrapposte.

Tipo competenza
Questo campo va compilato se il conto è un costo o un ricavo e a fine anno genererà dei ratei o risconti.
Se in prima nota (e in fatturazione) l'utente inserirà l'intervallo di competenza in corrispondenza a una riga con questo conto, verrà proposto in automatico il tipo competenza indicato qui: giornaliero o mensile

Codici di riclassificazione
Decodifica da tabella riclassificazioni.
Impostando in ciascuno di questi campi un codice diverso è possibile ottenere bilanci riclassificati.
Si potranno fare bilanci diversi a seconda che si raggruppi per il primo codice, per il secondo etc.
In stampa verranno raggruppati e quindi totalizzati i conti con lo stesso codice di riclassificazione.

Acquisto per Ventilazione
E' un segnale che indica se il conto deve o meno incrementare la base di ventilazione.
Dovrà essere impostato a Si quando si tratta di un conto di acquisto di merce che poi verrà venduta come corrispettivo da ventilare.

Conto collegato e Percentuale indeducibilità
Questi campi verranno utilizzati dalla prima nota, durante l'inserimento di una fattura d'acquisto per generare la riga di costo non deducibile.

Soggetto a ritenuta d'acconto
 (Si - No - Standard) Standard è il valore di default
Questo campo viene utilizzato dall'input prima nota, durante l'inserimento di fatture di un fornitore per il quale è prevista la ritenuta d'acconto. Se non si impongono condizioni, il programma considera come imponibile su cui calcolare la ritenuta, la somma degli importi delle varie righe della registrazione. Per far sì che solo alcuni conti concorrano a formare tale imponibile occorre:
creare il parametro di personalizzazione DetSoggRitAcc con valore N in modo che, in generale, nessun conto accumuli imponibile. Poi, andare su quei conti che generano imponibile e mettere il flag di Soggetto.
Viceversa per chi non ha creato o non crea il parametro, la Rit. d'acconto verrà calcolata per tutti i conti (se sono valide le altre condizioni) tranne per quelli che hanno il flag a No.

Beni strumentali (com.iva annuale)
La procedura prevede che il calcolo degli importi "CD1 - di cui cessioni beni strumentali" e "CD2 - di cui acquisti beni strumentali" della Comunicazione iva annuale venga fatto considerando le registrazioni fatte con codici iva opportunamente creati.
E' tuttavia possibile attivare il parametro di personalizzazione: Iva BeniStrum in modo da utilizzare gli importi delle registrazioni fatte su determinati conti nei quali è stato spuntato il campo "Beni Strumentali" Acquisto o Cessione.

Beni o Servizi
Questo campo interessa la Comunicazione telematica delle operazioni fatte con soggetti in 'black list' e la registrazione delle Bolle Doganali. Su ogni conto di costo e ricavo è indispensabile dichiarare se si tratta di bene o servizio, al fine di poter separare gli importi nelle comunicazioni. Di default si assume che si tratti di "bene".
Il campo va invece impostato a 'Costi accessori per Bolle doganali' nei conti utilizzati per inserire ad es. gli Oneri doganali nelle fatture della Dogana per far si che, quando si crea in automatico l'autofattura, non si tenga conto degli importi messi in tali righe.
Quando si crea la scadenza di una fattura d'acquisto 'importazione no cee' , si mette come importo quello derivato dalla somma dei conti che sono 'Costi accessori per Bolle doganali' più l'iva.
Se vengono utilizzati conti di questo tipo in fatture d'acquisto 'normali' (cioè non con flag 'bolla doganale') di fornitori Black List, essi verranno considerati: Servizi.

Collegamento Bilancio Cee
Possibilità di collegare il conto ai codici della tabella del Bilancio Cee
Si possono collegare fino a 2 codici diversi.
Dovrà essere digitato il codice Cee e il Segno+ o -
L'operatore sarà + se il conto dovrà entrare nel bilancio con il suo segno oppure - se 'con segno invertito' (vedi Bilancio Cee dettagli)

Tessera Sanitaria- Tipo Spesa
Questo campo serve per definire, in fase di estrazione dati dalla Prima Nota, per preparare il file XML da inviare per il Progetto Tessera Sanitaria, il tipo di prestazione erogata in corrispondenza ai conti presenti in fattura.
I valori da assegnare al campo sono quelli definiti nelle specifiche del Progetto Tessera Sanitaria
E' possibile impostare questo campo anche con il valore: NON Estrarre . In questo modo, il conto in oggetto NON verrà mai estratto anche se presente in fattura.


STAMPA PIANO DEI CONTI

Percorso: Archivi Comuni - Anagrafiche - Stampe

La stampa può essere fatta per separatamente dei soli Gruppi, dei Mastri o dei Conti.

L'ordinamento può essere per codice o per descrizione.

Se si stampano i conti si può definire l'intervallo dei codici e si può scegliere di stamparli tutti o solo i movimentati. (Controllo DA FARE IN SEGUITO !!!! SULLA SINTESI DI CONTABILITA' !!!! )


CLIENTI E FONITORI

CLIENTI E FORNITORI

Percorso: Archivi Comuni - Anagrafiche

Le informazioni che seguono fanno riferimento ai clienti ma sono ugualmente valide anche per i fornitori.
Verranno via via segnalati i campi non comuni ad entrambe le gestioni.

Prima di inserire i dati anagrafici occorre aver creato un gruppo e uno o più mastri clienti. Il codice, alfanumerico, è composto da tre parti: XX-YY-ZZZZ dove XX è il gruppo e YY è il mastro al quale il cliente appartiene.

La ricerca, anche parziale, avviene posizionandosi sul campo Cod.Cliente/Fornitore e premendo uno dei tasti descritti in seguito:

  • F2 sul codice
    se il campo codice è vuoto verrà presentato un elenco di tutte le anagrafiche ordinate per codice
  • F3 sulla Ragione sociale contabile
    se il campo codice è vuoto verrà presentato un elenco di tutte le anagrafiche ordinate per Ragione sociale contabile
  • F4 sulla Partita Iva
  • F5 sul Codice Fiscale
  • F11 sulla prima parte della Ragione Sociale
  • F12 sulla Ragione sociale completa (unione della prima e seconda parte)

Vedi parametri di personalizzazione:

CFHelpRicF11 per estendere ulteriormente i campi di ricerca
PrimoCampo per poter impostare il primo campo su cui si posiziona il cursore in inserimento (es. Cognome). Vedi anche: ClientiPrimo e FornitoriPrimo

La cancellazione dei dati anagrafici di un cliente è consentita solo se non è mai stato movimentato.

Nel caso in cui vengano fatte variazioni di dati anagrafici: Ragione Sociale, Indirizzo, Cap , località , Provincia, Stato , Comune verrà chiesto all'operatore se vuole effettuare la storicizzazione di tali dati. Come data di storicizzazione viene messa quella impostata nel menu.
Se avvengono due variazioni successive, nello stesso giorno, sarà possibile archiviare SOLO la prima volta.
In questo modo si consente, se si ristampa una fattura o un registro iva/giornale di un periodo precedente, di poter riportare, per ogni codice, i dati anagrafici in essere in quel periodo.
Per la variazione di altri dati, in particolare Codice Fiscale o Partita Iva, si dovrà necessariamente creare una nuova anagrafica.

Codice
Vengono visualizzati Gruppo e Mastro inseriti in tabella generale di contabilità.

In caso di creazione di una nuova anagrafica, è possibile utilizzare il pulsante Genera codice, che assegna automaticamente il codice successivo all'ultimo inserito per quel mastro. Se l'utente, prima di premere questo pulsante, scrive una lettera, il codice che verrà assegnato sarà sequenziale all'ultimo che inizia con quella lettera, rispettando sempre la lunghezza 4. Es. se si scrive: A e si preme il pulsante, il codice che assegna sarà A001 la prima volta, A002 la seconda etc.

Se il prossimo codice che si chiede di creare è superiore a 9999, il programma creerà in automatico il codice A001 e numererà i successivi come A002, A003 etc.
Questo pulsante è stato inserito per quanti, avendo tanti clienti occasionali (es. studi medici), necessitano di più di 9999 anagrafiche e non vogliono utilizzare mastri diversi.

Ragione sociale (prima e seconda parte) e Ragione Sociale Contabile
Per consentire la compilazione completa della ragione sociale sia in contabilità (dove lo spazio disponibile nelle stampe è limitato) sia sui documenti delle vendite, dove negli indirizzi serve l'anagrafica il più completo possibile, sono stati messi a disposizione tre campi utilizzati come segue:

E' obbligatorio inserire la ragione sociale contabile, verrà utilizzata in contabilità e in ogni ricerca del cliente, se non ci sono problemi di lunghezza i due campi di Ragione Sociale potranno essere lasciati bianchi.

Se si utilizza la procedura delle Vendite ed è stato necessario abbreviare la Ragione Sociale appena scritta, essa potrà essere riportata in modo dettagliato sui due campi di Ragione Sociale.

Se invece serve solo completare la Ragione Sociale Contabile per l'indirizzo dei documenti di vendita si può semplicemente scrivere SOLO la seconda parte del campo Ragione Sociale.

Il campo Ragione Sociale è diviso in due pezzi perché sul documento non ci sarebbe spazio per stampare tutti i caratteri di seguito. Nelle stampe dei documenti di vendita si controlla se è compilata la prima parte della Ragione Sociale, se lo è, la si stampa, seguita dalla seconda parte; se invece non è compilata si stampa la Ragione Sociale Contabile seguita, se compilata, dalla seconda parte della Ragione Sociale.

Per quanto riguarda la preparazione del file XML per la Comunicazione dati fatture, sono stati inseriti due nuovi campi: Cognome e Nome che, se compilati verranno sempre scaricati sul file

(Pre 2017) Nella compilazione del file telematico per la Comunicazione delle operazioni rilevanti ai fini iva, per quanto riguarda le operazioni fatte con soggetti NON residenti, si chiede di trasmettere Nome e Cognome se persona fisica. In questo caso o si compila la Ragione sociale contabile con Cognome-Nome o Cognome_Nome o Cognome 'spazio' Nome (si considera il primo spazio) oppure si scriverà il Cognome in Ragione Sociale (1' parte) e il Nome in Ragione Sociale (2' parte).

In inserimento di una nuova anagrafica viene data una segnalazione nel caso ci sia già in archivio un'altra anagrafica con la stessa Ragione Sociale Contabile.

Data apertura
E' la data di creazione del cliente. In creazione, viene posta uguale alla data del terminale, ed è obbligatoria.

Data chiusura
In condizioni di cliente attivo questa data non è impostata. Può essere impostata manualmente nel caso si voglia sospendere l'utilizzo del cliente durante l'anno. L'inserimento della prima nota darà una segnalazione di cliente chiuso se verrà richiamato un cliente in una data successiva alla data di chiusura impostata.

Per semplicità di gestione i dati sono stati suddivisi in gruppi a seconda della tipologia.
I dati anagrafici rimangono sempre visualizzati mentre agli altri si può accedere con tasti opportuni.
Dati Anagrafici
Nota
Classi Attributi e Codici di riclassificazione
Dati per Contabilità
Dati per Fatturazione
Note per documenti
Documenti
Email
Dichiarazioni di intento


CF-Nota

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Campo in formato Memo che consente di memorizzare delle righe di note relative al cliente.

Queste note potranno essere consultate durante la registrazione di un documento di vendita.

E' possibile impostare il parametro di personalizzazione InizioAvvisoCliente con i caratteri iniziali delle note IMPORTANTI, es. $$. I programmi di ordini , ddt e fatture, in corrispondenza a clienti con nota che inizia per $$, visualizzeranno, nella maschera dell'anagrafica cliente una nota 'rossa' per avvisare di leggere le note del cliente in oggetto, nell'apposito spazio.


CF-Dati anagrafici

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Comune
E' il comune in cui risiede il cliente.
E' presente, nel database del menu, una tabella dei Comuni completa di Codice Erariale, Cap etc.
Se si inserisce un comune e non è compilata la provincia, il programma controlla che esso esista in tabella e compila i campi provincia e cap, viceversa se la provincia è compilata, cerca tra quelli della provincia.

Con i tasti F2 e/o F3 si ottiene l'elenco dei comuni della provincia,
con il tasto F4, dopo aver digitato il Codice erariale, verranno elencati i comuni con quel codice
con il tasto F5, dopo aver digitato il CAP, anche parziale, verranno elencati i comuni con quel cap

Se compilato, viene stampato sulla Comunicazione dei dati delle Dichiarazioni di intento in quanto in tale stampa si prevede, per ogni anagrafica, frazione e comune di residenza. In tal caso verrà stampato in Comune il contenuto del campo Comune e in Frazione, via e nr.civico la località e l'indirizzo del cliente.

Indirizzo
Va compilato con l'indirizzo del cliente.
Se il cliente è estero si raccomanda di lasciare bianca la sigla della provincia (anche quella di nascita) o compilarla con EE oppure 99.
Se si compila il campo 'provincia' con EE oppure 99:
- il campo Comune non verrà controllato e si potrà compilare a piacere (Per SEDE clienti esteri in fattura elettronica).
- in preparazione del file XML della fattura elettronica il cap verrà modificato in modo da renderlo accettabile, cioè verrà reso di lunghezza 5 e verranno tolte le eventuali lettere.

Per quanto riguarda lo stato, se compilato, ne viene controllata l'esistenza sulla tabella stati, verrà impostato automaticamente il codice Iso, per gli stati della comunità europea, e sarà possibile controllare la lunghezza della partita iva.
Se lo stato viene lasciato bianco o impostato a IT il programma esegue i controlli sulla partita iva e codice fiscale secondo le norme italiane.
La tabella Stati presente nei singoli database, è collegata a sua volta a una tabella generale degli Stati, presente sul menu, tramite un codice. Questo serve ad attribuire ad ogni stato alcune caratteristiche particolari quali in Black List etc.
Quando si compila il campo Stato, è importante controllare che nella tabella Stati sia stato compilato il campo 'codice di collegamento'.

A fianco all'indirizzo viene visualizzato un pulsante 'Mappa' con il quale è possibile visualizzare la pagina di Google Maps relativa all'indirizzo stesso.

Da estrarre in file paesi in Black List
Questo campo viene spuntato automaticamente dal programma quando si imposta uno stato il cui codice risulta in Black List e viene copiato sulla registrazione dei documenti in Prima Nota in modo da poterli estrarre con la funzione di preparazione file per invio 'Black List'

Email Telefono Fax

Codice ISO e Partita Iva
Viene considerato 'italiano' un cliente con stato 'bianco' oppure con stato presente in tabella stati e codice iso IT, in questo caso viene effettuato il controllo sulla correttezza della Partita Iva secondo la normativa italiana.
Per gli stati appartenenti alla Comunità Europea, il programma controlla la correttezza della partita iva inserite nelle anagrafiche, secondo le specifiche date dall'Agenzia delle Entrate. La condizione è che sia stato impostato correttamente il codice ISO.

Se il codice inserito risulta errato viene dato un messaggio e si consente di mantenerlo ugualmente in archivio. Se invece esistono altri clienti con lo stesso codice, viene visualizzato il primo di questi. Si consente tuttavia di inserire Partite Iva doppie su conferma. Se il cliente fa parte della Comunità Europea (flag tabella stati) la partita iva sarà preceduta dal codice ISO che verrà letta dalla tabella stati.

Nota: Se, inserendo la Partita Iva di uno straniero, non bastano i caratteri disponibili nel campo P.Iva, si possono mettere i caratteri restanti nel campo Cod. Fiscale facendoli precedere dal segno - (meno)

Se un cliente/fornitore appartiene ad un gruppo di aziende che ai soli fini iva viene visto come un unico soggetto passivo (legge 2006/112/CE) occorre mettere nella Partita Iva quella principale (cioè quella che viene utilizzata ai fini iva) e nel codice fiscale la partita Iva della singola azienda. Se si hanno rapporti con più aziende del gruppo occorre creare un cliente per ogni singola azienda differenziandoli per codice fiscale (NB il programma segnalerà Partita Iva doppia)

Codice Fiscale
Viene fatto il controllo di correttezza e si consente di forzarlo.
Se vengono inseriti i dati della persona fisica: Cognome, Nome, data di nascita, Sesso e Comune di nascita , con un click sul pulsante apposito verrà calcolato il codice fiscale che si compone di:
3 caratteri alfabetici per il cognome;
3 caratteri alfabetici per il nome;
2 caratteri numerici per l'anno di nascita;
1 carattere alfabetico per il mese di nascita;
2 caratteri numerici per il giorno di nascita ed il sesso;
4 caratteri associati al Comune oppure allo Stato estero di nascita.
1 carattere alfabetico usato come carattere di controllo

Stato Giuridico
Indica se il cliente è Persona Fisica o Persona Giuridica
In generale se ha la Partita Iva è Persona Giuridica, se ha il codice fiscale è Persona Fisica.
E' possibile attivare il parametro di personalizzazione: CognomePersFisica ponendolo ad S in modo che se si compilano Cognome, Nome e prima erano bianchi, il programma pone lo Stato Giuridico a Persona Fisica così abilita la data di nascita etc.
Nel caso di persona fisica si potranno compilare: Cognome e Nome, sesso, comune e data di nascita.

Persona di Riferimento
Campo descrittivo. Per la compilazione della Comunicazione delle operazioni rilevanti ai fini iva: in caso di "società, assicurazioni o altre organizzazioni senza personalità giuridica" NON RESIDENTI è indispensabile dichiarare l'anagrafica come Persona fisica, compilare i dati di nascita ed inserire in questo campo Cognome-Nome di una delle persone che ne hanno la rappresentanza

Cognome - Nome
Se vengono impostati Cognome e Nome e lo stato giuridico è Persona Fisica (Vedi par.personalizzazione: CognomePersFisica) si consentirà di inserire data , luogo , stato di nascita e sesso e di calcolare in automatico il codice fiscale.
Inoltre sul file della Comunicazione dati fattura verranno compilati i campi Nome e Cognome nei dati anagrafici
Se, per una persona fisica, si compila nome e cognome, sul file xml della fattura elettronica verranno scaricati questi al posto della Ragione Sociale. Per evitare questo si può scrivere NO nel campo Titolo

Dati di nascita
Verranno comunicati nella trasmissione delle Black List e delle Comunicazione delle operazioni rilevanti ai fini iva quando si tratta di soggetti NON residenti
In caso di nascita all'estero la sigla della provincia dovrà essere EE
Per quanto riguarda la località di nascita, valgono le stesse regole scritte per il 'Comune'

Titolo
Campo opzionale per la fattura elettronica
Se nel titolo si scrive NO , nella file XML della fattura elettronica verrà estratta la Ragione Sociale al posto di Nome e Cognome

Parametri di personalizzazione:

DescDescPersX e DescDataPersX (X=1,2,3) per utilizzare fino a 3 campi 'data' e 3 campi 'testo', personalizzati


CF-Classi, Attributi e Codici di Riclassificazione

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Attributi(1-5)
Consentono di raggruppare i clienti, in fase di stampa anagrafiche e situazioni contabili.

Esempio: se con la classe 1 si vuole codificare la tipologia dei clienti, si possono creare come attributi della classe 1: (ep) ente pubblico, (un) università, (pr) privato etc. e nel singolo cliente si metterà, nel primo attributo, la sigla corrispondente alla sua tipologia e cioè ep o un o pr.

Vengono elencate le classi create con la gestione Classi ed Attributi. Se si rende necessario creare una nuova classe e si lavora in multiutenza, occorre, dopo averla creata, eseguire la funzione Rileggi parametri (dal menu Parametri e utilità) oppure uscire e rientrare nel menu per poterla utilizzare nel programma.

Codici di riclassificazione
Decodifica da tabella riclassificazioni.Impostando in ciascuno di questi campi un codice diverso è possibile ottenere bilanci riclassificati.


CF-Dati per Contabilità

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Codice banca
Decodifica dall'archivio Banche. Viene utilizzato per l'emissione degli effetti e per poter stampare sulla fattura emessa il nome della banca del cliente.

La ricerca del codice banca, oltre che per codice e descrizione, anche per ABI o ABI e CAB digitando l' ABI (completo o incompleto con * finale) oppure ABIçCAB (il carattere ç deve essere sempre scritto in fondo all'abi anche se non si mette anche il cab) e premendo il tasto F2 (lista per codice) o F3 (lista per descrizione).

Numero c/corrente
Se impostato viene inserito sulla scadenza.

Condizione di pagamento
Decodifica da archivio Condizioni di Pagamento.
E' la condizione che verrà proposta in fatturazione e in prima nota, durante la registrazione di fatture, per consentire la generazione delle scadenze. La condizione può tuttavia essere variata all'occorrenza documento per documento.
2' Condizione di pagamento
E possibile definire una seconda condizione di pagamento da utilizzare in corrispondenza ai Tipi documento in cui è richiesta questa opzione (da utilizzarsi, ad esempio, per applicare in automatico un pagamento a 30 in certi casi e a 60 in altri casi)

Raggruppo Ricevute Bancarie
Se impostato a Si verrà emessa un'unica ricevuta bancaria a fronte di più scadenze con la stessa data.

Mesi no emissione effetti
Indicano i mesi nei quali, per il cliente, non devono essere emessi effetti; pertanto gli effetti scaduti in tali mesi (da 01 a 12) saranno spostati al giorno del mese successivo specificato nel campo seguente.

Giorno mese successivo
E' il giorno del mese successivo al mese di non emissione effetti in cui spostare la scadenza.
Se questo campo si lascia vuoto, le scadenze riprenderanno con regolarità dal mese successivo a quello saltato (verranno cioè tutte spostate di un mese).
Nel caso di scadenza a giorno fisso se qui verrà messo il giorno fisso già impostato sulla condizione di pagamento, in quel giorno, del mese successivo a quello saltato, verranno emesse 2 scadenze.

Codice IBAN
E' la coordinata bancaria internazionale del cliente. Il contenuto di questo codice varia a seconda della nazione con un massimo di 34 caratteri alfanumerici. Per l'Italia la lunghezza è di 27 caratteri: IT, 2 caratteri di controllo internazionali, 1 carattere alfabetico di controllo nazionale (CIN), 5 caratteri numerici per il codice ABI, 5 per il CAB, 12 caratteri alfanumerici per il numero di conto.
Eliminando dall'IBAN i primi 4 caratteri si ottiene il codice BBAN. Serve per incassi e pagamenti.

Codice B.I.C.
Codice internazionale di 8 o 11 caratteri che identifica le banche (swift). Serve per incassi e pagamenti internazionali.

C/Partita
Se valorizzato verrà proposto in Input Prima Nota come conto di ricavo/costo nella registrazione di fatture.

Solo in Gestione fornitori:
Caricamento fatture XML (solo per Fornitori)
Indica da dove prendere il conto di costo, in fase di caricamento del file XML di una fattura passiva, se dal fornitore o dall' articolo.
E' possibile creare il parametro di personalizzazione ContoPrior per impostare per tutti i fornitori lo stesso punto da cui prelevare il conto.

Cliente collegato (per registrazione acquisto Intracee e Reverse_Charge))
Nel caso di un fornitore intracee o per il quale devono essere registrate delle fatture di Reverse-Charge (settore edilizia), in questo campo si dovrà inserire il codice del cliente che verrà utilizzato per la generazione automatica della fattura di vendita da inserire in parallelo all'acquisto.

Vedi Registrazione acquisti intracee e Reverse-Charge.

Categoria
Decodifica dalla tabella Categorie. Consente di stampare elenchi ordinati per categoria.
E' possibile definire varie categorie di clienti in modo da applicare sconti diversi in bolla o fattura. (Esempio: occasionali, a rischio etc.)

Zona
Decodifica dalla tabella Zone. Se valorizzato consente di suddividere i clienti per zona, nelle stampe della rubrica, delle etichette e della situazione contabile.

Moneta
E' il codice della moneta utilizzata dal Cliente se diversa dalla standard della ditta. Viene utilizzata nell'input di prima nota per l'inserimento di articoli in valuta (nelle vendite viene utilizzata la moneta del listino).

Lingua
Decodifica dalla tabella lingue. Indica la lingua da utilizzare per la descrizione degli articoli nei documenti di vendita. Ha senso inserirla solo se si intende utilizzare le descrizioni in lingua.

Fido
E' l'importo del fido che si può attribuire al cliente.

Rischio
E' un segnale da inserire manualmente nei clienti per indicare il grado di rischio (S/N)
Potrà poi essere aggiornato automaticamente da elaborazioni che confrontano il fido con lo scoperto, potrà essere richiamato in emissione documenti per segnalazioni.

Soggetto a Ritenuta d'acconto (solo fornitori)
Se spuntato verrà generata in automatico la riga o la registrazione per l'importo della ritenuta d'acconto quando si registra, in prima nota, una fattura del fornitore in oggetto.
Leggere il paragrafo: Ritenuta d'acconto fornitori per vedere quali campi occorre impostare per avere l'automatismo.

Percentuale Ritenuta d'acconto (Fornitori)
Utilizzata dal programma di input prima nota per calcolare e registrare la Ritenuta d'acconto, nel momento in cui si registra la fattura di acquisto di un fornitore che ha questa percentuale valorizzata. Se la percentuale è uguale per tutti i fornitori questa può essere inserita una volta per tutte in Parametri comuni (Dati generali azienda-parametri) e verrà proposta su ogni fornitore.

Se solo qualche fornitore ha la ritenuta d'acconto ma la percentuale è la stessa, essa può essere messa direttamente sulla causale utilizzata per la registrazione della fattura d'acquisto.

In Elenco (allegati)

  • Da stampare in Elenco clienti di fine anno
  • Da non stampare in Elenco
  • Da stampare e R.Acconto
  • Dogana (cioè da totalizzare in allegati come importazioni)

Cliente Fittizio
Impostare a SI in corrispondenza al fornitore Carta Carburante al fine che venga inserito nello Spesometro

E' un segnale che indica, solo per le aziende in semplificata, che si tratta di un cliente fittizio creato per poter stampare i registri iva in modo corretto.

Valuta
Indica se il cliente può avere documenti in valuta. (Potrebbe esserci il codice valuta e c'è un flag se vuole gestire le scadenze in valuta)

Date procedura concorsuale da ... a ...
Occorre impostare almeno la data iniziale se si sta utilizzando il regime dell'Iva per cassa e il cliente ha in corso una procedura concorsuale. L'iva delle fatture emesse a questo soggetto e non ancora incassate, anche da più di un anno, non dovrà essere versata.

Iva per Cassa disabilitata
Se impostato a Si indica che le fatture emesse a questo cliente NON seguono mai il regime dell'iva per cassa

Indirizzo amministrativo
Decodifica da Tabella Indirizzi di Spedizione.
E' il codice dell'indirizzo a cui va spedita la fattura. E' utilizzato in fatturazione. In creazione di una nuova anagrafica si possono inserire gli indirizzi collegati solo una volta che l'anagrafica stessa è stata salvata.
Per la creazione dell'XML della fattura elettronica è stato introdotto il parametro IndAmmSede per avere nei dati della Sede del cliente (cessionario) quelli dell'indirizzo amministrativo al posto di quelli della sua anagrafica

Codice cointestatari
E' il codice che consente di collegare il cliente con eventuali altri clienti, quando c'è la necessità di emettere fatture cointestate. Vedi Clienti cointestari

Comunicazione dati fatture
La normativa prevede che vengano trasmessi tutti i documenti emessi e ricevuti

  • Normale o Sempre
    Verranno trasmessi TUTTI i documenti
  • Escluso
    Nessun documento di quel cliente/fornitore verrà comunicato

Resta comunque la possibilità di intervenire manualmente sulle registrazioni per variare il campo che dice se, quella singola registrazione, va trasmessa o meno.

Dati dichiarazione di intento (Solo clienti)
Dalla versione 3.03B è consigliabile inserire le dichiarazioni di intento nella maschera apposita del cliente.
I dati che seguono vengono utilizzati dalla stampa della Comunicazione dei dati contenuti nelle dichiarazioni di intento ricevute e, se abilitato il parametro di personalizzazione DichIntentiTesto, in stampa Fattura.
Versioni precedenti la 3.03B:
Data di ricevimento
Poiché le dichiarazioni ricevute vanno comunicate all'agenzia delle entrate, il programma di stampa selezionerà i clienti in base a questa data ricevimento.
Numero progressivo assegnato dalla ditta
E' il numero progressivo che la ditta assegna ad ogni dichiarazione di intento che riceve da un suo cliente
Numero progressivo e data della dichiarazione
Sono rispettivamente numero e data della dichiarazione di intento consegnata dal cliente
La dichiarazione si riferisce a:

  • Una sola operazione per un importo pari a euro: seguirà la richiesta dell'importo
  • Operazioni fino a concorrenza di euro: seguirà la richiesta dell'importo
  • Operazioni comprese nel periodo da .. a .. : seguirà la richiesta delle date che individuano il periodo


CF-Dati per fatturazione

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Listino
Decodifica dalla tabella Listini.
Indica il codice del listino da applicare al cliente. Se verrà lasciato vuoto si applicherà il listino principale inserito in tabella di magazzino.

Per i fornitori, indica il listino che verrà utilizzato in fase di caricamento ordini di acquisto. Se viene lasciato vuoto si utilizzerà l'ultimo costo (oppure il listino definito nella tabella acquisti).

Iva ad esigibilità differita
Fino al dicembre 2014, se il cliente è un ente pubblico le fatture verranno emesse in iva sospesa. Dal 1 gennaio 2015 netra in vigore il meccanismo dello Split Payment per cui questo flag sul cliente Ente Pubblico va sbiancato.

Se l'azienda gestisce i livelli: Livelli su Xml
In base a questo campo si stabilisce come esplicitare sul file XML della fattura elettronica, le righe di articoli con livelli

  • Standart
    E' il valore di default impostato sul cliente dal programma. In questo caso il programma di preparazione dell'XML va a cercare il parametro di personalizzazione: NoStampaLivelli
  • No articolo principale
    Verranno elencate tutte le righe dei livelli ciascuno con quantità e prezzi
  • Solo articolo principale
    Verrà riportata solo la riga dell'articolo principale con la somma delle quantità e dei prezzi delle singole righe dei livelli
  • Prezzo sui livelli
    Verrà stampata la riga articolo senza prezzo seguita dalle righe dei livelli ciascuna col suo prezzo
  • Prezzo su riga articolo
    Verrà stampata la riga articolo con il prezzo totale , seguita dalle righe dei livelli con prezzo a 0

Sconto
Il campo riporta una o più percentuali di sconto (nella forma 2+5+3, da calcolarsi in cascata) indicate nella procedura come sconto cliente. A fianco verrà riportato lo sconto calcolato.

Codice iva
Decodifica dalla Tabella dei codici iva.
Il campo dovrà essere valorizzato solo nel caso in cui il cliente sia soggetto ad una particolare esenzione o ad una particolare aliquota, sempre.

Estrarre in Tessera Sanitaria
impostare a No sui clienti le cui fatture non dovranno essere trasmesse.
Il programma di estrazione estrae i documenti dei clienti che hanno questo flag impostato a Si, che sono Persone Fisiche, con Codice Fiscale valorizzato, Partita Iva vuota e Flag Fittizio diverso da Si.

Vettore
Decodifica da tabella Vettori.
Indica il codice del vettore che abitualmente recapita la merce al cliente. Se impostato viene proposto al momento dell'emissione bolla/ddt o fattura accompagnatoria e viene stampato sui documenti.

Resa
Decodifica da tabella Rese.
Indica il modo in cui, solitamente, viene fornita la merce al cliente (es. Porto Franco). Viene presentato come default in fatturazione tra i dati di accompagnamento dei documenti.

Codice Spesa
E' il codice della spesa da portare sui documenti di Vendita, se impostato.
In Preventivi, Ordini, Ddt e Fatture è possibile, una volta inserito il documento ed entrati nel quadro spese, premere il pulsante [image] (E) sp(E)se cliente e generare in automatico una riga di spese con il codice spesa scritto in anagrafica cliente.
Se si imposta il parametro di personalizzazione SpesaClieAutom a S , i suddetti programmi caricheranno in automatico tale spesa.

Dati per lettera di Intenti
Utilizzato per la compilazione del campo riferito alla lettera di intenti sui documenti e per la successiva stampa in fattura.
Se questo campo viene lasciato vuoto , per i clienti che hanno comunicato la lettera di intenti e per i quali è stata compilata una riga nella maschera 0-DichInt il campo nella testata dei documenti verrà impostato come specificato nel parametro DichIntentiTab
In alternativa si può scrivere qui la frase completa da riportare mettendo come primo e ultimo carattere di questo campo el campo § (paragrafo), (in questo caso il parametro di personalizzazione verrà ignorato e verrà sostituito integralmente con il contenuto di questo campo)
oppure si può scrivere il solo articolo di esenzione e compilare il parametro DicIntentiTab in modo particolare (vedi spiegazioni)

[Versioni precedenti la 4.01 - La compilazione di questo campo è in alternativa alla compilazione dei dati relativi alla Comunicazione dichiarazioni di intento ricevute, presenti nella sezione: dati Contabilità del cliente.
Se il cliente ha mandato la lettera di intenti (in quanto esportatore abituale) si può inserire qui il numero, la data etc.
Il programma di stampa Fatture, in corrispondenza ai clienti per i quali questo campo è compilato, stamperà, a fine corpo, un testo così composto:
una parte fissa (che si può scrivere in tabella di fatturazione)
il contenuto del campo in oggetto
una parte finale che si può scrivere nel parametro di personalizzazione DichIntentiDopo.
Es. se la parte fissa è:
Operaz.non impon.ai sensi degli art.8/8 bis-9 del DPR 633/72 come da vostra dich.di intento
In questo campo si scriverà: N' … del xx/xx/xxx]

Addebito bolli
Viene utilizzato in fatturazione. Se impostato ad Si verranno addebitati al cliente i bolli in fattura calcolati in base agli importi inseriti in tabella bolli.

Addebito Spese bancarie
Utilizzato in fattura per sapere se addebitare o meno le spese bancarie al cliente quando vengono emesse delle ricevute bancarie.

Stampa Riferimento Preventivo/Ordine
Indica se sui documenti che evadono un preventivo o ordine dovrà essere scritto numero e data dell'ordine/preventivo di provenienza (Ordine/Preventivo n. xxx del xx/xx/aaaa).
Nella tabella di fatturazione è possibile indicare un modo generale di operare, potranno però fare eccezione quei clienti per i quali verrà personalizzato questo campo.
Se si sceglie di evidenziare il riferimento dal documento di origine, è possibile personalizzare la scritta che precede nr. e data, scrivendola sul tipo documento.

  • Come da tabella di fatturazione
  • No
  • Si
  • Preventivo
    Solo sui documenti che evadono un preventivo verrà stampato il riferimento ad esso
  • Ordine
    Solo sui documenti che evadono un ordine verrà stampato il riferimento ad esso

Stampa Riferimento Cliente
Indica se si deve stampare sui documenti (ordini, Ddt, fatture) il campo Riferimento Cliente impostato nella testata. Per i documenti generati da una evasione sarà la fase di evasione a portare o meno il campo sul documento a seconda di questo flag.
Nella tabella di fatturazione è possibile indicare un modo generale di operare, potranno però fare eccezione quei clienti per i quali verrà personalizzato questo campo.
T- Come da tabella di fatturazione /S/N

Prezzo in Bolla/DdT
Indica cosa si vuole stampare nel corpo dei documenti di trasporto a livello di prezzi e sconti.

  • Come da Tipi Documenti di Fatturazione
  • Non stampa i prezzi
  • Stampa prezzi di listino e sconti
  • Stampa prezzi di listino
  • Prezzi al netto degli sconti
  • Prezzi di listino, Sconti, Totale di riga ivato
  • Prezzi al netto dello sconto, ivati e Totale di riga ivato

Raggruppo bolle/ddt
Viene utilizzato in fatturazione.
Indica come devono essere raggruppate le bolle/ddt in fattura riepilogativa.

  • S - tutte le bolle/ddt del cliente vengono riepilogate in un'unica fattura.
  • N - verrà emessa una fattura per ogni bolla.
  • A - gli articoli verranno raggruppati, in evasione, per codice per cui compariranno una sola volta in fattura con una quantità che sarà la somma delle quantità dei vari ddt. Verrà inoltre stampato l'elenco (numero e data) delle bolle/ddt alle quali tali articoli appartengono.
  • Questo metodo viene utilizzato da chi fa consegne ripetitive agli stessi clienti per gli stessi prodotti, ad esempio i panifici.
  • D - le bolle verranno riepilogate per destinazione.
  • E - Come A + D

Raggruppo ordini
Viene utilizzato in evasione ordini per decidere se si possono evadere in un unico documento più ordini dello stesso cliente o se devono generare documenti separati.

  • Si
    Raggruppa sempre
  • No
    Ogni evasione genera documenti diversi
  • A parità di Ordine
    Consente di raggruppare in un' unico fattura i ddt generati dallo stesso ordine
  • A parità di Contratto
    Consente di generare un'unica fattura a fronte di ordini (ddt) che fanno riferimento allo stesso contratto.

Soggetto a Cassa Previdenza
Se il campo è impostato a Si e in tabella parametri (Causali comuni) è stato impostato il codice spesa per Cassa Previdenza, quando si emette fattura al cliente, verrà calcolato in automatico l' importo della Cassa Previdenza.

Soggetto a Ritenuta d'acconto (Clienti)
Se spuntato verrà generata in automatico la riga o la registrazione per l'importo della ritenuta d'acconto quando si registra, in prima nota, una fattura del cliente in oggetto.
Leggere il paragrafo: Ritenuta d'acconto per vedere quali campi occorre impostare per avere l'automatismo.

Percentuale Ritenuta d'acconto (Clienti)
Se sulla fattura che si emette al cliente (con il programma di emissione fatture), va calcolata e contabilizzata la Ritenuta d'acconto, si può inserire qui la percentuale per il calcolo. Se la percentuale è uguale per tutti i clienti questa può essere inserita una volta per tutte in Parametri comuni (Dati generali azienda-parametri) e verrà proposta su ogni cliente.

Tale percentuale può essere inserita anche solo su una particolare causale contabile (di tipo fattura) collegata al tipo documento con il quale verranno emesse le fatture dirette o accompagnatorie con ritenuta d'acconto.
Nota: nel caso la ritenuta d'acconto debba essere calcolata NON sul 100% ma su una diversa percentuale dell' imponibile si dovrà impostare nel campo percentuale un numero ZZZZ,XXY ottenuto in questo modo:
ZZZZ è la percentuale ritenuta moltiplicata per 100 , XX è la parte intera della percentuale dell'imponibile su cui va applicata la ritenuta, Y l'eventuale parte decimale
(ES. 2300,010 corrisponde al 23% sul 1% dell' imponibile
2300,500 corrisponde al 23% sul 50% dell' imponibile
2300,505 corrisponde al 23% sul 50,5% dell' imponibile

Indirizzo di spedizione
Decodifica da Tabella Indirizzi di Spedizione.
E' il codice dell' indirizzo a cui va spedita la merce del cliente se diverso dall'indirizzo del cliente stesso.
E' utilizzato in fatturazione. In creazione di una anagrafica si possono inserire gli indirizzi collegati solo una volta che l'anagrafica stessa è stata salvata.

Agente 1 e 2
Decodifica dalla tabella Agenti. E' necessario inserirlo se si intendono gestire le provvigioni.

Provvigioni (1 e 2) (%)
Indica la percentuale di provvigione legata al cliente con riferimento rispettivamente all' agente 1 e all'agente 2.

Estrazione Percentuale Provvigioni (1 e 2)
Indica ai programmi di emissione documenti da dove prendere la percentuale di provvigione per l'agente 1 e l'agente 2
Può assumere i seguenti valori:

  • N Per il cliente non vengono gestite le provvigioni
  • A Percentuale da estrarre dall'articolo di magazzino
  • C Dal cliente
  • G Dall'agente

Se da agente o da cliente e sono valorizzati entrambi i codici agenti, verranno portate sul documento le rispettive percentuali di provvigione.
NOTA:
Dalla versione 2.01 del novembre 2008, momento nel quale è stata aggiunta la possibilità di definire, sul cliente e sulle testate documenti, il "Tipo provvigione" per entrambi gli agenti, è stato modificato il fatto che:
"se la percentuale di provvigione viene presa dall'articolo, verrà attribuita solo al primo agente"
in quanto, per decidere la provvigione di ciascun agente, si va a vedere il rispettivo "Tipo provvigione".

Percentuale maggiorazione automatica per creazione listino di vendita (fornitori)
Al momento del caricamento in magazzino di un movimento di acquisto è possibile, attivando il parametro di personalizzazione: ListVenDaAgg, aggiornare un listino di vendita degli articoli acquistati, con un valore pari al costo inserito sulla riga maggiorato di una percentuale che può essere derivata dal fornitore (o dalla tabella di magazzino se è uguale per tutti i fornitori) o dall'articolo.

Codice Destinatario (IPA)
E' il codice che identifica il destinatario della fattura elettronica. Per le fatture emesse verso la Pubblica Amministrazione, è un campo obbligatorio che identifica l'ufficio, appartenente all'Amministrazione di cui all'art.1 del DM 03 aprile 2013, n.55.
Fattura elettronica tra privati
Se si prepara la fattura elettronica per un cliente privato (cioè non PA) in questo campo si dovrà inserire il codice, di 7 caratteri, assegnato dal Sdi ai soggetti che hanno accreditato un canale. Qualora il destinatario non abbia accreditato un canale presso Sdi e riceva le fatture via PEC , si dovrà compilare il Codice IPA con sette 0 (0000000) e compilare sul cliente l'indirizzo email per la Pec (di default l'indirizzo amministrativo) Vedi Parametro EmailPEC
Nel caso che il cliente al quale si emette fattura elettronica sia straniero, il campo andrà impostato con XXXXXXX
Se sul cliente, non si compila questo campo , esso potrà comunque essere compilato sulla fattura stessa, anche in considerazione del fatto che a uno stesso cliente (ente pubblico) possono corrispondere più uffici (e quindi più codici) a cui inviare fatture diverse.

Codice Eori e Titolo (titolo onorifico)
Campi utilizzati nella fattura elettronica ma facoltativi

Allegare PDF nel file XML
Consente di specificare se, per questo cliente, si vuole allegare la stampa della fattura in formato pdf, quando si genera il file XML della fattura elettronica. Se si sceglie di allegare il file pdf, questo dovrà essere stato generato con una precedente stampa
Le possibilità sono:

  • In base alla scelta nel programma di stampa
  • Sempre
  • Mai


CF-Note per Documenti

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Sono campi note che, se impostati, possono essere stampati sui documenti corrispondenti a condizione che siano state inserite, rispettivi filtri, le righe che fanno riferimento a questi campi.
Nomi dei campi:
D.PianoConti. seguito rispettivamente da:
NoteOrdini
NoteDdt
NoteFattura
NoteFatacc

Il contenuto del campo 'NoteFattura' verrà riportato come riga descrittiva nel corpo, sul file XML della fattura elettronica
Per variare questa impostazione vedere il parametro: NoteClie


CF-Documenti

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

In questa sezione è possibile associare ad ogni cliente o fornitore uno o più documenti. In ogni punto della procedura dove si chiede un codice cliente e si può entrare nella lista di aiuto (tasti F2 o F3) una volta posizionati su un cliente di tale lista è possibile caricare il primo documento scritto nella lista dei suoi documenti premendo il pulsante: (Y) Lancia il primo documento associato oppure Alt Y.

Per inserire una riga con un documento collegato occorre innanzitutto digitare due caratteri per determinare l'ordine che deve avere quel documento nella lista, poi una descrizione a piacere e infine il percorso che individua il file associato. Il nome del file da associare si può digitare oppure cercare, premendo l'icona [image] (X) Documenti e alla conferma verrà scritto nel campo percorso il percorso completo del file individuato.

Una volta inseriti i nomi dei file collegati, ci si può posizionare su una qualsiasi delle righe valorizzate e caricare il file corrispondente con il pulsante: (Y) Apri documento.
Al fine di poter accedere da terminali diversi allo stesso file che viene visto in indirizzi diversi, è possibile specificare il percorso utilizzando un parametro apposito da creare nell'AziWin.ini.


CF-Email

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Contiene gli indirizzi email disponibili per l'anagrafica in oggetto. Per una stessa anagrafica è possibile gestire fino ad un massimo di 4 indirizzi.

Sarà possibile utilizzare questi indirizzi al momento dell'invio per email di una stampa qualsiasi o di un documento (preventivo etc.)

Si possono definire indirizzi diversi a cui inviare i preventivi o le conferme d'ordine, piuttosto che le fatture.

Indirizzi: Principale, Amministrativo, Commerciale, Magazzino
E' possibile tramite l'impostazione di parametri di personalizzazione, cambiare la descrizione, a video, di questi campi.
Parametri: DescEmail

Quale email usare per:
Invio Fatture, Ddt, Ordini/Preventivi, altre stampe, PEC

L'impostazione di questi campi consente di diversificare gli indirizzi a cui inviare i documenti.
I programmi spediranno le email, se presenti i vari indirizzi, rispettivamente:
le fatture all'indirizzo 'Amministrativo'
preventivi-ordini-ddt all'indirizzo 'commerciale'
le altre stampe a quello 'Principale'

Come indirizzo Pec di default, viene scelto quello Amministrativo (preparazione XML della Fattura Elettronica)
Se tale indirizzo manca, NON viene scaricata nessuna PEC.
E’ possibile creare il parametro di personalizzazione: PecNoAltreEmail Gruppo: XML con valore N in modo che se l'indirizzo PEC del cliente è vuoto utilizza il primo indirizzo email che trova tra i primi 2 presenti sulla maschera

Con questi campi, l'operatore può definire destinazioni diverse da quando specificato come standard. E' possibile tuttavia, per non intervenire su ogni anagrafica, cambiare in modo generalizzato l'impostazione standard, tramite la creazione di parametri di personalizzazione: EmailPreDef

Durante la stampa dei documenti (ordini,... , fatture) nella maschera di richiesta dei parametri per Pdf ed Email, vengono proposti, in 'Indirizzo Email a cui si invia', due campi:
Valore predefinito o Valido per tutti e il tipo di indirizzo che verrà utilizzato (Es. amministrativo per le fatture).
Lasciando inalterato, se sul cliente c'è l'indirizzo amministrativo utilizzerà quello altrimenti quello principale, in alternativa si può variare. Se si stampano più documenti da inviare a clienti diversi (es. fatture riepilogative), si può ad esempio impostare di utilizzare: Valido per tutti - Il Principale

'Valore predefinito' indica che verrà utilizzato l'email indicata nell'anagrafica clienti per il tipo documento da stampare; se quel valore è stato lasciato nella modalità predefinita viene usata l'email impostata dal programma o dal parametro di personalizzazione EmailPreDef
I valori predefiniti dal programma sono:

  • Amministrativo (2) per le fatture
  • Commerciale (3) per Preventivi, Ordini e Ddt

Può essere variato al momento scegliendo: Valido per tutti, nel caso di stampa/invio fatture riepilogative a più clienti.

L'altro campo indica qual'è l'email che verrà utilizzata (Amministrativo - Commerciale - Magazzino - Principale)
Può essere variato al momento. Se, sul cliente, la email che si sceglie non è valorizzata , verrà utilizzata l'email principale.

Per tutte le stampe è possibile indicare una email temporanea da usare solo per quella stampa.
Si può digitare sul posto oppure cercare, tramite il tasto F2 o il pulsante di aiuto [...], l'indirizzo di un cliente o di un fornitore.
Se si preme F3 si ottiene un elenco, di Clienti e Fornitori, ordinato per Ragione Sociale.
Per avere solo i Clienti: C poi F3 , solo i Fornitori: F poi F3
Con F4 si cerca per partita iva - Con F5 per Codice Fiscale

L'elenco ha, come intestazione degli indirizzi email, quelli eventualmente impostati con i parametri DescEmail.
Una volta ottenuto l'elenco, se un cliente ha più indirizzi di email, si può sceglierne uno con un click sull'indirizzo voluto.
Se si clicca in un posto diverso, verrà preso l'indirizzo definito, con il parametro EmailPreDef, per il tipo di stampa in cui ci si trova.
Il valore Predefinito è: Principale (1)

Parametro EmailPEC (Gruppo: stFatture) indica quale email considerare come PEC (di Default è la seconda cioè quella amministrativa)


CF-Dati dichiarazioni di Intenti

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Negli anni la normativa è cambiata prevedendo a volte l'invio da parte del fornitore e a volte da parte del cliente con informazioni cambiate nel tempo, dal primo gennaio 2020 è entrato in vigore una nuova normativa
che prevede che l'esportatore abituale invii la dichiarazione di intento all'agenzia delle entrate e fornisca al fornitore il protocollo di ricezione che è l'unica informazione che deve essere riportata nella fattura,
mentre non è più obbligatorio riportare altre informazioni né mantenere altri registri.
Per le versioni precedenti si rimanda più sotto

Dal primo gennaio 2020 si può inserire nell'anagrafica cliente nella gestione della dichiarazione di intenti il protocollo di ricezione dell'agenzia delle entrate e una data di ricezione (al momento è importante
l'anno che deve essere quello della dichiarazione di intenti)

E' possibile inserire nelle testate di Ordini - Ddt - Fatture il codice di riferimento della lettera di intenti che servirà per identificare i dati per la compilazione del testo della nota da stampare sulla fattura e per mostrare a video i totali degli ordini , ddt e fatture collegati alla stessa lettera di intenti.
I totali visualizzati a fondo video in questa maschera sono quelli relativi alla riga corrente.
Al momento dell'inserimento di una fattura, sia nel caso di evasione da documenti quali ordini o DDT, sia nel caso di inserimento diretto di fatture, il programma controllerà se, per il cliente, c'è almeno una riga attiva in questa tabella; in questo caso verrà compilato il testo della nota da stampare sulla fattura, personalizzabile tramite il parametro di personalizzazione DichIntentiTab
Se manca il parametro di personalizzazione il programma scriverà la frase:

Oper. non imponib.ai sensi ART.8/C DPR 633/72 e succ.mod.
Protocollo ricezione agenzia delle entrate: xxxxx

Dove al posto di xxxxx verrà riportato il numero protocollo di ricezione dell'agenzia delle entrate

Sul file xml della fattura elettronica, la frase suddetta verrà riportata come riga descrittiva alla fine del corpo.

Versioni Precedenti

Per Fornitori (Per Clienti vedi **)

La stessa dichiarazione, unitamente alla ricevuta di presentazione rilasciata dall'Agenzia delle Entrate, va poi consegnata al fornitore o prestatore, oppure in Dogana.
Il programma di Stampa e preparazione file della Dichiarazione d' Intenti considererà il fornitore come 'Dogana' se nel fornitore è stato compilato il campo 'In Elenco Fornitori (Allegati)' con il valore Dogana o Importazioni

Al fine di poter stampare il modulo della Dichiarazione d'intento e di preparare il file telematico, occorre compilare, sui fornitori interessati, alcuni campi con i dati da trasmettere.

Codice
E' il numero che identifica la riga
Descrizione
Descrizione della merce.
Attivo
Indica se la riga riporta dei dati che sono:

  • S - Attivi
    dati per i quali deve ancora essere Stampata la Dichiarazione d'intenti
  • X - Attivi e già Stampati
    dati per i quali è già stata Stampata la Dichiarazione d'intenti (è ammessa la Ristampa)
  • Non attivi
    Dati di anni precedenti da non elaborare più

Numero e data (Anno) della dichiarazione
Le dichiarazioni DEVONO essere numerate progressivamente all'interno dell'anno.
Si può ottenere automaticamente il numero progressivo, premendo il pulsante a destra nel campo Numero, a condizione che sia stata impostata la data della dichiarazione facendo attenzione particolare all'anno.

Riferimento:
indica a cosa si riferisce la dichiarazione. E' obbligatorio inserire un numero (1,2,3) a seconda di cosa si vuole indicare, come descritto in seguito.
Nel caso di un fornitore che indica Dogana o Importazione (dato da inserire nella maschera (4) Contabilità nel campo 'In Elenco Cli/For') , il campo Riferimento potrà assumere SOLO i valori 1 o 2 inserendo, nel caso del 2, l'importo corrispondente all'ammontare della quota parte del proprio plafond Iva che si presume di utilizzare all'importazione nell'anno solare.

  1. Una sola operazione per un importo fino a euro: seguirà la richiesta dell'importo
  2. Operazioni fino a concorrenza di euro: seguirà la richiesta dell'importo
  3. (Non più attiva dal marzo 2017: Operazioni comprese nel periodo da .. a .. : seguirà la richiesta delle date che individuano il periodo)

Non vengono utilizzati i campi:
Numero progressivo assegnato dalla ditta
E' il numero progressivo che la ditta assegna ad ogni dichiarazione di intento che riceve da un suo cliente
Data di ricevimento
Poiché le dichiarazioni ricevute vanno comunicate all'agenzia delle entrate, il programma di stampa selezionerà i clienti in base a questa data ricevimento.

Per la Gestione Clienti

In questa maschera dovranno essere inseriti i dati delle eventuali dichiarazioni di intenti ricevute da parte dei clienti esportatori abituali, in modo da poter fare il controllo di non superamento del plafond, durante la preparazione di Ordini, Ddt e Fatture e di stampare sulle fatture la nota per l'esenzione.
Ogni dichiarazione è individuata da un segnale di Attiva Si o No in modo da mantenere memorizzate anche le eventuali dichiarazioni consegnate in periodi precedenti e non più attive.
Se un cliente NON avesse più, ad un certo momento, nessuna dichiarazione attiva, basta mettere a No tutte le righe di questa tabella.

Da marzo 2017, essendo stata eliminata la possibilità di avere importi utilizzabili da data a data. E' stato chiarito che nel caso in cui sia stata presentata una dichiarazione d’intento con il vecchio modello nel quale siano stati compilati i campi “operazioni comprese nel periodo da … a …” (es. dall’1/1/2017 al 31/12/2017), la dichiarazione non ha validità per le operazioni di acquisto da effettuare a partire dal 1° marzo 2017
e pertanto deve essere presentata una nuova dichiarazione d’intento utilizzando il nuovo modello.
Il plafond ivi indicato è da considerarsi annuale e quindi dovrà anche tenere conto delle operazioni già effettuate con il medesimo soggetto a decorrere dal 01/01/2017.
Il numero di protocollo di questa nuova dichiarazione deve essere il medesimo della lettera precedentemente ricevuta dallo stesso soggetto.

Viceversa, nel caso in cui venga presentata una dichiarazione d’intento con il vecchio modello nel quale sia stato compilato
il campo 1 “una sola operazione per un importo fino ad euro” o il campo 2 “operazioni fino a concorrenza di euro”,
la dichiarazione ha validità, fino a concorrenza dell’importo indicato,
rispettivamente per la sola operazione o per le più operazioni di acquisto effettuate anche dopo il 1° marzo 2017.

Dal 2015 i dati di questa gestione non servono più per la comunicazione del modello della Dichiarazione d'intento, che dovranno invece essere compilati sull'anagrafica del fornitore in quanto sarà la ditta stessa (se esportatore abituale) a compilarlo, mandarlo al fornitore e trasmetterlo telematicamente all'Agenzia delle Entrate.

L'utilizzo di questi dati è assolutamente consigliato rispetto al vecchio modo di inserire gli stessi.
 (Si consiglia di compilare questa maschera e sbiancare sia il campo 'Lettera di intenti', nella pagina dei dati di Fatturazione del cliente, sia gli estremi della dichiarazione di intenti, unica, scritti nella maschera dei dati di Contabilità del cliente)

Dal 2017 è possibile inserire nelle testate di Ordini - Ddt - Fatture il codice di riferimento della lettera di intenti che servirà per identificare i dati per la compilazione del testo della nota da stampare sulla fattura e per mostrare a video i totali degli ordini , ddt e fatture collegati alla stessa lettera di intenti.
I totali visualizzati a fondo video in questa maschera sono quelli relativi alla riga corrente.
Al momento dell'inserimento di una fattura il programma controllerà se, per il cliente, c'è almeno una riga attiva in questa tabella; in questo caso verrà compilato il testo della nota da stampare sulla fattura, personalizzabile tramite il parametro di personalizzazione DichIntentiTab
Se manca il parametro di personalizzazione il programma scriverà la frase:
Oper. non imponib.ai sensi ART.8/C DPR 633/72 e succ.mod.
Vs dich. nr. xxx del gg/mm/aa - ns. dich. nr. xx del gg/mm/aa

Sul file xml della fattura elettronica, la frase suddetta verrà riportata come riga descrittiva alla fine del corpo.

Se invece (vecchio metodo), gli estremi della dichiarazione di intenti, non sono stati inseriti in questa maschera, ma sono stati compilati sulla pagina dei dati di Contabilità del cliente ed è presente il parametro di personalizzazione: DichIntentiTesto, il campo sulla fattura verrà compilato utilizzando questi ultimi.
In questo caso però, se il cliente NON avrà più nessuna dichiarazione attiva, occorre andare manualmente a sbiancare tutti i campi relativi per evitare che vengano stampati sulle nuove fatture.

Infine (vecchio metodo), se gli estremi della lettera sono stati inseriti nel campo: Lettera di intenti (pagina dei dati di Fatturazione del cliente) verrà stampato il testo così come si trova in quel campo, preceduto dal contenuto del campo 'Testo per dich.intenti' della tabella 'Dati generali azienda - Parametri di Fatturazione).
Anche in questo caso, se il cliente NON avrà più dichiarazione di intenti, occorre sbiancare il campo sul cliente per evitare che venga stampato in fattura.
Significato dei campi per i Clienti:
Codice
E' il numero che identifica la riga
Descrizione
Descrizione della merce. Il che verrà sta
Attivo
Indica se i dati presenti sulla riga sono attivi, cioè da considerare nell'eventuale emissione di fattura, o no.
Numero e data della dichiarazione
Sono rispettivamente il numero e la data della dichiarazione di intento consegnata dal cliente
Numero progressivo assegnato dalla ditta
E' il numero progressivo che la ditta assegna ad ogni dichiarazione di intento che riceve da un suo cliente
Data di ricevimento
Poiché le dichiarazioni ricevute vanno comunicate all'agenzia delle entrate, il programma di stampa selezionerà i clienti in base a questa data ricevimento.
Riferimento:
indica a cosa si riferisce la dichiarazione. E' obbligatorio inserire un numero (1,2,3) a seconda di cosa si vuole indicare, come descritto in seguito:

[Componente di FrontPage Inclusione pagina]


CF-Rappresentante Fiscale / Stabile Organizzazione

Percorso: Archivi comuni - Anagrafiche - Clienti/Fornitori

Questi campi verranno utilizzati nella preparazione del file della Comunicazione Dati Fatture

Per entrambi i gruppi, se si compila uno dei campi, vanno compilati anche gli altri ad eccezione della provincia della Stabile Organizzazione

Rappresentante Fiscale
Dati opzionali che si possono compilare se il cliente/fornitore ha un rappresentante fiscale in ITALIA
Il codice Fiscale e lo Stato possono essere lasciati bianchi entrambi o se compilati, compilati entrambi.

Stabile Organizzazione
Dati che si possono compilare se il cliente/fornitore è non residente con Stabile organizzazione in ITALIA
Non sono obbligatori


CLIENTI COINTESTATARI

Percorso: Archivi Comuni - Anagrafiche

Questa funzione consente di definire la relazione tra un cliente, al quale viene emessa fattura, e tutti i suoi cointestatari al fine di ottenere una compilazione corretta dell' elenco delle Operazioni Rilevanti ai fini Iva (Spesometro).

I clienti cointestatari non devono comparire nei registri iva, giornale etc. mentre nell' elenco suddetto, andranno elencati tutti i cointestatari della fattura, ciascuno con la sua parte in base alla percentuale inserita in gestione altrimenti l'importo viene diviso per il numero dei cointestatari.

Prima di procedere all'inserimento dei dati con questa funzione, occorre aver creato tutte le anagrafiche dei clienti coinvolti nell' operazione, con la Gestione clienti, sia quella del cliente principale, sia quelle dei suoi cointestatari.

Successivamente si dovrà creare una nuova riga in questa gestione con un codice cointestatario (codice alfanumerico libero, può essere usato anche il codice stesso del cliente o parte della sua Ragione Sociale).
Tramite il pulsante [image] (E) Gestione cointestatari si procede ad elencare i codici dei clienti cointestati con questo.
E' possibile inserire, per ogni cointestatario, la percentuale di cointestazione. Questa servirà per suddividere adeguatamente il totale delle fatture intestate al 'cliente principale' sui vari cointestatari, in fase di preparazione dello Spesometro.
Se tale percentuale non viene compilata, si intende che tutti i cointestatari possiedono parti uguali della proprietà, se viene impostata solo per qualcuno, il resto verrà diviso in parti uguali sugli altri.

Infine occorre inserire sul cliente principale con la gestione clienti, il codice cointestatario in modo da creare il legame.

In fase di Ricalcalo progressivi per elenchi Clienti, il programma in presenza di una fattura intestata ad un cliente con codice cointestatario compilato, aggiornerà i progressivi iva anche di tutti i clienti cointestatari.

Per ottenere in stampa Fatture la stampa dei dati anagrafici del/dei cointestatari, occorre inserire nel filtro di stampa delle fatture le righe opportune. E' possibile stampare fino ad un massimo di 20 cointestatari per ogni fattura.
Vedi campi per filtro

NOTA BENE:
Se a uno stesso cliente si emettono fatture sia come singolo sia come cointestatario, questo dovrà essere presente in archivio con due diversi codici da utilizzare, l'uno per le fatture emesse a lui solo, l'altro, che dovrà avere nel campo cointestatario il codice opportuno, per le fatture cointestate.


INDIRIZZI CLIENTI

Percorso: Archivi Comuni - Anagrafiche

Contiene l'elenco degli indirizzi ai quali va spedita la merce o la fattura (indirizzo amministrativo) qualora siano diversi rispetto quelli inseriti in anagrafica clienti.

Questi indirizzi potranno essere richiamati nell' anagrafica del cliente in modo da averli in linea in automatico al momento dell'inserimento di un documento (ddt o fattura).

Per ogni cliente possono essere creati più indirizzi.

In creazione di una nuova anagrafica si possono inserire gli indirizzi collegati solo una volta che l'anagrafica stessa è stata salvata. L'annullamento di una anagrafica provoca la cancellazione degli indirizzi ad essa collegati.

E' possibile indicare se l'indirizzo sostituisce quello principale sul ddt e/o sulla fattura.

Vedere i parametri di personalizzazione IndSpedInv e IndSpedNoStesso per altri dettagli sulla stampa dei due indirizzi.

Per la stampa della fattura diretta/riepilogativa è possibile impostare il parametro IndAmmSep per mettere a disposizione separatamente l'indirizzo amministrativo.

Per la creazione dell'XML della fattura elettronica è stato introdotto il parametro IndAmmSede per avere nei dati della Sede del cliente (cessionario) quelli dell'indirizzo amministrativo al posto di quelli della sua anagrafica

Senza attivare parametri, se si vuole semplicemente replicare, nel caso manchi l'indirizzo di spedizione, l'indirizzo del cliente nello spazio riservato, nel filtro, all'indirizzo di spedizione, occorre testare nel filtro stesso, il parametro T_MancaSped e inserire le righe opportune come da esempio.

Nel caso in cui un cliente chieda di ricevere le Ri.BA. a un indirizzo diverso da quello in cui è stata spedita la fattura, è possibile inserire anche questo indirizzo. Perché venga riconosciuto come indirizzo per Ri.Ba. dal programma di generazione Distinta e del file delle Ri.Ba. occorre creare il parametro di personalizzazione IndirRiba assegnargli un valore XXX (es. 999)

Gli indirizzi Ri.Ba dei vari clienti verranno così individuati dal codice del cliente e dal numero XXX

(Es. l'eventuale indirizzo per Ri.Ba. del cliente 03-01-0001 dovrà essere creato con Codice indirizzo: 999, idem quello del cliente 03-01-0123 e così via)

Vedi anche fattura elettronica tra privati


STORICO ANAGRAFICHE

Percorso: Archivi Comuni - Anagrafiche

Nelle gestione delle anagrafiche Clienti e Fornitori è possibile effettuare la storicizzazione dei dati anagrafici nel caso in cui avvengano variazioni di dati riportati poi nei prospetti fiscali (registri iva, giornale) e nelle fatture.

Questa tabella contiene, per ogni codice cliente e fornitore, i dati anagrafici precedenti agli attuali, ordinati per data variazione.

I dati che si possono storicizzare sono:
Ragione sociale contabile, Ragione Sociale (parte 1 e 2), Indirizzo, Cap , Località , Provincia, Comune, Stato

Per la variazione di altri dati, in particolare Codice Fiscale o Partita Iva, si dovrà necessariamente creare una nuova anagrafica.


VARIAZIONE AUTOMATICA CLIENTI e FORNITORI

Percorso: Contabilità - Utilità - Utilità

La funzione consente di variare automaticamente il contenuto dei campi delle anagrafiche Clienti e dei Fornitori.

Segue un elenco di campi per i quali è possibile fare la variazione automatica.
Potrà essere modificato un campo per volta scegliendolo con un click.

Potrà essere modificato un campo per volta scegliendolo con un click, tra quelli elencati nella seconda parte della maschera.

Se il campo da modificare non è tra quelli elencati, potrà essere modificato con la scelta: Campo selez.
Con questa scelta verranno elencati tutti i campi dell'anagrafica e si potrà scegliere quello da modificare.

Nella colonna DA occorre impostare il contenuto attuale del campo da modificare, in colonna A, il nuovo contenuto.

Nelle selezioni iniziali, si chiede:
Se il campo "Da" viene lasciato vuoto, quali anagrafiche si intende modificare:

  • Tutti
    verrà scritto il contenuto del campo "A" su TUTTE le anagrafiche selezionate
  • Solo quelli con campo interessato vuoto
    verrà scritto il contenuto del campo "A" solo sulle anagrafiche selezionate che abbiano il campo interessato "Vuoto"

Se invece viene lasciato bianco il campo "A" verrà sbiancato quel campo su tutte le anagrafiche selezionate, in cui il contenuto del Campo "Da" è quello digitato.


CONTROLLO PARTITA IVA E CODICE FISCALE

Percorso: Contabilità - Servizio - Stampe

Il programma, oltre a controllare la correttezza della Partita Iva e/o del Codice Fiscale inseriti sulle anagrafiche dei clienti e dei fornitori e a stampare quelli errati, consente di evidenziare quelli con partita iva doppia e/o con dati anagrafici incompleti.

Scelta dei soggetti da controllare (Clienti o Fornitori, tutti o solo un intervallo di codici).

Il controllo può essere fatto

  • su tutte le anagrafiche scelte
  • solo su quelle Movimentate in un determinato anno (il controllo del movimentato viene fatto sulla presenza di registrazioni sui registri iva)

Solo clienti/fornitori che hanno segnalazioni

Se spuntato, vengono stampate solo le anagrafiche (comprese nelle selezioni indicate) per cui risulta almeno una segnalazione tra quelle previste dal programma e/o quelle aggiuntive selezionate (vedi "Segnalazioni aggiuntive" [**] ) .

Se non spuntato, vengono stampate anche le anagrafiche (comprese nelle selezioni indicate) per cui non risulta alcuna segnalazione.

Segnalazioni aggiuntive [**]

  • C.Fisc.=P.Iva
    Se spuntato, vengono segnalate anche le anagrafiche con Cod.Fiscale uguale a P.Iva (nel campo Codice Fiscale c'è una Partita Iva).
    Questo caso, in stampa viene segnalato con: "CF contiene PI"
  • Anagrafica incompleta
    Se spuntato, vengono segnalate anche le anagrafiche che risultano incomplete (cioè manca o la Ragione sociale o l'indirizzo o il cap o la località o la provincia).
    Questo caso, in stampa viene segnalato con: "(Incompl.)"

Campi in stampa
Codice cliente/fornitore
Descrizione
Partita Iva
Codice fiscale
Sp.(Spesometro) Viene riportato il flag 'Op.ril. Iva' che può essere impostato a N=normale, E=escluso, S=sempre
Doppia
Se esistono più anagrafiche con la stessa P.Iva, vengono stampati due asterischi **
Causa di non validità(vedi dettaglio segnalazioni riportate sotto)

In testa ad ogni segnalazione di anomalia verrà stampato il carattere "F", se l'anagrafica è stata inserita come persona fisica, "G" se persona giuridica.

Se un cli/for è definito 'persona fisica' il programma segnala se manca il Codice Fiscale, se è definito 'persona giuridica' segnala sia se manca la Partita Iva, sia se manca il Codice Fiscale

Nel caso in cui il Codice Fiscale sia stato posto uguale alla Partita iva, su questo campo verrà fatto il controllo della partita iva, invece di quello del codice fiscale e, se risulta errato, verrà dato il messaggio:
"C.F. errato (PI)" ad indicare che è una Partita iva.

Se si trova, in corrispondenza ad un fornitore, una partita iva che inizia per 8 o 9, viene segnalato come errore in quanto si tratta di codice fiscale.

Se il codice ISO dello stato di appartenenza è diverso da IT, verrà segnalato 'straniero' in modo da poter verificare se i rispettivi documenti andranno riportati o meno sullo Spesometro.
Il caso di anagrafica incompleta (cioè manca o la Ragione sociale o l'indirizzo o il cap o la località o la provincia), verrà segnalato con: "(Incompl.)".


STAMPA ELENCO CLIENTI E FORNITORI

Percorso: Archivi Comuni - Anagrafiche - Stampe

Il programma consente di stampare l'elenco dei clienti o fornitori in formato sintetico o dettagliato.

Le anagrafiche possono essere ordinate per Codice o per Ragione Sociale Contabile; all'interno di questo ordinamento possono poi essere raggruppate per Zona, Categoria, Agente, Agente 2, Cap, Classi/Attributi.

Altre selezioni:

Data registrazione da .. a...
Consente di stampare solo le anagrafiche per le quali sono stati registrati dei documenti nell'intervallo

Data stampa ddt da .. a...
Consente di stampare solo le anagrafiche per le quali sono stati registrati dei documenti nell'intervallo

Data Inserimento fatture da .. a...
Consente di stampare solo le anagrafiche per le quali sono stati registrati dei documenti nell'intervallo

Anagrafica con Comune vuoto
Anagrafica senza Cod.Destinatario FE (Identificativo) e senza PEC

Infine possono stampare tutte le anagrafiche selezionate, solo quelle chiuse o solo quelle attive (con data di chiusura bianca).


STAMPA ETICHETTE CLIENTI E FORNITORI

Percorso: Archivi Comuni - Anagrafiche - Stampe

La funzione consente di stampare le etichette con l'anagrafica dei clienti e dei fornitori. Il formato e il contenuto dell'etichetta sono modificabili dall'utente attraverso l'uso della personalizzazione dei formati di stampa.

Per accedere al programma che gestisce i formati premere i tasti Shift-Ctrl-Alt L dal menu principale poi scegliere, tra i programmi da eseguire:
Gestione filtri etichette Laser o ad aghi

Si può scegliere di stampare gli indirizzi scritti sull'anagrafica oppure quelli dell'archivio Indirizzi di Spedizione (utilizzati come diversa destinazione in Ddt e fatture accompagnatorie).

In quest'ultimo caso verrà stampato, per ogni cli/for l'eventuale indirizzo collegato in anagrafica come Indirizzo di spedizione.

Un'altra possibilità è quella di stampare gli indirizzi facendo riferimento a una o più fatture (o ddt).
In questo modo si otterranno le etichette necessarie per la spedizione dei documenti.

Se si desidera stampare l'indirizzo di spedizione delle fatture, quando c'è, piuttosto dell'indirizzo del cliente che è in testata fattura, occorre spuntare l'apposito campo sulla prima maschera delle opzioni di stampa poi, successivamente, scegliere Stampa da Fatture Clienti.

Se si imposta il parametro di personalizzazione StampaEti a S, al termine delle stampa di un ddt verrà caricata questa funzione al fine di consentire la stampa dell' etichetta collegata al documento stampato. Il numero di etichette stampate è pari al numero colli impostato nella testata del Ddt

Parametro: NoStampa
Per velocizzare nel caso si stampi da DDt o Fatture


STAMPA CLIENTI-FORNITORI PARAMETRICA

Percorso: Archivi Comuni - Anagrafiche - Stampe

Questo programma consente di stampare dati anagrafici dei clienti/fornitori a scelta dell'operatore (il limite è che i dati scelti devono stare su un'unica riga, però la stampa si può fare anche su foglio orizzontale)

Prima di eseguire la stampa verificare quale stampa si lancia leggendo il contenuto del campo: stampa da eseguire.

Se in tale campo è impostata la scritta: NUOVA STAMPA, non si può stampare ma occorre prima proseguire con il pulsante: Personalizza la stampa ed eseguendo via via quanto chiesto a video (vedi stampe parametriche). In questo modo l'operatore può preparare una o più stampe diverse, ciascuna con i dati che via via gli servono.

E' possibile effettuare delle selezioni sulle anagrafiche da stampare, tra le altre:

  • Tutti
  • Solo attivi
  • Solo chiusi

Sono considerate attive le anagrafiche che NON hanno il campo Data Chiusura compilato

Data registrazione da .. a...
Consente di stampare solo le anagrafiche per le quali sono stati registrati dei documenti nell'intervallo

Data stampa ddt da .. a...
Consente di stampare solo le anagrafiche per le quali sono stati registrati dei documenti nell'intervallo

Data Inserimento fatture da .. a...
Consente di stampare solo le anagrafiche per le quali sono stati registrati dei documenti nell'intervallo

Anagrafica con Comune vuoto
Anagrafica senza Cod.Destinatario FE (Identificativo) e senza PEC
Se si spuntano queste caselle, indipendentemente dai campi in stampa, verranno stampati SOLO quei clienti che soddisfano questi criteri

Stampa intestazioni

  • Sempre
  • Mai
  • Solo colonne

Utile per la stampa su file, consente di NON stampare nessuna intestazione o Solo l'intestazione delle colonne, omettendo le righe di intestazione comuni ad ogni stampa: anagrafica ditta, versione , data

Stampa su file
Se si deve ripetere più volte la stampa su file si può entrare in Selezione destinazione stampa - Scegliere la stampa su file con la destinazione e le opzioni volute, poi scegliere: Salva opzioni di Stampa , Deseleziona tutto , spuntare solo le opzioni che riguardano la stampa su file: File di stampa per file, qualificatore testo , formato di stampa , separatore campi e Salvare
Se si esce dal programma e si rientra, sarà sempre disponibile la stampa su stampante ma, cliccando il pulsante Stampa su file, si otterrà la stampa su file con le caratteristiche scelte in precedenza e memorizzate

Aggiungi ID azienda nel nome file
Consente di ottenere file diversi stampando da Aziende diverse in quanto aggiunge al nome del file l'ID azienda, assegnato ad ogni azienda al momento della sua creazione (consultabile in Parametri e utilità - Gestione database aziende)

Identificativo azienda da .. a ..
Consente di selezionare, tra le aziende in linea, un gruppo dalle quali estrarre i clienti/fornitori


STAMPA INDIRIZZI CLIENTI

Percorso: Archivi Comuni - Anagrafiche - Stampe

Consente di stampare, per ogni cliente o fornitore, l'elenco degli indirizzi di destinazione della merce o amministrativi


INVIO EMAIL

Il programma consente di inviare un'email a un gruppo di clienti in base ai parametri impostati nella maschera delle selezioni, allegando un file il cui nome viene chiesto a video in file da allegare.

Tale file può contenere un testo 'fisso' oppure un testo word che dovrà essere integrato con dei dati personalizzati presi dall'anagrafica del cliente / fornitore a cui verrà spedito. Vedi Note su come compilare un testo con campi personalizzati

Perchè l'invio abbia buon esito occorre aver configurato Sendmail o See , a seconda dei cosa si usa per spedire, come descritto nelle rispettive note.

A video viene visualizzato il nome del file log (se è stato impostato sull'aziwin.ini, oppure può essere scritto al momento) e viene chiesto il nome del file da allegare alla email

Con opportuni pulsanti è inoltre possibile:
richiamare l'ultimo log usato,
rileggere i parametri memorizzati sull'aziwin.ini: Leggi parametri
Sbiancare i parametri (pulsante Sbianca posto in fondo al video)
Salvare i nuovi parametri impostati a video
Usa il Merge di Word - Si può spuntare questo campo se il testo da spedire dovrà essere integrato con dei dati personalizzati presi dall'anagrafica clienti / fornitori. Se non viene spuntato verrà spedito il file indicato in 'file da allegare' così com'è.
Se il file Word è aperto, il programma va in errore 287 e non farà il merge

Fai Merge su Pdf - opzione utilizzabile solo da Word2007 in poi
Lascia file temporanei - c'è la possibilità di lasciare i file Word generati con il Merge o di cancellarli dopo averli inviati. Se si lasciano occorre fare attenzione al nome che si da ai file . Ad esempio se il nome contiene solo data e ora potrebbe dare errore in quanto ne crea più di uno nello stesso minuto.

La maschera contiene tre etichette: Selezioni - Testi Email - Parametri email

Con le Selezioni è possibile scegliere se spedire email a clienti - fornitori, e quindi impostare gli intervalli con le caratteristiche dei destinatari, oppure scegliere tra gli intestatari di un certo numero di ddt o fatture
Se si sceglie il cliente con il pulsante di aiuto, nella lista vengono visualizzati gli indirizzi di email e, cliccando su un indirizzo per scegliere 'quel cliente', automaticamente si imposta anche quell'indirizzo come indirizzo email a cui inviare.

Testi email - è possibile impostare, memorizzare e richiamare fino a 5 testi diversi in cui scrivere l'oggetto e il testo dell'email
Tali testi vengono memorizzati sulla tabella Appoggio del file AziMenu.mdb con codice PdfEmail. Nella compilazione dei testi, oltre a parti fisse, possono essere inseriti alcuni parametri facendolo precedere e seguire dal simbolo §:
Ora (hh:mm) , Data (gg/mm/aaaa) e DataLunga (gg mese aaaa), Codice (cod. cli/for completo nel formato xx-xx-xxxx) , Term : nome terminale, Pianoconti.XXXX dove xxxx è il nome di un campo di Pianoconti, Conto (che indica gli ultimi 4 caratteri del codice cli/for), IndSped.nome_campo (per i campi dell'indirizzo di spedizione) e IndAmmin.nome_campo (per i campi dell'indirizzo Amministrativo)
Es. §DataLunga§

Utilizzando l' html, è possibile inserire nel testo dell' email una immagine o font diversi (es. grassetto o corsivo)
Col pulsante Cerca Img: è possibile cercare l'immagine da inserire nel testo e, una volta individuato, verrà scritta la frase completa:
<img src="path_immagine">

Parametri Email - maschera che consente di impostare i parametri per l'invio delle email

Perchè l'invio abbia buon esito occorre aver configurato Sendmail o See , a seconda dei cosa si usa per spedire, come descritto nelle rispettive note.

Configurazione invio email attiva: SceltaX con X=1,2,3 - fa riferimento a quanto impostato nella maschera di definizione dei parametri di invio email dove si possono memorizzare fino a 3 configurazioni di invio email
A seconda della scelta verranno impostati a video i parametri relativi già impostati nella maschera suddetta.
Indirizzo email da utilizzare per i clienti/forn.: indicare uno dei possibili indirizzi impostati sull'anagrafica
Se non disponibile si può decidere, spuntando l'apposita opzione, di utilizzare l'email principale.
E' possibile infine Richiedere notifica dell'email ricevuta

I parametri impostati nel programma verranno memorizzati nel paragrafo InvioEmailCF del file AziWin.ini locale:

[InvioEmailCF]
FileLog=c:\LogEmail
Percorso e nome del 'file di log', file in cui il programma scriverà i messaggi che descrivono il risultato dell'invio dell'email. Questo percorso verrà proposto a video e potrà essere modificato all'esecuzione del programma
UltFileLog=
In questa variabile verrà memorizzato il percorso dell'ultimo file log utilizzato in modo da poterlo visualizzare se richiesto dall'operatore con l'apposito pulsante.
Se si utilizza più volte lo stesso file log, il programma accoda i nuovi messaggi e se si chiede di rileggere i parametri legge l'ultimo gruppo inserito.
EmailPredef=N
Dove N sarà un numero da 1 a 4 che fa riferimento ai 4 indirizzi email memorizzati sulle anagrafiche clienti e fornitori (il valore di default è l'email amministrativo)
EmailConf=Scelta X (X=1,2,3)
Poichè nella maschera di definizione dei parametri di invio email si possono memorizzare fino a 3 configurazioni di invio email, in questo parametro si può impostare quella da usare per questo programma per indicare , ad esempio , che va usata sempre la posta certificata.
MergePdf= serve a preimpostare il campo corrispondente a video

Parametri di personalizzazione per la definizione del nome da assegnare al file da spedire in allegato
Gruppo: InvioEmailCF

Parametro: FileMergePri
Default: vuoto

Parametro: FileMergeDop
Default: §Conto§_§DataOra§
Se si fa il Merge il programma prenderà il nome originale del file DOC e lo riscrive completando il nome con quanto previsto nei due parametri suddetti.

Se nel valore del parametro FileMergePri si scrive §vuoto§ il nome che verrà assegnato al file DOC sarà composto da quanto scritto nei due parametri FileMergePri e FileMergeDop

Nei due parametri si possono usare oltre a Conto (che indica gli ultimi 4 caratteri del codice cli/for) e DataOra (aaaammgg_hhnn)
anche: Data (aaaammgg), Codice (cod. cli/for completo nel formato xx-xx-xxxx) , Term : nome terminale, RagioneSociale: ragione sociale 1 e 2 oppure Ragione Sociale contabile se la prima non è compilata, Pianoconti.XXXX dove xxxx è il nome di un campo di Pianoconti

Note su come compilare un testo Word contenente campi personalizzati

E' possibile personalizzare il testo word da spedire in modo tale che il programma lo completi, prima dell'invio, con i dati del cliente/fornitore destinatario. Per ottenere questo risultato occorre premere, nel punto del testo word dove si vogliono, ad esempio, i dati anagrafici del cliente destinatario: Inserisci , scegliere 'Campo' poi , nella maschera che compare, scegliere in 'Nomi dei campi' Merge Field e quindi scrivere in 'Nome campo' il nome del campo da inserire presente sulla tabella PianoConti es. Indirizzo (non ci va il nome tabella PianoConti ma solo il nome del campo)
Il risultato sarà che nel testo viene scritto: «Indirizzo»
Come 'Nome campo' si possono usare oltre a tutti i campi della tabella PianoConti, i 'nomi fissi' : Codice e RagioneSociale
Se si inserisce il nome di un campo che non esiste, si blocca il merge, in una finestra di word viene creato un testo 'Lettere tipo3' contenente il messaggio di campo unione non valido, occorre premere 'Annulla' su questa maschera per proseguire. Il messaggio verrà spedito ugualmente ma nel file word al posto del campo 'errato' viene scritto:
'Errore. Campo unione non è stato trovato ..'

Altri parametri di personalizzazione:
Parametro: NoStampa
Per velocizzare nel caso si stampi da DDt o Fatture


ELENCO CLIENTI ESENTI

Percorso: Contabilità - Servizio - Stampe

Il programma produce una stampa contenente l'elenco dei clienti esenti cioè hanno il campo codice iva valorizzato con il codice di un'esenzione. Per ogni cliente stampato, viene stampato anche il contenuto del campo Lettera d'intenti.

Questa stampa può essere utilizzata ad inizio di un nuovo anno per verificare la correttezza dei clienti esenti.


ARTICOLI

Percorso: Archivi Comuni - Anagrafiche - articoli

Questa funzione consente di inserire, variare, annullare gli articoli di magazzino. I dati dell'articolo vengono divisi , per la visualizzazione e gestione, in gruppi omogenei.
Per la creazione di un nuovo articolo occorre digitare il codice e premere il [image] (R) Ricerca. Se l'articolo non esiste in programma si predispone per l'inserimento, se esiste si predispone per la variazione.
E' possibile assegnare in automatico il codice (numerico progressivo) premendo il pulsante:
'Crea codice automatico'. I parametri ChiaveBase e ChiaveBaseLun consentono di personalizzare la creazione del codice.

E' consentita la duplicazione di un articolo. Se si duplica un articolo che ha distinta base, viene chiesto all'operatore se duplicare o meno anche la distinta.

Durante la cancellazione di un articolo vengono cancellati anche tutti gli elementi di altri archivi collegati nei quali l'articolo compare (costi, fornitori, progressivi, lifo, lingue, listini,listini promozione, localizzazioni, scorte, sconti). Non è tuttavia consentito cancellare un articolo movimentato (cioè per il quale sia presente almeno un movimento di magazzino o con progressivi diversi da 0).

Parametri di personalizzazione gestiti da questa funzione:

CodIvaDef
Permette di inserire un codice iva di default che verrà poi proposto in creazione di nuovi articoli
CodUmDef
Permette di inserire un codice di unità di misura di default che verrà poi proposta in creazione di nuovi articoli. Es. PZ o NR
CodRepDef
Permette di inserire un codice reparto di default che verrà poi proposto in creazione di nuovi articoli.
LabAlt (e anche LabLarg e LabLung)
Consentono di personalizzare la scritta che compare come label nei campi Altezza, Larghezza e Lunghezza.
Immagini
Consente di memorizzare e visualizzare, per ogni articolo, una immagine.
ArtAggStringa(0-3) e ArtAggNum(0-3)
per abilitare nuovi campi gestibili in Gestione Articoli. La loro gestione viene fatta nella maschera (3) Attr/Pers
NoDecInattivi Consente di evitare che, un articolo definito inattivo e quindi escluso dalla lista di aiuto, possa comunque essere inserito in un documento se lo si richiama digitando il codice esatto.

Codice e descrizione
Per la ricerca dell'articolo per codice o descrizione, valgono le regole descritte in Lista di aiuto
Se si utilizza il Codice a barre, è possibile utilizzarlo come chiave di ricerca (digitandolo, anche parzialmente, sul codice articolo) premendo il tasto F4.
La descrizione è di 40 caratteri e può essere completata da una ulteriore descrizione 'libera' da inserire in Descrizione Aggiuntiva. Questa seconda parte di descrizione può essere stampata o meno sui documenti allineata con la descrizione articolo.

Tipo codice a barre
Se in tabella di magazzino si è dichiarato di gestire il codice a barre sugli articoli e, di conseguenza, è stato indicato un tipo di Codice a Barre principale, qui viene proposto tale tipo ma può essere variato per ogni articolo. Questo per consentire di avere in magazzino articoli con codice a barre diversi.
Può assumere i seguenti valori:

  • 12 Per utilizzare il codice 128 il quale permettere di utilizzare tutti i caratteri ascii e nel codice non viene memorizzato il check digit.
  • 39 Per utilizzare il codice 39 il quale permettere di utilizzare codici alfanumerici con solo lettere maiuscole con check digit
  • 13 Per utilizzare il codice EAN 13
  • E8 Per utilizzare il codice EAN 8
  • UA Per UPC A (codice di 12 caratteri)

Questo tipo verrà utilizzato dalla eventuale generazione in automatico del bit di controllo e dalla stampa etichette (se sul filtro di stampa non si scrive direttamente il tipo fisso).

Codice a barre
E' un codice univoco per ogni articolo. (max.128 caratteri)
Questo campo è obbligatorio se nella tabella di magazzino si dichiara di voler gestire il codice a barre.
Il programma controlla che non vengano inseriti codici doppi.
Utilizzo del codice a barre per articoli con livelli (Taglia/Colori)

Ricerca per codice a barre:
si utilizza il tasto F4, dopo aver inserito il codice a barre nel campo codice articolo.
Il Codice a barre viene cercato sulla tabella degli articoli e anche sulla tabella 'ArticoliBarCode' dove si possono memorizzare gli eventuali ulteriori BarCode che fanno riferimento ad uno stesso articolo.

Se si desidera utilizzare il codice a barre, occorre definire, nella tabella di magazzino:

  • il Tipo di codice a barre
  • se si vuole la generazione automatica dello stesso
  • se il programma deve generare in automatico il bit di controllo
    Nel caso non si voglia la generazione automatica del bit di controllo, il codice a barre deve essere inserito completo.

Pulsante: imposta codice a barre
Questo pulsante consente, una volta posizionati su un articolo, di generare automaticamente di codice a barre solo per quell'articolo.
Per il codice 128, se si preme il pulsante di generazione automatica, viene messo il codice a barre uguale al codice articolo (è indifferente che sia numerico o alfanumerico) per gli altri si cerca l'ultimo numero presente e lo si incrementa di uno.
Se il tipo di codice è diverso da Ean 8 e Ean 13, nell'allineamento si utilizza il valore impostato in tabella di magazzino in Lunghezza codice a barre.
E' possibile inserire il parametro di personalizzazione CodIniAut per definire una sequenza di caratteri che verrà messa all'inizio del nuovo codice a barre alla richiesta della generazione automatica.

Data Creazione
E' una data obbligatoria, compilata automaticamente alla creazione dell'articolo con la data del terminale e può essere variata a piacere. Viene utilizzata in creazione e variazione listini come elemento di selezione.

Data Variazione
Campo da gestire manualmente. Se valorizzato può essere utilizzato, in selezioni, es. in Stampa Listini.

Articolo Si/No
Indica se 'l'articolo' in oggetto è un articolo di magazzino (di cui tenere la giacenza, inventario etc) o un articolo fittizio (es. spese) per il quale non occorre memorizzare i progressivi.

In giornale
E' un indicatore che specifica se i movimenti dell'articolo vanno stampati o meno sul giornale di magazzino.

Inattivo
Indica se l'articolo è ancora in uso. Impostando questo segnale su un articolo lo si esclude dalla lista di aiuto e lo si può escludere dalle stampe nelle quali a video viene proposta la scelta se stampare tutti gli articoli o solo quelli attivi (Es. Listino).
Un articolo definito inattivo può comunque essere inserito in un documento se lo si richiama digitando il codice esatto. Per escluderlo anche in questo caso occorre impostare a S il parametro di personalizzazione: NoDecInattivi

Reparto
Definisce il reparto del registratore di cassa al quale appartiene l'articolo. Decodifica dall'archivio reparti
Se è attivato il collegamento con il registratore di cassa (Dati generali azienda -parametri, Procedure installate) è obbligatorio valorizzare questo campo.
Si può impostare, per velocizzare la creazione, un valore di default inserendo il parametro di personalizzazione: CodRepDef
Seguono altre caratteristiche dell'articolo che sono accessibili premendo i tasti corrispondenti alle voci:
Dati Generali
Descrizione aggiuntiva
Classi e Attributi e Campi personalizzati
Progressivi
Listini
Altri dati
Descrizioni in lingua
Promozioni
Distinta Base
Immagini
Articolo Fornitori


Art-Dati Generali

Percorso: Archivi Comuni - Anagrafiche - articoli

Gruppo e Sottogruppo articolo
Decodifica da Tabella Gruppi e Sottogruppi Articoli. Consentono, se codificati, di ottenere nelle stampe di magazzino delle selezioni per gruppo merci. Inoltre è possibile creare una tabella sconti per Categoria Cliente/Gruppo Articolo

Unità di misura principale
Decodifica da tabella unità di misura.
E' l'unità di misura con la quale vengono memorizzate le quantità dell'articolo. Campo obbligatorio. Si può impostare, per velocizzare la creazione, un valore di default inserendo il parametro di personalizzazione: CodUmDef

Unità di misura per Vendite e Acquisti
Decodifica da tabella unità di misura.
Sono rispettivamente le unità di misura utilizzate nei documenti di vendita e di acquisto. Vengono impostate uguali a quella principale e sono obbligatorie. Se sono diverse rispetto la principale dovrà essere digitato il fattore di conversione.

Fattori di conversione
E' il numero per cui va moltiplicata la quantità venduta o acquistata, espressa rispettivamente nelle unità di misura di vendita o di acquisto, per ottenere la quantità espressa nell'unità di misura principale dell'articolo. Non può essere impostato a 0, ma nel caso si lavori sempre con la stessa unità di misura dovrà essere 1.

Codice Iva Vendite e Codice Iva Acquisti
Decodifica dalla Tabella dei codici iva

Indicano i codici iva che verranno proposti rispettivamente nella vendita e acquisto dell'articolo. Appena se ne compila uno, l'altro, se vuoto, viene assunto uguale al primo. Si può impostare, per la creazione, un valore di default inserendo il parametro di personalizzazione CodIvaDef
Se è attiva la fatturazione o il collegamento col registratore di cassa, il codice iva vendite è obbligatorio.

Merci c/vendite - c/acquisti
Decodifica dal Piano dei Conti.
Indica il conto di ricavo da utilizzare, in sede di fatturazione, per la registrazione contabile. (Quello acquisti per ora non è utilizzato).
Viene proposto il codice inserito in tabella.

Sconto Articolo
Questo campo può contenere una o più percentuali di sconto (da applicare in cascata), separate dal segno + o - (es. 2+3+1).

Maggiorazione
Viene utilizzato nella variazione automatica listini per generare un nuovo listino da uno preesistente applicando una maggiorazione diversa per ogni articolo.

Percentuale Provvigione
Indica la percentuale di provvigione dovuta all'agente per la vendita dell'articolo se nell'anagrafica cliente è prevista la provvigione sull'articolo.

Fornitore abituale
Decodifica dall'archivio fornitori.
Indica il codice del fornitore abituale del prodotto. Questo campo verrà utilizzato in gestione preventivi per generare in automatico l'ordine al fornitore.
Ad ogni carico viene aggiornato col codice ultimo fornitore SOLO se in tabella di magazzino è previsto.

Pezzi per confezione
Questo campo dovrà essere valorizzato solo se l'articolo fa parte di una confezione (es. le bottiglie di acqua minerale sono 6 per ogni confezione). Se valorizzato, in fase di vendita si potrà digitare il numero dei colli (corrispondenti alle confezioni) e automaticamente verrà valorizzata la quantità in uscita. Sugli articoli RAEE (quelli creati per associarli ad un articolo per il quale va gestita anche la riga RAEE) occorre lasciare bianco questo campo.
Vedi parametro RicalcColli
Personalizzando il parametro DivPezziConf è possibile inserire 'pezzi per confezione' decimale.

Articolo RAEE
Se lo smaltimento dell'articolo in oggetto è regolamentato dal decreto RAEE, in questo campo va impostato il codice dell'articolo sul quale dovrà essere impostato l'importo del contributo Raee. Ogni volta che verrà movimentato l'articolo in oggetto, i programmi (Caricamento movimenti, Ordini, Ddt e Fatture) genereranno una riga ulteriore con codice articolo Raee, quantità uguale a quella dell'articolo 'principale' e valore unitario uguale al prezzo di listino Base dell'articolo Raee.

Articolo sostitutivo
E' il codice dell'articolo che può sostituire il principale se quest'ultimo manca. (descrittivo).

Scorta Minima
Indica la quantità minima di giacenza dell'articolo al di sotto della quale scatta la segnalazione di sottoscorta. In caso di gestione della scorta minima su magazzini, occorre lasciare bianco questo campo e impostare la scorta minima per ogni magazzino con l'apposita funzione.
Se si compila la scorta minima sull'articolo, si intende globale su tutti i magazzini.
La stampa controllo scorte utilizza questo campo e il successivo.

Scorta massima
Indica la quantità massima di giacenza dell'articolo. In caso di più magazzini è valido quello detto per la scorta minima.

Lotto di Riordino
E' la quantità minima da riordinare. In caso di più magazzini è valido quello detto per la scorta minima.

Punto di Riordino
Indica il limite minimo per la giacenza dell'articolo. Quando la giacenza scende oltre questo limite scatta la segnalazione di riordino. In caso di più magazzini è valido quello detto per la scorta minima.

Segnalazione giacenza negativa / sottoscorta
Indica se e quando dare la segnalazione di articolo con giacenza negativa o sottoscorta.
L'impostazione iniziale è quella stabilita in tabella di magazzino, è possibile scegliere tra:

  • Mai
  • Sempre
  • Solo ddt/bolla
  • Solo fattura

Distinta base
Indica se l'articolo fa parte di una distinta base e attiva lo scarico dei componenti se si movimenta il magazzino con causali che lo prevedano.

  • No
  • Prodotto Finito
    E' un articolo composto da altri ma che non è a sua volta componente di nessuno.
  • Semilavorato
    E' un articolo che ha dei componenti e che è a sua volta componente di qualcosa a livello superiore.
  • Materiale di base
    E' un articolo che non ha componenti ma che interviene come componente di altri articoli.

Vedi Distinta Base


Art-Descrizione aggiuntiva

Percorso: Archivi Comuni - Anagrafiche - articoli

In questo spazio si consente di inserire delle righe di testo che vanno a completare la descrizione degli articoli. Per inserire la descrizione aggiuntiva su più righe occorre andare a capo con CTRL Invio e non con il solo invio.

Se la scritta inizia con NOXML non verrà riportata nel file XML delle fattura elettronica.


Art-Classi e attributi

Art-Classi e attributi e campi personalizzati

Percorso: Archivi Comuni - Anagrafiche - articoli

Attributi articolo

Decodifica dalla tabella Attributi articolo a seconda della classe (1-5) nel quale l'attributo viene inserito.

Consentono di selezionare e raggruppare in stampa gli articoli.

Vengono elencate le classi create con la gestione Classi ed Attributi. Se si rende necessario creare una nuova classe e si lavora in multiutenza, occorre, dopo averla creata, eseguire la funzione Rileggi parametri (dal menu Parametri e utilità) oppure uscire e rientrare nel menu per poterla utilizzare nel programma.

Campi personalizzati

Per la gestione di eventuali campi personalizzati, stringhe o numeri, occorre creare i parametri di personalizzazione ArtAggStringa(0-3) e ArtAggNum(0-3)


Art-Progressivi

Percorso: Archivi Comuni - Anagrafiche - articoli

Vengono visualizzati i progressivi dell'articolo divisi per anno e magazzino e i costi. Tramite due pulsanti si può accedere ai singoli programmi di Gestione progressivi e Gestione Costi.


Art-Listini

Percorso: Archivi Comuni - Anagrafiche - articoli

In questa sezione si consente di inserire un nuovo prezzo di listino associato all'articolo o di variare o annullare quelli già esistenti.

Su ogni riga sono presenti i campi: Prezzo in Lire (ivato e non) e Prezzo (ivato e non).
Il campo prezzo in lire dovrà essere compilato dall'operatore, solo se il listino è in Lire.
Il campo prezzo dovrà invece essere compilato quando il listino è in valuta (Euro compreso)

Se il listino è in Lire, una volta compilato il prezzo in Lire verrà calcolato automaticamente il Prezzo (in Euro), viceversa se il listino è in Euro, compilato il campo Prezzo, verrà calcolato il corrispondente Prezzo in Lire.

E' possibile evitare l'aggiornamento automatico del corrispondente 'prezzo' al variare di uno dei due, attivando una riga particolare nella Tabella di Personalizzazione.

Viene visualizzato l'elenco dei listini già creati per l'articolo in oggetto. I campi da inserire sono gli stessi presenti in Listini Articoli, in particolare viene visualizzato l'eventuale sconto associato al codice listino ed è possibile inserire uno sconto a livello listino-articolo specificando se va applicato in aggiunta (M) o in sostituzione (S) allo sconto prodotto.

Inizialmente il campo S/M viene impostato a L che significa che su quella riga vengono applicate le condizioni di sconto scritte nell'anagrafica Listino.

Le variazioni fatte in questa maschera non verranno annullate se si esce con Annulla dalla variazione dell'articolo in oggetto.

Se l'articolo ha i livelli (taglia-colore) non si consente di inserire lo sconto a livello di listino-articolo.


Art-Altri dati

Percorso: Archivi Comuni - Anagrafiche - articoli

Numero etichette
E' il numero di etichette da stampare con la stampa etichette. Se impostato a 0 ne verrà stampato un numero pari a quanto specificato in tabella di magazzino.
Per non stampare nessuna etichetta per un articolo occorre scrivere in questo campo: -1.

Cauzione
Indica se l'articolo è una cauzione

Tempo di consegna
Descrittivo. Si può indicare qui il tempo medio di consegna dell'articolo.

Categoria Fiscale
Decodifica da Tabella delle Categorie Fiscali.
Consente la suddivisione degli articoli di magazzino per categoria fiscale in fase di inventario (Es. 01-Minuteria).

Localizzazione: Settore - Scaffale - Posizione
Campo descrittivo nel quale si può riportare la localizzazione degli articoli (posizione fisica in magazzino)
Utilizzato per ottenere una stampa per localizzazione. Se ci sono più magazzini è possibile inserirne uno per ogni Articolo/Magazzino.

Lunghezza, Larghezza, Altezza
Sono le dimensioni dell'articolo. Possono essere utilizzate nel caso di legname per il quale si vuole gestire la giacenza in metri cubi mentre si vende a pezzi (in personalizzazioni).

Percentuale di Riduzione
E' una percentuale che, in fase di inventario, verrà applicata alla quantità in giacenza per ridurla.
E' applicabile per legge per alcuni materiali.

Peso Lordo e Netto
Pesi dell'articolo utilizzati in ordini/ddt/fatture.
Nei documenti è possibile ottenere il calcolo automatico del peso attivando il parametro di personalizzazione CalcolaPeso (CalcolaPesoLordo, CalcolaPesoUm). Il peso può essere, a seconda dell'impostazione dei parametri suddetti, la somma delle quantità nelle righe di dettaglio o la somma dei pesi scritti nel campo 'peso lordo' dell'anagrafica dei singoli articoli.

Articolo Trasformato
E' il codice dell'articolo derivato dal principale per trasformazione. Quando si registra un movimento di trasformazione (scarico) dell'articolo principale verrà automaticamente generato un movimento di carico dell'articolo trasformato con quantità dipendente dal coefficiente di trasformazione e dall'operatore di trasformazione.

Operatore per la Trasformazione
Operazione aritmetica da eseguire (* per moltiplicazione, / per divisione) in fase di trasformazione.

Gruppo Livello 1 e 2
Se nei parametri generali di magazzino è stata scelta la gestione di 'Taglia/Colore', vengono chiesti due codici che fanno riferimento alla tabella Gruppi livelli (Funzione: Composizione livelli), che indicano quale gruppo di taglie (e colori) si utilizzano nell' articolo. Se l'articolo non ha gestione di livelli si possono lasciare vuoti questi campi, viceversa si può compilare solo il primo dei due o entrambi.

Gestione prezzi
Indica a che livello si vogliono gestire i prezzi (Listini e costi) dell'articolo nel caso si siano gestiti i livelli. E' possibile gestire i livelli per differenziare le quantità movimentate ed avere un unico prezzo di listino oppure avere listini (e quindi costi) al primo o al secondo livello.
Si consiglia di non variare mai, se l'articolo è stato movimentato, i campi che riguardano i livelli in quanto i movimenti, i progressivi e i costi non sarebbero più compatibili.
Se, per necessità, si varia il flag di Gestione prezzi, è indispensabile fare una rigenerazione progressivi e costi (menu di servizio di magazzino).

Articolo on line
Uso futuro

Gestione lotti
Se è abilitata la gestione della tracciabilità, questo campo indica se e come, in corrispondenza all'inserimento dell'articolo in oggetto in un documento, presentare la maschera di inserimento dei lotti. Tale maschera può essere: Abilitata Disabilitata Abilitata obbligatoria (cioè al termine dell'inserimento dell'articolo nella riga del documento si apre automaticamente la maschera di inserimento lotti)

Codice imballo
Per gestione vuoti su fattura accompagnatoria. E' il codice dell'articolo 'imballo' legato all'articolo corrente. Prima di inserire il codice dell'articolo imballo, occorre aver inserito, sulla prima maschera dell'articolo, il numero dei pezzi per confezione.

Litri per bottiglia
Nel caso di vendita di vino, occorre indicare in fattura il numero di litri consegnati. Questo numero serve per poter calcolare in automatico tale valore.

Tessera Sanitaria- Tipo Spesa
Questo campo serve per definire, in fase di estrazione delle Fatture per preparare il file XML da inviare per il Progetto Tessera Sanitaria, il tipo di prestazione erogata nelle varie righe della fattura.
I valori da assegnare al campo sono quelli definiti nelle specifiche del Progetto Tessera Sanitaria
E' possibile impostare questo campo anche con il valore: NON Estrarre . In questo modo, l'articolo in oggetto NON verrà mai estratto anche se presente in fattura.


Art-Descrizioni in lingua

Percorso: Archivi Comuni - Anagrafiche - articoli

E' possibile associare ad ogni articolo delle descrizioni in lingua. Vengono visualizzate quelle esistenti e si permette di inserire e variare.


Art-Listini promozione

Percorso: Archivi Comuni - Anagrafiche - articoli

Viene visualizzato l'elenco dei listini promozione dell'articolo. E' possibile inserirne di nuovi e apportare variazioni. I campi gestiti sono gli stessi della Gestione listini promozione.


Art-Componenti

Percorso: Archivi Comuni - Anagrafiche - articoli

Se nei parametri iniziali della ditta è stata dichiarata la presenza della Distinta base tra le procedure installate (Parametri e utilità, Dati Generali azienda, Procedure installate) e l'articolo è un Prodotto Finito o un Intermedio (campo Distinta Base), è possibile inserire con questo quadro, i suoi componenti.
Tali componenti possono essere a loro volta degli intermedi o dei materiali di base.
Se si duplica un articolo che ha distinta base, viene chiesto all'operatore se duplicare o meno anche la distinta.
(Per ora non è possibile definire i componenti dei livelli (Gestione taglia-colore) ma solo dell'articolo)

Per ora questi componenti vengono considerati:
- se si fa un carico o uno scarico di un prodotto finito con il programma di Caricamento movimenti (magazzino) e la causale prevede una causale collegata per la distinta base
- se si effettua uno scarico di prodotti finiti letti da un file esterno (vedi Caricamento movimenti di magazzino da file)
Se la distinta è a più livelli si dovrà cominciare a creare gli articoli dal livello più basso e cioè: prima il materiale di base, poi i semilavorati che utilizzano quei materiali e così via.

Ogni articolo che non ha a sua volta componenti, va definito come materiale di base.
Per ogni articolo composto quindi si inseriranno i vari componenti (che necessariamente dovranno essere materiali di base o un intermedi).

Dovranno essere inseriti: la quantità necessaria a produrre un'unità del composto, l'unità di misura in cui tale quantità è espressa (può essere o l'unità di misura principale di questo componente e quella di vendita o quella di acquisto), il valore da utilizzare per fare il movimento di scarico (Ultimo costo, costo medio, costo standard, o un listino) e, se si valorizza a un listino, il suo codice.


Art-Immagini

Percorso: Archivi Comuni - Anagrafiche - articoli

Questa maschera viene visualizzata se è stato abilitato il parametro di personalizzazione Immagini=S ed eventualmente , gli altri parametri ad esso correlati.
In questo spazio è possibile associare ad ogni articolo una immagine che poi verrà visualizzata nell'Help (lista ottenuta con i tasti F2 o F3) del campo articolo.

Le immagini (si accettano file con estensione bmp, gif, wmf, etc.) potranno essere memorizzate in una directory particolare (scritta nel parametro: DirImgArt o DirImmagini della sezione Base dell'aziwin.ini).

Su ogni articolo occorre memorizzare il nome del file dell'immagine. Se tale file, si trova sul percorso diverso dallo standard (quello indicato in DirImgArt o in DirImmagini) occorre digitare la path completa o cercarla tramite il pulsante: Sfoglia.
Viene inoltre proposto il valore del flag di personalizzazione: ImgDimReali che può essere variato articolo per articolo.

Nel campo 'immagine' viene accettato anche un URL a un'immagine e, se è attiva la connessione ad internet, questa verrà visualizzata.

La posizione dell'immagine dell'articolo nell'help e la modalità di mostrarla, sono indicate da parametri di personalizzazione. Cliccando sull'immagine si ottiene la sua visualizzazione in dimensioni reali o in modo da occupare tutto lo spazio a disposizione (ad ogni click cambia il tipo di visualizzazione).

Tali immagini potranno essere stampate sui moduli Ordini, ddt e fatture modificando opportunamente i filtri di stampa (vedere manuale filtri) e sulla stampa della distinta base se si sceglie di stampare "una pagina per ogni distinta".


Art-Articoli Fornitore

Percorso: Archivi Comuni - Anagrafiche - articoli

In questo folder si consente di inserire il codice e la descrizione che ogni fornitore dell' articolo da all'articolo stesso. Questi dati possono essere utili se si vuole, in fase di preparazione e stampa degli ordini ai fornitori, utilizzare i codici articolo del fornitore piuttosto del propri.

Per ogni fornitore vengono inoltre gestiti: l'ultimo prezzo pagato, lo sconto avuto su quel prodotto, l'eventuale unità di misura se diversa da quella dell'articolo, il tempo di consegna e la moneta con cui è stato effettuato l'ultimo acquisto.

C'è un parametro nei dati generali di Magazzino (Parametri e utilità - Dati generali azienda, parametri) con il quale si indica alla procedura se si vuole gestire o meno l'archivio Articoli-Fornitore.

Se viene inserito l' articolo fornitore questo potrà essere stampato sulle conferme d'ordine al fornitore:

  • al posto del codice e descrizione articolo, se lo si dichiara nei Parametri Ordini di Acquisto,
  • oppure inserendo nel filtro di stampa le righe con i campi:
    C_RigCodArtFor per il codice articolo
    C_RigDesArtFor per la descrizione articolo


ARTICOLI FORNITORE

Percorso: Archivi Comuni - Anagrafiche - articoli

Se previsto da tabella di magazzino (flag: Gest. archivio articoli fornitori), per ogni articolo acquistato da un fornitore diverso, vengono memorizzate una serie di informazioni aggiornate in base alla data dell'ultimo acquisto. Questi dati, oltre a servire per statistiche, possono essere utilizzati nella compilazione di un ordine al fornitore.

Se viene inserito l' articolo fornitore questo potrà essere stampato sulle conferme d'ordine al fornitore:

  • al posto del codice e descrizione articolo, se lo si dichiara nei Parametri Ordini di Acquisto,
  • oppure inserendo nel filtro di stampa le righe con i campi:
    C_RigCodArtFor per il codice articolo
    C_RigDesArtFor per la descrizione articolo

Codice fornitore

Codice e descrizione articolo fornitore

Unità di misura dell'ultimo acquisto
Viene aggiornato, insieme al costo ultimo, dai movimenti di carico inseriti con la funzione Caricamento movimenti.

Prezzo di Acquisto (al netto dagli sconti)

Sconto (percentuale)

Costo ultimo (al lordo di sconti)
Viene aggiornato, insieme alla data costo ultimo, dai movimenti di carico inseriti con la funzione Caricamento movimenti.
Viene utilizzato dagli ordini fornitori come prezzo unitario da proporre.

Data costo ultimo

Tempo di consegna
Descrittivo


DESCRIZIONI ARTICOLI IN LINGUA

Percorso: Magazzino - Gestioni

Ad ogni articolo è possibile associare una descrizione e una descrizione aggiuntiva espresse in lingue diverse da quella di codifica del magazzino.

Per inserire la descrizione aggiuntiva su più righe occorre andare a capo con CTRL Invio e non con il solo invio.


STAMPA ARTICOLI

Percorso: Archivi Comuni - Anagrafiche - Stampe

E' possibile ottenere due forme di stampa: dettagliata o sintetica.

Nella forma sintetica vengono riportati: codice e descrizione articolo, unità di misura (vendita e acquisto),aliquota iva e codice a barre (se utilizzato, vedi flag in tabella magazzino)

Nella dettagliata invece vengono stampati tutti i dati anagrafici.


STAMPA PARAMETRICA ARTICOLI

Percorso: Archivi Comuni - Anagrafiche - Stampe

E' possibile impostare formati di stampa personalizzati con i campi desiderati.

Prima di eseguire la stampa verificare quale stampa si lancia leggendo il contenuto del campo: stampa da eseguire.

Se in tale campo è impostata la scritta: NUOVA STAMPA, non si può stampare ma occorre prima proseguire con il pulsante: Personalizza la stampa ed eseguendo via via quanto chiesto a video (vedi stampe parametriche). In questo modo l'operatore può preparare una o più stampe diverse, ciascuna con i dati che via via gli servono.

Stampa intestazioni

  • Sempre
  • Mai
  • Solo colonne

Utile per la stampa su file, consente di NON stampare nessuna intestazione o Solo l'intestazione delle colonne, omettendo le righe diintestazione comuni ad ogni stampa: anagrafica ditta, versione , data


ETICHETTE ARTICOLI

Percorso: Magazzino - Stampe

La funzione consente di stampare delle etichette per ogni articolo di magazzino. Il formato e il contenuto dell'etichetta sono modificabili dall'utente attraverso l'uso della personalizzazione dei formati di stampa.

Per accedere al programma che gestisce i formati premere i tasti Shift-Ctrl-Alt L dal menu principale poi scegliere, tra i programmi da eseguire:
Gestione filtri etichette Laser o ad aghi
In questa gestione verranno proposti filtri già predisposti per la stampa di etichette Articoli e Clienti/Fornitori.

Nell'etichetta è possibile stampare anche il codice a barre dell'articolo se impostato.

Occorre però aver specificato, in generale sulla tabella di magazzino, o in particolare su ogni articolo, il tipo di Codice a Barre.

Se i codici a barre sono tutti dello stesso tipo, si può inserire il tipo anche sul filtro , nel campo Formato:
Es. Tb=12 significa Codice 128, Tb=13 significa Ean 13 etc.

Se a questa scritta si fa seguire la virgola e la scritta NoCod si può dire di non stampare il codice in chiaro all'interno del codice a barre.

Il programma consente di leggere gli articoli da:

  • Tabella articoli
    Il numero di etichette da stampare potrà essere quello definito sull' anagrafica articoli (o nella tabella di magazzino - Parametri e utilità Dati generali azienda) oppure quello calcolato come giacenza per l'anno corrente di magazzino, sul magazzino principale
  • Movimenti di magazzino di carico
    In questo caso è possibile definire un intervallo di date e/o numeri di inserimento movimenti.
    Il numero di etichette da stampare sarà quello del movimento o quello digitato al momento a video.
  • Ordini di vendita
    In questo caso è possibile definire un intervallo di date e/o numeri di inserimento degli ordini
    Il numero di etichette da stampare sarà pari alla quantità dell'ordine o a quello digitato al momento a video.

Indicando la riga e la colonna da cui partire (con un numero diverso da 1) è possibile stampare le etichette su una qualsiasi posizione del foglio. Si consente così di recuperare le etichette bianche dei fogli dove sia già stata stampata solo qualche etichetta.

Se si stampano etichette con prezzi, il programma stampa le etichette SOLO degli articoli per i quali trova il prezzo in archivio, per il listino selezionato.


STAMPA ARTICOLI FORNITORE

Esegue una lista, per articolo o per fornitore, dei dati inseriti in archivio


STAMPA DESCRIZIONI ARTICOLI IN LINGUA

Percorso: Magazzino - Gestioni - Stampe

Per ogni articolo, esegue la stampa delle descrizioni in lingua associate.


TABELLE DI CONTABILITA'

I programmi presenti in questo menu consentono di inserire tutti i dati ai quali si fà riferimento nella creazione dei clienti e fornitori e in generale nella registrazione dei documenti (da contabilità, da magazzino, da vendite)

Gran parte di questi dati rimarranno stabili nel tempo.

Nei programmi, ogni volta che viene chiesto un codice di una tabella di riferimento (es. condizione di pagamento, banca), è possibile, tramite un pulsante posto sulla lista di aiuto, accedere alla funzione che consente di creare il codice se questo non esiste.

Attività
Monete
Lingue
Codici iva
Cambi
Tipi pagamento
Condizioni di pagamento
Stati
Banche
Zone
Categorie
Riclassificazioni
Classi e Attributi clienti e fornitori


ATTIVITA'

Percorso: Archivi Comuni - Tabelle contabilità

Questa tabella è indispensabile se la ditta deve gestire più attività iva (dichiarazione fatta in Dati Generali Azienda: Parametri di Contabilità).

Al momento dell'installazione, l'utente troverà una attività già impostata, attività "." (punto)).

Se la ditta ha un'unica attività iva, è indispensabile lasciare questa riga, completandola scrivendo
la descrizione dell' attività,
il Codice attività (codice Ateco) che verrà stampato e trasmesso nella Comunicazione annuale dati iva
Attività con obbligo di fatturazione
campo utilizzato per la Comunicazione telematica delle operazioni di importo pari o superiore a 3mila euro. Se impostato a N indica che la ditta non ha obbligo di fatturazione (es. dettaglianti) per cui vengono automaticamente escluse le operazioni precedenti al 1' Luglio 2011 e le altre vengono tutte confrontate con 3600 invece di 3000.

Nel caso di più attività si consiglia di lasciare l'attività . (punto) come la principale e di aggiungere altre righe con attività: A, B, C per le attività successive.

Nel menu Contabilità, Gestioni, Gestione prefissi e numeratori documenti, per ogni registro iva attivato occorre inserire il codice attività al quale quel registro appartiene.

Se una ditta ha più attività iva, dovranno essere compilate, nella tabella dei dati iniziali iva, tante righe per lo stesso anno, una per ogni attività.

Tutto questo per consentire di fare, per le ditte che hanno più attività iva, una Dichiarazione Periodica Iva per ogni attività (considerando i documenti inseriti con i prefissi abbinati ad ogni attività) e una riepilogativa.

Cancellazione di una attività
Il programma non consente la cancellazione di una attività se sono state fatte delle registrazioni di prima nota su questa attività. In pratica si cerca se c'è un prefisso nei numeratori dei documenti al quale sia stata collegata l'attività da cancellare e, se si trova, si prosegue cercando le eventuali registrazioni di prima nota con tale prefisso.

Se non si trovano registrazioni, ma si trova che l'attività è stata collegata a un registro sulla tabella dei numeratori, verrà data la segnalazione di correggere quest'ultima tabella (cancellando il prefisso o collegandolo ad un'altra attività) poi si potrà procedere alla cancellazione dell'attività.


PREFISSI e NUMERATORI DOCUMENTI

Percorso: Contabilità - Gestioni

Questa funzione consente di inserire o variare i numeratori delle fatture/note di credito di acquisto, di vendita e dei corrispettivi registrati in ogni anno.

Se la ditta ha più registri iva Vendite o Acquisti o Corrispettivi, ogni registro avrà il suo numeratore.

Scegliendo, in Parametri Comuni (Parametri e Utilità - Dati generali azienda), la numerazione automatica delle fatture, il numero di protocollo verrà incrementato automaticamente ad ogni nuova registrazione (o stampa fattura dalla procedura Vendite).

Nei Parametri Comuni è possibile scegliere se dare alle note di credito una numerazione separata o consecutiva alle fatture.

Per accedere alla variazione dei numeratori di un certo anno, occorre prima scegliere quali variare tra Vendite, Acquisti, Corrispettivi, poi premere Gestione Numeratori.

Per tornare a gestire un altro gruppo di numeratori, occorre premere il pulsante Torna a tipo registro

Prefisso
L'elenco dei prefissi accettati è quello inserito in Parametri Comuni (Parametri e Utilità - Dati generali azienda).
Esso serve ad differenziare, all'interno dello stesso tipo di registro (es. Vendite), più numerazioni (protocolli).

Se la ditta non utilizza più protocolli per le Vendite (o Acquisti o Corrispettivi) si può lasciare bianco il campo e in automatico verrà compilato con un '.' (punto) per esigenza di procedura, viceversa occorre compilare il prefisso con una lettera o un numero che individua un determinato protocollo.

Quando si inserisce un documento con iva in prima nota (o una fattura da Vendite) verrà proposto sempre il 'prefisso' per il protocollo. Questo sarà quello eventualmente inserito nella causale utilizzata per la registrazione oppure quello inserito in Parametri Comuni.

Il contenuto del campo intestazione verrà stampato come intestazione del Registro Iva.

Numero e Data ultimo documento stampato
Numero e Data ultima Nota Credito stampata
Sono relativi all'ultima fattura e all'ultima nota di credito stampata sui registri iva.
Per quanto riguarda i dati relativi alla Nota di Credito, verranno memorizzati SOLO SE nei parametri generali si è scelto di tenere separata la numerazione delle Fatture da quella delle Note di Credito.
Se si desidera separare la numerazione SOLO per le note di credito clienti e NON per quelle fornitori, basta inserire nei parametri di personalizzazione il flag NcAcqSepar impostato = N

Numero ultima pagina di registro stampata
Se si numerano le pagine di registro durante l'utilizzo, in questo campo viene memorizzato l'ultimo numero utilizzato. (Vedi Libri contabili - numerazione pagine)

In caso di ditta che gestisce più attività iva (Parametri di Contabilità da Parametri e Utilità - Dati generali azienda) è indispensabile codificare le attività nell'apposita tabella e inserire in ogni riga di numeratore, il codice dell'attività alla quale appartengono i documenti inseriti con quel prefisso.

In questo modo si potranno ottenere liquidazioni separate per le varie attività.

Trasportatori
Questo campo è gestibile solo all'interno dei registri Vendite e indica che il registro in oggetto conterrà fatture emesse a trasportatori e che dovranno seguire il regime iva dei trasportatori e in particolare essere stampate sul registro iva nel periodo successivo a quello di registrazione.

Regime del margine
Questo flag va posto a S (Si) se il prefisso corrispondente verrà utilizzato per registrazioni di acquisto e vendita di beni usati (Regime del margine)

Solo per registro acquisti
% detraibilità iva acquisti e % detraibilità iva acquisti annuale
Normalmente questi campi andranno lasciati bianchi e le rispettive percentuali potranno essere scritte nella tabella dei Dati Iniziali Iva. Se invece, in presenza di registri iva acquisti sezionali, l'iva di un registro è detraibile al 100% mentre quella di un altro registro ha una percentuale di prorata (quindi non è tutta detraibile), le percentuali vanno inserite qui.

Per i registri nei quali non viene inserita una percentuale, la chiusura iva prenderà la percentuale presente nella tabella dei Dati iniziali Iva.

La % di detraibilità acquisti annuale, se inserita, verrà utilizzata dalla Chiusura iva annuale, al posto della % di detraibilità utilizzata nei vari periodi.


CODICI IVA

Percorso: Archivi Comuni - Tabelle contabilità

Con questa funzione dovranno essere inseriti tutti i codici iva che individuano le aliquote e gli articoli di esenzione da utilizzare per le registrazioni delle fatture/note di credito.

Possono essere creati codici iva diversi a fronte della stessa aliquota o articolo di esenzione per tenere separati gli importi relativi in fase di Chiusura iva ed Elenco clienti e fornitori.

La cancellazione di un codice iva non è consentita se esistono righe di Ddt e Fatture o registrazioni in contabilità iva in cui quel codice è stato utilizzato.

Per quanto riguarda l' Elenco clienti e fornitori in particolare, si consiglia di fare molta attenzione alla compilazione del Tipo iva e dei campi che indicano se le registrazioni fatte con quel codice vanno o no in elenco e se vanno a incrementare campi particolari quali No separata indicazione imponibile e imposta o Iva non esposta in fattura.

Descrizione e Descrizione breve
Devono essere compilati con l' aliquota stessa o con la descrizione dell'articolo di esenzione o non imponibile. In particolare la descrizione breve verrà stampata in fattura e sui registri iva.
Nota da stampare in fattura
Se nella stampa delle fatture, in presenza di questo codice, serve stampare una nota descrittiva più lunga, compilando questo campo il suo contenuto verrà stampato alla fine del corpo a meno che non sia presente nella testata o nel piede un riferimento al campo stesso (T_Iva01Memo )

Tipo iva
Consente di determinare il tipo di iva individuato dal codice: Normale, Non detraibile, Esente, Non imponibile, Non imponibile Art.8 c.2, Iva esclusa
Se Iva esclusa non verrà trasmesso nella Comunicazione delle operazioni rilevanti ai fini iva (Spesometro)

Natura per Fattura Elettronica e Comunicazione dati fatture
Viene utilizzato per la preparazione dei file XML della Comunicazione dati fatture e delle Fatture elettroniche.
Campo obbligatorio, in corrispondenza di codici iva con Tipo iva diversi da Normale e Non detraibile.
Nota Bene:
Se sono state fatte registrazioni di acquisti in Reverse Charge, anche sul codice iva utilizzato per queste registrazioni va impostata la Natura (N6)

Deve essere compilato con i codici indicati nel pulsante di aiuto

  • N1 - escluse ex art. 15
  • N2 - non soggette:
    - Prestazioni di servizi extra ue
    - Acquisto fuori campo IVA ex articolo 74 del d.P.R. n 633/1972 commi 1 e 2
    - Fatture ricevute da contribuenti che si sono avvalsi dei regimi agevolati, di cui all’articolo 27, commi 1 e 2 del decreto legge n. 98/2011 (regime fiscale di vantaggio) e di cui all’articolo 1, commi da 54 a 89, delle Legge 190/2014 (regime forfettario)
    Dal 01/01/2021 non è più utilizzabile questo codice al suo posto vanno usati
    • N2.1 non soggette ad IVA ai sensi degli artt. da 7 a 7-septies del DPR 633/72
    • N2.2 non soggette - altri casi
  • N3 - non imponibile
    - Fatture emesse relative ad operazioni non imponibili (ad esempio una esportazione ovvero una cessione di beni intraUE), anche se effettuate da un soggetto in regime del margine
    - Con riferimento agli acquisti intracomunitari effettuati ai sensi dell’articolo 42 del decreto legge n. 331/1993, occorre riportare la natura “N3” nel caso di operazione “non imponibile”
    Dal 01/01/2021 non è più utilizzabile questo codice al suo posto vanno usati
    • N3.1 non imponibili - esportazioni
    • N3.2 non imponibili - cessioni intracomunitarie
    • N3.3 non imponibili - cessioni verso San Marino
    • N3.4 non imponibili - operazioni assimilate alle cessioni all'esportazione
    • N3.5 non imponibili - a seguito di dichiarazioni d'intento
    • N3.6 non imponibili - altre operazioni che non concorrono alla formazione del plafond
  • N4 - esenti
    Operazioni esenti. Es. una prestazione sanitaria
    Con riferimento agli acquisti intracomunitari effettuati ai sensi dell’articolo 42 del decreto legge n. 331/1993, occorre riportare la natura “N4” nel caso di operazione “esente”.
  • N5 - regime del margine / IVA non esposta in fattura
    - Fatture relative alle operazioni per le quali si applica il regime speciale dei beni usati (decreto-legge 23 febbraio 1995, n. 41, articolo 36 e seguenti), come ad esempio una cessione di un’autovettura usata, o quello dell’editoria.
    - Fatture emesse senza separata indicazione dell’imposta (articolo74-ter del d.P.R. n. 633/1972) dalle agenzie di viaggio e turismo.
  • N6 - inversione contabile
    - per le operazioni in reverse charge (es. cessione di rottami)
    - fattura d'acquisto in reverse charge (sul file verrà compilato sia il campo “imposta” che il campo “aliquota”) , acquisti intra cee
    - nei casi di autofatturazione per acquisti extra UE di servizi
    - per importazioni di beni nei soli casi previsti
    Dal 01/01/2021 non è più utilizzabile questo codice al suo posto vanno usati
    • N6.1 inversione contabile - cessione di rottami e altri materiali di recupero
    • N6.2 inversione contabile - cessione di oro e argento puro
    • N6.3 inversione contabile - subappalto nel settore edile
    • N6.4 inversione contabile - cessione di fabbricati
    • N6.5 inversione contabile - cessione di telefoni cellulari
    • N6.6 inversione contabile - cessione di prodotti elettronici
    • N6.7 inversione contabile - prestazioni comparto edile e settori connessi
    • N6.8 inversione contabile - operazioni settore energetico
    • N6.9 inversione contabile - altri casi
  • N7 - IVA assolta in altro stato UE
    - vendite a distanza ex art. 40 c. 3 e 4 e art. 41 c. 1 lett. b, DL 331/93
    - prestazione di servizi di telecomunicazioni, tele-radiodiffusione ed elettronici ex art. 7-sexies lett. f, g, art. 74-sexies DPR 633/72)
    (sul file il campo “Imposta” deve essere valorizzato con “0.00”)

In particolare:
per l’N3: le esportazioni (- N3.1 – art. 8 Dpr 633/72 – rigo della dichiarazione – VE30 col 2 ); le cessioni intracomunitarie (N3.2 – art. 41 Dl 3311/93 – rigo della dichiarazione – VE30 col 3 ); le cessioni verso San Marino (N3.3 – art. 71 Dpr 633/72 – rigo della dichiarazione – VE30 col 4); le operazioni assimilate alle cessioni all’esportazione (N3.4 – art. 8 bis del Dpr 633/72 rigo della dichiarazione – VE30 col 5); cessioni non imponibili con lettere d’intento (N3.5 – art. 8, 1 comma, lett. c) del Dpr 633/72 – rigo della dichiarazione – VE31); altre operazioni che non concorrono alla formazione del plafond – (N3.6 art. 21comma 6 bis ovvero cessioni verso depositi Iva art. 50 bis del Dl 331/93 – rigo della dichiarazione – VE32)
Per N6: nella particolare classe di operazioni vi rientrano le operazioni ad inversione contabile di cui all’art. 17 5 e 6 comma, del Dpr 633/72 e inoltre sono ricomprese anche in casi di autofatturazione di acquisti di servizi extra-ue ovvero le operazioni di importazione. Quindi il codice non ricomprende solo le operazioni attive ma anche alcune operazioni passive. In particolare, i codici specifici comprendono: cessione di rottami e altri materiali di recupero (N6.1 – art. 74 Dpr 633/72 – rigo della dichiarazione VE35 col. 2); cessioni di oro e argento puro (N6.2– art. 17, 5 comma Dpr 633/72 – rigo della dichiarazione VE35 col. 3); subappalto nel settore edile (N6.3 – art. 17, 6 comma Dpr 633/72 – rigo della dichiarazione VE35 col. 4); cessione di fabbricati (N6.4 – art. 17, 6 comma lett. a bis), Dpr 633/72 – rigo della dichiarazione VE35 col. 5); cessione telefoni cellulari (N6.5 – art. 17, 6 comma lett. b), Dpr 633/72 – rigo della dichiarazione VE35 col. 6); cessione di prodotti elettronici (N6.6– art. 17, 6 comma lett. c), Dpr 633/72 – rigo della dichiarazione VE35 col. 7); prestazioni comparto edile e settori connessi (N6.7 – art. 17, 6 comma lett. a ter), Dpr 633/72 – rigo della dichiarazione VE35 col. 8); operazioni settore energetico (N6.8 – art. 17, 6 comma lettera da d bis a d quater), Dpr 633/72 – rigo della dichiarazione VE35 col. 9); altri casi (N6.9).

N.B. leggere anche note su Comunicazione Dati Fatture

Forza Split
Nella preparazione del file XLS delle fatture elettroniche e della Comunicazione Dati Fatture, in corrispondenza a fatture emesse con iva Split, le righe 'senza iva' (esenti, non imponibili, escluse) verranno scaricate con 'Esigibilità iva' Immediata. Per forzare anche su queste l'Esigibilità Iva (S) Scissione dei pagamenti occorre mettere a Si questo campo.

Aliquota
Il campo dovrà contenere l'aliquota iva. Se il codice iva individua un esenzione, non imponibile etc. questo campo va lasciato vuoto.

Percentuale non detraibile
Indica, in caso di Tipo iva non detraibile, la percentuale di indetraibilità.

Non detraibile SOLO per contabilità
Questo campo indica che le registrazioni fatte con il codice iva in oggetto vanno considerate indetraibili per quanto riguarda la parte contabile (la parte di iva indetraibile va tutta a costo) mentre per i registri e la chiusura iva la loro iva è normale cioè tutta detraibile.

Scorporo
Se impostato a Si indica che in fase di registrazione, in corrispondenza a questo codice iva, viene digitato un importo da scorporare. Il programma in questo caso eseguirà in automatico il calcolo dell'imponibile e dell'imposta in base all'aliquota.

Reverse Charge
E' indispensabile spuntare questo campo se si registrano fatture che contengono contemporaneamente merci con l'obbligo del Reverse Charge e merci 'normali'. Il programma di inserimento prima nota, in corrispondenza a una causale di tipo 'acquisto Reverse Charge Misto' creerà la fattura corrispondente per il registro vendite per le sole righe inserite con codice iva con reverse charge impostato a Si.

Codice Iva per Ventilazione speciale
Questo campo deve essere valorizzato SOLO nel caso che la ditta applichi la ventilazione speciale (es. macellai). In questo caso si dovrà inserire il codice iva da utilizzare per la ventilazione in corrispondenza agli acquisti registrati con il codice iva 'principale' utilizzato nella registrazione della fattura.
La base di ventilazione verrà incrementata in corrispondenza del codice iva collegato e non del codice iva del movimento.

Codice Iva Sostitutivo (non gestito in Chiusura iva ma solo in Prima nota)
questo campo dovrà essere compilato con un codice iva appropriato, nel caso di codice iva utilizzato per la registrazione di un acquisto intra cee (o reverse-charge) indetraibile che deve creare una fattura di vendita fittizia con iva detraibile (es. acquisti intracee per Produttore agricolo in regime speciale, registrazione di un acquisto Reverse Charge da parte di Studi Medici per cui l'iva acquisti è tutta indetraibile)

ProRata (non gestito)
Indica se e come è utilizzata a fine anno per il calcolo della % di PRORATA

Aggiornamento Plafond
Va impostato in corrispondenza ai codici di esenzione che devono aggiornare il plafond utilizzato

Applico bollo su fatture esenti
Indica se addebitare o no in fase di emissione fattura (da Vendite) l'importo del bollo 'Esente' in caso di fattura completamente esente (cliente esente).

Percentuale Detraibilità Iva Agricola
% di detraibilità per iva agricola da applicare sulle vendite in fase di chiusura iva (PRORATA agricolo)

Servizi Cee
Va impostato in corrispondenza a codici iva che verranno utilizzati per registrare Servizi Intra Cee per individuare gli importi da utilizzare per dichiarazione annuale.

Volume d'Affari
Non utilizzato - Impostare a Si se concorre alla determinazione del volume d'affari

Acquisto-Cessione Beni strumentali:
La procedura prevede che il calcolo degli importi "CD1 - di cui cessioni beni strumentali" e "CD2 - di cui acquisti beni strumentali" della Comunicazione iva annuale venga fatto considerando le registrazioni fatte con codici iva nei quali viene spuntato questo campo.
E' tuttavia possibile attivare il parametro di personalizzazione: Iva BeniStrum in modo da utilizzare gli importi delle registrazioni fatte su determinati conti nei quali è stato spuntato il campo "Beni Strumentali" Acquisto o Cessione.

Cessioni intra Cee
Indica se questo codice iva è utilizzato per registrare le cessioni intra cee. In questo caso gli importi dei movimenti registrati con tale codice verranno sommati sul campo 'di cui cessioni intracom.' del VP1 della Dichiarazione periodica.

Aliquota regime del margine
Nel codice che identifica l'esenzione con la quale verranno registrate le vendite con il regime del margine, dovrà essere indicato in questo campo l'aliquota (non il codice iva) da utilizzare nei calcoli dell'iva del margine sui registri e chiusura iva.

Comunicazione liquidazione Iva: Operazioni attive e passive
In questo campo viene indicato se gli importi registrati con questo codice iva vanno o meno totalizzati nelle sezioni Totale delle Operazioni Attive e Passive della Comunicazione Liquidazione Iva .
Se si cambia il valore di questo campo durante l'anno occorre ripetere le Chiusure iva periodiche, anche in prova, al fine di preparare i dati per la comunicazione trimestrale oppure eseguire il Ricalcolo del periodo dal programma di Chiusura Iva.

  • No - Non verranno considerati (es. Es. art.15) .
    Si riferisce in particolare ai codici con Tipo Iva Esente, Non Imponibile, Iva Esclusa
    I codici con Tipo Iva 'Normale e Non detraibile' , verranno sempre considerati per il calcolo delle Operazioni Attive e Passive
  • Si - Verranno considerati

Articolo 74Ter
Se la ditta gestisce l'articolo 74Ter (Agenzie di viaggio), dovranno essere segnalati i codici iva 'particolari' per poter fare correttamente la chiusura periodica dell'iva e in essi dovrà essere impostato a Si il campo: Iva non esposta in fattura

Nei codici utilizzati per le varie registrazioni, occorre spuntare una delle caselle seguenti, a seconda del tipo di registrazione in cui esso verrà utilizzato.

  • viaggi interamente nella Cee oppure
  • viaggi interamente fuori Cee oppure
  • misti (costi parte Cee e corrispettivi) oppure
  • misti (costi parte no Cee)

Si deve barrare la casella 'Aliquota iva ordinaria' se questo codice iva è quello che dovrà utilizzare la chiusura iva, per scorporare l' iva sull'utile.
ATTENZIONE: ci deve essere un'unico codice IVA in tabella con il campo 'Aliquota iva ordinaria' impostato.

Comunicazione Dati Fatture
Dal 2017 è obbligatorio trasmettere l'elenco delle fatture trimestralmente.

  • Codice che va in elenco
    Indica se le righe, presenti sul documento, con questo codice iva vanno inserite nella Comunicazione.
  • Iva non esposta in fattura e No separata indicazione imponibile e imposta
    Non utilizzati

Fatture ricevute: codice iva prioritario
Questo campo serve per il caricamento delle fatture elettroniche passive.
Spuntare il campo sul codice iva che il programma dovrà utilizzare in automatico nel caricamento delle fatture ricevute

Inoltre si può compilare il campo necessario per scaricare, sul file XML delle fatture, informazioni aggiuntive secondo il tracciato Standard Assosoftware , al fine di rendere più leggibili le fatture elettroniche da parte di chi le riceve: Codifica AssoSoftware Esenzione
 _________________

Precedente al 2017

Comunicazione operazioni rilevati ai fini Iva
Questo gruppo di campi interessa la preparazione corretta del file telematico per la comunicazione delle operazioni rilevati ai fini Iva. E' INDISPENSABILE COMPILARLI CORRETTAMENTE

  • Codice che va in elenco
    Indica se gli importi dei documenti registrati con questo codice iva vanno considerati al fine del calcolo per decidere se il documento va inserito o meno nella Comunicazione.
    In fase di Estrazione dati Operazioni rilevanti ai fini iva verranno considerati SOLO i codici iva che 'Vanno in Elenco'.
    (Elenchi Cli/For: Se impostato a no, l'aggiornamento iva non sommerà l'importo relativo alla riga con questo codice iva, nei progressivi iva clienti-fornitori)
  • Iva non esposta in fattura
    Indica se questo codice iva viene utilizzato per la registrazione di operazioni particolari con Iva non esposta in fattura. (Es. art.74 Ter Agenzie di viaggio, regime del margine).
    Dovrà essere impostato a Si questo campo nei codici iva utilizzati per le registrazioni art.74 Ter Agenzie di viaggio in modo che nell'estrazione delle Op.Ril.ai fini IVA il programma confronti l'importo con il limite utilizzato per chi NON ha P.Iva (3600€)
Il campo seguente, momentaneamente non viene utilizzato
No separata indicazione imponibile e imposta (Operazioni imponibili comprensive dell'imposta afferente)
Indica se questo codice iva viene utilizzato per la registrazione di operazioni senza separata indicazione di imponibile e imposta. In caso affermativo, gli importi registrati con questo codice iva, verranno sommati in un progressivo a parte.


CAUSALI

Percorso: Contabilità - Gestioni

Con questa funzione è possibile inserire tutte le causali che caratterizzano la registrazione degli articoli in Prima Nota.

Ogni causale è caratterizzata da una serie di parametri che, se impostati correttamente, guidano l'utente nell'inserimento degli articoli di prima nota, minimizzando le possibilità di commettere errori.

Una volta creata una causale (deve essere stato premuto il tasto salva) è possibile, premendo il pulsante: Gestione conti collegati, inserire una serie di conti Dare e Avere che verranno proposti nelle varie righe di una nuova registrazione di Input prima nota.

Descrizione e Descrizione aggiuntiva
In ogni causale oltre alla descrizione, che verrà proposta in fase di inserimento di un articolo in input prima nota con possibilità di essere variata, è possibile inserire anche quella che sarà la descrizione aggiuntiva proposta in Prima Nota.

Tipo causale
Campo fondamentale per la caratterizzazione della causale. A seconda di come viene impostato, l'input di prima nota si predisporrà per accettare un tipo di registrazione piuttosto che un'altra.

  • Vendite (fatture - note credito emesse)
  • Acquisti (fatture - note credito ricevute)
  • Corrispettivi normali
  • Corrispettivi da ventilare
  • Iva ad esigibilità differita clienti e rispettivo incasso
  • Iva ad esigibilità differita fornitori e rispettivo pagamento
  • Apertura e Chiusura conti
  • Generica (per tutti i movimenti diversi a diversi, non identificabili nei tipi causali descritti in precedenza).

Segno
Indica il segno (Dare-Avere) della prima riga di prima nota inserita con questa causale.
Assume un valore essenziale nella definizione delle Note di Credito in quanto in questo caso è obbligatorio che sia Avere per quelle emesse e Dare per quelle ricevute.

Nota di variazione
Occorre spuntare questo campo in corrispondenza alle Note di credito emesse e ricevute (Vendita con segno Avere e Acquisto con segno Dare) e alle causali da utilizzare per la registrazione di Note di variazione relative a fatture già registrate in precedenza.
Verrà utilizzato in Prima Nota e contabilizzazione fatture per capire se chiedere i dati della 'fattura di riferimento' e quindi cercarla in archivio al fine di stabilire se e come va trasmessa nella Comunicazione operazioni rilevanti ai fini iva (Spesometro).

In valuta
Indica se la registrazione fatta con questa causale deve essere memorizzata in valuta.

Fattura dettaglianti
Impostare a Si per indicare che si tratta di fattura ma non deve incrementare i progressivi iva vendite in quanto gli importi verranno inseriti come corrispettivi.

Trasportatori
Indica se la causale Per fatt./NC di vendita la cui Iva va al Trimestre successivo.

Intra Cee
Indica se la causale verrà utilizzata per inserire fatture di acquisto (vendita) IntraCee.
Se si abilitano i dovuti automatismi, al momento della conferma della registrazione della fattura di acquisto intracee, il programma di prima nota farà la registrazione automatica della fattura di vendita e del giroconto (vedi acquisti intracee)

Importazioni/Autofattura No-Cee
Indica che si sta registrando una fattura per importazione da un paese extra cee. Questo campo dovrà essere spuntato nelle causali utilizzate per la registrazione delle fatture d'acquisto da San Marino, per le Bolle Doganali (in modo da abilitare la richiesta del codice fornitore per Black List) e per le Autofatture corrispondenti (in modo da riconoscerle per escluderle dal calcolo per la Comunicazione Annuale). Spuntando questo campo e attivando gli opportuni collegamenti, come descritto nel capitolo "importazioni", si attiva la creazione automatica dell'autofattura e giroconto a fronte dell'inserimento di un acquisto di questo tipo.

Importazioni/Autofattura San Marino
Questo campo va spuntato, SOLO se è spuntato il precedente, al fine di tenere separati, nella liquidazione dell'iva, le importazioni/autofatture da San Marino.

Iva Split Payment
Questo campo va spuntato in corrispondenza a causali utilizzate per la registrazione di fatture emesse alla Pubblica Amministrazione, che pagano l'iva direttamente all'erario e non al fornitore (Split payment)

Codice partita e contropartita
Se impostati verranno proposti nella registrazione. Devono essere compatibili con il tipo causale, per Vendite e Acquisti l'eventuale cliente o fornitore va sempre in partita.

Reverse-Charge (No Si Mista)
Indica se la causale verrà utilizzata per inserire fatture di acquisto (vendita) nel sistema del Reverse-Charge
 Se le fatture registrate conterranno beni soggetti a R.C. (es. componenti elettronici) e altri non soggetti, la causale dovrà essere impostata come Mista e dovranno essere utilizzati codici iva diversi, uno normale e uno Reverse Charge, per differenziare i due tipi di merce.
Se si abilitano i dovuti automatismi, al momento della conferma della registrazione della fattura di acquisto che segue la regola del Reverse_Charge, il programma di prima nota farà la registrazione automatica della fattura di vendita e del giroconto

Comunicazione dati fatture:
(campi abilitati SOLO in causali di tipo fattura e note di variazione)
Tipo Documento: è obbligatorio valorizzare questo campo con il tipo documento tratto dalla rispettiva tabella messa a disposizione dall'Agenzia delle Entrate.

TD01 | fattura
TD04 | nota di credito
TD05 | nota di debito
TD07 | fattura semplificata
TD08 | nota di credito semplificata
TD10 | fattura di acquisto intracomunitario beni
TD11 | fattura di acquisto intracomunitario servizi

Se il campo non è valorizzato, il programma di estrazione dati fatture lo valorizzerà in base il tipo causale.
Nel caso di fattura di acquisto intracomunitaria, dovrà essere valorizzato in modo diverso a seconda che si tratti di beni (TD10) o di servizi (TD11); se non sono già state create causali diverse per i due casi, si può lasciare bianco il campo 'Tipo documento' e il programma di estrazione assegnerà l'uno o l'altro valore a seconda che sui conti di costo utilizzati nella registrazione sia stato spuntato il campo Beni o Servizi (in caso di presenza di conti dell'uno e dell'altro tipo, verranno sommati separatamente le due tipologie e si terrà conto di quello che ha il totale imponibile più alto)
Inclusione forzata
In generale lasciare a No, sarà il programma di estrazione a decidere se estrarre o meno il documento.
Impostare a S per includere le rispettive registrazioni SEMPRE

Regime del margine
Questo flag è abilitato SOLO se si sta inserendo una causale di acquisto o di vendita. Consente di registrare acquisti e vendite di beni usati da gestire e stampare seguendo le regole del regime del margine.

Dopo aver compilato questo flag occorre specificare, nell'apposito riquadro del Margine, per vendita: se si tratta di vendita normale o esportazione, per acquisto: se si tratta di acquisto normale o importazione e se acquisto di un bene oppure spese di trasporto o spese accessorie.
In causali di questo tipo è OBBLIGATORIO inserire un prefisso creato con flag Regime del margine a Si.

Conto iva
Se si gestisce l'iva per cassa occorre NON compilare mai questo campo. Sarà il programma a decidere se utilizzare il conto iva normale o iva per cassa leggendoli dalla tabella dei conti comuni.
Se il tipo causale prevede una registrazione con iva, si può scrivere in questo campo il conto iva da utilizzare se diverso da quello generale inserito nella tabella dei conti comuni (Parametri: Dati generali azienda)

Codice iva
E' il codice iva che verrà presentato di default, nelle righe di costo o ricavo in registrazione di fatture/note di credito o corrispettivi. Se anche sul cliente è stato inserito un codice iva, quest'ultimo ha priorità su quello inserito nella causale.

Prefisso
Indica l'eventuale prefisso (registro iva) da proporre nella registrazione (campo obbligatorio se causale per Regime del Margine)

Protocollo, documento obbligatorio
Gli estremi del protocollo e documento, prefisso, numero e data, sono obbligatori 'sempre' se si tratta di fatture o note di credito. Inoltre, se nei parametri di personalizzazione è impostato il parametro 'dataop' per ordinare i partitari e il giornale per data protocollo, esso è sempre obbligatorio.

Condizioni di pagamento obbligatorie
Indica se in inserimento di movimenti di vendita o di acquisto è obbligatorio l'inserimento della condizione di pagamento e la successiva generazione delle scadenze.

Tipo partita
Indica se l'articolo gestisce le partite. Es. una fattura apre partita, un incasso 'si riferisce' a una partita già aperta.
Una partita è individuata da codice Cliente/Fornitore, prefisso, numero e data documento.
Il prefisso non viene utilizzato se impostato a S il parametro di personalizzazione NoUsaPreDoc
Una corretta impostazione di questo campo sulle causali opportune, consente, al momento della registrazione in prima nota di inserire sempre i riferimenti alla partita e quindi di visualizzare e stampare correttamente le partite dei clienti e dei fornitori.
Il tipo partita può essere variato anche se sono già state fatte delle registrazioni con la causale in oggetto, le partite però verranno riconosciute solo se sulle registrazioni sono stati compilati numero e data documento.
Sono state predisposte due funzioni per sistemare le partite, una in automatico e una che consente l'intervento manuale.

Aggancio scadenze/partite
Indica se la registrazione chiude le scadenze (o una partita). Ha senso impostarlo a Si nelle causali di tipo Generico o Incasso-Pagamento fatture con iva ad esigibilità differita.

Registrazione insoluto
Indica se questa causale verrà utilizzata per la registrazione di un insoluto e quindi per riaprire il cliente. Se questo campo viene impostato a Si, il programma di prima nota, in corrispondenza a una registrazione fatta con questa causale, proporrà la condizione di pagamento inserita sulla causale stessa e genererà una nuova scadenza per l'importo dell'insoluto.

Condizione di pagamento per scadenza derivata da un insoluto
Vedi sopra

Movimento generato da cespiti
Se è installata la procedura Cespiti, questo campo va impostato a Si sulle causali di ammortamento cioè su quelle causali richiamate nella tabella di collegamento Cespiti-Contabilità e che servono per la generazione automatica in contabilità dei movimenti relativi ai Cespiti.

Se la ditta è in Semplificata, le causali di ammortamento dovranno essere di tipo 'Acquisti' in quanto anche le registrazioni di ammortamento dovranno essere stampate sui registri iva (per questo motivo, il flag 'generato da cespiti', non è gestito sulle causali generiche di una ditta in semplificata).

Causale cespiti
Se è installata la procedura Cespiti ed è stato attivato il parametro di personalizzazione LanCespiti, in corrispondenza alle causali di acquisto e vendita cespite è possibile impostare la corrispondente causale cespiti in modo da poter passare automaticamente, al termine della registrazione in prima nota, all'anagrafica Cespiti per inserire il movimento corrispondente.

Causale collegata
La compilazione di questo campo attiva, in corrispondenza ad alcuni tipi causali, la generazione di un articolo in automatico ogni volta che si conferma una registrazione con la causale principale.
(Es. fattura di acquisto intra-cee, reverse charge, importazioni)

Percentuale Ritenute d'acconto
Vedi gestione Ritenuta d'acconto.
Se si imposta questa percentuale in una causale che verrà utilizzata per la contabilizzazione delle fatture emesse, in fase di emissione fattura diretta e accompagnatoria verrà calcolata la ritenuta d'acconto.

Se si imposta su una causale utilizzata per la registrazione di una fattura di acquisto ed è stato attivato il parametro di personalizzazione: RitAccFornAutom, al termine della registrazione verrà generata in automatico la registrazione della Ritenuta d'acconto.

Causale Ritenuta
Vedi gestione Ritenuta d'acconto.
E' la causale utilizzata dalla contabilizzazione fatture o dal programma di Prima Nota (a seconda che si tratti di una causale per fattura di vendita o di acquisto), per la registrazione dell'eventuale movimento di ritenuta d'acconto.

Causale prioritaria per fattura ricevuta
Questo campo serve per poter importare correttamente in contabilità le fatture / note di credito ricevute. Va spuntato in corrispondenza alle causali di acquisto in modo che la funzione 'Contabilizzazione fatture d'acquisto' la scelga come causale della registrazione.

Percentuale costo indeducibile
Questa percentuale può essere impostata su una causale di fattura d'acquisto. Essa verrà utilizzata dalla prima nota, durante l'inserimento di una fattura d'acquisto per generare la riga di costo non deducibile.

Campi non utilizzati dal 2017:
Segnalazione Reverse Charge in Spesometro
Consente di individuare le registrazioni di acquisto Reverse Charge, relative ad acquisti per cui andrà barrata la casella Reverse Charge nella stampa/preparazione del file dello Spesometro, in corrispondenza a operazioni in cui questo conto è utilizzato.
Potrà essere impostato a Si nelle causali utilizzate per la registrazione di acquisti 1972 (acquisto di materiale d’oro e d’argento e le prestazioni di servizi rese nel settore edile da soggetti subappaltatori) e in quelle di cui all’articolo 74, commi 7 e 8 (acquisti di rottami e metalli non ferrosi)
Questo per differenziare dalla registrazione di acquisti di apparecchi elettrici e telefonini che verranno considerati ma senza flag Reverse Charge
Quadro TU Spesometro
Se vale S nello spesometro le registrazioni fatte con questa causale verranno riportate nel quadro TU (Operazioni legate al turismo)


CAUSALI - GESTIONE CONTI COLLEGATI

Percorso: Contabilità - Gestioni - Causali

Questa maschera consente di inserire, per ogni causale, dei codici di conti.

Lo scopo è quello di automatizzare l'inserimento di una registrazione di prima nota in quanto tali conti verranno proposti nelle varie righe della registrazione, in Dare o in Avere a seconda di come l'utente ha impostato qui il campo Dare/Avere sulle varie righe.

Codice iva
E' il codice iva che verrà presentato di default, in registrazione di fatture/note di credito o corrispettivi, nelle righe corrispondenti ai conti inseriti in questa tabella. Se anche sul cliente è stato inserito un codice iva, quest'ultimo ha priorità su quello inserito nella causale.


BANCHE

Percorso: Archivi Comuni - Tabelle contabilità

Vengono gestite tutte le banche dei clienti (e fornitori) per poterle stampare sulle fatture e gestire adeguatamente scadenzari ed emissioni di effetti. Quando si codifica una banca sulla quale verranno appoggiate delle distinte, oltre ai campi descrittivi, occorre compilare il codice del conto del piano dei conti della ditta in gestione, per consentire di registrare, in modo automatico, operazioni di contabilizzazione degli effetti.

Se si inserisce una banca con ABI e CAB uguali ad una già inserita, viene dato un messaggio. Si consente tuttavia di salvare ugualmente quest'ultima banca o di correggerla.

In questa gestione tutti i campi della maschera sono abilitati per la ricerca. Per cui se si deve cercare una banca tramite il codice abi, si può inserirlo sul campo codice e premere il tasto F4 oppure si può scriverlo direttamente nel campo ABI e premere il pulsante di ricerca.

In qualsiasi punto delle procedure in cui venga richiesto un codice banca, la ricerca può essere fatta, oltre che per codice e descrizione, anche per ABI o ABI e CAB digitando l' ABI (completo o incompleto con * finale) oppure ABIçCAB (il carattere ç deve essere sempre scritto in fondo all'abi anche se non si mette anche il cab) e premendo il tasto F2 (lista per codice) o F3 (lista per descrizione).

Per ogni banca è possibile definire se azzerare o meno, all'inizio di ogni generazione del file delle Ri.Ba., il numero progressivo effetti, questo perché alcune banche richiedono che gli effetti vengano numerati, all'interno della stessa riba, sempre a partire da 1.

Nei codici che identificano banche utilizzate dall'azienda, è possibile inserire, oltre ad Abi, Cab e ContoCorrente, anche gli altri dati che concorrono a formare il codice Iban: Codice di controllo Iban e Cin.

Il codice di controllo per l'Italia è IT seguito da due cifre.
Sul video viene visualizzato il codice iban completo, creato sommando i vari componenti: Codice di controllo, Cin, Abi, Cab, ContoCorrente.
Se il codice di controllo inizia con IT, il programma segnala se la lunghezza totale dell'Iban risulta diversa da 27.
Questi campi vengono utilizzati da quanti vogliono stampare nelle fatture con pagamento Bonifico, i dati della banca su cui eseguirlo (occorre inserire nel filtro di stampa i campi che compongono l'iban).

In questo caso vengono compilati questi dati solo sulle banche della ditta stessa poi, al momento dell'emissione della fattura, si mette come banca del cliente la banca della ditta su cui si vuole venga fatto il bonifico.

E' stato inserito anche il codice B.I.C. per eventuali utilizzi futuri.

Per Fattura elettronica

Nella tabella Banche, dovrà essere creato un codice banca con tutti i dati della banca su cui va fatto il pagamento: ABI CAB CIN e Conto corrente in modo da derivarne l'IBAN da riportare sul file xml della fattura in corrispondenza a una modalità di pagamento che prevede un bonifico.

Codice Ufficio Postale
Va compilato in corrispondenza al codice banca 'fittizio' creato per indicare, sul file xml della fattura elettronica, l'ufficio in cui dovrò avvenire l'incasso nei casi di modalità di pagamento in cui ha senso l'indicazione dell'ufficio postale. Tale codice banca dovrà essere indicato sulla condizione di pagamento e verrà riportata, con possibilità di variazione, in testata fattura come banca della ditta che emette la fattura.


TIPI DI PAGAMENTO

Percorso: Archivi Comuni - Tabelle contabilità

In questa tabella devono essere impostati tutti i tipi di pagamento che la ditta utilizza (es. C=Contanti, D=Rimessa Diretta, R=Ric.Bancaria, S=C/assegno). Il dettaglio del pagamento, numero scadenze etc, dovrà essere impostato con la funzione: Condizioni di Pagamento.

Descrizione e descrizione breve
La descrizione breve verrà stampata sulle distinte e comunque là dove, per la lunga, non ci sarebbe spazio.

Causale contabile
Decodifica dall'archivio causali. E' la causale che viene proposta al momento della generazione in automatico delle registrazioni di incasso (es. contabilizzazione delle distinte o incasso immediato fattura).

Codice Conto
E' il conto che verrà proposto al momento della generazione in automatico delle registrazioni di incasso (es. contabilizzazione delle distinte).

Tipo effetto
Indica se il pagamento è un effetto e di che tipo.

  • No Effetto
  • Ricevuta bancaria
  • Rimessa diretta
  • Tratta

Emissione effetti
Indica se questo tipo di pagamento genera effetti. In fase di generazione distinta si tiene conto solo delle scadenze generate da tipi pagamento che prevedono l'emissione effetti.

Addebito bolli
Indica se la condizione di pagamento prevede l'applicazione del bollo in fattura. Il calcolo dei bolli verrà fatto a partire dagli scaglioni di importo, se Ricevuta Bancaria, o in percentuale, se Tratta.
I bolli verranno poi addebitati o meno al singolo cliente a seconda di come è stato previsto nei suoi dati anagrafici.

Progressivo effetti
E' il numeratore degli effetti emessi con questo tipo di pagamento. Viene incrementato dalla stampa degli effetti o dalla generazione dell'archivio delle Ri.Ba. Sull' anagrafica banche si può scegliere se numerare gli effetti per distinta (ricominciando sempre da 1 per le distinte appoggiate su quella banca) oppure dare ad essi un numero progressivo.

Registrazione automatica incasso fattura
Indica se al momento dell'emissione di una fattura con un pagamento di questo tipo deve essere registrato in automatico l'incasso. La registrazione dell'incasso avrà la causale e il conto specificati sul tipo pagamento pertanto questi due campi diventano, in questo caso, obbligatori.

Escluso da Operazione rilevante ai fini iva
(campo non più utilizzato da Spesometro 2012)
Il campo dovrà essere spuntato per indicare le modalità di pagamento in corrispondenza delle quali la fattura emessa a privati, anche se di importo 'rilevante ai fini iva', non va trasmessa negli elenchi relativi perchè incassata con carte di credito o prepagate etc.
Se nella registrazione della fattura verrà indicato un pagamento di questo tipo, il programma non considererà l' operazione 'rilevante ai fini iva'.

Nota fissa
E' possibile inserire qui il codice di una nota fissa da stampare in DDt o in fattura. Questo codice verrà riportato automaticamente, nel momento in cui verranno create, su tutte le condizioni di pagamento che hanno questo tipo di pagamento.

Questa nota potrà contenere, in particolare, i dati per il pagamento contrassegno (da stampare sul ddt) o gli estremi bancari della ditta da comunicare ai clienti che devono pagare con bonifico (da stampare sulla fattura).

Modalità pagamento per fattura elettronica
Campo obbligatorio in caso di emissione di fattura elettronica.
In ogni tipologia di pagamento che verrà utilizzata nell'emissione della fattura elettronica occorre compilare questo campo in base ai valori elencati nella tabella di decodifica.

Inoltre si può compilare il campo necessario per scaricare, sul file XML delle fatture, informazioni aggiuntive secondo il tracciato Standard Assosofware: Codifica AssoSoftware Tipo Pagamento


CONDIZIONI DI PAGAMENTO

Percorso: Archivi Comuni - Tabelle contabilità

Nella tabella devono essere inserite tutte modalità di pagamento da richiamare nelle anagrafiche dei clienti (e fornitori) per ottenere la generazione delle scadenze al momento della registrazione delle fatture e quindi le successive elaborazioni.

Tipo di pagamento
Deve essere stato precedentemente codificato nella tabella dei tipi di pagamento.

Numero scadenze
Indica il numero delle scadenze da calcolare. Sono ammesse fino a 99 scadenze. Se viene utilizzata la periodicità tabellare, con tabella giornaliera o mensile, il massimo è 15.
Se il numero di scadenze viene impostato a 0, la scadenza si considera a vista.

Impostando a -1 il numero di scadenze, queste non verranno generate.
Serve per creare una condizione di pagamento 'fittizia' che anche se richiamata in prima nota (nelle causali dove c'è l'obbligo condizioni di pagamento) NON genera la scadenza.
N.B. Se si imposta a -1 questo campo, non verrà compilato sul file XML della Fattura elettronica la sezione <DatiPagamento> che consente di stampare in fattura le modalità di pagamento

Spesa
E' il codice della spesa da addebitare in corrispondenza alla condizione di pagamento. Se la ditta addebita le spese bancarie o il costo del bollo per le tratte, anche a un solo cliente, qui dovrà essere inserito il codice Spesa opportuno e cioè Spese Bancarie o Spese per tratte.

Sconto
E' la percentuale di sconto incondizionato da applicare sui documenti con questa condizione di pagamento.

Nota fissa
Questo campo viene impostato automaticamente in creazione del codice di pagamento, in base a quanto è stato inserito sul Tipo pagamento ad esso associato. Può essere variato o sbiancato.

Se impostato, la nota fissa corrispondente verrà riportata e stampata in DDt o in fattura quando si inserisce un documento con un cliente che ha questo Codice di pagamento. Sul ddt la nota verrà inserita se il flag 'Da stampare sul documento di evasione' è posto a No altrimenti verrà inserita dall'evasione ddt direttamente sulla fattura.

Questa nota potrà contenere, in particolare, i dati per il pagamento contrassegno (da stampare sul ddt) o gli estremi bancari della ditta da comunicare ai clienti che devono pagare con bonifico (da stampare sulla fattura).

Scadenze in valuta
Indica se le scadenze generate sono in valuta.

Decorrenza
Indica la data da cui partire per il calcolo delle scadenze.
Può assumere i seguenti valori:

  • Fine mese
  • Data fattura
  • Fine mese successivo

Periodicità

Indica la periodicità delle scadenze.
Può assumere i seguenti valori:

  • Mensile (seguirà la richiesta del numero dei mesi)
  • A giorni (seguirà la richiesta del numero dei giorni)
  • Mensile tabellare (seguirà la richiesta degli intervalli mensili e delle relative percentuali per il calcolo dell'importo scadenza)
  • A giorni tabellare (seguirà la richiesta degli intervalli in giorni e delle relative percentuali per il calcolo dell'importo scadenza)

Giorno Fisso
Se la Periodicità è mensile o mensile tabellare, si può impostare un giorno fisso al quale dovrà essere rimandata la scadenza. In questo caso, se sul cliente viene impostato come giorno a cui si rimanda la scadenza nel caso di mesi in cui non si vogliono effetti, lo stesso giorno del 'giorno fisso', in quel mese si otterranno 2 scadenze.

Trattamento iva
Indica se ripartire o meno sulle varie scadenze l'imposta (iva) delle fatture.

  • Iva suddivisa
  • Iva in rata unica (la prima rata di sola iva)
    L'iva viene addebitata tutta sulla prima rata

Tabella scadenza-percentuale
Se la periodicità è tabellare è possibile inserire fino a 15 periodi di scadenza, ciascuno con la relativa percentuale.
Es. con tabella a giorni:
la prima scadenza, per il 20% dell'importo della fattura, dopo 30 giorni dalla data fattura
la seconda con il restante 80%, dopo altri 20 giorni.
In tabella si imposterà:
30 20 (cioè a 30 gg il 20%)
20 80 (cioè dopo altri 20 gg il restante 80%)

La somma delle percentuali dovrà essere 100.

- Se Trattamento iva = 1 e si fa la tabella dei mesi (o giorni) la prima percentuale dovrà essere 0 perché ho l'iva da sola poi a 30 o 60 ci va il 100% del resto o 50% + 50% o …

- Se periodicità tabellare e si lasciano tutte le % corrispondenti all'intervallo scadenze, a 0 vuol dire che si dovrà dividere l'importo totale della fattura per il numero scadenze (cioè in parti uguali) senza utilizzare le percentuali (questo per evitare che vengono fuori importi strani con 33.33).

- Se si vuole che la prima scadenza cada nel mese di emissione della fattura si dovrà mettere 0 nel campo Scadenza sulla riga 1 della tabella che si va a creare

Per Fattura elettronica

Nostra Codice banca per Bonifici o Ufficio Postale
Compilare con il codice banca della ditta che ha emesso la fattura. Da questa banca verranno estratti C/Corrente, ABI , CAB, CIN per ottenere l'IBAN dove effettuare il Bonifico.
Analogamente, sulla modalità di pagamento che coinvolge l'Ufficio Postale (es. 'domiciliazione postale'), si può impostare il codice della banca su cui è stato compilata la 'Descrizione Ufficio Postale'.
Tale banca, se impostata, verrà visualizzata in testata fattura con possibilità di variazione


CLASSI E ATTRIBUTI CLIENTI E FORNITORI

Percorso: Archivi Comuni - Tabelle contabilità

La tabella classi consente di gestire diverse classificazioni (raggruppi) di clienti e fornitori. Sono disponibili fino a cinque classi diverse. Ad ogni classe è possibile associare degli attributi che sono delle caratteristiche della classe. Se si creano classi nuove o si variano le descrizioni delle esistenti, per poterle utilizzare subito nella Gestione dei Clienti e Fornitori occorre eseguire dal Menu di Utilità la funzione Rileggi Parametri altrimenti saranno utilizzabili solo una volta usciti e rientrati nella procedura.

Esempio: La classe 1 può indicare la tipologia cliente e si potrà mettere in ogni cliente in corrispondenza alla classe 1 un attributo diverso a seconda della sua tipologia: ente pubblico, privato, azienda etc..

In ogni anagrafica cliente (fornitore) è possibile inserire, per ogni classe creata, un codice attributo.


ZONE CLIENTI - FORNITORI

Percorso: Archivi Comuni - Tabelle contabilità

Contiene codice e descrizione delle zone da associare alle anagrafiche clienti. Se inserite, è possibile eseguire stampe dei clienti raggruppati per zona.

E' possibile stampare la tabella premendo il pulsante Stampa.


CATEGORIE CLIENTI

CATEGORIE CLIENTI - FORNITORI

Percorso: Archivi Comuni - Tabelle contabilità

La tabella contiene codici e descrizioni delle categorie che possono essere associate ai clienti. Se vengono gestite, sarà possibile creare delle tabelle di sconto per Categoria Cliente e Gruppo Prodotti.

E' possibile stampare la tabella premendo il pulsante Stampa.


RICLASSIFICAZIONI

Percorso: Archivi Comuni - Tabelle contabilità

Contiene codici e descrizioni da impostare per ottenere bilanci riclassificati.

La stampa del bilancio riclassificato, riordinerà i conti in base ai codici di riclassificazione impostati e, per ogni gruppo di conti con lo stesso codice di riclassificazione, calcolerà il saldo.

E' possibile stampare la tabella premendo il pulsante Stampa.


REGIME DEL MARGINE - BENI USATI

Percorso: Contabilità - Gestioni - Beni usati

Questa funzione consente di inserire l'elenco dei beni usati da richiamare nelle registrazioni di acquisto e di cessioni che interessano il Regime del Margine.

La descrizione del bene verrà stampata sui Registri degli acquisti e cessioni dei beni usati.


STATI

Percorso: Archivi Comuni - Tabelle contabilità

La tabella stati viene utilizzata nella decodifica dello stato dei clienti e fornitori.

Moneta
E' il codice della moneta dello stato.

Lunghezza partita iva
Per gli stati appartenenti alla Comunità Europea, il programma controlla la correttezza della partita iva inserite nelle anagrafiche, secondo le specifiche date dall'Agenzia delle Entrate. La condizione è che sia stato impostato correttamente il codice ISO dello stato.
Per gli stati Cee si consiglia pertanto di lasciare bianchi questi due campi oppure di impostarli correttamente scrivendo, per quegli stati che ammettono codici di diverse lunghezze, le prime due lunghezze ammesse.

Cee
Indica se lo stato fa parte della Comunità Europea (consente di individuare in prima nota le registrazioni INTRACEE)

Codice tabella generale Stati
E' il codice di collegamento con la tabella completa degli stati, memorizzata nel database del menu.
La compilazione di questo codice consente di associare, ai vari stati codificati dall'utente, alcune informazioni contenute nella tabella generale (es. l'informazione se lo stato è o meno in Black List e il numero che rappresenta il codice stato per la compilazione dei moduli per la comunicazione delle operazioni con soggetti aventi sede in paesi a fiscalità privilegiata - Black List-)

Codice ISO
Se lo stato fa parte della Comunità Europea, dovrà essere inserito il codice ISO che andrà a completare la Partita Iva dei clienti e fornitori.

TABELLA GENERALE DEGLI STATI

Percorso: Parametri e utilità - Dati azienda e parametri - Tabella generale Stati

La tabella contiene l'elenco generale di tutti stati e viene fornita, già compilata, sul database del menu (AziMenu.mdb)
Per ogni stato è stato

Codice ISO

Codice agenzia delle entrate
Serve, ad esempio, per la compilazione (e l'invio telematico) dei moduli per la Comunicazione delle operazioni con soggetti aventi sede in paesi a fiscalità privilegiata

Stato in Black List
Impostato a Si consente di individuare le registrazioni di prima nota (vendite e acquisti) che riguardano transazioni fatte con soggetti aventi sede in paesi a fiscalità privilegiata


MONETE

Percorso: Archivi Comuni - Tabelle contabilità

La tabella contiene l'elenco delle monete (valute) da utilizzare nella gestione.

Dovranno obbligatoriamente essere definite almeno due monete: Lira ed Euro. I rispettivi codici andranno riportati nella tabella ditta. In corrispondenza a queste due monete il cambio dovrà essere obbligatoriamente a 1 e l'operatore è ininfluente.

La stampa della tabella si ottiene premendo il pulsante Stampa.

Numero decimali
E' il numero di decimali da considerare negli importi generati dall'uso della moneta in oggetto (es. totali della riga documento).

Numero decimali in gestione
E' il numero di decimali (4 al massimo) da gestire negli importi unitari di riga dei documenti (listini).
Per avere un listino in lire, con decimali si potrà impostare questo valore diverso da 0 mentre il numero decimali della moneta sarà 0.

Operatore
Servirà per convertire in euro un importo espresso nella moneta in oggetto. Dovrà essere * (moltiplicazione) o / (divisione) a seconda di come verrà espresso il cambio.
Se OP è l'operatore, il calcolo che fa il programma è: importo in euro=importo in moneta OP cambio

Un.Mon.
Indica se si tratta della moneta di uno stato che ha aderito all'unione monetaria europea. Varrà utilizzato in Variazione automatica listini, nel passaggio tra due listini con moneta diversa da Lire ed Euro, per sapere se fare o meno la triangolazione (passaggio dall'euro).

Simbolo moneta
Indica il simbolo della moneta. Può essere stampato in fattura utilizzando nel filtro la variabile T_SimbMon

Codice ISO
Campo obbligatorio se si dovrà preparare il file XML delle fatture elettroniche. Per l'Euro il codice è EUR


CAMBI MONETE

Percorso: Archivi Comuni - Tabelle contabilità

Questa funzione serve per inserire giorno per giorno i cambi delle monete da utilizzare nella registrazione dei documenti. In inserimento di movimenti di magazzino o di documenti, data la moneta, verrà proposto il valore del cambio più vicino che potrà essere variato di volta in volta, poi ogni registrazione si porterà dietro il suo cambio.

Il valore del cambio deve essere dato rispetto all'EURO e dovrà essere inserito in modo coerente con quanto è stato messo nel campo operatore della moneta.

Se OP è l'operatore, il calcolo che fa il programma è: importo in euro=importo in moneta OP cambio.

I cambi delle due monete Lire ed Euro dovranno essere obbligatoriamente a 1.

In Dati generali azienda (parametri comuni) viene inserito il cambio lira/euro e l'operatore da utilizzare per la conversione.


LINGUE

Percorso: Archivi Comuni - Tabelle contabilità

Serve per associare al cliente/fornitore l'eventuale codice lingua da utilizzare per la descrizione degli articoli sui documenti di Vendita o Acquisto.

La stampa della tabella si ottiene premendo il pulsante Stampa.


CONTRATTI

Percorso: Archivi Comuni - Tabelle di Contabilità

L'anagrafica dei contratti serve a definire gli eventuali contratti stipulati con i clienti, in modo da poter inserire dei dati del contratto da utilizzare nell'inserimento di documenti.

E' possibile generare automaticamente il codice contratto dopo aver creato il parametro di personalizzazione ChiaveBaseLun che indica la lunghezza (il numero di cifre) del codice contratto 'numerico' e progressivo da generare in automatico dopo che l'utente avrà premuto il pulsante
'Crea codice automatico'.
Inoltre si può impostare il parametro ChiaveBase contenente alcuni caratteri di 'Prefisso' da usare come base per calcolo automatico del codice contratto

Sia in input prima nota, sia su ordini, ddt e fatture verrà data la possibilità di associare un codice contratto al documento.
In fase di inserimento fattura, se si inserisce un codice contratto, verranno riportati sulla testata della fattura stessa i campi in esso compilati

In particolare i dati serviranno per la compilazione della fattura elettronica. In questo caso si potrà creare un codice 'contratto' anche per indicare un Ordine di Acquisto o Convenzione o Dati Ricezione o Fattura Collegata e compilare i campi seguenti.
Nella maschera dei dati aggiuntivi per la fattura elettronica si potrà mettere il codice corrispondente; in questo modo il programma di preparazione del file xml, estrarrà i vari campi (es. CIG , CUP) dal 'contratto' . Viceversa si possono inserire i dati relativi a contratto etc. direttamente sulla fattura.

Codici CIG (Codice Identificativo Gara) e CUP (Codice Unico di Progetto)
Se inseriti sul contratto verranno riportati in automatico sui documenti che si riferiscono a tale contratto al fine di poter essere stampati su ddt, fatture e Ri.Ba e fattura elettronica

Numero e Data dell'ordine di acquisto associato alla fattura
Si può compilare se si emetterà una fattura unica a fronte di questo contratto

Riga dell'ordine di acquisto associato alla fattura
Codice della commessa o della convenzione

I campi seguenti sono stati utilizzati nell'estrazione delle Operazioni Rilevanti ai fini iva fino al 2012. Ora non vengono più utilizzatiL'anagrafica dei contratti serve a definire gli eventuali contratti con clienti e/o fornitori che comporteranno fatture multiple, il cui importo totale, se superiore ai 3000,00 €, dovrà essere comunicato con la 'Comunicazione telematica delle operazioni rilevanti ai fini iva', anche se singolarmente sono di importo inferiore.
Tipo contratto
Indica come si dovrà comportare il programma di estrazione delle Operazioni Rilevanti ai fini Iva; quando incontrerà fatture collegate al contratto.

  • Da comunicare in base al Totale fatturato nell'anno
  • Da comunicare SEMPRE (verranno comunicate le singole fatture, qualunque sia l'importo totale)
  • Da NON comunicare

Modalità di Pagamento

  • Importo NON frazionato
  • Importo frazionato
    Ad esempio un acquisto di un bene il cui valore complessivo supera i 3.000,00 (3.600,00) € per il quale sono state emesse più fatture, eventualmente in più anni. Le singole fatture potranno essere anche inferiori ai 3.000,00 €.
  • Corrispettivo periodico
    Es. contratti di appalto, somministrazione e/o a corrispettivi periodici.

Nota: se un documento è associato ad un contratto e quest'ultimo prevede la comunicazione, esso verrà sempre comunicato, se ci sono i requisiti, anche se il documento è intestato ad un cliente (o fornitore) escluso dalla comunicazione.


PUNTI VENDITA

Percorso: Archivi Comuni - Tabelle contabilità

Con questa funzione dovranno essere inseriti tutti i Punti Vendita della ditta, quando si utilizzano i programmi di Estrazione e Preparazione del file per l'invio telematico dei corrispettivi.

Codice - Descrizione

I campi seguenti sono tutti obbligatori in quanto sono quelli richiesti nel tracciato record del file di invio.

Indirizzo Cap Comune Provincia

Provincia Camera Commercio
Sigla provincia

R.E.A. Assegnato S /N
Indica se è stato attribuito o meno l'identificativo R.E.A.

Numero R.E.A.
Campo obbligatorio se R.E.A. Assegnato è posto a SI
E' il numero di Repertorio Economico Amministrativo attribuito dalla Camera di Commercio

Progressivo R.E.A.
Campo obbligatorio se R.E.A. Assegnato è posto a SI
Numero d'ordine attribuito alla sede dalla Camera di Commercio.

Ident.provvisorio assegn.da Camera di Commercio in attesa del R.E.A.
Campo obbligatorio se R.E.A. Assegnato è posto a NO

Elenco dei Prefissi utilizzati dal punto vendita per l'inserimento dei corrispettivi
Ogni punto vendita dovrà avere prefissi diversi
In pratica lo stesso punto vendita può utilizzare lo stesso prefisso sia per corrispettivi che per le fatture ma quel prefisso NON deve essere utilizzato da altri punti.

Verrà visualizzato l'elenco dei prefissi corrispettivi (da Parametri e Utilità - Dati generali azienda (parametri) - Parametri Comuni) seguito dagli eventuali prefissi utilizzati per le fatture/note dei corrispettivi inseriti nel parametro di personalizzazione: PreFattCorri
Questo perchè il programma possa individuare queste ultime e differenziarle dalle fatture/note che non vanno estratte in questa fase (Es. cessioni di immobili e/o di beni strumentali)

Requisiti dimensionali nella norma S/N

Ventilazione S/N
Indica se il punto vendita ha la ventilazione dei corrispettivi

Attivo S/N
Indica se il punto vendita è attivo. L'estrazione dei corrispettivi NON considera le registrazioni con prefissi che appartengono a punti vendita NON attivi

Per una corretta estrazione dei dati, nel caso il punto vendita emetta fatture per corrispettivi, dovranno essere creati anche i seguenti parametri di personalizzazione: FattCorri e NotaCorri in quanto queste dovranno essere sommate nel calcolo degli importi giornalieri.


STAMPA CAUSALI

Percorso: Contabilità - Gestioni - Stampe

Esegue la stampa delle Causali di contabilità generale.


STAMPA PREFISSI E NUMERATORI DOCUMENTI

Percorso: Contabilità - Gestioni

Consente la stampa della lista dei prefissi e numeratori delle fatture emesse e ricevute.


STAMPA CODICI IVA

Percorso: Archivi Comuni - Tabelle contabilità

Esegue una stampa dei codici iva ordinati per codice o per descrizione.


STAMPA BANCHE

Percorso: Archivi Comuni - Tabelle contabilità

Stampa un elenco delle banche in archivio ordinate per codice o per descrizione o per codice abi.


STAMPA TIPI DI PAGAMENTO

Percorso: Archivi Comuni - Tabelle contabilità - Stampe

Esegue una stampa dei tipi di pagamento in archivio ordinati per codice o per descrizione.


STAMPA CONDIZIONI DI PAGAMENTO

Percorso: Archivi Comuni - Tabelle contabilità

La funzione consente la stampa delle condizioni di pagamento ordinate per codice o per descrizione.


STAMPA CLASSI E ATTRIBUTI CLIENTI E FORNITORI

Percorso: Archivi Comuni - Tabelle contabilità

Consente la stampa dell'elenco degli attributi previsti per ogni classe in cui si possono raggruppare i clienti e fornitori.


STAMPA CAMBI

Percorso: Archivi Comuni - Tabelle contabilità

Esegue la stampa di tutti i cambi inseriti ordinati per moneta o per data.


STAMPA TABELLA STATI

Percorso: Archivi Comuni - Tabelle contabilità - Stampe

Stampa un elenco degli stati in archivio ordinati per codice o per descrizione.


TABELLE DI MAGAZZINO

I programmi presenti in questo menu consentono di inserire tutti i dati ai quali si farà poi riferimento nella creazione degli articoli. Gran parte di questi dati rimarranno stabili nel tempo.

Nei programmi, ogni volta che viene chiesto un codice di una tabella di riferimento (es. gruppo, unità di misura), è possibile, tramite un pulsante posto sulla lista di aiuto, accedere alla funzione che consente di creare il codice se questo non esiste.

Magazzini
Listini
Unità di misura
Classi e attributi
Gruppi e sottogruppi
Reparti
Categorie Fiscali
Tabella arrotondamenti
Livelli (per taglia-colore)
Composizione livelli


MAGAZZINI

Percorso: Archivi Comuni - Tabelle magazzino

La tabella contiene l'elenco dei magazzini o depositi utilizzati dalla procedura. I magazzini possono essere fisici (Magazzino Centrale, Deposito di Roma etc.) o logici (Conto Visione).

Nel caso di magazzino fisico si può inserire l'indirizzo che potrà essere utilizzato nei documenti di spostamento merce da un magazzino all'altro.

E' possibile stampare la tabella premendo il pulsante Stampa.


LISTINI

Percorso: Archivi Comuni - Tabelle magazzino

In questa tabella dovranno essere inseriti i codici e le descrizioni dei vari listini da utilizzare per la vendita e l'acquisto degli articoli di magazzino.

Nel caso si utilizzi un solo listino, ne dovrà essere creato obbligatoriamente uno dichiarato in tabella di magazzino come principale.

Con la funzione Listini articolo, sarà poi possibile associare ad ogni articolo, un prezzo diverso per ogni listino.

In fase di inserimento di un cliente/fornitore viene chiesto il codice listino per poter poi associare, in automatico, al momento dell'emissione dell' ordine, bolla, ddt o fattura il prezzo di vendita.

Moneta
E' il codice della valuta di quel listino. Nel campo viene preimpostato il codice della moneta principale scritta tra i parametri generali della ditta.

Nei documenti di Vendita la moneta viene sempre prelevata dal listino.

Sconto listino e modalità di attivazione
Se valorizzato, lo sconto verrà applicato in aggiunta o in sostituzione allo sconto prodotto a seconda di come è compilato il campo 'modalità di attivazione'.

Se non è valorizzato non è valido nemmeno il flag che indica le modalità di attivazione.

In fase di inserimento dei listini prodotto, è possibile confermare questo sconto o impostarne un altro, che sostituirà questo localmente.

Ivato
Indica se il prezzo inserito nel listino è comprensivo di iva. Viene impostato a No e ha senso solo se si tratta di listino in lire (o in euro).

Vendita-Acquisto
Indica se il listino verrà utilizzato per la vendita o per l'acquisto. Consente di poter visualizzare e stampare i prezzi netti e ivati (nei listini) prendendo dall'articolo il codice iva di vendita o di acquisto.


UNITA' DI MISURA

Percorso: Archivi Comuni - Tabelle magazzino

Nella tabella devono essere inserite tutte le unità di misura utilizzate per la vendita e l'acquisto degli articoli di magazzino.


CLASSI / ATTRIBUTI ARTICOLI

Percorso: Archivi Comuni - Tabelle magazzino

La tabella classi consente di gestire diverse classificazioni (raggruppi) di articoli. Sono disponibili fino a cinque classi diverse. Esempio: La classe 1 può indicare la Marca (HP, IBM), la classe 2 il tipo di articolo (Stampanti, Monitor).

Ad ogni classe potranno essere associati più attributi (nell'esempio HP e IBM sono gli attributi della classe 1 (Marca).

In ogni articolo di magazzino in corrispondenza alle classi attivate, potrà essere scritto il relativo attributo.


GRUPPI, SOTTOGRUPPI ARTICOLI

Percorso: Archivi Comuni - Tabelle magazzino

Tabella contenente codici e descrizioni dei gruppi nei quali si possono suddividere gli articoli in stampa. E' possibile inoltre attivare una tabella sconti per Categoria Clienti-Fornitori / Gruppo Articoli.

Ad ogni gruppo è possibile associare uno o più sottogruppi utilizzando il pulsante [image] (E) Gestione sottogruppi.

Prima di procedere alla creazione dei sottogruppi di un determinato gruppo, occorre salvare il gruppo stesso.

Ad ogni articolo di magazzino sarà possibile associare un codice gruppo ed, eventualmente, un sottogruppo.


REPARTI

Percorso: Archivi Comuni - Tabelle magazzino

Tabella contenente l'elenco dei reparti attivi sul registratore di cassa (se si utilizza la funzione di emissione scontrino) o comunque da collegare agli articoli.

Se è attivato il collegamento con il registratore di cassa, è obbligatorio inserire sugli articoli il codice reparto e in ogni reparto deve essere impostato obbligatoriamente il codice iva, inoltre tra i parametri generali Ditta, nella Tabella per Registratore di Cassa, va riportato il numero di reparti attivi sul registratore.

In programma accetterà, nel campo codice reparto, un numero minore o uguale al numero di reparti dichiarati in tabella.

Conto ricavi
E' il conto utilizzato per la contabilizzazione del ricavo da vendita con il registratore di cassa se diverso da quello impostato nella tabella dei parametri per il collegamento al registratore di cassa.


CATEGORIE FISCALI

Percorso: Archivi Comuni - Tabelle magazzino

Consente la suddivisione degli articoli di magazzino per categoria fiscale in fase di inventario (Es. 01-Minuteria).

E' possibile stampare la tabella premendo il pulsante Stampa.


TABELLE per ARROTONDAMENTI IN LIRE e IN EURO

TABELLE per ARROTONDAMENTI IN EURO (e LIRE)

Percorso: Archivi Comuni - Tabelle magazzino

Questa tabella viene utilizzata dal programma di creazione/variazione listini, se l'operatore sceglie di arrotondare il listino di destinazione.
Se si lascia vuota, e nel programma suddetto NON si sceglie di arrotondare, il programma arrotonda comunque ai decimali della moneta (per l'euro, a 2 decimali).

Possono essere inseriti un numero di intervalli a piacere e, per ogni intervallo, viene chiesto di digitare:
- il limite superiore (fino A)
- il valore dell'arrotondamento (0,01, 0,1, etc)
- come arrotondare gli importi:

  • A=arrotondamento standard
  • S=superiore (per eccesso)
  • T=troncamento (per difetto)

I parametri impostati nell'ultimo intervallo valgono anche per gli importi superiori al fino A di questo intervallo.


LIVELLI (TAGLIA/COLORE)

Percorso: Archivi Comuni - Tabelle magazzino (Livelli e Composizione livelli)

Questa funzione, se nei parametri generali di magazzino è stata scelta la gestione di 'Taglia/Colore', consente di inserire codice e descrizione di tutte le entità per cui si vogliono tenere separate le giacenze degli articoli.
(Esempio: I, II, III, Rosso, Blu, Verde, 42, 44, 46,S,M,L,XL, etc.)

Una volta inserito l'elenco dei livelli si deve dire come vanno raggruppati utilizzando la funzione: Composizione livelli

In fase di inserimento nei movimenti di magazzino e nei documenti (ordini, ddt e fatture) di articoli con livelli, una volta inserito il codice articolo sarà possibile inserire il dettaglio dei livelli secondo le modalità specificate in Gestione livelli.

Nuova maschera di Gestione Livelli a Tabella (parametro GestTab)

Codice Barre
Questo campo, se inserito, consente di creare un codice a barre composto dal codice a barre dell'articolo seguito da un gruppo di N caratteri per individuare il primo livello ed eventualmente, da uno di M caratteri per individuare il secondo (Es. 2 cifre per la Taglia e 3 per il Colore).
In questo modo un articolo di una determinata taglia e colore viene individuato in modo univoco.

Il campo è alfanumerico ed è importante che sia diverso all'interno dei gruppi di livelli omogenei.
Cioè: I,II,II, IV avranno una sequenza di numeri, blu, rosso, verde un'altra sequenza etc.

Vedi Ricerca per codice a barre di articoli con livelli


COMPOSIZIONE LIVELLI

Percorso: Archivi Comuni - Tabelle magazzino

La funzione riguarda la gestione dell'opzione 'Taglia/Colore' sugli articoli.

Una volta inseriti i 'Livelli' con l'apposita gestione (cioè le codice e descrizione delle singole taglie e colori che si intendono gestire), con questa funzione si inseriscono codice e descrizione dei GRUPPI DI LIVELLI e (es. Taglie USA, Taglie intimo, Colori maglieria etc.) poi, con il pulsante [image] (E) Gestione composizione livelli, si associano ad ogni raggruppo i livelli desiderati.

(ES. al Raggruppo Taglie Intimo si associano i livelli I, II, III , a quello Taglie Italia: 42,44,46 …)

Se si cerca di associare un codice livello che non esiste nella tabella livelli, si consente di inserire anche la descrizione e viene creato automaticamente.

In ogni articolo per il quale si dovranno gestire i livelli, nella maschera (Altro) verranno chiesti: Gruppo Liv.1 e Gruppo Liv. 2
Per gli articoli nei quali vanno gestiti a taglia e colore, in questi campi andranno riportati rispettivamente i codici del gruppo 'Taglia' e del gruppo 'Colore' definiti nella funzione: Composizione livelli.
E' inoltre possibile stabilire, per ogni articolo con 'livelli', se il prezzo di listino e i costi si riferiscono all'articolo in generale, al primo livello o in dettaglio a entrambi i livelli.

In fase di inserimento nei movimenti di magazzino e nei documenti (ordini, ddt e fatture) di articoli con livelli, una volta inserito il codice articolo sarà possibile inserire il dettaglio dei livelli secondo le modalità specificate in Gestione livelli.

Esempio: attivando nell'articolo i codici Gruppi Livelli che individuano Taglie Intimo e Colori, in fase di carico e scarico di quell'articolo verranno chieste e memorizzate, quantità separate per le combinazioni di Taglie intimo e colori (I Bianca, II Bianca, I Rossa etc.) secondo quanto definito in Composizione Livelli.


TABELLE DECODIFICHE VARIE

Percorso: Archivi Comuni - Tabelle magazzino

Questa funzione consente di inserire e variare alcune tabelle semplici costituite da Codice e Descrizione, che verranno utilizzate per caratterizzare l'anagrafica lotti (tracciabilità).

Ogni tabella è identificata da un Tipo Tabella, una volta inserito il Tipo, si entra nella Gestione di quella tabella specifica.

I Tipi tabelle gestiti sono i seguenti:
Categoria Lotti
Specie Lotti
Trattamento Lotti
Confezione Lotti


CAUSALI DI MAGAZZINO

Percorso: Magazzino - Gestioni

Sono i codici che consentono la registrazione dei movimenti di magazzino e quindi determinano l'aggiornamento delle quantità di carico e scarico (e quantità aggiuntive) e i rispettivi valori.

Esempio: carico, scarico, caricamento giacenza iniziale, movimento interno tra magazzini/depositi, resi etc.

In inventario e giornale
Indica se il movimento che verrà generato dovrà essere considerato per il calcolo della giacenza dell'articolo nella stampa inventario e se dovrà essere stampato sul giornale di magazzino.

In generale questo campo va spuntato in quanto ogni movimento deve incidere sulla giacenza dell'articolo.

Tipo Movimento:
Questo campo assume fondamentale importanza in quanto in base al suo valore vengono abilitati o meno i campi successivi e indica i vari tipi di movimenti che si possono fare sugli articoli.

  • Normale
    Si intende un movimento che non sia Interno, di Carico Inventario, di Trasformazione, Ordine. In questo caso viene abilitata la gestione di tutti i campi successivi ad eccezione della causale di trasformazione.
  • Interno
    Un movimento interno consente di fare uno spostamento di articoli tra due magazzini.
  • Carico Inventario
    Un movimento di questo tipo consente di caricare l'inventario manualmente. I movimenti di carico inventario non verranno memorizzati e per correggerli basta inserire un altro movimento, con la quantità giusta, che andrà a sostituire i dati iniziali precedenti.

    Il movimento può aggiornare i costi (medio di carico, costo ultimo, medio ponderale) andando in sostituzione di un eventuale valore preesistente; questo per fare in modo che i costi siano valorizzati anche se nell'anno non sono stati fatti acquisti.
    NOTA:
    Si consente di creare un'unica causale di caricamento inventario (con nessun aggiornamento delle quantità aggiuntive).
    Se si abilita sulla causale la gestione di una delle tre quantità aggiuntive allora viene aggiornata quella quantità e non la giacenza iniziale dell'articolo (in questo caso viene messo automaticamente a Nullo il flag di carico/scarico).
    Occorrerà, in questo caso, creare un'altra causale per caricare la giacenza iniziale degli articoli.

  • Trasformazione
    Una causale di questo tipo consente la trasformazione di un articolo in un altro.
    Può essere utilizzata anche per spostare completamente la giacenza di un articolo su un altro.
    In una causale di trasformazione è indispensabile compilare il campo: "causale collegata per trasformazione"
  • Ordine
  • Ordine Interno
    Servono per inserire ordini di acquisto o vendita e ordini interni.
    Non si accettano in caricamento movimenti di magazzino causali di questo tipo.

Carico-Scarico-Niente
Si dovrà impostare carico o scarico a seconda che debbano essere incrementati i progressivi di carico o scarico dell'articolo. Nelle causali di tipo 'caricamento inventario' e in quelle Interne verrà impostato Carico in modo fisso.

Se Interno - si intenderà uno scarico dal primo magazzino e un carico sul secondo.

Se Ordine - Nel caso non si voglia incrementare l'ordinato, inserendo comunque un ordine di acquisto o di vendita, occorre che questo campo sia impostato a 'Niente' poi nel tipo documento si associa questa Causale di magazzino.

Se Nullo non verrà aggiornata nessuna quantità Carico Scarico ma solo la quantità personalizzata specificata nella causale. Il Nullo qui si accetta solo se viene scelto l'aggiornamento di una quantità personalizzata altrimenti si segnala l'errore in fase di caricamento causali e inoltre una causale con nullo deve avere obbligatoriamente No Giornale.

Segno
Indica se il movimento è positivo o negativo.
Un movimento di Reso da Cliente potrà così essere definito come Scarico Negativo (e andrà a decrementare la quantità scarico) oppure come Carico Positivo.

Acquisti-Vendite-Nullo
Indica se il movimento deve incrementare i progressivi di acquisto o vendita (oltre a quelli di carico e scarico). Questo per tenere separato quanto viene realmente acquistato e venduto da quanto viene spostato da un magazzino all'altro.

I progressivi così incrementati serviranno a calcolare il medio di acquisto.

Importo Unitario
E' l'importo da proporre in caricamento movimenti (o nei documenti) come valore unitario

  • Listino o Niente
    si prende il prezzo di listino, se è stato impostato un listino, o si lascia vuoto.
  • Costo Ultimo
    se si sta inserendo un movimento di un fornitore ed è prevista la gestione degli articoli-fornitore si prende il costo ultimo del fornitore in oggetto, altrimenti si prende quello dell'articolo dall'archivio costi dell'anno.
  • Costo Medio Ponderale

Provenienza e Destinazione

Indicano rispettivamente 'da dove viene' e 'dove va' la quantità dell'articolo movimentato.
Verranno utilizzati in fase di caricamento movimenti di magazzino per chiedere all'operatore un cliente (o un fornitore) e un magazzino, oppure due magazzini.

Un movimento può non avere niente in provenienza e avere un magazzino in destinazione (carico inventario) così come può avere un magazzino in provenienza e niente in destinazione (uno scarico a rottamazione).

Questo consente di fare dei movimenti senza obbligare ad inserire sempre il codice di un cliente o di un fornitore, obbligando però ad inserirlo quando da tipo movimento sia stato specificato.

Esempi di codifica corretta causali:

 |  | Provenienza | Destinazione
Carico da fornit. | Carico + | Fornitore | Magazzino
Reso a fornitore | Carico - | Fornitore | Magazzino
OPPURE | Scarico + | Fornitore | Magazzino
Vendita | Scarico + | Magazzino | Cliente
Reso da Cliente | Scarico - | Magazzino | Cliente
OPPURE | Carico + | Magazzino | Cliente
Mov.Interno tra Magazzini | Carico +- | Magazzino | Magazzino

Valorizzazione Scarico
Campo valido solo sui movimenti di scarico.

Se attivato, consente di memorizzare in ogni movimento di scarico, il costo dell'articolo al momento in cui avviene la vendita. Il costo memorizzato potrà essere il Medio di Carico, il Costo Ultimo o il Medio Ponderale. Verrà inoltre incrementato un progressivo annuale sull'articolo con il valore ottenuto moltiplicando la quantità del movimento per il costo richiesto. Questo valore potrà essere utilizzato per consultazione.

Aggiornamento Costo Medio di Carico
Campo valido solo sui movimenti di acquisto.
Se attivato verranno incrementati, in corrispondenza al movimento, Quantità e Valore Carico, progressivi con i quali verrà calcolato il Medio di Carico: Valore Carico/Quantità Carico.
Non è detto che tutti i carichi debbano necessariamente aggiornare questo valore. Es. se carico un omaggio varia la giacenza ma si può non abbattere il Medio di Carico essendo variata la quantità di carico e non il valore.

Aggiornamento Costo Medio Ponderale
Campo valido solo sui movimenti di acquisto.
Indica se aggiornare, in corrispondenza a un movimento di carico, il Medio Ponderale.
L'aggiornamento di questo valore è molto delicato in quanto il nuovo importo viene calcolato come segue:
(CMP * Giacenza + Valore Movimento) / Nuova Giacenza.
Se la Nuova Giacenza è minore o uguale a 0 o è >0 ma il nuovo CMP <=0 allora si pone CMP uguale all'ultimo costo.

Poiché il valore calcolato dipende dalla giacenza, è indispensabile che venga aggiornato al momento del carico, cioè se si inserisce una bolla di carico senza il prezzo poi la si completa in un secondo momento il valore non viene aggiornato correttamente così come se si varia un movimento preesistente.

Per rimediare a questo inconveniente è stato creata una funzione che ricalcola questo costo rileggendo in sequenza tutti i movimenti.

Aggiornamento Ultimo Costo
Campo valido solo sui movimenti di acquisto.
Indica se aggiornare o meno il costo ultimo dell'articolo. Anche se attivato verrà aggiornato solo se il movimento ha una data superiore alla data del costo ultimo già in archivio.

Ripartizione Spese
Per le causali di carico merce (acquisto) che prevedono l'aggiornamento del Costo Ultimo è possibile definire la modalità di ripartizione, sul costo dei vari articoli, delle eventuali spese (es. di trasporto) sostenute al momento dell'acquisto:

  • Sulla quantità
  • Sul Valore

Se, al momento del carico della merce con l'evasione di un ordine di acquisto o con l'inserimento manuale di un movimento di magazzino, viene inserito un importo (o una percentuale) di Spesa, tale importo verrà ripartito sui costi dei vari articoli per calcolare il costo ultimo, con le modalità indicate in questo campo.
Nel campo Importo spese, proposto al momento del caricamento della merce, è possibile inserire, in alternativa all'importo, direttamente la percentuale di incidenza delle spese (In questo caso ha senso che venga applicata unicamente sul Valore e non sulla Quantità).
E' possibile creare il parametro di personalizzazione RipartSpesePercVal per dichiarare se nel campo Spese verrà inserito prevalentemente un importo o una percentuale. Se si inserisce un numero negativo, verrà inteso come % se si è dichiarato di usare prevalentemente un importo e viceversa.

Causale collegata per Trasformazione
Il campo è attivo solo nei movimenti di trasformazione.
E' la causale da utilizzare per generare il movimento collegato e deve essere di Tipo Normale.
L'indicatore di Carico/Scarico, la Provenienza e la Destinazione della causale collegata, devono essere compatibili con quelli della principale e cioè se la principale è Carico (Provenienza Nulla e Destinazione Magazzino), la collegata dovrà essere Scarico (Provenienza Magazzino Destinazione Nulla)

Causale collegata per Distinta Base
Serve per generare il movimento/i movimenti di distinta Base (vedi Distinta Base)

Magazzino componenti
In corrispondenza della causale che servirà per fare lo scarico dei componenti, si può indicare il codice del magazzino da cui scaricare.
Se questo campo viene lasciato bianco i componenti verranno scaricati dal magazzino del movimento del prodotto finito.

Quale altra quantità aggiuntiva aggiorno
In tabella di magazzino si consente di mettere la descrizione di 3 campi quantità aggiuntivi da gestire come totalizzatori (solo visualizzati, non vengono considerati nei calcoli di giacenza né disponibilità)

Qui è possibile dire se la causale aggiorna o meno uno di questi campi.
L'aggiornamento verrà fatto a incremento o decremento della quantità del campo a seconda di come è fatta la causale e cioè:
Se carico + incrementa
Carico - decrementa
Scarico + decremento
Scarico - incremento
Null: se provenienza = null: incremento se +, decremento se -, altrimenti il contrario

Esempi:

Acquisto | Carico + | Fornitore | Magazzino | Incrementa
Reso a Fornitore | Carico - | Fornitore | Magazzino | Decrementa
 | Scarico + | Fornitore | Magazzino | Decrementa
Vendita | Scarico + | Magazzino | Cliente | Decrementa
Reso da cliente | Scarico - | Magazzino | Cliente | Incrementa
 | Carico + | Magazzino | Cliente | Incrementa

Se in una causale di tipo 'carico inventario', si prevede di aggiornare una quantità aggiuntiva, non verrà movimenta le quantità standard.

Potrà essere utilizzato per avere traccia di quantità uscite (o entrate) in magazzino ma per motivi particolari senza spostarle in un altro magazzino (logico o fisico)
Esempio: tenere la somma degli usciti in c/demo, in uso interno.

CONTROLLI:
In visualizzazione di un codice esistente, il programma controlla se è utilizzato in movimenti, collegato ad un'altra causale o a tipi documenti di vendite o acquisti; in caso positivo visualizza un messaggio.

Viene consentita ugualmente la variazione ma è a cura dell'utente valutarne le conseguenze. Non viene invece consentito l'annullamento.

Alla conferma di una causale vengono eseguiti controlli di correttezza dell'impostazione dei parametri e in caso non risultino corretti vengono dati opportuni messaggi.


STAMPA CAUSALI DI MAGAZZINO

Percorso: Magazzino - Gestioni - Stampe

Esegue la stampa delle causali di magazzino esistenti in archivio.


STAMPA GRUPPI E SOTTOGRUPPI ARTICOLI

Percorso: Archivi Comuni - Tabelle magazzino

Stampa elenco dei gruppi e sottogruppi inseriti.


STAMPA CLASSI E ATTRIBUTI ARTICOLI

Percorso: Archivi Comuni - Tabelle magazzino - Stampe

Esegue la stampa delle classi articoli e per ogni classe riporta l'elenco degli attributi creati.


STAMPA REPARTI

Percorso: Archivi Comuni - Tabelle magazzino

Stampa elenco dei reparti inseriti


STAMPA TABELLA LISTINI

Percorso: Archivi Comuni - Tabelle magazzino

Esegue una stampa dei listini inseriti ordinati per codice o per descrizione.


STAMPA LIVELLI

Percorso: Archivi Comuni - Tabelle magazzino

Esegue la stampa di livelli e gruppi livelli.


TABELLE VENDITE

I programmi presenti in questo menu consentono di inserire tutti i dati ai quali si farà poi riferimento nell'inserimento dei documenti di vendita. La maggior parte di tali dati (es. tipi di resa, aspetto dei beni, vettori) rimarranno poi stabili nel tempo.

La tabella più importante in assoluto è quella dei Tipi documento in quanto contiene i codici e le caratteristiche dei documenti che si andranno ad emettere.

Nei programmi, ogni volta che viene chiesto un codice di una tabella di riferimento (es. vettore), è possibile, tramite un pulsante posto sulla lista di aiuto, accedere alla funzione che consente di creare il codice se questo non esiste.


SPESE

Percorso: Archivi Comuni - Tabelle vendite

La tabella contiene l'elenco dei codici spesa utilizzabili nei documenti con le caratteristiche di applicazione e i parametri per lo scarico contabile.

Un'attenzione particolare è da riservare a due tipi di spesa:

  • Spese bancarie ('a importo per rata' con 'evasione singola') che verranno caricate in automatico sulle fatture, per l'addebito al cliente, solo se:
  • sul cliente è stata spuntata la casella che dice di addebitare le spese bancarie
  • sulla condizione di pagamento (ricevuta bancaria) è stato impostato il codice che, in questa tabella, individua le spese bancarie.
  • Spese per bolli tratte (obbligatorio definire il 'Tipo addebito' in Percentuale per rata, il 'Tipo evasione' Singola, 'Addebito Iva' Ripartita). Verrà impostato in automatico a No sia l'assoggettamento a sconto pagamento sia a ritenuta d'acconto.
    La spesa verrà caricata in automatico sulla fattura solo se:
  • sul cliente è stata spuntata la casella che dice di addebitare i bolli
  • sul Tipo di pagamento (Tratta) il flag Addebito bolli è a Si
  • sulla condizione di pagamento (Tratta) è stato impostato il codice che, in questa tabella, individua le spese per tratte.

Codice e descrizione

Codice Iva
E' il codice iva dal quale prendere l'aliquota iva alla quale assoggettare la spesa in fattura.

Codice Moneta
E' la moneta in cui è espresso l'importo della spesa. Dovrà essere impostata SOLO se la spesa dovrà essere utilizzata per documenti in moneta diversa da Euro.

In fase di inserimento documenti (ordini, ddt, fatture) verrà consentito di richiamare dal documento solo spese con moneta compatibile con quella del documento.

Conto per la registrazione contabile
E' il codice del conto per la registrazione contabile della riga di spesa.

Addebito Iva

  • Ripartita
  • Propria

Tipo evasione
Indica il modo di riportare le spese da ordine a bolla a fattura.

  • Singola
    nel documento di evasione se si evade più volte la stessa spesa, si considera sempre solo la prima.
  • Multipla
    il documento di evasione riporterà la stessa spesa più volte.
  • Somma
    il documento di evasione riporterà la spesa una volta sola con la somma degli importi

Tipo addebito

  • a importo
  • a importo per rata
  • in percentuale
  • in percentuale per rata
  • a importo per unità di peso
    La spesa finale addebitata sul documento verrà calcolata moltiplicando l'importo della 'spesa' per il peso riportato nel campo Peso dei dati di Accompagnamento (Il calcolo viene fatto sui Ddt e sulle Fatture accompagnatorie e dirette/riepilogative)
    Una spesa di questo tipo dovrà avere il 'Tipo evasione' posto a 'Singola'

Percentuale, Importo minimo e massimo
Se il tipo addebito è in percentuale, si chiede di compilare la percentuale per il calcolo della spesa ed eventualmente un importo minimo da addebitare se la percentuale calcolata sul totale merce porta a una spesa troppo piccola e un importo massimo da utilizzare nel caso il calcolo porti ad un importo di spesa troppo alto.
Per indicare che la % delle spese per tratte è il 12 x mille, si imposterà: 1,2

Importo:
Se il tipo addebito è a importo o a importo per rata, si chiede di compilare l'importo. Questo è espresso in lire e in euro. Se la moneta della spesa è diversa da lire ed euro, l' importo in lire non va compilato.

Valore a cui arrotondare:
Campo attivo solo se la spesa è stata definita: 'in percentuale per rata'
Il campo deve necessariamente essere valorizzato se la spesa è quella da addebitare per le Tratte, in quanto queste vanno arrotondate al decimo di euro; pertanto il valore da impostare nel campo è 0,10.

Identificativo per stampa
E' un carattere da impostare se si desidera stampare quella spesa in una determinata posizione del modulo e non nel corpo alla fine dei dettagli. In fase di definizione del modulo di stampa si dovrà far riferimento ad ogni spesa da stampare separata come T_Spesa_X dove X è il carattere inserito in questo campo.
Es. in spese bancarie si può mettere B, in spese trasporto T etc.
Nella spesa eventualmente definita per addebitare i bolli delle Tratte, questo campo può essere lasciato bianco in quanto l'importo corrispondente verrà stampato in Totale Bolli.

Soggetto sconto pagamento S/N
Indica se la spesa è soggetta a sconto pagamento o meno.
Sulla spesa creata per Cassa previdenza NON va barrato questo campo.

Standard
Se impostato a Si la spesa verrà portata automaticamente sul documento nel quadro spese. Non vengono considerate nelle note di credito.

Soggetta ritenuta d'acconto S/N
Indica se la spesa è soggetta o meno alla ritenuta d'acconto e cioè se il suo importo concorre al calcolo dell'imponibile su cui calcolare la Ritenuta nel caso la fattura sia soggetta a ritenuta.

Spesa per Cassa Previdenza S/N
E' possibile creare un codice spesa per addebitare la Cassa Previdenza in fattura.
La Spesa può essere definita o in Percentuale o a Importo e deve avere Tipo evasione: Singola
La percentuale impostata deve essere quella corretta per la Cassa Previdenza.
Se si mette a importo (può servire nel caso in cui l'importo da mettere in fattura sia diverso da quello calcolato in percentuale sull'imponibile sul quale viene calcolata la ritenuta d'acconto) occorre comunque compilare, oltre al campo importo, anche il campo Percentuale.
L'importo della Cassa previdenza viene sottratta dall'imponibile della fattura. E' possibile creare il parametro di personalizzazione CassaPrevNoImpon (Gruppo: Tutti) impostato a S per non sommare l'importo all'imponibile ma sottrarlo dall'importo a pagare

Il codice di questa spesa va poi inserito in tabella comune (Causali comuni)
Tale spesa verrà caricata automaticamente tra le spese, dai programmi di Gestione documenti (preventivi, ordini, ddt, fatture) in corrispondenza a clienti con il flag di Soggetto a Cassa previdenza a Si.

Se si imposta il parametro di personalizzazione SpesaClieAutom a S , i programmi di inserimento documenti (ordini, ddt, fatture) caricheranno in automatico la spesa eventualmente inserita nell'anagrafica del cliente. In alternativa, tale spesa, può essere caricata manualmente, premendo il pulsante: (E) sp(E)se cliente nel quadro Spese del documento.
Su questa spesa NON verrà mai applicato lo sconto pagamento.

Tessera Sanitaria- Tipo Spesa
Questo campo serve per definire, in fase di estrazione delle Fatture per preparare il file XML da inviare per il Progetto Tessera Sanitaria, il tipo di prestazione erogata in corrispondenza a questa spesa.
I valori da assegnare al campo sono quelli definiti nelle specifiche del Progetto Tessera Sanitaria
E' possibile impostare questo campo anche con il valore: NON Estrarre . In questo modo, la spesa in oggetto NON verrà mai estratta anche se presente in fattura.

Si può compilare il campo necessario per scaricare, sul file XML delle fatture, informazioni aggiuntive secondo il tracciato Standard Assosoftware, al fine di rendere più leggibili le fatture da parte di chi le riceve: Codifica AssoSoftware Tipo Spesa
Gli importi delle spese potranno essere contabilizzati sul conto corretto, letto dalla tabella spese, SOLO se, sia sul file xml della fattura, sia nella tabella Spese del database in uso, è stato compilato questo campo.


AGENTI

Percorso: Archivi Comuni - Tabelle vendite

La tabella contiene tutte le anagrafiche degli agenti e le rispettive percentuali di provvigioni.

Vedi Gestione Provvigioni.

Percentuale o importo provvigione
Indica la percentuale o l'importo unitario di provvigione, a seconda di com'è impostato il Tipo di calcolo, da applicare in sede di fatturazione se nell'anagrafica clienti il campo "estrazione % provvigioni" è : da agente.

Codice sub agente
E' il codice dell'eventuale sub agente collegato all'agente. In questo modo si può creare una sequenza di agenti a partire da uno principale.

Tipo di Calcolo
Indica i vari modi in cui possono essere calcolate le provvigioni.

  • Sul prezzo al Netto o al Lordo degli sconti
  • Importo per quantità di riga (l'importo va messo in perc. o importo provvigione)
  • Percentuale sul totale merce
  • Importo per Totale peso (l'importo va messo in perc. o importo provvigione)

Tipo Liquidazione

Indica se la liquidazione delle provvigioni andrà fatta sul

  • Fatturato
  • Incassato
    In questo caso è obbligatorio gestire le scadenze ed è indispensabile che le provvigioni e le scadenze abbiano la stessa moneta

Valuta S/N

L' indicazione di gestione o meno della valuta comporta la possibilità di gestire la valuta estera sul conto dell'agente cioè sui suoi movimenti di provvigione.


VETTORI

Percorso: Archivi Comuni - Tabelle vendite

La codifica dei vettori consente di associare ad ogni cliente l'eventuale spedizioniere con il quale vuole ricevere la merce e di richiamarlo poi automaticamente in fase di emissione di Bolla, di Documento di Trasporto o Fattura Accompagnatoria per poi stamparlo sul documento.

Per la stampa sui documenti dei dati del vettore, si rimanda al capitolo: Ddt (campi per filtri di stampa)

La stampa si ottiene premendo il tasto corrispondente.


TIPI DI TRASPORTI

Percorso: Archivi Comuni - Tabelle vendite

In questa tabella devono essere inserite le varie modalità utilizzate nella spedizione delle merci. Potranno essere richiamate durante il caricamento degli ordini, ddt, fatture accompagnatorie per stabilire a cura di chi viene fatto il trasporto della merce: mittente , destinatario, posta, corriere ….

La stampa si ottiene premendo il pulsante Stampa.


RESE

Percorso: Archivi Comuni - Tabelle vendite

In questa tabella possono essere memorizzati i tipi di resa della merce (porto franco, porto assegnato).

La stampa si ottiene premendo il pulsante Stampa.


ASPETTO DEI BENI

Percorso: Archivi Comuni - Tabelle vendite

Tabella contenente codice e descrizione dell'aspetto della merce consegnata per la spedizione (es. scatola, pacco, sfuso). Verrà utilizzata nei dati di accompagnamento di DdT e Fatture Accompagnatoria.


CAUSALI TRASPORTO

Percorso: Archivi Comuni - Tabelle vendite

Tabella contenente codice e descrizione dei 'motivi' per cui viene spedita la merce (es. vendita, c/demo, reso da riparazione). Verrà utilizzata nei dati di accompagnamento di DdT e Fattura Accompagnatoria.


TIPI DOCUMENTO

Percorso: Archivi Comuni - Tabelle vendite

La tabella contiene il codice, la descrizione e le caratteristiche dei documenti che si vogliono emettere dalla procedura di Vendite: Ordini, Documenti di Trasporto, Fatture.

La descrizione verrà stampata sul documento. Dovranno cioè essere definiti tipi documento diversi per documenti di trasporto di merci in vendita, c/visione etc., per fatture dirette, accompagnatorie, note di credito, ordini.

E' indispensabile compilare bene il tipo documento in quanto contiene i parametri che definiscono il documento stesso. In particolare occorre fare attenzione al collegamento con i numeratori, le causali di magazzino e di contabilità.

A seconda del Tipo Documento inserito (cioè se Ordine, Ddt etc.) verranno abilitati o meno alcuni campi.

Nota: Per l'emissione di fattura elettronica alla pubblica amministrazione è obbligatorio creare un Tipo documento apposito collegato a un prefisso (numeratore per registro iva) diverso dalle altre fatture.
Dal 1 gennaio 2015 questo tipo di fatture NON verranno più emesse con 'iva ad esigibilità differita' ma con il meccanismo dello 'Split payment'.
per il campo 'Causale Co.GE.' dovrà essere compilato con un codice causale nel quale sia stato spuntato il campo 'Iva Split payment'

Descrizione
E' la descrizione del documento.

Tipo
Indica come e dove verrà utilizzato il tipo documento in oggetto: cioè se si tratta di un Preventivo, Ordine, Bolla/Ddt, Fattura, Fattura Dettaglianti.

Interno
Per documento interno si intende ad esempio un Documento di trasporto per spostamento merci da un magazzino ad un altro della stessa ditta. In un documento interno la causale di magazzino collegata dovrà essere obbligatoriamente di tipo interno.

Segno +
Per bolle di reso da riepilogare in Note di Credito o Note di Credito il segno dovrà essere negativo per cui va sbiancato il campo corrispondente.

Fattura Accompagnatoria
Se si tratta di fattura accompagnatoria occorre barrare la casella. In questo modo all'emissione fattura verranno chiesti i dati di accompagnamento.

A Fornitore
Questo campo è gestito solo nel caso di Tipo Ddt. Se impostato a SI indica che dovrà essere chiesto in inserimento documento il codice di un fornitore al posto del cliente. Dovrà servire per il reso di merce a un fornitore. La numerazione e il modulo sono quelli dei documenti di trasporto di vendita (solo nei tipi documento Ddt).

Aperto
Campo abilitato solo nei tipi documento Ordini di acquisto e di vendita.
Serve ad assegnare un valore iniziale al campo 'aperto' che è sulla testata dell'ordine e che indica se l'ordine è da considerare sempre aperto anche una volta evaso (in pratica sugli ordini aperti non verrà mai messo il segnale di evasione né parziale né totale anche se verranno evasi)

Regime del Margine
Questo flag (abilitato per preventivi, ordini, ddt e fattura) consente di creare un tipo documento da utilizzare per la cessione di beni usati che poi verrà elaborato dalla procedura secondo la normativa del Regime del margine.
Se si imposta questo flag su fattura, diventa obbligatorio compilare la causale contabile e il prefisso che dovranno essere stati creati appositamente per la gestione del regime del margine.
Il documento corrispondente dovrà essere emessa in esenzione e con le note opportune.

Listino
Se per questo tipo di documenti si vuole utilizzare un listino particolare si può mettere qui altrimenti verrà applicato quello collegato al cliente.

Magazzino proposto
E' il magazzino dal quale esce la merce, che verrà proposto in automatico nel documento. Se lasciato bianco si prenderà il magazzino principale dalla tabella di magazzino.

Tabella Sconti prioritaria
Indica se, per l'applicazione degli sconti, è prioritaria la tabella sconti: Categoria/Articolo o quella Cliente/Gruppo Articoli

Stampa Prezzo in DDT, Ordini e Preventivi
Per ogni tipo documento Ddt e Ordine si chiede di specificare se e in che forma si vuol stampare il prezzo.

  • Non stampa i prezzi
  • Stampa prezzi di listino e sconti
  • Stampa prezzi di listino
  • Prezzi al netto degli sconti
  • Prezzi di listino, Sconti, Totale di riga ivato
  • Prezzi al netto dello sconto, ivati e Totale di riga ivato

Per quanto riguarda i Ddt, sul cliente viene ripetuta questa scelta e sarà possibile decidere cliente per cliente se e come stampare i prezzi oppure definirlo in modo generale in questo punto.

Per la stampa di Ordini e Preventivi invece, occorre impostare in questa fase, la modalità generale di stampa del prezzo.

In ogni caso, in testata di Ddt, Ordini e Preventivi verrà riproposta la scelta con possibilità di variazione.

Prefisso per Ddt
Indica quale numeratore utilizzare per numerare i ddt in stampa. Se valorizzato, deve essere uno di quelli già specificati in Tabella parametri di fatturazione.
E' possibile avere più numeratori (equivalenti a più bollettari) individuati ciascuno da un prefisso. L'elenco dei prefissi utilizzati deve essere specificato sulla tabella parametri di fatturazione, sulla stessa tabella è specificato anche il prefisso 'principale'.
Se questo campo viene lasciato bianco in emissione Ddt verrà preso il numeratore dal prefisso principale.

Causale per aggiornamento magazzino
E' la causale che specifica come aggiornare i progressivi di magazzino e con la quale verrà generato il movimento di magazzino e deve esistere sulla tabella delle causali di magazzino. Se lasciata bianca non verrà generato il movimento (Es. per bolla di reso a fornitore di merce non caricata perché in conto visione)
Se è installato il modulo della Distinta Base e si vuole fare lo scarico dei componenti al momento in cui si fa la vendita di un prodotto finito, occorre che la causale di scarico di magazzino inserita in questo campo
abbia il campo 'Causale collegata per DiBa' compilato con una causale che farà il carico del prodotto finito
che a sua volta abbia il campo 'Causale collegata per DiBa' compilato con una causale che farà lo scarico dei componenti
Nei Tipi documenti ORDINE - Se viene lasciato bianco il campo, verrà ugualmente incrementato l'ordinato. Nel caso non si voglia incrementare l'ordinato, occorre associale una causale di magazzino dove nel campo Carico/Scarico sia stata scelta l'opzione 'Niente'.

Causale per movimento di rientro in magazzino
Si chiede di digitare una causale per la generazione di un movimento di magazzino. L'inserimento di questo campo è abilitato solo sui documenti di tipo Ddt normali (non interni) e non evadibili (cioè con il campo 'documento di evasione' non compilato). Serve per generare un movimento di rientro alla chiusura ad esempio di un DdT di c/visione.

Causale per evasione dell'ordine/preventivo con corrispettivo
Si chiede di digitare una causale per la generazione di un movimento di magazzino. L'inserimento di questo campo è abilitato solo sui documenti di tipo Ordini normali (non interni) e Preventivi.
Serve per generare un movimento di magazzino in caso di evasione con corrispettivo. Per gli ordini con cliente manuale occorre che la causale di magazzino sia uno scarico da Magazzino a Niente, per gli altri dovrà invece essere uno scarico da magazzino a cliente.

Causale Co.Ge.
E' la causale che servirà per registrazione in Contabilità Generale della fattura e viene letta dalla tabella delle causali di Contabilità. Se lasciata bianca, in fase di contabilizzazione della fattura, si prende quella indicata nei Parametri al punto (4) Caus.e Conti Comuni. Se invece non si vogliono contabilizzare i documenti emessi con questo tipo documento occorre inserire in questo campo $$ (es. per un tipo documento che 'evade' una bolla di c/dimostrazione perché il cliente ha fatto il reso).
Se è impostato a Si il flag del regime del margine, il codice causale è obbligatorio.

Causale Co.Ge. (se iva ad esigibilità differita)
E' la causale che servirà per registrazione in Contabilità Generale di fatture emesse a clienti che hanno l'iva ad esigibilità differita (Iva Sospesa) e deve esistere nella tabella delle causali di Contabilità.
Se lasciata bianca, in fase di contabilizzazione della fattura, si prende quella indicata nei Parametri al punto (4) Caus.e Conti Comuni.
Se invece non si vuole contabilizzare quel documento occorre inserire in questo campo $$.

Prefisso fatture (registro iva)
Individua il registro iva vendite su cui verrà stampata la fattura e dal quale verrà preso il numero progressivo.
Se valorizzato, deve essere uno di quelli già specificati in Tabella parametri di contabilità.
E' possibile avere più registri vendite individuati ciascuno da un prefisso. L'elenco dei prefissi utilizzati per le vendite e il prefisso principale, deve essere specificato sulla tabella parametri comuni.
Se questo campo viene lasciato bianco, significa che in emissione fattura si deve considerare il prefisso 'principale'.
Se è impostato a Si il flag del regime del margine, il prefisso è obbligatorio e deve essere stato creato appositamente per tale regime.

Tipo documento di evasione
E' la causale del documento di evasione. Se si sta gestendo un tipo documento per vendita di beni usati (regime del margine), anche il tipo documento di evasione deve avere questa caratteristica. Se impostato, verrà proposto in evasione.

Tipo documento per Fattura Elettronica
Campo obbligatorio, in corrispondenza a tipi documento Fattura o Nota di Credito, se si utilizza la fattura elettronica.
Deve essere compilato con i codici indicati nel pulsante di aiuto (Fattura, Acconto/Anticipo su fattura,Acconto/Anticipo su parcella,Nota di Credito, Nota di Debito, Parcella)

Descrizione su fatt. riepilogativa
E' la descrizione che in fattura riepilogativa identifica i documenti che vengono riepilogati: bolla, ddt, ricevuta fiscale, buono di consegna. Se viene lasciata bianca il programma di evasione scriverà "Ddt".
Deve essere impostato sui tipi documento Ddt (Ddt o Ricevuta Fiscale).
Descrizione su documento di evasione
Ha senso compilare questo campo sui tipi documento Preventivo e/o Ordine se in tabella di fatturazione o sul singolo cliente si sceglie di stampare, sui documenti generati dall'evasione di altri, il riferimento al documento di provenienza.
Quanto scritto qui, precederà l'indicazione del nr. e data del documento di provenienza sul documento generato dall'evasione.
Es. sul Preventivo si può mettere: Ns Rif. Interno Preventivo e sull'ordine con il quale si evaderà il preventivo verrà generata la riga:
Ns Rif. Interno Preventivo N. x del gg/mm/aaaa
Se il campo viene lasciato bianco, il programma di evasione scriverà semplicemente:
Prev. (Ord.) n. x del
E' possibile scrivere in questo campo dei caratteri di controllo per impostare in stampa di questa riga un font diverso da quello del corpo del documento o per cambiare l'allineamento.
In particolare facendo precedere <B> si otterrà la stampa in grassetto della riga. Per altri font vedere Font personalizzati

Stampa descrizione aggiuntiva articolo
La descrizione aggiuntiva dell' articolo può non essere stampata sui documenti, essere stampata sopra o sotto le righe di dettaglio, oppure essere copiata sulle note di dettaglio (sopra o sotto). Questo campo consente di scegliere come operare sul documento che si sta inserendo. L'evasione (in caso di ordine o ddt) copierà, sul documento di arrivo (ddt o fattura), il flag così come lo trova.
E' possibile fare in modo che, sul documento di arrivo il flag venga impostato secondo quanto scritto sul tipo documento, impostando il parametro di personalizzazione: StDesLunDaDoc

Giorni per controllo scaduto
Se questo campo è valorizzato, verrà attivato un controllo sulle scadenze ancora aperte, nelle vendite, al momento dell'inserimento del documento. Cioè, verrà segnalato, una volta digitato il codice del cliente, se esistono scadenze aperte con data inferiore alla data di inserimento documento meno il numero dei giorni. Inoltre, sul documento, nel quadro 'note del cliente' verrà visualizzato l'importo di tali scadenze.

Rischio
Indica se i documenti emessi con questo tipo documento vanno considerati o meno nel calcolo dell'esposizione del cliente (utilizzato in una stampa di contabilità)

In fatturato
Indica se i documenti emessi con questo tipo documento vanno considerati o meno nelle statistiche del fatturato

Codici Note fisse 1-2-3
E' possibile associare ad ogni documento fino ad un massimo di 3 note fisse che verranno proposte in inserimento del documento e stampate.

Condizione di pagamento
E' possibile impostare una condizione di pagamento particolare che verrà utilizzata sempre, dai programmi di Ordini e Vendite, quando si usa questo tipo documento, indipendentemente dalla condizione presente sul cliente.
Se questo campo viene lasciato bianco (o viene posto a $1) si utilizzerà sempre la condizione di pagamento principale del cliente.
Se invece si imposta a $2, i programmi di Ordini e Vendite utilizzeranno la 2' condizione di pagamento del cliente che, ovviamente, dovrà essere valorizzata.

Stampo documento su - Con Modello
Impostando questi due campi si potrà decidere di stampare i documenti che hanno il Tipo documento in gestione, con un modello di stampa indicato qui e predisposto per un certo tipo di stampante. I modelli di stampa devono essere stati precedentemente creati con le apposite funzioni.

I campi possono essere lasciati bianchi, se non si stampa questo documento con condizioni particolari.
Es. ci può essere un Tipo documento Ddt e uno Ricevuta fiscale. Essi hanno senz'altro due modelli di stampa diversi. Il modello di stampa potrà essere scelto di volta in volta al momento della stampa oppure può essere impostato fisso in questi campi in modo tale che il programma lo legge direttamente da qui.

Personalizzazione Fine Corpo
In questo campo potrà essere impostata la sequenza delle sottosezioni 'particolari' da stampare in fondo al corpo del documento (es. note del cliente), tali sottosezioni devono essere state inserite nel filtro di stampa.
Se nel filtro di stampa sono presenti anche altre sottosezioni (stampabili se si attiva il parametro: finecorpo) queste non verranno stampate per questo tipo documento, ma verrà stampata SOLO la sottosezione indicata in questo campo.

Se invece questo campo viene lasciato vuoto, viene stampato tutto il corpo come previsto dal filtro.

Campi necessari per scaricare sul file XML delle fatture informazioni aggiuntive secondo il tracciato Standard Assosofware, al fine di rendere più leggibili le fatture da parte di chi le riceve
Codifica AssoSoftware Tipo Documento
Codifica AssoSoftware Caratteristica Documento
Codifica AssoSoftware Trattamento Fiscale
E' possibile inserire nei rispettivi campi un valore decodificato dalle tabelle AssoSoftware (caricate sul file Decodifiche dell'AziMenu.mdb)


TABELLA BOLLI

Percorso: Archivi Comuni - Tabelle vendite

Note sul calcolo dei bolli in fattura:

Sono soggette alla marca da bollo di 2€, le fatture di importo superiore ad € 77.47 riguardanti:

  • Operazioni fuori campo IVA per mancanza del presupposto soggettivo o oggettivo (Art. 2, 3, 4 e 5 DPR 633/1972), territoriale (Art. da 7 a 7-septies DPR 633/1972);
  • Operazioni escluse dalla base imponibile dell’ IVA (Art. 15 DPR 633/1972);
  • Operazioni esenti da IVA (Art. 10 DPR 633/1972);
  • Operazioni non imponibili perché effettuate in operazioni assimilate alle esportazioni, servizi internazionali e connessi agli scambi internazionali, cessioni ad esportatori abituali (esportazioni indirette Art. 8 lett. c) DPR 633/1972);
  • Operazioni effettuate dai soggetti passivi che usufruiscono del nuovo regime dei minimi e del regime forfettario.

Sono sempre esenti dalla marca da bollo:

  • Fatture, note di credito e addebito e documenti simili che riguardano operazioni soggette ad IVA
  • Fatture riguardanti operazioni non imponibili relative ad esportazioni di merci (Art. 8 lett. a) e b) DPR 633/1972) ed a cessioni intracomunitarie di beni (Art. 41, 42 e 58 DL 331/1993)
  • Fatture soggette al reverse charge (Art. 17, comma 6 lett. a), a-bis) e a-ter) DPR 633/1972) e cessione dei rottami (Art. 74 comma 7 e 8 DPR 633/1972)

Al fine di ottenere l'applicazione del bollo sulla fattura occorre:

  • Compilare correttamente i campi della Tabella Bolli (come descritto sotto)
  • Spuntare sul cliente ha il flag 'addebito bolli' (Gestione clienti, maschera dati di fatturazione)
  • Spuntare sul codice iva (esenzione) utilizzato in fattura il flag: 'Applico bolli su fatture esenti'

Date questi presupposti verrà calcolato il bollo se:

  • la fattura è completamente esente e supera l'importo limite esente da bollo (€ 77.47 da riportare in tabella bolli)
  • in fattura c'è un importo esente che supera tale limite

Bolli per Ricevute Bancarie (Tratte) vengono applicati se:

  • il cliente ha il flag di addebito bolli a Si
  • sul Tipo di pagamento il flag Addebito bolli è a Si
  • Per tratte è stato creato un codice Spesa associato alla condizione di pagamento

Importo del bollo su una fattura esente

lmporto limite esente da bollo (€ 77.47)
Se in una fattura compare un importo esente minore o uguale a questo importo, non verranno applicati i bolli per fattura esente, anche se si verificano le condizioni di cui sopra

Codice iva (esenzione)
E' il codice che nella tabella iva, identifica l'esenzione da applicare all'importo dei bolli.

Conto per Bolli
E' il conto di contabilità su cui contabilizzare l'importo dei bolli

Arrotondamento bolli
È la cifra alla quale arrotondare l'importo del bollo calcolato per tratte e Ricevute Bancarie (es. 0,10 vuol dire arrotondare al decimo di euro)

Percentuale del bollo per le tratte
Indica la percentuale da applicare in caso di fattura con pagamento Tratta
Per il calcolo dei bolli per le tratte, si consiglia, in alternativa alla compilazione di questo campo, di creare una spesa nella tabella Spese ed associarla alla condizione di pagamento, in questo modo sarà possibile indicare in fattura l'importo dei bolli per ogni scadenza.

Scaglioni di bollo per ricevute bancarie
Sono 6 intervalli di imponibili fattura e i relativi importi del bollo da addebitare in caso di fattura con pagamento ricevuta bancaria.


NOTE FISSE PER DOCUMENTI

Percorso: Archivi Comuni - Tabelle vendite

Sono delle note che, una volta inserite, possono essere stampate sui documenti a richiesta. Ogni nota è individuata da un codice, al momento dell' inserimento di un preventivo, ordine, ddt, fattura è possibile decidere se stampare o meno fino a tre di queste note.

Ogni nota è individuata da un codice e una descrizione. La descrizione serve solo per descrivere la nota nelle gestioni dove ne viene chiesto il codice.

Per fare in modo che una nota venga stampata 'sempre' su un documento, basta inserirla nell'anagrafica del tipo documento, nell'apposito campo: codice nota fissa. Ad un documento possono essere associate fino a 3 note fisse.

Posizione di stampa:
indica la posizione in cui la nota verrà stampata sui documenti

  • Inizio corpo
    prima degli articoli
  • Fine corpo
    dopo gli articoli
  • Non nel corpo
    in questo caso occorrerà inserire nel filtro le istruzioni per stampare la nota in testata o nel piede, facendo riferimento alle variabili: D.NoteFn.TestoNota (dove n=1,2,3).
    Se nel filtro, si dice di stampare sempre nel piede la prima nota impostata sul documento, occorre fare attenzione a impostare in tale posizione sempre dei codici di nota fissa con Posizione stampa: "Non nel corpo"
    Nota: se c'è la necessità di stampare la nota 'particolare' SOLO nell' ultima pagina del documento, occorre differenziare nel filtro la stampa dell'ultima pagina impostando le relative righe con sottosezione 0, mentre quelle delle pagine precedenti vanno impostate con sottosezione 1.

Da stampare su documento di evasione
 indica se, caso di documento da evadere, la nota va stampata o meno anche sul documento di evasione.

Occorre utilizzare quest'ultima caratteristica con attenzione perché su ogni documento possono esserci al massimo tre note fisse per cui se una fattura evade bolle con tante note fisse diverse, alla fine sulla fattura se ne potranno stampare comunque solo tre.

Nota fissa collegata alla condizione di pagamento (es. quella collegata al 'Bonifico' per stampare in fattura l'IBAN):
Sul ddt la nota verrà inserita se il flag 'Da stampare sul documento di evasione' è posto a No altrimenti verrà inserita dall'evasione ddt direttamente sulla fattura.

Riportare su file XML della Fattura Elettronica
In generale tutte le note fisse verranno riportate sul file XML della fattura elettronica nel campo 'Descrizione Causale', impostando a no questo campo la nota verrà esclusa.
In tale campo della fattura elettronica verrà riportata anche, se esiste, la nota per fattura presente sull'anagrafica cliente (6-Note docum.).
Tramite l'impostazione del parametro di personalizzazione: NoteFisse è possibile cambiare quanto fa il programma

Con Ctrl Tab premuti all'inizio di una riga di un campo Note è possibile lasciare davanti al testo, un certo numero di caratteri bianchi mentre non verranno riconosciuti i caratteri bianchi scritti premendo la barra spaziatrice.


SCONTI TABELLE

Percorso: Archivi Comuni - Tabelle vendite

Sconti Categoria Cliente/Fornitore - Articolo

La tabella consente di inserire per ogni categoria cliente o fornitore e per ogni articolo una percentuale di sconto (o un importo)

Con la definizione di ' Tipo sconto' si decide se lo sconto impostato deve: sostituire l'eventuale sconto articolo e sconto cliente oppure, sostituire solo quello cliente, sostituire solo quello articolo o, infine, sommarsi a entrambi.

Es.: sconto tabella = 2, sconto articolo=3 e sconto cliente= 5

Se si vuole che sulla riga della fattura lo sconto sia 2 si dovrà indicare di sostituire lo sconto articolo e lo sconto cliente.
Se lo sconto deve essere 3+2 si indicherà che sostituisce lo sconto cliente
Se lo sconto deve essere 5+2 si indicherà che sostituisce lo sconto articolo
Infine se lo sconto deve essere 3+5+2 si indicherà che si somma a entrambi.

Sconti Cliente - Gruppi Articoli
Ad ogni cliente/fornitore possono essere associati sconti diversi per gruppi (e sottogruppi) di articoli.

Sconti Categoria Cliente/Fornitore - Gruppo Articoli
Ad ogni categoria cliente/fornitore e Gruppo (Sottogruppo) articoli possono essere associati sconti particolari.

Sconti Cliente - Articolo
La tabella consente di inserire per ogni cliente e per ogni articolo una percentuale di sconto (o un importo) da considerare nelle vendite. Lo sconto può sostituire quello articolo o sommarsi ad esso e può sostituire quello cliente o sommarsi ad esso.

Se si inserisce un importo piuttosto di uno sconto, questo diventerà il prezzo dell'articolo per quel cliente.

% Abbattimento Provvigione
E' possibile definire una percentuale di abbattimento della percentuale provvigione in corrispondenza ad ogni sconto inserito.
Questa verrà utilizzata, in inserimento Preventivi, Ordini, Ddt e Fatture per abbattere la percentuale di provvigione della riga.
Se vale -1 non verrà applicato nessun abbattimento, se vale 0 potrà essere applicato, se impostato, l'abbattimento della Tabella abbattimenti per fasce di sconto


SCONTI QUANTITA'

Percorso: Archivi Comuni - Tabelle vendite

La funzione consente di inserire sconti (o prezzi) diversi a seconda della quantità dell'articolo che si sta movimentando.
Per abilitare i vari programmi di emissione documenti alla lettura di questa tabella è indispensabile spuntare il campo : Uso sconto quantità in Parametri e utilità - Dati generali azienda(parametri) quadro di Fatturazione

In particolare potranno essere inserite tabelle diverse per:

  • Articolo Gruppi/sottogruppi articoli
  • Cliente-Articolo Cliente-Gruppi/sottogruppi articoli
  • Categoria cliente-ArticoloCategoria cliente -Gruppo/sottogruppi articoli

Una volta selezionato il tipo di gestione, occorre inserire i codici che individuano le quantità e gli sconti es. Articolo, Cliente e articolo, Gruppo-Sottogruppo articolo etc.

Nella richiesta Gruppo - Sottogruppo, quest'ultimo può essere lasciato vuoto.

Successivamente si passa alla gestione delle fasce di sconto premendo il pulsante: GESTIONE SCONTI

Viene chiesto di inserire da quale quantità applicare un certo sconto (o in caso di articolo anche un certo prezzo unitario) e questo ripetuto per tante fasce quante ne necessitano.

Terminato l'inserimento degli intervalli di quantità si torna all'inserimento dei codici iniziali premendo il pulsante TORNA A …

Esempio:
Da quantità 1 sconto: 2
Da 10 sconto: 3
Da 15 sconto: 4
Significa che se si fatturano per questo articolo da 1 a 9 pezzi, verrà applicato uno sconto del 2%, da 10 a 14 uno sconto del 3%, da 15 in su uno sconto del 4%.

In caso di inserimento sconti per Articolo o Cliente-Articolo può essere inserito direttamente il prezzo di listino da applicare in alternativa al listino in uso.

Le colonne:
sostituisce sconto tabella e
sostituisce sconto cliente
si riferiscono al fatto che questo sconto vada a sostituire o si sommi agli sconti derivati da tabella sconti e dal cliente.

Se lo sconto non sostituisce gli altri, si può lasciare bianco il campo che verrà impostato automaticamente a No.

Abbattimento Provvigione
E' possibile definire una percentuale di abbattimento della percentuale provvigione in corrispondenza ad ogni sconto inserito.
Questa verrà utilizzata, in inserimento Preventivi, Ordini, Ddt e Fatture per abbattere la percentuale di provvigione della riga.
Se vale -1 non verrà applicato nessun abbattimento, se vale 0 potrà essere applicato, se impostato, l'abbattimento della Tabella abbattimenti per fasce di sconto


PROVVIGIONI - ABBATTIMENTO PER FASCE SCONTI

Percorso: Archivi comuni - Tabelle Vendite

Questa tabella consente di inserire una percentuale di abbattimento della provvigione per fasce di sconto.

I programmi delle vendite, nel punto in cui viene impostata la percentuale provvigione su ogni riga articolo, diminuiranno tale percentuale in base alle condizioni dettate da questa tabella.

Per attivare la ricerca dell' abbattimento da applicare occorre impostare il parametro di personalizzazione: RidPercAgenti
Questo parametro, oltre ad attivare l'applicazione dell'abbattimento, indica il numero di decimali che dovrà avere la percentuale di provvigione ottenuta dopo aver applicato la riduzione.

Un'altra possibilità attivata è quella di inserire le % di abbattimento sulla tabella Sconti


STAMPA SPESE

Percorso: Archivi Comuni - Tabelle vendite -Stampe

La funzione esegue la stampa dell'elenco dei codici spesa creati.


STAMPA AGENTI

Percorso: Archivi Comuni - Tabelle vendite -Stampe

Esegue una stampa dei dati anagrafici degli agenti ordinati per codice o ragione sociale.


STAMPA TIPI DOCUMENTO

Percorso: Archivi Comuni - Tabelle vendite -Stampe

E' possibile scegliere di stampare tutti i tipi documento o solo quelli di tipo Preventivo, Ordine, Ddt, etc. ed eventualmente digitare l'intervallo dei codici da stampare.

La stampa in forma sintetica elenca su un'unica riga le caratteristiche principali di ogni tipo documento mentre quella analitica riporta tutti i campi.


STAMPA TABELLA BOLLI

Percorso: Archivi Comuni - Tabelle vendite -Stampe

Consente di stampare la tabella dei bolli utilizzata in fatturazione per l'emissione effetti


STAMPA NOTE FISSE

Percorso: Archivi Comuni - Tabelle vendite -Stampe

Consente di stampare l'elenco delle note fisse inserite.


SCONTI STAMPA TABELLE

Percorso: Archivi Comuni - Tabelle vendite -Stampe

La funzione consente di stampare una per una le tabelle degli sconti dopo averla selezionata tra quelle disponibili.

E' stato introdotto un parametro di personalizzazione: SaltoPagClie (Gruppo: StaSconti) che, se impostato a S, nella stampa degli sconti cliente/articolo, consente di stampare l'indirizzo completo del cliente (oltre alla ragione sociale) e di fare un salto pagina a cambio cliente

(Serve a chi utilizza la tabella sconti Cliente/Articolo come Listino, compila cioè il prezzo piuttosto che lo sconto, per ogni coppia cliente/articolo. Questo modo di operare è in alternativa a creare un listino diverso per ogni cliente)


STAMPA SCONTI QUANTITA'

Percorso: Archivi Comuni - Tabelle vendite -Stampe

Consente di effettuare la stampa delle Tabelle di sconti quantità inserite dopo aver scelto la tabella desiderata.


CONTABILITA'

La procedura di Contabilità adempie a tutti gli obblighi fiscali di una ditta in contabilità ordinaria o in semplificata.

Può essere utilizzata singolarmente oppure in collegamento con la procedura di Vendite dalla quale può ricevere i movimenti derivati dalle fatture.

La Contabilità può essere installata anche nella forma 'Ridotta'. In questo caso verranno abilitate tutte le sue funzioni tranne le stampe fiscali (giornale bollato, registri iva e chiusure iva).

La contabilità ridotta, che ha un costo inferiore a quella completa, è utile agli utenti che emettono fatture con il computer mentre fanno tenere la contabilità al commercialista. Installando questo pacchetto, insieme alla fatturazione, potranno consultare le schede e gli scadenzari dei clienti, controllare le entrate e le uscite, pur continuando a demandare al commercialista le stampe fiscali.

Caratteristiche principali:

  • Piano dei conti a tre livelli, riclassificabile secondo la normativa Cee o altri criteri.
  • Nell'anagrafica dei clienti e fornitori c'è la possibilità di scrivere delle note, consultabili in particolare durante l'emissione dei documenti di Vendita.
  • E' possibile gestire più attività iva all'interno della stessa ditta, più registri Vendite, Acquisti e Corrispettivi, la ventilazione dei corrispettivi, il plafond per gli esportatori abituali, la registrazione di fatture emesse e ricevute in sospensione di imposta e il relativo incasso-pagamento, gli acquisti Intra Cee e regimi iva particolari quali ad esempio l'agricoltura e le agenzie di viaggio.
  • Gestione regime iva per cassa
  • Gestione Split Payment per fatture emesse verso la Pubblica Amministrazione
  • Gestione Reverse Charge
  • Registrazione automatica della ritenuta d'acconto.
  • La registrazione dei documenti è guidata da causali parametriche, preimpostate dall'utente, che consentono di ridurre al minimo le possibilità di errore.
  • Scadenzari attivi e passivi, saldaconto, gestione degli effetti con preparazione delle distinte e delle Ri.Ba. e Rid su supporto magnetico.
  • Gestione delle partite con possibilità di preparare lettere di sollecito ai clienti.
  • Bilanci a sezioni contrapposte o scalari, con possibilità di elaborazioni da data a data
  • Bilanci per Centro di Costo
  • Bilancio Cee anche in formato Xbrl
  • Giornale bollato, Registri iva e Liquidazione iva (periodica e annuale)
    possono essere stampati in prova e definitivi.
  • Preparazione dei file per l'invio telematico di:
    Comunicazione Liquidazioni periodiche Iva
    Dichiarazione d'intento (a fornitori)
    Corrispettivi (per grande distribuzione)
    Modello F24
    Elenco di acquisti/vendite in paesi in Black List
    Comunicazione dati fatture Emesse e Ricevute
    Tessera Sanitaria
  • Chiusura e riapertura automatica dell'esercizio con possibilità di tenere in linea più anni.

La procedura gestisce gli adempimenti di alcune attività particolari quali:

  • Agenzie di viaggio (gestione dell'articolo 74 Ter)
  • Trasportatori (iva vendite conteggiata nel periodo successivo rispetto quello di emissione delle fatture)
  • Prorata agricolo
  • Regime del margine (beni usati)
  • Reverse charge

Come impostare i dati per cominciare ad utilizzare la procedura.

Qualsiasi sia la procedura da utilizzare, occorre andare nel Menu Parametri e Utilità poi eseguire Dati Generali Azienda e compilare tutti i parametri comuni e quelli delle procedure da utilizzare.

E' inoltre fondamentale compilare le tabelle:

  • Prefissi e Numeratori Documenti
  • Dati iniziali Iva per l'anno da gestire ed eventualmente: Plafond
  • Caratteristiche esercizio di Contabilità

Successivamente occorre compilare, dal menu Archivi comuni, le anagrafiche e le tabelle di contabilità.


INPUT DI PRIMA NOTA

Percorso: Contabilità - Prima nota - Input prima nota

Prima nota extracontabile

Prima nota movimenti di appoggio

Questo programma consente l' inserimento, gestione e annullamento di Fatture e Note di credito (di Clienti e di Fornitori), dei Corrispettivi, di Fatture emesse e ricevute con iva ad esigibilità differita e infine dei movimenti diversi a diversi quali giroconti, pagamenti etc.

Come inserire una nuova registrazione:

Digitare 0 nel campo Numero di registrazione e premere invio, in automatico il programma va in inserimento proponendo la data del giorno come data di registrazione. Successivamente completare i dati richiesti, che variano a seconda della causale, e infine premere il tasto F10 oppure i pulsanti [image] (E F10) Gestione Dettaglio o [image] (S) SALVA per passare all'inserimento delle varie righe della registrazione.

Successivamente viene chiesto di inserire il codice di un conto (la ricerca per descrizione si può fare digitando il carattere c/f/g, a seconda che si voglia cercare un cliente, un fornitore o un conto, seguito da qualche lettera della ragione sociale o descrizione, seguito dal tasto F3. Vedi: Lista di aiuto )

Finito l'inserimento di una riga (es. una riga di ricavo in una fattura clienti) con F10 o Salva si passa alla richiesta di un'altra riga. Quando non ci sono più righe con conti da inserire, con F10 sul codice conto vuoto, si conferma e salva la registrazione e si torna alla prima maschera.

Il programma rimane in stato di inserimento, presenta cioè una registrazione nuova, in parte già compilata, con la stessa causale della registrazione precedente. Se si vuole tornare a menu basta uscire con Esci senza confermare, se invece si vuole rimanere dentro al programma, ad esempio per andare a variare una registrazione, occorre premere il tasto [image] (A) Annulla e confermare.

E' possibile inserire un flag nei parametri di personalizzazione, in modo che dopo l'inserimento di una registrazione il programma non torni in inserimento ma rimanga sulla registrazione appena fatta.
In questo caso per fare un'altra registrazione occorrerà premere il pulsante [image] (R) Ricerca poi digitare di nuovo 0 sul campo numero registrazione.

Come variare una registrazione:

La variazione di una registrazione è possibile finchè questa non sia stata aggiornata come iva né stampata sul giornale né sul registro iva.
Ci sono tuttavia alcuni campi che sarà possibile variare comunque: codice contratto, 'Op.rilevante ai fini iva' , 'pref-numero e data fattura di riferimento'.

La registrazione può essere richiamata tramite il numero di registrazione, trovata nella lista oppure cercata tramite un campo qualsiasi della testata. Esempio: se si digita il codice causale Fatt.emessa e il codice del cliente e si preme il pulsante Ricerca, verranno elencate tutte le fatture di quel cliente; se si digita un numero protocollo verrà visualizzata la fattura con quel protocollo.

Se la fattura (o nota di credito) è stata aggiornata come iva ma non è ancora stata stampata sul registro, può essere disaggiornata tramite il pulsante: (V) Disaggiornamento iva, poi modificata e di nuovo riaggiornata con l'apposito pulsante.

In regime di Iva per Cassa il pulsante di aggiornamento/disaggiornamento comparirà anche nelle registrazioni di incassi/pagamenti (in pratica in tutti i diversi a diversi). In ogni caso, se lanciato, verrà eseguito SOLO SE nella registrazione c'è almeno una riga con riferimento a un documento con iva per cassa.

Come cancellare una registrazione:
richiamare la registrazione (con il numero o cercandola nella lista) poi premere il pulsante [image] (C) Cancella
Si consente di cancellare una registrazione se non è aggiornata come iva, né stampata sul giornale né sul registro iva.

E' possibile registrare un documento in valuta e farlo trasformare nella valuta corrente dal programma. Basta utilizzare una causale normale (con il flag in valuta non settato) e mettere la moneta del documento in testata e l'esatto valore del cambio. Gli importi inseriti nei dettagli saranno nella moneta del documento e al salva il programma memorizzerà la registrazione nella valuta corrente utilizzando il cambio inserito in testata.

Registrazioni particolari:
Fattura d'acquisto IntraCee
Fattura Reverse Carge
Fattura con Ritenuta d'acconto
Fattura con Costi non deducibili
Acquisto da un paese in Black List
Importazione
 Nota di variazione
Regime iva per Cassa
Sulle fatture/note di variazione emesse e ricevute che vengono registrate con causali compatibili con l'iva per Cassa, in un periodo in cui questa è attiva, verrà messo in automatico il campo 'Iva per cassa' impostato a Si.
Inoltre anche quando si registrano incassi/pagamenti di tali fatture, nella riga corrispondente al cliente o al fornitore verrà messo in automatico il campo 'Iva per cassa' impostato a Si
In regime di Iva per Cassa il pulsante di aggiornamento/disaggiornamento comparirà anche nelle registrazioni di incassi/pagamenti (in pratica in tutti i diversi a diversi). In ogni caso, se lanciato, verrà eseguito SOLO SE nella registrazione c'è almeno una riga con riferimento a un documento con iva per cassa.

Quando si inserisce la riga di dettaglio con il costo, viene visualizzata l'icona [image] (B) Costo Indeducibile che consente di creare in automatico la riga del costo indeducibile con il relativo importo.

Anno
E' l'anno nel quale verranno incrementati i progressivi dare/avere dei conti che intervengono nella registrazione, indipendentemente dalla data di registrazione.

Tale anno viene posto in automatico uguale all'anno contabile al quale appartiene la data di registrazione, in base a quanto specificato in Parametri di contabilità (dati generali azienda - parametri).

Se però non è ancora stata fatta la chiusura contabile dell'anno precedente, si consente di variarlo e di registrare operazioni di rettifica o di chiusura con data anno in corso e competenza 'anno precedente'. In questo modo le registrazioni verranno stampate sul giornale dell'anno in corso ma aggiorneranno i progressivi dell'anno precedente.

Data registrazione
Viene proposta quella digitata nel menu all'accensione del sistema. Si può variarla o confermarla.
Non si accettano registrazioni con data maggiore di quella di sistema.
Tale data determina l'ordine di stampa degli articoli sul giornale bollato, se nei parametri di personalizzazione non è stato settato il parametro DataOp che prevede l'ordinamento per data protocollo piuttosto che per data di registrazione.

Cod. Causale
A seconda della causale che si digita, il programma si predispone a ricevere un certo tipo di dati.
Per una corretta compilazione delle registrazioni è indispensabile quindi che le causali siano codificate correttemente in tutte le loro parti.
Ci sono sostanzialmente due tipi di registrazioni: quelle 'con iva' (fatture, note di credito, corrispettivi) e quelle che non interessano l'iva cioè i diversi a diversi (giroconti, incassi, pagamenti etc.)

In una registrazione già fatta la causale può essere variata ma SOLO con una con le stesse caratteristiche.
Se nell'anagrafica della causale utilizzata per la registrazione è stato impostato il codice della causale cespiti collegata, verrà visualizzato un pulsante (tra quelli in alto) per accedere direttamente all'anagrafica cespiti: (T) Passa a gestione cespiti
Questa possibilità c'è per le causali di acquisto o vendita cespite.

Prefisso/Numero protocollo - data
Campi obbligatori in caso di fatture.
Il prefisso individua il registro iva nel quale le fatture verranno stampate e deve essere una lettera tra quelle impostate in 'Elenco prefissi' nei parametri generali 'Parametri Comuni' .
Se la ditta non utilizza più registri iva, il prefisso verrà impostato a . (punto).

Il numero protocollo viene incrementato in automatico ad ogni nuova registrazione di fattura. Ci sono numeratori separati per fatture di vendita e di acquisto (e corrispettivi) e anche per prefisso.
Se si interviene manualmente sul numero, il programma controlla che non sia doppio o che non sia rispettata la sequenza e da un messaggio.
Il numero e la data dell'ultimo protocollo inseriti si possono gestire con la funzione Prefissi e Numeratori Documenti dal Menu Contabilità - Gestioni.
Se è stato impostato il parametro di personalizzazione DataOp, diventa obbligatorio inserire numero e una data protocollo su ogni registrazione (l'obbligatorietà va posta su tutte le causali). Il numero da attribuire alle registrazioni "no iva" dovrà essere gestito manualmente.

Prefisso/Numero documento - data
Sono rispettivamente il prefisso (opzionale) e il numero documento della fattura (o nota di credito) in oggetto.
Individuano la Partita contabile se si gestiscono le partite.
Se si registra un insoluto (flag di insoluto sulla causale) questi campi sono obbligatori

Se si inserisce una fattura d'acquisto, il programma segnala con un messaggio non bloccante se trova la stessa fattura (prefisso, numero e data documento) già registrata.

Descrizione aggiuntiva
Campo descrittivo della registrazione che verrà stampato sul giornale bollato.
Se sulla causale è stata impostata una descrizione aggiuntiva, essa verrà riportata automaticamente in questo campo e potrà essere variata o completata.
E' possibile impostare il parametro di personalizzazione FattDescrAgg che consente di compilare automaticamente la descrizione aggiuntiva

Descrizione testata
Ulteriore campo descrittivo della registrazione che verrà stampato sul giornale bollato.

Campi in testata per registrazioni di fatture, note credito, corrispettivi

Cliente/Fornitore/Conto
In questo campo va impostato il codice del cliente o fornitore intestatario della fattura (o il conto se si sta registrando un corrispettivo)

Codice fornitore di riferimento:
il campo può essere valorizzato se il fornitore principale inserito nella registrazione NON è quello con cui è stata fatta l’operazione.
In particolare si fa riferimento ad acquisti da paesi in black list, dove la registrazione sia fatta utilizzando il fornitore ‘dogana’ e quindi serve avere il fornitore per poter mettere i suoi dati anagrafici nella comunicazione Black List OPPURE nelle registrazioni di un acquisto da un fornitore che ha un rappresentante fiscale in Italia, se si registra l’acquisto come autofattura (in questo caso occorrerà registrare manualmente anche la fattura sul registro Vendite e il giroconto in quanto, per una corretta compilazione dello Spesometro, NON si dovrà utilizzare una causale con il flag ‘Importazione’).

Nell’elaborazione dello Spesometro, se si trova una registrazione con questo campo compilato, verrà considerata come fatta con uno straniero.

Iva per Cassa
Nelle fatture/note di credito emesse e ricevute, indica se in corrispondenza al documento si applica o meno l'iva per cassa.

Operazione rilevante ai fini iva (Spesometro)
Indica come dovrà essere considerata la registrazione, al momento dell'estrazione dei dati per la comunicazione dell'elenco delle Operazioni rilevanti ai fini Iva.
Può assumere i valori:

  • Normale
    Il programma di estrazione valuterà sulla base della normativa, se considerare o meno la registrazione
  • da Ignorare
    Il programma di estrazione non considererà affatto la registrazione
  • estrazione Forzata
    Il programma di estrazione considererà la registrazione indipendentemente dal fatto che rispetti o meno i requisiti

Alla conferma della registrazione il campo verrà impostato a Normale, l'utente potrà poi variarlo manualmente se lo ritiene necessario. Nelle registrazioni dove viene inserito un codice contratto, questo campo verrà considerato solo se impostato a 'da ignorare'.

Pref/Numero e data Fattura di riferimento
Questi campi vengono chiesti SOLO in corrispondenza di registrazioni fatte con causali nelle quali è stato spuntato il campo: Nota di variazione.
Fino al 31/12/2011 Se il documento inserito doveva essere trasmesso nella comunicazione dell'elenco delle Operazioni rilevanti ai fini Iva questi campi erano obbligatori. Solo se la nota di variazione fa riferimento a più fatture oppure non è possibile indicare il riferimento alla fattura, si dovrà lasciare bianco il numero e valorizzare la data con 31/12/aa dove aa è l'anno di registrazione.
Nello Spesometro del 2012 il campo non è più utilizzato

Condizione pagamento
Se sulla causale è stato impostato a Si il campo 'Obbligo condizioni di pagamento', in questo campo dovrà essere inserito un codice di pagamento. Alla conferma della registrazione, il programma genererà in automatico le scadenze e le proporrà all'operatore che può confermarle, variarle o annullarle (vedi Quadro scadenze).

E' possibile creare una condizione di pagamento con -1 nel numero di scadenze in modo da NON generare la scadenza in corrispondenza a fatture particolari.

Se si registra un insoluto (flag di insoluto sulla causale) in questo campo verrà proposta la condizione di pagamento messa sulla causale per la creazione della nuova scadenza.

Contratto
Se la fattura si riferisce a un contratto, è possibile associarne il codice in modo da compilare poi correttamente la Comunicazione delle Operazioni rilevanti ai fini Iva.

CIG e CUP
Sono rispettivamente il Codice Identificativo di Gara e Codice Unico di Progetto. Possono essere digitati direttamente sul documento o venire dal contratto.
Se si imposta un codice contratto sul quale sono stati inseriti i codici Cig e Cup, questi verranno riportati sul documento SOLO se non sono già impostati.
Se si sbianca il codice contatto, sul documento i codici Cig e Cup eventualmente già impostati perchè letti dal contratto inserito in precedenza, non verranno sbiancati.
Potranno essere stampati sul documento (occorre inserire righe apposite nel filtro di stampa) e verranno poi riportati sulle scadenze.

Mese/Anno per iva: (solo nel caso di documenti con iva)
questi due campi in generale, vanno lasciati bianchi. Occorre impostarli solo se il documento viene registrato in un determinato mese ma, ai fini dell'iva, va considerato in un altro. Es. i trasportatori rimandano l'iva di un trimestre a quello successivo; l'iva di una fattura riepilogativa emessa nel mese successivo alla consegna della merce, va considerata nel mese precedente.

Data scadenza
Campo descrittivo. Si può stampare sui partitari

Black List
Indica se il documento interessa la comunicazione delle operazioni fatte con soggetti residenti in paesi in Black List

Nota di variazione che si riferisce ad anni precedenti
può assumere i seguenti significati:

  • Non si riferisce a periodi precedenti
  • Si riferisce ad anni precedenti
  • Si riferisce a periodi già comunicati nell'anno (Black List)

Questo campo dovrà essere impostato correttamente nel caso si stia registrando una Nota di variazione (nota di credito) riferita a fattura dell'anno precedente o a fattura dell'anno corrente ma registrata in un periodo di cui è già stato fatto l'invio telematico del file 'Black List'.

[Vecchi elenchi Cli/For - Questo campo viene visualizzato solo in corrispondenza a fatture e note di credito.
Verrà utilizzato dal programma di aggiornamento iva e da quello di Ricalcolo dei progressivi iva clienti e fornitori al fine di poter stampare correttamente gli Elenchi clienti e fornitori.
Va impostato a Si se il documento che si sta registrando è una Nota di variazione registrata nell'anno ma riferita ad anni precedenti.
Esso non si può variare su una registrazione già stampata sul giornale o appartenente ad un anno contabile chiuso.
Se si varia lo stato di questo flag su una registrazione nella quale l'iva è già stata aggiornata, occorre eseguire la funzione di Ricalcolo progressivi iva per elenchi clienti e fornitori per poter avere, tali progressivi, aggiornati correttamente.]

Moneta - Cambio
E' la moneta della registrazione. Viene impostata automaticamente la moneta del cliente o del fornitore della registrazione. Se la causale non prevede la memorizzazione dell'articolo in valuta, se si inserisce un articolo in una valuta diversa da quella di gestione (EURO), esso verrà cambiato automaticamente con il cambio inserito. Viceversa l'articolo verrà memorizzato in valuta, ma stampato sul giornale e conteggiato nei progressivi, nella valuta corrente.

Centro di Costo
In questo campo si può inserire il centro di costo 'unico' al quale imputare la registrazione.
Il centro di costo viene poi ripetuto sui dettagli per cui è possibile assegnare un centro di costo diverso per ogni conto di costo della registrazione.
Se sul conto della riga di dettaglio, c'è il flag di obbligatorietà del centro di costo, il programma non consente di confermare la riga se non è stato inserito il Centro di costo. Di default verrà proposto quello letto sul conto.

Doc. Collegato
In questo campo è possibile inserire il nome (specificando l'indirizzo completo) di un eventuale documento collegato alla registrazione. Il nome del documento si può cercare sul disco con il pulsante posto sulla destra del campo.
Una volta inserito il nome, tornando sulla registrazione, si potrà aprire il documento con un click sulla scritta blu: doc.collegato.
In visualizzazione partitari sarà possibile, quando si è posizionati su una riga,
visualizzare l'eventuale documento collegato, premendo un apposito pulsante.
Nel parametro di personalizzazione DirDocCollegato è possibile definire la cartella che contiene tali documenti.
(Con il parametro MostraDocColl posto a N, è possibile disabilitare dal partitario l'accesso al documento)

In corrispondenza alle registrazioni di fatture emesse direttamente dalla procedura di Fatturazione, viene visualizzato un pulsante "Apri fattura" che consente di entrare direttamente sulla maschera della fattura.

Incasso e pagamento automatico di una fattura: si ottiene confermando i dettagli con il tasto F9 oppure con il pulsante: (F9)Pagamento per Cassa vedi incasso e pagamento immediato.

Gestione dettagli fatture
Gestione dettagli diversi a diversi

Parametri di personalizzazione gestiti da questa funzione:

ContoNegN
Si possono creare più righe (N=0,1,2 etc) con questo parametro e mettere in ogni riga, nel campo Valore, il codice di un conto nel formato: xx-yy-zzzz oppure xxyyzzzz oppure xxyyz (verrà interpretato come xxyy000z).
Durante l'inserimento di articoli in prima nota verrà dato un messaggio se il saldo di uno dei conti in elenco diventa negativo. Oltre a questi conti, il programma controlla comunque sempre il saldo del conto Cassa Contante il cui codice è inserito nella tabella dei conti comuni.

DtRifPag
Se vale 1 il programma mette nella data di registrazione dell'articolo di pagamento per cassa la data del documento e non la data registrazione della fattura di cui si sta registrando l'incasso o il pagamento.

LanCespiti
Se impostato a S al termine della registrazione in Prima nota di una fattura d'acquisto o di vendita (se nella causale c'è la causale cespiti collegata) verrà caricata la gestione Cespiti per consentire di inserire anche lì la registrazione.

ListaOrdin
Per personalizzare l'ordinamento dei campi della lista

NoAccorri
Se impostato ad S, in corrispondenza di registrazioni di corrispettivi con conti diversi di ricavo ma con la stessa aliquota, verranno generati movimenti iva diversi. Se la ditta è in semplificata, il programma si comporta come se il flag fosse sempre ad S cioè non accorpa mai movimenti con la stessa aliquota.

NoInsAutom
Se vale S dopo un inserimento non propone un altro inserimento.

PlafPeriodoDa
Data da usare per calcolare il periodo per il plafond: se vale D è la data documento altrimenti la data registrazione.

NotaVarDataObblig e NotaVarVerEsiste
per note di variazione

MostraDettTmp
Per velocizzare in presenza di molte registrazioni.

SegnAnnoPrec
Se posto uguale a S, nel momento in cui si salva la testata di una registrazione in inserimento, viene chiesta conferma se l'anno della data di registrazione è maggiore dell'anno contabile.


INSERIMENTO DETTAGLI FATTURE

In questa sezione vanno inseriti i conti di costo o di ricavo, per ciascuno va specificato il codice iva, l'imponibile e l'eventuale imposta.

E' possibile, in sede di definizione della causale, definire i conti che verranno proposti in Dare e in Avere.
Inoltre sulla causale, o sui singoli clienti e fornitori, si può definire il codice iva da presentare di default sul dettaglio.

Per passare da una riga ad un'altra, in inserimento, basta digitare il tasto F10 o il pulsante Salva.

Per aggiungere righe a una registrazione già fatta, premere il pulsante Nuovo in alto a sinistra sulla maschera.

Per cancellare una riga, posizionarsi su di essa e premere il pulsante Cancella

Per variare una riga, posizionarsi su di essa, fare la variazione e premere il pulsante Salva

L' iva viene calcolata automaticamente dal programma per cui l'operatore non deve inserire la riga con il conto iva.

Se all'uscita dei dettagli, viene dato un messaggio di squadratura dell'iva cioè di non corrispondenza tra la somma delle imposte calcolate su ogni riga e l'imposta calcolata (per ogni codice iva) sul totale imponibile, si può scegliere di visualizzare il Quadro iva (riepilogo iva per codice iva) [image] e, se i valori inseriti sono corretti, si dovrà mettere a Si il flag di forzatura su una riga dell'aliquota che non quadra.

E' stato abilitato il tasto F6 sul campo imponibile, consente di modificare e uscire dal campo senza ricalcolare l'imposta (in particolare se si sta utilizzando un codice iva con scorporo, non viene ricalcolato lo scorporo)

Il programma consente di inserire, nei dettagli di una fattura, delle righe con codice iva bianco, che si devono compensare tra di loro. Es. in una fattura fornitori si può inserire l'importo della ritenuta di acconto in Dare del fornitore e in avere del conto ritenuta di acconto, in alternativa a registrare prima la fattura poi fare un giroconto.

Incasso e pagamento automatico di una fattura: si ottiene confermando i dettagli con il tasto F9 oppure con il pulsante: (F9)Pagamento per Cassa vedi incasso e pagamento immediato.

In basso a destra viene visualizzato un pulsante Date competenza che consente di accedere a una maschera nella quale si possono inserire il tipo di competenza (giornaliera o mensile , il valore impostato viene preso da quello inserito sul conto) e l'intervallo delle date di competenza di quella riga.

Se si caricano le date di competenza sulle dovute registrazioni, a fine anno sarà possibile calcolare in automatico i Ratei e i Risconti.

Se tali date non vengono inserite in questa fase, possono essere inserite velocemente con l'utility: Variazione periodo di competenza registrazioni

Registrazione di un costo non deducibile
Se si sta registrando una fattura d'acquisto in presenza di certe condizioni descritte in Costi non deducibili
Quando si inserisce la riga di dettaglio con il costo, viene visualizzata l'icona [image] (B) Costo Indeducibile che consente di creare in automatico la riga del costo indeducibile con il relativo importo.

Ritenuta d'acconto
Nell'inserimento di una fattura d'acquisto, se il fornitore prevede la gestione della Ritenuta d'acconto, viene presentata, in ogni riga di dettaglio, una casella nella quale si può dire se quella riga concorre o meno a formare l'imponibile ritenuta. Il suo valore (Si o No) viene letto direttamente dall'anagrafica del conto corrispondente.

Incasso/Pagamento iva ad esigibilità differita
Se nella maschera di testata si mette il numero e la data della fattura che si va a incassare (o pagare) (in numero e data documento), a fianco al campo "Imponibile", viene presentato il pulsante "Importi sospesi" che consente di visualizzare le righe della fattura interessata e che evidenzia quanto resta ancora da incassare/pagare per ogni aliquota.

Bene usato
Se la causale prevede la gestione del regime del margine (cioè si sta inserendo una fattura di acquisto o di vendita di un bene usato) in questo campo va inserito il codice del bene. Serve per poter scrivere sul Registro di vendita dei beni usati la natura del bene. Il documento dovrà necessariamente avere un prefisso abilitato per il Regime del Margine. Nel caso di fattura di vendita, dovrà essere richiamato un codice iva nel quale sia stata valorizzata l'aliquota per il Regime del margine.


INPUT DI PRIMA NOTA (DETTAGLI DIVERSI A DIVERSI)

In questa sezione vanno inseriti i conti che intervengono nell'articolo in Dare o in Avere, ciascuno con il proprio importo.
E' possibile, in sede di definizione della causale, definire i conti che verranno proposti in Dare e in Avere.

Per passare da una riga ad un'altra, in inserimento, basta digitare il tasto F10 o il pulsante Salva.
Per aggiungere righe a una registrazione già fatta, premere il pulsante Nuovo in alto a sinistra sulla maschera.
Per cancellare una riga, posizionarsi su di essa e premere il pulsante Cancella
Per variare una riga, posizionarsi su di essa, fare la variazione e premere il pulsante Salva

Ricerca del conto: per cercare un conto, un cliente o un fornitore per descrizione, occorre digitare come primo carattere della descrizione c (per i clienti), f (per i fornitori), g (per i conti) poi parte della descrizione (ragione sociale) poi F3. Se il testo inserito non inizia per c, f, g, il programma cerca tra i conti.

Pulsante Lista partite: consente di visualizzare l'elenco delle partite aperte del cliente.
Una partita è individuata da codice Cliente/Fornitore, prefisso, numero e data documento.
Il prefisso non viene considerato nell'ordinamento se si imposta a S il parametro di personalizzazione NoUsaPreDoc
Se, sulla maschera, viene impostato un prefisso, un numero o una data documento verranno visualizzate solo le partite relative.
Per velocizzare l'estrazione non viene considerata la moneta delle partite. Se si registrano fatture e incassi/pagamenti in valuta, occorrerà definire il parametro di personalizzazione UsaMonetaInPartite.

Cliccando 2 volte su una riga della lista il programma imposta in automatico sulla riga di prima nota il numero, la data documento e l'importo di quella riga.

Il programma non consente di uscire dal dettaglio se la registrazione non quadra.

Iva per Cassa
Nelle registrazioni di incasso/pagamento in corrispondenza a righe che si riferiscono a documenti su cui è stata applicata l'iva per cassa, indica che questa registrazione verrà considerata nella chiusura iva del periodo per il calcolo dell'iva da versare o a credito.

Pulsante Date competenza, in basso a destra, consente di accedere a una maschera nella quale si possono inserire il tipo di competenza (giornaliera o mensile , il valore impostato viene preso da quello inserito sul conto) e l'intervallo delle date di competenza di quella riga.

Se si caricano le date di competenza sulle dovute registrazioni, a fine anno sarà possibile stampare i Ratei e i Risconti.

Se tali date non vengono inserite in questa fase, possono essere inserite velocemente con l'utility: Variazione periodo di competenza registrazioni


INPUT DI PRIMA NOTA (QUADRO SCADENZE)

Percorso: Contabilità - Prima nota - Input prima nota

Il quadro scadenze viene visualizzato alla conferma della registrazione di una fattura oppure durante la registrazione di un incasso o pagamento di un documento che ha generato scadenze, fatta con una causale nella quale è stato posto a Si il flag 'Aggancio scadenze/partite'

Alla conferma della registrazione di una fattura o premendo il tasto [image] (Z) Gestione scadenzario, dalla testata, se è stata inserita una condizione di pagamento in una registrazione in cui la causale non ne prevede l'obbligo, viene presentato all'utente l'elenco delle scadenze generate.

Le scadenze proposte, si possono confermare con il tasto F10 o uscendo con il pulsante Chiudi, oppure si possono variare, cancellare o aggiungere delle nuove.

Se è stata variata una fattura per la quale le scadenze sono già state generate, occorre premere il pulsante di Rigenera scadenze, per aggiornare le scadenze ai nuovi importi o alla nuova condizione di pagamento.
Se la fattura, di cui si è variata la registrazione in contabilità, esiste in fatturazione ed è stato generato il quadro scadenze sulla stessa, la rigenerazione delle scadenze verrà fatta sulla base di queste e non secondo la condizione di pagamento della testata della registrazione.

Nella colonna in uso, viene evidenziato con un asterisco il fatto che una o più scadenze della fattura in elaborazione sia in uso da un altro utente o sia già stata inserita in una distinta o risulti già pagata (o incassata). Non si consente di modificare le scadenze che risultino 'in uso' e, se almeno una scadenza risulta 'in uso' non si consente di rigenerare.

Durante la registrazione di un incasso (o pagamento), alla conferma della riga di un cliente (o di un fornitore) nella quale è stato messo un numero e data documento di riferimento, viene presentato l'elenco delle scadenze ancora aperte di quel documento con possibilità di chiuderle parzialmente o totalmente, inserendo un importo e modificando lo stato: A=Aperta, C=Chiusa.


INCASSO-PAGAMENTO IMMEDIATO da PRIMA NOTA

Percorso: Contabilità - Prima nota - Input prima nota

Al termine della registrazione di una fattura di acquisto o di vendita (prima di uscire dall'inserimento dei dettagli, conti di costo o di ricavo) è possibile registrare in automatico il relativo pagamento o incasso premendo il tasto F9 sul codice conto in una riga vuota (in pratica si conferma la registrazione con F9 invece che con F10).
In alternativa si può uscire dalla registrazione premendo il pulsante
(F9)Pagamento per Cassa, invece di [image] (H) Chiudi.

A questo punto vengono proposti la causale e il conto inseriti nelle tabelle dei parametri (causali e conti comuni). La registrazione del pagamento o incasso verrà fatta, se confermata, con tale conto e causale.


INSERIMENTO VELOCE CORRISPETTIVI

Percorso: Contabilità - Prima nota

Il programma è stato predisposto per consentire l'inserimento veloce dei corrispettivi di un intervallo di giorni (settimana o mese). I movimenti, una volta inseriti, potranno essere variati con il programma di input prima nota.

Per ogni inserimento (giorno) è possibile digitare, oltre all'importo del corrispettivo, anche l'eventuale importo di Credito Sospeso (cioè corrispettivo non incassato); in questo caso la registrazione registrerà in cassa la differenza tra l'importo del corrispettivo e del corrispettivo non incassato e girerà quest'ultimo al conto Crediti Sospesi che dovrà essere impostato sulla tabella di contabilità (Parametri e utilità - dati generali azienda e parametri).
Sulla stessa tabella occorre inoltre inserire gli eventuali giorni settimanali di chiusura dell'esercizio al fine di evitare la richiesta del corrispettivo per quei giorni.

In testata, come in input prima nota, vengono chiesti i seguenti dati:

Anno Mese Da giorno a giorno
Sono i campi che consentono di determinare la data di registrazione dei corrispettivi. Non si possono inserire corrispettivi con data superiore alla data odierna. Vengono proposti anno e mese corrente e l'intervallo dei giorni è quello dall'inizio del mese al giorno di registrazione.

Per le ditte con l'anno contabile che non coincide con l'anno solare, ci pensa il programma a registrare gli articoli con anno contabile giusto (anno contabile corrente).

Cod. Causale
Si accettano causali di tipo corrispettivo normale o da ventilare.
A seconda della causale che si digita, il programma si predispone a ricevere un certo tipo di dati.
Dalla causale vengono letti i conti di partita e contropartita eventualmente inseriti e il codice iva.

Conto cassa
In questo campo va impostato il codice del conto dare delle registrazioni dei corrispettivi (cassa o cliente corrispettivo).

Prefisso/Numero protocollo - data
Campi obbligatori solo se dichiarati tali sulla causale.
Il prefisso individua il registro iva nel quale i corrispettivi verranno stampati e deve essere una lettera tra quelle impostate in 'Elenco prefissi' nei parametri generali 'Parametri Comuni' .
Se la ditta non utilizza più registri iva, il prefisso verrà impostato a . (punto).
Il numero protocollo viene incrementato in automatico per ogni nuova registrazione creata.

Prefisso/Numero documento - data
Campi obbligatori solo se dichiarati tali sulla causale.

Descrizione aggiuntiva
Campo descrittivo della registrazione che verrà stampato sul giornale bollato.
Se sulla causale è stata impostata una descrizione aggiuntiva, essa verrà riportata automaticamente in questo campo e potrà essere variata o completata.

Descrizione testata
Ulteriore campo descrittivo della registrazione che verrà stampato sul giornale bollato.

Centro di costo
Se inserito verrà riportato su tutte le registrazioni generate.
Con il tasto F10 o con il pulsante Inserisci dettagli si passa ad inserire gli importi giornalieri dei corrispettivi.

A questo punto il programma predispone una griglia con una riga per ogni giorno del mese da inserire.

Nella prima riga vengono proposti: il conto di ricavo, il codice iva (se impostati sulla causale) e il conto corrispettivi sospesi (letto dalla tabella di contabilità).
Se tali codici non vengono compilati automaticamente dovrà essere cura dell'utente compilarli.

L'operatore inserirà l'incasso giornaliero (con iva o senza a seconda del codice iva e della causale inseriti) e, solo se nel giorno il corrispettivo non è stato incassato completamente, scriverà l'importo del mancato incasso nella colonna: importo sospeso.

Per velocizzare l'inserimento, una volta digitato l'importo del corrispettivo, si può passare al giorno successivo premendo il tasto: freccia in giù.

La/e colonna/e F contiene il flag di forzatura dell'imposta e consente, come in prima nota, di forzare l'importo dell'imposta evitando il controllo del programma che ricalcola l'imposta sempre a partire dall'imponibile. Nell'impossibilità di visualizzare il cursore quando è su questo campo, vengono messi in rosso l'indicatore di riga e di colonna.

E' stato abilitato il tasto F6 sul campo imponibile, consente di modificare e uscire dal campo senza ricalcolare l'imposta (in particolare se si sta utilizzando un codice iva con scorporo, non rifa lo scorporo)

Se in uno stesso giorno il corrispettivo va diviso su conti di ricavo o codici iva diversi:
premendo il pulsante Aggiungi colonne Conto/Iva sarà possibile inserire altre colonne in cui mettere codice conto, codice iva e importo del corrispettivo per i giorni che interessano.

Il pulsante: Aggiungi riga giorno consente di aggiungere una riga relativa ad un giorno compreso nel mese di inserimento ma escluso dall'intervallo generato.

Al termine dell'inserimento premendo il tasto F10 o il pulsante Contab. Righe corrispettivi si procede con la generazione delle registrazioni in prima nota.

Verrà generato un articolo per ogni giorno in cui è stato digitato almeno un importo.


PRIMA NOTA EXTRACONTABILE

Percorso: Contabilità - Prima nota

Questa funzione consente di inserire delle registrazioni extracontabili e cioè 'provvisorie' (es. Ratei, Ammortamenti etc.) che non verranno considerate dalla stampa del giornale e dei bilanci.

Sarà tuttavia possibile includere tali registrazioni nella stampa del bilancio di verifica tramite la spunta, nella maschera di stampa, di una voce apposita.

Sono di questo tipo, ad esempio, i movimenti temporanei generati in automatico dalla Contabilizzazione cespiti.

E' consentita la duplicazione delle registrazioni e la cancellazione anche di registrazioni riferite ad anni già chiusi.

L' operatività della funzione è la stessa della Prima Nota 'normale'

Le registrazioni fatte con questa funzione possono essere stampate con il Brogliaccio movimenti e controllate con il Controllo quadratura.
Tramite l'icona [image] è possibile rendere definitiva una registrazione 'provvisoria' passandola sulla prima nota definitiva. Tale trasferimento è consentito SOLO per le registrazioni diverse da fattura.

Spesometro: Se fosse necessario, per casi estremi, includere operazioni che non sono state registrate nell’anno (il riferimento è agli eventuali corrispettivi > 3600€ da segnalare separatamente evidenziando l’anagrafica cliente) si possono fare le registrazioni utilizzando il programma di inserimento Prima Nota extracontabile mettendo il flag di 'Op.Ril.ai fini iva' a Forzato sulla registrazione stessa o sulle causali utilizzate.

Vedi Trasferimento movimenti in Pn definitiva


PRIMA NOTA EXTRAC.- TRASF.MOV. IN PN DEFINITIVA

Percorso: Contabilità - Prima nota - Prima nota extracontabile

Questa funzione consente di rendere definitiva una registrazione inserita nella prima nota provvisoria, passandola sulla prima nota definitiva.
Ad essa si accede dal programma: Prima nota extracontabile.
Quando si è posizionati su una registrazione diversa da fattura, cioè inserita con una causale generica (diversi a diversi) viene abilitata in alto a destra l'icona [image] (K) Contabilizza

Tale trasferimento non è consentito per le registrazioni di tipo fattura.

Prima del trasferimento, viene chiesto all'utente di digitare data ed anno da attribuire alla registrazione sulla prima nota definitiva e al termine, visualizza il numero di registrazione che le è stato attribuito.

Si consente di cancellare la registrazione dalla prima nota provvisoria di o mantenerla, a discrezione dell'utente.


PRIMA NOTA - MOVIMENTI DI APPOGGIO

Percorso: Contabilità - Prima nota

Questa gestione consente di variare o cancellare le registrazioni presenti sulle tabelle di appoggio dei movimenti di contabilità. Queste registrazioni (che non sono ancora definitive cioè non hanno aggiornato i progressivi contabili) possono essere state generate dalla contabilizzazione delle fatture (se nei parametri di fatturazione si è scelto di memorizzare i movimenti generati dalle fatture su archivi di parcheggio) oppure da un caricamento dei movimenti da file esterno che non sia stato completato con la fase di trasferimento in contabilità degli stessi.

Non è permessa la creazione di nuove registrazioni.

Se nei parametri di fatturazione si è scelto anche di generare le scadenze durante la contabilizzazione delle fatture su file di appoggio, variando i movimenti di una fattura potranno essere rigenerate anche le rispettive scadenze.

Le registrazioni gestite con questa funzione, per essere rese 'effettive' dovranno essere trasferite in contabilità con la funzione: Trasferimento in contabilità dei movimenti di fatturazione.

Le funzionalità sono uguali alla Prima Nota 'normale'

Queste registrazioni possono essere stampate con il Brogliaccio movimenti e controllate con il Controllo quadratura.


BROGLIACCIO MOVIMENTI DI PRIMA NOTA

Percorso: Contabilità - Prima Nota - Stampe

Il programma stampa le registrazioni di prima nota in ordine cronologico o di numero di registrazione.

Esso consente di controllare le registrazioni ed individuare eventuali errori che dovranno poi essere corretti richiamando la registrazione interessata dal programma di input prima nota.

Si può scegliere tra diversi tipi di stampa:

  • Registrazioni complete: verranno stampati tutti i dati presenti sui movimenti contabili e iva, sarà possibile stampare i dettagli delle righe iva con l'elenco di imponibile e imposta per codice iva e il quadro scadenze (se la registrazione ha generato scadenze).
    Se è stato scelto l'ordinamento per data registrazione verrà stampato un totale per data e uno finale.
  • Movimenti contabili
  • Movimenti iva
  • Movimenti iva su una riga
    Questa scelta, per la quale viene abilitata una selezione sui codici iva piuttosto che sulle causali, consente di fare una stampa su file excel in modo da ottenere dati utili per la compilazione dei modelli Intra.

E' possibile selezionare quali movimenti stampare dando limiti per data registrazione e protocollo, numero, tipo di registro, causali. E' possibile inoltre selezionare o escludere fino a 7 causali diverse.

Se si digita l'intervallo dei codici conto dei quali si vuole stampare le registrazioni, si può scegliere se stampare tutta le registrazioni oppure SOLO le righe in cui i conti intervengono.

Se si stampano le registrazioni Complete si può scegliere di stampare Solo le registrazioni senza contratto o solo quelle con contratto. E' possibile infine ordinare per codice contratto e data registrazione.

N.B. Al fine di ottenere un elenco delle fatture che concorrono al calcolo dell'iva di un determinato mese o trimestre (sono quelle con data registrazione oppure con anno e mese iva compresi nel mese/trimestre interessato) si può chiedere una stampa compilando SOLO i campi Anno contabile , anno Iva e Mese iva da ... a ... e scegliendo il Tipo Registro (non va compilata la data di registrazione!)


PARTITARI DI PRIMA NOTA (VISUALIZZAZIONE)

Percorso: Contabilità - Prima nota - Visualizzazioni

Il programma permette di visualizzare il mastrino di un cliente, di un fornitore o di un conto con tutti i movimenti registrati in un determinato periodo. E' possibile decidere di visualizzare anche i movimenti fittizi o solo i movimenti fittizi.
A video, le righe dei movimenti fittizi, sono evidenziate con un asterisco (*) che precede il codice causale.

E' possibile personalizzare i dati da visualizzare impostando uno o più modalità di visualizzazione (vedi Stampe parametriche).

Il pulsante [image] consente di stampare i movimenti visualizzati.

Si può scegliere l'anno contabile dei movimenti da visualizzare, l'intervallo delle date di registrazione e un conto o un intervallo di conti (clienti o fornitori).
Se non si specifica niente verranno visualizzati, in sequenza, tutti i mastrini con tutti i movimenti dell'anno.
E' possibile scegliere di visualizzare il saldo dei movimenti al cambio del giorno, di visualizzare solo le registrazioni definitive, solo le extracontabili o entrambe.

na volta inseriti o confermati i parametri di selezione, con il pulsante Estrai si ottiene la visualizzazione dei movimenti.
Cliccando sulle freccette poste a fianco del codice del conto:
(I) Inizio archivio [image] (P) Precedente [image] (U) Successivo [image] (F) Fine Archivio
ci si può spostare sui mastrini nell'intervallo dei conti selezionati..

I movimenti vengono ordinati per data di registrazione, è tuttavia possibile attivare il parametro di personalizzazione Dataop per ordinare per data protocollo.

Una volta visualizzato l'elenco dei movimenti di un conto, se ci si posiziona su una riga che ha un documento collegato (il collegamento di un documento a una registrazione si può fare in inserimento Prima Nota), verrà visualizzato un pulsante "Apri doc.collegato", premendo il quale è possibile visualizzarlo.
Questa funzione si può disabilitare tramite il parametro: MostraDocColl impostato a N

In corrispondenza alle registrazioni di fatture emesse direttamente dalla procedura di Fatturazione, viene visualizzato un pulsante "Apri fattura" che consente di entrare direttamente sulla maschera della fattura.

Significato degli importi riportati alla fine di ogni scheda.
Esempio: Visualizzazione partitari dal 01/07/xx al 31/07/xx

 | Saldo Iniziale | Dare | Avere | Saldo
Fino al 30/06/xx | A1 | A2 | A3 | A4
Dal 01/07/xx al 31/07/xx | B1 | B2 | B3 | B4
 | __________ | __________ | __________ | ______
Dati al 31/07/00 | C1 | A2+B2 | A3+B3 | A4+B4
Tot.registr.anno xx | X1 | X2 | X3 | X4

I campi An : se in tabella di contabilità risulta aperto l'anno precedente allora A1 è il saldo finale dell'anno precedente. A2 e A3 sono la somma dei movimenti dell'anno selezionato con data compresa tra l'inizio dell'esercizio contabile e la data di inizio del periodo da visualizzare.

Viceversa, se l'anno precedente è chiuso, A1 è la somma dei movimenti con tipo causale 'apertura', A2 e A3 sono la somma dei movimenti dell'anno selezionato con data compresa tra l'inizio dell'esercizio contabile e la data di inizio del periodo da visualizzare.

I campi Bn sono la somma dei movimenti del periodo scelto, in particolare B1 è la somma di quelli con causale di tipo 'apertura', se nel periodo richiesto è stata fatta la registrazione dell'apertura dei conti.

I campi nella terza riga di totale sono i progressivi, calcolati dai movimenti, da inizio anno alla data finale dell'intervallo richiesto, con un particolare: il campo C1. Questo, se non è ancora stata fatta l'apertura, contiene il saldo finale dell'anno precedente, se invece è stata fatta l'apertura, anche in una data successiva alla suddetta 'data finale', contiene il saldo iniziale dell'anno in corso.

Infine nell'ultima riga vengono riportati i totali Xn, aggiornati all'ultima registrazione fatta sul conto (letti dai progressivi del conto).

Se è stato impostato il parametro di personalizzazione DataOp, l'ordinamento delle registrazioni in stampa verrà fatto per data protocollo piuttosto che per data registrazione.
NOTA: Se attivo questo parametro e sulle registrazioni manca la data protocollo, esse NON verranno stampate sul giornale.

Altri parametri:
TotReg
consente di impostare automaticamente a SI, a video, la richiesta 'Tot.Reg. cli/for'


PARTITARI DI PRIMA NOTA (STAMPA)

Percorso: Contabilità - Prima nota - Stampe

Il programma permette di stampare i mastrini dei clienti, fornitori o conti con tutti i movimenti del periodo selezionato.

E' possibile personalizzare i dati da stampare impostando uno o più modalità di stampa (vedi Stampe parametriche).

Si può scegliere l'anno contabile dei movimenti da visualizzare, l'intervallo delle date di registrazione e un conto o un intervallo di conti (clienti o fornitori). Se non si specifica niente verranno stampati, in sequenza, tutti i mastrini con tutti i movimenti dell'anno.

E' possibile scegliere di stampare fino a 7 codici di conti diversi, non consecutivi, o escluderli dalla stampa.

Con la scelta Conti in stampa è possibile scegliere se stampare:

  • tutti i mastrini dei conti che soddisfano le selezioni fatte
  • solo quelli con saldo diverso da 0 (si escludono i conti che, pur essendo stati movimentati, hanno saldo a 0)
  • solo quelli con movimenti nell'anno (vengono esclusi i conti che non hanno movimenti nell'anno e, se è aperto l'anno precedente, hanno anche il saldo dell'anno precedente a 0).

Se si sceglie di stampare la descrizione del mastro, questa verrà stampata a fianco della descrizione del conto.

In fondo ad ogni scheda vengono stampati i totali
(vedi Partitari di prima nota - visualizzazione)

Se è stato impostato il parametro di personalizzazione DataOp, l'ordinamento delle registrazioni in stampa verrà fatto per data protocollo piuttosto che per data registrazione.
NOTA: Se attivo questo parametro e sulle registrazioni manca la data protocollo, esse NON verranno stampate sul giornale.

Se è attivo il parametro FidoBudget verrà stampato anche il Fido per i Clienti/Fornitori e il Budget per i Conti.

TotReg
consente di impostare automaticamente a SI, a video, la richiesta 'Tot.Reg. cli/for'


PARTITE (VISUALIZZAZIONE)

Percorso: Contabilità - Prima nota - Visualizzazioni

La funzione consente di visualizzare l'elenco delle partite (aperte o tutte) di un cliente o fornitore.

Il pulsante [image] consente di stampare i movimenti visualizzati.

Per partita si intende l'insieme delle registrazioni fatte in corrispondenza a una fattura e ai relativi incassi (o pagamenti). La partita è individuata da prefisso/numero e data documento (fattura).

Per una corretta gestione delle partite occorre aver compilato correttamente sulle causali contabili il flag di Gestione Partita. Per le fatture esso dovrà essere posto uguale a Apre, per le Note di credito e per gli incassi e pagamenti, a Si riferisce. Inoltre dovrà essere reso obbligatorio l'inserimento di numero e data documento.

Il programma calcola il saldo delle singole partite considerando i movimenti la cui data registrazione e data documento è compresa nell'intervallo di date inserite a video. Pertanto per vedere le partite di un cliente o fornitore dall'inizio occorre cambiare opportunamente le date presentate a video.

E' possibile includere, nel calcolo del saldo della partita, anche le eventuali scadenze appartenenti a distinte già contabilizzate (su conti di appoggio senza aver chiuso il cliente/fornitore) e non ancora effettivamente incassate/pagate.
In questo caso, per ottenere una visualizzazione completa e corretta, occorre chiedere la stampa di TUTTE le partite , anche le chiuse.
In stampa, le righe relative alle scadenze verranno identificate dalla scritta 'Scadenza' nel campo Descrizione causale e 'Dist. zz Scad: gg/mm/aa' nel campo Descrizione aggiuntiva, è necessario quindi che questi campi vengano inclusi tra quelli da stampare.
Se si imposta il parametro di personalizzazione IncludScad a S, nella maschera delle selezioni verrà impostata a Si questa opzione.

In corrispondenza alle registrazioni di fatture emesse direttamente dalla procedura di Fatturazione, viene visualizzato un pulsante "Apri fattura" che consente di entrare direttamente sulla maschera della fattura.

Se si vogliono ordinare i documenti, indipendentemente dal prefisso, si può attivare il parametro di personalizzazione: NoUsaPreDoc


PARTITE (STAMPA)

Percorso: Contabilità - Prima nota - Stampe

La funzione consente di stampare l'elenco delle partite (aperte o tutte) di un cliente o fornitore.

Per partita si intende l'insieme delle registrazioni fatte in corrispondenza a una fattura e ai relativi incassi (o pagamenti). La partita è individuata da prefisso/numero e data documento (fattura).

Per una corretta gestione delle partite occorre aver compilato correttamente sulle causali contabili il flag di Gestione Partita. Per le fatture esso dovrà essere posto uguale a Apre, per le Note di credito e per gli incassi e pagamenti, a Si riferisce. Inoltre dovrà essere reso obbligatorio l'inserimento di numero e data documento.

Il programma calcola il saldo delle singole partite considerando i movimenti la cui data registrazione e data documento è compresa nell'intervallo di date inserite a video. Pertanto per vedere le partite di un cliente o fornitore dall'inizio occorre cambiare opportunamente le date presentate a video.

E' possibile includere, nel calcolo del saldo della partita, anche le eventuali scadenze appartenenti a distinte già contabilizzate (su conti di appoggio senza aver chiuso il cliente/fornitore) e non ancora effettivamente incassate/pagate.
In questo caso, per ottenere una visualizzazione completa e corretta, occorre chiedere la stampa di TUTTE le partite , anche le chiuse.
In stampa, le righe relative alle scadenze verranno identificate dalla scritta 'Scadenza' nel campo Descrizione causale e 'Dist. zz Scad: gg/mm/aa' nel campo Descrizione aggiuntiva, è necessario quindi che questi campi vengano inclusi tra quelli da stampare.
Se si imposta il parametro di personalizzazione IncludScad a S, nella maschera delle selezioni verrà impostata a Si questa opzione.

Se si utilizzano più registri iva vendite o acquisti, è possibile, impostando un prefisso particolare, chiedere di visualizzare SOLO le partite relative ai documenti di un determinato registro iva.

Attraverso il pulsante 'Personalizza la stampa' è possibile impostare stampe personalizzate, includendo i campi messi a disposizione dal programma.

Se si vogliono ordinare i documenti, indipendentemente dal prefisso, si può attivare il parametro di personalizzazione: NoUsaPreDoc

Se è attivo il parametro FidoBudget verrà stampato anche il Fido.


CONTROLLO QUADRATURA

Percorso: Contabilità - Prima Nota - Stampe

Il programma esegue un controllo generale di quadratura sui movimenti, sommando per ognuno di essi nel totale dare o nel totale avere il relativo importo.

Dal controllo vengono esclusi i movimenti già stampati sul giornale bollato.

E' possibile controllare la quadratura di tutte le registrazioni in archivio oppure scegliere quelle comprese in un certo intervallo di numeri o date di registrazione.

Viene segnalato se ci sono registrazioni non ancora stampate su bollato ma con data minore o uguale all'ultima stampata.

  • E' possibile visualizzare il risultato o stamparlo su carta.
    In visualizzazione vengono presentati:
  • Totale Avere
  • Totale Dare
  • Saldo

Nel caso in cui ci siano registrazioni che squadrano vengono visualizzati anche i relativi numeri di registrazione.

Se invece si sceglie la stampa, vengono ugualmente visualizzati i totali dare e avere e il saldo e inoltre, viene stampato l'eventuale elenco di registrazioni che squadrano.

  • Numero registrazione
  • Totale Dare della registrazione
  • Totale Averedella registrazione
  • Saldo


CONTROLLO SALDO CASSA

Percorso: Contabilità - Prima Nota - Visualizzazioni

Il programma consente di visualizzare la prima data di un determinato anno in cui il saldo del conto chiesto a video (viene proposto il conto cassa contante) è minore o uguale dell'importo a video.

In particolare potrà segnalare quando la cassa va sotto zero.


MOVIMENTI EXTRACONTABILI DI CENTRI DI COSTO

Percorso: Contabilità - Servizio - Gestioni

Questa funzione consente di inserire dei movimenti extracontabili, sui vari Centri di Costo gestiti dall'azienda per poterli poi considerare nella Stampa Movimenti per Centro di costo.

Lo scopo è quello di poter inserire dei dati di preventivo o di variazione di preventivo o altro, per ogni centro di costo e conto.

La stampa terrà conto di questi movimenti, oltre ai movimenti inseriti da prima nota sui vari centri di costo e darà un risultato di Maggiore o Minor spesa a seconda che la differenza tra Costi e Ricavi sia positiva o negativa.


BILANCIO DI VERIFICA

Percorso: Contabilità - Prima Nota - Stampe

Questo programma consente di stampare il bilancio a partite contrapposte o verticale, anche su carta uso bollo.

Se richiesto a video e se si stampano i progressivi dai movimenti (da data registrazione .. a data registrazione …) è possibile:

  • includere, nel calcolo del saldo del periodo, anche i movimenti inseriti con la prima nota extracontabile
  • stampare il bilancio per competenza (cioè tenendo conto delle date di competenza inserite sulle registrazioni).
    Per il calcolo dei saldi dei conti con movimenti con date di competenza, si considerano SOLO gli importi di competenza del periodo richiesto, indipendentemente dalla data di registrazione dei movimenti.
    Se si chiede il bilancio dall' 1/1 al 30/3 verranno considerati gli importi di tutti i movimenti con data registrazione compresa tra gli estremi e senza date di competenza, poi tutti i movimenti le cui date di competenza hanno un intervallo interno alle due date suddette (il loro importo verrà considerato solo per la parte di competenza).

    Se l'anno precedente risulta aperto, si chiede anche:
    Considero competenza anno precedente / successivo
    Se vengono spuntate queste opzioni, pur avendo chiesto il bilancio di un certo periodo di un anno, si terrà conto anche delle registrazioni dell'anno precedente o successivo che hanno competenza nel periodo richiesto.
  • includere il saldo anno precedente dei conti patrimoniali e d'ordine, in caso di anno precedente ancora aperto.
    In queste condizioni però manca la registrazione dell' utile o della perdita che viene comunque calcolata e stampata nella sezione apposita con un codice conto fittizio: "Z*Z*****" altrimenti il bilancio non risulterebbe corretto.

Selezione del Centro di Costo: La funzione consente di stampare SOLO i progressivi appartenenti a conti (se fatto dalle sintesi) o a righe di registrazioni (se fatto dai movimenti) sui quali sia stato inserito il Centro di Costo impostato a video.
In particolare, se si imposta un codice di Centro di Costo nella stampa da Sintesi, non verranno stampati gli importi relativi ai mastri clienti e fornitori ma solo quelli dei conti (La giusta impostazione dei dati per ottenere una stampa per CdC corretta , da Sintesi, è mettere il codice cdc direttamente sui conti economici. In questo modo verrà stampata solo il conto Economico rilevando l'utile o la perdita del cdc interessato.
Vedi anche Situazione Conti per Centro di Costo

Per la spiegazione delle varie scelte proposte a video si rimanda a Situazioni contabili - note operative.


SITUAZIONI CONTABILI - NOTE OPERATIVE

Le stampe delle situazioni contabili e bilanci richiedono un tempo di elaborazione variabile a seconda del numero di movimenti e di conti da esaminare. Per consentire un risparmio di tempo a chi deve ripetere la stessa stampa semplicemente con qualche parametro diverso, viene mantenuta in memoria l'ultima elaborazione e si da la possibilità di riutilizzarla.

L'operatore può decidere di assegnare una descrizione all'elaborazione in modo da capire, successivamente, se può riutilizzarla o meno.

Ovviamente ha senso riutilizzare l'elaborazione precedente solo se nel frattempo non sono stati variati i dati su cui si basa la stampa: sintesi e movimenti.

Scegliendo di utilizzare l'elaborazione precedente, sarà possibile variare solo qualcuno dei parametri di selezione impostati, a seconda del tipo di situazione che si va a stampare.

Situazione contabile generale
Si può variare il tipo di ordinamento e il fatto di stampare tutto o solo mastri e gruppi. Il tipo di stampa si può variare solo se prima era stato scelta la situazione generale, viceversa, se ne era stata scelta una particolare, non è consentito variarlo.

Situazione contabile clienti-fornitori
Si può variare: il tipo di stampa (sintetica o analitica) , il fatto che la stampa sia continua o meno e gli ordinamenti.

Situazione costi per centro di costo
Si può variare: il tipo di stampa (sintetica o analitica) e il fatto che la stampa sia continua o meno.

Significato delle selezioni:

Tipo di stampa
sintetica: viene stampato solo il saldo; analitica: dare, avere e saldo.

Stampa continua
se NO, verrà fatto un salto pagina a cambio di centro di costo.

Selezione conti

  • Tutti
  • Solo quelli con saldo diverso da 0 (si escludono i conti che, pur essendo stati movimentati, hanno saldo a 0)
  • Solo quelli con movimenti nell'anno (vengono esclusi i conti che non hanno movimenti nell'anno e, se è aperto l'anno precedente, hanno anche il saldo dell'anno precedente a 0).

Stampa progressivi
Questa scelta ha priorità sull'intervallo di date selezionate. In particolare, se si lasciano bianche le date il programma stamperà i progressivi delle sintesi o dei movimenti a seconda di quanto si sceglie qui. Le possibilità sono:

  • Attuali: si stampano i progressivi aggiornati all'ultima registrazione inserita, letti dalle sintesi contabili
  • Solo progressivi del periodo: si calcolano i progressivi leggendo i movimenti con data di registrazione compresa tra quelle digitate
  • Progressivi del periodo e progressivi attuali: comprende entrambe le scelte precedenti

Escludere la causale bilancio di chiusura
Consente di stampare il bilancio anche dopo aver fatto la chiusura di un anno contabile. Se impostato a Si verranno esclusi dal conteggio i movimenti fatti con causale di chiusura.

Compreso anno precedente
Questa opzione compare solo se l'anno precedente è ancora aperto
Indica se la stampa deve presentare nel saldo iniziale il saldo dell'anno precedente. Per il solo Bilancio di verifica, non verranno riportati sul nuovo anno i saldi anno precedente degli economici ma solo quelli dei patrimoniali e dei conti d'ordine. In queste condizioni però manca la registrazione dell' utile o della perdita che viene comunque calcolata e stampata nella sezione apposita con un codice conto fittizio: "Z*Z*****" altrimenti il bilancio non risulterebbe corretto.

Dati in stampa
I dati stampati sono i seguenti:
Codice (conto, mastro o gruppo).
Descrizione
Dare Periodo \
Avere Periodo > solo se ha scelto la stampa dai movimenti
Saldo Periodo /

Saldo iniziale\
Dare \
Avere / solo se ha scelto da sintesi o entrambi
Saldo /

Elaborando i movimenti, non si tiene conto di quello di apertura in modo particolare ma lo si somma nel Dare o nell'Avere a seconda del segno.


SITUAZIONE CONTABILE

Percorso: Contabilità - Prima Nota - Stampe

Il programma stampa la situazione dei conti e dei mastri esistenti con l'indicazione dei progressivi dare, avere e saldo.

E' possibile stampare i saldi dei soli gruppi e mastri o di gruppi, mastri e conti, aggiornati all'ultima registrazione inserita o calcolati dai movimenti registrati in un certo intervallo di date.

Non viene stampato il dettaglio dei clienti e fornitori ma solo il relativo gruppo e mastro con i progressivi che sono la somma di quelli dei vari clienti e fornitori.

Centro di Costo
Verrà considerato SOLO se si stampa dai movimenti, in questo caso verranno considerati solo i movimenti con questo centro di costo.

Ordinamento
Sono possibili due tipi di ordinamento
Per tipo (Patrim./Econom./d'Ordine), natura (Attività, Passività, Costi, Ricavi, a Saldo) e codice
Per codice conto
L'ordinamento per codice conto ha effetto solo se si stampa la Situazione generale.

Tipo di stampa
Situazione contabile generale (con tutti i conti)
Situazione contabile economica (con i soli conti economici: Costi e Ricavi)

In fondo alla stampa viene evidenziato il totale a pareggio (utile o perdita) calcolato come somma tra il saldo dei costi e quello dei ricavi.

Situazione contabile patrimoniale (con i soli conti patrimoniali: Attività e Passività). Al termine della stampa viene riportato il totale a pareggio (utile o perdita) calcolato come somma tra il saldo delle Passività e quello delle Attività.

NOTA BENE:

Se i dati elaborati sono corretti i due totali a pareggio (economico e patrimoniale) saranno uguali e di segno opposto.

Per altre spiegazioni si rimanda a Situazioni contabili - note operative.


SITUAZIONE CONTABILE CLIENTI-FORNITORI

Percorso: Contabilità - Prima Nota - Stampe

Il programma esegue la stampa dell'elenco dei clienti o dei fornitori, riportando per ciascuno il solo saldo o i progressivi saldo iniziale, dare e avere calcolati dai movimenti di un certo periodo o letti dalle sintesi.

E' possibile stampare solo i clienti a Rischio e operare selezioni per agente, saldo compreso tra due valori etc.

Si può scegliere la modalità di ordinamento delle anagrafiche in stampa: per codice, per ragione sociale, per mastro, per mastro e ragione sociale.

Si possono inoltre creare dei raggruppamenti ulteriori: per Zona, Categoria, Agente 1 e 2, Attributi.
All'interno di questi raggruppamenti verrà applicata la modalità di ordinamento richiesta.
Se è stato scelto l' ordinamento per Zona o Categoria etc. verranno stampati i totali a cambio di codice, viceversa se non è stato scelto nessun ordinamento verranno stampati i totali a cambio di mastro, se selezionato come ordinamento secondario.

Se è attivo il parametro FidoBudget verrà stampato anche il Fido.

E' possibile includere, nel calcolo del saldo, anche gli importi delle eventuali scadenze appartenenti a distinte già contabilizzate (su conti di appoggio senza aver chiuso il cliente/fornitore) e non ancora effettivamente incassate/pagate.
Se si imposta il parametro di personalizzazione IncludScad a S, nella maschera delle selezioni verrà impostata a Si questa opzione.

Per la spiegazione delle varie scelte proposte a video si rimanda a Situazioni contabili - note operative.


SITUAZIONE CONTI PER CENTRO DI COSTO

Il programma esegue la stampa dei progressivi (saldo iniziale, dare e avere) dei conti con centro di costo valorizzato.
N.B. Non si tiene conto del Centro di Costo eventualmente inserito nelle registrazioni di prima nota (vedi Stampa movimenti per CdC) MA SOLO di quello messo sui conti.

I conti vengono ordinati per centro di costo e codice (si escludono quelli con centro di costo bianco).

Se è stato messo un codice di centro di costo sui mastri clienti e fornitori, verrà stampato anche il saldo di tali mastri.

Al cambio di centro di costo viene stampato il saldo ed è possibile scegliere di fare un salto pagina.

Le scelte possibili sono le stesse della situazione contabile, si può utilizzare l'ultima elaborazione solo se non sono state fatte variazioni sui dati dalla sua esecuzione.


STAMPA MOVIMENTI PER CENTRO DI COSTO

Percorso: Contabilità - Prima nota - Stampe

Questa stampa consente di ottenere un resoconto per Centro di Costo e Conto di costo/ricavo tenendo conto dei CdC inseriti nelle registrazioni di Prima Nota e, a richiesta, dei movimenti extracontabili inseriti con la Gestione movimenti extracontabili di Centri di Costo (menu di servizio di contabilità)

Nella forma dettagliata verrà dato un risultato di Maggiore o Minor spesa a seconda che la differenza tra Costi e Ricavi sia positiva o negativa.

Tramite l'impostazione del parametro di personalizzazione StaAncheMov=S è possibile impostare a Si l'opzione che, nella maschera delle scelte di stampa, consente di includere anche i movimenti extracontabili.

In stampa i movimenti vengono ordinati per Centro di costo, conto (costo), contropartita (fornitore) e data documento.


GESTIONE SCADENZE

Percorso: Contabilità - Scadenzario

Il programma consente di variare le scadenze degli incassi/pagamenti generati dalla registrazione delle fatture in input prima nota e/o dalla contabilizzazione delle fatture di vendita. Le scadenze vengono generate secondo quanto specificato nella condizione di pagamento inserita sul documento.

Con questa funzione è inoltre data la possibilità di inserire nuove scadenze, compilando manualmente tutti i dati.

La ricerca delle scadenze può essere fatta digitando uno qualsiasi dei campi presenti sul video e premendo il pulsante di ricerca.
Fare attenzione all' impostazione del campo Entrata/Uscita, esso va impostato a:

  • E - fattura cliente / nota credito fornitore (l'importo è sempre positivo)
  • U - fattura fornitore / nota credito cliente (l'importo è sempre positivo)

Se si cercano tutte le scadenze di un particolare cliente e si digita il suo codice, occorre sbiancare (prima di fare la ricerca) il campo banca e, premendo il tasto Canc oppure il pulsante destro del mouse su tali campi, rendere grigio il flag Raggruppo Ricevute Bancarie e sbiancare Entrata/Uscita

Una scadenza è considerata "chiusa" quando ha la data e il numero dell'articolo di pagamento nel quadro Dati incasso/pagam.

Nella maschera 'Dati incassi/pagamenti' è possibile inserire manualmente i due campi: CIG (Codice Identificativo di Gara) e CUP (Codice Unico di Progetto) che verranno poi riportati sul record 50 del file delle Ri.Ba.
Nel D.L. 187/2010 è stato previsto che su tutti gli strumenti di pagamento utilizzati per le transazioni relative a lavori, servizi e forniture pubbliche, debba essere sempre indicato il codice CIG (10 caratteri). Tale codice è attribuito dall'Autorità di Vigilanza sui Contratti Pubblici di lavori, servizi
e forniture, su richiesta della Stazione Appaltante.
Sui predetti strumenti di pagamento dovrà essere indicato anche il codice CUP (15 caratteri) solo nel caso di operazioni relative a progetti di investimento pubblico di cui all’articolo 11 della Legge 16 gennaio 2003, n. 3.

Da input prima nota:
Se la causale con cui si registra una fattura prevede l'obbligo della condizione di pagamento, alla conferma della registrazione verrà presentato il quadro delle scadenze da confermare, altrimenti queste ultime verranno generate solo se, sulla testata della fattura è stata messa una condizione di pagamento e se l'utente, una volta registrata la fattura, richiamerà il quadro scadenze, con l'icona [image] (Z) Gestione scadenzario e cliccherà sul pulsante rigenera.

Scadenze di Note di CREDITO
Le eventuali scadenze registrate in corrispondenza di note di credito saranno caratterizzate da importo sempre positivo e il campo Entrata/Uscita impostato a U se nota credito Cliente o a E se nota credito Fornitore.
Nel caso di coincidenza della scadenza di una fattura e di una nota credito, è possibile compensarle in distinta. Occorre creare il parametro di personalizzazione: RaggFtNc e mettere sulle scadenze interessate il campo 'Raggruppa Ric.Ban. in distinta' a Si.


AGGIORNAMENTO BANCHE IN SCADENZE

Percorso: Contabilità - Scadenzario - Gestioni

Questa funzione consente di memorizzare su tutte le scadenze aperte di un cliente o di un fornitore, la banca che è scritta nella rispettiva anagrafica.

Serve nel caso il cliente comunichi un cambio di banca quando ci siano in archivio delle sue scadenze ancora aperte.


CONFRONTO SALDO SCADENZE E SALDO CONTABILE

Percorso: Contabilità - Scadenzario - Stampe

Il programma consente di fare due tipi di stampe diverse:

  • Controllare, per uno o più clienti (o fornitori), se l'importo totale delle scadenze aperte coincide con il saldo contabile. Verrà poi stampato l'elenco dei nominativi per cui questo non si verifica, con l'evidenza dei due saldi.
  • Calcolare il saldo contabile, il saldo delle scadenze che risultano in distinte contabilizzate senza chiudere il cliente e non ancora incassate e il saldo finale (scelta inserita per chi è in regime di iva per cassa)

Per preimpostare la scelta, si può valorizzare il parametro di personalizzazione: StSaldoDist

Si chiede all'operatore di scegliere un intervallo di clienti o fornitori sui quali fare il controllo.

Se risulta aperto l'anno precedente, nel calcolo del saldo si terrà conto anche di questo.


CANCELLAZIONE SCADENZE

Percorso: Contabilità - Scadenzario - Gestioni

Questa funzione consente di cancellare fisicamente le scadenze. Sono state predisposte diverse selezioni sulle scadenze.

  • Tutte le scadenze fino ad una cera data di scadenza (con possibilità di scegliere solo le chiuse, solo quelle clienti etc.)
  • Tutte le scadenze di una determinata distinta. La distinta deve essere stata contabilizzata.

  • Tutte e sole le scadenze che hanno una determinata condizione di pagamento.

Se si desidera cancellare tutte le scadenze di una distinta, basta digitare il numero della distinta, viceversa occorre digitare la data di scadenza fino alla quale cancellare e specificare quali scadenze.

Sarebbe bene eseguire questa funzione periodicamente, in modo da ridurre il numero di scadenze in linea e velocizzare le elaborazioni sulle scadenze. Successivamente alla cancellazione si consiglia di eseguire un compattamento del database dal Menu: parametri e utilità - Utilità.


SALDACONTO

Percorso: Contabilità - Effetti

Questa funzione consente di registrare in prima nota, in automatico, articoli di Pagamento o Incasso a partire dalle scadenze memorizzate in archivio e di conseguenza di chiudere le scadenze stesse e le partite.

Viene data la possibilità di selezionare le scadenze da esaminare tramite la richiesta di una serie di parametri.

Successivamente vengono visualizzate tutte le scadenze che soddisfano tali parametri e si consente di selezionare quelle pagate o incassate completamente o parzialmente.

Parametri di personalizzazione gestiti da questa funzione:
DescAgg
Questo parametro può contenere una scritta (es. Scadenza del: ) alla quale verrà aggiunta la data scadenza, il tutto verrà memorizzato sulle righe, relative al cliente, dell'articolo di prima nota generato dal saldaconto.

Tipo pagamento
Tipo di pagamento da elaborare.
Se viene lasciato il campo vuoto verranno considerati tutti i pagamenti.

Anche effetti
Questo campo non viene chiesto se è stato selezionato un particolare tipo di pagamento, altrimenti consente di decidere se considerare o meno, tra le scadenze da visualizzare, quelle derivate da effetti.

Moneta e Cambio
Verranno estratte solo le scadenze con la moneta indicata.

Importo massimo
Massimo importo utilizzabile nell'elaborazione.
Durante la selezione viene segnalato in alto su video il totale degli importi delle scadenze selezionate e l'importo residuo calcolato rispetto al valore inserito in questo campo.

Tipo elaborazione

  • Interattiva: l' utente può selezionare, una per una, le scadenze pagate o incassate.
  • Automatica: il programma genera la registrazione contabile e quindi chiude tutte le scadenze che soddisfano le condizioni inserite nella maschera principale.

I dati chiesti successivamente sono quelli che caratterizzano le registrazioni che verranno fatte in automatico dal programma una volta che l'utente conferma le scadenze selezionate. Alcuni di questi sono obbligatori.

Causale incasso/pagamento
Se è stato scelto precedentemente un tipo di pagamento viene proposta la causale letta da tale tabella altrimenti quella letta dalle causali comuni (Dati generali azienda) come Incassi o Pagamenti per saldaconto a seconda che si stiano elaborando scadenze di clienti o di fornitori.

ATTENZIONE: non è possibile registrare con questa funzione l'incasso o il pagamento di una fattura con iva ad esigibilità differita. Queste registrazioni vanno fatte da prima nota in quanto non sono semplici incassi (pagamenti) ma il programma dovrà fare in automatico anche un giroconto tra i conti iva ad esigibilità differita ad iva vendite.

Contropartita pagamento
Se è stato scelto precedentemente un tipo di pagamento viene proposta quella letta da tale tabella altrimenti viene proposto il conto di partita (se incassi) o contropartita (se pagamenti) della causale inserita in precedenza.

Descrizione aggiuntiva
Se impostata, verrà scritta sull'articolo generato.

Codici conti sconto/abbuono attivo e passivo
Sono i codici che verranno utilizzati per la registrazione degli abbuoni attivi o passivi che si verranno eventualmente a generare chiudendo le scadenze.
Vengono proposti quelli impostati nella tabella dei Conti Comuni (dati generali azienda).

Data registrazione-anno
Viene proposta la data del giorno, con possibilità di variarla.

Numero e data protocollo
Sono obbligatori se la causale digitata in precedenza ha il segnale di obbligo numero e data protocollo oppure se, nei parametri di personalizzazione, si è scelto di ordinare il giornale per data documento piuttosto che per data registrazione (flag Dataop).

Conti utile - perdita su cambio
Verranno utilizzati nel caso di scadenze in moneta diversa da quella corrente per la generazione degli articoli che vanno a compensare gli utili o le perdite su cambio.
Alla conferma vengono visualizzate le scadenze attive che soddisfano i parametri di selezione.

Per selezionare le scadenze da chiudere, posizionarsi nella colonna Incasso, sulla riga desiderata e con un click far comparire l'importo, se la scadenza va chiusa completamente, oppure digitare l'importo desiderato e, nella colonna, Stato, confermare o variare la C di Chiusa o la A di Aperta per la differenza.

  • Se si conferma l'importo della scadenza, come importo pagato, la scadenza viene considerata chiusa.
    N.B. Nel caso di scadenza negativa generata da una nota di credito (parametro di personalizzazione: NotaCredInvSegno) è assolutamente obbligatorio che l'importo della colonna incasso sia anch'esso negativo.
  • Se l'importo digitato è MINORE di quello della scadenza, questa potrà essere ugualmente considerata chiusa o restare aperta per la differenza. Se va CHIUSA, il programma calcola l'abbuono e lo evidenzia nella colonna apposita.
  • Se l'importo digitato è MAGGIORE di quello della scadenza, al momento della registrazione in prima nota dell'articolo di incasso/pagamento, verrà generata anche una riga di sconto attivo (se cliente), passivo (se fornitore).
  • Se l'importo di incasso/pagamento viene impostato a 0 la scadenza viene deselezionata.

E' possibile visualizzare i dati completi della scadenza su cui si è posizionati premendo il pulsante Visualizza.

Con il pulsante Annulla si può uscire dall'elaborazione in qualsiasi momento annullando le selezioni fatte.

Uscendo con il pulsante Esci si confermano le scadenze selezionate e verranno generati in automatico gli articoli di incasso/pagamento in contabilità.


DISTINTA EFFETTI

Percorso: Contabilità - Effetti - Gestioni

Il programma consente di Creare, Variare o Annullare una distinta contenente un elenco di effetti (scadenze) da presentare alla banca.

Condizione essenziale perchè un effetto possa essere selezionato per l'inserimento in distinta è che il suo tipo di pagamento abbia il campo emissione effetti impostato a Si.

Nel caso di coincidenza della scadenza di una fattura e di una nota credito, è possibile compensarle in distinta. Occorre creare il parametro di personalizzazione: RaggFtNc e mettere sulle scadenze interessate il campo 'Raggruppa Ric.Ban. in distinta' a Si.

Impostando il parametro di personalizzazione: NotaCredInvSegno con valore S le scadenze delle note di credito Clienti verranno create in Entrata con importo negativo (quelle fornitori in Uscita negativa). Se si assegna al parametro il valore T , oltre a creare le scadenze come appena detto, si metterà su tutte le scadenze create il flag Raggruppa Scadenze a S (Il raggruppo scadenze è la condizione necessaria perchè in distinta le due scadenze si compensino)

Una volta generata la distinta potranno essere fatte le successive elaborazioni di:
stampa distinta, generazione file RIBA, contabilizzazione.

NON vengono presentati, per essere inseriti in distinta, le scadenze generate da Note di credito, nemmeno se è stato scelto il raggruppo degli effetti per un certo cliente. In questo caso dovrà essere l'operatore a richiamare una scadenza di una fattura e decrementare l'importo di una quantità pari all'importo della nota di credito.

Ne segue che si può fare una distinta non solo per le scadenze relative a ricevute bancarie ma anche per quelle di rimesse dirette o altri tipi di pagamento.

Si possono fare delle distinte anche con scadenze di fornitori, stamparle e contabilizzarle.
Per poter invece chiudere le stesse scadenze con il saldaconto, occorre cancellare la distinta una volta stampata.

Il programma presenta un elenco di scadenze che soddisfano i parametri inseriti nella maschera iniziale e che non sono ancora state inserite in nessuna distinta.
E' possibile impostare nei parametri di personalizzazione il parametro: SaldPortaf con valore S. In questo caso le scadenze verranno prima chiuse manualmente a portafoglio con il saldaconto e in distinta verranno presentate SOLO quelle già chiuse. In questo caso non verrà mai dato il messaggio di distinta già contabilizzata. La contabilizzazione della distinta dovrà, in questo caso, fare il movimento Portafoglio o Clienti.

Ricerca distinta
Sul campo Numero distinta è possibile effettuare ricerche di vario tipo, verrà visualizzato l'elenco delle scadenze che soddisfano i parametri e basta selezionarne una per entrare in quella particolare distinta.

Se si digita direttamente il numero distinta, il programma la cerca tra quelle generate nell'anno della data di emissione scritta a video sotto al numero distinta.
Per elencare tutte le distinte, occorre sbiancare il campo Data (o Anno) distinta prima di fare la ricerca.

Tasti di Help attivi sul numero distinta: sono stati abilitati i seguenti tasti che, digitati sul campo bianco, provocano la visualizzazione dell'elenco delle scadenze in distinte, ordinate a seconda del tasto scelto. Le scadenze che verranno elencate, nei vari casi, saranno quelle appartenenti a distinte generate nell'anno della data emissione scritta a video. Se non si vuole questa restrizione, basta sbiancare questa data.

  • F2 fa l'elenco delle scadenze (già inserite in una distinta) ordinate per Anno, data e numero distinta
  • F3 fa la ricerca delle scadenze (in distinta) per codice Banca d'appoggio
  • F4 fa la ricerca delle scadenze in (distinta) per descrizione Banca d'appoggio
  • F5 fa la ricerca delle scadenze in (distinta) per codice cliente o fornitore (codice completo, es. 03010001)
  • F6 fa la ricerca delle scadenze in (distinta) per descrizione cliente o fornitore

Se invece si digita rispettivamente, un numero distinta, un codice o una descrizione banca, un codice o descrizione cliente/fornitore e si preme uno dei tasti funzione suddetti, si ottiene un elenco che contiene le scadenze relative al solo campo cercato.

La ricerca viene fatta con le condizioni opportune a seconda della funzione:

  • la Gestione distinta cerca le scadenze in cui è compilato il numero distinta.
  • la contabilizzazione distinta cerca le scadenze appartenenti a distinte non ancora contabilizzate
  • la Gestione incassi effetti in distinta cerca le scadenze in cui è compilato il numero distinta, la data dell'articolo di contabilizzazione distinta e senza Anno di Incasso

Per aggiungere altri campi a quelli visualizzati nell'help, basta attivare il parametro di personalizzazione ScadenzeCampi con valore: elenco dei campi da visualizzare preceduti e separati dalla virgole (es.,AnnoPag,NumRegPag per anno e numero registrazione di contabilizzazione distinta)

Numero distinta
In creazione di una nuova distinta, questo campo va lasciato bianco, sarà il programma ad assegnare il numero progressivo della distinta a partire da quello memorizzato in tabella Caratteristiche esercizio di contabilità (da Contabilità - Servizio)
Variazione: se si digita il numero di una distinta esistente il programma consente di visualizzarla.
Se la distinta richiesta non è contabilizzata, si consente di aggiungere effetti, di cancellare degli effetti o di cancellare la distinta stessa.
In questo caso, non occorre compilare tutte le selezioni, perché vengono impostate automaticamente in base ai dati della distinta richiamata (questo per far si che se si vogliono successivamente aggiungere effetti a una distinta già esistente, le selezioni per estrarre nuove scadenze siano compatibili con le precedenti).
Se la distinta è già stata contabilizzata, si consente SOLO la visualizzazione.
Per poter effettuare le altre operazioni è necessario cancellare l'articolo di prima nota generato dalla contabilizzazione.

Annulla la distinta

Il programma esegue l'annullamento della distinta togliendo da tutti gli effetti della distinta il numero, la data distinta e il codice banca di presentazione. Se il numero della distinta è uguale a quello indicato nella tabella di contabilità, esso viene riportato indietro automaticamente.

Elimina una o più scadenze

Vengono visualizzate le scadenze della distinta e dà la possibilità di cancellare gli effetti selezionati: viene cioè tolto sull'effetto il numero, la data distinta e il codice banca di presentazione. Se vengono eliminate tutte le scadenze, viene controllato anche il numeratore come per la cancellazione della distinta ed eventualmente riportato indietro.

Codice della banca/abi di presentazione
Campo obbligatorio nel caso di creazione di una nuova distinta
E' il codice della banca alla quale verrà presentata la distinta.
Deve esistere nell'archivio banche e deve avere il campo codice contabile valorizzato con il conto della banca sul quale si appoggia la distinta.
NB.
La ricerca della banca è possibile anche inserendo il codice ABI e confermando con il tasto F9.
Non essendo questa una chiave, la ricerca avviene su tutto l'archivio banche in modo sequenziale e può pertanto risultare lenta. Il dato inserito può essere anche parziale.

Data di emissione
Data di presentazione della distinta.

Tipo di elaborazione

  • Automatica
    verrà creata automaticamente la distinta con tutti gli effetti che soddisfano le selezioni fatte dall'operatore. Questo tipo di elaborazione può essere scelto anche con l'opzione AGGIUNGI ad una distinta già esistente.
  • Interattiva
    verranno proposti i vari effetti e sarà l'operatore a selezionarli.

Tipo di pagamento
Campo obbligatorio in fase di creazione distinta.
Viene proposto quello inserito nei parametri generali in Dati Riba.
Viene controllato, nell'archivio dei tipi pagamento, che per il codice digitato sia stata prevista l'emissione degli effetti.

Importo massimo
Campo obbligatorio. Indica l'importo massimo della distinta.

Una volta terminate le selezioni, se è stata scelta l'elaborazione automatica, verrà creata la distinta senza intervento dell'operatore.

Se invece è stata scelta l'elaborazione manuale, verranno visualizzate tutte le scadenze attive comprese nei parametri, proposte secondo l'ordine richiesto.

Per selezionare / deselezionare le scadenze, occorre fare click con il mouse sulla 1a colonna (cioè assegnare il numero distinta). Se si fa un click in corrispondenza delle altre colonne, si seleziona la scadenza in modo da poterne visualizzare tutti i dati per esteso tramite il pulsante VISUALIZZA.

Con il pulsante "ESCI" si termina la selezione confermando la distinta impostata.

Viceversa con il pulsante "Annulla" si annulla e si torna alla maschera iniziale.

Su ogni scadenza selezionata, vengono memorizzati:

  • il numero e la data distinta
  • il codice della banca di presentazione

Per cancellare la registrazione di una fattura in prima nota (o decontabilizzare una fattura da Vendite) è necessario che le sue scadenze non siano state inserite in una distinta. Vedi Nota.


DISTINTA (STAMPA)

Percorso: Contabilità - Effetti - Stampa

Il programma consente di stampare le distinte precedentemente inserite con l'apposita funzione.

In stampa verranno elencate tutte le scadenze presenti in distinta.
E' possibile ordinare le scadenze per data scadenza o per Ragione sociale cliente (fornitore)
Totale per data scadenza/cliente: spuntando questo campo si otterrà un totale delle scadenze di un cliente a parità di data scadenza, se è stato scelto di ordinare per data scadenza, oppure un totale di tutte le scadenze di un cliente se si ordina per Ragione Sociale.

Le scadenze di uno stesso cliente che hanno la stessa data di scadenza e il flag di raggruppato a Si, verranno raggruppate su una sola riga.

Se si esegue la stampa su stampante ad aghi, occorrerà impostare il numero colonne a 150 e stampare in compresso altrimenti non verranno stampati ABI e CAB.

E' possibile spedire le riba ad un indirizzo diverso da quello scritto sull' anagrafica clienti, inserendo il parametro di personalizzazione: IndirRiba

Esiste un parametro Gruppo: Distinta - Parametro: StaCUPCIG che se contiene il valore S preimposta a selezionato l'opzione per la stampa dei valori CIG e CUP.


CONTABILIZZAZIONE DISTINTA

Percorso: Contabilità - Effetti - Elaborazioni

Con questa funzione si genera in automatico l'articolo (o gli articoli) di prima nota relativi alla distinta selezionata.

Vengono elaborate tutte le scadenze, con numero e data distinta uguali a quelli digitati, che non hanno già la data pagamento valorizzata.
Quest'ultimo controllo viene fatto se non è attivo il flag saldoportaf , nei parametri di personalizzazione.

NOTA:
In caso di interruzione dell'elaborazione, è indispensabile eseguire subito il ripristino della contabilizzazione della distinta (dal menu Contabilità - Ripristini) prima di lanciare un'altra elaborazione.

Dopo che la distinta è stata contabilizzata, se ne consente SOLO la visualizzazione.
Per poter effettuare le altre operazioni è necessario cancellare l'articolo di prima nota generato dalla contabilizzazione.

E' possibile cercare il numero distinta tra quelle non ancora contabilizzate utilizzando i pulsanti come descritto in Ricerca distinta.

Una volta digitato il numero distinta viene visualizzata la Data di presentazione, la banca e la moneta.

Causale Contabile
Viene proposto il codice causale presente nella tabella del tipo pagamento delle scadenze in distinta e può essere modificata dall'operatore.
Se la distinta è in moneta corrente, la causale non può avere il flag 'in valuta' attivo viceversa una scadenza in valuta va contabilizzata con una causale che gestisce la valuta.

Data di registrazione articolo
E' la data che verrà messa sulla registrazione generata sia come data registrazione sia come data protocollo.

Anno
Viene proposto l'anno contabile derivato dalla data di registrazione

Conto DARE e Conto AVERE
Saranno rispettivamente il conto Dare e Avere dei movimenti generati
La compilazione di questi conti consente di ottenere, a seconda dei valori che l'operatore imposterà, registrazioni diverse (vedere note successive).

Cambio
E' il valore del cambio per la contabilizzazione di distinte in divisa. Verranno generati anche eventuali dettagli di utile o di perdita.

Utile su cambio e Perdite su cambio
Viene proposto il conto letto dalla Tabella dei Parametri generali (Conti comuni)
E' il codice conto da utilizzare per la generazione di movimenti di utile su cambio per distinte in divisa.
(è attivato e obbligatorio solo se distinta in valuta)

Centro di Costo
Se impostato viene memorizzato sull'articolo generato

Generazione di un articolo per ogni effetto S/N
Ha valore SOLO se non vengono compilati entrambi i conti DARE e AVERE (caso 2 in spiegazioni successive)
Se si risponde in modo affermativo verrà generato un articolo per ogni effetto: Banca a Cliente (o Fornitore a Banca), altrimenti, verrà generata una registrazione unica con un dettaglio per ogni effetto elaborato.

Riga unica per scadenze raggruppate S/N
Ha valore SOLO se viene compilato solo il Conto Dare o non vengono compilati entrambi i conti DARE e AVERE però non è stato scelto di generare un articolo per ogni effetto.
Nel caso venga impostato a Si, verrà effettuato il raggruppo scadenze (in corrispondenza quelle che hanno il flag settato) creando una riga col totale per cliente e data scadenza.

Durante l'elaborazione su ogni scadenza viene scritto il numero e la data di pagamento che coincidono con numero e data di registrazione dell'articolo generato.

Conto DARE e Conto AVERE - Possibilità di registrazione

  • CONTO DARE : conto portafoglio.
    CONTO AVERE: viene presentato vuoto.
    Se si conferma questa situazione verrà fatta una registrazione che chiude i clienti a portafoglio.
    Dovrà poi essere fatta da prima nota una registrazione da portafoglio a banca di presentazione della distinta, non effetto per effetto ma per data valuta.
  • Lasciare bianco il conto dare.
    Lasciare bianco il conto avere.
    In questo modo la registrazione viene fatta con in DARE il conto della banca di presentazione della distinta e in AVERE i codici dei vari clienti.
  • Lasciare bianco il Conto DARE.
    Impostare un conto di transito sul Conto AVERE (es.: effetti incassati).
    In questo modo si chiude la banca di presentazione della distinta a effetti incassati; i clienti invece rimangono aperti e andranno chiusi con delle registrazioni da prima nota fatte al momento dell'incasso effettivo.
  • Impostare nel Conto DARE un conto di transito (es.: effetti all'incasso).
    Impostare nel Conto AVERE un conto di transito (es.: effetti attivi).
    In questo modo rimangono aperti sia la banca che i clienti che verranno chiusi con registrazioni fatte in prima nota al momento dell'incasso.


INCASSO EFFETTI IN DISTINTA

INCASSO - PAGAMENTI EFFETTI IN DISTINTA

Percorso: Contabilità - Effetti - Elaborazioni

Il programma consente di richiamare una distinta già contabilizzata senza aver chiuso i clienti, al fine di elencare le sue scadenze e di poter via via selezionare quelle effettivamente incassate per poi registrare l'incasso in automatico.

Questa funzione è utile, in particolare, a chi è in regime di iva per cassa e deve registrare gli incassi nella data esatta in cui la banca li accredita sul conto.

E' possibile cercare il numero distinta tra quelle non ancora contabilizzate utilizzando i pulsanti come descritto in Ricerca distinta.

Una volta digitato il numero distinta viene visualizzata la Data di presentazione, la banca e la moneta.

Causale utilizzata per la registrazione
dovrà avere i campi:
Tipo partita a si riferisce
Aggancio Scadenze/Partite a SI

Una volta confermate le selezioni, verrà visualizzato l'elenco degli effetti e con un doppio click sul campo STATO, si potranno selezionare/deselezionare

Alla Conferma dell'elaborazione verrà fatta una registrazione di prima nota per l'incasso che avrà in dare il conto utilizzato 'in avere' nella contabilizzazione della distinta e in avere il/i clienti.
Questa registrazione non potrà essere variata dal programma di input prima nota, ma solo cancellata completamente

Con Annulla si torna alla maschera delle selezioni, annullando l'elaborazione.


RICEVUTE BANCARIE (RI.BA. ELETTRONICHE)

RICEVUTE BANCARIE (RI.BA. ELETTRONICHE) - RID

Percorso: Contabilità - Effetti - Stampe

Questa funzione consente di preparare un file ASCII, da consegnare alla banca, contenente gli effetti di una determinata distinta.

I tracciati dei file Ri.Ba. e RID, sono conformi a quelli definiti in sede A.B.I. per cui sono validi per tutte le banche.
I parametri di personalizzazione utilizzati e descritti in seguito, definiti con gruppo: riba, saranno validi anche per Rid.
Solo il parametro Estensione può essere definito diverso.

Per una corretta compilazione del file occorre che su ogni scadenza in distinta sia presente la banca del cliente e che in essa ci siano Abi e Cab. Abi e Cab devono essere necessariamente presenti anche sull'anagrafica della banca di presentazione della distinta.
Inoltre, per riportare sul record 14 della Riba (10 del Rid), il numero di conto corrente della ditta, occorre impostare il parametro di personalizzazione Ccditta

Se si prepara un file di RID 'da regolare su canale SEPA' (cioè convertire da RID nazionale ad Addebiti Diretti Sepa (SDD)) , è obbligatorio compilare, sulla banca di presentazione e sull'anagrafica del cliente, il codice IBAN completo e corretto; viene chiesto inoltre di digitare il Codice di Riferimento bb

E' possibile spedire le riba/rid ad un cliente ad un indirizzo diverso da quello scritto sulla sua anagrafica, inserendo il parametro di personalizzazione: IndirRiba

Il programma, per ogni indirizzo cliente da stampare, cerca se esiste un indirizzo per quel cliente, con codice personalizzato (XXX) in indirizzi clienti, se lo trova, stampa quello altrimenti stampa quello dell'anagrafica del cliente.

Nel caso di scadenze raggruppate, il programma raggruppa al massimo 10 fatture. Per raggrupparle tutte, senza limite, occorre attivare il flag: RottDopo10

Il nome che il programma assegna automaticamente al file, dipende da quello che è stato predisposto nella tabella Dati Riba (Parametri Generali).
Si può scegliere tra due possibilità:

  • R + Identificatore Azienda + Numero distinta.SEQ (se si sceglie questa opzione si possono preparare i file per distinte diverse e portarle alla banca successivamente)
    Per il file Rid verrà utilizzata la lettera D
  • Riba + Identificatore Azienda.SEQ (Ogni volta che si fa una preparazione per una stessa azienda si sovrappone alla precedente)
    Per il file Rid verrà utilizzata la parola Rid

Per Identificatore azienda, si intende il numero progressivo assegnato ad ogni azienda in Gestione database aziende al momento della sua creazione.

Al file generato viene assegnata l'estensione .SEQ. E' possibile tuttavia creare un parametro di personalizzazione Estensione (diverso per Riba e Rid) in cui mettere i tre caratteri dell'estensione voluta (es. txt)
La cartella nella quale viene scaricato il file è impostata in aziwin.ini tra i parametri generali:
DirRiBa= ….
e può essere variata dall'installatore (in generale è \database); l'utente può tuttavia decidere di volta in volta, di variare la destinazione e nome del file, tramite il pulsante Cambia.

Nella tabella Dati Riba/Rid (Parametri Generali) ci sono altri campi che vanno compilati per effettuare uno scarico corretto.

Numero progressivo effetti
Durante l'elaborazione, ad ogni effetto viene assegnato un numero progressivo in base a quanto indicato nella BANCA nella quale è stata appoggiata la distinta e nel TIPO PAGAMENTO.

Nell'anagrafica banche è possibile definire se azzerare o meno, all'inizio di ogni generazione del file delle Ri.Ba., il numero progressivo effetti, questo perché alcune banche chiedono espressamente che gli effetti vengano numerati, all'interno della stessa riba, sempre a partire da 1.

Il numero progressivo degli effetti emessi con un certo tipo di pagamento, si trova sull'anagrafica del Tipo pagamento.

In fase di Cambio anno (funzione necessaria per aprire un nuovo anno di lavoro), la procedura chiede se si vuole azzerare il NUMERATORE EFFETTI, presente sui TIPI PAGAMENTO (tutti).

Se c'è la necessità di azzerarli solo per alcuni TIPI PAGAMENTO, si consiglia di non azzerarli in automatico e poi farlo manualmente con la gestione dei tipi pagamento.

Tipo di elaborazione

  • Creazione del file ascii e stampa di controllo del suo contenuto
  • Solo creazione del file ascii
  • Solo stampa del contenuto

Se al termine dell'elaborazione viene data una segnalazione di errore, il file per la banca è stato ugualmente generato però è bene controllare di che errore si tratta eseguendo SOLO la stampa Tracciato e esaminando il contenuto delle righe a fianco delle quali verrà stampata la scritta ERRORE.

L'eventuale segnalazione di errore riporta il Tipo record (vedi elenco che segue) e il numero progressivo dell'effetto all'interno del file (per poter trovare meglio sulla stampa il campo che ha generato errore).

Gli errori sono generati dalla mancanza di dati obbligatori. Questi dati sono evidenziati con un * nella struttura che segue.

Struttura del file RIBA (RID)
Tutti i record del file contengono 120 caratteri e ciascuno è identificato da una sigla o un numero che viene scritto in seconda e terza posizione.
Nell'elenco che segue sono evidenziati da con * i campi ritenuti obbligatori

RECORD di tipo IB (IR se RID) - primo record del file

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso IB
 | 4 | 8 | Codice S.I.A. della banca di presentazione della distinta
* | 9 | 13 | Codice A.B.I. della banca di presentazione
* | 14 | 19 | Data creazione supporto magnetico nella forma GGMMAA
 | 20 | 45 | Riferimenti del mittente (da scrivere in Parametri e Utilità, Dati generali azienda-parametri, Ri.Ba.)
 | 46 | 112 | Vuoto
 | 113 | 113 | Vuoto - Se RID indica RID Ordinario, se Rid SEPA: RID SDD Core (Previsti dal tracciato RID, ma non inseriti anche: U - RID Ordinario, V - RID Veloce)
 | 114 | 114 | Divisa della distinta (fisso E=Euro)
 | 115 | 120 | Vuoto

Gruppo di record (dal 14/10 al 70) ripetuti per ogni scadenza

RECORD 14 (Ri.Ba.) - RECORD 10 (Rid)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso: 14 (Ri.Ba.) - 10 (Rid)
 | 4 | 10 | Num. progressivo della ricevuta (scadenza) all' interno del flusso. Inizia con 1 ed è progressivo di 1 Il numero è uguale per tutti i records (14-70) relativi alla stessa ricevuta
 | 11 | 22 | Vuoto
* | 23 | 28 | Data scadenza della ricevuta bancaria nella forma GGMMAA
 | 29 | 33 | Causale fissa 30000
* | 34 | 46 | Importo preceduto da zeri (sempre intero, se Euro è moltiplicato per 100)
 | 47 | 47 | Segno fisso "-"
* | 48 | 52 | Codice A.B.I. della banca assuntrice (banca di presentazione della distinta)
* | 53 | 57 | Codice C.A.B. banca assuntrice (CAB -sportello- della banca su cui viene appoggiata la distinta)
* | 58 | 69 | C/Corrente letto dalla Banca su cui è appoggiata la distinta oppure Vuoto a seconda che sia impostato a S o no il parametro di personalizzazione CCDitta
* | 70 | 74 | Codice A.B.I. banca domiciliataria (banca del cliente)
* | 75 | 79 | Codice C.A.B. banca domiciliataria sportello (banca del cliente)
 | 80 | 91 | Vuoto
 | 92 | 96 | Codice (S.I.A.) di riconoscimento del creditore presso la banca assuntrice (alla quale viene presentata la distinta)
 | 97 | 97 | Codice fisso 4
 | 98 | 113 | Codice con il quale il debitore è conosciuto dal creditore (è il codice cliente XXMMZZZZ)
 | 114 | 119 | Vuoto
 | 120 | 120 | Divisa della distinta (E=Euro)

RECORD 16 - Solo per RID da regolare su canale SEPA
(Coordinate ordinante)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
* | 2 | 3 | Tipo record fisso: 16
* | 4 | 10 | Num. progressivo della ricevuta (scadenza) all' interno del flusso. Inizia con 1 ed è progressivo di 1 Il numero è uguale per tutti i records relativi alla stessa ricevuta
* | 11 | 12 | Codice paese (IT o DM) letti dall'IBAN banca di presentazione
* | 13 | 14 | Check digit IBAN banca di presentazione
* | 15 | 37 | Codice BBAN - Parte di IBAN banca di pres. che contiene: CIN(1)-ABI(5)-CAB(5)-C/CORRENTE(12)
 | 38 | 44 | Vuoto
 | 45 | 79 | Identificativo creditore (campo NON gestito)
 | 80 | 120 | Vuoto

RECORD 17 - Solo per RID da regolare su canale SEPA
(Coordinate debitore)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
* | 2 | 3 | Tipo record fisso: 17
* | 4 | 10 | Num. progressivo della ricevuta (scadenza) all' interno del flusso. Inizia con 1 ed è progressivo di 1 Il numero è uguale per tutti i records relativi alla stessa ricevuta
* | 11 | 12 | Codice paese (IT o DM) letti dall'IBAN del cliente
* | 13 | 14 | Check digit IBAN del cliente
* | 15 | 37 | Codice BBAN - Parte di IBAN del cliente che contiene: CIN(1)-ABI(5)-CAB(5)-C/CORRENTE(12)
 | 38 | 41 | Tipo sequenza FRST, RCUR, FNAL, OOFF (campo NON gestito)
 | 42 | 47 | Data sottoscrizione mandato ggmmaa (campo NON gestito)
 | 48 | 120 | Vuoto

RECORD 20

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso 20
 | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
 |  |  | Se RIBA o RID no SEPA:
* | 11 | 34 | Denominazione o ragione sociale del creditore (dalla Tabella parametri: Ri.Ba.)
* | 35 | 58 | Via e Numero del creditore
* | 59 | 82 | Cap e Località del creditore
* | 83 | 106 | Provincia del creditore
 | 107 | 120 | Vuoto
 |  |  | Se RID (SEPA)
 | 11 | 70 | Denominazione o ragione sociale del creditore (dalla Tabella parametri: Ri.Ba.)
 | 71 | 120 | Vuoto

RECORD 30

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso 30
 | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
 |  |  | Se RIBA o RID no SEPA:
* | 11 | 40 | Denominazione o ragione sociale del debitore (Cliente) I vari campi di ragione sociale del cliente vengono utilizzati con il seguente criterio (lo stesso utilizzato in fatturazione): si considera la 1' parte del campo Ragione Sociale, se sull'anagrafica cliente questa risulta non compilata, si prende la Ragione Sociale Contabile.
 | 41 | 70 | Denominazione o ragione sociale del debitore (si mette comunque il contenuto della seconda parte della Ragione Sociale cliente)
* | 71 | 81 | Partita Iva
 | 82 | 120 | Vuoto
 |  |  | Se RID (SEPA)
 | 11 | 70 | Denominazione o ragione sociale del debitore (Cliente)
 | 71 | 120 | Vuoto

RECORD 40

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso 40
 | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
* | 11 | 40 | Indirizzo del debitore
* | 41 | 45 | C.A.P. del debitore
* | 46 | 70 | Comune e sigla di provincia
 | 71 | 120 | Banca domiciliataria (del cliente) in chiaro

RECORD 50 (Solo Ri.Ba.)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso 50
 | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
* | 11 | 50 | Descrizione dell' operazione che ha generato l'effetto (Nr.dt.doc.:Numero documento e data,Nr.reg.:Numero registrazione, eventuali codici CIG e CUP).
* | 51 | 90 | Numero e data riferimento della fattura che ha generato l'effetto
 | 91 | 100 | Vuoto
* | 101 | 116 | Partita Iva di chi presenta le Ri.Ba. (può essere inserita in Parametri generali, Dati Riba oppure si prende quella dell'anagrafica ditta)
 | 117 | 120 | Vuoto

Se RID Sepa, a seconda della lunghezza della descrizione della disposizione di incasso verranno scaricati:
un record 50 oppure due record 60.
RECORD 50/60 (RID Sepa)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso 50 o 60
 | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
* | 11 | 100 | Descrizione dell' operazione che ha generato l'effetto (Numero/Data documento , eventuali codici CIG e CUP).
 | 101 | 120 | Vuoto

RECORD 51 (Solo Ri.Ba.)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso 51
 | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
 | 11 | 20 | Numero effetto
* | 21 | 40 | Firma emittente. (Da tabella parametri: Ri.Ba.)
 | 41 | 55 | Provincia di intendenza di finanza. (Da tabella parametri: Ri.Ba.)
 | 56 | 65 | Numero autorizzazione (Da tabella parametri: Ri.Ba.)
 | 66 | 71 | Data autorizzazione (Da tabella parametri: Ri.Ba.)
 | 72 | 120 | Vuoto

RECORD 70

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
* | 2 | 3 | Tipo record fisso 70
* | 4 | 10 | Numero progressivo della ricevuta all' interno del flusso (vedi record 14)
 | 11 | 120 | Vuoto se RIBA o RID generico
 |  |  | Se RID (SEPA)
 | 11 | 25 | Codice di riferimento (chiesto a video)
 | 26 | 94 | Vuoto
 | 95 | 95 | Campo a disposizione (non gestito)
 | 96 | 96 | Facoltà di storno di addebito (Non gestito)
 | 97 | 120 | Vuoto

RECORD EF (record di chiusura del flusso)

 | Da | A | Contenuto
 | 1 | 1 | Vuoto
 | 2 | 3 | Tipo record fisso EF
 | 4 | 8 | Codice S.I.A. dell'azienda creditrice (banca di presentazione) presso la banca del cliente
* | 9 | 13 | Codice A.B.I. della banca di presentazione effetti
* | 14 | 19 | Data creazione supporto magnetico nella forma GGMMAA
 | 20 | 45 | Riferimenti del mittente
 | 46 | 52 | Numero delle ricevute contenute nel supporto magnetico
* | 53 | 67 | Importo totale delle ricevute contenute nel supporto magnetico
 | 68 | 82 | Contiene zero
 | 83 | 89 | Numero records contenuti nel supporto magnetico compresi il record di testa RB ed il record di coda EF (se Riba=n ricevute x 7 + 2) - (Se Rid Sepa n ricevute x 8 (opp.9) + 2
 | 90 | 113 | Vuoto
 | 114 | 114 | Divisa della distinta (E=Euro)
 | 115 | 120 | Vuoto


TABELLA TASSO BCE

Percorso: Contabilità - Scadenzario - Gestioni

Tabella con elenco, nei vari periodi, dei tassi Bce da applicare per ritardato pagamento. Viene utilizzata dal programma di Stampa Interessi maturati.

Al fine di un corretto funzionamento del programma di stampa interessi, occorre che in questa tabella sia stata compilata almeno una riga.


TABELLA % MAGGIORAZIONE INTERESSI

Percorso: Contabilità - Scadenzario - Gestioni

Tabella con elenco, nei vari periodi, delle percentuali di maggiorazione che vanno ad aumentare il tasso BCE per ritardato pagamento. Viene utilizzata dal programma di Stampa Interessi maturati.

Al fine di un corretto funzionamento del programma di stampa interessi, occorre che in questa tabella sia stata compilata almeno una riga.


STAMPA INTERESSI MATURATI

Percorso: Contabilità - Scadenzario - Stampe

Il programma esamina le scadenze 'scadute' e non pagate o pagate in ritardo e calcola gli interessi applicando le percentuali scritte nelle tabelle dei Tassi BCE e Maggiorazioni ai giorni di ritardato pagamento.

Al fine di un corretto funzionamento del programma di stampa interessi, occorre che le suddette tabelle siano state compilate almeno con una riga.

Quando si esegue questa stampa per calcolare gli interessi ad una certa data e si fatturano, l'utente deve poi inserire manualmente sulle scadenze intervenute nel calcolo, la data di fatturazione interessi (con Gestione scadenze)


SCARICO SCADUTO PER SOLLECITI

Percorso: Contabilità - Scadenzario - Stampe

La funzione ha lo scopo di esaminare, per l'intervallo di clienti richiesti, le scadenze 'scadute' alla data inserita a video e non ancora saldate.

Verrà preparato il file 'scaduto.txt' nella directory \programmi\aziwin\carica che potrà poi essere elaborato con Word (stampa/unione) per compilare le lettere di sollecito da spedire ai clienti in oggetto.

Il nome e la destinazione del file viene proposto ed possibile variarlo.

Il file che viene preparato è di tipo testo con separatori TAB e fine record CR (invio).Per ogni cliente viene scaricata una riga con i seguenti campi:

Codice
Ragione Sociale
Indirizzo
Cap
Località
Provincia
Moneta (codice)
Totale
Scadenza 1
...
Scadenza 25

Vengono scaricate un massimo di 25 scadenze ancora aperte.

I campi 'scadenza n' possono essere diversi a seconda della scelta dell'operatore sul parametro Tipo scarico scadenza.

Si può decidere di scaricare una stringa unica che contiene: Nº e data documento, Data Scadenza Importo oppure tutti i campi separati. La differenza sta nell'utilizzo dei campi nella lettera che poi si andrà a scrivere.

Se si sceglie la prima modalità di scarico, per mantenere gli allineamenti in word è necessario che le descrizioni e i sottostanti campi 'Scadenze' siano definiti con carattere Courier 10.

Esempio di utilizzo del file generato per la stampa unione:

  • Aprire Word e da strumenti scegliere Stampa Unione, poi scegliere 'Documento principale: Crea' poi scegliere 'lettera tipo' e 'finestra attiva'.
  • Da 'Origine dati' aprire l'archivio SCADUTO.TXT (es. in programmi\aziwin\carica) poi selezionare 'Seleziona Metodo' e in Tipo file scegliere TXT.
  • Entrare poi in modifica documento e creare una lettera inserendo all'occorrenza i campi estratti scelti dal pulsante 'Inserisci stampa unione':

Esempio:
Spett.
<<Ragione Sociale>>
<<Indirizzo>>
<<CAP>> <<Localita>> <<Provincia>>

Da un controllo contabile ci risultano non pervenuti i pagamenti relativi alle seguenti operazioni per un totale di L. <<Totale>>
<<Scad1>>
<<Scad2>>
....
<<Scad25>>

Vogliate cortesemente provvedere .....

I campi fra <<>> sono quelli della testata del file SCADUTO che Word mette a disposizione come Campi Di Inserimento. Se si sceglie di riportare le scadenze in campi separati, al posto di <<scadn>> ci saranno i vari campi: prefisso, numero e data documento, data scadenza e importo.

E' conveniente inserire tutti i 25 campi <<Scadn>>,in quanto poi verranno assegnati solo quelli effettivamente presenti.

Riattivando la scelta Stampa-Unione e l'opzione unisci, si potrà generare un documento diviso in tante lettere quanti sono i clienti della lista SCADUTO.TXT, oppure si possono scegliere i pulsanti 'Unisci in nuovo documento' o 'Unisci alla stampante' per stampare.

Le possibilità di selezione presentate all'operatore sono le stesse della stampa scaduto.


STAMPA SCADUTO

Percorso: Contabilità - Scadenzario - Stampe

Il programma consente di stampare l'elenco delle scadenze (Clienti e Fornitori) ancora aperte ad una data impostata a video dall'operatore.

E' possibile effettuare una selezione per Agente.
Se si imposta un agente, verranno stampate le scadenze dei clienti che hanno in anagrafica in agente 1 e 2 quel codice.

Se si fa la stampa ordinata per Codice o per Descrizione Cliente/Fornitore a fianco alla Ragione sociale verrà stampato il numero di telefono e l'indirizzo email Amministrativo, letti dall'anagrafica.
E' possibile cambiare l'indirizzo email da stampare impostando il parametro di personalizzazione: QualeEmail
Per non stampare l'indirizzo email , impostare il parametro suddetto con valore 0.

Aggiunta opzione a video se stampare CIG e Cup oppure Agente
Messo parametri di personalizzazione per preimpostarlo (se vale S preimposta opzione stampa Agente):
Per scaduto
Gruppo: StScaduto Parametro: StaAgente


SEGNALAZIONE SALDO ESTRATTO CONTO

Percorso: Contabilità - Scadenzario - Stampe

Questa funzione, con le stesse selezioni della situazione contabile clienti, consente di calcolare il saldo contabile di un cliente e di stampare una lettera con cui comunicargli tale saldo.
E' stata inoltre inserita una scelta: Elenco partite aperte che consente di stampare, per ogni cliente sceto, il contenuto del testo selezionato, seguito dall'elenco delle partite aperte, ciascuna col suo saldo.
In questo caso le date di registrazione chieste a video saranno le date documento delle partite da considerare.
Non verrà calcolato il saldo del cliente per cui nella lettera non ha senso impostare il campo relativo.

Si possono memorizzare fino a 5 testi (lettere) diversi che possono essere richiamati tramite il pulsante: carica testo da stampare.

Per scrivere e memorizzare questi testi occorre premere il pulsante: Modifica testi che consente di entrare in una maschera nella quale i testi possono essere richiamati, variati e memorizzati con i pulsanti: testo di base da salvare.

Vedi Estratto conto clienti - Gestione testo

Stampe separate per ogni cliente

I testi in oggetto vengono memorizzati sulla tabella Appoggio del database del menu (AziMenu.mdb)

Es. di personalizzazione della stampa per aumentare il font dei caratteri. Inserire le righe nel file aziwin.ini dell'utente:

[CogeStaSEsC]
FontPersCor=1
CodiceFontCor1=CorpoCampo
CorpoCampo_Size=12


SEGN. SALDO E.C. CLIENTI - GESTIONE TESTO

Nel testo ci possono essere delle parti fisse e delle parti variabili.

Per inserire in TAB, per lasciare un margine a sinistra del testo, occorre premere i tasti Ctrl Tab

Le parti variabili fanno riferimento ai campi della tabella Pianoconti (anagrafica clienti) etc. e vanno scritte nel testo precedute da <$ e seguite da $>

Esempio, l'intestazione dovrà avere un formato del tipo:
Spett. <$Descrizione$> oppure Spett. <$RagSoc$> <$RagSoc2$>
<$Indirizzo$> <$Cap$> <$Localita$> <$Pr$>
All'attenzione di <$PersRiferimento$>

Altre variabili disponibili sono:

<$Pianoconti.PartIva$> partita iva cliente (e tutti gli altri campi della tabella Pianoconti)

<$Data$> o <$Datagg$> è la data di stampa inserita a video nei due formati gg/mm/aaaa e gg mese anno (es. 25 luglio 2002)

<$dataregda$> e <$datarega$> intervallo delle date dei movimenti selezionati per il calcolo del saldo

<$saldo$> è il saldo calcolato (NON viene calcolato nella scelta Elenco partite aperte)

<$DesAge1$> e <$DesAge2$> descrizione agente 1 e 2

<$zona.descrizione$> descrizione zona

<$categoria.descrizione$> descrizione categoria

Se non si vuole stampare la riga: All'attenzione di: … quando in archivio il campo persona di riferimento è vuoto, si può usare la sintassi seguente:

<$NV(PersRiferimento)All'attenzione di <$PersRiferimento$>

NV$>

Se si vuole stampare la descrizione dell'agente 1 solo se compilata:

<$NV(DesAge1), Agente = <$DesAge1$>NV$>

All'interno del testo si possono utilizzare font particolari, vedere 'Font personalizzati'

Cerca immagini
Il pulsante Cerca Img: consente di cercare una immagine da inserire nel testo.
Una volta selezionata, verrà scritta la frase completa: <img src="path_immagine"> nel punto in cui in stampa verrà inserita l'immagine.

N.B. La stampa dell'immagine avverrà solo se la lettera verrà spedita per email diversamente sulla lettera rimarrà la scritta <img ....>


ESTRATTO CONTO CLIENTI - LETTERA

Percorso: Contabilità - Scadenzario - Stampe

Il programma consente di stampare una lettera indirizzata al cliente con un testo parametrizzabile all'inizio, l'elenco delle scadenze e un testo parametrizzabile finale.

I due testi si possono scrivere a video negli appositi campi e possono essere memorizzati per poi utilizzarli ogni volta che si dovrà stampare una lettera di questo tipo.
Per spostare a destra delle parti di testo occorre inserire dei TAB e non degli spazi.
Per inserire i TAB occorre premere i tasti Ctrl Tab
Per quanto riguarda la scrittura del testo, si consiglia di leggere il paragrafo: Estratto conto clienti - testo.

Le scadenze stampate sono quelle ancora aperte, di tipo 'Entrata' e con data scadenza minore o uguale alla data scadenza inserita a video.

Per ogni scadenza stampata il programma calcola gli interessi:
(Importo scadenza /100 * %Interessi)/365) * NumeroGiorni scaduto
La percentuale viene estratta dal valore del parametro di personalizzazione Interessi

E' possibile inserire a video un importo fisso da addebitare ad ogni cliente, in alternativa o in aggiunta agli interessi.

Per rendere più leggibile questa stampa, si può rendere necessario aumentare il font dei caratteri.
Inserire le righe successive nel file aziwin.ini dell'utente:
[CogeStaStEs]
FontPersCor=1
CodiceFontCor1=CorpoCampo
CorpoCampo_Size=10

Stampe separate per ogni cliente
Se si seleziona questo pulsante il programma produrrà una lettera in formato pdf per ogni cliente, lettera che poi verrà spedita in automatico via email se saranno stati impostati tutti i parametri necessari.

Viene chiesto quale indirizzo email dei clienti utilizzare per l'invio (indirizzi impostati in gestione clienti)
Successivamente, per la preparazione del file pdf e l'invio, si dovranno spuntare 'Nome pdf automatico' e 'Invio per email' quindi compilare, in modo opportuno, i campi della maschera 'Par ini/pdf email'
Il nome del file prodotto è quello scritto nella maschera dei parametri in 'Percorso file per pdf' + codice cliente.
Verranno segnalati a video i codici degli eventuali clienti ai quali manca l'indirizzo email e nel file di log verranno scritti i nomi dei file NON inviati per mancanza dell'indirizzo email.

NOTA BENE: è necessario spuntare questo campo anche se si sta preparando la lettera per un solo cliente.


ESTRATTO CONTO CLIENTI - TESTO

Nel testo ci possono essere delle parti fisse e delle parti variabili.

Per spostare a destra delle parti di testo occorre inserire dei TAB e non degli spazi.
Per inserire i TAB occorre premere i tasti Ctrl Tab

Le parti variabili fanno riferimento ai campi delle tabelle Ditta, Pianoconti (anagrafica clienti) etc. e vanno scritte nel testo precedute da <$ e seguite da $>

In questa stampa, oltre ai dati anagrafici del cliente, sono disponibili i seguenti campi tratti dai dati anagrafici della ditta:
DtRagSoc
IndirLegale
CapLegale
LocalitaLegale
PrLegale
IndirOp
CapOp
LocalitaOp
PrOp
DtPartIva
DtCodFisc
DtTelefono
DtFax
RegImprese
NumRegImp

Sono disponibili inoltre le seguenti variabili:

DataScadutoA | data inserita a video nel campo Scaduto a
TotScaduto | totale scaduto del cliente
TotInteressi | totale interessi calcolati
PercInteressi | percentuale degli interessi (da parametri di personalizzazione)
TotPagare | totale a pagare: Totale scadenze + totale interessi

Per gli altri campi disponibili e la sintassi da seguire vedi: Segnalazione saldo E.C. clienti

All'interno del testo si possono utilizzare font particolari, vedere 'Font personalizzati'


AGGIORNAMENTO IVA

Percorso: Contabilità - Iva - Gestioni

Il programma esegue l'aggiornamento dei progressivi iva periodici e di quelli dei clienti e fornitori, a partire dai movimenti del periodo che si desidera aggiornare.
Se la ditta applica il Regime di iva per Cassa, è indispensabile eseguire, dopo l'aggiornamento 'tradizionale' che aggiornerà le eventuali registrazioni 'escluse' da suddetto regime, anche la funzione di 'Aggiornamento Iva per Cassa'.

E' indispensabile aggiornare i movimenti prima della stampa definitiva del Registro Iva.

Se si rende necessario variare un movimento aggiornato ma non ancora stampato sul Registro Iva, si può eseguire il disaggiornamento dal pulsante apposito della Prima Nota. Una volta fatta la variazione, la registrazione dovrà essere riaggiornata.
Se invece servirà inserire una o più registrazioni in un periodo iva già aggiornato, lo si può fare, rispettando la sequenza dei numeri protocollo e delle date, poi si procederà con il riaggiornamento del periodo interessato (sarà cura del programma aggiornare SOLO i movimenti 'nuovi').
Vedi anche note.

E' stata predisposta, nel menu di servizio di contabilità (Sez.utilità) una funzione per il disaggiornamento di un gruppo di registrazioni. Questa funzione si deve utilizzare con molta attenzione.

Oltre ad aggiornare i progressivi iva, questa funzione aggiorna i progressivi Clienti e fornitori al fine di poter compilare e comunicare telematicamente gli Elenchi clienti e fornitori.

Nell'aggiornamento di questi progressivi si tiene conto in particolare dei flag impostati su ogni codice iva nella sezione: elenco clienti e fornitori.

In particolare, per aggiornare correttamente i progressivi imponibile e imposta clienti e fornitori, è stata predisposta una funzione di ricalcolo degli stessi per un determinato anno, da eseguire OBBLIGATORIAMENTE, prima della presentazione degli elenchi.


AGGIORNAMENTO IVA PER CASSA

Percorso: Contabilità - Iva - Gestioni

Il programma prende in considerazione le registrazioni che hanno un riferimento all'iva per cassa, siano esse fatture o incassi/pagamenti e, oltre ad aggiornare i progressivi iva, crea in corrispondenza ad ogni incasso/pagamento, il giroconto tra i conti iva vendite/acquisti per cassa e iva vendite/acquisti.

La causale utilizzata per questa registrazione viene letta dalla tabella delle Causali comuni (Parametri e Utilità - Dati Generali azienda parametri).
Si consiglia di creare una causale apposita in modo da poter selezionare in visualizzazione o stampa solo questi movimenti se se ne presenta la necessità.

E' indispensabile aggiornare i movimenti prima della stampa definitiva del Registro Iva e, comunque, prima di procedere alla Chiusura Iva, anche in prova, dell'anno successivo.

Anche se la ditta applica il Regime di iva per Cassa, è indispensabile eseguire anche l'aggiornamento 'tradizionale' che aggiornerà le eventuali registrazioni 'escluse' da suddetto regime.

E' stata predisposta, nel menu di servizio di contabilità (Sez.utilità) una funzione per il disaggiornamento IVA per CASSA di un gruppo di registrazioni. Questa funzione si deve utilizzare con molta attenzione.

Il programma memorizza, per ogni fattura emessa o ricevuta che aggiorna, i dati su alcune tabelle di appoggio e, per ogni incasso/pagamento cerca su tali tabelle la fattura corrispondente per determinare l'iva da considerare nel periodo e scrive in esse l'importo dell'incasso/pagamento e la sua ripartizione per le aliquote della fattura. Tali tabelle si possono gestire dalla funzione Gestione riepilogo Movimenti Iva per Cassa.

Parametri di personalizzazione:
ArrotPercInc
ArrotIvaPerCassa


GESTIONE RIEPILOGO MOV. IVA PER CASSA

Percorso: Contabilità - Iva - Gestioni

La tabella viene compilata dall' Aggiornamento Iva per Cassa

Il programma consente di visualizzare le fatture emesse e ricevute in regime di iva per cassa con l'evidenza, per ogni fattura, delle eventuali note di variazione e degli incassi/pagamenti.

Esso è diretto principalmente alla consultazione in quanto i dati presenti sulle tabelle visualizzate sono ottenuti dalle elaborazioni dell'aggiornamento iva dei periodi precedenti e la loro variazione potrebbe determinare errori nella liquidazione dell'iva.

E' possibile tuttavia abilitare la variazione premendo i tasti: Ctrl Alt W

Oltre ai dati che identificano la fattura, vengono presentati i campi:

Data entro cui saldare
E' la data a un anno dalla data del documento, data nella quale l'iva della fattura andrà comunque considerata nella liquidazione anche se non è stata incassata/pagata.
Saldato
Indica se la fattura è stata incassata/pagata.
Importo note di variazione
Se per quel documento sono state fatte più note di variazione il campo conterrà la somma degli importi.
Importo ancora da incassare dopo un anno
E' l'importo su cui calcolare l'iva da considerare nella liquidazione ad una anno dall'emissione della fattura.
Data saldo per trascorso anno da data fattura
Questa data viene impostata in automatico dall'aggiornamento iva per cassa quando il documento in oggetto risulta ancora non incassato/pagato ed è trascorso un anno dalla sua data di emissione. In questo caso l'iva dovrà essere comunque considerata nella liquidazione del periodo.
Tramite ln pulsante 'Det. Incassi dopo anno', posto a fianco alla data, è possibile visualizzare il dettaglio degli importi per aliquota che verranno sommati sulla Chiusura Iva.
Anno e Numero di registrazione del movimento per fine anno
si riferiscono al movimento di giroconto generato dell'aggiornamento per l'iva rimasta ad un anno dall'emissione della fattura (giroconto tra iva per cassa e iva vendite o acquisti).

Vengono infine visualizzate due liste alle quali si accede premendo rispettivamente:

  • (E) Gestione dettaglio iva - elenco dei codici iva presenti in fattura con relativo imponibile e imposta
  • (N) Incassi - elenco delle registrazioni di incasso


GESTIONE RIEPILOGO MOV. IVA PER CASSA: Dettagli

Percorso: Contabilità - Iva - Gestioni - Gestione riepilogo movimenti iva per cassa

Si accede a questa gestione dalla Gestione riepilogo movimenti iva per cassa, premendo

(E) Gestione dettaglio iva

Per ogni codice iva presente in fattura, viene riportata una riga con i relativi imponibile e imposta e imponibile e imposta delle eventuali note di variazione


RIEPILOGO MOV.IVA PER CASSA: INCASSI

Percorso: Contabilità - Iva - Gestioni - Gestione riepilogo movimenti iva per cassa

Si accede a questa gestione dalla Gestione riepilogo movimenti iva per cassa, una volta posizionati su una fattura, premendo

(N) Incassi - elenco delle registrazioni di incasso/pagamento della fattura

Per ogni incasso viene visualizzato l'importo, il numero e la data della registrazione e anno e numero della registrazione del giroconto iva (iva per cassa a iva vendite o iva acquisti a iva per cassa) per l' importo dell'iva considerata nella liquidazione del periodo.

Per accedere ad ulteriori dati del singolo incasso si deve premere

(E) Dettagli


RIEPILOGO MOV.IVA PER CASSA: Dettagli Incassi

Percorso: Contabilità - Iva - Gestioni - Gestione riepilogo movimenti iva per cassa

Si accede a questa gestione dalla Gestione riepilogo movimenti iva per cassa, una volta posizionati su una fattura, premendo

(N) Incassi - elenco delle registrazioni di incasso/pagamento della fattura

poi, posizionati su una riga di incasso, premendo:

(E) Dettagli

si può vedere la ripartizione per aliquota di quell'incasso


GIORNALE BOLLATO

Percorso: Contabilità - Stampe Fiscali

La funzione consente di stampare il giornale di contabilità.

Oltre all'intervallo delle date di registrazione dei movimenti da stampare è possibile inserire anche l'anno cui esse appartengono.

Se il campo anno viene lasciato bianco, verranno stampate le registrazioni nell'ordine richiesto (indipendentemente dall'anno contabile di appartenenza) e i numeri progressivi di riga, i totali etc. vengono prelevati dalla tabella dell'anno della prima data di registrazione stampata.

Viceversa, se si imposta l'anno, verranno stampati i movimenti compresi nelle date richieste ma con anno uguale a quello digitato.

Questo consente di stampare, consecutivamente ai movimenti del 31/12 di un certo anno, gli eventuali movimenti di chiusura generati con una data dell'anno successivo ma aventi come anno di riferimento quello per cui è stata fatta la chiusura e, separatamente, tutti i movimenti appartenenti completamente all'anno successivo.

E' possibile stampare il numero di pagina contestualmente al resto. Vedi Libri contabili - numerazione pagine.

La stampa del giornale può essere fatta in tre diverse modalità:

  • Prestampa
    Produce una stampa uguale alla definitiva ma senza assegnare, ai movimenti stampati, il segnale di stampato e senza incrementare i totali memorizzati.
  • Stampa (stampa definitiva)
    Una volta stampate in modo definitivo le registrazioni non sono più modificabili.
    oltre a mettere il segnale sui movimenti, aggiorna la tabella con i progressivi numero di riga e dare-avere giornale per avere il punto di partenza per la stampa del periodo successivo (vedi: Caratteristiche esercizio di Contabilità)
    Se il programma, mentre sta eseguendo la stampa definitiva, si interrompe per qualche motivo (esempio mancanza di corrente), una volta rientrati nella procedura e scelta di nuovo la stampa giornale, verrà proposta una maschera che consente il RECUPERO DELLA STAMPA interrotta.
    In questo caso si chiede di digitare:
    - il numero dell'ultima riga dell'ultima pagina di giornale stampato bene e i rispettivi Totali dare e Avere
    - il numero dell'ultima riga stampata nel periodo (mese) precedente
    Alla conferma la stampa verrà ripresa correttamente.
  • Ristampa (recupero stampa)
    Consente di ripetere la stampa completa o parziale di un gruppo di movimenti già stampati in modo definitivo.
    In questo caso è obbligatorio eseguire il programma con le stesse scelte fatte nel momento della 'Stampa' (in particolare lo stesso intervallo di date)
    - impostare il numero della prima pagina da stampare nel recupero
    e compilare i Dati obbligatori in caso di Ristampa (dati necessari al programma per riprendere la stampa del punto desiderato):
    - il numero dell'ultima riga dell'ultima pagina di giornale stampato bene e i rispettivi Totali dare e Avere
    - il numero dell'ultima riga stampata nel periodo (mese) precedente

Parametri di personalizzazione:
Se è stato impostato il parametro di personalizzazione DataOp, l'ordinamento delle registrazioni in stampa verrà fatto per data protocollo e numero registrazione.
NOTA: Se attivo questo parametro e sulle registrazioni manca la data protocollo, esse NON verranno stampate sul giornale.

StaPagFisc - per impostare a Si il campo, a video, che indica di stampare sempre il numero di pagina

StaIndir - consente la stampa anche dell'indirizzo di ogni cliente/ fornitore stampato. (Per simulare il registro professionisti)

StaAnnoDoc - consente di stampare /Anno a fianco del numero documento delle fatture emesse.

Intest - consente di cambiare l'intestazione del Giornale

NoRiporti - consente di non stampare i riporti


REGISTRI IVA

Percorso: Contabilità - Stampe Fiscali

Questa funzione consente di eseguire la stampa dei registri iva della ditta.

E' possibile stampare il numero di pagina contestualmente al resto. Vedi Libri contabili - numerazione pagine.

Se la ditta è in semplificata (vedi tabella Caratteristiche esercizio contabilità nel menu di servizio), verranno stampate anche le descrizioni delle c/partite poiché questo registro sostituisce il giornale.

Si può chiedere al programma di controllare la sequenza dei numeri di protocollo.

In caso di errata sequenza, se si stampa in prova verrà stampata una segnalazione, mentre se si stampa in 'definitiva' verrà data SOLO una segnalazione a video e chiesta la conferma di stampa.

Registro corrispettivi: è possibile attivare il parametro CorriRaggGio in modo da raggruppare in un'unica riga i corrispettivi di un giorno.

La stampa può essere eseguita in tre modalità diverse:

Prestampa: verranno stampati i documenti anche se non è stato eseguito l'aggiornamento iva del periodo

Stampa: i documenti devono essere stati aggiornati e ogni documento stampato viene contrassegnato con un flag in modo da non ristamparlo in una stampa successiva

Con la funzione di Variazione stato iva (menu di servizio di contabilità) è possibile riassegnare lo stato di non stampato a un gruppo di documenti e quindi eseguire di nuovo la stampa

Ristampa: consente di eseguire la ristampa, anche parziale, di un registro già stampato in modo definitivo. Perché la ristampa risulti corretta occorre digitare il prefisso, il numero e la data dell'ultimo protocollo stampato correttamente, per questo motivo si consente di ristampare un registro per volta.
Nota: per ristampare tutto l'anno, occorre lasciare bianchi questi dati, mettendo solo il prefisso, se si vuol ristampare un unico registro.

L'orientamento diverso della stampa: orizzontale o verticale, ha effetto SOLO se la ditta non è in contabilità generale ma in Semplificata o Forfetaria per cui su ogni riga deve stampare anche i dati del conto di costo o di ricavo e quindi ha bisogno di più spazio.

Registro iva Trasportatori
In fase di stampa registri iva, al cambio prefisso, nella maschera dove viene chiesto di inserire il 'registro con prefisso X', (dove X è un prefisso Trasportatori), verrà chiesta la data di registrazione che dovrà sostituire in stampa, quella effettiva delle fatture.

Nei campi Data Ric. e Num Ric. SDI vengono messi i dati di ricezione dello SDI :
Vengono riportati i dati indicati nella registrazione di prima nota; nel caso in cui siano vuoti vengono prelevati dalle fatture emesse per le fatture attive e dall'archivio fatture ricevute per le fatture passive.

Parametri:
 StaAliquota - per abilitare la stampa dell'aliquota iva sulle righe delle registrazioni

StaAnnoDoc - Per stampare /Anno a fianco del numero documento delle fatture emesse.

StaPagFisc per impostare sempre a video il campo che indica la stampa del numero di pagina


REGIME DEL MARGINE - REGISTRI IVA

Percorso: Contabilità - Stampe Fiscali

Questa funzione consente di stampare i registri degli acquisti e delle cessioni dei Beni Usati secondo le specifiche richieste dal regime del margine globale.

NOTA: E' obbligatorio fare la stampa definitiva del Registro Acquisti prima di quello delle Vendite in modo tale che venga stampato corretto il riepilogo finale.

In fondo al Registro Acquisti dei Beni Usati verrà stampato un prospetto con il totale Costi suddividendo: Acquisti, Spese di Trasporto e Spese Accessorie (informazione derivata dalla causale della registrazione)

In fondo al registro iva Vendite/Cessioni dei Beni Usati verrà riportato il Riepilogo col calcolo del Margine Lordo che, se negativo, genera un Credito di Costo che verrà rimandato al periodo successivo.
Nel riepilogo si evidenzia:
(V) Valore Cessioni
(V) Export
(A) Costi
(A) Import
(D) Differenza
(C) Credito Precedente
(M) Margine Lordo

Dove:
V - è la somma delle vendite del periodo elencate nel registro divise tra normali e esportazioni (dalla Causale della registrazione)
A - è la somma degli acquisti elencate nel registro acquisti Beni Usati dello stesso periodo divisi tra normali e importazioni (dalla Causale della registrazione)
D - è la differenza tra i due
C - è l'eventuale Credito del margine riportato dal periodo precedente

M - Margine è D-C

Se Margine Lordo <0 verrà stampata un'altra riga:
Credito di Costo con lo stesso importo ma positivo

Se Margine Lordo è maggiore di 0, il Credito di Costo è nullo mentre si riparte proporzionalmente il margine rispetto le fatture di acquisto e relative aliquote e si stabilisce l' imposta da considerare per il periodo

Ripartizione aliquote iva Margine Lordo Imponibile % Iva Importo

3000 21% (66,67%) 1363,80 1127,11 21% 236,69

1500 22% (33,33%) 681,80 558,85 22% 122,95
_______________________________________________________________

4500 2045,60 1685,96 359,64

L'importo 359,64 verrà riportato in Chiusura iva sull'iva a debito del periodo con la nota che si tratta di iva del margine

Se in un periodo non ci sono state cessioni, si può stampare ugualmente sul registro delle cessioni il suddetto riepilogo, richiedendo in modo specifico la stampa del registro vendite con il prefisso utilizzato per le registrazioni delle cessioni dei beni usati.


CHIUSURA IVA

Percorso: Contabilità - Stampe Fiscali

Questa funzione consente di stampare, in prova e definitiva, la liquidazione iva periodica e annuale della ditta.
Consente inoltre di effettuare il Ricalcolo Annuale per preparare i dati per il Calcolo della Comunicazione Iva annuale.
Vedi 'domande frequenti' per casi particolari

Data Chiusura
E' la data in cui si effettua la chiusura, in generale una data compresa nella prima quindicina del mese successivo al periodo di chiusura.

Si consente

  • Prestampa
    o stampa in prova. Può essere ripetuta più volte.
    Non serve che i movimenti iva siano aggiornati in quanto è il programma stesso ad eseguire, in simulazione, l'aggiornamento degli eventuali movimenti iva non aggiornati.
    In caso di regime di iva per cassa è possibile eseguire la simulazione SOLO a partire dalla data del primo movimento non aggiornato, non si possono 'escludere' dei periodi.
  • Stampa
    si deve fare solo dopo aver eseguito l'aggiornamento dei movimenti iva del periodo da stampare (e aggiornamento Iva per Cassa). Al termine della stampa il programma aggiorna, in tabella dati iniziali iva, i campi: ultimo periodo iva stampato e data di stampa.
  • Ristampa
    di un periodo già stampato in modo definitivo

E' possibile stampare il numero di pagina contestualmente al resto. Vedi Libri contabili - numerazione pagine.

Stampa dettaglio codici iva per:
Esenti, Reverse Charge, San Marino, Iva agricola
Spuntando queste opzioni si ottiene la stampa dettagliata per codice iva (e non per aliquota)

Se la ditta è trimestrale
 Si renderà necessario effettuare una chiusura di prova al 10/12 per calcolare l'eventuale importo dell'acconto da versare. Per fare questo occorre non aver aggiornato dicembre e mettere nelle date per la simulazione dall'1/1/xx al 20/12/xx oppure aver aggiornato SOLO fino al 20/12.

La chiusura del 4' trimestre predispone un pulsante già inizializzato con l'opzione: Non aggiornare l'IVA versata
Questo rispecchia il modo di operare della maggioranza delle aziende.
Confermando l'esecuzione con questa opzione, l'eventuale iva da versare nel quarto trimestre non verrà considerata versata e verrà riportata nella chiusura iva annuale.
In stampa, se si sceglie di "Non aggiornare" verrà stampato: (*) a fianco ai campi che risultano essere solo un'evidenza (Interessi, Iva da versare etc.)
Dalle istruzioni per la compilazione della Comunicazione Liquidazioni periodiche Iva si riporta:
I contribuenti trimestrali di cui all’art. 7 del d.P.R. 14 ottobre 1999, n. 542, versano l’IVA dovuta per il 4° trimestre trimestre, comprensivo degli interessi dell’1%, in sede di conguaglio annuale, entro l’ordinario termine di versamento previsto per la dichiarazione annuale. Pertanto, tali contribuenti, nella Comunicazione relativa al quarto trimestre, non devono compilare i righi VP11(Crediti d'imposta), VP12 (Interessi) e VP14 (Iva da versare) e inoltre devono indicare “5” per il quarto trimestre nel campo VP1: Trimestre

Chi invece versa effettivamente l'iva di dicembre, dovrà togliere la spunta alla suddetta opzione e nella Comunicazione Liquidazione Periodica Iva verrà riportata l'iva versata e il VP1 verrà impostato a 4

Nella maschera della chiusura annuale, verrà fatta un'altra domanda:
Tener conto dell'iva versata nel 4' trimestre
La risposta viene impostata a NO e può essere variata.
Si dovrà valutare se tenerne conto o no a seconda di come è stata fatta la chiusura del 4' trimestre.
Solo se, in quella sede, si era scelto di aggiornare l'Iva versata (cioè era stata tolta la spunta all'opzione proposta a video), ha senso spuntare, in questa fase, l'opzione che dice di tenerne conto.

VISUALIZZAZIONE RISULTATO CALCOLI CHIUSURA
Gli importi vengono visualizzati secondo lo schema della Comunicazione Liquidazione Periodica Iva (dal 2017)
L'utente può confermare la maschera così com'è oppure può intervenire per rettificare o completare alcuni dati.

Nuovi campi 2018 da valorizzare, quando necessario, per la Comunicazione Liquidazioni Periodiche:

  • Operazioni Straordinarie
    La casella va barrata in caso di contribuenti con operazioni straordinarie o altre trasformazioni sostanziali soggettive (fusioni, scissioni, cessioni di azienda, conferimenti, ecc.) nel caso in cui ci sia un trasferimento del credito.
  • Metodo calcolo acconto
    Se presente l'acconto occorre impostare il metodo con cui è stato calcolato

Per quanto riguarda il calcolo dei due importi: Totale delle operazioni attive e passive occorre fare attenzione alla correttezza dei flag sui codici iva: "Tipo iva", "Comunicazione annuale: op.attive/passive", "Cessioni intra cee", "servizi cee"

Importo | Modalità di calcolo
Totale delle operazioni attive (al netto dell'iva) | Imponibili vendite e corrispettivi + imponibile iva sospesa e iva per cassa vendite + importi esenti/non imponibili delle vendite e corrispettivi sul cui codice iva è stato impostato che va sommato in "Comunicazione annuale: op.attive/passive" Non si sommano gli importi Reverse Charge, quelli delle autofatture, quelli delle fatture registrate a fronte di acquisti intra cee, quelli relativi a incassi di iva per cassa e iva sospesa.
Totale delle operazioni passive (al netto dell'iva) | Imponibili acquisti (anche regime del margine) + importi acquisti esenti/non imponibili sul cui codice iva è stato impostato che va sommato in "Comunicazione annuale: op.attive/passive". + imponibile cee acquisti + imponibile iva sospesa acquisti++ imponibile iva per cassa acquisti + imponibile iva non detraibile acquisti + imponibili Reverse Charge, NoCee e RSM Non si sommano i movimenti dei pagamenti di iva per cassa e iva sospesa.
IVA esigibile (V) | Somma dell'iva a debito (vendite e corrispettivi) dei vari periodi
IVA detratta (A) | Somma dell'iva a credito (acquisti) dei vari periodi
IVA dovuta (Debito o Credito) | Calcolato: (V) - (A)
Debito precedente | Iva non versata in precedenza perchè inferiore a 25,82 euro (tale importo minimo va impostato nella tabella dei dati iniziali iva (menu Contabilità - Iva)
Credito periodo precedente | E' l'eventuale Credito con cui si è chiuso il periodo precedente eventualmente detratto degli eventuali Crediti chiesti a rimborso o accantonati
Credito anno precedente (se 1' periodo) di cui Credito Compensabile (periodi succ.) | Nella prima liquidazione dell'anno (Gennaio o 1' trimestre) è l'eventuale credito riportato dall'anno precedente, inserito nella tabella dei dati iniziali iva (menu Contabilità - Iva). Nelle Liquidazioni successive è l'eventuale importo di credito iniziale che ancora si può utilizzare in compensazione
VP16-Credito compensabile utilizzato per iva | E' la parte di credito iniziale utilizzato nel periodo per coprire un eventuale debito iva. Questo campo, normalmente, è disabilitato e quindi gestito automaticamente dal programma. Se si rende necessario variare l'importo proposto occorre spuntare il campo Abilita e blocca importo VP16.
Abilita e blocca importo VP16 | Consente di impostare manualmente il campo VP16 Credito compensabile
(Disponibile: xxxx) | E' la parte di credito iniziale ancora disponibile per F24
Credito da utilizzare in compensazione con modello F24 | E' l'eventuale importo
Versamenti auto UE | Importo libero. Indicare eventuali versamenti per cessione interna di autoveicoli in precedenza oggetto di acquisto intracomunitario
Crediti d'imposta | Importo libero. Indicare particolari crediti di imposta utilizzati nel periodo esclusi quelli la cui compensazione avviene con F24
Iva dovuto o a Credito | Risultato compreso di tutto il credito iva compensabile (di inizio anno)
Credito infrannuale da accantonare | Nei mesi 3 , 6 ,9 12 è possibile accantonare del credito che si è formato nell'anno (non si può accantonare la parte di credito derivante dal credito di inizio anno)
Credito Infrannuale utilizzato per F24 nel periodo | E' la parte del credito infrannuale accantonato che verrà utilizzato per F24. Questo importo serve SOLO per essere stampato sulla Chiusura
Interessi dovuti per liquidazioni trimestrali | Importo degli interessi dell' 1% calcolati, nelle liquidazioni delle aziende trimestrali, sull'eventuale debito. Nel mese di dicembre il calcolo degli interessi viene fatto sul debito risultante dalla liquidazione detratto dall'eventuali acconto versato.
Acconto dovuto | Importo dell'acconto eventualmente pagato nel mese di dicembre
Metodo utilizzato per la determinazione dell'acconto | Per Com.Liquidazione Iva: Storico - Previsionale - Analitico - Sogg.particolari (campo da valorizzare se acconto diverso da 0)
Iva da versare | Importo dell'iva da versare, comprensivo degli interessi se liquidazione trimestrale

Se il periodo si chiude a debito, si può barrare la casella in fondo: stampo estremi di versamento, inserire la data in cui è stato fatto il versamento e compilare il campo A mezzo (si può scrivere una volta per tutte in Dati generali per iva annuale (e periodica) nella sezione periodica), in questo modo verrà stampata, in fondo alla chiusura, la frase:

Versamento-compensazione di X euro eseguito il xx/xx/xx a mezzo ….

In stampa viene riepilogato l'utilizzo del Credito iniziale:

Credito IVA compensabile all'inizio del periodo | Nella prima liquidazione dell'anno (Gennaio o 1' trimestre) è l'eventuale credito riportato dall'anno precedente, inserito nella tabella dei dati iniziali iva (menu Contabilità - Iva). Nelle Liquidazioni successive è l'eventuale importo di credito iniziale che ancora si può utilizzare in compensazione sia per iva sia per F24
Credito IVA compensabile utilizzato nel periodo per IVA |
Credito IVA compensabile utilizzato nel periodo per F24 |
Credito IVA compensabile rimasto alla fine del periodo | Credito che nei periodi successivi potrà essere utilizzato, oltre che per iva, anche per F24

ed eventualmente il Credito infra-annuale accantonato e utilizzato per F24

Credito infra-annuale accantonato nel periodo | Nei mesi 3 , 6 ,9 12 è possibile accantonare del credito che si è formato nell'anno (non si può accantonare la parte di credito derivante dal credito di inizio anno)
Credito del periodo da rimandare al periodo successivo | E' il credito del periodo detratto dell'importo del credito accantonato e che diventerà il Credito Precedente nella liquidazione del periodo successivo
Credito infra-annuale utilizzato nel periodo per F24 | Importo
Credito infra-annuale accantonato residuo |

______________________________________________________________

Utilizzo del credito di inizio anno:
Credito da utilizzare in compensazione con mod. F24: è possibile inserire in questo campo un valore fino a quando resta disponibile del Credito di inizio anno (perché non utilizzato per coprire un debito iva o per F24 di periodi precedenti). L'importo di credito disponibile viene evidenziato a sinistra del campo. Se, nella stessa liquidazione si sta già utilizzando del credito iniziale in VP16, quello disponibile per F24 sarà quello disponibile inizialmente, diminuito di quello utilizzato in VP16.

La parte di Credito iniziale non utilizzato né nel credito compensabile per iva né in quello per F24 resterà disponibile per i periodi successivi.

Utilizzo del credito infrannuale:
Per le aziende che ne hanno diritto (es. esportatori abituali o dalle aziende il cui fatturato è per più del 70% indirizzato verso esportatori abituali) è possibile accantonare l'eventuale credito accumulato nel trimestre o nell'ultimo mese di ogni trimestre, per utilizzarlo per altri tributi in F24.
Nella chiusura iva del trimestre o, dei mesi 3, 6, 9 e 12 (se l'azienda è mensile) , se c'è un credito di iva, viene consentito all'operatore di digitare l'eventuale parte di credito da accantonare poi si chiede di specificare, quale parte, di tale credito accantonato, verrà utilizzato in quel mese, per F24. I campi interessati sono:
Credito iva infrannuale da accantonare (utilizzabile per F24 nel periodo corrente e/o nei successivi)
Credito infrannuale utilizzato per F24 nel periodo
Esempio
Il primo trimestre a credito, consente di inserire un importo in Credito infr. da accantonare e di indicare se ne è già stato utilizzato per F24 (campi in basso a destra)

Secondo trimestre:

Se, come nell'esempio, si chiude a credito, si consente di inserire un ulteriore importo in Credito infr. da accantonare (importo che non può superare il credito del periodo) e di indicare l'eventuale importo del credito utilizzato per F24 (campi in basso a destra). In rosso viene evidenziato l'importo del credito residuo derivante dal periodo precedente.

Se i periodi suddetti si chiudono a debito, verrà data la possibilità di inserire solo l'eventuale importo di credito da utilizzare (se l'ammontare del credito accantonato Residuo è maggiore di 0).
Ci pensa il programma, in fase di stampa, a calcolare il totale del credito accantonato e a segnalare il residuo.

Nella chiusura annuale i due campi suddetti vengono compilati rispettivamente con la somma di tutti i crediti accantonati e con la somma di quelli utilizzati e poi viene calcolato il credito accantonato residuo. (Vedi anche esempio)

Chiusura annuale:
Se l'anno si chiude a credito, il programma quando si esegue la stampa 'Definitiva', memorizza il credito da mandare all'anno successivo sui dati iniziali iva dell'anno successivo. Se si chiude a debito, mette il credito di inizio anno successivo a 0. (Si chiede quindi di fare attenzione quando si esegui la chiusura dopo aver già impostato i dati iva anno nuovo)
(prima faceva: credito derivato dalla chiusura iva - credito accantonato + credito residuo)

Se l'azienda ha dei corrispettivi da ventilare, in fase di chiusura annuale viene rifatta la ventilazione del totale incassi da ventilare anno, sulla base di ventilazione annuale, questo porta a importi diversi degli incassi ventilati, rispetto quelli calcolati nell'ultimo mese o trimestre. Inoltre dopo la preparazione dei dati per la comunicazione iva annuale, non rifacendo essa la ventilazione ma sommando tutti i dati periodici, si riscontrava una differenza tra l'iva esigibile della chiusura anno e quella della comunicazione, differenza dovuta al modo diverso di fare i calcoli, differenza che si ripercuote anche nelle operazioni attive.

Per eliminare questo problema, in fase di chiusura iva annuale di una ditta con una sola attività e con ventilazione, viene memorizzato un record con periodo di comodo (98) sulla tabella IvaDichPeriod con i dati della chiusura in modo che il calcolo della Comunicazione iva possa leggere da lì i due importi suddetti invece di ricalcolarli.

Regime dell' Iva per Cassa

L'iva si dovrà pagare e detrarre al momento dell'incasso/pagamento delle fatture.
In presenza di Iva per Cassa verranno evidenziate, in ogni periodo, imponibile e imposta distinte per:

  • Iva per Cassa per incasso / Iva per Cassa Pagata
    importo totale dell'iva incassata/pagata nel periodo a fronte di fatture emesse/ricevute ancora aperte
  • di cui Incassata/Pagata nell'anno di emissione delle rispettive fatture
    importo dell'iva incassata/pagata, riferita a fatture emesse nell'anno corrente (quello di cui si sta stampando la chiusura)
    (Questo importo è compreso in quello stampato al punto precedente)
  • Iva per cassa per decorrenza anno
    importo dell'iva delle fatture emesse/ricevute con iva per cassa, non ancora incassate/pagate, per le quali, nel periodo della chiusura , è passato un anno dalla data di emissione. L'iva di tali fatture va 'obbligatoriamente' considerata nella chiusura del periodo.
  • Il totale delle fatture emesse e ricevute, nel periodo, con iva per cassa

Nella maschera che mostra il risultato della chiusura, viene visualizzato un pulsante'Mostra iva per cassa del periodo' che consente di visualizzare/stampare la lista delle fatture incassate/pagate nel periodo e quelle ancora aperte.

Regime del margine
Se sono state fatte registrazioni di acquisto /cessione di beni usati con causali che interessano il regime del margine, queste non verranno considerate nel calcolo dell'iva del periodo ma conteggiate a parte come descritto nel capitolo regime del margine
Sulla chiusura del periodo verrà indicato (e sommato all'iva a debito) l'eventuale importo di Debito iva da cessione beni usati, su quella annuale verrà stampato il prospetto di ricalcolo del margine sui movimenti di tutto l'anno.

Parametri di personalizzazione utilizzabili:
CogeTerzi

Ricalcolo Operazioni Attive/Passive fino al periodo x
Questa scelta esegue il ricalcolo dei SOLI importi periodici relativi alle Operazioni Attive e Passive da riportare sulla Comunicazione Liquidazioni Periodiche Iva, considerando tutte le registrazioni , anche se già aggiornate, fino al periodo richiesto (mese o trimestre) e considerando le caratteristiche 'corrette e attuali' di causali e codici iva (in particolare l'indicatore che dice, in corrispondenza di codici iva 'esenti' o 'non imponibili' se sommarli o meno) .
(Es. se su una causale 'autofattura' non era stato settato in precedenza il flag 'autofattura', lo si può fare in qualsiasi momento dell'anno e, alla fine, eseguendo questo ricalcolo, gli importi delle autofatture non verranno sommati nelle operazioni attive, come richiesto).

Il ricalcolo è possibile SOLO se è già stata fatta la Chiusura iva, anche solo in prova, per i periodi da ricalcolare


CHIUSURA IVA RIEPILOGATIVA

Percorso: Contabilità - Stampe Fiscali

(di più attività)

Il programma consente di fare un prospetto che riassume le chiusure iva di un periodo di più attività in modo da dare un risultato unico per la compilazione dell'F24.
E' indispensabile, per le ditte che gestiscono più attività, eseguire questa funzione per ogni mese/trimestre prima di eseguire la Preparazione dati per Comunicazione liquidazione Periodica Iva in quanto prepara i dati che poi verranno elaborati da quest' ultima.

Il calcolo viene fatto sommando i risultati delle chiusure, effettuate anche solo in prova, delle varie attività, compensando gli eventuali debiti con i crediti e riportando al periodo successivo l'eventuale credito precedente riepilogativo rimasto.

Mese
E' il mese del quale si vogliono raggruppare le chiusure
Anno
E' l'anno del periodo da elaborare
Numero pagina
Al termine della elaborazione non si aggiorna il numero di pagina.
Se non si vuole stampare il numero di pagina, basta lasciarlo vuoto a video.

Per quanto riguarda la chiusura riepilogativa annuale, essa considera sempre che non sia stata versata l'eventuale imposta da versare nel 4' trimestre.


ESTRAZIONE DATI COMUNICAZIONE LIQUIDAZIONI PERIODICHE IVA

ESTRAZIONE FILE E STAMPA COMUNICAZIONE LIQUIDAZIONI PERIODICHE IVA

Percorso: Contabilità - Iva - Comunicazione Liquidazioni periodiche IVA

Questa funzione consente di estrarre i dati elaborati dalla Chiusura Iva per poterli poi gestire e preparare un file che potrà poi essere caricato sull'applicativo CADI di Zucchetti che consentirà di gestire, preparare il file XML delle dichiarazioni ed eventualmente spedirle all'Agenzia delle Entrate secondo quanto previsto dal 2017.

E' perciò indispensabile aver eseguito almeno in prova, tutte le chiusure dei mesi/trimestre da comunicare. In particolare per la corretta compilazione dei due importi Totale delle operazioni attive e passive occorre fare attenzione a com'è stato compilato sui codici iva che indicano un'esenzione o un non imponibile, il campo : "Comunicazione ann. Iva: Op.attive/passive" Vedi (**)

Prima di eseguire questa funzione, per le ditte che gestiscono più attività, è obbligatorio aver eseguito la Chiusura iva mensile o Trimestrale per tutte le attività (anche se in un mese/trimestre una di esse non ha avuto movimentazione) e anche la Chiusura Riepilogativa.

A video viene richiesto di compilare alcuni campi che costituiscono i dati di 'testata' della comunicazione.
Come specificato sotto, alcuni di questi possono essere preimpostati nelle tabelle Dati per Comunicazioni telematiche (intermediario) e (ditta) - Menu Contabilità - Iva

Anno
E' l'anno della Comunicazione
Numero comunicazione (Trimestre)
Numero da 1 a 4 corrispondente al trimestre cui si riferisce la Comunicazione
Azienda con multiattività
Viene impostato a Si o a No a seconda di quanto specificato nel campo 'Gestione più attività iva' nella tabella 'Parametri di Contabilità' (menu Parametri e utilità - Dati azienda
Subfornitura - Eventi eccezionali
Spuntare o meno i campi a seconda che si verifichi la necessità nel periodo in oggetto

Dichiarante (compilare se diverso dal contribuente)
Vengono visualizzati i dati letti dalla tabella 'Dati per comunicazioni telematiche (ditta)' nella sezione DICHIARANTE
Codice fiscale / Codice fiscale società dichiarante
Verrà compilato un campo o l'altro a seconda che in Cod.Fiscale / P.Iva dichiarante sia stato messo un codice fiscale o una partita iva.
Codice carica
Firma dichiarante
Questo campo viene impostato sempre a Si in quanto la Comunicazione non è valida se non risulta firmata
La firma che verrà stampata sul cartaceo, se presente, viene letta dai 'Dati per Comunicazioni Telematiche (ditta)' (menu contabilità - iva) nella sezione DICHIARANTE
Presenza di anomalie
Spuntare o meno il campo a seconda che si verifichi la necessità nel periodo in oggetto

IMPEGNO ALLA PRESENTAZIONE TELEMATICA
Codice Fiscale dell'incaricato
Impegno alla presentazione
Data dell'impegno
Firma dell'intermediario - Questo campo viene impostato sempre a Si in quanto la Comunicazione non è valida se non risulta firmata

Se la presentazione delle Comunicazioni viene fatta da un intermediario, ed è stato compilato con la funzione Dati per Comunicazioni Telematiche (intermediario) menu Contabilità - Iva, il Codice fiscale dell'intermediario che effettua la trasmissione, verrà visualizzato questo campo nell'elaborazione delle Liquidazioni di tutte le ditte con possibilità di variarlo.
Il campo Impegno alla presentazione: verrà compilato in base a quanto scritto sulla tabella 'Dati per Comunicazioni Telematiche (ditta)' (se compilati) oppure su Dati per Comunicazioni Telematiche (intermediario)

(**) Calcolo degli importi

Per quanto riguarda il calcolo dei due importi: Totale delle operazioni attive e passive occorre fare attenzione alla correttezza dei flag sui codici iva: "Tipo iva", "Comunicazione annuale: op.attive/passive", "Cessioni intra cee", "servizi cee"

Importo | Modalità di calcolo
Totale delle operazioni attive (al netto dell'iva) | Imponibili vendite e corrispettivi + imponibile iva sospesa e iva per cassa vendite + importi esenti/non imponibili delle vendite e corrispettivi sul cui codice iva è stato impostato che va sommato in "Comunicazione annuale: op.attive/passive" Non si sommano gli importi Reverse Charge, quelli delle autofatture, quelli delle fatture registrate a fronte di acquisti intra cee, quelli relativi a incassi di iva per cassa e iva sospesa.
Totale delle operazioni passive (al netto dell'iva) | Imponibili acquisti (anche regime del margine) + importi acquisti esenti/non imponibili sul cui codice iva è stato impostato che va sommato in "Comunicazione annuale: op.attive/passive". + imponibile cee acquisti + imponibile iva sospesa acquisti++ imponibile iva per cassa acquisti + imponibile iva non detraibile acquisti + imponibili Reverse Charge, NoCee e RSM Non si sommano i movimenti dei pagamenti di iva per cassa e iva sospesa.
IVA esigibile (V) | Somma dell'iva a debito (vendite e corrispettivi) dei vari periodi
IVA detratta (A) | Somma dell'iva a credito (acquisti) dei vari periodi
IVA dovuta (Debito o Credito) | Calcolato: (V) - (A)
Debito periodo precedente non superiore 25,82 euro | Iva non versata in precedenza perchè inferiore a 25,82 euro (tale importo minimo va impostato nella tabella dei dati iniziali iva (menu Contabilità - Iva)
Credito periodo precedente | E' l'eventuale Credito con cui si è chiuso il periodo precedente eventualmente detratto degli eventuali Crediti chiesti a rimborso o accantonati
Credito anno precedente | Nella prima liquidazione dell'anno (Gennaio o 1' trimestre) è l'eventuale credito riportato dall'anno precedente, inserito nella tabella dei dati iniziali iva (menu Contabilità - Iva). Nelle Liquidazioni successive è l'eventuale importo di credito iniziale utilizzato per F24 , che quindi dovrà essere detratto dal credito totale
Versamenti Auto UE | Importo libero
Crediti d'imposta (*) | Importo libero (VP11)
Interessi dovuti per liquidazioni trimestrali(*) | Importo degli interessi dell' 1% calcolati, nelle liquidazioni delle aziende trimestrali, sull'eventuale debito (VP12)
Acconto dovuto | Importo dell'acconto eventualmente pagato nel mese di dicembre
Iva da versare / a Credito(*) | Risultato finale della liquidazione (VP14)

(*)Nota per i Contribuenti Trimestrali
La chiusura iva del 4' trimestre predispone un pulsante già inizializzato con l'opzione: Non aggiornare l'IVA versata
Questo rispecchia il modo di operare della maggioranza delle aziende.
Confermando l'esecuzione con questa opzione, l'eventuale iva da versare nel quarto trimestre non verrà considerata versata e verrà riportata nella chiusura iva annuale.
Dalle istruzioni per la compilazione della Comunicazione Liquidazioni periodiche Iva si riporta:
I contribuenti trimestrali di cui all’art. 7 del d.P.R. 14 ottobre 1999, n. 542, versano l’IVA dovuta per il 4° trimestre trimestre, comprensivo degli interessi dell’1%, in sede di conguaglio annuale, entro l’ordinario termine di versamento previsto per la dichiarazione annuale. Pertanto, tali contribuenti, nella Comunicazione relativa al quarto trimestre, non devono compilare i righi VP11(Crediti d'imposta), VP12 (Interessi) e VP14 (Iva da versare) e inoltre devono indicare “5” per il quarto trimestre nel campo VP1: Trimestre

Chi invece versa effettivamente l'iva di dicembre, dovrà togliere la spunta alla suddetta opzione in Chiusura Iva e nella Comunicazione Liquidazione Periodica Iva verranno compilati i campi VP11, VP12 e VP14 e il VP1 verrà impostato a 4


GEST.DATI COMUNICAZIONE LIQUIDAZIONI PERIODICHE IVA

Percorso: Contabilità - Iva - Comunicazione Liquidazioni periodiche IVA

Questa funzione consente la gestione dei dati estratti dalla funzione di Preparazione dati per Comunicazione Liquidazione Periodica per poi preparare il file da spedire all'Agenzia delle Entrate

La gestione è composta da un gruppo di dati, identificati dal numero comunicazione (Trimestre 1-4) che costuiscono la testata cioè la prima pagina del modulo cartaceo e dati iniziali del file da preparare. Ad ogni testata corrispondono delle righe di dettaglio che contengono gli importi delle liquidazioni da inviare in ogni periodo.

Es. per una ditta mensile dopo la preparazione dati per il primo trimestre sarà una testata e tre righe di dettaglio contenenti rispettivamente le liquidazioni di Gennaio , Febbraio e Marzo.

Numero Comunicazione
E' il numero della Comunicazione (1-4)
Anno
E' l'anno della Comunicazione
Codice Fiscale / Partita Iva
Dati del soggetto d'imposta letti dall'anagrafica ditta oppure, se compilati, da Dati per Comunicazioni Telematiche (ditta)' (menu contabilità - iva) nella sezione 'Dati del contribuente'

Partita Iva delle controllate - Ultimo mese - Liquidazione di gruppo
Campi da compilare solo se la comunicazione è presentata da società che si è avvalsa della comunicazione dell'iva di gruppo

Dichiarante (se diverso dal contribuente) - Letti dalla tabella 'Dati per Comunicazioni Telematiche' nella sezione DICHIARANTE
Codice fiscale / Codice fiscale società dichiarante
Verrà compilato un campo o l'altro a seconda che in Cod.Fisc / P.Iva dichiarante sia stato messo un codice fiscale o una partita iva.
Codice carica
Firma dichiarante S/N
La firma che verrà stampata sul cartaceo, se presente, viene letta dai 'Dati per Comunicazioni Telematiche (ditta)' (menu contabilità - iva) nella sezione DICHIARANTE
Presenza di anomalie
Spuntare o meno il campo a seconda che si verifichino anomalie nel periodo in oggetto

IMPEGNO ALLA PRESENTAZIONE TELEMATICA (Intermediario)
Codice Fiscale dell'incaricato
Impegno alla presentazione
Data dell'impegno
Firma dell'intermediario

Se la presentazione delle Comunicazioni viene fatta da un intermediario, occorre compilare con la funzione Dati per Comunicazioni Telematiche (intermediario) menu Contabilità - Iva, il Codice fiscale dell'intermediario che effettua la trasmissione. Quest'ultimo codice va impostato una volta sola e vale per tutte le ditte.
Il campo Impegno alla presentazione: verrà compilato in base a quanto scritto sulla tabella 'Dati per Comunicazioni Telematiche (ditta)' (se compilati) oppure su Dati per Comunicazioni Telematiche (intermediario)

DETTAGLIO

Numero modulo
E' il numero della riga all'interno della comunicazione

Importi (Vedi schema)


PREP. FILE COMUNICAZIONE LIQUIDAZIONI PERIODICHE IVA

Percorso: Contabilità - Iva - Comunicazione Liquidazioni periodiche IVA

Questa funzione consente di stampare la Comunicazione liquidazione periodica sul modulo previsto dall'Agenzia delle Entrate e di estrarre un file in formato XML o in formato TXT

I dati sono quelli elaborati con la funzione Preparazione dati ed eventualmente variati con la Gestione dati

Il nome del file TXT che dovrà essere letto dal CADI Zucchetti dovrà essere Liquidazione.N dove N è il numero dell'azienda all'interno del pacchetto Cadi.

Il nome del file XML dovrà essere in questa forma: IT00111100111_LI_20171.xml e cioè IT + l’identificativo univoco del responsabile della trasmissione + _LI_ + un progressivo univoco del file ha il solo scopo di differenziare il nome dei file trasmessi da parte del medesimo soggetto (il programma propone l'anno seguito dal numero dell'invio

Nuovi campi 2018 da valorizzare in Chiusura Iva o Gestione dati liquidazione periodica, quando necessario, per la preparazione corretta del file:

  • Operazioni Straordinarie
    La casella va barrata in caso di contribuenti con operazioni straordinarie o altre trasformazioni sostanziali soggettive (fusioni, scissioni, cessioni di azienda, conferimenti, ecc.) nel caso in cui ci sia un trasferimento del credito.
  • Metodo calcolo acconto
    Se presente l'acconto occorre impostare il metodo con cui è stato calcolato


COMUNICAZIONE DATI FATTURE - ESTRAZIONE

Percorso: Contabilità - Iva - Comunicazioni periodiche iva e dati fattura

Verranno estratte tutte le fatture emesse e ricevute del semestre richiesto in base alla data di registrazione al fine di poter preparare il file XML per la Comunicazione delle stesse all'Agenzia delle Entrate.

Prima di procedere con l'estrazione, si raccomanda di leggere attentamente il capitolo Comunicazione dati fatture, in modo da controllare se sono stati preparati bene i dati anagrafici dei clienti e fornitori, le causali e i codici iva.

Anno
Anno della Comunicazione

Numero Comunicazione
Se verrà fatta la Comunicazione semestrale dovrà assumere valore 1 (1' semestre) e 2 (2' semestre)

Data documento da .. a ..
Questi campi consentono di selezionare i documenti di un determinato periodo.
(** Non più utilizzato: Se si abilita il parametro di personalizzazione AbilDate che chiede l'intervallo delle date documento, in questo campo si accetteranno anche i valori 3 e 4 per chi volesse fare la comunicazione trimestrale)

Considerare solo gli stranieri
Consente di estrarre i documenti dei clienti stranieri (con stato diverso da bianco o da IT) per lo scarico dell' Esterometro
Per impostare a Si questo parametro al caricamento della maschera si può attivare il parametro di personalizzazione SoloStranieri

Durante l'estrazione il programma controlla la correttezza dei campi da scaricare e verranno dati dei messaggi ad indicare campi obbligatori mancanti o solo opzionali
I dati anagrafici dei clienti e fornitori (ragione sociale, indirizzo) sono opzionali , obbligatoria è la Partita Iva (o il Codice Fiscale)
Nota: Se, inserendo la Partita Iva di uno straniero, non bastano i caratteri disponibili nel campo P.Iva, si possono mettere i caratteri restanti nel campo Cod. Fiscale facendoli precedere dal segno - (meno)

Se l'elaborazione sostituisce la ragione sociale nei dati fiscali dice: 'messo descrizione'

Si può impostare il parametro di personalizzazione EstraiAnag ad N per NON scaricare tali dati opzionali

Se su una registrazione estratta si trova il campo Bolla Doganale impostato ad S verrà compilato sul file ID Paese=OO e IDCodice=99999999999
(Questo campo viene impostato a Si dall'estrazione in corrispondenza a registrazioni con causali che abbiano il campo 'Import No Cee' spuntato, senza causale concatenata oppure con causale concatenata di tipo Generico (quindi non si è fatto il reverse charge), con fornitore italiano (es. Bolla doganale)
Se in tale registrazione manca il fornitore (black list) collegato o c'è ma con stato IT viene dato anche il messaggio 'manca il fornitore straniero

Messaggi dati dal programma:

  • Registrazione Anno xxxx Nr. yy non ha record iva corretto
    Se si verifica questo messaggio il file estratto NON è corretto. Pertanto è indispensabile entrare nella registrazione specificata con il programma di Input Prima Nota, premere F10 per entrare nei dettagli poi uscire, senza fare modifiche ma salvando, in modo che la registrazione venga riscritta corretta.
  • Se fornitore persona giuridica senza partita iva, viene data una segnalazione bloccante
  • Se cliente persona giuridica senza partita iva, viene data una segnalazione ma non è bloccante

Elenco parametri di personalizzazione utilizzabili:

Gruppo: DatiFat

Parametro: AbilDate Se vale S viene abilitata la gestione delle date a video per la selezione delle registrazioni

Parametro: PIvaGiurid
Per compilazione dei campi Cognome e Nome o Ragione Sociale
Valore di default= N cioè per la compilazione di Cognome e Nome si testa il flag Persona Fisica o Persona Giuridica
Se si imposta a S questo parametro nel caso di anagrafica

  • senza partita iva e con cod.fiscale che inizia per 8 e 9 verranno compilati sul file i campi Cognome e Nome
  • con partita iva o cod. fiscale che inizia per 8 e 9 verrà compilata la Ragione sociale
  • Negli altri casi, se nella Ragione Sociale calcolata dal programma compare _ (sottolineato) vengono compilati Cognome e Nome altrimenti la Ragione Sociale

Parametro: EstraiCodFisc
Se impostato S estrae anche il campo Codice Fiscale per chi ha Partita Iva

Parametro: UsaFittizio
Se impostato a S permette di aggiungere ai dati della prima nota quelli memorizzati nella prima nota fittizia

Parametro: EstraiAnag
Se impostato con un valore diverso da S, non estrae i dati anagrafici dei clienti e fornitori (dati opzionali)

Parametro: SoloStranieri
Se impostato con un valore S, nel programma di estrazione dati fatture preimposta il flag per estrarre solo gli stranieri (default = N)

Parametro: Anag1000
Se impostato a S verrà spuntato a video il campo ' Suddividere files se supera numero massimo anagrafiche' che consente di produrre più files XML quando si superano le 999 anagrafiche, limite massimo accettato. E' possibile tuttavia variare a video il numero massimo di anagrafiche da inserire in ogni file.
In questo caso in stampa verrà messo davanti al numero progressivo dell'anagrafica una lettera che corrisponde alla lettera che identifica il file sul quale essa è stata scaricata. In questo caso il nome del file conterrà l'anno con una sola cifra (per il 2017 ci sarà 7) e in fondo una lettera che partirà da A per il primo file, B per il secondo etc. (es. IT00111100111_DF_ 71E0A.xml)


COMUNICAZIONE DATI FATTURE - GESTIONE

Questa funzione consente di gestire le registrazioni estratte per la Comunicazione dati fatture prima di generare in modo definitivo il file XML da inviare

Si può cancellare una registrazione estratta ma non ancora elaborata in modo definitivo sul file XML

Si può variare in particolare il fornitore straniero se Bolla Doganale etc. se non era stato collegato alla registrazione di prima nota e questa è già stata stampata su bollato

Per la ricerca delle registrazioni basta compilarne qualcuno (Es. anno e numero comunicazione) e premere il tasto di Ricerca. La ricerca può essere fatta su qualsiasi campo della maschera. Per sbiancare i campi Stato e Tipo Comunicazione, basta premere il tasto destro del mouse o il tasto Canc sul campo da sbiancare.

Il pulsante [image] (X) Ripristina a non inviato consente di ripristinare a 'NON inviati' tutti i documenti che hanno lo stesso numero invio di quello su cui si è posizionati e per i quali è già stato creato il file XML della comunicazione in modo definitivo. Si può eliminare solo l'ultimo invio.
Se si preme questo pulsante quando si è posizionati su un documento per il quale è stata fatta una comunicazione di annullamento (del singolo documento o di tutta la precedente comunicazione) il programma controlla che il documento non sia presente nella tabella come non cancellato (potrebbe essere stata fatta un'estrazione successiva)

Vengono gestiti i campi descritti in seguito:

Comunicazione Anno - Numero (1-4)
Anno e numero progressivo all'interno dell'anno relativo (trimestre) a cui appartiene la registrazione da gestire

Registrazione PN Anno - Numero

Numero cancellazione
Questo campo normalmente vale 0. Se la registrazione è stata comunicata, poi cancellata (annullata) la comunicazione (creando un nuovo file XML di annullamento della sola registrazione o di tutto il file inviato precedentemente) essa verrà marcata con un numero progressivo di cancellazione (numero che si può rilevare dall' ultima cifra del nome del file generato per la cancellazione)

Tipo Comunicazione

  • Fatture Emesse
  • Fatture Ricevute

Stato:
Indica se la registrazione è stata comunicata oppure se, una volta comunicata, è stata anche fatta una comunicazione di annullamento della Comunicazione precedente

  • Normale
  • Cancellato file
  • Cancellato Singolo

Cliente / Fornitore
Se non è stata scelta nessun tipo comunicazione, con i tasti F2 ed F3 si cercano i clienti, con F4 e F5 i fornitori

Tipo documento
Indica il Tipo documento, con riferimento alla tabella ministeriale, cui si riferisce la registrazione

Data registrazione

Data e numero documento

Importo documento

Bolla Doganale S/N
Questo campo viene impostato a Si dall'estrazione in corrispondenza a registrazioni con causali che abbiano il campo 'Import No Cee' spuntato, senza causale concatenata oppure con causale concatenata di tipo Generico (quindi non si è fatto il reverse charge), con fornitore italiano (es. Bolla doganale)
Per le registrazioni di questo tipo verrà compilato sul file ID Paese=OO e IDCodice=99999999999

Numero invio e Progressivo nel file
Questi due numeri sono diversi sa 0 una volta preparato il file XML in modo 'definitivo'.

  • Numero invio
    Indica il numero progressivo dell'invio (la prima volta che la registrazione verrà estratta sul file verrà impostato a 1, poi ogni volta che verrà ritrasmessa, per annullamento e per comunicazione successiva, il numero verrà incrementato (questo numero si trova sul nome del file in posizione Z)
  • Progressivo nel file
    Indica la posizione che quel documento ha nella prima comunicazione che lo contiene (indipendentemente dalle volte che è stato inviato)

Base nome file
Sono gli ultimi 5 caratteri del nome del file nel caso che siano stati generati più file per una comunicazione (per eccesso di dimensione)

Campi del dettaglio:
Ogni documento può avere più righe di dettaglio in corrispondenza ad aliquote diverse o alla stessa aliquota ma con Natura diversa es. acquisto con righe in Reverse Charge e righe normali (causale Reverse Charge mista)

Aliquota
E' l'aliquota della riga del documento

Natura
Indica la Natura dell'operazione secondo la Tabella ministeriale. Questo campo viene impostato in automatico dal programma in base a quanto indicato sui codici iva
Campo obbligatorio, in corrispondenza di codici iva con Tipo iva diversi da Normale e Non detraibile

Imponibile / Imposta
della riga

Esigibilità Iva
Questo campo viene impostato in automatico dal programma di estrazione in base alla causale

  • Immediata
  • Differita
    Per iva per Cassa o iva sospesa
  • Scissione dei pagamenti
    Per fatture emesse alla Pubblica Amministrazione (Split Payment)
  • Non definito
    in corrispondenza a righe Esenti

Detraibile / Deducibile
Questi due campi sono opzionali e NON vengono compilati automaticamente dal programma. Possono però essere valorizzati manualmente dall'operatore. Non possono essere presenti contemporaneamente con riferimento allo stesso importo (comporta il rifiuto del file)

  • Detraibile
    Può contenere il valore percentuale di detraibilità, se gli importi si riferiscono a spese detraibili fiscalmente
  • Deducibile
    Indica se gli importi indicati si riferiscono a spese deducibili


COMUNICAZIONE DATI FATTURE - PREP. FILE e STAMPA

Questa funzione deve necessariamente essere preceduta dalla Preparazione dati fatture e provvede a preparare un file, in formato XML, contenente le fatture da comunicare.
Per la correttezza dei dati da estrarre leggere il capitolo Comunicazione dati fatture

E' importante, prima di spedire il file, fare il controllo tramite il sito Fatture e Corrispettivi dell'Agenzia delle Entrate. Per fare ciò è però indispensabile avere le credenziali per entrare sul sito

Se il file viene inviato, poi respinto per errori, si dovranno correggere gli errori e rimandare tutto il file di nuovo con un numero file diverso.
Operativamente occorrerà fare una Cancellazione (ma il file XML relativo non va trasmesso), correggere gli errori, estrarre di nuovo il file e reinviarlo.

Il programma scriverà sul file i dati anagrafici di Clienti e Fornitori completi (Ragione Sociale o Nome e Cognome, Indirizzo, Cap, Comune, Provincia), tuttavia, poichè tali dati sono opzionali (è obbligatoria solo la Partita Iva), si può impostare il parametro di personalizzazione EstraiAnag ad N per NON scaricarli.

In basso nel video viene visualizzata la cartella nella quale il file XML è stato memorizzato.

Tipo elaborazione

  • Prova
    L' elaborazione in prova consente di preparare il file e/o stampare, anche più volte, senza marcare le fatture come inviate (Il nome del file, in questo caso NON valido per l'invio, conterrà il suffisso '_prova'
  • Definitivo
     Per preparare il file da inviare è necessario eseguire l'elaborazione Definitiva
    In questa fase verranno numerate progressivamente le righe messe su file. Se si prepara il file in modo 'definitivo' e non lo si invia perchè ci si rende conto che è 'errato' (manca qualcosa etc.) si potrà annullare questa preparazione dal programma di Gestione
  • Rielabora
    Con Rielabora si potrà ricreare il file XML e/o fare una Ristampa con gli stessi dati ottenuti dalla precedente elaborazione fatta in modo 'definitivo' identificata da 'Numero invio' Si può ripetere n volte e non modifica i dati sulle tabelle

Anno - Comunicazione numero (1-4)
verrà proposto l'anno corrente e il numero progressivo dell'anno relativo al semestre/trimestre da comunicare

Tipo comunicazione
E' possibile, dopo aver inviato un file contenente tutte le fatture del periodo (comunicazione normale), mandare comunicazioni successive per annullare o l'intera comunicazione precedente o singoli documenti in essa contenuti.

  • Normale
    Se è stato scelto Rielabora , verrà chiesto di digitare 'Numero invio' per identificare quale spedizione (all'interno del periodo di comunicazione) si vuole rielaborare

    Il nome del file, con estensione XML, è composto come segue:
    IT + 00000000000 + _DF_ + AA + N + X + Z dove:

    • IT + l’identificativo univoco del responsabile della trasmissione
      Partita iva
    • DF: campo fisso
    • AA: ultime due cifre dell'anno della Comunicazione
    • N: Numero progressivo della Comunicazione (da 1 a 4 cioè una per ogni trimestre)
    • X: Sarà posto uguale a E per il file che contiene le fatture Emesse, R per quelle Ricevute
      In caso di file di cancellazione conterrà il carattere sarà C se si sta cancellando la comunicazione dei clienti, F se quella dei fornitori
    • Z: Numero da 1 a 9 che identifica la spedizione all'interno del periodo di comunicazione (se si fa, per un periodo, un'unica comunicazione questo numero sarà sempre 1, se invece si annulla una comunicazione o una o più fatture, ogni volta che si ritrasmette, nello stesso periodo, questo numero si incrementa)
      In fase di elaborazione definitiva questo numero viene assegnato in automatico come progressivo nel periodo, mentre se si rielabora verrà chiesto all'operatore di digitarlo al fine di individuare la Comunicazione da rielaborare.
      In caso di file di cancellazione conterrà una cifra (progressivo da 1 a 9 per ogni cancellazione)
  • Cancellazione
    Il file per la cancellazione DEVE essere fatto con elaborazione 'Definitiva'
    E' possibile, dopo aver inviato un file (comunicazione normale), mandare comunicazioni successive per annullare o l'intera comunicazione precedente o singoli documenti in essa contenuti. Con questa scelta non è ammessa la Stampa
    Se si intende cancellare un'intera comunicazione occorre digitare l' Identificativo del file da cancellare (stringa fornita dal sistema in fase di invio del file all'Agenzia delle Entrate) , il numero Invio da cancellare, per identificare il periodo di comunicazione.
    Nel caso che nell'invio in oggetto le fatture siano state messe su più file (per superamento di numero massimo), occorre compilare anche il campo: Base File con gli ultimi 5 caratteri del nome del file da cancellare (questi caratteri sono visualizzati in Gestione comunicazione dati fatture nel campo: Base nome file)

    Se si intende cancellare SOLO un singolo documento trasmesso, si dovrà digitare l' Identificativo del file che contiene la registrazione da cancellare, l' anno e il numero di registrazione di prima nota corrispondente a quella fattura. Il programma controllerà che il documento sia già stato spedito e che non sia mai stata mandata una precedente comunicazione di cancellazione dello stesso. In questo caso il nome del file preparato, conterrà, dopo le due cifre dell'anno, il num comunicazione + un numero di 2 cifre (progressivo da 10 a 99 per ogni cancellazione)

Non si consente di comunicare una variazione. Per fare una variazione occorre prima cancellare l'intera comunicazione o un singolo documento poi fare un nuovo invio.

Cosa estrarre
Come da istruzioni dell' Agenzia delle Entrate verranno preparati due file distinti, uno per le fatture emesse (Clienti) e uno per le fatture ricevute (Fornitori) . La preparazione può essere fatta contemporaneamente di entrambi o singolarmente

  • Clienti
  • Fornitori

Identificativo azienda
è possibile creare i file / stampare per un intervallo di aziende, con una singola elaborazione digitando l'intervallo degli ID (da Parametri e Utilità - Dati azienda e parametri - Gestione database aziende)
In questo caso verrà comunque preparato un file per ogni azienda e non verrà visualizzato / gestito il codice fiscale del dichiarante

Visualizzazione dati dichiarante : Codice Fiscale e Codice Carica del dichiarante, solo se si sta elaborando un'unica azienda
Dichiarante (se diverso dal contribuente) - Letti dalla tabella 'Dati per Comunicazioni Telematiche' nella sezione DICHIARANTE
E' possibile variarli a video e in questo caso la variazione vale solo per la comunicazione corrente
Sulle istruzioni della preparazione del file, a proposito di questi campi, viene scritto:
"Questo blocco va valorizzato solo se il soggetto obbligato alla comunicazione dei dati fattura non coincide con il soggetto passivo IVA al quale i dati si riferiscono. NON deve essere valorizzato se per il soggetto trasmittente è vera una delle seguenti affermazioni:
- coincide con il soggetto IVA al quale i dati si riferiscono;
- è legato da vincolo di incarico con il soggetto IVA al quale i dati si riferiscono;
- è un intermediario.
In tutti gli altri casi questo blocco DEVE essere valorizzato."

Tipo Elaborazione:

  • Prep. file e stampa
  • Preparazione file
  • Stampa
    Non viene fatta se si è scelto cancellazione
    La stampa, se fatta per elaborazione Definitiva o Riestrazione , riporta in prima posizione sulla riga il campo 'progressivo' che indica la posizione occupata da quel documento sul file. Questo numero è importante per individuare la riga nel caso vengano rilevati errori sul file comunicato.

In Stampa, per ogni Cliente /Fornitore viene riportata, oltre alla Partita Iva (Codice Fiscale), la Ragione Sociale o il Nome e Cognome , indipendentemente dal fatto che sia stato impostato o meno il parametro di personalizzazione EstraiAnag che indica se scaricare o no sul file i dati anagrafici.
Quando si compilano i campi Cognome e Nome (invece di Ragione Sociale) vengono stampati due asterischi tra i due campi: (Rossi ** Guido) in modo da evidenziare il fatto e permettere all'utente di controllare la correttezza di tali dati.

Suddividere files se supera numero massimo anagrafiche e Num. massimo anagrafiche
Se spuntato consente di produrre più files XML quando si superano le 999 anagrafiche, limite massimo accettato.
E' possibile tuttavia variare, al momento, il numero massimo di anagrafiche da inserire in ogni file.
Se si attiva il parametro di personalizzazione Anag1000 con valore S , il campo che indica se suddividere il file verrà spuntato al caricamento della maschera.
In questo caso il nome del file conterrà , dopo il campo fisso DF un insieme di caratteri che chiameremo Base File e che verranno chiesti a video in caso di cancellazione

  • A: ultima cifra dell'anno della Comunicazione (es. 7 per 2017)
  • N: Numero progressivo della Comunicazione (da 1 a 4 cioè una per ogni trimestre)
  • X: Sarà posto uguale a E per il file che contiene le fatture Emesse, R per quelle Ricevute
  • Z: Numero da 1 a 9 che identifica la spedizione all'interno del periodo di comunicazione (se si fa, per un periodo, un'unica comunicazione questo numero sarà sempre 1, se invece si annulla una comunicazione o una o più fatture, ogni volta che si ritrasmette, nello stesso periodo, questo numero si incrementa)
  • Lettera (A, B, C ...) che differenzia i vari file

File estratto nella cartella:
Indica la cartella nella quale verranno generati i file XML. A fianco viene presentato un pulsante 'cambia' per cambiare e memorizzare la cartella di destinazione che verrà salvata nel file AziWin.ini nel gruppo Base con parametro DirDatiFat


IVA PER CASSA - VISUAL. DETTAGLIO INCASSI/PAGAMENTI PERIODO

Percorso: Contabilità - Stampe Fiscali

Il pulsante visibile nella maschera della Chiusura Iva, è attivo se l'azienda applica il regime dell'Iva per Cassa. Consente di visualizzare/stampare l'elenco delle fatture con 'iva per cassa', incassate-pagate, parzialmente o totalmente, nel periodo della liquidazione.
Il pulsante non è utilizzabile se il database è in formato Access 97.

E' inoltre possibile visualizzare anche le fatture non ancora incassate/pagate fino a quel periodo.

Il prospetto è diviso per acquisti e vendite, per ogni sezione vengono riportati i campi:

Numero e data documento
Cliente/Fornitore - Ragione Sociale
Anno e numero registrazione dell'incasso/pagamento
Data incasso/pagamento (se sulla registrazione è bianca viene visualizzata la data registrazione)

Imponibile
 E' la parte di imponibile incassata/pagata nel periodo (A)

Imposta
 E' la parte di imposta incassata/pagata nel periodo (B)

Incasso/Pagamento periodo
 E' l'importo incassato/pagato nel periodo (A+B)

Totale fattura
 E' il totale della fattura

Totale incassato/pagato
 E' il totale incassato/pagato per quella fattura FINO al periodo in elaborazione

Incass./Pagato Esente
E' l'eventuale importo esente presente in una fattura con iva per cassa. Tale importo viene considerato subito nella liquidazione del periodo della fattura


IVA PERIODICA

Percorso: Contabilità - Iva - Gestioni

Il programma consente la gestione dei progressivi che vengono elaborati e memorizzati durante la Stampa della Chiusura Iva periodica (anche se fatta in prova). La gestione avviene per anno iva, codice attività iva e periodo.

Si consiglia vivamente di non cambiare gli importi in questa gestione ma di ripetere la Chiusura Iva del periodo interessato. Se si varia un importo NON verranno ricalcolati gli eventuali importi che dipendono da quello variato.
Questo perchè i calcoli della chiusura iva di ogni mese/trimestre utilizzano questa tabella per riprendere gli eventuali progressivi utili dei periodi precedenti (es. credito precedente) e così pure la chiusura annuale. Inoltre su questa tabella si basa la preparazione dati per la Comunicazione Liquidazione Periodica Iva

I dati gestibili sono divisi in varie maschere:

In Dati dich.periodica e Dati dich.periodica 2' parte: c'è il risultato della Chiusura iva del periodo.

Ci sono due campi che potranno essere utilizzati in fase di chiusura iva, dagli esportatori abituali o dalle aziende il cui fatturato è per più del 70% indirizzato verso esportatori abituali (per cui vendite fatte in esenzione):

Credito iva infrann. accantonato nel periodo

Credito accantonato e utilizzato per F24 nel periodo

Per le aziende suddette è possibile accantonare l'eventuale credito dell'ultimo mese di ogni trimestre, per utilizzarlo per altri tributi. Durante la chiusura iva, in corrispondenza a questi mesi, se il periodo si chiude a credito, viene chiesto all'operatore di digitare l'eventuale parte di credito da accantonare e la parte di tale credito accantonato, da utilizzare in quel mese, per F24.

Se i periodi suddetti si chiudono a debito, verrà data la possibilità di inserire solo l'eventuale importo di credito già accantonato, da utilizzare.

Questi due dati sono quindi relativi al periodo cui si riferiscono. Ci pensa poi il programma di chiusura iva, a calcolare il credito accantonato totale e il residuo.

Altri progressivi periodici: sono gli importi totali del periodo di Iva ad esigibilità differita clienti e fornitori (fatture emesse e ricevute, incassate e pagate), plafond, prorata, gest.Art.74 agenzie di viaggio.
Progressivi Iva per Cassa
sono gli importi totalizzati, nel periodo, dalla Chiusura iva eseguita in Prova o Definitiva relativa alle fatture emesse/ricevute con l'iva per cassa, all'iva per Cassa incassata, pagata totale del periodo e a quella incassata/pagata per scadenza dei termini (cioè relativa a fatture non ancora saldate/incassate ma per le quali è decorso un anno dall'emissione)

Dati per invio telematico:
L'unico campo, di questa pagina, che viene utilizzato è:
Da trasmettere per invio telematico F24
Indica se il periodo in oggetto deve essere preso in considerazione in fase di preparazione del file per l'invio telematico dell'F24. Esso viene impostato a Si dalla Chiusura Iva definitiva del periodo. La preparazione del file per F24, una volta elaborato un determinato periodo, imposta il flag a No. In questo modo, in una successiva rielaborazione dello stesso periodo, questa ditta verrà scartata.

Gli altri dati non vengono più utilizzati in quanto non viene più richiesto l'invio telematico della liquidazione periodica.
Vengono gestiti qui due campi che servono anche alla stampa della seconda pagina della dichiarazione periodica: Impegno a trasmettere telematicamente la dich.del contribuente e Impegno a trasmettere telematicamente la dichiarazione predisposta dal soggetto che la trasmette.

I periodi che si consente di gestire sono i 12 mesi per i mensili e i 4 trimestri per i trimestrali. Si consente inoltre di gestire il periodo 98, un periodo di comodo dove la Chiusura Iva annuale scarica i dati.


F24 IVA - STAMPA E PREPARAZIONE FILE TELEMATICO

Percorso: Contabilità - Iva - File per invio telematico

Il programma consente di stampare gli F24 e/o preparare un file ascii contenente uno o più F24 con i dati della sezione Erario compilata.
Verranno prese in considerazione le ditte, mensili o trimestrali, che, nel mese o trimestre indicato a video hanno un debito (o un credito chiesto a rimborso) e con flag "da trasmettere" impostato a Si.
I dati presi in considerazione sono quelli preparati dalla Chiusura Iva Periodica e gestibili con la funzione: Iva Periodica.
In particolare:

  • "Iva versata", "Credito chiesto a rimborso"
    della maschera (2) Dati Dich.Per. 2'parte
  • Flag "Da trasmettere"
    della maschera (4) Dati per invio telematico
    Quest'ultimo campo viene impostato a Si dalla Chiusura iva fatta "in esecuzione".

L'elaborazione può essere fatta per una sola ditta o per più ditte, in Prova o Definitiva (Esecuzione). Al termine dell'elaborazione Definitiva il programma imposta il flag "da trasmettere" a No.

Si può scegliere:

  • Preparazione del file e stampa elenco ditte elaborate
  • Solo preparazione del file
  • Solo stampa F24
    In questo caso il file non verrà generato e l'elaborazione sarà sempre in Prova.
    Per la stampa è indispensabile aver copiato il file F24.gif nella cartella ..aziwin\immagini (esso contiene il modello fincato su cui stampare i dati dell'F24).

Il file F24TEL.TXT viene generato automaticamente in c:\tmp ma si consente all'operatore di variare la destinazione; la nuova destinazione verrà memorizzata nel file aziwin.ini nel parametro DirF24Telematica.

Tipo F24

  • Mensile/Trimestrale
  • Acconto (elaborazione non completata)
  • Versamento annuale
    Dovrà essere stata eseguita la Chiusura Iva anno (il risultato di questa chiusura è gestibile con la funzione Iva periodica con periodo=98.

Mese / Trimestre da scaricare
Dovrà essere impostato il periodo al quale si riferisce l’F24
Se si elaborano più ditte, alcune mensili altre trimestrali, si potranno compilare entrambi i campi nei mesi 3, 6, 9 , 12 (trimestre 1,2,3,4).
Viceversa il campo trimestre verrà lasciato bianco negli altri mesi.
Se si vogliono elaborare SOLO mensili, si può valorizzare solo il mese, stessa cosa per i soli trimestrali.
A fianco al periodo va impostato il Codice tributo che viene già valorizzato con valori di default.

Elaborazione fatta da intermediario
Questo campo viene automaticamente impostato a Si e può essere variato dall'utente.

  • Si
    Il programma prepara un file unico per tutte le ditte scelte. Nel file preparato, i dati del record A (record di testa) saranno quelli dell’intermediario per cui verranno letti dalla tabella gestita da “Dati per comunicazione annuale iva” (tabella comune a tutte le ditte)
  • No
    Verranno generati file diversi per ogni ditta elaborata (il nome è quello riportato a video seguito dal codice identificativo dell’azienda. Es. F24TEL001.txt)
    Nel record A (record di testa) verranno riportati i dati del contribuente

Se a preparare e spedire il file non è un intermediario ma la ditta stessa, questo campo dovrà essere impostato a No.
E’ possibile creare, nei parametri di personalizzazione, il parametro Intermediario per impostare automaticamente "No intermediario" al caricamento della maschera.

NOTE sulla compilazione dei dati dell'F24
In fase di chiusura iva a debito è indispensabile inserire, nella maschera in cui a video vengono riepilogati dei dati della chiusura, la data versamento e il codice della banca tramite la quale si fa il pagamento.
In Chiusura iva viene proposta, come banca di pagamento, quella inserita nella gestione “Dati generali per iva annuale (e periodica)” nel quadro “dati per iva periodica” con rispettivo Abi e Cab (che, se impostati qui, devono essere corretti).
E' indispensabile inoltre che sull'anagrafica della banca utilizzata per il pagamento vengano inseriti ABI, CAB, Cin e Conto corrente corretti

Se la ditta ha più attività iva, occorre aver eseguito, oltre alle liquidazioni delle varie attività, anche quella riepilogativa.

Se la preparazione dell'F24 viene fatta da un intermediario, occorre compilare i dati dell'intermediario con la funzione:

  • Dati per comunicazioni telematiche (intermediario) (Tabella unica per tutte le ditte, da compilare una tantum)
    Dovrà essere inserito il telefono e l'email (opzionali), il codice fiscale del fornitore (obbligatorio, in Dati per invio telematico),
    e i dati anagrafici delle sezioni per il fornitore persona fisica o non fisica (obbligatori).
    Il campo Tipo Fornitore viene compilato fisso dal programma: 14 se Persona non fisica - 04 se Persona Fisica

Dati di chi effettua il pagamento (rappresentante della ditta) OBBLIGATORI:
vanno compilati su “Dati per comunicazioni telematiche (ditta)”, i dati del dichiarante (rappresentante):
Cod.Fiscale (o partita iva)
Codice Carica (0 o 1)
Altri dati del Rappresentante (dati anagrafici)
Il COGNOME va separato dal NOME con il - (meno)

Dati del contribuente
I dati completi si possono scrivere nella gestione "Dati per comunicazioni telematiche (ditta)”. Se questi dati non sono compilati, verranno presi dall'anagrafica ditta.

www.aziendapc.it
Versione 4.03C 		Apri il sito www.AziendaPC.it


ESTRAZIONE CORRISPETTIVI PER INVIO TELEMATICO

Percorso: Contabilità - Iva - File per invio telematico

Vedi anche Note generali per invio telematico dei corrispettivi
Questa funzione consente di estrarre i corrispettivi di un mese e memorizzare, su una tabella d'appoggio, il totale giornaliero per Aliquota / Tipologia operazione al fine di poterli visualizzare poi preparare il file per l'invio telematico (Utilizzabile dalla grande distribuzione con più punti vendita e requisiti richiesti dalla normativa).
Viene visualizzata la data dell'ultimo corrispettivo estratto e si consente l'estrazione di un mese. Se si chiede un mese già estratto, i nuovi dati calcolati verranno sovrascritti ai vecchi.

Nella comunicazione telematica i corrispettivi devono essere divisi per Punto Vendita per cui occorre aver creato i Punti di cui si vuole fare la comunicazione e assegnato ad ogni Punto l'elenco dei prefissi che identificano sia i suoi corrispettivi sia le eventuali fatture/note credito relative a operazioni, da trasmettere.
Ogni punto vendita dovrà avere prefissi diversi

Per individuare le eventuali fatture/note da estrarre, il programma leggerà i codici delle causali di contabilità scritti rispettivamente nei parametri di personalizzazione: FattCorri e NotaCorri

Per aggiungere delle 'aliquote iva' da scaricare oltre a quelle previste attualmente dal modello per l'invio telematico nel campo 'Aliquota iva' (22,21,10,04,NI,ES,RP) occorre attivare i parametri di personalizzazione EleTelemCod, EleTelemDesc,EleTelemSta
(Es. per aggiungere un'eventuale aliquota 23%)

L'estrazione NON considera le registrazioni con prefissi che appartengono a punti vendita NON attivi.


GESTIONE CORRISPETTIVI PER INVIO TELEMATICO

Percorso: Contabilità - Iva - File per invio telematico

Vedi anche Note generali per invio telematico dei corrispettivi
Questa funzione consente di gestire i corrispettivi di un mese, preparati per l'invio telematico.
I corrispettivi possono essere scritti direttamente con questa gestione oppure si possono vedere e variare gli importi estratti con la funzione Estrazione Corrispettivi.

Viene chiesto l'anno, il mese e il codice del punto vendita Punto Vendita cui appartengono i corrispettivi.
A video vengono proposti, in verticale, tutti i giorni del mese e, sulla riga, per ogni giorno, il totale giornaliero e gli importi del totale corrispettivo (imponibile più imposta) diviso per le aliquote/tipologia operazione previste:
Iva 22%
Iva 21%
Iva 10%
Iva 4%
Non Imponibile
Esente
Regimi Particolari (gli importi di questa colonna non verranno mai scaricati dal programma di estrazione)
Ventilazione (se nell'anagrafica del punto vendita si è detto che ha ventilazione)

Gli importi calcolati dall'estrazione, per ogni aliquota, sono sempre la somma dei corrispettivi più le eventuali fatture/note credito identificate dalle causali indicate nei parametri di personalizzazione FattCorri e NotaCorri

E' possibile muoversi sulla tabella a video con i tasti:
Pg Up e Pg Down (avanza o torna indietro di una pagina)
Ctrl Freccia Dx va alla fine della riga
Ctrl Freccia Sx va all' inizio della riga
Ctrl Freccia Su va all' inizio del mese
Ctrl Freccia Giù va alla fine del mese

NOTA: L'estrazione NON considera le registrazioni con prefissi che appartengono a punti vendita NON attivi.


PREP. FILE PER INVIO TELEMATICO DEI CORRISPETTIVI

Percorso: Contabilità - Iva - File per invio telematico

Questa funzione consente di preparare il file per l'invio telematico dei Corrispettivi dopo aver eseguito l'estrazione dei dati del periodo desiderato.
Vedi anche Note generali per invio telematico dei corrispettivi

Oltre alla comunicazione Ordinaria o Sostitutiva è possibile preparare il file anche per Adesione o Revoca alla trasmissione telematica.

Se si sta facendo un invio Ordinario o Sostitutivo è indispensabile aver fatto, prima, l' Estrazione Corrispettivi per invio telematico per preparare la tabella dei dati da scrivere sul file.
Mentre in caso di Adesione o Revoca , basta aver creato correttamente i Punti Vendita.

Il file contiene anche alcuni dati anagrafici dell'azienda (da compilare sulla tabella dei dati ditta o sulla tabella dei Dati per comunicazioni telematiche (ditta) e dell'eventuale Intermediario (da compilare sulla tabella Dati per comunicazioni telematiche (intermediario) .

Fare attenzione al fatto che i campi 'Data dell'impegno' e 'Impegno a trasmettere ...' sono presenti sia su ogni singola ditta in Dati per comunicazioni telematiche (ditta) sia nella tabella generale Dati per comunicazioni telematiche (intermediario). Il programma, se ci sono sulla ditta leggerà quelli, altrimenti leggerà quelli generali.

Anno e il mese da comunicare

Tipo di invio

  • Ordinario
  • Sostitutivo
    Obbligatorio poi inserire il numero del Protocollo telematico sostitutivo
  • Adesione o Revoca
    Obbligatorio poi inserire la data di adesione o revoca

Tipo operazione
In caso di invio per Adesione o Revoca NON viene mai fatta la stampa mentre per invio Ordinario e Sostitutivo è possibile fare:

  • Estrazione e stampa
  • Solo estrazione
  • Solo stampa

Nome file Ascii
Il programma prepara il nome del file da creare, in questo modo:
per il nome della cartella cerca nel file AziWin.ini, Sezione "Base" la riga
DirCorriTelem=C:\.....
Se non è stata mai impostata questa riga, verrà proposto il percorso della cartella 'Database'
Il nome del file proposto, invece, viene costruito con una parte fissa:
"Corrisp" a cui si aggiunge l'anno e il mese


DATI PER COMUNICAZIONI TELEMATICHE (Intermediario)

Percorso: Contabilità - Iva - Tabella Unica per tutte le ditte

Tabella unica per tutte le ditte.

Contiene delle informazioni generali riguardanti la stampa e la trasmissione telematica dello Spesometro, della comunicazione annuale IVA, della Comunicazione Black List, F24 etc.

I dati vengono proposti su più schermate:
Dati Generali
Dati per invio telematico
Fornitore persona fisica
Fornitore persona non fisica
Fornitore CAF


DATI GENERALI PER IVA ANNUALE (e periodica)

DATI GENERALI (Intermediario)

Percorso: Contabilità - Iva - Tabella Unica per tutte le ditte - Dati per Comunicazioni Telematiche (intermediario)

Questa tabella contiene delle informazioni comuni a tutte le ditte, utilizzate per la preparazione dei file, da inviare telematicamente di: Spesometro Spesometro - Black List, Comunicazione annuale dati iva, F24 , File dei corrispettivi

Tipo Fornitore
Impostare il codice Tipo Fornitore a seconda delle disposizioni date nelle istruzioni per la preparazione del file per l'invio telematico dei vari modelli.
In generale:
01 - Soggetti che inviano la propria comunicazione
10 - Intermediari

Dati INTERMEDIARIO
 Se è compilato il codice fiscale intermediario, i programmi di preparazione file per l'invio telematico richiedono che siano compilati correttamente anche gli altri campi in maschera relativi all'intermediario.

Impegno a trasmettere la dichiarazione predisposta dal contribuente
Impegno a trasmettere la dichiarazione del contribuente predisposta dal soggetto che la trasmette
e Data dell'impegno è possibile compilarli su questa tabella, per tutte le ditte, oppure inserirli sulle singole ditte con la funzione
Dati per Comunicazioni Telematiche (ditta)

Viceversa se manca il codice fiscale NON vanno compilati gli altri dati suddetti
I campi Telefono ed email intermediario, sono opzionali

Maschera: (2)Dati per invio telematico:
per la Comunicazione annuale Dati iva e F24, se la ditta non trasmette da sola la Comunicazione, occorre compilare anche il Codice Fiscale del fornitore cioè di chi effettua la trasmissione telematica dei file e il Tipo fornitore

Le altre maschere:
Maschera (3) Fornitore Persona Fisica
Maschera (4) Fornitore Persona Non Fisica
Maschera (5) Fornitore CAF
Vanno compilate per l'invio dell'F24

Tolti dal video perchè usati solo in Stampa Comunicazione Iva periodica, non più in uso:
Numero copie moduli da stampare
Indica il numero di copie di dichiarazioni da stampare per ogni ditta gestita.
Per stampa su stampanti ad aghi:
Numero righe bianche da lasciare in testa
Viene impostato a 0. Se la stampa, lasciando questo numero a 0 non viene posizionata bene, si può provare a impostarlo per posizionarla. Mettere qui il numero di righe da saltare all'inizio della stampa.


DATI per INVIO TELEMATICO (STUDIO)

Percorso: Contabilità - Iva - Tabella Unica per tutte le ditte - Dati per comunicazioni telematiche (intermediario)

Compilare prima di eseguire la funzione di Preparazione del file per invio telematico della Comunicazione iva annuale e l'invio F24

Compilare il Codice Fiscale del fornitore se a preparare il file è un intermediario.


FORNITORE PERSONA FISICA (dich.telematica studio)

FORNITORE PERSONA FISICA

Percorso: Contabilità - Iva - Tabella Unica per tutte le ditte - Dati per comunicazioni telematiche (intermediario)

Per preparazione file F24

A seconda che chi fa l'invio telematico sia persona fisica, non fisica o Caf occorre compilare la maschera corrispondente con tutti i dati richiesti. Vanno scaricati nel primo record (record A) del file delle dichiarazioni per l'invio telematico.


FORNITORE PERSONA NON FISICA

Percorso: Contabilità - Iva - Tabella Unica per tutte le ditte - Dati per comunicazioni telematiche (intermediario)

Per preparazione file F24

A seconda che chi fa l'invio telematico sia persona fisica, non fisica o Caf occorre compilare la maschera corrispondente con tutti i dati richiesti. Vanno scaricati nel primo record (record A) del file delle dichiarazioni per l'invio telematico.


FORNITORE CAF

Percorso: Contabilità - Iva - Tabella Unica per tutte le ditte - Dati per comunicazioni telematiche (intermediario)

Per preparazione file F24

A seconda che chi fa l'invio telematico sia persona fisica, non fisica o Caf occorre compilare la maschera corrispondente con tutti i dati richiesti. Vanno scaricati nel primo record (record A) del file delle dichiarazioni per l'invio telematico.


DATI PER COMUNICAZIONI TELEMATICHE (Ditta)

Percorso: Contabilità - Iva - Gestioni

Questa funzione consente di inserire i dati anagrafici per la stampa e l'invio telematico della Comunicazione Annuale IVA e dell' F24, per la Stampa della Comunicazione Dichiarazioni di intenti ricevute, per lo Spesometro etc.

E' perciò indispensabile compilare correttamente tutti questi dati prima di procedere alle elaborazioni suddette.

Un primo gruppo di dati riguarda il contribuente e sono da compilare SOLO se il contribuente non coincide con l'intestatario della ditta
Se si preparano gli F24 con il programma, si consiglia di impostare sempre i dati ditta in questa tabella in quanto sono più completi di quanto lo siano sulla tabella Anagrafica ditta.

In questo caso occorre inserire qui TUTTI i dati del contribuente richiesti. Se si tratta di persona fisica la Ragione sociale dovrà contenere Cognome-Nome (cioè il cognome dovrà essere separato dal nome dal carattere - (meno)), in modo tale che là dove sono previsti campi separati per i due, si possano effettivamente riportare separati; il comune dovrà essere quello di nascita e si dovranno compilare anche sesso e data di nascita.

Periodicità di invio della Comunicazione black list
Mensile o Trimestrale. Tale periodicità è determinata dall'ammontare delle importazioni nell'anno.

Altri dati da compilare riguardano il Dichiarante/Rappresentante (se diverso dal contribuente)
Questi campi dovranno essere compilati con i dati del soggetto tenuto alla comunicazione (soggetto che effettua la comunicazione) se questo è diverso dal soggetto cui si riferisce la comunicazione. Servono per le comunicazioni telematiche (es.Spesometro)

ATTENZIONE:
Se il Dichiarante/Rappresentante è una persona fisica è indispensabile compilare il campo Cognome-Nome scrivendo esattamente il COGNOME seguito dal NOME, separati dal carattere - (meno) es. Rossi-Mario

Se Codice Fiscale/Partita Iva Rappresentante è compilato si chiede di compilare, se 'esistono' due nuovi campi:
'Data inizio procedura o decesso' e 'Data fine procedura' (Spesometro)
Nello Spesometro il Rappresentante va compilato SOLO se previsto dalle istruzioni per cui se si vuol lasciare compilato il codice fiscale rappresentante per altri invii ma nello Spesometro NON ci va occorre compilare la 'data inizio procedura o decesso' con il valore 01/01/1919

Intermediario
Se la presentazione delle Comunicazioni viene fatta da un intermediario, occorre compilare per ogni ditta il flag che indica il tipo di impegno e la data dell' impegno e inoltre, in Contabilità - Iva - Dati per Comunicazioni Telematiche (Intermediario), il Codice fiscale dell'intermediario che effettua la trasmissione. Quest'ultimo codice va impostato una volta sola e vale per tutte le ditte.

Nella seconda pagina si possono gestire alcuni dati utilizzati in chiusura iva periodica:
Banca (Abi - Cab)
Impostare con il codice della banca utilizzata per pagare il debito iva. Se si preparano gli F24, nell'anagrafica della banca devono essere stati impostati correttamente Abi, Cab, Cin e numero conto corrente.
Al momento della Chiusura iva a debito, verrà presentata questa come banca ma l'utente può decidere di sceglierne un'altra al momento.

Versamento iva a mezzo (es. a mezzo Mod.F24)
Il contenuto di questo campo verrà stampato sulla Chiusura iva di ogni periodo che si chiude a debito, se si sceglie di stampare gli estremi di versamento.


RICALCOLO PROGR. IVA PER ELENCO CLIENTI-FORNITORI

RICALCOLO DATI IVA PER ELENCO CLIENTI-FORNITORI

Percorso: Contabilità - Utilità

Questa funzione esegue l'aggiornamento dei movimenti iva finalizzato alla preparazione dei progressivi iva clienti e fornitori per la compilazione del file per l'invio telematico dell'Elenco clienti e fornitori (invio non più da effettuare).

Non si tiene conto del fatto che i movimenti iva siano aggiornati o meno per cui la funzione può essere ripetuta più volte per lo stesso anno.

Verranno considerati tutte le registrazioni con anno della data documento uguale all'anno da elaborare (anno per il quale si stanno preparando gli elenchi).

I progressivi calcolati possono essere gestiti con la funzione: Contabilità - Servizio - Progressivi iva clienti e fornitori.

Nell'aggiornamento di questi progressivi si tiene conto in particolare dei flag impostati su ogni codice iva nella sezione: elenco clienti e fornitori per cui è indispensabile che siano stati impostati correttamente.

Verranno inoltre tenuti separati i progressivi relativi a note di variazione emesse o ricevute nell'anno ma relative ad anni precedenti (sono identificate da un campo particolare da compilare, a cura dell'utente, in testata della fattura in fase di registrazione della stessa in Fatture o in Prima nota) (dati obbligatori per gli Elenchi relativi all'anno 2008 e successivi).


COMUNICAZIONE DICHIARAZIONI DI INTENTO RICEVUTE

COMUNICAZIONE DICHIARAZIONI DI INTENTO A FORNITORI

Percorso: Contabilità - Iva - Stampe

Dal 12 febbraio 2015 gli esportatori abituali che intendono acquistare o importare senza applicazione dell'IVA debbono trasmettere telematicamente all'Agenzia delle Entrate la dichiarazione d'intento. La stessa dichiarazione, unitamente alla ricevuta di presentazione rilasciata dall'Agenzia delle Entrate, va poi consegnata al fornitore o prestatore, oppure in Dogana.

Il programma consente di Stampare e preparare il file telematico della Dichiarazione d' Intento di Acquistare o importare beni e servizi senza applicazione dell' iva.

E' indispensabile che nella cartella aziwin\immagini siano presenti i due file contenenti le due pagine del modulo: LetteraIntFornTest.gif e LetteraIntFornDett.gif

E' possibile la selezione dei fornitori destinatari della dichiarazione.
Su tali fornitori dovrà essere compilata almeno una riga nella maschera 9) DichIntenti.
Nel caso di Importazione o Dogana , sul fornitore dovrà essere impostato a Importazione o Dogana nella maschera (4) Contabilità il campo 'In Elenco Cli/For'

E' possibile fare Prestampa - Stampa - Ristampa
Verranno considerate le righe con Dati dichiarazione di intenti definite come Attive (S) e con Data Dichiarazione compresa nell' anno impostato a video
In caso di ristampa verranno considerate le righe Attive e già stampate (X)

Se si intende rettificare o integrare i dati di una dichiarazione già presentata è necessario inviare una nuova dichiarazione barrando la casella Integrativa e compilare il numero di protocollo della dichiarazione che si intende integrare. La dichiarazione integrativa sostituisce la precedente.

E' possibile eseguire SOLO la stampa o preparare anche il file.
Inizialmente a video viene presentata la cartella e il nome di default assegnato al file, l'utente può variare nome e destinazione che il programma, in seguito, manterrà per le prossime elaborazioni (verrà memorizzato nell'aziwin.ini, sezione [Base] riga: FileDichIntenti=C:\....(Percorso)

Comunicazione inviata da un intermediario
Se l'elaborazione è fatta da un intermediario occorre compilare in Dati per comunicazione annuale iva (Tabella unica per tutte le ditte, da compilare una tantum) i campi:
'Tipo fornitore' impostato a 10
'Partita Iva o cod. fiscale dell'Intermediario'
'E' presente la firma'
In questo caso la casella Comunicazione inviata da un intermediario, presentata a video, verrà barrata. E' possibile togliere la spunta per escludere l'intermediario nel caso che questa comunicazione venga fatta direttamente dal Soggetto

Se la comunicazione è inviata dall'intermediario, occorre compilare la data dell'impegno

Tipo Plafond
Indicare la natura del Plafond: Fisso o Mobile

Operazioni che concorrono alla formazione del Plafond

  1. Dichiarazione annuale IVA presentata
  2. Esportazioni
  3. Cessioni intracomunitarie
  4. Cessioni verso San Marino
  5. Operazioni assimilate
  6. Operazioni straordinarie

Se, alla data di trasmissione della dichiarazione d’intento, la dichiarazione annuale IVA è stata già
presentata, va barrata la casella 1“Dichiarazione annuale IVA presentata” e non è necessario indicare
quali operazioni concorrono alla formazione del plafond (caselle da 2 a 5).
Se la dichiarazione annuale IVA non è stata ancora presentata occorre barrare almeno una delle caselle
da 2 a 5del rigo A2, indicando quali operazioni hanno concorso alla formazione del plafond:
• la casella 2, per le esportazioni di beni (art. 8, primo comma, lettere a) e b) del d.P.R. 633/72);
• la casella 3, per le cessioni intracomunitarie di beni;
• la casella 4, per le cessioni di beni effettuate nei confronti di operatori sammarinesi;
• la casella 5,perle operazioni assimilate alle cessioni all’esportazione.
Nell’ipotesi in cui il dichiarante abbia effettuato operazioni straordinarie che hanno concorso alla
formazione, anche parziale, del plafond disponibile, deve barrare la casella 6 operazioni straordinarie

Al fine di una compilazione corretta del modulo e del file per la presentazione telematica occorre verificare i dati anagrafici:

Se i dati del contribuente sono diversi dai dati della ditta stessa, compilare, con la funzione “Dati generali per Comunicazioni Telematiche” (menu contabilità - iva) i dati anagrafici del contribuente, altrimenti controllare che siano tutti compilati i dati nell'anagrafica ditta
In caso di nascita all'estero nel campo Comune dovrà essere scritto lo Stato di nascita e in provincia EE
Dati del Dichiarante/Rappresentante se diverso dal Contribuente

Se esiste un rappresentante, firmatario della dichiarazione, dovranno essere compilati , nella maschera di cui sopra, i dati del Dichiarante/Rappresentante :
Codice Fiscale
Codice Carica
Dati anagrafici e di nascita
(Cognome e Nome possono essere scritti separati da un carattere bianco o meno (-) )

I recapiti: telefono e indirizzo email (campi non obbligatori) vengono letti dall'anagrafica Ditta.

Se la residenza del fornitore è Frazione e Comune e, attualmente in località è stata messa la frazione, occorre compilare il campo Comune.

Per indicare sul file che è presente la firma della comunicazione del dichiarante, spuntare il campo 'è presente la firma della comunicazione' nella maschera di cui sopra

Per una stampa corretta del modulo deve:
essere inserita nell'aziwin.ini la sezione:
[ComunDichIntento]
e nella directory aziwin\immagini devono essere presenti i file:
LetteraIntTest.gif e LetteraIntDett.gif

CLIENTI

Sono stati predisposti dei campi in anagrafica clienti che dovranno essere compilati quando si riceve una 'dichiarazione di intenti' da un cliente esportatore abituale per poter poi controllare il suo plafond durante l'emissione dei documenti


STAMPA SITUAZIONE FATTURE IVA PER CASSA

Percorso: Contabilità - Iva - Stampe - Stampa situazione fatture iva per cassa

Questa funzione consente di stampare un elenco delle fatture emesse e ricevute in regime di 'iva per cassa' che risultano ancora aperte alla fine dell'anno precedente a quello che si sta elaborando oppure alla maggiore delle due date: data del menu e data ultimo aggiornamento.
Può essere utilizzata per rilevare il volume d'affari relativo a tali documenti.

L'anno non può essere successivo all'anno della prima data non aggiornata.

Documenti che scadono entro il:
In regime di iva per cassa, l'iva delle fatture va comunque inserita nella liquidazione a un anno dalla data documento, indipendentemente che esse siano state incassate o pagate.
Se si scrive una data in questo campo, verrà stampato un elenco delle sole fatture con data documento precedente di un anno alla data inserita
Ha senso impostare questa data a un periodo successivo alla data della 'stampa situazione al'

Stampa anche documenti anni precedenti con incassi/pagamenti nel periodo ...
stampa anche i documenti incassati/pagati completamente ma con data documento anno precedente.

Solo documenti scaduti (passato anno)
Stampa SOLO le fatture non ancora incassate/pagate ma per le quali è passato un anno dalla data documento.

A fianco al numero documento, viene riportato un * in quelle fatture per cui esiste anche una nota di variazione. Gli importi sono il risultato della 'differenza/somma' tra quelli della fattura e quelli delle note di variazione.

Nella stampa compare una colonna Note.
Serve per evidenziare situazioni particolari:
PARZ indica fattura incassata/saldata parzialmente
NV PREC indica una fattura dell'anno precedente, non ancora incassata/pagata, per la quale esiste una nota nota di credito nell'anno di stampa
(Se si chiede la stampa di fine anno e ci sono fatture aperte per le quali, nell'anno successivo, è stata registrata una nota di credito ed già aggiornata, questa verrà comunque evidenziata (anche se dell'anno successivo))


BILANCIO PER REGISTRO INVENTARIO

Percorso: Contabilità - Prima Nota - Stampe

La funzione consente di stampare le seguenti sezioni del Registro inventario:

  • Situazione Patrimoniale ed Economica
  • Elenco clienti
  • Elenco fornitori

L'operatore può decidere di stampare separatamente le sezioni oppure una consecutiva all'altra.

E' possibile stampare anche solo lo Stato Patrimoniale, spuntando l'opzione: St. Solo Patrimoniale (per le società di capitale).

Per ogni sezione può essere impostata una intestazione personalizzata.

A video si può inserire il numero della prima pagina in stampa, che viene posto a 1 di default. Il programma numererà le pagine a partire dalla pagina indicata, con il formato: pag/anno (es. 1/2008)

Si può richiedere la stampa dell'intestazione ditta completa, così come viene stampata sui registri.

Se si fa la stampa su file, il programma chiederà di digitare il nome del file da generare. Se si sceglie di stampare più di una sezione tra le tre previste, alla prima stampa verrà assegnato il nome del file digitato, alla seconda il nome seguito da un 2, alla terza il nome seguito da un 3.

Nella stampa dei fornitori, il saldo viene moltiplicato per -1 in modo da presentarlo positivo.


STAMPA RATEI

Percorso: Contabilità - Annuali - Stampe

Il programma prende in esame le registrazioni di prima nota di determinati anni contabili, nelle quali sono state inserite le date di competenza e elenca per ogni conto coinvolto, in modo sintetico o dettagliato, gli importi relativi al periodo di competenza, quelli del periodo precedente e quelli del periodo successivo.

Lo scopo di questa stampa è stabilire qual è l'importo da togliere (o da aggiungere) al saldo del conto per trovare il saldo di competenza di un certo periodo.

Viene chiesto di digitare un anno contabile di riferimento e le date relative al periodo da esaminare (tali date devono appartenere allo stesso anno contabile)

Se non si inseriscono le date si ottiene l' elaborazione dei risultati di fine anno cioè la colonna Importo successivo contiene gli importi di competenza degli anni successivi che andranno stornati dai conti rispettivi e registrati su un conto patrimoniale al fine di riaprirli nell'anno successivo.

Se si inserisce l'intervallo delle date, verrà chiesto se:
Considerare i movimenti dell'anno contabile precedente a quello richiesto
Questo consente di includere nella stampa i movimenti inseriti l'anno precedente che però hanno competenza nel periodo in esame e per i quali non è ancora stata fatta la registrazione del giroconto dal patrimoniale, aperto con la procedura di apertura automatica, al conto di competenza con le date di competenza giuste.

Considerare i movimenti dell'anno contabile successivo a quello richiesto

Stampa dati di fine anno
Si prendono in esame tutte le registrazioni dell'anno chiesto a video, con periodo di competenza:
data comp.iniziale < data inizio anno contabile OR
data comp. Finale > data fine anno contab
ordinate per codice conto e data registrazione (stampa analitica)
per codice conto, data di fine competenza e data inizio competenza (se sintetica)

Nella stampa sintetica, per ogni conto verranno stampate più righe:
- totali (senza date competenza) per gli importi di competenza dell'anno e anno successivo
- totali (con data fine competenza) per i movimenti con stessa data fine competenza (se questa cade dal secondo anno successivo all'anno di stampa in poi), purchè la data inizio competenza sia <= della data di inizio anno contabile dell'anno successivo a quello in stampa
- righe dettagliate con data inizio e fine competenza quando l'inizio competenza è nell'anno di stampa e la fine è successivo all'anno di stampa +1

Quando a inizio anno si dovranno fare i giroconti dal conto patrimoniale (Ratei) ai singoli Costi o Ricavi per la competenza si dovranno fare tante righe sui singoli conti quante quelle riportate nella stampa sintetica con importo dalla colonna Anno successivo e date di competenza uguali a quelle stampate o, dove non viene stampata la data di competenza Da, questa andrà posta = alla data inizio anno contabile dell'anno in cui si sta facendo la registrazione.

Stampa dati di un periodo
E' la stampa fatta quando vengono compilate le date a video
Si considerano:
- Tutti i movimenti con Anno uguale a quello digitato e date di registrazione comprese nel periodo digitato
Oppure
- Tutti i movimenti con Anno uguale a quello digitato, date di registrazione esterne al periodo digitato e data competenza interna all'intervallo digitato (basta che una delle due date sia interna!)
- Se a video è stata spuntata la scelta di considerare anche l'anno precedente: si considerano anche le registrazioni dell' anno precedente, con data competenza compresa nell'intervallo a video (basta che una delle due date sia interna!)

Se dettagliata si stampano tutti i movimenti che soddisfano le condizioni

Se sintetica si stampa, per ogni conto, una riga unica con tutti i movimenti dell'anno prima che hanno data di competenza interna all'intervallo richiesto (se si è scelto di considerarli) e una riga per l'anno in corso.


FINE ANNO DI CONTABILITA'

All'inizio di ogni nuovo anno solare, occorre predisporre gli archivi a ricevere le registrazioni del nuovo anno.
Questo, indipendentemente dal fatto che si debbano ancora registrare operazioni dell'anno che si è appena chiuso.
La funzione da eseguire, prima di iniziare a fare registrazioni (o a emettere fatture) nel nuovo anno, è il Cambio Anno.
A seconda che l'anno contabile coincida o meno con l'anno solare, si dovrà eseguire il Cambio anno contabile e iva oppure Solo quello IVA (al 31/12) e Solo quello contabile (al termine dell'anno contabile).

Condizione necessaria perchè l'esecuzione di questa funzione vada a buon fine è che sia già stata fatta la chiusura dell'anno precedente a quello che si sta concludendo. Se così non fosse, occorre verificare perchè tale anno è ancora aperto.
Potrebbero non essere state fatte le operazioni di Chiusura e di Apertura, occorre farle prima di procedere, oppure semplicemente si potrebbe essere intervenuti manualmente sul flag: "Anno precedente Aperto", lasciandolo spuntato, nel qual caso va tolta la spunta.

Durante i primi mesi del nuovo anno si procederà con le registrazioni delle operazioni ordinarie e con le eventuali registrazioni di rettifiche sull'anno precedente.
Dopo l'approvazione del bilancio si procederà con la Generazione movimenti di chiusura sull'anno precedente e successiva Generazione movimenti di apertura sull'anno in corso.
Nota: la Generazione dei movimenti di apertura di un certo anno deve necessariamente essere preceduta dalla Generazione dei movimenti di chiusura dell'anno precedente.


CAMBIO ANNO DI CONTABILITA'

Percorso: Contabilità - Annuali

Il programma consente di predisporre la procedura a ricevere le registrazioni di un nuovo anno contabile. Questa funzione DEVE essere eseguita prima di cominciare a fare le registrazioni di un nuovo anno.

Non si consente di aprire un nuovo anno se è ancora aperto anche l'anno precedente a quello appena finito (es. in apertura del 2002 deve essere stato chiuso definitivamente il 2000).
Nel momento in cui si esegue l'apertura contabile di un anno (Generazione movimenti di apertura), il programma chiude l'anno precedente nel senso che non consente di aggiungere altre registrazioni (si può invece continuare a visualizzare e stampare quelle già esistenti).
Per chiudere definitivamente, in modo forzato, l'anno precedente, occorre eseguire la funzione: Chiusura definitiva anno precedente oppure andare in Parametri e Utilità, Dati generali azienda e parametri, tabella Contabilità e togliere la 'spunta' al campo 'Anno precedente aperto'.

Vengono proposte tre scelte:

  • Anno contabile e anno IVA
    Scelta da fare per tutte le ditte per le quali l'anno contabile coincide con l'anno solare.
  • Anno contabile
    Scelta da fare al momento del cambio dell'anno contabile (es. al 30 aprile) dalle ditte per le quali l'anno contabile non coincide con l'anno solare. In questo caso, l'anno delle registrazioni contabili sarà quello nel quale inizia l'anno contabile (es. nell'anno contabile che va dal 01/06/2008 al 30/05/2009, l'anno delle registrazioni sarà 2008). Una volta fatta questa scelta l'anno corrente di contabilità verrà incrementato di uno (es. 2009).
  • Anno IVA
    Scelta da fare al momento del cambio dell'anno solare (31/12) dalle ditte per le quali l'anno contabile non coincide con l'anno solare per inizializzare i numeratori delle fatture e i progressivi iva del nuovo anno.

Per quanto riguarda la numerazione delle registrazioni di prima nota, viene visualizzata la scelta fatta nei parametri generali e si consente di variarla.

Azzera numero registrazione ogni anno
Con questo campo si consente all'operatore di decidere se azzerare o no, all'inizio di ogni nuovo anno contabile, il numeratore degli articoli di prima nota.
Anno inizio numerazione
Questo campo non viene preso in considerazione se si è scelto di azzerare il numeratore delle registrazioni di prima nota all'inizio di ogni nuovo anno.
Se invece è stata scelta una numerazione continua e, da un certo anno, si vuole azzerare per ricominciare da uno, basta mettere qui l'anno.

Si sconsiglia di intervenire manualmente per inizializzare le tabelle per il nuovo anno in quanto si rischia di lasciare le cose incomplete.
Le tabelle interessate da questa funzione sono:

  • Tabella generale di Contabilità
  • Prefissi e Numeratori Documenti
  • Dati iniziali Iva
  • Caratteristiche esercizio di Contabilità


GENERAZIONE MOVIMENTI DI CHIUSURA

Percorso: Contabilità - Fine anno

Il programma consente di generare i movimenti per la chiusura del bilancio.

Prima di eseguirlo occorre aver registrato tutti i movimenti dell'anno e aver fatto le rettifiche di bilancio.
Il programma, prima di iniziare l'elaborazione, controlla il saldo totale degli eventuali conti d'ordine aperti.
Possono verificarsi tre casi diversi:

  • I conti d'ordine non sono stati movimentati
    Si procede con la chiusura
  • Il saldo totale dei conti d'ordine è uguale a 0
    viene comunque dato un messaggio e si consente di interrompere l'elaborazione per chiudere manualmente i conti interessati
    o di continuare l'elaborazione. Il programma chiuderà i conti d'Ordine a Bilancio di Chiusura, così come fa per i Patrimoniali
  • Il saldo totale dei conti d'ordine è diverso da 0
    viene data una segnalazione di errore e si interrompe l'elaborazione

Nota: Dopo l'elaborazione della chiusura di un anno contabile è indispensabile eseguire la Generazione dei movimenti di apertura sull'anno successivo prima di eseguire un'altra chiusura.

Se è stata interrotta una precedente esecuzione della chiusura, verrà dato un messaggio in cui si visualizza la data di questa, prima di procedere con un'altra chiusura occorrerà eseguire il Ripristino da interruzione in gestione prima nota poi, dal programma di input di prima nota, cancellare tutti i movimenti di chiusura eventualmente generati. Successivamente si può ripetere la chiusura.

Viene chiesto l'anno contabile da chiudere e i codici delle causali Chiusura conti economici, Chiusura conti patrimoniali e dei conti Profitti e Perdite, Utile o Perdita d'esercizio, Bilancio di Chiusura e Bilancio di Apertura.
Tali codici verranno proposti in automatico se sono stati impostati nei conti e causali comuni (col menu Parametri e utilità - Dati generali azienda)

Vengono poi chieste le date di registrazione, protocollo e documento e la descrizione aggiuntiva da utilizzare nella creazione delle registrazioni.
Se una delle due causali da utilizzare per la chiusura ha l'obbligo dei dati del documento (numero e data) viene chiesto anche il prefisso e il numero documento.

I conti vengono chiusi secondo questa sequenza:

  • Conti Economici in ordine di Costi e Ricavi.
    Viene utilizzato come conto transitorio il "Conto Profitti/Perdite" e come causale la "Causale Chiusura economici".
  • Successivamente viene rilevato l' utile o la perdita come saldo del conto profitti e perdite (Economico) e girato al conto utile o perdita (Patrimoniale).
  • Conti Patrimoniali in ordine di Passività e Attività.
    In automatico viene aggiunta una riga con l'importo (saldo) del conto Utile/Perdita d'esercizio nella registrazione delle Passività o delle Attività a seconda del segno del saldo.
    Viene utilizzato come conto transitorio il 'Bilancio di chiusura' e come causale la causale 'Chiusura conti patrimoniali' confermati all'inizio.
  • Clienti e Fornitori.

Se si deve ripetere la Generazione dei movimenti di chiusura (per aggiungere o correggere registrazioni dell'anno chiuso) occorre cancellare 'ad una ad una', con l' "Input di prima nota" tutte le registrazioni di chiusura generate (cercare quelle con causale di Chiusura e anno interessato)


GENERAZIONE MOVIMENTI DI APERTURA

Percorso: Contabilità - Fine anno

Il programma genera in automatico i movimenti dell'apertura del bilancio a partire dai dati memorizzati nella fase di Generazione Movimenti di Chiusura.
Nota: la Generazione dei movimenti di apertura di un certo anno deve necessariamente essere preceduta dalla Generazione dei movimenti di chiusura dell'anno precedente.
Caso particolare è la possibilità di effettuare una chiusura infrannuale e una successiva riapertura nel caso di trasformazione della società.

La sequenza esatta è:

  1. Chiusura di un anno
  2. Apertura dell'anno successivo.

L'apertura infatti utilizza dei dati preparati dalla chiusura che non hanno un riferimento all'anno al quale si riferiscono per cui non possono essere riconosciuti dal programma di apertura come provenienti dalla chiusura dell'anno 'giusto, deve perciò essere l'operatore a rispettare la sequenza.

Il programma visualizza, per controllo, la data in cui è stata fatta la chiusura. Se la chiusura non è stata fatta (o non sono stati importati i dati di chiusura sull'apposita tabella), non si potrò procedere con l'apertura.

Viene visualizzato inoltre l'anno contabile da aprire e vengono chiesti all'operatore i codici della causale Bilancio di apertura e dei conti Bilancio di Apertura, Profitti e Perdite, Utile o Perdita d'esercizio.
Tali codici verranno proposti in automatico se sono stati impostati nei conti comuni e causali comuni.
Vengono chieste le date di registrazione, protocollo e documento e la descrizione aggiuntiva da utilizzare nella creazione delle registrazioni.

Se la causale di apertura ha l'obbligo dei dati del documento (numero e data) viene chiesto anche il prefisso e il numero documento.

Infine si chiede se si intende
'Chiudere definitivamente l'anno precedente'.
Quando un anno contabile è chiuso, su di esso non è più possibile variare le registrazioni esistenti o farne di nuove. Restano invece possibili tutte le stampe e visualizzazioni.

In teoria, una volta fatta e controllata la chiusura, un anno può essere chiuso anche per evitare che, per errore si vadano a variare delle registrazioni che, anche se non sono state stampate sul giornale, sono da ritenersi 'definitive'.

Se non si conferma in questa fase la 'Chiusura dell'anno precedente, questa dovrà essere effettuata con la funzione: Chiusura definitiva anno precedente del menu.

Vengono generati dei movimenti che riaprono prima i conti Patrimoniali in ordine di Passività e Attività poi i Clienti e i Fornitori.

Se durante l'esecuzione dell'apertura il programma si interrompe, occorre eseguire il Ripristino da interruzione in gestione prima nota poi, dal programma di input di prima nota, cancellare tutti i movimenti di apertura già creati. Successivamente si può ripetere l'apertura.

Casi particolari:

  • Per poter fare l'apertura in automatico, avendo fatto la Chiusura dei conti in ambiente Dos (con Azienda Dos) o su un altro database, occorre prima importare, con l'apposita funzione: Caricamento file per apertura, i dati di chiusura sul database attuale.
    Per una corretta esecuzione è indispensabile che i codici dei conti, dei clienti e dei fornitori della ditta nella quale è stata fatta la chiusura siano gli stessi di quella in cui si fa l'apertura.
  • Per poter fare l'apertura in automatico, avendo fatto la Chiusura dei conti su un altro database occorre spuntare il campo Prelevo i dati chiusura da altro database e scegliere il database
  • Eseguo solo il carico dei saldi anno precedente
    Questo campo è stato inserito per consentire di ricaricare (per motivi vari) il saldo anno precedente nelle sintesi contabili (da stampare poi nel bilancio Cee).
    Se viene spuntato, il programma eseguirà UNICAMENTE il carico di tale importo da altro database o dalle sintesi dell'anno precedente a seconda di quanto indicato dall'operatore.
  • Se la moneta principale è Euro si chiede se convertire in euro i progressivi generati durante la Chiusura.
    Questa scelta ha consentito, a suo tempo, di riaprire il bilancio in euro a partire dalla chiusura fatta in lire. Doveva essere digitato anche il codice di un conto di riserve per la riga di quadratura delle registrazioni convertite.
  • Possibilità di effettuare una chiusura infrannuale e una successiva riapertura
    Nel caso si renda necessario, ad esempio per una trasformazione della società, effettuare una chiusura e apertura infrannuale, occorre variare manualmente l'anno di apertura e verrà dato il messaggio: 'L' anno di apertura deve essere quello successivo a quello della chiusura'. Oltre al pulsante Annulla, è possibile premere il pulsante 'Prosegui' per portare a termine comunque l'operazione.

Se si deve ripetere la Generazione dei movimenti di apertura (perchè si rileva un errore nella chiusura e serve aggiungere o correggere registrazioni dell'anno precedente) occorre:

  • cancellare 'ad una ad una', con l' "Input di prima nota" tutte le registrazioni di apertura generate (cercare quelle con causale di Apertura conti e anno interessato).
  • eseguire la funzione: "Chiusura definitiva anno precedente". Essa darà il messaggio: "Anno precedente chiuso, si consente la riapertura"
  • cancellare 'ad una ad una', con l' "Input di prima nota" tutte le registrazioni di chiusura generate in precedenza (cercare quelle con causale di Chiusura e anno interessato)

A questo punto si può correggere l'anno precedente e si può ripetere la chiusura e la riapertura.


CHIUSURA DEFINITIVA ANNO PRECEDENTE

Percorso: Contabilità - Annuali

La funzione 'Chiude' definitivamente un anno contabile.

Quando un anno contabile è chiuso, su di esso non è più possibile variare le registrazioni esistenti o farne di nuove.
Restano invece possibili tutte le stampe e visualizzazioni.

In teoria, una volta fatta e controllata la chiusura, un anno può essere chiuso anche per evitare che, per errore si vadano a variare delle registrazioni che, anche se non sono state stampate sul giornale, sono da ritenersi 'definitive'.

E' indispensabile che, prima di fare il Cambio Anno per aprire un nuovo anno contabile, sia stato definitivamente chiuso quello precedente all'attuale.

Se si esegue la funzione su un anno già 'Chiuso' si consente di riaprirlo. Fare molta attenzione perché questa operazione potrebbe essere rischiosa nel senso che i programmi consentiranno poi di variare dati già consolidati.


CARICAMENTO FILE PER APERTURA

Percorso: Contabilità - Annuali - Utilità

Questo programma consente di importare sul database di lavoro i dati, preparati dalla chiusura del bilancio eseguita in un altro ambiente o su un altro database, e necessari per poter effettuare la generazione in automatico dei movimenti di apertura.
E' stato predisposto in particolare per importare i dati dalla chiusura effettuata in ambiente DOS.

Questo programma non si deve utilizzare se si intende eseguire l'apertura sullo stesso database su cui è stata fatta la chiusura.

I dati vengono letti da due tabelle:
chiueco.dat che contiene i saldi prima della chiusura di tutti i conti (in Contabilità DOS per generarlo occorre eseguire la funzione: Copia archivio di chiusura e salso anno precedente indicando semplicemente il codice dell'azienda 'chiusa')
chiusura.dat che contiene i codici dei conti patrimoniali da riaprire e i rispettivi importi
Viene chiesto all'operatore di indicare la directory dalla quale caricare le due tabelle suddette:
es. c:\arcaz001

Se durante il caricamento si incontrano dei codici di conti, clienti o fornitori che non esistono sul database di lavoro, si completa ugualmente il caricamento e viene presentato un elenco di tali codici con la raccomandazione di creare le relative anagrafiche prima di procedere con l'apertura dei conti.


CHIUSURA PROVVISORIA

Percorso: Parametri e utilità - Euro

Questo programma genera le registrazioni di chiusura del bilancio e prepara i dati per la riapertura dei conti sia Patrimoniali sia Economici, non deve perciò essere eseguito a fine anno.

Dovrà invece, essere utilizzato da quanti fanno il passaggio all'Euro prima di fine anno e pertanto devono fare una chiusura del bilancio in Lire (prima di cominciare a fare registrazioni in Euro) e una successiva riapertura in Euro (su un altro database)

Prima di eseguire questo programma occorre creare una causale per la Chiusura Provvisoria (non deve essere definita di tipo Chiusura ma Generico) e due conti: uno per la chiusura e uno per l'apertura provvisoria.

I movimenti generati andranno poi stampati su bollato.

Se si interrompe l'esecuzione, occorre eseguire il ripristino Prima Nota (se richiesto dal menu), cancellare con la gestione prima nota gli articoli già creati e ripetere l'operazione di Chiusura.

ATTENZIONE: Dopo la Generazione dei movimenti di chiusura provvisoria non è più possibile stampare il bilancio per cui si consiglia di farne più copie prima o di farsi una copia degli archivi prima della chiusura.


APERTURA PROVVISORIA

Percorso: Parametri e utilità - Euro

DA UTILIZZARSI SOLO PER la riapertura in Euro (prima della fine del 2001) di una contabilità tenuta precedentemente in lire.

Per l'apertura del 2002 si deve utilizzare la procedura normale di apertura.

Questa funzione va eseguita sul database ottenuto duplicando, con l'apposita funzione, quello con la gestione in Lire.

Prima di eseguire questa funzione deve essere stata eseguita la Conversione per il passaggio ad Euro e, sul database Lire, la chiusura provvisoria.

Questa funzione consente di generare dei movimenti di apertura (provvisoria) a partire dai dati preparati dalla Chiusura Provvisoria eseguita su un altro database. In particolare serve, nel passaggio della contabilità dalle Lire all'Euro prima del 31/12/2001, per impostare i saldi iniziali in Euro dopo aver fatto una chiusura infra-annuale in Lire

Il programma chiede di specificare il database (corrispondente all'attuale) sul quale è stata fatta la chiusura provvisoria e dal quale quindi leggere i saldi.

Si dovrà creare una causale di Apertura Provvisoria e un conto di Riserva nel quale memorizzare le differenze di cambio generate dal cambio in Euro di ogni saldo.

A differenza dell'apertura normale, vengono generati i saldi iniziali di tutti i conti: economici e patrimoniali.


BILANCIO CEE

La stampa del bilancio, secondo la IV direttiva CEE, è stata realizzata prelevando i dati memorizzati dalle registrazioni e trasferendoli, tramite un programma di estrazione dati che fa riferimento a una tabella di collegamento opportunamente precompilata, su una tabella di appoggio che potrà essere gestita e stampata.

Per poter effettuare l'estrazione dei dati di bilancio e la successiva stampa, o la preparazione del file in formato XBRL, è indispensabile aver compilato correttamente la suddetta tabella di collegamento tra le voci previste dal bilancio Cee e il piano dei conti della singola azienda.

Le voci previste dal bilancio CEE sono state classificate con un codice numerico di 2 cifre per un massimo di 5 livelli, in modo da avere una struttura piramidale (tabella di testate).
Ad ogni voce viene poi associata la lista dei conti che ne compongono il totale (tabella dei dettagli).
Queste due tabelle, assieme costituiscono la tabella base di bilancio.

Una volta compilate le tabelle, prima di eseguire la stampa o la preparazione del file in formato XBRL, occorre eseguire il programma di Estrazione dati Bilancio Cee che calcola, per ogni voce della tabella, gli importi, dell'anno e dell'anno precedente, elaborando i saldi dei conti.
Lo scopo di questa elaborazione è duplice:

  • Consentire all'operatore di intervenire per modificare importi o inserire nuovi dettagli, superando così i controlli inseriti nel modulo di estrazione
  • Semplificare la procedura di stampa.

Altre funzioni del menu Bilancio Cee:

Preparazione file del bilancio in formato XBRL
Stampa bilancio su Excel
Stampa bilancio Cee
Tabella elementi
Tabella prospetti
Tabella pesi

NOTA: Caricamento della tabella del bilancio cee dalla procedura Azienda DOS
Sono state predisposte due tabelle di caricamento (in Caricamento dati da archivi esterni - menu Parametri e Utilità) che consentono di caricare sul database di lavoro le tabelle: Biltesta e Bildett scaricate in formato ascii da Azienda Dos.
Una volta scaricate da Azienda Dos tali tabelle è però indispensabile, prima di caricarle sul database access, eseguire una funzione che le 'adatti' ad essere caricate correttamente.
Sul CD della procedura, nella directory \util, è stato inserito SortFile.EXE, un programma che consente di ordinare un file asci secondo certi campi prestabiliti.
Occorre eseguire questo programma e selezionare, come file da ordinare, il file BILDETT.TXT scaricato in ascii da dos, il file da scrivere potrà essere sempre lo stesso (nel qual caso il file verrà sovrapposto al vecchio), oppure si può scegliere un'altra destinazione, ad esempio \programmi\aziwin\carica\bildett.txt in modo da trasferirlo già nel posto dal quale verrà caricato.
Successivamente, trasferite le due tabelle Biltesta.txt e Bildett.txt in \aziwin\carica, si può eseguire il caricamento con la funzione: Caricamento dati da archivi esterni dal menu Parametri e Utilità


BILANCIO CEE IN FORMATO XBRL

Le Società di Capitali devono redigere il bilancio secondo i principi dettati dall'art. 2423 del codice civile e lo schema previsto dall’art. 2424 (Stato Patrimoniale), 2425 (Conto Economico) del Codice Civile.

Il nuovo bilancio xbrl non è altro che un diverso modo di presentare il bilancio, usufruendo di un linguaggio diverso che utilizza i cosiddetti codici di lettura (“tassonomie”) e che permetterà al fisco di analizzare i valori del conto economico e dello stato patrimoniale secondo nuovi elementi.

Vedi Note su Bilancio Xbrl per particolari sulla struttura

Prima di eseguire la funzione per la preparazione del bilancio in formato Xbrl occorre:

  • Completare i dati anagrafici della ditta in "Dati generali azienda (parametri) - Anagrafica ditta".
    In particolare vanno compilati il capitale sociale, codice CCIAA, numero REA, forma giuridica etc.
  • Inserire il codice attività (codice ATECO) con la Gestione attività
    In presenza di più attività verrà considerato il codice impostato sulla prima.
  • Compilare in modo opportuno le tabelle del Bilancio Cee collegando i conti dell' azienda ai codici Bilancio Cee.
    Per l'allineamento di tabelle già esistenti vedere Note su Bilancio Xbrl
  • Eseguire la funzione Estrazione dati Bilancio Cee per l'anno da elaborare

Per la preparazione del file del bilancio si può procedere in due modi diversi:

  • Utilizzare la funzione "Stampa bilancio su excel" in modo da generare un file in formato excel.
    Se si fa questa scelta occorre procurarsi dal sito di Infocamere, il file zip contenente il file di generazione dell’Istanza XBRL e l’esempio di import per i bilanci e scompattarlo sul disco.
    https://webtelemaco.infocamere.it/newt/rootdata/xbrl/Strumenti. html
    Una volta aperto il file IstanzaXBRL.xls scaricato, attenzione al livello delle Macro in Excel che deve essere impostato su basso, si può importare tramite la funzione interna di Import, il file del bilancio preparato in precedenza ed elaborarlo all'interno dell'Istanza.
  • Procedere con la funzione "Preparazione file XBRL".
    Se si esegue la preparazione del file xbrl con la scelta "visualizzazione" verrà generato un file con estensione xml che sarà possibile visualizzare immediatamente a condizione di aver copiato, nella stessa cartella in cui è stato creato il file, i fogli di stile forniti sul cd di installazione (file ic_stylesheet_1_1_1Ese.xsl per il Bilancio normale etc. della cartella XBRL)
    Altrimenti verrà generato un file con estensione xbrl che potrà essere visualizzato e verificato sul sito:
    http://tebe.infocamere.it/client_TEBEplus/index.jsp


NOTE SU BILANCIO XBRL

Vedi Bilancio in formato Xbrl

Come impostare il Bilancio Cee (anche in formato Xbrl) su una NUOVA azienda

  • Sono state predisposte delle tabelle che contengono le voci fondamentali del bilancio e la struttura del bilancio xbrl, esse dovranno essere completate, da parte dell'utente, collegando i codici del piano dei conti dell'azienda.
    Tali tabelle precompilate si trovano sul database del menu (AziMenu.mdb):
    CeeXbrlElementi, CeeXbrlProspetti, CeeXbrlImpost
    e sul database vuoto (AziVuoto.mdb che viene copiato nella cartella database ad ogni aggiornamento):
    CeeXbrlPesi, CeeBiltesta, CeeBilDett
    Quando si crea una nuova azienda a partire dal database vuoto, la struttura del bilancio è quindi già impostata e basterà collegare i conti del piano dei conti dell'azienda con la funzione: Gestione tabella Bilancio Cee

Come fare il bilancio Xbrl su un'azienda su cui è già impostata la struttura per il bilancio cee precedente al rilascio dell'xbrl (giugno 2010)

  • Se non sono mai stati collegati i conti alla struttura del Bilancio si dovrà procedere come descritto nei punti b) e c) successivi.
  • La forma xbrl del bilancio ha richiesto alcune variazioni alla struttura preesistente dei codici della tabella cee per cui NON è possibile eseguire la preparazione del file xbrl utilizzando la tabella così com'era stata impostata in precedenza.
    A tal proposito è stata predisposta una nuova funzione: Struttura Bilancio Cee che consente di confrontare la struttura del bilancio cee (tab. CeeBiltesta e CeeBilDett) dell'azienda corrente con una di riferimento corretta (es. quella del database vuoto) e di allinearla.
    L'alternativa all' uso di tale funzione è quella di:
    a) fare una "Stampa tabella Cee" per avere l'elenco dei conti collegati ai codici cee e quindi fare un fare una copia del database corrente
    b) copiare dal database Azivuoto.mdb le nuove tabelle: CeeBiltesta, CeeBilDett utilizzando la funzione: Clona Tabelle (da Ctrl Alt Shift L) che le sostituisce alle precedenti
    c) procedere con la Gestione tabella Bilancio Cee a collegare alla nuova struttura, i codici del piano dei conti seguendo la stampa fatta in precedenza.

Come inserire nel Bilancio Xbrl una nuova voce:

  • Creare, con la Gestione tabella Bilancio Cee, la voce desiderata inserendola con un codice opportuno a seconda della posizione in cui si dovrà trovare nel bilancio e collegare ad essa i conti interessati.
  • Aggiungere una nuova riga nella tabella Pesi, cercando la descrizione della voce di bilancio da inserire tra quelle presenti nella tabella Elementi e associando il codice cee creato in precedenza.


TABELLA TESTATE

Percorso: Contabilità - Bilancio Cee - Tabella Bilancio Cee

Tramite questa funzione vengono inserite le voci da stampare sul bilancio cee, e per la preparazione del file XBRL del bilancio, con l'ausilio di codici numerici che possono avere fino a 5 livelli di suddivisione.

In questo modo l'inserimento di ogni voce avviene con un codice che dà chiaramente la dipendenza dal livello superiore ed è pertanto più chiaro e semplice.

La gestione della tabella è di tipo Testate-Dettagli

Ci sono due modi diversi di gestione dettagli, raggiungibili rispettivamente con i pulsanti:
(E-F10) Gestione dettagli
(T) Totali accede ai dettagli con importi calcolati dall'estrazione dati per bilancio cee.

Quando si è posizionati su una voce della tabella, è disponibile un pulsante che consente di spostare quella voce/codice (e tutte quelle che la compongono) attribuendo un codice precedente o seguente.

Il pulsante [image] (X) Ricalcola consente di ricalcolare tutto il bilancio se sono stati variati manualmente degli importi in corrispondenza a qualche dettaglio accedendo con il pulsante: 'Dettagli con importi'.
In particolare può essere utilizzato per sistemare gli importi dell'anno precedente.

Codice
Il codice deve essere composto obbligatoriamente da coppie di cifre (Es.: 01, 0101, ..., mentre non viene accettato 1 o 011).
Un codice 0101 può essere inserito SOLO SE è già stato inserito il codice 01 cioè il livello superiore.

Descrizione e Descrizione aggiuntiva
La seconda riga descrittiva è opzionale e serve per poter descrivere meglio la voce.

Se presente verrà stampata nel bilancio nella riga successiva sotto la prima descrizione.

La codifica prevista dalla normativa (A, a,1,III, .) viene inserita come Sigla Cee

Nella tabella di riferimento che viene consegnata assieme ai programmi, si è scelto di far seguire alle lettere e cifre una parentesi chiusa, mentre per i numeri romani si è usato ":" (due punti).

Per ogni codice si chiede si specificare la Natura, cioè in quale sezione del bilancio va stampato: Economico, Patrimoniale Attività, Patrimoniale Passività, D'Ordine attività o Passività.

La natura viene definita al primo livello e viene poi impostata automaticamente su tutti i livelli sottostanti.

Tipo riga

  • Normale: indica una riga sulla quale non va stampato il totale, che invece verrà stampato a rottura di livello
  • Totale: indica che in stampa va riportato il totale in linea
  • Calcolata: indica un totale in linea ma senza dettagli
  • Totale e somma invertita: indica un totale che va stampato in linea con il suo segno, ma va sommato ai livelli superiori con segno invertito (es: ricavi e costi).
  • Normale e somma invertita: indica una riga sulla quale non va stampato il totale, che invece verrà stampato a rottura di livello. Tale totale va però sommato ai livelli superiori con segno invertito (es: ricavi e costi).

Forma di stampa
Sotto certi limiti di dipendenti, di attività patrimoniali e di ricavi, è possibile fare la stampa patrimoniale in forma ridotta, stampando solo le voci indicate da lettere maiuscole o numeri romani con la evidenziazione di alcune voci (ammortamenti, svalutazioni, crediti e debiti esigibili oltre l'esercizio).

Per consentire questo tipo di stampa è stato previsto questo campo che può assumere 3 valori:

  • da stampare sempre
  • solo nella forma normale
  • solo nella forma abbreviata
    Le voci di tipo A sono quelle da inserire per evidenziare quei dettagli previsti nella forma abbreviata.
    I totali di queste voci non vengono sommati al totale del livello superiore in quanto i conti in esse contenuti devono già essere presenti nella forma generale e quindi nel totale.
    Se per una ditta si deve stampare il Bilancio anche in forma abbreviata occorre collegare i conti opportuni anche alle testate con il campo "Forma di stampa": in forma abbreviata (oltre che a quelle normali).
    Se per una ditta si deve stampare SOLO in forma abbreviata è possibile attivare il parametro di personalizzazione AbbSommaSup.
    In questo modo si dovranno collegare i conti opportuni solo alle testate con il campo "Forma di stampa": in forma abbreviata (evitando di collegarle anche in quelle "in forma normale")

Il programma imposta un default per questo campo seguendo questi criteri:
Negli Economici e d'Ordine si propone e si accetta solo: da stampare sempre
Nei Patrimoniali se in Sigla Cee ha lettere maiuscole e numeri romani si propone 'da stampare sempre' e si accettano comunque tutte e tre le possibilità.
Nei Patrimoniali se in Sigla Cee ha lettere minuscole e numeri si propone 'solo nella forma normale' ma si accetta anche 'solo nella forma abbreviata'

Arrotondamento diretto
Questo flag interviene nella stampa del bilancio arrotondato all'unità di euro.

Esso va impostato a Si in corrispondenza a codici riferiti a righe calcolate, i cui importi devono essere arrotondati direttamente e non ricalcolati come somma di valori arrotondati.
Va impostato a Si in corrispondenza del codice 12 Utile/Perdita d'esercizio

Codice excel per Xbrl
Numero di collegamento codice cee con il codice xbrl richiesto per effettuare la creazione del file xbrl usando la stampa su file excel e il file excel fornito da Infocamere come indicato nelle note generali per XBRL

L'operatore potrebbe scegliere di creare per lo stesso gruppo di conti (es. le banche) due Codici Cee diversi uno da inserire nelle attività (dicendo di stampare Solo quelli con saldo +) e l'altro da inserire tra le passività (dicendo di stampare Solo quelli con saldo -)
Fare questo comporterà che una banca con saldo negativo, invece di venire stampata tra le attività con segno -, verrà stampata tra le passività.

Se si sono gestite le testate come descritto sopra, è possibile attivare il parametro di personalizzazione: SeparaAP (Gruppo: BilCee)

Il parametro riguarda i saldi della colonna: Anno Precedente. Essi vengono stampati, di default, con segno, sulla riga dove si stampa il saldo corrispondente per l'anno corrente.

Se si imposta questo parametro a S, verranno stampati su una riga quando sono di segno opposto al saldo dell'anno corrente. In questo caso ci saranno perciò due righe per lo stesso conto, in due sezioni diverse del bilancio, una con il saldo dell'anno in corso e una con quello dell'anno precedente.


TABELLA DETTAGLI

Percorso: Contabilità - Bilancio Cee - Tabella Bilancio Cee

Le righe di dettaglio servono per collegare il piano dei conti della ditta alle varie voci del Bilancio Cee.
E' possibile collegare lo stesso conto a codici diversi di Bilancio, il programma lo segnala, ma consente comunque di farlo.
Il collegamento del singolo conto alle voci del bilancio cee si può fare anche da Gestione conti.

Tipo
In ogni riga di dettaglio può essere inserito il codice di un conto, di un mastro o di un gruppo oppure il codice di una voce dello stesso bilancio (cioè di una testata che a sua volta verrà calcolata in base ai sui dettagli (formula)
Essendo l'elaborazione fatta a partire dai codici economici e a seguire attività e passività fino a fine archivio, è ragionevole inserire solo dei codici formula già elaborati
Per far quadrare il calcolo del bilancio arrotondato all'unità di euro, sono stati inseriti altri 4 tipi:
Arrot. Ricavi, Costi, Patrimoniali, d'Ordine

Questi tipi dovranno essere assegnati a righe particolari da inserire, come dettagli, nei seguenti codici, per gli economici
06-01-02 (06-01) Proventi
06-02-03 (06-02) Oneri
per i patrimoniali:
60-07 Altre riserve
Una volta assegnato uno di questi tipi 'particolari', il programma imposterà automaticamente sempre il codice 01-01-ARRO su cui memorizzerà gli arrotondamenti.
Nota: se per la preparazione del bilancio XBRL si passa attraverso la stampa su file excel, vedere nota a riguardo.

Considero il dettaglio
Indica quando il dettaglio deve essere preso in considerazione dal calcolo del bilancio

  • Sempre
  • Dare: solo se il conto ha saldo in dare
  • Avere: solo se il conto ha saldo in avere

Se il campo è riferito ad un mastro o gruppo, si intende che la caratteristica è applicata a tutti i conti che vi appartengono.
Non vi sono controlli su questo campo, tuttavia l'attribuzione di un valore "D" o "A", ha senso solo se si sta trattando una voce di attività o passività.

L'operatore potrebbe scegliere di creare per lo stesso gruppo di conti (es. le banche) due Codici Cee diversi uno da inserire nelle attività (dicendo di stampare Solo quelli con saldo +) e l'altro da inserire tra le passività (dicendo di stampare Solo quelli con saldo -)
Fare questo comporterà che una banca con saldo negativo, invece di venire stampata tra le attività con segno -, verrà stampata tra le passività.
Se si sono gestite le testate come descritto sopra, è possibile attivare il parametro di personalizzazione: SeparaAP (Gruppo: BilCee)

Il parametro riguarda i saldi della colonna: Anno Precedente. Essi vengono stampati, di default, con segno, sulla riga dove si stampa il saldo corrispondente per l'anno corrente.

Se si imposta questo parametro a S, verranno stampati su una riga quando sono di segno opposto al saldo dell'anno corrente. In questo caso ci saranno perciò due righe per lo stesso conto, in due sezioni diverse del bilancio, una con il saldo dell'anno in corso e una con quello dell'anno precedente.

Operatore
Indica se prendere l'importo col suo segno o invertirlo.
In base al tipo di voce elaborata, (economica, attività, ...) e al segno viene proposto il valore dell'operatore in modo tale da consentire di ottenere delle stampe in cui i segni degli importi siano conformi alla sezione stampata cioè, ad esempio, le passività saranno stampate in positivo se sono effettivamente passività.
Vedi "note su operatore".


STRUTTURA BILANCIO CEE

Percorso: Contabilità - Bilancio Cee - Gestioni

Lo scopo fondamentale di questa funzione è quello di agevolare l'utente nella preparazione di un'azienda su cui già si stampa il bilancio cee, per l'elaborazione del primo bilancio in formato xbrl.
(NOTA: i nomi dei database utilizzati da questa funzione non devono contenere caratteri bianchi)
La funzione consente di:

  • visualizzare e modificare la tabella del Bilancio Cee evidenziandone la struttura ad albero
  • confrontare la tabella dell'azienda attuale con una di riferimento, di aggiornarla trasferendo i codici (via via selezionati)
  • apportare le stesse modifiche che si fanno sull'azienda corrente, anche su tutti i database selezionati prima di iniziare l'elaborazione, che DEVONO però avere la tabella dei codici del bilancio cee ASSOLUTAMENTE UGUALE all'azienda corrente.

La prima maschera presenta l'elenco delle aziende (manca quella corrente) e consente di selezionare quelle sulle quali modificare in automatico le tabelle cee, così come verranno modificate sull'azienda corrente.
Condizione NECESSARIA affinchè l'operazione abbia un risultato sensato è che le aziende selezionate abbiano la tabella dei codici del bilancio cee (CeeBilTesta) ASSOLUTAMENTE UGUALE all'azienda corrente.
Se non si seleziona nessun database si lavorerà solo sul database corrente.

Se il programma alla partenza, trova che ci sono, nella tabella CeeBilDett, dei conti collegati a voci del bilancio cee inesistenti, da la seguente segnalazione:
"Ci sono dettagli senza la relativa testata, usare l'apposita funzione per eliminarli"
La funzione per cancellarli è all'interno del programma stesso:
Verif.Dett.

Successivamente, al centro del video, viene visualizzata la struttura della tabella Cee dell'azienda corrente e a destra le caratteristiche del nodo (voce) su cui si è posizionati.
Per il significato dei campi vedere Tabella bilancio cee.

Con un click sui nodi è possibile comprimere o espandere il singolo nodo della struttura.
Con i pulsanti: Espandi, Comprimi dettagli e Comprimi, è possibile visualizzare rispettivamente il dettaglio dei nodi fino ad avere l'elenco dei conti collegati ad ogni nodo, solo i nodi principali oppure tutta la struttura tranne l'elenco dei conti collegati.

Se ci si posiziona su un nodo di dettaglio (conto, mastro, gruppo o formula) a destra verranno visualizzate le sue caratteristiche con possibilità di variazione. Non è possibile tuttavia variare il tipo.

Inserisci
Consente di inserire un nuovo codice sopra a quello su cui si è posizionati. Se si è posizionati sull'ultimo codice della tabella verrà chiesto se inserire prima o dopo.
Si può inserire una testata oppure un conto.
Se si inserisce una testata, chiede se spostare le righe sulla tabella Pesi. Poichè in generale questa funzione verrà utilizzata per allineare la tabella cee a quella del db vuoto, e la tabella pese è già 'corretta', si consiglio di non spuntare l'opzione se non dopo attenta valutazione.
Se si inserisce un conto chiede se farlo anche sui db collegati.

Cancella
La cancellazione di una riga (nodo) che contiene dei sottonodi cancella tutto il nodo, 'sottonodi' e dettagli di quel nodo, mentre quella di una che contiene un gruppo, mastro o conto chiede se deve essere effettuata anche sui database collegati o solo su questo di lavoro.
Se si dice di operare anche sui database collegati, la cancellazione verrà fatta per quel dettaglio in modo posizionale, senza controllare se ha lo stesso codice (Cioè se cancello un conto che è il secondo dettaglio, il programma cancellerà su tutti i db collegati il secondo dettaglio di quella testata)
La cancellazione di un nodo non compatta.

Appendi
Consente di creare un "sottonodo" o inserire una voce di dettaglio (conto).
Es. sotto al codice 01-02 si vuole creare un nuovo nodo 01-02-01: occorre posizionarsi su 01-02 e premere il tasto Appendi. Verrà chiesto se si vuole appendere una Testata o un Dettaglio e a seconda della risposta verrà generato il codice della nuova testata e chiesto di digitare le caratteristiche , oppure verrà proposta la maschera per l'inserimento di una riga di dettaglio.
Se si aggiunge una riga di dettaglio, questa NON verrà aggiunta anche ai DB collegati.

Confronto
Consente di scegliere il database di confronto (quello 'corretto') da utilizzare per allineare l'attuale (e quelli eventualmente collegati). La sua struttura viene visualizzata nella colonna di sinistra. Quando l'operatore si posiziona su un nodo di questa struttura il programma cerca di posizionarsi sullo stesso nodo anche sul database di lavoro.
Le caratteristiche del nodo del database 'di confronto' verranno visualizzate, in modo sintetico, nella riga sotto la sua struttura.
In alto, sopra le strutture da confrontare, ci sono rispettivamente il nome del database di 'confronto' e la descrizione dell'azienda da allineare.
Con un clik su quest'ultimo verrà letta di nuovo dal disco la struttura e rivisualizzata in modo da aggiornarla se fosse stata modificata da un altro utente o da un'altra sessione.

Per aggiornare il database di lavoro a partire dall'altro sono state abilitate le seguenti funzioni:
Trasferisci voce
Non trasferisce la tabella Pesi
Posizionarsi sulla voce da trasferire del db di confronto e su quella successiva al punto dove si vuole l'inserimento, sul db di lavoro. Il programma chiede se trasferire con lo stesso codice di origine oppure Prima dell'attuale codice di destinazione.
Poi chiede: nei dettagli trasferire solo le formule o tutto. Se Tutto verranno trasferiti anche i conti collegati, se "Solo formule" invece, solo i dettagli che contengono delle formule.
Copia voci
Copia le caratteristiche della voce selezionata, dal db di confronto all'attuale. Se si è posizionati su voci diverse, chiede conferma prima di proseguire.
Se si è posizionati su una riga di dettaglio, copia solo sul database di lavoro e non su quelli collegati.

Copia codici excel
Consente di copiare i codici excel dalle voci della testata del database di confronto all'altro/i a parità di codice voce.

Altri pulsanti per la gestione

Annulla
Annulla l'ultima operazione fatta

Esci

Salva

Db Collegati
Apre una pagina con l'elenco dei database in modo da poter vedere i database collegati al momento dell'entrata nel programma ed eventualmente variarli.

Verif.Dett.
Consente di controllare se ci sono, nella tabella CeeBilDett, dei conti collegati a voci del bilancio cee inesistenti e di cancellarle.

Sposta dett
Se si spostano un gruppo di dettagli li può spostare su tutti i db perchè vede il blocco. Se invece si chiede di spostare un solo conto, lo spostamento va fatto solo sul db attuale (togliere la spunta sul flag proposto).

Descrizione delle operazioni da eseguire per allineare alla nuova struttura, una tabella Cee che abbia la struttura fornita in precedenza nel database vuoto

Confronto le Tabelle Cee dell'archivio dimostrativo attuale, adeguate per xbrl, con quelle delle versioni precedenti.
Voce 01-05 Altri ricavi e proventi in precedenza aveva i conti collegati direttamente, ora ha due voci collegate: 01-05-01 e 01-05-02 alle quali vanno collegati i conti
Si dovrà perciò trasferire la voce 01-05-01 dal database di confronto a quello di lavoro (e ai collegati)
Posizionarsi sul codice 01-05-01 del db di confronto
Posizionarsi sulla riga successiva al codice 01-05 del db di lavoro
Scegliere: Trasferisci voce
Viene posta una richiesta: "
Vuoi trasferire con lo stesso codice di origine 01-05-01 o prima dell'attuale codice di destinazione 01-05?" Scegliere "con lo stesso codice di origine 01-05-01"
Alla domanda "Dei dettagli trasferire solo le formule o tutto" Scegliere Formule se non si vogliono trasferire gli eventuali conti collegati altrimenti scegliere "Tutto"

Idem per 01-05-02

Per spostare i conti che prima erano collegati direttamente alla testata 01-05:
posizionarsi sulla riga 01-05 del db di lavoro e fare un click su

Sposta dett
Viene chiesto il codice voce su cui sposare i dettagli e se si vogliono aggiornare o meno anche i db collegati.

La voce 04-01 ora si divide in 04-01-01, 04-01-02, 04-01-03
Si possono trasferire le nuove voci con il pulsante: Trasferisci voce da sinistra a destra, una volta che a sinistra si è posizionati su 04-01-01 e a destra su 04-01 dicendo di trasferire con lo stesso codice e Tutto.
Stessa cosa per le righe: 04-01-02, 04-01-03

La voce 04-02-01 ora si divide in 04-02-01-01, 04-02-01-02, 04-02-01-03, 04-02-01-04
Si possono trasferire le nuove voci con il pulsante: Trasferisci voce da sinistra a destra, una per volta.
Posizionarsi a sinistra su 04-02-01-01 e a destra su 04-02-01 dicendo di trasferire con lo stesso codice e Tutto.
Stessa cosa per le righe: 04-02-01-02, 04-02-01-03, 04-02-01-04
Alla voce 04-02-01-04, sul db di confronto è associato in mastro che viene trasferito (se si dice di trasferire Tutto).
Se nel db di lavoro ci sono dei conti o mastri collegati direttamente alla voce 04-02 o 04-02-01 occorre cancellarli e collegarli alle nuove 'sottovoci'.

La voce 04-02-04 ora si divide in 04-02-04-01, 04-02-04-02, 04-02-04-03, 04-02-04-04
Operare come per il codice precedente

La voce 04-03 ora si divide in 04-03-01, 04-03-02, 04-03-03, 04-03-04
Operare come per le precedenti

La voce 04-04 è nuova e va inserita con il pulsante: Trasferisci voce

La voce 06-01 ora si divide in 06-01-01, 06-01-02, 06-01-03
Operare come per le precedenti. Fare attenzione al dettaglio 06-01-02 che ha collegata la riga di arrotondamento perchè DEVE essere trasferito completamente.
Se nel db di lavoro ci sono dei conti o mastri collegati direttamente alla voce 06-01 occorre cancellarli e collegarli alle nuove 'sottovoci'.

La voce 06-02 ora si divide in 06-02-01, 06-02-02, 06-02-03, 06-02-04
Operare come per la precedente

Nella voce 08 occorre trasferire le 'sottovoci': 08-01, 08-02, 08-03, 08-04 e collegare i conti opportuni

Le voci 09, 10, 11 non ci sono più nel db di confronto per cui vanno cancellate nel db di lavoro, prendendo nota degli eventuali conti collegati che andranno collegati ad altre testate.

La voce 12 è una voce di totale che è variata, si può cancellare quella del db di lavoro e Trasferirla dal db di confronto.

Nella voce 50 occorre trasferire le 'sottovoci': 50-01 e 50-02 e collegare i conti opportuni

Nella voce 51-01 è stata aggiunta la 'sottovoce' 51-01-07. Trasferirla.

Nella voce 51-02 è stata tolta la 'sottovoce' 51-02-06. Cancellarla e collegare i suoi eventuali conti, ad altre voci.

Nella voce 51-03-01 è stata aggiunta la voce 51-03-01-03 IMPRESE CONTROLLANTI che ha spostato alla 51-03-01-04 la successiva: ALTRE IMPRESE. Basta utilizzare il pulsante [image] Trasferisci voce posizionandosi a sinistra sulla 51-03-01-03 e a destra sulla stessa. Il programma copierà la voce e sposterà di una posizione la successiva.

Nella voce 51-03-03 non ci vanno più le sottovoci 51-03-03-01 e 51-03-03-02 che vanno cancellate

Nella voce 51-03-04 si deve aggiungere la 'sottovoce' 51-03-04-01

Tra le voci 52-02-04 e 52-02-05 si inseriscono 2 nuove voci: PER CREDITI TRIBUTARI e IMPOSTE ANTICIPATE. Si possono trasferire dal db di confronto con lo stesso codice; il programma sposterà di 2 posizioni il codice delle voci successive.

Le voci 52-02-08 e 52-02-09 sono state create per la stampa del bilancio in forma abbreviata.
Se si deve stampare il bilancio in tale forma occorre inserire queste due nuove voci ed associare anche ad esse gli stessi conti associati alle voci precedenti dello stesso nodo 52-02 perchè per l'abbreviato stamperà solo queste. Vedi parametro di personalizzazione AbbSommaSup.

Dopo la voce 52-03-02 va inserita PART.IMPRESE CONTROLLANTI. Posizionarsi su questa voce e cliccare su Trasferisci voce

Sotto la voce 52-03-05 è stata creata la 52-03-05-01 Valore nominale che va inserita

La voce 53-01 che si chiamava Ratei attivi ora è RATEI e RISCONTI ATTIVI. Si può modificare direttamente la descrizione e premere i pulsante Salva
Stessa cosa per la 53-02. Si può variare la descrizione o premere [image] Copia voci

La voce 60-09 può essere cancellata dal db di lavoro poi si può trasferire, con tutte le sue sottovoci, dal db di riferimento

Dopo la 63-02 va inserita la voce: DEBITI VERSO SOCI PER FINANZIAMENTI. Posizionarsi a Sinistra sulla 63-03 e premere Trasferisci voce. Verrà inserita la nuova voce e rinumerate le voci successive
Nelle voci successive: 63-04 etc. occorre sistemare la sigla Cee che, avendo inserito un codice, va aumentata di uno (vedere db di confronto in basso a destra dove vengono visualizzate la descrizione e le caratteristiche della voce corrente.

Le voci 63-15 e 63-16 sono state create per la stampa del bilancio in forma abbreviata.
Vale lo stesso discorso delle 52-02-08

Le voci 64-01 e 64-02 sono nuove e si possono trasferire. A questo rimangono le due voci vecchie con gli eventuali conti collegati, occorre spostare i conti nella posizione giusta (con Sposta dettagli) poi cancellarle.

I conti d'ordine: nodo 70 con tutti i sottonodi sono nuovi per cui si possono trasferire così come sono.

A questo punto occorre copiare i codici excel dal database di riferimento con il pulsante [image] Copia codici excel.

Controllare con Elenco conti non utilizzati se ci sono dei conti che eventualmente non sono stati collegati e hanno un saldo nell'anno di bilancio, quindi provvedere a collegarli.

Con la Stampa tabella Cee, controllare che le caratteristiche delle voci di testata (Sigla cee, Natura, Tipo Riga etc.) siano corrette (cioè uguali a quelle dell'archivio dimostrativo)

NOTE:

Per esigenze del nuovo bilancio in alcune voci, nella testata è cambiato il Tipo riga:
in 04-03 e 06-02 ora ci va: Normale e Somma invertita al posto di Totale e somma invertita.

Segno dei conti collegati:
Fare attenzione al fatto che per alcune voci nei conti collegati si dovrà cambiare, rispetto quanto scritto prima, l'impostazione del campo:
Operatore: "col suo segno" o "con segno invertito".
Segue un elenco di voci e di come va impostato attualmente il campo Operatore per i conti collegati ad esse e alle loro 'sottovoci'.
Codice 01 - "con segno invertito"
Codice 02 - "col suo segno" (prima era "con segno invertito")
Codice 04-03 - "col suo segno" (prima era "con segno invertito")
Codice 05 - "con segno invertito"
Codice 06-01 - "con segno invertito" (tranne 06-01-02 -arro- che va "col suo segno"
Codice 06-02 - "col suo segno" (prima era "con segno invertito")
Codice 08-01 e 08-02 - "col suo segno" (prima era "con segno invertito")
Codice 08-03 e 08-04 "con segno invertito"

Patrimoniale:
Attivo: Codici 50 - 54 - "col suo segno"
I conti (gruppi o mastri) collegati alle voci del Patrimoniale Passivo (Codice voce 60 ...64) devono avere in Operatore: "con segno invertito" (prima della realizzazione dell'XBRL il campo Operatore andava impostato "col suo segno" perchè ci pensava il programma a invertire gli importi). Solo il 'conto' fittizio 01-01-arro (collegato al codice 60-07) va lasciato "col suo segno" e la voce di totale 60-09-01


BILANCIO CEE - SPOSTAMENTO CODICI

Percorso: Contabilità - Bilancio Cee - Tabella Bilancio Cee

Questo pulsante può essere utilizzato per spostare un codice e tutti i suoi "sottocodici" della tabella del Bilancio Cee.
Es. per mettere il codice 63 al posto del 62:
posizionarsi sul codice 63 con la gestione
Voce da spostare: 63, Codice voce: 62 poi utilizzare il pulsante Spostare prima di questa voce


ESTRAZIONE DATI

Percorso: Contabilità - Bilancio Cee - Gestioni

Questa funzione prepara, a partire dalle tabelle impostate per il bilancio cee, dal piano dei conti e dai progressivi dei conti nell'anno richiesto, una tabella nella quale, per ogni voce di bilancio vengono calcolati l'importo dell'anno in corso e dell'anno precedente.

Tali importi possono essere visualizzati e gestiti con la funzione: Tabella Bilancio Cee entrando nel dettaglio con il pulsante [image] (T) Totali piuttosto che con [image] (E-F10) Gestione dettagli. Se si modificano gli importi o si aggiungono dettagli occorre poi eseguire la funzione ricalcolo, per far entrare i nuovi importi nei totali, tramite il pulsante [image] (X) Ricalcola, visualizzato come ultimo nella barra dei pulsanti in testata.

Se per una ditta si deve stampare il Bilancio anche in forma abbreviata occorre collegare i conti opportuni anche alle testate con il campo "Forma di stampa": in forma abbreviata (oltre che a quelle normali).
Se per una ditta si deve stampare SOLO in forma abbreviata è possibile attivare il parametro di personalizzazione AbbSommaSup.
In questo modo si dovranno collegare i conti opportuni solo alle testate con il campo "Forma di stampa": in forma abbreviata (evitando di collegarle anche in quelle "in forma normale")


STAMPA BILANCIO CEE

Percorso: Contabilità - Bilancio Cee - Stampe

La funzione consente di stampare il Bilancio Cee secondo l'ordine:

  • Economico
  • Attività
  • Passività
  • Conti d'ordine attivi e passivi

Tipo di stampa

  • Normale
  • Abbreviata (riguarda i conti patrimoniali in cui è stato inserito il flag di Abbreviato). In questo caso verranno stampate tutte le voci del conto economico e SOLO quelle dei patrimoniali nelle quali in Forma di Stampa è stato messo Sempre o in forma Abbreviata.
    Questo tipo di stampa è valida quando siano verificati i criteri previsti dalla legge per la presentazione del bilancio cee in forma abbreviata.

Formato di stampa

  • carta normale
  • carta "Uso bollo" (con doppia interlinea
    Se si stampa su carta Uso Bollo si consente l'inserimento di un insieme di dati riguardanti la ditta, (ragione sociale, indirizzo, sede, capitale, campi liberi, ecc.) che verranno stampati sulla prima pagina delle varie sezioni (economici, patrimoniali, d'ordine).

E' possibile stampare solo le voci previste dalla tabella base oppure le voci e il dettaglio dei conti, clienti e fornitori (in quest'ultimo caso si possono escludere i conti con saldo a 0)
Si possono stampare o meno i codici dei vari conti.
Si può stampare solo il saldo corrente o anche quello dell'anno precedente.

Se si sceglie la stampa su stampante ad aghi, come indicato nella maschera, è possibile inserire dei codici di controllo per la stampante al fine di ottenere una stampa più leggibile evidenziando le voci di livello più significative.
Va specificata una sequenza di caratteri per avviare la stampa in grassetto, o in sottolineato e una per tornare al normale.
I valori proposti (27,71/27,72) si riferiscono ad una stampante MT.
Cancellando i valori si esclude questa opzione.

La richiesta 'livello' indica per quanti livelli, a partire dal primo, va applicata la funzione di evidenziazione e riguarda anche le stampanti Laser.


GESTIONE DATI ESTRATTI

Percorso: Contabilità - Bilancio Cee - Gestioni - Tabella Bilancio Cee

Questa funzione, inserita a menu all'interno della scelta: Tabella bilancio cee, può rendersi necessaria per inserire o modificare gli importi calcolati dal programma di estrazione dati.
Si accede ai dettagli con importo premendo il pulsante: (T) Totali nella maschera di testata della Gestione bilancio cee.

Non è previsto alcun controllo sui dettagli inseriti e o modificati in modo che l'utente possa forzare qualsiasi situazione.
Se si modificano gli importi o si aggiungono dettagli occorre poi eseguire la funzione ricalcolo, per far entrare i nuovi importi nei totali, tramite il pulsante [image] (X) Ricalcola , visualizzato come ultimo nella barra dei pulsanti in testata.

Questa funzione di ricalcolo, deve essere obbligatoriamente usata per risolvere casi di calcoli ciclici come indicato al paragrafo relativo alla estrazione dati.

Si noti che qui, nei dettagli, è previsto l'inserimento di conti, clienti e fornitori, ma non di gruppi o mastri, poichè questa è una struttura d'appoggio già esplicitata.

Importo
E' il saldo del conto (cliente o fornitore) della riga.

Importo anno precedente
E' il saldo dell'anno precedente scritto, al momento dell'apertura, sulla sintesi del conto.


STAMPA TABELLA

Percorso: Contabilità - Bilancio Cee - Stampe - Tabella Cee

La funzione consente la stampa sequenziale della tabella dei collegamenti tra le voci del bilancio cee e i conti del piano dei conti.
Questa tabella deve essere impostata correttamente per la preparazione e la stampa del Bilancio Cee.

E' possibile stampare tutta la struttura del bilancio (testate) con l'elenco dei conti collegati ad ogni voce (dettagli), oppure escludere i conti.
Se si escludono i conti, verranno comunque stampati i dettagli contenenti le formule per i totali e le righe di arrotondamento.


ELENCO CONTI NON UTILIZZATI

Percorso: Contabilità - Bilancio Cee - Stampe

Questa funzione serve, prima di procedere all'estrazione dati per bilancio cee, per verificare se sono stati inseriti, nelle tabelle di collegamento del bilancio cee con il piano dei conti, direttamente o in forma di mastro o gruppo, tutti i conti presenti sul piano dei conti.

Viene prodotta una stampa/visualizzazione con l'elenco dei conti mancanti.


BILANCIO CEE - PREPARAZIONE FILE XBRL DEL BILANCIO

Percorso: Contabilità - Bilancio Cee - Xbrl

Questa funzione consente di preparare il file per l'invio del Bilancio in formato xbrl.
Per il corretto funzionamento del programma occorre aver predisposto in modo opportuno le tabelle del Bilancio Cee con i collegamenti ai codici del piano dei conti dell'azienda e aver eseguito l' Estrazione dati per bilancio cee.
Devono inoltre essere stati compilati correttamente i dati anagrafici ditta, tutti i campi inseriti nella maschera Cee-Xbrl: Cap.sociale, codice CCIAA etc. e il codice attività nella tabella attività.
(Dalla tabella ditta e attività, vengono estratti i campi descrittivi con i valori indicati nella tabella "Elementi" con descrizione "Dati anagrafici")
Vengono inoltre utilizzate le tabelle Elementi, Prospetti e Pesi per xbrl che sono collegate ai codici del Bilancio Cee.
E' pertanto indispensabile NON variare i codici del Bilancio Cee forniti nell'archivio di base (azivuoto.mdb) ma limitarsi a collegare in modo opportuno i conti ad ogni codice.
Se si renderà necessario apportare variazioni verranno date indicazioni ben precise su come farlo.

Anno
 anno del bilancio

Identificativo azienda da a
E' possibile elaborare il bilancio per una o più aziende.
Con il tasto di aiuto F2 ottiene l'elenco delle aziende disponibili in ordine di codice identificativo, con F3 in ordine di Descrizione.

Tipo di estrazione
 Serve per scegliere il tipo di bilancio da estrarre: in particolare Normale o Abbreviato
Il programma selezionerà il tipo dalla tabella dei prospetti
Normale corrisponde al tipo: ese
Abbreviato corrisponde al tipo: abb

Base per nome file xbrl
Indica dove salvare il file generato e con quale nome. Con il pulsante Cambia si può cercare un'altra destinazione piuttosto che scriverla direttamente.

Per quanto riguarda il nome da dare al file generato:
Per il nome file usare

  • Codice azienda + anno bilancio
  • Identificativo aziende + anno bilancio

Se sono più aziende e si scrive qualche lettera prima del .xbrl, il programma inserisce un _ (underline) davanti al codice azienda ( _cod.azienda+anno bilancio)

Se si usa il pulsante Cambia:
se nel nome selezionato non c'è un _ lascia soltanto il . e l'estensione xbrl e si ricostruisce il nome (codice+anno) mentre se c'è un carattere _ lascia i caratteri che lo precedono.

Estrarre anche anno precedente
Se si sta elaborando il bilancio di un'azienda nata nell'anno, occorre togliere la spunta a questa opzione.

Versione per visualizzazione

  • Se si spunta questa opzione, il file estratto avrà estensione xml piuttosto che xbrl e conterrà l'istruzione per usare, nella visualizzazione, il foglio di stile corrispondente al tipo di estrazione.
    Per la sua corretta visualizzazione, nella directory dove viene salvato il file xml, si dovranno trovare i fogli di stile forniti sul cd di installazione (file ic_stylesheet_1_1_1Ese.xsl etc. della cartella XBRL)
  • Altrimenti verrà generato un file con estensione xbrl che potrà essere visualizzato e verificato sul sito:
    http://tebe.infocamere.it/client_TEBEplus/index.jsp


STAMPA BILANCIO CEE SU EXCEL

Percorso: Contabilità - Bilancio Cee - Stampe

La funzione consente di stampare il Bilancio Cee su un file in formato excel con i requisiti per essere letto dal foglio predisposto per la compilazione delle Istanze XBRL(*)

Per poter utilizzare in modo opportuno il file generato è indispensabile aver inserito, nelle testate dei codici del bilancio cee, il codice excel.
Inoltre occorre aver eseguito l'Estrazione dati bilancio Cee per l'anno da elaborare.

l programma propone di default la stampa su un file excel: BilXbrl.xls che verrà creato nella cartella indicata dal parametro DirCarica presente nell'aziwin.ini del computer.
E' possibile cambiare la destinazione, utilizzando il pulsante: Selezione destinazione stampa.
Per memorizzare la nuova destinazione, occorre premere il pulsante "Salva opzioni stampa", deselezionare tutte le opzioni, spuntare solo: "Path di default", salvare i parametri: "SOLO per questa stampa" e Salvare
altrimenti, rientrando nel programma, verrà proposta di nuovo la destinazione di default.

Se si elaborano più ditte, il nome che verrà assegnato al file di stampa dall'operatore verrà poi completato con il codice IdAzienda
(esempio: se nome digitato è BilCee.xls e si elaborano le aziende con codice ID 003 e 004, i file generati avranno il nome: BilCee003.xls e BilCee004.xls)

Nella tabella cee fornita NON sono stati inseriti, perchè non esistenti sul file di traccia, i codici excel delle seguenti voci:
06-01-02 - Diff.da arrotondamento all'unità di euro
06-02-03 - Diff.da arrotondamento all'unità di euro
08-04 Proventi(oneri) da adesione a cons.fisc.
per cui i valori corrispondenti a tali righe non verranno caricati sul file di compilazione delle Istanze XBRL e dovranno essere inseriti manualmente. Una alternativa, se si utilizza SOLO lo scarico su excel e non la preparazione diretta del file xbrl, è quella di collegare i due dettagli 01-01-arro rispettivamente ai codici: 06-01-03 (piuttosto che la 06-01-02) e al 06-02-04 (invece che al 06-02-03)

Il codice excel manca inoltre in tutte le voci di dettaglio dei conti d'ordine e nelle due:
03 - DIFF.TRA VALORE E COSTI PRODUZIONE
07 - RISULTATO PRIMA DELLE IMPOSTE
Queste due ultime righe però risultano comunque corrette anche dopo il caricamento

(*) Occorre scaricare dal sito di Infocamere, il file zip contenente il file di generazione dell’Istanza XBRL e l’esempio di import per i bilanci e scompattarlo sul disco.
https://webtelemaco.infocamere.it/newt/rootdata/xbrl/Strumenti.html

Una volta aperto il file IstanzaXBRL.xls scaricato, attenzione al livello delle Macro in Excel che deve essere impostato su basso, si può importare tramite la funzione interna di Import, il file del bilancio preparato in precedenza ed elaborarlo all'interno dell'Istanza.


BILANCIO CEE - TABELLA ELEMENTI XBRL

Percorso: Contabilità - Bilancio Cee - Xbrl

Questa funzione consente di modificare la tabella degli Elementi, utilizzata dal programma di Preparazione del bilancio in formato XBRL.
La Tabella inserita nel database del menu (Azimenu.mdb), viene fornita già compilata, è unica per tutte le ditte e non dovrà essere modificata salvo precise indicazioni.

Codice
numero progressivo libero

Descrizione
 è il campo previsto dalla Tassonomia Xbrl

CampoAnag
 utilizzato solo per gli elementi delle sezioni informative
Se il valore corrispondente al campo inserito è una stringa vuota l'elemento non verrà estratto nel file xbrl
E' previsto il parametro di personalizzazione CampiPersInfo che può essere utilizzato per creare una stringa che contiene una combinazione di campi estratti dalle tabelle: Ditta e DitAttivita

Decimali
questo campo è normalmente a 0 per i campi INFO deve essere lasciato vuoto per i valori non numerici (tutti tranne il capitale sociale)

Unit
E' la moneta del bilancio: normalmente Eur


BILANCIO CEE - TABELLA PROSPETTI PER XBRL

Percorso: Contabilità - Bilancio Cee - Xbrl

Questa funzione consente di modificare la tabella "Prospetti", utilizzata dal programma per la preparazione del file del Bilancio in formato Xbrl per selezionare gli elementi che verranno estratti.
La Tabella inserita nel database del menu (Azimenu.mdb), è unica per tutte le ditte, viene fornita già compilata e non dovrà essere modificata salvo precise indicazioni.

Tipo
Indica il tipo di bilancio previsti: ese (bilancio normale), abb (forma abbreviata), abbsemp (forma abbreviata semplificata), cons (consolidato), info (per sezione:dati anagrafici)
Il tipo Info (che contiene i dati anagrafici) viene estratto in tutti i tipi di bilancio.

Prospetto
 per ogni tipo di bilancio vengono elencate le sottosezioni da estrarre (patrimoniale, economico, d'ordine)

Elemento
 fa riferimento ai codici della tabella "Elementi" xbrl

Ordine prospetto
 è l'ordine con cui i prospetti vengono estratti all' interno di un tipo

Ordine
 è l'ordine con cui gli elementi vengono estratti all' interno di un prospetto


BILANCIO CEE - TABELLA PESI XBRL

Percorso: Contabilità - Bilancio Cee - Xbrl

Questa funzione consente di modificare la Tabella pesi utilizzata per la preparazione del bilancio in formato Xbrl.
La Tabella viene fornita già compilata e non dovrà essere modificata salvo precise indicazioni.

Elemento
 fa riferimento ai codici della tabella "Elementi" xbrl

Codice Cee
 fa riferimento ai codici della tabella bilancio Cee

Peso
E' il peso con cui il valore calcolato con l'estrazione dati bilancio cee, corrispondente al codice cee, viene utilizzato per il calcolo del corrispondente elemento xbrl


PROGRESSIVI DI CONTABILITA'

Percorso: Contabilità - Servizio - Gestioni

Il programma consente di gestire, conto per conto (compresi i clienti e i fornitori) i progressivi contabili di un determinato esercizio. Tali progressivi vengono aggiornati in tempo reale, al momento della conferma delle registrazioni (da prima nota, da saldaconto, da contabilizzazione distinte etc.).

Tali progressivi sono memorizzati nella moneta di gestione.

Il campo Saldo anno precedente viene aggiornato al momento dell'apertura e servirà per essere stampato sul bilancio cee.

A questa funzione è possibile accedere, tramite un pulsante apposito, dalla gestione dei conti, dei clienti e dei fornitori.


PROGRESSIVI IVA PER CODICE IVA

Percorso: Contabilità - Servizio - Gestioni

Questa funzione consente di visualizzare e modificare i progressivi iva (acquisti, vendite e corrispettivi) dei vari periodi, aggiornati durante l'esecuzione dell'aggiornamento iva.

I progressivi presenti pertanto, sono SOLO quelli corrispondenti alle registrazioni dei periodi per cui è stato fatto l'aggiornamento Iva.

La variazione manuale di questi campi deve essere fatta SOLO dopo un'attenta valutazione in quanto essi contengono il risultato di registrazioni aggiornate che poi verranno stampate sui registri iva.

Pertanto, invece di variare questi progressivi, si consiglia di variare le registrazioni stesse che li hanno generati (dopo aver fatto il loro disaggiornamento iva).


PROGRESSIVI IVA

Percorso: Contabilità - Servizio - Stampe

La funzione consente di stampare i progressivi iva di un determinato anno, con possibilità di scegliere il tipo di registro (Vendite, acquisti, corrispettivi) e il periodo.

I progressivi presenti sono SOLO quelli corrispondenti alle fatture dei periodi per cui è stato fatto l'aggiornamento Iva.

I progressivi stampati possono essere, a scelta dell'operatore, solo i progressivi del periodo richiesto oppure quelli da inizio anno al periodo richiesto sintetici o dettagliati mese per mese.


ELENCO RISULTATI CHIUSURE IVA

Percorso: Contabilità - Servizio - Stampe

La funzione consente di stampare il risultato delle Chiusure Iva effettuate, anche solo in prova, in un determinato anno.
Per ogni periodo (mese o trimestre) viene stampato il credito o il debito iva del periodo con la relativa data di versamento.

Questa stampa è utile per la compilazione della Dichiarazione iva annuale.

Note:
Nel caso che la ditta abbia più codici attività, per un corretto funzionamento del programma, occorre che siano state eseguite le chiusure delle singole attività e, per ogni periodo, la chiusura riepilogativa.

Se la ditta ha iva trimestrale, la liquidazione del 4' trimestre non memorizza il risultato finale per cui, nella stampa, potrebbe non essere corretto il risultato dell'ultimo trimestre. Per questo motivo viene scritta la nota: "Verificare".


PROGRESSIVI IVA PERIODICI

Percorso: Contabilità - Servizio - Gestioni

Questa funzione consente di visualizzare e modificare il progressivo incassi da ventilare di un determinato anno-attività-periodo.

L'importo dei corrispettivi da ventilare di ogni periodo viene aggiornato dall'aggiornamento iva (dei movimenti iva) in corrispondenza a causali con tipo iva: incassi da ventilare.

La variazione manuale di questo campo deve essere fatta SOLO dopo un'attenta valutazione in quanto esso rispecchia un risultato di registrazioni che poi verranno stampate sui registri iva.

Pertanto, invece di variare questo progressivo, si consiglia di variare le registrazioni stesse che lo hanno generato (dopo aver fatto il loro disaggiornamento iva).


PROGRESSIVI IVA CLIENTI-FORNITORI

Percorso: Contabilità - Servizio - Gestioni

I progressivi presenti sono SOLO quelli corrispondenti alle fatture dei periodi per cui è stato fatto l'aggiornamento Iva.

La maschera contiene due gruppi di progressivi:

Un primo gruppo: imponibile, imposta, esente e numero documenti di ogni cliente o fornitore aggiornati dall'aggiornamento iva considerando tutti i documenti in base alla data di registrazione. Per cui per ogni anno e codice cli/for c'è la somma dei documenti registrati.

L'altro gruppo di dati invece, contiene i progressivi che verranno scaricati nel file per l'invio telematico dell'Elenco clienti e fornitori. Essi vengono aggiornati, dal Ricalcolo progressivi iva clienti e fornitori, in base a criteri ben precisi, come richiesto dalla normativa che spiega come compilare gli elenchi suddetti.

In particolare:

- Gli importi sono la somma degli importi delle fatture con anno della data documento (e non di registrazione) uguale all'anno indicato a video. Cioè una fattura che arriva da un fornitore nel 2008 ma ha data documento del 2007 va ad aggiornare i progressivi del fornitore nel 2007.

Poiché a regime, l'invio degli Elenchi clienti e fornitori andrà fatto entro il 29 aprile di ogni anno, è indispensabile aver registrato, a quella data, anche tutte le fatture ricevute, con data anno precedente.

- Su ogni codice iva (tabella dei codici iva) c'è un flag che indica se gli importi registrati con quel codice deve andare a sommarsi sui progressivi per gli allegati (es. l'esente art.15 non ci deve andare). Inoltre ci sono altri due flag che indicano, se sommare su due importi particolari: Operazioni imponibili con iva non esposta in fattura e Operazioni registrate senza separata indicazione di imponibile e imposta

Occorre compilare adeguatamente questi flag per ottenere dei progressivi corretti

- Verranno tenuti separati, dall'aggiornamento, i progressivi relativi a note di variazione emesse o ricevute nell'anno ma relative ad anni precedenti (sono identificate da un flag da compilare, a cura dell'utente, in testata della fattura in fase di registrazione della stessa in Fatture o in Prima nota).


PROGRESSIVI IVA CLIENTI E FORNITORI

Percorso: Contabilità - Servizio - Stampe

Il programma consente di stampare i progressivi imponibile, imposta, esente e numero documenti di ogni cliente-fornitore per anno contabile (corrispondenti ai documenti registrati nei periodi per cui è stato fatto l'aggiornamento Iva) e/o i progressivi calcolati dal Ricalcolo progressivi iva per Elenchi clienti e fornitori (vecchia funzione lasciata per consentire di controllare le movimentazioni fatte)

Le varie opzioni consentono di stampare i dati che serviranno, tra l'altro, alla compilazione del MODELLO IVA Annuale e di controllare i progressivi degli Elenchi.

E' stata inserita una selezione per consentire di stampare SOLO i clienti con Partita Iva (Aziende) o SOLO quelli con codice fiscale o partita iva che inizia per 8 o 9 (privati o assimilati a privati: condomini, scuole, parrocchie). Questo per ottenere il totale fatturato (imponibile e imposta) fatto con i privati e non.

Per un ulteriore controllo è possibile stampare anche la Partita Iva/codice fiscale dei clienti in elenco.

Al fine di preparare i dati per la compilazione del quadro in cui viene chiesto di riportare le operazioni imponibili verso i consumatori finali suddivisi per regione, viene data la possibilità di stampare i clienti raggruppati per regione, in formato sintetico (solo i totali di ogni regione) o dettagliato (con l'elenco dei clienti). (Dalla Versione 1.13C)

Perché la stampa per regione risulti corretta occorre che sia stato compilato correttamente il CAP, su tutte le anagrafiche. Per determinare la regione di appartenenza del cliente il programma utilizza due tabelle: CAP e Regioni che sono sul database. Di queste tabelle non esiste la gestione e devono essere precompilate.

Pertanto prima di eseguire la stampa per la prima volta o se la stampa non fa la suddivisione per regioni, occorre caricare dal database vuoto tali tabelle:

  • accertarsi che nella cartella \database ci sia il file: AziVuoto.mdb
  • dal menu principale di Aziwin premere i tasti Shift Ctrl Alt L (contemporaneamente)
  • scegliere: Copia tabelle tra i programmi da eseguire
  • copiare da AziVuoto.mdb al database di lavoro, il contenuto delle tabelle CAP e Regioni


VARIAZIONE AUTOMATICA CONTI

Percorso: Contabilità - Utilità - Utilità

La funzione consente di variare automaticamente il contenuto dei campi dell' anagrafica Conti.

Segue un elenco di campi per i quali è possibile fare la variazione automatica.
Potrà essere modificato un campo per volta scegliendolo con un click.

Se il campo da modificare non è tra quelli elencati, potrà essere modificato con la scelta: Campo selez.
Con questa scelta verranno elencati tutti i campi della tabella Pianoconti e si potrà scegliere quello da modificare. (Nota: poichè la tabella che contiene i conti, contiene anche i clienti e i fornitori i campi elencati sono tutti e non solo quelli dei conti)

Nella colonna DA occorre impostare il contenuto attuale del campo da modificare, in colonna A, il nuovo contenuto.

Nelle selezioni iniziali, si chiede:
Se il campo "Da" viene lasciato vuoto, quali anagrafiche si intende modificare:

  • Tutti
    verrà scritto il contenuto del campo "A" su TUTTI i conti selezionati
  • Solo quelli con campo interessato vuoto
    verrà scritto il contenuto del campo "A" solo sui conti selezionati che abbiano il campo interessato "Vuoto"

Se invece viene lasciato bianco il campo "A" verrà sbiancato quel campo su tutti i conti selezionati, in cui il contenuto del Campo "Da" è quello digitato.


RICERCA MOVIMENTI PER IMPORTO

Percorso: Contabilità - Utilità - Utilità

Il programma consente di visualizzare i movimenti registrati in un certo anno, con importo compreso tra due importi digitati dall'utente.

Se si clicca sul pulsante "Posiziona in Prima Nota" quando si è posizionati su una riga di un movimento visualizzato, il programma entrerà nella maschera di prima nota della registrazione.

Può essere utile quando serva cercare una registrazione della quale si conosce più o meno l'importo.


VARIAZIONE STATO GIORNALE

Percorso: Contabilità - Utilità - Utilità

Questa funzione deve essere eseguita con molta attenzione.

Essa consente di cambiare lo stato di una registrazione di prima nota da stampata a non stampata sul giornale e viceversa.

Può essere utilizzata:

  • Per poter variare una o più registrazioni già stampate e fare poi la variazione a mano sul giornale
  • Per ristampare tutto un pezzo di giornale (invece di utilizzare l'opzione di ristampa)

In quest'ultimo caso occorre fare molta attenzione, prima di rieseguire la stampa 'definitiva' a riportare indietro il numeratore di righe del giornale e i progressivi Dare e Avere ai valori stampati nell'ultima pagina 'corretta' stampata in precedenza.


VARIAZIONE STATO IVA

Percorso: Contabilità - Utilità - Utilità

Questa funzione deve essere eseguita con molta attenzione in quanto modifica lo stato dei movimenti iva cioè il segnale che indica se è avvenuto o meno, per registrazione, l'aggiornamento dei progressivi e la stampa sul registro.

Essa consente di cambiare lo stato di una o più registrazioni di prima nota da 'stampato sul registro iva' ad 'aggiornato iva' per poter poi ripetere la stampa oppure disaggiornare, variare e riaggiornare.

Può essere utilizzata inoltre, per portare una o più registrazioni dallo stato di 'aggiornato' a 'stampato sul registro iva'.


DISAGGIORNAMENTO MOVIMENTI IVA

DISAGGIORNAMENTO MOVIMENTI IVA e IVA per CASSA

Percorso: Contabilità - Utilità - Utilità

Il programma consente di 'disaggiornare' uno o più movimenti iva (purchè non siano stati stampati sul registro iva), in modo da poterli poi variare dall'input prima nota e riaggiornarli.
Vedi note su come variare o aggiungere documenti.

Il 'disaggiornamento' consente nel decrementare i progressivi iva, per gli importi dei movimenti interessati.

Nel caso del regime dell'Iva per Cassa, si consente di disaggiornare anche movimenti di incasso/pagamento che si riferiscono a documenti con iva per cassa.


RIGENERAZIONE PROGRESSIVI CONTABILI

Percorso: Contabilità - Utilità - Utilità

Il programma azzera i progressivi contabili di un determinato anno e li ricalcola a partire dai movimenti.

Viene data la possibilità di inserire un intervallo di date di registrazione al quale devono appartenere i movimenti da aggiornare. Normalmente tali date dovranno essere lasciate bianche in quanto si dovrà tener conto di tutti i movimenti con anno uguale a quello scritto a video, indipendentemente dalla loro data di registrazione.

Ci possono però essere dei casi 'molto particolari' nei quali si rende necessario considerare solo i movimenti registrati in un certo intervallo di date, SOLO in questi casi verranno digitate le date Da.. A …


RINUMERAZIONE PROTOCOLLI

Percorso: Contabilità - Utilità - Utilità

Questa funzione consente di rinumerare i protocolli assegnati alle fatture/note di credito di acquisto al momento della registrazione per riparare un errore ad esempio il salto di un protocollo.

E' obbligatorio l'inserimento dell'anno di registrazione, del prefisso (per identificare il registro iva da rinumerare e del primo numero nuovo da assegnare. Nel caso, per altro più comune, che venga utilizzato un unico registro iva acquisti, in 'prefisso protocollo' si dovrà digitare un . (punto)

Se viene compilata anche la data protocollo, il programma controlla che non ci siano movimenti con data protocollo inferiore e numero maggiore del nuovo numero iniziale.

Nel caso si sia scelto di numerare le note di credito separatamente rispetto le fatture viene data la possibilità di rinumerare le une o le altre.

Una volta modificato il numero protocollo su una fattura/Nc, esso viene aggiornato anche sulle eventuali registrazioni di pagamento con uguale numero e data documento e stesso protocollo.

Vengono inoltre aggiornate le scadenze generate dalla fattura (stesso anno, numero registrazione, prefisso e numero protocollo)

Nota:
Il programma suppone che le registrazioni abbiano numeri documenti diversi (in quanto riferite a fatture diverse). Le registrazioni con numero documento uguali non vengono rinumerate correttamente per cui è indispensabile sistemarle prima di procedere alla Rinumerazione.


NUMERAZIONE REGISTRI DA VIDIMARE

Percorso: Contabilità - Servizio - Stampe

Il programma consente di numerare automaticamente del fogli bianchi che potranno poi essere vidimati ed utilizzati per la stampa del giornale bollato, dei registri iva o di altri registri.

A video vengono fatte una serie di richieste per consentire all'utente di personalizzare i dati da stampare e la forma in cui stamparli. Si può decidere di dare o meno un'intestazione ai fogli numerati, di stampare la ragione sociale e anche l'indirizzo della ditta. Per ottenere la stampa di queste tre informazioni occorre barrare gli appositi campi e compilare l'intestazione.

Per le stampanti diverse da quelle ad aghi, si può digitare un numero, in millimetri, che indicherà il margine da lasciare in alto nel foglio prima dell'intestazione.

A seconda del tipo di utilizzo che si intende fare dei fogli numerati, viene proposto un testo precompilato, con possibilità di variarlo e di scegliere se stamparlo 'sul primo', 'sull'ultimo foglio' o 'non stamparlo.
E' possibile memorizzare un testo personalizzato e richiamarlo al bisogno.

L'unica restrizione, nella compilazione del testo, è che si rimanga nell'ambito dei 110 caratteri per riga.
All'interno del testo con la scritta <$NUMPAG$> si intende che in quel punto verrà riportato il numero di pagine stampate.


COMPETENZA - VARIAZIONE DATE

Percorso: Contabilità - Utilità - Utilità

Questa funzione consente di variare velocemente le date di competenza sulle righe di registrazione, richiamandole per anno contabile, data di registrazione, causale e codice conto.

Le date di competenza,se inserite, consentiranno a fine anno di calcolare in automatico i ratei e i risconti.

Tali date possono essere inserite, con l'apposito pulsante, durante la registrazione di prima nota oppure, in un secondo momento, con questo programma di utilità.


SISTEMAZIONE PARTITE

Percorso: Contabilità - Utilità - Utilità

Prima di procedere con l'esecuzione di questo programma si consiglia di

  • fare una copia del database
  • sistemare il campo Tipo partita sulle causali

Una partita è individuata da codice Cliente/Fornitore, prefisso, numero e data documento.
Il prefisso non viene utilizzato se impostato a S il parametro di personalizzazione NoUsaPreDoc
Una partita si apre con la registrazione della fattura e si chiude con le registrazioni dei relativi incassi/pagamenti
Su ogni causale utilizzata per le registrazioni in prima nota è possibile compilare un campo che indica se quella causale Apre o Interessa partita

Poichè è possibile decidere di gestire le partite in qualsiasi momento, impostando in modo corretto le causali, si può rendere necessario sistemare il pregresso per evitare che vengano considerate aperte delle partite vecchie solo perchè gestite in modo errato.

Questa funzione ha lo scopo di esaminare le partite e, a seconda delle opzioni scelte dall'operatore, impostando in esse un campo che le dichiara chiuse indipendentemente dal saldo.
In questo modo si renderanno più veloci la visualizzazione e la stampa delle partite o la stessa richiesta di elenco partite aperte che si può fare in prima nota quando si registra un incasso o un pagamento in quanto quelle 'eliminate' perché chiuse, non verranno più esaminate.

Si può intervenire anche manualmente, per sistemare una partita particolare, utilizzando la funzione: Modifica stato partite

Data registrazione di riferimento
Non verranno chiuse le partite con registrazioni successive a questa data.

E' possibile scegliere alcune opzioni:
Chiusura di tutte le partite, anche di quelle con saldo 0
Chiude 'forzatamente' tutte le partire, anche con saldo diverso da 0, purchè non abbiano movimenti in date successive alla data inserita a video.

Considera solo causali che si riferiscono a partita
Se non si spunta questa opzione, verranno considerate, per calcolare il saldo delle partite, tutte le registrazioni fatte con causali di contabilità nelle quali è stato spuntato il flag di Apre o Interessa partita (così come fanno i programmi di visualizzazione o stampa partite).
Se sono state chiuse delle partite con registrazioni con causali che "non interessano partita", queste risulterebbero comunque aperte per cui si possono chiudere forzatamente spuntando questo flag.

Riaprire partite non forzate che non hanno saldo 0 o che hanno movimenti in data successiva a quella inserita a video
 il programma cerca di riaprire le partite che risultano chiuse (cioè quelle alle quali il programma ha messo, in una elaborazione precedente, il segnale di partita chiusa) pur non avendo saldo a 0
se si spunta anche il flag:
Togliere flag forzato a movimenti con data successiva
verranno considerate e quindi riaperte anche eventuali partite 'con saldo diverso da 0' che sono state chiuse in modo Forzato in precedenza.

Chiusura Incassi/Pagamenti per i quali manca il documento di riferimento
Consente di impostare come Chiuse le righe relative a incassi/pagamenti per i quali non esistono più in archivio le registrazioni delle relative fatture (ad esempio perchè è stata fatta la Cancellazione completa dei movimenti di anni vecchi).


MODIFICA STATO PARTITE

Percorso: Contabilità - Utilità - Utilità

Il programma consente di visualizzare, attraverso alcune selezioni, una o più partite di un cliente o di un fornitore e di chiuderle o riaprirle.
In presenza di molti anni in linea, la visualizzazione può risultare lenta.

Per effettuare una sistemazione di tutte le partite in automatico, si consiglia di utilizzare la funzione Sistemazione partite.

Selezioni:
Cliente /Fornitore
Documento
Consente di esaminare una partita ben precisa
Il prefisso non viene utilizzato, nelle selezioni, se impostato a S il parametro di personalizzazione NoUsaPreDoc
Data documento da .. a ..
Consente di esaminare le partite di un determinato periodo
Tipo partite da visualizzare:

  • solo aperte
    con saldo diverse da 0
  • solo chiuse
    con saldo uguale a 0
  • tutte
  • solo le forzate
    (quelle che sono state chiuse in modo forzato, pur non avendo saldo 0)
  • solo le non forzate
  • tutte

Con almeno una registrazione con data maggiore di: xx/xx/aaaa e minore di xx/yy/aaaa

Considera solo le causali che si riferiscono a partita
Se non si spunta questa opzione, verranno considerate, per calcolare il saldo delle partite, tutte le registrazioni fatte con causali di contabilità nelle quali è stato spuntato il flag di Apre o Interessa partita (così come fanno i programmi di visualizzazione o stampa partite).
Se sono stati registrati incassi e o pagamenti, e quindi chiuse delle partite, con registrazioni con causali che "non interessano partita" si possono visualizzare spuntando questo flag.

Una volta confermate le selezioni verrà visualizzato l'elenco delle partite
In ogni riga viene evidenziato, in una colonna, lo STATO della partita e il segnale di FORZATO

  • A Aperta
  • C Chiusa
  • F Chiusa forzata

Si può agire con comandi utilizzando i pulsanti posti in fondo al video:

Seleziona tutto con stato X
Dove X può essere A o C a seconda dello stato della riga (partita) su cui si è posizionati,
consente di selezionare un gruppo di partite.
Per selezionare più partite si può usare il tasto Ctrl una volta posizionati con il mouse sul bordo grigio a sinistra sulla lista.

Cambia stato
Consente di cambiare lo stato alla partita della riga corrente o alle partite selezionate (se è stato premuto il pulsante precedente)
Se lo stato iniziale è A, il cambio stato imposterà il campo "stato" a C e il campo "forzato" a F

Uscire dopo aver cambiato stato
E' possibile scegliere di uscire dalla maschera dopo ogni variazione oppure di rimanere.
Se si sceglie di mantenere i movimenti perchè, fatta una variazione, se ne devono fare altre, il programma riscriverà il video e l'operazione potrebbe risultare abbastanza lenta.

E' possibile selezionare più righe da modificare contemporaneamente:
posizionarsi a sinistra della prima riga da modificare in modo che questa venga evidenziata poi, con il tasto Ctrl premuto, fare in click a sinistra delle righe successive da includere nella modifica.


RIPRISTINO DA INTERRUZIONE IN GESTIONE PRIMA NOTA

Percorso: Contabilità - Ripristini

La funzione consente di portare a termine correttamente la registrazione (e l'elaborazione) di un articolo di prima nota, qualora ci sia stata una interruzione durante l'inserimento.

Nella maggior parte dei casi l'articolo sul quale è avvenuta l'interruzione viene cancellato completamente.


RIPRISTINO DA INTERRUZIONE SALDACONTO

Percorso: Contabilità - Ripristini

La funzione consente di portare a termine il saldaconto, qualora ci sia stata una interruzione durante l'elaborazione.


RIPRISTINO DA INTERRUZIONE IN CONTABIL. DISTINTE

Percorso: Contabilità - Ripristini

La funzione consente di portare a termine la contabilizzazione delle distinte, qualora ci sia stata una interruzione durante l'elaborazione.


CANCELLAZIONE REGISTRAZIONI DI PRIMA NOTA

Percorso: Contabilità - Utilità - Utilità

Questo programma consente di cancellare un gruppo di registrazioni di Prima Nota dagli archivi definitivi di contabilità, da quelli di appoggio (movimenti eventualmente generati dalla contabilizzazione delle fatture) e da quelli della prima nota fittizia.

Non sono cancellabili le registrazioni che hanno l'iva aggiornata o che sono state stampate su bollato.

Non sono cancellabili le registrazioni di anni contabili chiusi. (Per cancellare completamente un anno contabile chiuso, utilizzare la funzione apposita)

Al termine della cancellazione dei movimenti sugli archivi definitivi di prima nota, è indispensabile eseguire il ricalcolo dei progressivi contabili, in quanto il programma cancella le registrazioni ma non aggiorna i saldi dei conti.


CANCELLAZIONE COMPLETA ESERCIZI CONTABILI CHIUSI

Percorso: Contabilità - Utilità - Utilità

Con questa funzione si consente di cancellare fisicamente tutti i dati contabili e iva relativi ad anni già chiusi.

Viene chiesto di digitare un anno e vengono eliminati, sulle tabelle che seguono, tutti i dati che si riferiscono a quell'anno:

  • Movimenti di Prima nota (vengono cancellati tutti o solo quelli che si riferiscono a partite chiuse a seconda della scelta 'Cancello anche le Partite Aperte')
    Per determinare se una partita è chiusa o no viene calcolato il saldo indipendentemente da quanto impostato sulla causale delle registrazioni.
  • Progressivi Contabili
  • Progressivi Iva (compresi quelli clienti e fornitori) e Dati Dichiarazione periodica
  • Inoltre, se si è scelto di cancellare i file di transito, si cancellano anche i Movimenti di Prima Nota presenti sull'archivio di appoggio (es. fatture) (in generale queste tabelle sono già vuote)
  • Dati iniziali iva (definizione di Mensile o Trimestrale etc.)
  • Tabelle di appoggio per iva per cassa (fatture/incassi)
  • Tabella contenente i corrispettivi inviati telematicamente
  • Se si sceglie di azzerare anche i file di transito, verranno cancellati anche gli eventuali dati contenuti nelle tabelle utilizzate come appoggio per la contabilizzazione delle fatture.

Se si esegue la cancellazione per pulire un database che dovrà poi essere utilizzato per gestire la contabilità, occorre, prima di iniziare a inserire le registrazioni, controllare le seguenti tabelle:

  • Contabilità - Gestioni - Prefissi e Numeratori documenti
    Non viene cancellata per cui occorre azzerare numero e data dell'ultimo documento registrato in acquisto, vendita e corrispettivo, in corrispondenza all'anno da gestire.
  • Contabilità - Servizio - Caratteristiche Esercizio di contabilità e
    Contabilità - Iva - Dati iniziali Iva
    Inserire i dati per l'anno da gestire.


CANCELLAZIONE ANAGRAFICHE NON MOVIMENTATE

Percorso: Contabilità - Utilità - Utilità

Il programma consente di cancellare fisicamente dall'archivio quei clienti o fornitori che non sono stati movimentati in nessuno degli anni in linea.

Per stabilire se un codice è stato utilizzato, il programma fa una ricerca su:
movimenti di magazzino, preventivi, ordini, ddt, fatture, movimenti di prima nota e sintesi contabili, se compare in uno di questi archivi, o sulle sintesi ha un saldo diverso da zero, l'anagrafica non potrà essere cancellata.

Per quelle anagrafiche che possono essere cancellate, verranno cancellati anche eventuali indirizzi di spedizione collegati.

Se, nelle selezioni, si inserisce 'codice da' uguale a 'codice a' e l'anagrafica scelta non è cancellabile, verrà data una segnalazione a video. Se invece si sceglie di cancellare un intervallo di codici, verrà stampato l'elenco di quelli effettivamente cancellati.

Se si spunta la richiesta: SOLO stampa anagrafiche non movimentate - Senza cancellare sarà possibile ottenere la sola stampa di controllo.


CARIC. MOVIMENTI DI P.NOTA DA FILE ESTERNO

Percorso: Contabilità - Utilità - Trasferimenti

Il programma legge da una tabella esterna (file ascii), opportunamente compilata, i movimenti di prima nota e li carica su un archivio di parcheggio nel quale possono essere stampati e gestiti.

Prima di caricare i movimenti, vengono creati gli eventuali codici mancanti sul database ricevente leggendoli da un file txt che deve essere preparato al momento dello scarico: conto, cliente o fornitore, codice iva, causale, banca, condizione di pagamento, centro di costo, moneta.
Compilando in modo opportuno una tabella del menu, in questa fase è possibile anche aggiornare, sul database ricevente, determinati campi in base al contenuto della tabella da caricare.

Per le specifiche del tracciato del file vedere:

  • trasferimento movimenti di prima nota (di fatture) su file
  • scarico movimenti di prima nota su file

Può essere utilizzato per caricare movimenti di fatture, creati opportunamente dall'esterno o scaricati da un altro database dopo aver contabilizzato le fatture sulle tabelle di parcheggio, oppure in generale movimenti di prima nota, scaricati su file da un altro database.

Al termine della sua esecuzione, viene lanciata in automatico la funzione che trasferisce sugli archivi di prima nota i movimenti caricati, li aggiorna e genera le scadenze quando necessario. L'operatore potrà eseguire subito questa funzione o lanciarla dal menu in un momento successivo, dopo aver controllato i dati caricati.

Il nome del file da caricare viene proposto e può essere variato. Al termine del caricamento viene rinominato con estensione '.trasf'

I movimenti vengono caricati con numero di registrazione successivo a quelli in archivio.
E' tuttavia possibile, attivando un flag di personalizzazione MantieniNumero=S mantenere lo stesso numero di registrazione originale (sempre che sull'archivio destinatario non ci siano già registrazioni con quel numero e che le registrazioni esistenti abbiano una numerazione inferiore a quelle da caricare).

Aggiornare il contenuto dei campi delle tabelle in base a quanto letto dal file esterno
Se, in fase di caricamento, oltre a caricare gli eventuali codici nuovi che si trovano sul file esterno e non presenti sul database, si vogliono aggiornare tutti o in parte, i campi delle tabelle caricate (Pianoconti, Causali, Monete, CentriDiCosto, Banche, Pagamenti e PagTipi), occorre procedere in questo modo:

Aprire la tabella Appoggio del database AziMenu.mdb

Nella prima riga vuota compilare i campi come descritto:
Codice: ImportaTab
Descr1: Nome tabella interessata (Pianoconti, Causali, Monete, CentriDiCosto, Banche, Pagamenti e PagTipi)
Descr2: Se si vogliono aggiornare tutti i campi scrivere: Tutti
viceversa, se si vogliono aggiornare pochi campi, i loro nomi possono essere scritti in Descr2, Descr3, Descr4, Descr5.
(Attenzione: per quanto riguarda la tabella PianoConti , se si mette 'Tutti' il programma va in errore in quanto i campi superano il numero previsto dal linguaggio)

Se i campi da aggiornare sono di più, si metterà l'elenco in:
Memo1 (Es. Descrizione, RagSoc, RagSoc2, Indirizzo, ...)

Dovrà essere creata almeno una riga per ogni tabella interessata. Il campo codice, per le tabelle successive alla prima, dovrà contenere la scritta ImportaTabXX dove XX può essere un numero o una stringa, l'importante è che sia sempre diverso per ogni tabella da indicare.

Se il programma di caricamento non trova in Appoggio nessuna riga con Codice: ImportaTab, procederà creando i codici nuovi, senza aggiornare nessun campo di anagrafiche preesistenti.

Note:
I campi 'codice' non possono essere aggiornati e se, sul file esterno, manca un campo chiave, viene segnalato un errore e si blocca il caricamento.
Se un campo , presente nell'elenco dei campi da aggiornare, NON è presente sul file, viene data una segnalazione non bloccante.


TRASFERIMENTO IN CONTABILITA' DEI MOV. DI FATTURE

Percorso: Contabilità - Utilità - Trasferimenti

Questa funzione consente di caricare sugli archivi della prima nota, i movimenti che si trovano sull'archivio di appoggio (di parcheggio) e quindi non ancora in linea per la contabilità.

Durante il caricamento vengono aggiornati i progressivi contabili e, se presente una condizione di pagamento, vengono generate le scadenze.

Tali movimenti possono essere stati generati dalla contabilizzazione delle fatture, se nella tabella di Fatturazione (Dati generali azienda - parametri-) si è scelto di scaricare i movimenti di fatture su archivi di parcheggio, oppure dall'importazione di movimenti da un file esterno creato con regole ben definite (es. per chi ha una fatturazione particolare e vuole passare sulla prima nota di AziendaPc i movimenti in automatico).

Nel caricamento si può scegliere di far mantenere alle registrazioni, il numero di registrazione originale. Il programma eseguirà questa opzione se non trova già sulle tabelle di destinazione una registrazione con lo stesso anno e numero altrimenti assegnerà lui automaticamente un nuovo numero.


SCARICO MOVIMENTI DI PRIMA NOTA SU FILE

Percorso: Contabilità - Utilità - Trasferimenti

Il programma consente di scaricare, su un file TXT, i movimenti di prima nota, in modo da poterli poi ricaricare su un altro database.

Come nome di file da generare viene proposto MovPn+idazienda (idazienda è il numero progressivo di tre cifre assegnato ad ogni azienda al momento della sua creazione, vedi Gestione database aziende)

E' utile, ad esempio, ad un'azienda che emetta fatture e registri gli incassi, per passare al consulente, periodicamente, le registrazioni fatte in modo tale che quest'ultimo non le debba digitare di nuovo e possa completarle e stampare i bollati.

Lo scarico si può fare per i movimenti di un determinato anno contabile e fino ad una certa data di registrazione oppure scegliendo un intervallo di registrazioni per numero o per data. In questo caso l'operatore dovrà fare attenzione a scaricare esattamente le registrazioni desiderate.

E' possibile eseguire una seconda estrazione di un gruppo di registrazioni scegliendole in un intervallo di numero o data registrazione.

Mentre esegue lo scarico delle registrazioni, il programma prepara anche un altro file .txt (stesso nome del precedente+Tab) che contiene tutte le anagrafiche che via via incontra sui movimenti: clienti, fornitori, conti, causali, condizioni di pagamento, banche etc..
Il caricamento dei movimenti, come prima operazione, farà la creazione, sul database di destinazione, degli eventuali codici mancanti leggendoli dal suddetto file.

Per quanto riguarda il tracciato della tabella generata si rimanda al paragrafo: Trasferimento dei movimenti di fattura su file


CARICAMENTO REGISTRAZIONE DA FILE PAGHE CSS

Percorso: Contabilità - Utilità - Trasferimenti

Questo programma consente di generare in automatico la registrazione degli stipendi.

I dati vengono letti da un file di testo opportunamente compilato.
La registrazione viene generata sui Movimenti di Appoggio di prima nota, possono essere trasferiti immediatamente sulla prima nota definitiva oppure controllati e trasferiti successivamente.

Descrizione campo | Tipo | Lungh. | Nota
Codice azienda | N | 3 | CCC Es. 001
Anno di elaborazione | N | 4 | AAAA
Mese di elaborazione | N | 2 | MM
Data registrazione | A | 8 | ggmmaaaa
Descrizione | A | 22 | fisso: "REGISTRAZIONE STIPENDI"
Numero registrazione | N | 8 | fisso: 00000001
Codice causale | A | 2 | CC
Codice contropartita | A | 8 | xx-yy-zzzz
Dare/avere | A | 1 | D o A
Importo | N | 9+2 | 99999999999
Descrizione tabella riepilogo | A | 30 |
Codice CDC | A | 6 |


DATI INIZIALI IVA

Percorso: Contabilità - Iva - Gestioni

Questa tabella consente di definire per ogni anno solare, i dati caratteristici per quanto riguarda il regime I.V.A. Se la ditta gestisce più attività, andrà specificata, oltre l'anno, anche l'attività, viceversa il programma presenta l'attività '.' generica.

Tipo Liquidazione
Indica la periodicità della dichiarazione iva dell'azienda: Mensile o Trimestrale

Credito di inizio anno
è il credito iva con cui si è chiuso l'anno precedente da riportare ad anno nuovo.

Debito di inizio anno
E' il debito con cui si è chiuso l'anno precedente (solo descrittivo)

Data inizio e fine regime iva per cassa
Nel caso la ditta abbia optato per il regime dell'Iva per Cassa , indicando in Parametri e Utilità - Dati Generali azienda (parametri) - parametri di Contabilità che dipende dall'attività dovrà essere impostata, per ogni attività, la data in cui si inizia ad applicare il regime in oggetto.
La data di fine è anch'essa obbligatoria e se è sconosciuta dovrà essere impostata a 31/12/9999.

Data ultimo aggiornamento iva
E' la data dell'ultimo aggiornamento iva eseguito.

Data ultimo aggiornamento iva per cassa
E' la data dell'ultimo aggiornamento iva per cassa eseguito.

Data ultima chiusura Iva e Ultimo periodo elaborato in chiusura iva

Gestione Art.74 (Agenzie di Viaggio)
Se la ditta è un'agenzia di viaggio verrà attivata la gestione dell'esenzione per Art.74 Ter in sede di Chiusura dell'iva. In questo caso occorre compilare i dati aggiuntivi per le agenzie di viaggio.

Credito di costo di inizio anno
E' l'eventuale credito iniziale da stampare nella chiusura iva art.74Ter
Va inserito manualmente il primo anno poi viene aggiornato automaticamente dalla chiusura annuale.

Ultimo periodo elaborato
Ultimo periodo per il quale è stata fatta la chiusura Art.74 Ter

Regime del margine - Credito iniziale
Contiene l'eventuale credito di inizio anno derivato dal calcolo dell'iva del margine dell'anno precedente (Regime del margine).

Percentuale interessi per Iva trimestrale
Percentuale degli interessi da applicare in fase di Chiusura dell'iva, per le ditte trimestrali, in caso di debito.

Percentuale detraibilità iva acquisti
E' la percentuale che individua la parte di iva acquisti che si può detrarre in fase di Chiusura Iva. Il valore normale è 100 ma può essere anche inferiore in caso di PRORATA.

Percentuale detraibilità iva acquisti annuale
E' la percentuale che individua la parte di iva acquisti che si può detrarre in fase di Chiusura Iva annuale. Se viene lasciata bianca, verrà utilizzata la percentuale scritta nel campo precedente.

NOTA: entrambe queste percentuali sono ripetute in Gestione prefissi e numeratori documenti, per ogni prefisso acquisti utilizzato, per consentire di poter avere un registro acquisti la cui iva è completamente detraibile e un altro con prorata. In fase di stampa chiusura iva, verranno considerate prioritarie le eventuali percentuali presenti in 'prefissi e numeratori' , altrimenti si prendono quelle impostate qui.

Percentuale recupero iva vendite
Interessa le ditte a regime forfettario e indica la percentuale di riduzione dell'iva vendite.

Importo minimo per versamento iva
Indica l'importo minimo al di sotto del quale l'iva del periodo, anche se a debito, non va versata.

Gestione Plafond
Indica se la ditta può avvalersi della facoltà di effettuare acquisti o importazioni senza l'applicazione dell'iva.

In caso affermativo occorre impostare a SI, all'interno del codice iva che individua l'esenzione con la quale si registreranno gli acquisti, il segnale che riguarda il Plafond e compilare gli importi del Plafond da utilizzare. In questo modo in fase di registrazione di fatture di acquisto da Prima Nota verrà controllato che non si superi il plafond.


CARATTERISTICHE ESERCIZIO DI CONTABILITA'

Percorso: Contabilità - Servizio - Gestioni

Il programma consente di gestire, anno per anno, alcuni numeratori e progressivi utilizzati dalla procedura di contabilità e alcune caratteristiche per la contabilità ha, nell'anno in quell'azienda.

In fase di apertura di un nuovo esercizio contabile, il programma provvederà a generare in automatico i dati del nuovo anno a partire da quelli dell'anno precedente e ad azzerare i progressivi.

Anno
È l'anno dell'esercizio contabile al quale si riferiscono le informazione successive.

Tipo
Indica il tipo di Contabilità adottata dall'azienda in oggetto: Generale, Semplificata, Forfetaria

Ultima riga stampata, progressivi dare e avere, data ultimo articolo stampato
Vengono aggiornati con la stampa in esecuzione del giornale bollato.

Numero ultima pagina di giornale stampata
Se si numerano le pagine di giornale durante l'utilizzo, in questo campo viene memorizzato l'ultimo numero utilizzato. (Vedi Libri contabili - numerazione pagine)

Numero ultima distinta creata
E' il progressivo delle distinte e viene incrementato ogni volta che si conferma una nuova distinta.


PLAFOND - TABELLA

Percorso: Contabilità - Iva - Gestioni

Se la ditta può avvalersi della facoltà di effettuare acquisti o importazioni senza l'applicazione dell'iva dovrà compilare questa tabella.

Essa contiene per ogni anno, attività e periodo iva, l'importo del plafond da utilizzare e quello già utilizzato. Potrà essere compilata per un unico periodo (plafond annuale) mettendo 0 (zero) in codice periodo, per 4 periodi (trimestrale) o per 12 periodi (mensile).

Nel caso, più comune che la ditta abbia un'unica attività iva, il codice attività verrà impostato uguale a '.' (punto).

Viene gestita inoltre una percentuale utilizzata dalla prima nota per stabilire quando dare il messaggio di plafond esaurito.

La gestione del plafond consente di totalizzare gli acquisti effettuati in esenzione di imposta e di gestirne il raggiungimento dell'importo del plafond.

Per attivare la Gestione del Plafond occorre:

  • nel menu IVA -Dati iniziali iva: impostare a Si il flag di Gestione Plafond
  • inserire nei codici iva opportuni (gli esenti utilizzati nel caricare le fatture d'acquisto in esenzione) il flag di aggiornamento plafond
  • compilare con gli importi dovuti la tabella Plafond dell'anno interessato (dal menu Contabilità - Iva)

La gestione del Plafond comporta:

  • Prima Nota
    quando si inserisce una fattura di acquisto utilizzando un codice iva con flag di aggiornamento plafond verrà dato un messaggio se si sta superando (o se ci si sta avvicinando troppo) il massimo del plafond utilizzabile nel periodo (impostato in tabella Plafond)
    Il periodo è individuato dalla data registrazione ma è attivabile un flag nella tabella di personalizzazione per cui lo si può legare alla data documento: PlafPeriodoDa=D.
  • Aggiornamento iva
    aggiornerà, di periodo in periodo, il plafond utilizzato.
  • Chiusura iva
    evidenzierà il Plafond disponibile: cioè quello di inizio anno/periodo (letto in tabella) decrementato degli importi utilizzati nei periodi precedenti
    Utilizzo plafond: l'importo utilizzato nel periodo di liquidazione
    Residuo Plafond: la differenza tra i due importi precedenti e quello rimanente.
  • Stampa del registro iva acquisti
    riporterà un (*) in corrispondenza alla colonna PL in corrispondenza alle righe delle fatture con codici iva riferiti al plafond


CALCOLO DATI PER COMUNICAZIONE IVA ANNUALE

Percorso: Contabilità - Iva - Gestioni

Il programma prepara i dati per la gestione e la stampa della Comunicazione iva annuale.

Se una ditta ha più attività verrà comunque prodotta una dichiarazione annuale unica.

Per ottenere un risultato corretto, è indispensabile aver eseguito, anche solo in prova, tutte le chiusure iva (liquidazioni) periodiche in quanto alcuni importi vengono calcolati sommando i risultati delle varie chiusure periodiche.
(tali importi sono evidenziati con ** nella tabella che segue).
Gli altri importi vengono invece calcolati direttamente dai progressivi iva. Se non è stato fatto l'aggiornamento iva per tutto l'anno, il programma simulerà l'aggiornamento per cui il risultato sarà ugualmente corretto (Fare attenzione alla correttezza dei flag sui codici iva: "Tipo iva", "Comunicazione annuale: op.attive/passive", "Cessioni intra cee", "servizi cee" e "Acquisti e Cessioni Beni strumentali").

N.B. Poichè il calcolo degli importi suddetti dipende dalle impostazioni delle caratteristiche delle causali e dei codici iva delle registrazioni, può rendersi necessario, modificare tali impostazioni quando siano già state fatte delle liquidazioni. Al fine di ripetere il calcolo su tutte le registrazioni dell'anno (anche se già aggiornate) con le caratteristiche 'corrette e attuali' di causali e codici iva, è stata predisposta una scelta apposita sul programma di Chiusura Iva: 'Ricalcolo annuale'.
Tale funzione dovrà essere eseguita prima del Calcolo dati per Comunicazione Annuale e richiede che siano state fatte, almeno in prova, le Liquidazioni di tutti i periodi dell'anno in esame.
(Es. se su una causale 'autofattura' non era stato settato in precedenza il flag 'autofattura', lo si può fare in qualsiasi momento dell'anno e, alla fine, eseguendo questo ricalcolo, gli importi delle autofatture non verranno sommati nelle operazioni attive, come richiesto).

Per Beni strumentali vedi parametro IvaBeniStrum

Importo | Modalità di calcolo
CD1 - Totale delle operazioni attive (**) | Imponibili vendite e corrispettivi + importi esenti/non imponibili delle vendite e corrispettivi sul cui codice iva è stato impostato che va sommato in "Comunicazione annuale: op.attive/passive" (Si escludono i codici iva che abbiano i campi Cessioni intra cee e servizi cee a Si) + imponibile iva sospesa vendite Non si sommano gli importi Reverse Charge, quelli delle autofatture, quelli delle fatture registrate a fronte di acquisti intra cee, quelli relativi a incassi iva sospesa.
di cui non imponibili | Si sommano gli imponibili, vendite e corrispettivi, relativi ai codici iva con Tipo iva: 'non imponibile' e sui quali è stato impostato a Si il campo "Comunicazione annuale: op.attive/passive" Si escludono i codici che abbiano i campi Cessioni intra cee e servizi cee a Si.
di cui operazioni esenti | Si sommano gli imponibili (vendite e corrispettivi) relativi ai codici iva con Tipo iva: 'esente' e sui quali è stato impostato a Si il campo "Comunicazione annuale: op.attive/passive". Si escludono i codici che abbiano i campi Cessioni intra cee e Servizi cee a Si.
di cui cessioni intracomunitarie di beni (**) | Importi di registrazioni fatte con codice iva con campo: Cessioni intra cee posto a Si
CD2 - Totale delle operazioni passive (**) | Imponibili acquisti (anche regime del margine) + importi acquisti esenti/non imponibili sul cui codice iva è stato impostato che va sommato in "Comunicazione annuale: op.attive/passive". (Si escudono i codici iva che abbiano i campi servizi cee a Si) + imponibile cee acquisti + imponibile iva sospesa acquisti + imponibile iva non detraibile acquisti + imponibili Reverse Charge, NoCee e RSM Non si sommano i movimenti dei pagamenti iva sospesa.
di cui non imponibili | Si sommano gli imponibili,acquisti, relativi ai codici iva con Tipo iva: 'non imponibile' e sui quali è stato impostato a Si il campo "Comunicazione annuale: op.attive/passive" Si escludono i codici che abbiano i campi Cessioni intra cee e Servizi cee a Si.
di cui acquisti esenti | Si sommano gli imponibili (acquisti) relativi ai codici iva con Tipo iva: 'esente' e sui quali è stato impostato a Si il campo "Comunicazione annuale: op.attive/passive". (Si escludono i codici che abbiano i campi Cessioni intra cee e Servizi cee a Si)
di cui acquisti intracomunitari di beni (**) | Importi di registrazioni di acquisti intra cee (fatte con con causali col flag Acq. intra cee posto a Si)
di cui Cessioni/acquisti Beni strumentali | Si sommano gli imponibili (di vendite/corrispettivi o acquisti) in corrispondenza ai codici iva nei quali è stato spuntato il campo: "Acquisti e Cessioni Beni strumentali" E' tuttavia possibile attivare il parametro di personalizzazione: Iva BeniStrum in modo da ottenere questo valore utilizzando gli importi delle registrazioni fatte su determinati conti nei quali è stato spuntato il campo "Beni Strumentali" Acquisto o Cessione.

CD3
Oro industriale e argento puro
Rottami e altro materiale ... 		Da inserire manualmente con il programma di gestione Comunicazione annuale dati iva.

CD4 Iva esigibile | Somma dell'iva a debito (vendite e corrispettivi) dei vari periodi
CD5 Iva detratta | Somma dell'iva a credito (acquisti) dei vari periodi
CD6 Iva Dovuta (o a Credito) | Calcolato: CD4 - CD5

Se l'azienda ha dei corrispettivi da ventilare, in fase di chiusura annuale viene rifatta la ventilazione del totale incassi da ventilare anno, sulla base di ventilazione annuale, questo porta a importi diversi degli incassi ventilati, rispetto quelli calcolati nell'ultimo mese o trimestre. Inoltre dopo la preparazione dei dati per la comunicazione iva annuale, non rifacendo essa la ventilazione ma sommando tutti i dati periodici, si riscontrava una differenza tra l'iva esigibile della chiusura anno e quella della comunicazione, differenza dovuta al modo diverso di fare i calcoli, differenza che si ripercuote anche nelle operazioni attive.

Per eliminare questo problema, in fase di chiusura iva annuale di una ditta con una sola attività e con ventilazione, viene memorizzato un record con periodo di comodo (98) sulla tabella IvaDichPeriod con i dati della chiusura in modo che il calcolo della Comunicazione iva possa leggere da lì i due importi suddetti invece di ricalcolarli.


COMUNICAZIONE IVA ANNUALE

Percorso: Contabilità - Iva - Gestioni - Comunicazione annuale dati iva

La funzione consente di gestire i dati, calcolati dalla funzione Calcolo dati per comunicazione IVA annuale, che dovranno poi essere stampati ed inviati per via telematica.

E' indispensabile compilare il codice attività (Tab. Ateco) in tabelle Contabilità: Gestione attività (il campo da impostare è quello dopo la descrizione).

I dati anagrafici da riportare sulla comunicazione annuale iva vanno inseriti con le voci di menu:
Dati per comunicazione annuale iva e Dati generali per iva annuale.

Perché i dati calcolati siano corretti, è indispensabile aver aggiornato tutti i movimenti iva dell'anno ed aver eseguito, anche solo in prova, tutte le chiusure iva dei vari periodi.

Perché la dichiarazione della ditta richiesta venga scritta sul file, occorre che sia impostato a SI il campo 'DA trasmettere per invio telematico' gestito nella maschera: (2) Dati per invio telematico


STAMPA COMUNICAZIONE IVA ANNUALE

Percorso: Contabilità - Iva - Stampe - Comunicazione annuale dati iva

Il programma consente la stampa della Comunicazione Annuale IVA su modulo ministeriale prefincato (stampante a modulo continuo) o su foglio singolo (stampati a getto d'inchiostro o laser).

Prima della stampa occorre aver eseguito il programma di calcolo dati per Comunicazione annuale iva che prepara i dati.

Per ottenere, dal calcolo, un risultato corretto, è indispensabile aver aggiornato tutti i movimenti iva dell'anno ed aver eseguito, anche solo in prova, tutte le chiusure iva dei vari periodi.

Occorre inoltre aver controllato tutti i dati con la Gestione comunicazione annuale iva e con la gestione delle tabelle:

Dati per comunicazioni telematiche (intermediario) (Tabella unica per tutte le ditte da compilare una tantum)

Dati per comunicazioni telematiche (ditta) (da compilare una tantum)

Se NON si utilizza una stampante ad aghi, è possibile stampare, dopo la Comunicazione, una lettera con un testo precedentemente scritto e memorizzato nell'apposito spazio sulla maschera (Es. Lettera di impegno alla presentazione telematica).
Nella lettera, oltre a parti di testo "fisso", possono essere inserite parti variabili, identificate da: <$nome_var$>
Dove Nome_var può essere:
Intermediario, CFiscIntermediario: Intermediario e suo codice fiscale
Dichiarante, PIvaDich, CFiscDich: Dichiarante, cod.fiscale e partita iva
DtRagSoc: Ragione sociale ditta
IndirLegale, CapLegale, LocalitaLegale: Indirizzo legale ditta
IndirOp, CapOp, LocalitaOp, PrOp: Indirizzo operativo ditta
DtPartIva, DtCodFisc: Partita Iva e Cod.Fiscale ditta
DtTelefono, DtFax, RegImprese, NumRegImp
Data: Data inserita a video

Per quanto riguarda il font da utilizzare e i comandi particolari (grassetto, sottolineato etc.) si rimanda al capitolo: Font personalizzati


IVA ANNUALE - PREP. FILE PER INVIO TELEMATICO

Percorso: Contabilità - Iva - File per invio telematico

Il programma consente di preparare un file ascii contenente una o più COMUNICAZIONI IVA ANNUALI da trasmettere per via telematica.

Il tracciato del file rispetta le caratteristiche tecniche fornite dal ministero.

Il programma propone destinazione e nome del file generato (IVATELAN.TXT) e si consente all'operatore di variarli.

Prima di eseguire questo programma accertarsi di aver compilato, con le apposite gestioni:

  • Il codice attività (Tab. Ateco) in tabelle Contabilità: Gestione attività (il campo da impostare è quello dopo la descrizione)
  • L'anagrafica ditta sulla tabella Ditta (Parametri e Utilità - Dati Generali Azienda - parametri)
    Ragione Sociale - Partita Iva e Codice Fiscale, indicatore di Persona Fisica/Giuridica e, se fisica, il campo Cognome e Nome e i dati di nascita
    N.B. Al fine di separare il Cognome dal Nome: se c'è un unico spazio bianco si può semplicemente scrivere Cognome Nome (es. Rossi Mario), se invece c' è un cognome o un nome composto occorre separare il cognome dal noe con il carattere - (meno) o _ (underline)
    (Es. Ricci Bitti-Mario)
    Se i dati anagrafici del contribuente sono diversi dai dati ditta, questi dovranno essere scritti in Dati per Comunicazioni Telematiche (ditta) nella zona Dati del Contribuente, compilati con lo stesso criterio descritto sopra
  • I dati dell' eventuale Dichiarante: Codice fiscale (o Partita Iva se società) e Codice Carica in Dati per Comunicazioni Telematiche (ditta) nella zona Dati del Dichiarante
  • il Tipo Fornitore: 01 Soggetti che inviano le proprie dichiarazioni - 10 CAF / Intermediari in Dati per comunicazioni telematiche (ditta)
  • I dati dell' intermediario (se esiste) in Dati per comunicazioni telematiche (intermediario) (Tabella unica per tutte le ditte, da compilare una tantum)
    Codice Fiscale , Numero di iscrizione la CAF (in caso di CAF)
    Il codice fiscale dell' intermediario va messo anche nel campo 'Codice Fiscale fornitore' nella maschera 'Dati per invio telematico'

e di aver fatto il Calcolo dati per comunicazione annuale Iva che prepara gli importi da trasmettere.

In particolare perché la dichiarazione della ditta richiesta venga scritta sul file, occorre che sia impostato a SI il campo 'DA trasmettere per invio telematico' gestito con la Gestione Comunicazione annuale dati Iva nella maschera: (2) Dati per invio telematico

L'identificazione delle ditte per le quali trasmettere la dichiarazione avviene tramite il codice Identificativo ditta (numero progressivo che viene inserito al momento della creazione di una nuova ditta: Gestione database aziende)

Comunicazione inviata da intermediario
Questo campo viene automaticamente impostato a Si o a No a seconda che sia valorizzato o meno il campo 'Codice Fiscale fornitore' nella maschera 'Dati per invio telematico' della Tabella unica per tutte le ditte 'Dati per comunicazioni telematiche (intermediario)' e può essere variato dall'utente.

  • Si
    Nel file preparato, i dati del record A (record di testa) saranno quelli dell’intermediario per cui verranno letti dalla tabella gestita da “Dati per comunicazione annuale iva” (tabella comune a tutte le ditte) In particolare: Codice fiscale del fornitore, Tipo Fornitore
  • No
    Nel record A (record di testa) verrà riportato il Codice fiscale del contribuente, letto dalla tabella dei Dati generali per iva annuale, se presente, o dai dati anagrafici ditta.
    In questo caso non dovrà essere compilato il "codice fiscale del fornitore" di cui sopra e sarà possibile elaborare una ditta per volta.

Se a preparare e spedire il file non è un intermediario ma la ditta stessa, questo campo dovrà essere impostato a No.
E’ possibile creare, nei parametri di personalizzazione, il parametro Intermediario per impostare automaticamente "No intermediario" al caricamento della maschera.

Se l'elaborazione è fatta da un intermediario, per ogni ditta si deve scrivere sul file il codice fiscale dell'intermediario e i dati dell'impegno.
Il codice fiscale dell'intermediario va compilato sulla tabella Dati per comunicazioni telematiche (intermediario) una volta per tutte le ditte mentre i campi: Impegno a trasmettere ... e data dell'impegno, possono essere compilati sulla singola ditta (Dati per Comunicazioni Telematiche (ditta) oppure, se lì sono lasciati bianchi, verranno letti dalla tabella di cui sopra.

Prova - Esecuzione: l'esecuzione comporta l'impostazione a No del flag 'da trasmettere' (di cui sopra).

Al termine dell'elaborazione viene prodotta, se l'operatore lo vuole, una stampa con l'elenco delle ditte per le quali sono stati scaricati i dati da trasmettere.


OPERAZIONI RILEVANTI AI FINI IVA (Ante 2012)

Con provvedimento prot. n. 2010/184182 del 22/10/2010 L'Agenzia delle Entrate ha stabilito le modalità e i termini di presentazione della comunicazione telematica delle operazioni rilevanti ai fini IVA di importo non inferiore a 3000,00 €, introdotta dall'art. 21 del DL n. 78/2010 e convertito nella legge n. 122/2010.

Relativamente all'anno di imposta 2011 dovranno essere comunicate le operazioni di importo non inferiore a 3.000€ e rimarranno escluse le operazioni non soggette a fatturazione effettuate solo fino al 30 giugno (importo di riferimento 3.600€).
Il limite si determina sul totale della fattura depurato solo delle anticipazioni e delle spese di cui all'art.15 del dpr 633/1972 e di tutto ciò che è fuori campo iva.

Al fine di recepire il Comunicato dell'Agenzia delle Entrate del 5/4/2012 nel quale si dice che 'si consente l'invio di operazioni anche di importo inferiore alla soglia stabilita' per semplificare in attesa delle nuove norme per il prossimo anno, è possibile impostare a 0 'l'importo di riferimento delle operazioni con fattura' in fase di estrazione dati, in modo l'estrazione verrà fatta come se su tutte le anagrafiche ci fosse l'obbligo di trasmettere tutte le operazioni.

Non devono essere trasmesse:

  • importazioni
  • esportazioni soggette all'obbligo della bolla doganale
  • operazioni con soggetti Black List
  • operazioni effettuate e ricevute in ambito comunitario (intra cee)
  • operazioni già comunicate all'Agenzia tributaria (contratti di assicurazione, di fornitura di energia elettrica etc.)
  • operazioni effettuate nei confronti di privati se il pagamento è avvenuto con carta di credito o prepagate

I valori di confronto vengono letti dalla tabella di contabilità.
Se là mancano si assume 3.000€ per le operazioni fatte con fattura e 3.600€ per quelle fatte con Scontrino, Ric.Fiscale, Fattura Dettaglianti che verranno però considerate solo dal 1' luglio.
Se la ditta non ha l'obbligo di fatturazione (sempre o solo per una delle sue attività), per i documenti relativi a tale attività verrà fatto il confronto con 3600 € sempre.

L'estrazione verrà fatta dalla funzione 'Preparazione file Operazioni Rilevanti ai fini Iva'

Al fine di consentire una forzatura in modo che una registrazione venga comunicata anche se apparentemente non ci sono le condizioni o viceversa, venga esclusa pur avendo le condizioni per essere comunicata, è stato inserito, nella maschera della PrimaNota, il campo 'Operazione rilevante ai fini iva' in ogni registrazione di fatture (emesse e ricevute), di note di credito e di corrispettivi intestati ad un codice cliente (diverso dal cliente corrispettivi dichiarato in tabella dei conti comuni).

Per una corretta preparazione dei dati occorre:

  • Impostare gli importi di riferimento nella tabella di contabilità (Dati generali azienda - parametri).
  • Se la ditta ha un'attività che non ha l'obbligo di fatturazione, impostare a N il campo corrispondente in Gestione Attività (Archivi Comuni- tabelle di Contabilità)
  • Se sono state fatte registrazioni con iva non esposta in fattura (es. art74), è' possibile abilitare il parametro di personalizzazione EsclIvaNoEsp .
    Se impostato a S le registrazioni con iva non esposta in fattura (es. art74) verranno scartate fino al 30 giugno 2011 altrimenti verranno considerate e confrontate con 3600 invece di 3000.
  • Impostare correttamente la Partita iva e il Codice fiscale sui clienti/fornitori.
    Nella maschera 'Contabilità' dei clienti/fornitori, è stato inserito il campo: Operaz. rilevanti ai fini Iva' che consente di indicare casi particolari (da considerare sempre o mai).
    In generale questo campo assume il valore di 'Normale', ad indicare che le fatture del cliente vanno considerate o meno a seconda delle clausole generali.
    Dati anagrafici da compilare attentamente
    • Codice Fiscale
    • Partita Iva
    • Codice cointestatari (se si emettono fatture con più cointestatari)

    Per ogni documento trasmesso verrà infatti comunicata la Partita Iva o il Codice Fiscale del cliente/fornitore a seconda che il soggetto sia o meno titolare di Partita Iva.
    E' possibile abilitare il parametro di personalizzazione NoIvaNoFat per modificare la selezione dei soggetti le cui fatture vanno comunicate:
    Se impostato a S il programma considera senza obbligo di fattura i clienti/fornitori che non hanno partita iva, compresi i codici fiscali che iniziano per 8 e per 9
    Se impostato a V considera senza obbligo di fattura SOLO quelli con partita iva vuota.

    In caso di Soggetti Non Residenti invece, si chiede di comunicare anche i dati anagrafici:

    • Nome e Cognome e dati di nascita se persona fisica
    • Ragione sociale, verranno presi i campi Ragione sociale 1 e 2, se compilate oppure la Ragione sociale contabile, se persona giuridica.
    • Occorre compilare SEMPRE lo stato di Nascita o di Domicilio, (nella tabella Stati, questo dovrà avere il codice stato da Tabella Generale compilato)
    • Se "società, assicurazioni o altre organizzazioni senza personalità giuridica": vengono richiesti anche cognome, nome, dati di nascita di una delle persone che ne hanno la rappresentanza.
      Il programma, in presenza di un soggetto estero, compilerà questi dati se:
      - è impostato come 'persona fisica'
      - è stato compilato il campo 'Persona di riferimento' con Cognome-Nome
      - sono stati compilati i dati di nascita.
  • Clienti Cointestatari
    Se viene emessa una fattura che abbia le caratteristiche per essere trasmessa, a più intestatari, vanno trasmessi i dati di tutti gli intestatari per cui occorre collegare il cliente 'principale' della fattura ai cointestatari che quindi vanno creati nella tabella dei clienti.
  • Causali di contabilità
    Predisporre causali apposite per le note di variazione (note di credito e fatture che andranno rettificarne una precedente) , spuntando il campo 'nota di variazione'.
    Il programma di aggiornamento dei database (che viene eseguito all'installazione della versione 3.03) imposterà già questo campo a SI nelle causali Nota di Credito.
  • Codici iva - Su ogni codice iva è indispensabile compilare correttamente, oltre al campo Tipo Iva, il campo 'Codice che va in elenco'
    Nei codici utilizzati per l'emissione e il ricevimento di documenti con art.74 Ter (Agenzie di viaggio) dovrà essere impostato a Si il campo Iva non esposta in fattura in modo che nell'estrazione delle Op.Ril.ai fini IVA il programma confronti l'importo con il limite utilizzato per le operazioni (3600€)
    E' possibile, a tal proposito, abilitare il parametro di personalizzazione EsclIvaNoEsp
    Se impostato a S le registrazioni con iva non esposta in fattura (es. art74) verranno scartate fino al 30 giugno 2011.
  • Tipo di pagamento
    Al fine di individuare le fatture pagate/incassate con modalità di pagamento che ne escludono l'invio telematico ('carta di credito' etc.) è stato inserito, sul tipo pagamento, il campo 'Escluso da comunicazione Op.Rilev.ai fini Iva'. E' necessario perciò inserire sulle registrazioni delle fatture incassate/pagate in questi modi, una Condizione di pagamento collegata a un Tipo 'da escludere'.
  • Contratti
    E' stata predisposta una tabella contratti per poter legare un gruppo di fatture relative allo stesso contratto al fine di calcolare l'importo totale e stabilire se vanno trasmesse o meno.
    Le fatture alle quali è stato associato lo stesso contratto verranno considerate come specificato sul contratto.

REGISTRAZIONI DI PRIMA NOTA (Inserimento fatture)

  • Corrispettivi/Ric.Fiscali
    Per le vendite fatte a privati, senza fattura, al fine di poter trasmettere la transazione se ne ha i requisiti, occorre creare il cliente in tabella con tutti i dati anagrafici e registrare il corrispettivo inserendo il cliente particolare in Partita al posto del 'Cliente corrispettivo' generico o della Cassa. Dovrà poi seguire la registrazione dell'incasso.
  • Fatture dettaglianti
  • Nell'inserimento delle Note di variazione ricordare di mettere sempre il numero e la data della fattura a cui la nota si riferisce (sia quando si inserisce da Prima Nota che da Vendite)
    A tal proposito è possibile impostare alcuni parametri di personalizzazione che intervengono nei controlli: NotaVarDataObblig , NotaVarVerEsiste , CopiaOrigInDoc
  • Per le fatture che si riferiscono a un contratto, occorre creare il contratto e inserire il codice sulla registrazione (in Prima Nota o in emissione fatture).
  • Fatture ricevute in Reverse Charge
    L'imposta non viene considerata in quanto viene rilevata solo da chi la riceve ma sulla fattura non compare.
  • Importo Frazionato
    Una delle informazioni che viene chiesta nel file da trasmettere è se si tratta di importo NON frazionato, frazionato o Corrispettivo periodico.
    Ogni documento viene considerato come Importo non frazionato. Per poter trasmettere una fattura o un corrispettivo come importo frazionato, occorre legarli ad un contratto, sul quale si dirà: importo frazionato.
    Tuttavia, se sul cliente/fornitore si mette il segnale di Obbligo trasmettere tutte le fatture e ci sono fatture inferiore al limite, queste verranno trasmesse col flag 'Importo frazionato'. L'alternativa è quella di modificare manualmente con l'Elenco operazioni rilevanti ai fini Iva la/le riga generata.

SISTEMAZIONE DOCUMENTI GIA' REGISTRATI IN PRIMA NOTA
 al momento dell'installazione della Versione 3.03
Vedi Note di Release 3.03

Sequenza operazioni da eseguire per la preparazione del file da inviare telematicamente:

  • Controllare che i dati inseriti siano conformi a quanto elencato sopra
  • Verifica Operazioni Rilevanti ai fini Iva per controllo (Contabilità - Utilità)
  • Estrazione delle operazioni da comunicare
  • Elenco delle operazioni estratte per eventuali variazioni
  • Preparazione del file per l'invio telematico


VERIFICA OPERAZIONI RILEVANTI AI FINI IVA (Pre 2012)

Percorso: Contabilità - Utilità

(Funzione in uso per comunicazioni precedenti al 2012)
Il programma consente di visualizzare un elenco delle Fatture/Note Var. emesse e ricevute e dei Corrispettivi registrati con un codice cliente non generico, al fine di poter controllare le registrazioni prima della preparazione della Comunicazione delle 'Operazioni rilevante ai fini iva'
Per il 2011 i valori di riferimento saranno rispettivamente 3000 e 3600 e sarà il programma ad escludere, per i primi 6 mesi, le operazioni fatte con Scontrino, Ric.Fiscale (registrazioni con causale di tipo corrispettivo) e le Fatture dettaglianti.
A video viene comunque proposta una scelta che consente di includere, per verifica, anche queste ultime registrazioni.

Se si sceglie l'ordinamento per Ragione Sociale Cli/For verranno elencate le registrazioni in modo tale che ogni fattura sarà seguita dalla/e eventuali sue note di credito (note di variazione). In particolare verranno estratte 'tutte' le note di credito per valutare se manca l'indicazione della fattura di riferimento.

Ignora contratto per importo mostrato (impostato in automatico a Si):
Per le registrazioni legate da contratto, si può visualizzare l'importo totale contratto al posto dell'importo della singola registrazione, in ogni registrazione del contratto.
Questo comporta però un rallentamento del programma che, in presenza di tante registrazioni, diventa quasi un blocco. Per questo motivo, sulla maschera iniziale, viene esclusa questa opzione.

Non vengono visualizzati gli importi relativi a fatture o a righe di fatture in cui sul codice iva è stato impostato a No il campo 'Codice che va in Elenco Op.Ril.Iva'.

Una volta visualizzato un elenco di registrazioni, sarà possibile accedere al programma di prima nota tramite il pulsante [image] al fine di visualizzare/variare la registrazione su cui si è posizionati.
La variazione è possibile anche se questa è stata già stampata sui Registri Iva e/o Giornale. NON è invece possibile se l'anno contabile a cui si riferisce è già chiuso; in questo caso occorre riaprirlo momentaneamente utilizzando la funzione 'Chiusura (Apertura) anno precedente' da Contabilità - Annuali poi richiuderlo, al termine delle variazioni, con la stessa funzione.

In particolare sarà possibile variare i campi: codice contratto, campo 'Op.rilevante ai fini iva' , 'Pref-numero e data fattura di riferimento' , anche di registrazioni già stampate sul registro iva e/o sul giornale.

I campi visualizzati nella lista delle registrazioni sono:
Anno, numero e data registrazione
Ragione sociale cliente / fornitore
PIva S/N
Indica se il soggetto ha la Partita Iva o No (ha solo il codice fiscale)
Residente S/N
Indica se il soggetto è residente in Italia o No
Causale - Documento - Protocollo
Operazione Rilevante N/F/I
Indica se sulla registrazione è stato scritto che è da Ignorare oppure Forzata (da comunicare sempre) oppure Normale.
Importo movimento
L' importo visualizzato per ogni riga comprende o meno l'iva a seconda che si riferisca ad un cliente/fornitore con Partita Iva o no.
Codice e Tipo Contratto
N Non Estrarre S Sempre, T Totale calcolato nell'anno
Estremi della fattura di riferimento (per le note di variazione)
 Per le Note di credito dovrà essere impostato numero e data della fattura cui si riferiscono. In mancanza di una fattura ben precisa occorre lasciare vuoto il numero e impostare la data 31/12/2011
Tipo di registrazione
 Vendita - Acquisto - Corrispettivo

NOTA: Restano escluse dalla visualizzazione tutte le registrazioni escluse dalla Comunicazione:
quelle con causali di tipo 'Generico', 'Incasso e Pagamento Iva differita', Importazione NoCee, Intra Cee, Corrispettivi da ventilare, Reverse Charge (registrata con causale 'vendita', perchè si tratta della fattura 'fittizia' creata a fronte di un acquisto Reverse Charge), righe con codici iva 'Da non comunicare'.


ELENCO OPERAZIONI RILEVANTI AI FINI IVA (Pre 2012)

Percorso: Contabilità - Servizio

(Funzione in uso per comunicazioni precedenti al 2012)
Il dati presenti in questa tabella, divisi per anno, vengono generati dalla funzione: Estrazione dati Operazioni rilevanti ai fini Iva, possono tuttavia anche venire inseriti manualmente.
Le righe manuali, segnalate a video con un campo 'Manuale' spuntato, non verranno cancellate dalla rielaborazione dell'anno.

Le righe presenti in questa tabella, verranno trasferite, dalla funzione Preparazione file Operazioni rilevanti ai fini Iva, sul file per l'invio telematico.

Tipo Registrazione

  • Residenti NO P.Iva
  • Residenti con P.Iva
  • Non Residente
  • Nota di Variazione (Residenti)
  • Nota di Variazione (Non Resid.)

Data Operazione
E' la data documento o, in mancanza di questa, la data registrazione.

Contratto
Se più fatture fanno riferimento ad uno stesso contratto per cui vanno comunicate quando la somma dei loro importi supera il limite, potranno (dovranno) essere collegate tra loro dal codice contratto.

Dati per fatture/ricevute/corrispettivi

Numero fattura
E' il numero documento
Obbligatorio se Tipologia dell'operazione è Cessione e/o Prestazione e se il Cliente è titolare di partita iva

Importo dovuto / Imposta
Nel caso di soggetto NON titolare di Partita Iva l'importo è comprensivo dell'Iva

Modalità di Pagamento

  • Importo NON frazionato
  • Importo frazionato
    Ad esempio un acquisto di un bene il cui valore complessivo supera i 3.000,00 (3.600,00) € per il quale sono state emesse più fatture, eventualmente in più anni. Le singole fatture potranno essere anche inferiori ai 3.000,00 €.
  • Corrispettivo periodico
    Es. contratti di appalto, somministrazione e/o a corrispettivi periodici.

Tipo operazione
Dato obbligatorio

  • Cessione e/o Prestazione
  • Acquisto e/o Prestazione Ricevuta

Numero/anno di registrazione
Vengono visualizzati anno e numero di registrazione in Prima Nota della riga

Note di Variazione

Numero
Non obbligatorio

Imponibile / Imposta

Dati della fattura da rettificare:

Numero e data
Vengono letti dalla registrazione di prima nota, campi 'Fattura di Riferimento'
Numero - Non obbligatorio
Data - Obbligatoria. Se si ignora, inserire nel campo 31/12/Anno della nota

Variazione dell'imponibile a Credito o a debito
Variazione dell'imposta a Credito o a debito
Obbligatori. Indicare in riferimento al soggetto che comunica l'operazione


ESTRAZIONE OPERAZIONI RILEVANTI AI FINI IVA (Pre 2012)

Percorso: Contabilità - Servizio

(Funzione in uso per comunicazioni precedenti al 2012)
La funzione consente di preparare i dati per l'invio telematico delle Operazioni Rilevanti ai fini Iva. Verranno estratte le registrazioni 'rilevanti' dagli archivi di Prima Nota, scritte su una tabella di appoggio in modo da poterle controllare e gestire con l'apposita Gestione prima di eseguire la preparazione del file da inviare telematicamente.

Al fine di recepire il Comunicato dell'Agenzia delle Entrate del 5/4/2012 nel quale si dice che 'si consente l'invio di operazioni anche di importo inferiore alla soglia stabilita' per semplificare in attesa delle nuove norme per il prossimo anno, è possibile impostare a 0 'l'importo di riferimento delle operazioni con fattura'. In questo modo l'estrazione verrà fatta come se su tutte le anagrafiche ci fosse l'obbligo di trasmettere tutto.

Una opzione a video consente di includere SOLO le note di variazione dell'anno di elaborazione o anche quelle dell'anno successivo ma riferite all'anno di elaborazione.

Ogni volta che si esegue l'elaborazione di un anno, vengono cancellati tutti i dati relativi all'elaborazione precedente (dello stesso anno) mentre vengono lasciate eventuali righe inserite manualmente con la gestione.

L'estrazione presuppone che siano stati impostati correttamente i dati sulle anagrafiche e sulle registrazioni, come descritto in Comunicazione telematica delle operazioni rilevanti ai fini Iva

E' possibile abilitare due parametri di personalizzazione per modificare la selezione dei soggetti le cui fatture vanno comunicate:
EsclIvaNoEsp Se impostato a S le registrazioni con iva non esposta in fattura (es. art74) verranno scartate fino al 30 giugno 2011 altrimenti verranno considerate e confrontate con 3600 invece di 3000.
NoIvaNoFat Se impostato a S considera senza obbligo di fattura i clienti/fornitori che non hanno partita iva, compresi i codici fiscali che iniziano per 8 e per 9
Se impostato a V considera senza obbligo di fattura SOLO quelli con partita iva vuota.

Verranno estratte tutte le registrazioni, salvo quelle che non vanno comunicate, con importo maggiore del limite, a condizione che il cliente/fornitore e/o la registrazione di prima nota NON abbiano il flag 'da non comunicare'

Calcoli particolari:

Vengono escluse dall'estrazione tutte le registrazioni che hanno un Cli/For con 'da escludere' e/o quelle con 'da ignorare' sulla registrazione di prima nota.

Se una fattura è stata emessa a un cliente che ha compilato il campo 'codice cointestatari' ed è nelle condizioni di dover essere trasmessa, verranno trasmessi tutti i cointestatari della fattura, ciascuno con la sua parte (l'importo viene diviso per il numero dei cointestatari).

Corrispettivi: verranno esaminate quelle registrazioni che hanno un cliente in Partita al posto del 'Cliente corrispettivo' generico o della Cassa.

Fatture legate da contratto: seguono le caratteristiche del contratto. Se si inserisce una Nota di variazione positiva, riferita ad una fattura dell'anno precedente e legata ad un contratto sul quale si dice che va comunicato in base al totale dell'anno, il programma non è in grado di considerarla nel totale per cui, se è da considerare, andrà forzata inserendo nella registrazione: 'op. rilevante ai fini iva' Forzata.
Le fatture legate a un contratto, se da trasmettere, verranno trasmesse singolarmente.

Note di Variazione
Fattura e Note di Variazione riferite a quella fattura, emesse/ricevute nello stesso anno:
si calcola l'importo risultante e si estrae la fattura se tale importo supera il valore di confronto.

Vengono esaminate quelle con data registrazione maggiore dell'ultima data registrazione elaborata nell'estrazione dell'anno precedente (se non è stata fatta l'estrazione nell'anno precedente si considera il 31/12) e anno della data della fattura di origine.

Per quelle che si riferiscono a fatture non comunicate in precedenza si va a cercare, solo se sono note di variazione in positivo e non note di credito, la fattura corrispondente e, se questa era nelle condizioni di essere estratta, si sommano gli importi e si stabilisce se è da estrarre o no.
Se però ha il flag di 'forzata' verrà comunicata sempre.

Ogni documento viene considerato come Importo non frazionato. Per poter trasmettere una fattura dichiarata come importo frazionato, occorre legarla ad un contratto, sul quale si dirà: importo frazionato. L'alternativa è quella di modificare manualmente con l'Elenco operazioni rilevanti ai fini Iva la/le riga generata.


PREP.FILE TELEMATICO OPER.RILEVANTI AI FINI IVA (Pre 2012)

Percorso: Contabilità - Servizio

(Funzione in uso per comunicazioni precedenti al 2012)
La funzione consente di preparare il file per l'invio telematico e di stampare un elenco delle operazioni in esso inserito.
E' possibile preparare un unico file contenente l'invio dei dati di più ditte oppure file separati.
L'utente può scegliere la cartella in cui salvare il file generato.

All'interno del file gli importi vengono scritti allineati a sinistra con spazi (es. 3245), per averli allineati con zeri (es. 00003245) si deve attivare il parametro di personalizzazione: RiempiZeri
(La modifica si è resa necessaria in quanto alcuni software di controllo richiedono quest'ultimo formato mentre per l'Agenzia delle Entrate vanno bene entrambi)

Prima di procedere all'estrazione il programma controlla, per ogni azienda da elaborare, se ci sono, sulla tabella delle 'Operazioni Rilevanti ai fini Iva', righe di soggetti Residenti con e senza partita iva e non residenti con importi minori di 3.000,00 € (o 25.000) e campo 'Modalità di pagamento' diverso da Non frazionato e verrà data segnalazione (darebbero errore nella trasmissione).

Tipo invio
se si fa un invio sostitutivo o un annullamento è obbligatorio compilare i due campi Protocollo telematico e documento con due numeri rispettivamente di 17 e 6 cifre, le posizioni vuote non significative vanno compilate con 0 (es. 000125)

Invio fatto da intermediario: Se è stato compilato il codice fiscale dell'intermediario sulla tabella Dati per comunicazione annuale Iva, verrà abilitata e spuntata a video questa opzione. Servirà a compilare, sul file dei dati, i campi codice fiscale o partita iva dell'intermediario ed, eventualmente il Numero di iscrizione al CAF (Dati per comunicazione annuale iva )

Numero massimo di registrazione estratte per file
Si possono trasmettere file con un massimo di 15000 record (dimensione massima 3 MB). Al fine di predisporre il programma a distribuire i dati su due o più file, in caso di dimensioni eccessive, occorre digitare qui il numero di registrazioni da mettere in ogni file.

Per agevolare il controllo è possibile stampare ordinando per Ragione Sociale cli/for e documento (senza estrarre il file) in modo da poter confrontare quanto verrà inserito nella comunicazione con quanto visualizzato nella funzione di verifica.

L'estrazione presuppone che siano stati impostati correttamente i dati sulle anagrafiche e sulle registrazioni, come descritto in Comunicazione telematica delle operazioni rilevanti ai fini Iva

Inoltre occorre inserire, come descritto in seguito, tutti i dati anagrafici ditta, dichiarante, rappresentante etc.

  • Se l'elaborazione è fatta da un intermediario occorre compilare in Dati per comunicazione annuale iva (Tabella unica per tutte le ditte, da compilare una tantum)
    Partita Iva o cod. fiscale dell'Intermediario e Numero di iscrizione al CAF se esiste.
    Compilare inoltre, con la funzione “Dati generali per iva annuale/periodica” (menu contabilità - iva), nei dati 'Intermediario' la spunta sulla voce opportuna in 'Impegno a trasmettere ...' e la data dell'impegno (questi ultimi dati possono essere scritti una volta per tutte sulla tabella unica e lasciati bianchi qui).
  • Se i dati del contribuente sono diversi dai dati della ditta stessa, compilare, con la funzione “Dati generali per iva annuale/periodica” (menu contabilità - iva) i dati anagrafici del contribuente, altrimenti controllare che siano tutti compilati i dati nell'anagrafica ditta
    In caso di nascita all'estero nel campo Comune dovrà essere scritto lo Stato di nascita e in provincia EE

Calcoli particolari:

Vengono escluse dall'estrazione tutte le registrazioni che hanno un Cli/For con 'da escludere' e/o quelle con 'da ignorare' sulla registrazione di prima nota.

Note di Variazione
Fattura e Nota di Variazione (con riferimenti alla fattura) emesse/ricevute nello stesso anno:
viene estratta se l'importo risultante supera il valore di confronto.

Vengono esaminate quelle con data registrazione maggiore dell'ultima data registrazione elaborata nell'estrazione dell'anno precedente (se non è stata fatta l'estrazione nell'anno precedente si considera il 31/12) e anno della data della fattura di origine.

Per quelle che si riferiscono a fatture non comunicate in precedenza si va a cercare, solo se sono note di variazione in positivo e non note di credito, la fattura corrispondente e, se questa era nelle condizioni di essere estratta, si sommano gli importi e si stabilisce se è da estrarre o no.
Se però ha il flag di 'forzata' verrà comunicata sempre

IMPORTANTE: NON si dovranno inserire, in fatture di vendita, righe negative a storno di fatture emesse in precedenza (in particolare se l'importo di fattura+nota rientra in quelli da comunicare). Il programma di estrazione dati darà un messaggio se trova una riga negativa all' interno di una fattura per segnalare l'anomalia, l'utente valuterà se la registrazione è corretta o meno.

Spiegazione dei campi in stampa:

N = Numero progressivo

T = Tipo Anagrafica

  • 1 Residenti NO P.Iva
  • 2 Residenti con P.Iva
  • 3 Non Residente
  • 4 Nota di Variazione (Residenti)
  • 5 Nota di Variazione (Non Resid.)

P = Modalità di Pagamento

  • 1 Importo NON frazionato
  • 2 Importo frazionato
    Ad esempio un acquisto di un bene il cui valore complessivo supera i 3.000,00 (3.600,00) € per il quale sono state emesse più fatture, eventualmente in più anni. Le singole fatture potranno essere anche inferiori ai 3.000,00 €.
  • 3 Corrispettivo periodico
    Es. contratti di appalto, somministrazione e/o a corrispettivi periodici.

C/A = Tipo operazione

  • C Cessione e/o Prestazione
  • A Acquisto e/o Prestazione Ricevuta


SPESOMETRO - OPERAZIONI RILEVANTI AI FINI IVA (dal 2012)

N. B. Questa funzione è stata sostituita, dal 2017, dalla Comunicazione dati fatture

Con provvedimento 2013/94908 del 2 agosto 2013 è stato approvato il nuovo modello da utilizzare per la comunicazione delle operazioni rilevanti ai fini Iva (Spesometro) e nel mese di ottobre sono state comunicate sul sito dell’ Agenzia delle Entrate le specifiche tecniche per la preparazione del file da spedire.

All' indirizzo http://www.aziendapc.it/documenti e nella cartella \BaseDoc\Spesometro\ dell'area di installazione sono disponibili i file prelevati dal sito dell’Agenzia delle Entrate, contenenti istruzioni e tracciati.
Si consiglia vivamente di leggerli e far riferimento ad essi per comprendere meglio quanto esposto in seguito.

La funzione che consente di preparare il file da spedire è nel menu Contabilità - Iva - Spesometro

Operazioni incluse
A decorrere dal 1° gennaio 2012, per le operazioni per le quali viene rilasciata fattura occorre comunicare per ciascun cliente e fornitore tutte le operazioni effettuate, indipendentemente dall’importo (comprese quelle soggette al regime del reverse charge, rientranti nel regime del margine, autoconsumo)
Per le operazioni per le quali non è stata emessa fattura invece, rimane ferma la comunicazione delle singole operazioni di importo non inferiore a 3.600 euro al lordo dell’Iva se non sono state pagate con carta di credito o prepagate.
Devono essere incluse infine le operazioni legate al turismo effettuate in contanti in deroga alla normativa dell’antiriciclaggio.

Operazioni Escluse

  • Le importazioni
  • Le esportazioni di cui all’art. 8 co.1, lett. a) e b) del DPR n. 633/1972
    Resta fermo l’obbligo di comunicazione per le cessioni effettuate all’esportatore abituale, non imponibili Iva ai sensi dell’art.8, lett. c) del DPR n.633
  • Le operazioni effettuate e ricevute in ambito comunitario (intra cee)
    [Rimane l’obbligo di comunicazione invece per le cessioni interne dei beni nell’ambito delle triangolazioni comunitarie di cui all’art.58 del D.L. n.331/93]
  • Le operazioni già comunicate all'Agenzia tributaria (verificare per contratti di assicurazione, di fornitura di energia elettrica etc.)
  • Le operazioni effettuate nei confronti di privati, se inferiori a 3600 € e comunque se il pagamento è avvenuto con carta di credito o prepagate
  • Il nuovo modello, piuttosto complesso, è stato predisposto per comunicare, dal 2014, anche:
    - Gli acquisti da operatori di San Marino
    - Le operazioni con paesi in Black List
    che, nella comunicazione dello Spesometro vengono esclusi

La comunicazione può essere fatta in forma Aggregata (per ogni anagrafica viene comunicato il totale degli importi) oppure Analitica e prevede che le operazioni vengano raggruppate nei seguenti quadri a seconda delle loro caratteristiche.
Si consiglia di leggere attentamente l’ elenco che segue per capire se, in base al tipo di operazioni da comunicare, si sarà vincolati a scegliere la forma analitica piuttosto che quella aggregata e se si dovrà impostare qualche campo particolare su causali, codici iva, conti etc.

Elenco dei quadri della Comunicazione:

Frontespizio dove vanno indicati i dati del contribuente e le caratteristiche della comunicazione (tipo di invio, modalità di comunicazione dei dati, ecc.)

Quadri che dovranno contenere le operazioni da comunicare:

  • QUADRO FA - OPERAZIONI DOCUMENTATE DA FATTURA ESPOSTE IN FORMA AGGREGATA
    Operazioni attive e passive e Note di variazione. Importi totalizzati a parità di Partita Iva/Cod.Fiscale
    Ai fini dell’aggregazione, le note di variazione sono considerate documenti autonomi, da non sommare algebricamente all’operazione principale.
  • QUADRO SA - OPERAZIONI SENZA FATTURA ESPOSTE IN FORMA AGGREGATA
    (Corrispettivi di importo maggiore di 3600 € registrati come corrispettivo di un determinato cliente)
  • QUADRO BL - OPERAZIONI CON SOGGETTI AVENTI SEDE, RESIDENZA O DOMICILIO IN PAESI CON FISCALITÀ PRIVILEGIATA (Black List)
    Si tratta delle operazioni ‘Black List’ che per ora vengono trasmesse separatamente, quindi non faranno parte dello Spesometro 2012
    - OPERAZIONI CON SOGGETTI NON RESIDENTI IN FORMA AGGREGATA
    - ACQUISTI DI SERVIZI DA NON RESIDENTI IN FORMA AGGREGATA
    Se la ditta deve trasmettere operazioni dei due tipi suddetti, dovrà fare OBBLIGATORIAMENTE la comunicazione in forma aggregata
  • QUADRO FE - FATTURE EMESSE / DOCUMENTI RIEPILOGATIVI
    Dettaglio delle fatture emesse
    Poiché deve essere evidenziata la presenza di “IVA non esposta in fattura” (vendita beni usati con regime del margine o agenzie di viaggio), se si stanno trasmettendo fatture delle attività suddette, CONTROLLARE con la gestione dei codici iva che nel codice iva utilizzato sia stato spuntato il campo IVA non esposta in fattura
    In questo quadro è prevista l'eventuale segnalazione della casella 'Autofattura’ in caso di autofatture emesse in ottemperanza al disposto dell’articolo 17, secondo comma, del DPR n. 633 del 1972 a seguito di un acquisto da un soggetto non residente senza stabile organizzazione che non si sia identificato direttamente o non abbia nominato un rappresentante fiscale.
    La casella non deve essere selezionata per il caso di autofattura emessa per autoconsumo di beni, operazione che viene rappresentata con la semplice ripetizione della propria partita IVA.
  • QUADRO FR - FATTURE RICEVUTE / DOCUMENTI RIEPILOGATIVI
    Dettaglio delle fatture ricevute
    Vanno evidenziate con una spunta particolare le Autofatture registrate per :
    - operazioni rientranti nella fattispecie disciplinata dagli articoli 7-bis e 7-ter del dPR n. 633 del 1972 in mancanza degli elementi identificativi del fornitore non residente;
    – acquisto da un imprenditore agricolo esonerato ai sensi dell’articolo 34, comma 6, del dPR n. 633 del 1972, dall’emissione della fattura;
    – acquisto per il quale il cessionario o committente obbligato alla comunicazione, non avendo ricevuto la fattura da parte del fornitore o avendola ricevuta per un importo inferiore a quello reale, regolarizza con l’emissione di autofattura o di fattura integrativa e con il versamento della relativa imposta ai sensi dell’articolo 6, comma 8 del decreto legislativo n. 471 del 1997 e dell’articolo 46, comma 5 del DL n. 331 del 1993.

    Vanno evidenziate inoltre eventuali operazioni in reverse charge nelle ipotesi di cui all’articolo 17 quinto e sesto comma del DPR n. 633 del 1972 (acquisto di materiale d’oro e d’argento e le prestazioni di servizi rese nel settore edile da soggetti subappaltatori) e in quelle di cui all’articolo 74, commi 7 e 8 (acquisti di rottami e metalli non ferrosi) dello stesso decreto.
    In presenza di acquisti in Reverse Charge sia del tipo suddetto sia di altri tipi, occorre differenziare i primi impostando sul conto utilizzato nelle loro registrazioni il campo: ‘Segnalazione Reverse Charge’ a SI in Spesometro (gestione Conti) o, se le registrazioni sono state fatte con causali diverse, impostando sulla causale del primo tipo, il campo: ‘Segnalazione Reverse Charge’ a SI (gestione Causali)
  • QUADRO DF - OPERAZIONI SENZA EMISSIONE DELLA FATTURA
    Operazioni di importo superiore a 3.600 euro, senza emissione di fattura, effettuate nei confronti di soggetti privati. (Dettaglio degli scontrini)
  • QUADRO NE - NOTE DI VARIAZIONE EMESSE
    Note di Credito e Note di Variazione clienti. Sulla causale deve essere spuntato il campo: Nota di variazione
    (Nota: le note di credito risultano corrette se hanno imponibile e imposta negativi)
  • QUADRO NR - NOTE DI VARIAZIONI RICEVUTE
  • QUADRO FN – OPERAZIONI CON NON RESIDENTI
    Operazioni attive realizzate con soggetti non residenti (le cessioni interne dei beni nell’ambito delle triangolazioni comunitarie di cui all’art.58 del D.L. n.331/93)
    Tali operazioni vengono riconosciute esaminando lo stato del Cliente interessato che quindi deve essere compilato obbligatoriamente.
  • QUADRO SE - ACQUISTI DI SERVIZI DA NON RESIDENTI
    Accoglie la comunicazione delle prestazioni di servizi documentate da fatture ricevute da soggetti extracomunitari di cui agli artt. da 7bis a 7septiesdel dPR 633/1972, per le quali, all’atto della registrazione della fattura devono risultare i dati del prestatore.
    e gli ACQUISTI DA OPERATORI RESIDENTI NELLA REPUBBLICA DI SAN MARINO (che non vanno inseriti nella comunicazione 2012 e
    vengono scartati in quanto vengono riconosciuti dal campo 'Imp. RSM' impostato a SI sulla causale di registrazione.
    Se tali operazioni non sono state registrate con una causale così impostata, occorre escludere o il fornitore o la registrazione impostando a NO il campo 'Operaz. Ril.ai fini iva'
  • QUADRO TU - OPERAZIONI LEGATE AL TURISMO (Elencate in forma analitica)
    Il quadro è riservato alle operazioni da comunicare ai sensi dell’art. 3 comma 2bis del decreto-legge n. 16 del 2012 qualora siano realizzate le condizioni previste alle lettere a) e b) dell’art. 3, primo comma, del decreto legge 2 marzo 2012 n. 16.
    Se si devono mettere operazioni in questo quadro, occorre impostare a SI il campo Quadro TU sulla causale con cui sono state registrate.
  • QUADRO TA - Quadro finale di riepilogo delle operazioni inserite nei vari quadri

Rispetto la versione precedente si evidenziano le seguenti novità:

  • suddivisione delle operazioni in quadri come descritto sopra
  • il limite di 3.600 euro lordi resta solo per i corrispettivi
  • eliminazione dell'abbinamento della fattura con relative note di variazione, le quali andranno riportate in un apposito
    quadro
  • l'esclusione delle operazioni incassate con carta di credito o prepagata solo per i corrispettivi
  • la soppressione della gestione dei contratti
  • nuove informazioni sulle fatture come Iva non esposta in fattura, autofattura, opzioni in reverse charge, documento riepilogativo

Casi particolari:
Cessioni gratuite oggetto di autofattura – Le cessioni gratuite di beni oggetto di autofatturazione rientranti nell’attività propria dell’impresa cedente, sono da comunicare con l’indicazione della partita IVA del cedente.

Fatture cointestate – Le operazioni documentate da fatture cointestate devono essere comunicate per ognuno dei contestatari, ciascuno per la sua parte di importi.

Operazioni in applicazione del regime IVA del margine – Le operazioni effettuate in applicazione del regime IVA dei beni usati di cui ai commi da 36 a 40 del decreto legge n. 41 del 1995, non documentate da fattura, sono oggetto di comunicazione

Operazioni realizzate con spedizioni internazionali delle merci
 In considerazione dell’esclusione dall’obbligo di comunicazione dei seguenti tipi di operazioni:
- importazioni
-esportazioni di cui all’art. 8 (merci)
-operazioni effettuate e ricevute in ambito comunitario (intracee)
-cessione di beni e prestazioni di servizi effettuate e ricevute registrate e soggette a -registrazione nei confronti di operatori economici aventi sede in paesi cosiddetti Black List
si fa presente che le prestazioni di servizio strettamente legate ad operazioni di importazione ed esportazione (es. servizi di spedizione e trasporto), disciplinate dall’articolo 9 del d.P.R. del 26 ottobre 1972 n. 633, sono da comunicare al netto degli importi esclusi (es. diritti doganali)

Schede carburante
Gli acquisti di carburante effettuati da privati mediante carta di credito saranno acquisiti attraverso la comunicazione degli operatori finanziari.
Per i casi in cui permane la tenuta delle schede carburante il modello prevede la possibilità del soggetto obbligato alla comunicazione di riportarne i dati con le stesse modalità del documento riepilogativo (Quadri FR o FA)
Per includerle occorre impostare sul fornitore con cui si registra la carta carburante il campo ‘fittizio’ a SI, accertarsi che non sia presente Partita Iva/Codice fiscale e infine impostare a 'Sempre' il campo 'Operaz.rilevanti ai fini iva'.

Per escludere le registrazioni fatte sul registro vendita a fronte di acquisti da San Marino, se non è stato usato un cliente di appoggio, senza partita iva, occorre mettere a No Op.Ril. Iva il campo sul cliente o sulla registrazione (altrimenti verrebbero prese come autofatture)

Per una corretta preparazione dei dati occorre:

  • Impostare l’importo di riferimento per le operazioni senza fattura nella tabella di contabilità (Dati generali azienda - parametri).
    Se è stato lasciato a 0 il programma assumerà di default il valore: 3600
  • Anagrafiche Clienti e fornitori
    Impostare correttamente la Partita iva e il Codice fiscale (controllare con la funzione Contabilità - Servizio -Controllo partita Iva /Cod.fiscale)
  • Dati anagrafici da compilare attentamente
    • Partita Iva e/o Codice Fiscale
      Per ogni documento trasmesso verrà infatti comunicata la Partita Iva o il Codice Fiscale del cliente/fornitore a seconda che il soggetto sia o meno titolare di Partita Iva e NON la ragione sociale (quando il soggetto non è straniero)
      Se sono presenti più anagrafiche con la stessa partita iva/cod.fiscale e si chiede l'invio in forma aggregata, verranno sommati gli importi dei documenti relativi.
    • Stato (deve essere compilato correttamente, se straniero, altrimenti lasciato bianco o IT se italiano)
      (accertarsi inoltre che sulla tabella Stati, in corrispondenza ai vari stati utilizzati, sia compilato il campo 'Riferimento tabella stati')
    • Codice cointestatari (se si emettono fatture con più cointestatari)
    • Campo: 'Operazione Rilevante ai fini Iva' in maschera Contabilità (Normale-Sempre-Escluso)
    • Campo : cliente/fornitore fittizio in maschera Contabilità (impostare a SI solo in corrispondenza del fornitore Carta Carburante che non ha Partita Iva, mettere anche 'Operazione Rilevante ai fini Iva' a SEMPRE e sulla registrazione mettere 'Operazione Rilevante ai fini Iva' a Forzato.

    In caso di Soggetti Non Residenti invece, si chiede di comunicare anche i dati anagrafici:

    • Nome e Cognome e dati di nascita se persona fisica
    • Ragione sociale, verranno presi i campi Ragione sociale 1 e 2, se compilate oppure la Ragione sociale contabile, se persona giuridica.
    • Occorre compilare SEMPRE lo stato di Nascita o di Domicilio
      (fare molta attenzione che nella tabella Stati, in ogni Stato sia stato compilato il codice di riferimento alla Tabella Generale STATI)
    • Se "società, assicurazioni o altre organizzazioni senza personalità giuridica": vengono richiesti anche cognome, nome, dati di nascita di una delle persone che ne hanno la rappresentanza.
      Il programma, in presenza di un soggetto estero, compilerà questi dati se:
      - è impostato come 'persona fisica'
      - è stato compilato il campo 'Persona di riferimento' con Cognome-Nome
      - sono stati compilati i dati di nascita.
  • Clienti Cointestatari
    Se viene emessa una fattura che abbia le caratteristiche per essere trasmessa, a più intestatari, vanno trasmessi i dati anagrafici di tutti gli intestatari, ciascuno con la sua parte di importo per cui occorre collegare il cliente 'principale'della fattura ai cointestatari che quindi vanno creati nella tabella dei clienti.
  • Causali di contabilità
    Sono stati introdotti due nuovi campi:
    Segnalazione Reverse Charge in Spesometro
    Consente di individuare le registrazioni di acquisto Reverse Charge, relative ad acquisti per cui andrà barrata la casella Reverse Charge nella stampa/preparazione del file dello Spesometro, in corrispondenza a operazioni in cui questo conto è utilizzato.
    Potrà essere impostato a Si nelle causali utilizzate per la registrazione di acquisti 1972 (acquisto di materiale d’oro e d’argento e le prestazioni di servizi rese nel settore edile da soggetti subappaltatori) e in quelle di cui all’articolo 74, commi 7 e 8 (acquisti di rottami e metalli non ferrosi)
    Questo per differenziare dalla registrazione di acquisti di apparecchi elettrici e telefonini che verranno considerati ma senza flag Reverse Charge
    Inclusione forzata in Spesometro
    Impostare a S per includere le rispettive registrazioni SEMPRE nello spesometro (per rendere obbligatoria l'inclusione di registrazioni fatte con causale di tipo importazione no cee)
    Quadro TU Spesometro
    Se vale S nello spesometro le registrazioni fatte con questa causale verranno riportate nel quadro TU (Operazioni legate al turismo)
    - Infine Controllare che nelle causali utilizzate per registrare le note di variazione (note di credito e fatture che andranno rettificarne una precedente) , sia stato spuntato il campo 'nota di variazione' in modo da poterle evidenziare nei campi appositi.
  • Codici iva - Su ogni codice iva è indispensabile compilare correttamente, oltre al campo Tipo Iva, il campo 'Codice che va in elenco'
    Nei codici utilizzati per l'emissione e il ricevimento di documenti con art.74 Ter (Agenzie di viaggio) dovrà essere impostato a Si il campo Iva non esposta in fattura
    Per eventuali chiarimenti sull'impostazione dei codici IVA inclusi ed esclusi dall'invio dati Spesometro si consiglia di consultare il proprio consulente fiscale
  • Conti
    Nuovo campo : Segnalazione Reverse Charge in Spesometro
    Consente di individuare le registrazioni di acquisto Reverse Charge, relative ad acquisti per cui andrà barrata la casella Reverse Charge
    Dovrà essere impostato a Si nei conti utilizzati per la registrazione di acquisti 1972 (acquisto di materiale d’oro e d’argento e le prestazioni di servizi rese nel settore edile da soggetti subappaltatori) e in quelle di cui all’articolo 74, commi 7 e 8 (acquisti di rottami e metalli non ferrosi)
    Questo per differenziarli dalla registrazione di acquisti di apparecchi elettrici e telefonini che verranno considerati ma senza flag Reverse Charge
  • Tipo di pagamento (dalla comunicazione 2012 NON serve fare nessuna modifica)
    Poichè la fatture vanno comunque trasmesse tutte, non si deve più compilare il campo sul tipo pagamento il campo 'Escluso da comunicazione Op.Rilev.ai fini Iva' al fine di individuare le fatture pagate/incassate con modalità di pagamento 'carta di credito' etc..(il programma non ne tiene più conto)
    Vanno escluse, se incassate con tali modalità, sono solo le operazioni fatte con privati senza fattura (corrispettivi).

REGISTRAZIONI DI PRIMA NOTA (Inserimento fatture)

  • Corrispettivi/Ric.Fiscali
    Per le vendite fatte a privati, senza fattura, al fine di poter trasmettere la transazione se ne ha i requisiti, occorre creare il cliente in tabella con tutti i dati anagrafici e registrare il corrispettivo inserendo il cliente particolare in Partita al posto del 'Cliente corrispettivo' generico o della Cassa. Dovrà poi seguire la registrazione dell'incasso.
  • Fatture dettaglianti
    Il programma le comunica sempre. Se si ritiene di doverle comunicare solo se > 3600€ occorre impostare a N il parametro di personalizzazione: FattDettSempre
  • Le Note di variazione vengono scaricate separatamente per cui non è più indispensabile collegarle alla fattura.
    A tal proposito è possibile impostare alcuni parametri di personalizzazione che intervengono nei controlli: NotaVarDataObblig , NotaVarVerEsiste , CopiaOrigInD
  • Fatture ricevute in Reverse Charge
    Il programma le estrae tutte, salvo quelle che, sulla registrazione hanno il campo ‘Op. rilev.Iva’ a No.
    Poiché il programma possa barrare la casella ‘Reverse charge’ a fronte di registrazioni di acquisto di materiale d’oro e d’argento, di prestazioni di servizi rese nel settore edile da soggetti subappaltatori e in quelle di cui all’articolo 74, commi 7 e 8 (acquisti di rottami e metalli non ferrosi) dovrà essere impostato a Si il campo ‘Segnalazione Reverse Charge in Spesometro’ sulla causale o sui singoli conti utilizzati per le suddette registrazioni.

    Per la preparazione del file da inviare telematicamente utilizzare la funzione: Spesometro (Contabilità - Iva)

Note sulle modalità di estrazione del programma per la compilazione dei vari quadri

Al fine di consentire una forzatura in modo che una registrazione venga comunicata anche se apparentemente non ci sono le condizioni o viceversa, venga esclusa pur avendo le condizioni per essere comunicata, è stato inserito, nella maschera della PrimaNota, il campo 'Operazione rilevante ai fini iva' in ogni registrazione di fatture (emesse e ricevute), di note di credito e di corrispettivi intestati ad un codice cliente (diverso dal cliente corrispettivi dichiarato in tabella dei conti comuni).

Il flag Forzato sulla testata della registrazione è prioritario per l’inclusione, viene inclusa anche se sul cliente/fornitore c’è scritto di escluderla nel campo ' Op.rilevante ai fini Iva

Se invece, sulla testata della registrazione c’è il flag ‘Op.rilevante ai fini iva’ a Si, questa verrà scartata se c’è un motivo di scarto es. Causale Black List, Intra Cee , Tipi Pagamenti con flag da escludere etc.

Autofatture
Nelle Vendite: Viene impostato il flag autofattura a Si in quelle con causale con flag autofattura a Si però poiché ci vanno SOLO quelle registrate a fronte di acquisti da non residenti e non quelle per autoconsumo, andranno fatte con causali diverse.
Eventualmente pare che non venga considerato un errore sanzionabile l’eclusione delle autofatture per acquisti da non residenti e quindi se non si può fare causali diverse si potrà andare sul movimento a mettere il flag di esclusione.
Negli Acquisti: viene considerato autofattura SOLO se il fornitore indicato ha la stessa partita iva dell’azienda
Se in Prima nota, in un acquisto, viene messo il codice del conto fornitore di riferimento, la registrazione verrà considerata come fatta con uno straniero.

Se non è straniero e non è nota di variazione e non è un corrispettivo o fattura dettagliante:

  • se è un acquisto e la Partita Iva è uguale a quella della ditta è autofattura

  • se è una vendita ci deve essere il flag di autofattura a S , NON va ad S invece se la fattura è fatta per autoconsumo

Per includere una registrazione di un servizio fatto ai sensi dell’articolo 7 bis etc. , fatta con causale ‘importazione no cee’ occorre mettere a Forzato il flag in testata della prima nota

Infine, se fosse necessario, per casi estremi, includere operazioni che non sono state registrate nell’anno (il riferimento è agli eventuali corrispettivi con importo maggiore si 3600€ da segnalare separatamente evidenziando l’anagrafica cliente) si può attivare il parametro di personalizzazione UsaPNFittizia e si possono fare le registrazioni utilizzando il programma di inserimento Prima Nota extracontabile mettendo il flag di 'Op.Ril.ai fini iva' a Forzato sulla registrazione stessa o sulle causali utilizzate.

Le fatture dettaglianti vengono inviate Sempre indipendentemente dall'importo. Per inviare Solo quelle maggiori di 3600€, impostare il parametro FattDettSempre a N

Elenco parametri di personalizzazione utilizzabili:
 FattDettSempre , UsaPNFittizia , ScartaZero , Arrot , FornCodFisc per criteri di estrazione

 OrdStampa , StaConto per stampa


SPESOMETRO - PREP.FILE TELEMATICO OP. RILEVANTI AI FINI IVA (dal 2012)

Percorso: Contabilità - Iva - Spesometro

La funzione consente di preparare il file per l'invio telematico delle Operazioni Rilevanti ai fini iva (Spesometro) secondo il tracciato stabilito dall’Agenzia delle Entrate: Specifiche_Comunicazione_Polivalente.xls (consultabile all'indirizzo http://www.aziendapc.it/documenti e nella cartella \BaseDoc\Spesometro\ ) e di stampare l’elenco delle operazioni in esso inserite.
Tale elenco sarà preceduto dalla pagina di frontespizio con i dati generali della comunicazione e seguito dalla pagina di Riepilogo (Quadro TA).

La funzione può essere ripetuta più volte, si consiglia tuttavia di compattare il database (funzione: Parametri e utilità - utilità - compatta database) dopo aver lanciato più volte l' elaborazione, per velocizzare e ridurre la dimensione del database.

Per la stampa vengono utilizzate 2 immagini che l'installazione ha copiato nella cartella aziwin\immagini (Spesometro01.gif e Spesometro14.gif)

Accertarsi che siano compilati correttamente i dati dell'azienda per il frontespizio

Le operazioni scritte sul file predisposto per l’invio, verranno estratte direttamente dalle registrazioni di Prima Nota (e dalla prima nota fittizia se necessario e richiesto).
Il programma esaminerà tutte quelle con data di registrazione compresa nell’anno da comunicare, verificando se soddisfano o meno i requisiti per la comunicazione e, in caso positivo, inserendoli in un quadro o in un altro a seconda del tipo di operazione.

L'estrazione perciò presuppone che siano stati impostati correttamente i dati sulle anagrafiche e sulle registrazioni, come descritto nel capitolo Spesometro - Comunicazione telematica delle operazioni rilevanti ai fini Iva

Durante l'elaborazione il programma darà segnalazioni se:
- sono state estratte 'righe' (fatture) dove gli importi sono tutti a 0 - evidenzia codice cli/for o Anno e Nr.Registrazione
Si può impostare il parametro di personalizzazione ScartaZero che , se impostato a S e si sceglie di preparare il file dello Spesometro in modalità: Analitica, consente di scartare i documenti nei quali gli importi di imponibile e imposta, una volta arrotondati, sono a 0.
Se si sceglie la preparazione in forma Aggregata, eventuali righe a 0, verranno segnalate a video . Per escluderle occorrerà andare a mettere sulle singole registrazioni di prima nota il campo 'Op.Ril. iva' a 'Da ignorare'

E' possibile preparare un unico file contenente l'invio dei dati di più ditte oppure file separati.
L'utente può scegliere la cartella in cui salvare il file generato.
Anno – Data da A
La comunicazione è annuale per cui qui va indicato l’anno di riferimento. E’ stata data la possibilità di inserire un intervallo di date per comunicare i documenti di un certo periodo nel caso si renda necessario

Estrazione dati (Si/No)
La casella viene proposta sempre barrata, in quanto per fare la comunicazione occorre estrarre i dati su una tabella di servizio. E’ possibile tuttavia, dopo aver fatto una elaborazione con estrazione, NON estrarre più e preparare il file e/o stampare, utilizzando i dati estratti in precedenza.

Formato Comunicazione

  • Aggregata
  • Analitica

Tipo elaborazione

  • Preparazione file e stampa
  • Preparazione file
  • Stampa
    La stampa presenta, per ogni quadro, le operazioni i ordine di data registrazione.

Per ogni quadro vengono stampate le operazioni estratte. Quando c'è una partita iva o codice fiscale, viene stampata anche la descrizione dell'anagrafica. Per stampare anche il codice conto si può attivare il parametro di personalizzazione Staconto

Ordinamento in stampa
Si può impostare il parametro di personalizzazione OrdStampa in modo da preimpostare il valore per ordinare le anagrafiche in stampa

Tipo Invio

  • Ordinario
  • Sostitutivo
  • Annullamento

Se Sostitutivo o Annullamento vanno compilati i due campi: Protocollo comunicazione da sostituire/annullare (max 17 cifre) e Protocollo documento da sostituire/annullare (Max 6 cifre)
In questo caso si consente di elaborare una ditta per volta

Invio fatto da intermediario:
Questo campo viene automaticamente impostato a Si o a No a seconda che sia stato compilato o meno il Codice Fiscale/Partita Iva dell'intermediario nella tabella "Dati per comunicazione telematiche" (comune a tutte le ditte) e può essere variato dall'utente.
Inoltre verranno visualizzati il codice fiscale dell'intermediario e la data dell'impegno. La data visualizzata sarà quella della tabella suddetta, se compilata, oppure quella della tabella 'Dati per comunicazioni telematiche Ditta' con riferimento al codice della prima ditta impostato a video.
E' possibile variare tale data e, tramite la spunta dell'apposito campo 'Data valida per tutte le aziende', far si che questa venga utilizzata come data impegno per tutte le ditte elaborate, in stampa e sul file, nella sezione intermediario (altri dati obbligatori in caso di presenza di intermediario sono: codice fiscale o partita iva dell'intermediario ed, eventualmente il Numero di iscrizione al CAF)
Se a preparare e spedire il file non è un intermediario ma la ditta stessa, questo campo dovrà essere impostato a No, anche se in tabella sono stati inseriti i dati dell'intermediario.

Stampa numero modulo
Spuntando questo campo si ottiene la stampa, all'inizio di ogni riga, del numero di modulo in cui quell'anagrafica verrà scritta sul file.
Questo numero potrà servire per cercare l'anagrafica in cui si è verificato l'errore, se, quando si spedisce il file all'Agenzia delle Entrate, si riceve un messaggio di errore in cui è specificato il numero del modulo.
Per ottenere la stampa ordinata per numero modulo, basta selezionare Stampa ordinata 'Come file'

Numero massimo di moduli estratti per file
Si possono trasmettere file con un massimo di 40.000 record (dimensione massima 5 MB).
Se si superano i 40.000 record il programma da un messaggio di avvertimento; se si sta facendo un’unica azienda, si dovrà ripetere l’estrazione impostando a video il Numero moduli da inserire in ogni file e il programma suddividerà la comunicazione in più file.
(per modulo si intende una pagina di stampa secondo il modello dell’Agenzia delle Entrate, vedi pdf: Modello+di+comunicazione+polivalente.pdf inserito nell’area di installazione nella cartella BaseDoc\Spesometro)
Se invece si stanno elaborando più ditte, l’operatore dovrà elaborare un numero inferiore di ditte per volta.

Stampa ordinata per

  • Ragione sociale
  • Codice conto
  • Come file (partita iva)

Stampa frontespizio e stampa riepilogo
Si può scegliere se stampare o meno queste due pagine per velocizzare le stampe di prova.

Vedi Cosa estrae il programma

Per compilare correttamente il quadro di frontespizio con i dati dell'azienda etc. occorre:

inserire nella Tabella Attività il codice attività dell'azienda

Compilare in Dati per comunicazione annuale iva il Tipo Fornitore

Se l'elaborazione è fatta da un intermediario occorre compilare in Dati per comunicazione annuale iva (Tabella unica per tutte le ditte, da compilare una tantum) Partita Iva o cod. fiscale dell'Intermediario e Numero di iscrizione al CAF se esiste.
Compilare inoltre, con la funzione “Dati generali per iva annuale/periodica” (menu contabilità - iva), nei dati 'Intermediario' la spunta sulla voce opportuna in 'Impegno a trasmettere ...' e la data dell'impegno (questi ultimi dati possono essere scritti una volta per tutte sulla tabella unica e lasciati bianchi qui).

Se i dati del contribuente sono diversi dai dati della ditta stessa, compilare, con la funzione “Dati generali per Comunicazioni Telematiche” (menu contabilità - iva) i dati anagrafici del contribuente, altrimenti controllare che siano tutti compilati i dati nell'anagrafica ditta
In caso di nascita all'estero nel campo Comune dovrà essere scritto lo Stato di nascita e in provincia EE
Dati del Dichiarante/Rappresentante se diverso dal Contribuente

Se esiste un rappresentante, SOLO del tipo previsto dalle istruzioni dello Spesometro, compilare con la funzione “Dati generali per iva annuale/periodica” il campo Codice Fiscale/Partita Iva Rappresentante e tutti gli altri dati anagrafici in maschera, relativi ad esso.
ATTENZIONE: se Codice Fiscale/Partita Iva Rappresentante è compilato si chiede di compilare, se 'esistono' due nuovi campi:
'Data inizio procedura o decesso' e 'Data fine procedura'.
Se si vuol lasciare compilato il codice fiscale rappresentante per altri invii ma nello Spesometro NON ci va occorre compilare la 'data inizio procedura o decesso' con il valore 01/01/1919

Note sulla stampa:

Gli importi vengono troncati. Si può impostare il parametro di personalizzazione Arrot per arrotondare

Se sono presenti più anagrafiche con la stessa partita iva/cod.fiscale e si chiede l'invio in forma aggregata, verranno sommati gli importi dei documenti relativi e verrà stampata la partita iva e l'anagrafica di uno solo.

Nella stampa del quadro FA i campi O.A. e O.P. indicano rispettivamente

  • O.A. - numero delle operazioni attive aggregate (fatture emesse, note di credito ricevute, note di variazione 'positive' a clienti)
  • O.P. - numero operazioni passive aggregate (fatture ricevute, note di credito emesse, note di variazione di fornitori)

Durante l'elaborazione verranno segnalati eventuali errori o anomalie. Ad esempio vengono segnalate:
- le registrazioni con importo minore di un euro che, se scaricate singolarmente, generano delle righe con importi a 0 che vengono segnalate come errore dal programma di controllo dell'Agenzia delle Entrate. Se invece si fa la comunicazione Aggregata queste verranno sommate per cui, se l'importo supera 1 euro, non genera problemi.
- Se si trova un fornitore con fatture, che ha nel campo Partita Iva (o Cod. Fiscale) un codice che inizia per 8 o 9, per cui una partita iva non valida(questa anagrafica non verrà estratta)

Errore 13 appena prima della stampa, dopo aver elaborato:
NON SI è aggiornata la DLL Stampe.dll

Se in archivio esistono più anagrafiche con la stessa Partita Iva, poichè, nella comunicazione Aggregata, si deve mettere una voce per ogni partita iva, verrà stampato il codice e la ragione sociale della prima anagrafica incontrata.

La stampa, visto la complessità dei dati, potrà essere fatta su file Pdf SOLO scegliendo al momento la stampa su stampante pdf creator. Inoltre, in questo caso, verranno generati pdf diversi per ogni gruppo di dati stampati e verranno quindi chiesti più nomi di file pdf.

Se la stampa del frontespizio non è incasellata nel modo giusto, si può procedere come segue:
si può inserire nell'aziwin.ini del terminale o generale, il paragrafo:

[Spesometro]
NomeImg=Spesometro01.gif
#AltezzaFoglio01=296,5496
AltezzaFoglio01=XXX

Dove XXX va valutato.
Questo valore determina la dimensione della parte prefincata e non delle scritte
Il programma calcola questo valore in base alle caratteristiche della stampante.
Se si vuole allungare la parte prefincata o accorciarla (in base a come poi vengono le scritte, in modo da farle corrispondere) si possono fare dei tentativi mettendo un valore, rispettivamente, maggiore o minore di quello indicato sopra: 296,5496


PREP.FILE PER INVIO TELEMATICO OPERAZIONI CON SOGGETTI IN 'BLACK LIST'

Percorso: Contabilità - Iva - File per invio telematico

Funzione utilizzata fino al 31/12/2013
Dal 2014 viene utilizzata la nuova funzione Black List con modello Spesometro.

Il programma consente di preparare il file per l'invio telematico della Comunicazione delle operazioni con soggetti aventi sede, residenza o domicilio in paesi a fiscalità privilegiata (Black List).

Per una corretta compilazione del file per l'invio telematico occorre inserire tutti i dati anagrafici del contribuente, dichiarante, eventuale intermediario etc. come descritto nel capitolo Black List

Verranno prese in considerazione tutte le registrazioni di fatture/note credito emesse e ricevute, registrate nel periodo da inviare, che hanno come soggetto un residente in un paese presente in Black List.

La periodicità di invio della Comunicazione black list: Mensile o Trimestrale viene letta dai “Dati per Comunicazioni Telematiche (ditta)”
A seconda che la periodicità sia mensile o trimestrale dovrà essere compilato il campo Mese o Trimestre con il numero esatto relativo al periodo delle registrazioni da considerare.
Il programma elaborerà le ditte con periodicità uguale a quella scelta a video.

Correttiva nei termini - da spuntare se si sta rettificando o integrando, prima della scadenza del termine di presentazione, una comunicazione già presentata.
Comunicazione integrativa - da spuntare se si sta spedendo, dopo la scadenza del termine di presentazione ma entro l'ultimo giorno del mese successivo alla scadenza del termine per la presentazione della comunicazione originaria, una comunicazione già spedita in precedenza per rettifica o integrazione.
Variazione di periodicità - da spuntare se è variato il periodo di riferimento della Comunicazione

Comunicazione inviata da intermediario
Questo campo viene automaticamente impostato a Si o a No a seconda che siano stati compilati o meno i dati dell'intermediario nella tabella "Dati per comunicazione annuale iva" (comune a tutte le ditte) e può essere variato dall'utente.
Se a preparare e spedire il file non è un intermediario ma la ditta stessa, questo campo dovrà essere impostato a No, anche se in tabella sono stati inseriti i dati dell'intermediario.
E’ possibile creare, nei parametri di personalizzazione, il parametro Intermediario per impostare automaticamente "No intermediario" al caricamento della maschera.

  • Si
    Il programma prepara un file unico per tutte le ditte scelte. Nel file preparato, i dati del record A (record di testa) saranno quelli dell’intermediario per cui verranno letti dalla tabella gestita da “Dati per comunicazione annuale iva” (tabella comune a tutte le ditte)
  • No
    Occorre elaborare una ditta per volta
    Nel record A (record di testa) verranno riportati i dati del contribuente

Stampa elenco Black List e Stampa riga con importi
Consento di stampare o meno i dati che verranno inseriti nel file

Raggruppa per codice fiscale
Se spuntato, verranno raggruppati gli eventuali importi di documenti registrati per anagrafiche diverse ma con lo stesso codice fiscale/partita iva. Nel caso di un cliente che si anche fornitore, esso comparirà in elenco una volta sola con gli importi sia nelle Operazioni Attive che Passive

Si può scegliere di generare:

  • File separati per ogni azienda
  • Unico file cancellando eventuali estrazioni precedenti dello stesso periodo

Il file generato prenderà il nome BlackListAAAAPXX(DDD).TXT dove
AAAA è l'anno della comunicazione
P è la periodicità: M per mensile o T per trimestrale
XX è il numero che indica il mese o il trimestre
DDD è il codice ditta nel caso si elaborino più ditte contemporaneamente scegliendo di generare file separati.
Esso viene generato automaticamente nell'area contenente i database ma si consente all'operatore di variare la destinazione; la nuova destinazione verrà memorizzata nel file aziwin.ini nel parametro DirBlackList.

www.aziendapc.it
Versione 4.03C 		Apri il sito www.AziendaPC.it


PREP.FILE PER INVIO TELEMATICO OPERAZIONI CON SOGGETTI IN 'BLACK LIST' (dal 2014)

Percorso: Contabilità - Iva - File per invio telematico

Il programma consente di preparare il file per l'invio telematico della Comunicazione delle operazioni con soggetti aventi sede, residenza o domicilio in paesi a fiscalità privilegiata (Black List).
La comunicazione viene fatta, dal 2014 , con il modello Polivalente, lo stesso dello Spesometro.

Per una corretta compilazione del file per l'invio telematico occorre inserire tutti i dati anagrafici del contribuente, dichiarante, eventuale intermediario etc. come descritto nel capitolo Black List

Verranno prese in considerazione le registrazioni di fatture/note credito emesse e ricevute, registrate nell' anno da inviare, che hanno come soggetto un residente in un paese presente in Black List.
In base al DLgs.n.175/2014, la ditta è tenuta all'invio della comunicazione solo se l'importo complessivo delle operazioni effettuate/ricevute è superiore a € 10.000.
In tal caso vanno comunicate anche le operazioni di importo <= 500€ che erano state invece escluse dal DL n. 16/2012

Il programma elaborerà, per le ditte scelte a video, tutti i movimenti di Prima Nota con segnale Black List a Si e anno scelto.

La comunicazione diventa annuale per cui non si testa più valida la periodicità

Estrazione dati (Si/No)
La casella viene proposta sempre barrata, in quanto per fare la comunicazione occorre estrarre i dati su una tabella di servizio. E’ possibile tuttavia, dopo aver fatto una elaborazione con estrazione, NON estrarre più e preparare il file e/o stampare, utilizzando i dati estratti in precedenza.

Tipo elaborazione

  • Preparazione file e stampa
  • Preparazione file
  • Stampa
    La stampa presenta, per ogni quadro, le operazioni i ordine di data registrazione.

Tipo Invio

  • Ordinario
    Nel caso di invio, nello stesso periodo, di due comunicazioni Ordinarie, verranno considerate, dall'Agenzia delle Entrate come l'una il completamento dell'altra per cui verranno sommate.
  • Sostitutivo
    da spuntare per preparare un file con i dati di una ditta già spedita in precedenza, per rettifica della precedente.
  • Annullamento
    da spuntare per preparare un file che annulla un invio precedente

Se Sostitutivo o Annullamento vanno compilati i due campi: Protocollo comunicazione da sostituire/annullare (max 17 cifre) e Protocollo documento da sostituire/annullare (Max 6 cifre)
In questo caso si consente di elaborare una ditta per volta

Comunicazione inviata da intermediario
Questo campo viene automaticamente impostato a Si o a No a seconda che sia stato compilato o meno il Codice Fiscale/Partita Iva dell'intermediario nella tabella "Dati per comunicazione telematiche" (comune a tutte le ditte) e può essere variato dall'utente.
Inoltre verranno visualizzati il codice fiscale dell'intermediario e la data dell'impegno. La data visualizzata sarà quella della tabella suddetta, se compilata, oppure quella della tabella 'Dati per comunicazioni telematiche Ditta' con riferimento al codice della prima ditta impostato a video.
E' possibile variare tale data e, tramite la spunta dell'apposito campo 'Data valida per tutte le aziende', far si che questa venga utilizzata come data impegno per tutte le ditte elaborate, in stampa e sul file, nella sezione intermediario (altri dati obbligatori in caso di presenza di intermediario sono: codice fiscale o partita iva dell'intermediario ed, eventualmente il Numero di iscrizione al CAF)
Se a preparare e spedire il file non è un intermediario ma la ditta stessa, questo campo dovrà essere impostato a No, anche se in tabella sono stati inseriti i dati dell'intermediario.
E’ possibile creare, nei parametri di personalizzazione, il parametro Intermediario per impostare automaticamente "No intermediario" al caricamento della maschera.

  • Si
    Nel file preparato, i dati del record A (record di testa) saranno quelli dell’intermediario per cui verranno letti dalla tabella gestita da “Dati per comunicazione annuale iva” (tabella comune a tutte le ditte)
  • No
    Nel record A (record di testa) verranno riportati i dati del contribuente

Raggruppa per codice fiscale
Se spuntato, verranno raggruppati gli eventuali importi di documenti registrati per anagrafiche diverse ma con lo stesso codice fiscale/partita iva. Nel caso di un cliente che sia anche fornitore, esso comparirà in elenco una volta sola con gli importi sia nelle Operazioni Attive che Passive

Si può scegliere di generare:

  • File separati per ogni azienda
  • Unico file cancellando eventuali estrazioni precedenti dello stesso periodo

Il file generato prenderà il nome BlackListAAAAPXX(DDD).TXT dove
AAAA è l'anno della comunicazione
P è la periodicità: M per mensile o T per trimestrale
XX è il numero che indica il mese o il trimestre
DDD è il codice ditta nel caso si elaborino più ditte contemporaneamente scegliendo di generare file separati.
Esso viene generato automaticamente nell'area contenente i database ma si consente all'operatore di variare la destinazione; la nuova destinazione verrà memorizzata nel file aziwin.ini nel parametro DirBlackList.

Numero massimo di moduli estratti per file
Si possono trasmettere file con un massimo di 40.000 record (dimensione massima 5 MB).
Se si superano i 40.000 record il programma da un messaggio di avvertimento; se si sta facendo un’unica azienda, si dovrà ripetere l’estrazione impostando a video il Numero moduli da inserire in ogni file e il programma suddividerà la comunicazione in più file.
(per modulo si intende una pagina di stampa secondo il modello dell’Agenzia delle Entrate, vedi pdf: Modello+di+comunicazione+polivalente.pdf inserito nell’area di installazione nella cartella BaseDoc\Spesometro)
Se invece si stanno elaborando più ditte, l’operatore dovrà elaborare un numero inferiore di ditte per volta.

www.aziendapc.it
Versione 4.03C 		Apri il sito www.AziendaPC.it


ELENCO CLIENTI E FORNITORI

Percorso: Contabilità - Iva - File per invio telematico

Questa funzione consente di preparare, per ogni azienda, il file per la trasmissione telematica dell' Elenco dei clienti e dei fornitori. La preparazione del file può essere ripetuta più volte.

Tale file è stato predisposto secondo le specifiche tecniche riportate in Gazzetta Ufficiale.

I progressivi stampati vengono letti dalla tabella gestita in Progressivi iva clienti e fornitori che viene compilata funzione di Ricalcolo del progressivi IVA

E' pertanto OBBLIGATORIO, prima di eseguire questa funzione, fare il Ricalcolo dei progressivi iva per elenco clienti e fornitori dopo aver controllato l'esattezza delle registrazioni con data documento nell'anno di presentazione degli Elenchi e dei Codici Iva.

Inoltre è necessario controllare l'esattezza dell'impostazione della Partita Iva (e per gli anni successivi al 2007 del Codice Fiscale) dei clienti e dei fornitori e il segnale di Incluso in allegato su ogni anagrafica.

Per i controlli si possono utilizzare la funzione "Controllo P.Iva e CF" dal menu di servizio di Contabilità e la lista Clienti/Fornitori dai rispettivi programmi di gestione (nella quale è stata inserita la possibilità di fare la stampa).

Sul file generato non possono esserci due partite iva uguali per cui se in archivio ci sono clienti o fornitori con la stessa Partita Iva (Es. perché hanno cambiato indirizzo ed è stata fatta un'altra anagrafica) il programma somma i loro importi e li riporta una volta sola. Per evidenziare questi casi, in stampa, viene stampato un asterisco (*) davanti alle partite iva doppie.

Per gli anni 2006 e 2007 verranno inclusi in Elenco i soggetti nei cui confronti siano state emesse/ricevute fatture che siano titolari di Partita Iva e con il campo "In elenco cli/for (allegati)" posto a Si o ad A (allegati e ritenuta d'acconto).

(Sono escluse le Partite Iva che iniziano per 8 o 9, cioè privati o assimilati a privati: condomini, scuole, parrocchie)

Per gli stessi anni è possibile indicare anche solo la Partita IVA, poi diventerà obbligatorio il codice fiscale)

Anno
E' l'anno per il quale si deve preparare il file telematico dell' Elenco dei clienti e dei fornitori.
Identificativo azienda da … a …

E' il numero che identifica l'azienda in Parametri e Utilità, Gestione database aziende. Viene presentato il numero relativo all'azienda corrente. Si possono variare uno o entrambi gli identificativi, in modo da elaborare più aziende in sequenza.

Estrarre codice fiscale e partita iva
Per gli anni 2006 e 2007 si chiede di inserire negli Elenchi SOLO i titolari di partita iva, ma di questi, si può scaricare solo la partita iva o anche il codice fiscale. Se si barra questa casella e il cliente/fornitore scaricato ha anche il codice fiscale, oltre alla partita iva, verrà scaricato anch'esso.

Stampa elenco clienti e fornitori estratti
Se si barra questa casella verrà prodotta una stampa dei dati scritti sul file in modo tale da poter controllare i dati estratti prima di fare l'invio.

Stampa riga con importi
La stampa prodotta può contenere solo i dati anagrafici dei clienti/fornitori o anche gli importi (quelli obbligatori per l'invio del 2006 e 2007)

Numero massimo di clienti/fornitori estratti per file
Nelle note sulla struttura del file da inviare si chiede che la dimensione complessiva delle comunicazioni da inviare non superi i 3MB compressi (la compressione la effettua il programma ministeriale di controllo).

Una volta preparato, il file dovrà essere trasmesso per via telematica al Ministero e, in questa fase, verrà sottoposto a dei controlli che ne verificano la correttezza. Se si dovesse verificare un errore per superata dimensione, si può ripetere l'estrazione assegnando un numero massimo di anagrafiche da inserire in ogni file. (Il numero di clienti e fornitori estratti lo si può vedere sulla stampa prodotta contemporaneamente all'estrazione). In questo caso il programma provvederà a generare più file, per la stessa ditta, ciascuno con il numero di anagrafiche richiesto.

Raggruppa dichiarazioni di aziende diverse
Le scelte che seguono hanno senso solo se si deve preparare il file degli Elenchi per più aziende.

Si può scegliere se generare file separati per ogni azienda in elaborazione, se accodare i dati dell'azienda in elaborazione a quelli di altre aziende già elaborate: "Unico file aggiungendo ad eventuali estrazioni precedenti" oppure se si vuole generare un unico nuovo file contenente le sole aziende in elaborazione: "Unico file cancellando eventuali estrazioni precedenti".

Qualunque sia la scelta, occorre fare molta attenzione al nome da assegnare al file da generare e alla posizione sul disco, dove questo verrà generato. Queste specifiche vengono assegnate in:

Nome file ascii (generato).
Il programma propone di generare il file nella cartella aziwin\carica e assegna il nome:
EleCliForXX.txt dove XX è l'anno di presentazione dell'Elenco.
Se è stato scelto di assegnare nomi diversi ai file di ogni azienda, al nome (EleCliForXX) verrà aggiunto in numero che è l' Identificativo dell'azienda.
Se si chiede di generare più file per una stessa azienda, digitando un limite massimo di anagrafiche da inserire, al nome verrà aggiunto il progressivo del file (Es. _1 , _2 etc.).
Premendo il pulsante 'Cambia', è possibile scegliere di dare altro nome al/ai file e/o di salvarli in una cartella diversa da quella assegnata di default.
Se viene cambiato il nome della cartella in cui si scarica il file, il programma lo memorizza nell'aziwin.ini nel parametro: DirEleCliForn=…

NOTE per una corretta compilazione degli ELENCHI

Il file contiene una riga di dati generali della ditta, una o più righe con i dati dei clienti seguite da una o più righe con i dati dei fornitori. Nella riga finale vengono ripetuti i dati della ditta.

Se il contribuente coincide con l'intestatario della ditta, i dati verranno estratti dall'anagrafica ditta gestiti in
Parametri e utilità - Dati generali azienda parametri - Anagrafica ditta.
Se la ditta è persona fisica dovranno essere compilati Cognome-Nome nell'apposito campo, Partita Iva, Codice fiscale e i dati di nascita.

Se è persona giuridica invece, oltre alla Ragione sociale, Partita Iva e codice fiscale, dovranno essere compilati il Comune legale (se non è compilato si prende la località legale) e la provincia legale.
ATTENZIONE: Non deve essere assolutamente compilato il campo Ragione Sociale dei dati Contribuente in Contabilità - Iva - Dati generali per iva annuale, altrimenti verranno considerati questi dati al posto di quelli dell'anagrafica ditta.

Se il contribuente non coincide con l'intestatario della ditta, i dati anagrafici verranno estratti dai Dati contribuente gestiti in Contabilità - Iva - Dati generali per iva annuale

In questo caso occorre inserire qui TUTTI i dati del contribuente richiesti a video. Se si tratta di persona fisica la Ragione sociale dovrà contenere Cognome-Nome (cioè il cognome dovrà essere separato dal nome dal carattere - (meno)), il comune dovrà essere quello di nascita e si dovranno compilare anche sesso e data di nascita.

Codice fiscale del soggetto obbligato (se diverso dal contribuente)
Si chiede di compilare il campo CodFiscale/Partita iva del Dichiarante/Rappresentante (se diverso dal contribuente) presente in Contabilità - Iva - Dati generali per iva annuale

Intermediario

Se la presentazione dell'Elenco viene fatta da un intermediario, occorre aver compilato, per ogni ditta in Contabilità - Iva - Dati generali per iva annuale - INTERMEDIARIO il flag che indica il tipo di impegno e la data dell' impegno e inoltre, in Contabilità - Iva - Dati per Comunicazione IVA annuale, (sulla Tabella comune a tutte le ditte), il Codice fiscale dell'intermediario che effettua la trasmissione. Quest'ultimo codice va impostato una volta sola e vale per tutte le ditte trasmesse.

Controllare Partita Iva (e Codice Fiscale) dei Clienti e Fornitori.


INVIO TELEMATICO ELENCO CLIENTI E FORNITORI

Vedi Elenco Clienti e Fornitori


MAGAZZINO

La procedura di magazzino può essere utilizzata in modo indipendente oppure può costituire parte integrante delle Vendite, degli Ordini di Acquisto e di Vendita.
Sono inoltre disponibili il moduli di Distinta Base e Gestione dei Lotti (tracciabilità)

CARATTERISTICHE PRINCIPALI

  • Gestione di più anni in linea
  • Gestione di più magazzini per la stessa azienda con possibilità di effettuare spostamenti di merci dall'uno all'altro.
  • Articoli con varianti a due livelli (es. per gestione taglia/colore (vedi Livelli e Composizione Livelli))
  • Articolo con codice alfanumerico di 20 caratteri e 40 di descrizione, quest'ultima può essere completata da una descrizione aggiuntiva (stampabile sui documenti di vendita)
  • Possibilità di identificare ogni articolo con un codice a barre, di raggruppare gli articoli per Gruppo e Sottogruppo, per Reparto, per attributi.
  • Gestione di unità di misura diverse per vendita e acquisti
  • Descrizioni in lingua
  • Movimentazioni di magazzino generate da causali parametriche (carico, scarico, movimenti interni, trasformazione)
  • Più listini (in lire e in euro o in diverse valute) con possibilità di attivare per uno stesso listino, diverse date di validità.
  • Listini con prezzi netti o comprensivi di iva.
  • Variazione o creazione automatica listini con arrotondamento degli importi personalizzabile
  • Listino promozione.
  • Possibilità di memorizzare per ogni Articolo l'ultimo costo del singolo fornitore.
  • Stampe listini, partitari e situazione articoli parametrizzabili dall'utente.
  • Gestione scorta minima e massima per articolo o per magazzino, valorizzazione LIFO, costo ultimo, costo medio ponderale, costo standard etc.
  • Giornale di Magazzino
  • Possibilità di collegamento con Registratore di Cassa per emissione scontrino.
  • Inserimento matricole in movimenti di acquisto e di vendita - Visualizzazione e stampa della movimentazione di una matricola
  • Gestione lotti (Tracciabilità)
  • Gestione contributo Raee
  • Gestione vuoti (cauzioni)

Come impostare i dati per cominciare ad utilizzare la procedura.

Come per uno qualsiasi degli altri moduli della procedura, è necessario compilare le tabelle generali tramite la funzione: Dati Generali Azienda

Nel caso specifico dell'utilizzo della sola procedura di Magazzino è indispensabile compilare:

  • Anagrafica ditta
  • Parametri comuni e di Magazzino
  • Per mettere sui singoli articoli il conto di ricavo e il fornitore abituale, occorre creare gruppo e mastro clienti e fornitori e mettere il codice in tabella Conti Comuni e inoltre creare il conto di ricavo nel Piano dei Conti.
    La creazione, nelle singole tabelle, dei codici obbligatori, può essere fatta direttamente dalla maschera della richiesta parametri aprendo la lista di aiuto sui codici (tasto F2 o click sul quadratino posto a fianco ad ogni codice) e premendo il pulsante [image] (X) Gestione archivio
  • Successivamente occorre compilare, con la scelta Archivi comuni:
    le Tabelle di Magazzino quindi le anagrafiche degli articoli, i listini etc.


CARICAMENTO MOVIMENTI DI MAGAZZINO

Percorso: Magazzino - Movimenti

Con questa funzione si consente di movimentare il magazzino in entrata e in uscita, indipendentemente dall'utilizzo di programmi di Fatturazione o di Gestione Acquisti e comunque di variare i movimenti generati da queste procedure.

E' indispensabile aver precedentemente creato, con l'apposita gestione, la causale di magazzino opportuna. E' quest'ultima infatti a determinare prima, i campi che verranno chiesti all'operatore, poi i progressivi dell'articolo che verranno aggiornati.

L'utilizzo delle procedure di Fatturazione e degli Acquisti (per ora solo evasione di un ordine a fornitore) determinano la generazione automatica di movimenti di magazzino che poi potranno essere gestiti con questo programma.

La registrazione di un movimento comporta l'immediato aggiornamento dei progressivi dell'articolo.

Gli articoli coinvolti in un movimento, possono essere caricati da un file esterno oltre che digitati manualmente (Caricamento dettagli documenti da file)

Per ogni articolo caricato è possibile gestire la matricola ed ottenere una stampa dei movimenti delle matricole.
Per abilitare la gestione matricole occorre inserire nei parametri di personalizzazione, il parametro: MatrGest.

Una volta abilitato il parametro, in fase di inserimento di un articolo è possibile digitare o caricare da file le matricole

Per ogni articolo caricato è possibile gestire i lotti ed ottenere una stampa dei movimenti dei lotti. La gestione dei lotti è possibile se è installato il modulo di tracciabilità.

Ogni movimento si compone di due gruppi di dati, la testata e il dettaglio degli articoli che si intende movimentare.

Per inserire un nuovo movimento basta digitare 0 nel campo Numero Movimento, compilare la causale e gli altri campi della testata poi premere il pulsante [image] (E) Gestione Dettagli, per passare all'inserimento dei dettagli. Se si desidera rimanere in inserimento, dopo aver inserito un nuovo movimento, occorre impostare il flag di personalizzazione: NoInsAutom = N

In variazione possono essere variati tutti i dati di testata, se la variazione comporta una variazione sull'aggiornamento delle righe di dettaglio, tutti i dettagli verranno disaggiornati e riaggiornati.

In caso si ottenga il messaggio 'dati in uso' occorre premere il tasto di annullo delle variazioni fatte.

Nella variazione di un movimento registrato in precedenza, è possibile variare tutti i dati in esso contenuti, compreso il codice dell'articolo. Questo è reso possibile dal fatto che il programma, ripristina nell'articolo, la situazione precedente alla movimentazione (eccetto il costo ultimo e il medio ponderale).

Per ulteriori spiegazioni sui pulsanti, si rimanda a Pulsanti in gestione movimenti e documenti.

Vedi anche:
Caricamento Movimenti di Magazzino (Dettagli)
Caricamento Movimenti Articoli con Livelli
Movimenti di Trasformazione
Distinta Base
Lotti (Tracciabilità)

Parametri di personalizzazione gestiti da questa funzione

ChiediMagScarico
In presenza di distinta base, se questo parametro vale S, in corrispondenza a un movimento di carico di un prodotto finito, viene chiesto da quale magazzino scaricare gli articoli componenti, altrimenti si utilizza lo stesso magazzino del movimento di origine.

CausVerif, nella forma: caus1;caus2;
Contiene l'elenco delle causali per le quali si vuole gestire questo parametro che consente di avere, su ogni movimento di magazzino, il flag di movimento 'Testato'.
(Questo flag può essere utilizzato ad esempio per dire su quali Bolle di carico è stato già messo il prezzo e su quali no)

Testata

Numero movimento
Ogni movimento è individuato da un numero progressivo all'interno dell'anno gestito direttamente dal programma. Per inserire un nuovo movimento basta lasciare a 0 il numero, compilare gli altri campi della testata e salvare.

Se invece viene digitato un numero, il programma cerca in archivio il movimento (se non viene impostata la data si cerca l'ultimo) e lo si presenta per la variazione.

Anno - Data movimento (registrazione)
L'anno proposto in creazione viene definito in base alla data del movimento, all'anno del magazzino e all'intervallo determinato da data inizio e data fine esercizio di magazzino (Tabella di Magazzino). Se la data del movimento è precedente a tale intervallo l'anno verrà impostato come anno di esercizio di magazzino-1, viceversa, se è successiva, come anno+1.

Non si consente l'inserimento di movimenti con date minori di due anni rispetto quelle in tabella di magazzino.

Data movimento: è la data di registrazione del movimento. In creazione viene proposta quella del giorno e può essere variata.

E' la data che serve per l'ordinamento dei movimenti sul giornale e sui partitari.

Numero e Data documento
Sono rispettivamente numero e data del documento che ha generato il movimento (ddt, fattura). Nel caso di movimenti inseriti dal magazzino, il numero può essere lasciato a 0 mentre la data viene impostata con la data del giorno e può essere variata.

Tipo documento
Viene impostata automaticamente se il movimento è stato generato da Fatturazione, in ogni caso non è obbligatorio.

Causale
Decodifica dalla tabella Causali di magazzino. E' la causale che caratterizza il movimento. In base alla causale verranno aggiornati certi progressivi e verrà chiesto il codice di un cliente, di un fornitore ….

A seconda di quanto è stato impostato sulla causale come Unità da .. o Unità a .. dovrà essere digitato dall'operatore in questi due campi un cliente, un fornitore o un magazzino (o niente) salvo per i movimenti di trasformazione dove dovranno essere chiesti sempre 2 magazzini.

Sarebbe bene se in corrispondenza al campo dove ci si aspetta un magazzino, venisse impostato il magazzino di default da tabella.

Una volta inserito il codice del cliente o fornitore viene visualizzato, se previsto dalla causale in 'Importo da presentare in caricamento movimenti' e se valorizzato in anagrafica, il codice del listino.

Provenienza e Destinazione non potranno essere mai nulli entrambi.

Se si sta inserendo un movimento interno, viene reso disponibile un campo Cliente/Fornitore da intendersi come l'eventuale destinatario della merce nel movimento (esempio: in un ddt interno per l'invio di merce in lavorazione, il destinatario sarà un fornitore ma la merce può transitare da un magazzino principale a uno, fittizio, di merce in lavorazione in modo da potere, in ogni momento, sapere quanto è stato consegnato e quanto è ritornato).

Codice Listino

Indica il codice del listino dal quale prelevare il valore unitario dei movimenti.

Se la causale del movimento prevede che l'importo unitario venga prelevato dal listino e si tratta di un movimento a cliente o a fornitore, viene proposto il listino dell'anagrafica, se esiste, viceversa quello principale. Deve esistere nella Tabella Listini.

Se invece il movimento prevede che il prezzo venga dall'ultimo costo etc. il listino non sarà gestibile.

Se è prevista la gestione dell'archivio Articoli/Fornitore (da tabella di magazzino) il costo ultimo viene cercato in tale archivio.

Viene impostata la moneta e il cambio in automatico dal listino.

Se il listino è ivato (o da pulsante si è scelto prezzi ivati), verranno visualizzati prezzo unitario e importo totale di riga sia ivati sia scorporati. I campi con i valori scorporati non si possono variare.

Se il listino prevede uno sconto o uno sconto articolo, il prezzo visualizzato sarà già al netto dello sconto.
Su ogni riga di dettaglio, per cambiare modalità in cui sono espressi i prezzi: da prezzi ivati a non e viceversa, è previsto il pulsante F8.

Se il listino è in valuta verrà visualizzato e gestito anche:

codice valuta, cambio e data cambio
La data verrà visualizzata, solo in inserimento, per dare modo di vedere a quando risale il cambio proposto.

Se il cambio è già impostato e si desidera rileggerlo dalle tabelle in base alla data movimento, occorre premere il pulsante di aiuto posto a fianco ad esso.

Se la moneta è Cee, il cambio viene letto dalla tabella cambi e non è gestibile.

Valore spese per calcolo costo ultimo
(Campo valido solo per i movimenti di carico merce che aggiornano il costo ultimo)
In questo campo potrà essere inserito un importo o una percentuale (vedi parametro di personalizzazione: RipartSpesePercVal)
A seconda di quanto dichiarato sulla Causale del movimento, l'aggiornamento del Costo Ultimo degli articoli caricati terrà conto anche del valore inserito in questo campo.

Variazione testata:

Se si entra in variazione della testata e si salva, se si è variato: causale, cambio, provenienza e destinazione (solo se magazzino), viene effettuato il disaggiornamento e il riaggiornamento dei progressivi.

Se si modifica il codice listino direttamente o perché si varia la causale per cui si passa da gestione dei prezzi dal listino a un costo o perché si varia la moneta, si avranno le seguenti combinazioni:

  1. cambia la moneta da Euro a Lira o viceversa: viene richiesto se si vuole rileggere il prezzo dall'archivio richiesto (o dai listini o dai costi), se convertire gli importi inseriti mediante il valore del cambio oppure se lasciare gli importi inalterati (in questo caso sarà l'operatore a variare i prezzi che non hanno più senso).
  2. cambia il listino (non lasciato vuoto), non cambia la moneta oppure ne' la moneta precedente ne' quella attuale è Euro: Viene richiesto se si vuole rileggere il prezzo dal Listino
  3. Variato il listino (non lasciato vuoto), cambiata la moneta e o la moneta precedente o quella attuale è Euro: Viene richiesto se si vuole rileggere il prezzo dal Listino oppure se si vuole convertire gli importi inseriti mediante il valore del cambio
  4. Cambiata la moneta ma non c'è nessun listino nel nuovo salvataggio, o c'è il listino e la moneta precedente o quella salvata sono Euro: viene richiesto se si vuole rileggere il prezzo (in questo caso può essere letto solamente dai costi) oppure se si vuole convertire gli importi inseriti mediante il valore del cambio. Se invece c'è un listino e si mette una moneta diversa viene dato un messaggio di errore.

Negli altri casi i dettagli non vengono modificati.

Una volta terminato l'inserimento della testata, si può iniziare a inserire i dettagli dopo aver premuto il pulsante SALVA
oppure [image] (E) Gestione Dettagli .


CARICAMENTO MOVIMENTI DI MAGAZZINO (DETTAGLI)

Percorso: Magazzino - Movimenti

Per l'utilizzo dei pulsanti vedere Gestione movimenti e documenti.

Caricamento movimenti da file (Caricamento dettagli documenti da file).
E' possibile, configurando opportuni parametri, (in particolare LettArtDaFile) , compilare automaticamente un movimento di magazzino, leggendo da file le varie righe di dettaglio. L'operazione avviene cliccando sull'icona [image] (B) Lettura da file Ascii che compare nella maschera di Gestione dettagli

Gestione matricole sulle righe articolo:
Se è stata abilitata la gestione delle matricole è abilitato un ulteriore pulsante: (J) Gest.matricole
Se è stato abilitato il caricamento degli articoli/matricole (dettagli) da file è presente un ulteriore pulsante:
(Q) Lett.matricole da file

Gestione lotti (tracciabilità)

Gestione Raee

Codice e descrizione articolo
Con F9 si attiva il pulsante per cambio modalità di ricerca dell'articolo (codice/descrizione o codice a barre).
La ricerca dell'articolo avviene con i tasti F2 (codice), F3 (descrizione), F4 (codice a barre), come specificato in Lista di aiuto (ricerca codice)
Se è attiva la gestione dei Livelli vedi anche Caricamento movimenti di articoli con livelli.

Se si sta facendo la ricerca per codice a barre, è possibile attivare il parametro di personalizzazione: CodBarSalva in modo che, in inserimento, all'uscita del campo articolo venga salvata la riga e si passi ad un altro inserimento. Ovviamente è indispensabile che sull'articolo siano compilati tutti i campi necessari (unità di misura, codice iva etc.) e che sia stato definito il parametro Qtadef per impostare in automatico le quantità sulla riga.

Una volta scelto l'articolo, viene visualizzata l'unità di misura di acquisto o vendita a seconda che nel movimento ci sia un cliente o un fornitore (si tratti di un movimento di carico o di scarico) e il relativo fattore di conversione.

Se si cambia l'unità di misura il programma esamina se è quella di acquisto o vendita dell'articolo per ricavarne il fattore di conversione, in ogni modo quest'ultimo dovrà essere verificato dall'operatore.

La quantità che verrà digitata dovrà essere quella relativa all'unità di misura data e verrà automaticamente trasformata nella quantità reale da aggiornare il magazzino.
Se la quantità viene lasciata a 0, verrà posto il valore totale uguale al valore unitario.
E' possibile attivare il parametro di personalizzazione QtaDef per impostare un valore da attribuire al campo, es. 1

La Quantità che aggiorna il magazzino viene calcolata moltiplicando la quantità digitata per il fattore di conversione per cui è diversa se l'unità di misura del movimento non è quella principale dell'articolo.

E' modificabile dall' operatore e, se modificata, verrà ricalcolata la quantità del movimento in base al fattore di conversione.

In caso di Gestione Taglie/Colori non si permette di variare l'unità di misura né il fattore di conversione ma si prende quella in archivio di magazzino (di acquisti o di vendita) con il rispettivo fattore di conversione e si aggiorna il magazzino con le quantità trasformate.

Valore unitario
Verrà visualizzato il prezzo di listino o il costo ultimo o medio di carico secondo quanto indicato nella causale.
Se esiste, nel listino del movimento, un prezzo promozione per l'articolo in uso, valido nella data del movimento, verrà proposto quel prezzo ed eventualmente verrà dato il messaggio previsto nella promozione.

Se sull'anagrafica articolo è stato impostato uno sconto e nel listino è previsto uno sconto (che somma o sostituisce quello articolo), il prezzo proposto terrà conto di questi sconti.

Se il listino è ivato (o da pulsante si è scelto prezzi ivati), verranno visualizzati il prezzo e totale ivato e prezzo e totale scorporato. I campi con i valori scorporati verranno disabilitati.

E' possibile abilitare il parametro di personalizzazione: PulsLordoNetto=S che consente all'operatore di inserire un prezzo lordo e il programma calcolerà il prezzo netto applicando lo sconto impostato sul listino collegato al movimento (utile nel carico merce da fornitore).

Se per l'articolo non viene trovato nessun prezzo, ed è stato attivato il parametro di personalizzazione CercaListBase, il programma cerca il prezzo sul listino Base (quello indicato nella tabella di Magazzino, parametri comuni).

Sul campo sono abilitati alcuni tasti funzione:

  • F8 consente di passare da prezzi non ivati a ivati e viceversa.
  • F2 su questo campo (o il pulsante con i .. a fianco al campo) consente di rileggere il prezzo dagli archivi secondo le modalità stabilite dalla causale.
  • F3 su questo campo consente di visualizzare la lista dei prezzi di listino codificati per l'articolo in oggetto. Una volta ottenuta la lista dei prezzi del prodotto, è possibile, quando si è posizionati su una riga della lista, accedere con un click sull'icona [image], alla gestione di quel listino per la variazione del prezzo.
    Può, in questo caso, essere utile settare il flag di personalizzazione HlpSpost a 3 (spostamento riga in help con passaggio mouse: mai)

E' possibile abilitare il parametro di personalizzazione ListAcqDaAgg per aggiornare, durante l'inserimento dei movimenti di acquisto un listino di acquisto col prezzo unitario della riga.

E' possibile abilitare il parametro di personalizzazione ListVenDaAgg per aggiornare, durante l'inserimento dei movimenti di acquisto, un listino di vendita col prezzo unitario della riga maggiorato di una percentuale di maggiorazione scritta sul fornitore o sull'articolo.

Valore Totale
E' il prodotto tra il valore unitario e la quantità del movimento. Se viene digitato il valore totale e il valore unitario è bianco, quest'ultimo viene calcolato.

Nota
Se movimento è di trasformazione, alla conferma dei dettagli si chiede di digitare il magazzino su cui fare il secondo movimento.

Quantità per etichette:
In questo campo l'utente può digitare il numero di etichette da stampare in corrispondenza a questa riga di movimento. Verrà utilizzato dalla stampa etichette se si sceglie di stampare le etichette degli articoli presenti in un determinato movimento di magazzino. Se si lascia bianco questo campo, il numero di etichette stampato per ogni articolo sarà pari alla quantità della riga.
Se, in corrispondenza di una riga, non si vuole stampare nessuna etichetta, occorre mettere in questo campo un numero negativo.

IN CASO DI INTERRUZIONE:
è indispensabile eseguire dal menu di Servizio di magazzino la funzione Gestione movimenti interrotti.
Verranno elencati i movimenti che risultano in elaborazione (possono essere effettivamente in elaborazione da altri terminali oppure rimasti lì perché interrotti).
Prima di riabilitare o annullare un movimento verificare che sia veramente 'interrotto'.

Nel caso di interruzione durante la duplicazione di un gruppo di righe di dettaglio, può succedere che eseguendo l'utility di ripristino rimangano sul movimento sia le righe originali sia quelle duplicate, in questo caso occorre, una volta fatto il ripristino ricontrollare il movimento e la situazione degli articoli coinvolti.

AGGIORNAMENTI
Se «l'articolo» non è un articolo NON vengono movimentate le quantità

Se da tabella di magazzino si prevede l'aggiornamento del fornitore abituale, ad ogni acquisto verrà memorizzato sull'anagrafica articolo, il codice del fornitore sostituendolo al precedente e se è prevista la gestione dell'archivio Articoli/fornitore, in verrà aggiornato l'ultimo costo dell'articolo per il fornitore del movimento.

Se sulla causale di magazzino viene messo a nullo il flag di Carico/Scarico, verrà aggiornata solo la quantità aggiuntiva segnalata sulla causale e nient'altro!!!

Sul movimento di magazzino viene memorizzato, se è uno scarico e la causale prevede la valorizzazione del costo dello scarico, il costo UNITARIO in base a quanto previsto sulla causale.

Aggiornamento ANNO -Articolo- Magazzino
se il Flag Carico/Scarico è nullo non fa niente sulle quantità principali ma solo sulle quantità aggiuntive
Quantità e valore iniziale: vengono incrementati dai movimenti di carico inventario.
Sia i progressivi che i costi vengono aggiornati in base a quanto specificato sulla causale di magazzino.

Esempi di codifica corretta causali:

 |  | Provenienza | Destinazione
Carico da fornitore | Carico + | Fornitore | Magazzino
Reso a Fornitore | Carico - | Fornitore | Magazzino
 | Scarico + | Magazzino | Fornitore
Vendita | Scarico + | Magazzino | Cliente
Reso da Cliente | Scarico - | Magazzino | Cliente
 | Carico + | Cliente | Magazzino

Aggiornamento costi articolo
A seconda di quanto previsto nella causale del movimento, vengono aggiornati o meno i costi dell'articolo: costo ultimo, più alto, medio ponderale. Per quanto riguarda il medio ponderale, questo risulterà corretto solo se i movimenti che lo modificano saranno fatti nella sequenza temporale corretta e non verranno variati.

Se un movimento ha quantità o valore unitario a zero, non verrà aggiornato, anche se la causale lo prevede, l'ultimo costo.

Per quanto riguarda le modalità di aggiornamento dei costi si rimanda a quanto scritto nella gestione causali di magazzino.

NOTE SULL'INSERIMENTO DI MOVIMENTI PARTICOLARI

  • MOVIMENTI DI CARICO GIACENZA INIZIALE
    Servono per caricare la giacenza e il valore iniziale degli articoli sui vari magazzini.
    Se la causale utilizzata prevede la movimentazione di una quantità aggiuntiva, avverrà l'aggiornamento della quantità iniziale della SOLA quantità aggiuntiva!!
    Per cui la causale utilizzata per il caricamento della giacenza iniziale non deve aggiornare nessuna quantità aggiuntiva.
  • MOVIMENTI INTERNI
    Consentono di spostare gli articoli da un magazzino ad un altro.
    Si intende Scarico dal magazzino indicato in Unità da .. e Carico in magazzino indicato in Unità a ..
  • MOVIMENTI DI TRASFORMAZIONE
    Consentono di trasformare un articolo A in un altro B, scaricando A e caricando B. L'operazione può avvenire sullo stesso magazzino o su magazzini diversi. Per effettuare la trasformazione occorre che nell'anagrafica dell'articolo A siano stati compilati i campi articolo trasformato, operatore per la trasformazione, coefficiente di trasformazione.
    La movimentazione dell'articolo A viene fatta secondo quanto specificato nella causale di trasformazione. Viene inoltre creato un secondo movimento, con causale presa dal campo causale collegata per trasformazione, della prima, per movimentare l'articolo B.
    La causale collegata deve essere di tipo 'normale'.
    La causale di trasformazione e quella collegata, dovranno avere M in Unità da .. o in Unità a .. a seconda della logica e cioè se faccio uno scarico del prodotto principale e un carico del trasformato avrò sulla prima causale M in Unità da .. e sulla seconda M in Unità a .. (o viceversa se carico con la principale e scarico con l'altro).
    Sul movimento di trasformazione si potrà impostare un solo magazzino, che è quello su cui avviene la movimentazione dell'articolo da trasformare, al termine dell'inserimento del movimento verrà chiesto il magazzino per il secondo movimento.

    La quantità del secondo movimento sarà calcolata in base al coefficiente di trasformazione impostato nei dati anagrafici del primo articolo.
    Il valore del secondo movimento è quello del primo movimento. Nel secondo movimento l'unità di misura è la principale dell'articolo del movimento e il fattore di conversione è 1.

    Una volta generati i due movimenti, in caso di variazione o annullamento, dovranno essere gestiti in modo indipendente l'uno dall'altro.
    ES.
    Da una matassa di cavo ottengo 50 Spezzoni:
    Art. Princ.: Matassa Coeff. 50 Operatore / Art. Trasf. Spezzoni oppure
    Art. Princ.: Spezzoni Coeff. 50Operatore * Art. Trasf. Matassa
    Oppure :
    Lo scarico di Mq. X di legno di un certo tipo provoca il carico di Mq. Y di assi lavorate.


CARICAMENTO MOVIMENTI DI ARTICOLI CON LIVELLI

Percorso: Magazzino - Movimenti - Caricamento movimenti dettagli

Se è prevista la gestione dei livelli (Taglia-Colore) in tabella di Magazzino e l'articolo ha i livelli, viene data la possibilità di inserire la quantità per ogni singola unità gestita. Una volta inserito il codice dell'articolo non si può passare direttamente all'inserimento della quantità ma occorre premere il pulsante opportuno, vedi Gestione Livelli, in modo da passare alla maschera di Gestione Dettaglio Livelli nella quale dovranno essere elencati i 'livelli' da caricare o scaricare, con quali quantità e valori.

Se si modifica il codice articolo con livelli sul dettaglio, vengono cancellate tutte le sue righe dei livelli e sarà necessario entrare nella gestione dei livelli per reinserirle.


MOVIMENTI DI TRASFORMAZIONE

Percorso: Magazzino - Movimenti - Caricamento movimenti

Il movimento di trasformazione di un articolo A determina la sua movimentazione (di carico o scarico a seconda di quanto specificato nella causale di trasformazione) e quella dell'articolo B collegato (letto dall'anagrafica di A o inserito a video) secondo quanto specificato nella causale collegata alla prima.

La causale collegata alla causale di trasformazione, deve essere obbligatoriamente di tipo 'Normale'

La trasformazione avviene tramite i parametri specificati nei dati anagrafici dell'articolo A oppure scritti a video nel momento dell'inserimento del movimento.

La causale di trasformazione e quella collegata, dovranno avere il Magazzino in Unità da .. o in Unità a .. a seconda della logica e cioè se si fa uno scarico del prodotto principale e un carico del trasformato si avrà sulla prima causale M in Unità da .. e sulla seconda M in Unità a .. (o viceversa se si carica con la principale e scarica con l'altra).

La quantità del secondo movimento verrà calcolata in base al coefficiente di trasformazione impostato nei dati anagrafici del primo articolo (o inserito a video)

Il valore del secondo movimento è uguale a quello del primo movimento. Nel secondo movimento l'unità di misura è quella principale letta dall'articolo del movimento e il fattore di conversione è 1.

Una volta generati i due movimenti, in caso di variazione o annullamento, dovranno essere gestiti in modo indipendente l'uno dall'altro.

L'uscita (o l'entrata) dal mag1 dell'articolo A determina l'entrata (o l'uscita) nel mag1 dell'articolo B trasformato di A (B è scritto dentro A e la trasformazione avviene tramite i parametri specificati nei dati anagrafici dell'articolo A).

In questo modo i due magazzini verranno presi per i due movimenti (vedere se nell'ordine o con criterio a seconda di carico/scarico)

ES. Da una matassa di cavo ottengo 50 Spezzoni:

Art. Princ.: Matassa Coeff. 50 Operatore / Art. Trasf. Spezzoni oppure

Art. Princ.: Spezzoni Coeff. 50 Operatore * Art. Trasf. Matassa


CARICAMENTO MOVIMENTI MAGAZZINO-MATRICOLE

Percorso: Magazzino - Movimenti

Caricamento movimenti - Dettagli movimenti
Se è stata abilitata la gestione delle matricole (parametro di personalizzazione: MatrGest) , nella maschera dei dettagli, è abilitato il pulsante:
(J) Gest.matricole

Inoltre se è stato abilitato il caricamento degli articoli/matricole (dettagli) da file (parametro di personalizzazione: LettMatrDafile) è presente sulla maschera un ulteriore pulsante:
(Q) Lett.matricole da file

Per ulteriori dettagliate sulla Gestione matricole, vedere il paragrafo: matricole.


CARICAMENTO DETTAGLI DOCUMENTI DA FILE

Nei programmi:

  • Caricamento movimenti di magazzino
  • Inserimento preventivi, ordini di vendita e di acquisto
  • Ddt e fatture
  • Inserimento inventario manuale

è possibile caricare le righe degli articoli interessati (codice, quantità e prezzo) leggendoli da file (oltre che manualmente). L'anagrafica degli articoli dovrà essere stata caricata in precedenza, nel caso che un articolo presente su file non venga trovato in anagrafica, il programma lo segnala in modo tale che l'operatore lo possa creare e possa proseguire con il caricamento delle righe successive.

Per attivare, sulla maschera delle funzioni suddette, il pulsante che consente di caricare gli articoli da file, occorre impostare il parametro di personalizzazione: LettArtDaFile valore S e Gruppo: carmov, acquisti, preventivi, ddt, ordini, fatture a seconda del programma dove lo si vuole attivare.

I programmi per i quali verrà attivato il parametro, una volta che l'utente ha compilato i dati iniziali del documento (dati di testata) e preme F10 per entrare nei dettagli e inserire gli articoli, presenteranno una ulteriore icona in alto a destra: (B) Lettura da file Ascii

Per definire da quale file leggere i dati e il formato in cui leggerli, dovrà essere inserito un apposito paragrafo sull' aziwin.ini generale, se si tratta di una installazione monoutente o i parametri sono uguali per ogni terminale, oppure sull' aziwin.ini di ogni terminale.

Il nome del paragrafo è: [LettArtDaFile]

Possono essere presenti più paragrafi che iniziano con il nome LettArtDaFile seguito da altre lettere es. [LettArtDaFileSepApici]

Questi servono se c'è la necessità di leggere da file con formato diverso, ad esempio, in caricamento movimenti si legge la merce arrivata da un fornitore da un file di un certo tipo mentre per la vendita (ordini, ddt etc) si legge da un file prodotto da un terminale, che ha un altro formato.

La ricerca dei vari parametri del suddetto paragrafo avviene, come sempre, prima sull'ini personalizzato poi su quello generale. Il paragrafo perciò potrebbe essere presente in entrambi, la parte comune sull'ini generale e sui personalizzati la parte variabile per ogni terminale (es. nome del file da cui leggere i dati)
Nei vari programmi interessati, se si clicca con il pulsante destro sull'icona [image] 'Lettura da file Ascii', nel caso siano stati definiti più paragrafi 'LettArtDaFilexxx' per letture di file di diverso tipo, verrà presentato un elenco:
Selezione parametro per caricamento file
con le descrizioni che in ogni paragrafo compaiono nel parametro:
Descr= e l'utente potrà scegliere quale utilizzare per il caricamento in quel particolare momento.

I campi che si possono caricare dal file sono:

  • codice (codice articolo o codice a barre)
  • quantità
  • valore unitario (opzionale)
  • valore totale(opzionale)

L'importo totale è prioritario sull'importo unitario, se sul file ci sono entrambi, verrà caricato il totale e l'unitario viene calcolato dividendo per la quantità. Se dal file legge un importo a 0, l'importo verrà cercato sugli archivi come se il movimento fosse inserito manualmente.

Nell' Aziwin.ini di ogni terminale è possibile inoltre, mettere la sezione [NomiParagLettFile] per definire, per ogni programma nel quale si vuole utilizzare il caricamento da file, quale deve essere il paragrafo che contiene le caratteristiche.

[NomiParagLettFile]
carmov=LettArtDafileSepApici
ddt=LettArtDaFileFisso

a indicare che le caratteristiche del file che si caricherà in Caricamento movimenti sono quelli descritti nell'ini nel paragrafo: LettArtDafileSepApici mentre quelle del file per ddt sono contenute nel paragrafo: LettArtDaFileFisso

Descrizione dei parametri contenuti nel paragrafo [LettArtDaFile]

Descr=AAAA Dove AAAA descrive a quale tipo di file si riferiscono i parametri successivi.
Es. Modello base
Tramite questa descrizione, se sono stati impostati più paragrafi LettArtDaFile, si potrà capire quale scegliere all'interno di ogni programma che consente la lettura, quando, posizionandosi col mouse sull'icona di importa dati e, premendo il pulsante destro, si otterrà l'elenco di tutte le descrizioni.

Se in un paragrafo manca questa variabile descrittiva, alla richiesta dell'elenco delle possibilità di caricamento, il programma mostrerà il nome del paragrafo stesso.

FileOrigine=c:\ScarPen\dati.dat
E' il nome del file che contiene i dati da caricare per quel computer

FissoSep=
Serve per dire com'è fatto il file dati.
Il default è F lunghezza fissa
Altri valori sono S con separatori, A ogni campo è compreso tra apici e c'è la , "virgola" che separa i campi (formato dei file .csv)

Separatore =
Nel caso che il file sia con separatori, va specificato il codice ascii del carattere 'separatore', se questo è compreso nell'intervallo 0<codice<256, oppure il carattere stesso (es. se il separatore è il TAB si dovrà impostare il parametro a 9)
Se il file è con separatori e manca questo parametro non sarà possibile abilitare il caricamento da file e non verrà visualizzata sul programma l'icona che consente il caricamento.

PreCodInizio= CodInizio= QtaInizio= ImpUniInizio= ImpTotInizio=
Sono obbligatori, per ogni campo che devo leggere, qualsiasi sia il formato.
Se il file è a lunghezza fissa, indicano il punto d'inizio rispettivamente del campo codice, quantità, valore unitario, valore totale.
Negli altri due formati indicano la posizione (colonna) in cui si trova il campo sul file.
PreCodInizio fa riferimento ad un eventuale campo che, se letto, diventerà la prima parte del codice articolo, in pratica il codice articolo verrà formato da PreCodice+Codice

PreCodLung= CodLung= QtaLung= ImpUnitLung= ImpTotLung=
Sono obbligatori solo se il file è a lunghezza fissa. Indicano il numero dei caratteri occupati da ciascun campo.

CodArtSeqRic=
(es.: "BC")

Indica la sequenza con la quale si fa la ricerca degli articoli.

  • B = codice a barre
  • C = codice articolo

Se manca questo parametro, il programma parte cercando in archivio un articolo con codice a barre uguale a quello letto dal file, se non lo trova cerca con codice articolo.
Se si vuole prima la ricerca per codice articolo basta mettere il parametro = "CB", se si mette una lettera sola, cerca solo in quella modalità.

Se però il codice letto inizia per la sequenza scritta in:
CodArtInizIdent = "XXX"(parametro non obbligatorio)
significa che sto leggendo un codice articolo e il parametro precedente perde significato.
Ha senso usare questo parametro solo nel caso che ci siano articoli con codice uguale al codice a barre di un altro articolo. In questo caso la ricerca sarebbe ambigua per cui questi articoli dovranno essere ricercati sempre per codice e sul file il loro codice dovrà essere preceduto dalle lettere scritte nel parametro.

AddArtPrima
Lettere che il programma mette davanti al codice articolo letto sul file, prima di cercarlo in archivio

AddArtDopo
Lettere che il programma mette in fondo al codice articolo letto sul file, prima di cercarlo in archivio

CancFile =
Serve per dire se alla fine del caricamento il programma deve cancellare o meno il file caricato. I valori possibili sono:

  • S (Si)
  • N (No)
  • C (Chiedi)
    è il valore di default e al termine del caricamento verrà posta la domanda all'operatore: Vuoi cancellare il file caricato?

ExePrima= esempio c:\ScarPen\RiceviDir.bat
Questo parametro consente di lanciare un programma prima del caricamento.
Serve nel caso che il file da caricare debba essere prima elaborato o semplicemente scritto su disco perché contenuto in una penna/calamaio/terminalino. Quando termina l'elaborazione richiesta l'utente riceve un messaggio di OK.
Ovviamente il programma lanciato sarà diverso a seconda delle esigenze.

Esempi di utilizzo:

L'utente dispone di un terminalino ottico (es. BHT 8044) con il quale legge i barcode (o il codice) degli articoli da inserire nel documento e digita la quantità poi deve preparare il ddt o la fattura accompagnatoria sul computer.
In questo caso dovrà essere creata una cartella c:\BHT che dovrà contenere i file:

  • Ricevi.bat dal contenuto:
    c:
    cd \bht
    BHTManager /RX:C:\bht
  • BHTManager.exe

inoltre nell'aziwin.ini si dovrà inserire la sezione con le specifiche del
file da caricare, a lunghezza fissa:
[LettArtDafile]
Descr=Lettura da BHT
FileOrigine=c:\bht\dati.dat
CodInizio=1
CodLung=30
QtaInizio=31
QtaLung=5
CancFile="C"
ExePrima=c:\bht\RiceviDir.bat

(Far riferimento alla documentazione del terminalino per i dettagli di utilizzo)

Una volta raccolti i dati sul terminalino, esso verrà collegato al computer per consentirne la lettura.

L'utente imposterà la testata del ddt e, una volta entrato nei dettagli con F10, potrà premere il pulsante
(B)Lettura da file Ascii

Il programma leggerà dal terminalino gli articoli e il dettaglio del ddt verrà compilato in automatico.

Se manca qualche dato, il programma lo compilerà leggendolo dagli archivi (nel caso specifico: il prezzo di vendita che non ha letto sul terminalino), se ci saranno su una riga dei dati mancanti, verrà dato un messaggio e si consentirà di completarli poi si prosegue con il caricamento dell' articolo successivo.

Allo stesso modo, sul programma di Caricamento movimenti di magazzino, si può fare uno scarico merce o un carico di inventario iniziale o il carico della merce disponendo del file del ddt (o fattura) fornito dal fornitore.

Esempio di paragrafo per file con separatori

[LettArtDaFile]
Descr=Modello base (separatore TAB)
FileOrigine=c:\dati\dati.dat
FissoSep="S"
Separatore = 9
CodInizio=1
QtaInizio=2
' se ci sono importi abilito i campi corrispondenti
'ImpUniInizio=3
'ImpTotInizio=4
CancFile="C"
'ExePrima=c:\procopy\scomp\RiceviDir.bat
'CodArtInizIdent = "QR"
'CodArtSeqRic="BC"

Esempio di paragrafo per file a lunghezza fissa

[LettArtDaFileFisso]
Descr=Modello a lunghezza fissa
FileOrigine=c:\dati\dati.dat
FissoSep="F"
CodInizio=1
CodLung=30
QtaInizio=31
QtaLung=5
' se ci sono importi abilito i campi corrispondenti
'ImpUniInizio=
'ImpUniLung=
'ImpTotInizio=
'ImpTotLung=
CancFile="C"
'ExePrima=c:\procopy\scomp\RiceviDir.bat
'CodArtInizIdent = "QR"
'CodArtSeqRic="BC"

Esempio di paragrafo per file con campi separati da apici

[LettArtDafileSepApici]
Descr=Modello con separatore apici
FileOrigine=f:\procopy\PPbolla00286074.csv
FissoSep="A"
CodInizio=1
QtaInizio=4
' se ci sono importi abilito i campi corrispondenti
ImpUniInizio=5
'ImpUniLung=
'ImpTotInizio=
'ImpTotLung=
CancFile="N"
'ExePrima=c:\procopy\bht\scomp\RiceviDir.bat
'CodArtInizIdent = "QR"
'CodArtSeqRic="BC"


DISTINTA BASE

Il modulo gestisce una distinta base di 'n' livelli integrata con il magazzino.

La valorizzazione e lo scarico della distinta di un articolo avvengono in tempo reale con i movimenti di magazzino.

Per attivare questo modulo occorre dichiarare la Distinta base tra le procedure installate (Parametri e utilità, Dati Generali azienda).

In gestione articoli verrà presentata un'ulteriore etichetta ' DiBa' che consentirà di elencare i componenti dell'articolo in oggetto, quando questo sia un Prodotto Finito o un Intermedio (campo Distinta Base) Vedi Articoli - distinta base
Esempio:
X1
/ | \
X2 X3 X4
/ \
X5 X6
X3, X5, X6, X4 devono essere definiti: materiali di base
X2 semilavorato (prodotto intermedio)
X1 prodotto finito
(Per ora non è possibile definire i componenti dei livelli (Gestione taglia-colore) ma solo dell'articolo)

Una volta impostata la distinta base di un articolo, è possibile movimentarla con causali opportune di magazzino:

  • dai movimenti di magazzino
    (carichi dei prodotti finiti e relativi scarichi in automatico dei componenti, scarico di prodotti finiti con relativo carico 'valorizzato' degli stessi e scarico dei componenti.
  • dalle vendite (ordini , ddt, fatture)
    Ordini: all'inserimento dell'ordinato di un prodotto finito si possono mettere in ordine i suoi componenti in automatico
    Ddt e fatture: lo scarico di un prodotto finito

Distinta movimentata da
MOVIMENTI DI MAGAZZINO

Con la funzione Caricamento movimenti di Produzione è possibile preparare un movimento di carico di un prodotto finito e di scarico dei suoi componenti assegnando ad ogni articolo il lotto relativo.

Se si movimenta un articolo definito 'prodotto finito', con il programma di Caricamento movimenti di magazzino e una causale opportunamente compilata, è possibile far creare in automatico al programma anche il movimento di scarico di tutti i suoi componenti.

Carico da produzione di un prodotto finito
Preparazione delle causali di magazzino - servono due causali:
'Scarico componenti' - provenienza: magazzino - destinazione: niente, eventualmente si può indicare in essa il magazzino da cui scaricare i componenti. In mancanza di questo codice, il magazzino di scarico dei componenti verrà chiesto a video, se è stato impostato il parametro di personalizzazione ChiediMagScarico, oppure si prenderà quello del movimento di produzione.
'Carico da produzione' - provenienza: niente - destinazione: magazzino. Nel campo 'causale collegata per DiBa' dovrà essere messo il codice della causale 'Scarico componenti'

L'operatore inserirà un movimento di carico da produzione del prodotto finito per la quantità prodotta, se il valore non viene specificato, il programma imposterà automaticamente il valore uguale alla somma dei valori di scarico dei componenti.
In automatico verrà creato un movimento di scarico di tutti i materiali di base che intervengono nella distinta dell'articolo caricato. Il valore di scarico di ogni componente viene attribuito in base a quanto è stato dichiarato nella distinta base, sulla riga del componente stesso, nel campo Quale importo.

Gli articoli intermedi non intervengono nella movimentazione.

I movimenti generati sono:

  • Carico del prodotto finito (compilato dall' operatore)
  • Scarico dei componenti (materiali di base)

Scarico di un prodotto finito con produzione automatica dello stesso
In questo caso vanno preparate 3 causali di magazzino:
'Scarico componenti' - provenienza: magazzino - destinazione: niente, eventualmente si può indicare in essa il magazzino da cui scaricare i componenti. In mancanza di questo codice, il magazzino di scarico dei componenti verrà chiesto a video, se è stato impostato il parametro di personalizzazione ChiediMagScarico, oppure si prenderà quello del movimento di produzione.
'Carico da produzione' - provenienza: niente - destinazione: magazzino. Nel campo 'causale collegata per DiBa' dovrà essere messo il codice della causale 'Scarico componenti'
'Scarico prodotto finito' - provenienza: magazzino - destinazione: cliente o magazzino o niente. Nel campo: 'causale collegata per DiBa' dovrà essere messo il codice della causale 'Carico da produzione'

Gli articoli intermedi non intervengono nella movimentazione.

I movimenti coinvolti sono:

  • Scarico del prodotto finito (compilato dall' operatore)
  • Scarico dei componenti (materiali di base)
    Il magazzino di scarico dei componenti potrà essere messo sulla causale oppure sarà lo stesso del movimento di scarico del prodotto finito, oppure, se è stato impostato il parametro di personalizzazione ChiediMagScarico, verrà chiesto a video all'operatore.
  • Carico del prodotto finito (sullo stesso magazzino dal quale l'operatore ha effettuato lo scarico e con il valore totale uguale al valore totale del movimento di scarico dei componenti)

Distinta movimentata da Vendite
ORDINI - DDT - FATTURE

ORDINI - Tipo documento Ordine
Compilare il campo 'Causale che aggiorna il magazzino' con il codice di una causale di magazzino di tipo 'Ordine' che a sua volta abbia il campo 'Causale collegata per DiBa' compilato (si può mettere la causale 'scarico componenti' descritta sopra). Il magazzino in cui mettere in ordine i componenti, se diverso da quello dell'ordine, andrà impostato sulla causale di magazzino 'scarico componenti'.

Se il tipo documento è stato codificato come descritto, alla conferma, oltre ad incrementare la quantità ordinata degli articoli in ordine, verrà incrementato l'ordinato di tutti i loro componenti definiti come 'materiale di base' (non vengono considerati gli eventuali semilavorati)
L'aggiornamento dell'ordinato dei componenti viene fatto solo per la quantità e non per il valore.

DDT e FATTURE - Tipi documento
Compilare il campo 'Causale che aggiorna il magazzino' con il codice di una causale di magazzino (di scarico)
che a sua volta abbia il campo 'Causale collegata per DiBa' compilato con una causale che farà il carico del prodotto finito
che a sua volta abbia il campo 'Causale collegata per DiBa' compilato con una causale che farà lo scarico dei componenti
(si può mettere la causale 'scarico componenti' descritta sopra).
Il magazzino da cui scaricare i componenti, se diverso da quello del documento in oggetto, andrà impostato sulla causale di magazzino 'scarico componenti'.

Se il tipo documento è stato codificato come descritto e nel documento ci sono articoli con distinta base, al momento della stampa, oltre a creare il movimento di magazzino di scarico degli articoli venduti, il programma creerà un altro movimento per lo scarico dei componenti ed eventualmente
Se il documento è ottenuto per evasione di un ordine, verrà decrementato anche il progressivo ordinato dei componenti.


TRACCIABILITA'

Questo modulo, collegato al Magazzino, da la possibilità di gestire i prodotti per lotto.

Per abilitare il modulo, una volta inserita la PassWord, occorre spuntare la casella apposita tra le procedure installate.

Sono controllate le problematiche di scadenza e di rintracciabilità dei lotti relative al controllo della qualità.

In fase di carico merce (acquisto) è possibile indicare il numero del lotto fornitore, la data di scadenza, una descrizione etc.
In fase di scarico di un articolo gestito a lotti la procedura provvede automaticamente, se l'utente lo desidera, al controllo delle quantità disponibili sui lotti assegnando il lotto sulla base delle date di scadenza più vicine.

Sono stati previsti alcuni parametri di personalizzazione che caratterizzano l'operatività nelle varie fasi: vedere parametri di personalizzazione Tracciabilità

  • Lotti obbligatori o facoltativi per il singolo articolo
  • Anagrafica lotti con descrizione, indicazione di una eventuale data di scadenza etc.
  • Movimentazione di magazzino per lotto (in entrata e uscita) con liste di aiuto per facilitare la ricerca/scelta dei lotti in uscita - Caricamento movimenti di produzione con lotto
  • Situazione articoli per lotto
  • Stampa dei lotti sui ddt e sulle fatture
  • Programmi di utilità per cancellazione lotti etc.

I programmi interessati al modulo sono, oltre alla gestione articoli, il caricamento movimenti di magazzino e l'inserimento e stampa di ddt e fatture. Inoltre sono state predisposte stampe e programmi di utilità.

Alcune note generali sulla operatività

Se per l'articolo non è prevista la gestione dei lotti, i programmi non consentiranno di inserirli, altrimenti, a seconda di come è stata abilitata, o si entrerà in gestione dei lotti con l'apposito pulsante [image], dopo aver salvato la riga di dettaglio oppure, al salvataggio della riga, il programma entrerà in automatico in inserimento dei lotti associati alla riga stessa e all'uscita se non verranno inseriti lotti, chiederà conferma.

In caricamento movimenti di magazzino, in ddt e fatture, nella maschera di inserimento lotti, è presente un'icona [image] (Seleziona lotti) che propone una lista per la selezione dei lotti disponibili. In fase di vendita tuttavia, o movimenti di uscita di magazzino, è possibile vedere la disponibilità dei lotti di un articolo in base ai flag inseriti nei parametri di personalizzazione.

Il codice lotto è accompagnato da un numero progressivo, che in generale vale 1 ma che potrebbe assumere valori successivi se l'utente ritiene di dover diversificare il rientro di un lotto dello stesso prodotto e dello stesso fornitore, dall'acquisto stesso.

Il lotto viene memorizzato sui movimenti di magazzino e, al momento della registrazione di un carico di articoli con lotto, viene creata una riga in una tabella lotti. Tale tabella conterrà quindi l'elenco dei lotti movimentati. Se si cancella un movimento di carico di un lotto, esso continuerà ad esistere in questa tabella fino a quando non si farà girare un programma di servizio (a menu) che consente di cancellare tutti i lotti per i quali non sono presenti movimenti.

Sulla tabella lotti è presente un campo, gestito automaticamente dalla procedura nelle varie fasi di carico e scarico, che indica se il lotto è aperto o chiuso.

Per il calcolo della giacenza dei prodotti per lotto, si tiene conto anche delle eventuali fatture e ddt non stampati.

Il lotto rimarrà aperto fino a quando esisteranno in magazzino delle quantità per quel lotto salvo non venga chiuso manualmente, in modo forzato, dalla gestione lotti.

Se, con uno scarico, la giacenza va a 0, il lotto viene chiuso automaticamente (vengono controllati singolarmente i magazzini che sono stati movimentati con quel lotto)

Se si cancella uno scarico il lotto viene riaperto, salvo la chiusura non fosse stata Forzata.

Per l'inserimento dei lotti in giacenza al momento dell'inizio dell'utilizzo della procedura si deve utilizzare una causale di magazzino particolare da specificare nel parametro di personalizzazione: LottiCausaliNoMovCar

Nella ricerca del lotto: se è già stato impostato sulla maschera il fornitore, verranno visualizzati i lotti di quel fornitore, se l'articolo, quelli di quell'articolo etc

Ad ogni lotto è associato un numero progressivo che consente di registrare entrate successive dello stesso lotto, differenziandole con tale numero.

La gestione dei lotti, a seconda di come viene parametrizzata, consente di soddisfare le esigenze delle varie attività nelle quali trova applicazione.

Per quanto riguarda la lavorazione delle carni (macelli) è possibile attribuire alle carni lavorate (bistecche etc.) ricavate da uno stesso pezzo (coscia) lo stesso lotto del pezzo originario.

Questo si ottiene attivando il parametro di personalizzazione HlpLottoForn e disattivando tutti i controlli di sequenza di Carico/scarico e di disponibilità (tramite i relativi parametri: QtaVer=0)

Se attivo questo parametro, nella maschera di richiesta del lotto (in movimenti di magazzino, ddt, fatture) viene presentato un pulsante [Dupl.], a sinistra del codice fornitore, che consente, una volta inserito il codice del fornitore, di aprire una maschera con l'elenco dei lotti di quel fornitore, indipendentemente dall'articolo.

Selezionando uno di questi lotti, verrà attribuito il lotto scelto all'articolo della riga, e quindi creato se ancora non esiste.


CARICAMENTO MOVIMENTI DI PRODUZIONE

Percorso: Magazzino - Movimenti

Questa funzione consente di caricare un prodotto finito e di scaricare, uno per uno, i suoi componenti, impostando il lotto sia del carico sia dei vari prodotti scaricati. Alla conferma dell'inserimento verranno generati in automatico i rispettivi movimenti di magazzino.

In pratica la funzione simula quello che fa il programma di 'Caricamento movimenti di magazzino' quando si inserisce, con la causale opportuna, un movimento di carico da produzione se è installato il modulo di distinta base ed è stata creata la distinta base dei prodotti. In questo caso il movimento di scarico dei componenti viene fatto in automatico dal programma.

Nel caso di utilizzo del lotto di produzione (tracciabilità), questa nuova funzione diventa particolarmente utile in quanto consente di assegnare manualmente un codice lotto al prodotto che si va a caricare e ai vari componenti scaricati.

E' possibile definire il parametro di personalizzazione: DettDibaAutom per precompilare in automatico i dettagli con i componenti di base del prodotto inserito nella prima maschera. In questo caso, se esiste, per il componente, un unico lotto aperto, esso verrà inserito sulla riga.
Se attivo anche il parametro VerDispQtaProd il programma metterà il lotto SOLO SE, su quel lotto, c'è quantità disponibile.
Si utilizzano inoltre i parametri QtaVer e QtaDivBloc
I lotti inseriti con questa funzione diventeranno effettivi SOLO una volta che i movimenti verranno trasferiti sui movimenti di magazzino.

Per inserire una nuova produzione occorre scrivere 0 nel campo: numero movimento. I pulsanti per la gestione sono gli stessi utilizzati in Caricamento movimenti di magazzino.

Causale movimento principale
E' la causale del movimento di carico del prodotto derivato dalla produzione

Causale movimento secondario
E' la causale del movimento di scarico dei componenti intervenuti nella produzione di cui sopra

Note
Sono le eventuali note che verranno memorizzate nei due movimenti generati.

Articolo prodotto
E' il codice dell'articolo che si vuole caricare a magazzino

Quantità e Prezzo
L'utente dovrà impostare la quantità che vuole caricare. Per quanto riguarda il prezzo, se lo si lascia vuoto, il programma, lo compilerà al momento di creare il movimento in magazzino, come somma dei costi dei vari componenti che si andranno ad inserire successivamente.

Fornitore/Lotto
E' possibile generare in automatico o digitare il nuovo lotto dell'articolo che si è prodotto.
Per la generazione automatica del lotto e informazioni sulla tracciabilità vedere il paragrafo Tracciabilità
Con F10 o digitando il pulsante [image] (F10 dettagli) si passa alla maschera che chiede i dati degli articoli componenti.

Al termine dell'inserimento dei componenti, il programma torna alla maschera iniziale. Se la 'produzione' inserita viene semplicemente salvata, può essere ripresa, variata, cancellato o completata successivamente ma non ha avuto ancora nessun effetto sul magazzino.
Solo premendo il pulsante: (O) Crea movimenti magazzino si consente di creare il relativi movimenti di magazzino di carico e scarico. Se sono stati impostati i lotti, sia del prodotto finito sia dei componenti, essi verranno scritti sui movimenti generati e in particolare, sul movimento di scarico di ogni componente, verrà evidenziato il lotto del prodotto finito generato. Questi dati verranno utilizzati dalla stampa della tracciabilità/rintracciabilità : Stampa movimenti lotti
Se attivo il parametro VerDispQtaProd il programma consentirà di trasferire il movimento SOLO SE, c'è quantità disponibile sui vari lotti, viceversa verrà dato un messaggio con l'elenco dei lotti su cui non c'è giacenza sufficiente.

Segue la richiesta di conferma o annulla.
Se si sceglie annulla i movimenti non verranno generati.

Successivamente si chiede se cancellare la registrazione dalla tabella di appoggio o mantenerla. Potrebbe tornare comodo mantenerla nel caso di produzioni ripetitive nelle quali ad esempio andare a variare solo le date di produzione e i lotti.

Vedi Caricamento mov. di produzione dettagli


CARICAMENTO MOV. PRODUZIONE (Dettagli)

Percorso: Magazzino - Movimenti - Caricamento movimenti di produzione

Con questa funzione dovranno essere inseriti, manualmente, uno dopo l'altro, gli articoli che sono intervenuti nella produzione, ciascuno con la quantità giusta. Su ogni articolo si può impostare il lotto di produzione scegliendolo tra quelli caricati.
Se è stato attivato il parametro di personalizzazione : DettDibaAutom , la maschera verrà compilata in automatico con i componenti di base dell'articolo da produrre inserito in testata. Se, per il componente, esiste un unico lotto da cui prelevare la quantità, tale lotto verrà scritto sulla riga, altrimenti, tramite il pulsante [image] (Gestione lotti), è possibile assegnare manualmente più lotti alla riga di dettaglio.

NON vengono fatti controlli sulla disponibilità della quantità di prodotto nel lotto inserito.
Per attivare tale controllo occorre creare il parametro di personalizzazione VerDispQtaProd
Si utilizzano inoltre i parametri QtaVer e QtaDivBloc
I lotti inseriti con questa funzione diventeranno effettivi SOLO una volta che i movimenti verranno trasferiti sui movimenti di magazzino.

Per confermare la riga corrente e inserire un nuovo articolo, premere il tasto F10. Per uscire e tornare alla maschera iniziale della funzione, premere F10 per 2 volte.


STAMPA BROGLIACCIO MOVIMENTI

Percorso: Magazzino - Movimenti - Stampe

Il programma consente di stampare un elenco dei movimenti di magazzino registrati in un certo periodo, dopo aver fatto, se necessario, selezioni per causale movimento, articolo, cliente/fornitore.

Gli importi possono essere espressi in lire o in euro.

Si può scegliere tra due formati di stampa: sintetico (una riga per ogni articolo del movimento) o dettagliato (più informazioni per ogni articolo).


VISUALIZZAZIONE PARTITARI ARTICOLO (PARAMETRICO)

Percorso: Magazzino - Movimenti

Il programma consente di visualizzare i movimenti di ogni articolo. La visualizzazione viene fatta secondo dei 'modelli' preimpostati dall'utente secondo quanto descritto in Stampe Parametriche.

A seconda del tipo di visualizzazione necessaria, l'utente dovrà per prima cosa sceglierla tra le possibili, poi si dovranno impostare i parametri di selezione.

In visualizzazione vengono considerati tutti i movimenti compresi negli intervalli selezionati, senza esclusione di articoli non fiscali o non attivi.

A sinistra del video vengono elencati i livelli per i quali è stata chiesta la visualizzazione. All'entrata sono attivi comunque solo due livelli, per ottenere i successivi occorre fare un click sul simbolo + (posto a sinistra della riga di livello). Per ottenere la visualizzazione dei movimenti occorre selezionare il livello corrispondente.

Tra i campi selezionabili per la stampa ci sono il costo del venduto, il costo ultimo e il costo medio ponderale e i rispettivi margini calcolati tra il Valore Scarico e i Costi selezionati (Ric.-Costo)*100/Costo.

Se si seleziona di eseguire una stampa nella quale compare il campo Costo Ultimo e nella maschera delle scelte iniziali è stato scelto di stampare solo i movimenti dei fornitori (digitando F in F=solo fornitori), il costo ultimo stampato verrà estratto dall'archivio Articoli/fornitori per cui verrà stampato il costo ultimo per ogni fornitore e non il costo ultimo dell'articolo.

Se ci si posiziona con il mouse su una riga di movimento visualizzato si può accedere, con un doppio click, alla gestione del movimento stesso.


VISUALIZZAZIONE PARTITARIO ARTICOLI

Percorso: Magazzino - Movimenti

Si esaminano i movimenti (con causale di tipo normale, trasformazione, interno) ordinati per Magazzino Articolo, data registrazione e numero movimento.

Si escludono gli articoli con flag di No giornale e i movimenti con causale con No mag.fiscale

Viene chiesto un intervallo di date obbligatorio e si controlla che abbiano lo stesso anno. Per ogni articolo si calcola la giacenza alla giorno precedente la prima data dell'intervallo di stampa, si stampano tutti i movimenti e si calcola la giacenza finale.

Se ci si posiziona con il mouse su una riga di movimento visualizzato si può accedere, con un doppio click, alla gestione del movimento stesso.


STAMPA PARTITARIO ARTICOLO (PARAMETRICO)

Percorso: Magazzino - Movimenti - Stampe

Il programma consente di stampare i movimenti di ogni articolo.

La stampa viene fatta secondo dei 'modelli' preimpostati dall'utente così come descritto in Stampe Parametriche.

Una volta impostato il tipo o i tipi di stampa desiderati e definito quello di default, l'utente dovrà scegliere, prima di stampare, quello da utilizzare in quel momento.

Tra i campi da selezionare per la stampa sono stati aggiunti, rispetto la visualizzazione:
il costo ultimo dell'articolo
la percentuale di margine del ricavo (valore scarico), rispetto al costo ultimo, al costo del venduto scritto sui movimenti e al costo medio ponderale.

Le percentuali vengono calcolate: (Ricavo-Costo)*100 / Costo

E' possibile, costruendo un tipo di stampa opportuno, utilizzare l'opzione di Stampa sintetica per ottenere, ad esempio, l'importo giornaliero della merce venduta ad ogni cliente impostando l'ordinamento per cliente e data di registrazione.


STAMPA PARTITARIO ARTICOLO

Percorso: Magazzino - Movimenti - Stampe

Viene stampato l'elenco dei movimenti degli articoli selezionati, ordinati per data registrazione.

Nella prima riga di ogni articolo viene riportata la giacenza precedente, cioè quella precedente alla prima data di stampa. Se si stampa da inizio anno, verrà riportata la giacenza iniziale.

Al termine di ogni articolo si stampano i totali carico e scarico del periodo selezionato e la giacenza finale.

Nella stampa non si considerano gli articoli con il flag 'in Giornale' a NO né i movimenti con causali con flag No Giornale.


GIORNALE DI MAGAZZINO

Percorso: Magazzino - Movimenti - Stampe

E' la stampa fiscale dei movimenti di magazzino.

I movimenti vengono ordinati per codice articolo e data registrazione.

E' possibile stampare per intervalli di date di registrazione e la stampa può essere ripetuta a piacere. Se si dichiara che la stampa è fiscale, viene memorizzata la data dell'ultimo movimento stampato per facilitare l'operatore nel determinare l'intervallo di stampa del periodo successivo.

E' possibile scegliere tra stampa Sintetica (viene stampata una riga per ogni articolo e per ogni giorno contenente la somma dei carichi e scarichi effettuati) e Dettagliata (vengono stampati tutti i movimenti dell'articolo, per data, in modo analitico).

I movimenti stampati sono quelli che hanno nella causale il flag di stampabile sul giornale e sull'articolo il flag di in magazzino fiscale a si.

Per ogni articolo, sulla prima riga di stampa, si riporta la giacenza iniziale (se la data di inizio dell'intervallo di stampa coincide con inizio anno) oppure la giacenza precedente calcolata sommando alla giacenza iniziale i movimenti effettuati fino al giorno precedente la prima data di stampa.


SITUAZIONE DI MAGAZZINO

Percorso: Magazzino - Stampe - Situazione articoli

Il programma consente di predisporre una o più stampe personalizzate mettendo a disposizione le quantità di carico e scarico degli articoli, i rispettivi valori e i costi in un determinato anno.

Viene proposta una selezione iniziale per determinare l'intervallo dei magazzini, degli articoli etc. da riportare in stampa.

Se si fa la stampa per Magazzino, per ogni Magazzino verranno elencati gli articoli selezionati.

Se si fa per Articolo, i progressivi dell'articolo saranno la somma dei rispettivi progressivi dei magazzini selezionati (in questo caso, in presenza di gestione taglie, non verranno stampate le quantità per livello ma solo per articolo)

Per stampare su una riga separata il codice e la descrizione dell'articolo è sufficiente metterli nei raggruppi.

I progressivi stampati vengono letti dall'archivio Articoli / Progressivi in base all'anno di stampa.
Si può scegliere se stampare:

  • Tutti gli articoli per i quali siano stati fatti, nel tempo, dei movimenti
  • Movimentati
    consente di stampare solo gli articoli movimentati. Se viene fatta questa scelta il programma esclude gli articoli che nell'anno non hanno n'è una giacenza iniziale n'è movimenti (cioè quelli per i quali è stato fatto un movimento poi cancellato).
  • Senza movimenti nell'anno
    consente di stampare solo gli articoli che sono stati movimentati in altri anni ma, nell'anno di stampa, non hanno movimenti

Anche articoli mai movimentati
Consente di stampare anche gli articoli che sono stati inseriti come anagrafica ma mai utilizzati nei movimenti.

Se si rende necessario stampare SOLO la giacenza degli articoli, compresi quelli mai movimentati, si consiglia di vedere anche la funzione: Stampa modulo per inventario.

Tra i campi che si possono stampare c'è la Percentuale di ricarico che viene calcolata come segue:
[ Valore scarico - Costo Venduto(valore scarico ultimo costo) * 100] / Costo del Venduto
Se uno dei termini è 0 allora tutto viene posto a 0.

Vedi Stampe Parametriche


CONTROLLO SCORTE (SOTTOSCORTA)

Percorso: Magazzino - Stampe

Il programma confronta, per ogni articolo che soddisfa le condizioni impostate dall'operatore, la giacenza dell'articolo nell'anno di stampa con la scorta minima o la massima o il punto di riordino.

Se la giacenza dell'articolo risulta inferiore alla scorta minima o al punto di riordino o maggiore della scorta massima, a seconda del tipo confronto, verrà fatta una segnalazione (es. *****)

A seconda che la stampa venga fatta per magazzino o per articolo verranno considerati i parametri «scorta» inseriti in Scorte per Magazzino o in Articoli

Se si fa la stampa per magazzino e non è stato creato il record dei parametri magazzino/articolo, questi vengono posti a 0.

Stampa per Magazzino o per Articolo

Gli articoli possono essere ordinati per codice o per descrizione e possono essere raggruppati per gruppo, sottogruppo, classi/attributi

Tipo confronto
Indica il campo col quale confrontare la giacenza (e disponibilità) dell'articolo.

  • Con Scorta Minima
  • Con Scorta Massima
  • Con Punto di Riordino

E' possibile inoltre operare le seguenti scelte:

  • escludere articoli con campo di confronto (scorta minima, scorta massima, punto di riordino) = 0
  • stampare solo gli articoli con giacenza minore o uguale a 0
  • stampare solo gli articoli in evidenza (cioè quelli la cui giacenza risulta inferiore al campo di confronto)
  • confrontare e stampare anche la disponibilità oltre la giacenza
  • in presenza di gestione di taglia/colore si può scegliere tra stampa sintetica (una riga per ogni articolo) o analitica (dettaglio di taglia/colore per ogni articolo).


STAMPA MOVIMENTI MATRICOLE

Percorso: Magazzino - Movimenti - Stampe

Questa stampa è abilitata solo se si utilizza la Gestione matricole e cioè se si memorizzano le matricole degli articoli di magazzino.

La stampa elenca, per ogni matricola, i movimenti fatti nel periodo richiesto.


SCORTE PER MAGAZZINO

Percorso: Magazzino - Gestioni

E' la gestione di Scorta Minima, Massima, lotto di riordino, etc. per MAGAZZINO /ARTICOLO


STAMPA SCORTE PER MAGAZZINO

Percorso: Magazzino - Gestioni - Stampe

La funzione consente di stampare un elenco dei dati inseriti nell'archivio delle scorte articoli per magazzino.

Se si gestiscono i livelli (Taglia/Colore) verranno stampate tante righe con le scote, se sono state inserite, dello stesso articolo, per ogni taglia e colore.


LOCALIZZAZIONI ARTICOLI

Percorso: Magazzino - Gestioni

E' la gestione delle localizzazioni: scaffale etc. degli articoli nei vari magazzini gestiti.


STAMPA LOCALIZZAZIONI ARTICOLI

Percorso: Magazzino - Gestione - Stampe

Esegue una stampa, per magazzino o per articolo delle localizzazioni inserite in archivio.


PROGRESSIVI ARTICOLI

Percorso: Magazzino - Servizio

I progressivi degli articoli vengono tenuti divisi per anni in modo da tenere in linea più anni, e per magazzini, in modo da avere la situazione delle giacenze sui vari magazzini gestiti.
Essi vengono aggiornati quando si registrano dei movimenti di carico e scarico a seconda di quanto specificato sulla causale di magazzino utilizzata.

Se è attiva per l'articolo la gestione di taglia e colore c'è una riga di progressivi per ogni combinazione.

Per una corretta gestione dei progressivi si consiglia di non intervenire manualmente con variazioni tramite la questo programma ma, se si rende necessario operare delle correzioni, inserire dei movimenti dopo aver creato le causali opportune.
Per la rigenerazione automatica dei progressivi e costi a partire dai movimenti, è disponibile una funzione a menu.

Giacenza e valore iniziale
Indica la giacenza e il rispettivo valore ad inizio esercizio. Viene aggiornato dalla stampa inventario di fine anno o dal caricamento di un movimento di giacenza iniziale.

Quantità e Valore Ordinato a Fornitore
Quantità e Valore Impegnato da Cliente
Vengono movimentati dall' inserimento ed evasione degli ordini Clienti e fornitori.

Valore scarico al Costo
E' il costo del venduto. Aggiornato se previsto dalla causale. In ogni movimento abbiamo, se previsto da tabella di magazzino, il costo unitario. Indica il valore relativo alla quantità di scarico in base al costo scelto. E' un progressivo all'interno dell'anno aggiornato da scarichi (mov.di magazzino e bolle e fatture).

In azienda viene utilizzato nella stampa della situazione di magazzino per calcolare la percentuale di ricarico.

Quantità opzionali (vedi tabella di magazzino)
Queste quantità verranno visualizzate o meno a seconda che nella tabella di magazzino siano state definite. Esse, se definite, vengono movimentate dai movimenti di magazzino la cui causale lo prevede e in modo del tutto autonomo dalle quantità di carico e scarico. Sono dei progressivi di consultazione. Possono servire per avere un riscontro di quanti pezzi di un articolo sono usciti per dimostrazione o altro.


COSTI ARTICOLO

Percorso: Magazzino - Servizio

Per ogni articolo vengono gestiti, anno per anno, i costi per poter effettuare le valorizzazioni secondo i vari criteri di legge. Se è attiva per l'articolo la gestione di taglia e colore c'è una tabella costi per ogni combinazione o una sola a seconda di quanto specificato sull'articolo.

I valori di questa tabella vengono aggiornati dai movimenti di carico merce quando la causale di magazzino lo prevede.

Costo Ultimo - Data costo ultimo
Vengono aggiornati, se la causale lo prevede, quando viene fatto un acquisto in una data successiva a quella già memorizzata.

Costo più alto - Data costo più alto
Vengono aggiornati, in corrispondenza a movimenti con causali che prevedono l'aggiornamento di uno dei costi, ma solo se il costo del movimento è maggiore del costo più alto già memorizzato.

Costo Medio Ponderale (Medio di Carico)
Viene aggiornato, se la causale lo prevede, secondo questa formula:

(CMP * Giacenza + Valore del movimento) / Nuova Giacenza

C'è il dubbio eventuale di quali magazzini usare per il calcolo della giacenza.

A fianco al Costo Medio Ponderale viene gestito un indicatore di valore corretto o no. Questo indicatore viene posto a 'valore non corretto, in fase di variazione di movimenti di magazzino che prevedono l'aggiornamento del costo medio ponderale. E' disponibile un programma di utilità per ricalcolare questo valore dai movimenti.

Costo standard
Da compilarsi manualmente. Può essere utilizzato in fase di inventario.

Medio di Carico
E' il valore calcolato dividendo il Valore di Carico per la Quantità di Carico dell'articolo nell'anno. Questi due progressivi vengono incrementati in corrispondenza ai movimenti con causali che lo prevedono.

Medio di Acquisto
E' il valore calcolato dividendo il Valore Acquisti per le Quantità Acquistate dell'articolo nell'anno. Questi due progressivi vengono incrementati in corrispondenza ai movimenti con causali che lo prevedono.

Medio di Vendita
E' il valore calcolato dividendo il Valore del Venduto per le Quantità Vendute dell'articolo nell'anno. Questi due progressivi vengono incrementati in corrispondenza ai movimenti con causali che lo prevedono.


STAMPA COSTI ARTICOLI

Percorso: Magazzino - Servizio - Stampe

E' la stampa dei costi degli articoli memorizzati in archivio dai movimenti di carico e scarico, per ogni anno di attività dell'azienda.

Una volta fatto l'inventario di magazzino e trasferite le giacenze, i costi dell'anno precedente possono essere cancellati con l'apposita funzione.


Ulteriori Codici a Barre Articoli

Percorso: Magazzino - Anagrafiche

Con questa funzione è possibile associare ad ogni articolo ulteriori codici a barre oltre a quello messo in anagrafica.
Quando si effettua la ricerca di un articolo per codice a barre, il programma prima lo cerca in tabella Articoli poi su questa tabella.

Lo scopo è di mantenere in magazzino le giacenze su un unico articolo anche se, fisicamente, tale articolo ha codici a barre diversi (es. perchè acquistato da vari fornitori).


GESTIONE MOVIMENTI INTERROTTI

Percorso: Magazzino - Servizio

Questa funzione consente di 'ripristinare' i movimenti di magazzino, a seguito di un blocco del programma Caricamento Movimenti

In caso di blocco, questa funzione dovrà essere eseguita subito dal terminale su cui si è verificato l'errore. Se ciò non avverrà, alla prossima apertura del menu, verrà dato a quel terminale un messaggio:
Esecuzione interrotta con lock attivi: eseguire ripristino movimenti di magazzino.

Viene visualizzato l'elenco dei movimenti in elaborazione. Prima di procedere confermando l'elaborazione movimento, verificare che esso non sia in esecuzione da un altro terminale.

E' possibile scegliere se cancellare il movimento o terminare l'elaborazione.

Se si elabora il movimento, si consiglia di entrare, successivamente, in Caricamento movimenti per controllarlo.


VARIAZIONE AUTOMATICA ARTICOLI

Percorso: Magazzino - Servizio

La funzione consente di variare automaticamente il contenuto dei campi delle anagrafiche Articoli.

In presenza di un numero molto alto di articoli, il programma potrebbe andare in errore di memoria. Per ovviare a questo, basta togliere la spunta al campo "In Transazione" ed elaborare di nuovo. Se il campo suddetto è spuntato, in caso di interruzione per errore, nessun record verrà modificato; al contrario, se NON si spunta il campo, se accade un errore durante l'elaborazione, ci saranno degli articoli variati e altri no per cui si dovrà provvedere ad individuare il motivo dell'interruzione prima di procedere alla variazione dei rimanenti articoli.

E' possibile impostare una selezione iniziale per definire l'intervallo degli articoli da variare: per articolo, reparto, gruppo, sottogruppo.

Segue un elenco di campi per i quali è possibile fare la variazione automatica.
Potrà essere modificato un campo per volta scegliendolo con un click.

Se il campo da modificare non è tra quelli elencati, potrà essere modificato con la scelta: Campo selez.
Con questa scelta verranno elencati tutti i campi dell'anagrafica e si potrà scegliere quello da modificare.

Nella colonna DA occorre impostare il contenuto attuale del campo da modificare, in colonna A, il nuovo contenuto.

Nelle selezioni iniziali, si chiede:
Se il campo "Da" viene lasciato vuoto, quali anagrafiche si intende modificare:

  • Tutti
    verrà scritto il contenuto del campo "A" su TUTTE le anagrafiche selezionate
  • Solo quelli con campo interessato vuoto
    verrà scritto il contenuto del campo "A" solo sulle anagrafiche selezionate che abbiano il campo interessato "Vuoto"

Se invece viene lasciato bianco il campo "A" verrà sbiancato quel campo su tutte le anagrafiche selezionate, in cui il contenuto del Campo "Da" è quello digitato.

Con questo programma è possibile, in particolare, rigenerare i codici a barre degli articoli a seconda del Tipo codice a barre scritto in ciascuno di essi.
Se non è mai stato utilizzato il codice a barre, occorre prima impostare su tutti gli articoli il Tipo di codice a barre (Ean 13, Ean 8 etc.), poi rigenerare in automatico il valore del codice.
E' possibile generare il codice a barre:

  • Solo degli articoli con codice a barre vuoto
  • Tutti gli articoli selezionati

Impostando il parametro di personalizzazione CodIniAut, si consente la generazione automatica del codice a barre a partire da una stringa iniziale di caratteri.


RIGENERAZIONE PROGRESSIVI E COSTI DAI MOVIMENTI

Percorso: Magazzino - Servizio

Consente di rigenerare i progressivi di carico e scarico e i costi di tutti gli articoli o solo di un gruppo a partire dai movimenti inseriti nell'anno.

Se, per qualche motivo, il programma viene interrotto durante l'esecuzione, occorre rieseguirlo operando le stesse selezioni fatte in precedenza.

Riaggiorna anche il costo ultimo sull'archivio articoli fornitore, se previsto da tabella di magazzino e se sui movimenti è gestito il Valore Scarico al Costo (costo unitario dello scarico).

I programma non modifica i progressivi ordinato per cui, se si gestiscono gli Ordini, ed è necessario ricalcolare anche questi, occorre eseguire il programma di Ripristino dell'ordinato che li rigenera a partire dagli Ordini aperti.


SISTEMAZIONE DATA DI FINE LISTINO

Percorso: Magazzino - Servizio

La funzione consente di sistemare automaticamente le date di fine listino su ogni articolo. Dovrà essere utilizzata solo in caso di anomalie in quanto, in condizioni normali, nel momento di inserimento o cancellazione di un listino di un articolo il programma imposta automaticamente la data di fine validità.


RICALCOLO COSTO ULTIMO DA LISTINO

Percorso: Magazzino - Servizio

Il programma consente di ricalcolare il costo ultimo degli articoli, selezionandoli per gruppo, sottogruppo o reparto a partire da un listino inserito e applicando ad esso una percentuale di sconto.

Questa funzione è stata messa a punto per utenti che caricano i listini di vendita da file esterni forniti dai fornitori.

Se si crea il parametro di personalizzazione CalcValIniDaCosti, gruppo: Articoli con valore S, il programma presenta l' opzione: Ricalcolo il valore della Giacenza Iniziale che consente di ricalcolare il valore della giacenza iniziale dell'anno come:

  • G.Iniziale * listino di riferimento, indicato a video, eventualmente scontato


GENERAZIONE MOV.GIORNALIERO DA VENDITA AL BANCO

Percorso: Magazzino - Servizio

Utilizzando, per la vendita al banco, l'emissione scontrini (in presenza o meno del registratore di cassa) viene memorizzato un movimento di magazzino per ogni scontrino confermato.

Questo comporta che a fine giornata i movimenti di magazzino possono essere moltissimi.

Questa funzione consente di raggruppare tutti quelli che hanno stessa data, causale, cliente e magazzino di uscita e di creare una riga per ogni articolo con la quantità e il valore che saranno il totale del venduto del giorno.

I movimenti creati durante il giorno verranno cancellati e rimarranno solo i(l) movimenti(o) riepilogativi(o).

Se sono stati fatti scontrini con causali di magazzino diverse, con merce uscita da magazzini diversi etc. occorre eseguire questa funzione più volte, variando a video i parametri di selezione.

Nota: fare attenzione alla data confermata in 'Movimento del' perché quella sarà la data dei movimenti che verranno raggruppati.


STAMPA MODULO PER INVENTARIO

Percorso: Magazzino - Servizio - Stampe

Il programma consente di stampare un elenco degli articoli (per articolo o per magazzino) con evidenziata la giacenza attuale, predisponendo, per ogni riga, uno spazio nel quale si potrà scrivere manualmente la giacenza effettiva rilevata fisicamente in magazzino.

La richiesta: articoli attivi, inattivi o entrambi si riferisce al segnale di Inattivo (cioè articolo non più utilizzato) che si può mettere sull'anagrafica articoli.

La stampa prende in considerazione gli articoli che hanno una giacenza iniziale o un carico o uno scarico, se di un articolo è stata caricata l'anagrafica ma non è mai stato movimentato, questo non verrà stampato.

Tutti gli articoli creati
Spuntando questa opzione, si potranno includere nella stampa anche gli articoli mai movimentati.
Non stampo la giacenza
Consente di stampare o meno la colonna contenente la giacenza degli articoli.


VISUALIZZAZIONE PREZZI ARTICOLI

Percorso: Magazzino (personalizzato)

Questa funzione è stata fatta su richiesta specifica di un cliente e non è, per ora, collegata al menu standard.

Consente di visualizzare, dato un articolo e un listino, il prezzo di quell'articolo e i relativi prezzi scontati dello sconto articolo che, nel caso specifico è sempre del tipo X+Y.

Viene quindi applicato al listino lo sconto X e visualizzato il prezzo risultante, poi a questo viene applicato lo sconto Y e visualizzato il nuovo prezzo.

Si possono scorrere gli articoli con i pulsanti precedente e successivo.

La ricerca avviene per codice articolo. Sul video c'è un pulsante che dice qual' è il tipo di ricerca in uso. Premendo tale pulsante si può passare alla ricerca per codice a barre.

Se si vuole che, al caricamento del programma, la ricerca sia per codice a barre, basta creare un parametro di personalizzazione RicArt = B


LISTINI

Percorso: Magazzino - Listini - Gestioni

E' possibile collegare ad ogni articolo uno o più prezzi di listino di vendita o di acquisto.

Se sull'articolo è abilitata la gestione 'taglia e colore' è possibile avere un listino unico o uno per ogni taglia/colore a seconda del valore assegnato al flag 'gestione prezzi' dell'articolo.

Il listino deve essere stato creato in precedenza in tabella listini.

Il campo prezzo dovrà essere compilato quando il listino è in valuta (Euro compreso)

Il campo prezzo in lire invece, dovrà essere compilato solo se il listino è in Lire.

Se il listino è in Lire, una volta compilato il prezzo in Lire verrà calcolato automaticamente il Prezzo (in Euro), viceversa se il listino è in Euro, compilato il campo Prezzo, verrà calcolato il corrispondente Prezzo in Lire.

E' possibile evitare l'aggiornamento automatico del corrispondente 'prezzo' al variare di uno dei due, attivando una riga particolare nella Tabella di Personalizzazione.

Data inizio validità
Indica la data di inizio validità del listino. Nella Tabella di magazzino è possibile scegliere se utilizzare o meno, per ogni listino più date di inizio validità.

La valorizzazione di questa data consente di preparare un nuovo listino che verrà applicato in una data futura.

Se si sceglie di non utilizzare più date di validità per lo stesso listino, come data di inizio validità verrà impostata quella messa in tabella di magazzino.

Sconto listino e modalità di attivazione

Se valorizzato, lo sconto verrà applicato in aggiunta o in sostituzione allo sconto prodotto a seconda di come è compilato il campo 'modalità di attivazione'. Il valore iniziale della modalità di attivazione dello sconto è quello impostato nella tabella listini, sarà possibile variarlo in corrispondenza ad uno o più articoli.

Per far si che su un articolo non venga considerato l'eventuale sconto impostato sul listino generale, si deve mettere 0 sullo sconto in corrispondenza al listino dell'articolo specifico.

Questi campi non vengono gestiti se l'articolo ha la gestione dei Livelli (taglia/colore)


STAMPA LISTINI

Percorso: Magazzino - Listini

Il programma consente di impostare una o più stampe dei listini, scegliendo i campi e gli ordinamenti.

Per spiegazioni dettagliate far riferimento a Stampe Parametriche.
Il programma prepara campi particolari che possono essere utilizzati in questa stampa, una volta inseriti tra i Campi disponibili con il programma di gestione della tabella dei campi

Prima della stampa è possibile effettuare selezioni sugli articoli da stampare.

E' possibile attivare il parametro SfondoRigaGrigio che consente di impostare a Si, a video, l'opzione che permette di stampare alternativamente le righe con sfondo bianco e sfondo grigio.

Scelta: Articolo modificato dal ... al ...
impostando una data o intervallo di date , verranno stampati gli articoli con data ultima modifica compresa nell'intervallo. Se sull'articolo tale data è bianca, esso verrà considerato se ha la data di creazione compresa nell'intervallo.


LISTINO PROMOZIONE

Percorso: Magazzino - Listini - Gestioni

Con questa gestione è possibile inserire, per ogni articolo e ogni listino, un prezzo particolare 'prezzo promozione' valido solo in un determinato intervallo di tempo. Questo prezzo verrà assunto come prezzo di listino nelle vendite quando la data del documento è nell'intervallo di validità.

E' possibile inserire anche una descrizione della promozione. Tale descrizione potrà essere visualizzata o meno in fase di inserimento documenti di vendita (e movimenti di magazzino) a seconda di quanto si imposta nel campo: Visualizzazione Descrizione.


STAMPA LISTINI PROMOZIONE

Percorso: Magazzino - Listini

Il programma consente di stampare i listini promozione creati ordinati per codice listino/articolo o per articolo/listino. E' possibile decidere le date validità promozione da considerare.


LISTA ARTICOLI SENZA LISTINO

Percorso: Magazzino - Listini - Stampe

Questo programma consente di stampare una lista con tutti gli articoli ai quali non è stato assegnato un prezzo di listino.

E' possibile digitare un codice listino: in questo caso il programma stampa tutti gli articoli che non hanno quel particolare listino.

Se lasciato bianco, il programma stampa tutti gli articoli senza listino.


VARIAZIONE AUTOMATICA LISTINI

Percorso: Magazzino - Listini

Questa funzione consente di Creare un nuovo listino a partire da uno esistente (o da un costo) oppure di Variare o Cancellare un listino preesistente valido ad una certa data.

In creazione e in variazione viene visualizzato, durante la compilazione dei parametri, un elenco degli articoli interessati con prezzo originario e ricalcolato.

Creazione:
Consente di creare un listino nuovo o di rigenerarne uno già esistente, a partire da un altro listino valido a una certa data o dal costo ultimo dell'anno in corso.
Il codice del nuovo listino deve già essere stato inserito con la funzione Tabella Listini (Tab.di magazzino).
La data di inizio validità dovrà essere digitata SOLO se nella tabella di magazzino è stato dichiarato di gestire più date per uno stesso listino.
Nel caso siano coinvolti listini in valuta, questa data sarà quella con la quale si cercherà il cambio in tabella cambi.

Per passare da un listino all'altro è possibile applicare un ricarico o uno sconto, un aumento o una diminuzione (importo), la percentuale di maggiorazione presente sui singoli articoli.
Se il listino da creare non è nella stessa moneta di quello di partenza, verrà applicata la variazione (aumento o diminuzione) su quello di partenza poi si fa il cambio.
Il ricarico e lo sconto possono essere dati nella forma 2+3+1.
Volendo utilizzare più di uno dei suddetti parametri, è possibile stabilire la sequenza di applicazione.

Per quanto riguarda lo sconto e le sue modalità di applicazione, il listino nuovo avrà in ogni articolo, sconto e modalità del listino di origine.

Il nuovo prezzo di listino potrà essere arrotondato secondo la tabella degli arrotondamenti
Se si sceglie di NON arrotondare, togliendo la spunta al campo, il programma calcolerà comunque il nuovo prezzo:

  • arrotondando ai decimali della moneta, se la tabella degli arrotondamenti è vuota
  • arrotondando ai decimali di gestione della moneta, se è stata compilata almeno una riga della tabella degli arrotondamenti

Si può decidere di cancellare il listino di destinazione prima di procedere alla nuova creazione in modo da eliminare eventuali prezzi di articoli non più in uso. In caso di cancellazione vengono cancellate tutte le ricorrenze di quel listino, indipendentemente dalle date.

La variazione viene fatta sul prezzo di partenza e, se necessario verrà effettuato il cambio.
Applicazione del cambio nel passaggio tra listini con monete diverse (campi cambio e operatore):

  • Entrambe le monete hanno il flag Si Cee (cioè sono di paesi dell'UEM): verranno applicati i cambi letti dalla tabella cambi.
  • Entrambe le monete NON fanno parte dell'UEM: in questo caso o si imposta il Cambio e il rispettivo operatore per fare il cambio diretto oppure il programma cerca nella tabella Cambi i relativi cambi rispetto l'Euro.
  • SOLO UNA delle due monete fa parte dell'UEM: per questa si prende il cambio dalla Tabella Cambi, per l'altra o si imposta a video il cambio e l'operatore (come si farebbe in tabella cambi es. per il dollaro: cambio 1,1682 e operatore / ) oppure il programma cerca il cambio in tabella.

    Se il cambio inserito viene utilizzato per la moneta del listino di destinazione, il programma invertirà l'operatore (se / applicherà * e viceversa)

Variazione
Consente di variare un listino a una certa data applicando parametri di aumento o diminuzione in modo analogo alla creazione.

E' possibile in questa fase, variare la percentuale di sconto del singolo articolo/listino scegliendo Modifica sconto articolo-listino e digitando il vecchio valore (o selezionando 'tutti' se si vuole mettere in tutti il nuovo valore) e il nuovo valore da assegnare.

In modo analogo è possibile variare la modalità di applicazione dello sconto assegnando a Tutti la stessa modalità o impostando la modalità da variare e quella nuova da assegnare.

Cancellazione
Si chiede il codice del listino e la data di validità. Poiché per ogni listino e per ogni articolo si possono inserire più prezzi di listino, ciascuno con la propria data, verranno cancellati tutti i prezzi non più validi alla data digitata. Es. un articolo ha per il listino 1 due prezzi: uno con data inizio listino 01/01/99 e un' altro con data inizio 01/03/99. Se si cancella questo listino fino alla data 15/03/99, verrà cancellato il primo prezzo e mantenuto il secondo in quanto valido al 15/03/99.

Se si lascia bianca la data verranno cancellati TUTTI i prezzi di quel listino, per gli articoli selezionati.

Occorre inoltre specificare se si vuole cancellare il listino, il listino promozione o entrambi.


FINE ANNO (MAGAZZINO)

All'inizio di un nuovo, prima di cominciare a movimentare il magazzino, è necessario eseguire la funzione Cambio Anno per predisporre gli archivi a ricevere i progressivi del nuovo anno.

La suddetta funzione trasferisce i costi e la giacenza finale dell'anno precedente sulla giacenza iniziale del nuovo anno.
Potrebbe succedere che al momento di eseguire il cambio anno non sia ancora stato controllato il magazzino e non siano state sistemate le giacenze.
In questo caso si consiglia di eseguire ugualmente il Cambio anno poi, di eseguirlo di nuovo, una volta sistemate le giacenze sull'anno precedente.

In alternativa si può sistemare la giacenza iniziale del nuovo anno e quindi fare l'inventario col metodo: Solo valore iniziale.

Sono disponibili anche una serie di funzioni che consentono di inserire (o caricare da file) un' inventario manuale e di generare automaticamente i movimenti per l'allineamento delle giacenze.


CAMBIO ANNO DI MAGAZZINO

Percorso: Magazzino - Annuali

Questa funzione deve essere eseguita ad ogni fine anno, prima di inserire registrazioni dell'anno 'nuovo'. (Per fine anno si intende normalmente il 31/12 tuttavia, per alcune ditte, la fine dell'anno contabile è spostata, ad esempio, al 30 aprile)

Se non risulta installata la procedura di contabilità, questa funzione aggiorna anche l'anno di lavoro di contabilità che serve per esigenze interne alla procedura.

Lo scopo di questa funzione è quello di predisporre i progressivi e i costi di ogni articolo per il nuovo anno (in particolare di trasferire sul nuovo anno la giacenza iniziale).

Se, al momento dell'esecuzione del programma, le giacenze finali dell'anno precedente non sono ancora definitive, esso dovrà essere eseguito di nuovo, non appena queste ultime siano state sistemate.

La necessità di trasferire i costi sul nuovo anno, nasce dal fatto che i nuovi movimenti fatti sull'articolo non dovranno alterare i costi dell'anno precedente (che potranno servire per stampe varie) ma dovranno partire da una copia di questi per una corretta elaborazione.

Viene visualizzato l'anno e il periodo di validità attuale del magazzino e si chiede di inserire il nuovo anno.

L'anno inserito dovrà essere, quando si esegue la funzione per aprire un nuovo anno, maggiore di una unità rispetto a quello attualmente in uso. Se invece si utilizza il programma in un secondo tempo, per trasferire le giacenze finali dell'anno precedente sulle iniziali di quello in uso, l'anno digitato dovrà essere uguale a quello in uso.

Se l'anno digitato è successivo (di una unità) a quello in tabella il programma si predispone per calcolare e trasferire sul nuovo anno di ogni articolo (per ogni magazzino in uso): i progressivi dell'ordinato, la giacenza iniziale e i costi (ultimo, medio di carico etc.).

La giacenza iniziale viene valorizzata e si chiede di scegliere tra vari metodi di valorizzazione (gli stessi utilizzati nella stampa dell'inventario). E' possibile indicare anche un metodo alternativo da utilizzarsi nel caso che, per qualche articolo, il costo utilizzato per la valorizzazione sia a 0; in questo caso la valorizzazione della giacenza iniziale verrà fatta con questo secondo metodo.

Al termine verrà scritto in tabella di magazzino il nuovo anno e il nuovo periodo di validità.

Viceversa, se l'anno digitato è uguale a quello corrente (di magazzino) si consente di scegliere se:

  • - ritrasferire le giacenze iniziali (potrebbero essere state fatte, sull'anno precedente le opportune correzioni di giacenza e si rende quindi necessario ricalcolare le giacenze iniziali e scriverle sulle sintesi dell'anno in corso); in questo caso si chiede se si intendono ricoprire o meno, le giacenze iniziali già esistenti.
  • - ritrasferire i costi (se, sul nuovo anno, esiste già la tabella dei costi per un articolo, verranno trasferiti solo quei costi che non sono valorizzati sul nuovo anno o la cui data è minore o uguale a quella del vecchio anno).

Tipi di valorizzazione della giacenza:

  • Medio di Carico
  • Medio Ponderale
  • Ultimo Costo
  • Costo Standard
  • Come valorizzato (non implementato)
  • Per i calcoli, vedere Inventario

Trasferimento dei progressivi dell'ordinato
La prima volta che si esegue il programma, vengono trasferiti i progressivi dell'ordinato dell'anno precedente su quelli del nuovo anno. Se sul nuovo anno c'è già un progressivo ordinato (cioè sono già stati inseriti ordini) questo viene sommato al vecchio.

In ogni caso, per risistemare i progressivi dell'ordinato, basta eseguire rispettivamente le funzioni 'ripristino progressivi ordinato clienti' e 'ripristino progressivi ordinato a fornitori'.

In caso di interruzione:

  • se non sono stati scelti nè il passaggio delle giacenze, né dei costi, il programma trasferisce solo l'ordinato per cui basta eseguirlo d i nuovo.
  • se si stavano trasferendo le giacenze iniziali occorre rilanciare il programma dicendo di sovra scrivere le giacenze
  • se si stavano trasferendo i costi, basta rieseguire il programma.


INVENTARIO

Percorso: Magazzino - Annuali

Questa funzione consente di ottenere la stampa della valorizzazione del magazzino a una qualsiasi data. Se non viene impostata la data verranno considerati i progressivi attuali di ogni articolo (e l'elaborazione sarà più breve), viceversa verranno elaborati tutti i movimenti dell'anno fino a quella data.

Se si imposta la data di stampa, verranno elaborati tutti e soli i movimenti con causale di magazzino con flag: In inventario e giornale impostato a si.

La giacenza attuale calcolata può, a scelta dell'operatore, essere abbattuta della percentuale di riduzione inserita nell'anagrafica articolo (questo per la gestione di articoli particolari quali ad esempio i legnami).

La stampa può essere fatta in due formati: normale e per libri inventari nelle quale per ogni articolo si riporta solo giacenza attuale, valore unitario, valore totale.

Se è stata scelta la stampa Normale, è stata impostata la data e a quella data è stato inserito un inventario manuale, è possibile stampare, oltre alla giacenza calcolata anche la giacenza inserita manualmente con la gestione inventario manuale. In questo caso, al termine della stampa inventario, verranno elencati gli eventuali articoli presenti solo nella tabella dell'inventario manuale.

Poiché sulla tabella dell'inventario manuale possono essere stati inseriti inventari con codice diverso e stessa data, selezionando con il pulsante di aiuto sulla data inventario, una riga dell'inventario manuale, verranno comunque stampati tutti gli articoli presenti sull'inventario manuale, alla data di quella riga, indipendentemente dal codice inventario.

E' possibile escludere dalla stampa gli articoli con giacenza a zero.

E' obbligatorio scegliere un 'metodo' cioè indicare quale valore utilizzare per la valorizzazione dei prodotti.

Si può scegliere tra:

  • Medio di Carico
  • Costo Medio Ponderale
  • Costo ultimo
  • L.I.F.O.
  • Costo Standard
  • Prezzo Medio Aritmetico
  • (L.I.F.O. continuo verrà fatto a parte)
  • Costo Medio Ponderale Annuale
  • Solo valore iniziale

Metodo alternativo
Serve per dire quale costo prendere nel caso il costo indicato dal primo metodo sia a 0. Vengono riproposti gli stessi metodi elencati sopra.

Viene proposto anche il codice di un listino che servirà nel caso si scelga uno dei due metodi: Prezzo Medio Aritmetico o Listino.

E' possibile includere o escludere dall'inventario alcuni gruppi articoli

Applico % di riduzione: se si spunta questo campo, il programma, calcolata la giacenza, la ridurrà della percentuale di riduzione inserita nell'anagrafica articolo (questo per la gestione di articoli particolari quali ad esempio i legnami).

Gli articoli sui quali sono stati impostati a No i segnali di 'In Giornale' e 'Articolo di magazzino', potranno essere esclusi dall'inventario, a scelta dell'operatore, spuntando, tra le selezioni di stampa, le opzioni relative.

Vengono considerati tutti gli articoli che soddisfano le selezioni, attivi e non.

CALCOLI

Se viene chiesto l'inventario a una data, vengono ricalcolati a partire dai movimenti, la giacenza, il costo ultimo e il medio di carico (per semplicità: somma valori carico/quantità carico e non in base alla causale che aggiorna il medio di carico) a quella data.

  • Medio di Carico
    Il valore unitario è il Costo Medio di Carico dell'anno (vedi Costi articolo). Il medio di carico si ottiene dividendo il Valore per Costo Medio di Carico per la Quantità (progressivi incrementati dalle causali che aggiornano il medio di carico).
    Se sia il medio di carico sia l'alternativo sono a 0 e la giacenza è diversa da 0 perché lo è la giacenza iniziale allora si valorizza al valore della giacenza iniziale.
  • Costo Medio Ponderale
    Il valore unitario è il Costo Medio Ponderale (vedi Costi Articoli)
  • Costo Ultimo
    Il valore unitario è il Costo Ultimo
    Se quantità carico e Ultimo Costo=0 allora valore unitario = valore unitario della giacenza iniziale
  • L.I.F.O. continuo
    Se Giacenza Attuale <= G.Iniziale allora Valore Unitario = Valore Unitario della Giacenza Iniziale
    Altrimenti :
    Val. Unitario = [(Giac.Attuale - Giac.Iniz.)*Costo Medio Pond. + Valore Giacenza Iniziale] / Giac.Att
    Valore Totale = Valore unitario * Giacenza Attuale
  • Costo Standard
    Il valore unitario è il costo standard (vedi Costi articolo)
    E' un costo da inserire manualmente nell'archivio costi per chi lo vuole utilizzare.
  • Prezzo Medio Aritmetico
    Se quantità scarico = 0 allora Valore Unitario = Prezzo di Listino
    Se <> 0 allora Valore Unitario = Valore Scarico / Quantità Scarico dai costi dell'articolo.
  • Costo Medio Ponderale Annuale
    Valore Totale = Valore della Giacenza Iniziale + Valore Carico
    Quantità = Giacenza Iniziale + Quantità Carico
    Se Quantità <> 0 allora Valore Unitario = Valore Totale / Quantità altrimenti Valore Unitario = 0
    Valore Totale = Valore unitario * Giacenza Attuale
  • Solo valore iniziale
    Valore unitario = valore unitario della giacenza iniziale
    Quantità =Giacenza Iniziale e si pongono Quantità Carico e di Scarico =0


INVENTARIO MANUALE

Percorso: Magazzino - Annuali - Inventario manuale

Questa tabella consente di inserire, per ogni riga, identificata da un codice inventario diverso, inserita nella tabella Inventari, la giacenza effettiva degli articoli nei vari magazzini a quella data. I dati, in questa tabella, potranno essere caricati manualmente da gestione o da file, tramite collegamento con lettore ottico.

Se si leggono gli articoli da inserire da file (o da lettore ottico) verrà chiesto di digitare il codice del magazzino su cui caricare le giacenze.

In automatico viene proposto il codice inventario corrispondente all'ultima data inserita in tabella inventari.

Lo scopo è di poter poi generare in automatico dei movimenti di rettifica (in aumento o in diminuzione) per sistemare la giacenza degli articoli a quella data. Ad eseguire questa funzione è il programma:

Generazione movimenti da inventario manuale.

Se un articolo, alla data dell'inventario, ha la giacenza a 0 (mentre dalla procedura risulta diversa da 0) occorre inserire nella tabella inventari una riga con giacenza 0. Il programma che genera i movimenti provvederà a generarne uno con una quantità tale da portare a 0 la giacenza.

Se gli articoli hanno taglia e colore, occorre inserire una riga di giacenza per ogni taglia/colore.

Se in una ditta, durante l'inventario manuale, c'è la possibilità di trovare gli stessi articoli in posti diversi per cui c'è la necessità di inserire, per uno stesso articolo, giacenze diverse che poi dovranno essere sommate, si può operare nel modo seguente:
inserire più codici inventari alla stessa data, in ogni inventario ogni articolo dovrà essere presente una volta sola

in fase di Creazione movimenti da giacenze inventario, sarà possibile digitare la data inventario e lasciare bianco il codice, in questo caso il programma considererà tutte le righe di inventario manuale inserite in quella data, sommerà le quantità a parità di codice articolo determinando la giacenza totale degli articoli che ricorrono più volte e infine creerà i movimenti di rettifica.

Nella stampa inventario di magazzino, è possibile, se si chiede l'inventario a una data che esiste anche nella tabella inventari, stampare la giacenza dell'articolo calcolata a quella data, a partire dai movimenti, quella inserita con l'inventario manuale e la differenza.


INVENT.MANUALE - TABELLA INVENTARI

Percorso: Magazzino - Annuali - Inventario manuale

Questa tabella contiene codici, date e descrizioni degli eventuali inventari manuali inseriti o da inserire con la funzione: inventario manuale.

E' obbligatorio inserire la riga che identifica l'inventario (codice e data) in questa tabella prima di procedere all'inserimento delle singole giacenze con la funzione "Inventario manuale".


INVENT. MANUALE - STAMPA

Percorso: Magazzino - Annuali - Inventario manuale

Questa funzione esegue la stampa parziale o totale dei dati inseriti nella tabella degli inventari manuali.


INVENT.MANUALE - GEN. MOVIMENTI

Percorso: Magazzino - Annuali - Inventario manuale

Questa funzione consente di generare dei movimenti di rettifica per 'sistemare' la giacenza di un gruppo di articoli, ad una certa data.
La data e le giacenze di riferimento vengono prelevate dalla tabella dell'inventario manuale.

L'operatore dovrà inserire in tale tabella l'elenco delle giacenze effettive, ad una certa data, degli articoli da rettificare .

Il programma chiede il "codice inventario" che identifica l'inventario manuale dal quale prelevare data, articoli e giacenze. Tale data diventerà la data dei movimenti di rettifica.

E' possibile anche digitare solo la data e lasciare bianco il codice, in questo caso il programma considererà tutte le righe di inventario manuale inserite in quella data, sommerà le quantità a parità di codice articolo determinando la giacenza totale degli articoli che ricorrono più volte e infine creerà i movimenti di rettifica.

(Questo è utile se in una ditta, durante l'inventario manuale, c'è la possibilità di trovare gli stessi articoli in posti diversi per cui c'è la necessità di inserire, per uno stesso articolo, giacenze diverse che poi dovranno essere sommate. Si dovranno inserire più codici inventari alla stessa data, in ogni inventario ogni articolo dovrà essere presente una volta sola)

Vengono chiesti inoltre due codici causali di magazzino, uno per le rettifiche in positivo (un movimento di carico se la giacenza calcolata alla data del movimento è inferiore a quella digitata nella tabella inventari) e uno per quelle in negativo per il movimento inverso.

Queste due causali dovranno essere impostate in tabella Causali di magazzino rispettivamente solo il magazzino in destinazione (carico) o in provenienza (scarico) e non dovranno toccare i prezzi in quanto i movimenti vengono fatti a prezzo 0.

Se un articolo, alla data dell'inventario, ha la giacenza a 0 (mentre dalla procedura risulta diversa da 0) occorre inserire nella tabella inventari una riga con giacenza 0. Il programma provvederà a generare un movimento con una quantità tale da portare a 0 la sua giacenza.
In alternativa è stata inserita una opzione:
Azzera giacenza articoli che non sono presenti nell'inventario manuale che si sta elaborando
Spuntando questa opzione si ottiene l'azzeramento della giacenza di TUTTI gli articoli NON presenti nell'inventario che si sta elaborando. Il calcolo della giacenza, anche per gli articoli da azzerare, verrà fatta alla data dell'inventario in elaborazione.


LIFO ARTICOLI - GESTIONE

Percorso: Magazzino - Annuali - LIFO

Il programma consente la gestione dell'archivio LIFO. Per ogni articolo (ed eventualmente per articolo/taglia e colore) è possibile inserire la giacenza e la valorizzazione per n anni indietro, questo per consentire una corretta stampa della valorizzazione Lifo.

I campi in gestione, vengono aggiornati, anno per anno, dalla stampa dell'inventario lifo.
Giacenza
giacenza di fine esercizio.
Valore unitario
valore di inventario calcolato col metodo lifo a scatti.
Valore totale
è uguale al valore unitario moltiplicato per la quantità in giacenza.
Costo medio
costo medio di carico dell'anno dato dal rapporto fra valore e quantità di carico dell'articolo.


LIFO - CANCELLAZIONE ARCHIVIO

Percorso: Magazzino - Annuali - LIFO

Il programma consente la cancellazione parziale dell'archivio LIFO. Si possono cancellare le righe di anni passati con eventuale selezione sugli articoli.


LIFO - STAMPA ARCHIVIO

Percorso: Magazzino - Annuali - LIFO

Il programma permette la stampa dei valori presenti nell'archivio Lifo, ordinati per codice articolo e anno.


LIFO - STAMPA INVENTARIO

Percorso: Magazzino - Annuali - LIFO

Il programma consente la stampa dell'inventario L.I.F.O a scatti.
Generalmente sarà utilizzata a fine anno e la sua esecuzione come DEFINITIVA provvede a creare, nell'archivio Lifo, i valori relativi all'anno corrente.

Se l'articolo è nuovo viene valorizzato in base al costo medio ponderato di periodo attribuendo ad ogni unità il valore risultante dalla divisione del costo complessivo dei beni prodotti e acquistati nell'esercizio stesso per le loro quantità.

La valutazione così ottenuta costituisce la base di partenza alla quale rapportare le giacenze dei periodi successivi.


CANCELLAZIONE ARTICOLI

Percorso: Magazzino - Servizio

Questa funzione può essere utilizzata per eliminare uno o più articoli dall'archivio 'articoli' e dagli archivi collegati (es. progressivi, costi, etc)

Condizione necessaria perché un articolo sia cancellabile è che esso non sia mai stato movimentato per cui i suoi progressivi in qualsiasi anno e in qualsiasi magazzino devono essere a 0 e non devono esistere dei movimenti di magazzino che si riferiscono ad esso.

Se si vogliono cancellare anche gli articoli movimentati occorre fare un click sulla apposita casella.

La selezione degli articoli da cancellare può essere fatta per codice, per gruppo e sottogruppo.

E' possibile infine decidere di escludere dalla cancellazione, articoli il cui codice contiene una sequenza di caratteri da scrivere nel campo specificato (es. WEL* oppure *WEL).

E' possibile interrompere l'elaborazione premendo il pulsante Interrompi

Nota: Se si inserisce un codice articolo inesistente, il programma 'elimina' dagli archivi listini, costi, progressivi, le righe che si riferiscono ad articoli non presenti in archivio articoli.


CANCELLAZIONE MOVIMENTI FINO ALLA DATA

Percorso: Magazzino - Servizio

Esegue la cancellazione dei movimenti di magazzino fino alla data richiesta a video.

Potrà essere utilizzato, in particolare, per cancellare i movimenti di anni precedenti non più utili.

E' possibile digitare anche il codice di un magazzino per specificare che si vogliono cancellare SOLO i movimenti di quel magazzino.
In questo caso NON verranno comunque cancellati i movimenti interni, in quanto questi, anche quando coinvolgono il magazzino per cui si chiede la cancellazione, coinvolgeranno sempre anche un altro magazzino e cancellarli genererebbe errore sulla correttezza dei movimenti di quest'ultimo.

Si può impostare il parametro di personalizzazione MagCancMov con il codice di magazzino del quale si vogliono cancellare i movimenti.

E' inoltre possibile mantenere, se utilizzati, i movimenti relativi ad articoli con codice lotto (tracciabilità) oppure con matricola in modo da non perdere le informazioni, pur cancellando tutti gli altri movimenti. Per quanto riguarda il lotto si può scegliere se cancellare comunque tutti i movimenti o solo quelli riferiti a lotti chiusi o solo quelli riferiti a lotti chiusi e chiusi forzati o non cancellarli affatto.

Se il programma trova dei movimenti in cui manca la testata (situazione anomala) chiede se si vogliono stampare oppure se proseguire cancellandoli.


CANCELLAZIONE PROGRESSIVI E COSTI ARTICOLI

Percorso: Magazzino - Servizio

Esegue la cancellazione di tutti gli elementi, degli archivi dei progressivi e costi articoli che soddisfano le richieste a video.
E' possibile cancellare tutti i dati di un intervallo di anni, scegliere tutti o solo un gruppo di articoli, SOLO i Progressivi o SOLO i Costi e, per i Progressivi, è possibile scegliere di cancellare SOLO quelli che sono tutti a zero per un determinato anno (cioè quelli degli articoli non movimentati nell'anno e senza giacenza iniziale).

Potrà essere utilizzato per cancellare dati di anni precedenti non più utili.

In particolare, se servisse cancellare le anagrafiche di articoli NON più a magazzino, non movimentati nell'ultimo anno e senza giacenza iniziale, si può:

sdoppiare il database in modo da rimanere uno storico

sul database da utilizzare per l'anno in corso, eseguire una cancellazione progressivi e costi degli anni precedenti.
Successivamente eseguire una cancellazione dei progressivi dell'anno in corso con l'opzione 'SOLO quelli con TUTTE le quantità a 0'
A questo punto sarà possibile la cancellazione dei soli articoli non movimentati con l'apposita funzione.

Durante la cancellazione nessuno deve lavorare sui movimenti di magazzino.
Se, nonostante nessun altro stia lavorando, il programma da il messaggio: Ci sono movimenti in elaborazione, impossibile eseguire la cancellazione, occorre, prima di procedere, eseguire il recupero movimenti interrotti per ripristinare una situazione anomala preesistente.

Se nel campo Anno Da si mette il valore 1 cancella tutti i progressivi fino all’anno messo nel campo Anno A per gli articoli che hanno a 0 tutte le quantità nell’anno indicato in Anno A


AZZERAMENTO PROGRESSIVI ARTICOLI

Percorso: Magazzino - Servizio

Consente di azzerare i progressivi (quantità e valore), relativi ad un certo anno, di un gruppo o di tutti gli articoli. A scelta dell'operatore potranno essere azzerati anche i progressivi dell' ordinato.

Questa funzione deve essere utilizzata con molta attenzione in quanto la sua esecuzione crea un disallineamento tra movimenti, ordini e progressivi. Ha senso che venga utilizzata solo da chi non utilizza in assoluto i movimenti.


VENDITE (FATTURAZIONE)

La procedura di Vendite (fatturazione) può essere utilizzata in modo indipendente oppure in collegamento con Magazzino, Ordini di Acquisto e di Vendita e Contabilità.

CARATTERISTICHE PRINCIPALI

  • Gestione di più anni in linea
  • Possibilità di utilizzare gli articoli di magazzino, come descrizioni da inserire sui documenti, anche senza installare la procedura di magazzino.
  • Documenti in euro, (in lire) o in qualsiasi altra valuta.
  • Emissione documenti tramite Tipi documento personalizzabili a seconda delle esigenze
  • In presenza del modulo della Distinta Base, possibilità di generare in automatico il movimento di scarico dei componenti al momento della vendita del prodotto finito.
  • Se si utilizzano Ordini e Preventivi, sarà possibile, con l'evasione, generare in automatico Ddt e Fatture che poi potranno essere gestite, completate e stampate successivamente.
  • Emissione Ddt ed evasione in fattura riepilogativa con possibilità di raggruppo per articolo e/o per destinazione.
  • Emissione di ddt interni per spostamento merci da una sede ad un'altra.
  • Emissione fatture dirette e accompagnatorie.
  • Emissione fatture alla Pubblica Amministrazione. Disponibilità del modulo aggiuntivo, Fattura PA, per la preparazione del file della fattura in formato XML e un servizio di invio alla PA e Conservazione Sostitutiva a norma di legge. Gestione Split Payment per le fatture PA
  • Estrazione dati per preparazione file Xbrl per Progetto Tessera Sanitaria
  • Utilizzo della stessa interfaccia per l'inserimento dei vari documenti in modo da facilitare l'operatività.
  • Descrizioni in lingua degli articoli sui documenti
  • Per ogni documento è possibile fare prestampa, stampa e ristampa
  • Possibilità di 'annullare la stampa' di una fattura stampata per poterla poi variare o cancellare. In caso di cancellazione di una fattura proveniente da Ddt, verranno ripristinati a 'non evaso' tutti i Ddt
  • Formati di stampa completamente parametrizzabili dall'utente tramite la creazione di filtri (modelli) di stampa sia per stampanti ad aghi sia laser.
  • Personalizzazione delle diverse tipologie di spese da richiamare nei documenti
  • Sconti codificabili nella forma x+y. Oltre allo sconto diretto sul listino, sconto articolo e cliente, è possibile compilare delle tabelle di sconto (o prezzo già definito) per articolo-cliente, categoria cliente-articolo, cliente-gruppo/sottogruppo articolo, categoria cliente-gruppo/sottogruppo articolo. Sconti a quantità.
  • Generazione scadenze da fatture emesse con possibilità di creazione distinte e successiva presentazione delle Ri.Ba.
  • Statistiche
  • Provvigioni: calcolo delle provvigioni sul fatturato o sull'incassato, con percentuale ( o importo) a livello di cliente, di agente o di singolo articolo.
  • Possibilità di abilitare le gestioni: livelli (taglia e colori), matricole e tracciabilità nei documenti.

Come impostare i dati per cominciare ad utilizzare la procedura.

Come per uno qualsiasi degli altri moduli della procedura, è necessario compilare le tabelle generali tramite la funzione: Dati Generali Azienda
Nel caso specifico dell'utilizzo della sola procedura di Fatturazione è indispensabile compilare:

  • Anagrafica ditta
  • Parametri comuni di Magazzino, di Fatturazione e inoltre alcuni conti in Conti Comuni e alcune causali in Causali comuni (in particolare se le fatture devono poi essere passate in contabilità).
    La creazione, nelle singole tabelle, dei codici obbligatori, può essere fatta direttamente dalla maschera della richiesta parametri aprendo la lista di aiuto sui codici (tasto F2 o click sul quadratino posto a fianco ad ogni codice) e premendo il pulsante [image] (X) Gestione archivio
  • Successivamente occorre compilare, con la scelta Archivi comuni
    - le Tabelle di Magazzino (quelle collegate agli articoli: es.unità di misura)
    - le Tabelle di Contabilità (quelle collegate ai clienti: banche, condizioni di pagamento etc.)
    - le Tabelle Vendite
  • Infine, per una corretta numerazione delle fatture, occorre inserire in Contabilità – Gestioni – Prefissi e numeratori documenti, almeno una riga per il numeratore delle fatture di vendita.


DdT GESTIONE

Percorso: Vendite - Ddt - Gestione ddt

La funzione consente di inserire, variare, cancellare o visualizzare i Ddt (Bolle).

Possono essere inserite e stampate con questa funzione anche i DdT di Reso merce ai fornitori in quanto, se specificato sul tipo documento, può essere impostato un codice fornitore al posto del cliente.

Se il tipo documento utilizzato è di tipo Interno, verrà chiesto di inserire anche il magazzino di destinazione e, alla stampa, verrà generato un movimento interno di spostamento merce da un magazzino all'altro.

Gli articoli coinvolti in un ddt, possono essere caricati da un file esterno oltre che digitati manualmente (Caricamento dettagli documenti da file).

Per ogni articolo caricato è possibile gestire il lotto e/o la matricola in modo da ottenere la tracciabilità, una stampa dei movimenti delle matricole etc.

Per abilitare la gestione dei lotti occorre aver installato il modulo Tracciabilità

Per abilitare la gestione matricole occorre inserire nei parametri di personalizzazione, il parametro: MatrGest
Una volta abilitato il parametro, in fase di inserimento di un articolo è possibile digitare o caricare da file le matricole.

E' possibile gestire in automatico il contributo Raee, per gli articoli per il quali è previsto.

E' prevista la gestione delle cauzioni consegnate e rese.
Vedi Gestione vuoti.

Se è stato installato il modulo della distinta base, codificando in modo opportuno il tipo documento Ddt e nel documento ci sono articoli con distinta base, al momento della stampa, oltre a creare il movimento di magazzino di scarico degli articoli venduti, il programma creerà un altro movimento per il carico degli stessi articoli che sono prodotti finiti e uno per lo scarico dei relativi componenti.
Inoltre, se il documento è ottenuto per evasione di un ordine, verrà decrementato anche il progressivo ordinato dei componenti.

Per inserire un nuovo DdT occorre accertarsi di aver precedentemente creato, con l'apposita gestione, il Tipo di documento Ddt opportuno, digitare 0 nel campo Numero Riferimento, compilare i campi della testata poi premere il pulsante [image] (E) Gestione Dettagli, o Salva, per passare all'inserimento dei dettagli.
Nella testata di un ddt è abilitato il pulsante [image] (D) Duplica
Esso consente di generare un ddt con le stesse caratteristiche di quello su cui si è posizionati. Il suo stato sarà 'bianco' cioè appena inserito.

E' consentita la ricerca di un documento digitando uno o più campi della testata e premendo il pulsante di Ricerca. Se esiste un unico documento con le caratteristiche impostate, verrà visualizzato mentre se ne esiste più di uno, verrà proposto un elenco.
Una volta inserito, il documento si può stampare premendo il pulsante
(T) sTampa

Vedi Stampa DdT

Variazione di un Ddt stampato:
poiché al momento della stampa del Ddt gli viene attribuito il numero progressivo e vengono movimentati gli articoli in esso contenuti, sulla testata si può variare unicamente la Condizione di pagamento e la Banca mentre, nel corpo, si possono variare le descrizioni degli articoli, le rispettive note sopra/sotto e le righe descrittive; si possono inoltre aggiungere righe descrittive.

Per poter variare altri dati su un Ddt 'stampato' occorre portarlo allo stato di 'non stampato' utilizzando uno dei modi seguenti:

  • premendo il pulsante [image] (N) Annulla la stampa
  • eseguendo la funzione Reintegro DdT a 'non stampato' dal menu di Servizio delle Vendite.

In questo modo il Ddt rimarrà numero e data assegnati in precedenza ma verrà cancellato il movimento di uscita della merce dal magazzino, registrato al momento della stampa. Una volta effettuata la modifica è indispensabile stampare di nuovo il Ddt.

Un Ddt può essere cancellato fino a quando non è stampato.
La cancellazione di un ddt che evade uno o più ordini, riapre tali ordini.

La variazione (o cancellazione) di un Ddt evaso non può essere fatta se non cancellando la fattura con la quale è stato evaso e, successivamente, togliendo ad esso lo stato di 'stampato'.

Se però si tratta di un ddt da non fatturare (evaso forzatamente da Evasione ddt) basta entrare nel ddt, sul quadro 'Documenti di origine e di evasione' e premere il Pulsante [image] (Ripristino ddt da evaso a stampato)

Ogni DdT si compone di due gruppi principali di dati: la testata (dati del cliente, note, dati di accompagnamento, spese) e il dettaglio (elenco degli articoli).

Per ulteriori spiegazioni sui pulsanti, si rimanda a Pulsanti in gestione movimenti e documenti.

Parametri di personalizzazione gestiti da questo programma:

InizioAvvisoCliente
Se impostato con qualche carattere (es. $$), il programma stamperà un avviso sulla maschera del cliente se la nota in anagrafica cliente/fornitore inizia con questi caratteri.
Se nel valore si scrive Tutti , l'avviso verrà evidenziato ogni volta che si richiama un cliente con le note compilate.

CalcolaPeso
Se impostato a S, il programma all'uscita dai dettagli (righe di articoli), calcola il peso totale (peso lordo letto sull'anagrafica di ogni articolo * quantità * Fattore di conversione) e compila la casella Peso gestita nei dati di accompagnamento.
Se il parametro manca o non è impostato a S, per forzare il calcolo del peso occorrerà premere il pulsante con i puntini a fianco al campo peso nei dati di accompagnamento.

Segnalazione giorni scaduto
Se sul tipo documento utilizzato per la registrazione, è stato impostato il campo 'Giorni per controllo scaduto' verrà segnalato, una volta digitato il codice del cliente, se esistono scadenze aperte con data inferiore alla data di inserimento documento meno il numero dei giorni. Inoltre, sul documento, nel quadro 'note del cliente' verrà visualizzato l'importo di tali scadenze.

Testata Documento

Nr.Riferimento, anno
Se viene digitato un numero e si preme il pulsante Ricerca, il programma va in ricerca del documento con quel numero. Impostando il numero a 0 si entra in modalità inserimento e viene assegnato un numero progressivo nell'anno, automaticamente dal programma.

Questo numero serve unicamente per identificare, insieme alla data, il documento prima che esso venga stampato. Non è da confondere con il numero documento!

Inserito il
È la data in cui è stato inserito il documento ed è indipendente dalla data di stampa. Serve, insieme al numero, per identificare il documento in ricerca anche prima che questo venga stampato.

Tipo documento
Identifica le caratteristiche del documento inserito. Viene proposto quello scritto nella tabella di fatturazione. Dal tipo documento vengono lette alcune caratteristiche es. il prefisso, il listino, il magazzino di scarico del documento, il fatto che si rivolga ad un cliente o ad un fornitore e in particolare come aggiornare i progressivi dell'articolo. Se nel tipo documento Ddt non è stata collegata una causale di magazzino non verrà generato il movimento di magazzino e non verrà aggiornato di conseguenza il progressivo di scarico dell'articolo.

Questo campo non si può variare se ci sono dei dettagli.

Pref.
Viene proposto quello del tipo documento (se c'è), altrimenti quello principale scritto sulla tabella di fatturazione. E' possibile variarlo nell'ambito dei caratteri inseriti in Tabella di Fatturazione come Elenco Prefissi Ddt. Consente di inserire DdT appartenenti a diversi bollettari.

Numero e data documento
Il numero viene assegnato, al momento della stampa, prendendo il progressivo dai numeratori DdT, in base al prefisso, e aggiornandolo. Non si consente di stampare dei DdT con data di stampa inferiore alla data dell'ultimo DdT stampato in quanto si avrebbe un numero successivo in una data precedente.

Viene data la possibilità di impostare manualmente questi due campi, per recuperare, ad esempio, un documento fatto a mano. Il numero e la data inseriti dovranno tuttavia essere minori o uguali a quelli scritti sul numeratore (stesso prefisso). Se viene assegnato un numero manualmente, il programma controlla se in archivio esiste un'altra bolla con lo stesso numero e lo segnala con un messaggio consentendo di proseguire o correggere.

NON si consente di mettere manualmente un numero successivo a quello memorizzato nel numeratore.

Cod. Cliente/Fornitore
A seconda di come è stato definito il Tipo documento, in questo campo verrà accettato il codice di un cliente o di un fornitore come intestatario del DdT.

Con i tasti F2 ed F3 si consente di cercare rispettivamente per codice o ragione sociale cliente, con F4 e F5 per fornitore. Di seguito vengono visualizzati i dati anagrafici.

Le due 'parti' di ragione sociale vengono visualizzate con il seguente criterio (che è lo stesso utilizzato per la stampa dell'intestazione dei documenti): 1' parte è la 1' parte della Ragione Sociale del cliente, se sull'anagrafica cliente questa risulta non compilata, si prende la Ragione Sociale Contabile; 2' parte: si mette comunque il contenuto della seconda parte della Ragione Sociale cliente.

Se si sta inserendo un ddt interno, questo campo è comunque obbligatorio. Se la merce viene spostata in un altro magazzino e non c'è un soggetto interessato al movimento, si consiglia di utilizzare un cliente fittizio che può essere la ditta stessa. In alcuni casi invece può essere utile avere un destinatario effettivo come ad esempio nell'uso di un ddt interno per l'invio di merce in lavorazione; in questo caso il destinatario sarà un fornitore ma la merce può transitare da un magazzino principale a uno, fittizio, di merce in lavorazione in modo da potere, in ogni momento, sapere quanto è stato consegnato e quanto è ritornato.

Di seguito vengono visualizzati: indirizzo, Iso, P.Iva, Cod.Fiscale, Telefono

Se sul cliente è compilata la data di chiusura viene visualizzata la scritta CHIUSO di fianco alla Ragione sociale.

Se sul tipo documento è compilato il campo 'giorni per controllo scaduto (X)', verrà data una segnalazione se il cliente ha delle scadenze aperte da più di X giorni.

Se si varia il cliente verrà visualizzato il listino del nuovo cliente se prima il listino veniva da cliente con tutti i controlli di cambio listino.

Se varia il cliente deve vedere se il codice spesa del nuovo è diverso dal vecchio e se è diverso cancella sul quadro spese la spesa vecchia.

Num. Movimento
Solo visualizzato. E' il numero di movimento di magazzino generato.
Se è stato installato il modulo della Distinta Base, vengono visualizzati, in Altri Dati, anche anno e numero dei movimenti Di.Ba. Carico Produzione e Scarico componenti

Rif. Cliente
Campo descrittivo. In caso di ordine può essere il riferimento all'ordine del cliente che può essere richiesto di stampare sulla conferma d'ordine, e/o sui documenti di evasione. Se previsto sull'anagrafica del cliente, questo campo verrà stampato sul documento di evasione come riga di dettaglio.

Stato
Indica lo stato del documento. Il campo sarà bianco nei DdT appena inseriti mentre conterrà le scritte Stampato o Evaso rispettivamente dopo la stampa e l'evasione.

Sotto i dati di Testata vengono visualizzati i seguenti totali:
Tot. Spese Tot. Merce Tot. Imponibile Tot. Iva Totale Documento
Inoltre viene fatto un elenco sintetico delle righe di dettaglio inserite.

Parametri di personalizzazione:

NonContrSucc
Per non attivare il controllo della sequenza del numero/data ddt

Cliccando sulle etichette delle varie cartelle proposte sotto l'anagrafica del cliente, (o digitando Alt e il numero corrispondente) si può accedere ad altri dati.

DdT Cliente (1)
DdT Altri dati (2)
DdT Note di Testata (3)
DdT Dati di Accompagnamento (4)
DdT Nota Cliente (5)
DdT Doc. di origine e destinazione (6)
DdT Spese
DdT Dettagli


DdT CLIENTE (1)

Percorso: Vendite - Ddt - Gestione ddt

Listino
Codice listino. In generale è il codice di listino letto dall'anagrafica cliente. Se però sul Tipo Documento utilizzato è stato impostato un listino particolare, verrà visualizzato quest'ultimo. Nel caso che la causale per l'aggiornamento del magazzino, posta sul tipo documento, preveda che il prezzo da proporre sui dettagli debba venire dal costo ultimo o dal costo medio invece che da un listino, questo campo verrà lasciato bianco.

In presenza di un listino, la moneta del documento è quella del listino e i prezzi verranno intesi 'ivati o meno' a seconda di quanto specificato sul listino stesso.

Quando ci sono già dei dettagli inseriti, si consente di variare il codice listino a condizione che il nuovo abbia la stessa moneta e lo stesso valore nel flag 'prezzi ivati o no'.

Da un listino in lire si può passare a uno in euro e viceversa purchè abbiano lo stesso valore del flag 'prezzi ivati o no', ma non viene cambiata la moneta iniziale (sul listino c'è sempre il prezzo in lire e in euro).

Il nuovo listino varrà per i dettagli inseriti successivamente. Per assegnare il prezzo di listino nuovo sulle righe di dettaglio preesistenti occorre andare su ogni riga e premere il pulsante [..] posto a fianco a prezzo e a sconti.

Prezzi ivati
Indica come sono i prezzi sul documento se netti o comprensivi di iva. Viene impostato con il valore letto dal listino e, in inserimento, può essere variato dall'utente.

In questo modo un listino ivato in origine può essere utilizzato come non ivato e viceversa in quanto ci pensa il programma a ivare o scorporare il prezzo in base a questo flag.

Condizione di Pagamento
In generale, viene proposta quella del cliente e può essere variata per il documento in oggetto. Se la condizione richiamata prevede uno sconto pagamento, questo verrà visualizzato a fianco.
Esiste però la possibilità di impostare, sul tipo documento, quale condizione di pagamento utilizzare: o una particolare, il cui codice andrà scritto sul tipo documento stesso, o la seconda condizione scritta sul cliente.

Solo sulla fattura, se vengono generate al momento della stampa basterà che il programma che toglie lo stato di stampato, cancelli questa riga. Al cambio della condizione di pagamento variano le spese bancarie e le spese bolli per cui il totale fattura.

In fattura occorre cancellare, se si varia la condizione di pagamento, l'eventuale riga di spese bancarie creata perché prima c'era una condizione con spese bancarie.

Sconto Pagamento
Viene proposto il valore letto sulla condizione di pagamento del cliente.
Se viene variato, o cambia perché è variata la condizione di pagamento, viene ricalcolato il totale documento.

Sconto pagamento su dettaglio (S/N)
Se impostato a SI, l'eventuale sconto pagamento, verrà sommato agli sconti delle singole righe, piuttosto che essere calcolato sull'imponibile/i alla fine del documento. Si può impostare il parametro ScontoPagInDet per assegnare un valore di default al campo.

Sconto Cliente
Viene proposto il valore letto dall'anagrafica del cliente.
Se viene variato e sono già stati inseriti degli articoli sul documento, verrà chiesto se si vuole riportare il nuovo sconto sui dettagli. In caso affermativo verrà sostituito su ogni dettaglio in cui lo sconto cliente ha il valore vecchio, il nuovo valore e verrà ricalcolato lo sconto totale e l'importo di riga.

In particolare se viene messo uno sconto dove prima non c'era, questo verrà riportato in tutti i dettagli dove lo sconto cliente era vuoto.

Banca
Viene proposta quella del cliente e si può variare.
La ricerca del codice banca, oltre che per codice e descrizione, anche per ABI o ABI e CAB digitando l' ABI (completo o incompleto con * finale) oppure ABIçCAB (il carattere ç deve essere sempre scritto in fondo all'abi anche se non si mette anche il cab) e premendo il tasto F2 (lista per codice) o F3 (lista per descrizione).

Raggruppamento Ricevute Bancarie
Indica se in fase di compilazione distinte le ricevute bancarie del cliente devono essere raggruppate.
Viene visualizzato il valore letto sull'anagrafica cliente. Solo sulle fatture può essere variato.

Acconto
E' possibile indicare un acconto che il cliente ha anticipato per la merce in oggetto. La procedura ne terrà conto al momento della fatturazione per la determinazione degli importi delle scadenze da generare.

Perc.Riten.acconto
E' l'eventuale percentuale di ritenuta acconto che verrà utilizzata per il calcolo della ritenuta d'acconto da evidenziare sulla fattura e per la registrazione del relativo movimento durante la contabilizzazione.

Codice Iva
Viene visualizzato il valore impostato in anagrafica del cliente. Indica il codice di esenzione a cui è soggetto il cliente e che deve prevalere sull'aliquota dei vari articoli. Può tuttavia contenere anche un codice 'iva'. Se valorizzato, viene assunto come codice iva di ogni articolo che verrà inserito nel corpo del documento e non sarà possibile varialo.

Tale codice verrà impostato anche sulle eventuali righe di spesa, con possibilità di variazione.

Se viene variato il codice iva e ci sono delle righe di dettaglio (righe articolo) e/o spese, si chiede se si vuole aggiornare il codice iva su tutti i dettagli. Se il campo in testata è valorizzato e lo si sbianca, non viene fatta nessuna variazione sui codici iva dei dettagli.

Iva sospesa
Viene visualizzato il valore letto dall'anagrafica cliente con possibilità di varialo. Consente di emettere al cliente una fattura con iva differita o immediata.

Magazzino
E' il codice del magazzino dal quale scaricare gli articoli. Viene proposto quello scritto sul tipo documento o, se lì è bianco, si prende il magazzino principale dalla Tabella di Magazzino.

Magazzino di destinazione
Questo campo viene chiesto solo se si sta utilizzando un Tipo documento Interno, che consente cioè di fare un movimento da un magazzino ad un altro.

Da Fatturare
Indica se la bolla dovrà essere fatturata o meno. Viene impostato a SI o a NO a seconda che sul tipo documento sia stato compilato il tipo documento di evasione. Consente di avere un unico tipo documento bolla e di decidere, al momento dell'emissione, se fatturarla o no.

Dichiarazione di intenti
Vedi Dichiarazione di intenti in inserimento fattura


DdT ALTRI DATI (2)

Percorso: Vendite - Ddt - Gestione ddt

Moneta
E' la moneta del listino. Se non c'è un listino la moneta è quella principale. Si può variare solo in inserimento della testata del documento.

Cambio
Campo obbligatorio.
Viene proposto il cambio letto dalla tabella cambi, con data più vicina a quella del documento. In caso di documento in una moneta diversa rispetto quella principale, servirà per l'aggiornamento del valore di scarico sul magazzino. Nel caso di Ddt, il cambio non è da considerarsi definitivo, lo sarà quello inserito alla stampa della fattura.
Si può variare e provoca il ricalcolo dei valori in Lire e in Euro sui dettagli.

Prezzo in DDT
Indica le modalità di stampa dei prezzi sul Ddt. Viene impostato in base a quanto indicato in anagrafica cliente.
I casi previsti sono:

  • NO prezzi
  • Prezzi di listino e sconti
  • Prezzo di listino
  • Prezzo al netto degli sconti
  • Prezzo, sconti e totale di riga ivato (4)
  • Prezzo ivato, sconti e totale di riga ivato (5)
  • Prezzi, Sconti e Totale (6)

Addebito bolli (solo visualizzato)
E' una caratteristica letta dall'anagrafica clienti. Indica se addebitare o no il costo dei bolli per effetti, sulla fattura.

Raggruppo documenti
Indica se il documento deve essere evaso da solo o insieme ad altri compatibili. Viene proposta l'impostazione data al campo in anagrafica cliente.
Le possibilità sono:

  • Non raggruppabile
    Ogni ddt genera una fattura
  • Raggruppabile
    In evasione ddt, i ddt del periodo indicato, verranno inseriti in una unica fattura, purchè soddisfino una serie di condizioni
  • Raggruppabile per articolo
    Si riporta in fattura ogni articolo una volta sola con quantità uguale alla somma delle quantità dei vari ddt -utilizzata in particolare dai forni-
  • Ragguppabile per destinazione
    si genera una fattura per ogni destinazione - utilizzata da grandi distributori es.Conad -
  • Raggruppabile per articolo e per destinazione
  • Raggruppabile se stesso codice contratto

Ci sono inoltre in Tabella di Fatturazione altre due possibilità per raggruppare o meno in evasione:

  • Magazzino di Provenienza (consegna)
  • Vettore

Nota: Il raggruppo per articolo si fa solo se non c'è il taglia/colore.

Condizioni per cui più Ddt sono raggruppabili
In essi il contenuto dei campi in elenco deve essere identico:
Cliente
Moneta
Lingua
Condizione di pagamento
Sconto pagamento
Banca
Ragguppamento ricevute
Codice iva
Agenti
Flag prezzi ivati
Iva normale o ad esigibilità differita
Contratto (solo se raggruppabile per contratto)
CIG (Codice Identificativo di Gara)
CUP (Codice Unico di Progetto)
Magazzino (a seconda di quanto specificato in Tabella di Fatturazione)
Vettore (a seconda di quanto specificato in Tabella di Fatturazione)
(non ci sono acconti) oppure gli acconti si sommano tutti in un unico campo acconto della fattura
Cod.indirizzo di spedizione \
Indirizzo di spedizione / Solo se specificato nel flag Raggruppabile
Flag Sconto pagamento su dettagli (per fattura elettronica)
Codice lettera dichiarazione di intenti

Addebito spese bancarie (solo visualizzato)
Viene proposto il valore impostato sul cliente. Indica se addebitare o no in fattura le spese bancarie.

Contratto
Se il ddt si riferisce a un contratto, è possibile associarne il codice in modo da compilare poi correttamente la fattura e la Comunicazione delle Operazioni rilevanti ai fini Iva.

CIG e CUP
Sono rispettivamente il Codice Identificativo di Gara e Codice Unico di Progetto. Possono essere digitati direttamente sul documento o venire dal contratto.
Se si imposta un codice contratto sul quale sono stati inseriti i codici Cig e Cup, questi verranno riportati sul documento SOLO se non sono già impostati.
Se si sbianca il codice contatto, sul documento i codici Cig e Cup eventualmente già impostati perchè letti dal contratto inserito in precedenza, non verranno sbiancati.
Potranno essere stampati sul documento (occorre inserire righe apposite nel filtro di stampa) e verranno poi riportati sulla fattura.

Estrazione provvigioni 1 e 2
Vengono proposti i valori letti sull'anagrafica cliente in corrispondenza a ciascun agente:
NO, da Articolo, da Cliente, da Agente.

Se si varia questo campo e ci sono dei dettagli già inseriti, verrà fatta la richiesta se portare il nuovo valore su tutti i dettagli o solo su quelli per cui la percentuale coincide con la vecchia percentuale in testata.
La richiesta non viene tuttavia fatta se il campo viene impostato a NO o a 'da Articolo'.

Agente 1 , Agente 2 - % Provv. 1 e 2
Vengono proposti i codici agenti letti dall'anagrafica cliente e le rispettive percentuali, lette dall'agente o dal cliente a seconda di come sono stati impostati i campi: Estrazione Provvigioni.

Se è sull'agente verranno visualizzate le % dei due agenti con possibilità di variazione

Se si varia questo campo e ci sono dei dettagli già inseriti, verrà fatta la richiesta se portare il nuovo valore su tutti i dettagli o solo su quelli per cui la percentuale coincide con la vecchia percentuale in testata.

Lingua
Codice lingua letto dall'anagrafica cliente. Verrà utilizzato, compilato, per stampare sul documento le descrizioni degli articoli in lingua piuttosto che quelle in italiano.

Codici Note Fisse
Vengono proposti i codici letti dal tipo documento. Sono note fisse, scritte nel rispettivo archivio, che possono essere stampate sul documento. Verranno portate, solo se la nota lo prevede, sul documento di evasione, con un massimo di tre.

Mov.Di.Ba. Carico Produzione e Scarico componenti
Se è stato installato il modulo della Distinta Base, vengono visualizzati anno e numero dei movimenti di magazzino che contengono rispettivamente il carico da produzione e lo scarico dei componenti relativi agli articoli del ddt, generati al momento della stampa.


DdT NOTE TESTATA (3)

Percorso: Vendite - Ddt - Gestione ddt

Si consente di inserire delle righe di testo e di scegliere se stamparle o meno sul documento. Sarà poi con il filtro che si stabilisce dove stamparle (se in testa o nel piede).


DdT DATI di ACCOMPAGNAMENTO (4)

Percorso: Vendite - Ddt - Gestione ddt

Questi dati vengono in parte letti dall'anagrafica del cliente e possono essere variati per il singolo documento.

Per scrivere indirizzo, vettore etc. direttamente sul documento, senza averli prima inseriti sui rispettivi archivi, basta via via sbiancare il codice corrispondente e scrivere direttamente negli spazi a fianco.

Destinatario (Indirizzo di spedizione)
Viene proposto il codice dall'anagrafica del cliente ma è possibile anche inserirne uno valido solo per questo documento.
Se sull'indirizzo di spedizione in archivio, è stato impostato a Si il campo Indirizzo Principale per Ddt, la stampa Ddt invertirà l'indirizzo del cliente e l'indirizzo di spedizione.

Vettore
Viene proposto il codice vettore scritto sul cliente.
Impostando il parametro MemTargaVet si consente di inserire/variare la targa del vettore nella maschera dei dati di accompagnamento

Causale Trasporto
Viene proposto il codice inserito in tabella di fatturazione.

Aspetto dei Beni
Viene proposto il codice inserito in tabella di fatturazione.

Porto (Resa)
Viene proposto il codice inserito sul cliente (porto franco, porto assegnato).

Tipo Trasporto
Viene proposto il codice inserito in tabella di fatturazione (posta, corriere,..)

Colli
Questo campo può essere compilato manualmente oppure si può premere il pulsante posto al suo fianco per ottenere la compilazione automatica con il risultato della somma dei colli (e non delle quantità) inseriti in ogni riga. Vedi parametro RicalcColli
Di default il numero dei colli è intero, è possibile impostare il parametro di personalizzazione ColliDec per gestirlo con decimali.

Peso
E' possibile ottenere il calcolo automatico del peso attivando il parametro di personalizzazione CalcolaPeso (CalcolaPesoLordo, CalcolaPesoUm). Il peso può essere, a seconda dell'impostazione dei parametri suddetti, la somma delle quantità nelle righe di dettaglio o la somma dei pesi lordi dei singoli articoli.

Data e Ora Inizio Trasporto

Data e Ora Ritiro Merce


DdT NOTA CLIENTE (5)

Percorso: Vendite - Ddt - Gestione ddt

In inserimento, in questo quadro vengono visualizzate alcune informazioni del cliente:

il contenuto dell'eventuale nota scritta sull'anagrafica, il segnale di rischio e il fido.

Se nella tabella Tipi documento, in corrispondenza al tipi documento utilizzato per il ddt attuale, si imposta un numero di giorni per calcolo scaduto, verrà calcolato in automatico (dalle scadenze aperte) lo scaduto alla data del documento che si sta inserendo.

In variazione del documento si può rileggere lo scaduto premendo il pulsante [..] posto a fianco di Pagamenti scaduti.

Inoltre in questo quadro vengono proposti i campi 'liberi': es. Modello, Targa (se sono state impostate le rispettive descrizioni in tabella di fatturazione).

Questi campi, se valorizzati, potranno essere stampati sul documento e portati sull'eventuale documento di evasione.


DdT DOCUMENTI di ORIGINE e DESTINAZIONE (6)

Percorso: Vendite - Ddt - Gestione ddt

In questo quadro è possibile consultare i riferimenti dei documenti che hanno generato il DdT (ordini) e di quelli in cui è stato evaso (fatture).

Se il ddt è già stato evaso in fattura viene visualizzato un pulsante "Apri fattura" che consente di entrare direttamente sulla maschera della stessa.


DdT SPESE

Percorso: Vendite - Ddt - Gestione ddt

Per inserire le righe di spesa da addebitare al cliente per il documento che si sta inserendo (es. Spese di Trasporto), occorre premere il pulsante [image] (X)Spese posto sulla barra delle icone e attivo dal momento che si conferma la testata del documento.

La spesa inserita dovrà essere stata precedentemente creata con la corrispondente gestione e dovranno essere state definite le sue caratteristiche: il suo codice iva, se è a importo o in percentuale, etc

Se si imposta il parametro di personalizzazione SpesaClieAutom a S , il programma caricherà in automatico la spesa eventualmente inserita nell'anagrafica del cliente. In alternativa, tale spesa, può essere caricata manualmente, premendo il pulsante: (E) sp(E)se cliente nel quadro Spese del documento.

NOTA sul codice iva: gli importi inseriti nelle righe 'spese' vengono considerati sempre al netto dell'iva. E' possibile inserire in fattura una spesa esente ma NON un codice iva da Scorporare, quest'ultimo verrà considerato come un'iva normale e sull'importo verrà nuovamente calcolata l'iva.
Se sul cliente è stato impostato un codice iva (esenzione) esso verrà messo anche sulle spese con possibilità di variarlo.

In ordini e ddt le spese dovranno essere inserite manualmente e potranno essere variate anche se il Ddt è stampato.


DdT DETTAGLI

Percorso: Vendite - Ddt - Gestione ddt

Una volta inserita la testata del documento si procede all'inserimento dei dettagli premendo il pulsante [image] (E) Gestione Dettagli o Salva.

In questo punto è possibile inserire le varie righe del corpo del documento. Le righe possono essere costituite da: articoli presenti in tabella articoli (dovranno essere richiamati con codice), articoli manuali (il codice dovrà essere lasciato vuoto e dovrà essere compilata la descrizione) oppure righe descrittive (per commenti).

Se è stata abilitato il modulo di tracciabilità e per l'articolo in oggetto, da anagrafica, è stata prevista la gestione dei lotti, verrà presentata in alto a destra, un pulsante che consente di inserire i lotti da attribuire alla merce in uscita: (Gestione lotti)

Per l'inserimento dei lotti vedere Lotti-Caricamento movimenti e Lotti Selezione quantità

Se è stata abilitata la gestione delle matricole (Parametro di personalizzazione: MatrGest, Gruppo: Tutti) verrà presentata, in alto a destra, una icona che consente di inserire, su ogni riga articolo, le matricole associate [image] (J) Gest.matricole

Se sono stati abilitati la lettura degli articoli o delle matricole da file (Parametri di personalizzazione LettArtDaFile o LettMatrDafile verranno visualizzate le rispettive icone che consentono la lettura dei dati

(B) Lettura da file Ascii o [image] (Q) Lett.matricole da file

(vedi Caricamento dettagli documenti da file e

Caricamento movimenti di magazzino - matricole da file)

Cod. Articolo(Ricerca per cod. descr. Cod a barre)
Se il codice articolo viene lasciato bianco si consente di inserire un articolo 'manuale' cioè di compilare manualmente tutti i dati della riga: descrizione, quantità, sconto, codice iva etc. In questo caso non verrà generato nessun movimento di magazzino.

Se invece viene inserito un codice articolo, esso dovrà esistere nella tabella degli articoli di magazzino.

Con F9 si attiva il pulsante per cambio modalità di ricerca dell'articolo (codice/descrizione o codice a barre).
La ricerca dell'articolo avviene con i tasti F2 (codice), F3 (descrizione), F4 (codice a barre), come specificato in Lista di aiuto (ricerca codice)
E' abilitata inoltre la ricerca con i tasti Shift F2 - F3 - F4

Premendo il tasto F8 è possibile inserire una Riga Descrittiva.
Premendo il tasto F6 è possibile inserire una Riga di Comando.

Se si sta facendo la ricerca per codice a barre, è possibile attivare il parametro di personalizzazione: CodBarSalva in modo che, in inserimento, all'uscita del campo articolo venga salvata la riga e si passi ad un altro inserimento. Ovviamente è indispensabile che sull'articolo siano compilati tutti i campi necessari (unità di misura, codice iva etc.) e che sia stato definito il parametro Qtadef per impostare in automatico le quantità sulla riga.

In una riga 'Articolo', dopo aver inserito il codice di un articolo verranno proposti unità di misura, quantità per confezione, prezzo (se codificato), sconti, aliquota iva e conto ricavo letti dall'articolo etc.
Verranno inoltre visualizzate giacenza e disponibilità dell'articolo sul magazzino impostato sulla testata del documento ed eventualmente anche su tutti i magazzini (vedi parametro di personalizzazione: MagaNoGiac.

Se sull'articolo è stato chiesto di segnalare se è esaurito, verrà data una segnalazione se la giacenza è minore di 0.

Se l'articolo ha la gestione dei livelli (taglia-colore) l'inserimento del dettaglio procede come descritto in Dettagli con livelli

Descrizione
E' la descrizione dell'articolo richiamato. Se viene modificata verrà memorizzata sul documento per la stampa e l'evasione e verrà visualizzata la nota 'descrizione modificata'.
Se l'articolo è manuale, la descrizione dovrà essere inserita dall'operatore.

Cliccando sulle etichette delle varie cartelle proposte (o digitando Alt e il numero corrispondente), si accede ad altri dati:

Altri dati dettaglio articolo
Descrizione lunga articolo e note di dettaglio
Riferimenti documento di provenienza
Altro
Vengono gestiti i campi: lunghezza, larghezza, altezza e codice contratto

Per ulteriori spiegazioni sui pulsanti utilizzabili nella gestione dei dettagli, si rimanda a Pulsanti in gestione movimenti e documenti.


DdT DETTAGLIO (1) PRINCIPALE

Percorso: Vendite - Ddt - Gestione ddt

Caricamento movimenti da file (Caricamento dettagli documenti da file).
E' possibile, configurando opportuni parametri, (in particolare LettArtDaFile) , compilare automaticamente un ddt, leggendo da file (o da terminale ottico) le varie righe di dettaglio. L'operazione avviene cliccando sull'icona [image] (B) Lettura da file Ascii che compare nella maschera di Gestione dettagli

Gestione matricole sulle righe articolo:
Se è stata abilitata la gestione delle matricole è abilitato un ulteriore pulsante: (J) Gest.matricole
Se è stato abilitato il caricamento degli articoli/matricole (dettagli) da file è presente un ulteriore pulsante:
(Q) Lett.matricole da file

Gestione lotti (tracciabilità)

Gestione Raee

Quantità
Non può mai essere lasciata a 0. Viene accettato un numero di decimali pari a quelli specificati in Tabella di magazzino. Se sono stati impostati sull'articolo i pezzi per confezione (con valore maggiore di uno), invece della quantità si possono digitare i colli e la quantità verrà impostata automaticamente (colli moltiplicato per pezzi per confezione), viceversa se si digita la quantità, non verranno ricalcolati i colli.
Se l'articolo ha uno sconto quantità e la quantità viene variata, si chiede se ricalcolare gli sconti.

Colli
Se il valore dei pezzi per confezione dell'articolo è maggiore di 1, si digita il numero dei colli e il campo quantità è vuoto, viene calcolata la quantità come pezzi per confezione * colli.
Di default il numero dei colli è intero, è possibile impostare il parametro di personalizzazione ColliDec per gestirlo con decimali.

Viceversa se si inserisce la quantità e il campo colli è vuoto, questi ultimi vengono impostati automaticamente arrotondando per eccesso.

Per ottenere in automatico il calcolo dei colli sul quadro di accompagnamento, occorre inserire in ogni riga il numero dei colli, anche in articoli 'normali'.

Pezzi per Confezione
Viene visualizzato il valore letto dall'articolo (non modificabile)

Promozione
Solo visualizzato. Indica se è stato impostato per quell'articolo un prezzo promozione.

Prezzo Unitario
Prezzo unitario della riga. Viene proposto il prezzo dell'articolo letto dal listino (se impostato in testata), valido alla data di inserimento del documento.
Nella causale di magazzino collegata al Tipo documento è possibile tuttavia, definire che il prezzo venga prelevato dal costo ultimo o dal medio di carico.

E' possibile infine impostare il prezzo unitario dell'articolo sulle tabelle degli sconti, in questo caso verrà prelevato solo se il documento è in Lire o in Euro.

Se per l'articolo non viene trovato nessun prezzo, nei modi suddetti, ed è stato attivato il parametro di personalizzazione CercaListBase, il programma cerca il prezzo sul listino Base (quello indicato nella tabella di Magazzino, parametri comuni).
Sul campo prezzo possono essere premuti alcuni tasti con il seguente risultato:

  • F2: rilegge dagli archivi il prezzo unitario e ricalcola gli sconti
  • F3: visualizza una lista dei listini validi dell'articolo in oggetto.
  • F7: questo tasto è da utilizzare quando un valore digitato manualmente non è compatibile con il listino e cioè: se si sta utilizzando un listino NON ivato e si ha la necessità di digitare un prezzo ivato, lo si può poi scorporare premendo il tasto F7. Allo stesso modo se utilizzo un listino ivato e, per un articolo, digito un prezzo non ivato, con F7 il programma calcolerà l'iva sul prezzo digitato.

Se è attivato il parametro di personalizzazione MostraCostoUltimo uguale a S, è possibile premere il tasto F4 per visualizzare il costo ultimo dell'articolo.

Alla lettura del prezzo di listino da archivio il programma se trova che listino e flag di testata sono 'uguali' cioè indicano entrambi ivato o non ivato, presenta il prezzo così com'è letto mentre se sono diversi provvede a ivare o a fare lo scorporo a seconda dello stato del listino e del flag di testata.

Se il prezzo viene dal listino promozione si visualizza solo lo sconto cliente. In questo caso, anche se si fa il ricalcolo sconti, lo sconto listino viene ignorato in quanto, ricercando il prezzo, vede che viene da promozione .

Se si varia il prezzo gli sconti non vengono variati. Per provocare il ricalcolo degli sconti occorre o premere F2 sul prezzo o premere ricalcolo sconti dal campo sconto totale.
Parametri: DisabTermPrz, DisabTermVisPrz
per disabilitare uno o più terminali rispettivamente alla gestione o alla visualizzazione dei prezzi e degli sconti in gestione ordine di acquisto.

Sconto
E' lo sconto totale a cui è soggetto l'articolo. In presenza di gestione di taglia/colore gli sconti verranno considerati uguali per tutti i livelli di uno stesso articolo. Lo sconto viene dato nella forma x+y+z e a fianco viene calcolato lo sconto risultante.

A fianco dello sconto totale viene visualizzato un pulsante [..] (F2) per il ricalcolo degli sconti.
Il ricalcolo degli sconti può provocare la variazione del prezzo se lo si trova in una tabella sconti e la moneta del documento è euro.
Se sulla riga c'è un prezzo promozione e si fa il ricalcolo degli sconti, viene reimpostato solo lo sconto cliente.
Per ulteriori informazioni vedere modalità di ricerca sconti

Di seguito vengono elencati i vari sconti abilitati sull'articolo in modo da poter capire come è stato calcolato lo sconto finale:

Sconto del Cliente/Fornitore
Viene proposto lo sconto confermato in testata come sconto cliente.
Sconto Articolo
E' il risultato della combinazione tra sconto listino e sconto messo sull'anagrafica articolo.
Sconto Tabellare
E' lo sconto derivato dalle Tabelle di sconto
Sconto Quantità
Viene cercato sulla tabella degli sconti quantità, in base all'articolo e al cliente, e, se valorizzato può sostituire lo sconto tabellare e/o lo sconto cliente.

Indicatore di riga soggetta a sconto pagamento
Viene valorizzato in automatico sempre a Si e può essere variato. Lo sconto pagamento è sulla testata del documento e viene applicato a piede fattura.

Unità di misura
Viene visualizzata l'unità di misura delle vendite dall'articolo (o quella degli acquisti in caso di ddt a fornitore)

Fattore di conversione
Viene proposto il valore scritto sull'articolo e relativo all'unità di misura di vendita (o di acquisto). Può essere variato se si varia l'unità di misura. Serve per calcolare la quantità che andrà ad aggiornare i progressivi di scarico dell'articolo. Se l'unità di misura dell'articolo coincide con quella di vendita, il fattore di conversione dovrà essere uguale ad 1 (non può mai essere posto a 0).

Codice Iva
E' il codice iva dell'articolo (iva vendite o acquisti). Se però in testata viene impostato un codice iva (esenzione) cui il cliente è soggetto questo verrà impostato automaticamente su tutti i dettagli senza possibilità di variazione.

Importo di riga
E' l'importo calcolato moltiplicando il prezzo scontato per la quantità della riga. Se si varia o imposta direttamente questo importo e il prezzo unitario è vuoto, quest'ultimo verrà ricalcolato automaticamente , viceversa occorre premere il tasto F7 per ricalcolarlo.

Omaggio
Consente di definire se la riga contiene o no articoli ceduti a titolo gratuito. E' previsto che la gestione dell'omaggio possa essere:

  • omaggio totale
    la riga non verrà addebitata in assoluto
  • addebito solo Iva
    al cliente verrà addebitata solo l'imposta relativa a questa riga e non l'imponibile

Conto ricavi
E' il conto di ricavo che servirà in fattura per lo scarico contabile dell'importo relativo alla riga.

Viene proposto il conto impostato sull'articolo. Se nell'articolo manca o se articolo manuale verrà proposto quello della tabella conti comuni (da compilarsi tra i parametri ditta).

Se anche in tabella non c'è nessun conto, il problema sorge nel momento della contabilizzazione della fattura, sarà la stampa a chiedere che sia compilata la tabella 'causali e conti comuni'.
Se si tratta di un documento a fornitore, per reso merce, in questo conto viene proposto il merci c/acquisti dell'articolo ma non serve a niente.

% provvigione 1 e 2
Sono le percentuali di provvigione relative ai due agenti impostati sulla testata.
Se le provvigioni sono per articolo e in testata ci sono due agenti, verrà assegnata la stessa percentuale di provvigione ad entrambi.

Bene usato
Se il tipo documento prevede la gestione del regime del margine (cioè si sta facendo un ordine per la vendita di un bene usato) in questo campo va inserito il codice del bene. Serve per poterlo passare in fattura poi in contabilità e scrivere sul Registro di vendita dei beni usati la natura del bene.

E' possibile attivare il parametro di personalizzazione NotaLinguaDove per utilizzare la descrizione lunga in lingua come ulteriore descrizione dell'articolo da copiare nella nota sotto e stampare sul documento.


DdT DETTAGLIO (2) DESCRIZIONE LUNGA ARTICOLO E NOTE

Percorso: Vendite - Ddt - Gestione ddt

Dove stampo descrizione lunga
Se l'articolo ha una descrizione aggiuntiva, inserita con la gestione articoli, questa può essere stampata o meno sul documento o copiata sulla nota del dettaglio (sopra o sotto) a seconda di come è stato impostato il campo: "Stampa desc.agg.articolo" sul tipo documento.
L'operatore può però variare questo campo.
In fase di evasione del ddt in fattura, il flag viene copiato con il suo significato originario. Per impostarlo sul documento di arrivo, così come previsto sul tipo documento, occorre impostare il parametro di personalizzazione: StDesLunDaDoc

Nota sopra e nota sotto
Si consente di inserire o variare eventuali note da stampare sul documento 'sopra' e 'sotto' la riga dell'articolo.
Per ciascuna di queste due note si può scegliere di:

  • non stamparla
  • stamparla solo sul documento in oggetto e non su quello di evasione
  • stamparla solo sul documento di evasione
  • stamparla su entrambi i documenti.

E' possibile impostare un valore di default sul campo, tramite i parametri di personalizzazione: DoveStampoSopra e DoveStampoSotto
Se il tipo documento prevede di importare in automatico la descrizione aggiuntiva dell'articolo sulle note, queste verranno precompilate con tale descrizione. In ogni caso, sulle due note, è abilitato il tasto F7 che consente di importarla in automatico anche se non è stato previsto prima.


DdT DETTAGLIO (3) RIFERIMENTO DOCUMENTI DI PROVENIENZA

Percorso: Vendite - Ddt - Gestione ddt

Se il Ddt è stato generato dall' evasione di un ordine, in questa sezione vengono visualizzati i riferimenti alla riga di tale ordine.


DdT DETTAGLIO CON I LIVELLI

Percorso: Vendite - Ddt - Gestione ddt

Se è prevista la gestione dei livelli (Taglia-Colore) e l'articolo li ha, viene data la possibilità di inserire la quantità per ogni singola unità gestita. Una volta inserito il codice dell'articolo non si può passare direttamente all'inserimento della quantità ma occorre premere il pulsante opportuno, vedi Gestione Livelli a Tabella, in modo da passare alla maschera di Gestione Dettaglio Livelli nella quale dovrà essere specificato per ogni 'livello' da mettere sul documento, la quantità e il prezzo unitario.Gli sconti vengono considerati a livello di articolo per cui se si varia uno sconto su un 'dettaglio-livello' questo viene riportato su tutte le righe-livello di quell'articolo. Vedi Sconti in Dettagli con Livelli

Se si modifica il codice articolo con livelli sul dettaglio, vengono cancellate tutte le sue righe dei livelli e sarà necessario entrare nella gestione livelli per reinserirle.


DdT DETTAGLIO - RIGA di COMANDO

Percorso: Vendite - Ddt - Gestione ddt

In questo punto si consente di inserire una riga di comando che verrà presa in considerazione dalla stampa Ddt, si può scegliere tra quelli proposti:

  • .TD Stampa testata dettaglio
  • .PA Cambio pagina
  • .SR Salta N righe
    Segue richiesta del numero di righe da saltare
  • .NS Non stampa il totale finale
  • .TT Stampa un totale parziale in questo punto
  • .PT Stampa un totale parziale e cambia pagina
  • .TZ Stampa un totale parziale e lo azzera
  • .PZ Stampa un totale parziale, lo azzera e cambia pagina

Per tutti i comandi che prevedono la stampa di un totale viene chiesto all'operatore di digitare la descrizione da stampare prima dell'importo.

Nota: per la stampa corretta del totale parziale, occorre inserire nel filtro una riga con sottosezione 18.
Nella descrizione scritta, in corrispondenza al comando 'Stampa un totale parziale' si può digitare qualcosa che poi potrà essere testato nel filtro (es. se si vuole stampare una riga orizzontale in una certa posizione del corpo, poi stampare il totale parziale, si potrà inserire nel corpo del documento una prima riga comando del tipo Tot. parziale, con descrizione: riga poi nel filtro si dovranno mettere le istruzioni per stampare la riga (Sottosezione 18) precedute dal test:
se$ C_RigDesArt <> "riga";vai NoRiga


STAMPA DdT

Percorso: Vendite - Ddt - Stampe

Il programma consente di stampare uno o più DdT già inseriti.

E' importante fare attenzione alla data di stampa in quanto sarà la data in cui verrà fatto lo scarico in magazzino degli articoli del documento.

Per quanto riguarda i formati di stampa, è possibile personalizzarli tramite apposite funzioni (Gestione Filtri) e al momento di stampa scegliere quale formato utilizzare.
Si consentono:

  • Prestampa dei DdT mai stampati. Non crea il movimento di magazzino
  • Stampa viene generato il movimento di magazzino e vengono assegnati al Ddt data e numero progressivo in base alla data di stampa impostata a video.
  • Ristampa per stampare un ddt già stampato

E' possibile operare selezionare i DdT da stampare: per numero e data riferimento, per cliente, per numero e data documento (nel caso di ristampa).

Ordinamento righe dettaglio:
La stampa delle righe presenti nel corpo del documento avviene secondo l'ordine con cui vengono presentate a video. E' possibile modificare l'ordine utilizzando i parametri di personalizzazione:
OrdStampaDettDef , OrdStampaDettDesc , OrdStampaDettBy

Vengono proposti, per la variazione, Data e Ora inizio trasporto (impostati con data e ora attuale) e Data e Ora ritiro, verranno stampati su tutti i DdT in cui tali dati non sono già valorizzati.
Si può intervenire per eliminare l'impostazione automatica dei suddetti campi impostando il parametro di personalizzazione: PropRitiro.

Se si preme il pulsante Ora Standard, il programma imposterà le ore di Inizio Trasporto e di Ritiro merce così come sono state impostate nei parametri di personalizzazione StOraTrasporto e StOraRitiro e manderà in stampa il Ddt.

Se il programma si blocca durante la Stampa dei DdT, occorre eseguire la funzione di Ripristino da interruzione in elaborazione DdT dal menu di Servizio delle Vendite.

E' possibile attivare dei parametri di personalizzazione per caratterizzare la stampa ddt:

  • StessoDest
  • FincPrecDatiTest , FincPrecDatiPie
  • FineCorpo
  • TraspVetSta
  • MemTargaVet
  • NoStampaLivelli
  • CampiStAggDec
  • DescLivNotaSot
  • Immagini
  • StampaEti
    Consente di stampare delle etichette al termine del ddt
  • StDocFine
    Consente di definire il percorso e il nome di un documento che verrà stampato al termine del ddt. Se è stato attivato il parametro di personalizzazione però, in qualche caso, non si vuole la stampa, si può togliere la spunta al campo: 'Stampa file doc. finale' che compare nella maschera di stampa.
    N.B. Condizione necessaria per la stampa del documento è che sul computer sia installato WORD. Viene dato a word il comando di stampare il testo selezionato, la stampa avviene SEMPRE sulla stampante preselezionata di Word
  • StDescAttr e StTotAttr per stampa descrizione attributi e riepiloghi nel corpo (Es. riepilogo ADR)
  • CampiStAggCor
  • TabFromCor

Per quanto riguarda i parametri da inserire per la stampa delle matricole in ddt e fatture vedere: parametri matricole.

Per quanto riguarda i parametri da inserire per la stampa dei lotti in ddt e fatture vedere: parametri lotti

Selezione destinazione stampa
Le stampe su modulo hanno, in questa sezione, opzioni particolari rispetto quelle delle stampe normali (Stampe). Vedi Stampe su modulo

Se si intendono stampare più documenti insieme, occorre che essi abbiano lo stesso modello di stampa.

Se non si imposta niente in DA .. viene mantenuto il modello predefinito, se si lascia vuoto il campo Tipo documento A: esso viene posto uguale al Tipo documento DA


EVASIONE DdT

Percorso: Vendite - Ddt

Questa funzione consente di creare le fatture dai Ddt stampati, selezionandoli per data, per numero, per cliente (o fornitore).

Vengono considerati nella selezione tutti i DdT con data documento minore o uguale alla data di evasione.

Se si interrompe il programma in fase di Evasione ddt, occorre eseguire il Ripristino fatture

Terminata l'evasione di un DdT, ad esso viene assegnato lo stato di Evaso.

Se la condizione di pagamento della fattura generata prevede il codice spesa e al cliente vanno addebitate le spese bancarie, queste ultime verranno generate sul quadro spese della fattura.

Per i DdT che richiedono il raggruppo per articolo in evasione (flag sulla testata DdT), verrà generata in fattura una riga per ogni articolo la cui quantità sarà la somma delle singole quantità e gli altri dati verranno presi del primo ddt considerato nell'evasione. I riferimenti ai DdT che si accumulano in quella fattura vengono memorizzati su una riga descrittiva all'interno della fattura stessa (per la stampa).

Il raggruppo per articolo si fa SOLO SE non è abilitata la Gestione di taglia e colore (Parametri comuni - Tabella magazzino).

Con questa funzione si consente di 'chiudere' cioè mettere il flag di evaso anche tutti i DdT da non fatturare. Ad esempio un DdT fatto per merce spedita in c/visione, che ha un tipo documento sul quale è stato impostata la causale di magazzino per lo scarico ma anche quella per il rientro, evaso con questa funzione, provoca il rientro della merce in magazzino secondo quanto specificato sulla causale di rientro.

Per quanto riguarda tutti gli altri DdT da non fatturare, l'evasione fittizia consentirà poi di poterli cancellare insieme a tutti gli altri, una volta che si decida di fare pulizia sull'archivio.

Parametri di personalizzazione gestiti da questa funzione:

NoRigDescr
Se S non verrà evasa nessuna riga descrittiva

StDesLunDaDoc
Se S il flag "Dove stampo descr.lunga" sui dettagli, viene impostato come previsto sul tipo documento di evasione piuttosto che copiato dal documento di partenza.

RigaDescrDef
Se impostato ad N e sulla tabella del Tipo documento corrispondente non c'è niente nel campo Descrizione su fattura riepilogativa non viene generata la riga DDT N' in fattura.

RaggrDestin
Se impostato ad S in evasione Ddt viene chiesto all'utente se, indipendentemente da quello che è stato impostato in testata dei Ddt, si vuole stampare una fattura per ogni destinazione e si chiede l'intervallo delle destinazioni da prendere in considerazione. (Utilizzato da chi emette Ddt per trasferire la merce ai cantieri poi la fattura)

RigaDescrTotale (S o P)
Questo parametro serve per far sì che in fattura riepilogativa, invece di stampare l'elenco degli articoli di ogni ddt vengano stampate semplicemente le varie righe: DDT Nr. xx del xx/xx/xx e l'importo totale del ddt
In evasione Ddt viene calcolato il totale di ogni ddt e scritto nella riga descrittiva a seguito di Ddt. Nr. xx del xx/xx/xxxx.

  • S l'importo viene scritto dopo la data del ddt
  • P l'importo viene messo nel campo ValoreEuro e calcolato in C_ValEuro (per poterlo poi stampare su una colonna a parte modificando in modo opportuno il filtro)

SommaPesi
Il campo Peso dei dati di accompagnamento della fattura dovrà contenere la somma dei pesi dei vari Ddt.

DicIntentiVerif
Per raggruppo ddt con stessa dichiarazione di intento

BolleAccXml
Per cambiare il default SSN dei campi ( 'in xml' 'in stampa' 'in altri dati articolo') messi nella riga descrittiva del corpo fattura riepilogativa che riporta l'elenco dei ddt in caso di raggruppo per articolo (es. forno)

DdtEleXml
Per cambiare il default NSN dei campi ( 'in xml' 'in stampa' 'in altri dati articolo') messi nella riga descrittiva del corpo fattura riepilogativa che riporta il numero e la data della bolla

DdtXmlGen
Per cambiare l'impostazione di default dei campi: S per 'in xml' ; S per 'in stampa' ; N per 'in altri dati articolo', messi nelle righe descrittive del corpo fattura riepilogativa

DdtDocNoXml Gruppo: XML
Deve contenere l’elenco, separato da virgola, dei tipi documento DDT che non si vuole vengano scaricati nei campi Numero e data ddt sulla fattura elettronica (Es. per Ddt emessi come ricevute Fiscali caricati da Gesoff)

Data di evasione
E' la data in cui viene creata la fattura, verrà memorizzata sulla fattura in data riferimento.

Tipo Doc. da evadere : XX
Tipo Doc. di evasione : YY
Si possono verificare più casi:

  • Bianchi entrambi
    verranno evasi SOLO i DdT da Fatturare (flag di testata) e che hanno il Tipo doc.di Evasione in tabella Tipi documento.
  • Valorizzati entrambi
    verranno evasi solo quelli con flag DA FATTURARE in testata e il cui tipo documento non ha il 2' tipo movimento (quello da utilizzare per creare ad esempio un rientro da c/demo)
  • Solo il secondo (YY) non è valorizzato
    si estraggono SOLO i DdT da non fatturare (flag testata) e si da un messaggio per dirlo : VERRANNO ELABORATI (EVASI) SOLO I DDT DA NON FATTURARE. Verrà messo il flag di evaso su tali DDT e verrà generato il movimento di rientro se previsto. (Es. rientro da DEMO).

Chiusura DdT da non fatturare
Si-No

Prefisso fatture
Occorre confermare o variare il prefisso che dovranno avere le fatture generate. Quello visualizzato è quello impostato sul Tipo Documento selezionato (se c'è) o in Tabella comune.

Periodo Iva: Mese /Anno
Indica il mese (anche se l'iva è trimestrale) in cui quella fattura va considerata per quanto riguarda la liquidazione dell'iva. Se il mese è quello in cui la fattura viene emessa, questi due campi vanno lasciati bianchi, viceversa dovranno essere impostati al giusto valore.

Questi dati servono in quanto ci sono casi in cui il documento ai fini iva va considerato in un periodo diverso rispetto quello in cui viene emesso. Esempio: un mensile che evade, nei termini di legge, DdT del mese precedente, dovrà considerare l'iva della fattura generata nel mese di consegna della merce e non nel mese di registrazione della fattura.

Stampa le fatture
Se impostato a si, dopo la generazione delle fatture verrà lanciata in automatico la stampa della fatture generate. Vedi Stampa Fatture.

Evasione campi particolari
Riferimento Cliente
Se il cliente da anagrafica, prevede che si stampi il campo Riferimento Cliente scritto sulla testata del DdT, questo verrà portato sul documento di evasione come prima riga descrittiva del DdT cui si riferisce.
'Campi Liberi' della testata (es. TARGA, MODELLO)

Se in tabella di fatturazione è specificato che vanno evasi, l'evasione crea per questi campi delle righe descrittive sulla fattura.

Evasione note dei dettagli
Verranno copiate sulla fattura le solo le note di dettaglio per le quali è stato specificato che vanno stampate 'anche sul documento di evasione' o 'solo sul documento di evasione'.

Evasione Spese
Se sui DdT ci sono delle righe di spese, sulla fattura che raggruppa quei DdT verranno riportate le stesse spese tenendo conto di come è stato impostato il campo Tipo di evasione che c'è sulla spesa stessa.

Moneta / Cambio
La moneta è uno dei parametri di raggruppo per i DdT.

La fattura generata da DdT con moneta diversa da Lire, Euro o da una qualsiasi moneta dell'UEM (per le quali il cambio è 'fisso' in tabella), NON avrà un cambio impostato .

Il cambio verrà dato al momento della Stampa. Se l'operatore interviene manualmente e mette il cambio sulla fattura non ancora stampata, al momento della stampa si potrà decidere se aggiornare o meno quel cambio.


BROGLIACCIO DdT

Percorso: Vendite - Ddt - Stampe

La funzione consente di stampare un elenco Sintetico (solo le testate) o Analitico (anche i dettagli) dei DdT in archivio. A scelta dell'operatore potrà essere stampato anche il totale merce per ogni DdT e il totale finale.

In caso di stampa dei Ddt da non fatturare, è possibile scegliere se stamparli tutti, oppure solo quelli il cui tipo documento ha la il codice di movimento di rientro collegato (es. Ddt per c/visione per i quali è previsto il rientro della merce) oppure solo quelli senza movimento di rientro.


ELENCO ARTICOLI CONSEGNATI

Percorso: Vendite - Ddt

Questa funzione elenca gli articoli consegnati con Ddt ai vari clienti. E' possibile stampare solo l'elenco degli articoli, codice e descrizione, oppure anche quantità e importi

  • No quantità e no prezzi
  • Solo quantità
  • Solo prezzi
  • Quantità e prezzi

Stampa una pagina per indirizzo
Se si spunta questa opzione, verranno separare le consegne fatte allo stesso cliente ma a destinazioni diverse (indirizzi di spedizione).

Stampa solo riepilogo articoli
Se si spunta questa opzione, verranno elencati tutti gli articoli consegnati nei ddt che rispettano le selezioni impostate a video, indipendentemente dal cliente.
E' possibile attivare il parametro di personalizzazione TotQtaEleArt che consente di stampare il totale articoli quando si stampa 'solo riepilogo articoli' e 'Solo quantità',

Solo articoli anche No articoli
Con questa scelta si possono includere (anche no articoli) nella stampa anche gli 'articoli' codificati in tabella ma nei quali non è stato spuntato il campo "Articolo di magazzino", esempio articoli creati per inserire nei documenti delle lavorazioni, delle ore etc.
In particolare, se si sceglie "anche no articoli", verranno stampati anche gli articoli manuali che compaiono dei ddt.


NUMERATORI DDT

Percorso: Vendite - Gestioni

I Documenti di trasporto al momento della stampa devono essere numerati progressivamente nell'anno.

Per ogni anno è possibile avere più numeratori (es. in presenza di bollettari diversi) ciascuno individuato da un prefisso, oppure un numeratore unico. L'elenco dei prefissi/numeratori disponibili per i Ddt è nella tabella di Fatturazione.

Quando si inserisce un Ddt, ad esso deve essere attribuito uno di questi prefissi in modo tale che al momento della stampa gli si possa assegnare il numero giusto (che sarà quello letto da questa tabella aumentato di 1), tale numero e la data di stampa verranno poi scritti sulla tabella.

Questa funzione consente di gestire l'ultimo numero di Ddt stampato per ogni prefisso. In fase di stampa Ddt se non esiste già in questa tabella il numeratore, esso verrà creato automaticamente e il documento prenderà il numero 1.


STAMPA NUMERATORI DDT

Percorso: Vendite - Gestioni - Stampe

La funzione consente di stampare l'elenco dei numeratori utilizzati per i DDT.


RICALCOLO PREZZI IN DDT E FATTURE

Percorso: Vendite - Servizio

Il programma prende in considerazione tutte le righe di ddt e fatture con stato bianco e che rispettino le selezioni fatte a video.

Per ogni documento esaminato il programma cerca il codice listino del cliente (se questo è bianco si prende il listino principale) e imposta tale listino nella testata del documento poi, per ogni riga di dettaglio, cerca il prezzo e lo imposta come prezzo unitario, ricalcola il totale e i totali del documento.

Inoltre se l'indirizzo di spedizione sul documento è bianco, il programma lo imposta uguale a quello letto sull'anagrafica cliente.

Per quanto riguarda i ddt, l'elaborazione considera SOLO i documenti con il flag 'da evadere' a Si.


RICALCOLO PREZZI IN ORDINI E DDT

Percorso: Vendite - Servizio

Il programma prende in considerazione tutte le righe di ordini non evasi e i ddt non ancora fatturati che soddisfano le richieste fatte a video (numero e data documento e riferimento).

Se in testata dell'ordine o del ddt esaminato c'è il codice di un listino, per ogni riga 'articolo' di quel documento verrà riletto il nuovo prezzo di listino (non si fa ricalcolo di sconti o altro!) e impostato sulla riga.

Se invece il codice listino di testata manca, verranno aggiornati i prezzi leggendoli dal listino indicato a video, SE è stato indicato, altrimenti non verranno toccati.

L'elaborazione considera SOLO i documenti emessi a clienti e i Ddt con il flag 'da evadere' a Si.

Se gli articoli gestiscono i livelli (taglia/colore), vengono aggiornati anche i prezzi sulle righe dei livelli.


RIPRISTINO DA INTERRUZIONE IN ELAB. DdT

Percorso: Vendite - Servizio - Ripristini da interruzione

La funzione consente di portare a termine l'elaborazione dopo una interruzione anomala di una operazione che coinvolge uno o più Ddt (inserimento, stampa).

E' indispensabile eseguirla per ottenere un corretto aggiornamento dei progressivi.

Quanto detto sopra vale anche per interruzioni durante l'elaborazione di Ordini di Vendita, Preventivi e Ordini di Acquisto e Fatture.

Se uno dei suddetti programmi si interrompono durante la gestione di un documento (inserimento o variazione) e in questa fase di ripristino si sceglie di 'salvare i dati', il programma non esegue il calcolo dei totali della testata (totale spese, merce, imposta, documento). Per forzare il ricalcolo, occorre entrare in gestione dei dettagli del documento che si era interrotto e uscire salvando.


REINTEGRO DdT A NON STAMPATO

Percorso: Vendite - Servizio - Utilità

Consente di riportare un DdT già stampato, allo stato di non stampato per poterlo variare.

Viene cancellato il movimento di magazzino che la stampa ha creato e tolto, dalla testata del DdT, lo stato di stampato.

Per i DdT 'da non fatturare', si consente di tornare indietro dallo stato di Evaso allo stato di stampato.

In questo caso verrà cancellato l'eventuale movimento di rientro.


PULIZIA ARCHIVIO DDT

Il programma consente di cancellare dall'archivio i Ddt di uno o più anni.

In genere dovrà essere utilizzato per eliminare i Ddt degli anni precedenti.

E' possibile cancellare SOLO i Ddt già fatturati (non spuntando nessuna delle due opzioni proposte sotto le selezioni) operando selezioni per anno e intervalli di numeri e date.

La scelta: Cancello anche i Ddt non fatturati provoca la cancellazione di TUTTI i Ddt che soddisfano le condizioni inserite nelle selezioni (indipendentemente dallo stato).

La scelta: Cancello anche i Ddt da non fatturare, consente di eliminare quei Ddt che sono stati inseriti e stampati ma che hanno il segnale 'da non fatturare' a condizione però che sul tipo documento non sia stato impostato il campo: movimento di magazzino di rientro.

Nota: Questa cancellazione, elimina fisicamente i Ddt ma lascia inalterati i movimenti di magazzino che essi hanno generato.

Se il programma trova dei ddt in cui manca la testata, cioè i dati del cliente, (situazione anomala) chiede se si vogliono stampare oppure se proseguire cancellandoli.


FATTURE

Percorso: Vendite - Fatture

La funzione consente di inserire, variare, cancellare o visualizzare le fatture dirette e accompagnatorie.
Le fatture, una volta stampate e/o contabilizzate non possono essere variate.
In generale, per abilitare la variazione di tali fatture occorre Decontabilizzare e/o Destampare; è però possibile variare/aggiungere righe descrittive e variare la descrizione degli articoli (modifiche che non toccano gli importi della fattura).

Gli articoli coinvolti in una fattura, possono essere caricati da un file esterno oltre che digitati manualmente (Caricamento dettagli documenti da file)

Per ogni articolo caricato è possibile gestire il lotto e/o la matricola in modo da ottenere la tracciabilità, una stampa dei movimenti delle matricole etc.

Per abilitare la gestione dei lotti occorre aver installato il modulo Tracciabilità

Per abilitare la gestione matricole occorre inserire nei parametri di personalizzazione, il parametro: MatrGest
Una volta abilitato il parametro, in fase di inserimento di un articolo è possibile digitare o caricare da file le matricole.

E' possibile gestire in automatico il contributo Raee, per gli articoli per il quali è previsto.

E' prevista la gestione delle cauzioni consegnate e rese.
Vedi Gestione vuoti.

Se è stato installato il modulo della distinta base, codificando in modo opportuno il tipo documento Fattura e nel documento ci sono articoli con distinta base, al momento della stampa, oltre a creare il movimento di magazzino di scarico degli articoli venduti, il programma creerà un altro movimento per il carico degli stessi articoli che sono prodotti finiti e uno per lo scarico dei relativi componenti.
Inoltre, se il documento è ottenuto per evasione di un ordine, verrà decrementato anche il progressivo ordinato dei componenti.

Quadro scadenze [image] (Z) Gestione scadenzario
Per motivi tecnici, nelle fatture con condizione pagamento Tratta, il calcolo bolli viene fatto con le scadenze 'originali' e non con quelle di questa maschera.

Altri Dati per Fattura Elettronica

Preparazione file XML per fattura elettronica [image] (FattElettronica)
ATTENZIONE: Se si installa la versione dei programmi che prevedono la fatturazione elettronica che si avvale dell'HUB Zucchetti, NON sarà più possibile accedere alla preparazione del file XML della Fattura Elettronica (da inviare tramite Arthur Informatica) dal pulsante presente nel programma di Gestione Fattura.
Per mantenere attiva questa possibilità (per le fatture emesse per l’anno 2018) è stato messo a menu, nella maschera VENDITE - FATTURE un pulsante ‘Fattura Elettronica vecchia versione’.

Per inserire una nuova Fattura occorre accertarsi di aver precedentemente creato, con l'apposita gestione, il Tipo di documento opportuno, digitare 0 nel campo Numero Riferimento, compilare i campi della testata poi premere il pulsante
(E) Gestione Dettagli, o Salva,
per passare all'inserimento dei dettagli.
Nella testata di una fattura è abilitato il pulsante [image] (D) Duplica.
Esso consente di generare una fattura con le stesse caratteristiche di quella su cui si è posizionati. Il suo stato sarà 'bianco' cioè appena inserita.

E' consentita la ricerca di un documento digitando uno o più campi della testata e premendo il pulsante di Ricerca. Se esiste un unico documento con le caratteristiche impostate, verrà visualizzato mentre se ne esiste più di uno, verrà proposto un elenco.

Stampa
Una volta inserito o generato in automatico con l'evasione dei DdT, il documento può venir stampato direttamente premendo il pulsante
(T) sTampa oppure con l'apposito programma di stampa fattura.

Poiché al momento della stampa viene attribuito il numero progressivo di fattura, vengono movimentati gli articoli che sono sul documento e, se previsto, vengono generati i movimenti sull'archivio provvigioni, le fatture stampate (o già contabilizzate) non potranno essere né variate né annullate ma solo visualizzate.

Variazione
in una fattura non stampata è consentito variare qualsiasi campo della testata (tranne la moneta). Per quanto riguarda i dettagli invece occorre distinguere tra fatture dirette/accompagnatorie e fatture riepilogative.
Mentre nelle dirette si accetta qualsiasi variazione, nelle riepilogative si consente di variare SOLO prezzi, sconti e provvigioni delle righe con articoli, non si possono cancellare righe con articoli e infine si possono aggiungere solo righe descrittive, articoli manuali o articoli che non movimentano il magazzino (vedi campo Articolo di magazzino in anagrafica articolo)

Se la fattura è stata stampata, o anche contabilizzata, è possibile variare unicamente le descrizioni degli articoli, le rispettive note sopra/sotto e le righe descrittive; si possono inoltre aggiungere righe descrittive. In questo modo si consente di aggiungere informazioni alla fattura e ristamparla, senza alterarne gli importi.

Se invece si rende necessario variare altri dati, occorre riportarla allo stato di 'non stampato' seguendo una delle due strade possibili:

  • premendo il pulsante [image] (N) Annulla la stampa
  • eseguendo la funzione Ripristino fatture a 'non stampato' dal menu di Servizio delle Vendite.

In questo modo non verranno variati numero e data documento ma verrà cancellato il movimento di uscita della merce dal magazzino e i movimenti di provvigione generati al momento della stampa.
Una volta effettuate le modifiche la fattura dovrà essere ristampata.

Se la fattura, oltre che stampata, è stata anche contabilizzata e la registrazione non è ancora stata stampata su registro iva o giornale bollato, per poterla variare occorre, prima di destamparla, togliere lo stato di contabilizzazione (cioè cancellarla dalla prima nota) e lo si deve fare con il pulsante:
(Ripristino a non contabilizzato)
Nel caso di Registro Iva già stampato, fattura già incassata etc. vedi Note su come correggere una fattura

Cancellazione
Una fattura può essere cancellata fino a quando non è stampata.
La cancellazione di una fattura riepilogativa riporta allo stato di 'stampato' tutti i ddt in essa riepilogati.
Allo stesso modo, la cancellazione di una fattura che evade un ordine, riapre l'ordine.

Ogni Fattura si compone di due gruppi principali di dati: la testata (dati del cliente, note, dati di accompagnamento, spese) e il dettaglio (elenco degli articoli).

Per ulteriori spiegazioni sui pulsanti, si rimanda a Gestione movimenti e documenti.

Parametri di personalizzazione gestiti da questo programma:

InizioAvvisoCliente
Se impostato con qualche carattere (es. $$), il programma stamperà un avviso sulla maschera del cliente se la nota in anagrafica cliente/fornitore inizia con questi caratteri.

RicalcColli
Fattura accompagnatoria
Per calcolare i colli in automatico nel quadro di accompagnamento

CalcolaPeso
Fattura accompagnatoria
Se impostato a S, il programma all'uscita dai dettagli (righe di articoli), calcola il peso totale (peso lordo letto sull'anagrafica di ogni articolo * quantità * Fattore di conversione) e compila la casella Peso gestita nei dati di accompagnamento.
Se il parametro manca o non è impostato a S, per forzare il calcolo del peso occorrerà premere il pulsante con i puntini a fianco al campo peso nei dati di accompagnamento.

CausalePerRicavo
Fattura diretta e accompagnatoria
Consente di mettere in automatico sui dettagli un conto di ricavo diverso da quello eventualmente scritto sul cliente o sull'articolo di magazzino.
Se si mette nel campo Valore il codice di una causale di contabilità, il programma controlla se tale codice è uguale a quello inserito nel campo Causale Co.Ge. del tipo documento con il quale viene fatta la fattura. In questo caso il conto di ricavo che verrà messo nei vari dettagli della fattura sarà quello scritto sulla causale di contabilità

SegnRicCli
In Variazione del codice cliente Segnala se il nuovo cliente ha un conto di ricavo in anagrafica

NoDecodSeProv
Se vale S, se si cambia il Tipo documento in una fattura proveniente da Ddt, da Ordine o da Preventivo, non verrà cambiata la condizione di pagamento nè il listino anche se sul nuovo tipo documento lo prevede.

Segnalazione giorni scaduto
Se sul tipo documento utilizzato per la registrazione, è stato impostato il campo 'Giorni per controllo scaduto' verrà segnalato, una volta digitato il codice del cliente, se esistono scadenze aperte con data inferiore alla data di inserimento documento meno il numero dei giorni. Inoltre, sul documento, nel quadro 'note del cliente' verrà visualizzato l'importo di tali scadenze.

Testata Documento

Nr.Riferimento, anno
Servono per identificare un documento appena inserito e cioè prima che venga assegnato ad esso il numero documento (fase di stampa).

Se viene digitato un numero e si preme il pulsante Ricerca, il programma va in ricerca del documento con quel numero. Impostando il numero a 0 si entra in modalità inserimento e viene assegnato un numero progressivo nell'anno, automaticamente dal programma.
Il campo Numero riferimento NON deve essere confuso con numero documento, in quanto è un numero interno

Inserito il
È la data in cui è stato inserito il documento ed è indipendente dalla data di stampa. Serve per identificare il documento in ricerca anche prima che questo venga stampato.

Tipo documento
Identifica le caratteristiche del documento inserito. Viene proposto quello scritto nella tabella di fatturazione. Dal tipo documento vengono lette alcune caratteristiche es. il prefisso, il listino, il magazzino di scarico e in particolare come aggiornare i progressivi dell'articolo. Se nel tipo documento Fattura non è stata collegata una causale di magazzino e la fattura non è riepilogativa, non verrà generato il movimento di magazzino e non verrà aggiornato di conseguenza il progressivo di scarico dell'articolo.
Questo campo non si può variare se sono stati inserite delle righe di dettaglio (articoli o descrittive).

Pref.
Identifica il registro iva su cui verrà stampato il documento. Viene proposto quello del tipo documento (se c'è), altrimenti quello principale scritto nei parametri comuni (Dati Generali Azienda). E' possibile variarlo nell'ambito dei caratteri inseriti nel campo: Elenco Prefissi Vendite dichiarati sempre in Parametri comuni. Consente di gestire più registri iva vendite. Il carattere '.' punto significa prefisso vuoto.

Numero e data documento
Sono numero e data della fattura e vengono assegnati, al momento della stampa, prendendo il progressivo dalla tabella dei Prefissi e Numeratori Documenti in base all'anno di stampa e al prefisso.

Non si consente di stampare fatture in data inferiore alla data dell'ultima fattura stampata in quanto verrebbe assegnato un numero successivo in una data precedente.

Viene data la possibilità di impostare manualmente questi due campi, per recuperare, ad esempio, un documento fatto a mano. Il numero e la data inseriti dovranno tuttavia essere minori o uguali a quelli scritti sul numeratore (stesso prefisso). Se viene assegnato un numero manualmente, il programma controlla se in archivio esiste un'altra fattura con lo stesso numero e non consente di proseguire.

Stato
Indica lo stato del documento. Il campo è bianco nel documento appena inserito, viceversa può contenere le scritte Stampato o Contabilizzato (cioè stampato e portato in contabilità).
La variazione è consentita SOLO se lo stato è bianco. Sono state predisposti dei pulsanti e delle funzioni per riportare un documento già stampato o contabilizzato allo stato iniziale.

Cod. Cliente
E' il codice del cliente al quale verrà intestata la fattura.

Le due 'parti' di ragione sociale vengono visualizzate con il seguente criterio (che è lo stesso utilizzato per la stampa dell'intestazione dei documenti): 1' parte è la 1' parte della Ragione Sociale del cliente, se sull'anagrafica cliente questa risulta non compilata, si prende la Ragione Sociale Contabile; 2' parte: si mette comunque il contenuto della seconda parte della Ragione Sociale cliente.

Di seguito vengono visualizzati: indirizzo, Iso, P.Iva, Cod.Fiscale, Telefono
Se sul cliente è compilata la data di chiusura viene visualizzata la scritta CHIUSO di fianco alla Ragione sociale.
Se sul tipo documento è compilato il campo 'giorni per controllo scaduto (X)', verrà data una segnalazione se il cliente ha delle scadenze aperte da più di X giorni.
Se si varia il cliente: verrà visualizzato il listino del nuovo cliente se prima il listino veniva da cliente con tutti i controlli di cambio listino e inoltre, se la variazione comporta una variazione della riga di spese bancarie, questa verrà rigestita in automatico.

Num.Movimento
Solo visualizzato. E' il numero di movimento di magazzino generato.
Se è stato installato il modulo della Distinta Base, vengono visualizzati, in Altri Dati, anche anno e numero dei movimenti Di.Ba. Carico Produzione e Scarico componenti

Num.Articolo Coge
Solo visualizzato. E' il numero di articolo di prima nota generato dalla contabilizzazione della fattura.

Rif. Cliente
Campo descrittivo.

Periodo Iva Mese/Anno
Questi campi dovranno essere valorizzati dall'utente se il periodo iva di competenza della fattura è diverso rispetto quello ricavato dalla data di stampa. Per le fatture riepilogative viene chiesto in fase di evasione.

Al momento della stampa, se il programma trova questi campi vuoti, li imposta con mese e anno della data di stampa.

Sotto i dati di Testata vengono visualizzati i seguenti totali:

Tot. Spese Tot. Merce Tot. Imponibile Tot. Iva Totale Documento
E, se sono state inserite delle righe di dettaglio, ne viene fatto l'elenco sintetico.
Cliccando sulle etichette delle varie cartelle proposte sotto l'anagrafica del cliente, (o digitando Alt e il numero corrispondente) si può accedere ad altri dati.

Dati Cliente (1)
Altri dati (2)
Campi Descrittivi (3)
Note di Testata (4)
Dati di accompagnamento (5)
Nota Cliente (6)
Documenti di Origine (7)
Spese
Dettagli


FATTURE (1) DATI CLIENTE

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Listino
Codice listino. In generale è il codice di listino letto dall'anagrafica cliente. Se però sul Tipo Documento utilizzato è stato impostato un listino particolare, verrà visualizzato quest'ultimo. Nel caso che la causale per l'aggiornamento del magazzino, posta sul tipo documento, preveda che il prezzo da proporre sui dettagli debba venire dal costo ultimo o dal costo medio invece che da un listino, questo campo verrà lasciato bianco.

In presenza di un listino, la moneta del documento è quella del listino e i prezzi verranno intesi 'ivati o meno' a seconda di quanto specificato sul listino stesso.

Quando ci sono già dei dettagli inseriti, si consente di variare il codice listino a condizione che il nuovo abbia la stessa moneta e lo stesso valore nel flag 'prezzi ivati o no'.

Il nuovo listino varrà per i dettagli inseriti successivamente. Per assegnare il prezzo di listino nuovo sulle righe di dettaglio preesistenti occorre andare su ogni riga e premere il pulsante [..] posto a fianco a prezzo e a sconti.

Prezzi ivati
Indica come sono i prezzi sul documento se netti o comprensivi di iva. Viene impostato con il valore letto dal listino e, in inserimento, può essere variato dall'utente.
In questo modo un listino ivato in origine può essere utilizzato come non ivato e viceversa in quanto ci pensa il programma a ivare o scorporare il prezzo in base a questo flag.

Condizione di Pagamento
Viene proposta quella del cliente e può essere variata per il documento in oggetto. Se la condizione richiamata prevede uno sconto pagamento, questo verrà visualizzato a fianco.
Esiste però la possibilità di impostare, sul tipo documento, quale condizione di pagamento utilizzare: o una particolare, il cui codice andrà scritto sul tipo documento stesso, o la seconda condizione scritta sul cliente.

Al cambio della condizione di pagamento variano le spese bancarie e le spese bolli per cui il totale fattura.

Se è già stata generata la riga di spese bancarie e si varia la condizione di pagamento o il campo che indica se il cliente è soggetto o no a spese bancarie, il programma gestirà in automatico la variazione.

Sconto Pagamento
Viene proposto il valore letto sulla condizione di pagamento del cliente.
Se viene variato, o cambia perché è variata la condizione di pagamento, viene ricalcolato il totale documento.

Sconto pagamento su dettaglio (S/N)
Se impostato a SI, l'eventuale sconto pagamento, verrà sommato agli sconti delle singole righe, piuttosto che essere calcolato sull'imponibile/i alla fine del documento. Si può impostare il parametro ScontoPagInDet per assegnare un valore di default al campo.
Sulle fatture elettroniche è obbligatorio che questo parametro sia impostato a SI

Sconto Cliente
Viene proposto il valore letto dall'anagrafica del cliente.
Se viene variato e sono già stati inseriti degli articoli sul documento, verrà chiesto se si vuole riportare il nuovo sconto sui dettagli. In caso affermativo verrà sostituito su ogni dettaglio in cui lo sconto cliente ha il valore vecchio, il nuovo valore e verrà ricalcolato lo sconto totale e l'importo di riga.
In particolare se viene messo uno sconto dove prima non c'era, questo verrà riportato in tutti i dettagli dove lo sconto cliente era vuoto.

Banca
Viene proposta quella del cliente e si può variare.
La ricerca del codice banca, oltre che per codice e descrizione, anche per ABI o ABI e CAB digitando l' ABI (completo o incompleto con * finale) oppure ABIçCAB (il carattere ç deve essere sempre scritto in fondo all'abi anche se non si mette anche il cab) e premendo il tasto F2 (lista per codice) o F3 (lista per descrizione).

Raggruppamento Ricevute Bancarie
Indica se in fase di compilazione distinte le ricevute bancarie del cliente devono essere raggruppate.

Acconto
Se al momento della fattura viene dato un acconto, occorre compilare il campo Acconto della maschera dati cliente e la rispettiva modalità di pagamento (campo a fianco all'acconto). In questo modo sul file xml della fattura verrà evidenziato che è stato dato un acconto, ad esempio in Contanti, e verranno generate le scadenze per la differenza tra l'importo della fattura e l'acconto.

Viceversa se è stata emessa precedentemente una fattura di acconto, occorre inserire nel corpo fattura una riga 'articolo' con quantità 1, importo (imponibile fatturato) negativo e codice iva utilizzato nella precedente fattura. In questo modo il totale a pagare, verrà calcolato correttamente
La procedura ne terrà conto al momento della contabilizzazione fatture per la determinazione degli importi delle scadenze da generare e verrà generato un articolo di prima nota (c.to/acconti da tabella Conti Comuni in Dare e Cliente in Avere) con l'importo dell'acconto.

Modalità di pagamento anticipato
Campo utilizzato per la fattura elettronica, da compilare nel caso venga digitato un importo in Acconto

Abbuono
E' possibile indicare un abbuono fatto sul totale della fattura. La procedura ne terrà conto al momento della contabilizzazione fatture per la determinazione degli importi delle scadenze da generare.

Iva sospesa
Viene visualizzato il valore letto dall'anagrafica cliente con possibilità di varialo. Consente di emettere al cliente una fattura con iva differita (Pubblica amministrazione)
Dal gennaio 2015 NON dovrà più essere utilizzato in quanto, per la Pubblica Amministrazione, entra in vigore il meccanismo dello Split Payment

Dichiarazione di intenti
Se il cliente ha presentato la dichiarazione di intenti ed è stata compilata sui suoi dati anagrafici, una riga nella maschera (0) Dich.Int., al momento dell'inserimento di un ordine, ddt o fattura, verranno compilati in automatico questi campi con il codice assegnato sul cliente alla riga di dich. di intenti attiva in quel momento e la nota costruita in base al valore assegnato al parametro di personalizzazione DichIntentiTab
Si può creare il parametro di personalizzazione DichIntentiValDef con valore diverso da S per disabilitare la compilazione automatica del campo 'codice'
Premendo il tasto F2 sul campo 'codice' vuoto o compilato con qualche carattere oppure con un click sui pulsantini a fianco, il programma cerca sulle descrizioni delle righe di dichiarazioni di intento attive compilate sul cliente. Col tasto F3 cerca su tutte le righe (anche quelle inattive)
L'assegnazione di un 'codice' lettera di intenti al documento consentirà al programma di calcolare e visualizzare i totali Fatture, Ddt (stampati e/o appena inseriti) e Ordini NON evasi (non si considerano i parzialmente evasi) che hanno lo stesso codice e quindi di segnalare se si sta superando il plafond e calcolare il residuo
E' possibile definire due parametri di personalizzazione:
DicIntentiCalcRes che indica quali documenti considerare nel calcolo del residuo per dichiarazione d'intenti: F = solo fattura, D = fattura + DDT, O = fattura + DDT + ordini
DichIntentiQualeTot per stabilire quali importi considerare nel calcolo del residuo (default il totale documento)

E' possibile variare il codice Dichiarazione di intenti anche su una fattura già stampata e contabilizzata, premendo il pulsante 'Varia' posto a sinistra del codice poi salvando con il pulsante 'Salva dich.intenti'

Sul file xml della fattura elettronica, la frase con i dati della dichiarazione di intenti, verrà riportata come riga descrittiva alla fine del corpo.

Il campo 'codice' dichiarazione di intento è una condizione di Raggruppo per evasione preventivi,ordini e ddt per cui se si evade un documento nel quale questo campo è stato compilato, esso verrà raggruppato solo in documenti nei quali questo campo ha lo stesso valore.
Se invece non è compilato entra in gioco il parametro: DicIntentiVerif

Perc.Riten.acconto
E' l'eventuale percentuale di ritenuta acconto che verrà utilizzata per il calcolo della ritenuta d'acconto da evidenziare sulla fattura e per la registrazione del relativo movimento durante la contabilizzazione.

Codice Iva
Viene visualizzato il valore impostato in anagrafica del cliente. Indica il codice di esenzione a cui è soggetto il cliente e che deve prevalere sull'aliquota dei vari articoli. Può tuttavia contenere anche un codice 'iva'. Se valorizzato, viene assunto come codice iva di ogni articolo che verrà inserito nel corpo del documento e non sarà possibile varialo.
Tale codice verrà impostato anche sulle eventuali righe di spesa, con possibilità di variazione.
Se viene variato il codice iva e ci sono delle righe di dettaglio (righe articolo) e/o spese, si chiede se si vuole aggiornare il codice iva su tutti i dettagli. Se il campo in testata è valorizzato e lo si sbianca, non viene fatta nessuna variazione sui codici iva dei dettagli.


FATTURE (2) ALTRI DATI

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Magazzino
E' il codice del magazzino dal quale scaricare gli articoli. Viene proposto quello scritto sul tipo documento o, se lì è bianco, si prende il magazzino principale dalla Tabella di Magazzino. In caso di fattura riepilogativa con raggruppo delle bolle per magazzino, questo campo non verrà visualizzato.

Moneta
E' la moneta del listino. Se non c'è un listino la moneta è quella principale. Si può variare solo in inserimento della testata del documento.

Cambio
Indica il cambio della moneta del documento rispetto l'Euro.
Nel momento dell'inserimento, se la moneta è Lire, Euro o altra moneta dell' UEM, il cambio verrà impostato automaticamente (letto dalla tabella cambi) e non sarà possibile variarlo.

Per ogni altra moneta il cambio verrà cercato nell'archivio cambi con data minore o uguale alla data di inserimento. Questo cambio potrà tuttavia non essere definitivo in quanto verrà chiesto di nuovo e reso definitivo al momento della Stampa fattura.

Addebito bolli
E' una caratteristica letta dall'anagrafica clienti. Indica se addebitare o no il costo dei bolli per effetti, sulla fattura.

Addebito spese bancarie
Viene proposto il valore impostato sul cliente. Indica se addebitare o no in fattura le spese bancarie.

Estrazione provvigioni 1 e 2
Vengono proposti i valori letti sull'anagrafica cliente in corrispondenza a ciascun agente

  • NO
  • da Articolo
  • da Cliente
  • da Agente

Se si varia questo campo e ci sono dei dettagli già inseriti, verrà fatta la richiesta se portare il nuovo valore su tutti i dettagli o solo su quelli per cui la percentuale coincide con la vecchia percentuale in testata.
La richiesta non viene tuttavia fatta se il campo viene impostato a NO o a 'da Articolo'.

Contratto
Se la fattura si riferisce a un contratto, è possibile associarne il codice in modo da compilare poi correttamente la Comunicazione delle Operazioni rilevanti ai fini Iva.

CIG e CUP
Sono rispettivamente il Codice Identificativo di Gara e Codice Unico di Progetto. Possono essere digitati direttamente sul documento o venire dal contratto.
Se si imposta un codice contratto sul quale sono stati inseriti i codici Cig e Cup, questi verranno riportati sul documento SOLO se non sono già impostati.
Se si sbianca il codice contatto, sul documento i codici Cig e Cup eventualmente già impostati perchè letti dal contratto inserito in precedenza, non verranno sbiancati.
Potranno essere stampati sul documento (occorre inserire righe apposite nel filtro di stampa) e verranno poi riportati sulle scadenze.

Codice IPA (Ufficio Pubblica Amministrazione)
E' il codice dell'ufficio a cui va spedita la fattura elettronica (Tale codice dovrà essere fornito dal cliente e può essere impostato sulla sua anagrafica)

Agente 1 , Agente 2 - % Provv. 1 e 2
Vengono proposti i codici agenti letti dall'anagrafica cliente e le rispettive percentuali, lette dall'agente o dal cliente a seconda di come sono stati impostati i campi: Estrazione Provvigioni.
Se è sull'agente verranno visualizzate le % dei due agenti con possibilità di variazione
Se si varia questo campo e ci sono dei dettagli già inseriti, verrà fatta la richiesta se portare il nuovo valore su tutti i dettagli o solo su quelli per cui la percentuale coincide con la vecchia percentuale in testata.

Banca per bonifici
Per la fattura elettronica; se la condizione di pagamento è Bonifico qui deve essere impostato il codice della banca su cui il cliente dovrà fare il bonifico, in modo che il programma possa prendere da tale banca il codice IBAN da riportare in fattura. La banca può essere impostata sulla condizione di pagamento

Fattura di riferimento (Pref. Numero e Data Doc. Originale)
Questi campi vengono richiesti e visualizzati quando si sta inserendo un documento con un 'Tipo documento' che ha la causale di contabilità collegata definita come 'Nota di variazione'
Sono i riferimenti alla fattura che viene rettificata e serviranno in particolare per controlli per preparare i dati per la Comunicazione operazioni rilevanti ai fini IVA.
Nel caso di una Nota di Credito creata in automatico da un Ddt di reso, dovranno essere inseriti manualmente sul documento, prima della stampa.
Tali dati potranno essere stampati in campi particolari del modulo di stampa, nel caso di nota di credito, se inseriti nel filtro di stampa.
Per ulteriori informazioni sull' obbligatorietà di tali dati leggere il paragrafo: Note di variazione'

Periodo di riferimento Nota di Variazione
può assumere i seguenti significati:

  • Non si riferisce a periodi precedenti
  • Si riferisce ad anni precedenti
  • Si riferisce a periodi già comunicati nell'anno (Black List)

Questo campo dovrà essere impostato correttamente nel caso si stia registrando una Nota di variazione (nota di credito) riferita a fattura dell'anno precedente o a fattura dell'anno corrente ma registrata in un periodo di cui è già stato fatto l'invio telematico del file 'Black List'.

[Vecchio utilizzo:Questo campo verrà utilizzato, una volta contabilizzata la fattura, dal programma di aggiornamento iva e da quello di Ricalcolo dei progressivi iva clienti e fornitori al fine di poter stampare correttamente gli Elenchi clienti e fornitori.Questo flag va impostato a Si se il documento che si sta registrando è una Nota di variazione registrata nell'anno ma riferita ad anni precedenti]


FATTURE (3) CAMPI DESCRITTIVI

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Lingua
Codice lingua letto dall'anagrafica cliente. Verrà utilizzato, compilato, per stampare sul documento le descrizioni degli articoli in lingua piuttosto che quelle in italiano.

Codici Note Fisse
Vengono proposti i codici letti dal tipo documento. Sono note fisse, scritte nel rispettivo archivio, che possono essere stampate sul documento. Verranno portate, solo se la nota lo prevede, sul documento di evasione, con un massimo di tre. Se sulla condizione di pagamento è stato messo un codice di nota fissa, questo verrà portato sulla fattura.

Indirizzo amministrativo
In questo campo viene proposto l'eventuale indirizzo amministrativo presente sull'anagrafica del cliente (indirizzo a cui va spedita la fattura se diverso dall'indirizzo del cliente).
In stampa questo indirizzo sostituirà quello del cliente. E' possibile impostare il parametro IndAmmSep per mettere a disposizione separatamente l'indirizzo amministrativo.

Mov.Di.Ba. Carico Produzione e Scarico componenti
Se è stato installato il modulo della Distinta Base, vengono visualizzati anno e numero dei movimenti di magazzino che contengono rispettivamente il carico da produzione e lo scarico dei componenti relativi agli articoli del ddt, generati al momento della stampa.

Invio per email
Data ultimo invio
Risultato: Riuscito Fallito Non inviata Da non inviare
Se si spedisce la fattura via email direttamente col programma, questo campo consente di conoscere, oltre a consultare il file di log, se la fattura è stata inviata o meno. Se una fattura NON dovrà mai essere inviata si può impostare il campo a 'Da non inviare'.
La fattura risulterà NON spedita se manca l'indirizzo email del cliente, mentre risulterà comunque spedita se tale indirizzo è errato.
Per variare il criterio di aggiornamento della data di ultimo invio, si può utilizzare il parametro di personalizzazione: AggDataInvioEmail


FATTURE (3) NOTE TESTATA

FATTURE (4) NOTE TESTATA

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Si consente di inserire delle righe di testo e di scegliere se stamparle o meno sul documento. Sarà poi con il filtro che si stabilisce dove stamparle (se in testa o nel piede).

Se su una fattura, nel campo Note Testata si scrive: NOXML , NON verrà riportata nessuna riga descrittiva

Il contenuto di questo campo verrà riportato sul file XML della fattura elettronica nel corpo fattura come riga descrittiva. Vedi parametro NoteFat


FATTURE (4) DATI di ACCOMPAGNAMENTO

FATTURE (5) DATI di ACCOMPAGNAMENTO

Percorso: Vendite - Fatture - Fatture Dirette-Accompagnatorie

Questi dati vengono in parte letti dall'anagrafica del cliente e possono essere variati per il singolo documento.

Per scrivere indirizzo, vettore etc. direttamente sul documento, senza averli prima inseriti sui rispettivi archivi, basta via via sbiancare il codice corrispondente e scrivere direttamente negli spazi a fianco.

Destinatario (Indirizzo di spedizione)
Viene proposto il codice dall'anagrafica del cliente ma è possibile anche inserirne uno valido solo per questo documento.
Se sull'indirizzo di spedizione in archivio, è stato impostato a Si il campo Indirizzo Principale per Fattura, la stampa Ddt invertirà l'indirizzo del cliente e l'indirizzo di spedizione e ignorerà l'indirizzo amministrativo.

Vettore
Viene proposto il codice vettore scritto sul cliente.
Impostando il parametro MemTargaVet si consente di inserire/variare la targa del vettore nella maschera dei dati di accompagnamento

Causale Trasporto
Viene proposto il codice inserito in tabella di fatturazione.

Aspetto dei Beni
Viene proposto il codice inserito in tabella di fatturazione.

Porto (Resa)
Viene proposto il codice inserito sul cliente (porto franco, porto assegnato).

Tipo Trasporto
Viene proposto il codice inserito in tabella di fatturazione (posta, corriere,..)

Colli
Questo campo può essere compilato manualmente oppure si può premere il pulsante posto al suo fianco per ottenere la compilazione automatica con il risultato della somma dei colli (e non delle quantità) inseriti in ogni riga. Vedi parametro RicalcColli
Di default il numero dei colli è intero, è possibile impostare il parametro di personalizzazione ColliDec per gestirlo con decimali.

Peso
E' possibile ottenere il calcolo automatico del peso attivando il parametro di personalizzazione CalcolaPeso (CalcolaPesoLordo, CalcolaPesoUm)Il peso può essere, a seconda dell'impostazione dei parametri suddetti, la somma delle quantità nelle righe di dettaglio o la somma dei pesi scritti nel campo 'peso lordo' dell'anagrafica dei singoli articoli, maschera (6) Altro.

Data e Ora Inizio Trasporto
Data e Ora Ritiro Merce


FATTURE (5) NOTA CLIENTE

FATTURE (6) NOTA CLIENTE

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

In inserimento, in questo quadro vengono visualizzate alcune informazioni del cliente:

il contenuto dell'eventuale nota scritta sull'anagrafica, il segnale di rischio e il fido.

E' possibile impostare il parametro di personalizzazione InizioAvvisoCliente con i caratteri iniziali delle note IMPORTANTI, es. $$. I programmi di ordini , ddt e fatture, in corrispondenza a clienti con nota che inizia per $$, visualizzeranno, nella maschera dell'anagrafica cliente una nota 'rossa' per avvisare di leggere le note del cliente in oggetto, nell'apposito spazio.

Se nella tabella Tipi documento, in corrispondenza al tipi documento utilizzato per il ddt attuale, si imposta un numero di giorni per calcolo scaduto, verrà calcolato in automatico (dalle scadenze aperte) lo scaduto alla data del documento che si sta inserendo.

In variazione del documento si può rileggere lo scaduto premendo il pulsante [..] posto a fianco di Pagamenti scaduti.

Inoltre in questo quadro vengono proposti, solo nelle fatture dirette o accompagnatorie, i campi 'liberi': es. Modello, Targa (se sono state impostate le rispettive descrizioni in tabella di fatturazione).

Questi campi, se valorizzati, potranno essere stampati sulla fattura.


FATTURE (6) DOCUMENTI di ORIGINE

FATTURE (7) DOCUMENTI di ORIGINE

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

In questo quadro è possibile consultare i riferimenti dei documenti che hanno generato la fattura (es. ordini o DdT)


FATTURA ELETTRONICA - DATI TESTATA

Percorso: Vendite - Fatture - Fattura diretta/accompagnatoria

Dalla testata della fattura, con il tasto (K)Altri Dati per Fattura Elettronica [image] si può accedere al quadro, che contiene i dati che vanno a completare il documento e che sono previsti nel tracciato della fattura elettronica.

In questa maschera viene riproposto il Codice Destinatario della fattura elettronica (IPA) allo scopo di poterlo variare anche dopo che la fattura è stata stampata e contabilizzata con scadenze già elaborate.

Dati Ordini di Acquisto - Contratto - Convenzione - Ricezione - Fatture collegate
La valorizzazione di questi dati è necessaria al fine di consentire un collegamento con il processo di approvvigionamento e, di conseguenza, la possibile dematerializzazione del ciclo passivo; tali informazioni non sono obbligatorie ma la loro definizione nel rapporto contrattuale è fortemente consigliata.

Codice (viene utilizzata la tabella dei Contratti per tutti e quattro i tipi)
E' possibile creare, nella tabella Contratti, dei codici relativi a Ordini di Acquisto, Contratti, .... compilare in essi i vari campi e mettere qui il codice corrispondente; in questo modo il programma il programma di preparazione del file xml, estrarrà i vari campi (es. CIG , CUP) dal 'contratto' . Viceversa si possono inserire i dati direttamente qui.
I campi in gestione sono uguali per tutti i tipi: Ordini di Acquisto - Contratto - Convenzione - Ricezione

Identificativo Documento:
numero dell’ ordine di acquisto (contratto,...) associato alla fattura o alla linea/linee di fattura indicate nel campo NumeroLinea.
Campo OBBLIGATORIO affinchè eventuali altri dati (es. CIG e CUP) compilati nella sezione, vengano riportati in fattura

Data: data dell’ ordine di acquisto (contratto,...) associato alla fattura o alla linea/linee di fattura indicate nel campo
NumeroLinea: numero della linea di dettaglio della fattura alle quali si riferisce l’ordine di acquisto
Nel caso in cui l’ordine di acquisto si riferisce all’intera fattura, questo campo non deve essere valorizzato.
Codice della Commessa o della Convenzione

Codici CIG (Codice Identificativo Gara) e CUP (Codice Unico di Progetto)

Fatture collegate
blocco contenente le informazioni relative alle fatture precedentemente trasmesse e alle quali si collega il documento presente;
riguarda i casi di invio di nota di credito e/o di fatture di conguaglio a fronte di precedenti fatture di acconto (contiene gli stessi dati descritti sopra)
Se nota di variazione il programma di preparazione del file xml della fattura, cerca se sono compilati i dati in 'Fatture collegate' nei quadri di Testata o Dettaglio fatture elettroniche, se non li trova scrive sul file il numero e la data della fattura di riferimento scritta in testata fattura

DDT
Questi campi dovranno essere compilati solo in corrispondenza a una fattura con ddt fatti a mano, nel caso che l'intera fattura si riferisca a un'unico ddt (in caso di fattura riepilogativa, il programma provvederà a compilare direttamente sul file XML i campi di riferimento ai ddt)

Altri dati
Codice progressivo univoco
Stringa che, se inserita, verrà scaricata, sul file xml, a completamento del campo Progressivo Invio che già viene compilato con Prefisso+una cifra che identifica l'anno + il numero fattura.
Riferimento amministrazione (non obbl)
Eventuale riferimento utile all’amministrazione destinataria (capitolo di spesa, conto economico etc.)
Numero Bollo / Importo Bollo
Vanno valorizzati nei casi in cui sia prevista l’imposta di bollo (dal febbraio 2015, col bollo virtuale, si dovrà impostare SI il campo Numero Bollo se è stato assolto il Bollo)
Art.73
valore ammesso S/N. Se S - documento emesso secondo modalità e termini stabiliti con DM ai sensi dell'art. 73 DPR 633/72
Ciò consente al cedente/prestatore l'emissione nello stesso anno di più documenti aventi stesso numero
Causale Descrizione
Descrizione della causale del documento
Questo campo verrà riportato nel corrispondente campo sul file xml e può servire per inserire delle note sul documento.
In fase di estrazione del file XML a quanto scritto in questo campo verrà aggiunta, se è compilata, la nota che dice se la fattura è Split Payment (parametro: SplitPayment)
Fase stato avanzamento lavori
Norma di riferimento (campo eliminato dal Febbraio 2015)
Norma di riferimento, comunitaria o nazionale, da indicare nei casi in cui il cessionario/committente è debitore di imposta in luogo del cedente/prestatore (reverse charge), o nei casi in cui sia tenuto ad emettere autofattura.
Negli altri casi il campo non va valorizzato
Fattura principale numero e data
valorizzare nei casi di fatture per operazioni accessorie, emesse dagli 'autotrasportatori' per usufruire delle agevolazioni in materia di registrazione e pagamento dell' IVA

DATI pagamento:
Beneficiario
beneficiario del pagamento (utilizzabile se si intende indicare un beneficiario diverso dal cedente/prestatore)
Nome , Cognome, Codice fiscale e Titolo quietanziante
impostare nei casi in cui la modalità di pagamento per fattura elettronica (codice inserito in Tipo pagamento e riportato nel quadro scadenze) sia MP04: Contanti presso tesoreria

Eventuali allegati
C'è la possibilità di inserire dei percorsi completi che individuano uno o più file (in formato word, jpg etc.) da inviare come allegati al l'XML della fattura. Gli allegati possono essere aggiunti anche nella maschera di stampa fattura (in fase di preparazione del file XML), in questo caso verranno memorizzati all'interno della fattura solo se è stata scelta la STAMPA e non la Prestampa o Ristampa

Allegare Pdf nel file XML

  • In base alla scelta in stampa
  • Sempre
  • Mai

Invio all'HUB Zucchetti

  • Stato iniziale
  • Attesa invio
  • Inviato

Terminale di invio
Nome del terminale che ha fatto l'invio

Id file XML
E' l'identificativo del file Xml della fattura. Viene attribuito al momento dell'invio all'HUB

Stato iniziale
Questo campo verrà impostato dal programma al momento dell'inserimento della fattura come DV - da validare.
Può essere variato manualmente sulla singola fattura oppure impostando il parametro di personalizzazione: HubStatoIniz

  • DF Da Firmare
  • DI Da integrare
  • DV Da Validare
  • DC Da Confermare
  • DN Da inviare a Sdl

Livelli su Xml (Solo se l'azienda gestisce i livelli)
In base a questo campo si stabilisce come esplicitare sul file XML della fattura elettronica, le righe di articoli con livelli.

  • Standart
    E' il valore di default impostato sulla fattura dal programma. In questo caso il programma di preparazione dell'XML va a vedere cosa c'è sul campo corrispondente presente in Gestione Clienti
  • No articolo principale
    Verranno elencate tutte le righe dei livelli ciascuno con quantità e prezzi
  • Solo articolo principale
    Verrà riportata solo la riga dell'articolo principale con la somma delle quantità e dei prezzi delle singole righe dei livelli
  • Prezzo sui livelli
    Verrà stampata la riga articolo senza prezzo seguita dalle righe dei livelli ciascuna col suo prezzo
  • Prezzo su riga articolo
    Verrà stampata la riga articolo con il prezzo totale , seguita dalle righe dei livelli con prezzo a 0


FATTURE SPESE

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Per inserire le righe di spesa da addebitare al cliente per il documento che si sta inserendo (Es. spese di trasporto in fatture accompagnatorie), occorre premere il pulsante [image] (X)Spese posto sulla barra delle icone e attivo dal momento che si conferma la testata del documento.

La spesa inserita dovrà essere stata precedentemente creata con la corrispondente gestione e dovranno essere state definite le sue caratteristiche: il suo codice iva, se è a importo o in percentuale, etc

Se si imposta il parametro di personalizzazione SpesaClieAutom a S , il programma caricherà in automatico la spesa eventualmente inserita nell'anagrafica del cliente. In alternativa, tale spesa, può essere caricata manualmente, premendo il pulsante: (E) sp(E)se cliente nel quadro Spese del documento.
Eventuali altre spese dovranno essere inserite manualmente e potranno essere variate anche se il Ddt è stampato o se l'ordine è parzialmente evaso.

NOTA sul codice iva: gli importi inseriti nelle righe 'spese' vengono considerati sempre al netto dell'iva. E' possibile inserire in fattura una spesa esente ma NON un codice iva da Scorporare, quest'ultimo verrà considerato come un'iva normale e sull'importo verrà nuovamente calcolata l'iva.
Se sul cliente è stato impostato un codice iva (esenzione) esso verrà messo anche sulle spese con possibilità di variarlo.

In evasione ordini e ddt nel documento che si va a generare, verranno portate le righe di spese dei documenti originali raggruppandole secondo quanto specificato nel campo 'Tipo evasione' di ogni spesa.

Inoltre in evasione ordini o ddt in fattura, se per il cliente è previsto l'addebito delle spese bancarie e la condizione di pagamento è ricevuta bancaria con associato un codice spesa (in tabella), verrà generata in automatico la riga di Spese Bancarie.

Se si varia la condizione di pagamento nella testata della fattura, viene gestita la cancellazione o ricalcolo della riga di Spese Bancarie.


FATTURAZIONE (QUADRO SCADENZE)

Percorso: Vendite - Fatture - Fattura diretta/accompagnatoria

Al quadro scadenze si può accedere dalla testata della fattura con il tasto [image] (Z) Gestione scadenzario a condizione che sia stato impostata sulla testata fattura una condizione di pagamento.

In questa maschera, è possibile, col tasto 'Rigenera', generare le scadenze in base alla condizione di pagamento messa in testata fattura
Se la fattura non è ancora stata stampata sarà necessario compilare il campo 'la data fattura' presentato sulla maschera al fine di un corretto calcolo delle scadenze, viceversa verrà utilizzata la data documento.
Se si varia una fattura per la quale le scadenze sono già state generate, verrà presenta la maschera e l'operatore potrà variarle manualmente o Rigenerarle per aggiornare le scadenze ai nuovi importi o alla nuova condizione di pagamento.

Al momento della contabilizzazione della fattura, se questo quadro è vuoto, verranno generate le scadenze in base alla condizione di pagamento, altrimenti verranno considerate queste.

Campi in gestione:
Scadenza
E' la data di scadenza
Tipo e Descrizione
Il campo Tipo pagamento verrà lasciato bianco se è lo stesso della condizione di pagamento della testata (situazione tipica) , altrimenti dovrà essere digitato
Importo
importo relativo alla scadenza

Campi informativi, facoltativi, per la compilazione del file Xml della fattura elettronica
Sconto pagamento anticipato
Importo dello sconto che potrà essere fatto in caso di pagamento anticipato
Data limite anticipato
data limite stabilita per il pagamento anticipato
Pen PagRit
ammontare della penalità dovuta per pagamenti ritardati
Data dec pen
data di decorrenza della penale
Codice pagamento
codice per la riconciliazione degli incassi da parte del cedente/prestatore
Rif.data
S/N - Indica se scrivere o meno sul file della fattura elettronica la data di cui al campo successivo
Data Rifpag
data dalla quale decorrono i termini di pagamento (es. data fattura o data dell'ultimo giorno del mese della fattura)

Per motivi tecnici, nelle fatture con condizione pagamento Tratta, il calcolo bolli viene fatto con le scadenze 'originali' e non con quelle di questa maschera.

N.B. Se vengono aggiunte manualmente delle scadenze con tipo pagamento Bonifico, è necessario inserire in testata fattura (maschera (2) Altri Dati) il codice della Banca per Bonifici


FATTURE DETTAGLI

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Una volta inserita la testata del documento si procede all'inserimento dei dettagli premendo il pulsante [image] (E) Gestione Dettagli o Salva o F10.

In questo punto è possibile inserire le varie righe del corpo del documento. Le righe possono essere costituite da: articoli presenti in tabella articoli (dovranno essere richiamati con codice), articoli manuali (il codice dovrà essere lasciato vuoto e dovrà essere compilata la descrizione) oppure righe descrittive (per commenti).

Se è stata abilitato il modulo di tracciabilità e per l'articolo in oggetto, da anagrafica, è stata prevista la gestione dei lotti, verrà presentata in alto a destra, un pulsante che consente di inserire i lotti da attribuire alla merce in uscita: (Gestione lotti)

Per l'inserimento dei lotti vedere Lotti-Caricamento movimenti e Lotti Selezione quantità

Se è stata abilitata la gestione delle matricole (Parametro di personalizzazione: MatrGest verrà presentata, in alto a destra, una icona che consente di inserire, su ogni riga articolo, le matricole associate [image] (J) Gest.matricole

Se sono stati abilitati la lettura degli articoli o delle matricole da file o Terminale ottico
(Parametri di personalizzazione LettArtDaFile o LettMatrDafile) verranno visualizzate le rispettive icone che consentono la lettura dei dati

(B) Lettura da file Ascii [image] (Q) Lett.matricole da file
vedi Caricamento dettagli documenti da file e

Caricamento movimenti di magazzino - matricole da file)

Il pulsante (U)Altri Dati per Fattura Elettronica [image] consente di accedere ai dati che sono previsti nel tracciato della fattura elettronica
Si tratta degli stessi dati già descritti anche nella maschera della testata della fattura. Mentre là riguardano l'intera fattura, qui si possono impostare per ogni riga , nel caso di fatture che comprendano beni relativi a Ordini, Contratti , .. diversi.
In questo caso su ogni riga si imposteranno i dati relativi.

Cod. Articolo
(Ricerca per cod. descr. Cod a barre)
Se il codice articolo viene lasciato bianco si consente di inserire un articolo 'manuale' cioè di compilare manualmente tutti i dati della riga: descrizione, quantità, sconto, codice iva etc. In questo caso non verrà generato nessun movimento di magazzino.
Se invece viene inserito un codice articolo, esso dovrà esistere nella tabella degli articoli di magazzino.
Con F9 si attiva il pulsante per cambio modalità di ricerca dell'articolo (codice/descrizione o codice a barre).
La ricerca dell'articolo avviene con i tasti F2 (codice), F3 (descrizione), F4 (codice a barre), come specificato in Lista di aiuto (ricerca codice)
E' abilitata inoltre la ricerca con i tasti Shift F2 - F3 - F4

Premendo il tasto F8 è possibile inserire una Riga Descrittiva.
Per una corretta compilazione della fattura elettronica, nella maschera di inserimento della riga descrittiva, sono stati inseriti tre campi i cui valori di default possono essere impostati con i parametri di personalizzazione RigaDescInXml , RigaDescInStampa , RigaDescAltroXArt :

  • in XML
    Se impostato a Si il contenuto della riga descrittiva verrà riportato sul file XML
  • su Carta
    Viene utilizzato per impostare il valore del campo 'Su carta' presente sulla riga descrittiva del corpo fattura. Se impostato a Si il contenuto della riga descrittiva verrà stampato sulla fattura
  • Altri dati per articolo
    Se sulla riga di un articolo serve avere più di un elemento nella sezione ‘altri dati gestionali su XML’ si dovrà creare una o più righe descrittive prima della riga articolo, impostare a Si questo campo poi andare in ‘altri dati x fatt. elettronica’ con il pulsante apposito e inserire nel quadro (7) Altri dati, i dati necessari in Altri dati gestionali (esempio: identificativo scontrino)

Premendo il tasto F6 è possibile inserire una Riga di Comando.

Se si sta facendo la ricerca per codice a barre, è possibile attivare il parametro di personalizzazione: CodBarSalva in modo che, in inserimento, all'uscita del campo articolo venga salvata la riga e si passi ad un altro inserimento. Ovviamente è indispensabile che sull'articolo siano compilati tutti i campi necessari (unità di misura, codice iva etc.) e che sia stato definito il parametro Qtadef per impostare in automatico le quantità sulla riga.

Dopo aver inserito il codice di un articolo verranno proposti unità di misura, quantità per confezione, prezzo (se codificato), sconti, aliquota iva e conto ricavo letti dall'articolo etc.
Verranno inoltre visualizzate giacenza e disponibilità dell'articolo sul magazzino impostato sulla testata del documento ed eventualmente anche su tutti i magazzini (vedi parametro di personalizzazione: MagaNoGiac.

Se sull'articolo è stato chiesto di segnalare se è esaurito, verrà data una segnalazione se la giacenza è minore di 0.

Se l'articolo ha la gestione dei livelli (taglia-colore) l'inserimento del dettaglio procede come descritto in Dettagli con Livelli.

Descrizione
E' la descrizione dell'articolo richiamato. Se viene modificata verrà memorizzata sul documento per la stampa e l'evasione e verrà visualizzata la nota 'descrizione modificata'.
Se l'articolo è manuale, la descrizione dovrà essere inserita dall'operatore.

Cliccando sulle etichette delle varie cartelle proposte (o digitando Alt e il numero corrispondente), si accede ad altri dati:
(1) Principale
(2) Descrizione lunga articolo e note di dettaglio
(3) Riferimento documenti di provenienza
(4) Altro
Vengono gestiti i campi:
lunghezza, larghezza, altezza, codice contratto e dati fattura di riferimento se si tratta di nota di credito.
In caso di Nota di Credito è possibile impostare sui vari dettagli riferimenti di fatture diverse cui si riferiscono.

Tipo Cessione/Prestazione
Per fattura elettronica, indica se quella riga è 'Normale' , 'Sconto', 'Premio', 'Abbuono', 'Spesa accessoria'
Se la riga è già è stata impostata come omaggio, indipendentemente da cosa si scrive qui, il programma metterà sulla fattura elettronica: Premio
Se il programma trova spuntato spesa accessoria la somma nel riepilogo iva delle spese accessorie

Se sulla riga di un articolo, ai fini della compilazione della fattura elettronica, serve avere più di un elemento di ‘altri dati gestionali su XML’ si devono creare una o più righe descrittive prima della riga articolo settare il flag Altri dati per articolo e andare in ‘altri dati x fatt. elettronica’ , inserendo in (7) i dati in Altri dati gestionali

Se sulla riga di un articolo, ai fini della compilazione della fattura elettronica, serve avere più di un elemento nella sezione ‘altri dati gestionali su XML’ si dovrà creare una o più righe descrittive prima della riga articolo, impostare a Si il campo 'Altri dati per articolo' , salvare la riga, tornare sulla riga e andare col pulsante in alto a destra: ‘altri dati x fatt. elettronica’ e inserire nel quadro (7) Altri dati, i dati necessari in Altri dati gestionali (esempio: identificativo scontrino)

Nelle righe di dettaglio per la compilazione di 'altri dati gestionali' del file XML :
Per righe relative a Sconto – abbuono – spese accessorie – Omaggi con rivalsa iva e Omaggi senza rivalsa, Assosoftware ha previsto alcune codifiche, in particolare:
storno omaggio (sigla #SO#)
sconto merce (sigla #SM#)
sconto (#SC#)
acconto #AC#

Se si compila il campo Nota sotto con una delle sigle corrispondenti , il programma vede che la nota sotto inizia con questi 4 caratteri crea la sezione Altri Dati Gestionali dove mette questa informazione (es fattura con acconto già fatturato in precedenza: si può fare una riga con l’importo dell’acconto in negativo dove mette nella nota sotto la sigla corrispondente)

Se è un articolo in promozione in altri dati gestionali mette Promozione
Aggiunto l’elenco dei lotti e delle matricole

--- Nelle righe di dettaglio possono esserci
sconto premio, abbuono o spesa accessoria (nella maschera Altro della riga articolo)
Se il programma trova spuntato spesa accessoria la somma nel riepilogo iva delle spese accessorie (già scritto nel manuale) ---
E' possibile attivare il parametro di personalizzazione NotaLinguaDove per utilizzare la descrizione lunga in lingua come ulteriore descrizione dell'articolo da copiare nella nota sotto e stampare sul documento.


FATTURE DETTAGLIO PRINCIPALE

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Caricamento movimenti da file (Caricamento dettagli documenti da file).
E' possibile, configurando opportuni parametri, (in particolare LettArtDaFile) , compilare automaticamente una fattura, leggendo da file le varie righe di dettaglio. L'operazione avviene cliccando sull'icona [image] (B) Lettura da file Ascii che compare nella maschera di Gestione dettagli

Gestione matricole sulle righe articolo:
Se è stata abilitata la gestione delle matricole è abilitato un ulteriore pulsante: (J) Gest.matricole
Se è stato abilitato il caricamento degli articoli/matricole (dettagli) da file è presente un ulteriore pulsante:
(Q) Lett.matricole da file

Gestione lotti (tracciabilità)

Gestione Raee

Quantità
Non può mai essere lasciata a 0. Viene accettato un numero di decimali pari a quelli specificati nella Tabella di Magazzino.
Se sono stati impostati sull'articolo i pezzi per confezione (con valore maggiore di uno), invece della quantità si possono digitare i colli e la quantità verrà impostata automaticamente (colli moltiplicato per pezzi per confezione), viceversa se si digita la quantità, non verranno ricalcolati i colli.

Se l'articolo ha uno sconto quantità e la quantità viene variata, si chiede se ricalcolare gli sconti.

Colli
Se il valore dei pezzi per confezione dell'articolo è maggiore di 1, si digita il numero dei colli e il campo quantità è vuoto, viene calcolata la quantità come pezzi per confezione * colli.
Viceversa se si inserisce la quantità e il campo colli è vuoto, questi ultimi vengono impostati automaticamente arrotondando per eccesso.
Per ottenere in automatico il calcolo dei colli sul quadro di accompagnamento, occorre inserire in ogni riga il numero dei colli, anche in articoli 'normali'.
Di default il numero dei colli è intero, è possibile impostare il parametro di personalizzazione ColliDec per gestirlo con decimali.

Pezzi per Confezione
Viene visualizzato il valore letto dall'articolo (non modificabile)

Promozione
Solo visualizzato. Indica se è stato impostato per quell'articolo un prezzo promozione.

Prezzo Unitario
Prezzo unitario della riga. Viene proposto il prezzo dell'articolo letto dal listino (se impostato in testata), valido alla data di inserimento del documento.

Nella causale di magazzino collegata al Tipo documento è possibile tuttavia, definire che il prezzo venga prelevato dal costo ultimo o dal medio di carico.

E' possibile infine impostare il prezzo unitario dell'articolo sulle tabelle degli sconti, in questo caso verrà prelevato solo se il documento è in Lire o in Euro.

Se per l'articolo non viene trovato nessun prezzo, nei modi suddetti, ed è stato attivato il parametro di personalizzazione CercaListBase, il programma cerca il prezzo sul listino Base (quello indicato nella tabella di Magazzino, parametri comuni).
Sul campo prezzo possono essere premuti alcuni tasti con il seguente risultato:

  • F2: rilegge dagli archivi il prezzo unitario e ricalcola gli sconti
  • F3: visualizza una lista dei listini validi dell'articolo in oggetto.
  • F7: questo tasto è da utilizzare quando un valore digitato manualmente non è compatibile con il listino e cioè: se si sta utilizzando un listino NON ivato e si ha la necessità di digitare un prezzo ivato, lo si può poi scorporare premendo il tasto F7. Allo stesso modo se utilizzo un listino ivato e, per un articolo, digito un prezzo non ivato, con F7 il programma calcolerà l'iva sul prezzo digitato.

Alla lettura del prezzo di listino da archivio il programma se trova che listino e flag di testata sono 'uguali' cioè indicano entrambi ivato o non ivato, presenta il prezzo così com'è letto mentre se sono diversi provvede a ivare o a fare lo scorporo a seconda dello stato del listino e del flag di testata.

Se è attivato il parametro di personalizzazione MostraCostoUltimo uguale a S, è possibile premere il tasto F4 per visualizzare il costo ultimo dell'articolo.

Se il prezzo viene dal listino promozione si visualizza solo lo sconto cliente.
In questo caso, anche se si fa il ricalcolo sconti, lo sconto listino viene ignorato in quanto, ricercando il prezzo, vede che viene da promozione .

Se si varia il prezzo gli sconti non vengono variati. Per provocare il ricalcolo degli sconti occorre o premere F2 sul prezzo o premere ricalcolo sconti dal campo sconto totale.

Sconto
E' lo sconto totale a cui è soggetto l'articolo. In presenza di gestione di taglia/colore gli sconti verranno considerati uguali per tutti i livelli di uno stesso articolo. Lo sconto viene dato nella forma x+y+z e a fianco viene calcolato lo sconto risultante.
A fianco dello sconto totale viene visualizzato un pulsante [..] (F2) per il ricalcolo degli sconti.
Il ricalcolo degli sconti può provocare la variazione del prezzo se lo si trova in una tabella sconti e la moneta del documento è lire o euro.
Se sulla riga c'è un prezzo promozione e si fa il ricalcolo degli sconti, viene reimpostato solo lo sconto cliente.

Per ulteriori informazioni vedere modalità di ricerca sconti

Di seguito vengono elencati i vari sconti abilitati sull'articolo in modo da poter capire come è stato calcolato lo sconto finale:

Sconto del Cliente
Viene proposto lo sconto confermato in testata come sconto cliente.
Sconto Articolo
E' il risultato della combinazione tra sconto listino e sconto messo sull'anagrafica articolo.
Sconto Tabellare
E' lo sconto derivato dalle Tabelle di sconto
Sconto Quantità
Viene cercato sulla tabella degli sconti quantità, in base all'articolo e al cliente, e, se valorizzato può sostituire lo sconto tabellare e/o lo sconto cliente.

Indicatore di riga soggetta a sconto pagamento.
Viene valorizzato in automatico sempre a Si e può essere variato. Lo sconto pagamento è sulla testata del documento e viene applicato a piede fattura.

Unità di misura
Viene visualizzata l'unità di misura delle vendite dall'articolo

Fattore di conversione
Viene proposto il valore scritto sull'articolo e relativo all'unità di misura di vendita. Può essere variato se si varia l'unità di misura. Serve per calcolare la quantità che andrà ad aggiornare i progressivi di scarico dell'articolo. Se l'unità di misura dell'articolo coincide con quella di vendita, il fattore di conversione dovrà essere uguale ad 1 (non può mai essere posto a 0).

Codice Iva
E' il codice iva vendite dell'articolo. Se però in testata viene impostato un codice iva (esenzione) cui il cliente è soggetto, questo verrà impostato automaticamente su tutti i dettagli senza possibilità di variazione.

Importo di riga
E' l'importo calcolato moltiplicando il prezzo scontato per la quantità della riga. Se si varia o imposta direttamente questo importo e il prezzo unitario è vuoto, quest'ultimo verrà ricalcolato automaticamente, viceversa occorre premere il tasto F7 per ricalcolarlo.

Omaggio
Consente di definire se la riga contiene o no articoli ceduti a titolo gratuito. E' previsto che la gestione dell'omaggio possa essere:

  • omaggio totale: la riga non verrà addebitata in assoluto
  • solo Iva: al cliente verrà addebitata solo l'imposta relativa a questa riga e non l'imponibile

Conto ricavi
E' il conto di ricavo che servirà in fattura per lo scarico contabile dell'importo relativo alla riga.
Viene proposto il conto impostato sull'articolo. Se nell'articolo manca o se articolo manuale verrà proposto quello della tabella conti comuni (da compilarsi tra i parametri ditta).
Se anche in tabella non c'è nessun conto, il problema sorge nel momento della contabilizzazione della fattura, sarà la stampa a chiedere che sia compilata la tabella 'causali e conti comuni'.

Centro di costo
Se sul conto ricavi dell'articolo c'è un codice centro di costo, esso verrà portato automaticamente in questo campo, inoltre se sul conto ricavi dell'articolo c'è il flag di centro di costo obbligatorio, non si può salvare la riga senza mettere un codice centro di costo. La contabilizzazione della fattura dovrà creare movimenti diversi in corrispondenza a righe con conti uguali ma con centri di costo diversi.

% provvigione 1 e 2
Sono le percentuali di provvigione relative ai due agenti impostati sulla testata.
Se le provvigioni sono per articolo: la seconda % è vuota

Date di competenza
Tramite questo pulsante si consente di inserire sulla riga le date di competenza (per la gestione dei ratei e risconti). Verrà proposta la periodicità giornaliera o mensile a seconda di quanto scritto sul conto di ricavo e si consentirà di inserire la data inizio e fine competenza.


FATTURE DETT - DESCRIZIONE LUNGA ARTICOLO E NOTE DI DETTAGLIO

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Se l'articolo ha una descrizione aggiuntiva, inserita con la gestione articoli, questa può essere stampata o meno sul documento o copiata sulla nota del dettaglio (sopra o sotto) a seconda di come è stato impostato sul tipo documento, il parametro corrispondente.

In questo quadro si consente di variare 'il se e come stampare la descrizione lunga dell'articolo' e di inserire o variare le note 'sopra' e 'sotto' il dettaglio. Anche per ciascuna di queste due note si può decidere se stamparla o meno sulla fattura.
E' possibile impostare un valore di default sul campo, tramite i parametri di personalizzazione: DoveStampoSopra e DoveStampoSotto
Nella preparazione del file XML se indicato di mettere sopra al dettaglio la descrizione lunga verrà messa prima della descrizione normale, se indicato di metterla sotto verrà messa dopo. Se all'inizio della descrizione lunga c'è la scritta NOXML non verrà messa nel file XML.

Se il tipo documento prevede di importare in automatico la descrizione aggiuntiva dell'articolo sulle note, queste verranno precompilate con tale descrizione. In ogni caso, sulle due note, è abilitato il tasto F7 che consente di importarla in automatico anche se non è stato previsto prima.

Per una corretta compilazione della fattura elettronica, nella maschera di inserimento della riga descrittiva, sono stati inseriti tre campi i cui valori di default possono essere impostati con i parametri di personalizzazione RigaDescInXml , RigaDescInStampa , RigaDescAltroXArt :

  • in XML
    Se impostato a Si il contenuto della riga descrittiva verrà riportato sul file XML
  • su Carta
    Viene utilizzato per impostare il valore del campo 'Su carta' presente sulla riga descrittiva del corpo fattura. Se impostato a Si il contenuto della riga descrittiva verrà stampato sulla fattura
  • Altri dati per articolo
    Se sulla riga di un articolo serve avere più di un elemento nella sezione ‘altri dati gestionali su XML’ si dovrà creare una o più righe descrittive prima della riga articolo, impostare a Si questo campo poi andare in ‘altri dati x fatt. elettronica’ con il pulsante apposito e inserire nel quadro (7) Altri dati, i dati necessari in Altri dati gestionali (esempio: identificativo scontrino)

Nella compilazione del file XML per la fattura elettronica il contenuto di questo campo verrà scaricato nel campo 'descrizione' del corpo della fattura (blocco 'DatiBeniServizi'), poichè tale campo può avere una lunghezza massima di 1000 caratteri, è stato messo un blocco nel numero dei caratteri che si possono scrivere nel campo.

Se c'è la necessità di scrivere note più lunghe dovranno essere inserite più righe descrittive

N.B. Se nella riga descrittiva si premono degli 'Invio' per andare a capo (riga nuova) , ogni invio prende 2 caratteri. Poichè la preparazione del file XML elimina i 'ritorni a capo', si consiglia di non utilizzarli.


FATTURE DETT - RIFERIMENTI DOCUMENTI DI PROVENIENZA

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

In caso di fattura riepilogativa o da ordine, vengono elencati i documenti DdT o Ordine che hanno generato questa riga.


FATTURE DETTAGLI CON LIVELLI

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Se è prevista la gestione dei livelli (Taglia-Colore) ed è stato inserito un articolo che li prevede, viene data la possibilità di inserire la quantità per ogni singolo gruppo di levelli, es. III - Rosso oppure IV Blu. Una volta inserito il codice dell'articolo non si può passare direttamente all'inserimento della quantità ma occorre premere il pulsante opportuno, vedi Gestione Livelli a Tabella, in modo da passare alla maschera di Gestione Dettaglio Livelli nella quale dovrà essere specificato per ogni 'livello' da mettere sul documento, la quantità e il prezzo unitario.
Gli sconti vengono considerati a livello di articolo per cui se si varia uno sconto su un 'dettaglio-livello' questo viene riportato su tutte le righe-livello di quell'articolo. Vedi Sconti in Dettagli con Livelli

Se si modifica il codice articolo con livelli sul dettaglio, vengono cancellate tutte le sue righe dei livelli e sarà necessario entrare nella gestione livelli per reinserirle.


FATTURE DETT - RIGA COMANDI

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

In questo punto si consente di inserire una riga di comando che verrà presa in considerazione dalla stampa Fattura, si può scegliere tra quelli proposti:

  • .TD Stampa testata dettaglio
  • .PA Cambio pagina
  • .SR Salta N righe
    Segue richiesta del numero di righe da saltare
  • .NS Non stampa il totale finale
  • .TT Stampa un totale parziale in questo punto
  • .PT Stampa un totale parziale e cambia pagina
  • .TZ Stampa un totale parziale e lo azzera
  • .PZ Stampa un totale parziale, lo azzera e cambia pagina

Per tutti i comandi che prevedono la stampa di un totale viene chiesto all'operatore di digitare la descrizione da stampare prima dell'importo.

Nota: per la stampa corretta del totale parziale, occorre inserire nel filtro una riga con sottosezione 18.
Nella descrizione scritta, in corrispondenza al comando 'Stampa un totale parziale' si può digitare qualcosa che poi potrà essere testato nel filtro (es. se si vuole stampare una riga orizzontale in una certa posizione del corpo, poi stampare il totale parziale, si potrà inserire nel corpo del documento una prima riga comando del tipo Tot. parziale, con descrizione: riga poi nel filtro si dovranno mettere le istruzioni per stampare la riga (Sottosezione 18) precedute dal test:
se$ C_RigDesArt <> "riga";vai NoRiga


FATTURA ELETTRONICA - DATI TESTATA

FATTURA ELETTRONICA - DATI DETTAGLI

Percorso: Vendite - Fatture - Fattura diretta/accompagnatoria

Al quadro, che contiene i dati che vanno a completare il documento e che sono previsti nel tracciato della fattura elettronica , si può accedere quando si è posizionati sulla maschera dei dettagli della fattura con il tasto (U)Altri Dati per Fattura Elettronica

Sono gli stessi dati già descritti anche nella maschera della testata della fattura. Mentre là riguardano l'intera fattura, qui si possono impostare per ogni riga , nel caso di fatture che comprendano beni relativi a Ordini, Contratti , .. diversi.
In questo caso su ogni riga si imposteranno i dati relativi.

Dati Ordini di Acquisto - Contratto - Convenzione - Ricezione - Fatture collegate
La valorizzazione di questi dati è necessaria al fine di consentire un collegamento con il processo di approvvigionamento e, di conseguenza, la possibile dematerializzazione del ciclo passivo; tali informazioni non sono obbligatorie ma la loro definizione nel rapporto contrattuale è fortemente consigliata.

DDT
Questi campi dovranno essere compilati, in corrispondenza ad ogni riga di fattura, solo in corrispondenza a una fattura con ddt fatti a mano, nel caso in cui la fattura si riferisce a più ddt (in caso di fattura riepilogativa, il programma provvederà a compilare direttamente sul file XML i campi di riferimento ai ddt)

Altri dati
blocco che consente di inserire, con riferimento ad una linea di dettaglio, diverse tipologie di informazioni utili ai fini amministrativi, gestionali etc
Data inizio e fine periodo:
Campi non obbligatori. Data, iniziale e finale, del periodo di riferimento cui si riferisce l'eventuale servizio prestato
Riferimento amministrazione
Campo non obbligatorio. Codice identificativo ai fini amministrativo-contabili.

Altri dati gestionali
blocco che consente di inserire, con riferimento ad una linea di dettaglio, diverse tipologie di informazioni utili ai fini amministrativi, gestionali (es. scrivere in dettaglio un articolo di esenzione)
Vedi parametro di personalizzazione RigaDescAltroXArt
Tipo dato
codice che identifica la tipologia di informazione (es. Note riga)
Al fine di riportare in fattura il riferimento ad uno scontrino o ad un documento commerciale, nei casi in cui l’operazione “fatturata” sia stata così precedentemente rendicontata, l’elemento 'TipoDato' va
valorizzato con la stringa “SCONTRINO”
Al fine di riportare il dato della targa in fattura, l’elemento TipoDato va valorizzato con la stringa “TARGA”
Riferimento testo
campo in cui inserire un valore alfanumerico riferito alla tipologia di informazione di cui al campo Tipo dato. Es. con l’identificativo alfanumerico dello scontrino oppure con la targa del veicolo
Riferimento numero
campo in cui inserire un numero riferito alla tipologia di informazione di cui al campo Tipo dato
Riferimento data
campo in cui inserire una data riferito alla tipologia di informazione di cui al campo Tipo dato
Al fine di riportare in fattura il riferimento ad uno scontrino o ad un documento commerciale, nei casi in cui l’operazione “fatturata” sia stata così precedentemente rendicontata, l’elemento
RiferimentoData va valorizzato con la data di emissione dello scontrino (o del documento commerciale)
Riportiamo una faq dell'Agenzia delle Entrate:

Quando le fatture elettroniche sono precedute dall’emissione di scontrino o ricevuta fiscale (o, nel caso di
trasmissione telematica dei corrispettivi, da un “documento commerciale”), nella fattura vanno riportati gli
estremi identificativi dello scontrino/ricevuta; in particolare, il blocco informativo “AltriDatiGestionali” va
compilato riportando:
- nel campo “TipoDato” le parole “NUMERO SCONTRINO” (oppure “NUMERO RICEVUTA” oppure
“NUMERO DOC. COMMERCIALE”);
- nel campo “RiferimentoTesto” l’identificativo alfanumerico dello scontrino (o della ricevuta o del
documento commerciale);
- nel campo “RiferimentoNumero” il numero progressivo dello scontrino (o della ricevuta o del documento
commerciale);
- nel campo “RiferimentoData” la data dello scontrino

Elenco eventuali allegati

Livelli su XML
In base a questo campo si stabilisce come esplicitare sul file XML della fattura elettronica, le righe di articoli con livelli.
Se l'utente non varia il contenuto del campo impostato di default a 'Standard', il programma di preparazione del file XML si comporterà come richiesto dallo stesso parametro impostato sul singolo cliente

  • Standart
  • No articolo principale
    Verranno elencate tutte le righe dei livelli ciascuno con quantità e prezzi
  • Solo articolo principale
    Verrà riportata solo la riga dell'articolo principale con la somma delle quantità e dei prezzi delle singole righe dei livelli
  • Prezzo sui livelli
    Verrà stampata la riga articolo senza prezzo seguita dalle righe dei livelli ciascuna col suo prezzo
  • Prezzo su riga articolo
    Verrà stampata la riga articolo con il prezzo totale , seguita dalle righe dei livelli con prezzo a 0


CONTABILIZZAZIONE FATTURE

Percorso: Vendite - Fatture

La fase di contabilizzazione fatture consente di generare, a partire dalle fatture stampate, i movimenti per la contabilità e le rispettive scadenze.

Vengono 'contabilizzate' tutte le fatture con data minore o uguale a quella impostata a video dall'operatore e nel cui tipo documento è stata compilata la causale contabile.

A seconda di cosa è previsto nella tabella dei parametri di Fatturazione (Parametri e utilità - Dati generali azienda) nei campi:
Scarico movimenti fatture e Dalle fatture crea solo le scadenze, non verranno generati i movimenti ed eventualmente verranno generate le scadenze, verranno generati i movimenti su un archivio di fatture (di appoggio) o direttamente negli archivi di contabilità.

Se prevista la generazione della registrazione in Prima Nota, il programma provvederà a segnalarla come 'Black List' se ci sono le condizioni (vedi capitolo relativo).

Parametri di personalizzazione utilizzati:
CopiaOrigInDoc per decidere, nella contabilizzazione delle Note di variazione, come copiare la data/num doc. di origine.

Se si interrompe l'elaborazione durante la contabilizzazione occorre, rientrando, eseguire dal menu di servizio delle Vendite, la funzione: Ripristino da interruzione in contabilizzazione fatture.

Se si rende necessario variare una fattura già contabilizzata si può procedere in due modi diversi:

  • Caricarla e 'decontabilizzarla' premendo il pulsante: (Ripristino a non contabilizzato) dal programma di Gestione fatture
    NOTA: Non è possibile decontabilizzare una fattura le cui scadenze sono state inserite in una distinta o sono già state chiuse perchè incassate.
    In questo caso occorre:
    - cancellare l'articolo di prima nota dell'incasso o generato dalla contabilizzazione della distinta
    (il numero e la data di questa registrazione si trova andando sulla scadenza in 'Gestione scadenze' nella maschera 'Dati incasso-pagamento' oppure nella visualizzazione del partitario dell'anagrafica interessata).
    - se la scadenza è in una distinta, occorre cancellare dalla scadenza stessa il numero e la data distinta (si può fare richiamando la distinta ed eseguendo Cancellazione scadenza oppure sulla maschera 'Dati incasso-pagamento' in gestione della scadenza interessata).
    A questo punto si può procedere con la decontabilizzazione della fattura, la correzione, la stampa e la successiva contabilizzazione. Se la distinta non è ancora stata presentata si può inserire la nuova scadenza entrando in Gestione distinta e Aggiungi effetto poi si rigenera il file Riba che rinumera gli effetti, oppure la si inserirà in una nuova distinta.
  • Eseguire la funzione: Reintegro fatture a stato di non contabilizzato, dal menu di servizio delle Vendite.


STAMPA FATTURE

Percorso: Vendite - Fatture - Stampe

Questa funzione consente di stampare una o più fatture attribuendo ad esse numero e data di stampa e creando, se previsto dal tipo documento, il movimento di scarico del magazzino.
E' importante perciò fare molta attenzione alla data di stampa in quanto diventerà la data documento (data della fattura) e quella in cui verrà fatto lo scarico in magazzino degli articoli (se fattura diretta o accompagnatoria).

In particolare, se sulla fattura non è stato scritto qualcosa di specifico in creazione o in evasione, mese e anno della data di stampa verranno memorizzati sul documento come mese e anno per la competenza iva (cioè mese in cui considerare la fattura ai fini iva).

Se si intendono stampare più documenti insieme, occorre che essi abbiano lo stesso modello di stampa.

Se si imposta il 'Tipo documento Da' e si lascia vuoto il campo Tipo documento A, quest'ultimo viene posto uguale al primo.

Per ogni documento è possibile eseguire:

  • Prestampa (stampa in prova): si può fare, anche più volte, per i documenti con stato Bianco (cioè mai stampati); si esegue la stampa senza fare nessun' altra elaborazione
  • Stampa: si può fare solo per i documenti mai stampati; il documento viene stampato in modo definitivo, si prende il numero e vengono fatti gli aggiornamenti dovuti (magazzino, provvigioni).
  • Ristampa: si può fare solo se è già stata fatta la 'stampa' e può essere ripetuta a piacere.

Numero copie fatture
Indica il numero delle copie da stampare. In Dati generali azienda parametri - Tabella di Fatturazione si può impostare un numero che verrà proposto in questo campo.

Regime iva per Cassa:
Poichè le fatture emesse con questo regime devono riportare la scritta:
“Operazione effettuata in regime di IVA per cassa, ai sensi dell’art.32-bis del D.L. 83/2012”
il programma stamperà la frase se ci sono le condizioni (così come in Prima Nota nell' inserimento fattura viene impostato a Si il campo 'Iva per Cassa').
Per sopperire a casi particolari, nella maschera di stampa compare la richiesta:
'Scritta Iva per Cassa' da stampare

  • Come da elaborazione
  • Sempre
  • Mai

Se si sceglie di forzare, una volta contabilizzata la fattura/nota di Variazione, occorre andare sull'articolo di prima nota a sistemare il campo: Iva per Cassa.

Split Payment
Sulle fatture emesse alla Pubblica Amministrazione con il meccanismo dello Split P. va riportata la scritta:
'Iva da versare a cura del cessionario o committente ai sensi dell’art. 17-ter del D.P.R. n. 633/1972'
che dovrà essere impostata nel parametro di personalizzazione: SplitPayment

Ordinamento righe dettaglio:
La stampa delle righe presenti nel corpo del documento avviene secondo l'ordine con cui vengono presentate a video. E' possibile modificare l'ordine utilizzando i parametri di personalizzazione:
OrdStampaDettDef , OrdStampaDettDesc , OrdStampaDettBy

Selezione destinazione stampa
Le stampe su modulo hanno, in questa sezione, opzioni particolari rispetto quelle delle stampe normali (Stampe). Vedi Stampe su modulo
Se, come Tipo di stampa, si sceglie: File/Stampante ad aghi, ed è stato predisposto un filtro per stampante ad aghi adeguato, si può scegliere di stampare la fattura su file excell.

Stampa PDF
Se è stato installato PdfCreator (o Pdf995) (versione scaricabile dal nostro sito), è possibile stampare le fatture in formato PDF
Per ottenere la stampa su pdf occorre quindi spuntare:
Nome automatico pdf
che consente di attribuire al pdf generato un nome in automatico (come descritto nei parametri di personalizzazione) o digitato al momento
Unico file pdf per tutte le fatture
che consente di generare un'unico file contenente tutte le fatture stampate o file diversi per ogni fattura.
Quando si sceglie di stampare su pdf il numero di copie viene messo automaticamente ad 1.

Invio fattura per email
Se ci sono tutte le condizioni descritte nel paragrafo Invio fatture per email e sulla maschera di stampa è stato spuntato il campo "Nome automatico pdf", è possibile inviare via email la/le fatture stampate.
Il testo delle email generate può essere gestito tramite il pulsante "Cambia testi"
Prima dell'invio, se si utilizza SendMail, viene chiesta login e password per accedere al server SMTP di posta.

Stampa file doc. finale
Consente di stampare un documento al termine della stampa della fattura. Il nome del file da stampare va impostato nel parametro di personalizzazione StDocFine. Se è stato attivato il parametro di personalizzazione però, in qualche caso, non si vuole la stampa, si può togliere la spunta a questo campo nella maschera di stampa.
 N.B. Condizione necessaria per la stampa del documento è che sul computer sia installato WORD. Viene dato a word il comando di stampare il testo selezionato, la stampa avviene SEMPRE sulla stampante preselezionata di Word

Parametri di personalizzazione gestiti da questa funzione:

NoStampaLivelli
Se vale S in stampa fattura, anche se l'articolo ha i livelli (taglia-colore) non vengono stampate le righe dei livelli ma solo la riga principale dell'articolo con quantità e valore totale.
Ovviamente, in questa riga, il prezzo unitario non e' "affidabile" perchè viene calcolato togliendo l'eventuale sconto dall'importo totale e dividendo per il numero di pezzi e poi arrotondato al numero di decimali di gestione

DescLivNotaSot
Consente di stampare le descrizioni dei livelli nel campo Nota sotto l'articolo. Il valore del parametro dovrà contenere il/i carattere/i di separazione tra le due descrizioni (Es. spazio - spazio)

DataDoc
Se S, la data Fattura (documento), invece di venire posta uguale alla data di stampa , viene posta uguale alla data Riferimento. Se è attivo questo flag il programma ordina le fatture da stampare, sempre per Data Riferimento poi per numero o per cliente a seconda di quello che chiede l'utente.
Se il programma si trova a stampare una fattura con data riferimento minore dell'ultima fattura stampata, assegna come data documento la data dell'ultima fattura stampata (letta nella tabella dei numeratori fatture)

MessIvaSosp
Valore: Frase da scrivere alla fine del corpo fattura se la fattura è per un cliente con iva sospesa

RigaDescrTotale (S o P)
In evasione Ddt viene calcolato il totale di ogni ddt e scritto nella riga descrittiva a seguito di Ddt. Nr. xx del xx/xx/xxxx.

  • S l'importo viene scritto dopo la data del ddt
  • P l'importo viene messo nel campo ValoreEuro e calcolato in C_ValEuro (per poterlo poi stampare su una colonna a parte modificando in modo opportuno il filtro)

CampiStAggDec
per aggiungere campi di decodifica nella query di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa

CampiStAggCor
per aggiungere campi di decodifica nella query di stampa del corpo

CampiStDecDef per eliminare qualche tabella dalla query di stampa se si verifica un errore di troppi campi.
Per eliminare alcune tabelle è possibile utilizzare in alternativa: TabNo*

TabFromCor

IndAmmSep
Se è stato associato al cliente un indirizzo amministrativo questo verrà stampato in fattura al posto dell'indirizzo del cliente.
Se invece si assegna al parametro uno qualsiasi dei valori U o B o S questo verrà copiato nell'indirizzo di spedizione.
IndSpedInv
IndSpedNoStesso

Solo fattura accompagnatoria: StDescAttr e StTotAttr per stampa descrizione attributi e riepiloghi nel corpo (Es. riepilogo ADR)

Per quanto riguarda i parametri da inserire per la stampa delle matricole in ddt e fatture vedere: parametri matricole.

Per quanto riguarda i parametri da inserire per la stampa dei lotti in ddt e fatture vedere: parametri lotti

Per stampa dati della Dichiarazione di intenti del cliente: DichIntentiTesto


GESTIONE TESTI PER INVIO DOCUMENTI PER EMAIL

Percorso: Vendite - Fatture - Stampa fattura
Vendite - Ddt - Stampa Ddt
Preventivi/Ordini - Preventivi e Ordini - Stampe Preventivi e Ordini

Nella maschera delle funzioni di 'stampa documenti' (preventivi, ordini, ddt, fatture) ed etichette è presente una opzione che, se spuntata, consente l'invio per email del/dei pdf delle fatture stesse.

A fianco dell'opzione c'è un pulsante: "Cambia Testi"
Esso fa riferimento a un massimo di 5 testi che si possono richiamare, dopo averli preparati e salvati, i quali contengono l'oggetto e il testo dell' email da inviare.
I testi che gestisce e che si possono memorizzare sono diversi per ogni tipo di documento.
A video viene presentato il numero del testo selezionato nell'ultimo stampa (informazione che viene salvata sull'aziwin.ini del computer in uso)

Il programma utilizza automaticamente il primo testo presente, se l'utente vuole utilizzare un'altro testo basta entrare nella gestione con il pulsante "Cambia testi", e premere il pulsante corrispondente a un altro testo.

I testi vengono memorizzati nel database del menu (AziMenu.mdb, tabella Appoggio)

Se occasionalmente, serve un testo un pò modificato rispetto quelli memorizzati, è possibile richiamare un testo, modificarlo senza salvarlo e stampare/inviare le fatture. L' email verrà completato con il testo modificato a video.

Segue un elenco di campi del database, personalizzabili all'interno dell'oggetto e del testo dell'email (devono essere racchiusi fra due §, es. §NumDoc§ )

NumDoc | numero documento (comprensivo di eventuale prefisso se diverso dal .)
DataDoc | data documento
RiferimFat | campo "riferimento cliente" (dalla testata documento)
NoteTestata | note della testata documento
Cliente | ragione sociale del cliente
PIva | Partita iva del cliente
CodFisc | Codice fiscale del cliente
PersRif | Persona di riferimento del cliente

E' inoltre possibile inserire:

  • un qualsiasi altro campo della testata documento mettendo il nome tabella Testate (OrdAcqTes, OrdVenTest, DdtTest, PreVenTest, FatTest), un punto (.) e il nome campo
    (Ad esempio: §FatTest.Pagamento§ stampa il codice del pagamento)
  • il contenuto di un campo di un'altra tabella letta dal programma (campi di decodifica), facendo precedere il campo da D.
    (Esempio: §D.PianoConti.Indirizzo§ stampa l'indirizzo del cliente)
    Si ricorda, a tal proposito, che è’ possibile impostare il parametro di personalizzazione CampiStAggDec per aggiungere campi di decodifica nella query del programma di stampa in modo da rendere disponibili altri campi, oltre a quelli già disponibili, da stampare sulla testata o piede dei documenti, tramite i filtri di stampa.


SPLIT PAYMENT - FATTURAZIONE

La Legge di Stabilità per il 2015 ha introdotto nel D.P.R. 633/1972 l'articolo 17-ter, che disciplina il nuovo meccanismo del cosidetto "split payment"
per le operazioni effettuate nei confronti degli enti pubblici, i quali dovranno versare l'IVA relativa alle fatture ricevute dai loro fornitori, al posto del fornitore stesso.

In pratica, dall' 1 Gennaio 2015, chi emetterà fatture nei confronti della pubblica amministrazione (PA)

  • esporrà regolarmente l'iva sulla fattura ma, questa, sarà annotata solo nel registro Iva delle vendite, senza peraltro concorrere alla liquidazione Iva periodica.
  • gli enti pubblici verseranno al fornitori le somme loro spettanti al netto dell'Iva.

Saranno interessati allo split payment tutti i fornitori della pubblica amministrazione che dal 1 gennaio 2015 pur avendo emesso regolare fattura con addebito di Iva, incasseranno solo l’imponibile.
Saranno invece esclusi quei fornitori che sulle proprie prestazioni sono soggetti a ritenuta alla fonte sulle prestazioni (i professionisti) e coloro che già applicano il reverse charge (che quindi prevale sullo split payment).

Per poter poi essere in grado di ottemperare a questi obblighi, nel programma AziendaPC occorre:

Istituire un numeratore apposito per le fatture emesse con Split payment (così come per le fatture elettroniche alla Pubblica Amministrazione)
- Parametri e utilità - Dati Generali Azienda (parametri) - Parametri Comuni
aggiungere una lettera a piacere nell'elenco Prefissi vendite (sarà quella che identifica il prefisso per il registro delle vendite 'Split')
- Contabilità - Gestioni - Prefissi e numeratori documenti
creare una nuova riga per il nuovo prefisso (Registro) Split

Gestione Conti (Archivi Comuni - Anagrafiche)
creare un nuovo conto: 'IVA Split Payment' (nello stesso mastro del conto iva vendite) che verrà utilizzato in automatico dalla Prima Nota e dalla contabilizzazione fatture , nella registrazione della fattura Split Payment.

Tabella dei conti Comuni (Parametri e utilità - Dati azienda e parametri - Dati generali azienda (parametri))
compilare il campo 'conto IVA Split Payment' con il codice del conto 'IVA Split Payment' di cui sopra

Gestione causali di contabilità (Contabilità - Gestioni)
Creare una nuova causale con la quale registrare in Prima Nota le fatture verso la PA e spuntare il campo 'Iva Split Payment'.
Nel conto IVA di questa causale si può mettere il codice del conto di cui sopra, se invece non si compila il campo, il programma leggerà il conto iva dalla tabella dei conti comuni e, se manca anche lì non farà il giroconto dell'iva split sulla registrazione della fattura.

Tipi Documento per fattura/nota credito (Archivi Comuni - Tabelle vendite)
Creare nuovi Tipi documento da utilizzare per l'emissione di fatture/note in Split Payment. In essi dovrà essere inserito nel campo: 'Causale Co.Ge.', il codice della causale contabile di cui al punto precedente e dovrà essere lasciato bianco il campo 'Causale Co.Ge. esig.differita'
(La creazione del nuovo tipo documento è utile anche per la Fatturazione Elettronica al fine di utilizzare un Prefisso 'dedicato')

Gestione Clienti (Archivi Comuni - Anagrafiche)
Sull'anagrafica dei clienti per i quali si dovrà emettere fattura 'Split Payment' controllare che sia a NO (cioè che non sia spuntato) il campo 'Iva ad esigibilità differita' nel quadro (5) Fatturazione

Consigliamo inoltre di creare CODICI IVA appositi da utilizzare nelle fatture emesse verso la PA

Quanto descritto sopra va fatto in aggiunta alle istruzioni per l'attivazione delle Fatture Elettroniche verso la Pubblica Amministrazione

Sulle registrazioni delle fatture emesse con causale 'Split Payment' NON verrà mai messo il flag iva per cassa e le causali non dovranno mai essere di tipo Revese Charge

Prima Nota
La registrazione in contabilità della fattura viene evidenziata a video con una nota e genera le seguenti righe:
 | Dare | Avere
Crediti vs Pa (Cliente) | 122 |
Ricavi |  | 100
Iva c/Split payment |  | 22
Crediti vs Pa (Cliente) |  | 22
Iva c/Split payment (storno) | 22 |

Stampa registri iva
Le fatture emesse con causale Split Payment verranno evidenziate con la nota: *SPLIT e verranno totalizzati a parte imponibili e imposte relative

Chiusura Iva
Verrà evidenziato, in una riga a parte, il totale imponibile e imposta delle fatture emesse con causale 'Split'

FATTURAZIONE - Stampa fattura

Al fine di evidenziare sulla stampa di una fattura registrata con un Tipo documento/causale che prevede il meccanismo dello Split Payment, si può scegliere tra due soluzioni:

  • Creare una nota fissa con la scritta da stampare in fattura SENZA spuntare il campo: Riportate sul file XML della Fatt.Elettronica
    e associare il codice della nota creata al tipo documento
  • Creare un parametro di personalizzazione: SplitPayment Gruppo: Fatture
    Valore: ' Operazione con 'scissione dei pagamenti' DM 23/01/2015'

Se nel filtro della fattura si stampa il totale a pagare (T_TotPagare) (solo stampa fattura e non xml) , in presenza di Split Payment (Fattura agli enti pubblici) , questo verrà decrementato dell'importo dell'iva.
E' possibile impostare il parametro TotPagareSplit con un valore diverso da S (es. N) per stamparlo comprensivo di iva.


BROGLIACCIO FATTURE

Percorso: Vendite - Fatture - Stampe

Il programma consente di stampare un elenco delle fatture registrate con o senza il dettaglio degli articoli.

Per ottenere un elenco contenente una sola riga per fattura con totale merce, totale imponibile e totale iva e un totale finale, eseguire la stampa scegliendo come Tipo di stampa: sintetica su una riga e spuntando la casella Stampa totali.

Si può impostare il parametro di personalizzazione: StaCondPag = S per far si che a video, quando si sceglie la stampa sintetica su una riga, venga sempre spuntata l'opzione di stampare la condizione di pagamento della fattura al posto del totale merce e del totale spese.

Allo stesso modo si può impostare il parametro di personalizzazione: StaCodFisc = S per far si che a video, quando si sceglie la stampa sintetica su una riga, venga sempre spuntata l'opzione di stampare la P.Iva o il Cod.Fiscale del cliente al posto del totale merce e del totale spese.


STATISTICHE SUL FATTURATO

Percorso: Vendite - Fatture - Stampe

Un documento "fattura" viene considerato in questa stampa se nel suo Tipo documento (fattura o nota di credito) è stato spuntato il flag: in fatturato (Vedi Archivi comuni - Tabelle vendite - Tipi documento)

Questo programma consente di ottenere stampe diverse, dopo aver preparato, con l'aiuto del programma stesso, dei tracciati di stampa personalizzati.
I dati messi a disposizione dal programma sono quelli delle fatture. Si può quindi impostare una stampa di fatturato per cliente, per cliente/prodotto etc.
E' possibile creare due tipi di stampe: Sintetica e Dettagliata
Nella Sintetica il programma somma, per ogni riga delle fatture da stampare, i campi che vengono selezionati in "Personalizza la stampa", e riporta una riga riepilogativa per cliente, per agente, per moneta a seconda dei Gruppi scelti.

Esempio: di costruzione di una stampa Sintetica che riporti su ogni riga Codice e Ragione sociale cliente e totale fatturato.
In Gruppi mettere Codice cliente , non mettere nessun campo in rottura e nei campi da stampare scegliere Ragione Sociale come primo campo, poi a seguire, gli altri. Se non si mette la ragione sociale ad inizio riga, cioè un campo lungo, la stampa avverrebbe su due righe.

Con la scelta Dettagliata è possibile utilizzare il pulsante a video 'Seleziona movimenti di carico' per stampare tutte e sole le fatture di vendita relative agli articoli presenti nei movimenti di carico merce registrati in un certo intervallo di tempo per un determinato fornitore.

Vedi stampe parametriche


STAMPA MARGINI

Percorso: Vendite - Fatture - Stampe

Il programma consente di rilevare il margine ottenuto dalle fatture di vendita ordinate per Articolo/Cliente, Cliente/Articolo, Cliente.

Il costo della merce può essere riferita a: ultimo costo, medio di carico, medio ponderale.

La stampa riporta, per ogni articolo presente in fattura: il ricavo (importo di riga), il costo, il margine (ricavo-costo) e la percentuale di margine lordo calcolata: (ricavo-costo)/ricavo * 100 (percentuale è la % di guadagno realizzato sul prezzo di vendita)

E' possibile, spuntando la scelta 'St.quantità e val.unitario' , ottenere, per ogni riga, anche la stampa aggiuntiva di quantità, val.unitario, costo unitario e sconto. In questo caso la stampa verrà fatta in orizzontale piuttosto che in verticale.
Per impostare a Si, di default, la suddetta scelta nella maschera iniziale si può creare il parametro di personalizzazione: StMargOrizz con valore S.

Nota: Se si sceglie l'ordinamento per Cliente, la selezione degli articoli serve unicamente a estrarre SOLO le fatture che contengono quegli articoli ma l'importo stampato, per ogni fattura è il totale merce e non l'importo relativo agli articoli selezionati.


RIPRISTINO DA INTERRUZIONE IN ELAB. FATTURE

Percorso: Vendite - Servizio - Ripristini da interruzioni

La funzione consente di portare a termine l'elaborazione dopo una interruzione anomala di una operazione che coinvolge una o più fatture (inserimento, stampa, evasione ddt in fattura).

E' indispensabile eseguirla per ottenere un corretto aggiornamento dei progressivi.

Se il programma si blocca in fase di evasione ddt in fattura nel momento in cui ha evaso il ddt ma non ha ancora chiuso la fattura, il ripristino completa la chiusura della fattura che però potrebbe non contenere Tutte le righe di dettaglio del ddt. In questo caso, se controllando la fattura, questa non risulta completa, occorre cancellarla per riaprire il ddt ed evaderla di nuovo.


RIPRISTINO DA INTERRUZIONE IN CONTAB. FATTURE

Percorso: Vendite - Servizio - Ripristini da interruzione

La funzione consente di portare a termine l'elaborazione dopo una interruzione anomala della funzione di Contabilizzazione fatture.

E' indispensabile eseguirla per ottenere la creazione corretta dei movimenti e scadenze e un corretto aggiornamento dei progressivi contabili.


RIPRISTINO FATTURE A 'NON STAMPATO'

Percorso: Vendite - Servizio - Reintegro fatture a stato di non stampato

Consente di riportare una Fattura già stampata, allo stato di non stampata per poterla variare.

Viene cancellato il movimento di magazzino che la stampa ha creato e tolto, dalla testata della Fattura, lo stato di stampato. Inoltre se periodo e anno iva sono uguali a mese e anno della data fattura, vengono sbiancati anch'essi.


RIPRISTINO FATTURE A NON CONTABILIZZATE

Percorso: Vendite - Servizio - Utilità

Il programma cancella i movimenti e le scadenze create in fase di contabilizzazione delle fatture selezionate e cambia ad esse lo stato.

Se almeno una scadenza di una fattura da decontabilizzare è già chiusa, non si consente di 'decontabilizzarla'; occorrerà prima togliere lo stato di 'chiuso' alla scadenza (sbiancando con la Gestione scadenze, i 'dati incasso/pagamento') oppure cancellarla.


PULIZIA ARCHIVIO FATTURE

Il programma consente di cancellare le Fatture dopo aver impostato opportune selezioni.
E' possibile scegliere se cancellare indipendentemente dallo stato del documento o Solo quelle contabilizzate o Solo quelle con Provvigioni elaborate o Solo quelle Contabilizzate e con Provvigioni elaborate.

Questa cancellazione, elimina fisicamente le fatture ma lascia inalterati i movimenti di magazzino e contabilità che esse hanno generato.

Se il programma trova delle fatture in cui manca la testata, cioè i dati del cliente, (situazione anomala) chiede se si vogliono stampare oppure se proseguire cancellandole.


FATTURA ELETTRONICA

Percorso: Vendite - Fattura Elettronica

Vedi anche Fatture elettroniche ricevute

Dal 6 giugno 2014 Ministeri, Agenzie Fiscali ed Enti Nazionali di Previdenza non potranno più accettare fatture emesse o trasmesse in forma cartacea né potranno procedere al pagamento, nemmeno parziale, di documenti non trasmessi in forma elettronica. Dal 31 marzo 2015 la disposizione si estenderà ai restanti enti nazionali.
Inoltre il DDL Stabilità per il 2015 introduce per le fatture emesse verso la Pubblica Amministrazione dal 1 gennaio 2015, lo Split Payment che prevede il pagamento dell'iva direttamente all'erario da parte della PA.

Dal 1 gennaio 2019 l'obbligo dell'emissione in formato elettronico viene esteso a tutte le fatture (escluso regimi particolari).
La fattura elettronica è intesa come un documento informatico non contenente codice eseguibile né macroistruzioni, ed in cui l’attestazione della data, l'autenticità dell'origine e l’integrità del contenuto sono garantite mediante l'apposizione del riferimento temporale e della firma elettronica qualificata dell'emittente.

Dal 1 ottobre 2020 in modalità facoltativa e dal 1 gennaio 2021 in modalità obbligatorio è stato cambiato il tracciato della fattura elettronica ed alcuni codici; si rimanda alle note della release 4.05 per le varie novità

Per supportare le Aziende nella gestione di questa importante scadenza, proponiamo un nuovo modulo, collegato ad aziendapc, che prevede un insieme di funzioni per la gestione delle fatture elettroniche attive e passive. Per le fatture attive è prevista la generazione dei files xml, il servizio di invio all'SDI e Conservazione Sostitutiva a norma di Legge

Il modulo in oggetto dovrà essere acquistato per ogni soggetto emittente fattura
Per attivarlo occorre richiedere una nuova chiave di attivazione che va inserita in Licenza concessa A, dopo aver scritto: XMZ nel campo Moduli aggiuntivi.

Verrà generato un file della fattura elettronica per ogni documento e spedito direttamente all'HUB Zucchetti
Alla preparazione del file della fattura elettronica si può arrivare dall'icona [image] (FattElettronica) posizionata nella maschera di testata della funzione di Gestione fatture Dirette/Riepilogative oppure dall'apposita funzione a menu: Stampa Fattura Elettronica

E' possibile allegare al file XML il pdf della stampa della fattura.
Si precisa che con l’introduzione della fattura elettronica la fattura cartacea/PDF non ha più nessun valore fiscale.
A tal proposito consigliamo di inserire una nota sul documento cartaceo ad indicare che si tratta di copia conforme, cioè di creare una nota fissa (Archivi comuni-tabelle vendite- note fisse) con il testo che concorderete con il Vs. commercialista (Es. Il presente documento è una copia conforme all'originale). Importante: in questa nota fissa NON va spuntato il campo 'Riportare su file XML fatt.elettronica'
Al fine di ottenere la nota fissa in automatico sulla fattura occorre collegarla al tipo documento (Archivi comuni-Tabelle Vendite-Tipi documento)

Fatture elettroniche ad aziende e a privati (B2B/B2C)

Il processo B2B/B2C è differente rispetto a quello PA, in particolare nelle Ricevute e Notifiche.
Il destinatario della fattura elettronica non potrà più, via SDI, Accettare o Rifiutare la fattura. Pertanto, scompaiono le ricevute di Accettazione, Rifiuto e Decorsi Termini e i rispettivi flussi di notifica.
Inoltre, nel caso di impossibilità da parte del SdI di veicolare la fattura elettronica al destinatario, al trasmittente sarà inoltrata l’Attestazione di avvenuta trasmissione della fattura con impossibilità di recapito.

N.B. < Solo per le fatture verso la Pubblica Amministrazione è obbligatorio creare un nuovo protocollo (Prefisso) per la numerazione ed eventualmente uno, per le note di credito PA:
- Parametri e utilità - Dati Generali Azienda (parametri) - Parametri Comuni
aggiungere una lettera a piacere nell'elenco Prefissi vendite (sarà quella che identifica il prefisso per il registro delle vendite 'Split')
- Contabilità - Gestioni - Prefissi e numeratori documenti
creare una nuova riga per il nuovo prefisso (Registro) Split
Archivi comuni - tabelle vendite - tipi documento
Creare un Tipo documento Fattura PA associato a tale protocollo (duplicando quello utilizzato per le fatture 'normali') e associare ad essa una nuova causale di contabilità con le caratteristiche per lo Split Payment >

Si raccomanda di leggere quanto riportato di seguito circa i campi da impostare per una corretta compilazione

Operazioni preliminari per la fatturazione elettronica

Dopo aver eseguito l'installazione/aggiornamento dei programmi alla versione 4_03, per accedere all'HUB Zucchetti occorre:

  • copiare, dall'area di installazione, la cartella DLLNet sul computer locale (si consiglia di copiarla nella cartella AziWin\DLL)
  • registrare le DLL tramite il file Registra.bat (che si trova nella cartella suddetta)
    (aprire una finestra dos come amministratore, posizionarsi nella cartella dllnet ed eseguire il .bat)
  • posizionarsi sulla cartella DLL\AggOcx ed eseguire MSXML6.msi per sistemi a 32 bit o msxml6_x64.msi per sistemi a 64 bit
  • Se la password per l'accesso all'HUB Zucchetti è uguale per tutte le aziende:
    inserire le Credenziali: LOGIN e PASSWORD, per accesso comune con la funzione: Vendite - Fatture: Utilità Fatture Elettroniche - Dati Accesso all'HUB
    Viceversa se l'accesso è diversificato per azienda questi dati vanno inseriti nella tabella di fatturazione di ogni singola ditta
    Tali dati verranno forniti al momento dell'acquisto delle fatture

  • Per stampare la fattura su PDF per allegarla al file XML
    Installare Pdf Creator dal sito www.aziendapc.it e non aggiornarlo mai.
    Creare una cartella nella quale scaricare i pdf delle fatture (se in multiutenza si consiglia di crearla all'interno della cartella Aziwin al fine di renderla disponibile a tutti i terminali)
    - inserire manualmente nel file AziWin.ini comune (es eventualmente nell'aziwin.ini della cartella main del Server) nella sezione [Base] la riga: DirPdf=XXXX Dove XXXX indica la cartella in cui memorizzare i file derivati dalle stampe documenti in pdf
    - da Stampa Fatture entrare i Selezione destinazione stampa - pulsante: Par Ini Pdf Email poi pulsante: Deseleziona tutto
    Spuntare a sinistra in alto i due campi a sinistra di Usa PdfCreator e scegliere Salva sull'ini di questo terminale o sull'Ini generale
    Questa operazione crea nell'aziwin.ini le righe:
    [StampaPdf]
    UsaPdfCreator=S

  • Creare due cartelle diverse (si consiglia dentro la cartella Aziwin, es: \aziwin\FattureAttive e \aziwin\FatturePassive) nelle quali verranno messi i file XML delle fatture emesse e di quelle ricevute, scaricate dall'HUB Zucchetti con le apposite funzioni a menu.
    Scrivere nella sezione [Base] dell'AziWin.ini comune o del terminale due righe:
    DirFe =X:\aziwin\FattureAttive
    DirFeScar =X:\aziwin\FatturePassive
    DirFatPas=X:\aziwin\PdfPassive
    dove X è il disco che contiene le cartelle. Se manca questo parametro il programma utilizzerà la cartella indicata nel parametro DirCarica
    Per quanto riguarda la personalizzazione del nome da assegnare ai file pdf generati vedere Pdf Fatture Attive e Pdf Fatture Passive

    N.B. Se vengono emesse fatture elettroniche da più aziende in linea:
    E' consigliato differenziare, all'interno delle directory scritte sopra, oltre a quella che conterrà le stampe in pdf, le cartelle nelle quali verranno salvate le fatture delle varie aziende .
    Occorre creare, per ogni azienda, più parametri di personalizzazione con Gruppo: DirPerAzie
    Parametri: DirPdf , DirFe , DirFeScar , DirFatPas oppure il Parametro: Tutte (in alternativa ai precedenti) e mettere nel campo Valore il nome della directory dove scaricare. Per differenziare questo nome per le varie aziende è possibile mettere nel campo 'Valore':
    §IdAzienda§ che verrà sostituito con l'identificativo dell'azienda
    §CodiceAzie§ che verrà sostituito col codice azienda
    Esempio: Gruppo: DirPerAzie Parametro:Tutte Valore: §CodiceAzie§
    Prima di inserire questi parametri occorre creare nella cartella C:\Aziwin\FatturePassive una cartella con il codice dell’azienda gestita reperibile da : Parametri Utilità -> Gestione Database Aziende. Quindi se l’azienda ha codice AZ01 dovrete creare una cartella AZ01.
    Attenzione, il paragrafo precedente è da considerare come esempio, nella vs. installazione non è detto che il disco usato sia C: e che la cartella 'fatture passive' si chiami FatturePassive, potrebbe avere un altro nome.
    Dovrete creare le cartelle delle ditte nella cartella usata per memorizzare le fatture passive.

Elenco dati da impostare per una corretta compilazione del file XML della fattura elettronica:

La valorizzazione di questi dati è indispensabile ai fini di un corretto recapito del documento elettronico.

I dati anagrafici e gli altri campi necessari alla compilazione dei dati di testata delle fatture elettroniche devono essere compilati con la funzione: Dati generali azienda (Parametri e utilità - Dati azienda e parametri) nelle seguenti sezioni:

  • Anagrafica Ditta: oltre ai dati anagrafici ditta, in particolare: indirizzo legale (Cap - Località - Prov., Stato e Comune Legale), Registro imprese (Sigla Provincia), Nr. Iscrizione Registro Imprese
  • Fatturazione: Prima di procedere con questo punto leggere Operazioni preliminari al punto 4 (dati accesso all'Hub)
    Progressivo invio HUB (campo necessario per la compilazione del corrispondente campo da riportare all'interno del file XML): per compilare questo campo è necessario entrare nella funzione 'Informazioni fattura elettronica' (menu Vendite - Fatture) e premere il pulsante 'Salva progressivo invio'.
    Accesso Hub: Login e Password: vanno inserite quelle fornite al momento dell'acquisto del pacchetto delle fatture se devono essere diversificate per ogni singola azienda
  • Fatt.Elettr.: in particolare il Regime Fiscale del Cedente/Prestatore del bene o servizio; il campo: Causale pag. 770 (quella del Mod CU), nel caso di emissione fatture con Ritenuta d'Acconto; i dati dell'eventuale Rappresentante Fiscale (solo nei casi in cui il cedente / prestatore si avvalga di un rappresentante fiscale in Italia)
    Inoltre, Tipo soggetto emittente:
    Distinguiamo due casi:
    1) Se si acquistano i pacchetti che hanno tutto incluso, NON serve la firma e il programma scriverà nel file XML della Fattura che il terzo emittente è Zucchetti (Selezionare Terzo Emittente). Non compilare i campi sottostanti.
    2) Se si acquista il pacchetto a funzioni separate NON c’è Terzo emittente (Selezionare Diretto) e si possono verificare due casi diversi:
    - l’azienda NON emette fatture PA e non c’è l’esigenza che le fatture viaggino firmate, in questo caso non serve la firma, le fatture pertanto vengono spedite, non firmate, allo SDI e firmate da Zucchetti al momento di mandarle in conservazione
    - l’azienda EMETTE fatture PA o, per questione di sicurezza si vuole che le fatture viaggino verso lo SDI firmate in modo da garantirsi che non vengano modificate, occorre acquistare una propria firma da tenere sull’HUB Zucchetti.
    (In questo caso le fatture devono essere caricate in uno stato : Da Firmare o da Validare e , successivamente, bisogna dare il comando di cambio stato, manualmente dal programma di Gestione, selezionando ad esempio: Firma e Conferma
    Non compilare i campi sottostanti
  • Cee Xbrl: i campi 'capitale sociale' , 'Ditta con socio unico' , 'Ditta in liquidazione'

Monete
Compilare sulla tabella monete (Tabelle di Contabilità), il codice ISO (Per l'Euro è EUR)

Causali
Per un corretto caricamento e contabilizzazione delle fatture fatture ricevute, spuntare, almeno in una causale di tipo 'Fattura ricevuta' e in una di tipo 'Nota di credito ricevuta il campo 'Prioritaria'

Codici Iva
Compilare il campo 'Natura per Fattura Elettronica', obbligatorio, in corrispondenza di codici iva con Tipo iva diversi da Normale e Non detraibile Deve essere compilato con i codici indicati nel pulsante di aiuto, ad indicare se si tratta di Escluso ex art.15, Esente, Non imponibile etc.
Inoltre, per gli stessi codici è obbligatorio compilare, il campo: Note da scrivere in fattura con il Riferimento Normativo cioè la descrizione per esteso dell'articolo di esenzione.
Inoltre si può compilare il campo necessario per scaricare, sul file XML delle fatture, informazioni aggiuntive secondo il tracciato Standard Assosoftware, al fine di rendere più leggibili le fatture elettroniche da parte di chi le riceve: Codifica AssoSoftware Esenzione

Tipo Documento
Compilare il campo 'Tipo documento per fattura elettronica' sui tipi documento fattura / nota credito da inviare.
Deve essere compilato con i codici indicati nel pulsante di aiuto (Fattura, Acconto/Anticipo su fattura,Acconto/Anticipo su parcella,Nota di Credito, Nota di Debito, Parcella). La causale contabile associata al tipo documento dovrà necessariamente avere la caratteristica dello Split Payment
Inoltre si possono compilare i campi necessari per scaricare sul file XML delle fatture informazioni aggiuntive secondo il tracciato Standard Assosotfware, al fine di rendere più leggibili le fatture da parte di chi le riceve: Codifica AssoSoftware Tipo Documento, Caratteristica Documento, Trattamento Fiscale

Clienti
Compilare, in Gestione Clienti, tutti i dati anagrafici tenendo presente che sul file XML della fattura verrà scaricato il Comune al posto della Località. E' possibile attivare il parametro di personalizzazione LocalComune per fare in modo che il programma di preparazione del file XML scarichi la Località se trova il campo 'Comune' dell'anagrafica non compilato.

Se si compila il campo 'provincia' con EE oppure 99:
- il campo Comune non verrà controllato e si potrà compilare a piacere (Per SEDE clienti esteri in fattura elettronica).
- in preparazione del file XML della fattura elettronica il cap verrà modificato in modo da renderlo accettabile, cioè verrà reso di lunghezza 5 e verranno tolte le eventuali lettere.

N.B. Se il cliente ha un codice fiscale che inizia per 8 o 9 , questo NON va mai messo nel campo Partita Iva ma nel campo Codice Fiscale

Nella maschera '5-Fatturazione', compilare il campo 'Codice destinatario (IPA)', con il 'codice' dell'ufficio/cliente che deve ricevere la fattura
(tale codice verrà riportato sulla testata della fattura).
Per le fatture alla Pubblica Amministrazione tale campo è obbligatorio.
Allegare PDF nel file XML
Consente di specificare se, per questo cliente, si vuole allegare la stampa della fattura in formato pdf, al file XML della fattura elettronica.

Se è compilato il campo 'Note per fatture' nella maschera 6 dell'anagrafica clienti, esso verrà riportato come riga descrittiva nel corpo, sul file XML della fattura elettronica. Per variare questa impostazione vedere il parametro: NoteClie

Se un cliente appartiene ad un gruppo di aziende che ai soli fini iva viene visto come un unico soggetto passivo (legge 2006/112/CE) occorre mettere nella Partita Iva quella principale (cioè quella che viene utilizzata ai fini iva) e nel codice fiscale la partita Iva della singola azienda.
Se si hanno rapporti con più aziende del gruppo occorre creare un cliente per ogni singola azienda differenziandoli per codice fiscale (NB il programma segnalerà Partita Iva doppia)

Fattura elettronica tra privati
Il Codice Destinatario, composto da 7 caratteri alfanumerici, è attribuito dal Sistema di Interscambio ai soggetti che hanno in essere un canale di ricezione accreditato e che, per conto del cessionario/committente provvedono a ricevere la fattura elettronica dal SdI e a smistarla al destinatario finale.
Qualora il destinatario non abbia accreditato un canale presso Sdi e riceva le fatture via PEC , si dovrà compilare il Codice Destinatario con sette 0 (0000000) e , nella maschera '9-Email' , compilare l'indirizzo email per la Pec (di default l'indirizzo amministrativo, per sceglierne un altro vedi Parametro EmailPEC)
Di default se l'indirizzo pec è vuoto, non verrà scaricato nulla (vedi parametro di personalizzazione: PecNoAltreEmail
Si consiglia di impostare, con la funzione 'Variazione automatica clienti/fornitori' il campo FECodIpa a 0000000 in tutti i clienti dove è vuoto.
E' possibile attivare il parametro di personalizzazione CodDestZero per fare in modo che il programma imposti in automatico gli zeri nel campo destinatario anche se nel cliente è stato lasciato bianco.
Nel caso che il cliente al quale si emette fattura elettronica sia straniero, il campo andrà impostato con XXXXXXX

I campi 'Codice Eori' e 'Titolo (titolo onorifico)' , presenti nella stessa maschera della Gestione Clienti, sono invece facoltativi.
Se sul cliente sono compilati i campi Nome e Cognome, verranno riportati questi sul file Xml al posto della Ragione Sociale. Per evitare questo, si può scrivere NO nel campo Titolo (maschera (1)Anagrafica).

Le fatture elettroniche emesse nei confronti dei consumatori finali sono rese disponibili a questi ultimi dall’Agenzia delle Entrate nel cassetto fiscale del consumatore.

Se il cliente privato è un non residente e con stabile organizzazione in Italia dovrà essere impostato un indirizzo di spedizione collegato al cliente con codice indirizzo fisso: FPO
Nell'indirizzo creato dovranno essere compilati i dati in questo modo:
Se ditta va compilata solo la Ragione Sociale,
se persona fisica: Cognome in Ragione Sociale , Nome in Ragione Sociale2
Poi compilare Indirizzo con numero civico, Cap , Comune, provincia, Stato

Se il cliente privato è straniero e si avvale di rappresentante fiscale in Italia dovrà essere impostato un indirizzo di spedizione collegato al cliente con codice indirizzo fisso: FPR
Nell'indirizzo creato dovranno essere compilati i dati in questo modo:
Se ditta va compilata solo la Ragione Sociale,
se persona fisica: Cognome in Ragione Sociale , Nome in Ragione Sociale2
Codice stato
Note: compilare con Identificativo Fiscale (la Partita Iva/Cod.Fisc)

Spese:
Si può compilare il campo necessario per scaricare, sul file XML delle fatture, informazioni aggiuntive secondo il tracciato Standard Assosoftware, al fine di rendere più leggibili le fatture da parte di chi le riceve: Codifica AssoSoftware Tipo Spesa

Al fine di compilare, sul file xml, i campi relativi al Pagamento:

Banche
Se si prevede di emettere fattura con codice di pagamento Bonifico, si dovrà creare, nella tabella Banche, un codice banca con tutti i dati della banca su cui va fatto il pagamento: ABI CAB CIN e Conto corrente in modo da derivarne l'IBAN da riportare sul file xml della fattura.
Nel caso di modalità di pagamento che coinvolge l'Ufficio Postale (es. 'domiciliazione postale') occorre creare un codice banca nel quale compilare unicamente il campo Ufficio Postale.

Tali codici banca dovranno essere indicati sulle relative condizioni di pagamento BONIFICO e domiciliazione postale e verranno riportate, con possibilità di variazione, in testata fattura come banca della ditta che emette la fattura.

Tipi pagamento
Compilare il campo 'Modalità pagamento per fattura elettronica' sulla tabella Tipi pagamento (Tabelle di Contabilità), per ogni tipologia di pagamento che verrà utilizzata nell'emissione della fattura elettronica in base ai valori elencati nella tabella di decodifica.
In particolare con le modalità:

  • MP05 - Bonifico e MP17 Domiciliazione bancaria verrà portata sulla testata della fattura (maschera altri Dati, campo Banca per Bonifici) il codice della banca che dovrà essere inserita obbligatoriamente in ogni condizione di pagamento collegata a un Tipo pagamento con tali modalità. Nella preparazione del file XML della fattura verrà preso ABI e CAB e IBAN da tale banca
  • MP09 -RID , MP10 RID utenze , MP11 RID veloce , MP12 RIBA
    Nella preparazione del file XML della fattura verrà preso ABI e CAB della banca del cliente scritta in testata fattura

Inoltre si può compilare il campo necessario per scaricare, sul file XML delle fatture, informazioni aggiuntive secondo il tracciato Standard Assosoftware: Codifica AssoSoftware Tipo Pagamento

Inoltre compilare il campo: 'Codifica Assosoftware' al fine di poter stampare, sulle fatture ricevute, l'esatta descrizione del pagamento secondo la tabella prevista da Assosoftware (dati scritti in tabella Decodifiche dell'AziMenu.mdb)

Condizioni di Pagamento
 Per ottenere lo scarico, sul file XML della fattura, della sezione <DatiPagamento> che riporta la modalità di pagamento, è indispensabile impostare il campo 'Num.scadenze' con un valore diverso da -1 (valore per il quale non vengono generate le scadenze).

 In corrispondenza alle condizioni di pagamento Bonifico (dove nel tipo pagamento è stato compilato con MP05 il campo 'Modalità pagamento per fatt. elettronica) è indispensabile compilare il codice banca con la banca della ditta che ha emesso la fattura,
Da questa banca verranno estratti C/Corrente, ABI , CAB, CIN per ottenere l'IBAN dove effettuare il Bonifico e scritti sul file XML della fattura.

Analogamente, sulla modalità di pagamento che coinvolge l'Ufficio Postale MP17 (es. 'domiciliazione postale'), si deve impostare il codice della banca su cui è stato compilata la 'Descrizione Ufficio Postale'.

Tale banca, se impostata, verrà visualizzata in testata fattura con possibilità di variazione (maschera altri Dati, campo Banca per Bonifici)

Per quanto riguarda invece le condizioni di pagamento con modalità pagamento: MP09 -RID , MP10 RID utenze , MP11 RID veloce , MP12 RIBA, nella preparazione del file XML della fattura verrà preso ABI e CAB della banca del cliente scritta in testata fattura

Note fisse
Di default tutte le note fisse che verranno richiamate in fattura, verranno scritte nel campo 'Descrizione causale' del file XML (Nota: non vengono però copiate sul campo corrispondente della fattura, dati di testata per fattura elettronica) Vedi parametro di personalizzazione NoteFisse
Per escludere una nota fissa, impostare a N il campo corrispondente in Gestione Note fisse

Contratti
Al fine di compilare alcuni campi sulla fattura, se questa viene fatta a seguito di un Contratto o Ordine di Acquisto o Convenzione o Dati Ricezione, si può creare un codice Contratto in cui inserire i dati CIG, CUP, numero e data Contratto o Ordine di Acquisto o Convenzione o Dati Ricezione, etc.

Testata e dettagli fatture
Sconto pagamento: potrà essere calcolato a piede fattura oppure sulle singole righe. Di default è calcolato a piede fattura
A tal proposito è stato inserito un campo in testata 'Sconto pag.su dettaglio' dove si potrà impostare l'uno o l'altro modo. Si può impostare un valore fisso in questo campo tramite il parametro di personalizzazione: ScontoPagInDet

Le fatture preparate per l'invio telematico dovranno eventualmente essere completate, prima dell'invio, con campi 'particolari'.
Testata fattura:
Nella maschera (1) Cliente, la 'modalità di pagamento' da compilare nel caso venga digitato un importo in Acconto
Nella maschera (2) Altri dati, i campi interessati sono:
Codice IPA (codice destinatario, identificativo del cliente o ufficio pubblica amministrazione) obbligatorio, se questo non è stato impostato sul cliente
Se il cliente non ha un codice particolare impostare a 0000000
Codice banca della ditta per bonifici, se non è già stata impostata sulla condizione di pagamento
L' eventuale Abbuono inserito nella testata della fattura, verrà scaricato nella sezione 'DatiGeneraliDocumento' del file XML come 'Sconto Maggiorazione'
Acconto: se al momento della fattura viene dato un acconto, occorre compilare il campo Acconto della maschera dati cliente e la rispettiva modalità di pagamento (campo a fianco all'acconto). In questo modo sul file xml della fattura verrà evidenziato che è stato dato un acconto, ad esempio in Contanti, e verranno generate le scadenze per la differenza tra l'importo della fattura e l'acconto.
Viceversa se è stata emessa precedentemente una fattura di acconto, occorre inserire nel corpo fattura una riga 'articolo' con quantità 1, importo (imponibile fatturato) negativo e codice iva utilizzato nella precedente fattura. In questo modo il totale a pagare, verrà calcolato correttamente
Scadenze: al fine di scrivere sulla fattura elettronica le scadenze corrette, eventualmente diverse da quelle generate in automatico in base alla condizione di pagamento, si possono impostare direttamente in testata fattura nella maschera accessibile dal pulsante: Quadro scadenze [image] (Z) Gestione scadenzario

Il contenuto dei campi Note di Testata presenti in testata fattura e eventuali Note Documento (Fattura) lette dal cliente verranno inserite, di default nel file XML, come righe descrittive del corpo fattura. Per variare questa impostazione occorre inserire rispettivamente i parametri di personalizzazione NoteFat e NoteClie (Gruppo: XML)

Se su una fattura, nel campo Note Testata si scrive: NOXML , NON verrà riportata nessuna riga descrittiva e nessuna nota a meno che non siano stati messi i parametri di personalizzazione per mettere le note nel campo causale
Con il tasto (K)Altri Dati per Fattura Elettronica [image] si può accedere al quadro, che contiene i dati che vanno a completare il documento e che sono previsti nel tracciato della fattura elettronica.Nel campo 'Causale' del file xml verrà riportata la nota che dice se la fattura è Split Payment (parametro: SplitPayment) mentre la Nota che dice se una fattura è emessa in regime di iva per cassa viene riportata come riga descrittiva nel corpo fattura.

Dettagli Fattura:
Sia per quanto riguarda le righe descrittive sia la nota sopra delle righe articolo, il numero massimo di caratteri che si possono inserire è 1000 per cui è indispensabile creare più righe descrittive se si devono fare delle descrizioni molto lunghe
Nelle righe Articolo, maschera (4) Altro è possibile gestire il campo Tipo Cessione/Prestazione che indica se quella riga è 'Normale' , 'Sconto', 'Premio', 'Abbuono', 'Spesa accessoria'
Se la riga è già è stata impostata come omaggio, indipendentemente da cosa si scrive qui, il programma metterà sulla fattura elettronica: Premio

Tipo articolo
Indica la tipologia di codice articolo (per esempio, TARIC, CPV, EAN, SSC, ...). Di default viene scaricato 'Codice'
Il tipo articolo può essere sempre fisso per quell'articolo oppure occasionale
Per far scaricare il Tipo Articolo e il codice articolo desiderato (diverso da quello in archivio) , occorre mettere la sequenza nella Nota Sopra : Tipo (per esempio: TARIC, CPV, EAN, SSC) seguita da |-> (Pipe Meno Maggiore) seguito dal codice da indicare come articolo comunicato dall'Agenzia delle Entrate (es.attivazione) . Ad esempio, per le fatture della CARTADELDOCENTE, nel codice articolo va messo il codice del buono ( insegnanti ) .
Se si vuole aggiungere una descrizione ad uso interno, dopo la sequenza descritta sopra mettere <-| (minore meno pipe) seguito dal commento desiderato.

Nel caso in cui questa sequenza sia sempre fissa per un determinato articolo si può inserire nella Tabella Lingue (Archivi Comuni - Tabelle contabilità ) una lingua fissa con codice FPA e mettere nella Gestione articoli, maschera 7 DesLingue, una riga con tale codice lingua e in descrizione la frase con la stessa logica descritta sopra

La tabella lingue con la lingua dal codice FPA può essere utilizzata anche per inserire sul file xml un codice articolo che contiene un carattere asci > 126 . Tale codice non passerebbe al controllo della validazione
Nella descrizione in tabella articolo/lingua si scriverà la sequenza: AswArtFor|-> seguito dal codice articolo scritto con caratteri accettati dal sistema.

L'alternativa è quella di creare il parametro di personalizzazione: NoOltre126 che fa si che il programma trasformi i caratteri particolari in _ (underline)

Nel caso in cui sia stato previsto di mettere la descrizione lunga sopra o sotto il dettaglio, questa verrà estratta nella descrizione rispettivamente prima o dopo di quella normale dell'articolo a meno che la descrizione lunga non inizi con NOXML

Nel caso si imposti il valore totale di una riga il prezzo unitario che viene calcolato arrotondandolo a 2 decimali potrebbe essere tale che moltiplicato per la quantità dia un importo totale che differisce di un centesimo rispetto quello inserito ed in tal caso il programma di controllo dell'Agenzia delle Entrate genererebbe errore su questa riga (es. importo totale 80,00 quantità 7 , importo unitario calcolato 11,43).
Per superare questo problema mettere a 3 il 'numero di decimali di gestione' per la moneta Euro, nell'anagrafica delle monete ed inserire la riga della fattura in modo che l'importo unitario venga calcolato con più decimali. Successivamente il numero di decimali in 'monete' può essere riportato a 2.
Inoltre nelle maschere della testata fattura e in quella dei dettagli, sono presenti due pulsanti: che consentono rispettivamente di accedere ad altri dati che vanno a completare il documento e che sono previsti nel tracciato della Fattura Elettronica.

Note sulla compilazione di campi particolari del file xml

TipoRitenuta (al punto 2.1.1.5.1 del tracciato) nei dati della Ritenuta Fiscale
Viene impostata il valore Ritenuta persone fisiche o persone giuridiche a seconda di come è stato impostato il campo 'Stato giuridico' sui dati anagrafici ditta.

Le eventuali Spese presenti vengono scaricate come righe di dettaglio con Tipo prestazione: AC: spesa accessoria. Per quelle definite 'con iva ripartita', viene creata una riga di dettaglio per ogni aliquota. In tale riga la descrizione sarà la somma delle descrizioni delle spese ripartite presenti e l'importo quello ripartito relativo all'aliquota.

Pagamenti
Se non c'è la condizione di pagamento o il numero scadenze della condizione utilizzata, è negativo, non verrà compilata la sezione.
CondizioniPagamento (al punto 2.4.1 del tracciato)
Campo che indica se il pagamento è a Rate, Completo, Anticipo
Il programma lo compila in automatico con questo criterio:

  • se si tratta di Fattura di Acconto/Anticipo (dal Tipo documento) mette Anticipo
  • se sulla Condizione di pagamento della fattura il campo Numero scadenze è vuoto o impostato a 1 la scadenza sarà definita come 'Pagamento Completo'
  • se sulla testata fattura c'è indicato un importo di Acconto/Anticipo, o sulla Condizione di pagamento della fattura il campo Numero scadenze è maggiore di 1, mette 'A Rate'

Se nota di variazione il programma cerca se sono compilati i quadri di Testata o Dettaglio relativi a 'Fatture Collegate' , se non li trova scrive sul file il numero e la data della fattura di riferimento scritta in testata fattura

Sul file xml della fattura elettronica, la frase con gli estremi dell'eventuale dichiarazione di intenti del cliente, verrà riportata come riga descrittiva alla fine del corpo.

In tutte le stringhe il programma toglie tab e ritorni a capo prima di scaricarle sul file XML

Parametri di personalizzazione utilizzati:

ScontoPagInPiede
Se impostato deve contenere l'elenco dei tipi documento, separati da virgola (,), per i quali, lo sconto pagamento continuerà ad essere calcolato sull'imponibile/i alla fine della fattura piuttosto che venire sommato agli sconti delle singole righe come è INDISPENSABILE per le fatture elettroniche.

ScontoPagInDet (Gruppo: Fatture) attivo fino al 31/12/2019
Se impostato deve contenere l'elenco dei tipi documento, separati da virgola (,), per i quali, lo sconto pagamento, va sommato agli sconti delle singole righe, piuttosto che essere calcolato sull'imponibile/i alla fine della fattura.
Durante l'inserimento di una fattura il campo 'Sconto pag.su dett' della testata, verrà impostato a Si se il tipo documento è nell'elenco.
Per le fatture elettroniche E' OBBLIGATORIO che lo sconto pagamento sia applicato sulle singole righe.

Il programma di preparazione del file XML estrarrà il totale documento (campo opzionale) e lo scriverà nella sezione 'Dati generali documento'
Per non estrarlo occorre impostare il Parametro:
EstraiTotDoc (Gruppo: XML) con valore diverso da S

Il contenuto dei campi Note Cliente, Note Fisse e Note di testata fattura vengono inserite, di default, come righe descrittive del corpo fattura.
Al fine di variare questa impostazione, si possono impostare i seguenti parametri di personalizzazione che possono assumere i valori:
0 – Non va da nessuna parte
1 – Copia nel campo Causale
2 – Mette in una riga descrittiva (Valore di default)
Parametro: NoteClie (Gruppo: XML)
Indica dove inserire, sul file XML della fattura, l'eventuale contenuto del campo 'Note per fatture' presente sulla maschera 6 dell'anagrafica clientiParametro: NoteFisse (Gruppo: XML)
Indica dove inserire, sul file XML della fattura, le eventuali Note Fisse presenti in fattura se non hanno il campo: 'NON riportare su Fattura Elettronica' impostato a No
Parametro: NoteFat
Indica dove inserire, sul file XML della fattura, le eventuali Note di testata inserite in fattura

Parametro: AllegPdf
Valori accettati: Se vale S (Default N) preimposta a Si il campo che indica di 'Allegare il file Pdf automatico se disponibile'

Parametro: NoStampaLivelli
Si può personalizzare cosa riportare sull'XML della fattura a fronte di articoli con livelli (Taglia/Colore)

Parametro: CodDestZero (Gruppo: XML)
Impostare a S perchè il programma di preparazione dell'XML imposti in automatico gli zeri nel campo destinatario anche se nel cliente è stato lasciato bianco.

Parametro: LocalComune (Gruppo: XML)
Se vale S se il campo Comune è vuoto nella fattura elettronica mette la località

Parametro: CassaPrevNoImpon (Gruppo: Tutti)
L'importo della Cassa previdenza viene aggiunto all'imponibile della fattura.
Per prevedere l' ENASARCO e tutte le altre casse che non prevedono un aumento dell'imponibile ma solo una diminuzione occorre creare il parametro di personalizzazione impostato a S per non sommare l'importo all'imponibile ma sottrarlo dall'importo a pagare

Parametro: IndAmmSede (Gruppo: XML)
Se vale S e in testata fattura c'è l'indirizzo amministrativo mette i dati relativi nei campi della SEDE del Cessionario

Parametro: AssoInfoDoc (Gruppo: XML)
Se vale S mette sul file XML una riga fittizia descrittiva con i dati aggiuntivi come da specifiche AssoSoftware (Versione del software,etc)
E' necessario impostare questo parametro nel caso il cliente richieda queste informazioni aggiuntive, in tal caso si consiglia di compilare sulle varie tabelle i campi Assosoftware.

Parametro: PecNoAltreEmail (Gruppo: XML)
Impostare con valore N se si desidera che, se l'indirizzo PEC del cliente è vuoto, utilizzi il primo indirizzo email che trova tra i primi 2 presenti sulla maschera da scaricare sul file XML come indirizzo PEC (di default il programma se PEC vuota non scaricherebbe nulla)

Parametro: NoOltre126 (Gruppo: FatEl)
Se impostato con valore S il programma di preparazione del file XML della fattura, trasformerà gli eventuali caratteri particolari del codice articolo (con codice asci > 126 e non accettati dal controllo dell'XML) in _ (underline)

Parametro: DdtDocNoXml (Gruppo: XML)
Utilizzato in Evasione DDt. Deve contenere l’elenco, separato da virgola, dei tipi documento DDT che non si vuole vengano scaricati nei campi Numero e data ddt sulla fattura elettronica (Es. per Ddt emessi come ricevute Fiscali caricati da Gesoff)

Per lotti: parametro: LottiCompilaCod (Gruppo: XML)
Stringa per compilare il codice lotto che verrà scaricato in 'altri dati gestionali' sul file xml, al seguito della riga articolo cui si riferisce.
Se non è impostato il parametro, il programma compila il campo con Codice fornitore/Codice Lotto/Nr.Progressivo/Descrizione Lotto
I campi disponibili per la compilazione del campo valore sono:
§Forn§ Codice fornitore
§Lotto§ Codice Lotto
§NrProg§ Numero Progressivo Lotto
§Descr§ Descrizione Lotto
§DescForn§ Ragione sociale fornitore
§ArtCod§ Codice Articolo
§ArtDesc§ Descrizione articolo
§DataScad§ Data scadenza
§Categ§ Cod.Categoria del lotto
§Tratt§ Cod.Trattamento del lotto
§Conf§ Cod. Confezione del lotto
§Specie§ Cod. Specie del Lotto

Esempio: §Lotto§-§ArtCod§-§Categ§-§Tratt§-§Conf§-§Specie§

FUNZIONI DI UTILITA'

Dal menu: Vendite - Fatture

  • Dati Accesso HUB
    Se la password per l'accesso all'HUB Zucchetti è uguale per tutte le aziende, con questa funzione dovranno essere fornite login e password forniti al momento dell'acquisto
  • Informazioni fatture Elettroniche
    Per conoscere il numero delle fatture elettroniche acquistate (in entrata e in uscita) e quante ne sono state utilizzate.

FUNZIONI PER L'INVIO DELLA FATTURA ELETTRONICA

  1. Creazione Fatture Elettronica
    Una volta compilate le fatture, sia diretta sia riepilogative (con evasione dei ddt), si dovranno preparare i file XML per l'invio automatico all'Hub Zucchetti.
    La preparazione può avvenire per una singola fattura utilizzando il pulsante [image] (FattElettronica) oppure con l'apposita funzione a menu: Creazione Fattura Elettronica.
    Il programma di preparazione esegue un primo controllo del file XML ma, almeno per i primi tempi, si raccomanda di non modificare il campo: 'Stato iniziale di caricamento sull'Hub' impostato come 'Da Validare' in modo da far fare un ulteriore controllo prima dell'invio.
    Una volta eseguita questa funzione occorre eseguire il programma: Hub lista fatture attive.

    Il programma scrive un file di log giornaliero con l'elenco fatture inviate e rispettivo esito
  2. Hub Lista Fatture Attive
    Durante l'invio all'Hub, il programma scrive un file di log con l'elenco fatture inviate e rispettivo esito

    Se le fatture sono state caricate come Da Validare, dovrà essere utilizzata questa funzione per Validarle poi inviarle allo SDI
    Selezionare la/le fatture che si intende Validare (controllare) poi , in fondo al video, vicino all'etichetta 'Tipi cambio stato': scegliere Validazione e premere il pulsante: Cambio stato
    Se la validazione segnala degli errori, occorre correggere la fattura con la Gestione Fatture e ripetere la sequenza dal punto 1)

    Viceversa, se la/le fatture superano i controlli della validazione si dovrà procedere in modo diverso a seconda della modalità di acquisto delle fatture elettroniche:
    A     - acquisto delle fatture tramite il portale www.ZucchettiStore.it (Caso più comune)
    selezionare i documenti validati, vicino all'etichetta 'Tipi cambio stato': scegliere Conferma poi premere il pulsante Cambio stato
    A questo punto la fattura viene firmata automaticamente (Firma Zucchetti) e l’invio è concluso.
    Nel Digital HUB Zucchetti la fattura è nello stato “da consegnare” e successivamente occorrerà verificare che lo stato sia “consegnato”, il che ci permette di capire che il processo di invio fattura è terminato positivamente.

    B     - acquisto delle fatture tramite ordine standard Zucchetti

    1) non è stata acquistata da Zucchetti una firma personale:
     controllare che nel digital HUB Zucchetti , Menù impostazioni accessibile in alto a sinistra nella sezione dati Azienda
    • paragrafo Abilitazioni,
    • non sia spuntato il check “Firma B2B”
    A questo punto, dopo la validazione non si dovrà scegliere le opzioni con la Firma ma sarà necessario selezionare l’opzione “Conferma” e cliccare su cambio stato

    2) Se invece avete acquistato da Zucchetti una firma personale sarà necessario effettuare la firma scegliendo il comando “Firma” oppure “Firma e Conferma” nel caso in cui si voglia effettuare l’invio contemporaneamente alla firma

    A questo punto la fattura si considera spedita

N.B. Le stesse funzioni riportate sopra si possono effettuare direttamente dal Digital Hub Zucchetti.
Una volta entrati nel DHZ , dopo aver scelto Fatturazione Elettronica Attiva, cliccare sulla cartella Verso Privati e selezionare una o più fatture.
Successivamente cliccando sul simbolo della Chiave Inglese (è a dx del rigo della fattura) si aprirà un menù dove sono presenti le opzioni:
Da Validare
Da Confermare
Che andranno eseguiti nell’ordine.

La funzione Da Firmare non si deve usare se l’emissione dovesse essere delegata a Zucchetti in qualità di terzo soggetto emittente (perché appositamente delegato), quindi lo stato successivo alla validazione sarebbe “Da confermare”.

Come controllare se una fattura è stata spedita al Digital HUB.

Per fare questo controllo, oltre ai programmi di lista fatture, è possibile andare in gestione fatture emesse (dirette e accompagnatorie), richiamare la fattura e cliccare nella barra degli strumenti sul tasto [image] (Altri dati per fattura elettronica), verrà presentata una videata con varie etichette. Cliccate su (7) Altri Dati. Se la fattura è stata inviata, in basso saranno riportati i parametri di invio.

FUNZIONI PER LA RICEZIONE DELLE FATTURA ELETTRONICHE PASSIVE

  1. Hub Lista Fatture Passive
    Consente di visualizzare e scaricare l'elenco delle fatture fornitori che arrivano sull'HUB
    Per fare in modo che i file xml scaricati vengano immediatamente caricati nella tabella d'appoggio per poi poter essere stampati occorre spuntare il campo Importa Xml scaricati
  2. Stampa Fatture Passive
    Consente la Stampa in un formato 'interno' delle fatture passive che sono state scaricate in precedenza tramite la funzione al punto 1 e caricate nella tabella d'appoggio al fine di effettuare la registrazione in prima nota
  3. Contabilizzazione Fatture Passive
    Consente la registrazione in contabilità delle fatture passive caricate sulla tabella di appoggio tramite la funzione di cui al punto 1 oppure tramite la funzione di Caricamento XML fatture descritta in seguito

    Sono inoltre disponibili altre due funzioni di supporto alla elaborazione dei file XML delle fatture passive:
  • Caricamento XML Fatture Passive
    Questa funzione, già integrata nel programma Hub Lista Fatture Passive quando si scarica lasciando spuntato il campo che indica 'Importa Xml scaricati' , consente di caricare su una tabella di appoggio i file XML delle fatture passive in casi particolari quali , ad esempio:
    - fatture non arrivate sull' Hub in modo da caricarle con la data di ricezione corretta (quando si caricano sull'Hub viene messa come data ricezione la data di caricamento , che non è corretta per la contabilizzazione)
    - xml di fatture d'acquisto arrivati e conservati in altri ambienti ma con necessità di essere caricati in Prima Nota con il programma AziendaPc
  • Gestione Fatture Passive (in fase di sviluppo)


HUB:FUNZIONE DI APPOGGIO PER FATTURA ELETTRONICA

Note generali:

Identificativo fattura è l' Identificativo del documento
AZIPC+Piva+Anno(AA)+Pref+Numdoc(5cifre allineato con 0) dove AZIPC è fisso

Campo che viene mandato all’HUB col descrittore che descrive la fattura caricata.
Dove:

  • Anno è ottenuto dall'anno della data fattura a cui viene applicata una routine per aumentare gli anni disponibili (in pratica non c'è una corrispondenza tra l'anno reale e la cifra scritta) può essere lungo 1 o 2 caratteri
  • Prefisso fattura + numero fattura:
    - se c'è il prefisso e il numero è inferiore a 1000 verrà scritto di 3 cifre allineato con 0 a sinistra, se invece è superiore a 999 verrà scritto per intero
    - se non c'è il prefisso ed è inferiore a 10000 verrà scritto di 4 cifre allineato con 0 a sinistra
    In ogni caso, se si superano le 4 cifre, poichè la lunghezza della variabile deve essere di 10 caratteri, il numero scritto sarà comunque quello esatto e, nella creazione del campo: Id vengono scartati eventualmente i caratteri iniziali della stringa creata

Parametri:
Gruppo: FatEl
Parametro: ColSfondoSel
Valore: &H0080FFFF
Significato: Valore di sfondo per la riga selezionata. Se non si mette prende lo sfondo standard

Parametro: UtenteCheScarica
Valore: Pippo
Id di chi scarica fatture passive: T=nome terminale, L=Login(default), G=Gruppo, oppure nome completo da indicare

Funzione non visibile a menu


FATTURA ELETTRONICA - PREPARAZIONE FILE XML

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione, che verrà abilitata SOLO se l'utente è in possesso di Login e PassWord per accedere all'HUB Zucchetti, consente di generare il file XML della fattura Elettronica.
Il file generato verrà inviato direttamente all'HUB Zucchetti

Alla PREPARAZIONE DEL FILE si può arrivare anche dall'icona [image] (FattElettronica) posizionata nella maschera di testata della funzione di Gestione fatture Dirette/Riepilogative

  • Stampa/Invio
    Se la fattura non è ancora stata stampata il programma provvederà, oltre a preparare e inviare il file xml per l'invio, anche ad aggiornare il magazzino se previsto, come per la normale stampa della fattura.
  • Ristampa

Stato iniziale al caricamento dell' HUB (Importante)
Indica lo 'stato' con il quale verrà caricata la fattura sull'HUB. Si può impostare il parametro di personalizzazione HubStatoIniz per dare un valore iniziale a questo campo.
Si consiglia di lasciare impostato il valore impostato di default: Da Validare in modo da poter poi procedere con un passaggio successivo al controllo della fattura e al successivo invio con la funzione Hub Lista Fatture Attive

Alla conferma dell'invio verrà dato un messaggio di file inviato poi il programma resta in attesa di risposta dall'HUB di una corretta ricezione. Se si cerca di uscire dal programma prima di aver ricevuto risposta verrà dato un messaggio di avvertimento. E' necessario attendere il messaggio finale di ritorno dall'HUB in modo da avere l'esito dell'invio.

N.B. Se la preparazione del file si conclude col messaggio di errore: 'Campi obbligatori mancanti' , l' XML non viene inviato all' HUB.

Lo stato di invio della fattura elettronica potrà essere consultato dalla Gestione fatture, richiamando la fattura stessa e cliccando sul pulsante:
(K)Altri Dati per Fattura Elettronica, quadro (7) Altri dati

Eventuali allegati:
Questa richiesta verrà visualizzata SOLO se si entra nel programma di preparazione del file XML dal programma di fattura (cioè se si elabora una fattura per volta) in quanto consente di allegare dei documenti in formato word, jpg etc. al file XML della fattura che si sta preparando.

Allegare PDF nel file XML
Se spuntato verrà allegata, al file xml della fattura, la stampa della fattura stessa in formato pdf. Tuttavia, se sul cliente è stato dichiarato che NON si deve mai allegare il pdf, esso non verrà comunque allegato. o se è stata fatta una preparazione precedente
Si precisa che con l’introduzione della fattura elettronica la fattura cartacea/PDF non ha più nessun valore fiscale.
A tal proposito consigliamo di inserire una nota sul documento cartaceo ad indicare che si tratta di copia conforme, cioè di creare una nota fissa (Archivi comuni-tabelle vendite- note fisse) con il testo che concorderete con il Vs. commercialista (Es. Il presente documento è una copia conforme all'originale). In questa nota fissa NON va spuntato il campo 'Riportare su file XML fatt.elettronica'
Al fine di ottenere la nota fissa in automatico sulla fattura occorre collegarla al tipo documento (Archivi comuni-Tabelle Vendite-Tipi documento)

Il fatto che, per una determinata fattura, sia stato generato il file XML con allegato il pdf , viene memorizzato tra i dati di testata della fattura elettronica per cui una volta fatta la prima estrazione con quella determinata condizione (allego / non allego), le successive verranno fatte con lo stesso criterio. Per variare occorre variare il campo sui dati di testata della fattura elettronica.
Se si sceglie di allegare il file pdf, questo dovrà essere stato generato con una precedente stampa. La ricerca del pdf verrà fatta con lo stesso criterio utilizzato dal programma di stampa che lo ha generato. Si può creare in parametro di personalizzazione AllegPdf per impostare a Si questo campo

Fatture Cointestate
Per le fatture con cointestatari vengono create tante righe <Causale> che contengono per ogni cointestatario, escluso il principale, il codice fiscale o la partita iva – la prima parte della ragione sociale o, se non compilata, la ragione sociale (descrizione) – la percentuale se nell’elenco dei cointestatari almeno uno ha il valore percentuale diverso da 0
Aggiunto parametro per disabilitarlo:
Gruppo: XML
Parametro: CointestCausale
Valore: Se contiene un valore diverso da S (che è il default) nel file xml non mette in automatico i cointestatari nel campo causale

Log Fatture estratte
Il programma tiene traccia delle fatture estratte creando un file di log: LogXML_aaaa_mm_gg.txt
dove aaaa_mm_gg è la data del giorno dell'estrazione.
Tale file viene messo di default nella cartella delle fatture attive (indicate nell'Aziwin.ini dal parametro DirFe)
Contiene l'esito per ogni fattura inviata nel giorno, esempio:
Fattura anno 2019 n. rif. 5 n. doc. 6 del 16/01/2019 - Estratta correttamente
Fattura anno 2019 n. rif. 6 n. doc. 7 del 16/01/2019 - Campi mancanti: Codice Destinatario

E' possibile definire il parametro di personalizzazione: Gruppo: XML
LogEstrXml - Se vale N, nella maschera dell' Estrazione batch della fattura elettronica, verrà sbiancato il pulsante che dice di scrivere il log

Solo fatture non inviate all'Hub
Questo pulsante viene impostato sempre a Si al caricamento del programma in modo da assicurare la trasmissione delle sole fatture non ancora inviate. E' possibile impostare il parametro di personalizzazione NoInviateHub per impostarlo di default a No

Trattamento di possibili errori
A) Se si verificano errori, durante l'elaborazione e invio di una o più fatture, verrà dato un messaggio nel quale viene evidenziato il numero della fattura su cui si è verificato il problema.
Se si verifica che nella segnalazione ne viene evidenziata una che non è compresa nell'intervallo delle fatture che si stanno elaborando, vuol dire che l'invio di tale fattura era rimasto 'sospeso' in un invio precedente.
In questo caso occorre verificare con la funzione 'Hub lista fatture attive' se tale fattura è comunque stata inviata all'Hub.
Poi richiamare la fattura con il programma di Gestione Fatture, entrare nella maschera 'Altri dati per fattura elettronica' maschera (7)Altri dati

  • se è già presente sull'Hub , occorre selezionare, in basso a sinistra in 'Invio Hub Zucchetti' , l'opzione: Inviato
  • se NON è presente sull'Hub , occorre selezionare, in basso a sinistra in 'Invio Hub Zucchetti' , l'opzione: Stato iniziale e sbiancare gli altri campi Terminale invio, Stato iniziale e ID

B) Nel caso si verifichi una interruzione nell'invio all'Hub di una fattura, senza errori particolari, si può provare a terminare l'invio entrando nella funzione: Hub lista fatture attive e , senza selezionare nulla, fare un click sull'icona in basso a destra sul video: Invia

Se c'è qualcosa di sospeso, verrà inviato.

Gestione di caratteri particolari
Non è possibile scaricare sul file XML un codice articolo che contiene un carattere asci > 126
Per ovviare a questo inconveniente si può procedere come descritto in asci > 126

Parametri di personalizzazione:

Gruppo: FatEl
Parametro: OperGiaTrasf
Cosa fa il programma se la fattura è già trasferita su HUB:
R=la reimposta come 'da trasferire', L= la lascia come già trasferita, S=se stampa mette 'Reimposta', se ristampa mette 'Lascia', I=se stampa mette 'Lascia' se ristampa 'Reimposta'

Parametro: HubStatoIniz
Stato iniziale con cui caricare le fatture sull'HUB - deve essere uno degli stati iniziali previsti
Elenco degli stati possibili:

  • DF Da Firmare
  • DI Da integrare
  • DV Da Validare
  • DC Da Confermare
  • DN Da inviare a Sdl
  • IC In attesa di consegna
  • IE In Elaborazione

Parametro: NoInviateHub
(default S) Se si imposta a N , sulla maschera dell'invio non verrà spuntato il pulsante: Solo fatture non inviate all'Hub

Altri parametri di personalizzazione che riguardano la preparazione del file XML delle fatture elettroniche ma che interessano varie funzioni della procedura:

RigaDescInXml , RigaDescInStampa , RigaDescAltroXArt
consentono di assegnare dei valori di default ai campi delle righe descrittivi del corpo fattura che indicano dove riportare tali righe

Parametro: NoOltre126 (Gruppo: FatEl)
Se impostato con valore S il programma di preparazione del file XML della fattura, trasformerà gli eventuali caratteri particolari del codice articolo (con codice asci > 126 e non accettati dal controllo dell'XML) in _ (underline)

Se sulla riga di un articolo serve avere più di un elemento nella sezione ‘altri dati gestionali su XML’ si dovrà creare una o più righe descrittive prima della riga articolo, impostare a Si questo campo poi andare in ‘altri dati x fatt. elettronica’ con il pulsante apposito e inserire nel quadro (7) Altri dati, i dati necessari in Altri dati gestionali (esempio: identificativo scontrino)

Gruppo: XML

Parametro: UnireIndELoc
Se vale S o se l'ultimo carattere dell'indirizzo è uguale a quello inserito in questo parametro (ad es. _) nel file xml nell'indirizzo unisce il campo indirizzo alla località (default = "N" cioè non unire)


HUB: LISTA FATTURE ATTIVE

Percorso: Vendite - Fatture - Fattura elettronica

Con questa funzione è possibile ottenere una lista delle fatture emesse in un certo intervallo di date e/o a un determinato cliente e con lo stato indicato a video, generate dal terminale su cui si sta lavorando.
Per visualizzare tutte le fatture, indipendentemente dal terminale, sbiancare il campo 'Terminale' scritto in basso a destra sul video.
Verranno visualizzate un massimo di 100 fatture per volta.

Se le fatture sono state caricate come Da Validare, dovrà essere utilizzare questa funzione per Validarle poi inviarle all'SDI

  1. Selezionare la/le fatture che si intende Validare (controllare) poi , in fondo al video, vicino all'etichetta 'Tipi cambio stato': scegliere Validazione e premere il pulsante: Cambio stato
    Se la validazione segnala degli errori, occorre correggere la fattura con la Gestione Fatture e riestrarla
  2. Se la/le fatture superano i controlli della validazione si dovrà procedere in questo modo:
    selezionare i documenti validati, vicino all'etichetta 'Tipi cambio stato': scegliere Firma e Conferma poi premere il pulsante
    Cambio stato

Selezione per 'stato documenti'
elenco degli stati possibili:

  • Qualsiasi
  • DF Da Firmare
  • DI Da integrare
  • DV Da Validare
  • DC Da Confermare
  • DN Da inviare a Sdl
  • IC In attesa di consegna
  • IE In Elaborazione
  • MC Mancata consegna
  • CO Consegnato
  • RI Rifiutato
  • SC Scartato
  • NR Non recapitabile
  • RC Rifiutato e completato
  • AC Accettato
  • DT Decorsi i termini

Nella lista delle fatture vengono visualizzati i campi:
Ragione sociale e P.Iva (Cod.Fiscale) Cliente, Numero e Data fattura, Totale fattura, Tipo Documento, Stato (es. Da firmare), Data Ricezione, Att S/N (Se S=ha file collegati), C.S.=Conservazione Sostitutiva, IdDocumento

Pulsanti disponibili:

Selez.Tutto [image] e Deselez. Tutto
Servono rispettivamente per selezionare o deselezionare i documenti presenti nella lista per poi applicare un comando tra quelli resi possibili dai pulsanti:

Scarica [image] Scarica l'XML della fattura
Scarica allegati [image] Consente di scaricare un file ZIP per ogni fattura contenente la fattura stessa, la ricevuta ed eventuali allegati

La cartella in cui verranno scaricati i file, è quella indicata nel parametro DirFe che va impostato manualmente nella sezione [Base] dell'AziWin.ini (Es. DirFe =C:\aziwin\FattureAttive). Se manca questo parametro il programma utilizzerà la cartella indicata in DirCarica

Cambio stato
Consente di cambiare lo stato di una riga (fattura):

  • Da validare
  • Validato
  • Firma
  • Firma e conferma
  • Conferma

Se la fattura è caricata con stato: 'Da validare' e si sceglie di cambiare stato mettendo 'Validato' il programma fa il controllo che il file XML sia corretto rispetto il tracciato dell' Agenzia delle Entrate.

Cancella
La cancellazione è consentita SOLO per le fatture ancora non inviate

Completato
Serve per le fatture emesse verso la pubblica amministrazione che vengono respinte (scartate). In questo caso si deve selezionare la fattura e spingere questo tasto per dire che è finito l'iter, che deve andare in conservazione così com'è poi l'utente ne dovrà fare un'altra corretta.

Dati ric. SDI
Serve per importare nei dati aggiuntivi per fattura elettronica delle fatture emesse, la data e il numero di ricezione dello SDI delle righe che sono state selezionate. Questi dati possono venire usati per la stampa del registro IVA.

Invia
In teoria questo pulsante non dovrebbe servire, andrà utilizzato SOLO in casi di emergenza.

Se si carica con lo stato Firma o successivi (Firma e Conferma, Conferma) non fa nessun controllo per cui occorre che il file XML sia stato controllato prima.

Una fattura Scartata si può solo sostituire e non cancellarla

N.B. Se lo SDI non riesce a consegnare la fattura (es. Pec errata) arriverà un messaggio di 'No consegna'. In questo caso occorrerà avvisare il cliente di cercare la fattura sul suo cassetto fiscale

Log Fatture attive inviate all'HUB
Il programma tiene traccia delle fatture inviate all'HUB creando un file di log:
LogInvioHub.txt
Tale file viene messo di default nella cartella delle fatture attive (indicate nell'Aziwin.ini dal parametro DirFe)
Contiene l'esito per ogni fattura inviata, ad esempio:
Esempio:
23/01/2019 - Invio Fattura anno: 2019 n.rif: 7: Riuscito
23/01/2019 - Fattura anno: 2019 n.rif: 5 - Errore Si è verificato un errore durante l'importazione del file /opt/tomcat_a/webapps/test/WEB-INF/Tmp/takntgxnnm/dgrqiocgzi/IT05006900962_50006.xml. org.xml.sax.SAXParseException; lineNumber: 119; columnNumber: 39; È stato trovato un carattere XML non valido (Unicode: 0x1f) nel contenuto dell'elemento del documento.

Per evitare di creare questo file di log è possibile definire il parametro di personalizzazione: Gruppo: XML
FaiLogInvio con valore N (valore di default S)

Parametri di personalizzazione di questa funzione:

Parametro: ColSfondoSel
Per impostare lo sfondo della riga selezionata

Ordinamento sulle colonne della maschera:
Col pulsante DX sui titoli delle colonne, si esegue l'ordinamento sulla colonna, inoltre tenendo premuto il tasto Ctrl si possono aggiungere colonne all'ordinamento

Con Ctrl Alt si toglie o ripristina l'ordinamento

E' possibile memorizzare il tipo di ordinamento e la dimensione e posizione della maschera, posizionandosi su un campo qualsiasi e premendo i tasti: Ctrl Alt e pulsante Destro del mouse. Per le installazioni in rete la configurazione viene memorizzata sull' Aziwin.ini di ogni terminale.
Esempio di come viene memorizzato:
[Configurazioni]
FELisPasLarg=18840
FELisPasAlt=11739
FELisPasSort=5
FELisAttLarg=15502
FELisAttAlt=11739
FELisAttSort=3


FATTURE ELETTRONICHE PASSIVE

Per poter accedere alle fatture passive ricevute sull' HUB di Zucchetti è necessario impostare alcuni parametri di personalizzazione

Gruppo: FatEl
Parametro pers: UtenteCheScarica
Identificativo (ID) di chi scarica fatture passive: T=nome terminale, L=Login(default), G=Gruppo, oppure nome completo da indicare

Gruppo: Menu
Parametro: VerFattPassMenu
Elenco, valori separati dal ";" , di chi all'avvio del menù controlla l'esistenza di fatture passive.
Se inizia con T- è l'elenco dei terminali, altrimenti delle login
Per aggiungere gruppi farli precedere da G^, per abilitare ogni utente mettere Tutti
Se non si mette il parametro non verrà mai controllata l'esistenza di fatture
Parametro: VerFattPassPn
Valore: elenco degli utenti che all'avvio del programma di Prima Nota controlla l'esistenza di fatture passive e da un messaggio

Inoltre, se attivati i parametri descritti sopra, gli utenti abilitati, posizionati sul folder Vendite del menu, possono premere il pulsante Destro del mouse per vedere il numero di fatture d’acquisto in attesa

FUNZIONI PER LA RICEZIONE ed ELABORAZIONE DELLE FATTURE ELETTRONICHE PASSIVE

  1. Hub Lista Fatture Passive
    Consente di visualizzare e scaricare l'elenco delle fatture fornitori che arrivano sull'HUB
    Per fare in modo che i file xml scaricati vengano immediatamente caricati nel file d'appoggio per poi poter essere stampati occorre spuntare il campo Importa Xml scaricati
  2. Caricamento XML Fatture Passive
    Consente di caricare su una tabella di appoggio i file XML delle fatture passive in modo da poterle integrare, stampare e registrarle in automatico in contabilità
  3. Gestione Fatture Passive
  4. Stampa Fatture Passive
    Consente la Stampa in un formato 'interno' delle fatture passive che siano state scaricate in precedenza tramite la funzione al punto 1 e caricate nella tabella d'appoggio.
  5. Contabilizzazione Fatture Passive
    Consente di registrare in Prima Nota le fatture passive


Pers. parametri fattura elettronica

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione Personalizzazioni

Gruppo: FatEl
Parametro: NoOltre126
Se impostato con valore S il programma di preparazione del file XML della fattura, trasformerà gli eventuali caratteri particolari del codice articolo (con codice asci > 126 e non accettati dal controllo dell'XML) in _ (underline)

Gruppo: FatEl
Parametro: UtenteCheScarica
Identificativo (ID) di chi scarica fatture passive: T=nome terminale, L=Login(default), G=Gruppo, oppure nome completo da indicare

Gruppo: FatEl
Parametro: DatiPagamAutom
 Valore: Default S
 Se vale S contabilizzando dalla gestione fatture passive se previsto crea incasso con causale e conto standard.

Gruppo: FatEl
Parametro: FatPassDataReg
Valore: R
In questo modo la data registrazione verrà posta uguale alla Data ricezione.
Se manca la data ricezione, il programma utilizza la data della fattura.

Gruppo: FatEl
 Parametro: ScadNoData
Valore: A

Gruppo: FatEl
Parametro: CreaPagAut
Valore: A

Gruppo: FatEl
Parametro: ScadNoData
Valore: N non crea registrazioni (default)
A non crea nessuna scadenza
 D crea una scadenza con data Scadenza uguale a Data fattura
F crea una scadenza con data scadenza a Fine anno in base a data fattura
NNN dove NNN è il numero dei giorni da sommare alla data fattura per ottenere la data scadenza

Gruppo: FatEl
Parametro : CreaPagAut
 in fase di contabilizzazione automatica il programma deciderà se creare la riga di pagamento automatico.

Gruppo: FatEl
Parametro: ColSfondoSel
Valore: &H0080FFFF
Significato: Valore di sfondo per la riga selezionata. Se non si mette prende lo sfondo standard

Gruppo: FatEl
Parametro: OperGiaTrasf
Cosa fa il programma se la fattura è già trasferita su HUB:
R=la reimposta come 'da trasferire', L= la lascia come già trasferita, S=se stampa mette 'Reimposta', se ristampa mette 'Lascia', I=se stampa mette 'Lascia' se ristampa 'Reimposta'

Gruppo: FatEl
Parametro: NoOltre126
Se impostato con valore S il programma di preparazione del file XML della fattura, trasformerà gli eventuali caratteri particolari del codice articolo (con codice asci > 126 e non accettati dal controllo dell'XML) in _ (underline)


GESTIONE FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione consente di visualizzare il contenuto delle fatture passive che si trovano nella tabella di appoggio, e permette di modificare alcuni dati per semplificare la loro contabilizzazione.
E' anche possibile stampare e contabilizzare le singole fatture.

Nella pagina principale oltre al codice e alla descrizione del fornitore, al numero di fattura e alla data di ricezione viene indicato se è stata stampata e/o contabilizzata.
Vi sono inoltre 6 schede contenenti:

  1. Cedente (Fornitore) : dati fiscali, indirizzo e i contatti.
  2. Cedente (Altro) : iscrizione REA, stabile organizzazione e rappresentante fiscale.
  3. Cessionario (Cliente) : dati fiscali, indirizzo e i contatti, stabile organizzazione e rappresentante fiscale.
  4. Dati generali documento : Tipo documento, causale (se non è stata inserita in automatico durante il caricamento o se in prima nota si vuole usare una causale diversa va messa in questo campo), totale documento, cassa previdenza, ritenuta.
  5. Info trasmissione : Dati tecnici sul file ricevuto, dati intermediario o soggetto emittente.
  6. Dati trasporto.

Nella barra dei comandi sono presenti dei pulsanti aggiuntivi per effettuare le seguenti funzioni:

  • Per passare ai dettagli (che fra l'altro permetterà di modificare il conto di contropartita per ogni singola riga)
  • Per passare all'elenco dei pagamenti previsti in fattura
  • Per passare al quadro IVA
  • Per visualizzare altri dati presenti in fattura : Dati Ordine Acquisto, Dati Contratto, Dati Convenzione, Dati Ricezione, Dati Fatture Collegate, Dati DDT, Stati di Avanzamento, Dati Cassa Previdenziale, Sconto Maggiorazione, Allegati.
  • Per stampare la fattura.
  • Per annullare la stampa.
  • Per contabilizzare (può creare più registrazioni in prima nota ed esempio nel caso del reverse charge)
  • Per de-contabilizzare (verranno cancellate tutte le registrazioni in prima nota create in automatico dalla contabilizzazione)


GESTIONE FATTURE ELETTRONICHE PASSIVE

DETTAGLIO FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione mostra le righe di dettaglio delle fatture passive ricevute suddivise in 4 schede contenenti:

  1. Articolo : Codice e descrizione riportata dal fornitore; codice identificato all'interno del programma di AziendaPC; contropartite; quantità; prezzo e dati IVA.
  2. Altre Informazioni : Tipo cessione, sconto/maggiorazione ed altro.
  3. Uso interno : Riconoscimento dati Assosoftware.
  4. Altri dati gestionali : Informazioni di carattere generico inseriti dal fornitore per informazioni ad uso gestionale.

Sono riportati anche alcuni valori scelti dal programma durante la fase di caricamento e che serviranno per la contabilizzazione automatica delle fatture.
In questa maschera è possibile modificarli nel caso si vogliano usare dei valori diversi.
In particolar modo :

  • Contropartita : al momento della contabilizzazione in prima nota viene creata una riga per ogni contropartita trovata sommando gli importi relativi, modificando questi valori si può quindi indicare al programma quali righe andranno sommate fra di loro.
  • Codice IVA : si può correggere il codice in particolar modo per le esenzioni in quanto se non sono stati inseriti nella fattura i codici assosoftware, il programma non è in grado di identificarla in dettaglio.


GESTIONE FATTURE ELETTRONICHE PASSIVE

ELENCO PAGAMENTI FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione mostra le informazioni relativi ai pagamenti della fattura come indicato dal fornitore.

Oltre alla condizione di pagamento e al tipo (quest'ultima informazione è importante per le creazione dello scadenziario compilato al momento della contabilizzazione), vengono mostrate per ogni scadenza 3 schede contenenti:

  1. Scadenza : Modalità, data, importo. In base alla personalizzazione Gruppo: FatEl e Parametro : CreaPagAut in fase di contabilizzazione automatica il programma deciderà se creare la riga di pagamento automatico.
  2. Coordinate Pagamento : Banca, IBAN, e altri dati per altre modalità di pagamento.
  3. Spostamento data pagamento : Informazioni in caso di pagamenti anticipati o ritardati.


GESTIONE FATTURE ELETTRONICHE PASSIVE

QUADRO IVA FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione mostra il quadro di riepilogo dell'IVA presente in Fattura.

Vengono presentati i dati letti dal file XML : nel caso vengano modificati dei dati IVA (in particolare i codici) nelle righe di dettaglio, le modifiche vanno riportate anche in questa maschera in quanto in fase di contabilizzazione viene fatto un confronto fra questi dati.


GESTIONE FATTURE ELETTRONICHE PASSIVE

ALTRI DATI FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione riporta, se presenti, i dati letti dai seguenti paragrafi del file XML :

  • Dati Ordine Acquisto
  • Dati Contratto
  • Dati Convenzione
  • Dati Ricezione
  • Dati Fatture Collegate
  • Dati DDT
  • Stati di Avanzamento
  • Dati Cassa Previdenziale
  • Sconto Maggiorazione
  • Allegati

Se si ha la necessità di modificare qualche dato è necessario premere il pulsante "Abilita Variazione". Ripremere lo stesso pulsante per disabilitare nuovamente la variazione.

E' possibile estrarre gli eventuali allegati presenti nel file XML: dopo aver spinto sul pulsante allegati selezionare i file che si vogliono estrarre, evidenziando le righe cliccando sul quadratino grigio al suo inizio; per selezionare più righe tenere premuto il tasto CTRL mentre si preme il click del mouse. Dopo aver selezionato tutte le righe premere sul pulsante
Se il file XML non si trova nella cartella predefinita, verrà chiesto di selezionare il percorso. I file allegati verranno estratti nella stessa cartella del file XML : nel caso il file esista già viene chiesto se sovrascriverlo.


CARICAMENTO XML FATTURE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione consente di caricare su una tabella di appoggio i file XML delle fatture passive in casi particolari quali , ad esempio:

  • fatture non arrivate sull' Hub in modo da caricarle con la data di ricezione corretta (quando si caricano sull'Hub viene messa come data ricezione la data di caricamento , che non è corretta per la contabilizzazione)
  • xml di fatture d'acquisto arrivati e conservati in altri ambienti ma con necessità di essere caricati in Prima Nota con il programma AziendaPc

In generale, le fatture ricevute che si trovano sull'HUB, il cui elenco può essere consultato con la funzione: HUB: lista fatture passive, verranno caricate automaticamente su una tabella di appoggio quando si esegue, dalla funzione suddetta, lo scarico col pulsante Scarica [image] che consente di scaricare il file XML della fattura, con il campo Importa Xml scaricati spuntato, così facendo verranno inserite nella tabella d'appoggio.

Importare le fatture sulla tabella d'appoggio è importante per poter poi procedere ad integrarle, stamparle e registrarle in automatico in contabilità

L'utente può selezionare i file XML da caricare, sovrascrivere o meno fatture già esistenti, estrarre o meno gli eventuali allegati.
Non è possibile ricaricare una fattura già contabilizzata, il fatto verrà segnalato con un messaggio di errore.

N.B.
E' possibile caricare, sul Digital Hub Zucchetti, gli eventuali file XML arrivati sulla PEC o sul sito dell'Agenzia delle Entrate (proprio Cassetto Fiscale) e non presenti nella lista visualizzata dalla funzione 'Hub - Lista fatture passive'. Questa operazione consentirà di poter poi stampare, contabilizzare e soprattutto mandare in conservazione elettronica anche le suddette fatture.

Prima di procedere è necessario scaricare dal sito dell' Agenzia delle Entrate o dalla PEC anche il file metadati che andrà caricato assieme alla fattura. Il file dei metadati va rinominato mettendo lo stesso nome del file della fattura e aggiungendo _MT_001 (es. IT00000000_XXXXX_MT_001.xml)

Successivamente entrare con le proprie credenziali sul Digital Hub e cliccare sulla voce Fatture Passive.
Nella schermata che compare cliccare su NUOVO in alto a destra. Nella finestra che si apre, cliccare sul pulsante Aggiungi File e selezionare i file dei metadati e della fattura. Dopo cliccare su Start Upload e attendere il caricamento. Compilare il campo Identificativo con una sigla che dovrà identificare quella fattura in modo univoco. Infine, per terminare cliccare su Importa documento.
N.B. quando si caricano xml di fatture manualmente sull'Hub, viene messa come data ricezione la data di caricamento , che non è corretta ai fini della contabilizzazione per cui si consiglia di caricare poi manualmente, con la funzione descritta in questo capitolo, gli XML sulla tabella di appoggio mettendo la data di ricezione corretta.

Causale
Si può digitare la causale contabile da attribuire alla registrazione del documento ma non è obbligatorio farlo tranne nei casi in cui si vuole attribuire al documento una causale particolare (es. fattura reverse charge).
Se si lascia bianca il programma cercherà sulla tabella Causali una causale con il campo 'Tipo documento per FE' uguale a quello letto sul file xml della fattura. Se da questa ricerca si trova più di una causale, verrà presa la prima nella quale il campo 'Ft.ric.prior.' è spuntato.
Per cui diventa fondamentale aver spuntato sulla causale utilizzata più comunemente come Fattura di acquisto e su quella Nota di Credito ricevuta il campo 'Ft.ric.prior.'

Codice Iva / Natura
Si possono impostare fino a 3 codici iva, specificando per ognuno l'eventuale Natura diversa (N1-N2)
E' possibile digitare un codice iva e, in corrispondenza, un codice Natura (questo per il caricamento ad esempio, di una fattura emessa in Reverse Charge che conterrà la Natura N6 ma va caricata con codice iva)
Se sull'anagrafica del fornitore è impostato un codice iva, verrà utilizzato quello, altrimenti il programma cerca nella tabella dei Codici Iva, il primo con stessa aliquota e il campo 'Fatt.ric. codiva prior.' spuntato. Se non lo trova mette il codice presente in fattura

Identificativo HUB - Data Ricezione - Identificativo SDI
Questi campi, opzionali, possono essere compilati manualmente dall'operatore digitando i corrispondenti dati rilevati dal file da caricare.
In particolare la Data Ricezione è importante per determinare la data registrazione della fattura in contabilità. Va impostata la data ricezione comunicata dallo SDI (sul cassetto fiscale). Se si lascia bianca, il programma di contabilizzazione, registrerà la fattura con data registrazione uguale a data documento. N.B. La data ricezione assume una importanza fondamentale quando la fattura emessa in un determinato mese viene ricevuta dallo SDI entro il 15 del mese successivo. In questo caso la data registrazione della fattura dovrà essere quella di ricezione e nella registrazione verranno impostati i campi Mese/Anno Iva. Il campo Mese iva sarà posto uguale al mese della data fattura.

Fornitore: Gruppo - Mastro
Crea fornitore se Partita Iva non esiste in archivio
Se il fornitore non è già stato creato il programma può crearlo con codice progressivo a quelli in archivio

Per quanto riguarda il dettaglio di come viene caricata la fattura con l'intento poi di creare l'articolo di prima nota, si rimanda al capitolo Contabilizzazione fatture passive

Parametri di personalizzazione:

Gruppo XML
Parametro: ContoPrior
Valore: Default F (da fornitore) Valori validi F oppure A = articolo
Indica quale conto di costo mettere nelle righe delle fatture passive caricate dal file XML

Gruppo FatEl
Parametro: DatiPagamAutom
 Valore: Default S
 Se vale S contabilizzando dalla gestione fatture passive se previsto crea incasso con causale e conto standard.

Gruppo: FatEl
Parametro: PagAutomNoData
 Se data pagamento è vuoto indica se creare incasso automatico nella data fattura: N=No, S=Sempre, C=Solo pagamento contanti,cioè tipo pagamento MP01 (default).

Gruppo FatEl
Parametro: RigaZeroDescr
Valore: Default S
Se vale S le righe con aliquota, importo unitario, importo totale e quantità a 0 sono considerate descrittive,
se nel riepilogo iva aliquota, importo unitario, importo totale sono tutti a 0 viene ignorato per verificare reverse charge
Nella stampa se nel riepilogo iva aliquota, importo unitario, importo totale sono tutti a 0 quell'aliquota viene ignorata nella stampa riepilogo

Gruppo FatEl
Parametro: InvNotaCredNeg
Valore: Default N
Se vale S in presenza di note di credito (TD04 o TD08) se il totale documento è negativo inverte il segno agli importi sia nelle singole righe che nei riepiloghi IVA e negli importi di pagamento
Se sono presenti righe con totale importo positivo queste vengono messe con segno negativo invertendo il segno della quantità
Nella stampa fattura gli importi nelle righe di dettaglio vengono mostrate ancora con il segno originario del file XML mentre il piede con riepilogo IVA mostra già gli importi con segno modificato


STAMPA FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione consente di stampare su un modulo interno al programma delle fatture ricevute. La stampa sarà più o meno completa a seconda di quanto sono stati compilati i campi: Codici Assosoftware delle varie tabelle

Per poter stampare le fatture occorre averle precedentemente scaricate con la funzione Hub Lista Fatture Passive facendo attenzione che sia spuntato il campo 'Importa XML scaricati'

Campi di selezione:
Tipo doc. Fatt.Elettronica
E' possibile selezionare la/le fattura/e da stampare impostando uno dei tipi documento previsti dall'Agenzia delle Entrate
(es. TD01 - fattura, TD04 - Nota di credito ...). Si possono stampare ad esempio solo le note di credito selezionando il tipo TD04

Riferimento: Anno - Numero dal al
è il numero di riferimento che individua la fattura in Gestione fatture Passive

Data ricezione: Dal al

Partita Iva - Codice Fiscale
Se si desidera stampare le sole fatture di un fornitore, si può fare la ricerca del fornitore per codice (F2) , per Ragione Sociale contabile (F3) oppure si può scrivere la partita iva e premere F4 o il codice fiscale

E' possibile, spuntando il campo: Nome file automatico Pdf, stampare e salvare la fattura in formato pdf nella cartella indicata da DirFatPas nell'AziWin.ini

Per quanto riguarda la personalizzazione del nome da assegnare al file PDF delle fatture passive

  • creare due parametri di personalizzazione con Gruppo: StFatPas
    PdfNomeIni
    Inserire in Valore: eventuali caratteri che vengono messi nel nome file prima del nome assegnato
    PdfNomeFin
    Inserire in Valore: eventuali caratteri aggiunti nel nome file dopo il nome assegnato
  • In alternativa si può 'costruire' il nome del file, impostando il parametro di personalizzazione:
    PdfNomeDoc
    Il valore del parametro potrà contenere parti fisse e parti variabili. Le parti variabili dovranno essere precedute e seguite dal carattere §.
    Variabili disponibili:
Data | Data documento stampa nella forma ggmmaaaa (Es. 10012019)
DataLong | Data nella forma giorno-mese per esteso-anno (10 Gennaio 2019)
DataAbb | Data nella forma giorno-mese abbreviato-anno (10 Genn 2019)
DataRov | Data nella forma Anno-mese-giorno (Es.20190110)
DataMeno | Stesso formato di Data ma con separatori - (Es. 10-01-2019)
XMLAnno | Anno del documento
TipoDoc | Tipo documento letto dalla fattura (es. TD01-TD02)
DGD_Numero | numero documento letto sulla fattura (se c'è lo / viene sostituito da _)
Conto | Mette il codice del fornitore (GruppoMastroConto) se lo trova già creato come fornitore
RagSoc | Ragione Sociale fornitore letto dalla fattura dal campo: Anagrafica denominazione Se §ragsoc§ se invece scrivo §ragsoc,20§ prende i primi x caratteri della ragione sociale
PartIva | Partita iva letta dal file
Terminale |
Login |
Gruppo |

Esempio: §PartIva§§RagSoc,15§§Anno§
Il nome del file in questo caso sarà composto da Partita Iva fornitore seguita dai primi 15 caratteri della Ragione sociale e dall'anno

E' disponibile il parametro:

Gruppo FatEl
Parametro: RigaZeroDescr
Valore: Default S
Se vale S le righe con aliquota, importo unitario, importo totale e quantità a 0 sono considerate descrittive,
se nel riepilogo iva aliquota, importo unitario, importo totale sono tutti a 0 viene ignorato per verificare reverse charge
Nella stampa se nel riepilogo iva aliquota, importo unitario, importo totale sono tutti a 0 quell'aliquota viene ignorata nella stampa riepilogo


CONTABILIZZAZIONE FATTURE ELETTRONICHE PASSIVE

Percorso: Vendite - Fatture - Fattura Elettronica

Questa funzione consente di registrare in contabilità le fatture passive presenti nella tabella di appoggio.
Tali fatture sono state memorizzate nella tabella nel momento in cui sono state scaricate dall'Hub con il campo Importa Xml scaricati spuntato oppure caricate manualmente con la funzione: Caricamento xml fatture passive.
La registrazione risulterà più completa e corretta se saranno stati compilati:

Causali:

  • Nelle causali di acquisto: Il Tipo Documento (ad esempio TD01 nella causali delle fatture fornitori e TD04 nelle note di credito fornitori), e il flag della priorità nella causale più comunemente usata.
  • Se non presenti creare causali per le fatture di acquisto reverse charge e per le note di credito reverse charge da fornitori. Nel caso si ricevano anche fatture reverse charge miste creare le relative causali. In queste causali spuntare il flag reverse charge.

Codici Iva:

  • Nei codici IVA più comunemente usati per ogni aliquota spuntare il flag "Fatt.Ric CodIva Prior"
  • In tutti i codici con aliquota 0 (esenti,non imponibili, esclusi..) mettere la natura, impostare codice assosoftware e spuntare la priorità nel codice più utilizzato per quella natura.
  • Nei codici IVA di Reverse Charge mettere nel campo natura il valore N6.

Fornitori:

  • L'eventuale conto di contro partita da usare normalmente per quel fornitore.

Tipi pagamento:

  • Modalità pagamento per fattura elettronica
  • Codice Assosoftware

Spese:

  • Codici Assosoftware (utili sopratutto, per spese trasporto e bancarie).
  • Se non presente inserire una spesa per la cassa previdenza col conto da utilizzare per registrazione in prima nota e il flag "Spesa per cassa previdenza" spuntato.

I Codici Assosoftware sulle tabelle saranno usati se ci saranno i giusti riferimenti sul file XML caricato.

Campi di selezione:

Tipo doc. fattura elettronica
E' possibile selezionare la/le fattura/e da contabilizzare impostando uno dei tipi documento previsti dall'Agenzia delle Entrate
(es. TD01 - fattura, TD04 - Nota di credito ...).

Riferimento Anno / Numero da ... a ...
è il numero di riferimento che individua la fattura in Gestione fatture Passive

Documento Data dal ... al

Documento Numero

Data Ricezione dal ... al
la data ricezione deve diventare la data di registrazione della fattura. Se non è presente il programma utilizza come data registrazione la data della fattura.

Partita Iva / Codice Fiscale
Se si desidera stampare le sole fatture di un fornitore, si può fare la ricerca del fornitore per codice (F2) , per Ragione Sociale contabile (F3) oppure si può scrivere la partita iva (o il codice fiscale) e premere F4 o invio

Fornitore: Gruppo - Mastro
Crea fornitore se Partita Iva non esiste in archivio
Se il fornitore non è già stato creato il programma può crearlo con codice progressivo a quelli in archivio

Crea il fornitore se partita iva inesistente in archivio

Segna la fattura come contabilizzata senza creare la registrazione in prima nota

Dati per il pagamento automatico: Causale e Conto
Vengono proposti rispettivamente la causale presente in Causali Comuni alla voce: 'Pagamento per saldaconto e pn'
e il conto presente in Conti Comuni alla voce: 'Cassa Contante'
entrambi gestiti con la funzione: Dati generali azienda (parametri)
Se tali campi vengono lasciati bianchi NON verrà mai generata la registrazione di pagamento, viceversa si seguono le regole specificate nel parametro di personalizzazione: CreaPagAut

Regole con cui viene generata la registrazione di Prima Nota:

Ordinamento, se si contabilizzano più fatture: data ricezione e , in mancanza di questa, data documento

La Data protocollo sarà posta uguale alla più grande tra la data ricezione e la data dell’ultima fattura protocollata. Se non è presente la data ricezione il programma utilizzerà come data registrazione la data della fattura.

La Data registrazione viene posta uguale alla data protocollo.
E’ possibile cambiare questa impostazione creando il parametro di Personalizzazione:
FatPassDataReg (Gruppo: Fatel) con valore R. In questo modo la data registrazione verrà posta uguale alla Data ricezione.
Se manca la data ricezione, il programma utilizza la data della fattura.

N.B. La data ricezione assume una importanza fondamentale quando la fattura emessa in un determinato mese, viene ricevuta dallo SDI entro il 15 del mese successivo. In questo caso la data registrazione della fattura dovrà essere quella di ricezione e nella registrazione verranno impostati i campi Mese/Anno Iva. Il campo Mese iva sarà posto uguale al mese della data fattura.
Questa regola non vale a fine anno.
Le fatture con questa caratteristica verranno stampate sul registro iva del mese di registrazione (data ricezione) mentre finiranno nella liquidazione dell'iva del mese della data fattura.
Al fine di ottenere un elenco delle fatture che concorrono al calcolo dell'iva di un determinato mese o trimestre si può chiedere una stampa del Brogliaccio di Prima Nota, con scelta Movimenti iva su una riga, compilando SOLO i campi Anno contabile , anno Iva e Mese iva da ... a ... e scegliendo il Tipo Registro Acquisti (non va compilata la data di registrazione!)

Numero e data protocollo
Il numero protocollo non ha più necessità di essere stampato sul registro iva, viene incrementato ad ogni registrazione. La data protocollo può anche essere successiva alla data di registrazione.
Sulla stampa del registro iva acquisti si consiglia di stampare data registrazione e data documento

Causale
E' la causale attribuita al documento al momento del caricamento del file xml della fattura.
E' importante aver spuntato sulla causale utilizzata più comunemente come Fattura di acquisto e su quella Nota di Credito ricevuta il campo 'Ft.ric.prior.'

Conto di costo per le righe di dettaglio
In Gestione fornitori, maschera (4)Contabilità, è possibile definire quale conto di costo utilizzare per il caricamento delle fatture: quello scritto sul fornitore o quello sull'articolo. In mancanza di entrambi verrà utilizzato il codice del Merci c/acquisti scritto nella tabella dei conti comuni: Parametri e Utilità - Dati generali azienda (parametri) . Si può impostare un default col parametro di personalizzazione: ContoPrior

Codice Iva delle righe di dettaglio
Vedi codici iva in Caricamento xml fatture passive

  • Condizione di pagamento / Scadenze
    Poichè non è possibile ricostruire la condizione di pagamento da scrivere sulla registrazione di prima nota della fattura, questa verrà lasciata bianca pur creando le scadenze.
    Si consiglia pertanto di controllare che, sulle causali utilizzate per la registrazione delle fatture non sia spuntato il campo 'Condizioni di pagamento obbligatorie'
    Per NON creare mai le scadenze, creare il parametro di personalizzazione:
    ScadNoData (Gruppo: FatEl) e mettere in Valore la lettera A
  • Creazione automatica della registrazione del pagamento
    Se in una fattura risulta, dalle righe di pagamento, che c'è stato un pagamento immediato, verrà creato, al momento della sua contabilizzazione, anche la registrazione del pagamento. La creazione di tale registrazione verrà fatta secondo quanto specificato nel parametro di personalizzazione: CreaPagAut Gruppo: FatEl
    A (valore di default) automatica
    crea la registrazione per gli importi delle eventuali scadenze con data minore o uguale alla data fattura, oppure se il totale fattura è maggiore della somma delle scadenze
    N non crea registrazioni
    S crea la registrazione con importo delle eventuali scadenze con data minore o uguale alla data fattura

    Se invece NON si vogliono MAI generare le scadenze oppure in fattura non sono state riportate le condizioni di pagamento o manca la data scadenza, il programma si comporta come indicato dal parametro di personalizzazione: ScadNoData Gruppo: FatEl
    N non crea registrazioni (default)
    A non crea nessuna scadenza
     D crea una scadenza con data Scadenza uguale a Data fattura
    F crea una scadenza con data scadenza a Fine anno in base a data fattura
    NNN dove NNN è il numero dei giorni da sommare alla data fattura per ottenere la data scadenza

    La causale e il conto utilizzati per la registrazione di pagamento saranno quelli inseriti a video
  • Fattura con Ritenuta d'acconto, Cassa Previdenza, Enasarco
    Per la compilazione del conto da scaricare sulla riga corrispondente alla Cassa Previdenza, il programma cerca una spesa con flag Cassa Previdenza e stessa aliquota , se non la trova cerca una qualsiasi spesa con flag cassa previdenza

    Se invece c’è l' Enasarco , riportato sul file XML come specificato nelle istruzioni ministeriali:
    <AltriDatiGestionali>
    <TipoDato>CASSA-PREV</TipoDato>
    <RiferimentoTesto>ENASARCO #TC07#</RiferimentoTesto>
    <RiferimentoNumero>xx.00</RiferimentoNumero>
    </AltriDatiGestionali>

    si cerca una spesa che abbia il flag Cassa Previdenza e nella descrizione abbia la parola ENASARCO , se non la trova cerca una spesa con flag Cassa previdenza, se non la trova prende il conto 'Ritenuta d’acconto Acquisto' dalla tabella Conti Comuni (Parametri e utilità - Dati generali azienda-parametri)

    Per la contabilizzazione delle fatture di acquisto con ritenuta d’acconto verrà fatta 1 o 2 registrazioni a seconda del valore del parametro personalizzazione: RitAccFornAutom
  • Fattura con Spese (es. bancarie , trasporto)
    Gli importi delle spese potranno essere contabilizzati sul conto corretto, letto dalla tabella spese, SOLO se, sia sul file xml della fattura, sia nella tabella Spese del database in uso, è stato compilato il Codice Assosoftware della Spesa

Parametro:
Gruppo: Contabil
Parametro: CigCupDaFe
se vale S in contabilizzazione di una fattura se compilati CUP e CIG in altri dati per fattura elettronica nel riquadro degli ordini d’acquisto (campi 2.1.2.6 e 2.1.2.7) vengono portati in prima nota al posto di quelli che si trovano nella testata della fattura


HUB: LISTA FATTURE PASSIVE

Percorso: Vendite - Fatture - Fattura elettronica

La funzione consente di monitorare le fatture elettroniche passive ricevute sull'Hub Zucchetti in un determinato periodo e di scaricarle nell'area d'appoggio per poi completarle e caricarle in prima nota.
Vedere fatture elettroniche passive per la configurazione di eventuali parametri di personalizzazione

Data documento da .. a

Solo documenti non scaricati S/N
Consente di visualizzare tutti i documenti o solo quelli non ancora trasferiti dall' Hub sul database di lavoro (nell'area d'appoggio)

Mostra se in tabella di trasferimento
Se un documento è già stato scaricato dall'Hub e quindi caricato sulla tabella di appoggio (trasferimento) del database in uso, potrebbe già essere stato stampato e/o contabilizzato.
Impostando questo pulsante a SI, verranno visualizzati anche i documenti già scaricati con indicazione del numero di riferimento che hanno assunto sulla tabella di appoggio e del fatto che siano stati stampati e/o contabilizzati. Tale descrizione verrà evidenziata nella colonna: TRASF

Fornitore
Possibilità di selezionare SOLO le fatture di un fornitore

Nella lista delle fatture vengono visualizzati i campi:
Ragione sociale fornitore, Numero e Data fattura, Totale fattura, Data di ricevimento fattura, Stato (es. Ricevuto), Moneta, Att =Hanno file collegati, C.S.=Conservazione Sostitutiva, Ufficio destinatario, IdDocumento

Pulsanti in fondo:

Selez.Tutto [image] e Deselez. Tutto
Servono rispettivamente per selezionare o deselezionare i documenti presenti nella lista per poi applicare un comando tra quelli resi possibili dai pulsanti:
Scarica
Consente di scaricare il file XML della fattura
La cartella in cui verrà scaricato il file è quella indicata nel parametro DirFeScar che va impostato manualmente nella sezione [Base] dell'AziWin.ini (Es. DirFeScar =C:\aziwin\FatturePassive). Se manca questo parametro il programma cercherà il parametro: DirFe , se non esiste nemmeno questo verrà utilizzata la cartella indicata in DirCarica

Importa Xml scaricati
Per fare in modo che i file xml scaricati vengano immediatamente caricati nel file d'appoggio dal quale potranno essere stampati, occorre spuntare questo campo.

Verrà presentata una maschera nella quale si chiede il codice della causale contabile da utilizzare per la registrazione della fattura e un codice iva. Se si lascia bianca la causale il programma cercherà tra le causali contabili di acquisto quella nella quale è stato spuntato il campo 'Ft.ric.prior' e assegnerà quella.
Se si lascia bianco il codice iva il programma assegnerà il codice iva con l'aliquota o la natura uguali a quelle della fattura ricevuta, nel quale sia stato spuntato il campo: 'Fat. Ric. codiva prior'

Fornitore: Gruppo - Mastro
Crea fornitore se partita iva non esiste in archivio
se spuntato il campo e il fornitore non esiste in archivio, verrà creata un'anagrafica con la ragione sociale e la partita iva presente sulla fattura caricata

Sovrascrivi esistenti
Consente di importare di nuovo una fattura già importata

Estrai allegati
Consente di estrarre dall'XML gli eventuali allegati in modo da renderli visibili

Documento [image] e Zip
Consentono di ottenere un file ZIP per ogni fattura contenente l'una solo i documento e le ricevute, l'altra anche gli eventuali allegati

Togli firma
Consente di scaricare i documenti dopo aver tolto la firma elettronica

Ordinamento sulle colonne della maschera:
Col pulsante DX sui titoli delle colonne, si esegue l'ordinamento sulla colonna, inoltre tenendo premuto il tasto Ctrl si possono aggiungere colonne all'ordinamento

Con Ctrl Alt si toglie o ripristina l'ordinamento

E' possibile memorizzare il tipo di ordinamento e la dimensione e posizione della maschera, posizionandosi su un campo qualsiasi e premendo i tasti: Ctrl Alt e pulsante Destro del mouse. Per le installazioni in rete la configurazione viene memorizzata sull' Aziwin.ini di ogni terminale.
Esempio di come viene memorizzato:
[Configurazioni]
FELisPasLarg=18840
FELisPasAlt=11739
FELisPasSort=5
FELisAttLarg=15502
FELisAttAlt=11739
FELisAttSort=3


INFORMAZIONI FATTURA ELETTRONICA

Questa funzione consente di conoscere il numero delle fatture elettroniche acquistate (in entrata e in uscita) e quante ne sono state utilizzate.


FATT.ELETTRONICA-NOTE CAMPI PARTICOLARI

Fatt.Elettroniche: Note campi particolari

Per integrazione fattura con standard Assosoftware in modo da ottenere una miglior interpretazione del contenuto del file XML in fase di caricamento delle fatture passive e poter inviare ai clienti un file XML arricchito con un maggior numero di informazioni

Si possono compilare alcuni campi all'interno di determinate tabelle come da lista seguente:

AswCodIVA Codice trattamento IVA
E' la descrizione dell'esenzione (Tab Assosoftware) da impostare nella tabella dei codici IVA in corrispondenza agli esenti

AswTipoPag Tipo Pagamento
E' la descrizione del Pagamento (Tab Assosoftware) da impostare nella tabella dei codici Tipo Pagamento

AswTipoDoc Tipologia del Documento
AswTratFis Trattamento Fiscale del documento
AswCarDoc Caratteristica del Documento Es. #CD13# Ivata
Sono descrizioni, da Tab Assosoftware, da impostare nei corrispondenti campi della tabella dei Tipi Documenti

Altri campi scaricati dal programma di preparazione dell'XML

aswRifriga Riferimento Riga (Sconti, Maggiorazioni, Spese, ecc.)
<RiferimentoTesto> =
- KitPadre #nr. righe#
- KitFiglio #nr. righe#

aswtriga ---->
Nelle righe di dettaglio per la compilazione di 'altri dati gestionali' del file XML :
Per righe relative a Sconto – abbuono – spese accessorie – Omaggi con rivalsa iva e Omaggi senza rivalsa, Assosoftware ha previsto alcune codifiche, in particolare:
- Omaggio senza rivalsa #OS#
- Omaggio con rivalsa #OC#
storno omaggio (sigla #SO#)
sconto merce (sigla #SM#)
sconto (#SC#)
acconto #AC#

AswPrLordo Prezzo Unitario Lordo dell'IVA

AswSconMag Tipologia di Sconto / Maggiorazione e per identificare gli sconti di testata/piede riportati a livello di riga

Lotti

AswMatric Informazioni Matricole

AswSpSanit Tipologia di Spesa Sanitaria e opposizione

AswDestB2B Destinatario Fattura elettronica (Ufficio)

AswTratSco Trattamento sconti/maggiorazione di testata/piede
Dove calcolo sconto pagamento

AswDichInt Estremi dichiarazione intento


CANCELLAZIONE TABELLA DI APPOGGIO FATTURE ELETTR. PASSIVE

Percorso: Vendite - Servizio

Questa funzione consente di cancellare le fatture passive presenti nella tabella di appoggio.
Tali fatture sono state memorizzate nella tabella nel momento in cui sono state scaricate dall'Hub per poter poi essere stampate e completate per la contabilizzazione.

Oltre alla selezione per anno, numero e data riferimento, data ricezione, è possibile scegliere di cancellare

  • Tutte le fatture
  • Solo le stampate
  • Solo le contabilizzate
  • Solo le stampate e contabilizzate


CANCELLAZIONE TABELLA DI APPOGGIO FATTURE ELETTR.PASSIVE

Autofatture TD20 per mancata ricezione fattura dal fornitore

Procedura per effettuare un autofattura necessaria nel caso in cui non sia stata ricevuta la fattura dal fornitore e quindi andrà emesso un documento di tipo TD20 dove il cedente sarà il fornitore
e il cessionario la ditta in gestione.

  • Inserire nei parametri di personalizzazione il codice destinazione della propria ditta, in modo che lo sdi ci rimanderà il file xml nelle nostre fatture passive: gruppo XML – Parametro CodiceDestinatario
  • Creare un nuovo tipo documento di tipo fattura con le seguenti caratteristiche:
    • Spuntare il flag “A Fornitore”
    • Nella causale per coge mettere $$ per indicare che questa fattura non andrà contabilizzata
    • Lasciare vuota la causale che movimenta il magazzino
    • Nel prefisso mettere § per indicare che non si usano i normali numeratori delle fatture ma un numeratore d’appoggio con numerazione separata per ogni conto fornitore
    • Nel tipo documento mettere TD20
    • Mettere un codice filtro di stampa personalizzato se si vuole fare anche la stampa su carta o su pdf, filtro da personalizzare in modo da invertire cedente con cessionario.
  • Nel fornitore nel quarto codice di riclassificazione mettere il suo regime fiscale: per poter fare questo bisogna aggiungere nella tabella dei codici di riclassificazione questo valore (ad es. RF01 – Ordinario)
  • Quando si inserisce la fattura mettendo un tipo documento, creato come indicato sopra, nel campo cliente accetterà un conto fornitore e quando si invierà il file xml verranno messi i dati del fornitore nel cedente e i dati della ditta nel cessionario.


PROVVIGIONI

La procedura consente di calcolare le provvigioni, in percentuale, maturate dagli agenti e di stampare i riepiloghi di Fatturato e Maturato per agente.

A seconda di quanto è previsto sull'anagrafica Agente, le provvigioni possono essere calcolate sul

  • Fatturato
  • Incassato

L'automatismo del calcolo parte dal fatto che sulla fattura sia impostato il codice agente e il campo "Tipo provvigione" che indica da dove prelevare la % (o importo) provvigione:

  • dall'agente
  • dal cliente
  • dall'articolo

In fase di inserimento fattura, tali campi vengono proposti con i valori estratti dal cliente e possono essere modificati per il singolo documento. Al momento della stampa, il programma compilerà una tabella con l'elenco delle provvigioni spettanti per quella fattura.

Sul cliente, e quindi sui documenti, è possibile memorizzare due agenti.
Per ogni agente è possibile definire il "Tipo provvigione".

Le provvigioni possono essere calcolate, a seconda di quanto definito nell'anagrafica agente:

  • in percentuale su ogni riga, sul lordo o sul netto merce
  • a importo fisso moltiplicato per la quantità che è sulla riga del documento (es. 5,35 per ogni unità di merce venduta)
  • in percentuale sul totale merce
  • a importo fisso moltiplicato per il totale peso (letto nei dati di accompagnamento della fattura)

Sulla tabella Agenti, oltre ai dati anagrafici e al tipo di calcolo, è memorizzato anche il codice di un eventuale sub agente.

Per quanto riguarda il calcolo delle provvigioni del sub agente, la modalità è quella prevista per l'agente (Tipo provvigione) mentre l'eventuale percentuale o importo provvigione, verranno letti dalla sua anagrafica.

Note sul calcolo delle provvigioni

Nel caso di calcolo delle provvigioni a % sul totale merce o ad importo sul totale peso, verrà generata un'unica riga di provvigione dove manca il codice articolo e nella descrizione verrà riportato il tipo di calcolo. Se invece il calcolo viene fatto con le altre modalità previste, verrà generata una riga per ogni riga articolo presente in fattura per la quale sia stato previsto un agente e una perc/importo provvigione.

Le provvigioni vengono calcolate anche in corrispondenza di articoli manuali.

Il campo sconto che viene riportato in ogni record dell'archivio provvigioni è lo sconto risultante della riga del documento.

Se è attivo il parametro di personalizzazione DetraeSconPag nella determinazione dell'imponibile provvigione verrà considerato anche lo sconto pagamento. In particolare nel caso il tipo di calcolo sia a percentuale sul totale merce lo sconto visualizzato sulla riga è lo sconto pagamento.

Questi dati possono poi essere variati e stampati a piacere fino al momento in cui si dovrà fare la stampa definitiva del prospetto delle provvigioni.

E' possibile impostare il parametro di personalizzazione: RidPercAgenti e quindi compilare una tabella che consente di inserire una percentuale di abbattimento della provvigione per fasce di sconto.

Inoltre anche sulla tabella Sconti e Sconti Quantità (per cliente/articolo, cliente/gruppi articolo etc.) è possibile definire una percentuale di abbattimento della percentuale provvigione in corrispondenza ad ogni sconto inserito.
Questa verrà utilizzata, in inserimento Preventivi, Ordini, Ddt e Fatture per abbattere la percentuale di provvigione della riga. Se non trovano questa percentuale, i programmi cercheranno l'eventuale presenza della Tabella degli abbattimenti per fasce di sconto.

Parametro per la stampa: StSaldoPart

Provvigioni sull'incassato:
In questo caso è obbligatorio gestire bene le scadenze e i relativi incassi ed è indispensabile che le provvigioni e le scadenze abbiano la stessa moneta. Le scadenze vanno generate SEMPRE, anche per pagamenti in contanti.
Le causali utilizzate nelle registrazioni di incasso devono avere il campo 'Aggancio scadenze/partite' spuntato, in modo da chiudere le scadenze.
Le note di variazione devono riportare SEMPRE la condizione di pagamento in modo da generare una scadenza, che dovrà essere pagata a parte e non compensata con quella della fattura.

Vengono utilizzati i seguenti parametri di personalizzazione:
ImpArrChiuso, GioInsPag, GioInsReg

Funzioni:
Gestione provvigioni agente
Consente di Variare le righe di provvigione generate dalla stampa fattura.
Stampa provvigioni agente
Stampa provvigioni sull'incassato
Cancellazione provvigioni
Per cancellare dall'archivio le righe di provvigioni relative a periodi per i quali sono stati stampati i riepiloghi.


PROVVIGIONI-GESTIONE

Percorso: Vendite - Provvigioni

Il programma permette la variazione e l'annullamento dei movimenti, relativi alle provvigioni, preparati durante la stampa della fattura.

Se, digitati alcuni campi per la ricerca di una fattura e delle relative provvigioni, si preme il pulsante di ricerca, il programma cerca fra i dati memorizzati e visualizza l'elenco di quelli che soddisfano le caratteristiche richieste.

Viceversa se, compilati tutti i campi di testata: agente, cliente, tipo documento, prefisso, numero e data, si entra in ricerca e il programma non trova niente di memorizzato, si predispone per la creazione.

La gestione dei dati è del tipo Testata (con i dati della testata della fattura) e Dettaglio (con l'elenco degli articoli e relativi importi di provvigione) e, fino a quando non viene stampato il prospetto delle provvigioni per l'agente o il sub agente, si possono variare tutti i dati di testata (tranne la moneta e il cambio) e quelli delle righe degli articoli, inoltre è possibile aggiungere altre righe se necessario.
Se l'agente prevede le provvigioni sull'incassato, è possibile gestire anche l'elenco dei dati di incasso e pagamento provvigioni dei vari periodi per i quali è stata fatta la stampa definitiva.

Se l'agente prevede la gestione della valuta, in corrispondenza ad una fattura emessa in valuta verranno calcolati anche gli importi di provvigione in valuta.

Ad ogni fattura è possibile associare due agenti per cui una fattura nella quale sono codificati entrambi gli agenti, creerà due gruppi di movimenti in questa tabella, un gruppo per ogni agente.

Poiché ad ogni agente può essere collegato un sub agente, se questo è valorizzato, sarà poi possibile stampare anche il prospetto delle sue provvigioni.

La provvigione del sub agente viene SEMPRE calcolata sull'imponibile provvigione dell'agente, con lo stesso tipo di calcolo dell'agente e con la percentuale (o importo) del sub-agente.

In generale, se è stata fatta la stampa delle provvigioni in modo definitivo di una certa fattura (per l'agente e il sub agente), questa non potrà più essere variata ed è consentita la sola visualizzazione.

Se è stato stampato solo il prospetto per l'agente, e c'è il sub agente, si possono variare sui dettagli le percentuali e le provvigioni del sub agente ma niente in testata.

Se è stato stampato solo il prospetto per l'agente, si possono variare sui dettagli le percentuali e le provvigioni dell' agente ma niente in testata.

Dalla testata è abilitata la cancellazione di un intero documento di un agente, purchè non risulti già stampato il riepilogo in modo definitivo.
Una volta confermata la testata, con il tasto [image] (S) SALVA o con [image] (E) Gestione dettaglio, si prosegue con l'inserimento o la variazione delle righe articolo.

Gestione righe articolo (dettagli)

Gestione righe dettaglio dell'incassato
(solo per le fatture con agente che prevede le provvigioni sull'incassato)


PROVVIGIONI-GESTIONE RIGHE ARTICOLO

Percorso: Vendite - Provvigioni

In questa sezione si possono vedere e gestire le provvigioni relative ai vari articoli presenti in fattura. Vengono calcolate le provvigioni anche degli articoli manuali.

Per ogni dettaglio vengono memorizzati la quantità, il prezzo unitario, l'eventuale sconto riepilogativo, l'imponibile provvigione (al netto o meno dello sconto a seconda di quanto è previsto sull'anagrafica agente), le % (o importi) dell'agente e dell'eventuale sub agente e i relativi importi di provvigione.

Nel caso di calcolo delle provvigioni a % sul totale merce o ad importo sul totale peso, verrà generata un'unica riga di provvigione dove manca il codice articolo e nella descrizione verrà riportato il tipo di calcolo.

Nel caso di tipo di calcolo sia Importo per peso totale, nel campo imponibile viene visualizzato l'imponibile totale della fattura e nella quantità il peso totale che è servito per il calcolo dell'importo finale di provvigione.

Se è attivo il parametro di personalizzazione DetraeSconPag nella determinazione dell'imponibile provvigione verrà considerato anche lo sconto pagamento. In particolare nel caso il tipo di calcolo sia a percentuale sul totale merce lo sconto visualizzato sulla riga è lo sconto pagamento.

La provvigione del sub agente viene SEMPRE calcolata sull'imponibile provvigione dell'agente, con la stessa modalità dell'agente ma con la percentuale ( o l'importo) letto dal sub-agente.

In inserimento, come avviene per i documenti delle vendite, si può confermare la riga col tasto F10 e interrompere l'inserimento con il tasto ESC sul codice articolo.

Per inserire una nuova riga in una fattura esistente, occorre premere il tasto [image] (F10) Inserisci riga


PROVVIGIONI-STAMPA

Percorso: Vendite - Provvigioni

Il programma esegue la stampa delle provvigioni ordinate per codice agente, codice cliente e numero fattura.

A rottura di agente e di cliente vengono stampati i relativi totali.

L'operatore potrà scegliere se fare o meno un cambio pagina a cambio agente.

Prestampa - Stampa - Ristampa
La stampa può essere eseguita in prova (ripetuta a piacere), come definitiva (i movimenti di provvigione verranno marcati 'stampati' e verranno esclusi dalle stampe successive, sarà possibile ristamparli solo con l'opzione di Ristampa)

Esclusi sospesi - Solo sospesi - Tutti
In Gestione provvigioni, una volta posizionati su una riga, è possibile spuntare il campo: 'Sospeso' in modo da sospendere l'elaborazione di quella riga in stampa provvigioni. Tale riga potrà poi essere riabilitata per una stampa successiva, togliendo la spunta al campo.

I dati stampati sono diversi a seconda del tipo di stampa scelta: Sintetica o Analitica. Mentre nella sintetica verrà riportato l'elenco delle fatture con i relativi imponibili e importi di provvigione, nell'analitica, per ogni fattura, verrà stampato anche l'elenco degli articoli ciascuno con il dettaglio delle provvigioni.

Nella stampa in formato 'Sintetico' è possibile ottenere, sulla riga di ogni fattura, la stampa del saldo della partita. Le condizioni indispensabili sono una corretta gestione delle partite e l'attivazione del parametro di personalizzazione StSaldoPart.
Abilitando il parametro StScontoCli si ottiene la stampa dello sconto cliente.

Nella maschera è presente il campo 'Cerco Agente anche come SubAgente' spuntando il quale verranno stampate con un'unica sessione di stampa, tutte le fatture nelle quali un agente compare sia come agente sia come subagente. In questo caso l'eventuale selezione degli agenti da stampare va messa nel campo Agente da .. a .. (non va mai selezionato il subagente)
In stampa verrà riportata la scritta SubAgente sulla riga dei dati della fattura in corrispondenza alle fatture che , pur avendo un agente diverso, vengono stampate in quanto hanno il subagente compreso nell'intervallo di agenti selezionati.


PROVVIGIONI AGENTE SULL'INCASSATO

Percorso: Vendite - Provvigioni

Il programma permette la stampa delle provvigioni per gli agenti che le maturano sull'incassato.
La stampa dovrà essere fatta da un solo terminale per volta al fine di evitare sovrapposizioni di dati.

Per un calcolo corretto delle provvigioni da liquidare nel periodo è indispensabile che vengano generate e gestite correttamente le scadenze.
Nelle condizioni di pagamento ci deve essere perciò la richiesta di generare sempre almeno una scadenza.
La scadenza dovrà essere generata anche da una eventuali Nota di Credito e dovrà essere pagata perchè la stampa ne tenga conto.
Nel caso di compensazione tra scadenze di fatture e note di credito occorre intervenire manualmente.
E inoltre che, a fronte di un documento in valuta, sia prevista o non prevista la valuta sia sull'Agente sia sulla scadenza. In pratica provvigioni e scadenza devono avere la stessa valuta.

Possibilità di

  • Prestampa
    Consente una stampa di prova e può essere ripetuta a piacere
    Presenta una opzione che consente di stampare TUTTE le fatture del periodo che interessano l'agente in stampa, indipendentemente dal fatto che siano incassate o meno.
    Se si spunta la scelta: In prestampa stampa anche con pagamenti successivi , si ottiene la stampa di una situazione a una data senza tener conto degli eventuali pagamenti (e incassi) successivi a tale data.
    N.B. Qualsiasi sia la data di stampa impostata, il totale provvigioni può differire dalla somma delle provvigioni 'periodo + residuo' dell'importo corrispondente alle provvigioni delle fatture già pagate all'agente, in parte, in date precedenti.
  • Stampa - si può eseguire una sola volta
    scarta tutte le fatture per cui la provvigione risulta Stampata, con data minore o uguale all'attuale data di stampa e al termine mette a Si il campo Stampato sulla provvigione solo quando la fattura è stata tutta incassata completamente. Parametro di personalizzazione: ImpArrChiuso
    Occorre fare attenzione alla data di stampa chiesta a video, in quanto essa determina la scelta dei dati da elaborare e inoltre, per ogni fattura/provvigione elaborata, verrà memorizzata sulla tabella provvigioni la situazione a quella data, per determinare il punto di partenza delle elaborazioni successive.
    Per 'ripristinare' un periodo per il quale sia stata fatta la stampa definitiva, occorre andare in Gestione provvigioni, modificare manualmente il campo di 'Stampato' sulla testata Provvigione poi cancellare le righe 'Pagamenti Agente e/o Sub Agente' entrando rispettivamente con i pulsanti: e
    Se si interrompe l'elaborazione, rilanciando la stampa verrà dato un messaggio: "C'è un'elaborazione in corso" poi si suggerisce di verificare se è stata lanciata da un altro terminale e in quel caso basta uscire dal programma oppure di fare una Pulizia dell'elaborazione precedente per poi ripetere tutto.
  • Ristampa
    considera tutto quello che era già stato estratto in quella data per cui è fondamentale che venga inserita la stessa data utilizzata per la stampa.

Cerco agente anche come SubAgente
Spuntando questa casella è obbligatorio scegliere la stampa per agente ed eventualmente inserire un codice agente nel da.. a .. (non inserire mai codice subagente), verrà elaborata la stampa di tutte le fatture che soddisfano le condizioni a video nelle quali l'agente selezionato compare come agente o subagente. In pratica equivale a fare due stampe una per l'agente richiesto e una per il subagente.

Per le scadenze di tipo Ricevuta Bancaria, al fine di considerarle incassate o meno, se inserite in una distinta contabilizzata, viene presa la data scadenza al posto della data pagamento.
Gli insoluti possono venire considerati o meno a seconda del valore attribuito al parametro: GioInsReg

Se una fattura è chiusa poi arriva un insoluto, occorre riaprire manualmente la provvigione, variando il campo 'Stampato Agente (e/o sub Agente)' da S a N , sulla testata in Gestione Provvigioni.

Altro parametro di personalizzazione: GioInsPag


CANCELLAZIONE PROVVIGIONI

Percorso: Vendite - Servizio - Utilità

Questa funzione consente di eliminare dall'archivio provvigioni le righe relative a periodi o ad agenti per i quali sono stati stampati i riepiloghi in modo definitivo (sia dell'agente sia del sub agente, se valorizzato).

Una opzione consente di cancellare tutti i movimenti della tabella.


TESSERA SANITARIA

Il modulo Tessera Sanitaria è un pacchetto aggiuntivo di AziendaPC che consente di eseguire l'estrazione delle fatture al fine di poter preparare il file in formato XML per la trasmissione dei dati di spesa sanitaria, a cura dei medici e delle strutture sanitarie, al sistema Tessera Sanitaria per per il 730 precompilato, come previsto dall’articolo 3 comma 3 del D.Lgs. 175/2014.

E' possibile estrarre le fatture da inviare:

  • dalla Fatturazione
    le fatture che dovranno essere state inserite con il pacchetto di Fatturazione AziendaPC
    (scelta di default)
  • dalla Prima Nota di Contabilità
    se è impostato il parametro di personalizzazione
    Gruppo: TesSan
    Parametro: EstrDaCoge con valore S

Oltre alla preparazione del file da inviare formato XML è possibile preparare un file in formato CSV (opzione nel programma di Preparazione file)

Il modulo necessita dell'installazione dei 2 file: SanitelCF.cer e openssl.exe che vanno copiati nella cartella principale dell'installazione(Es. \AziWin) dalla cartella Varie\TesseraSan contenuta nell'area da cui sono stati installati/aggiornati i programmi (cartella in cui è stato scompattato il file ZIP).
Il programma di preparazione del file XML controlla che tali file siano presenti e, se mancano, lo segnala.

Dal menu Vendite si accede al gruppo di programmi: Tessera Sanitaria.
Elenco funzioni
Estrazione dati Tessera Sanitaria
Gestione dati Tessera Sanitaria
Preparazione file XML

Operazioni da eseguire per la preparazione dei dati:

Parametri e Utilità - Dati Generali azienda - Anagrafica ditta:
Se il soggetto che emette i documenti fiscali è Farmacia o Struttura inserire
Codice Regione (3 caratteri)
Codice ASL di appartenenza (3 caratteri)
Codice SSA
altrimenti basta il Codice Fiscale del Medico/odontoiatra

Gestione Clienti - maschera (5) Fatturazione
campo: Estrarre in Tessera Sanitaria
impostare a No sui clienti le cui fatture non dovranno essere trasmesse.
Il programma di estrazione estrae i documenti dei clienti che hanno questo flag impostato a Si, che sono Persone Fisiche, con Codice Fiscale valorizzato, Partita Iva vuota e Flag Fittizio diverso da Si.

A seconda che si scelga di estrarre le fatture dalla Fatturazione o dalla Contabilità, dovrà essere valorizzato il campo:
Tessera Sanitaria- Tipo Spesa
Questo campo serve per definire il tipo di prestazione erogata nelle varie righe della fattura. I valori da assegnare al campo sono quelli definiti nelle specifiche del Progetto Tessera Sanitaria
E' possibile impostare questo campo anche con il valore: NON Estrarre . In questo modo, l'articolo in oggetto NON verrà mai estratto anche se presente in fattura.

  • Gestione Articoli - maschera (4) Altro e Gestione Spese
    (per Fatturazione)
  • Gestione Conti
    (per Contabilità)

Parametri di personalizzazione che si possono impostare che verranno utilizzati per valorizzare alcuni campi chiesti a video in Estrazione dati, tali valori potranno poi essere variati sul momento dell'estrazione.
Gruppo: TesSan
Parametro: TipoSpesaDef

Parametro: TipoSpesaMan
Indica il tipo Spesa per articoli manuali

Parametro: TipoSpesaBolli
Indica il tipo Spesa per i Bolli
Nelle FAQ dell'Agenzia delle Entrate viene chiarito che:
"l’imposta di bollo e l’IVA esposte in fattura/ricevuta seguono il trattamento della spesa sanitaria cui si riferiscono e confluiscono nella relativa tipologia di spesa"

Il campo Tipo Spesa può assumere i seguenti valori:

  • TK Ticket (Quota fissa e/o Differenza con il prezzo di riferimento. Franchigia. Pronto Soccorso e accesso diretto)
    ( T1 per Ticket Pronto Soccorso - verrà scaricato TK sul file XML ma serve per differenziare la prestazione e poter valorizzare correttamente il campo 'FlagTipoSpesa' )
  • FC Farmaco, anche omeopatico. Dispositivi medici CE
  • FV Farmaco per uso veterinario
  • SV Spese veterinarie sostenute dalle persone fisiche
  • SP Prestazioni Sanitarie
  • AD Acquisto o affitto di dispositivo medico CE
  • AS Spese sanitarie relative ad ECG, spirometria, Holter pressorio e cardiaco, test per glicemia, colesterolo e trigliceridi o misurazione della pressione sanguigna, prestazione previste dalla farmacia dei servizi e simili
  • SR Spese prestazioni assistenza specialistica ambulatoriale esclusi interventi di chirurgia estetica.
    Visita medica generica e specialistica o prestazioni diagnostiche e strumentali.
    Prestazione chirurgica ad esclusione della chirurgia estetica.
    Ricoveri ospedalieri, al netto del comfort. Certificazione medica.
    (S2 per visita in intramoenia - verrà scaricato SR sul file XML ma serve per differenziare la prestazione e poter valorizzare correttamente il campo 'FlagTipoSpesa' )
  • CT Cure Termali
  • PI protesica e integrativa
  • IC Intervento di chirurgia estetica ambulatoriale o ospedaliero
  • AA Altre spese
  • NE Non estrarre (valore per uso interno al programma)
  • PR Primo Tipo Spesa definito nella fattura (valore per uso interno al programma, usato in Gestione conti)
    Utilizzato per lo scarico dei Bolli. Questo valore si dovrà impostare sul conto bolli (se si estrae dalla contabilità) oppure si può impostare a video al momento dell'estrazione o nel parametro TipoSpesaBolli (se si estrae dalla Fatturazione)


ESTRAZIONE DATI TESSERA SANITARIA

Percorso: Vendite - Tessera Sanitaria - Estrazione dati

Questa funzione estrae e memorizza su un archivio di appoggio, dalle Fatture oppure dalla Prima Nota di Contabilità, i dati per poter poi fare la preparazione del file XML da inviare nell'ambito del progetto Tessera Sanitaria
Si consiglia di leggere il capitolo Tessera Sanitaria per il dettaglio sulla preparazione dei dati.

Verranno estratte le fatture dei clienti che hanno il flag 'Estrarre in Tessera Sanitaria' impostato a Si, che sono Persone Fisiche, con Codice Fiscale valorizzato, Partita Iva vuota e Flag Fittizio diverso da Si.

Viene chiesta conferma se cancellare i dati di una eventuale estrazione precedente. Anche se si conferma, NON verranno cancellati eventuali fatture inserite manualmente con la Gestione dati tessera sanitaria.

Estrarre da

  • Fatturazione (default)
  • Prima Nota
    se è impostato il parametro di personalizzazione
    Gruppo: TesSan
    Parametro: EstrDaCoge con valore S

Anno

Data documento da: a:
Consente di estrarre solo un intervallo di documenti. Se l'estrazione viene fatta da Prima Nota, il programma estrae le fatture con data protocollo compresa nell’intervallo, se da Fatturazione, quelle con data documento.

Tipo spesa per articoli/conti senza codifica - Tipo spesa per articoli manuali - Tipo spesa per 'spese'

A seconda che si estraggano le fatture da Fatturazione o dalla Contabilità il 'tipo spesa' considerato sarà quello degli articoli o dei conti.
Nel caso della Contabilità NON verrà considerato nè 'Tipo spesa per articoli manuali' nè 'Tipo spesa per 'spese''

Per i valori vedi elenco Tipo Spesa
In più in questo elenco compare la scelta: 'Non definito'
Se si sceglie 'Non definito' , articoli/conti senza codifica del 'Tipo Spesa', verranno comunque estratti poi l'operatore dovrà intervenire con la gestione per assegnare loro un Tipo Spesa corretto
Si può anche decidere di NON estrarre gli articoli/conti senza codifica assegnando a questo campo il valore: NON ESTRARRE
In generale le spese avranno come Tipo Spesa: AA- Altre spese (Es. Bolli)

In questi campi viene visualizzato il tipo eventualmente impostato nei rispettivi parametri di personalizzazione:
Parametro: TipoSpesaDef , TipoSpesaMan , TipoSpesaBolli

Segnala articoli senza codifica
di default impostato a si
Se in Tipo spesa per articoli/conti senza codifica è impostato a ND - Non definito, verrà visualizzato il numero di articoli trovati senza codifica del Tipo Spesa


GESTIONE DATI TESSERA SANITARIA

Percorso: Vendite - Tessera Sanitaria - Gestione dati

Questa funzione consente di visualizzare , variare, cancellare le fatture estratte con Estrazione dati Tessera Sanitaria ed, eventualmente, di inserirne manualmente di nuove.

Pulsante lista
E' possibile impostare dei parametri per fare delle estrazioni particolari di fatture.
Esempio visualizzare tutte le fatture con un 'Tipo Spesa' particolare o un determinato articolo.

Per quanto riguarda i campi check, si possono spuntare o meno per selezionarli con valore Si o No, per neutralizzarli invece, cioè metterli in grigio, basta premere Canc sul Checkbox oppure fare un click col pulsante Destro del mouse.
E' possibile visualizzare nella lista anche il codice fiscale e la Ragione sociale dei clienti spuntando le scelte:
Mostra Codice Fiscale e Mostra Cognome e Nome
e inoltre visualizzare solo le testate con righe a importo 0

In gestione ogni fattura viene presentata con un gruppo di dati di testata e con le righe di dettaglio che corrispondono agli articoli, ciascuno riportato con l'evidenza del Tipo Spesa.

Numero riferimento
numero progressivo assegnato al momento dell'estrazione. Inserire 0 per andare in inserimento manuale

Cliente
E' il cliente a cui è stata emessa fattura

Tipo inserimento
Automatico o Manuale

Partita Iva di chi emette
Se lasciato bianco il campo, verrà presa la Partita Iva dalla tabella Ditta, viceversa si può scrivere qui la P.Iva da scaricare.

Numero e data fattura
Visualizzati dal documento emesso

Data pagamento
Se lasciato bianco viene posto uguale alla data documento

Pagamento anticipato rispetto data documento

Tipo Operazione
Inserimento - Variazione - Rimborso - Cancellazione
Normalmente è inserimento
Il programma mette Rimborso per le Note di Credito poi verrà compilato il campo 'Documento oggetto di rimborso'

Importo totale
Importo fattura

Importo Totale righe da inviare
E' l'importo 'calcolato' sommando le righe da inviare. Può essere diverso dal precedente se alcune righe sono state escluse dall'invio.

Documento oggetto di rimborso
E' l'eventuale fattura (numero e data) di riferimento nel caso di Nota di Credito
Questi campi verranno compilati se nella nota di credito sono stati compilati i campi numero e data fattura di riferimento

Numero righe con tipo 'Non definito'
è diverso da zero solo se in estrazione non è stato definito un tipo spesa particolare per 'Tipo spesa articoli/conti senza codifica'.

Il documento contiene dettagli scartati - Il documento contiene spese scartate
Verranno spuntati o meno, in automatico dal programma per segnalare se sono state scartate delle righe durante l'estrazione

Non estrarre questo documento
Consente di escludere il documento dalla preparazione del file XML

Numero e data riferimento
Numero e data riferimento della fattura in gestione fatture

Pulsante per accedere alla fattura in Gestione Fatture

RIGHE DI DETTAGLIO

Tipo Spesa
Per i valori vedi elenco Tipo Spesa
Qui non compaiono più i tipi ad uso interno: T1 e S2 perchè il programma di estrazioni li fa corrispondere rispettivamente a TK con Flag Tipo Spesa 1 e SR con Flag Tipo Spesa 2

Flag Tipo Spesa
Viene scaricato automaticamente dal programma in base al Tipo Spesa.
In generale è impostato a Nessuno. Viene impostato a 1 in corrispondenza del tipo spesa, ad uso interno, T1 (TK con Ticket)
e a 2 per Tipo Spesa S2 (SR visita intramoenia)

Importo
Importo della riga

Solo se estrazione da Fatture:
Riga documento
Numero di riga del documento

Riga Spesa
Se c'è una spesa , viene riportato il codice e descrizione spesa. Per i Bolli viene riportato fisso: -1


PREPARAZIONE FILE XML TESSERA SANITARIA

Percorso: Vendite - Tessera Sanitaria - Preparazione file XML

La funzione consente di preparare un file in formato XML o CSV con le fatture lette dalla tabella di appoggio in cui sono state scaricate con la funzione Estrazione Dati Tessera Sanitaria ed eventualmente variate.

Il modulo necessita dell'installazione dei 2 file: SanitelCF.cer e openssl.exe che vanno copiati nella cartella principale dell'installazione(Es. \AziWin) dalla cartella Varie\TesseraSan contenuta nell'area da cui sono stati installati/aggiornati i programmi (cartella in cui è stato scompattato il file ZIP).
Il programma di preparazione del file XML controlla che tali file siano presenti e, se mancano, lo segnala.

Anno
Anno delle fatture da scaricare

Data documento da: a:
Consente di preparare il file XML con le sole fatture che hanno data documento compresa nell’intervallo.

Nome file XML
Viene proposto un percorso e un nome. L'utente può varialo e il percorso verrà memorizzato nel file INI per successive elaborazioni.

Estrai codici fiscali criptati Si/No
Consente di mettere sul file i codici fiscali dei clienti in chiaro in modo da poter caricare il file su un altro gestionale

Estrai righe a valore 0
Se sul file XML vengono scaricate delle righe a valore 0, possono provocare errore nella trasmissione del file.
Perciò è stata inserita una opzione che consente di NON scaricarle. Tuttavia, se il programma trova delle righe con questa caratteristica, darà un messaggio in modo che l'operatore possa eventualmente controllarle con la gestione.

Tipo Operazione da Estrarre
Inserimento - Variazione - Rimborso - Cancellazione
Questo per consentire di preparare un file con le sole Variazioni o Cancellazioni

Codice fiscale medico o struttura
lo legge dalla tabella ditta e può essere variato

Partita Iva di chi emette fattura
lo pone uguale a quello in tabella ditta, può essere variato

Codice Regione
Codice di 3 caratteri che identifica la Regione di appartenenza del medico o struttura

Codice ASL di appartenenza
Codice di 3 caratteri che identifica l' ASL di appartenenza del medico o struttura

Codice SSA
Codice di 5 o 6 caratteri che identifica il medico o la struttura

Campi contenuti nel file CSV
Codice fiscale
Numero documento
Data documento
Data ultimo incasso
Importo documento
Tipo spesa 1
Importo 1
Tipo spesa 2
Importo 2
Tipo spesa 3
Importo 3
Numero fattura rimborsata
Data fattura rimborsata


FINE ANNO (VENDITE)

All'inizio di un nuovo anno solare, al fine di poter numerare correttamente le fatture che si andranno a stampare (ricominciando da 1), è indispensabile eseguire la funzione Cambio Anno dal menu di contabilità.

Per quanto riguarda la movimentazione corretta dello scarico di magazzino, dovrà invece essere eseguito il Cambio Anno dal menu di magazzino.


PREVENTIVI

Questo modulo consente di preparare delle offerte (preventivi) per i clienti che potranno, se confermati, essere trasformati parzialmente o integralmente in ordini i quali, a loro volta, daranno origine, in evasione, a Ddt o Fatture.

Nel momento dell'evasione di un preventivo in ordine, l'utente può decidere se generare in automatico anche l'ordine di acquisto della merce per la quantità totale in ordine, solo per gli articoli in sottoscorta o solo per quelli esauriti.

La stampa dei preventivi è completamente parametrizzabile dall'utente tramite la creazione di filtri (modelli) di stampa.

L'interfaccia con la quale vengono inseriti Preventivi, Ordini, Ddt e Fatture è la stessa in modo da facilitare l'operatività.

Vedi anche Ordini di vendita.

Come impostare i dati per cominciare ad utilizzare la procedura.

  • Anagrafica ditta
  • Parametri comuni di Magazzino, di Ordini e Preventivi.
    La creazione, nelle singole tabelle, dei codici obbligatori (Es. Tipi documento), può essere fatta direttamente dalla maschera della richiesta parametri aprendo la lista di aiuto sui codici (tasto F2 o click sul quadratino posto a fianco ad ogni codice) e premendo il pulsante [image] (X) Gestione archivio


NUMERATORI PREVENTIVI

Percorso: PrevOrdi - Gestioni

La tabella riporta, per ogni anno, il numero progressivo dell'ultimo preventivo stampato.


PREVENTIVI

Percorso: PrevOrdi - Preventivi

La funzione consente di preparare, gestire e stampare dei preventivi per i clienti.

Tali preventivi potranno essere trasformati in Ordini oppure evasi direttamente in Ddt e Fatture.

E' possibile gestire in automatico il contributo Raee, per gli articoli per il quali è previsto.

Parametro di personalizzazione per stampa righe descrittive: DoveStampoRigaDesc

Per quanto riguarda gli altri parametri di personalizzazione gestiti, la descrizione dettagliata dei campi gestibili e l'operatività si rimanda alla gestione Ordini di Vendita.


EVASIONE PREVENTIVI

Percorso: PrevOrdi - Preventivi

Il programma consente di generare ordini o Ddt o fatture a partire da preventivi precedentemente inseriti.

E' possibile evadere un preventivo con corrispettivo (nel caso la merce venga consegnata con scontrino e non con ddt o fattura), lasciando bianco il campo "documento di evasione" e spuntando "Evasione con corrispettivo". In questo caso verrà creato un movimento di magazzino con la causale che è stata scritta tra le caratteristiche del tipo documento "preventivo" che si sta evadendo, nel campo: "Causale evasione con corrispettivo".

L'evasione potrà essere manuale, una volta stabiliti quali preventivi evadere è l'operatore che sceglie uno per uno quali righe e con quali quantità, oppure automatica, una volta stabiliti quali preventivi evadere il programma fa l'evasione di tutti, senza interagire con l'operatore.

Se il preventivo è in valuta, durante l'evasione viene chiesto il cambio, in basso a destra nel video, per poter aggiornare il valore dell' ordinato. Il valore di cambio digitato, viene scritto sulla testata dell'ordine generato.

Durante l'evasione di un preventivo è possibile far generare al programma gli ordini di acquisto degli articoli contenuti in esso.

A tal proposito l'operatore ha diverse possibilità:

  • Non generare gli ordini di acquisto
  • Generarli per tutti gli articoli in preventivo
  • SOLO per gli articoli in sottoscorta
    se la giacenza è 22, scorta minima 0 e nel preventivo c'è una quantità di 30, l'ordine al fornitore verrà fatto con quantità 8, se scorta minima 10, l'ordine sarà di 18.
  • SOLO per gli articoli esauriti
    se la giacenza è 22 e nel preventivo c'è una quantità di 30, l'ordine al fornitore verrà fatto con quantità 8 cioè con la quantità che manca a raggiungere quella da evadere.

Nello stabilire la quantità dell'ordine di acquisto si può tener conto o meno, a scelta dell'operatore, dell'ordinato da cliente e a fornitore.
Il programma presenta questa opzione impostata a No, si può attivare il parametro di personalizzazione CreaOrdAcq per impostare una delle altre scelte

Il fornitore dell'ordine (o ordini) generato è letto dall'anagrafica articolo.

Parametri di personalizzazione gestiti da questa funzione:

NotaSoSotAttEEva
Consente, se impostato a S, di copiare sul documento di evasione dell'ordine il flag ' Dove stampo le note o righe descrittive' così com' è sull'ordine se è impostato 'anche documento di evasione'


CANCELLAZIONE ORDINI E PREVENTIVI

Percorso: PrevOrdi - Servizio - Utilità

Questa funzione consente di eliminare fisicamente dagli archivi gli ordini di vendita, di acquisto e i preventivi di un certo anno.

Attenzione: i progressivi dell'ordinato non vengono assolutamente variati dall'esecuzione di questa utility per cui occorre valutare se servirà ricalcolarli o no con l'apposita funzione.

Questo programma può essere utilizzato per pulire un archivio sul quale sono stati inseriti dei documenti di prova (occorrerà poi eseguire l'azzeramento dei progressivi dal magazzino!) oppure, con l'opzione 'Solo Evasi', per eliminare i documenti vecchi già evasi (in questo caso non dovrà seguire nessun'altra operazione).


CARICO ORDINI DA FILE

Percorso: Ordini - Servizio

La funzione consente di importare sul database corrente gli Ordini scritti su un file sequenziale in un formato 'predefinito'.
Il file può essere stato creato da un'altra procedura o scaricato da un altro database con la funzione: Scarico Ordini su file esterno.

Il file contenente gli ordini da caricare deve avere estensione .ORD (Es. xxxxxx.ORD con xxxxxx libero) . Il programma prevede inoltre che ci sia un altro file dal nome xxxxxxTab.Ord contenente l'elenco delle tabelle 'collegate' agli ordini da caricare: PianoConti (clienti e conti), Banche, Condizioni di Pagamento

Viene chiesto all'operatore il nome del/dei file dai quali leggere gli Ordini.

Se il caricamento va a buon fine, al termine i due files letti verranno rinominati in .OLD.

Il programma carica prima le tabelle presenti nel file xxxTab.Ord (Clienti, banche, articoli, spese, codici iva, condizioni di pagamento etc.)
I codici presenti nel file delle tabelle da caricare verranno sempre inseriti se non sono già presenti sulla tabella di destinazione mentre se esistono, verranno aggiornati SOLO i campi come indicato sulla tabella Appoggio dell' AziMenu.mdb (in particolare si potranno aggiornare, in questo modo, i dati anagrafici dei clienti)

Prima di caricare gli ordini il programma controlla l'esistenza di tutti i codici da caricare: clienti , articoli, etc. Se ad esempio trova che su una riga di ordine c'è un codice articolo che manca nella tabella articoli, ne da segnalazione e chiede se proseguire il controllo elencando eventuali altri codici mancanti. Solo se tutto risulta corretto prosegue con il caricamento.

E' possibile inserire con la gestione Tabelle Trascodifiche varie, per ogni tabella da caricare (Spese, Codici Iva, Condizione di pagamento etc.), un elenco di corrispondenze tra i codici letti dal file e quelli creati nel database corrente. In questo modo si consente di poter mantenere sulla procedura che prepara le tabelle, una codifica diversa (es. il codice iva per l’ esente art. 15 può essere ‘Art.15’ sul file da caricare e ‘E15’ in AziWin).
Per velocizzare il caricamento, è bene attivare il parametro di personalizzazione TabTrascod, con l'elenco delle tabelle per cui cercare dei codici corrispondenti in Trascodifica.

Vengono inoltre utilizzati alcuni parametri di personalizzazione: CarOrdGruppoDef, CarOrdMastroDef, CarOrdOrdRic, CarOrdContoKeyBase, CarOrdContoDesSin per la codifica dei clienti
CarSpeseBan Se vale S negli ordini carica e calcola le spese bancarie e anche i bolli.

Dopo aver caricato/aggiornato le anagrafiche, prima di effettuare il caricamento degli ordini, il programma controlla se nel database corrente sono presenti tutti i clienti, articoli, codici spesa, codici di pagamento, codici iva che sono negli ordini da caricare. Nel caso manchi qualche codice, questi verranno segnalati e NON verrà fatto il caricamento.

Lo stato dell'ordine viene impostato sempre 'bianco' e per tutti gli articoli presenti sull'ordine viene incrementato il progressivo ordinato nel magazzino in cui l'ordine è stato caricato, scritto in testata.
Se NON si vuole incrementarli occorre impostare il campo ' Causale per aggiornamento magazzino' sul tipo documento utilizzato per gli ordini, una causale di magazzino dove nel campo Carico/Scarico sia stata scelta l'opzione 'Niente'.

Note per caricamento di Fatture ProForma da CSS Paghe
Occorre creare su AziWin l' unità di misura NR per gli articoli
Per identificare in stampa gli articoli che di fatto sono Anticipazioni che il consulente fa per conto del cliente e poterli stampare come CONTRIBUTI, nel filtro utilizza il codice iva FC (Fuori campo iva) , per cui occorre creare un codice iva FC
Banche: il codice banca sarà AbiCab
La condizione di pagamento e il codice iva che sono sul cliente vanno impostati nella tabella di trascodifica se non c'è corrispondenza tra quello che è sul file e quello di AziendaPC (Su file c'è codice iva 22 per il 22%, E15 per esenti art.15, EXX per altri esenti (XX=cod.esenzione), FC per contributi anticipati per conto del cliente
Condizioni di pagamento: quelle utilizzate nelle paghe sono codici molto lunghi per cui occorre creare in tabelle trascodifica la corrispondenza con il codice di AziendaPc
esempio: sul file si trova il codice: 4-2-30/60 , il codice di AziendaPc RB36FM - Ricevuta Bancaria 30/60 FM
Spese
I codici spesa dovranno preventivamente essere creati in AziendaPc, in particolare la Spesa Cassa Previdenza che viene passata sempre con codice CPA .
La Spesa deve essere definita in Percentuale e con Tipo evasione: Singola e la percentuale corretta.
Poiché tale spesa viene caricata da file, NON serve mettere il codice in Tabella delle Causali Comuni.
Se i codici spesa utilizzati nelle paghe sono diversi da quelli di AziendaPc, si dovranno inserire le corrispondenze nella tabella trascodifiche.

L'ordine verrà caricato con il 'tipo documento' FP: Fattura ProForma (da creare come tipo documento Ordine)

Note tecniche su come impostare il file degli Ordini per il Caricamento

Struttura delle tabelle da caricare:

Clienti:
se il programma trova nei dettagli, i campi GruppoVen e MastroVen NON compilati, e ContoVen compilato, cercherà in PianoConti con Conto = CodTrascodifica e compilerà i campi sul dettaglio dell’ordine, se invece anche ContoVen NON è compilato, compilerà il campo del dettaglio ordine prendendo il conto di ricavo dall’articolo o dalla tabella dei Conti Comuni.

I campi dei clienti che non vanno caricati tali e quali ma che sono codici da cercare sulla tabella di trascodifica per poi scaricare il ‘nostro codice’(es. cond.pagamento, spese) vanno indicati con un – (meno) davanti al numero che identifica il tipo di campo, seguito dal nome della tabella da cercare in TabTrascodifica (vedi Pagamenti e Iva)


RIPRISTINO DA INTERRUZIONE IN ELAB. PREVENTIVI

Percorso: PrevOrdi - Servizio

Vedi Ripristino da interruzione in elaborazione Ddt.


ORDINI DI VENDITA

Il modulo consente di caricare l'ordine del cliente (eventualmente derivato da un preventivo), di stampare la conferma d'ordine e le statistiche dell'ordinato.

Con l'evasione dell'ordine verrà generato in automatico un nuovo documento (Ddt o Fattura), oppure verrà semplicemente creato il movimento di scarico del magazzino (a seconda del tipo di evasione richiesto).

L'interfaccia con la quale vengono inseriti Preventivi, Ordini, Ddt e Fatture è la stessa in modo da facilitare l'operatività.

Se è stato installato il modulo della distinta base, codificando in modo opportuno il tipo documento Ordini, il programma incrementerà il progressivo ordinato anche degli eventuali componenti degli articoli inseriti nell'ordine.

Per ulteriori informazioni vedere il capitolo Vendite.

Come impostare i dati per cominciare ad utilizzare la procedura.

Qualsiasi sia la procedura da utilizzare, occorre andare nel Menu Parametri e Utilità poi eseguire Dati Generali Azienda e compilare tutti i parametri comuni e quelli delle procedure da utilizzare.

Successivamente compilare, dal menu Archivi comuni, le anagrafiche e le tabelle della procedura Ordini.


TABELLE ORDINI DI VENDITA

I programmi presenti in questo menu consentono di inserire tutti i dati ai quali si farà poi riferimento nell'inserimento degli ordini di vendita.

La tabella più importante in assoluto è quella dei Tipi documento in quanto contiene i codici e le caratteristiche degli ordini che si andranno ad emettere.

Nei programmi, ogni volta che viene chiesto un codice di una tabella di riferimento, è possibile, tramite un pulsante posto sulla lista di aiuto, accedere alla funzione che consente di creare il codice se questo non esiste.

Tipi documento


NUMERATORI ORDINI

Percorso: PrevOrdi - Gestioni

La tabella riporta, per ogni anno, il numero progressivo dell'ultima conferma d'ordine stampata.


ORDINI

Percorso: PrevOrdi - Ordini

La funzione consente di inserire, variare, cancellare o visualizzare gli ordini di vendita.

A differenza di quanto avviene per Ddt e Fatture, è possibile inserire un ordine di un cliente 'manuale' cioè che non si vuole creare in archivio clienti, lasciando bianco il codice cliente e compilando manualmente i dati anagrafici.

Gli ordini con cliente manuale potranno essere evasi SOLO come corrispettivo (chiusura dell'ordine e scarico merce) e non in un documento Ddt o fattura.

E' possibile gestire in automatico il contributo Raee, per gli articoli per il quali è previsto.

Gli articoli coinvolti in un ordine, possono essere caricati da un file esterno oltre che digitati manualmente (Caricamento dettagli documenti da file)

Una volta confermato un ordine, verrà automaticamente aggiornato il progressivo impegnato degli articoli in esso inseriti.
L'aggiornamento del progressivo NON viene fatto se nella definizione del tipo documento dell'ordine è stata impostata in 'causale che aggiorna il magazzino' una causale di magazzino nella quale il campo 'tipo movimento' è impostato a Ordine e il campo 'carico/scarico' a Niente

Quando si stampa un ordine, gli viene semplicemente assegnato un numero progressivo, se ancora non ce l'ha e non si fanno altre elaborazioni, per questo la stampa definitiva dell'ordine non è obbligatoria.

Per inserire un nuovo Ordine occorre accertarsi di aver precedentemente creato, con l'apposita gestione, il Tipo di documento opportuno, digitare 0 nel campo Numero Riferimento, compilare i campi della testata poi premere il pulsante [image] (E) Gestione Dettagli, o Salva, per passare all'inserimento dei dettagli (articoli).

E' consentita la ricerca di un ordine digitando uno o più campi della testata e premendo il pulsante di Ricerca. Se esiste un unico ordine con le caratteristiche impostate, verrà visualizzato mentre, se ne esiste più di uno, verrà proposto un elenco.

Variazione: un ordine evaso NON è modificabile, per farlo occorre cancellare i documenti con cui è stato evaso.

Sulla testata di un ordine parzialmente evaso sono modificabili: condizioni di pagamento, banca, sconto cliente e sconto pagamento, flag di cliente con iva ad esigibilità differita.

Su una riga parzialmente evasa, se non sono attivi taglie e colore, si consente la variazione dei colli e della quantità (non dell'unità di misura e del fattore di conversione) purchè con un valore maggiore della quantità già evasa; viceversa con taglie e colori attivi, una riga parzialmente evasa non può essere variata.

Cancellazione: un ordine non può essere cancellato se è parzialmente o totalmente evaso.

L'ordine può essere stampato direttamente dalla gestione premendo il pulsante [image] (T) sTampa oppure con l'apposito programma di stampa di Stampa Ordini.

Quando si è in testata di un ordine è abilitato il pulsante [image] (D) Duplica Esso consente di generare un ordine con le stesse caratteristiche di quello su cui si è posizionati ma sempre completamente NON evaso.

Ogni Ordine si compone di due gruppi principali di dati: la testata (dati del cliente, note, dati di accompagnamento, spese) e il dettaglio (elenco degli articoli).

Per ulteriori spiegazioni sui pulsanti, si rimanda a Gestione movimenti e documenti.

Parametri di personalizzazione gestiti da questo programma:
InizioAvvisoCliente
Se impostato con qualche carattere (es. $$), il programma stamperà un avviso sulla maschera del cliente se la nota in anagrafica cliente/fornitore inizia con questi caratteri.

Testata Ordine

Nr.Riferimento, anno
Servono per identificare un ordine appena inserito e cioè prima che venga assegnato ad esso il numero documento (fase di stampa).
Attenzione: è un numero interno che non va confuso con numero documento!

Se viene digitato un numero e si preme il pulsante Ricerca, il programma va in ricerca del documento con quel numero. Impostando il numero a 0 si entra in modalità inserimento e viene assegnato un numero progressivo nell'anno, automaticamente dal programma.

Inserito il
È la data in cui viene inserito l'ordine. Tale data può essere variata, se l'ordine non è né parzialmente né totalmente evaso, purchè la nuova data sia sempre compresa nello stesso esercizio di magazzino della precedente.

Tipo documento
Identifica le caratteristiche del documento inserito. Viene proposto quello scritto nella tabella Preventivi-Ordini. Dal tipo documento vengono lette alcune caratteristiche es. il listino, il magazzino di scarico e in particolare come aggiornare i progressivi dell'articolo. A differenza di quanto avviene per gli altri documenti, se nel tipo documento Ordine non è stata collegata una causale di magazzino, viene ugualmente aggiornato l'ordinato dell'articolo, per non aggiornarlo occorre collegare una causale di magazzino che abbia il campo Carico/Scarico posto a 'Niente'

Questo campo non si può variare se ci sono dei dettagli.

Numero e data documento
Vengono assegnati al momento della stampa dell'ordine, prendendo il progressivo dalla tabella dei Numeratori Ordini in base all'anno.

Non si consente di stampare ordini con data di stampa inferiore alla data dell'ultimo ordine stampato in precedenza.

Viene data la possibilità di impostare manualmente questi due campi, in questo caso il programma controlla la sequenza della numerazione e segnala le eventuali anomalie.

Aperto
Indica se l'ordine è un ordine 'aperto' cioè che non deve essere posto ad evaso anche una volta fatta l'evasione. Può essere utilizzato in ordini creati a fronte di consegne ripetitive.

Nella tabella tipi documento, dove si definisce il tipo Ordine, è possibile assegnare un valore di default a questo campo. In pratica è possibile creare un tipo documento ordine nel quale venga sempre impostato a Si il flag di aperto, in creazione dell'ordine.

Cod. Cliente
E' il codice del cliente per cui si sta inserendo l'ordine.
E' possibile inserire un ordine di un cliente 'manuale' cioè che non si vuole creare in archivio clienti, lasciando bianco il codice cliente e compilando manualmente i dati anagrafici.
Gli ordini con cliente manuale potranno essere evasi SOLO come corrispettivo (chiusura dell'ordine e scarico merce) e non in un documento Ddt o fattura.

Se si inserisce il codice di un cliente esistente, verranno visualizzati i dati anagrafici letti da archivio.

Le due 'parti' di ragione sociale vengono visualizzate con il seguente criterio (che è lo stesso utilizzato per la stampa dell'intestazione dei documenti): 1' parte è la 1' parte della Ragione Sociale del cliente, se sull'anagrafica cliente questa risulta non compilata, si prende la Ragione Sociale Contabile; 2' parte: si mette comunque il contenuto della seconda parte della Ragione Sociale cliente.

Di seguito vengono visualizzati:
indirizzo, Iso, P.Iva, Cod.Fiscale, Telefono
Se sul cliente è compilata la data di chiusura viene visualizzata la scritta CHIUSO di fianco alla Ragione sociale.

Se sul tipo documento è compilato il campo 'giorni per controllo scaduto (X)', verrà data una segnalazione se il cliente ha delle scadenze aperte da più di X giorni.

Se si varia il cliente: verrà visualizzato il listino del nuovo cliente se prima il listino veniva da cliente con tutti i controlli di cambio listino e inoltre, se la variazione comporta una variazione della riga di spese bancarie, esse verranno ricalcolate in automatico.

Rif. Cliente
Campo descrittivo.

Descrizione
In questo campo è possibile descrivere l'ordine e può essere utilizzato per individuare l'ordine al momento dell' evasione.

Stato
Indica lo stato dell'Ordine. Il campo è bianco se l'ordine è appena inserito, viceversa può contenere le scritte Parzialmente Evaso (nel caso che solo qualche riga di dettaglio si a stata consegnata) o Evaso. La stampa della conferma d'ordine non mette lo stato di stampato sull'ordine ma assegna solo il numero e la data documento.

Sotto i dati di Testata vengono visualizzati i seguenti totali:
Tot. Spese Tot. Merce Tot. Imponibile Tot. Iva Totale Documento
E, se sono state inserite delle righe di dettaglio, ne viene fatto l'elenco sintetico.

Cliccando sulle etichette delle varie cartelle proposte sotto l'anagrafica del cliente, (o digitando Alt e il numero corrispondente) si può accedere ad altri dati.


ORDINI (1) DATI CLIENTE

Percorso: PrevOrdi - Ordini - Ordini di vendita

Listino
Codice listino. In generale è il codice di listino letto dall'anagrafica cliente. Se però sul Tipo Documento utilizzato è stato impostato un listino particolare, verrà visualizzato quest'ultimo. Nel caso che la causale per l'aggiornamento del magazzino, posta sul tipo documento, preveda che il prezzo da proporre sui dettagli debba venire dal costo ultimo o dal costo medio invece che da un listino, questo campo verrà lasciato bianco.

In presenza di un listino, la moneta del documento è quella del listino e i prezzi verranno intesi 'ivati o meno' a seconda di quanto specificato sul listino stesso.

Quando ci sono già dei dettagli inseriti, si consente di variare il codice listino a condizione che il nuovo abbia la stessa moneta e lo stesso valore nel flag 'prezzi ivati o no'.

Da un listino in lire si può passare a uno in euro e viceversa purchè abbiano lo stesso valore del flag 'prezzi ivati o no', ma non viene cambiata la moneta iniziale (sul listino c'è sempre il prezzo in lire e in euro).

Il nuovo listino varrà per i dettagli inseriti successivamente. Per assegnare il prezzo di listino nuovo sulle righe di dettaglio preesistenti occorre andare su ogni riga e premere il pulsante [..] posto a fianco a prezzo e a sconti.

Prezzi ivati
Indica come sono i prezzi sul documento se netti o comprensivi di iva. Viene impostato con il valore letto dal listino e, in inserimento, può essere variato dall'utente.
In questo modo un listino ivato in origine può essere utilizzato come non ivato e viceversa in quanto ci pensa il programma a ivare o scorporare il prezzo in base a questo flag.

Condizione di Pagamento
Viene proposta quella del cliente e può essere variata per il documento in oggetto. Se la condizione richiamata prevede uno sconto pagamento, questo verrà visualizzato a fianco.
Esiste però la possibilità di impostare, sul tipo documento, quale condizione di pagamento utilizzare: o una particolare, il cui codice andrà scritto sul tipo documento stesso, o la seconda condizione scritta sul cliente.

Sconto Pagamento
Viene proposto il valore letto sulla condizione di pagamento del cliente.
Se viene variato, o cambia perché è variata la condizione di pagamento, viene ricalcolato il totale documento.

Sconto pagamento su dettaglio (S/N)
Se impostato a SI, l'eventuale sconto pagamento, verrà sommato agli sconti delle singole righe, piuttosto che essere calcolato sull'imponibile/i alla fine del documento. Si può impostare il parametro ScontoPagInDet per assegnare un valore di default al campo.

Sconto Cliente
Viene proposto il valore letto dall'anagrafica del cliente.
E' consentita la variazione solo se l'ordine non è parzialmente evaso. Se viene variato e sono già stati inseriti degli articoli sul documento, verrà chiesto se si vuole riportare il nuovo sconto sui dettagli. In caso affermativo verrà sostituito su ogni dettaglio in cui lo sconto cliente ha il valore vecchio, il nuovo valore e verrà ricalcolato lo sconto totale e l'importo di riga.

In particolare se viene messo uno sconto dove prima non c'era, questo verrà riportato in tutti i dettagli dove lo sconto cliente era vuoto.

Banca
Viene proposta quella del cliente e si può variare.
La ricerca del codice banca, oltre che per codice e descrizione, anche per ABI o ABI e CAB digitando l' ABI (completo o incompleto con * finale) oppure ABIçCAB (il carattere ç deve essere sempre scritto in fondo all'abi anche se non si mette anche il cab) e premendo il tasto F2 (lista per codice) o F3 (lista per descrizione).

Raggruppamento Ricevute Bancarie
Viene visualizzato il segnale inserito sul cliente.
Indica se in fase di compilazione distinte le ricevute bancarie del cliente devono essere raggruppate.

Codice Iva
Viene visualizzato il valore impostato in anagrafica del cliente. Indica il codice di esenzione a cui è soggetto il cliente e che deve prevalere sull'aliquota dei vari articoli. Può tuttavia contenere anche un codice 'iva'. Se valorizzato, viene assunto come codice iva di ogni articolo che verrà inserito nel corpo del documento e non sarà possibile varialo.

Tale codice verrà impostato anche sulle eventuali righe di spesa, con possibilità di variazione.
Se viene variato il codice iva e ci sono delle righe di dettaglio (righe articolo) e/o spese, si chiede se si vuole aggiornare il codice iva su tutti i dettagli. Se il campo in testata è valorizzato e lo si sbianca, non viene fatta nessuna variazione sui codici iva dei dettagli.

Perc.Riten.acconto
E' l'eventuale percentuale di ritenuta acconto che verrà utilizzata per il calcolo della ritenuta d'acconto da evidenziare sulla fattura e per la registrazione del relativo movimento durante la contabilizzazione.

Iva sospesa
Viene visualizzato il valore letto dall'anagrafica cliente con possibilità di varialo. Consente di emettere al cliente una fattura con iva differita o immediata.

Magazzino
E' il codice del magazzino dal quale scaricare gli articoli. Viene proposto quello scritto sul tipo documento o, se lì è bianco, si prende il magazzino principale dalla Tabella di Magazzino. In caso di fattura riepilogativa con raggruppo delle bolle per magazzino, questo campo non verrà visualizzato.

Consegna totale
Se impostato a SI indica che l'ordine non è evadibile parzialmente. Questo campo non può essere variato se l'ordine è evaso parzialmente.

Data prevista consegna
Se è impostata in testata dell'ordine vale per tutte le righe. Se per qualche riga è richiesta una data di consegna diversa, questa dovrà essere specificata sulla singola riga.

Bene usato
Se il tipo documento prevede la gestione del regime del margine (cioè si sta facendo un ordine per la vendita di un bene usato) in questo campo va inserito il codice del bene. Serve per poterlo passare in fattura poi in contabilità e scrivere sul Registro di vendita dei beni usati la natura del bene.

Dichiarazione di intenti
Vedi Dichiarazione di intenti in inserimento fattura

Parametri di personalizzazione:

InizioAvvisoCliente
Per visualizzare un messaggio in caso di presenza della nota clienti


ORDINI (2) ALTRI DATI

Percorso: PrevOrdi - Ordini - Ordini di vendita

Moneta
E' la moneta del listino. Se non c'è un listino la moneta è quella principale. Si può variare solo in inserimento della testata del documento.

Cambio
Indica il cambio della moneta del documento rispetto l'Euro.
Nel momento dell'inserimento, se la moneta è Lire, Euro o altra moneta dell' UEM, il cambio verrà impostato automaticamente (letto dalla tabella cambi) e non sarà possibile variarlo.

Per ogni altra moneta il cambio verrà cercato nell'archivio cambi con data minore o uguale alla data di inserimento. Questo cambio potrà tuttavia non essere definitivo in quanto verrà chiesto di nuovo al momento dell'evasione e reso definitivo al momento della Stampa fattura.

Prezzi in stampa
Normalmente la stampa di Preventivi e Ordini riporta i prezzi se sul filtro è stata prevista la stampa delle variabili corrispondenti ai campi: prezzo unitario, sconto, totale di riga.
E' possibile impostare il parametro di personalizzazione UsaFlagPrezziOrd in modo che la stampa dei prezzi sia fatta a seconda di quanto impostato nel campo Prezzi in Stampa.
Nell' inserimento di un Preventivo o un Ordine, questo campo viene impostato come previsto sul corrispondente campo del Tipo documento utilizzato.
I casi possibili sono:

  • NO prezzi
    In ogni caso non verranno stampati sul documento la banca del cliente e la descrizione della condizione di pagamento.
  • Prezzo di listino, sconti e totale di riga (scontato)
  • Prezzo di listino
  • Prezzo al netto degli sconti e totale di riga (scontato)
  • Prezzo, sconti e totale di riga ivato
  • Prezzo scontato e ivato - totale di riga ivato
  • Prezzi Ivati,Sconti,Tot.Ivato

Nell'evasione dei preventivi questo campo (PrezzoOrd) NON viene portato direttamente sul campo corrispondente del documento di evasione ma:

  • se si evade in Ordine , il corrispondente campo, viene compilato con il valore assegnato allo stesso campo nel 'tipo documento' dell'ordine generato
  • se si evade in Ddt, il campo PrezzoDDT della testata del Ddt viene compilato con il valore assegnato allo stesso campo nell'anagrafica del cliente

Addebito bolli
E' una caratteristica letta dall'anagrafica clienti e solo visualizzata. Indica se addebitare o no il costo dei bolli per effetti, sulla fattura.

Addebito spese bancarie
Viene visualizzato il valore impostato sul cliente e non si consente la variazione. Indica se addebitare o no in fattura le spese bancarie in caso di condizione di pagamento che lo preveda.

Raggruppo ordini
Indica se l'ordine deve essere evaso da solo o insieme ad altri compatibili. Viene proposta l'impostazione data al campo in anagrafica cliente.
Le possibilità sono:

  • Si
    Raggruppa sempre
  • No
    Ogni evasione genera documenti diversi
  • A parità di Ordine
    Consente di raggruppare in un' unico fattura i ddt generati dallo stesso ordine
  • A parità di Contratto
    Consente di generare un'unica fattura a fronte di ordini (ddt) che fanno riferimento allo stesso contratto.

Di seguito vengono elencate le condizioni per cui più ordini, anche con 'raggruppo' impostato a SI, possono essere evasi in un unico documento (ddt o fattura):

  • Cliente
  • Moneta
  • Magazzino
  • Lingua
  • Condizione di pagamento
  • Sconto pagamento
  • Banca
  • Ragguppamento ricevute
  • Codice iva
  • Agenti
  • Flag prezzi ivati
  • Iva normale o ad esigibilità differita
  • Contratto
  • Cig e Cup
  • Vettore
  • Cod.indirizzo di spedizione
  • Indirizzo di spedizione
  • Cod.Resa
  • Cod.dichiarazione di intenti

Contratto
Se il documento si riferisce a un contratto, è possibile associarne il codice. Esso verrà riportato sul ddt e/o fattura che evaderanno l'ordine.

CIG e CUP
Sono rispettivamente il Codice Identificativo di Gara e Codice Unico di Progetto. Possono essere digitati direttamente sul documento o venire dal contratto.
Se si imposta un codice contratto sul quale sono stati inseriti i codici Cig e Cup, questi verranno riportati sul documento SOLO se non sono già impostati.
Se si sbianca il codice contatto, sul documento i codici Cig e Cup eventualmente già impostati perchè letti dal contratto inserito in precedenza, non verranno sbiancati.
Potranno essere stampati sul documento e verranno poi riportati su ddt e/o fattura che evaderanno l'ordine.

Estrazione provvigioni
Viene proposto il valore letto sull'anagrafica cliente: NO, da Articolo, da Cliente, da Agente.
Se si varia questo campo e ci sono dei dettagli già inseriti, verrà fatta la richiesta se portare il nuovo valore su tutti i dettagli o solo su quelli per cui la percentuale coincide con la vecchia percentuale in testata.
La richiesta non viene tuttavia fatta se il campo viene impostato a NO o a 'da Articolo'.

Agente 1 , Agente 2 - % Provv. 1 e 2
Vengono proposti i codici agenti letti dall'anagrafica cliente e le rispettive percentuali, lette dall'agente o dal cliente a seconda di come è impostato il campo: Estrazione Provvigioni.
Se è sull'agente verranno visualizzate le % dei due agenti con possibilità di variazione
Se si varia questo campo e ci sono dei dettagli già inseriti, verrà fatta la richiesta se portare il nuovo valore su tutti i dettagli o solo su quelli per cui la percentuale coincide con la vecchia percentuale in testata.

Lingua
Codice lingua letto dall'anagrafica cliente. Verrà utilizzato, compilato, per stampare sul documento le descrizioni degli articoli in lingua piuttosto che quelle in italiano.

Codici Note Fisse
Vengono proposti i codici letti dal tipo documento. Sono note fisse, scritte nel rispettivo archivio, che possono essere stampate sul documento. Verranno portate, solo se la nota lo prevede, sul documento di evasione, con un massimo di tre.


ORDINI (3) NOTE DI TESTATA

Percorso: PrevOrdi - Ordini - Ordini di vendita

Si consente di inserire delle righe di testo e di scegliere se stamparle o meno sul documento. Sarà poi con il filtro che si stabilisce dove stamparle (se in testa o nel piede).


ORDINI (4) DATI DI ACCOMPAGNAMENTO

Percorso: PrevOrdi - Ordini - Ordini di vendita

Questi dati vengono in parte letti dall'anagrafica del cliente e possono essere variati sul singolo ordine.

Per scrivere indirizzo, vettore etc. direttamente sull'ordine, senza averli prima inseriti sui rispettivi archivi, basta via via sbiancare il codice corrispondente e scrivere direttamente negli spazi a fianco.

Questi parametri, se inseriti, contribuiscono a consentire di raggruppare o meno in evasione un gruppo di ordini.

Destinatario (Indirizzo di spedizione)
Viene proposto il codice dall'anagrafica del cliente ma è possibile anche inserirne uno valido solo per questo ordine.

Se sull'indirizzo di spedizione in archivio, è stato impostato a Si il campo Indirizzo Principale per Fattura, la stampa Ddt invertirà l'indirizzo del cliente e l'indirizzo di spedizione e ignorerà l'indirizzo amministrativo.

Vettore
Viene proposto il codice vettore scritto sul cliente.

Porto (Resa)
Viene proposto il codice inserito sul cliente (porto franco, porto assegnato).

Tipo Trasporto
Viene proposto il codice inserito in tabella di fatturazione (posta, corriere,..)


ORDINI (5) NOTA CLIENTE

Percorso: PrevOrdi - Ordini - Ordini di vendita

In inserimento, in questo quadro vengono visualizzate alcune informazioni del cliente: il contenuto dell'eventuale nota scritta sull'anagrafica, il segnale di rischio, fido e lo scaduto alla data del documento (letto dalle scadenze aperte).

In variazione del documento si può rileggere lo scaduto premendo il pulsante [..] posto a fianco di Pagamenti scaduti.

Inoltre in questo quadro vengono proposti i campi 'liberi': es. Modello, Targa (se sono state impostate le rispettive descrizioni in tabella di fatturazione).

Questi campi, se valorizzati, verranno essere riportati nel corpo dei documenti con cui verrà evaso l'ordine.


ORDINI SPESE

Percorso: PrevOrdi - Ordini - Ordini di vendita

Vedi Fatture Spese


ORDINI (6) DOCUMENTI DI EVASIONE

Percorso: PrevOrdi - Ordini - Ordini di vendita

In questo quadro è possibile consultare i riferimenti ai documenti che hanno evaso l'ordine. Nel caso che l'ordine abbia generato ddt e che questi siano già stati fatturati, verranno riportati anche gli estremi delle fatture


ORDINI DETTAGLI

Percorso: PrevOrdi - Ordini - Ordini di vendita

Una volta inserita la testata dell'ordine si procede all'inserimento dei dettagli premendo il pulsante [image] (E-F10) Gestione Dettagli o Salva.

In questo punto è possibile inserire le varie righe degli articoli in ordine. Le righe possono essere costituite da: articoli presenti in tabella articoli (dovranno essere richiamati con codice), articoli manuali (il codice dovrà essere lasciato vuoto e dovrà essere compilata la descrizione), righe descrittive (per commenti), righe di comando (comandi per la stampa conferma d'ordine).

Il programma si predispone per una riga articolo ma si può passare in modalità Riga descrittiva o Riga Comando rispettivamente con i tasti F8 ed F6 sul codice articolo o premendo i pulsanti relativi.

Su una riga parzialmente evasa, se non sono attivi taglie e colore, si consente la variazione dei colli e della quantità (non dell'unità di misura e del fattore di conversione) purchè con un valore maggiore della quantità già evasa; viceversa con taglie e colori attivi, una riga parzialmente evasa non può essere variata.

Se sono stati abilitati la lettura degli articoli o delle matricole da file (Parametri di personalizzazione LettArtDaFile o LettMatrDafile verranno visualizzate le rispettive icone che consentono la lettura dei dati

(B) Lettura da file Ascii o [image] (Q) Lett.matricole da file
(vedi Caricamento dettagli documenti da file e

Caricamento movimenti di magazzino - matricole da file)

Riga articolo

Cod. Articolo(Ricerca per cod. descr. Cod a barre)
Se il codice articolo viene lasciato bianco si consente di inserire un articolo 'manuale' cioè di compilare manualmente tutti i dati della riga: descrizione, quantità, sconto, codice iva etc. In questo caso non verrà generato nessun movimento di magazzino.

Se invece viene inserito un codice articolo, esso dovrà esistere nella tabella degli articoli di magazzino.

Con F9 si attiva il pulsante per cambio modalità di ricerca dell'articolo (codice/descrizione o codice a barre).
La ricerca dell'articolo avviene con i tasti F2 (codice), F3 (descrizione), F4 (codice a barre), come specificato in Lista di aiuto (ricerca codice)
E' abilitata inoltre la ricerca con i tasti Shift F2 - F3 - F4
Premendo il tasto F8 è possibile inserire una Riga Descrittiva.
Premendo il tasto F6 è possibile inserire una Riga di Comando.

Se si sta facendo la ricerca per codice a barre, è possibile attivare il parametro di personalizzazione: CodBarSalva in modo che, in inserimento, all'uscita del campo articolo venga salvata la riga e si passi ad un altro inserimento. Ovviamente è indispensabile che sull'articolo siano compilati tutti i campi necessari (unità di misura, codice iva etc.).

Dopo aver inserito il codice di un articolo verranno proposti unità di misura, quantità per confezione, prezzo (se codificato), sconti, aliquota iva e conto ricavo letti dall'articolo etc.
Verranno inoltre visualizzate giacenza e disponibilità dell'articolo sul magazzino impostato sulla testata del documento ed eventualmente anche su tutti i magazzini (parametro di personalizzazione: MagaNoGiac)
Se si imposta il parametro SegnDispNeg, verrà data segnalazione, anche acustica, per disponibilità negativa.

Se sull'articolo è stato chiesto di segnalare se è esaurito, verrà data una segnalazione se la giacenza è minore di 0.

Se la riga è parzialmente o totalmente evasa, verrà visualizzata la quantità già evasa.

Se l'articolo ha la gestione dei livelli (taglia-colore) l'inserimento del dettaglio procede come descritto in Dettagli con Livelli.

Descrizione
E' la descrizione dell'articolo richiamato. Se viene modificata verrà memorizzata sul documento per la stampa e l'evasione e verrà visualizzata la nota 'descrizione modificata'.
Se l'articolo è manuale, la descrizione dovrà essere inserita dall'operatore.

Cliccando sulle etichette delle varie cartelle proposte (o digitando Alt e il numero corrispondente), si accede ad altri dati:
Principale
Descrizione aggiuntiva
Riferimento destinazione

E' possibile attivare il parametro di personalizzazione NotaLinguaDove per utilizzare la descrizione lunga in lingua come ulteriore descrizione dell'articolo da copiare nella nota sotto e stampare sul documento.
DisabTermPrz, DisabTermVisPrz:
per disabilitare uno o più terminali rispettivamente alla gestione o alla visualizzazione dei prezzi e degli sconti in gestione.


ORDINI DETTAGLIO PRINCIPALE

Percorso: PrevOrdi - Ordini - Ordini di vendita - Dettagli

Quantità
Non può mai essere lasciata a 0. Viene accettato un numero di decimali pari a quelli specificati in Tabella di magazzino. Se sono stati impostati sull'articolo i pezzi per confezione (con valore maggiore di uno), invece della quantità si possono digitare i colli e la quantità verrà impostata automaticamente (colli moltiplicato per pezzi per confezione), viceversa se si digita la quantità, non verranno ricalcolati i colli.

Se l'articolo ha uno sconto quantità e la quantità viene variata, si chiede se ricalcolare gli sconti.

Si consente di inserire una riga con quantità negativa che dovrà essere evasa completamente in un'unica evasione.
Su una riga completamente evasa è abilitato il tasto F11 con il quale si apre una maschera che consente di inserire una quantità che andrà ad aggiornare la quantità ordinata (ed evasa) della riga. Lo scopo è quello di sistemare, per le statistiche dell'ordinato, la quantità di un articolo di cui ne è stato effettivamente consegnato di più di quanto scritto inizialmente sull'ordine.

Colli
Se il valore dei pezzi per confezione dell'articolo è maggiore di 1, si digita il numero dei colli e il campo quantità è vuoto, viene calcolata la quantità come pezzi per confezione * colli.

Viceversa se si inserisce la quantità e il campo colli è vuoto, questi ultimi vengono impostati automaticamente arrotondando per eccesso.

Per ottenere in automatico il calcolo dei colli sul quadro di accompagnamento, occorre inserire in ogni riga il numero dei colli, anche in articoli 'normali'.

Pezzi per Confezione
Viene visualizzato il valore letto dall'articolo (non modificabile)

Promozione
Solo visualizzato. Indica se è stato impostato per quell'articolo un prezzo promozione.

Prezzo Unitario
Prezzo unitario della riga. Viene proposto il prezzo dell'articolo letto dal listino (se impostato in testata), valido alla data di inserimento del documento.

Nella causale di magazzino collegata al Tipo documento è possibile tuttavia, definire che il prezzo venga prelevato dal costo ultimo o dal medio di carico.

E' possibile infine impostare il prezzo unitario dell'articolo sulle tabelle degli sconti, in questo caso verrà prelevato solo se il documento è in Lire o in Euro.

Se per l'articolo non viene trovato nessun prezzo, nei modi suddetti, ed è stato attivato il parametro di personalizzazione CercaListBase, il programma cerca il prezzo sul listino Base (quello indicato nella tabella di Magazzino, parametri comuni).
Sul campo prezzo possono essere premuti alcuni tasti con il seguente risultato:

  • F2: rilegge dagli archivi il prezzo unitario e ricalcola gli sconti
  • F3: visualizza una lista dei listini validi dell'articolo in oggetto.
  • F7: questo tasto è da utilizzare quando un valore digitato manualmente non è compatibile con il listino e cioè: se si sta utilizzando un listino NON ivato e si ha la necessità di digitare un prezzo ivato, lo si può poi scorporare premendo il tasto F7. Allo stesso modo se utilizzo un listino ivato e, per un articolo, digito un prezzo non ivato, con F7 il programma calcolerà l'iva sul prezzo digitato.

Alla lettura del prezzo di listino da archivio il programma se trova che listino e flag di testata sono 'uguali' cioè indicano entrambi ivato o non ivato, presenta il prezzo così com'è letto mentre se sono diversi provvede a ivare o a fare lo scorporo a seconda dello stato del listino e del flag di testata.

Se il prezzo viene dal listino promozione si visualizza solo lo sconto cliente. In questo caso, anche se si fa il ricalcolo sconti, lo sconto listino viene ignorato in quanto, ricercando il prezzo, vede che viene da promozione .

Se si varia il prezzo gli sconti non vengono variati. Per provocare il ricalcolo degli sconti occorre o premere F2 sul prezzo o premere ricalcolo sconti dal campo sconto totale.

Sconto
E' lo sconto totale a cui è soggetto l'articolo. In presenza di gestione di taglia/colore gli sconti verranno considerati uguali per tutti i livelli di uno stesso articolo. Lo sconto viene dato nella forma x+y+z e a fianco viene calcolato lo sconto risultante.
A fianco dello sconto totale viene visualizzato un pulsante [..] (F2) per il ricalcolo degli sconti.
Il ricalcolo degli sconti può provocare la variazione del prezzo se lo si trova in una tabella sconti e la moneta del documento è lire o euro.
Se sulla riga c'è un prezzo promozione e si fa il ricalcolo degli sconti, viene reimpostato solo lo sconto cliente.
Per ulteriori informazioni vedere modalità di ricerca sconti

Di seguito vengono elencati i vari sconti abilitati sull'articolo in modo da poter capire come è stato calcolato lo sconto finale:

  • Sconto del Cliente
    Viene proposto lo sconto confermato in testata come sconto cliente.
  • Sconto Articolo
    E' il risultato della combinazione tra sconto listino e sconto messo sull'anagrafica articolo.
  • Sconto Tabellare
    E' lo sconto derivato dalle Tabelle di sconto
  • Sconto Quantità
    Viene cercato sulla tabella degli sconti quantità, in base all'articolo e al cliente, e, se valorizzato può sostituire lo sconto tabellare e/o lo sconto cliente.

Indicatore di riga soggetta a sconto pagamento
Viene valorizzato in automatico sempre a Si e può essere variato. Lo sconto pagamento è sulla testata del documento e viene applicato a piede fattura.

Unità di misura
Viene visualizzata l'unità di misura delle vendite dall'articolo

Fattore di conversione
Viene proposto il valore scritto sull'articolo e relativo all'unità di misura di vendita. Può essere variato se si varia l'unità di misura. Serve per calcolare la quantità che andrà ad aggiornare i progressivi di scarico dell'articolo. Se l'unità di misura dell'articolo coincide con quella di vendita, il fattore di conversione dovrà essere uguale ad 1 (non può mai essere posto a 0).

Codice Iva
E' il codice iva vendite dell'articolo. Se però in testata viene impostato un codice iva (esenzione) cui il cliente è soggetto, questo verrà impostato automaticamente su tutti i dettagli senza possibilità di variazione.

Importo di riga
E' l'importo calcolato moltiplicando il prezzo scontato per la quantità della riga. Se si varia o imposta direttamente questo importo e il prezzo unitario è vuoto, quest'ultimo verrà ricalcolato automaticamente, viceversa occorre premere il tasto F7 per ricalcolarlo.

Omaggio
Consente di definire se la riga contiene o no articoli ceduti a titolo gratuito. E' previsto che la gestione dell'omaggio possa essere:

  • omaggio totale: la riga non verrà addebitata in assoluto
  • solo Iva: al cliente verrà addebitata solo l'imposta relativa a questa riga e non l'imponibile

Conto ricavi
E' il conto di ricavo che servirà in fattura per lo scarico contabile dell'importo relativo alla riga.

Viene proposto il conto impostato sull'articolo. Se nell'articolo manca o se articolo manuale verrà proposto quello della tabella conti comuni (da compilarsi tra i parametri ditta).

Se anche in tabella non c'è nessun conto, il problema sorge nel momento della contabilizzazione della fattura, sarà la stampa a chiedere che sia compilata la tabella 'causali e conti comuni'.

% provvigione 1 e 2
Sono le percentuali di provvigione relative ai due agenti impostati sulla testata e assegnate a seconda del Tipo provvigione di ciascuno.

Data consegna
Deve essere impostata se diversa da quella eventualmente messa in testata. Viene utilizzata nella stampa ordini per data consegna.

Quantità evasa e stato
Se la riga è parzialmente o totalmente evasa, viene visualizzata la quantità già evasa. Se è stata evasa a saldo, in quantità evasa c'è la quantità effettivamente consegnata e lo stato è 'evaso'.


ORDINI DETT - DESCRIZIONE LUNGA ARTICOLO E NOTE DI DETTAGLIO

Percorso: PrevOrdi - Ordini - Ordini di vendita - Dettagli

Dove stampo descrizione lunga
Se l'articolo ha una descrizione aggiuntiva, inserita con la gestione articoli, questa può essere stampata o meno sul documento o copiata sulla nota del dettaglio (sopra o sotto) a seconda di come è stato impostato il campo: "Stampa desc.agg.articolo" sul tipo documento.
L'operatore può però variare questo campo.
In fase di evasione dell'ordine, il flag viene copiato con il suo significato originario. Per impostarlo sul documento di arrivo, così come previsto sul tipo documento, occorre impostare il parametro di personalizzazione: StDesLunDaDoc

Nota sopra e nota sotto
Si consente di inserire o variare eventuali note da stampare sul documento 'sopra' e 'sotto' la riga dell'articolo.

Per ciascuna di queste due note si può scegliere di:

  • non stamparla
  • stamparla solo sul documento in oggetto e non su quello di evasione
  • stamparla solo sul documento di evasione
  • stamparla su entrambi i documenti.

E' possibile impostare un valore di default sul campo, tramite i parametri di personalizzazione: DoveStampoSopra e DoveStampoSotto
Se il tipo documento prevede di importare in automatico la descrizione aggiuntiva dell'articolo sulle note, queste verranno precompilate con tale descrizione. In ogni caso, sulle due note, è abilitato il tasto F7 che consente di importarla in automatico anche se non è stato previsto prima.

Altri parametri per la stampa delle note: NotaSoSotAttEEva


ORDINI DETT - RIFERIMENTO DESTINAZIONE

Percorso: PrevOrdi - Ordini - Ordini di vendita - Dettagli

In questo quadro vengono elencati i documenti, Ddt e/o fatture, sui quali è stata evasa, parzialmente o totalmente, questa riga di dettaglio.


ORDINI DETTAGLI CON LIVELLI

Percorso: PrevOrdi - Ordini - Ordini di vendita - Dettagli

Se è prevista la gestione dei livelli (Taglia-Colore) e l'articolo li ha, viene data la possibilità di inserire la quantità per ogni singola unità gestita. Una volta inserito il codice dell'articolo non si può passare direttamente all'inserimento della quantità ma occorre premere il pulsante opportuno, vedi Gestione Livelli a Tabella, in modo da passare alla maschera di Gestione Dettaglio Livelli nella quale dovrà essere specificato per ogni 'livello' da mettere sul documento, la quantità e il prezzo unitario.
Gli sconti vengono considerati a livello di articolo per cui se si varia uno sconto su un 'dettaglio-livello' questo viene riportato su tutte le righe-livello di quell'articolo. Vedi Sconti in Dettagli con Livelli

Se si modifica il codice articolo con livelli sul dettaglio, vengono cancellate tutte le sue righe dei livelli e sarà necessario entrare nella gestione livelli per reinserirle.

Se una riga con livelli è parzialmente evasa, non è più possibile variarla.


ORDINI DETT - RIGA DESCRITTIVA

Percorso: PrevOrdi - Ordini - Ordini di vendita - Riga Dettaglio

Si consente di inserire una frase (una o più righe) che verrà stampata sul corpo dell'ordine e verrà riportata sul documento con cui l'ordine verrà evaso.

Se il Ddt viene da Preventivo o Ordine si può impostare il parametro di personalizzazione NotaSoSotAttEEva per fare in modo che la riga descrittiva venga stampata su tutti i documenti via via generati dall'evasione.


ORDINI DETT - RIGA COMANDO

Percorso: PrevOrdi - Ordini - Ordini di vendita - Riga Dettaglio

In questo punto si consente di inserire una riga di comando che verrà presa in considerazione dalla stampa Ordini, si può scegliere tra quelli proposti:

  • .TD Stampa testata dettaglio
  • .PA Cambio pagina
  • .SR Salta N righe
    Segue richiesta del numero di righe da saltare
  • .NS Non stampa il totale finale
  • .TT Stampa un totale parziale in questo punto
  • .PT Stampa un totale parziale e cambia pagina
  • .TZ Stampa un totale parziale e lo azzera
  • .PZ Stampa un totale parziale, lo azzera e cambia pagina

Per tutti i comandi che prevedono la stampa di un totale viene chiesto all'operatore di digitare la descrizione da stampare prima dell'importo.


EVASIONE ORDINI

Percorso: PrevOrdi - Ordini

Il programma consente di generare Ddt o fatture a partire dagli ordini precedentemente inseriti.

L'operatore dovrà scegliere quali ordini evadere (mediante selezione sul cliente, data e numero ordine etc) e quali documenti generare (Ddt o fattura).

E' possibile evadere un ordine con corrispettivo (nel caso la merce venga consegnata con scontrino e non con ddt o fattura), lasciando bianco il campo "documento di evasione" e spuntando "Evasione con corrispettivo". In questo caso verrà creato un movimento di magazzino con la causale che è stata scritta tra le caratteristiche del tipo documento "ordine" che si sta evadendo, nel campo: "Causale evasione con corrispettivo".

L'evasione potrà poi essere automatica: il programma evade completamente tutti gli ordini compresi nelle selezioni iniziali, oppure manuale: è l'operatore che, scorrendo gli ordini preselezionati, decide uno per uno, quali righe e con quali quantità.

Nell'evasione manuale, viene presentato un ordine per volta e con un click sulla colonna SEL, vengono visualizzate le sue righe con possibilità di compilare, riga per riga, le quantità da evadere.

Se la riga è da evadere completamente basta premere il tasto F9 sulla casella quantità da evadere e il campo viene valorizzato automaticamente uguale alla quantità ancora da evadere.

Se la riga contiene una quantità negativa si consente di evadere solo la quantità per intero e non un'evasione parziale.

Nel caso di un ordine da evadere completamente, si può velocizzare l'evasione facendo un clik sulla colonna Tutto della testata, in questo modo la quantità da evadere di ogni riga viene valorizzata automaticamente uguale alla quantità ancora da evadere. Cliccando di nuovo, le quantità da evadere verranno di nuovo riportate a 0.

Il tasto F10 consente di spostarsi tra i vari 'quadri' della videata di evasione: dalla testata ai dettagli, alle spese.

Evasione a saldo di una riga:

A fianco alla quantità da evadere, in ogni riga, si trova la colonna: a Saldo.

Per evasione a saldo si intende evadere completamente la riga senza però generare nessun documento di evasione. In pratica serve per evadere le righe per quantità di materiale in ordine ma che non verrà mai consegnato. L'alternativa sarebbe modificare o cancellare la riga di ordine corrispondente, operazione che però non è permessa se essa è parzialmente evasa.

Se l'ordine ha delle righe di spesa, anche per queste verrà proposta l'evasione.

Se l'ordine è in valuta, durante l'evasione viene chiesto il cambio, in basso a destra nel video.

Se nell'ordine c'è un Acconto, questo verrà riportato sulla fattura. Se invece l'ordine verrà evaso in ddt , l'acconto NON verrà riportato.

Evasione di ordini quanto è impostato il parametro di personalizzazione: QtaDaDimen (per legnami):
In corrispondenza agli articoli le cui unità di misura sono scritte nei parametri di personalizzazione QtaDaDimXX, con un doppio click, si accede ad una maschera che propone le dimensioni dell'articolo, chiede il numero pezzi da evadere e calcola la quantità corrispondente. Alla conferma viene inoltre riscritta la nota sotto dell'articolo con il numero pezzi in evasione.

Ordini con livelli (taglie-colori)
Evadendo ordini di articoli con livelli, è possibile vedere il dettaglio dei livelli con le quantità in ordine e per ogni riga compilare la quantità da evadere, oppure, nel caso tutti i livelli di una articolo debbano essere evasi, è possibile vedere solo la riga con la descrizione dell'articolo ed evaderla completamente

Si può passare da una modalità a un'altra premendo rispettivamente i tasti 'MostraLivelli' e 'Nascondi Livelli'. Per definire la modalità di partenza del programma, si può usare il parametro di personalizzazione: EvaManLivGruppo. Se impostato a S verrà presentata SOLO la riga dell'articolo (con possibilità di vedere i dettagli premendo il pulsante 'MostraLivelli'

Parametri di personalizzazione gestiti da questa funzione:

NotaSoSotAttEEva
Consente, se impostato a S, di copiare sul documento di evasione dell'ordine il flag ' Dove stampo le note o righe descrittive' così com' è sull'ordine se è impostato 'anche documento di evasione'

StDesLunDaDoc
Se S il flag "Dove stampo descr.lunga" sui dettagli, viene impostato come previsto sul tipo documento di evasione piuttosto che copiato dal documento di partenza.

EvaLisCampiAgg
Lista campi aggiuntivi da visualizzare nella griglia che visualizza i dati degli articoli durante l'evasione di un documento

StRigaRifOrd
Definisce il valore da dare al campo che indica dove stampare la riga descrittiva: Rif. Ordine xx del xx/xx/xxxx

StRigaRifCli
Definisce il valore da dare al campo che indica dove stampare la riga descrittiva:
Rif. Cliente: contenuto del campo Rif.Cliente di testata dell'ordine

StRigaRifLib
Definisce il valore da dare al campo che indica dove stampare la riga con i campi liberi della testata (definiti in Dati generali Azienda - Tab. Fatturazione)

EvaOrdCampiTesta - EvaLisCampiTeAggX
Consentono rispettivamente di variare l' elenco delle colonne da mostrare in evasione ordini nella griglia delle testate ed eventualmente, di aggiungere campi nella griglia.

EvaLisCampiAgg
Specifica la lista di eventuali campi da aggiungere nella griglia che visualizza i dati degli articoli durante l'evasione di un documento

EvaOrdCampiCorpo
Consente di variare l' elenco delle prime colonne da mostrare in evasione ordini nella griglia del corpo

DicIntentiVerif
Per raggruppo ordini con stessa dichiarazione di intento

PreXmlGen OrdXmlGen
Per impostare dei valori di default da assegnare, in fase creazione del file XML della fattura elettronica.
Campi messi nelle righe descrittive delle fatture per indicare se mettere in xml in stampa o altri dati articolo: default SSN


STATISTICA ORDINI

Percorso: PrevOrdi - Ordini - Stampe

Il programma consente di ottenere, dagli ordini registrati, una statistica dell'ordinato per cliente-articolo, per articolo-cliente e per data consegna-articolo.

Per quanto riguarda la stampa della quantità ordinata, è possibile attivare il parametro di personalizzazione QtaSaldo al fine di escludere le eventuali quantità evase a saldo e quindi non consegnate realmente.


STAMPA QUANTITA' EVASA

Percorso: PrevOrdi - Ordini - Stampe

Il programma consente di ottenere, per ogni cliente, l'elenco degli articoli ordinati e degli eventuali ddt stampati, con cui questi sono stati consegnati.

E' possibile attivare il Parametro di personalizzazione StaCodArt per stampare, oltre la descrizione, anche il codice dell'articolo.

La Stampa Quantità Inevasa/Ordinata presenta un prospetto dove, per ogni cliente, elenca gli articoli in ordine riportando le quantità ordinate o ancora inevase a seconda della richiesta dell'operatore.

Entrambe le stampe, riportano la descrizione degli articoli invece del codice.

Nota: causa lo strumento con cui si ottengono queste stampe, esse non risulteranno corrette in presenza di articoli con le seguenti caratteristiche:

Codice: 12x.f2g.zzz Descrizione: Libro

Codice: 12x_f2g_zzz Descrizione: Libro

Codice: 12x[f2g[zzz Descrizione: Libro

Codice: 12x]f2g]zzz Descrizione: Libro

Cioè con STESSA descrizione e codici uguali come sequenza di lettere o numeri ma diversi per caratteri particolari: . _ [ ]


STAMPA ORDINI ORDINATI PER FORNITORE ABITUALE ARTICOLO

Percorso: OrdiniAcquisto - Ordini Acquisto - Stampe

Il programma consente di elencare gli articoli in ordine da clienti, raggruppandoli per fornitore abituale.

Di ogni articolo viene stampata anche la giacenza e la disponibilità:
giacenza - impegnato da clienti + ordinato ai fornitori

In questo modo l'utente può avere un elenco della merce da consegnare e valutare se ordinarla o meno al fornitore.


RIPRISTINO DA INTERRUZIONE IN ELAB.ORDINI VENDITA

Percorso: PrevOrdi - Servizio - Utilità

Vedi Ripristino da interruzione in elaborazione Ddt.


RICALCOLO PROGRESSIVI ORDINATO

Percorso: PrevOrdi - Servizio - Utilità

Il programma rilegge tutti gli ordini in archivio e ricalcola i progressivi dell'ordinato ordinato da clienti per i vari articoli ancora in ordine (per il magazzino impostato a video dall'operatore).

Verranno aggiornati i progressivi dell'anno 'attuale' di magazzino ed eventualmente dei successivi (nel caso si incontrino ordini con data corrispondente all'anno successivo).

Durante questa elaborazione si richiede che gli utenti non inseriscano o evadano ordini.


ORDINI DI ACQUISTO

La procedura consente di inserire e stampare gli ordini da inviare ai fornitori.

Un ordine di acquisto può essere generato in automatico nel momento dell'evasione del preventivo.

Sull'ordine è possibile inserire e stampare il codice articolo del fornitore, al posto di quello in uso.

Tutte le condizioni di acquisto vengono lette dal fornitore.

Al ricevimento della merce, l' evasione parziale o totale dell'ordine, consente di generare in automatico il movimento di carico del magazzino.


TABELLE ORDINI DI ACQUISTO

I programmi presenti in questo menu consentono di inserire tutti i dati ai quali si farà poi riferimento nell'inserimento degli ordini di acquisto.

La tabella più importante in assoluto è quella dei Tipi documento in quanto contiene i codici e le caratteristiche degli ordini che si andranno a registrare.

Nei programmi, ogni volta che viene chiesto un codice di una tabella di riferimento, è possibile, tramite un pulsante posto sulla lista di aiuto, accedere alla funzione che consente di creare il codice se questo non esiste.


TIPO DOCUMENTI ORDINI ACQUISTI

Percorso: Archivi Comuni - Tabelle ordini di acquisto

La tabella contiene il codice, la descrizione e le caratteristiche dei tipi documenti ORDINE di Acquisto.

E' indispensabile compilare bene il tipo documento in quanto contiene i parametri che definiscono il documento stesso. In particolare occorre fare attenzione nel compilare le causali di collegamento con il magazzino.

Descrizione
E' la descrizione del documento.

Segno +
Indica che l'ordine dovrà incrementare il progressivo ordinato a fornitore degli articoli movimentati.

Magazzino proposto
E' il magazzino per il quale è stato fatto l'ordine. Se lasciato bianco si prenderà il magazzino principale dalla tabella di magazzino.

Tabella Sconti prioritaria
Indica se, per l'applicazione degli sconti, è prioritaria la tabella sconti: Categoria/Articolo o quella Fornitore/Gruppo Articoli

Causale per aggiornamento magazzino
E' la causale di magazzino secondo la quale viene aggiornato il progressivo degli ordini di acquisto. Se viene lasciato bianco il campo, verrà ugualmente incrementato l'ordinato. Nel caso non si voglia incrementare l'ordinato a fornitore, occorre associale una causale di magazzino dove nel campo Carico/Scarico sia stata scelta l'opzione 'Niente'.

Causale carico merce
E' la causale di magazzino con la quale verrà creato il movimento di carico della merce al momento dell'evasione dell'ordine.

Codici Note fisse 1-2-3
E' possibile associare ad ogni documento fino ad un massimo di 3 note fisse da riportare in stampa.


NUMERATORI ORDINI DI ACQUISTO

Percorso: Ordini Acquisto - Gestioni

La tabella riporta, per ogni anno, il numero dell'ultimo ordine di acquisto stampato.

I numeri sono progressivi per anno.


ORDINI ACQUISTO

Percorso: OrdiniAcquisto

La funzione consente di inserire, variare, cancellare o visualizzare gli ordini di acquisto.

E' possibile inserire un ordine di un fornitore 'occasionale' che non si vuole creare in archivio fornitori, lasciando bianco il codice fornitore e compilando manualmente i dati anagrafici.

Gli ordini con fornitore manuale potranno essere evasi SOLO con una causale di magazzino del tipo 'carico da deposito' cioè con Provenienza 'Niente' e Destinazione: 'Magazzino'.

E' possibile gestire in automatico il contributo Raee, per gli articoli per il quali è previsto.

Gli articoli coinvolti in un ordine, possono essere caricati da un file esterno, (icona sulla maschera del dettaglio: (B) Lettura da file Ascii) oltre che digitati manualmente (Caricamento dettagli documenti da file)

Una volta confermato un ordine, verrà automaticamente aggiornato il progressivo ordinato fornitori degli articoli in esso inseriti.

Per il significato dei campi in gestione si rimanda al capitolo Ordini di vendita.

Ci sono però alcune particolarità che distinguono gli ordini di acquisto:

Se si gestisce l'archivio articoli-fornitori (flag nei parametri di magazzino), è possibile inserire, per ogni articolo, anche i codici che i vari fornitori attribuiscono a quell'articolo. L'inserimento si potrà fare dalla stessa gestione articoli, quadro (9) Articoli Fornitore o con la gestione apposita.
articolo del fornitore nell'inserimento del corpo dell'ordine, sarà possibile richiamare gli articoli di magazzino con il codice o con il codice attribuito dal fornitore.
Nei Parametri Ordini di Acquisto, è inoltre possibile decidere, spuntando il campo: "Stampo sull'ordine il codice articolo-fornitore", di stampare sulla conferma d'ordine tale codice al posto del codice articolo della tabella articoli.

Parametri di personalizzazione gestiti da questo programma:
 PrezAcqOCostoUlt Se la causale di magazzino prevede che il costo dell'articolo sia letto dal Costo Ultimo, il parametro specifica da quale 'costo ultimo'.
DisabTermPrz, DisabTermVisPrz:
per disabilitare uno o più terminali rispettivamente alla gestione o alla visualizzazione dei prezzi e degli sconti in gestione ordine di acquisto.
StaTotMerce stampare nel corpo del documento il totale merce invece del totale documento (comprensivo di iva)
UsaFlagPrezziOrd fa si che la stampa dei prezzi sia fatta a seconda di quanto impostato nel campo Prezzi in Stampa presente sulla testata dell'ordine.
Al momento della creazione del documento, questo campo viene impostato come previsto sul corrispondente campo del tipo documento.


EVASIONE ORDINI DI ACQUISTO

Percorso: OrdiniAcquisto

Il programma consente di generare un movimento di carico della merce a partire dagli ordini di acquisto precedentemente inseriti.

L'operatore dovrà scegliere quali ordini evadere (mediante selezione sul tipo documento, fornitore, data e numero ordine etc) e quale causale utilizzare per il carico merce.

Se l'ordine da evadere non ha il codice fornitore (fornitore manuale), la causale di carico merce dovrà essere del tipo 'carico da deposito' e cioè con Provenienza 'Niente'.

Nella maschera si chiede di inserire i dati di Riferimento al documento di evasione cioè Prefisso, Numero e data del Ddt o della fattura accompagnatoria con cui è stata consegnata la merce.
E' possibile inserire anche un importo o una percentuale di eventuali spese sostenute, da utilizzare nel ricalcolo del Costo Ultimo degli articoli caricati in magazzino come indicato nella causale di carico, scelta a video per l'evasione dell'ordine.
Tali dati verranno memorizzati sul movimento di carico del magazzino.

E' possibile abilitare il parametro di personalizzazione ListAcqDaAgg per aggiornare, durante l'inserimento dei movimenti di acquisto un listino di acquisto col prezzo della riga.

Per ulteriori spiegazioni sulla operatività dell'evasione, si rimanda al capitolo: Evasione Ordini di vendita.


RIPRISTINO DA INTERR. IN ELAB. ORDINI DI ACQUISTO

Percorso: OrdiniAcquisto - Servizio

Vedi Ripristino da interruzione in elaborazione Ddt.


STAMPA DISTINTA BASE

Percorso: Distinta base - Stampe

Il programma consente di stampare la distinta base di uno o più articoli.

E' possibile valorizzare la distinta spuntando la scelta Stampo i costi.
L'operatore potrà decidere di 'valorizzare' il costo di ogni componente così come è stato dichiarato in sede di costruzione della distinta nel campo 'Quale importo' inserito sulla riga del componente quando si compila la distinta (da Gestione articoli)

oppure scegliere al momento tra:
Costo ultimo
Listino (cod.listino)
Costo medio
Costo standard

La scelta di un costo particolare varrà per tutti gli articoli in stampa e SOLO per la stampa in essere.

Il costo dei semilavorati e prodotti finiti viene calcolato SEMPRE come somma dei costi dei componenti.
Solo se un prodotto, definito 'semilavorato' non ha componenti e in distinta è stato inserito col prezzo 'da listino', verrà considerato con il suo prezzo.

La maschera di stampa è già impostata per effettuare l' "Esplosione Scalare" delle distinte e consente all'operatore di specificare fino a quale livello arrivare. Se il livello viene lasciato bianco, per ogni prodotto selezionato verrà stampata la distinta completa di tutti i semilavorati e materiale di base.
Se si cancella l'opzione di "esplosione scalare", verranno stampati solo gli articoli il cui codice è compreso nella selezione Da .. A .. e che soddisfano la caratteristica: Tutti, Solo prodotti finiti, Solo semilavorati e, in base alla quantità richiesta, verrà calcolato l'importo tenendo conto dei costi di tutti i componenti.

E' obbligatorio compilare il campo "Quantità prodotta" (o in presenza di "Numero pezzi"); la stampa riporterà il fabbisogno di ogni componente per ottenere una quantità X di prodotto finito.

Se si sceglie di stampare "una pagina ad ogni nuova distinta", si dà la possibilità all'utente di stampare l'eventuale immagine associata all'articolo spuntando: "Stampa immagine articolo".

Se è attivo il parametro di personalizzazione QtaDaDimen, verrà chiesto il "Numero pezzi" invece della "Quantità prodotta" e il programma calcolerà quest'ultima moltiplicando il numero pezzi per le dimensioni secondo le regole spiegate nel paragrafo di descrizione del parametro.
Le dimensioni dell'articolo potranno, a loro volta, essere digitate a video oppure lette dall'anagrafica dell'articolo stesso. Se le dimensioni vengono scritte a video e si stampa la distinta di più articoli, esse verranno considerate uguali per tutti gli articoli stampati.


IMPLOSIONE DISTINTA BASE

Percorso: Distinta base - Stampe

Il programma consente di elencare per ogni articolo 'materiale di base' e/o 'semilavorato' gli articoli nei quali esso interviene come componente in distinta base.

Sulla riga dell'articolo componente viene stampata la sua unità di misura.
Sulle righe seguenti viene stampato codice e descrizione degli articoli composti, l'unità di misura e la quantità del componente dichiarata nel legame.


STAMPA FABBISOGNO ORDINI/PREVENTIVI

Percorso: Distinta base - Stampe

Il programma consente di stampare, in forme diverse, l'elenco dei componenti che servono per mandare in produzione uno o più ordini (o preventivi), ciascuno con la quantità necessaria.

Sono previsti i seguenti tipi di raggruppamento

  • per ordine/preventivo e articolo
  • per articolo e ordine/preventivo
  • per articolo

E' inoltre possibile scegliere se stampare o no l'elenco dei componenti dei singoli articoli in ordine, e se includere o no nell'elenco dei componenti i semilavorati.

Al termine di ogni stampa verrà riportato l'elenco riepilogativo dei componenti con la quantità totale necessaria per la produzione degli ordini/preventivi stampati.


SOSTITUZIONE / CANCELLAZIONE ARTICOLI DI BASE E/O SEMILAVORATI

Percorso: Distinta base - Utilità

Il programma consente di variare/cancellare un componente dalle distinte basi di uno o più articoli in cui tale componente interviene interviene.

Sostituzione
Viene chiesto il codice dell'articolo da sostituire e quello con cui sostituire: si può scegliere tra gli articoli definiti come 'materiale di base' e 'semilavorati'.
E' possibile sostituire semplicemente un componente con un altro, lasciando inalterata la quantità con cui il nuovo interviene nel legame oppure digitare un numero 'proporzione quantità' che verrà utilizzato per moltiplicare o dividere la quantità del componente precedente per ottenere la nuova quantità.

Per quanto riguarda la modalità di estrazione del costo da considerare per il nuovo componente, può essere lasciata quella del precedente oppure si può impostare al momento.


LOTTI-CARICAMENTO MOVIMENTI MAGAZZINO

Percorso: Magazzino - Movimenti - Caricamento movimenti dettagli

Se è prevista la Gestione dei Lotti per l'articolo della riga su cui si è posizionati, nella maschera dei dettagli, è abilitato il pulsante:
(Gestione lotti)

Si entra in questa maschera, premendo il pulsante suddetto, tornando sulla riga dell'articolo dopo averla salvata oppure in automatico al salvataggi della riga stessa (a seconda che sull'articolo non ci sia o ci sia l'obbligo della gestione lotti )

In questa maschera dovranno essere inseriti uno o più lotti associati all'articolo. Se si sta inserendo un movimento di carico e il lotto non esiste, verrà creato automaticamente alla conferma.

Nel caso in cui l'utente stia caricando un articolo definito 'finito' o 'semilavorato', per cui prodotto internamente, al quale deve essere assegnato un nuovo codice lotto, può utilizzare il pulsante di generazione automatica di tale codice. Alcuni parametri di personalizzazione regolano tale generazione.

Se il movimento è di scarico, i dati che identificano il lotto, potranno essere inseriti manualmente oppure scelti nella lista dei lotti disponibili.

In particolare se è stato attivato il parametro di personalizzazione HlpLottoForn, nella maschera di richiesta del lotto (in movimenti di magazzino, ddt, fatture) viene presentato un pulsante [Dupl.], a sinistra del codice fornitore, che consente, una volta inserito il codice del fornitore, di aprire una maschera con l'elenco dei lotti di quel fornitore, indipendentemente dall'articolo.

Selezionando uno di questi lotti, verrà attribuito il lotto scelto all'articolo della riga, e quindi creato se ancora non esiste. In questo modo si consente di scaricare un articolo derivato dalla lavorazione o trasformazione di un altro (con lotto) attribuendo ad esso il lotto dell'articolo originale (Utilizzato per la lavorazione delle carni)
Nella maschera di inserimento lotti è disponibile il pulsante [image] (Seleziona lotti) che consente di selezionare i lotti, nei movimenti di uscita, in base alla disponibilità e alla data di scadenza.

Fornitore è il fornitore dell' articolo. Nei movimenti di carico merce viene impostato in automatico con il codice del fornitore messo in testata del movimento, in quelli di scarico è quello del lotto che si sta scaricando e potrà essere inserito manualmente (per scegliere poi un lotto di quel fornitore) oppure, compilato il lotto, verrà impostato automaticamente.

Lotto/nr prog
Una volta inserito il lotto, il programma verifica se è già esistente. Se non esiste verrà creato con numero progressivo 1. Se esiste già, viene data una segnalazione e per inserirlo, occorre variare il numero progressivo da 1 a 2 etc.

Il lotto può essere completato con una descrizione, una data scadenza e delle caratteristiche (categoria, specie etc)

In fase di inserimento di un nuovo lotto, queste caratteristiche vengono lette dall'articolo in base al parametro di personalizzazione DefParDaClassi

Quantità
se la somma delle quantità che si andranno ad inserire nelle varie righe di lotto di un articolo non coincidono con la quantità inserita nel dettaglio il programma esegue quanto previsto dal flag di personalizzazione QtaVer

Origine: mov. numero .. del
 solo nei movimenti di scarico, segnala da quale movimento di carico deriva quello scarico.

Nei movimenti di scarico per produzione (causale definita con Magazzino in Provenienza e Niente in destinazione) è possibile gestire,
per gli articoli definiti 'materiale di base' o 'semilavorati', anche il lotto dell'articolo prodotto in modo da sapere, per ogni componente, quale prodotto finito è andato a comporre.

Nei movimenti di scarico sono variabili solo lotto/nr e quantità mentre gli altri dati sono quelli inseriti al momento del carico. In questi movimenti viene riportato numero e data del movimento con il quale è stato fatto il carico del lotto in oggetto.

Variazione
Il codice articolo sul dettaglio principale non si può variare se ha dei lotti associati

Cancellazione
Se è previsto il controllo delle quantità dei lotti (parametri) e si cancella una riga di un movimento di carico con dei lotti associati, il programma controlla che non siano già stati fatti degli scarichi con quei lotti.
Se si cancella uno scarico, i lotti eventualmente chiusi verranno riaperti.


LOTTI-SELEZIONE QUANTITA'

Nella maschera di inserimento lotti è disponibile il pulsante [image] (E Seleziona lotti) che consente di selezionare i lotti, nei movimenti di uscita, in base alla disponibilità e alla data di scadenza.

Verranno presentati solo i lotti con giacenza positiva, solo non scaduti o anche scaduti a seconda del valore assegnato al parametro di personalizzazione VisLottiScad

L'ordinamento dei lotti disponibili alla vendita: data scad.+quantità disponibile o viceversa, viene determinato dal parametro VisLottiOrd, se non esiste la data scadenza si considera la data di acquisto.

La colonna C_M indica se il lotto è stato chiuso manualmente

Su questo elenco di lotti disponibili se ne possono scegliere alcuni, inserendo la quantità desiderata nella colonna Qta Mov, poi premere il pulsante OK e il programma creerà in automatico le righe corrispondenti.
In fondo ci sono tre pulsanti:

  • Rielabora quantità totale
  • Rielabora quantità precedente
    presenta la situazione delle quantità disponibili in base a quanto già confermato come dettagli lotti per quella riga
  • Ordina per quantità


LOTTI GESTIONE

Percorso: Magazzino - Tracciabilità

La funzione consente di inserire e variare i dati dei lotti inseriti durante il caricamento della merce, al fine di poter ottenere la tracciabilità dei prodotti.

L'anagrafica del lotto viene creata in automatico al momento della conferma di un movimento di carico di merce in magazzino, nella quale sia stato specificato il lotto.

I campi categoria, trattamento, confezione e specie che caratterizzano un lotto, possono derivare direttamente dall'articolo di magazzino (vedere parametri di personalizzazione DefParDaClassi) oppure possono essere creati in tabelle apposite tramite la gestione Tabelle decodifiche varie (menu tabelle di magazzino)

Oltre agli altri dati, ogni lotto è caratterizzato da un campo Stato; questo indica la disponibilità o meno della merce in magazzino e viene aggiornato automaticamente. Fino a quando c'è disponibilità lo stato è: aperto, poi diventa chiuso quando la merce di quel lotto è stata scaricata completamente.

Questo campo può essere variato anche manualmente e in particolare può essere impostato a Chiuso manualmente per indicare che lo si vuole chiuso anche se per il programma c'è ancora disponibilità.
Un lotto 'Chiuso manualmente' non verrà più riaperto dalla procedura, anche se si vanno a variare/cancellare i movimenti di scarico. Viceversa, uno 'chiuso', verrà riaperto se si entra in un movimento di scarico e il programma verifica che c'è ancora una giacenza.

E' possibile visualizzare la giacenza del lotto in gestione premendo il pulsante:
Calcola Situazione articolo/lotto

Cancellazione di un lotto
Se si sceglie di cancellare un lotto il programma controlla il suo Stato.
Se il lotto è aperto viene chiesta doppia conferma della cancellazione e si chiede, per estrema sicurezza, di confermare la cancellazione facendo presente all'utente dove tale lotto è stato utilizzato ad esempio nei movimenti di magazzino (o in ddt e/o fatture non ancora stampati).

Anche se il lotto è chiuso, viene fatta la ricerca dell'esistenza del lotto sui movimenti di magazzino etc. e viene chiesta conferma della cancellazione.
Si consiglia di utilizzare il pulsante "Calcola situazione lotto" per verificare lo stato effettivo del lotto.

Se si conferma la cancellazione ad ogni messaggio, al termine il lotto verrà cancellato insieme a tutte le sue ricorrenze, altrimenti verrà mantenuto.


LOTTI ELENCO

Percorso: Magazzino - Tracciabilità

Questo programma consente di ottenere una lista dei lotti, completa di descrizione, data scadenza etc. tramite varie selezioni.

Nelle stampe e utility dei lotti sono stati abilitati i tasti F4 ed F5 che fanno una ricerca tipo l' F2 e l'F3 però senza le selezioni su articolo e fornitore.


LOTTI STAMPA MOVIMENTI

Percorso: Magazzino - Tracciabilità

Questa stampa consente la tracciabilità / rintracciabilità di un prodotto.

Per ogni lotto vengono stampati tutti i movimenti e relative quantità, il fornitore da cui proviene e i clienti ai quali è stato venduto.

Si può chiedere la stampa dei soli lotti aperti, dei soli chiusi o di tutti.

Per quanto riguarda Ddt e Fatture, il lotto viene chiuso al momento dell'inserimento del documento (e non alla stampa), per questo motivo si consente di stampare anche i lotti presenti in articoli di ddt o fatture non ancora stampate.

Se ddt o fattura, anche non stampati, hanno determinato la chiusura di un lotto e si chiede la stampa comprensiva dei lotti in ddt e fatture non stampati, questo elenco verrà stampato solo se di chiedono tutti i lotti oppure solo quelli chiusi.

Nel caso che la ditta faccia produzione nel momento in cui si fa il carico da produzione (da Caricamento movimenti o da Caricamento movimenti di produzione) è possibile assegnare i lotti ai nuovi articoli caricati dalla produzione e, nel corrispondente scarico dei componenti, indicare sia il lotto del singolo componente utilizzato, sia quello del prodotto finito che tali componenti hanno generato.

Per consentire di elencare, a seguito del movimento di carico da produzione di un articolo che in anagrafica ha il flag Distinta Base posto a Prodotto finito o Semilavorato, l'elenco dei lotti dei prodotti componenti, occorre spuntare, a video, la richiesta: Stampa componenti di produzione

Per consentire di elencare, a seguito del movimento di scarico per produzione l'elenco dei lotti dei prodotti componenti, occorre spuntare, a video, la richiesta: Stampa componenti di produzione. Verranno considerati i movimenti di scarico che hanno la causale di magazzino con : Provenienza: magazzino e Destinazione: nulla e gli articoli che in anagrafica hanno il flag Distinta Base posto a Materiale di Base.


LOTTI UTILITA'

Percorso: Magazzino - Tracciabilità

Questo programma consente di controllare lo stato dei lotti e di intervenire per modificarlo.

  • Cancella lotti senza movimenti
    Consente di eliminare dalla tabella dei lotti quelli che NON sono stati mai utilizzati in Movimenti di magazzino, Ddt, Fatture, Movimenti di produzione (lotto dell'articolo da produrre) . Se un lotto è scritto in testata di un movimento di produzione NON verrà cancellato, anche se non è ancora stato fatto il carico in magazzino.
  • Verifica e aggiorna chiusura
    Per ogni lotto che soddisfa le selezioni iniziali, vengono esaminati i movimenti e, in base ad essi, viene reimpostato il flag di chiusura.
  • Chiusura Manuale
    Effettua la chiusura automatica dei lotti che soddisfano le selezioni impostando sul lotto il flag di chiusura M cioè Manuale
  • Elenco lotti per chiusura
    Viene presentata una lista dei lotti selezionati con evidenziate le quantità in entrata e in uscita.
    Un asterisco nel campo stato indica che non c'è compatibilità tra lo stato scritto sul lotto e quello calcolato in base ai movimenti presenti.
    L'operatore può scegliere di eseguire:
    - Verifica e aggiorna stato
    il programma aggiorna lo stato in base al ricalcolo fatto sui movimenti
    - Cambia stato
    viene chiesto lo stato da mettere nei lotti selezionati
    Per quanto riguarda le possibilità di scelta di più righe o di spostamenti di colonne sulla lista visualizzata, leggere la nota in fondo.
  • Lotti movimentati senza anagrafica
    Viene visualizzato un elenco dei lotti che risultano movimentati (movimenti di magazzino) ma per i quali non esiste una riga in gestione lotti.

Gestione lista visualizzata

Sulla lista è possibile:

  • spostare una o più colonne consecutive. Per fare ciò occorre evidenziare le colonne da spostare, spostarsi col mouse nel punto in cui si desidera inserirLe (senza cliccare!) e premere CTRL e il tasto Destro del mouse. Le colonne selezionate verranno inserite come colonne successive a quella in cui ci si è posizionati
  • ordinare una o più colonne consecutive. Per fare ciò occorre evidenziare le colonne da ordinare poi premere ALT e tasto destro del mouse
  • selezionare più righe non consecutive: evidenziare le varie righe tenendo premuto il tasto CTRL.


REGISTRATORE DI CASSA

La procedura permette di emettere scontrini con registratore di cassa in vari tipi di configurazione:

  • Un registratore di cassa per ogni terminale.
  • Un unico registratore di cassa su cui vengono stampati tutti gli scontrini.
  • Gruppi di terminali che stampano su un registratore di cassa, altri terminali che stampano su un altro.

Questo è possibile perché l' emissione scontrini scarica lo scontrino in una cartella predefinita. L'invio dei dati al registratore viene fatto, in automatico, da un altro programma (es. RCASSA.exe) che è in esecuzione sul terminale collegato fisicamente al registratore di cassa.

Per poter emettere lo scontrino in collegamento con un registratore di cassa, è indispensabile che sia stato predisposto, all'interno della procedura, il protocollo di comunicazione con quel particolare tipo di registratore e che siano stati configurati tutti i parametri necessari.

Segue un elenco dei parametri da impostare per poter eseguire il programma di emissione scontrino e l'elenco dei registratori abilitati con relative modalità di attivazione di attivazione.

E' infine possibile utilizzare la funzione di emissione scontrini anche senza aver abilitato il collegamento con un registratore di cassa, per creare il movimento di uscita del magazzino ed eventualmente stampare un documento con l'elenco degli articoli consegnati.


REGISTRATORI COLLEGATI

Segue l'elenco dei registratori dai quali è possibile emettere scontrino in collegamento con il programma:

  • SAREMA FRONTIERA (con protocollo XON-XOFF) o equivalenti
    Es. Registratore prodotto da EPM Sistemi spa e distribuito da E.D.it srl
  • SICO 6000 TOP (stesse caratteristiche di Sarema)
  • VANDONI DT 200
  • OLIVETTI CMS 400
  • KABEL (Piccolino, Winner (Europa))
  • INDESIT DITRON Serena
  • RCH (Mizar etc.)
  • RCH (Swing con protocollo XON-XOFF)
    Es. Registratore modello SPOT-RT Telematico
  • NIXDORF (Butterfly Plus)

Nuovi modelli telematici :

  • E.D.it Zero https://www.edit-srl.it/zero-top/ (compatibile con il precedente modello della E.D.it)
  • RCH modello SPOT-RT telematico (protocollo XON-XOFF)

Note tecniche di collegamento:

vedi Emissione scontrini parametri

Seguono alcune note dettagliate per le particolarità dei vari registratori.

Per i registratori che lo gestiscono, per stampare la Partita Iva o Codice Fiscale del cliente sullo scontrino, occorre inserire il parametro di personalizzazione InvPIva (Es. Kabel, Sarema)

Registratore: Frontiera

E' disponibile un parametro per impostare la lunghezza della descrizione inviata.

Sezione: [Altri parametri]
Parametro: FrontMaxDesc
che contiene la lunghezza massima della descrizione da inviare al registratore di cassa (default 10)

Esempio:
FrontMaxDesc=20

Registratore: OLIVETTI CMS 400

Note tecniche di collegamento:

Per utilizzare il registratore di cassa bisogna copiare i file rcassa.exe e rcassa.ini (dalla directory RCASSA del CD) sul computer che e' fisicamente collegato al registratore.

Tali file possono essere copiati in una directory qualsiasi (es. c:\rcassa o c:\programmi\aziwin\rcassa), l'importante è che si metta il riferimento nell'icona che lancia il programma rcassa, ad esempio: c:\rcassa\rcassa.exe c:\rcassa\rcassa.ini

Nel file rcassa.ini devono essere inseriti i parametri di settaggio della porta seriale, la directory nella quale leggere il file di dati da inviare al registratore di cassa (file preparato dal programma di emissione scontrini),

il nome del registratore (Olivetti per il registratore Olivetti modello CMS 400), AttRisposta e Pausa (vedi sotto)

Il registratore di cassa deve essere configurato per quello che riguarda la porta seriale.

In particolare per questo registratore:
se si imposta il parametro del protocollo fisico (parametro D del comando SET 901) a 1, cioè No Modem, il registratore non invierà messaggi di risposta al PC: in questo caso impostare il parametro
AttRisposta = N (per dire di non aspettare una risposta)
e Pausa = 0,03 (o 0,5) (pausa da fare tra l'invio di due stringhe successive)
Per configurare questo tempo considerare che piu' grande e' questo valore valore e' il tempo di uscita dello scontrino ma minore e' il rischio che, nel caso di scontrini con piu' righe, il registratore possa perderne qualcuno stampando quindi uno scontrino inesatto.

Se invece si imposta il parametro del protocollo fisico (parametro D del comando SET 901) a 0, cioè Full duplex, il registratore invierà messaggi di risposta al PC per ogni riga stampata: in questo caso impostare il parametro AttRisposta = S e mettere in
Pausa un tempo anche piccolo in quanto in ogni caso dopo aver inviato una riga il PC aspetterà la risposta dal registratore prima di inviarne altre.

Decimali=X
Con X numero di decimali da considerare quando si arrotonda valore unitario per quantità e la quantità è maggiore di 1. Il default è 2. In genere tuttavia, visto che la quantità non viene stampata, si darà quantità 1 e valore totale.

Ricordiamo che il registratore non riconosce differenze di reparti o iva o modalità di pagamento, quindi queste informazioni possono essere reperite soltanto dal PC e le scritte che compaiono sul registratore sono puramente descrittive e dal registratore sarà possibile soltanto avere un totale di incasso giornaliero ricevuto tramite PC.

Poichè inoltre il registratore non e' in grado di ricevere dal PC l'informazione relativa alla quantità e quindi non e' in grado di calcolare l'importo totale ottenuto come importo unitario per quantità si consiglia, al fine di evitare problemi di arrotondamento, di impostare il flag di personalizzazione: RegPrzTotale. Se vale "S" mette sul file per registratore di cassa l'importo totale al posto dell'importo unitario e la quantità viene posta a 1

Vedere anche: Emissione scontrini parametri e installazione per gli altri parametri da configurare.

Registratore: KABEL (Piccolino, Winner (Europa))

Particolarità: non gestisce gli abbuoni a fine scontrino.

Gestisce invece 'il reso' di una singola riga, occorre inserire una riga con articolo, quantità e mettendo un importo negativo.
Gestisce gli anticipi
Il registratore può stampare anche le quantità. Se non la si vuole stampare basta attivare il flag di personalizzazione:
Gruppo: Scontrini - Parametro: RegPrzTotale - Valore: S. In questo caso viene stampato l'importo totale di ogni riga al posto dell'importo unitario e la quantità viene posta a 1

Parametri di RegCassa.ini:
[Parametri Seriale]
CommPort=1
Settings=9600,N,8,2
Da notare che il numero di bit di stop va posto a 2.

[Altri parametri]
AttesaTimer=2000
DirPerFile=C:\rcassa\reg1
Ritenta=3
Registratore=Kabel
AttRisposta=N
Pausa=5,00
#PausaReady=0,2
LungMaxDesc=14
RepDef=3
ConfBase="00000000" (solo per winner ma opzionale)

Pausa è obbligatorio e se vale 0 il programma dopo un invio aspetta il ready dal registratore prima di fare un invio successivo, altrimenti aspetta il tempo indicato.

PausaReady è il tempo di attesa dopo che ha ricevuto il ready. Può mancare e se non c'è prende il valore di default.

RepDef è il reparto di default (il reparto viene passato in automatico letto dall'articolo per cui non dovrebbe mai mancare ma poich in questo registratore obbligatorio, ci siamo cautelati mettendone uno di default)

LungMaxDesc lunghezza massima di caratteri scritti per la descrizione Il Default è 14.

ConfBase="00000000"
E' la stringa che dovrà inviare il programma per ristabilire la configurazione base dopo la stampa del dettaglio degli imponibili e imposte per aliquota. Va impostata SOLO se si vuole stampare, in fondo allo scontrino, il dettaglio degli imponibili e imposte diviso per aliquota dopo aver stampato la Partita iva del cliente.
Se è impostato questo parametro, la stringa verrà proposta a video nella maschera dell' esecuzione della funzione Rcassa e a fianco ad essa verrà presentata una casella con l'opzione attivata per Riepilogo iva per ricevuta. Se l'utente disattiva l'opzione (toglie cioè la spunta alla casella), il dettaglio iva non verrà mai stampato altrimenti verrà stampato negli scontrini dei clienti con partita iva.

Per gli altri parametri da configurare, vedere anche: Emissione scontrini parametri e installazione

Registratore: INDESIT DITRON Serena

Per attivare la stampa dello scontrino su un registratore di questo tipo, è indispensabile creare, nei parametri di personalizzazione, le righe:
 RegSerena con Valore: S (in alternativa si può mettere nell'aziwin.ini nel paragrafo RegCassa la riga Serena=S)
e VirgolaVirtuale con Valore: P , questo per fare in modo che il programma invii il prezzo usando il . (punto) come separatore dei decimali e non metta nessuna virgola.

Inoltre, se si vuole stampare anche la quantità decimale, occorre attivare anche il parametro di personalizzazione: VirgolaVirtQta con Valore: P , per fare in modo che il programma invii la quantità usando il . (punto) come separatore dei decimali.

L'utilizzo di questo tipo di registratore prevede che sia in esecuzione il software di comunicazione: WinECRCom... che va configurato per andare in auto run e nella sua configurazione va scritto il percorso in cui si troverà il file dello scontrino e il nome di tale file (Es. c:\Rcassa\Scontr.ecr) e quello degli errori (Es. c:\Rcassa\Scontr.err)

Oltre a configurare la sezione [RegCassa] dell' AziWin.ini come descritto in Emissione scontrini (parametri) può essere aggiunto un ulteriore parametro opzionale.

[RegCassa]
Serena=S Dice che si sta utilizzando un registratore di cassa di questo tipo.
Se non si mette questa riga nell'INI occorre inserire il parametro di personalizzazione RegSerena con Valore: S
......
FileSerena=nome_file (parametro opzionale, nome _file è il nome che il programma darà al file dello scontrino che dovrà essere letto dal software di comunicazione con il registratore di cassa)

Il file scontrino prodotto dal programma che deve essere mandato al registratore, si trova nella directory indicata in DirInvia, il suo nome è scontr.ecr, oppure quello indicato nel parametro: FileSerena inserito nell'aziwin.ini

Gestisce gli anticipi e abbuoni

Può stampare anche la quantità. Se non la si vuole stampare basta attivare il flag di personalizzazione:
RegPrzTotale - Valore: S. In questo caso viene stampato l'importo totale di ogni riga al posto dell'importo unitario e la quantità viene posta a 1
Esempio di stampa scontrino col parametro impostato a S:

1x170,00 |
Reparto 01 | 170,00
Subtotale | 170,00
Totale € | 170,00
Subtotale | 170,00

Questo flag può essere utile nel caso che il valore unitario degli articoli abbia più di due decimali.

Vedere anche: Emissione scontrini parametri

Registratore: RCH (Mizar etc.)

Per attivarlo si deve:

  • Installare il software di comunicazione fornito da RCH sul computer collegato al registratore
    (E' un programma che installa il software di comunicazione e l'OCX usato da Visual Basic: Cmd900 es. cmd900v247)
  • Configurare la sezione [RegCassa] dell' AziWin.ini come descritto in Emissione scontrini (parametri)
  • Sullo stesso computer copiare dal CD di installazione di aziwin, directory RCASSA i file:
    RCASSARCH.exe e rcassarch.ini e lanciare RCASSARCH.exe
    Per l'installazione di questi file seguire le istruzioni descritte in Emissione scontrini (parametri) per il file RCASSA.EXE

Spiegazione dei parametri del file rcassarch.ini:

[Parametri Seriale]
CommPort=1
AddrCasse=01
Mode=1
BaudRate=8
DataBits=2
StopBits=1
Parity=1

Sono i parametri di settaggio.
AddrCasse serve se ci sono più casse collegate.

[Altri parametri]
Modello=7
DirPerFile=F:\rcassa\reg1
AttesaTimer=4000
NumDescPri=1
DescPri1=Benvenuto
NumDescDop=5
DescDop1=
DescDop2=..Gentile CLIENTE...........
DescDop3=.....Grazie per la..........
DescDop4=.....preferenza.............
DescDop5=..Accordataci...............

  • Modello: è il modello di registratore. Dipende dal software di collegamento. 7 è quello per Mizar
  • DirPerFile percorso dove l'exe va a leggere gli scontrini da stampare e deve coincidere con quello di aziwin.ini
  • AttesaTimer sono i millisecondi di attesa tra la ricerca di uno scontrino e un'altra.
  • NumDescPri numero di righe descrittive fisse da stampare all'inizio dello scontrino
  • DescPri1 … DescPriN relative righe di descrizione
  • NumDescDop numero di righe descrittive fisse da stampare alla fine dello scontrino
  • DescDop1 … DescDopN relative righe di descrizione

Particolarità:

  • Il programma invia gli importi come Totale1 per i contanti, Totale2 per le carte di credito e Totale3 per gli assegni.
  • Gestisce gli anticipi per pagamenti con carta di credito
  • Gli abbuoni sono chiamati deduzioni.
  • Lo scontrino da errore nella gestione dei sospesi in quanto questo modello (mizar) non lo gestisce.

Registratore RCH Swing (con protocollo XON-XOFF)

Il registratore SWING, purchè dotato del protocollo XON XOFF, può essere utilizzato allo stesso modo del Sarema Frontiera.
Ci sono tuttavia alcune particolarità, descritte in seguito, che caratterizzano questo tipo di registratore rispetto il Sarema.

  • Estrazione di una descrizione da stampare sugli scontrini quando si fa la stampa per reparto (se non c'e' la descrizione viene dato un messaggio di errore).
    Per questo motivo e' stato introdotto il parametro di personalizzazione EstrRepDescr , obbligatorio per questo tipo di registratore.
  • Invio di due scritte, di cui la prima e' semplicemente la parola "totale" mentre la seconda è l'importo del totale scontrino, che vengono visualizzate sulle due righe del display. Per ottenere queste scritte occorre inserire nel file rcassa.ini, nel gruppo [Altri parametri] la riga:
    TotDisplay=S

Registratore NIXDORF Butterfly Plus

Note tecniche di collegamento:

Per utilizzare il registratore di cassa occorre installare il suo software in dotazione: Smart3comm
In automatico tale software viene installato nella cartella c:\programmi\smart3comm ma si può cambiare la destinazione (questo potrebbe essere necessario in presenza di SO Vista)
Questo software dovrà essere in esecuzione quando si dovranno stampare gli scontrini.

Nel paragrafo RegCassa dell'aziwin.ini del computer, occorre definire i seguenti parametri:
DriveInvia e DirInvia che indicano rispettivamente il disco e la cartella in cui è stato installato il software "Smart3comm"
FileButterfly indica il nome del file scritto dal programma di emissione scontrini (default: scontr.txt) per comunicare lo scontrino al registratore (indicare il percorso completo)
Butterfly=S indica che si sta utilizzando questo tipo di registratore. In alternativa a questa riga si può creare nei parametri di personalizzazione il parametro RegButterfly
ConfCanc=
Parametro opzionale per stabilire se chiedere o meno conferma della cancellazione del file dello scontrino una volta terminata la stampa dello stesso.
Di default viene posto a N (cioè nessuna conferma). Per valori diversi da N verrà chiesta conferma.
PrgButterfly=
indica il percorso completo dell'exe da lanciare per il dialogo
Se non viene inserito usa: c:\programmi\smart3comm\stfisc.exe
E' infine possibile, ma non obbligatorio, configurare un altro parametro che conterrà il nome del servizio DDE: ParBatterfly =/DDE:<nome_del_servizio>
Il nome DDE può essere cambiato se ci sono più registratori di cassa.

Esempio:
[RegCassa]
DriveInvia=C:
DirInvia=\Programmi\SMART3comm\
FileButterfly=C:\Programmi\SMART3comm\scontr.txt
Butterfly=S

Parametri di personalizzazione considerati dal registratore:

Inoltre se nelle quantità vendute si utilizzano i decimali, poichè il registratore non può stamparle, è indispensabile attivare il parametro RegPrzTotale con Valore S per stampare nello scontrino solo il totale di riga.

Infine, al parametro di personalizzazione: VirgolaVirtuale viene dato dal programma il valore P fisso, che significa che invia "obbligatoriamente" gli importi al registratore usando il . (punto) come separatore dei decimali e non la virgola.

Note

  • E' prevista la stampa della partita iva del cliente
  • Gestisce l'abbuono
  • Gestisce SOLO quantità intere.
  • Con il parametro ConfCanc=S inserito nell'aziwin.ini, è possibile dire al programma di chiedere, al termine della stampa dello scontrino, se cancellare o meno il file di transito che è stato creato con i dati dello scontrino stesso.
    Si consiglia di inserire questo parametro se ci sono problemi frequenti con la stampa dello scontrino.
    Se la stampa è corretta l'operatore confermerà con un click su "OK".
    Se invece lo scontrino si è inceppato e si fa un click su "Annulla", il file, su disco, viene mantenuto e lo si può mandare direttamente al registratore operando manualmente nel seguente modo:
    Occorre posizionarsi (dalla finestra Dos) nella cartella in cui è stato installato il software di comunicazione con il registratore (Smart3comm) ed eseguire:
    StFisc scontr.txt
    (dove scontr.txt è il nome del file dello scontrino)
    Poi dovrà essere cancellato manualmente altrimenti al lancio di un successivo scontrino il programma darà un messaggio di "scontrino già esistente" e chiederà di cancellarlo.
  • Nel caso di più registratori dovrà essere installato in rete il software di gestione mentre i parametri per le installazioni locali restano uguali.
  • Se si blocca la stampa di uno scontrino, il registratore non lo chiude e se si manda un altro scontrino va in errore. Per risolvere il problema occorre creare manualmente il file scontr.txt dello scontrino, quello descritto nel parametro: FileButterfly, e scrivere dentro una riga con la parola: cash
    Poi lanciare manualmente la stampa eseguendo (es. da dos):
    StFisc scontr.txt
    così lo scontrino verrà chiuso


EMISSIONE SCONTRINO (PARAMETRI E INSTALLAZIONE)

Prima di iniziare ad utilizzare la funzione di emissione scontrini occorre aver compilato correttamente la Tabella per Registratore di Cassa (dal menu: Parametri e Utilità, scelta Dati Generali Azienda) e, con la stessa funzione, scelte Conti Comuni e Causali Comuni, aver inserito il conto Cliente corrispettivi e gli altri conti e causali utili per la registrazione in contabilità del corrispettivo giornaliero.

Inoltre è indispensabile aver creato tutti i Reparti che risultano attivi sul registratore, ciascuno con il relativo codice iva e aver inserito in ogni articolo di magazzino il codice di reparto al quale appartiene.

Se si devono emettere scontrini da allegare alle fatture o per fatture dettaglianti, è indispensabile creare un reparto particolare sul quale battere questi scontrini e mettere il suo codice nella tabella del registratore in corrispondenza a Reparto per fatturazione.

A seconda del tipo di installazione e del tipo di registratore occorre configurare parametri diversi. Per tutti dovrà essere creata, nel posto opportuno, una cartella di transito dove il programma memorizzerà gli scontrini e il programma che li invia al registratore li andrà a leggere. Inoltre occorre configurare dei parametri sui file: rcassa.ini e aziwin.ini)

Elenco delle possibili configurazioni

1) - Uno o più computer, ciascuno collegato al suo registratore di cassa
Seguire le istruzioni a seconda del tipo di registratore.
Per quelli dove serve Rcassa, su ogni computer va installato Rcassa.exe e va configurato Aziwin.ini locale.

2) - Un unico registratore su cui stampano gli scontrini da più computer
La cartella di transito dei file degli scontrini si può creare:

  • sul server
    in questo caso si configura AziWin.ini condiviso:
    DriveInvia=X: (X lettera con cui viene visto il server)
    DirInvia=\Scontr_Dir\ (dove Scontr_Dir è la cartella dove vengono scritti gli scontrini - es. RCassa))
  • sul computer che è fisicamente collegato col registratore.
    In questo caso la cartella creata va condivisa, in lettura e scrittura, con una lettera (es.K) in modo che sia visibile da tutti i computer che dovranno stampare gli scontrini.
    Nell' AziWin.ini condiviso mettere in DriveInvia questa lettera e
    DirInvia la cartella in cui vengono scritti i file degli scontrini
    mentre nell' AziWin.ini locale del computer collegato al registratore mettere in DriveInvia la lettera con cui lui vede il suo disco e in
    DirInvia la cartella in cui vengono scritti i file degli scontrini.

N.B. Nella cartella specificata in 'DirInvia' va sempre creata la " sottodirectory" Reg1

3) - Più di un registratore
possono presentarsi tre diverse situazioni

  • Ogni computer ha il suo registratore collegato
    La soluzione può essere quella presentata al punto 1) oppure si può configurare l'AziWin.ini condiviso purchè tutti utilizzino lo stesso percorso per identificare la cartella di transito degli scontrini.
  • Soluzione consigliata nel caso ci sia un numero di computer maggiore del numero dei registratori
    Mettere sul server la cartella di transito degli scontrini (es.Scontr_Dir) e nell'AziWin.ini condiviso:
    DriveInvia=X: (X lettera con cui i client vedono il server)
    DirInvia=\Scontr_Dir\
    Il file RCassa.INI di ogni computer collegato al registratore va configurato in modo da puntare, con il parametro DirPerFile, alla cartella giusta.
  • I computer collegati ai registratori devono condividere la cartella di scambio (crearne una su ogni computer). Tutti gli altri devono fare un collegamento con una lettera alla cartella del computer su cui vogliono emettere lo scontrino.
    Tutti devono configurare il proprio AziWin.ini locale mettendo i parametri DriveInvia= e DirInvia= con i riferimenti opportuni.
    In questo caso NON sarà possibile scegliere, al momento dell'emissione scontrino, il registratore di cassa su cui stampare.

Con più registratori collegati nella cartella specificata in 'DirInvia' vanno create tante " sottodirectory" quanti sono i registratori da utilizzare. I nomi di queste " directory" dovranno essere :
Reg1
Reg2 etc.
Il programma creerà il file dello scontrino in RegN poi alla fine lo copia nella cartella indicata in DirInvia perchè possa essere inviato.

Modifiche all'AziWin.ini

In presenza del collegamento con registratore di cassa occorre inserire nel file AziWin.ini opportuno, le righe descritte in seguito.
Per stabilire su quale AziWin.ini aggiungere tali righe si consiglia di leggere il paragrafo precedente e stabilire qual' è la configurazione che si sta installando.

[RegCassa]
DriveInvia=F: (o C:)
DirInvia=\RCassa\

  • DriveInvia disco condiviso nel quale andrà copiato il file rcassa.exe per i registratori che lo utilizzano.
  • DirInvia (es.: \.....\rcassa\) è la cartella in cui vengono scaricati i file di transito per la stampa scontrini.
    Nella cartella specificata in 'DirInvia' vanno create tante "sottodirectory" quanti sono i registratori di cassa da utilizzare. I nomi di queste "directory" dovranno essere :
    Reg1
    Reg2 etc.

RCASSA.EXE

Per i registratori che necessitano di RCASSA.EXE occorre creare una cartella sul disco opportuno, a seconda della configurazione che si sta installando e copiare in essa i files: rcassa.exe e rcassa.ini dalla directory \rcassa del CD di installazione.

Copiare anche mscomm32.ocx e registrarlo (ad es. da menù avvio/esegui col comando c:\windows\system\REGSVR32 c:\programmi\aziwin\rcassa\mscomm32.ocx supponendo di aver copiato l'ocx in quella directory.

In presenza di NT o windows 2000 questa registrazione non dovrebbe servire (se serve, per la registrazione, scrivere winnt\system32 al posto di windows\system)

Per far partire automaticamente il programma all'accensione è sufficiente creare un collegamento al file rcassa.exe in Menu Avvio, Programmi, Esecuzione automatica
(C:\WINDOWS\Menu Avvio\Programmi\Esecuzione automatica).
Nel collegamento (gestendo le sue proprietà) dopo il nome dell'eseguibile va aggiunto il percorso dove si trova il file rcassa.ini
Es. di destinazione: C:\programmi\aziwin\rcassa\rcassa.exe c:\rcassa\rcassa.ini

Il file RCASSA.INI va configurato in modo opportuno per ogni tipo di registratore di cassa che ne richiede l'utilizzo

Segue una spiegazione generale dei parametri comuni a tutti i registratori, contenuti in questo file.
Per altri parametri particolari del singolo registratore vedere il paragrafo: Registratori collegati.

[Parametri Seriale]

  • CommPort=1
    Porta seriale utilizzata (1 = Com1, 2 = Com2)
  • Settings=9600,N,8,1
    Impostazioni della porta (*) per ulteriori spiegazioni.

[Altri parametri]

  • AttesaTimer=2000Tempo, in millesimi di secondo, che trascorre tra un controllo di scontrini da inviare e l'altro.
  • DirPerFile=c:\rcassa\reg1 (oppure c:\programmi\aziwin\rcassa\reg1
    Directory in cui Rcassa cerca i file di scontrini da stampare.
    Nel caso di più registratori si dovranno creare directory reg1, reg2, reg3 cioè una per ogni registratore (se in rete questa directory deve essere condivisa dai vari computer che stampano sul registratore).
  • Ritenta=3
    Tentativi di invio scontrini prima di segnalare l'errore
  • Registratore=Frontiera
    Tipo di registratore di cassa (Frontiera o Vandoni o Olivetti o Kabel)
    (Nota: va impostato Frontiera anche per RCH Swing)
  • Sepdecimaliqta=. oppure =, Indica il separatore dei decimali per le quantità. Il default è il . (punto) (Frontiera e Kabel)
  • TotDisplay=S (Solo per registratore: RCH Swing)

(*) Note sull' impostazione della porta

"BBBB,P,D,S"
Dove BBBB è la velocità di trasmissione, P è la parità, D è il numero di bit di dati e S il numero di bit di stop.

  • Velocità di trasmissione valide:
    110, 300, 600, 1200, 2400, 9600, 14400, 19200, 28800
  • Valori di parità validi:
Impostazione | Descrizione
E | Pari
M | Segno
N | Nessuna
None | Nessuna
O | Dispari
S | Spazio
  • Valori di bit di dati validi:
    4, 5, 6, 7, 8, (Predefinita)
  • Valori di bit di stop validi.
    1 (Predefinita), 1.5, 2


VENDITA AL BANCO

Il programma di emissione scontrini può essere utilizzato per la vendita al banco anche se non c'è un registratore collegato.

E' necessario tuttavia impostare tutti i parametri sulle tabelle, come se ci fosse il registratore.

Vedi emissione scontrini e Registratore di cassa


EMISSIONE SCONTRINI

Percorso: Vendite - Scontrini

Questa funzione consente di preparare gli scontrini che verranno poi mandati al registratore di cassa (vedi Elenco registratori abilitati) oppure, semplicemente, di scaricare il magazzino e preparare la registrazione del corrispettivo giornaliero per la contabilità, nel caso non ci sia un registratore collegato.

Per utilizzare in modo corretto questa funzione occorre aver preparato in modo opportuno i dati e configurato alcuni parametri, a tal proposito si rimanda al paragrafo Emissione scontrino (parametri e installazione).

Si ricorda che se si emette uno scontrino da allegare a una fattura, questo va emesso con un articolo fittizio collegato al reparto di fatturazione e va chiuso sempre con CASSA Contanti. Questo perché la chiusura serale della cassa, che fa la creazione dei movimenti in Prima nota del corrispettivo giornaliero e degli incassi, decrementa l'importo del Contanti dell'importo entrato nel reparto di fatturazione.

Lo scontrino può essere emesso a un cliente particolare oppure a un cliente generico. Se la causale di magazzino utilizzata non prevede l'uscita da un cliente, il campo cliente va lasciato bianco, viceversa è obbligatorio.

Registratore attivo: va spuntato se al termine dello scontrino, questo dovrà essere stampato su un registratore collegato.

Nella maschera iniziale dell' emissione scontrini, se si lavora con più registratori di cassa, viene proposto:
Registratore numero: x cioè il registratore su cui si stamperà lo scontrino, con possibilità di varialo e di memorizzarlo con l'apposito pulsante (Memorizza numero registratore)
Tale numero verrà memorizzato nell'aziwin.ini del terminale, nel parametro: NumCassaLoc=x

Se è stato attivato il parametro di personalizzazione StAbil, al termine dello scontrino viene data la possibilità di stampare (oltre allo scontrino sul registratore di cassa, se collegato) un modulo con l'elenco degli articoli venduti e i totali (tipo Ricevuta fiscale). Il pulsante 'In stampa raggruppo articoli uguali' consente di raggruppare, in un'unica riga, eventuali articoli, consecutivi, con lo stesso codice.
Per evitare il raggruppo e stampare singolarmente tale articoli è necessario togliere la spunta all'opzione (per toglierla in modo permanente si può attivare il parametro di personalizzazione: RaggrArt)

Nel caso che il cliente non paghi o paghi solo parzialmente, verrà registrato il sospeso, che potrà essere evidenziato separatamente per i vari clienti o messo su un 'cliente sospeso' fittizio (vedi Contabilizzazione scontrino)

Se è stata attivata per la ditta la fattura dettaglianti, sarà possibile accedere al programma di emissione fattura dettaglianti dalla maschera dello scontrino.

NOTA: poiché nella contabilizzazione serale degli scontrini, in caso di corrispettivi da scorporare, l'aliquota iva viene prelevata dall'anagrafica dei vari reparti, è indispensabile che sui reparti sia inserito un codice iva corretto. Se sul reparto c'è un codice non corretto il programma da il messaggio: "Campo iva non valido".

Prezzo unitario:
Prezzo unitario della riga. Viene proposto il prezzo dell'articolo letto dal listino (se impostato in testata), valido alla data di inserimento del documento. Nella causale di magazzino collegata al Tipo documento è possibile tuttavia, definire che il prezzo venga prelevato dal costo ultimo o dal medio di carico.
E' possibile infine impostare il prezzo unitario dell'articolo sulle tabelle degli sconti, in questo caso verrà prelevato solo se il documento è in Euro (moneta corrente). Se il prezzo di listino viene letto dalla Tabella sconti e non è già stato impostato comprensivo di iva, sarà necessario attivare il parametro di personalizzazione PrezziScontatiIvati con valore N perchè il programma proponga il prezzo ivato.

Per ulteriori spiegazioni vedi dettaglio Ddt prima e seconda parte

Sul campo prezzo unitario dell'articolo, nel dettaglio scontrino, è possibile premere i tasti:

  • F2 : rilegge il prezzo di listino
  • F3 : fa un elenco dei listini dell'articolo
  • F7 : serve a ivare il prezzo scritto a video in quanto lo scontrino ha necessità di avere sempre prezzi ivati. Ha senso premerlo SOLO se si digita manualmente un prezzo al netto dell'iva.

Se è attivato il parametro di personalizzazione MostraCostoUltimo uguale a S, è possibile premere il tasto F4 per visualizzare il costo ultimo dell'articolo.

E' possibile abilitare il Parametro di personalizzazione: NumDecValUni per il calcolo del valore unitario scontato

Se non c'è o vale -1, nel calcolo del prezzo unitario utilizza il numero di decimali 'di gestione', se vale -2 non arrotonda, se c'è un numero N arrotonda a N decimali (consigliato 5).

L'utilizzo di N decimali nel calcolo fa si che, per importi unitari molto piccoli e quantità grandi, il valore totale scontato (calcolato moltiplicando il valore unitario scontato (e arrotondato) per la quantità) sia effettivamente quello reale.

Piede scontrino:

E' possibile distinguere diverse modalità di incasso che produrranno, nella chiusura serale e nella registrazione in contabilità dell'incasso giornaliero, progressivi differenziati:

  • Contanti
  • Assegno
  • Carta di credito
  • Bancomat
  • Sospeso
    se l'importo dello scontrino viene incassato solo parzialmente o non viene incassato, si dovrà inserire l'eventuale l'importo incassato e, al posto del codice Conto sospeso che viene proposto, il codice del cliente che non ha pagato per tenerne traccia in contabilità.

Per attivare le voci Carta di Credito e Bancomat occorre aver spuntato l'apposita scelta nella Tabella per Registratore di Cassa (dal menu: Parametri e Utilità, scelta Dati Generali Azienda)

Parametri di personalizzazione: vedi Parametri per scontrini


CONTABILIZZAZIONE SCONTRINO

Percorso: Vendite - Scontrini - Stampa e contabilizzazione giornaliera scontrini

Questa funzione consente di stampare un riepilogo serale con i totali degli scontrini emessi nella giornata da poter quadrare con la chiusura del registratore di cassa.

A scelta dell'operatore, si può fare:

  • solo la stampa
  • la stampa e la contabilizzazione (cioè la registrazione in contabilità (prima nota) del movimento del corrispettivo)
  • la stampa e la cancellazione dei dati degli scontrini.

In caso di contabilizzazione occorre inserire il prefisso da assegnare ai movimenti generati mentre le causali vengono lette dalla tabella dei parametri registratore di cassa che dovranno essere stati compilati correttamente in precedenza.
Inoltre occorre compilare, sempre in Parametri e utilità - dati generali azienda, i conti comuni, in particolare: conto iva corrispettivi, abbuoni attivi e passivi, cliente corrispettivo (creare, se già non c'è, un cliente fittizio), conti cassa contante, cassa assegni, bancomat e carta di credito.
Se non si ritiene di dover utilizzare questi ultimi conti, basta ripetere il codice della cassa in tutte e tre le posizioni.

All'utente viene data la possibilità di imputare il codice del centro di costo da inserire nella registrazione del corrispettivo.

Le registrazioni fatte in contabilità sono le seguenti:

Caus.Corrispettivo (da Param.RegCassa) | Dare | Avere
Cliente Corrispettivo (per il tot. corrispettivo giornaliero) | 1.210,00 |
Merci c/Ricavi |  | 1.000,00
Iva Corrispettivi |  | 210,00

Caus.Giroconto (da Param.RegCassa) | Dare | Avere
Cliente Corrispettivo (per il tot. corrispettivo giornaliero) |  | 1.210,00
Cassa (**) | 1.210,00 |

(**) se ci sono state diverse forme di pagamento l' importo della riga DARE viene ripartito su tante righe: cassa contanti, cassa assegni, cassa carta di credito, ciascuno per gli importi degli scontrini incassati rispettivamente con contanti, assegno , carta.
Inoltre se ci sono dei sospesi, corrispettivi non incassati, l'importo verrà messo su una riga DARE nel conto generico 'Corrispettivi sospesi' (da Param. RegCassa) oppure dettagliato per ogni codice cliente a seconda che l'utente, nel piede scontrino abbia inserito o meno il cliente interessato.

Gli importi degli scontrini emessi a fronte di articoli con cod. reparto uguale al codice reparto per fatturazione (indicato in tabella dei dati per reg.di cassa, parametri comuni), cioè quelli per i quali è stata richiesta la fattura, vengono tolti dal totale giornaliero 'Contanti' prima di fare lo scarico in quanto verranno contabilizzati con l'emissione delle rispettive fatture.


CANC.GIORNALIERA SCONTRINI

Percorso: Vendite - Scontrini

Questa funzione serve a quanti non eseguono la stampa della chiusura serale e la contabilizzazione giornaliera degli scontrini, per poter cancellare gli scontrini di un giorno, prima di emetterne il giorno successivo.

Il programma di emissione scontrini colorerà di rosso lo sfondo del campo data, se trova in archivio scontrini fatti in una data diversa da quella visualizzata. La data degli scontrini in archivio viene visualizzata in fondo al video e non si lascia proseguire tranne se si emettono scontrini nella stessa data dei precedenti; in alternativa occorre eseguire la funzione di cancellazione scontrini.


CESPITI

La procedura, completamente integrata alla contabilità generale, consente di seguire i cespiti aziendali dal momento del loro acquisto, all'eventuale implementazione, fino alla loro alienazione.
E' possibile calcolare sia l'ammortamento civile sia quello fiscale.

La procedura può essere indipendente dalla contabilità oppure collegata ad essa (occorre specificarlo nei Dati generali cespiti)
Se si utilizza il collegamento, sulle 'opportune' causali di contabilità andranno compilati i campi relativi al collegamento con i cespiti: causale cespiti e mov.generato da cespiti.

La fattura di acquisto e di vendita del cespite può essere caricata dalla Prima Nota di contabilità, utilizzando una causale sulla quale è stato compilata la causale cespiti collegata, oppure direttamente dalla procedura cespiti.

Nel primo caso, se è stato impostato il parametro di personalizzazione LanCespiti terminata, in prima nota, la registrazione della fattura di acquisto il programma caricherà la gestione cespiti.
Sarà così possibile creare il cespite acquistato (o cercarlo se già stato creato), entrare nei movimenti, premere il pulsante [image] (O) Dati da prima nota e generare in automatico la riga del movimento di acquisto.
Essa potrà essere completata con le note ma contiene già i dati del fornitore, del documento e l'importo.
La stessa cosa vale per la cessione (vedere note in fondo al paragrafo)

Calcolo delle quote di ammortamento:

  • possibilità di eseguire simulazioni di ammortamento, anche infrannuali, che possono integrare i bilanci contabili, al fine di determinare la modalità più conveniente per l'azienda
  • calcolo delle quote per singoli cespiti o per gruppi
  • generazione automatica delle registrazioni contabili provvisorie e definitive
  • In caso di vendita del cespite verranno generate in automatico le registrazioni relative allo storno del fondo e alla rilevazione della plusvalenza o della minusvalenza.

Note per iniziare:

  • Individuare sulla tabella ministeriale dei coefficienti per i vari tipi di cespite, che viene fornita già compilata, il gruppo che interessa.
  • Compilare le tabelle causali cespiti, completare le causali di contabilità relative ai cespiti per i flag che li riguarda, compilare i Dati generali cespiti, poi gruppi e locazioni (se si intende gestirli) e infine la tabella di collegamento cespiti-contabilità.
    Su questa tabella, anche se non si utilizza la generazione automatica dei movimenti dei cespiti in contabilità, vanno compilate le causali cespiti per i vari tipi di ammortamento.
  • Successivamente si può procedere alla creazione dei singoli cespiti.

Per i cespiti acquistati negli anni precedenti e già parzialmente ammortizzati, è possibile, dopo aver inserito il movimento di acquisto, generare in automatico i movimenti di ammortamento degli anni precedenti.


CESPITI - TABELLA MINISTERIALE

Percorso: Cespiti - Gestioni - Tabella unica per tutte le ditte

Questo elenco di codici, memorizzato nel database del menu su tre tabelle: Cespiti_Gruppi, Cespiti_Speci, Cespiti_TabCoeff, contiene l'insieme dei coefficienti di ammortamento delle Tabelle ministeriali.

Questi coefficienti rappresentano i valori massimi di ammortamento, salvo eccezioni ma potranno essere variati, cespite per cespite.

Il codice, che verrà richiamato nel singolo cespite come 'categoria', è così composto:

XXYYYZZZ

XX è il gruppo, da inserire con l'apposita funzione: Gestione Gruppi della tabella ministeriale
Ad ogni gruppo si possono associare più Specie definite come segue:

XXYYY (cioè il codice gruppo al quale vengono aggiunti 3 caratteri), da inserire con l'apposita funzione: Gestione Speci della tabella ministeriale.

Per ogni Specie si possono creare più Categorie, il cui codice XXYYYZZZ è XXYYY=cod.Specie al quale vengono aggiunti altri 3 possibili caratteri (ZZZ) per distinguere le varie categorie della specie.


CESPITI - DATI GENERALI

Percorso: Cespiti - Gestioni - Tabelle varie

Questa tabella deve essere compilata prima di iniziare ad utilizzare la procedura cespiti.

Collegamento con contabilità
Questo flag indica se la procedura cespiti viene utilizzata in collegamento con la contabilità. Se spuntato, si potrà utilizzare la funzione Contabilizzazione cespiti, che genera in automatico i movimenti di contabilità relativi ai cespiti.
Inoltre, se verrà creato il parametro di personalizzazione LanCespiti e sono state compilate in modo opportuno le causali di contabilità (campo: causale cespiti), terminata, in prima nota, la registrazione di una fattura di acquisto il programma caricherà la gestione cespiti.

Se si utilizza questo collegamento, sulle causali di contabilità andranno compilati i campi relativi al collegamento con i cespiti.

Valore minimo sotto cui si ammortizza tutto nell'anno di acquisto
Se un cespite ha un valore di acquisto minore o uguale all'importo scritto in questo campo, verrà ammortizzato tutto nell'anno di entrata in uso scritto sulla anagrafica cespite.

Contabilizzazione perdita fiscale
(dal 2004 non è più prevista la generazione della perdita fiscale)
Subito o a Fine Anno
A seconda di quanto indicato in questo flag, se si lavora in collegamento con la contabilità, l'eventuale Perdita Fiscale, generata da un ammortamento con percentuale minore alla metà della percentuale di legge, verrà registrata in contabilità subito (cioè nel momento in cui si registra l'ammortamento) o a Fine anno. Segue la richiesta della causale di contabilità e dei conti per la registrazione.
Causale per la registrazione della perdita fiscale
Conto per la registrazione annuale dell'eventuale perdita fiscale
Conto ammortamenti non effettuati
servono per la registrazione dell'eventuale perdita fiscale da farsi al momento dell'ultimo ammortamento del cespite o alla sua vendita.

Quota manutenzioni e riparazioni deducibili nell'esercizio
Indicare la percentuale spese di Manutenzione e Riparazioni deducibili nell'esercizio (dato facoltativo se è uguale a 5%).

Quota man. rip. deducibili nell'esercizio per automezzi di autotrasportatori
Indicare la percentuale spese di Manutenzione e Riparazioni deducibili nell'esercizio (dato facoltativo se è uguale a 25%).

Causale per ammortamento civile
E' la 'causale cespiti' che verrà proposta al momento della creazione dei movimenti di ammortamento CIVILE dei cespiti.

Come calcolo ammortamento civile
Indica come si vuol calcolare l'ammortamento civile. Si può scegliere di calcolarlo secondo le regole dell'ammortamento civile oppure secondo quelle del fiscale.

Se per un cespite particolare si vuole eseguire il calcolo diversamente, basta impostare questo flag sul cespite stesso.

Se si sceglie di calcolare il civile come il fiscale, il calcolo verrà fatto, per tutti gli anni, utilizzando le stesse percentuali del fiscale.


CAUSALI CESPITI

Percorso: Cespiti - Gestioni - Tabelle varie

Questa tabella consente di inserire le causali con le quali verranno inseriti i movimenti dei cespiti: acquisto, rivalutazione, vendita etc.

Vendita/Alienazione
Se impostata a Si, indica una causale di vendita (o alienazione) del cespite (tutti gli altri flag dovranno essere a No)

Per un corretto funzionamento delle stampe, al momento della vendita o dell'alienazione di un cespite, è necessario creare un movimento cespiti con una causale di questo tipo in modo.
Il cespite verrà così "marcato" come "venduto/alienato".
(N.B. Non basta spuntare semplicemente il campo "venduto/alienato" sul cespite).

Se si intende, a fine anno, generare in automatico in contabilità i movimenti dei cespiti, occorre creare tra le causali di contabilità una causale di Vendita cespiti (di tipo fattura) e mettere come causale cespiti collegata, una causale cespiti con il flag di Vendita a Si.

Nel momento della vendita del cespite, si dovrà registrare la fattura in contabilità e, come conto di ricavo, si utilizzerà un conto 'transitorio cessioni cespiti' creato tra le immobilizzazioni. Al termine della registrazione in prima nota della fattura, verrà lanciata in automatico la Gestione cespiti.
Dopo aver cercato il cespite in oggetto, essere entrati nei suoi movimenti con il tasto F10, premuto il pulsante di Nuovo [image] e il pulsante [image] che richiama i dati dalla contabilità, verrà compilata la maschera con i dati della fattura appena registrata e verrà quindi creato un movimento di vendita cespite con la causale (di tipo vendita) collegata alla causale fattura.

Al momento della generazione automatica in contabilità dei movimenti dei cespiti, in corrispondenza al movimento di vendita, verrà fatta una registrazione che chiude il Cespite con il relativo Fondo che rileva la plusvalenza o la minusvalenza
Esempio:

Fondo autovetture 19000 Dare
Transitorio cess. Cesp 6800 Dare
Plusvalenze 6800 Avere
Autovetture 19000 Avere

La causale del movimento generato è quella del giroconto indicata nella tabella di collegamento Cespiti-Contabilità nella sezione Cessioni. Anche tutti gli altri codici dei conti che intervengono in questa registrazione vengono presi da questa tabella.

Dismissione
Indica se si tratta di una causale di vendita parziale del cespite. In caso di Dismissione totale è necessario utilizzare una causale di tipo Vendita/Alienazione e non Dismissione in modo da gestire bene la chiusura completa del cespite.
In corrispondenza ad un movimento con questa causale verranno decrementati il valore iniziale (fiscale) del cespite e il fondo per importi digitati dall'utente e si potrà determinare una plusvalenza o una minusvalenza.
(tutti gli altri flag dovranno essere a No)

Nelle causali di dismissione non è possibile impostare il flag che indica se il movimento corrispondente interviene solo nel calcolo dell'ammortamento civile, del fiscale o di entrambi: Dove si applica (Entrambi, Solo civile, Solo fiscale).

Se fosse necessario differenziare i valori di dismissione, si suggerisce di far seguire un movimento di rivalutazione/svalutazione del fondo e del bene.

Acquisto- Rivalutazione-Svalutazione Bene
Indica se si tratta di causale per la registrazione dell' acquisto di un cespite oppure se deve incrementare o decrementare il suo valore originale (valore da cui parte il calcolo dell' ammortamento)

  • Non gestito
    i movimenti fatti con questa causale non modificano il valore iniziale del cespite
  • Acquisto
  • Incrementa l'importo di acquisto
  • Rivaluta il cespite
  • Svaluta il cespite

Se la causale è di acquisto o incremento dell'acquisto, non è possibile impostare il flag che indica se il movimento corrispondente interviene solo nel calcolo dell'ammortamento civile, del fiscale o di entrambi: "Dove si applica (Entrambi, Solo civile, Solo fiscale)".

Viceversa il flag è gestibile in causali di rivalutazione e svalutazione del bene.

Rivalutazione-Svalutazione Fondo
Indica se la causale deve incrementare o decrementare il fondo del bene (a seconda del valore che assume il flag "Dove si applica (Entrambi, Solo civile, Solo fiscale)"

Se non deve gestire il fondo, impostare a Non gestisce (es. una causale di acquisto o vendita, oppure di rivalutazione o svalutazione SOLO del bene e non del fondo)

E' possibile creare un'unica causale per fare insieme Rivalutazione e Svalutazione del Bene e del Fondo, utilizzabile però solo quando l'importo sia lo stesso per entrambi. In generale però si consiglia di creare causali diverse.
Quando si creeranno dei movimenti cespiti con causali di questo tipo, occorre fare attenzione che abbiano il flag "Stato mov.Coge" uguale "PN manuale".

Dove si applica (Entrambi, Solo civile, Solo fiscale)
Questo campo consente di predisporre delle causali di incremento (o decremento) del bene o del fondo che agiscano solo sul calcolo dell'ammortamento civile o solo sul fiscale.
Possono servire, ad esempio, per gestire il fatto che, in fase di conferimento d'azienda, un cespite abbia un valore fiscale diverso dal civile (per non far generare plusvalenza sull'azienda conferita).
I movimenti con causali di questo tipo vanno caricati sulla maschera dei movimenti civili.
Nel caso si sia scelto di fare il calcolo dell'ammortamento civile uguale a quello fiscale, il programma, pur applicando le stesse regole per il calcolo dei due ammortamenti, terrà conto degli eventuali movimenti che incrementano o decrementano SOLO uno dei due valori (civile o fiscale) e darà quindi valori diversi di ammortamento.

Se si rende necessario caricare un cespite già ammortizzato completamente o parzialmente è possibile adottare 2 soluzioni diverse dopo aver creata l'anagrafica Cespite e inserito manualmente il movimento di acquisto cespite:

  • Generare in automatico i movimenti di ammortamento per gi anni precedenti all'attuale, con il pulsante apposito dalla maschera di Gestione dettagli di un cespite, premendo il pulsante: (Y) Crea movimenti di ammortamento
  • Creare una causale per caricare il valore storico del fondo es. 'Caricamento Fondo Storico' con le caratteristiche:
    Rivalutazione/Svalutazione Bene valorizzato a Non gestito
    Rivalutazione/Svalutazione Fondo valorizzato a Incrementa
    Dove si applica valorizzato a: Entrambi
    Poi inserire un movimento, sul cespite, con questa causale mettendo il valore del Fondo di Ammortamento per il cespite in oggetto (valore già ammortizzato)

Accertarsi che entrambi i movimenti abbiano il campo 'Stato Mov. Coge' a Prima Nota manuale.

comunque caricare un cespite con una situazione iniz


CESPITI - STAMPA CAUSALI

Percorso: Cespiti - Gestioni - Stampe

Il programma stampa l'elenco delle causali create per la movimentazione dei cespiti.


CESPITI - GRUPPI e LOCAZIONI

Percorso: Cespiti - Gestioni - Tabelle varie

Queste tabelle contengono rispettivamente i gruppi e le locazioni da assegnare ai vari cespiti dell'azienda.


CESPITI - TAB COLL. CESPITI-COGE

Percorso: Cespiti - Gestioni - Tabelle varie

Questa tabella consente di collegare a ciascun cespite dell'azienda, le causali cespiti, le causali contabili e i conti necessari per la generazione automatica delle registrazioni degli ammortamenti (ordinario, anticipato, posticipato) e relativo passaggio in contabilità.
Inoltre si chiede di inserire i conti da utilizzare per le registrazioni di chiusura del cespite e di rilevazione di plusvalenza e minusvalenza, al momento della cessione (vendita o alienazione).

In generale si consiglia di creare una tabella per ogni conto di Ammortamento/Fondo presente sul piano dei conti in modo che, ad ogni cespite, si possa poi collegare la tabella corrispondente.
(Es. Mobili e arredi, Macchine per ufficio etc.)

Se si lavora con i cespiti scollegati dalla contabilità, occorrerà compilare SOLO le causali per i movimenti cespiti e si può creare anche un'unica tabella.

Le causali di contabilità richiamate in questa tabella, dovranno avere il flag: generato da cespite impostato a Si

Se l'azienda è in semplificata, ogni registrazione fatta in contabilità dovrà avere una causale del tipo 'fattura di acquisto' e i conto 'fondo' dovranno essere dei fornitori fittizi.

Codice tabella
Questo codice dovrà essere poi indicato nell'anagrafica di ogni cespite nel campo Raccordo Contabilità.

Conto Immobilizzazioni
E' il conto nel quale verranno registrate in contabilità le poste patrimoniali attive per il cespite in oggetto (es. Attrezzature, Arredi locali, Macchinari e Impianti, Telefoni cellulari etc.).

Conto quote indeducibili ammortamento ordinario o posticipato
E' il conto su cui verranno registrate le eventuali quote indeducibili

Causale per ammortamento civile
E' la causale che verrà proposta al momento della creazione dei movimenti di ammortamento CIVILE, per i cespiti appartenenti a questa categoria.

Ammortamento ordinario

Causale movimenti cespiti (fiscali)
E' la causale che verrà utilizzata dalla generazione automatica degli ammortamenti per la generazione della riga di ammortamento fiscale annuale (dato obbligatorio)

I dati che seguono sono obbligatori SOLO se nella tabella generale Cespiti si è dichiarato di utilizzare la generazione automatica dei movimenti in contabilità.

Causale Ammortamento Ordinario
E' il codice della causale di contabilità con cui verrà fatta la registrazione annuale dell'ammortamento ordinario (o la ripartizione delle plusvalenze/minusvalenze)

Conto Ammortamento Ordinario
Conto nel quale va, come costo di esercizio, la quota di ammortamento Ordinario

Su questo conto si registra al 31/12 la quota di ammortamento ed essendo economico si chiude a profitti e perdite. Ci sarà un conto per ogni bene da ammortizzare o per ogni gruppo/categoria di beni (mastro ammortamenti, economico costi)

Conto Fondo Ammortamento Ordinario
Conto nel quale verranno registrati, come poste patrimoniali passivi, i fondi di ammortamento derivati dall'ammortamento ordinario

Ammortamento anticipato

Causale per movimento cespiti di ammortamento anticipato
Si può inserire il codice di una causale creata appositamente per effettuare l'ammortamento anticipato o la stessa messa per l'ammortamento ordinario.

Causale Ammortamento anticipato
Codice causale da utilizzare nella registrazione in contabilità dell'ammortamento anticipato. Può essere la stessa dell'ammortamento ordinario.

Conto Ammortamento anticipato
Conto nel quale va, come costo di esercizio, la quota di ammortamento anticipato. Può essere lo stesso dell'ammortamento ordinario.

Conto Fondo Ammortamento anticipato
Conto nel quale vanno, come poste patrimoniale passive, i fondi di ammortamento derivati dall'ammortamento Anticipato.
Può essere lo stesso dell'ammortamento ordinario.

Conto quote indeducibili amm. anticipato
Conto di costo su cui verrà registrata la parte non deducibile di un ammortamento anticipato.

Ammortamento posticipato

Causale per movimento cespiti di ammortamento posticipato

Causale Ammortamento posticipato
causale contabile per registrazione di ammortamento posticipato.

Conto ammortamento posticipato
C/to nel quale va, come costo di esercizio, la quota di ammortamento posticipato.

Conto Fondo Ammortamento posticipato
C/to nel quale va, come costo di esercizio, il fondo ammortamento posticipato.

Cessioni

I dati inseriti in questa sezione serviranno al programma per generare in automatico il movimento di chiusura del Cespite in contabilità a fronte della registrazione di un movimento di vendita sul cespite.

Alla vendita di un cespite devono essere eseguiti i seguenti passaggi:

si dovrà registrare la fattura di vendita in contabilità e, come conto di ricavo, si utilizzerà un conto 'transitorio cessioni cespiti' creato tra le immobilizzazioni. Al termine della registrazione in prima nota della fattura, se alla causale era stata agganciata una causale di vendita cespiti, verrà lanciata in automatico la Gestione cespiti e, dopo aver cercato il cespite in oggetto, essere entrati nei suoi movimenti con il tasto F10, premuto il pulsante di Nuovo [image] , verrà presentata o si dovrà digitare una causale, cespiti, di vendita e, con il pulsante [image] richiamare i dati dalla contabilità; verranno richiamati i dati della fattura appena registrata.

Al momento della generazione automatica in contabilità dei movimenti dei cespiti, in corrispondenza al movimento di vendita, verrà fatta una registrazione che chiude il Cespite con il relativo Fondo che rileva la plusvalenza o la minusvalenza
Esempio:

Giroconto | Dare | Avere
Fondo autovetture | 19000 |
Transitorio cess. Cesp | 6800 |
Plusvalenze |  | 6800
Autovetture |  | 19000

La causale del movimento generato è quella indicata qui sotto come: Causale Cessione Beni Ammortizzabili e anche i conti utilizzati sono quelli di questa tabella.

Causale Cessione Beni Ammortizzabili
Causale di contabilità da utilizzare per la registrazione della cessione beni ammort. (è un GIROCONTO)

Conto Cessione Beni Ammortizzabili
C/to nel quale registrare le CessBeniAmm (è un conto transitorio Cessione cespiti)

Conto Plusvalenza
Conto a cui imputare le eventuali plusvalenze determinatasi dall'alienazione dei cespiti

Conto Minusvalenza
Conto a cui imputare le eventuali Minusvalenze determinatasi dall'alienazione dei cespiti

Conto Plusvalenza esente
Conto a cui imputare la Plusvalenza esente determinatasi dall'alienazione di un cespite con deducibilità fiscale limitata (es. autovetture)

Conto Minusvalenza indeducibile
Conto a cui imputare la Minusvalenza indeducibile che si origina dall'alienazione di un cespite con deducibilità fiscale limitata (es. autovetture)
La parte indeducibile o esente si calcola in rapporto agli ammortamenti non deducibili del cespite con la seguente formula:
% minusvalenza inded. O plusvalenza esente = (Ammortamento indeducibile/Tot.fondo ammortamento)*100


GESTIONE CESPITI

Percorso: Cespiti - Cespiti

Con questa funzione l'utente inserisce e varia le schede anagrafiche dei cespiti e i movimenti ad essi collegati.
Il codice del cespite è alfanumerico e può essere creato liberamente.

E' tuttavia possibile generare automaticamente il codice cespite dopo aver creato il parametro di personalizzazione ChiaveBaseLun che indica la lunghezza (il numero di cifre) del codice cespite 'numerico' e progressivo da generare in automatico dopo che l'utente avrà premuto il pulsante
'Crea codice automatico'.
Es. se il parametro vale 4, la generazione automatica dei codici produrrà 0001, 0002, 0003 etc.
Se questo parametro viene impostato a -1, a video viene tolto il pulsante che consente questo automatismo.
Inoltre si può impostare il parametro ChiaveBase contenente alcuni caratteri di 'Prefisso' da usare come base per calcolo automatico del codice cespite.
Es. se si vogliono numerare progressivamente i cespiti: macchinari, automezzi, mobili, si potrebbe mettere in questo parametro la sigla dei cespiti del gruppo più numeroso es. MACC per macchinari

Quando si andrà a creare i cespiti, se si preme subito il pulsante di generazione automatica del codice, il programma assegnerà un codice MACC0001, poi MACC002 etc. se invece l'operatore scriverà alcuni caratteri poi premerà il pulsante (es. AUTO), il codice generato sarà AUTO0001, AUTO0002 etc.

Una volta creato un cespite, se questo è collegato ad uno preesistente, si può dichiarare il collegamento con il pulsante: (Y) Collega ad altro cespite. Verrà chiesto di inserire il codice del cespite Padre, cioè quello a cui è collegato.
In questo caso i due o più cespiti avranno vita indipendente però nella scheda del principale si potranno vedere e gestire i cespiti ad esso collegati e i progressivi tenendo conto anche dei cespiti collegati.

Categoria
Categoria di appartenenza del cespite (decodifica da tabella Ministeriale). Da questa tabella vengono visualizzate e proposte per questo cespite, le percentuali di ammortamento civile e fiscali.

% di Ammortamento civile e fiscale
L'utente può variare queste percentuali nell'ambito della legge. Al momento della generazione automatica dell'ammortamento, il programma prenderà queste percentuali se verrà indicato: percentuale dal cespite.

Anno di acquisto del cespite
Campo obbligatorio.

Venduto/Alienato
Se spuntato, indica che il cespite è stato venduto (o alienato).
Il programma spunterà in automatico, al momento della creazione del movimento di vendita/alienazione, questo campo e il campo che indica che il cespite è "chiuso".

Chiuso e anno di chiusura
Se impostati indicano che il cespite è chiuso. Il programma porrà in automatico il cespite chiuso al momento dell'ultimo ammortamento o alla vendita.

Sulla barra delle icone sono disponibili le seguenti possibilità:

  • si accede all'inserimento o variazione dei movimenti civili del cespite.
  • si accede all'inserimento o variazione dei movimenti di ammortamento fiscale del cespite (vedi ammortamento fiscale)
  • (X) Gestione Cespiti collegati
    Si possono gestire i dati degli eventuali cespiti collegati al principale già in gestione.

QUADRO (1) DATI

Tipo Bene
M=Materiale I=Immateriale C=Costo pluriennale (derivato da quota di spese che non possono essere dedotte nell'esercizio in cui si manifestano)

Data e anno entrata in uso
Data obbligatoria dalla quale inizia il calcolo dell'ammortamento per beni materiali. E' fondamentale perché determina l'anno di inizio dell'ammortamento.
Viene utilizzata questa data anche per il calcolo delle manutenzioni (5%)

Usato
Indica se il cespite in oggetto, al momento dell'acquisto, era nuovo o usato (se usato si può applicare l'ammortamento anticipato solo per il primo anno, nel calcolo dell'ammortamento fiscale)

Data disponibilità (anno)
Indica la data dalla quale iniziare il calcolo dell'ammortamento civile. Se questa data non è compilata il programma considererà come data iniziale la data di entrata in uso.

Perc. indeducibilità quote di ammortamento civile e valore massimo ammortizzabile civile
Campi utilizzati nel calcolo dell'ammortamento civile, equivalenti a quelli dell'ammortamento normale.

Uso Promiscuo
Se impostato a Si indica che il cespite è un bene ad uso promiscuo.

Percentuale Indeducibile Uso Promiscuo
Questa percentuale è obbligatoria se il cespite è ad Uso promiscuo in quanto in questo caso c'è sempre una parte indeducibile. Se è valorizzata, verrà utilizzata questa, come % di indeducibilità civile al posto della % inded. Civile.
Se la % quota indeducibilità fiscale è vuota, per il calcolo dell'ammortamento fiscale si utilizza quella utilizzata per il calcolo dell'ammortamento civile.

Valore massimo ammortizzabile
Viene usato SOLO se presente una % di quota indeducibile. Rappresenta l'eventuale valore su cui viene calcolata annualmente la % di ammortamento (sostituisce cioè il valore fiscale), la quota di ammortamento risultante come differenza tra la % calcolata sul valore fiscale e il valore di cui sopra, è indeducibile.
Esempio:
 Valore del cespite: 1500
% ammortamento 10%
% inded 20%
massimo ammortizzabile: 500
Si calcola il 10% di 500 = 50
(Cioè si fa l'ammortamento del massimo ammortizzabile)
Si applica la % di indeducibilità al risultato ( se questa è diversa da 0):
cioè si fa il 20% di 50 = 10
La quota di ammortamento diventa perciò: 50-10 = 40 mentre l'Importo non Detraibile è 110 cioè la differenza: 150 - 40
(dove 150 è l'effettivo importo dell'ammortamento, in mancanza del max ammortizzabile: cioè il 10% di 1500)

Codice Raccordo con la Contabilità
Questo codice fa riferimento alla tabella nella quale è possibile definire, per ogni tipo di cespite, le causali per la generazione automatica degli ammortamenti, le causali di contabilità e i conti che serviranno per registrare in contabilità gli ammortamenti. (Cespiti , Gestioni, Tabella di collegamento Cespiti-Contabilità).
NOTA: Il campo non è obbligatorio ma il programma segnala con un messaggio al momento del 'salva' se viene lasciato bianco.
Questo perché, se viene lasciato bianco, non si consentirà di generare in automatico, per questo cespite, né i movimenti di ammortamento né di creare i movimenti in contabilità.

Bene Strumentale
Indica se il cespite in oggetto è un bene strumentale. Il default è Si

Gruppo - Locazione
Decodifica da tabella gruppi - locazioni cespiti

Centro di Costo
Decodifica da tabella centri di costo

Pubblico Registro
Impostare a Si se il bene è iscritto nei pubblici registri e/o bene immobile

Non considero per base 5%
Se impostato a Si, il bene NON verrà considerato nel calcolo della quota deducibile nell'esercizio delle spese di riparazione e manutenzione. (beni materiali)

Calc.amm. civile
Indica come si vuol calcolare l'ammortamento civile.
Viene impostato di default come è stato impostato sulla tabella cespiti.

Se per un cespite particolare si vuole eseguire il calcolo diversamente da quanto specificato in tabella, si potrà scegliere di calcolare:

  • secondo le regole dell'ammortamento civile
  • secondo le regole dell'ammortamento fiscale

Autotrasportatori c/terzi
Se S indica automezzo di trasportatore c/terzi la cui deduzione del valore delle spese di manutenzione e riparazione è del 25%

Generazione Automatica Ammortamento
Se posto a No indica che non si vuole eseguire la generazione automatica degli ammortamenti di questo cespite.

QUADRI (2) e (6) Altri dati - Civile e Fiscale

La maschera riporta la situazione dell'ammortamento del cespite. Viene visualizzato l'anno nel quale è stato calcolato l'ultimo movimento di ammortamento.

Valore
E' il valore attuale del cespite tenendo conto sia del valore iniziale sia degli eventuali incrementi o decrementi.

Totale fondo ammortamento:
di cui ordinario, anticipato, posticipato

Con rivalutazione fondo:
ordinario, anticipato, posticipato

Con svalutazione fondo:
ordinario, anticipato, posticipato

Totale indetraibile: di cui ordinario, anticipato, posticipato

Perdita Fiscale
Dal 2004 la legge non prevede che venga più generata una perdita fiscale.
(Valore non più ammortizzabile fiscalmente. La perdita fiscale si genera ogni volta che si fa un ammortamento con percentuale inferiore a meno della metà della percentuale di legge. Per quanto riguarda la contabilizzazione della perdita fiscale si consiglia di leggere le note della funzione: cespiti - dati generali)

Residuo ammortamento
Viene calcolato il residuo da ammortizzare

Plusvalenza - Minusvalenza

Se il cespite è chiuso viene visualizzata l'eventuale plusvalenza o minusvalenza realizzata.

QUADRI (3) e (7) Altri dati con figli - VALORI DI RIEPILOGO

Sono gli stessi dati riportati nel folder precedente, però calcolati tenendo conto anche di tutti i cespiti 'figli' cioè dipendenti da quello in elaborazione

QUADRO (4) NOTE

Note e Stampa note
E' disponibile un campo note che si può scegliere se stampare o no sul libro cespiti

Descrizione

Matricola e Targa
Dati descrittivi del cespite
Con un clik sull'icona [image] si accede all'inserimento o variazione dei movimenti civili del cespite.

Con un click sull'icona [image] si accede all'inserimento o variazione dei movimenti di ammortamento fiscale del cespite.

Cespiti collegati Premendo il pulsante [image] si possono gestire i dati degli eventuali cespiti collegati al principale già in gestione.


CESPITI - MOVIMENTI

Percorso: Cespiti - Cespiti - Gestione cespiti dettaglio

Gestione dettaglio movimenti ammortamento civile

Premendo il pulsante [image] (G) Dettaglio movimenti fiscali si consente di gestire i movimenti fiscali del cespite.

Tali movimenti possono essere generati in automatico dalla proceduta con il pulsante [image] (Y) Crea movimenti di ammortamento dall'interno della gestione cespiti - dettagli.

Ogni movimento è caratterizzato da una causale che dovrà essere creata con il programma di Causali cespiti.

Dal campo causale si esce con il tasto TAB e si vanno a compilare i campi successivi.

Anno e data movimento
Esercizio di competenza e data del movimento

Tipo ammortamento
Se si tratta di un movimento di ammortamento il campo tipo ammortamento è obbligatorio.
Se il movimento è stato generato dalla generazione automatica dei movimenti di ammortamento, questo campo viene compilato con il tipo ammortamento scelto nell'elaborazione.

Percentuale di ammortamento
E' la % di ammortamento applicata nel calcolo del movimento.

E' possibile cambiare la percentuale di ammortamento (quando si generano dei movimenti manualmente) ma in questo caso il programma calcola l'importo massimo ammortizzabile in base alla % di ammortamento fiscale oppure personalizzata scritti sulla anagrafica del cespite, poi tiene conto del flag che indica se il primo anno si deve fare l'ammortamento ridotto e mette l'importo che eccede, nel campo importo non detraibile.

Per cui per fare un ammortamento con una % particolare (es. 100% anche quando non ci sono le condizioni di importo < 516 euro), occorre scrivere sul cespite, in testata che si vuole fare un ammortamento fiscale personalizzato, mettere la relativa percentuale e togliere il flag che dice che il primo anno si fa l'ammortamento ridotto.

Importo e importo non detraibile
L'importo è l'importo dell'ammortamento
Se sul cespite c'è una percentuale non detraibile, in importo non detraibile viene memorizzata la parte non detraibile dell'ammortamento mentre in importo la parte detraibile.
In questo importo viene inoltre memorizzata la parte non detraibile dell'importo ammortizzato nel caso si sia effettuato un ammortamento con % maggiore del consentito per legge (vedi campo precedente)

Perdita Fiscale
(Non utilizzata dal 2004)
Calcolata dalla procedura di calcolo ammortamento, si genera quando si ammortizza un bene a una % minore alla metà della % di legge

Nota Libro Cespiti
Nota da stampare sul libro cespiti

Stato movimento
Provvisorio o Definitivo

Stato movimento coge
Sempre bianco in quanto sono i movimenti civili e non i fiscali a generare movimenti in contabilità.

Tipo inserimento
Indica se il movimento è stato inserito manualmente o è stato generato dalla procedura.


CESPITI - MOVIMENTI AMMORTAMENTO CIVILE

Percorso: Cespiti - Cespiti - Gestione cespiti dettaglio

Premendo, dalla gestione dell'anagrafica del cespite, il tasto
(E-F10) si accede alla gestione dei movimenti di ammortamento civile del cespite. Con questa maschera dovranno essere inseriti anche tutti i movimenti del cespite (acquisto, incremento/decremento, eventuali dismissione parziale e vendita) tranne i movimenti di ammortamento fiscale.

Il calcolo dell'ammortamento civile viene fatto in base a quanto specificato nel campo: Calcolo amm. Civile, presente sulla maschera principale di ogni cespite e cioè:

  • con le regole del civile
    il programma NON consentirà, ad esempio, di fare l'ammortamento civile anticipato e posticipato
  • con le regole del fiscale
    il programma consentirà di fare l'ammortamento civile anticipato e posticipato e creerà i movimenti con la stessa causale usata per il fiscale.

Se si lavora in collegamento con la contabilità, se è stato impostato il parametro di personalizzazione LanCespiti e sono state compilate in modo opportuno le causali di contabilità (campo: causale cespiti):
terminata, in prima nota, la registrazione di una fattura di acquisto il programma caricherà la gestione cespiti.
Sarà così possibile creare il cespite acquistato (o cercarlo se già stato creato), entrare nei movimenti, premere il pulsante [image] (O) Dati da prima nota e generare in automatico la riga del movimento di acquisto.
Essa potrà essere completata con le note ma contiene già i dati del fornitore, del documento e l'importo.
La stessa cosa vale per la cessione (vedere note in fondo al paragrafo)

I movimenti di ammortamento possono essere generati in automatico dalla proceduta con il pulsante
(Y) Crea movimenti di ammortamento.

Ogni movimento è caratterizzato da una causale che dovrà essere creata con il programma di Causali cespiti.
E' possibile creare delle causali per movimentare i cespiti, fatte in modo tale da consentire un incremento (o decremento) del bene o del fondo che agiscano solo sul calcolo dell'ammortamento civile o solo sul fiscale.
Possono servire, ad esempio, per gestire il fatto che, in fase di conferimento d'azienda, un cespite abbia un valore fiscale diverso dal civile (per non far generare plusvalenza sull'azienda conferita).

Dal campo causale si esce con il tasto TAB e si va a compilare i campi successivi.

Anno e data movimento
Esercizio di competenza e data del movimento

A seconda della causale inserita vengono chiesti/presentati fino a tre gruppi di dati:

  • (1) Principale
    Maschera comune a tutte le causali
  • (2) Acquisto , Vendita e Dismissione Totale
    Per i movimenti di acquisto, vendita/alienazione - dismissione totale vengono gestiti i dati della fattura: fornitore (cliente) , data e numero protocollo e documento, note
  • (3) Esclusione (Dismissione) parziale
    NB: la dismissione totale deve essere fatta con una causale di tipo vendita in modo che venga settato in automatico il campo VENDUTO sul cespite

(1) Principale

Tipo ammortamento
Se si tratta di un movimento di ammortamento il campo tipo ammortamento è obbligatorio.
Se il movimento è stato generato dalla generazione automatica dei movimenti di ammortamento, questo campo viene compilato con il tipo ammortamento scelto nell'elaborazione.

Percentuale di ammortamento
E' la % di ammortamento applicata nel movimento
(va inserita SOLO se si tratta di movimento di ammortamento)

Importo e importo non detraibile
L'importo è l'importo del movimento (il costo se si tratta di un acquisto o un incremento , il ricavo nel caso di dismissione o vendita, oppure l'importo dell'ammortamento)

Se sul cespite c'è una percentuale non detraibile, in importo non detraibile viene memorizzata la parte non detraibile dell'ammortamento mentre in importo la parte detraibile.

In questo importo viene inoltre memorizzata la parte non detraibile dell'importo ammortizzato nel caso si sia effettuato un ammortamento con % maggiore del consentito per legge (vedi campo precedente)

Perdita Fiscale
(Campo non utilizzato dal 2004)
Calcolata dalla procedura di calcolo ammortamento, si genera quando si ammortizza un bene a una % minore alla metà della % di legge

Anno e numero della registrazione di prima nota generata
Se è stata generata la prima nota dai cespiti (Contabilizzazione cespiti), questi campi contengono la chiave del movimento generato.

Nota Libro Cespiti
Nota da stampare sul libro cespiti

Stato movimento
Provvisorio o Definitivo. Se provvisorio non è possibile fare la generazione dei movimenti sulla contabilità definitiva (fiscale) ma solo sulla fittizia

Stato movimento coge
Stato del movimento rispetto la generazione della contabilità: Non generata, generato un movimento provvisorio, generato un movimento definitivo, prima nota manuale (cioè non c'è un collegamento).

Se è stato generato un movimento provvisorio, l'importo lo si potrà vedere nel bilancio solo includendo i movimenti provvisori.

Non è ammessa la variazione di una riga per la quale sia stato generato un movimento definitivo.

Lo stato dei movimenti può essere cambiato tramite appositi pulsanti presenti in alto a destra sulla barra degli strumenti.
 (B - Cambia stato movimento Coge)

NOTA: in tutti i movimenti relativi ad anni nei quali in contabilità, gli ammortamenti, sono stati registrati manualmente, è indispensabile che questo flag sia impostato a: prima nota manuale.
Il programma di controllo quadratura Cespiti-Coge, esclude dal calcolo i movimenti che hanno questo flag bianco

Tipo inserimento
Indica se il movimento è stato inserito manualmente o è stato generato dalla procedura.

(2) Acquisto/Vendita (Dismissione Totale)

Data di acquisto o Data di cessione
(non utilizzata)

Importo Iva Indetraibile
E' l'importo di iva indetraibile rilevata all'acquisto del cespite. Può essere presente solo nei movimenti di acquisto.

Plusvalenza-Minusvalenza (civile e fiscale)
Questo importo viene calcolato in automatico al momento della vendita (o dismissione parziale) del cespite.
Il calcolo si fa solo se il movimento cespiti è definitivo

Nel caso che il cespite abbia una percentuale di indetraibilità, si calcola:
Perc. = Tot. fondo ammortamento / (Tot. fondo ammortamento + eventuale Tot.indetraibile)
Plusvalenza o Minusvalenza= Importo della vendita*Perc.

Plusvalenza-Minusvalenza non tassabili (civile e fiscale)
Sono relativi alla vendita di un automezzo che aveva una parte indeducibile (es. agente di commercio 80% deducibile, 20% indeducibile…)

Plusvalenza Reinvestita
Plusvalenza reinvestita, la deve digitare l'utente in caso si sia realizzata, con la vendita, una plusvalenza e questa venga reinvestita.

(3) Esclusione (Dismissione) Parziale

(NB: la dismissione totale deve essere fatta con una causale di tipo vendita)

Percentuale della parte dismessa
Opzionale. Se si inserisce questo campo verranno calcolati tutti gli altri come percentuale dei rispettivi valori del cespite di riferimento.
Questo campo non viene memorizzato per cui tornando su un movimento esistente esso viene ricalcolato. Occorre perciò fare molta attenzione a non riposizionarsi su di esso e premere invio, altrimenti gli importi in maschera verranno ricalcolati, tenendo conto delle eventuali dismissioni già presenti (anche in anni successivi).
In alternativa, si può ignorare la percentuale e digitare manualmente gli importi successivi.

Valore fiscale
E' il valore fiscale relativa alla parte dismessa. Il nuovo valore iniziale del cespite verrà decrementato di questo importo.
Se sono state fatte delle precedenti dismissioni, il calcolo del valore della nuova parte dismessa ne terrà conto.

Valore fondo (civile e fiscale)
Valore quota indetraibile fondo (civile e fiscale)
Questi ultimi due valori sono divisi nelle parti relative a ammortamento ordinario, anticipato e posticipato.
Sono i valori del fondo relativo alla parte dismessa. Andranno a decrementare il fondo del cespite.

_________ NOTE ________

In fase di generazione automatica dei movimenti di ammortamento, a video viene chiesto se generare sia l'ammortamento civile sia il fiscale, oppure solo uno dei due. Se durante gli anni, termina uno dei due tipi di ammortamento, il programma continua a calcolare l'altro.

In caso di calcolo dell'ammortamento in una data diversa dal fine anno, l'ammortamento civile verrà ugualmente calcolato fino alla fine dell'anno

Ci sono REGOLE diverse per il calcolo dell'ammortamento civile rispetto al fiscale.

Tali regole, come descritto in seguito, si differenziano ulteriormente se l'azienda è in contabilità semplificata piuttosto che in contabilità generale.

Per calcolare l'ammortamento civile con le stesse regole del fiscale, basta valorizzare in modo opportuno il flag nella maschera iniziale dei cespiti:
calcolo ammortamento civile.

Bene materiale acquisito nell'esercizio: |  |
Azienda in Contabilità Ordinaria | Amm. Civile | Ragguaglio al periodo di utilizzo, con data acquisizione se presente o data entrata in uso
 | Amm. Fiscale | 50% quota normale
Azienda in Contabilità Semplificata | Amm. Civile e Fiscale | 50% quota normale

Bene materiale: |
Amm. Fiscale | Ammortamento anticipato previsto nei primi 3 esercizi
Amm. Civile | non è previsto l'ammortamento anticipato, ma solo ammortamento normale

Beni di valore minore di 516 euro |  |
Azienda in Contabilità Ordinaria | Amm. Civile | per quote
 | Amm. Fiscale | 100% nel primo esercizio
Azienda in Contabilità Semplificata | Amm. Civile e Fiscale | 100% nel primo esercizio

Ammortamento con % < 50% quota fiscale:
Non è più prevista la perdita fiscale

Note sulla vendita

Nel momento della vendita del cespite, si dovrà registrare la fattura in contabilità e, come conto di ricavo, si utilizzerà un conto 'transitorio cessioni cespiti' creato tra le immobilizzazioni. Al termine della registrazione in prima nota della fattura, verrà lanciata in automatico la Gestione cespiti e, dopo aver cercato il cespite in oggetto, essere entrati nei suoi movimenti con il tasto F10, premuto il pulsante di Nuovo [image] e il pulsante [image] che richiama i dati dalla contabilità, verranno richiamati i dati della fattura appena registrata, creando un movimento di vendita cespite con la causale (di tipo vendita) collegata alla causale fattura.

Al momento della generazione automatica in contabilità dei movimenti dei cespiti, in corrispondenza al movimento di vendita, verrà fatta una registrazione che chiude il Cespite con il relativo Fondo che rileva la plusvalenza o la minusvalenza
Esempio:

Conto | Dare | Avere
Fondo autovetture | 19000 |
Transitorio cessione Cespiti | 6800 |
Plusvalenze |  | 6800
Autovetture |  | 19000

La causale del movimento generato è quella del giroconto indicata nella tabella di collegamento Cespiti-Contabilità nella sezione Cessioni. Anche tutti gli altri codici dei conti che intervengono in questa registrazione vengono presi da questa tabella.


CESPITI - CREAZIONE MOVIMENTI AMMORTAMENTO

CREAZIONE MOVIMENTI AMMORTAMENTO

Percorso: Cespiti - Cespiti - Elaborazioni

Questa funzione consente di generare in automatico i movimenti di ammortamento dell'anno contabile corrente.

In questa fase il programma esclude dall'elaborazione i cespiti chiusi e quelli per i quali non è stato spuntato il flag di 'Generazione automatica ammortamento'.
(Se si vuole rielaborare un cespite chiuso occorre intervenire manualmente per riaprirlo).

I movimenti generati potranno essere provvisori o definitivi. Se provvisori, l'esecuzione successiva della contabilizzazione movimenti, potrà generare SOLO dei movimenti fittizi di contabilità.
(Una volta creati i movimenti provvisori, è possibile renderli definitivi utilizzando l'apposita scelta interna alla funzione "Utility Cespiti".

La Rigenerazione dei movimenti NON sarà possibile se, per lo stesso anno, sono già stati generati i movimenti in contabilità (anche solo Provvisori).
 In tal caso occorre prima, cancellare i movimenti di prima nota generati dalla Contabilizzazione cespiti.
(Tale cancellazione può essere fatta automaticamente dal menu di Utilità di Contabilità, funzione "Cancellazione registrazioni di Prima Nota", 'prima nota extracontabile' avendo cura di spuntare la scelta: Sbianco stato e riferimento nei cespiti collegati)

Si può scegliere se creare i movimenti di ammortamento civile e fiscale o solo uno dei due.
Per l'ammortamento civile viene applicata la stessa aliquota dell'ammortamento normale (o quella digitata a video nell'apposita casella) e vengono seguite le regole descritte nell'apposita sezione, in fondo.

Nella maschera iniziale viene chiesto il tipo di ammortamento Normale o Ordinario, Anticipato, Posticipato, Personalizzato

Se si elaborano ammortamenti anticipati e/o posticipati, non verranno generati i movimenti di ammortamento civile se non per i cespiti per i quali è scritto di fare il civile uguale al fiscale.

Se si esegue l'elaborazione chiedendo di generare i movimenti di ammortamento anticipato, è possibile ricevere una segnalazione se l'elaborazione incontra cespiti che hanno superato l'ultimo anno utile per applicare l'anticipato per cui viene applicato l'ordinario, oppure se incontrano cespiti per i quali non si può creare il movimento anticipato in quanto non hanno ancora, nello stesso anno, il movimento di ammortamento ordinario.

A seconda del Tipo ammortamento scelto il programma, nella creazione del movimento di ammortamento Ordinario, esegue quanto descritto in seguito:

  • ORDINARIO
    Calcola l'ammortamento ordinario con le seguenti aliquote:
    se sul cespite c'è Tipo ammortamento Ordinario: % ammortamento Fiscale
    se sul cespite c'è Tipo ammortamento Personalizzato: % ammortamento personalizzato (del cespite)
  • POSTICIPATO
    Calcola l'ammortamento posticipato, come fosse l'ordinario, ma con le seguenti aliquote:
    se sul cespite c'è Tipo ammortamento Ordinario: % ammortamento Fiscale/2
    (nel primo anno divide ancora per due se sul cespite è spuntato il flag: ammortamento primo anno ridotta)
    se sul cespite c'è Tipo ammortamento Personalizzato: % ammortamento personalizzato (del cespite)/2
  • ANTICIPATO
    Verranno generati movimenti di ammortamenti anticipati SOLO su quei cespiti per i quali l'anno di elaborazione è compreso tra l'anno di nascita e gli anni di ammortamento anticipato indicati sulla anagrafica (in genere 3).
    Calcola l'ammortamento anticipato con le seguenti regole:
    se sul cespite c'è Tipo ammortamento Ordinario: % ammortamento Fiscale
    se sul cespite c'è Tipo ammortamento Personalizzato: % ammortamento personalizzato (del cespite)
    Se però è stata inserita a video una % manuale e questa è inferiore alla % ordinaria (o personalizzata) applicabile, si applica questa % manuale.
    Non si deve calcolare l'ammortamento anticipato se nello stesso anno è presente un movimento di ammortamento posticipato o personalizzato.
    Non deve calcolare l'ammortamento anticipato se non è presente un movimento di ammortamento ordinario nello stesso anno.
  • PERSONALIZZATO:
    Se si lascia bianca la % di ammortamento a video, il programma utilizza la % di ammortamento personalizzato letta sul cespite
    Calcola l'ammortamento confrontando la % di ammortamento manuale inserita dall'operatore nella maschera della generazione movimenti e quella ordinaria o personalizzata del cespite (a seconda del tipo di ammortamento scritto sul cespite) e si comporta come segue:
    - se la % inserita è >= alla % ordinaria (o personalizzata) del cespite, viene applicata la % ordinaria o personalizzata
    - se tale % è > del 50% ma è <= alla % ordinaria (o personalizzata) del cespite, viene applicata essa stessa
    - se è <= al 50% della percentuale ordinaria (o personalizzata) del cespite, viene applicata essa stessa ma si genera una perdita fiscale per la differenza

Poiché secondo una circolare del 2002, la ditta può, nell'anno in cui vende un cespite, ammortizzarlo per i mesi precedenti a quello di vendita, in questo caso l'utente, prima di registrare la vendita, dovrà creare manualmente per quell'anno un movimento di ammortamento definitivo calcolando opportunamente l'importo. In questo caso il programma terrà conto, al momento della vendita, anche di quel movimento per l'eventuale calcolo della Plusvalenza/Minusvalenza

Se si esegue una rielaborazione per lo stesso anno (che non sia di tipo Anticipato) è possibile sovrascrivere i movimenti generati con la precedente elaborazione e, l'operatore, dovrà scegliere quali sovrascrivere.


CREAZ. MOV. AMMORT. DI UN CESPITE

Percorso: Cespiti - Cespiti - Gestione cespiti

Questa funzione consente di generare i movimenti di ammortamento civili e fiscali, del solo cespite in gestione. La si può eseguire dalla maschera di Gestione dettagli di un cespite, dopo aver inserito il movimento di acquisto, premendo il pulsante: (Y) Crea movimenti di ammortamento

Serve per velocizzare l'inserimento di cespiti vecchi e può essere eseguita per un intervallo di anni. I movimenti, una volta generati, se necessario, potranno essere variati manualmente. (**)
Poiché l'elaborazione può essere fatta per più anni, nella data da digitare si chiede di mettere l'anno corrente poi sarà il programma a reimpostare l'anno, movimento per movimento.

Se si lavora in collegamento con la contabilità è importante valorizzare correttamente il flag in corrispondenza alla richiesta:
Imposto stato mov. di prima nota come contabilizzato manualmente
Va impostato a Si se si stanno generando movimenti relativi ad anni contabili già chiusi o comunque nei quali gli ammortamenti sono già stati registrati. Viceversa va sbiancato (cioè posto a No).

Per il significato degli altri campi chiesti a video si rimanda alla funzione: Creazione movimenti cespiti

accessibile dal menu, che esegue la generazione dei movimenti di ammortamento dell'anno corrente, per tutti o una parte di cespiti.

(**) Per caricare dei cespiti vecchi con i relativi ammortamenti, vedi caricare un cespite già ammortizzato completamente o parzialmente


CONTABILIZZAZIONE MOVIMENTI

Percorso: Cespiti - Cespiti - Elaborazioni

Questa funzione è abilitata SOLO se si utilizzano i cespiti collegati alla contabilità.

Essa consente di generare in automatico in prima nota (definitiva o provvisoria/extracontabile ) i movimenti di ammortamento civili o di vendita o dismissione parziale di un cespite (plusvalenza, minusvalenza) a partire da quelli dell'anno in corso, presenti sui cespiti con flag Stato movimento coge bianco.

Una volta generate le registrazioni di contabilità, i movimenti cespiti NON potranno più essere variati.

In questo modo si potranno fare delle simulazioni, anche in corso d'anno: dopo aver generato i movimenti di ammortamento sui cespiti, si può eseguire questo programma per generare dei movimenti provvisori di contabilità digitando a video la data in cui si vuole contabilizzare l'ammortamento.
La generazione terrà conto di TUTTI i movimenti dell'anno creati sui cespiti e non ancora contabilizzati (con flag Stato movimento coge bianco).
Gli importi delle registrazioni contabili di ammortamento generate verranno parzializzati, terranno cioè conto SOLO dei mesi intercorsi tra la data di inizio dell'anno contabile e la data di generazione dei movimenti digitata dall'utente prima di confermare l'elaborazione.

I movimenti cespiti Temporanei (Provvisori), verranno considerati SOLO dalla creazione dei movimenti di prima nota provvisori e non definitivi.

Se si ripete la generazione, senza aver cancellato i movimenti (temporanei) generati in precedenza, il programma provvede a cancellarli utilizzando il numero di registrazione memorizzato sul movimento dei cespiti.
Se invece sono stati generati dei movimenti definitivi, non ne possono essere generati altri (per gli stessi cespiti) se prima non si cancellano manualmente i vecchi.
La cancellazione dei movimenti fittizi può essere fatta singolarmente cancellando ogni registrazione (dalla Prima Nota extracontabile) oppure in blocco utilizzando la funzione "Cancellazione registrazioni di prima nota" e scegliendo "P.Nota extracontabile" e spuntando "Sbianco stato e riferimento sui cespiti collegati".

Se è stato impostato il parametro di personalizzazione DataOp, si chiede di inserire un numero e una data protocollo da attribuire ai movimenti da generare. Il numero sarà quello progressivo all'ultimo numero protocollo assegnato alle registrazioni generiche.

Se la ditta è in regime di contabilità semplificata, ogni registrazione "cespiti" (di ammortamento), fatta in contabilità dovrà avere una causale del tipo 'fattura di acquisto' e i conti 'fondo' dovranno essere dei fornitori fittizi (questo va impostato nella tabella di collegamento cespiti-contabilità
In questo caso verranno chiesti all'operatore: numero e una data protocollo e documento e anche un codice iva (esenzione) da inserire nelle registrazioni.
Di default verrà proposto il prefisso protocollo acquisti di defoult e il corrispondente numero di protocollo successivo all'ultimo utilizzato.

I movimenti possono essere generati in modo più o meno sintetico. A seconda della scelta verrà generato un numero più o meno grande di movimenti:

  • Raggruppo a parità di causale
  • Raggruppo a parità di causale e codice raccordo
  • Movimenti distinti per ogni cespite
    con questa scelta, nella "descrizione aggiuntiva" delle registrazioni create viene riportata, oltre alla descrizione eventualmente scritta a video, anche la descrizione del cespite al quale il movimento si riferisce.
    E' possibile attivare il parametro di personalizzazione DescrAgg per variare il modo di compilazione del suddetto campo.

E' possibile, tramite l'attivazione del parametro di personalizzazione RaggrDef, assegnare un default a questa opzione in modo che il programma presenti sempre la stessa scelta.
All'interno di ogni movimento inoltre, si può decidere di:

  • avere una riga per ogni conto, con il totale derivato dai vari cespiti esaminati
  • tenere separate le righe, che pur avendo gli stessi conti, sono generate da cespiti diversi

Se sui cespiti ci sono Centri di costo diversi, le righe verranno COMUNQUE tenute separate anche se si utilizza lo stesso conto.

Gli eventuali movimenti di perdita fiscale vengono generati tutti separati, cioè una registrazione per ogni cespite che la prevede.


CESPITI - ELENCO

Percorso: Cespiti - Cespiti - Stampe

Questa funzione consente di stampare la situazione dei cespiti in archivio.
A scelta si può stampare la situazione dell'ammortamento civile o fiscale.

Possono essere stampati:

  • Tutti i cespiti che rientrano nelle selezioni fatte
  • Solo quelli attivi e quelli chiusi nell'anno indicato a video come ultimo anno dei movimenti da considerare.
  • Solo quelli chiusi negli anni precedenti all'ultimo anno dei movimenti da considerare.

Si può inoltre decidere se stampare o meno i cespiti venduti.

Se si esegue la stampa dettagliata, cioè con l'elenco dei movimenti, è possibile elencare, per controllo, SOLO i movimenti provvisori.

Per ogni cespite verranno elencati i movimenti degli anni richiesti (stampa dettagliata) o solo gli importi riepilogativi (valore d'acquisto, rivalutazioni, svalutazioni, fondo, residuo, etc.)


CESPITI - LIBRO CESPITI

Percorso: Cespiti - Cespiti - Stampe

La stampa del libro cespiti può essere ripetuta a piacere e, a scelta dell'utente, è possibile numerare le pagine a partire da un numero di pagina digitato.

A scelta si può stampare la situazione dell'ammortamento civile o fiscale.

Per ogni cespite che rientra nelle selezioni e che ha almeno un movimento nell'anno impostato a video nel campo "esercizio", viene stampato il riepilogo all'anno precedente, l'elenco dei movimenti dell'anno e i valori riepilogativi all'anno stampato.

I cespiti vengono ordinati categoria di appartenenza.

Per un corretto risultato in stampa del totale dei cespiti chiusi in anni precedenti (chiusi e non venduti), occorre che in quelli che hanno il flag di venduto a sì, l'ultimo movimento sia un movimento di vendita.

Note sui campi stampati:
(A) Riporto anno xxxx
in questa riga, per ogni cespite, vengono stampati rispettivamente il Valore del bene, del fondo Amm.Ordinario (che comprende l'amm.ordinario e posticipato e l'eventuale indetraibile), del fondo Amm. Anticipato e del Residuo all'anno precedente quello di stampa.
Nella pagina con i Totali di Categoria e in quella con i Totali Finali, tale riga riporta la somma di quanto stampato per ogni cespite.

Questa riga può differire da quanto è stato stampato come totale finale dell'anno precedente in quanto NON contiene i cespiti che NON hanno movimenti nell'anno di stampa.

(B) Elenco movimenti dell'anno
Nella pagina con i Totali di Categoria e in quella con i Totali Finali, viene stampata una riga con i valori riepilogativi di ogni causale incontrata stampando il dettaglio dei movimenti dei singoli cespiti.
L'importo Residuo, viene calcolato all'anno precedente per cui se in un anno c'è un movimento di ammortamento e uno di vendita o più movimenti di dismissione parziale, esso non è calcolato correttamente sulle varie righe.

(C) Totale all'anno yyyy
E' la somma di (A) + (B)

(D) Totale chiusi A.P. non movimentati nell'anno
Sono gli importi ai cespiti chiusi in precedenza e che non hanno avuto movimenti nell'anno per cui non sono stati stampati nella parte precedente (hanno movimenti quei cespiti che, chiusi in precedenza, vengono venduti totalmente o parzialmente nell'anno).

Totali Categoria (o finali)
E' la somma di (C) + (D)

Riporto dai cespiti chiusi in anni precedenti
Sono gli importi relativi a cespiti chiusi in precedenza e che quindi non hanno movimenti nell'anno

Totali cespiti chiusi da riportare nell'anno successivo
E' la somma degli importi della riga precedente più quelli dei cespiti chiusi nell'anno di stampa.


CESPITI - RIEPILOGO AMMORTAMENTI

Percorso: Cespiti - Cespiti - Stampe

Questa funzione consente di stampare il riepilogo degli ammortamenti di un certo esercizio contabile in forma sintetica (totali per categoria, gruppo, locazione, centro di costo suddivisi per Esercizio entrata in uso) o in forma analitica (con evidenziati i movimenti di ammortamento dell'esercizio)

A scelta si può stampare il riepilogo dell'ammortamento civilistico o la fiscale.

Vengono considerati tutti i cespiti che soddisfano le selezioni fatte a video, attivi all'esercizio per cui è richiesta la stampa (vengono considerati attivi anche quei cespiti che sono stati venduti nell'esercizio di stampa)

E' stato inserita a video la richiesta se stampare o no i cespiti che, nell'anno, hanno solo movimenti di incremento /decremento fondo o bene (in un primo tempo non li stampava).


CESPITI - PROSPETTO 5%

Percorso: Cespiti - Cespiti - Stampe

Questa funzione esegue il conteggio del valore base per il calcolo della quota di manutenzioni e riparazioni deducibili nell'esercizio e la stampa relativa.

La percentuale applicata a seconda che si effettui l'elaborazione per i trasportatori o meno, può essere scritta nella tabella generale cespiti (altrimenti vengono presi di default rispettivamente il 25% e il 5%)

La quota deducibile nell'esercizio è determinata applicando l'aliquota del 5% al valore dei beni materiali ammortizzabili esistenti a inizio esercizio. Fino al 2011, questo valore doveva essere incrementato del costo dei beni acquisiti e decrementato dei beni ceduti nell'esercizio, ragguagliando il valore al periodo di possesso.
Dal 2012 si deve considerare solo il valore dei beni materiali ammortizzabili esistenti a inizio esercizio, tuttavia è stata messa a video una opzione in modo tale che si possa ancora fare il calcolo includendo acquisti e vendite dell'anno.

La stampa riporta:

  • A seconda che venga spuntato o meno a video il campo Autotrasportatori
    se spuntato si stampa: Automezzi in possesso all'inizio dell'esercizio
    altrimenti: Beni materiali in possesso all'inizio dell'esercizio
    L'importo stampato è la somma del valore fiscale dei cespiti all'anno precedente quello di stampa.
    Se sul cespite c'è un max ammortizzabile e il valore fiscale supera tale massimo, questo diventa il valore da considerare
    inoltre se sul cespite c'è una Perc.Indeduc. Uso Promiscuo viene decrementato il valore fiscale del cespite di tale %
  • L'elenco degli acquisti o incrementi e delle vendite o decrementi avvenuti nell'anno di stampa.
  • In ogni riga viene riportato il codice cespite, il valore (che è il valore di acquisto o dell'incremento), il numero dei giorni intercorsi tra la data di entrata in uso e il 31/12 dell'anno di stampa e il plafond (valore rapportato ai giorni di utilizzo: valore / 365 (o366) moltiplicati i giorni calcolati)
  • Al termine viene fatto il calcolo del Valore residuo deducibile nei successivi esercizi e, se maggiore di 0, viene scritto sulla tabella Cespiti Manutenzioni con anno=anno di stampa, tipo manutenzione O se ordinaria, T se trasportatore e Quota annuale calcolata = alla quota calcolata divisa per 5 (se elaborazione ordinaria) o per 3 (se elaborazione per trasportatori).


CESPITI - QUADRATURA CESPITI / CONTABILITA'

Percorso: Cespiti - Servizio

Questa funzione è abilitata SOLO se si utilizzano i cespiti collegati alla contabilità (flag in tabella generale cespiti) e considera, dal lato cespiti, SOLO i movimenti civili con stato coge diverso da bianco.

NOTA: in tutti i movimenti relativi ad anni nei quali in contabilità, gli ammortamenti, sono stati registrati manualmente, è indispensabile che il flag stato Coge sia impostato a: prima nota manuale.

Viene effettuata una stampa di controllo della quadratura tra i saldi contabili dei conti che riguardano i cespiti (quelli richiamati nelle tabelle di collegamento cespiti-coge) e i rispettivi valori sui movimenti cespiti.

Se l'anno precedente è aperto, verrà calcolato, per i conti patrimoniali, anche il saldo iniziale.

E' possibile includere nel calcolo dei saldi contabili anche quello dei movimenti fittizi (dove possono essere stati generati in automatico dei movimenti di simulazione di ammortamento), in questo caso si considerano, nel calcolo del saldo cespiti, anche i movimenti cespiti Provvisori, che diversamente, non vengono conteggiati.

Per quanto riguarda i movimenti cespiti, vengono presi in considerazione per ogni cespite, tutti i movimenti presenti fino all'anno di stampa, purchè abbiano il segnale di Stato movimento Co.Ge. diverso da bianco.

Come detto sopra tuttavia, solo se si includono nella stampa le registrazioni contabili fittizie, vengono conteggiati i movimenti dei cespiti con stato Provvisorio, altrimenti si considerano solo quelli con stato definitivo.

Il flag Stato movimento Co.Ge. può assumere i seguenti valori:

  • Manuale cioè i movimenti corrispondenti in contabilità sono stati registrati manualmente, accade per gli anni precedenti a quello in cui si è deciso di gestire i cespiti con il programma
  • Provvisorio o Definitivo a seconda che siano stati generati in automatico dalla procedura i movimenti sulla prima nota provvisoria o definitiva.

Per i movimenti di ammortamento, viene sempre considerato nel calcolo del Saldo Cespiti, tutto l'importo annuale mentre nel saldo contabile potrebbe esserci un importo inferiore se è stato simulato un ammortamento ad una data inferiore al 31/12

Non vengono considerati i cespiti Chiusi e Venduti. Li considera solo se trova il movimento di vendita nell'anno di stampa.


CONFRONTO AMMORTAM. CIVILE e FISCALE

Percorso: Cespiti - Servizio

Il programma consente di stampare l'elenco dei cespiti, ordinati per categoria, gruppo etc., per i quali risulta diverso, in un determinato anno, l'importo dell'ammortamento civile rispetto a quello fiscale.

E' possibile scegliere di stampare anche tutti i cespiti a non solo quelli con importi di ammortamento diversi.

In stampa vengono riportati:
Codice e descrizione cespite
Percentuale Importo e Importo non detraibile (Amm. Civile)
Percentuale Importo e Importo non detraibile (Amm. Fiscale)


CESPITI UTILITA' VARIE

Percorso: Cespiti - Servizio

E' OBBLIGATORIO eseguire UNA COPIA DEGLI ARCHIVI prima di lanciare questo programma, in quanto se qualcosa va male durante l'esecuzione, è indispensabile ripristinare la copia.

Se si esegue questa utility per l'adeguamento alla versione 1.13C, leggere le note in fondo.

In generale il programma contiene delle utility per sistemare i cespiti, ciascuna utility ha varie opzioni da utilizzarsi con molta attenzione.

Cancellazione movimenti di ammortamento

  • Solo fiscali
  • Solo civili
  • Civili e Fiscali

Consente di cancellare, in automatico, i movimenti cespiti generati in precedenza

Controllo/sistemazione flag e anno chiusura

- Solo per mov. fiscali, solo per movimenti civili, per entrambi, solo copia flag e anno chiusura civili su fiscale e viceversa.
Questa opzione consente di sistemare in automatico il flag e l'anno di chiusura cespite in base ai movimenti di ammortamento presenti in archivio.
I cespiti Venduti non vengono considerati nell'elaborazione.
I Cespiti chiusi manualmente ma con residuo diverso da zero verranno riaperti

Modifica % di ammortamento

- Copia la percentuale di ammortamento civile del cespite sulla fiscale o viceversa.
- Importa l'una o l'altra percentuale, o entrambe, dalla tabella ministeriale dove ci sono le categorie

Sistemazione Plusvalenza - Minusvalenza
- Consente il ricalcolo della plusvalenza e minusvalenza civile e fiscale in base ai movimenti presenti sul cespite, oppure la copia dei valori già calcolati per uno dei due tipi di ammortamento su quelli relativi all'altro tipo. La copia può essere fatta anche degli importi della dismissione fondi (ordinario, anticipato, posticipato) in corrispondenza a movimenti di dismissione. Tali importi possono solo essere copiati gli uni sugli altri ma non essere ricalcolati.

Cambio stato movimenti cespiti da provvisorio a definitivo
Consente di cambiare valore al flag di stato dei movimenti cespiti civili, fiscali o entrambi.
Può servire a rendere definitivi dei movimenti generati come provvisori, variati e ritenuti corretti.

Cancellazione cespiti venduti
Consente di cancellare in automatico i cespiti venduti (con relativi movimenti civili e fiscali) che soddisfano le selezioni impostate a video e che non abbiano movimenti in anni successivi a quello chiesto a video (viene proposto un anno che è l'anno contabile-3. Il programma controlla inoltre che i cespiti cancellabili non abbiano 'figli' cioè cespiti collegati.

NOTE per l'adeguamento alla versione 1.13C

Questa utility dovrà essere utilizzata obbligatoriamente in alcune sue scelte, da quanti hanno utilizzato la procedura Cespiti fino alla versione 1.13B (del 13/02/2006) di Aziwin, dopo aver eseguito: Spostamento movimenti di ammortamento.

Se non sono mai stati creati i movimenti di ammortamento civile (quello elaborato in precedenza è considerato fiscale) dovranno essere eseguite due scelte in particolare:

  • sistemare plusvalenza e minusvalenza:
    Tipo elaborazione: Sistemazione Plusvalenza/Minusvalenza e a destra scegliere: Copia Puls/Minus/Dism civile nel fiscale (questo perché è già stata fatta in precedenza la copia dei movimenti)
  • sistemare le % di ammortamento civile e fiscale:
    Tipo elaborazione: Controllo/Sistemazione Flag e anno chiusura     e a destra scegliere: Copia flag da Fiscali a Civili

Successivamente valutare se eseguire: Tipo elaborazione: Modifica % di ammortamento per compilare la % di ammortamento civile, tenendo presente che le due percentuali sono già valorizzate perché lette dalla Categoria del cespite al momento della sua creazione. In precedenza però, veniva visualizzata e utilizzata SOLO la % di ammortamento fiscale, per cui se questa era stata variata, quella civile è invece rimasta invariata.

Gli utenti che hanno già creato dei movimenti di ammortamento civile con la versione precedenti alla 1.13C:

dovranno eseguire la funzione Spostamento movimenti ammortamento (che posiziona i movimenti nelle nuove tabelle) poi con l' utility cespiti faranno la copia plus/minus/dism civile nel fiscale (con o senza ricalcolo degli importi del civile)

Per quanto riguarda le dismissioni non possono essere ricalcolate per cui se i valori degli importi di dismissione dei fondi sono diversi nei civili rispetto ai fiscali, occorre andare nei movimenti corrispondenti e sistemarli manualmente.


UTILITA' SPOSTAMENTO MOV. AMMORTAMENTO

Percorso: Cespiti - Servizio

E' OBBLIGATORIO eseguire UNA COPIA DEGLI ARCHIVI prima di lanciare questo programma, in quanto se qualcosa va male durante l'esecuzione, è indispensabile ripristinare la copia.

Questa utility dovrà essere utilizzata una volta sola da quanti hanno utilizzato la procedura Cespiti fino alla versione 1.13B (del 13/02/2006) di Aziwin perché consente di sistemare gli archivi dei movimenti in modo da ottenere procedure corrette per il calcolo dell'ammortamento civile e fiscale secondo la nuova normativa.

L'obiettivo del programma è quello di avere in linea sulla tabella CespitiMov i movimenti di acquisto, incremento/decremento, vendita e degli ammortamenti civili mentre sulla nuova tabella CespitiMovFisc solo i movimenti di ammortamento fiscale (La tabella CespitiMovCiv non verrà più utilizzata).

Elaborazioni fatte dal programma:

  1. Copia da CespitiMov a CespitiMovFisc tutti e soli i movimenti di ammortamento. A questo punto se uno non ha fatto nessun movimento civile, l'elaborazione è terminata. Altrimenti si prosegue:

  2. Per ogni cespite, se in CespitiMovCiv ci sono dei movimenti (civili), li ordina per anno, cerca quelli corrispondenti in CespitiMov, legge da questi lo StatoPn e l'eventuale numero e anno dell'articolo di prima nota, poi i mov.originali li cancella e li sostituisce con questi di CespitiMovCiv

Sui movimenti civili viene messo il flag Stato a definitivo e il flag StatoPn lo deriva dai movimenti

Al termine della ricostruzione dei movimenti, se i campi di ogni cespite: perc. inded. quote di ammortamento civile e valore massimo ammortizzabile civile sono bianchi, vengono posti uguali ai rispettivi valori fiscali e i fiscali vengono sbiancati.

Una volta eseguito questa funzione, è indispensabile eseguire alcune scelte della funzione: Utility Cespiti per sistemare correttamente Plusvalenza/Minusvalenza e le % di ammortamento.


UTILITA' PROCEDURE

Questo capitolo contiene le spiegazioni delle funzioni di servizio disponibili alle procedure.
Si tratta di funzioni da utilizzare occasionalmente sia per intervenire sui dati scritti negli archivi (es. Rinumerazione articoli di prima nota), sia per riorganizzare o recuperare un database danneggiato (es. Rigenera/Duplica database)


AGGIORNAMENTO DATA BASE A NUOVE RELEASE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione può essere eseguita, al bisogno, dall'operatore ma viene lanciata in automatico ogni volta che si installa una nuova release di programmi che richiede un aggiornamento dei Data Base degli archivi o del menu.

Durante la sua esecuzione nessuno deve utilizzare gli archivi.

Per lanciarla manualmente, a differenza degli altri programmi, non si clicca su un pulsante del menu ma si premono contemporaneamente i tasti Shift-Ctrl-Alt L. In questo modo si manda in esecuzione una funzione particolare che consente di scegliere quale programma eseguire.
Nel caso particolare occorre scegliere: Aggiornamento poi premere il pulsante Esegui

Verrà presentato un elenco con la lista delle aziende in linea (elenco visualizzato al Cambio Azienda e gestibile dal menu Parametri e utilità, Gestione database aziende).

In automatico verranno selezionate per l'aggiornamento tutte le aziende tranne quelle il cui database non si trova più in linea al momento dell'aggiornamento. L'operatore potrà, a sua discrezione, deselezionare o selezionare una o più aziende per elaborare solo quelle.
Non sarà comunque possibile selezionare un'azienda non in linea

Al fine di poter controllare quale database viene utilizzato come guida per l'aggiornamento e quale come riferimento/origine dei dati da aggiornare, vengono visualizzati i percorsi in cui questi si trovano e le date

  • DataBase guida (AziMenAg.mdb) con Data ultima modifica da fare
  • Database di base (AziVuoto.mdb) con Data preparazione del db vuoto

Tramite l'apposito pulsante è possibile cambiare il percorso di uno o entrambi i database

Per conoscere la data dell'ultimo aggiornamento fatto su un database tra quelli in linea basta fare doppio click sulla riga corrispondente, nell'elenco delle aziende da aggiornare, in questo modo verranno visualizzati, in basso a destra, ID azienda e data.

Prima di iniziare l'elaborazione è possibile scegliere, spuntando o meno l'opzione:
Dare segnalazioni su errori di aggiornamento
se il programma deve interrompere l'elaborazione ogni volta che trova un errore da segnalare (es. un campo già presente sul Db) oppure se deve elaborare tutte le aziende senza interruzioni.
Quest'ultima scelta è senz'altro utile a quanti hanno molti database da elaborare. Al termine, se si presenteranno dei problemi durante l'utilizzo degli archivi, sarà indispensabile eseguire il Confronto del database in uso con il database Vuoto in modo da verificare se l'aggiornamento non è andato a buon fine.
(Funzione per il confronto dei database: dal menu premere Ctrl Alt Shift L e scegliere Confronta database)
Inoltre viene proposto una ulteriore opzione:
Log dettagliato
Al fine di tenere traccia dei vari passi dell'aggiornamento, il programma scrive un file di log (Aggiornalog.txt) nella directory aziwin dove, per ogni database, viene riportata la data contenuta inizialmente nella tabella Config, il numero delle modifiche, l'avvenuto compattamento e la data finale impostata dall'aggiornamento.
Se si conferma il log dettagliato, verranno elencati tutti i campi aggiornati e, per ciascuno, il risultato dell'aggiornamento.
Altre opzioni che, se selezionate, rendono più sicuro il risultato dell'aggiornamento in quanto fanno anche una verifica ulteriore del database:
Dopo il compattamento:

  • Esegui verifica
  • Copia prima di aggiornare

Queste due opzioni vengono spuntate automaticamente al caricamento del programma. E' possibile impostare il parametro di personalizzazione AggiornaVerifica a No in modo da non trovarle spuntate di default.

Data iniziale per aggiornamento
Questa data va valorizzata SOLO nel caso si vogliano aggiornare i campi a cominciare da una data precedente a quella scritta nella tabella Config dei database o del menu, per rimediare qualche malfunzionamento in aggiornamenti precedenti.
In automatico il programma prende in esame, uno dopo l'altro, i database selezionati e, se avranno nella tabella Config una data precedente alla data dell'aggiornamento attuale, li aggiornerà aggiungendo i nuovi campi (letti da AziMenAg.mdb e AziVuoto.mdb che dovranno essere sempre presenti rispettivamente nella cartella \aziwin e \database).

Per vedere la data di aggiornamento del singolo DataBase, basta fare un click sulla maschera in corrispondenza alla descrizione del DB interessato. La data verrà scritta in basso sul video: Data DB Id xxx: gg/mm/aaaa
Al termine dell'aggiornamento di ogni singolo database, verrà fatto il relativo compattamento.

Se uno dei database in aggiornamento risulterà già aggiornato (cioè la data nella tabella config è la stessa dell'aggiornamento attuale), verrà fatto solo il suo compattamento (riorganizzazione).

L'elenco dei campi, tabelle e indici da aggiornare è contenuto in alcune tabelle del database AziMenAg (AggDbStruct, AggDbCarica, AggDbStampe), database che l'installazione o l'aggiornamento dei programmi copia nella cartella AziWin. I database di riferimento dal quale copiare i nuovi campi o tabelle è AziVuoto.mdb e viene copiato in automatico nella cartella DataBase.

Se il programma di aggiornamento, durante l'esecuzione, trova qualche campo che esiste già sui DB, pone la domanda:

Continui l'elaborazione su questo DB

SI NO SI, non chiederlo più per questo DB

A cui si può rispondere in tre modi diversi:

  • Si
  • No (abbandona il DB corrente e passa a quello successivo, se c'è)
  • Sì e non chiedere più se proseguire
    Per un corretto funzionamento dell'aggiornamento (salvo casi particolari da valutare a parte) si consiglia di fare quest'ultima scelta
    In questo caso verrà poi chiesto:

    Continuare a dare segnalazioni di errore su questo Database

    rispondere NO


AGGIORNAMENTO PROGRAMMI E DLL

Percorso: dal menu principale: Shift-Ctrl-Alt L

L'aggiornamento dei programmi e delle DLL viene fatto in automatico all'esecuzione della funzione Aggiorna.exe direttamente da CD o da disco fisso (dopo aver copiato il contenuto del cd o aver scompattato il file zip scaricato dal sito www.aziendapc.it, in una cartella apposita del disco fisso).

L'aggiornamento dei programmi lancia in automatico anche l'aggiornamento dei database dei dati.

Se la procedura è installata in rete, dovranno essere aggiornati gli eseguibili e le dll (dal server stesso o da un primo client).

L'aggiornamento sugli altri client, aggiornerà le sole DLL

Dalla versione 1.13b:

Verifica versione delle DLL etc. sui Client e aggiornamento automatico di quelle non aggiornate

Questo controllo (lanciato in automatico quando si entra nel menu procedura) consente, una volta aggiornata la procedura sul server, di aggiornare automaticamente i client la prima volta che cercano di accedere ai programmi. Si può quindi evitare l'aggiornamento dei client 'manuale' da CD, procedura che andava fatta dopo aver aggiornato il server.

L'aggiornamento automatico richiede che sia disponibile su disco la Directory di installazione delle DLL e altri file di sistema.

Di default il programma cerca le DLL aggiornate nella cartella …..aziwin\DllInst nella path degli EXE (indicata nell'aziwin.ini dal parametro PathExe), altrimenti si può forzare la posizione delle dll con un parametro nell'aziwin.ini da inserire nel gruppo [Menu]: PathDllInst=percorso completo


AGGIORNAMENTO IVA - SISTEMAZIONE REVERSE CHARGE

Funzione di utilità utilizzata nel 2007.
Questa funzione deve essere eseguita una sola volta per ogni ditta per la quale si gestisce la contabilità e sono state registrate e aggiornate delle fatture di tipo Reverse Charge con il programma che non le distingueva dalle fatture normali. (Per 'aggiornate' si intende che è stato eseguito l'Aggiornamento Iva)

Lo scopo è quello di consentire di evidenziare, in fase di chiusura iva e, in ogni altra elaborazione dove verrà richiesto, l'importo delle fatture emesse in applicazione del sistema del Revese Charge.

Al fine di poter individuare queste registrazioni, fatture d'acquisto che vanno registrate anche come fatture di vendita, è stato predisposto un flag sulla causale, per cui la registrazione va fatta con causali apposite, come descritto nel paragrafo Reverse Charge.

Se fossero state fatte delle registrazioni di questo tipo, quando ancora non c'era il flag sulla causale, ma comunque con due causali di acquisto e di vendita ad hoc e cioè diverse dalle standard, occorre andare a mettere in tali causali il flag di Reverse Charge prima di eseguire questa funzione.

Il programma prenderà in considerazione i movimenti iva già aggiornati dall'inizio dell'anno al periodo segnalato dall'utente. Per ogni registrazione con causale con flag Reverse Charge, toglierà l'importo di imponibile e imposta dai progressivi 'normali' e li sommerà in progressivi Reverse charge, gestibili, come gli altri, con la Gestione progressivi iva (menu di servizio di contabilità)

Se si tenta di rieseguire questa funzione, verrà dato il messaggio di funzione già eseguita e, solo se l'utente lo vuole, verrà consentito di eseguirla di nuovo. ATTENZIONE: NON dovrà mai essere rieseguita per lo stesso periodo!!!

Il programma di aggiornamento iva, segnala se questa funzione non è stata eseguita.

Chi non ha fatto registrazioni in Reverse Charge o non ha mai aggiornato i movimenti iva del 2007, può uscire dalla segnalazione con la risposta: Non servirà mai eseguirlo (e la domanda non verrà più posta). Viceverse se si risponde: Proseguo senza eseguirlo, al prossimo aggiornamento iva, verrà riproposta la domanda.

Si precisa che fintanto che non verrà eseguita la sistemazione di questi progressivi, essi non verranno stampati separatamente in chiusura iva ma saranno conglobati nell'imponibile e imposta 'normale'.


AZZERA TABELLE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di cancellare, parzialmente o totalmente, il contenuto di una tabella del database.

Database di base è il database sul quale cancellare il contenuto della tabella. Può essere selezionato tra quelli in linea, cliccando sulla freccetta del primo campo bianco, oppure col pulsante cerca, si può prendere un qualsiasi database presente sul disco.

Tabella indica la tabella della quale cancellare il contenuto, da scegliersi nell'elenco delle tabelle presenti nel database.

Selezione dati

Consente di porre delle condizioni ai dati da cancellare. La modalità è la stessa descritta per la funzione Copia tabelle.


CALCOLATRICE PER DATE

Percorso: Parametri e utilità - Utilità

Questa funzione consente di eseguire delle operazioni tra date come ad esempio: somma o sottrazione di giorni, di mesi etc.
La funzione può essere raggiunta dal menu Parametri e utilità, Utilità.

E' possibile memorizzare risultati parziali da utilizzare per elaborazioni successive.

Es. utilizzo della funzione:
Giorno dell'anno corrente o dell'anno della data del primo operando

Se si mette un numero di giorni nel primo operando, verrà visualizzato il giorno corrispondente dell'anno corrente, se invece nel primo operando si mette una data e nel secondo un numero di giorni, il risultato è la data risultante e il giorno della settimana corrispondente.

Alcune funzioni variano il risultato impostando il primo giorno della settimana diverso da Domenica (default) ad esempio: di quale settimana dell'anno è il giorno.


COMPATTA DATABASE

Percorso: Parametri e utilità - Utilità - Varie

Questa funzione, che si consiglia di eseguire periodicamente, consente di ottimizzare la struttura dei Database e controllarne la correttezza, inoltre ne riduce lo spazio occupato su disco.

Viene presentato l'elenco dei database e dovrà essere selezionato il database da compattare. La prima riga dell'elenco NON individua un DB ma consente all'utente di selezionarne uno NON presente nella lista.

Al fine di rendere più sicuro l'esito del compattamento è possibile scegliere a video di fare anche:

Verifica dimensioni tabelle e Copia archivio prima di compattare
Per settare a Si in automatico queste due opzioni si può impostare il parametro di personalizzazione: CompattaVerifica
Si consiglia di eseguire periodicamente il compattamento attivando anche queste due opzioni aggiuntive

E' importante spuntare le due opzioni suddette in quanto, se si verificasse un errore nel compattamento, si dovrà eseguire il Rigenera/Duplica sul database copia in modo da cercare di recuperare i dati, poi procedere a seconda dei risultati ottenuti (ad esempio mettendo in linea la copia 'rigenerata' al posto del database rovinato)

Tramite l'attivazione di opportuni parametri di personalizzazione è possibile eseguire il compattamento degli archivi dell'azienda corrente appena si entra nel menu

(vedi parametri CompattaAvvioTerm , CompattaAvvioGiorni, CompattaAvvioCopiaDb, CompattaAvvioVerif)

In fase di compattazione, dopo aver digitato login e password del Supervisor, è possibile proteggere con password il database, cambiare la password, se già esistente, o eliminarla.
Viene visualizzata la password attuale, se si lascia bianca quella di destinazione, essa sarà mantenuta oppure si può digitare un'altra password
Se si sceglie, con un click sulla prima riga della lista, di compattare un Database non presente nella lista stessa e questo database ha una password, occorre digitarla per proseguire.


CONFRONTO TRA DATABASE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di confrontare la struttura di tabelle contenute in database diversi, in modo da individuare i campi mancanti o le eventuali differenze.

L'elenco delle differenze verrà scritto a video.


COPIA TABELLE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di copiare il contenuto, totale o parziale, di una tabella da un database all'altro.

Database di base è il database dal quale leggere (copiare) la tabella. Può essere selezionato tra quelli in linea, cliccando sulla freccetta del primo campo bianco, oppure col pulsante cerca, si può prendere un qualsiasi database presente sul disco.

Tabella indica la tabella da copiare da scegliersi nell'elenco delle tabelle presenti nel database.

Selezione dati

Consente di porre delle condizioni ai dati da copiare.

Ad esempio si vuole trasferire da un database ad un altro i conti e non i clienti e fornitori. Questi dati sono tutti contenuti nella tabella PianoConti e a distinguerli è il campo Tipo che vale: 1 per i conti, 2 per i fornitori, 3 per i clienti.

Si dovrà perciò impostare la condizione:
Campo:Test:Valore test
Tipo=1

Se invece si volessero trasferire i clienti e i fornitori e non i conti si potrebbe mettere:
Campo:Test:Valore test
Tipo <>1 (cioè tipo diverso da 1)

Oppure

Campo:Test:Valore test
Tipo=2 OR =3

Altra selezione
Si può impostare una query a piacere se non fossero sufficienti le condizioni precedenti

Destinazione
E' il database sul quale copiare i dati.

Se il database scelto come destinazione è un DB con password e NON è nella lista dei database del menu, per poter copiare la tabella occorre digitare la password

Azzera destinazione prima della copia
Spuntare solo se è necessario azzerare la tabella di destinazione prima di eseguire la copia

Sovrascrivere per chiave doppia
Se si sceglie di sovrascrivere i dati che esistono già sulla tabella di destinazione, con lo stesso codice, è possibile elencare quali campi in particolare sovrascrivere o non sovrascrivere.

(Es. su un database sono state aggiornate le Partite iva, sull'altro no, ma si vuole copiare solo quelle e non si vogliono sovrascrivere gli indirizzi. Si può dire di sovrascrivere solo il campo PartIva).

Salva parametri e leggi parametri, consentono rispettivamente di salvare le selezioni impostate sul video e di poterle poi richiamare in un momento successivo.


CLONA TABELLE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di copiare su uno o più database destinatari, il contenuto di una tabella.
Tale tabella deve già esistere, come struttura, sui destinatari.

Database di base è il database dal quale copiare la tabella. Può essere selezionato tra quelli in linea, cliccando sulla freccetta del primo campo bianco, oppure col pulsante cerca, si può prendere un qualsiasi database presente sul disco.

Tabella indica la tabella da copiare, da scegliersi nell'elenco delle tabelle presenti nel database.

Selezione destinazioni
Occorre indicare gli identificativi dei/del database sul quale copiare i dati.

Nota: questa funzione può essere utilizzata, in particolare, per copiare sui database delle varie ditte, le tabelle contenente i codici per il Bilancio Cee (CeeBilTesta e CeeBilDett).
Attenzione che in CeeBilDett ci sono i collegamenti con il piano dei conti della ditta per cui ha senso copiarla solo se i conti sono uguali oppure, una volta copiata, si dovrà intervenire sulla tabella per collegare i conti giusti.


ESEGUI PROGRAMMA

Questa funzione si lancia dal menu premendo la combinazione di tasti Shift Ctrl Alt L e consente di eseguire alcuni programmi di utilità standard, selezionabili in una lista, oppure programmi occasionali.

Quelli standard sono:

Aggiornamento Data Base
Copia Tabelle
Azzera Tabelle
Confronta database
Rigenera/Duplica database
Gestione filtri stampanti Laser
Gestione filtri stampanti ad Aghi
Gestione filtri etichette laser
Gestione filtri etichette aghi
Rinumerazione registrazioni di prima nota
Gestione utenti
Gestione menu
Gestione campi stampe/visual.parametrizzate
Personalizzazione tasti per avvio programmi
Gestione font personalizzati
Esegue query di aggiornamento su più database
Clona tabelle
Configurazione maschera menu

Se si sceglie uno di questi programmi, occorre poi premere il pulsante Esegui per lanciarlo, viceversa, per eseguire un programma 'occasionale' occorre compilare i campi della maschera e solo successivamente premere Esegui.

In questo caso, i campi che si chiede di compilare sono quelli che compongono ogni riga della tabella MenuDett (dettagli delle scelte di menu) e sono obbligatori fino a Maschera.


QUERY - ESECUZIONE QUERY DA MENU

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di scrivere ed eseguire una query sul database di lavoro o sul menu.
Tale query può essere di aggiornamento oppure di visualizzazione dei dati di una tabella della quale basta digitare il nome.
I dati visualizzati potranno essere variati o cancellati per cui questa funzione dovrà essere utilizzata con molta attenzione!

Esempio: se si vuole visualizzare il contenuto della tabella Causali (causali di contabilità) basta indicare in fondo al video che il Tipo di query è Visualizza dati e scrivere, nello spazio Query SQL da eseguire, il nome della tabella: causali poi premere Esegui

Se le query impostate devono poter essere riutilizzate, si possono memorizzare (fino ad un massimo di 10 query diverse) premendo i tasti CTRL più un numero da 0 a 9 corrispondente al numero da dare alla query.
Tali query potranno poi essere richiamate premendo il tasto ALT + lo stesso numero utilizzato nella memorizzazione.

Queste query vengono memorizzate sulla tabella Appoggio di AziMenu.mdb


QUERY DI AGGIORNAMENTO SU PIU' DATABASE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di eseguire un gruppo di istruzioni (query) per aggiornare uno o più campi, non solo sul database su cui si è posizionati ma su un gruppo di database da selezionare tra quelli in linea.

E' utile per assegnare 'a tappeto' un valore ad un certo campo.

La query da eseguire si può scrivere sul posto oppure selezionare tra quelle già predisposte e memorizzate sulla tabella 'FaiQuery' del file AziMenAg.mdb (database guida per aggiornamenti).


RECUPERA DATABASE

Percorso: Parametri e utilità - Utilità - Varie

Questa funzione consente di recuperare e riorganizzare il database in caso di malfunzionamenti.


RIGENERA / DUPLICA DATABASE

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di rigenerare un database rovinato caricando le tabelle su uno vuoto
(utile per utenti che non sono in possesso di Access e devono ricostruire un database rovinato).

La rigenerazione può essere fatta su un nuovo database, scrivendo, nel campo 'Database di destinazione' , la cartella di destinazione e il nome del database da creare
(Es. c:\Aziwin\database\dbcopia.mdb)
oppure sullo stesso, lasciando vuoto 'Database di destinazione'.

Se nel campo 'Database di destinazione' si mette solo il nome del database, questo verrà creato nella cartella AziWin.
Se si duplica sullo stesso database, il programma provvede a fare una copia dell'originale assegnando lo stesso nome col suffisso ORI.

Nel caso di un database molto grande, la cui rigenerazione andrebbe in errore per il superamento dei limiti di dimensione di un database access (2 giga), si deve scegliere di eseguire una compattazione parziale ogni N tabelle in modo da ridurre la dimensione.

Compatta prima di iniziare: se la funzione va in errore, si può eseguirla di nuovo spuntando questo pulsante

Al termine dell'elaborazione viene segnalato un elenco di eventuali tabelle non caricate.

Nel caso l'utente non riesca a lanciare il menu di Aziwin, questo programma può essere lanciato anche in modo autonomo, direttamente da Risorse del computer,
eseguendo da AziWin\Util la funzione DuplicaDb.exe


RINUMERAZIONE ARTICOLI DI PRIMA NOTA

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di assegnare un nuovo numero di registrazione agli articoli inseriti in prima nota, ordinandoli per anno, data e numero registrazione.

Dopo la rinumerazione, il numero di registrazione sarà sempre progressivo per data.

In questo modo si eliminano le situazioni per cui una registrazione fatta in una certa data ha un numero di registrazione maggiore di una fatta ad una data successiva, solo perché la prima è stata inserita successivamente alla seconda.

Poiché il numero di registrazione è anche sulle scadenze (numero articolo che ha generato la scadenza e numero articolo di pagamento) e sulle testate delle fatture contabilizzate (procedura vendite), la rinumerazione provvede ad aggiornare, parallelamente a quelli delle relative registrazioni, anche questi numeri.

Come ben evidenziato sul video al lancio del programma, si raccomanda di fare la copia del database prima di eseguire questa funzione in quanto, se si interrompe, non c'è modo di ripristinare la situazione.


SALVATAGGIO ARCHIVI

Percorso: Parametri e utilità - Utilità - Varie

Il programma consente di eseguire un salvataggio dei database in uso.

Viene proposto l'elenco dei database collegati al menu e si può scegliere

  • quali copiare
  • se eseguire il compattamento prima di copiare
  • dove memorizzare la copia

Per impostare a Si di default l'opzione di 'Compattare prima di salvare' si può impostare il parametro di personalizzazione BackupCompatta

Se si sceglie di compattare, occorre che nessuno stia utilizzando la procedura altrimenti il programma segnalerà la presenza di utenti collegati e non eseguirà le operazioni.
Al fine di rendere più sicuro l'esito del compattamento è possibile scegliere a video di fare anche:

Verifica dimensioni tabelle e Copia archivio prima di compattare
Per settare a Si in automatico questi due opzioni si può impostare il parametro di personalizzazione: CompattaVerifica
Si consiglia di eseguire periodicamente il compattamento attivando anche queste due opzioni aggiuntive

Se si intende salvare in un'area (directory) non ancora creata, si può scrivere il percorso direttamente nel campo: Salvare in poi premere il pulsante: Crea directory di salvataggio.

Si può scegliere tra due tipi di salvataggio: Zippato (i database selezionati daranno origine a un file di salvataggio 'compresso') oppure Normale.

Il salvataggio di tipo 'zippato' (compresso) viene fatto con un comando interno al menu e non supporta la copia multi volume su floppy.

Questo programma necessita di due dll (ZIP32.DLL e UNZIP32.DLL) che verranno copiate, durante l'installazione, nella directory del menu.

In alternativa al programma utilizzato in automatico si può utilizzare per la copia il Winzip che consente, in particolare, di fare la copia multi volume su floppy.

Per utilizzare il WINZIP occorre installare il Command Line Support Add On disponibile all'indirizzo http:\\www.winzip.com\wzcline.htm

Utilizzando il winzip occorre scrivere nella casella: Comando non integrato da usare per zippare, il percorso in cui si trova il programma winzip: es. C:\Programmi\WinZip\Wzzip

Si dovrà poi aggiungere il parametro: "-&" per la copia multi volume su floppy.

(Con XP e 2000 si apre una finestra che rimane in basso nel video (es. richiesta dischetto) e occorre cercarla lì per aprirla e proseguire).

Si può utilizzare anche il pkzip, specificando nel campo suddetto il percorso di dove si trova es.: c:\util\pkzip e facendolo seguire dalla scritta: "-&" per il multi volume su floppy.

In questo caso occorre barrare la casella: Uso nomi file in formato MsDos; il nome del file di origine se lo sistema lui, quello della destinazione lo assegna prendendo dal database del menu i primi 6 caratteri del codice dell'azienda che sta copiando.


VERIFICA AGGIORNAMENTI SUL SITO

Percorso: dal menu principale: Shift-Ctrl-Alt L

Controllo presenza di aggiornamenti sul sito


MENU E UTENTI

Alle funzioni

  • Gestione utenti
  • Gestione menu

descritte in questo capitolo si accede premendo contemporaneamente i tasti Ctrl-Alt-Shift L, quando si è posizionati sul menu ed eseguendo la scelta corrispondente.

Esse consentono, tra l'altro, di impostare delle password per accedere alle procedure o solo a qualche funzione particolare.
Una volta impostata una password per un determinato utente, questa potrà essere cambiata, dallo stesso utente, tramite la funzione Cambio PassWord


PASSWORD

E' possibile attivare delle password a vari livelli per l'accesso alle procedure.

E' possibile inoltre, proteggere con password i database delle aziende (vedi Compattazione, Gestione database aziende)

In seguito all'introduzione del Regolamento europeo in materia di Protezione dei Dati Personali (GDPR) entrato pienamente in vigore il 25 maggio 2018, sono state introdotte nuove regole, alcune modificabili, per la creazione delle Password.

L'attivazione avviene utilizzando la Gestione utenti.
Ogni utente potrà poi variare la sua Password tramite la funzione: Cambia password

Successivamente sarà possibile, con la gestione dei menu, abilitare o meno una funzione ad un certo gruppo di utenti e consentire ad essi di entrare nei programmi di gestione in variazione o in sola visualizzazione. Vedere esempio.

Regole per la creazione delle Password:

  • Minimo 8 caratteri (regola non modificabile)
  • E’ obbligatorio inserire almeno una maiuscola e una minuscola (il programma fa distinzione tra maiuscole e minuscole) (regola modificabile)
  • Si possono mettere caratteri speciali (regola modificabile)
  • Deve esserci almeno un numero (regola modificabile)

Nota Bene: La prima volta che un utente entrerà nel menu della nuova versione (Versione aggiornata per GDPR, giugno 2018 ), dovrà digitare la password attuale MAIUSCOLA e verrà invitato a impostare la nuova password secondo le nuove regole suddette.
Verrà presentata una nuova maschera nella quale verrà chiesto di impostare di nuovo:

  • la login (digitare la login data in precedenza)
  • la password attuale (che va scritta MAIUSCOLA)
  • la nuova password (che va impostata secondo le nuove regole)
  • campo ‘suggerimento’ nel quale si deve scrivere una frase che consenta di ricordare la password inserita

Per cambiare le regole:
una volta entrato nel menu, si dovrà eseguire la gestione utenti (Ctrl Alt Shift L) e digitare login e password del supervisor

  • Se non sono mai state impostate Login e Password del Supervisor occorre inserire come
    Login    : Supervisor e come Password una stringa che dovrà essere richiesta a Zucchetti sede di Ravenna (ex CSS) per ogni installazione. Una volta fatto l’accesso sarà obbligatoria cambiarla.
  • Per chi ha già inserita la password del supervisor dovrà digitare la password attuale MAIUSCOLA e si consiglia di cambiarla in base alle nuove regole.

Le regole di impostazione password sono modificabili cliccando sull'ultima icona a destra in alto [image] (E) Regole password
Verrà presentata una nuova maschera che consente di modificare le seguenti scelte:

  • Maiuscole e minuscole
    Distingue maiuscole e minuscole
    Obbligatorie sia maiuscole che minuscole (default)
    NON distingue maiuscole e minuscole
  • Caratteri speciali
    Accetta caratteri speciali (default)
    NON accetta caratteri speciali
    Obbligatori caratteri speciali
  • Numeri
    Numeri obbligatori
    Numeri vietati
    Numeri facoltativi
  • Memorizza data e ora ultimo accesso
    E' possibile scegliere se memorizzare o meno tali informazioni
  • Giorni prima della scadenza
    Viene memorizzata la data nella quale si imposta la password per un utente. Si può modificare il numero dei giorni passati i quali è obbligatorio cambiarla (se il numero è 0 non c’è limite di scadenza)
  • Pulsante: Imposta cambio password obbligatorio per tutti
    Se si preme questo pulsante, tutti gli utenti saranno costretti, la prima volta che entrano, a cambiare la Password


VARIAZIONE PASSWORD

Percorso: Parametri e utilità - Utilità - Varie

Questa funzione, se è stata abilitata dal Supervisor la Gestione utenti, consente ad ogni utente di variare, in qualsiasi momento, la sua password di accesso ad Azienda PC

Verrà presentata una maschera con la richiesta della Password attuale, della nuova password, che dovrà rispettare le regole descritte nel capitolo Password e di reimpostare la frase che dovrà servire da Suggerimento per ricordarla.


GESTIONE UTENTI

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di definire dei gruppi di utenti e di assegnare a ciascuno di essi una password che verrà chiesta dal menu ogni volta che si entra nelle procedure o che si vuole accedere ad una determinata azienda.

Se viene impostata, nella tabella delle personalizzazioni generali il parametro PwdTerminale con valore S, il menu controlla che un utente non acceda, con la stessa login, da più terminali.

Questa funzione è abilitata SOLO all'amministratore del sistema per cui ogni volta che si cerca di eseguirla viene chiesta una Login e una PassWord.
La prima volta occorre digitare:

  • Login: Supervisor
  • Password: XXXXX

Dove XXXX è la password iniziale da richiedere, per ogni installazione, al concessionario o, per i clienti diretti, a Zucchetti sede di Ravenna (ex CSS)

Una volta entrati nella 'Gestione PassWord Utenti' sarà obbligatorio cambiare subito login e password del supervisor. In seguito sarà possibile modificarli premendo il tasto
(U) Password supervisor

In questa fase viene chiesta anche la Chiave abilitazione generica menu.
In generale questo campo va lasciato bianco mentre va impostato uguale a "tutt" se si presenta il caso di abilitare qualche utente a tutte le procedure installate e qualche altro solo a qualche funzione.

Il supervisor potrà compilare una riga per ogni utente da creare ed assegnare ad ogni riga la rispettiva password temporanea premendo il pulsante:
(W) Richiesta password Il programma assegnerà una data fittizia di cambio password.

La prima volta che il singolo utente entrerà nel menu gli verrà chiesto di digitare la password temporanea e di cambiarla

Le password assegnate non saranno più visibili e dovranno rispettare le regole descritte in regole password

Il singolo utente potrà variare periodicamente la sua password utilizzando la funzione: "Cambia Password"

E' obbligatorio creare almeno un Gruppo (per accedere alla gestione gruppi utilizzare l'icona [image] ® Gestione gruppi) ,
poi per ogni Gruppo oppure per ogni coppia Gruppo-Login si potranno elencare i moduli di AziendaPc che si desidera disabilitare.
Se si devono disabilitare più moduli occorre separare i nomi da ; (punto e virgola)

Segue l'elenco dei 'nomi moduli' da indicare per disabilitarli:

Comuni (tutte le tabelle comuni); Coge; Cogecom; Cogefisc (Giornale, Registri Iva, Chiusura iva); DF (Comunicazione dati fattura); Fatt (ddt, Fatture etc.); Fattcom (tabelle di fatturazione); Maga (gestione movimenti e stampe di magazzino); Magacom; Ordi (ordini); DiBa (distinta base) ; Tracc (Tracciabilità - Lotti); Cespiti; XML (Preparazione file fattura Elettronica); TS (Preparazione file Tessera Sanitaria)

Se si rende necessario abilitare, a login diverse, l'accesso ai database delle aziende (cioè fare in modo che una login veda solo alcune aziende e non altre), occorre impostare le permissioni in Gestione database aziende.
Se invece si vuole abilitare/disabilitare le varie login a singoli programmi occorre eseguire la gestione dei menu. Questa consente di abilitare o meno una funzione ad un certo gruppo di utenti e di entrare nei programmi di gestione in variazione o in sola visualizzazione.
Con l' icona in alto a destra è possibile accedere alla [image] Abilitazione/Disabilitazione della creazione del file del LOG.

Una volta impostata dal Supervisor, ogni utente potrà cambiare la sua PassWord utilizzando la funzione Cambia PassWord dal menu Parametri e utilità, Utilità.

Attivando nel file AziWin.ini il parametro Dominio=Nome_Dominio
si da la possibilità di gestire le login degli utenti con cui si è fatto l'accesso a windows (solo se si usa un server con dominio). Se è impostato questo parametro, ed è stato creata in aziwin (con gestione utenti) un utente con una login uguale ad una con cui si accede al computer all'accensione, il programma, in entrata in aziwin, controlla che la login di accesso sia di quel dominio e sia nella lista delle login abilitate da aziwin e non verrà più chiesta in aziwin né login , né password.

Abilitazione File di LOG

Abilitando la scrittura del file del log il programma scriverà su un file con nome uguale al codice azienda inserito alla creazione dell'azienda e memorizzato nella directory AziWin\LOG, una riga in corrispondenza ad ogni accesso e uscita da una funzione da parte di ogni utente.


GESTIONE MENU

Percorso: dal menu principale: Shift-Ctrl-Alt L

La funzione permette la gestione e l'inserimento dei titoli, dei frame e dei pulsanti che vengono visualizzati nel Menu della procedura, con la descrizione dei programmi da eseguire.
E' disponibile un pulsante per spostare un frame o un singolo pulsante sotto un altro titolo o frame.

Gli ultimi due pulsanti posti in alto a destra consentono di Abilitare o Disabilitare le varie funzioni a terminali, login, gruppi di login

Le login e i gruppi vanno invece creati con le apposite funzioni da Gestione utenti

Con il pulsante [image] (T) Abilitazione Menu Testate si può abilitare o disabilitare una pagina intera di funzioni (es. Contabilità, Prima nota)

Inizialmente viene chiesta login e password del Supervisor (se non è mai stata inserita si digiteranno i valori di default)

Se si deve abilitare, anche un solo utente, a tutto occorre inserire una riga dove in "collegamento Menu" si digiterà -1 e in login abilitate (o gruppi) scrivere la/le login (gruppi) abilitate a tutto.

In modo analogo, se si deve abilitare, anche un solo utente a tutto, con il pulsante [image] (D) Abilitazione Menu dettagli si dovrà inserire una riga dove in "Colleg.al menu (chiave principale)" si scriverà: TUTTI e in "Colleg.al menu (chiave secondaria)" si scriverà: TUTT
Successivamente si possono cercare i singoli pulsanti delle varie funzioni (individuati da codice principale e secondario) e abilitarli o disabilitarli.

Nell' abilitazione dei dettagli (singole funzioni) è possibile abilitare terminali o utenti alla sola lettura.

Questa abilitazione ha senso solo su funzioni ben precise (es. le Gestioni)

Il nome terminale a cui si fa riferimento è quello inserito nell'ini di aziwin (scritto al momento dell'installazione).

Si possono mettere più nomi di terminali o di login separati da ; e si accettano anche i caratteri * , ? etc.

Con l'espressione !(xx;yy;zz) si indica che l'accesso a quella funzione è abilitata a tutti TRANNE a xx, yy, zz

Per spiegazioni più dettagliate leggere il paragrafo:
Come abilitare solo alcune scelte di menu ad un utente


CONFIGURAZIONE MENU

Percorso: dal menu principale: Shift-Ctrl-Alt L

Questa funzione consente di configurare i parametri per modificare la grafica del menu.

  • Barra comandi
  • Grafica
  • Colori

Barra comandi
E' possibile inserire fino a 20 icone che consentiranno l'accesso rapido alle funzioni di uso più comune. Le informazioni necessarie per ogni icona (riga) sono le seguenti:
Separa barrare la casella e non compilare nient'altro sulla riga se si vuole introdurre uno spazio di separazione tra un gruppo di icone e un altro.
Descrizione è la scritta che comparirà sotto l'icona, ad indicare la funzione corrispondente
ToolTip è la scritta che verrà visualizzata quando l'utente passa col cursore sopra l'icona. Si consiglia di mettere la lettera, che verrà poi specificata nella colonna C, da utilizzare per l'accesso senza mouse e una descrizione della funzione.
Comando cercare, con un click sui puntini, la funzione da associare all'icona
C impostare la lettera che, in combinazione con il tasto indicato nella riga in basso 'Con i comandi usa:' consente di accedere alla funzione in alternativa al click del mouse sull'icona
Immagine impostare l'immagine da visualizzare. Essa può essere scelta con un click sui puntini a fianco, tra quelle messe a disposizione dal programma, oppure con 'Cerca' tra i file presenti sul disco.

Grafica
Si consente di impostare
- il valore del parametro 'Generale' nel paragrafo 'RisoluzioneVideo'
per adattare le maschere al monitor in uso. Con il pulsante 'Prova', si consente di vedere immediatamente il risultato, dopo aver impostato la Risoluzione video.
- menu visibile - se non spuntato non saranno visibili i pulsanti delle scelte ma solo il menu a tendina (che andrà abilitato)
- il menu a tendina
- una immagine di sfondo del video per quando si usa il menu a tendina, selezionabile tra le immagini di default (1 - Logo di AziWin (farfalla) oppure 2 - Logo Zucchetti o quelle a disposizione sul computer.

I parametri per abilitare le modifiche impostare, a seconda della scelta che si fa alla richiesta: 'Dove salvare', potranno valere SOLO per il terminale che le conferma o per TUTTI i terminali e di conseguenza verranno memorizzati nella sezione [Menu] del file dei parametri aziwin.ini locale o su quello comune a seconda della scelta:

  • Parametri di questo terminale
  • Parametri comuni

Colori
Consente di gestire i colori per il Menu o per le Maschere dei programmi, in pratica verranno impostati in automatico, al termine delle scelte, i parametri per la personalizzazione dei colori: ColBackMenu e ColBackForm
Per utilizzare i colori standard basta spuntare l'opzione 'Uso colori standard' altrimenti si può scegliere il colore desiderato scegliendo, con un click, prima sulla lista dei colori Colori Base poi su un 'colore' particolare della tavolozza. Il risultato viene subito visualizzato nei campi di esempio in basso nel video e in alto vengono riportati i valori RGB del colore scelto.
Una volta fatta la scelta dei colori, si chiede di SALVARE e sono presenti due opzioni:
Generico per tutti i database oppure Scelta del database a cui applicare i colori


RIPRISTINI DA INTERRUZIONE

Questo capitolo contiene le spiegazioni delle funzioni che devono essere eseguite dopo un' interruzione accidentale di alcune elaborazioni quali l'inserimento di registrazioni con l'Input di prima nota, l'inserimento o la stampa di un documento (Ordine, ddt o fattura) etc.

Rientrando nel menu dopo una interruzione, il programma segnala subito quale di queste funzioni va eseguita per ripristinare i dati corretti sugli archivi.

Si raccomanda di eseguire subito la funzione suggerita al fine di evitare ulteriori danni ai dati.


SCARICO/CARICO FILE ASCII

In questo paragrafo vengono descritte le funzioni che consentono di importare dati sul database utilizzato dalle procedure e/o di esportarli.

E' possibile, ad esempio, importare i dati anagrafici di clienti, fornitori, articoli etc. da un file ascii, dopo aver compilato opportune tabelle con le caratteristiche dei dati da caricare. Questa funzione consente quindi di importare dati da altre procedure (Vedi Caricamento dati da archivi esterni)

Esiste poi un altro gruppo di funzioni che consente lo scambio di dati tra due database aggiornati alla stessa versione di AziWin, per rispondere ad esigenze quali:

Scaricare i movimenti di magazzino registrati in una sede periferica per poi ricaricarli nella sede centrale per aggiornare, anche lì, le giacenze.
Creare movimenti di magazzino in base a quanto scritto, con la sintassi opportuna, su un file preparato da un'altra procedura (es. una procedura di Gestione Hotel prepara dei movimenti di scarico per aggiornare un magazzino gestito con AziWin)
Scarico movimenti di magazzino su file
Caricamento movim.di magazzino da file

Scaricare su file i ddt emessi in una sede periferica per poi caricarli nella sede centrale che procederà alla fatturazione
Scarico Ddt su File
Carico Ddt da file

Scaricare le registrazioni contabili generati dalle fatture emesse da piccole imprese per trasmetterle al commercialista che le caricherà e completerà la contabilità del periodo
Trasferimento Mov.di Prima Nota di fatture su file
Caricamento Mov.di prima nota da file esterno
In questo caso verranno scaricate anche le tabelle correlate quali: Conti, Clienti, Fornitori, Causali, Monete, Centri di Costo, Banche, Pagamenti, Tipi pagamento e Codici iva in modo da caricare in automatico, quando si caricano i movimenti, anche le eventuali anagrafiche mancanti.

Scaricare un gruppo di registrazioni di prima nota per ricaricarle su un altro Database
Trasferimento Mov.di Prima Nota di fatture su file
Caricamento Mov.di prima nota da file esterno


TRASFERIMENTO MOV.DI P.NOTA DI FATTURE SU FILE

Percorso: Vendite - Servizio

Il programma consente di memorizzare su un file esterno i movimenti contabili e iva generati dalla contabilizzazione delle fatture, nel caso si debbano consegnare a un consulente o trasferire in un'altra sede.
Vedi note per la preparazione dei parametri e l'ordine con cui vanno eseguite le funzioni.

Condizione indispensabile perché si possa eseguire questa funzione è che nella tabella di fatturazione sia stato dichiarato che lo scarico dei movimenti delle fatture va fatto su: Area di Parcheggio.

I movimenti 'scaricati' verranno memorizzati in una tabella dal nome:
MovPnXXX dove xxx è l'ID azienda e viene generata in aziwin\carica, salvo l'operatore non decida di cambiare la destinazione; in questo caso, verrà memorizzato nell'ini (nel paragrafo: [Scarico Mov Pn Fat]) la destinazione scelta e riproposta negli scarichi successivi.
In parallelo a questa tabella, ne viene creata un'altra con lo stesso nome+Tab.txt (MovPnXXXTab.txt) contenente le anagrafiche (tutti i campi contenuti nelle rispettive tabelle sul database) incontrate durante lo scarico: conti, clienti, fornitori, causali, monete, centri di costo, banche, pagamenti, tipi pagamento e codici iva in modo da poterle creare, quando mancano, sul database ricevente.

Il programma di caricamento proporrà il nome: MovPnxxx.txt o quello già memorizzato in aziwin.ini nella sezione [Carico Mov Pn Fat].

E' possibile eseguire l'estrazione dei movimenti fino a una certa data ed, eventualmente, ripetere l'estrazione di movimenti già estratti, specificando il numero e la data dei documenti da estrarre di nuovo.

I movimenti estratti si possono accodare o meno sul file ottenuto dalla precedente estrazione, in generale non vanno accodati se la tabella estratta precedentemente è già stata consegnata ad altri per l'elaborazione.

Di seguito viene riportato il tracciato record della tabella generata.

Questa funzione può servire a chi vorrà produrre dei movimenti da una procedura di fatturazione personalizzata, da caricare in AziendaPc.

In questo caso la tabella nome+Tab.txt dovrà comunque essere creata anche se vuota.

I campi segnalati con * sono obbligatori

Le date possono essere scaricate nella forma gg/mm/aa (oppure aaaa) o ggmmaa (oppure aaaa)

Separatore per i record:
Carriage return + line feed (chr$(13) + chr$(10))

Separatore per i campi:
Tab (chr$(9))

La prima riga del file dovrà contenere la scritta fissa Fattura o PrimaNota a seconda che i movimenti scaricati su file siano stati generati da fatture oppure dalla prima nota.
Dopo questa scritta, il programma di preparazione del file, elenca altri campi che vengono scaricati (si tratta di campi aggiunti in un secondo momento). Il corrispondente programma di carico, terminato il caricamento dei campi 'vecchi', caricherà anche questi.
Elenco nuovi campi testata Elenco nuovi campi dettaglio
Dalla versione 3.04 di AziendaPc, il programma di scarico prepara TUTTI i campi leggendoli dalle rispettive tabelle access (MovPnTes, MovPnDett etc.)

E' indispensabile, se il file viene preparato da un'altra procedura, al fine di predisporre tutti i campi per il caricamento, aggiungere i nuovi campi con la seguente sintassi:
T:NomeCampo o D:NomeCampo
a seconda che sia un campo contenuto nelle righe T (testata) o D (dettaglio)
seguito da un numero che indica il tipo di campo:
integer: 2 long: 3 single: 4 double: 5 currency: 6 data: 7 stringa: 8
(stessa sintassi utilizzata per le tabelle)
Esempio:
PrimaNota T:RifAnniPrec 8 T:DocCollegato 8 T:BlackList 8
Ogni campo è separato dall'altro da un Tab cioè:
PrimaNota(Tab)T:RifAnniPrec(Tab)8(Tab)T:DocCollegato(Tab)8(Tab)T:BlackList(Tab)8

Nel primo campo di ogni record c'è un codice che indica che tipo di record è:

  • T Testata
  • D Record dettaglio
  • I Record IVA

Testata :

  • T (tipo record = testata)
  • * P (tipo movimento: P= mov.di prima nota)
  • E = Estrazione, R = Riestrazione
  • * Anno (anno della registrazione, es.2001)
  • NumReg
    (se a 0 o vuoto, il programma di caricamento, assegna il primo numero libero)
  • DataReg
  • * Codice Causale (obbligatorio) 2 caratteri
  • PreProt 1 carattere
    (è il prefisso, cioè il libro iva su cui va stampata la fattura. Se si utilizza un unico registro può essere lasciato vuoto).
    I campi: numero e data documento e protocollo, vanno impostati obbligatoriamente, se si tratta di una fattura o nota di credito.
  • Numero Protocollo numerico massimo 6 cifre
  • Data Protocollo
  • Prefisso Documento 1 carattere (si può omettere)
  • Numero Documento alfa 12 caratteri
  • Data Documento
  • Codice Moneta (se è quella di gestione si può omettere) alfa 4 caratteri
  • Cambio (se la moneta è quella di gestione si può omettere) num.
  • PeriodoIva (indica il mese nel quale il movimento aggiorna l'iva, lasciare bianco se è lo stesso della data di registrazione) num. 1-12
  • AnnoIva (lasciare bianco se è lo stesso della data di registrazione) num. 4 cifre
  • CentroDiCosto alfa 8 caratteri
  • Ragruppa Ricevute Bancarie S o N
  • Codice Banca alfa 10 caratteri
  • Condizione di Pagamento alfa 6 caratteri
  • Importo per la generazione delle scadenze, nella moneta della fattura. Nel caso di una fattura con acconto, non coincide con il totale fattura ma è il totale fattura meno l'acconto.
  • Importo per la generazione delle scadenze, espresso nella moneta di gestione
  • In Valuta (se movimento in valuta mettere S) alfa 1 carattere
  • Descrizione Causale alfa 20 caratteri
  • Descrizione Aggiuntiva alfa 30 caratteri
  • Descrizione Libera alfa 30 caratteri
  • Stato Giornale (vuoto, non viene ricaricato)
  • Stato Iva (vuoto, non viene ricaricato)
  • Flag Partita Chiusa (vuoto, N, S)
  • Dati Intra Cee alfa 30 caratteri
    (è la stringa che contiene Moneta, cambio etc. nel caso di fatt.di acquisto intracee)
  • Data Scadenza (è una data descrittiva, utilizzata da alcuni commercialisti)

Nuovi campi Testata (scaricati con la sintassi spiegata sopra)

  • T:RifAnniPrec stringa 1 carattere
    Impostare se il documento è una nota credito che va in Black List, relativo a fattura di un periodo precedente:
    S=relativa Anni precedenti, B = relativa a periodi precedenti nell'anno
  • T:DocCollegato stringa 255 caratteri
    Può contenere la path completa di un eventuale documento (es. pdf) collegato alla registrazione
  • T:BlackList stringa 1 carattere
    Impostare a S se il documento è una fattura o nota credito che va in Black List

Dettaglio:

Nelle fatture, il primo dettaglio deve contenere la riga del cliente, in Dare con il totale fattura
Seguiranno tante righe di dettaglio per ogni conto di ricavo (o stesso conto ma diverso codice iva) e, per ultimo, uno con il conto iva e l'importo totale dell'iva della fattura.

  • D per dettagli
  • Numero Progressivo dettaglio
  • * Codice Partita alfa 8 caratteri
    (Codice cliente/Fornitore/conto) (es. 03010001)
  • Codice contropartita alfa 8 caratteri
  • * DareAvere D = dare A = Avere
    Se nota di credito cliente, la riga cliente va in Avere, se nota di credito fornitore la riga fornitore va in Dare
  • Importo di riga, nella moneta del movimento
  • Importo di riga nella moneta corrente
  • Codice Ivaalfa 4 caratteri
    E' obbligatorio per i movimenti di contropartita di una fattura
  • Imposta della riga, nella moneta del movimento
  • Imposta di riga nella moneta corrente
  • Forzatura
    - Impostare ad S se imposta forzata cioè non calcolata come percentuale esatta dell'imponibile
    - E' obbligatorio mettere I (lettera I di Iva) nelle righe corrispondenti al conto iva di una fattura (ultimo dettaglio dei movimenti di una fattura)
  • Imposta Indetraibile nella moneta del movimento
  • Imposta Indetraibile nella moneta corrente
  • TipoPartita alfa 1 carattere
    (1=conto, 2=fornitore, 3=cliente, bianco)
    è obbligatorio se si deve creare il cliente o il conto
  • Tipo Contro Partita (1=conto, 2=fornitore, 3=cliente, bianco)
  • Descrizione aggiuntiva del dettaglio alfa 30 caratteri
  • Prefisso Protocollo (vedi testata)
  • Numero Protocollo (vedi testata)
  • Data Protocollo (vedi testata)
  • Prefisso Documento (vedi testata)
  • Numero Documento (es. è il numero della fattura fornitori) (vedi testata)
  • Data Documento (vedi testata)
  • Centro Di Costo alfa 8 caratteri
  • Tipo competenza
    G (Giornaliera) o M (Mensile)
    se le date successive mancano, anche questo campo va lasciato vuoto
  • Data Competenza da
  • Data Competenza a
  • Forzatura Moneta Corrente
    Valore di default: N
    Va impostato a S nel caso di una registrazione di una fattura in valuta, con iva se è stata forzata l'imposta calcolata nella moneta corrente
  • Flag partita Chiusa
    Indica se appartiene ad una partita chiusa: "C"=chiusa, "A" o vuoto=aperta

Nuovi campi dettaglio (scaricati con la sintassi spiegata sopra)

  • D:StatoGio stringa
    Impostare a S se la riga è stata stampata sul giornale
  • D:SoggRitAcc stringa
    Impostare a S se la riga è soggetta a ritenuta d'acconto
  • D:PartForzata stringa
    Impostare a F se la 'partita' è stata chiusa in modo forzato
  • D:BlackList stringa (S/N)
    Obbligatorio S se la registrazione va inclusa nell'invio Black List
  • D:GruppoBlackList stringa
  • D:MastroBlackList stringa
  • D:ContoBlackList stringa
    Sono rispettivamente il gruppo-mastro-conto del fornitore 'Black List' nella registrazione di una Bolla Doganale (acquisto).

Tipo record Iva

  • I (tipo record Iva)
  • Progressivo riga iva
  • Codice Iva alfa 4 caratteri
  • Imponibile nella Moneta della registrazione
  • Imponibile nella Moneta corrente
  • Imposta nella Moneta della registrazione
  • Imposta nella Moneta corrente

Basta impostare gli importi nella moneta della registrazione, l'altro verrà calcolato dal programma.
In caso di registrazione di Nota di credito, gli importi del record iva devono essere tutti negativi

  • Tipo Partita
  • Gruppo Partita alfa 2 caratteri
    (se numeri vanno allineati con 0 a sinistra es. 03)
  • Mastro Partita alfa 2 caratteri
    (se numeri vanno allineati con 0 a sinistra es. 02)
  • Conto Partita alfa 4 caratteri
    (se numeri vanno allineati con 0 a sinistra es. 0012)
  • Imponibile non detraibile nella moneta della registrazione
  • Imponibile non detraibile nella moneta corrente
  • Imposta non detraibile nella moneta della registrazione
  • Imposta non detraibile nella moneta corrente
  • Importo per base di Ventilazione (solo eventualmente negli acquisti per ventilazione)
  • Forzatura alfa 1 carattere
    Impostare: S o N
    Si dovrà impostare ad S il campo se l'imposta non corrisponde esattamente alla % di iva calcolata sull'imponibile ma è stata forzata.

Struttura del file: MovFattxxxTab.txt (o MovPnxxxTab.txt) contenente le anagrafiche collegate alle fatture che potrebbero mancare nel database destinatario e che in tal caso verranno create.

Le Tabelle interessate sono: PianoConti (per ogni cliente, o codice conto diverso presente in fattura), Causali, Monete, Centri di Costo, Banche, Pagamenti, PagTipi

Separatore campi: Tab (chr$(9))

I record delle varie tabelle vengono memorizzati uno dopo l'altro e finita una tabella si memorizza la riga di testata della tabella successiva.

Prima riga di ogni tabella (riga di testata)

  • Scritta fissa: "Tabella :"
  • Nome tabella
  • Numero totale campi della tabella poi per ogni campo si ripete la coppia:
    • Nome campo (quello letto dal database)
    • Tipo campo
      (si dovrà rispettare la seguente tabella, a seconda del tipo di campo:
      integer: 2 long: 3 single: 4 double: 5 currency: 6 data: 7 stringa: 8)

Le righe successive verranno compilate con il contenuto dei campi dei vari record, scritti nell'ordine indicato nella 1' riga, separati da un chr$(9).
Se un campo è vuoto, ma è stato dichiarato sulla prima riga, va ugualmente inserito, preceduto e seguito da un Tab (chr$(9)).

Per una descrizione dettagliata dei campi, in particolare della tabella Pianoconti, si rimanda al paragrafo: Elenco campi per trasferimento cli/for.
Sul cd di installazione di Aziwin, nella cartella \BaseDoc è stato inoltre inserito il file: "lista campi tab_pianoconti.rtf" contenente la stessa lista.


ELENCO CAMPI PER TRASFERIMENTO CLI/FOR

La procedura di Contabilità prevede che possano essere caricate delle registrazioni di prima nota direttamente da un file ascii adeguatamente preparato (es. dal nome: MovPn001.txt)
Se le registrazioni fanno riferimento ad anagrafiche che potrebbero non esistere sul database ricevente, è possibile preparare anche un ulteriore file (es. MovPn001Tab.txt) contenente l’elenco delle anagrafiche:
banche, condizioni di pagamento, clienti, fornitori, etc.

Di seguito viene riportato l'elenco dei campi della tabella Pianoconti che possono essere scritti nel file MovPnXXXTab per essere poi caricati su un altro database contestualmente ai movimenti di prima nota che li riguardano.

La colonna Tipo riporta il Tipo campo cui si fa riferimento nel capitolo che descrive il Trasferimento:
integer: 2 - long: 3 - single: 4 - double: 5 - currency: 6 - data: 7 - stringa: 8

Nome campo
(*) = obbligatorio 		Tipo Dimensione Descrizione Posizione relativa:
(*) Gruppo | 8 (Testo) | 2 | 1
(*) Mastro | 8 (Testo) | 2 | 2
(*) Conto | 8 (Testo) | 4 | 3
(*)Tipo | 8 (Testo) | 1 | 1 = Coge, 2=Fornitori,3=Clienti | 4
(*) Descrizione | 8 (Testo) | 40 | Ragione Sociale Contabile (OBBLIGATORIA) | 5
RagSoc | 8 (Testo) | 30 | Rag. Sociale utilizzata solo per INTESTAZIONI nelle Vendite | 6
RagSoc2 | 8 (Testo) | 30 | C/Fparte della Rag.Sociale | 7
(*) DataAp | 7 (Data/ora) | 10 | Mettere la data nella forma gg/mm/aaaa | 8
DataChiu | 7 (Data/ora) | 10 | Data chiusura conto | 9
CDC | 8 (Testo) | 6 | Centro di costo | 10
CdcObblig | 8 (Testo) | 1 | 11
Budget | 5 (Precisione. Doppia) | 8 | (PosizioniDecimali:2) | 12
Ventilazione | 8 (Testo) | 1 | 13
TipoConto | 8 (Testo) | 1 | 14
Ricl1 | 8 (Testo) | 5 | Riclassificazione 1 | 15
Ricl2 | 8 (Testo) | 5 | Riclassificazione 2 | 16
Ricl3 | 8 (Testo) | 5 | Riclassificazione 3 | 17
Ricl4 | 8 (Testo) | 5 | Riclassificazione 4 | 18
(*) Indirizzo | 8 (Testo) | 30 | 19
(*) CAP | 8 (Testo) | 5 | 20
(*) Localita | 8 (Testo) | 40 | 21
(*) Pr | 8 (Testo) | 2 | 22
Stato | 8 (Testo) | 4 | Obbligatorio se non è ITALIA | 23
Telefono | 8 (Testo) | 30 | 24
Telefono1 | 8 (Testo) | 30 | 25
Fax | 8 (Testo) | 20 | 26
EMail | 8 (Testo) | 50 | 27
(*) PartIva | 8 (Testo) | 12 | 28
(*) CodFisc | 8 (Testo) | 16 | 29
(*) StatoGiurid 8 (Testo) 1 "F" = Pers. Fisica
"G" = Pers. giuridica 		30
DatNascita | 7 (Data/ora) | 10 | Obbligatorio se Persona fisica | 31
(*) Sesso | 8 (Testo) | 1 | M o F (se pers.giuridica ci va comunque M) | 32
CapNascita | 8 (Testo) | 5 | (Obbligatorio se Persona fisica se Pers. Fisica) | 33
LocalitaNascita | 8 (Testo) | 40 | (Obbligatorio se Persona fisica se Pers. Fisica) | 34
PrNascita | 8 (Testo) | 2 | (Obbligatorio se Persona fisica se Pers. Fisica) | 35
StatoNascita | 8 (Testo) | 4 | 36
PersRiferimento | 8 (Testo) | 40 | 37
NoteCF 8 (Memo) - 38
PdcClasseAttr1 | 8 (Testo) | 3 | Attributto classe 1 | 39
PdcClasseAttr2 | 8 (Testo) | 3 | Attributto classe 2 | 40
PdcClasseAttr3 | 8 (Testo) | 3 | Attributto classe 3 | 41
PdcClasseAttr4 | 8 (Testo) | 3 | Attributto classe 4 | 42
PdcClasseAttr5 | 8 (Testo) | 3 | Attributto classe 5 | 43
(*) AllegCF | 8 (Testo) | 1 | In allegati: S o N | 44
Zona | 8 (Testo) | 5 | 45
Categoria | 8 (Testo) | 5 | 46
(*) CliForFittizio | 8 (Testo) | 1 | Mettere fisso "N" | 47
Lingua | 8 (Testo) | 3 | 48
(*) SiValuta | 8 (Testo) | 1 | Mettere fisso "N" | 49
(*)Moneta | 8 (Testo) | 4 | Mettere fisso il codice dell' Euro (Euro)
Banca | 8 (Testo) | 10 | 51
CCorrente | 8 (Testo) | 20 | Numero C. Corrente | 52
(*) RagRB | 8 (Testo) | 1 | Raggr. Ric.Bancarie in distinta : "S" o "N" | 53
Pagamento | 8 (Testo) | 6 | Cod.Condizione di Pagamento | 54
MeseNoEf1 | 2 (Intero) | 2 | Mese 1 nel quale non riceve effetti | 55
MeseNoEf2 | 2 (Intero) | 2 | Mese 2 nel quale non riceve effetti | 56
GioMesSucc1 | 2 (Intero) | 2 | Giorno del mese successivo al mese 1 in cui non riceve effetti | 57
GioMesSucc2 | 2 (Intero) | 2 | Giorno del mese successivo al mese 2 in cui non riceve effetti | 58
GruppoContr 8 (Testo) 2 \ 59
MastroContr | 8 (Testo) | 2 | > ---- Contropartita da proporre in prima nota | 60
ContoContr 8 (Testo) 4 / 61
(*) Rischio | 8 (Testo) | 1 | S/N Cliente a Rischio | 62
Fido 5
(Prec.Doppia) 		8 .PosizioniDecimali: 2 63
DicIntenti | 8 (Testo) | 30 | Dich.d'intenti: Descr. + data + numero | 64
Sconto | 8 (Testo) | 15 | Sconto del cliente da scriversi 10+3+2 | 65
Agente1 | 8 (Testo) | 4 | Cod.agente principale | 66
Agente2 | 8 (Testo) | 4 | Cod.secondo agente | 67
Provv1 | 5 (Prec.Doppia) | 8 | % Provv. agente 1 .PosizioniDecimali:2 | 68
Provv2 5
(Prec.Doppia) 		8 % Provv. agente 2 PosizioniDecimali:2 69
(*) TipoProvv | 8 (Testo) | 1 | Mettere fisso "N" | 70
(*) TipoProvv2 | 8 (Testo) | 1 | Mettere fisso "N" | 71
(*) SpeseBan | 8 (Testo) | 1 | Addebito spese bancarie : "S" o "N" | 72
Spesa | 8 (Testo) | 4 | Spesa da riportare in automatico sul documento | 73
(*) Bolli | 8 (Testo) | 1 | Addebito bolli: S o N | 74
(*) RagDDT | 8 (Testo) | 1 | Mettere fisso "N" | 75
RagOrd | 8 (Testo) | 1 | Raggr. ordini in evasione: S/N | 76
(*) StRifOrd | 8 (Testo) | 1 | Mettere fisso "N" | 77
(*) StRifCli | 8 (Testo) | 1 | Mettere fisso "N" | 78
(*) IvaSosp | 8 (Testo) | 1 | Iva Sospesa S/N | 79
Iva | 8 (Testo) | 4 | Cod.Esenz.o Cod.Iva (solo se particolare) | 80
Listino | 8 (Testo) | 2 | 81
Vettore | 8 (Testo) | 4 | 82
IndSped | 8 (Testo) | 3 | Cod. Indirizzo di Spedizione Merce | 83
IndAmm | 8 (Testo) | 3 | Cod. Indirizzo di Spedizione Fatture | 84
Resa | 8 (Testo) | 3 | Cod.Resa(P.Franco, P.Assegnato) | 85
(*) PrezzoDDT | 8 (Testo) | 1 | Mettere fisso "N" | 86
GruppoCFColl 8 (Testo) 2 \ 87
MastroCFColl | 8 (Testo) | 2 | > ----Cod.Cliente (o Fornit.collegato per CEE??) | 88
ContoCFColl 8 (Testo) 4 / 89
NoteOrdini 8 (Memo) - Note che, se inserite qui e nel filtro, verranno stampate sul corpo del docum. 90
NoteDdt 8 (Memo) - 91
NoteFattura 8 (Memo) - 92
NoteFatacc 8 (Memo) - 93
CompGiornMens | 8 (Testo) | 1 | Se vuota non gestisce date di competenza, se vale G calcolo su base giornaliera, M su base mensile | 94
DataPers1 | 7 (Data/ora) | 10 | per personalizz | 95
DataPers2 | 7 (Data/ora) | 10 | per personalizz | 96
DataPers3 | 7 (Data/ora) | 10 | per personalizz | 97
DescPers1 | 8 (Testo) | 50 | 98
DescPers2 | 8 (Testo) | 50 | 99
DescPers3 | 8 (Testo) | 50 | 100
ValPers1 5
(Prec.Doppia) 		8 per personalizz 101
ValPers2 5
(Prec.Doppia) 		8 102
ValPers3 | 5 (Precisione. Doppia) | 8 | 103
CodTrascodifica | 8 (Testo) | 20 | Per collegamento con altre tabelle clienti/fornitori di altre gestioni | 104
NrPrgIntenti | 2 (Intero) | 2 | Num. progressivo della dich. di intenti ricevuta, assegnato da chi riceve | 105
NrDichIntenti | 2 (Intero) | 2 | Num. della dich. di intenti, comunicato dal cliente | 106
DataRicComIntenti | 7 (Data/ora) | 8 | Data in cui è stata ricevuta la comunicazione di intenti | 107
RifComunicIntenti 8 (Testo) 1 1=Una sola operazione, 2=più operazioni,
3=oper.di un periodo 		108
ImportoDichIntenti | 5 (Precisione. Doppia) | 8 | Importo a cui la dich. di intenti si riferisce | 109
DataDAIntenti | 7 (Data/ora) | 8 | Data da (indicano il periodo di validità della dich. di intenti, se RifComu..=3 | 110
DataAIntenti | 7 (Data/ora) | 10 | Data A | 111
DataDichIntenti | 7 (Data/ora) | 10 | Data della comunicazione di intenti, comun.dal cliente | 112
PassWordOnLine | 8 (Testo) | 12 | PassWord per consultazioni via internet | 113
(*)SoggRitAcconto | 8 (Testo) | 1 | Mettere fisso "N" | 114
(*) Comune | 8 (Testo) | 30 | Obbligatorio se la Località non è già ,a sua volta, un comune | 115
PercRitAcc 5
(Prec.Doppia) 		8 % per calcolo importo Rit.Acconto 116
Cointest | 8 (Testo) | 12 | Codice cointestatario delle fatture | 117
Iban | 8 (Testo) | 34 | Codice Iban | 118
CodBic | 8 (Testo) | 11 | Codice B.I.C. | 119
CoAcqCessBeniStrum | 8 (Testo) | 1 | N-No A-Acquisti C-Cessioni (Per Conti in Comun.Annuale Dati Iva) | 120
(*) BlackList | 8 (Testo) | 1 | Mettere fisso "N" - residenti in paesi BlackList | 121
BeneServizio | 8 (Testo) | 1 | B=Bene S=Servizio C=Costi accessori(Conti - per bolle doganali) | 122
PercRicListClie 5
(Prec.Doppia) 		8 Percentuale ricarico listino cliente da carico fornitore 123
(*)OperazRilev 8 (Testo) 1 Operaz. rilevante ai fini IVA S=Sempre E=Escluso N=Normale
Mettere fisso “N" 		124
EMail2 | 8 (Testo) | 50 | Email - Amministrativo | 125
EMail3 | 8 (Testo) | 50 | Email - Commerciale | 126
EMail4 | 8 (Testo) | 50 | Email - Magazzino | 127
EmailFat | 3 (Intero lungo) | 1 | Quale email usare per stampa fattura (0-4) | 128
EmailDdt | 3 (Intero lungo) | 1 | Quale email usare per stampa ddt (0-4) | 129
EmailOrd | 3 (Intero lungo) | 1 | Quale email usare per stampa ordini (0-4) | 130
EmailAltro | 3 (Intero lungo) | 1 | Quale email usare per altre stampe (0-4) | 131
Pagamento2 | 8 (Testo) | 6 | Eventuale seconda Condizione di Pagamento (richiam. in FattDocumenti) | 132
DataProcConcDa | 7 (Data/ora) | 10 | Data Procedura concorsuale per sospendere l'iva pagata degli acquisti | 133
DataProcConcA | 7 (Data/ora) | 10 | 134
(*) IvaCassaDisabil 8 (Testo) 1 S=Non abilitato all'Iva per Cassa
Mettere fisso “N" 		135
(*) SpesRevCharge 8 (Testo) 1 Se vale S nell'estrazione per spesometro segnala reverse charge
Mettere fisso “N" 		136
(*) CassaPrev 8 (Testo) 1 Soggetto a Cassa Previdenza
Mettere fisso “S" 		137
FECodEori | 8 (Testo) | 17 | Codice EORI - Per fattura elettronica | 138
FECodIPA | 8 (Testo) | 7 | Codice Ufficio - Per fattura elettronica | 139
FETitolo | 8 (Testo) | 10 | Titolo (Ing.,Prof) - Per fattura elettronica | 140
(*)TSIncluso 8 (Testo) 1 S=per scaricare le sue fatture in Tessera Sanitaria(default) - N=No
Mettere fisso “S" 		141
TSTipoSpesa | 8 (Testo) | 2 | Lasciare bianco | 142
EmailPEC | 3 (Intero lungo) | 1 | Quale email usare come PEC (0-4) | 143
FAStabOrgIndir | 8 (Testo) | 60 | Stabile Organizzazione (per Comunicazione Fatture) | 144
FAStabOrgCap | 8 (Testo) | 5 | 145
FAStabOrgComune | 8 (Testo) | 60 | 146
FAStabOrgPr | 8 (Testo) | 2 | 147
FAStabOrgStato | 8 (Testo) | 2 | 148
FARappFiscCodIdFisc | 8 (Testo) | 28 | Dati del Rappresentante Fiscale (per Comunicazione Fatture) | 149
FARappFiscRagSoc | 8 (Testo) | 80 | Se c'è un - o un _ si estrae Cognome e Nome | 150
FARappFiscStato | 8 (Testo) | 2 | 151


SCARICO MOV.DI FATT.SU FILE (tracciato Team System)

Percorso: Vendite - Servizio (Personalizzato)

Il programma legge i movimenti di fattura ed eventuali incassi relativi, memorizzati dalla contabilizzazione fatture sui movimenti di transito (MovPnxxxFatt) e li scarica su un file creato appositamente nel formato leggibile dalla contabilità di Team System.

Vengono utilizzati due parametri di personalizzazione:
Gruppo: fatture
Chiave: ScarTSDitta e Chiave: ScarTSSerie

Dove vanno inseriti rispettivamente il codice della ditta e il prefisso (registro iva) utilizzato.


SCARICO MOV.DI FATT.SU FILE (tracciato PRAGMA)

Percorso: Vendite - Servizio (Personalizzato)

Il programma legge le registrazioni generate dalla contabilizzazione delle fatture sui movimenti di transito di prima nota (MovPnxxxFatt) e prepara due file, una con i movimenti e una con le anagrafiche clienti, creati nel formato leggibile dalla contabilità di Pragma.

Le registrazioni scaricate sono: fatture ed gli eventuali incassi, omaggi e anticipi.
Al fine di poter eseguire questa funzione occorre impostare, sulla tabella di Fatturazione (in Dati generali azienda -Parametri), il campo 'Scarico Mov.fatture' a 'Archivi di parcheggio'

Al fine di gestire la corrispondenza dei codici tra le due procedure, vengono utilizzate le tabelle di trascodifica e, per i conti e i clienti, il campo 'codice trascodifica' che è all'interno di ogni anagrafica.

Per tabella Clienti - note su valorizzazione di campi particolari

ID_Cliente | Campo 'Codice trascodifica' dell'anagrafica clienti oppure, se questo è vuoto, Mastro+Codice Cliente (es. xxzzzz)
ID_Provincia | è la sigla della Provincia
ID_Stato | è la sigla dello Stato (letto da Tabella Trascodifica) Per campo vuoto si scarica fisso '390'
ID_Regione | Viene ricostruito a partire dal Cap del cliente (Tabella Cap) Il codice Regione da scaricare si legge da Tabella Trascodifica
ID_Conto | Codice contabile del cliente - da parametro di personalizzazione: PragmaContoCli, uguale per tutti i clienti

Per tabella Movimenti - note su valorizzazione di campi particolari

ID_Movimento | Numero di registrazione
ID_Causale | Da tabella trascodifiche
ID_Regiva | E' il prefisso. Da tabella trascodifiche
ID_Conto | Se si tratta di un cliente, è il Codice contabile del cliente - da parametro di personalizzazione: PragmaContoCli, uguale per tutti i clienti Per i conti si legge dal campo 'codice trascodifica' che è all'interno di ogni anagrafica.
ID_SubConto | Cod.Cliente - Campo 'Codice trascodifica' dell'anagrafica clienti oppure, se questo è vuoto, Mastro+Codice Cliente (es. xxzzzz)
Importo_Lire | E' l'importo della riga. Positivo se in Dare, negativo se in Avere
ID_Iva | Da tabella trascodifiche
Importi (altri) | Sempre positivi

N.B. Se il programma non trova il codice 'Pragma' corrispondente a uno da scaricare, scaricherà il codice stesso.

Esempio di valore da dare al parametro TabTrascod, per la preparazione delle tabelle per Pragma:
§Prefissi - Codici Registri Iva;Tabiva;Regioni;Causali;Stati


SCARICO MOV.DI FATT.SU FILE (tracciato Zucchetti AGO)

Percorso: Vendite - Servizio (Personalizzato)

Il programma legge i movimenti contabili di fattura ed eventuali incassi relativi, memorizzati dalla contabilizzazione fatture sui movimenti di appoggio (Menu Contabilità - Prima Nota - Prima Nota movimenti di appoggio) e li scarica su un file di testo, secondo un tracciato stabilito per essere caricato sulla procedura AGO Infinity di Zucchetti.
E' possibile inoltre trasferire su file tutte le anagrafiche dei clienti oppure solo quelle a cui appartengono le fatture da scaricare.

Al fine di ottenere un file corretto occorre:

  • Impostare in Parametri e Utilità - Dati generali azienda (parametri) Tabella Fatturazione:
    Scarico Mov. fatture in archivi di parcheggio
  • Le registrazioni che non sono fatture devono avere una sola riga dare e una avere
  • L'esportazione necessita del 'Codice applicazione registrata'
    Tale codice, alfanumerico di 5 caratteri, rappresenta la macchina della ditta che prepara il file e viene utilizzato dalla procedura Ago per creare la trascodifica dei clienti/fornitori. Esso sarà sempre lo stesso per tutte le esportazioni e potrà essere digitato a video ogni volta che si prepara il file delle fatture oppure si può impostare come valore nel Parametro di personalizzazione : AppReg Gruppo: ZuccAgo

Per creare le corrispondenze tra i codici utilizzati dalla ditta che prepara il file e chi lo caricherà, occorre:

  • Impostare il parametro di personalizzazione: TabTrascod Gruppo: Tutti
    Valore: §Prefissi - Codici Registri Iva;Tabiva;Causali;DitAttivita
    cioè l'elenco delle tabelle per le quali è necessario impostare dei codici di corrispondenza
  • Creare, con la funzione: Parametri e Utilità - Tabelle trascodifiche varie, le corrispondenze dei codici nelle tabelle:
    §Prefissi con prefisso AziWin e prefisso Zucchetti
    Causali
    DitAttivita
    Tabiva
    (se in Tabiva oltre all'aliquota nel campo che indica il codice Zucchetti corrispondente, si mette § seguito da 2 caratteri ,
    questi verranno scaricati nel campo Norma del record D31 Es. 022§sn 022 è il codice iva, sn è la norma
  • Archivi Comuni - Gestione Conti
    Compilare il campo Codice Trascodifica dei conti interessati allo scarico (ricavi, abbuoni, cassa, banca etc) con il codice che quel conto ha su Ago Infinity.

Estrazione / Riestrazione
Poichè una volta estratti i movimenti delle fatture verranno 'marcati' come trasferiti, se si rende necessario riestrarli si può utilizzare la scelta Riestrazione.

Numero e data spedizione
Digitare numero progressivo e data di esportazione

Codice applicazione registrata
alfanumerico di 5 caratteri. Viene visualizzato il codice eventualmente impostato nel parametro di personalizzazione AppReg

Scarico su file
Scegliere una cartella e assegnare il nome al file da scaricare. Il nome del file è libero e una volta impostato, verrà mantenuto per gli scarichi successivi.

Note sulla preparazione del file:
Anagrafiche clienti: se Persona Fisica si deve dividere il Cognome dal Nome e devono essere stati scritti Cognome-Nome oppure Cognome_Nome nel campo Ragione Sociale Contabile.

Il codice del nostro cliente lo scarichiamo : 03-01-0001

Per aggiungere la funzione al menu:
Chiave: UtilFatt ChiaveSec: TrZ6 Abilita: fatt
NomeProgr: UtilFatt.exe
PathProgr: $PathIni$\Fatturaz
Parametri: $ParamIni$ /f: frmScaMoFaZucc_2016
Personalizzato: P


SCARICO MOV.DI FATT.SU FILE (tracciato PASSEPARTOUT)

Percorso: Vendite - Servizio (Personalizzato)

Il programma legge le registrazioni generate dalla contabilizzazione delle fatture sui movimenti di transito di prima nota (MovPnxxxFatt) e prepara i seguenti file nel formato leggibile dalla contabilità Passepartout

  • rubr_SiglaAzienda.csv
    contenente le anagrafiche dei clienti
  • pnt1_SiglaAzienda.csv
    contenente le testate dei movimenti (registrazioni) di prima nota
  • pnr1__SiglaAzienda.csv
    contenente le righe dei movimenti (registrazioni) di prima nota

Le registrazioni scaricate sono: fatture ed gli eventuali incassi, omaggi e anticipi. E' possibile inoltre decidere di scaricare tutti i clienti oppure solo quelli ai quali sono intestate le fatture.

Per poter eseguire questa funzione occorre impostare, sulla tabella di Fatturazione (in Dati generali azienda -Parametri), il campo 'Scarico Mov.fatture' a 'Archivi di parcheggio'

Al fine di gestire la corrispondenza dei codici tra le due procedure, vengono utilizzate le tabelle di trascodifica e, per i conti e i clienti, il campo 'codice trascodifica' che è all'interno di ogni anagrafica.
Per i clienti, se il codice trascodifica è bianco, viene scaricato il codice cliente nella forma: XXMMCCCC

N.B. Se il programma non trova in tabella Trascodifiche il codice 'Passpartout' corrispondente a uno da scaricare, scaricherà il codice stesso.

Testate (T) e dettagli (D) dei movimenti- note su valorizzazione di campi particolari

PNPRN (T) | Numero di registrazione
PNCAU (T) | Da tabella trascodifiche (Causale contabile)
PNSPR (T) | Da tabella trascodifiche (prefisso documento)
PNCIC1-8 (T) | Clienti cointestatari (vengono cercati per ogni eventuale cliente cointestatario il codice trascodifica o, in mancanza di questo, il codice cliente)
PNCIP1-8 (T) | Percentuali dei cointestatari
PNCTO | Codice conto della riga di dettaglio. Nel caso si tratti di un cliente si scarica il codice trascodifica se compilato, altrimenti il codice stesso xxmmcccc. Per i conti si legge dal campo 'codice trascodifica' che è all'interno di ogni anagrafica.
PNIMP | E' l'importo della riga. Positivo se in Dare, negativo se in Avere
PNIMB | Imponibile in valore assoluto
PNIVA | Imposta in valore assoluto
PNALI | Cod.Iva - Da tabella trascodifiche

Esempio di valore da dare al parametro TabTrascod, per la preparazione delle tabelle per Passpartout:
Pagamenti;Monete;Zone;Categorie;§Prefissi - Codici Registri Iva;Tabiva;Causali


SCARICO DDT SU FILE

Percorso: Vendite - Servizio

La funzione può essere utilizzata per memorizzare su un file sequenziale, fatto secondo un formato predefinito, i Ddt registrati sul database per poterli poi trasmettere a una ditta collegata che li potrà, ad esempio, fatturare.

Nei parametri di personalizzazione (parametro: ScarTipoDoc) è possibile memorizzare i Tipi documento da proporre a video per la trasmissione (nel caso non debbano essere trasmessi tutti i Ddt) e lo Stato Ddt da scaricare di Default (Parametro: ScarStatoDdt)

Viene proposto il nome e la directory del file che verrà generato con possibilità di variazione da parte dell'operatore.
Il nome proposto sarà: Ddt+Idazienda.ddt

Descrizione del formato del file dei DDT.

Separatore per i record:
Carriage return + line feed (chr$(13) + chr$(10))
Separatore per i campi: Tab (chr$(9))

I codici che verranno scaricati (es. cliente, vettore, trasporto, banca etc.) devono essere uguali a quelli di AziendaPC

La prima riga del file dovrà contenere un elenco di nomi di campi aggiuntivi descritti nell'ultima parte del capitolo

Successivamente per ogni DDT si dovrà mettere sul file:
una riga che inizia per T (Testata da DdtTest)
eventualmente una o più righe con S (Spese da DdtSpese)
una o più righe con D (dettaglio da Dett)

I campi indicati con * sono OBBLIGATORI, per quelli non obbligatori che non si vogliono scrivere sul file, si scriveranno 2 tab consecutivi

* T per indicare che si tratta del record di testata
* DataRif (Data di inserimento)
* FattDocumento Char Width 2 (Tipo documento es. BV)
PreDoc Char Width 1
NumDoc Integer
DataDoc Date
Stato Char Width 1
* GruppoCli Char Width 2
* MastroCli Char Width 2
* ContoCli Char Width 4
* Tipo Char Width 1 (3 se Cliente)
RifCli Char Width 35
Iva Char Width 4 (eventuale codice esenzione del cliente)
* IvaSosp Char Width 1 (S/N) Va impostato a S se iva Sospesa
* DaFatturare Char Width 1 (S/N)
Listino Char Width 2
* PrezziIvati Char Width 1 (S/N)
* Moneta Char Width 4 (Codice dell'euro: Euro)
* Cambio (Fisso: 1)
Pagamento Char Width 6 (Condizione di pagamento)
* RagRB Char Width 1 (S/N) Indica se le eventuali scadenze di Ri.Ba. vanno raggruppate
* RagOrd Char Width 1 (S/N)
* RagDDT Char Width 1 Raggr. DDT in fattura : S-Si N-No A-una riga per ogni art.D-Una fatt.per ogni dest. (E=A+D)
Banca Char Width 10
ScontoCli Char Width 15 (Es. 10 oppure 2+3)
ScontoPag Char Width 15
* PrezzoDDT Char Width 1 0-NO,1prezzi e sconti,2 prezzo,3 netto,4 prezzi,sconti e tot.finale+iva,5 Prezzi e tot.ivato,T-come da FattDoc
* MagazzProv Char Width 8 (Codice magazzino di Scarico)
* MagazzDest Char Width 8 (Cod.cliente nella forma xxyymmmm)
Agente1 Char Width 4
Agente2 Char Width 4
* TipoProvv Char Width 1 (Prelievo % Provv. : N-No provv A-da articolo C-da cliente G-da agente (era 0-3))
* TipoProvv2 Char Width 1 (Prelievo % Provv. : N-No provv A-da articolo C-da cliente G-da agente (era 0-3))
PercProvv1 (eventuale % Provv. da applicare sugli articoli per il primo agente: es. 4)
PercProvv2 ( eventuale % Provv. da applicare sugli articoli, per il secondo agente: es. 4)
Acconto (eventuale acconto)
Nota
* StampoNota Char Width 1 (S/N)
NumNota1 Char Width 2 (eventuali Codici Note Fisse)
NumNota2 Char Width 2
NumNota3 Char Width 2
IndSped Char Width 3 (eventuale codice Indirizzo di Spedizione)
RagSoc Char Width 40 (Se manca il codice IndSped, nei campi seguenti si possono mettere i dati del destinatario se diverso dal cliente del ddt)
RagSoc2 Char Width 30
IndirizzoSped Char Width 30
CAPSped Char Width 5
LocalitaSped Char Width 40
PrSped Char Width 2
StatoSped Char Width 4
AspettoBene Char Width 3 (Cod. aspetto beni)
DescAspetto Char Width 30 (Se manca AspettoBene si può mettere direttamente la descrizione dell'aspetto dei beni: es. scatole)
CauTrasporto Char Width 3 (Cod. causale trasporto)
DescCauTrasporto Char Width 30 (Se manca CauTrasporto si può mettere direttamente la descrizione della causale trasporto Es. Vendita)
Resa Char Width 3 (Cod. Resa)
DescResa Char Width 30 (Se manca Resa si può mettere direttamente la descrizione della Resa: es. Porto Franco)
Trasporto Char Width 3 (Cod. Trasporto)
DescTrasporto Char Width 30 (Se manca Trasporto si può mettere direttamente la descrizione del Trasporto: es. Vettore)
Vettore Char Width 4 (Cod. Vettore)
RagSocVett Char Width 30 (Se manca il codice Vettore, nei campi seguenti si possono mettere diretamente i dati del Vettore)
IndirizzoVett Char Width 30
CAPVett Char Width 5
LocalitaVett Char Width 40
PrVett Char Width 2
TargaVett Char Width 15
DataRitiroMerce Date
OraRitiroMerce Date
DataInizioTrasp Date
OraInizioTrasp Date
Colli Numerico Intero
Peso Float
* TotMerce Float Questi 5 campi vanno calcolati in base agli articoli e alle spese inserite sul ddt
* TotSpese Float
* TotIva Float
* TotDocum Float
* TotImpon Float Totale Imponibile
LiberoTest1 Char Width 20
LiberoTest2 Char Width 20
LiberoTest3 Char Width 20
LiberoTest4 Char Width 20
Lingua Char Width 3
* Interno Char Width 1 (S/N) S se Ddt interno e non a cliente
DescPers1 Char Width 50 3 Campi per personalizzazioni
DescPers2 Char Width 50
DescPers3 Char Width 50

* S Riga di Spesa
* Spesa Char Width 4 (Codice Spesa)
* Iva Char Width 4 (Codice iva della Spesa)
Percentuale Numerico (% della spesa, se da calcolare in %) è obbligatoria la % o l'importo
Importo (Importo della Spesa)
ImportoMax (Importo max per applicab.spese in %)
ImportoMin (Importo min per applicab.spese in %)
* SoggRitAcc Char (S/N) (Spesa soggetta a ritenuta d'acconto) - Da indicare nell'elenco dei campi aggiuntivi della prima riga

* D Riga di dettaglio
* RigDet Integer Numero riga di dettaglio
* TipoRiga Char Width 1 Articolo, D=Riga descrittiva,M=Manuale, C=Comandi
FormatoRiga Char Width 8 Lasciare bianco
* Articolo Char Width 20 Se lasciato bianco si intende 'articolo manuale' e va compilata la descrizione
Descrizione Char Width 40 (Serve solo se articolo manuale)
DoveStampoDesLung Char Width 1 0-No 1-Sopra 2-Sotto
* UM Char Width 2 Unità di misura
* Qta Quantità della riga
* FatCon (Fattore di convesione: se non c'è conversione mettere 1)
Colli
* ValUnitario
ScontoTab Char Width 15
ScontoCli Char Width 15
ScontoArt Char Width 15
ScontoQuant Char Width 15
ScontoTot Char Width 15 (è lo sconto risultante dai precedenti nella forma: x+y+z)
* FlScontoPag Char Width 1 (S/N) Sogg.sconto pagamento
* Promozione Char Width 1 (S/N) S riga con prezzo in promozione
* ValTotale (Calcolato: ValUnitario*Qta - sconti)
* Iva Char Width 4 (Codice iva della riga)
* GruppoVen Char Width 2 Gruppo del conto di ricavo (es.01)
* MastroVen Char Width 2 Mastro del conto di ricavo (es.01)
* ContoVen Char Width 4 Conto del conto di ricavo (es.0010)
StatoRiga Char Width 1 (lasciare bianco)
* Omaggio Char Width 1 N=NO, S=Omaggio totale, I=omaggio al cliente si addebita l'iva
PercProvv1 Numerico % provvigione agente 1
PercProvv2 Numerico % provvigione agente 1
Lunghezza Numerico
Larghezza Numerico
Altezza Numerico
NotaSopra Campo Memo
* NotaSopraStamp Char Width 1 N=No stampa- A=st.solo su doc.attuale, S=St.anche sul doc.di evasione, E=St.solo sul doc.di evasione
NotaSotto Campo Memo
* NotaSottoStamp Char Width 1 N=No stampa- A=st.solo su doc.attuale, S=St.anche sul doc.di evasione, E=St.solo sul doc.di evasione
ValLire Numerico
* ValEuro Numerico Impostare come ValTotale
FlagStato Char Width 1 Lasciare bianco
DescPers1 Char Width 50 (10 Campi per personalizzazioni)
DescPers2 Char Width 50
DescPers3 Char Width 50
DescPers4 Char Width 50
DescPers5 Char Width 50
DescPers6 Char Width 50
DescPers7 Char Width 50
DescPers8 Char Width 50
DescPers9 Char Width 50
DescPers10 Char Width 50
CentroDiCosto Char Width 8 Cod.Centro di Costo
BeneUsato Char Width 10 Cod.bene usato per regime del margine

CAMPI AGGIUNTIVI

Descrizione CAMPI AGGIUNTIVI che si devono mettere sulla prima riga se poi verrà messo il contenuto in fondo alle rispettive righe T, S, D
Sono campi delle tabelle DdtTest, DdtSpese e DdtDett, aggiunti in un secondo tempo nel caricamento.

Mentre i campi descritti sopra vanno messi TUTTI obbligatoriamente (come posizione), di questi aggiuntivi si possono mettere SOLO quelli
obbligatori (indicati con *) e quelli che servono all'utente. Andranno messi nei vari righi T , S , D, dopo quelli fissi descritti sopra e nell'ordine
indicato dai rispettivi nomi inseriti nella prima riga.

Se, in seguito, verranno modificate le tabelle Ddt e aggiunti nuovi campi, essi dovranno essere aggiunti a questo elenco di campi aggiuntivi per
poter essere caricati da file.
I campi aggiuntivi VANNO elencati con il Nome e un Numero che indica il tipo di campo:
integer: 2 long: 3 single: 4 double: 5 currency: 6 data: 7 stringa: 8

Esempio di elenco completo dei campi aggiuntivi (dovrà essere scritto su un'unica riga, ogni campo separato da Tab):
CampiAgg: T:AnnoMovim 2 T:NumMovim 3 T:AnnoMovimRientro 2 T:NumMovimRientro 3 T:EvasioneNota 8
T:NumNota4 8 T:NumNota5 8 T:Provenienza 8 T:Trasferito 8 T:CentroDiCosto 8 T:PercRitAcc 5
T:ImponRitAcc 5 T:Contratto 8 T:CIG 8 T:CUP 8 T:OrdAnno 2 T:OrdNumRif 3 T:AnnoMovProd 2
T:NumMovProd 3 T:AnnoMovDiBa 2 T:NumMovDiBa 3 S:SoggRitAcc 8 D:Comando 8 D:TipoProv 8
D:FattDocumentoProv 8 D:AnnoRifProv 2 D:NumRifProv 3 D:RigaRifProv 3 D:QtaProv 5
D:CompGiornMens 8 D:DataCompDa 7 D:DataCompA 7 D:SoggRitAcc 8 D:RigLivRAEE 3
D:Contratto 8 L:QtaProv 5

CAMPI AGGIUNTIVI TESTATA (Sono quelli che iniziano per T)
* EvasioneNota Char Width 1 (N=No eva-, S=lo evado e metto StampoNota a S, E=Evado e imposto StampoNota a N)
NumNota4 Char Width 2 (altri 2 eventuali Codici Note Fisse)
NumNota5 Char Width 2
Provenienza Char Width 1 O=Ordine, P=Preventivo, D=DDT, bianco = Nessuno
Trasferito Char Width 1 Se T indica ddt trasferito su file
CentroDiCosto Char Width 8 (Cod. Centro di Costo)
PercRitAcc Float Percentuale ritenuta d'acconto
ImponRitAcc Float Imponibile Ritenuta d'acconto
Contratto Char Width 15 (Cod. Contratto)
CIG Char Width 10
CUP Char Width 15
OrdAnno Short
OrdNumRif Integer
AnnoMovProd Short
NumMovProd Integer
AnnoMovDiBa Short
NumMovDiBa Integer

CAMPI AGGIUNTIVI SPESE (Sono quelli che iniziano per S)
* SoggRitAcc Char (S/N) (Spesa soggetta a ritenuta d'acconto)

CAMPI AGGIUNTIVI DETTAGLIO (Sono quelli che iniziano per D)
Comando Char Width 5 Per le righe in cui il TipoRiga è C=Comandi qui va messo il comando (Vedi Manuale)
TipoProv Char Width 1 Indicano l'eventuale doc.di provenienza P=Prev, O=Ord, B=Bolla, Vuoto=da nessuno
FattDocumentoProv Char Width 2
AnnoRifProv Short
NumRifProv Integer
RigaRifProv Integer
QtaProv Float
CompGiornMens Char Width 1 (Per Ratei: Se vuota non gestisce date di competenza, se vale G calcolo su base giornaliera, M su base mensile)
DataCompDa Date Date competenza DA e A in caso di Gestione Ratei
DataCompA Date
* SoggRitAcc Char Width 1 Soggetto ritentua d'acconto S/N
RigLivRAEE Integer In caso di articolo con Raee è il Numero di riga in cui si trova l'articolo Raee corrispondente
Contratto Char Width 15 Cod.Contratto

L:QtaProv è la quantità dell'ordine di provenienza in caso di Livelli (Taglia / Colore). E' obbligatorio SOLO se c'è taglia e colore


CARICO DDT DA FILE

Percorso: Vendite - Servizio

La funzione consente di importare sul database corrente i Ddt scritti su un file sequenziale in un formato 'predefinito'.
Il file può essere stato creato da un'altra procedura o scaricato da un altro database con la funzione: Scarico Ddt su file esterno.

Può essere utilizzato, ad esempio, per trasferire su un database 'principale' in cui si fattura, i Ddt emessi da depositi decentrati.

Viene chiesto all'operatore:

  • il nome del/dei file dai quali leggere i ddt
    Il nome del file che il programma si aspetta dovrà avere estensione .ddt (Es. Ddt+Idazienda.ddt ) comunque si potrà scegliere di volta in volta il file da caricare
  • lo 'stato' da impostare sui ddt caricati:
    Bianco (cioè appena inserito)
    Letto dal file che si carica
    Stampato
    Evaso
    Si può impostare nel parametro di personalizzazione 'StatoCaricamento' lo stato di default in modo che venga sempre proposto all'operatore.

Prima di iniziare il caricamento vengono fatti i controlli di esistenza del cliente, articoli, codici iva etc. coinvolti sui ddt da caricare e se mancano, sul database di destinazione, uno o più codici, viene dato un messaggio e non vengono caricati i ddt.

Al termine del caricamento il file letto viene rinominato.


SCARICO MOVIMENTI DI MAGAZZINO SU FILE

Percorso: Magazzino - Servizio

L'esecuzione di questa funzione consente di generare un file sequenziale contenente i movimenti di magazzino (quelli che l'utente intende scaricare in base ai parametri selezionati) da passare ad un'altra sede dove verranno a loro volta caricati.

I movimenti verranno scaricati secondo un formato predefinito
(vedi: caricamento movimenti di magazzino da file)

Viene chiesto all'operatore di digitare l' elenco dei codici causale dei movimenti da scaricare, separati da virgola. Se si scrive tale elenco nel parametro di personalizzazione ScarMovCau, verrà proposto automaticamente a video, con possibilità di variazione.

Inoltre si chiede la data dell'ultimo movimento da scaricare e il nome del file su cui scrivere i movimenti.

Su ogni movimento scaricato verrà messo un segnale di trasferito in modo tale da non riscaricarlo la volta successiva.


CARICAMENTO MOVIMENTI DI MAGAZZINO DA FILE

Percorso: Magazzino - Servizio

Questa funzione consente di generare nuovi movimenti di magazzino a partire da una lista di articoli scritti in modo opportuno su un file ascii.

I dati per la creazione del movimento possono essere tutti su file oppure possono essere digitati dall'operatore sulla maschera a video.

Se si spunta la casella: i dati di caricamento sono tutti su file, essi verranno letti dal file, altrimenti dovranno essere compilati i campi a video.
Se i dati devono venir sempre letti dal file, si può impostare tra i parametri di personalizzazione il parametro CarNoObblParam=S perché tale casella sia spuntata di default.
Dati chiesti a video:

  • Data movimento
    Data da assegnare ai movimenti da generare. Se però nella riga M del file da caricare ne verrà impostata una, utilizzerà quella
  • Causale
    E' la causale del movimento, di scarico o carico, da generare.
    A seconda delle caratteristiche della causale si chiede di impostare l'origine e/o la destinazione del movimento (es. se si fa uno scarico questo può semplicemente fare un'uscita dal magazzino oppure un'uscita dal magazzino verso un cliente). Viene proposto per la movimentazione, il magazzino principale.
  • Unità da e Unità a (Provenienza/Destinazione)
  • Listino
    viene proposto il listino principale
  • Moneta
    Viene proposta la moneta di gestione (euro)
  • Cambio

Il nome del file da caricare è libero; viene chiesto all'operatore di digitarlo o cercarlo col pulsante Sfoglia.
Verranno presentati di default quelli presenti nella directory ..\aziwin\carica, con estensione .CAR

E' disponibile un parametro di personalizzazione CarMovFiles per preimpostare il nome del file da caricare.

Una volta caricato il file verrà rinominato in .old

Nel caso più semplice che gli articoli non abbiano distinta base, verranno generati uno o più movimenti di magazzino (a seconda della presenza o meno di più righe di tipo M) aventi come dettagli i vari articoli.

Se nei parametri iniziali della ditta è stata dichiarata la presenza della Distinta base tra le procedure installate, è stata inserita una causale di carico e gli articoli presenti nel file da caricare hanno distinta base per cui si deve fare contemporaneamente lo scarico dei componenti, occorre compilare anche le due causali di magazzino: carico prodotti finiti e semilavorati e scarico prodotti di base e semilavorati e il codice del magazzino da utilizzare per questi movimenti.

Queste causali devono avere Provenienza Nulla e Destinazione Magazzino la prima, Provenienza Magazzino e Destinazione Nulla la seconda.

Perché queste causali vengano presentate in automatico occorre che nella causale principale chiesta a video, quella per il movimento di uscita, ci sia come collegata DiBa quella per l'entrata di quell'articolo stesso e in quest'ultima, quella per l'uscita dei vari componenti.

Se tali causali vengono lasciate vuote (e anche il magazzino) il programma chiede se non si vuole fare lo scarico dei componenti pur essendo installata la DiBA

E' inoltre indispensabile che per ogni articolo composto sia stata inserita la sua distinta base (da Gestione articoli di magazzino, quadro Distinta Base)

In questo caso verranno generati più movimenti di magazzino:

  • carico dei prodotti finiti (letti dal file) con quantità letta e valore uguale alla somma dei valori dei componenti.
  • scarico dei vari componenti con le quantità calcolate a seconda del fabbisogno di ogni componente e con il valore calcolato in base a quanto specificato sull'anagrafica di ogni componente (es. costo ultimo)
  • scarico dei prodotti finiti (letti dal file) con quantità e valore presenti sul file
  • eventuale carico dei semilavorati che intervengono nella distinta

Note:

  • se il programma non trova la quantità in ogni riga, verrà usata la quantità di default per i movimenti di mag. (da personalizzazioni), se manca anche questa mette 1
  • se non trova nessuno dei valori (né l'unitario né il totale) cerca il prezzo come in gestione movimenti
  • se in uno qualsiasi dei movimento manca il fattore di conversione a fronte di un'unità di misura che è diversa da quella principale dell'articolo del movimento, esso viene assunto uguale a 1.
  • Una volta generati, i vari movimenti saranno indipendenti e la variazione manuale di uno di loro non comporterà modifiche sugli altri.
  • Il caricamento, in caso di articoli con distinta base, NON prevede la gestione dei livelli.

Caratteristiche del file da caricare:

Verranno scartate le righe vuote e le righe che iniziano per # (si intendono righe di commento)

I campi vanno separati da un Tab

Riga di tipo M (opzionale)
Contiene i dati per la testata del movimento, non è obbligatorio che ci siano tutti, potrebbe esserci anche solo le prime informazioni, fino alla data movimento, in questo caso NON si devono mettere i Tab successivi.
Il file può contenere più righe di tipo M, ciascuna seguita da una o più righe articolo; questo significa che si deve creare un nuovo movimento.
Se nel file manca la riga di tipo M, verranno considerati, per la creazione della testata del movimento, i dati inseriti nella maschera.

  • M
  • Unità DA
  • Unità A
  • Data Movimento
  • Listino
  • Moneta
  • Cambio
  • Causale del movimento di magazzino
  • Tipo documento di fatturazione (Ddt o fattura dal quale è stato generato il movimento, se esiste)
  • Prefisso del documento
  • Numero del documento
  • Data del documento
  • Anno del movimento di magazzino
  • Numero del movimento

Nota
Il codice di magazzino eventualmente impostato in Unità da (o in Unità a) verrà utilizzato nel movimento (movimenti se ha distinta base) di scarico (o carico) degli articoli letti dal file. Gli eventuali altri movimenti della distinta base avranno invece come magazzino quello impostato a video.

Righe articolo:

  • Codice articolo
  • Quantità
  • Valore unitario del movimento da fare per quell'articolo
  • Valore Totale (opz.)
  • Unità di misura (opz.)
  • Fattore di conversione (opz.)
  • Lunghezza (opz.)
  • Larghezza (opz.)
  • Altezza (opz.)

Se per l'articolo sono previsti i livelli, andranno scaricate anche le righe relative ad essi:

Le righe di livello dovranno iniziare con L+Tab e contenere i campi:

  • Livello1
  • Livello2
  • Quantità
  • Valore unitario del movimento da fare per quel livello
  • Valore Totale (opz.)
  • Unità di misura (opz.)
  • Fattore di conversione (opz.)

NOTA: i numeri non devono contenere i separatori delle migliaia, ma solo quello del decimale.


TRASFERIMENTO FATTURE SU FILE

Percorso: Vendite - Servizio

Questo programma consente di scaricare su file i movimenti relativi alle fatture stampate fino a una certa data per poter poi essere importate, con un apposito programma, negli archivi dei movimenti di Contabilità della procedura Azienda DOS.

Tale file viene generato nella directory aziwin\database col nome MOV+id.azienda (campo gestito in Parametri e Utilità, Gestione database aziende) es. Mov001.txt.

Esso dovrà essere copiato in \proced o in \arcazxxx per caricare le fatture su Azienda Dos eventualmente con nome FATWIN.TXT (questo è il nome che si aspetta il programma che lo carica ma l'operatore lo potrà variare a video al momento del caricamento)

I campi sono separati da TAB e il file generato può essere letto e modificato con TextPad o con Blocco note

In Azienda Dos, la funzione:FATCARW carica su Fatcon e Fativa (movimenti di fatturazione) il file FATWIN.TXT (o altro nome digitato al momento con path completa) che cerca in area archivi poi programmi.

E' agganciata al menu di fatturazione. Servono Fatcon, Fativa e Tabfatt però per accedere al menu di fatturazione devono essere creati anche Bolle etc. (quelli obbligatori di fatturazione) salvo variare archivi.*

Alla fine dell'elaborazione, il file caricato, viene rinominato in .OLD e viene aggiornato sulla tabella di contabilità il numeratore delle fatture emesse.

Una volta verificata, ad esempio con la stampa di un brogliaccio, la correttezza dei movimenti, questi possono essere trasferiti in contabilità con il programma di trasferimento movimenti.

TIPO RECORD: T Individua il primo record di ogni gruppo
Tipo di Movimento (F=Fatt.clienti)
Estrazione (E)- Riestrazione ( R)
Cod. Cliente - FatTest.GruppoCli MastroCli ContoCli
Data Documento - (ggmmaaaa) DataDoc
Prefisso - PreDoc
Numero documento - NumDoc
Codice pagamento - Pagamento
Segno (da FattDocumenti.FattDocumento per dirmi se fatt. o NC)
Iva sospesa - IvaSosp
Cambio - Cambio Se vale -1 è Lire, se vale -2 è euro
Importo Acconto - Acconto
Totale Fattura - TotDocum
Totale Iva- TotIva
Totale BolliCalcolato dal piede

TIPO RECORD: D
Uno per ogni contropartita (conto merce e iva) Movimenti avere:

Cod.conto
Importo (Imponibile)
Aliquota (esenzione) (*)
Imposta
Flag forzatura (S/N)

TIPO RECORD: I
Uno per ogni Cod.Iva della fattura

Importo (Imponibile)
Aliquota (proprio l'aliquota)
Imposta

Particolarità:

(*) Aliquota: è il campo Aliquota di Tabiva (dal codice Iva), se il campo aliquota è 0 vuol dire che di tratta di una esenzione per cui viene scaricato il campo codice iva stesso (occorre perciò che anche in aziwin il codice iva (di un'esenzione) si-a nella forma 210, 215 etc.)

In questo caso sul file di passaggio, viene scaricato come codice iva: E+codice iva (Es. E210)

Nel programma che carica in DOS è possibile fare, prima del caricamento,una verifica dei codici da caricare, se non vengono trovate le corrispondenze (cioè manca un cliente o una cond.di pagamento o un'aliquota etc) viene stampata una segnalazione e non si carica nulla.

Dalla condizione di pagamento si decide se generare o meno la registrazione dell'incasso

In base al fatto che ci sia o meno l'acconto viene generata la registrazione di acconto

I movimenti generati hanno come causale, in base al segno passato, quella fattura o Nota di credito letta da tabella di fatturazione. I conti per l'acconto o l'incasso vengono presi dalla tabella di fatturazione.

Descrizione aggiuntiva: bianca o "Incasso fatt. n' "+pref+num. se incasso


CARICAMENTO

CARICAMENTO DATI DA ARCHIVI ESTERNI

Percorso: Parametri e utilità - Utilità - Carica dati esterni

Per caricare dati da tabelle esterne occorre prima definire, con l'apposita funzione: Gestione Caratteristiche caricamento dati, le caratteristiche delle tabelle da caricare.

Viene presentato l'elenco delle tabelle per le quali sono stati preparati i dati per il caricamento. E' possibile selezionarne una o più di una (tenendo premuto il tasto ctrl) e confermare il caricamento.

NOTA: Per selezionare una tabella occorre fare un click con il mouse nel rettangolino a sinistra della riga che la contiene, se si clicca in un altro punto, la riga sembra selezionata ma non lo è per il programma che quindi non carica la tabella corrispondente.

Prima del caricamento vengono richiesti, uno dopo l'altro, i campi che nelle tabelle di preparazione caricamento, sono stati impostati come 'da impostare manualmente al caricamento'.

In questa fase i campi data vanno inseriti nella forma xx/xx/xx e non viene fatto nessun controllo di correttezza del valore inserito. Quando si chiede la moneta di default o il magazzino di default è fondamentale, per una corretta conclusione del caricamento, inserire i codici corretti e uguali a quelli effettivamente già creati nelle rispettive tabelle delle ditte.

Durante il caricamento viene visualizzato il numero di errori eventualmente riscontrati. Tali errori si possono consultare la funzione: Visualizza errori di caricamento.

Il caricamento provvede a caricare i codici nuovi, per quelli già esistenti vengono aggiornati tutti i campi letti dal file da caricare.

Dopo il caricamento si consiglia di eseguire un COMPATTAMENTO dei database per ottimizzare l'occupazione di spazio.


CARICAMENTO DATI DA FILE ESTERNI

GESTIONE CARATTERISTICHE CARICAMENTO DATI

Percorso: Parametri e utilità - Utilità - Carica dati esterni

Questa funzione consente di impostare i parametri per importare automaticamente tabelle esterne sulle tabelle di AziendaPc.
Le tabelle esterne da caricare, dovranno essere state create in formato ascii e dovranno essere copiate nella directory CARICA da creare dentro la directory in cui è stata fatta l'installazione (es. in \programmi\aziwin), oppure in altra directory a condizione che venga cambiato il parametro DirCarica sul file aziwin.INI oppure che venga messo in tabella il percorso completo del file origine.

La tabella da caricare può contenere righe con campi a lunghezza fissa oppure con campi separati da un carattere (Es. TAB, chr$(255), etc) che dovrà essere specificato in fase di preparazione delle specifiche di caricamento.

NOTA BENE
Una volta impostate queste tabelle, il caricamento degli archivi da Azienda Dos può essere fatto in automatico scegliendo quali archivi caricare (Selezione files caricamento batch) poi creando un nuovo database e scegliendo l'opzione:
Eseguo caricamento automatico dati da file ascii.

Per caricare dati da tabelle esterne, diverse da quelle provenienti da archivi di Azienda Dos, occorre prima definire, con questa funzione, le caratteristiche della tabella da caricare poi eseguire il caricamento vero e proprio.

Dopo il caricamento si consiglia di eseguire un Compattamento del Database.

Codice caricamento
Serve ad individuare la tabella da caricare. Dovrà esserne predisposto uno per ogni tabella. Per comodità si può impostare con il nome della tabella da caricare.

File origine
Deve contenere il nome della tabella da caricare. Si accetta il nome con la path completa oppure solo il nome, in questo caso il percorso per la ricerca verrà letto dall' aziwin.ini, parametro DirCarica

Tipo
E' il tipo che caratterizza la struttura della tabella da caricare:

  • con separatore : i campi sono separati da un carattere asci, in questo caso nel campo successivo 'separatore' dovrà essere specificato qual è il carattere esprimendolo con il codice Ascii allineato a destra con degli 0, nel seguente formato: es. \255 indica che il separatore è CHR$(255), \009 indica che il separatore è il TAB. (Se il campo separatore viene lasciato bianco si intende che il separatore sia il Tab).
    Se invece di un unico carattere ce n'è una sequenza si possono inserire allo stesso modo, separati l'uno dall'altro dalla \
  • a posizioni fisse : ogni campo da caricare ha una lunghezza fissa predefinita

Modalità
Indica la sequenza delle operazioni da fare nel caricamento di ogni codice: provare prima l'inserimento o la variazione.

Se si deve fare solo la creazione è indispensabile mettere nel primo campo 'Prova prima la variazione' e nel secondo campo 'Soltanto Creazione'.

Il risultato è lo stesso qualunque sia la scelta fatta, quello che cambia è il tempo di caricamento. Se i codici nuovi da caricare sono di più rispetto a quelli da variare si metterà 'prima inserimento' viceversa 'prima variazione'. Potrebbe però, in certi casi, dare problemi per cui, se ci sono problemi si consiglia di eseguire un compattamento del Data base e modificare la scelta fatta su questo primo campo della modalità.

Nel secondo campo è possibile scegliere cosa fare dei dati da caricare: Crea se non trova/Varia se trova, Solo creazione (verranno solo inseriti i codici nuovi) o Solo Variazione (non verranno inseriti i codici nuovi ma solo variati quelli già esistenti).

Righe iniziali da saltare
Sono le righe che nella tabella da caricare precedono la prima valida per il caricamento.

Tabella principale
Deve contenere il nome della tabella di destinazione nel database di AZIWIN. Per facilitare la compilazione del nome viene presentata la lista dei file.

Tabella 2-3-4-5
Sono da compilare solo se il caricamento di una tabella comporta non solo la compilazione della corrispondente in Aziwin ma anche di qualche campo di altre tabelle (es. caricando gli articoli di magazzino vengono creati anche il listino principale, i costi e i progressivi di ogni articolo, se non si vogliono caricare questi archivi collegati basta eliminare il collegamento delle tabelle nel Codice di caricamento: Articoli e dei rispettivi campi nel Dettaglio)

Pulsante Trasformazioni Tabella N

Codice (2-3-4-5)
Il codice è una lettera che consentirà di capire, nella compilazione dei dettagli, i singoli campi a quale tabella appartengono. (Es. in Codice di caricamento: Articoli i campi della la tabella ArtListini verranno individuati con L, quelli di ArticoliCosti da C, quelli di ArticoliProg da P.

Azzera
Indica se si deve azzerare o meno la tabella di destinazione prima del caricamento. Impostando il campo a SI il caricamento risulterà più veloce. Se è lasciato a No non cancella i dati preesistenti, ricopre quelli esistenti se li ritrova nel file di caricamento ed inserisce gli eventuali nuovi.

Elenco campi
Per velocizzare il caricamento si può scrivere, in questa posizione, l'elenco dei campi da aggiornare (sono i campi che poi verranno compilati in dettaglio, separati da una virgola.

Condizione di azzeramento
In questo spazio si può scrivere una condizione di azzeramento. Ad esempio se si vogliono azzerare e ricaricare solo i conti dall'archivio PianoConti che contiene anche i clienti e i fornitori, si deve scrivere S in Azzeramento e qui scrivere la condizione: Tipo='1' cioè azzerare solo quei record in cui il campo Tipo vale 1, cioè i conti.

Per indicare una condizione di azzeramento con un join con un altro archivio occorre specificare: from ….

Una volta compilati questi dati, occorre inserire con il pulsante DETTAGLI, l'elenco dei campi da caricare, specificando, per ciascuno di essi, il nome (dal database), la posizione dalla quale viene caricato etc.

NOTE PER IL CARICAMENTO DEGLI ARCHIVI DA AZIENDA PC

Le tabelle, in Gestione caratteristiche caricamento dati, sono state impostate senza la cancellazione (campo Azzera bianco) prima del caricamento.

Compilare, sugli archivi delle ditte da caricare, le tabelle base delle procedure e quelle tabelle che serviranno da decodifica di campi caricati (es. monete, magazzini, listino principale in Tabella listini) . In particolare creare i codici iva, nella tabella dei codici iva, con il codice uguale all'aliquota o a 2+codice esenzione se si vuole avere la corrispondenza tra l'iva caricata sugli articoli e gli effettivi codici iva nuovi.

  • Scaricare le tabelle da Azienda PC con la funzione ESTRAZIONE DATI IN FORMATO ASCII dal Menu di servizio.
  • Copiare i file .txt generati, dall'arcazxxx della ditta di azienda pc, nella directory indicata nell'INI di aziwin.
  • Controllare le tabelle già predisposte per il caricamento tenendo conto delle note descritte di seguito e proseguire con il caricamento.

Si consiglia di caricare prima le tabelle più lineari: agenti, banche, categorie clienti, vettori, riclassificazioni, gruppi, mastri, tipi pagamento, pagamenti, clienti, fornitori, indirizzi clienti, gruppi articoli, tabella listini. Una volta controllati questi dati, anche tenendo conto delle note descritte di seguito, proseguire con articoli, listini articoli, unità di misura e aliquote iva.

Conti
Al termine del caricamento dei conti, modificare il segnale di Ventilazione a Si in corrispondenza ai conti che sono Acquisti per ventilazione (in azienda il loro codice era in Tabella di Contabilità)

Condizioni di pagamento
Se in azienda PC (tabpers.dat) il flag %scad.dec è a 1, cioè si stanno utilizzando, nelle condizioni di pagamento (in caso di Tabellare a Giorni o a Mesi), le percentuali con decimali (es. a 30 giorni scade il 20,35% e a 60 il 70,65%), occorre inserire con il programma Gestione caratteristiche caricamento dati, in corrispondenza a Pagamenti, nei campi Percentuale1, … Percentuale 9 : Tipo Operazione /, Stringa Operazione 100.

Al termine del caricamento occorre controllare la correttezza, in particolare di quelle con scadenze tabellari. La prima volta che si entra in gestione di una condizione appena caricata e si salva o si passa ad un'altra, verrà dato un messaggio di campo variato (anche se non è vero!), basta confermare.

Clienti
Il campo di azienda PC: numero lettera d'intenti diventa, in aziwin una stringa nella quale scrivere numero e data della lettera d'intenti del cliente (N' xxx del xx/xx/xxx). Nel caricamento viene impostato: NR. + il numero letto da azienda.

Fornitori
Tra i vari dati dei fornitori viene caricato anche Il codice contropartita. Se l'archivio originale è vecchio in questo codice potrebbe esserci un numero a caso, in quanto non utilizzato in azienda e mai azzerato. Si consiglia perciò di controllare il file txt scaricato da azienda, oppure di fare un caricamento di prova poi decidere successivamente se conviene caricare questo campo o toglierlo dalla tabella di caricamento con la Gestione caratteristiche caricamento dati.

MAGAZZINO
Si suppone che il magazzino non abbia la gestione di taglie e colori. Sugli archivi dove i campi livello 1 e livello 2 sono obbligatori, vanno inseriti con il carattere di default: ~ç~ ('tilde' (Alt 126) e ç (Alt 135))

Tabella Listini (con descrizioni listini; deve essere caricata e completata, prima di procedere al caricamento dei listini articoli):

In caricamento listini viene chiesto se il listino (o listini) che si caricano sono ivati o no e la moneta di default da assegnare al listino. Successivamente occorre entrare in gestione tabella listini e variare modificando la moneta, là dove è diversa da quella inserita di default, il segnale di Acquisto o Vendita, il segnale di ivato o no.

Listini Articoli
Se si caricano dopo gli articoli occorre che abbiano la Cancellazione a NO.

Verrà chiesta a video la data inizio listino (salvo variare Da Gestione caratteristiche caricamento dati, in corrispondenza a ArtListini (dettagli)), mentre la data di fine validità listino viene assunta in automatico uguale a 31/12/9999. Se esiste già lo stesso listino che non si vuole eliminare ma si dovrebbe mettere su quello una data di fine listino perché non più in vigore, è indispensabile, al termine del caricamento listini, eseguire la funzione di Sistemazione date Listini.

Al campo sconto si può assegnare un valore di default che però caricherà per ogni articolo oppure si può lasciare così com'è, azzera il campo ad ogni caricamento, o lo si può cancellare dalla lista in modo che venga ignorato.

Articoli
Occorre aver prima creato in Tabella Listini il codice del listino principale (in questo listino verranno copiati tutti i prezzi base degli articoli).

Se si caricano dopo i listini occorre che, in corrispondenza alla tabella ArtListini (dentro Articoli) ci sia NO Cancellazione.

In Gestione caratteristiche caricamento dati, in corrispondenza a Articoli (dettagli), sono stati lasciati, nella lista dei campi, solo i campi da caricare e quelli per i quali è necessario assegnare un valore di default, se si desidera valorizzare, nel caricamento, altri campi, basta aggiungerli nella lista.

Codice a barre: se non viene utilizzato in gestione conviene cancellarlo dalla lista dei campi da caricare.
Gruppo: in azienda pc è un codice numerico, qui è alfanumerico. Se lo si vuole caricare in modo da mantenere l'ordinamento occorre allinearlo con uno zero a sinistra (altrimenti l'ordine è 1,11,2,20 …
Per fare ciò occorre modificare la tabella di caricamento Articoli, in Dettagli, in corrispondenza al campo Gruppo mettendo in Caratteri di riempimento: 0 , Numero car.di riempimento: -2 (così riempie a sinistra) e Converti 0 a Null a Si.
Fornitore abituale: controllare l'esattezza del codice caricato (se in azienda il campo è 'sporco' potrebbe caricare un codice qualsiasi.
Inattivo: viene posto di default uguale a No, tuttavia se in gestione magazzino di azienda PC compare come campo: articolo esaurito, si può variare questa riga con la Gestione caratteristiche caricamento dati, mettendo il Numero campo = 28 e togliendo il valore di default (N). Inoltre occorre inserire in Trasformazioni due righe con Inattivo nelle quali si fa corrispondere 0 a N, 1 a S.
Pezzi per confezione: se in azienda pc veniva gestita la quantità per confezione su ogni articolo, si dovrà variare la tabella mettendo in corrispondenza a questo campo il numero campo=28.

UMIva
Questa tabella consente di caricare, a partire dagli articoli di magazzino (magazzin.txt), scaricati da azienda pc, la nuova tabella delle unità di misura (impostando il codice uguale alla descrizione) e i codici iva (impostando codice, descrizione e aliquota uguali a quelli letti sull'articolo).

Se si sceglie di caricare queste tabelle occorre poi controllare e completare manualmente i Codici Iva con la relativa gestione.


CARICAMENTO (DETTAGLI)

Percorso: Parametri e utilità - Utilità - Carica dati esterni

Viene proposto un elenco con tutti i campi della tabella di destinazione. I campi che non hanno una corrispondenza nella tabella di origine e che non devono essere inizializzati, devono essere cancellati dalla lista.
Vedi anche: Note su implementazioni successive per caricare clienti con controlli

Se il campo è stringa, una volta letto, vengono eliminati gli eventuali caratteri bianchi in testa o in fondo poi vengono fatte le eventuali elaborazioni.

Occorre stabilire, per ogni campo, una serie di parametri.

Codice tabella
Fa riferimento ai campi Codice (2,3,4,5). Per i campi della tabella principale dovrà essere lasciato sempre bianco.

Nome campo
E' in generale il nome del campo della tabella sul database ma è lasciato libero per poter scrivere nomi particolari per casi particolari.

Esempi:

  • I campi codice conto (cliente, fornitore) sul data base sono contenuti in tre campi separati: gruppo (2), mastro (2), conto (4), mentre nella tabella da caricare potrebbero essere in un unico campo lungo 8
  • Il codice conto potrebbe essere scritto, sulla tabella di origine nella forma: xx-yy-zzzz cioè con separatori, in questo caso il nome campo, scritto come nell'esempio precedente, dovrà essere preceduto dal separatore messo tra | e cioè: |-|Gruppo|Mastro|Conto

Condizione necessaria per poter fare questo è che i campi caricati e quelli di destinazione siano della stessa lunghezza.

Ordine scrittura
E' l'ordine con cui i campi letti vengono scritti sul database. E' importante dove è obbligatorio che un campo venga scritto prima di un altro.

Tipo origine e Tipo destinazione
Quando si tratta di numeri con decimali mettere sempre Double e non Currency per la corretta gestione dei decimali.

Numero campo
Se il file da caricare è a lunghezza fissa, questo campo va lasciato bianco.
Se si mette qualche carattere questo verrà inserito all'inizio del campo caricato.

Se la tabella da caricare è del tipo 'con separatore', il numero campo è obbligatorio e dovrà contenere il numero della colonna che lo contiene sulla tabella di origine.

Se è impostato a 0, il campo di destinazione viene sbiancato (azzerato).

Per fare in modo che due campi della tabella di origine vengano caricati su un unico campo della tabella di destinazione basta mettere i numeri, entrambi preceduti dal simbolo §.
Esempio:
nell'archivio banche Filiale e Sportello di azienda pc vanno caricate sul campo nuovo Agenzia; in Agenzia in numero campo si metterà: §3 §4 dove 3 e 4 sono filiale e sportello.
Se non si mette lo spazio tra i due numeri, i campi verranno caricati uno di seguito all'altro.

Se il campo destinazione dovrà contenere una scritta fissa seguita dal contenuto del campo 'sorgente' si scriverà: XXX§n
dove XXX è la scritta fissa (Es. un prefisso per dei codici articolo da caricare) e n è il numero campo

Se il numero di un campo viene messo tra parentesi quadre [§n] e questo campo è nullo o vale zero verrà sostituito con dei caratteri bianchi,
se viene messo tra parentesi graffe {n } , verrà sostituito solo se è nullo.
(Utilizzato nel caricamento della tabella Articoli per il campo sconto: i due sconti di azienda es. 2% e 5% vanno caricati in aziwin come 2+5. Se però lo sconto 2 è 0 non deve caricare 2+0 e nemmeno 0+0 se entrambi gli sconti sono a 0).

Inizio e lunghezza
Si devono compilare in alternativa al numero campo se la tabella da caricare è a lunghezza fissa

Se invece il file è 'con separatori', possono essere utilizzati questi campi per caricare parzialmente il campo letto.
Se in inizio si imposta:

  • un numero N<0 il programma prende gli N caratteri di destra del campo letto (se ci sono più campi ripete l'operazione per tutti i campi letti, se poi il campo risultante deve avere un prefisso, questo verrà aggiunto successivamente).
  • un numero positivo N e si lascia vuoto il campo Lunghezza, il programma prende gli N caratteri di sinistra del campo letto.

Se viene valorizzato anche il campo lunghezza con un numero positivo, il programma estrae dal campo letto, a partire dalla posizione indicata in Inizio, tanti caratteri quanti indicati in Lunghezza (In pratica esegue un Mid(variabile, inizio,lunghezza)

Dimensione
In generale non serve, viene letta dal database.
Se invece viene impostata ad N verranno estratti i primi N caratteri del campo, a -N, gli ultimi N caratteri del campo. Se il campo è stringa, una volta estratto, vengono subito eliminati gli eventuali caratteri bianchi in testa o in fondo poi vengono fatte le eventuali estrazioni.

Limite di lunghezza
Indica che il campo verrà caricato solo se di lunghezza non superiore al valore scritto qui (servirà ad esempio per caricare la partita iva o il codice fiscale dei clienti di azienda pc nel campo giusto del database)

Se si scrive un valore negativo, il campo verrà caricato solo se di lunghezza maggiore o uguale a quella scritta.

Valore di default
Può essere impostato per assegnare ad un campo un valore fisso: es. la data creazione su clienti, fornitori, conti che non viene letta dalla tabella oppure, se scritto con la sintassi §Codice (cioè con una stringa qualsiasi che inizia per §) indica che il valore da dare a quel campo deve essere chiesto all'operatore prima del caricamento.

Se si scrive §Anno$2000 all'operatore verrà chiesto:
Anno e verrà proposto il 2000 come default

Se è impostato questo campo viene ignorato il valore messo in Numero campo che però non può essere lasciato vuoto (mettere 0)

Per inserire nella tabella caricata un campo 'contatore' che non ha un corrispondente sulla tabella da caricare e che, eventualmente viene azzerato al cambiare di qualche campo di quest'ultima, si dovrà utilizzare la seguente sintassi:
§#<lista_di_campi_di_rottura># descrizione§<valore_di_default>
Il valore iniziale del contatore viene chiesto all'operatore; per partire da 1 occorre dare 0 perché il programma incrementa subito il valore digitato.

  • <lista_di_campi_di_rottura> è opzionale e indica il nome dei campi letti dalla tabella da caricare, in corrispondenza dei quali il contatore riparte da valore iniziale. Tali campi devono essere separati da una virgola. Nel caso di file a lunghezza fissa, questo invece della lista ci va la posizione di inizio e quella di fine del campo da considerare per la rottura.
  • Se lista_di_campi_di_rottura è vuoto, il contatore viene sempre incrementato.
  • Descrizione è la descrizione che verrà visualizzata all'operatore, prima del caricamento, alla richiesta del valore iniziale da cui partire.
  • <valore di default> è l'eventuale valore da proporre all'operatore

In variazione
Indica, solo se si è scelta la variazione dei dati esistenti nella maschera principale del caricamento della tabella, se il campo in oggetto deve essere variato o no. (es. nel caricamento degli articoli si potrebbe decidere che in variazione non si vuole aggiornare di nuovo la descrizione).

Valore non valido
E' possibile impostare in questo campo una stringa o un numero, verranno considerati non validi e quindi non caricati i record che nella tabella originale hanno quel valore.

Nella stringa sono ammessi * etc. ad esempio si può dire di escludere quei record nei quali un certo campo contiene la parola 'pippo' scrivendo: *pippo*

Valore valido
Se valorizzato indica l'unico valore valido di questo campo al fine di caricare il record. Come per il campo precedente, nella stringa vengono accettati gli * etc.

Servirà per caricare i listini. Dovranno essere caricati ad uno ad uno se ce ne sono in lire ed in valuta.

Carattere di riempimento / arrotondamento
Se il campo di destinazione è stringa, è possibile decidere di completare il campo da caricare con un certo carattere da impostare qui.

Nei campi numerici (quando non ha senso che ci sia un riempimento), in questo spazio si può mettere la modalità di arrotondamento del numero che si sta caricando: G=verrà considerato il numero di decimali di gestione della moneta, M =verrà considerato il numero di decimali della moneta, un numero X=numero fisso di decimali.

Se non c'è niente si assume il numero dei decimali messo nella moneta in decimali di gestione.

Num.caratteri di riempimento / Numero decimali

  • Se viene lasciato a 0 ed è stato scelto un carattere di riempimento, il campo viene riempito fino a raggiungere la sua lunghezza sul data base.
  • Se viene impostato un numero positivo N, saranno messi caratteri di riempimento a destra fino a raggiungere una lunghezza N,
  • se un numero negativo (-N) i caratteri di riempimento saranno messi a sinistra

Nei campi numerici (quando non ha senso che ci sia un riempimento), in questo spazio si può mettere il numero dei decimali da utilizzare nel caricamento (utile quando si carica un valore con virgola virtuale però si sa quante posizioni decimali contiene; es. se si imposta 2 il programma dividerà per 100 intendendo 2 decimali etc.) Questo valore deve poi essere arrotondato per decidere con quanti decimali deve essere arrotondato si utilizza il campo "Car. Riempimento/Arrotondamento" con le modalità descritte sopra.

Obbligatorio
Indica se il campo è obbligatorio. I campi chiave vengono comunque considerati obbligatori.

Converti 0 a Null
Consente di far si che un campo che in origine contiene la stringa o il valore '0' venga caricato come campo bianco.

Tipo operazione
Indica se sul campo da caricare deve essere fatto un calcolo particolare. Es.: caricando l'aliquota iva da azienda pc occorre dividere per 10 il campo letto. (accetta i simboli: * / %)

Se il campo destinatario deriva dalla combinazione di più campi, se il tipo operazione è valorizzato e i campi origine sono numerici, l'operazione viene fatta singolarmente sui campi origine (serve per creare la stringa sconto sull'articolo a partire dai due sconti numerici e da dividere per 100 di azienda pc)

Stringa operazione
Nel caso sia stata specificata un'operazione da fare sul campo, qui si dovrà mettere il valore del divisore o moltiplicatore.
Es. 10 nel caso dell'aliquota iva del caricamento della tabella Articoli.

Si accetta anche il simbolo § seguito dal numero di un campo ad indicare che il campo della riga va moltiplicato o diviso per quest'ultimo.

Nel caso si stia caricando un file a lunghezza fissa, per indicare il campo da utilizzare nell'operazione, occorre mettere il simbolo § seguito dal numero che indica la posizione iniziale che contiene l'operatore seguito dal carattere : e dal numero che contiene la lunghezza della stringa dell'operatore, es.: §78:4 significa che l'operatore parte dal 78esimo carattere ed è lungo 4

Prezzi in Lire o Valuta/Euro (L/V)
Indica come devono essere considerati i prezzi (listini) da caricare.

Viene utilizzato in questo modo: il prezzo letto viene considerato nella moneta del listino cui si riferisce (se è un progressivo del magazzino invece lo si considera nella moneta principale). Il prezzo, sull'archivio Listini Articoli dovrà essere memorizzato in valuta, se si tratta di listino in valuta o in lire e in euro se si tratta di listino in lire o in euro.

Consideriamo il campo con la specifica L: se il listino che si sta caricando è in lire (lo si legge dalla tabella listini) il prezzo verrà inserito così com'è; se è in euro il prezzo letto verrà cambiato e trasformato in Lire; se è in un'altra valuta, il campo viene lasciato bianco.

Se invece il campo ha la specifica V: se il listino che si sta caricando è in valuta o in euro il prezzo verrà inserito così com'è mentre se è in lire verrà memorizzato trasformato in Euro.

Note su implementazioni successive
fatte per consentire di caricare clienti/fornitori assegnando un codice progressivo e di fare controlli sulle anagrafiche caricate
Impostare i campi Gruppo e Mastro assegnando dei valori di default
Nella definizione del campo conto, campo da caricare da file, si può mettere in 'Valore di default' una stringa (es. ^4,J:gruppo,mastro)
composta da:

  • ^ carattere obbligatorio
  • un numero N che indica la lunghezza base del campo codice da generare
    (se il campo da caricare fosse numerico si può impostare N<0: indica un numero di N cifre al massimo, oppure N=0: nessun controllo)
  • (opzionale) da una virgola (,) e da uno o più caratteri che indicheranno la 'chiave base' cioè i primi caratteri da mettere 'fissi' nel campo 'conto' da generare o da cercare
  • : (due punti) carattere obbligatorio
  • elenco dei nomi dei campi, suddivisi da 'virgola' che dovranno servire per cercare il codice 'più grande' già inserito e poterlo incrementare per la nuova anagrafica da inserire

Nell'esempio: ^4,J:gruppo,mastro , la lunghezza del campo 'alfanumerico' è 4, il codice da cercare per accodarsi o da creare inizia per J, il gruppo e il mastro sono quelli indicati come 'Valori di default' nella definizione dei campi Gruppo e Mastro


CARICAMENTO (Trasformazioni)

Percorso: Parametri e utilità - Utilità - Carica dati esterni

In questa maschera si consente di specificare (per la tabella principale ed eventualmente per le collegate) se un campo deve essere trasformato prima del caricamento.

Es. il tipo dei Gruppi del piano dei conti, nella tabella 'origine' vale 0/1/9 e indica rispettivamente Patrimoniale, Economico, d'Ordine, sul nuovo database Patrimoniale è P, Economico è E, d'Ordine è O per cui si dovrà specificare di trasformare il campo Tipo da 0 a P, da 1 a E, da 9 a O.

Nel nome campo vengono elencati tutti i campi della tabella destinazione per agevolare la ricerca del campo da trasformare.


CARICAMENTO BATCH DI DATI DA FILE ASCII

Percorso: Parametri e utilità - Dati azienda e parametri - Gestione database aziende

Opzione inserita in fase di generazione di un nuovo database per consentire il carico e la trascodifica automatica dei dati di Azienda Dos sul database.

Prima di procedere alla creazione di una nuova ditta con caricamento delle tabelle da Azienda Dos, si consiglia di leggere il documento: CarDaDos.doc presente nella cartella BaseDoc del Cd di installazione di AziWin, che contiene le note operative per la preparazione delle tabelle da caricare.
Ricordare di eseguire la funzione: Selezione files caricamento batch, prima di procedere alla creazione della nuova ditta.

Se durante la creazione di una ditta è stata scelta l'opzione Eseguo caricamento automatico dati da file ascii si chiede di scegliere la directory dalla quale leggere i file ascii da caricare (es. \ARCAZ001).

Nel caso si debbano caricare anche i movimenti contabili e iva (registrazioni di prima nota), è obbligatorio inserire alcuni codici conto e causali necessari al programma per ricostruire correttamente le registrazioni nel nuovo database.

I codici dei conti, da inserire nella forma 04 / 03 / 0003 sono i conti iva (vendite, acquisti, corrispettivi e sospesa, acquisti e vendite intra cee).

Per quanto riguarda le causali si chiede di inserire i codici di Note di Credito emesse e ricevute (es. 02 e 04).

Se l'azienda da caricare, ha delle registrazioni di fatture di Trasportatori (la cui iva va portata al periodo successivo alla registrazione) occorre inserire anche il/i codic/i causale/i trasportatori e dire se è mensile o trimestrale in modo che il programma possa sistemare i dati del periodo iva sulle testate dei movimenti.

In questo caso occorre, appena finito il caricamento, inserire in Gestione causali nelle causali in oggetto, il flag Trasportatori (vedere manuale al capitolo: Trasportatori).

L'inserimento di tali codici è fondamentale per ottenere un caricamento corretto delle registrazioni.

Scarico del secondo Codice Fiscale di clienti e fornitori.

Viene chiesto a video se è stato gestito in dos il secondo Codice Fiscale per clienti e fornitori. Barrare la casella SOLO se è effettivamente stato gestito e sono state scelte le tabelle di caricamento Clienti_2CF (Fornitori_2CF) nella fase di Selezione files caricamento batch

In questo caso i 2 campi del dos verranno trattati come segue: il contenuto del vecchio campo: Cod.Fiscale/P.Iva verrà scritto sul cliente aziwin, in Partita iva se lungo 11 , viceversa in codice fiscale. Il secondo cod. fiscale viene scritto in Aziwin nel campo Cod.fiscale SOLO se questo è vuoto.

Alla conferma verrà eseguito il caricamento delle tabelle desiderate (scelta fatta con la funzione: Selezione file caricamento batch)

Al termine del caricamento viene presentata l'anagrafica ditta da completare. Per entrare effettivamente sugli archivi della ditta appena creata occorre eseguire, dal menu, Cambio azienda e selezionare la nuova azienda di lavoro.

Se il caricamento segnala degli errori, occorre, dopo essersi posizionati col cambio azienda sulla ditta in oggetto, controllare il tipo di errori con il programma: Visualizza errori di caricamento.

DOPO IL CARICAMENTO SI CONSIGLIA DI FARE UN COMPATTAMENTO DEL DATABASE per ottimizzare l'occupazione di spazio.


CONSULTAZIONE ERRORI DEL CARICAMENTO

VISUALIZZA ERRORI DI CARICAMENTO

Percorso: Parametri e utilità - Utilità - Carica dati esterni

Questa funzione permette di consultare i messaggi di errore generati dal caricamento di tabelle da file esterni.

E' possibile visualizzare l'elenco delle tabelle per le quali si sono verificati degli errori premendo la freccetta sul campo Codice caricamento.

Per ogni tabella viene presentata la lista degli errori che, una volta consultati, possono essere cancellati con l'apposito pulsante.


SELEZIONE FILES CARICAMENTO BATCH

Percorso: Parametri e utilità - Utilità - Carica dati esterni

Questo programma consente di selezionare quali tabelle, preparate precedentemente, dovranno essere caricate automaticamente in un nuovo DataBase al momento della sua generazione con la funzione: Gestione database aziende.
Questa funzione è nata per importare su un nuovo DB i dati esistenti nella procedura azienda Dos (es. clienti, fornitori, banche etc.) e scaricati da Azienda Dos in formato Ascii.
Le tabelle elencate a video, sono quelle per le quali è stato preparato un elenco dettagliato dei campi da caricare con la funzione: Gestione caratteristiche caricamento dati.

In corrispondenza delle tabelle da caricare occorre impostare una S nella colonna CARICA.
Per alcune tabelle occorre, tramite il pulsante [image] Dettagli, inserire, nei campi obbligatori, dei valori costanti da caricare. Tali valori sono già stati assegnati, eventualmente possono essere variati dall'utente.

Il loro significato si può leggere nella stessa riga in cui viene chiesto il valore, in corrispondenza alla colonna 'Richiesta'.

Es. premendo il pulsante 'Dettagli' quando si è posizionati sulla riga della tabella Conti, verrà chiesto di inserire la data di apertura (o creazione) dei conti.

In corrispondenza agli articoli di magazzino sono stati create tre possibili modalità di caricamento:

  • solo articoli
  • articoli e costi
    oltre ai dati dell'articolo, verrà caricato il costo ultimo, costo medio etc
  • articoli, costi e progressivi
    oltre ai dati anagrafici dell'articolo e ai costi vengono caricati anche i progressivi

basterà scegliere uno di questi, a seconda di quello che si vuole ottenere.

Caricando gli articoli viene caricato anche il prezzo di listino (che in dos è dentro l'anagrafica articoli) nel listino BA (base)

UMIva eseguendo il caricamento di questa tabella, vengono create, a partire dagli articoli di magazzino, le unità di misura e le aliquote iva che si trovano su di essi.

Al termine del caricamento è assolutamente necessario fare un controllo generale delle tabelle caricate e in particolare completare: Causali, Codici Iva, Tipi di pagamento, Condizioni di pagamento. Se si decide di caricare i movimenti contabili e iva occorre creare come codici iva, se utilizzati per le registrazioni, gli indetraibili: es. 320, 420 e il NON interessa iva es. 500, oltre alle aliquote normali se non caricate dagli articoli di magazzino.

Una volta impostate queste tabelle, si può procedere con la creazione dei vari database con la funzione Gestione database aziende - Creazione Nuova Azienda scegliendo l'opzione: Eseguo caricamento automatico dati da file ascii.


ACQUISTI INTRA-CEE

La registrazione di una fattura di acquisto IntraCee implica la registrazione della stessa anche sul registro iva vendite e la registrazione di un giroconto per sistemare i saldi dei conti interessati (vedi esempio in fondo).

La numerazione di tali fatture potrà seguire quelle di acquisto normali o andare su un registro a parte con un prefisso eventualmente specificato nella causale stessa.

Per la registrazione della fattura di acquisto occorre utilizzare una causale di tipo fattura di acquisto con il flag IntraCee settato.
Il programma può generare in automatico, al termine della registrazione della fattura di acquisto, le altre due registrazioni, a condizione che siano stati impostati gli automatismi descritti in seguito:

  • Creare un cliente d'appoggio per fatture intracee e, nella sezione Contabilità, inserire il conto di ricavo (Transitorio Cee), una alternativa può essere mettere questo una volta per tutte sulla causale Vendite intracee.
  • Sull'anagrafica del fornitore intraCee, nella sezione Contabilità, inserire il codice del cliente di appoggio IntraCee che servirà per la registrazione della fattura di vendita.
  • Creare una causale per il giroconto
  • Creare una causale per Vendita intracee, con il flag IntraCee settato, e nel campo: causale collegata mettere la causale del giroconto, nel campo Contropartita codice inserire il conto di ricavo (Transitorio Cee), l'alternativa può essere mettere questo conto sul cliente d'appoggio per fatture intracee
    (eventualmente mettere il conto iva da utilizzare e il prefisso)
  • Creare una causale per Acquisto intracee, con il flag IntraCee settato, e nel campo: causale collegata mettere il codice della causale Vendita IntraCee (eventualmente mettere il conto iva da utilizzare e il prefisso)
  • Per quanto riguarda il conto iva che verrà utilizzato, potrà essere impostato sulle rispettive causali di acquisto e vendita oppure nei conti comuni (dati generali azienda-parametri) e potrà essere lo stesso codice del conto "iva acquisti" o un codice di un conto specifico "iva acquisti intracee".

Il programma al termine della registrazione della fattura di acquisto intracee provvederà automaticamente a registrare la fattura di vendita e il giroconto che storna l'iva dal fornitore cee, l'imponibile dal conto di ricavo e l'importo totale della fattura dal cliente d'appoggio per intracee.

Esempio di registrazione:

Fattura del fornitore | Dare | Avere
Fornitore Intra Cee |  | 1200
Merci c/Acquisti | 1000 |
Iva Acquisti (Intra Cee) | 200 |

Il programma in automatico registrerà:

Fattura di vendita fittizia | Dare | Avere
Cliente transitorio Intra Cee | 1200 |
Ricavo Merci (Transitorio Cee) |  | 1000
Iva Vendite (Intra Cee) |  | 200

e

Giroconto | Dare | Avere
Fornitore Intra-Cee | 200 |
Ricavo Merci (Transitorio Cee) | 1000 |
Cliente transit. (Intra-Cee) |  | 1200

Produttori agricoli in regime speciale:
la registrazione dell'acquisto intracomunitario è indetraibile mentre l'iva della fattura di vendita registrata a fronte di tale acquisto dovrà essere versata. Per consentire al programma di generare in automatico la registrazione della fattura di vendita 'fittizia' con un'iva 'normale' piuttosto che indetraibile, si dovrà compilare, nella definizione del codice iva utilizzato nell'acquisto, il campo Codice iva sostitutivo.


AGENZIE DI VIAGGIO (ART.74 Ter)

L' Art.74 Ter della normativa Iva stabilisce particolari disposizioni per le agenzie di viaggio e turismo.

Come attivare la gestione dell'Art.74 Ter

Sulla tabella Dati iniziali iva, barrare la casella Gestione Art.74 e inserire l'eventuale credito di costo di inizio anno o controllare che sia corretto se si è elaborato anche l'anno precedente con questa procedura.

Inserire, con la Gestione Codici Iva, quattro esenzioni che dovranno poi essere utilizzate per le registrazioni, nelle quali andrà barrata, di volta in volta, una delle caselle poste nel riquadro Art.74 Ter:

  • Viaggi interamente CEE
  • Viaggi interamente fuori CEE
  • Misti (Costi parte Cee e Corrispettivi)
  • Misti (Costi parte No Cee)

Inserire inoltre un codice iva con tipo iva normale, con l'aliquota iva ordinaria per l'Art.74 Ter che verrà utilizzata dal programma in fase di chiusura iva.

In questo codice occorre barrare la casella: Aliquota IVA ordinaria che si trova nel gruppo di dati per Art.74 Ter

Inserire nel piano dei conti i seguenti conti:

  • Ricavi Art. 74 ter (gruppo economico)
  • Corrispettivi lordi art.74 ter (mastro ricavi)
  • Corrisp. lordi int. CEE 74ter (conto)
  • Corrisp. int. NOCEE 74ter (conto)
  • Corrisp. lordi MISTI 74 ter (conto)
  • Fatture emesse art.74 ter (mastro ricavi)
  • Proventi lordi viaggi int. CEE (conto)
  • Proventi org. viaggi int.NOCEE (conto)
  • Proventi lordi viaggi MISTI (conto)
  • Iva inclusa nei ricavi art.74ter (mastro ricavi)
  • Iva inclusa nei ricavi art.74ter (conto)
  • AcquistiI Art. 74 ter (gruppo economico)
  • Acquisti art. 74 ter (mastro costi)
  • Acquisti interamente CEE 74ter (conto)
  • Acquisti interamente NOCEE 74ter (conto)
  • Acquisti misti parte CEE 74ter (conto)
  • Acquisti misti parte NOCEE 74ter (conto)

Per quanto riguarda i registri iva (quindi i prefissi per la numerazione dei documenti) si può decidere di avere registri separati per vendite, acquisti, corrispettivi 'normali' e per vendite, acquisti, corrispettivi relativi a operazioni Art.74 ter o di avere un registro unico.

Registrazione, in prima nota, delle operazioni articolo 74 ter

  • Utilizzare causali di tipo fattura (acquisto-vendita) o corrispettivi normali
  • come conto di costo o di ricavo utilizzare uno dei conti di cui sopra
  • come codice iva utilizzare uno dei codici esenzione di cui sopra
    (quello appropriato al tipo di registrazione)

NOTA: i corrispettivi misti non sono suddivisi in parte CEE e parte NOCEE, pertanto conviene caricarli tutti con la stessa esenzione cioè quella inserita in tabella come: Art.74ter misti (costi parte CEE e Corrispettivi) per avere un unico importo totale.
Il programma di chiusura iva, comunque, somma anche i corrispettivi misti eventualmente caricati con codice esenzione di tipo: Misti (Costi parte No Cee)

La normativa prevede che per le agenzie di viaggio venga compilata una chiusura iva particolare, composta da tre parti da stampare in successione:

  • chiusura attività normale
  • chiusura art. 74 ter
  • chiusura riepilogativa

Se la chiusura periodica art. 74 ter evidenzia un debito iva, occorre fare la seguente registrazione in prima nota per l' importo dell' iva a debito rilevato dalla chiusura art.74 ter

Giroconto | Partita | C/Partita
 | conto "iva inclusa nei ricavi art.74 ter" |
 |  | conto "iva a debito art.74 ter"

A fine anno, se la chiusura annuale art.74ter evidenzia un debito Iva inferiore alla somma dell' iva a debito di tutti i periodi, occorre fare un giroconto, come descritto sopra, per la differenza (scambiare partita con c/partita).


BLACK LIST

L'argomento riguarda l’obbligo della comunicazione, da parte dei soggetti passivi iva, dei dati relativi alle operazioni effettuate nei confronti di operatori economici aventi sede, residenza o domicilio in paesi a fiscalità privilegiata (Black List).
Il decreto-legge n. 16/2012 ha escluso dall’obbligo di comunicazione le operazioni che non superano i 500 € (norma in vigore dal 2 marzo 2012)

E' prevista una funzione di preparazione di un file per l'invio telematico della Comunicazione black list
Durante la preparazione del file, è possibile ottenere anche una stampa dei dati in esso inserito.

Come identificare e compilare correttamente i dati per le operazioni Black List

E' stato compilato un elenco di tutti gli Stati, con indicazione in ciascuno se presente o meno in Black List (Tabella gestibile in Parametri e utilità - Dati azienda e parametri - Tabelle comuni, e contenuta nel database del menu - AziMenu.mdb)

In ogni database è presente la tabella Stati con l'elenco degli stati utilizzati nelle anagrafiche dei clienti e dei fornitori. In ciascuno di essi c'è un codice che fa riferimento alla tabella generale degli Stati, di cui sopra. E' indispensabile compilare questo codice in ogni stato, in particolare in quelli appartenenti a paesi in Black List.

Nelle anagrafiche dei Clienti e Fornitori, al momento della compilazione dello Stato, se questo è in B.L., verrà evidenziato con un messaggio a video e verrà spuntato il campo "Da estrarre in file paesi in Black List"
Se il cliente è estero e il suo stato è in Black List, si raccomanda di compilare correttamente tutti i dati anagrafici in quanto dovranno essere inseriti nella comunicazione:

  • Persona fisica
    Cognome-Nome in Ragione sociale contabile, Data di Nascita, Comune (o stato) estero di nascita, codice Stato di nascita.
  • Società
    Ragione sociale , Indirizzo, Città estera, Stato della sede legale

Lasciare bianca la sigla della provincia (anche quella di nascita) o compilarla con EE.

Su ogni conto di costo e ricavo è stato inserito un campo che indica se si tratta di Bene o Servizio al fine di poter separare gli importi nella comunicazione. Di default si assume che si tratti di "bene", per i servizi occorre andare sui singoli conti a modificare il campo.
Questo campo può assumere anche il significato di 'Costi accessori per Bolle doganali' (es. Oneri doganali da inserire nella registrazione di Bolle doganali).
Gli importi relativi a conti, utilizzati in fatture che vanno in Black list e che hanno questo campo impostato col valore suddetto, verranno considerati 'Servizi'.

Prima Nota - al momento della registrazione di una fattura/nota credito emessa o ricevuta, il programma, una volta compilato il codice del cliente/fornitore, imposta a video il campo "Relativa a paesi in Black List" con il valore letto dall'anagrafica richiamata.
Se invece si sta registrando una fattura d'acquisto (es. bolla doganale) da un paese in black list con una causale nella quale è stato spuntato il flag 'importazione no cee' , è indispensabile inserire il codice del fornitore nell'apposito campo 'fornitore black list straniero'.

Emissione fatture (da Vendite)
Nel momento del passaggio automatico delle fatture in prima nota (contabilizzazione), il programma imposta sulla registrazione i campi:
"Relativa a paesi in Black List" con il valore letto dall'anagrafica cliente

Per una corretta compilazione del file per l'invio telematico occorre inserire, come descritto in seguito, tutti i dati anagrafici ditta, dichiarante, rappresentante etc.
Con la funzione “Dati per Comunicazioni Telematiche (ditta)” occorre inserire innanzitutto la periodicità di invio della Comunicazione black list: Mensile o Trimestrale

  • Compilare correttamente l'anagrafica ditta, in particolare il Codice natura giuridica
  • Se l'elaborazione è fatta da un intermediario occorre compilare in Dati per Comunicazioni telematiche (intermediario) (Tabella unica per tutte le ditte, da compilare una tantum)
    Pagina: dati per invio telematico, il Tipo fornitore e il suo codice fiscale.
    Poi dati dell'Intermediario: cod. fiscale. I dati 'impegno' si possono compilare qui per tutte le ditte oppure nelle singole ditte con la funzione “Dati per Comunicazioni Telematiche (ditta)” (menu contabilità - iva)
  • Se i dati del contribuente sono diversi dai dati della ditta stessa, compilare, con la funzione “Dati per Comunicazioni Telematiche (ditta)” (menu contabilità - iva) i dati anagrafici del contribuente, altrimenti controllare che siano tutti compilati i dati nell'anagrafica ditta
  • Compilare inoltre, se esiste, sempre con la stessa funzione, i dati del Rappresentante (Dichiarante)

Compilare correttamente i campi che indicano se i vari soggetti sono persona fisica o giuridica e, nel caso di persona fisica, là dove ci sia un unico campo per inserire Cognome e Nome, scriverli separati dal carattere - (meno).
Nota: i numeri di telefono devono contenere solo delle cifre

Per quanto riguarda gli importi, essi vengono differenziati in acquisti/cessioni di beni e acquisti/prestazioni di servizi in base all'impostazione del campo 'Beni o servizi' Black List dei conti utilizzati nei documenti.
Gli importi relativi a conti, utilizzati in fatture che vanno in Black list e che hanno questo campo impostato a 'Costi accessori per Bolle doganali' verranno considerati 'Servizi'.

Inoltre a seconda del Tipo iva inserito nel codice iva della riga della registrazione, gli importi andranno ad incrementare progressivi diversi:
Operazioni imponibili
Operazioni non imponibili
Op. Esenti
Op. non soggette

Accertarsi inoltre che siano compilati correttamente i dati dell'azienda per il frontespizio (Stessi dati preparati per lo spesometro)


INVIO TELEMATICO DEI CORRISPETTIVI (PER GRANDE DISTRIBUZIONE)

Al fine di poter realizzare la trasmissione telematica dell'ammontare dei corrispettivi giornalieri delle cessioni di beni e delle prestazioni di servizi da parte delle imprese di grande distribuzione, sono state predisposte le seguenti funzioni:

  • Gestione dei Punti Vendita
  • Estrazione Corrispettivi per invio telematico
  • Gestione
  • Preparazione file per invio telematico

Le eventuali fatture/note i cui importi vanno trasmessi assieme ai corrispettivi, dovranno avere una causale di contabilità diversa da quelle da non trasmettere (cessioni di immobili e/o di beni strumentali). Tali causali dovranno essere scritte rispettivamente nei parametri di personalizzazione: FattCorri e NoteCorri

Nella comunicazione telematica i corrispettivi devono essere divisi per Punto Vendita; il programma utilizza il prefisso (prefisso protocollo) per identificare i corrispettivi di un certo punto vendita.

Occorre perciò definire prefissi diversi per ogni punto vendita sia per i corrispettivi sia per le eventuali fatture/note credito da trasmettere in Parametri e Utilità - Dati generali azienda (parametri) - Parametri comuni, poi creare la riga corrispondente in Contabilità - Gestioni - Prefissi e numeratori Corrispettivi ed eventualmente, Vendite. In pratica lo stesso punto vendita può utilizzare lo stesso prefisso sia per corrispettivi che per le fatture ma quel prefisso NON deve essere utilizzato da altri punti.

L'elenco dei prefissi che identificano le eventuali fatture/note da trasmettere dovrà poi essere scritto nel parametro di personalizzazione PreFattCorri

In fase di inserimento di un nuovo punto vendita, là dove si chiede l'elenco dei prefissi dei suoi corrispettivi, verrà visualizzato l'elenco dei prefissi corrispettivi seguito dagli eventuali prefissi utilizzati per le fatture/note i cui importi vanno trasmessi assieme ai corrispettivi.

Per aggiungere delle 'aliquote iva' da scaricare oltre a quelle previste attualmente dal modello per l'invio telematico nel campo 'Aliquota iva' (22,21,10,04,NI,ES,RP) occorre attivare i parametri di personalizzazione EleTelemCod, EleTelemDesc,EleTelemSta
(Es. per aggiungere un'eventuale aliquota 23%)


COSTI NON DEDUCIBILI

E' stato creato un automatismo per aiutare l'operatore a calcolare la quota di costo non deducibile fiscalmente, nelle registrazioni di fatture di acquisto nelle quali il costo è in parte deducibile e in parte non deducibile (a prescindere dalla indetraibilità dell'iva).

Esempio: Costi per telefonia fissa, telefonia mobile, autovetture.

E' possibile ottenere lo scopo seguendo due diverse modalità operative.

La prima è quella di compilare su ogni conto di costo (es. Spese telefoniche) i campi Conto collegato e percentuale di indeducibiltà. Il conto collegato sarà il conto della spesa non deducibile e la percentuale, la percentuale di costo non deducibile.

Quando si registrerà in prima nota una fattura d'acquisto e si inserirà come conto di costo, un conto con i campi suddetti compilati, verrà visualizzata in alto nella maschera l'icona [image] (B) Costo Indeducibile

Se, invece di confermare con F10 la riga, si preme questa icona, verrà ricalcolato l'importo della riga corrente mettendo solo la parte deducibile e verrà generata in automatico una nuova riga che ha come conto il conto della spesa non deducibile, come importo la parte non deducibile dell'importo iniziale, come codice iva lo stesso della riga principale.

Una seconda modalità è quella di creare una causale apposita per ogni registrazione di questo tipo, inserire nella causale stessa la percentuale di non deducibilità, il conto del costo deducibile (come codice contropartita, non obbligatorio) e, in particolare quello del costo non deducibile (o come codice contropartita o come conto collegato). In questo modo, una volta digitato l'importo del costo e premuto F10, il programma modificherà l'importo della riga inserita lasciando solo la parte del costo deducibile e creerà una nuova riga per l'importo del costo non deducibile.


FATTURE COINTESTATE

Vedi Clienti cointestatari.


FATTURA DETTAGLIANTI

Questo tipo di fatture è diretta ai dettaglianti che, per il tipo di Vendite che effettuano, sono costretti ad emettere un consistente numero di fatture, in quanto richieste dai clienti e tuttavia:

  • NON hanno l' obbligo di tenuta del Registro delle Fatture emesse
  • HANNO l' obbligo di compilazione del Registro Corrispettivi

In genere le fatture emesse non vengono rilevate in contabilità generale ed iva in forma analitica, ma con un'unica registrazione dei corrispettivi giornalieri mettendo in evidenza, nella descrizione,
le fatture emesse dal n. .... al n. ....

Tale rilevazione, pur essendo corretta ai fini dei risultati contabili, non adempie agli obblighi di 'chiarezza della Contabilità ' e inoltre non permette la gestione delle scadenze e la memorizzazione dei progressivi iva sui singoli clienti.

Soluzione adottata

Tramite l'inserimento di 'Fatture dettaglianti' con le caratteristiche spiegate in seguito, sarà possibile vedere in contabilità la registrazione della fattura sul cliente e quindi delle eventuali scadenze. Tale fattura, dal punto di vista iva, non verrà considerata ai fini della chiusura ma incrementerà i progressivi iva clienti.

La registrazione del corrispettivo giornaliero (fatta su un conto transitorio) dovrà essere comprensivo anche dell'importo delle fatture ma la registrazione dell'incasso vero e proprio sarà fatto per il solo importo degli scontrini non fatturati.

Come abilitare la possibilità di emettere fatture dettaglianti

  • Compilare la rispettiva casella di abilitazione in Parametri e Utilità, Dati generali azienda, Procedure installate
  • Creare una causale di contabilità avendo cura di impostare a Si la casella: fattura dettaglianti
  • Creare un Tipo documento di fatturazione avendo cura di impostare a Si la casella: fattura dettaglianti e mettere come causale Coge collegata, quella creata in precedenza.
  • Nei Conti comuni deve essere stato impostato il codice del conto transitorio: "cliente corrispettivo" che verrà utilizzato dalla fatturazione per gli scarichi contabili.
  • Creare un codice iva con le seguenti caratteristiche: Tipo iva: normale, aliquota 0, % non detraibile 100%
  • Inserire nei parametri di fatturazione il codice iva creato in precedenza, nel campo: Iva per fatture dettaglianti

La procedura consente di inserire queste fatture:

  • Direttamente dalla prima nota
  • Da fatturazione con emissione fattura e, se è collegato un registratore di cassa, successiva emissione dello scontrino da allegare ad essa.
    L'operatività in fase di inserimento, variazione , annullamento o stampa della fattura è assolutamente uguale alle fatture dirette.
    Viene impostato sempre in testata il flag di listino ivato.
    C'è un campo in più sulla testata fattura: sulla stessa riga dell'acconto viene chiesto l'abbuono. Se viene impostato un importo, la contabilizzazione della fattura registrerà anche l' articolo dell'abbuono.
    E' attivo inoltre un nuovo pulsante: (Y) scontrino per fatture dettaglianti premendo il quale è possibile entrare in gestione scontrini e, se tutto è stato predisposto in modo corretto, emettere lo scontrino relativo alla fattura in oggetto (vedi Emissione scontrini)
    Anche dallo stesso programma di emissione scontrini, se è stata attivata per la ditta la fattura dettaglianti, sarà possibile accedere al programma di emissione fattura dettaglianti.

Contabilizzazione della fattura dettaglianti:

Es. fattura di 228 euro con varie aliquote ma il totale imponibile è 200 e il totale imposta è 28

  • La registrazione viene fatta con causale fattura (con flag fatt. dettaglianti):
  • Cliente a Cliente Corrispettivo per l'importo totale: 228
  • Il codice iva è quello 'particolare' letto dai parametri di fatturazione: indetraibile al 100%
  • L'imponibile è il totale imponibile della fattura e l'imposta il totale imposta.
  • Il flag di forzatura è impostato a Si

Se gli importi di Abbuono e/o Acconto sono diversi da 0 vengono generati anche i movimenti relativi

Se il tipo di pagamento prevede la registrazione automatica dell'incasso viene generata anche questa registrazione.

Se viene emesso anche lo scontrino, la chiusura serale della cassa registrerà un corrispettivo comprensivo degli importi delle fatture, mentre i movimenti di incasso e abbuono non ne terranno conto in quanto gestiti dalla fattura stessa

Trattamento delle registrazioni fatte dalla fattura

Le registrazioni vengono riconosciute dal fatto che sulla causale è attivo il flag di Fattura dettaglianti.

Aggiornamento iva : aggiorna SOLO imponibile e imposta sul cliente e non i progressivi iva delle vendite.

Registro Iva: i movimenti non vengono stampati sui registri iva (la ditta non ha il registro iva vendite!)

(Occorre tuttavia selezionare la stampa del registro iva vendite per mettere anche su questi movimenti il segnale di stampato).

Come fare le registrazioni dei corrispettivi e delle fatture dettaglianti direttamente da Prima nota.

Nell' ipotesi di un corrispettivo giornaliero di 466.000 così suddiviso:

  • una fattura per 228 (119 con iva al 19% e 109 con iva al 9%)
  • corrispettivi per 238 (da scorporare iva 19%)

Le registrazioni dovranno essere fatte come segue:

Fattura n. Xx (causale di tipo fattura) a Cliente XY

Partita | C/Partita | Cod.Iva | Imponibile | Imposta
Cliente |  |  | 228 |
 | Cliente corrispettivo (Transitorio Corrispettivo) | Iva indetraib.100% | 200 | 28

Forzatura: Si

==================================================
Corrispettivo
Descrizione: Corrisp. + Fattura xx

Partita | C/Partita | Importo
Cliente corrispettivo |  | 466
 | Ricavi al 9% | 100
 | Ricavi al 19% | 300
 | Iva a debito | 66

==================================================
Registrazione incasso del giorno:
SOLO per la parte Corrispettivi incassati da vendite al dettaglio

Conto | Dare | Avere
Cassa | 238 |
Transitorio Corrispettivi |  | 238

==================================================

Gli incassi derivati da fatture potranno essere gestiti col saldaconto, se vengono generate le scadenze e andranno a chiudere i vari clienti.


FORFETARIA - Opzione

In sede di definizione del tipo di contabilità della ditta (Caratteristiche esercizio di contabilità) si può specificare se la ditta ha una contabilità generale, semplificata o forfetaria.

Nel caso venga specificato: forfetaria, occorre poi compilare il campo Percentuale recupero iva vendite nella tabella Dati iniziali iva (e lasciare vuoto il campo Percentuale detraibilità iva acquisti)

Di questa percentuale si terrà conto in fase di Chiusura Periodica dell'Iva.

Essa verrà applicata all'imposta delle vendite per ricavare la parte di iva a debito.


IMPORTAZIONI

  • Registrazione di una fattura di acquisto IntraCee
  • Registrazione di acquisti Extra Cee

All'interno di questo secondo gruppo, possiamo distinguere alcuni casi diversi:

Registrazione acquisto da Repubblica San Marino (Art.17) (vedi esempio 1)
si registra la fattura d'acquisto con rilevazione dell'iva, fattura 'fittizia' di vendita e un giroconto per chiudere i conti transitori (registrazione assimilabile a quella fatta per l'acquisto intra cee)
Utilizzare una causale d'acquisto dove siano stati spuntati entrambi i campi 'importazione no-cee' e 'importazione Rsm', creare i collegamenti per abilitare la creazione in automatico delle registrazioni che seguono la fattura come descritto in seguito (1'caso).

Acquisto da un paese extra cee (Registrazione della fattura della Dogana - Bolla doganale)
Vedi esempio 1
Utilizzare una causale d'acquisto dove sia stato spuntato il flag 'importazione no-cee' e creare i collegamenti per abilitare la creazione in automatico delle registrazioni che seguono la fattura.
Se l'importazione è stata fatta da un fornitore che appartiene ad un paese in Black List , inserire nella registrazione della fattura, anche il codice del fornitore Black List nell'apposito campo (questo affinché il programma possa poi estrarre gli importi per la comunicazione telematica B.L.)
Tale fattura sarà seguita dalla registrazione dell' autofattura e di un giroconto per chiudere i conti transitori (possibilità di generazione automatica abilitando le causali collegate).
Seguirà la registrazione della fattura del fornitore estero con una causale 'diversi a diversi' per il costo della merce.

Registrazione della fattura della Dogana (Bolla doganale) NON seguita da autofattura ma da un giroconto per chiudere il Merci c/transitorio e la Dogana per l'importo della merce (vedi esempio 2)
L'iva sulla Dogana si chiuderà al momento del pagamento.
Seguirà la registrazione della fattura del fornitore estero con una causale 'diversi a diversi' per il costo della merce.

Come impostare l'automatismo:
 Il programma può generare in automatico, al termine della registrazione della fattura di acquisto, le altre registrazioni descritte a fine capitolo, a condizione che siano stati impostati i codici descritti in seguito:

1 caso:

  • Creare un cliente per le Autofatture
  • Sull'anagrafica del fornitore (Bolla doganale o fornitore RSM), nella sezione Contabilità, si può inserire il codice del cliente di appoggio per le Autofatture (servirà per la registrazione dell'autofattura) oppure si può mettere una volta per tutte SOLO sulla causale autofattura.
  • Creare una causale per il giroconto
  • Creare una causale di tipo fattura di vendita per Autofattura con il flag 'Autofattura no-cee' settato (se andrà collegata a una causale di importazione da San Marino spuntare anche 'Autof.Rsm')
    'partita codice' inserire il codice del cliente per l'autofattura (se non lo si mette sul fornitore)
    si può scegliere se compilare il campo
    'contropartita codice', con un conto di ricavo Transitorio o se lasciarlo bianco.
    In questo caso il programma creerà l'autofattura con gli stessi conti inseriti sulla fattura d'acquisto, ignorando però quelli che hanno il campo 'Beni o servizi black list' impostato a 'Costi accessori per Bolle doganali' (es. Oneri doganali).
    nel campo: 'causale collegata' mettere la causale del giroconto
  • Creare una causale per la fattura d' Acquisto con il flag 'Importazione no-cee' settato (se importazione da San Marino spuntare anche 'Import.Rsm')
    nel campo: 'contropartita codice' inserire il conto merci c/Transitorio.
    nel campo: 'causale collegata' mettere il codice della causale Autofattura
    (eventualmente mettere il conto iva da utilizzare e il prefisso)
  • Per quanto riguarda i conti iva: potranno essere impostati sulle rispettive causali di acquisto e vendita oppure, verranno utilizzati quelli impostati nei 'conti comuni' in codice conto "iva acquisti e vendite".

2 caso:

  • Creare una causale per il giroconto
  • Creare una causale per la fattura d' Acquisto con il flag 'Importazione no-cee' settato
    nel campo: 'contropartita codice' mettere un codice conto: merci c/provvisorio
    nel campo: 'causale collegata' mettere il codice della causale Giroconto
    (eventualmente mettere il conto iva da utilizzare e il prefisso)

Esempi di registrazione:

1:

Bolla Doganale | Dare | Avere
Fornitore RSM o Fornit. reale: es. Rappr. fiscale in Italia di ditta estera |  | 1200
Merci c/Acquisti | 1000 |
Iva Acquisti | 200 |

Il programma in automatico registrerà:

Autofattura | Dare | Avere
Cliente transitorio per autofatture | 1200 |
Ricavo Merci Transitorio |  | 1000
Iva Vendite |  | 200

e

Giroconto | Dare | Avere
Fornitore Dogana (o RSM o Fornitore reale) | 200 |
Ricavo Merci Transitorio | 1000 |
Cliente transitorio per autofatture |  | 1200

1A)
Se si vuole utilizzare lo stesso conto transitorio (merci c/transitorio) sia nella registrazione della fattura d'acquisto sia nell'autofattura (basta non aver compilato nella causale autofattura il campo 'contropartita codice'), le registrazioni saranno:

Bolla Doganale | Dare | Avere
Fornitore Dogana |  | 1205
Merci c/Acquisti | 1000 |
eventuali Oneri Doganali (esenti) conto con Flag: 'Costi accessori per Bolle doganali' | 5 |
Iva Acquisti | 200 |

Il programma in automatico registrerà:

Autofattura | Dare | Avere
Cliente transitorio per autofatture | 1200 |
Ricavo Merci Transitorio |  | 1000
Iva Vendite |  | 200

e

Giroconto | Dare | Avere
Fornitore Dogana (o RSM o Fornitore reale) | 1200 |
Cliente transitorio per autofatture |  | 1200

2:

Bolla Doganale | Dare | Avere
Fornitore Dogana (o RSM o Fornitore reale) |  | 1205
Merci c/Transitorio | 1000 |
Eventuali Oneri Doganali (esenti) | 5 |
Iva Acquisti | 200 |

Se alla causale fattura d'acquisto si collega direttamente una causale 'giroconto' , il programma in automatico registrerà, per l'importo della merce:

Giroconto | Dare | Avere
Fornitore Dogana | 1000 |
Merci c/Transitorio |  | 1000

La Dogana si chiuderà per l'importo dell'iva, quando la si paga


INVIO DOCUMENTI PER EMAIL

Nella maschera della funzione di "stampa" dei vari documenti (ed etichette) è presente una opzione che, se spuntata, consente l'invio per email del/dei pdf del documento stesso.
Sul cliente (fornitore) è possibile impostare più indirizzi email e, a seconda del documento che si sta spedendo, decidere quale utilizzare.
Non si possono inviare più documenti in un unico pdf ma solo un documento per volta.

Se si sceglie l'invio per email, è indispensabile spuntare a video anche la scelta: "Nome file automatico per pdf" e quindi aver attivato la stampa su pdf.

Su ogni fattura verranno memorizzati Data ultimo invio e Risultato (Riuscito Fallito No invio)
Per variare il criterio di aggiornamento della data di ultimo invio, si può utilizzare il parametro di personalizzazione: AggDataInvioEmail

Per utilizzare questa opzione occorre:

  • inserire nell'anagrafica del/dei clienti interessati l'indirizzo (gli indirizzi) email (oppure inserire l'indirizzo 'occasionale' nella maschera raggiungibile con Selezione destinazione stampe)
  • attivare la procedura per la stampa su pdf delle fatture
  • Inserire, con il pulsante apposito (Selezione destinazione stampa - Parametri INI pdf-email) tutti i parametri necessari per l'invio automatico dell'email e confermali (se utilizzati solo al momento) oppure salvarli sull' AziWin.ini comune o locale.
    L' alternativa, sconsigliata, è inserire manualmente nel file aziwin.ini (principale o dell'utente) i parametri necessari
  • Configurare SendMail o See per l'invio (l'utilizzo di SEE è obbligatorio per i server di posta che utilizzano SSL, in particolare per la casella di posta certificata e Gmail)

A fianco dell'opzione c'è un pulsante: "Cambia Testi"
Esso fa riferimento a un massimo di 5 testi per ogni tipologia di documento (preventivi,.., fatture,etichette) che si possono richiamare, dopo averli preparati e salvati, i quali contengono l'oggetto e il testo dell'email da inviare.
Il programma utilizza automaticamente il primo dei testi presente nella gestione raggiungibile con questo pulsante.


INVIO STAMPE PER EMAIL

L'operatore può decidere di fare qualsiasi stampa in formato Pdf e spedirla per email all'indirizzo desiderato.
Per quanto riguarda l'invio dei documenti (fatture, ddt , ordini e preventivi) per email si rimanda a Invio documenti per email.

Per utilizzare questa opzione occorre:

  • attivare la procedura per la stampa su pdf
  • Inserire, con il pulsante apposito (Selezione destinazione stampa - Parametri INI pdf-email) tutti i parametri necessari per l'invio automatico dell'email e confermali (se utilizzati solo al momento) oppure salvarli sull' AziWin.ini comune o locale.

Con la funzione Testi per email da pdf (menu Parametri e Utilità), si possono configurare fino a 5 testi diversi che contengono l'oggetto e il testo dell' email da inviare. Sul singolo programma si potrà scegliere quale utilizzare.

Configurazione SendMail

Dalla versione 3.04 di AziendaPc (Gennaio 2013) l'installazione installa automaticamente anche i due file vbsendmail.dll e mswinsck.ocx.
Se si disinstalla la vecchia versione, esse NON vengono disinstallate.
Se si reinstalla, e la directory di installazione è la stessa, verrà dato un messaggio che la Dll esiste e chiede se si vuole sovrascrivere.
E' bene perciò o reinstallare nella stessa directory di prima o, ancora meglio, disinstallarle prima di ripetere l'installazione.

Sul Server 2008 l’installazione mette già mswinsck.ocx (e anche tutte le altre DLL) direttamente in Syswow64 così come va in windows7 a 64 bit
In windows7 a 64 bit le DLL le mette sia in System32 sia in Syswow64

Programmi aggiornati ma installati prima della vers. 3.04:

Se si utilizza Sendmail occorre registrare due file contenuti nel CD di installazione nella cartella DLL
Copiare dal CD, nella cartella del disco fisso che contiene le Dll
(es. c:\aziwin\dll ) il file: vbsendmail.dll
e registrarla da Start - Esegui - poi scrivere ad esempio:
REGSVR32 c:\aziwin\dll\vbSendMail.dll
(con windows7 da Start 'Cerca programmi e file')

Successivamente, cercare se esiste in C il file: mswinsck.ocx.
Se esiste controllare che sia la stessa versione che è nel CD (o successiva)
Se non esiste, occorre copiare dal CD il file (es. in c:\windows\system32) e registrarlo.
da Start - Esegui - poi scrivere ad esempio:
REGSVR32 c:\windows\system32\mswinsck.ocx

Se esiste ma ha una versione precedente, occorre deregistrarlo
(REGSVR32 /u c:\windows\system32\mswinsck.ocx) , copiare il nuovo e registrare quello.

Configurazione SEE

Dalla versione 3.04A è possibile utilizzare SEE in alternativa a Sendmail.
L'utilizzo di SEE è però obbligatorio per i server di posta che utilizzano SSL (in particolare per la casella di posta certificata)
Il CD di installazione di AziWin contiene:

  • nella cartella DLL, il file See32.dll che va semplicemente copiato in un percorso raggiunto dalla Path del computer da cui si spediscono le email (normalmente nella cartella windows, se a 64 bit in syswow64).
    Windows8     chiede se copiarlo come amministratore poi non lo lascia copiare. Per farlo si può copiare prima su una cartella qualsiasi di C poi, da questa, nella cartella windows.
  • nella cartella \Varie, la cartella \STUNNEL
    questa va copiata (SOLO SE si utilizza SEE con SSL, obbligatorio se si usa posta certificata o Gmail) sul computer da cui si inviano le email o in una cartella condivisa in rete.
    Nella maschera di configurazione dei parametri per l'invio di stampe per email, verrà chiesto di indicare questa cartella


INSOLUTI

Se un effetto torna insoluto, occorre riaprire il cliente per l'importo dell'insoluto ed eventualmente generare una nuova scadenza nello scadenzario per lo stesso importo.

E' possibile fare ciò in automatico, utilizzando per la registrazione una causale nella quale sia stato impostato a Si il campo Registrazione insoluto ed eventualmente la condizione di pagamento per generazione scadenza da insoluto. In corrispondenza a una registrazione fatta con questa causale, con un cliente in dare e un conto in avere, la prima nota propone e consente di variare, una scadenza creata secondo le caratteristiche specificate sulla condizione di pagamento letta sulla causale.

Perché venga creata bene la scadenza, si chiede che il numero e la data documento vengano impostati in testata della prima nota.


IVA AD ESIGIBILITA' DIFFERITA (IVA SOSPESA)

Dal 28 aprile 2009 è diventato operativo il nuovo regime dell' IVA in sospensione, definito per brevità anche "IVA per cassa".

Da tale data è stata estesa alla generalità dei soggetti passivi con volume d'affari non superiore a € 200.000,00 la facoltà di differire l'Iva al momento del pagamento della fattura emessa.

Prima di questa data tale modalità era applicabile solo per le fatture emesse ad enti pubblici.
Dal gennaio 2015 le fatture agli enti pubblici NON dovranno più essere emesse con iva ad esigibilità differita in quanto è stato introdotto lo Split Payment che prevede il pagamento dell'iva direttamente all'erario da parte dell'ente pubblico.

Il programma consente di emettere fatture del tipo suddetto e anche di registrare in prima nota fatture ricevute dello stesso tipo, utilizzando apposite causali.
Anche la registrazione dell'incasso o del pagamento (parziale o totale) di tali fatture andrà fatta con una causale apposita.

Alle fatture ad esigibilità differita emesse (o ricevute) deve essere attribuito un numero (protocollo) consecutivo alle altre fatture di vendita (o di acquisto), vanno stampate sul registro iva del mese di emissione (e totalizzate a parte) mentre l'imposta relativa verrà conteggiata solo nella liquidazione del periodo di incasso/pagamento.

La registrazione dell'incasso/pagamento non deve essere stampata sul registro iva.

Per la registrazione in prima nota:

  • Creare una causale contabile con Tipo causale: "Iva ad esig.differita Cli. (o For.)" e con le altre caratteristiche uguali a quella utilizzata per le registrare la fattura di vendita (o di acquisto).
    Allo stesso modo creare anche una Nota di Credito iva differita.
  • Creare una causale contabile con Tipo causale: "Incasso (Pagamento) Iva ad esig.differita" e con le stesse caratteristiche di quella utilizzata per le registrare gli incassi (pagamenti). Per quanto riguarda i campi: "Protocollo" e "Documento obbligatorio" si possono lasciare bianchi o spuntare.
    Di conseguenza, nella registrazione dell'incasso/pagamento di un documento con iva esigibilità differita, il numero e la data protocollo e documento, potranno essere lasciati vuoti, se nella causale si è dichiarato che non sono obbligatori, altrimenti si potrà mettere il numero e la data della fattura a cui si riferisce.
    Questa registrazione è analoga a quella della fattura. In testata si metterà il codice del cliente e nel dettaglio il conto su cui è avvenuto l'incasso (pagamento). Poi si dovrà digitare il codice iva, l'imponibile e verrà calcolata l'imposta. Se in testata sono stati compilati numero e data documento, nel dettaglio, a fianco al campo "Imponibile", viene presentato il pulsante "Importi sospesi" che consente di visualizzare le righe della fattura interessata e che evidenzia quanto è ancora da pagare per ogni aliquota.
  • Compilare in "Dati generali azienda (parametri)"
    - conti comuni: i codici dei conti "Iva differita clienti" e "Iva differita fornitori".
    - causali comuni: il codice causali "Fattura iva differita" e "Nota Credito iva differita"

Per l'emissione di fatture in iva differita:

N.B. Sulla fattura deve essere presente la frase:
Operazione con imposta ad esigibilità differita, ex art. 7, DL n.185/2008
in modo che chi la riceve possa identificarla come tale.

  • Creare quanto descritto in precedenza
  • Per l'emissione della fattura può essere utilizzato lo stesso tipo documento utilizzato per le fatture normali.
  • Sull'anagrafica clienti, nei dati di fatturazione, e a video nei dati di testata di ogni fattura è presente un flag che dice se il cliente ha o meno l'iva ad esigibilità differita.
    Se si spunta questo flag sul cliente, esso verrà riportato spuntato in tutte le fatture. Viceversa è possibile decidere di spuntarlo, fattura per fattura.
  • Se il flag è spuntato, al momento della contabilizzazione della fattura verrà generato un articolo in prima nota con causale "fattura di vendita con iva sospesa" piuttosto che "fattura di vendita"


IVA PER CASSA

Dal primo dicembre 2012 è possibile, da parte dei soggetti che nell'anno solare precedente hanno realizzato un volume d'affari non superiore a 2 milioni di euro, optare per la liquidazione dell'iva secondo la contabilità di cassa cioè di versare l'imposta SOLO quando la fattura viene incassata e non quando viene emessa. Anche la detrazione dell'imposta sarà resa possibile solo una volta effettuato il pagamento al proprio fornitore.
Una volta adottato il regime dell'iva per cassa dovrà essere mantenuto per almeno tre anni salvo superamento dei limite del volume d'affari (vedi Fine applicazione).

Come attivare l'iva per cassa

Poichè adottando questo regime diventa indispensabile che il momento dell'incasso/pagamento di una fattura sia ben 'identificabile' è stata inserita nelle registrazioni di incasso/pagamento la 'Data Incasso/Pagamento' che, se lasciata vuota verrà intesa uguale alla data di registrazione.
Essa identificherà esattamente il periodo nel quale l'iva della fattura corrispondente dovrà essere versata o portata in detrazione.

E' indispensabile inoltre che ogni registrazione di incasso/pagamento riporti in prefisso/numero-data documento quelli del documento cui si riferisce, per cui per una corretta gestione è indispensabile attivare la gestione delle partite.

Fare attenzione inoltre alla data registrazione del pagamento/incasso: deve essere quella 'effettiva'.

Input Prima nota
Sulle fatture/note di variazione emesse e ricevute che vengono registrate con causali compatibili con l'iva per Cassa, in un periodo in cui questa è attiva :

  • verrà messo in automatico il campo 'Iva per cassa' impostato a Si.
  • nel conto iva della registrazione verrà impostato il codice del conto iva per cassa (dalla tabella dei conti Comuni).
    Al momento dell'aggiornamento iva, nel periodo in cui si incontrerà l'incasso, il programma provvederà a registrare il giroconto dell'iva per cassa all'iva vendite o acquisti.

Inoltre anche quando si registrano incassi/pagamenti di tali fatture, nella riga corrispondente al cliente o al fornitore verrà messo in automatico il campo 'Iva per cassa' impostato a Si

Se si registra un incasso prima della fattura deve essere una registrazione a parte (cioè solo per quell’incasso)
Quando l'operatore emetterà la fattura corrispondente, occorre andare a mettere il collegamento sulla registrazione dell'incasso (pref/num e data documento della fattura).
Se, alla registrazione dell'incasso, la fattura non è ancora stata contabilizzata occorre mettere manualmente a Si il flag di Iva per Cassa nella riga di dettaglio dell'incasso.

Note di variazione
Sulle note di variazione di fatture emesse per Cassa è Obbligatoriamente inserire pref/numero e data della fattura di origine in modo da poter stabilire il collegamento.

Se la nota di variazione viene registrata DOPO che la fattura è stata incassata/pagata, anche solo parzialmente, essa verrà considerata dalla Chiusura Iva solo una volta che sia pagata/incassata.
Per includerla nella prima liquidazione utile occorre togliere il flag di iva per cassa.

Non sarà possibile riaggiornare l' incasso, quando la nota di variazione è già aggiornata. Verrà dato un messaggio di errore e occorrerà disaggiornare prima la nota.
Si consiglia comunque, dovendo disaggiornare, di disaggiornare a ritroso, periodo per periodo.

Non è possibile aggiornare una nota di variazione di una fattura se esiste, nello stesso periodo, un incasso/pagamento della stessa fattura non aggiornato

Se la nota di variazione in aumento è emessa prima di un anno da una fattura non ancora incassata/pagata, anche per il nuovo ammontare dell'imponibile e dell'imposta l'anno decorre dall'effettuazione dell'operazione originaria, se è in diminuzione va a diminuire l'importo iniziale.
Qualora la nota di variazione in aumento sia emessa dopo un anno dalla fattura, l'imposta va computata nella prima liquidazione utile per cui il programma lascia a NO il flag di iva per cassa.

Fatture con ritenuta d'acconto:
diventa obbligatorio fare una registrazione separata della ritenuta (impostare a 2 il parametro di personalizzazione: RitAccFornAutom)
Mettere manualmente la data Incasso/Pagamento sulla registrazione della ritenuta d'acconto se si ritiene di doverla considerare, ai fini iva, solo al momento in cui effettivamente si versa.

Fatture ricevute in Reverse Charge
Non seguono il regime di cassa. Con questo regime, il programma non consente la registrazione di fatture miste (parte in reverse charge e parte no) per cui diventa necessario, in questo caso, fare due registrazioni separate.

Distinta: la contabilizzazione non dovrà chiudere i clienti (fornitori) ma dovrà essere fatta su un conto d'appoggio e solo al momento dell'accredito in banca andrà fatta la registrazione dell'incasso. Tale registrazione dovrà essere fatta, nella data effettiva dell'incasso, utilizzando la funzione Incasso/pagamento effetti in distinta oppure direttamente da prima nota .
Se un effetto torna insoluto, occorre registrare comunque l'incasso poi registrare l'insoluto, con l'apposita causale, nella stessa data.

Saldaconto
 Quando si incassa/paga una scadenza di una fattura che ha l'iva per cassa, la registrazione riporterà sulla riga del cliente/fornitore il campo Iva per cassa a Si e verrà considerata dall'aggiornamento iva per cassa e dalla Chiusura iva del periodo dell'incasso/pagamento.

Registri Iva
In corrispondenza a documenti con Iva per Cassa verrà scritta la nota *IVA C.
In fondo verrà stampato il dettaglio di imponibile e imposta, divisi per codice iva, dei documenti con iva per Cassa

Aggiornamento Iva e Aggiornamento Iva per Cassa
e relativi disaggiornamenti
Chi attiva l'iva per cassa, oltre all'aggiornamento iva dovrà eseguire 'l'aggiornamento iva per cassa' che aggiornerà le fatture emesse e ricevute 'per cassa' e in particolare terrà conto anche degli incassi/pagamenti del periodo relativi a fatture registrate con iva per cassa.
Il programma prenderà in considerazione le registrazioni che hanno un riferimento all'iva per cassa, siano esse fatture o incassi/pagamenti e, oltre ad aggiornare i progressivi iva, crea in corrispondenza ad ogni incasso/pagamento, il giroconto tra i conti iva vendite/acquisti per cassa e iva vendite/acquisti.
Parametri di personalizzazione utilizzati per i calcoli:
ArrotPercInc
ArrotIvaPerCassa

Chiusura Iva
In presenza di Iva per Cassa verranno evidenziate, in ogni periodo, imponibile e imposta distinte per:

  • Iva per Cassa incassata/Pagata ____________
    di cui Incassata/Pagata nell'anno di emissione delle rispettive fatture: ____________
    cioè quella riferita a fatture per le quali non è ancora passato un anno dalla data di emissione
  • Iva per cassa per decorrenza anno : ____________
    quelli riferiti a fatture per cui è passato l'anno
  • Il totale delle fatture emesse e ricevute nel periodo con iva per cassa

Nella maschera che mostra il risultato della chiusura, viene visualizzato un pulsante'Mostra iva per cassa del periodo' che consente di visualizzare/stampare la lista delle fatture incassate/pagate nel periodo e quelle ancora aperte.

Non sarà più possibile elaborare la Chiusura iva di un nuovo anno se non è stato fatto l'aggiornamento iva di tutti i movimenti dell'anno precedente.

Fatturazione

E' la fase di Contabilizzazione fattura a mettere in automatico sulla registrazione di prima nota il segnale di iva per Cassa a Si o a No in base ai criteri elencati in seguito.

Stampa fatture
Poichè le fatture emesse con questo regime devono riportare la scritta:
“Operazione effettuata in regime di IVA per cassa, ai sensi dell’art.32-bis del D.L. 83/2012”
il programma di Stampa fatture stamperà la frase se ci sono le condizioni (così come in Prima Nota nell' inserimento fattura viene impostato a Si il campo 'Iva per Cassa'). N.B. Sulla fattura elettronica questa scritta verrà riportata nel corpo come riga descrittiva
Per sopperire a casi particolari, nella maschera di stampa compare la richiesta:
'Scritta Iva per Cassa' da stampare

  • Come da elaborazione
  • Sempre
  • Mai

Se si sceglie di forzare, una volta contabilizzata la fattura/nota di Variazione, occorre andare sull'articolo di prima nota a sistemare il campo: Iva per Cassa.
Per personalizzare la frase da scrivere in fattura si può utilizzare il parametro di personalizzazione: DescrIvaPerCassa

Attivazione dell'IVA per Cassa

Per attivare l'IVA per Cassa per la contabilità dell'azienda, occorre indicarlo in Parametri e Utilità - Dati Generali azienda (parametri) - parametri di Contabilità.
Si chiede di indicare se tale regime si applica a tutte le attività iva dell'azienda o solo ad alcune e
le date di inizio e di fine applicazione.
Se non si conosce la data di fine applicazione, essa andrà impostata a 31/12/9999

Se l'applicazione dipende dall'attività, occorrerà inserire, con la funzione Contabilità - Iva - Dati iniziali Iva nei dati iniziali di ogni attività se applicherà o meno tale regime per l'anno in corso e le eventuali date di inizio e fine attivazione.

Nei parametri di Contabilità potranno inoltre essere impostate le Date inizio e fine procedure concorsuali, indicando così l'eventuale periodo per cui la ditta, in presenza di fatture ricevute da più di un anno, non potrà detrarsi l'iva anche se non pagate.

Inserire nella tabella dei Conti Comuni (Parametri e Utilità - Dati Generali azienda (parametri)) i conti Iva per Cassa vendite e Acquisti che verranno utilizzati per la generazione della riga iva delle fatture al posto dei conti iva vendite e acquisti 'normali'.
Se si gestisce l'iva per cassa occorre NON mettere il conto iva fisso sulla causale.

Inserire nella tabella delle Causali Comuni la causale, di tipo giroconto, per la registrazione che gira l'iva per cassa all'iva effettiva (giroconto che verrà creato in automatico al momento dell'aggiornamento iva per cassa). Si consiglia di creare una causale apposita in modo da poter selezionare in visualizzazione o stampa solo questi movimenti se se ne presenta la necessità.

Clienti e Fornitori
Campo 'Iva per Cassa disabilitata'.
Consente di disabilitare in modo forzato un'anagrafica.
NOTA BENE: Se il cliente NON ha partita iva, sulla la fattura registrata NON verrà impostato in automatico il flag 'Iva per cassa a sì'.

Clienti
Date inizio e fine procedura concorsuale. Se impostate, indicano il periodo per cui anche in presenza di fatture emesse da più di un anno e non ancora incassate, l'iva non dovrà essere pagata.

I programmi di Inserimento prima nota e Contabilizzazione Fatture, in presenza registrazione di un documento o incasso/pagamento per una ditta o attività che nel periodo ha l'iva per cassa, impostano in automatico, sulla registrazione stessa, il campo Iva per Cassa a SI o a NO

Operazioni escluse dall'iva per Cassa

Operazioni attive

  • Il cliente ha il campo Disabilita Iva per Cassa impostato a Si
  • Il cliente ha il campo Partita Iva vuoto
  • Le fatture emesse con IVA ad esigibilità differita (enti pubblici)
  • Operazioni non imponibili (esportazioni, etc.)
  • Regime del margine

Operazioni passive

  • Acquisti di beni e servizi soggetti all'iva con meccanismo dell'inversione contabile
    (Reverse Charge)
  • Acquisti in Sospensione di Iva
  • Acquisti Intra Cee
  • Importazioni

Fine applicazione iva per cassa

Se in Parametri e Utilità - Dati Generali azienda (parametri) - parametri di Contabilità è stato posto a S il Campo Iva per Cassa Attiva ad indicare che è attiva per tutte le attività, si dovrà impostare la data di fine del suddetto regime. L'aggiornamento Iva e la Chiusura Iva del periodo terranno conto di quella data e si provvederà a chiudere l'iva di tutte le fatture ancora aperte.

Se invece l'applicazione dell'iva per cassa dipende dalle attività Iva e quindi le date di inizio e fine attivazione sono in Contabilità - Iva - Dati Iniziali Iva dell'anno occorre:
mettere la data di fine sull'attività
fare tutti gli aggiornamenti iva fino al mese corrente
con un'utility impostare la data di fine applicazione sul campo 'DataSaldo' della tabella MovPnCassaTes
Ripetere l'aggiornamento iva che così considererà tutte le fatture ancora aperte come fosse passato un anno dall'emissione.


LETTORE OTTICO

La procedura consente di inserire il barcode in ogni articolo di magazzino e di stampare tale codice sulle etichette degli articoli. E' possibile perciò utilizzare lettori di codici a barre per richiamare l'articolo in fase di inserimento di un acquisto o di una vendita (es. una penna ottica collegata alla tastiera).

Con la gestione 'Ulteriori codici a barre articoli' si possono memorizzare, per ogni articolo già creato, eventuali ulteriori BarCode che fanno riferimento sempre allo stesso articolo.

E' stata implementata la possibilità di utilizzare 'lettori' che memorizzano codice e quantità per più articoli, si collegano al computer, scaricano su un file le informazioni raccolte. Un pulsante sui programmi di Caricamento movimenti, emissione ordini, ddt e fatture consentirà di leggere gli articoli e le quantità dal suddetto file e compilare in automatico il documento.
(Applicazione realizzata con terminale ottico BHT 8044)

Tale funzione è abilitata anche nel programma di Gestione inventario manuale che consente di inserire l'inventario fisico e quindi di generare dei movimenti di carico e scarico per sistemare l'inventario sul computer.

Per spiegazioni sulle modalità operative e, in particolare, sull'impostazione dei parametri, vedi Caricamento dettagli documenti da file.


LIBRI CONTABILI - NUMERAZIONE PAGINE

Dato il cambio di normativa per cui non si deve più procedere alla vidimazione preventiva dei libri contabili è possibile numerare le pagine di detti libri al momento stesso dell'utilizzo.

Per ottenere questo risultato sono stati introdotti alcuni parametri di personalizzazione il cui nome e significato viene specificato di seguito mentre per la loro esatta definizione si rimanda al capitolo Personalizzazione - parametri.

Nelle stampe del giornale bollato, dei registri iva e della chiusura iva è stata inserita una richiesta: si vuole stampare il numero di pagina? Questa richiesta viene preimpostata a Si o a No a seconda della definizione data al parametro di personalizzazione: StaPagFisc

Il numero di pagina del Giornale bollato è memorizzato nella tabella: Caratteristiche esercizio di contabilità (menu di servizio di contabilità)

Per quanto riguarda i registri iva, il numero di pagina è memorizzato nella tabella: dei numeratori, uno per ogni prefisso (menu di contabilità: gestioni, prefissi e numeratori)

Nel caso, per ciascuno dei registri (Vendite, Acquisti, Corrispettivi) pur utilizzando più prefissi, si stampi su un unico 'registro' fisico, si può dire quale prefisso utilizzare per numerare le pagine impostando rispettivamente i parametri di personalizzazione:

NumPagDaRegV (Vendite) , NumPagDaRegA (Acquisti), NumPagDaRegC (Corrispettivi)

Per quanto riguarda la chiusura iva, che va stampata sul registro delle vendite, in caso di più registri vendite occorre impostare il parametro NumPagChiuIvaPref per dire da quale prendere il numero di pagina (in pratica su quale 'prefisso' viene stampata). Se non si setta il parametro si prenderà il numero di pagina dal prefisso di default.


MATRICOLE

La gestione delle matricole consente l'inserimento delle matricole collegate agli articoli di magazzino in fase di carico merce, di movimentazioni varie e infine di scarico con ddt e fatture.

(Non sono gestite le matricole in fase di inserimento scontrini, inoltre non vengono scaricate né ricaricate nel caso di trasferimento movimenti, ddt etc. su file)

Nelle varie fasi sarà possibile inserire manualmente le matricole oppure acquisirle da un lettore ottico opportunamente configurato.

Si potrà, infine, ottenere una stampa nella quale per ogni articolo/matricola verranno elencati i movimenti.

Per abilitare la gestione matricole occorre inserire nei parametri di personalizzazione, il parametro: MatrGest
Se, una volta abilitato questo parametro nei programmi suddetti non compare, sui dettagli, l'icona
(J) Gest.matricole
vuol dire che non è stata riconosciuta la causale di magazzino come una causale di carico o scarico e quindi non è abilitato l'inserimento delle matricole.

Nei movimenti di magazzino di tipo 'Inventario' (cioè di inserimento di giacenza iniziale) non è abilitato l'inserimento delle matricole in quanto tali movimenti non vengono memorizzati.

Per caricare le matricole su articoli in giacenza:

  • Nella tabella dei Parametri di magazzino in uno dei campi: Nome quantità aggiuntiva, scrivere: Car.GiacMatr (sarà l'intestazione del campo che verrà presentato in Causali di magazzino, quantità aggiuntive)
  • Creare una causale di magazzino con le seguenti caratteristiche:
    Descrizione: Ins.matricole iniziali
    In inventario e giornale: No
    Carico/Scarico: Niente
    Segno: Positivo
    Provenienza: Niente
    Destinazione: Magazzino
    Quantità aggiuntive: click su Car.GiacMatr
  • Inserire nei parametri di personalizzazione il parametro: MatrCausaliNoMovCar con valore XX dove XX deve essere il codice della causale di magazzino di cui al punto precedente.

Caricare dei movimenti con questa causale e inserire gli articoli desiderati, con la quantità in giacenza e l'elenco delle loro matricole.

I movimenti delle matricole sono identificati da un tipo operazione in riferimento alla causale di magazzino che li ha generati: Carico, Scarico, Guasto (cioè reso da cliente per riparazione), Reso da cliente, reso a Fornitore, Interno

Nei parametri di personalizzazione va definito inoltre il parametro MatrCausaliRientro che dovrà contenere l'elenco delle causali di magazzino che verranno utilizzate per la registrazione dei movimenti di rientro per guasto (separate da virgola ',').

La causale di Reso a fornitore DEVE essere un Carico Negativo (altrimenti non si riesce a controllare la sequenza delle operazioni su una matricola)

E' possibile definire altri parametri di personalizzazione per caratterizzare esigenze particolari di gestione e la stampa su ddt e fatture (vedi Parametri di personalizzazione Matricole)

La sequenza degli stati di una matricola è che essa venga caricata (eventualmente resa al fornitore), scaricata poi eventualmente resa o resa perché guasta, rientrata in magazzino e quindi di nuovo disponibile alla vendita.

Il programma controlla che tale sequenza sia rispettata e cioè che non si faccia uno scarico di una matricola non caricata (non si tiene conto però del magazzino in cui la matricola è caricata).

In caso di mancata sequenza viene dato un messaggio di incompatibilità e si consente di inserire ugualmente la matricola forzando.

La corretta sequenza viene stabilita sui movimenti di magazzino al momento dell'inserimento dei documenti e al momento della stampa, nel movimento viene inserita la matricola scaricata con quel documento, per cui lo stato della matricola cambia SOLO se il documento (ddt o fattura) che la contiene è stato stampato.

Per cui per garantire il controllo della sequenza, la stampa ddt/fatture deve essere fatta subito.

La compatibilità viene fatta non con l'ultimo movimento in archivio, ma con l'ultimo di data precedente a quello che si sta inserendo.

In fattura riepilogativa non è possibile modificare le righe di articolo e nemmeno le matricole per cui se sarà necessario variarle o si cancella la fattura e si variano le matricole sui ddt oppure si vanno a variare direttamente sul rispettivo movimento di magazzino.

Nella maschera di Gestione matricole ci sono due pulsanti:

(O) Mostra stato Succ. e Prec

consente di visualizzare numero, data e stato dell'ultimo movimento, in ordine di tempo, della matricola su cui si è posizionati Se questo ha una data successiva a quella del movimento attuale, verrà visualizzato, se esiste, anche il movimento precedente al movimento corrente.

(R) Ricerca Matricole

visualizza, se esiste, per ogni matricola dell'articolo su cui si è posizionati, la data e lo stato del movimento Precedente e Successivo compatibili con l'attuale.

Se le matricole verranno lette dal lettore ottico è inoltre necessario impostare un apposito paragrafo nel file aziwin.ini (generale o del terminale a seconda della necessità) per fornire al programma le informazioni relative al tipo di file, preparato dal lettore ottico, che il programma dovrà caricare.
Se i file da caricare hanno caratteristiche diverse, dovranno essere predisposti più paragrafi, tutti dovranno iniziare LettMatrDaFile seguito da qualcosa, es. LettMatrDaFilePippo e avere nella seconda riga, un diverso contenuto nel parametro: Descr).
[LettMatrDaFile]
Descr=Modello base
FileOrigine=c:\bht\dati\dati.dat
CodInizio=
CodLung=
QtaInizio=
QtaLung=
Imp1Inizio=
Imp1Lung=
ImpTotInizio=
ImpTotLung=
FissoSep
Separatore (solo se con separatore)
ExePrima=c:\bht\dati\RiceviDir.bat
CodArtInizIdent = "QR"
CodArtSecRic (B=cod.barre, C=cod.art)
CancFile
AddArtPrima
AddArtDopo

Il significato di questi parametri è lo stesso descritto nel paragrafo Caricamento dettagli documenti da file

Inoltre possono essere aggiunti altri parametri nel file:

  • MatrLungMin
    per forzare la lunghezza Minima della matricola, prevale sul parametro di personalizzazione: MatrLungMin
  • CodArtInizIdent
    parte iniziale del codice per identificare che si tratta di un codice articolo piuttosto che di una matricola
  • MatrSuUltRiga
    Può assumere più valori:
    U     la matricola letta viene messa sempre sull'ultimo articolo, in Inserimento, o sulla riga su cui si è posizionati, in Variazione, senza controllare la sequenza di entrata uscita - per chi non ha il codice matricola univoco -
    S     il programma cerca, sui movimenti, la matricola letta per trovare a quale articolo appartiene, se non trova la matricola già caricata, la aggiunge all'ultima riga del documento
    Se invece vale N e non trova la matricola caricata, se non ci sono ancora righe sul documento, chiede il codice articolo a cui associare la matricola.
  • SegnalNonUlt
    Se vale S (default) segnala se ci sono movimenti successivi all'attuale.

Esempio di righe da aggiungere all'INI:

[LettMatrDafile]
Descr=Lettura da file a lungh.fissa
FileOrigine=c:\bht\dati\dati.dat
CodInizio=1
CodLung=30
QtaInizio=31
QtaLung=5
CancFile="N"
'ExePrima=c:\bht\dati\RiceviDir.bat (Solo se si leggono le matricole con la penna ottica)
MatrLungMin = 14
MatrSuUltRiga = "S"
SegnalNonUlt = "S"

Modalità operative:

una volta inserita la testata del documento (movimento di magazzino, ddt, fattura) si entra nella maschera di inserimento dettagli. Se sono stati previste più modalità di caricamento (più paragrafi LettMatrDafileXXX nell'aziwin.ini) dovrà essere scelta quella del momento altrimenti il programma utilizzerà automaticamente quella di default. Per fare la scelta utilizzare, come descritto sopra, il tasto destro del mouse sull'icona di caricamento.

Nel file da caricare possono essere inserite righe nelle quali il codice è un codice articolo o un codice a barre o una matricola.

Sulla riga che inizia con un codice a barre può essere specificata una quantità > 1 ed eventualmente un prezzo, su una riga che inizia con una matricola invece la quantità rilevata dalla penna sarà sempre 1,

Il programma riconosce l'uno dall'altra dai parametri dell'INI e cioè:
se le prime lettere coincidono con quanto scritto nel parametro CodArtInizIdent allora si tratta di un codice articolo altrimenti prende in esame la lunghezza infatti il parametro MatrLungMin specifica la lunghezza minima di una matricola, i codici con lunghezza inferiore sono ritenuti codici articolo o a barre a seconda di quanto specificato nel parametro: CodArtSecRic (il default è cod. a barre)

Se, cercando l'articolo con codice o codice a barre, questo non viene trovato, il programma considera il codice letto 'una matricola' (anche se la lungh. Non è 'da matricola')

Se è un articolo fa le operazioni normali, come descritte nel paragrafo Caricamento dettagli documenti da file (cioè crea una nuova riga con quantità, prezzi letti dal file)

Se è una matricola testa il flag ' MatrSuUltRiga'

se vale U e si è in Inserimento aggiunge la matricola sull'ultima riga inserita, mentre, se si è in Variazione, aggiunge la matricola sulla riga su cui si è posizionati (se non ci sono righe chiede di inserire manualmente il codice articolo)

se vale S cerca la matricola tra le matricole dei movimenti di magazzino, se la trova ed è univoca ed è accettabile come sequenza di operazione abbina la matricola all'articolo in cui l'ha trovata , se la trova e non è compatibile fa partire una maschera che descrive l'incompatibilità e chiede conferma dell'inserimento o meno della matricola. Se si conferma, verrà ugualmente aggiunta la matricola a quelle dell'ultima riga, se invece NON si conferma l'inserimento, la riga viene creata ugualmente, sempre con quantità 1 ma senza inserire la matricola.

Se la matricola non è univoca (parametro di personalizzazione : MatrUnica=N) e viene trovata più di una compatibile con il movimento attuale compare la maschera di richiesta del codice articolo che propone il primo trovato; si consente quindi di selezionare un altro articolo al quale abbinarla e sul quale non verranno fatti controlli di sequenza di operazioni.

La stessa maschera compare se si è sulla prima riga di un documento e se la matricola non viene trovata per poter assegnare il codice articolo. Se non si è sulla prima riga, la matricola per la quale non si trova l'articolo da associare, viene associata all'articolo dell'ultima riga già presente sul documento.

Se il programma trova, nei movimenti, l'articolo a cui associare una matricola e tale articolo è già presente sul documento che si sta inserendo, la matricola verrà aggiunta a quelle di questa riga e la quantità verrà incrementata di 1 unità se il numero delle matricole inserite sulla riga è inferiore alla quantità della riga e verranno ricalcolati gli importi (nel ddt non viene ricalcolato lo sconto quantità né il numero dei colli)

Se invece, alla fine della ricerca, non trova un articolo a cui associare la matricola, questa viene scartata.

Se si crea il documento da un file che contiene codice articolo (o cod. a barre) su una riga poi sulle successive le sue matricole il programma crea una riga nuova per ogni articolo e inserisce le corrispondenti matricole (NON inserisce la matricola, ed esce il messaggio di: Matricola già inserita, se nello stesso movimento c'è già lo stesso articolo con la stessa matricola)

Es. di un file da caricare, a lunghezza fissa con una riga con codice a barre seguita da 3 matricole, un altro codice a barre seguito da 2 matricole e un ultimo codice a barre seguito da 1 matricola.
0000000000079 00001
11111111111110001 00001
11111111111110002 00001
11111111111110003 00001
0000000000086 00001
22222222222220001 00001
22222222222220002 00001
0000000000093 00001
33333333333330001 00001

Il tipo operazione per il controllo di compatibilità della sequenza dei movimenti viene assegnato in base alla causale di magazzino, tenendo conto del suo tipo movimento, del flag di Carico/Scarico, del segno, della provenienza, secondo il seguente schema:

Tipo movim | Carico Scarico | Segno | Tipo operazione assegnata
Inventario |  |  | Nessuna (cioè un mov. inventario non accetta matricola)
Interno |  |  | I Interno
Normale | S | + | S Scarico
Normale | C | - | F Reso a fornitore
Normale | S | - | Causale di rientro (nel parametro: MatrCausaliRientro): G Guasto Se provenienza è Cliente: R Reso da cliente Altrimenti C Carico
Normale | Niente | + | C Carico iniziale Il cod. causale va scritto nel param. di person. : MatrCausaliNoMovCar

Compatibilità di sequenza delle operazioni. Lo schema seguente riporta nella colonna centrale un tipo operazione e, in quelle di sinistra e di destra, quella/e compatibili per avvenire rispettivamente prima e dopo.

Operazione Precedente | Op.Corrente | Op. Successiva
Niente o F (Carico -) | C | S, I, F
C, I, G (con flag *), R | S | G, R
S | R | F, I, S
S | G | F,I
C, I, G, R | F | C
C, G, R | I | S, F

Nel movimento generato da ddt o fattura il tipo operazione è S o F o G a seconda del movimento di magazzino collegato.

(con flag *) significa che si accetta uno scarico dopo un rientro per guasto, se il parametro di personalizzazione MatrGuastoNoScar non è posto ad S, altrimenti non si accetta.


NOTE DI VARIAZIONE

Nelle causali contabili utilizzate per la registrazione delle Note di variazione è indispensabile spuntare l'apposito campo: 'Nota di variazione' (in particolare per una corretta compilazione dello Spesometro) dove verranno riportate in appositi campi.

Al momento dell'inserimento di una nota di variazione si dovrà impostare prefisso/numero e data della fattura di riferimento, cioè del documento originale che quest'ultima va a rettificare.
Il programma di inserimento prima nota considererà tali dati obbligatori tranne che il controllo non venga disabilitato dal parametro di personalizzazione: NotaVarDataObblig

Solo se la nota di variazione fa riferimento a più fatture oppure non è possibile indicare il riferimento alla fattura, si dovrà lasciare bianco il numero e valorizzare la data con 31/12/aa dove aa è l'anno di registrazione.

Caso di Cliente/Fornitore in cui sia stato impostato a Sempre il campo 'Comunic. rilevante ai fini Iva': Per quanto riguarda le note di credito che hanno il riferimento alla fattura, queste verranno stornate dal rispettivo importo, per quelle invece che non sono collegate, verranno estratte TUTTE con data di riferimento 31/12/aa (dove aa è l'anno in cui è stata emessa).

Il programma controlla poi se esiste un documento, dello stesso Cliente/Fornitore, con Pref/Numero e data documento uguali a quelli della 'fattura di riferimento'.
Questo controllo potrà essere disabilitato dal parametro di personalizzazione: NotaVarVerEsiste

Se il documento viene preparato da gestione Fatture, tali dati vanno inseriti nella maschera '(2)Altri dati' : 'Fattura di riferimento'.
Quando si tratta di una nota di credito ottenuta come evasione di ddt di reso, occorre entrare in variazione del documento e compilare tali campi della Stampa e Contabilizzazione.
La Contabilizzazione delle Note di Variazione provvederà a copiare Pre/Numero e data della fattura di riferimento sui campi corrispondenti della registrazione di prima nota e imposterà i dati del documento uguali al protocollo. Se invece si crea il parametro di personalizzazione CopiaOrigInDoc con valore S, i dati della della fattura di riferimento verranno copiati anche sui dati del documento (com'era fino alla versione 3.02a)

Note non più valide dalla Comunicazione 2012:
I controlli suddetti sono diretti ad una corretta compilazione della Comunicazione delle Operazioni rilevanti ai fini iva, dove si deve collegare la fattura alla nota per capire se l'importo è o meno tra quelli da comunicare (in caso affermativo verranno comunicate entrambe, se appartenenti allo stesso anno, oppure solo la nota, con il riferimento alla fattura di origine, se questa era stata comunicata nell'anno precedente).
Poichè nella preparazione della Comunicazione di un determinato anno (fatta entro il 30/04 dell'anno successivo) si terrà conto anche di tutte le note di variazione emesse nel nuovo anno ma riferite a fatture dell'anno precedente, una volta preparata la Comunicazione, è indispensabile non registrare Note di V. con data precedente alla data della Comunicazione.
IMPORTANTE: alla luce di quanto scritto sopra, NON si dovranno inserire, in fatture di vendita, righe negative a storno di fatture emesse in precedenza (in particolare se l'importo di fattura+nota rientra in quelli da comunicare). Il programma di estrazione dati darà un messaggio se trova una riga negativa all' interno di una fattura per segnalare l'anomalia, l'utente valuterà se la registrazione è corretta o meno.
Inoltre se si emette una nota di variazione relativa a più fatture fatte nell'anno con importo tale da andare a variare lo 'stato' delle fatture per quanto riguarda l'obbligo o meno di essere trasmesse (>3000 €), occorrerà entrare sulle singole fatture e nota, con il programma di 'Input prima Nota' e impostare il campo 'Op.rilevante ai fini Iva' con i valori: da Ignorare (cioè da non trasmettere) o Forzata (da trasmettere sempre). Questo perchè, diversamente, il programma di estrazione, NON potrà valutare come comportarsi.
Stesso ragionamento vale per le Note Var. che si riferiscono a fatture emesse in anni precedenti o a una fattura appartenente a un contratto non comunicato, il campo 'Op.rilevante ai fini Iva' dovrà essere impostato col valore giusto a seconda che sia stata trasmessa anche solo una delle fatture che si vanno a rettificare.


PRORATA

Il Pro Rata è costituito da una percentuale di abbattimento dell'iva sugli acquisti determinata dal rapporto tra Vendite in Esenzione e Acquisti soggetti.

Sulla tabella dei Dati iniziali Iva, è possibile impostare percentuali di detraibilità iva acquisti diverse per le Chiusure periodiche e per l'annuale.

Se invece la ditta ha più registri iva acquisti di cui qualcuno completamente detraibile e qualcuno con prorata, occorre mettere la percentuale di prorata direttamente in Gestione prefissi e numeratori acquisti sulla riga di ogni prefisso.

In fase di stampa chiusura iva, verranno considerate prioritarie le eventuali percentuali presenti in 'prefissi e numeratori' , altrimenti si prendono quelle impostate in Dati iniziali Iva.

Se la ditta ha più attività iva, inserire una percentuale per ogni attività.

La stampa della Chiusura iva evidenzierà la % e l'ammontare del Prorata.

Prorata agricolo
Il produttore agricolo diviene debitore dell'imposta nei confronti dell'Erario per la differenza tra le aliquote applicate ai singoli prodotti e le aliquote corrispondenti alle percentuali di compensazione detratte.

Ne consegue che per determinare la detrazione spettante in sede di liquidazione dell'iva, i produttori agricoli applicheranno all'ammontare complessivo imponibile delle cessioni di prodotti, la percentuale di compensazione corrispondente al prodotto ceduto.

Dall'imposta riscossa per rivalsa dovrà essere detratta l'imposta come sopra determinata e sarà così calcolata l'imposta da versare in sede di liquidazione periodica.
In pratica:
In presenza di regime iva per produttori agricoli, la percentuale di detraibilità iva acquisti va messa sempre a 0.

In ogni codice iva è possibile inserire una percentuale di detraibilità iva agricola in quanto per la stessa aliquota si possono avere % diverse a seconda del prodotto che si sta vendendo (a seconda che sia stato prodotto direttamente o no).

La percentuale di detraibilità, calcolata dal programma (in base alle vendite+corrispettivi) è legata alla differenza tra il totale iva delle vendite di prodotti agricoli e quella ricavata applicando agli stessi imponibili delle vendite, le percentuali di detraibilità (compensazione) corrispondenti.

Es. se si vende
uva (iva 10% perc.compensazione 4%) per 1.000.000
miele (iva 10% perc.compensazione 9%) per 1.000.000
kiwi (iva 4% perc.compensazione 4%) per 1.000.000 avrò la seguente liquidazione:
Iva 10% su UVA: 100.000
Iva 10% su MIELE 100.000
Iva 4% su KIWI 40.000
Totale iva 240.000

Iva detrazione forfait:
4% su 2.000.000: 80.000 (uva e kiwi)
9% su 1.000.000: 90.000 (miele)

Da versare 240.000-170.000= 70.000

Per quanto riguarda la registrazione degli acquisti Intra Cee, vedere produttori agricoli in Regime Speciale.

Calcolo della percentuale di Prorata

Il programma non fa il calcolo automatico della percentuale per cui dovrà essere calcolata manualmente.

La legge stabilisce che la percentuale di detraibilità PD è data dal rapporto tra l'ammontare delle operazioni che danno diritto a detrazione (comprendenti sia le operazioni imponibili (OI) che le operazioni non soggette ma assimilate ad operazioni imponibili ai fini delle detrazioni (OA) e lo stesso ammontare aumentato delle operazioni esenti (OE) effettuate nell'anno medesimo:

OI+OA
PD = ---------------
OI+OA+OE


RAEE (Rifiuti apparecch.elettriche ed elettroniche)

La gestione (smaltimento) di questo tipo di rifiuti è regolamentata dal decreto RAEE (DL n.151 del 25 Luglio 2005).
La "Direttiva RAEE" è basata sul principio secondo il quale chi inquina paga. Per ottemperare questo principio, il finanziamento e l'organizzazione della raccolta e del trattamento dei RAEE sono posti in capo ai fabbricanti di apparecchiature elettriche ed elettroniche, a partire dalla data di entrata in vigore in Italia del "Decreto RAEE", il 1° gennaio 2008. Per sostenere questi nuovi costi, i fabbricanti saranno liberi di far pagare un eco-contributo al momento dell'acquisto di un'apparecchiatura nuova.
Tale contributo, il cui importo varia per tipologia di merce, graverà sul costo del prodotto fino ad arrivare al consumatore finale.
Tale contributo può, a discrezione del produttore, diventare parte integrante del prezzo di vendita del prodotto oppure può essere evidenziato a parte e sommato al 'vecchio' prezzo di vendita.

La procedura consente di associare ad ogni articolo di magazzino un codice Raee al quale dovrà essere attribuito un prezzo sul listino base.

Ogni volta che si movimenterà in Caricamento movimenti, Preventivi, Ordini, Ddt e Fatture un articolo con codice Raee associato, verrà creata in automatico una nuova riga con il codice articolo Raee, quantità uguale a quella dell'articolo movimentato, prezzo unitario uguale al valore del listino base dell' articolo Raee /senza sconti.

E' possibile però stabilire che il programma non crei la riga Raee in corrispondenza di movimenti (ddt o fatture) fatti con determinate causali di magazzino. Queste andranno elencate nel parametro di personalizzazione:
NoRaeeAutom

Se si desidera visualizzare, a fianco di ogni articolo soggetto a contributo Raee, anche l'importo del Raee associato, occorre entrare nel programma di Gestione Personalizzazioni, cercare se già esiste, una riga con
Gruppo: Help
Parametro: ArticoloCampi
Valore: un elenco di campi dell'articolo. Se la riga non c'è la si può creare e, in Valore, si metterà o si aggiungerà a quanto già presente, la scritta: ,RAEE

Se il programma si interrompe, per un errore, durante l' inserimento di un articolo con Raee in un documento (movim. di magazzino, ordine, ddt, fattura), per cui non riesce a creare la riga dell'articolo Raee, occorre, rientrando sul documento, completare tale riga.

Dopo una interruzione, se si Cancella la riga Raee, è indispensabile Cancellare subito anche la riga dell'articolo che l'ha creata in automatico.

E' indispensabile, in presenza di un articolo con Raee, mantenere l'ordine: riga articolo e subito dopo, riga articolo raee corrispondente. Quando si cancella da un documento la riga di un articolo con Raee, il programma cancella automaticamente anche la riga Raee ad essa collegata.

In fase di evasione manuale di ordine o preventivo, quando si compila la quantità da evadere su una riga di articolo con Raee, viene impostata in automatico, la stessa quantità anche sulla riga dell'articolo Raee. Stessa cosa per l'evasione a saldo. Se si interrompe l'evasione di un documento con articoli Raee e sul documento di evasione è stata creata la riga articolo ma non la sua corrispondente riga Raee, dopo aver eseguito il ripristino, si consiglia di cancellare il documento incompleto e di ripetere l'evasione.


REGIME DEL MARGINE

Regime IVA applicabile ai soggetti che commerciano beni usati, avente il fine di evitare la doppia o reiterata imposizione per i beni che, dopo la prima uscita dal circuito commerciale, vengono ceduti ad un soggetto passivo d'imposta per la successiva rivendita. Tale regime ha fondamentalmente lo scopo di evitare che un bene, già colpito dall'imposta (perché, ad esempio, giunto al consumatore finale), nel momento in cui viene venduto di nuovo, venga tassato nuovamente, con una reiterazione dell'imposta contrastante con i principi fondamentali del tributo

Esistono tre metodi per la determinazione del regime del margine: il metodo analitico (o normale), il metodo forfetario ed il metodo del margine globale.
La procedura gestisce quest'ultimo.

Metodo Globale

Questo metodo prevede che l'imposta non sia determinata in relazione a ciascuna operazione ma con riferimento a tutte le operazioni compiute in un periodo di imposta (mese o trimestre).

Il margine lordo è dato dalla differenza tra l'ammontare complessivo delle vendite e quello degli acquisti (comprese spese di riparazione e accessorie) effettuati nel periodo di riferimento.

Nel caso di margine negativo, questo va utilizzato per abbattere o ridurre eventuali margini positivi dei periodi successivi.

Calcolo dell' eventuale debito iva da cessione beni usati (si fa se il margine calcolato è positivo):

Gli importi delle cessioni del periodo vengono raggruppati per aliquota del margine e verrà calcolata la % di incidenza di ogni importo sul margine totale del periodo. Successivamente si divide il margine lordo in tante parti quante sono le aliquote di cui sopra, applicando le percentuali calcolate.

Ogni importo ottenuto viene scorporato ottenendo un imponibile e un'imposta. La somma delle imposte costituisce il debito iva da cessione beni usati da sommare in Chiusura Iva all'imposta delle vendite per ottenere l'iva a debito totale del periodo.

OPERATIVITA' DEL PROGRAMMA

  • Creare un nuovo prefisso per registro iva acquisti e uno per le vendite(cessioni) di beni usati (nell'elenco dei prefissi - dati generali azienda (parametri))
  • In Gestione Prefissi e numeratori, inserire per il registro vendite e per gli acquisti, una nuova riga con questo prefisso e mettere a Si il flag Regime del margine
  • Gestione causali: creare delle causali apposite per le registrazioni delle cessioni e degli acquisti di beni usati, spuntando il flag: Regime del margine e compilare opportunamente i dati che riguardano questo regime particolare. Creare causali diverse per cessioni Normali o Esportazioni, per acquisti Normali, Importazioni, Spese accessorie, Trasporti. Nella causale è obbligatorio compilare il prefisso, che dovrà essere stato creato per il Regime del Margine.
  • In corrispondenza ai codici esenzioni da utilizzarsi per la Cessione di beni usati, con la Gestione dei codici iva, compilare il campo: aliquota per il regime del margine. Questa aliquota servirà per calcolare l'iva a debito derivata dall'elaborazione del margine.
  • Con la Gestione Beni Usati inserire codice e natura dei beni acquistati e venduti.
  • Prima Nota: quando da prima nota verranno inserite fatture di acquisto e vendita con causali per iva del margine, verrà chiesto, in ogni riga di dettaglio, il codice del bene al quale si riferisce.
    Le fatture di cessione di un bene usato vanno registrate in esenzione di iva, con codici iva ai quali sarà stato preventivamente associata l'aliquota per il Regime del margine.

    VENDITE
  • Gestione Tipi documento: si possono creare dei tipi documento fattura con flag Regime del Margine. In essi è obbligatorio impostare una causale e un prefisso creati appositamente per tale regime.
  • Emissione fatture per cessione beni usati: in ogni riga di dettaglio viene chiesto il codice del bene usato venduto e si controlla che sul codice iva utilizzato sia stata inserita l'aliquota per il regime del margine (il codice iva deve essere di tipo Esente).
    In tali fatture NON dovranno comparire né bolli né altre spese.

    Registri Iva - Le registrazioni fatte con le causali suddette non verranno stampate sui registri iva normali ma dovranno essere stampate a parte utilizzando la funzione Stampa registri iva Beni Usati.

    Chiusura iva
    Le registrazioni fatte con le causali suddette non verranno sommate alle altre 'nel modo standard' ma si somma, nel riepilogo finale, sul totale dell'Iva a Debito l'eventuale 'Debito iva derivato da cessione di beni usati'.
    Per ottenere questo importo si calcola il Margine del periodo e, se è positivo lo si evidenzia in chiusura iva, nel periodo in cui viene fatta la vendita, in: Debito Iva da Cessione di Beni Usati .
    Il prospetto del calcolo viene evidenziato sul Registro Vendite IVA del Margine.

    Se invece c'è un credito del Margine, viene memorizzato tra i dati riepilogativi del periodo (Iva periodica) per poterlo poi utilizzare nel calcolo del periodo successivo.

    Sugli Acquisti , le registrazioni dell'iva del margine non si sommano.

Nella chiusura iva di fine anno viene rifatto il calcolo su tutti i movimenti dell'anno e viene stampato, al termine della chiusura iva, il prospetto che si stampa mensilmente sul REGISTRO iva Vendite del margine.

Se c'è un credito del Margine va portato ad anno nuovo, come si fa per il credito iniziale iva

NOTA
Non è detto che l'iva del margine calcolata dalla dichiarazione annuale sia esattamente la somma dei risultati dei vari periodi (questo perchè si fanno delle proporzioni poi degli scorpori su dei totali (somme dei mov. dell'anno))

Nella comunicazione ANNUALE IVA invece, nell'iva a debito c'è esattamente la somma dell' IVA a debito dei vari periodi in quanto si sommano gli importi memorizzati dalle chiusure iva periodiche.


REVERSE CHARGE

La legge finanziaria per il 2007 (legge n.296 del 27 dicembre 2006) prevede l'applicazione del reverse-charge per prestazioni di servizi nel settore dell'edilizia. Successivamente è stato estesa l'applicazione anche in corrispondenza all'acquisto di telefoni cellulari e componenti dei personal computer.

La fattura, che viene emessa dal prestatore senza l'addebito dell'imposta, dovrà essere integrata indicando sul documento l'aliquota ordinaria e la relativa imposta.
Va poi registrata sul registro degli acquisti e inoltre anche su quello delle vendite, entro il mese di ricevimento della fattura stessa.
Si rende quindi necessario registrare anche un giroconto per sistemare i saldi dei conti interessati (vedi esempio in fondo).

A discrezione dell'utente è possibile registrare le fatture suddette sullo stesso registro delle fatture 'normali' e quindi con numerazione consecutiva ad esse, oppure su registri appositi; in quest'ultima ipotesi il prefisso può essere specificato nella causale stessa.

Al fine di evidenziare, in sede di Chiusura Iva, l'iva derivata da questo tipo di registrazioni, è indispensabile:

  • creare due causali apposite, una per fattura di acquisto e una per fattura di vendita, nelle quali andrà evidenziato che si tratta di Reverse Charge.
  • Nel caso di acquisto di telefonini etc. si può verificare che sulla stessa fattura ci sia materiale 'normale' e altro che deve seguire il R.C., per cui, nelle causali suddette si dovrà scegliere il tipo Reverse Charge 'misto'.

Se si impostano le tabelle dati in modo opportuno, come descritto in seguito, il programma al termine della registrazione della fattura di acquisto, fatta con una causale di tipo 'Reverse-Charge', provvederà automaticamente a registrare la fattura di vendita e il giroconto che storna l'iva dal fornitore Reverse-Charge, l'imponibile dal conto di ricavo e l'importo totale della fattura dal cliente d'appoggio per RC.

  1. Creare un cliente d'appoggio per fatture Reverse-Charge e, nella sezione Contabilità (campo 'c/partita') , inserire il conto di ricavo (Transitorio Reverse-Charge)
    (Una alternativa può essere mettere questo conto sulla causale Vendite Reverse-Charge)
  2. Sull'anagrafica del fornitore Reverse-Charge, nella sezione Contabilità, inserire il codice del cliente di appoggio Reverse-Charge che servirà per la registrazione della fattura di vendita.
    L'alternativa è mettere questo codice, sulla causale utilizzata per la registrazione della fattura di vendita nel campo: partita codice.
  3. Creare una causale per il giroconto
  4. Creare una causale per Vendita Reverse-Charge (nel campo Reverse C. impostare Si) e nel campo: causale collegata mettere la causale del giroconto, nel campo Contropartita codice inserire il conto di ricavo (Transitorio Reverse-Charge), l'alternativa può essere mettere questo conto sul cliente d'appoggio per fatture Reverse-Charge.
    Eventualmente mettere il conto iva da utilizzare, il prefisso e nel campo: partita codice, il codice del cliente da utilizzare nella registrazione: cliente d'appoggio per fatture Reverse-Charge.
  5. Creare una causale per Acquisto Reverse-Charge (nel campo Reverse C. impostare Si o Mista a seconda delle necessità) e nel campo: causale collegata mettere il codice della causale Vendita Reverse-Charge (eventualmente mettere il conto iva da utilizzare e il prefisso)
  6. Se si stanno predisponendo i dati per registrare una fattura di R.C. misto, occorre predisporre codici iva diversi (quelli utilizzati nelle righe R.C. dovranno avere il campo R.C. a Si) per differenziare le righe che, nella stessa fattura, seguono il Reverse Charge da quelle 'no' in modo tale che il programma generi la fattura di vendita e il giroconto solo per la parte R.C.

Per quanto riguarda il conto iva che verrà utilizzato, potrà essere impostato sulla causale (punto 4) oppure il programma utilizzerà il conto iva c/acquisti impostato nella tabella dei conti comuni.
(Nel caso di acquisto indetraibile vedere intracee)

Esempio di registrazione:

1)

Fattura del fornitore | Dare | Avere
Fornitore Reverse-Charge |  | 1200
Merci c/Acquisti | 1000 |
Iva Acquisti (Reverse-Charge) | 200 |

Il programma in automatico registrerà:

Fattura di vendita fittizia | Dare | Avere
Cliente transit. Reverse-Charge | 1200 |
Ricavo Merci (Reverse-Charge) |  | 1000
Iva Vendite (Reverse-Charge) |  | 200

e

Giroconto | Dare | Avere
Fornitore Reverse-Charge | 200 |
Ricavo Merci (Reverse-Charge) | 1000 |
Cliente transit. (Reverse-Charge) |  | 1200

1A)
Se si vuole utilizzare lo stesso conto transitorio (merci c/transitorio) sia nella registrazione della fattura d'acquisto sia nell'autofattura, basta non compilare i campi: 'contropartita codice', nella causale autofattura nè 'contropartita' nell'anagrafica del Cliente transit. Reverse-Charge.
In questo caso le registrazioni saranno:

Fattura del fornitore | Dare | Avere
Fornitore Reverse-Charge |  | 1200
Merci c/transitorio | 1000 |
Iva Acquisti | 200 |

Il programma in automatico registrerà:

Autofattura (Fattura di vendita fittizia) | Dare | Avere
Cliente transitorio Reverse-Charge | 1200 |
Merci c/transitorio |  | 1000
Iva Vendite |  | 200

e

Giroconto | Dare | Avere
Fornitore Reverse-Charge | 1200 |
Cliente transitorio Reverse-Charge |  | 1200


RITENUTA D'ACCONTO E CASSA PREVIDENZA

Calcolo Cassa Previdenza

Calcolo Ritenuta di Acconto in Fatture Emesse

Fatture Emesse dalla procedura di fatturazione

Il programma prevede il calcolo e la successiva registrazione in contabilità della Ritenuta d'acconto sulle fatture emesse.

In particolare questa procedura serve per il calcolo del 4% di Ritenuta d'acconto da evidenziare sulle fatture emesse nei confronti di imprese che effettuano interventi sulla base di contratti d'appalto o d'opera nei confronti di condomini.

Il 4% (o comunque la % di ritenuta d'acconto) viene applicata sulla somma degli imponibili che concorrono alla formazione dell' 'imponibile per ritenuta d'acconto'.

Per attivare il calcolo automatico della ritenuta occorre:

  • Impostare la % Ritenuta d'acconto:
    - Se è uguale per tutti i clienti: in Parametri comuni (Dati generali azienda-parametri)
    In questo modo verrà copiata in automatico sul cliente, ogni volta che se ne crea uno nuovo.
    - Viceversa se solo se per alcuni clienti va calcolata la Ritenuta d'acconto, la percentuale andrà messa direttamente nelle rispettive anagrafiche.
    - Un'altra strada può essere quella di inserire la % per il calcolo, sulla causale di contabilità 'Fattura Clienti' . In questo modo però il programma ne terrà conto solo per fatture dirette/accompagnatorie fatte con tipi documento che contengono quella causale.
    Nota: nel caso la ritenuta d'acconto debba essere calcolata NON sul 100% ma su una diversa percentuale dell' imponibile si dovrà impostare nel campo percentuale un numero ZZZZ,XXY ottenuto in questo modo:
    ZZZZ è la percentuale ritenuta moltiplicata per 100 , XX è la parte intera della percentuale dell'imponibile su cui va applicata la ritenuta, Y l'eventuale parte decimale
    (ES. 2300,010 corrisponde al 23% sul 1% dell' imponibile
    2300,500 corrisponde al 23% sul 50% dell' imponibile
    2300,505 corrisponde al 23% sul 50,5% dell' imponibile
  • Sui clienti interessati impostare a SI il campo del quadro di '5-Fatturazione' : 'Sogg. a Rit.d'acconto'
  • Creare, con la gestione conti, il conto Ritenute e inserire il codice di tale conto nella tabella dei conti comuni (Dati generali azienda-parametri) nel campo : Rit. d'acconto Vendite
    In alternativa il codice di tale conto può essere messo nel campo Partita Codice della causale da utilizzare per la registrazione della Ritenuta.
  • Creare una causale di contabilità di tipo 'Generica' per la registrazione della Ritenuta d'acconto
    (Mettere Segno Dare ed eventualmente, nel campo Partita Codice, mettere il codice del conto ritenute)
  • in Causali comuni (Dati generali azienda-parametri) compilare il campo: 'Ritenuta d'acconto' con il codice della causale di cui al punto precedente
    Un'alternativa può essere inserire questo codice causale nel campo 'Causale Ritenute' della causale con la quale verrà generato il movimento della fattura in contabilità (Contabilizzazione fatture)
  • Al fine di una corretta compilazione della fattura elettronica occorre aver compilato correttamente nella funzione Dati generali azienda (Parametri e utilità - Dati azienda e parametri) nella sezione FattElettronica il campo: Causale pag. 770 (quella del Mod CU)

La percentuale, se inserita, verrà poi memorizzata sul documento, a partire dall'ordine e in fase di stampa fattura verrà stampato l'importo della ritenuta.

E' possibile, per ogni riga presente sui documenti, dire se questa concorre o meno a formare l'imponibile su cui calcolare l'importo della ritenuta. Stessa cosa vale per le spese, per le quali esiste un flag che si può preimpostare direttamente in gestione spese.

La contabilizzazione di una fattura con ritenuta creerà, oltre alla registrazione della fattura, anche quella della Ritenuta.
Se mancano causale Ritenuta o conto Ritenuta, al termine della Contabilizzazione verrà data una segnalazione. La Contabilizzazione verrà comunque fatta utilizzando il codice di un altro conto letto in tabella tra quelli presenti. In questo caso la registrazione andrà poi corretta manualmente da prima nota.

Stampa dell'importo della Ritenuta d'acconto sui documenti, Preventivi, ordini, ddt e fatture.

Se non si modificano i filtri in uso, verrà stampata una riga nel corpo, dove si evidenzia la percentuale e l'importo della Ritenuta (è indispensabile che nel filtro non sia stata scritta, nemmeno in una riga disabilitata con 2 nella colonna opzioni, la variabile T_RitAcc).

Altrimenti sul filtro si può aggiungere la stampa dell'importo della ritenuta in una casella apposita del piede utilizzando la variabile T_RitAcc.

Un'ultima soluzione può essere quella di inserire nel corpo le righe per la stampa della Ritenuta con sottosezione 30. In questo modo le due righe verranno stampate solo se T_RitAcc è diverso da 0.

Es. Prima riga:
Riga di Corpo
PosY=0,5
PosX=27
Opzione = 0
Larghezza=63
Campo=
Fisso="Ritenuta d'acconto ai sensi dell'art.25-ter del dpr …"

Es. Seconda riga:
Riga di Corpo
PosY=0,5
PosX=160
Opzione = 0
Larghezza=22
Campo=T_RitAcc
Format: Fmon etc.

Nei filtri CssStd di ordini e fatture dell' AziMenu.mdb e AziMenAg.mdb sono state inserite, per un certo periodo, due righe di questo tipo, come esempio, che si possono abilitare mettendo uno 0 al posto del 2 nella colonna sottosezione. Per stampare nel modo standard la riga che evidenzia la ritenuta d'acconto, occorre cancellare, da tali filtri, queste righe, nonostante siano disabilitate.

Se non si vuole evidenziare in stampa l'importo della Ritenuta d'acconto (es. su preventivi e ordini), basta inserire nel filtro di stampa, una riga nel piede che nella colonna 'Campo' contenga la variabile T_RitAcc e in quella 'Lunghezza' contenga 0.

E' possibile attivare il Parametro di personalizzazione RitAccDescr nel quale scrivere la frase di descrizione della ritenuta sulla fattura

INPUT PRIMA NOTA (Fatture Emesse)

Vedi note che seguono, relative a R.A. su fatture ricevute.

Calcolo Ritenuta di Acconto in Fatture ricevute

INPUT PRIMA NOTA (Fatture di Acquisto)

Il programma consente, al termine dell' inserimento di una fattura d'acquisto, di generare in automatico la registrazione della Ritenuta d'Acconto per i fornitori che lo richiedono.

La registrazione verrà generata se:

  • Sul fornitore/cliente è impostato il flag di Soggetto Ritenuta d'acconto a Si,
  • se c'è una percentuale di Ritenuta d'acconto sul fornitore/cliente stesso o sulla causale utilizzata per la registrazione della fattura o nell'apposito campo in Parametri comuni (Dati generali azienda-parametri)
  • Se si desidera fare una seconda registrazione per la ritenuta (vedi parametro di personalizzazione RitAccFornAutom ), creare una causale Ritenuta (Causale di tipo 'Generica' , segno Dare, eventualmente Contropartita: conto Ritenute)
    POI sulla causale della fattura compilare il campo: Causale ritenuta collegata
  • Creare un Conto Ritenute e scrivere il suo codice nella tabella dei conti comuni (Dati generali azienda, parametri) nel campo 'Rit.acconto acquisti', o in Contropartita sulla causale Ritenuta
  • Gestione conti
    Se ci sono le condizioni per calcolare la Ritenuta d'acconto, la determinazione dell'imponibile, sul quale calcolarla, avviene sommando gli importi delle righe di dettaglio nelle quali è spuntato il segnale 'Sogg.ritenuta d'acconto'. Tale segnale viene letto dall'anagrafica del conto. E' perciò possibile preimpostare i dati in modo tale che solo determinati conti concorrano a formare l'imponibile ritenuta.

Se c'è la necessità che, nella registrazione di una fattura di un fornitore con ritenuta d'acconto, non tutte le righe di costo aumentino l'imponibile ritenuta, occorre fare quanto segue:

  • Creare il parametro di personalizzazione DetSoggRitAcc con valore N in modo che, in generale, nessun conto accumuli imponibile.
  • Andare in gestione dei conti che generano imponibile e mettere il flag di Soggetto.

Viceversa per chi non crea il parametro, la Rit. d'acconto verrà calcolata per tutti i conti (se sono valide le altre condizioni di cui sopra) tranne per quelli che hanno il flag a No.

Infine è indispensabile impostare il parametro di personalizzazione: RitAccFornAutom

  • a 1 si ottiene la registrazione automatica di una riga, per l'importo della ritenuta d'acconto, nella stessa fattura d'acquisto.
    La riga verrà generata se: sul fornitore è impostato il flag di Soggetto Ritenuta d'acconto a Si, se c'è una percentuale di Ritenuta d'acconto sul fornitore stesso o sulla causale utilizzata per la registrazione della fattura, se è presente il conto Ritenuta d'acconto in tabella dei conti comuni (Dati generali azienda, parametri).
  • a 2 si ottiene la generazione automatica di una seconda registrazione con la Ritenuta d'Acconto.

(L'automatismo per la creazione della Ritenuta, funziona solo in inserimento, successivamente le registrazioni sono indipendenti)

Calcolo Cassa Previdenza

Il programma di emissione fattura è in grado di calcolare e stampare in automatico l'importo della Cassa Previdenza ( Enasarco - Enpav etc.)
Per attivare il calcolo occorre:

  • Creare una Spesa in percentuale o a importo, con Tipo evasione: Singola e con il campo Calcolo Cassa Previdenza impostato a SI
    La percentuale impostata deve essere quella corretta per la Cassa Previdenza.

  • Inserire il codice di tale Spesa in Tabella generale (Causali comuni)

  • Controllare che sul cliente, quadro di fatturazione, sia impostato a Si il campo 'Soggetto a Cassa Previdenza'

  • Per una emissione corretta della fattura elettronica, compilare nella maschera 'Fatt.Elettr' della funzione 'Dati generali azienda -parametri' il campo Tipo Cassa previdenza con il codice opportuno

I programmi di Gestione documenti (preventivi, ordini, ddt, fatture), in corrispondenza a clienti con il flag di Sogg. a Cassa previdenza a Si, caricheranno in automatico tale spesa nel quadro Spese.
L'imponibile per il calcolo è lo stesso utilizzato per la Ritenuta d'acconto.
La percentuale e l'aliquota da applicare viene letta dal codice Spesa.

Dal momento che la spesa viene portata sui documenti se, nel tempo, variano aliquota iva o percentuale della Cassa Previdenza, queste possono essere variate direttamente sul codice spesa. Sui documenti già registrati rimarranno invece i valori precedenti.

Su questa spesa NON verrà mai applicato lo sconto pagamento.

L'importo della Cassa previdenza viene aggiunto all'imponibile della fattura.

Per prevedere l' ENASARCO e tutte le altre casse che non prevedono un aumento dell'imponibile ma solo una diminuzione occorre creare il parametro di personalizzazione CassaPrevNoImpon (Gruppo: Tutti) impostato a S.
In questo modo l’importo relativo NON verrà sommato all'imponibile ma sottratto dall'importo a pagare.

Stampa Cassa Previdenza sui documenti
Se non si modificano i filtri in uso, verrà stampata una riga nel corpo, dove si evidenzia la percentuale e l'importo.
Oppure si può inserire nel corpo delle righe personalizzate per la stampa con sottosezione 31
(Es. in una riga del filtro, nella posizione dove si stampa la descrizione articolo, mettere in
'campo': =$union("Cassa Prev. - perc. ";C_SpesePercS;"% su imp. ";C_ImpCassaPrevS)
poi servirà un'altra riga dove stampare il totale (in 'campo' C_TotCassaPrev) nella colonna dell'importo di riga

Altrimenti sul filtro si può aggiungere la stampa dell'importo direttamente nel piede.


SCONTI SUI DOCUMENTI (MODALITA' DI CALCOLO)

Tutti gli sconti sono digitati nella forma 2+1.3+4 in una stringa di 15 caratteri e, in ogni gestione, segue la visualizzazione dello sconto risultante calcolato in cascata.

Sconti abilitati:

Cliente

Quantità (sconto e prezzo)

Articolo

Listino/Articolo (o Listino) Sul listino c'è un flag che dice se lo sconto è sostitutivo o si aggiunge a quello dell' articolo. Lo sconto listino non è abilitato nella gestione Taglia/Colore.

Tabelle

  • Cliente / Articolo(sconto e/o prezzo)
  • Categoria Cliente / Articolo(sconto e/o prezzo)
  • Cliente / Gruppo-Sottogr. Articolo
  • Categ.Cliente / Gruppo-Sott. Articolo

(in queste tabelle viene gestito un flag che dice se lo sconto sostituisce lo sconto articolo e un altro che dice se sostituisce lo sconto cliente ). Prenderà così il posto di quello(i) che sostituisce oppure si sommerà ad essi come ulteriore sconto.

Su ogni Tipo documento (utilizzato per l'emissione dei documenti di Vendita) c'è un ulteriore richiesta per stabilire quale dei due sconti tabellari 5b o 5c è prioritario rispetto all'altro.

Pagamento
Si può impostare nella tabella della condizione di pagamento. Viene calcolato a piede fattura.

Metodo per assegnare gli sconti (prezzi) sui documenti:

Se è stato impostato un codice listino, si cerca subito se c'è un prezzo promozione (controllo che la data sia compresa) e se lo trova si prende quello come prezzo di listino e si considera unicamente lo sconto cliente se previsto dal listino promozione.

Viceversa si cerca il prezzo di Listino e si memorizza anche lo sconto articolo e listino secondo le modalità previste sul listino, si ottiene così lo sconto articolo.

Sconto Quantità
Se esiste si imposta. Se sulla tabella è impostato anche un prezzo, quest' ultimo diventa il prezzo di listino, verranno sbiancati tutti gli sconti tranne quello cliente se previsto da tabella sconti quantità.

Sconto cliente
Viene impostato in testata, preso dall'anagrafica cliente, riportato su ogni dettaglio con possibilità di variarlo. Alla variazione di tale campo in testata seguirà richiesta di aggiornamento di tutti i dettagli che lo avevano uguale.

Sconto Tabellare
Si cerca lo sconto (che si sommerà allo sconto articolo o lo sostituirà ) o un prezzo di listino, nell'ordine, sulle tabelle:

  • Cliente/Articolo
  • Sconto cliente
  • Categoria Cliente / Articolo
  • Cliente / Gruppo-Sott. Articolo
  • Categ. Cliente / Gruppo-Sott. Articolo

NOTA: per azzerare su un articolo lo sconto del listino si metterà 0 nel campo sconto listino che verrà riconosciuto e distinto dal campo vuoto che invece vuol dire che prendo lo sconto dalla tabella Listini.

Per (ordini a fornitore) carichi da fornitore se è prevista la gestione degli articoli fornitori lo sconto articolo può essere lì e se il valore unitario lo prendo dal costo ultimo lo devo prendere da questo archivio: campo prezzo.

Se si varia la quantità sui dettagli o si preme il pulsante di aiuto posto a fianco della quantità:
se c'è un prezzo promozione non fa niente altrimenti cerca lo sconto quantità se diverso da quello precedente.

Ricalcolo sconti:
ricalcola come la prima volta senza però reimpostare il prezzo di listino.

Ricalcolo listino
reimposta prezzi e sconti.

Priorità per la ricerca dello sconto quantità:

articolo/cliente
articolo / cat.cliente
poi dipende dal flag che stabilisce la priorità a livello di tipo documento:
se prima articolo si cerca quello e solo quello
se gruppo sott/cliente .., gruppo/sott.-cat.cliente , gruppo/sott. Articolo

Gestione sconti in Ordini di Acquisto

Non viene considerato lo sconto Quantità

Sconto articolo: se è stato impostato sulla causale di magazzino che il prezzo unitario deriva dall'ultimo costo, il programma cerca il prezzo in tabella Articoli-Fornitore, se non lo trova allora lo sconto viene lasciato a 0 e si imposta il prezzo uguale al costo ultimo.
Viceversa, se si trova il prezzo in Articoli-Fornitore, si prende di lì sia il prezzo che lo sconto.
Se invece il prezzo viene ricavato da un listino si segue la stessa metodologia già descritta per le vendite.
Per eliminare lo sconto articolo basta dire che lo sconto listino sostituisce quello articolo.
Sconto tabellare: come per le vendite con il fornitore al posto del cliente.


SCONTI IN DETTAGLI CON LIVELLI

Dato il codice articolo estrae gli sconti e sono modificabile SOLO in Creazione (nel caso dei livelli non ci sono gli sconti sul listino/articolo ma solo sul Listino)

Entrando nei livelli questi sono modificabili e li riporta in tutte le righe. Al ritorno li riporta sul dettaglio principale e si ricalcola il prezzo totale e l'unitario a livello di riga principale

Lo sconto quantità è cumulativo di tutte le quantità. Se c'è lo sconto quantità lo aggiorna su tutte le righe.

Se si modifica la quantità su un livello o si cancella una riga di livello, si cerca di nuovo lo sconto quantità. Nel caso prima ci fosse poi vada tolto, si ricalcolano gli altri sconti solo se sono bianchi.

Se promozione: cerca sull'articolo se ha qualche livello con il prezzo promozione, se viene trovato si chiede se considerare tutti i livelli di quell'articolo con promozione o no. Se SI viene sbiancato lo sconto cliente.

Nei livelli non c'è il pulsante di ricalcolo sconti.


SEMPLIFICATA Opzione

Non si tratta di una procedura per l' Iva Semplificata, ma di una opzione valida soprattutto per i consulenti, che consente di ottenere la stampa dei registri iva come richiesto per le ditte che hanno una contabilità semplificata.

In questo caso la ditta non deve stampare il giornale bollato ma solo i registri iva.
Questi ultimi tuttavia, dovranno essere integrati per le componenti reddituali (il costo del lavoro, le rimanenze etc.) che normalmente non entrano in questa stampa essendo operazioni senza iva.

La soluzione adottata è quella di creare dei fornitori (clienti, conti) di comodo per registrare queste operazioni come fatture utilizzando un codice iva definito Iva Esclusa in modo da ottenere una registrazione con solo imponibile e quindi nessuna influenza sull'iva stessa.

Le registrazioni così impostate vengono stampate sul registro con Descrizione Operazione composta dalla descrizione del cliente/fornitore fittizio più la descrizione aggiuntiva.

Per attivare l'opzione 'SEMPLIFICATA' è necessario fare quanto segue:

  • In sede di definizione del tipo di contabilità della ditta (Caratteristiche esercizio di contabilità) specificare che la ditta ha una contabilità semplificata.
  • Inserire nel piano dei conti i gruppi, mastri, conti, clienti e fornitori necessari per la descrizione delle operazioni particolari secondo il metodo sopra suggerito. I fornitori (clienti) particolari dovranno avere il campo 'Fittizio spuntato e 'Op.ril.ai fini Iva' impostato a 'Escluso' (nei rispettivi programmi di gestione, quadro Contabilità)
  • Creare due o più causali di tipo fattura (vendita e acquisto) con descrizione opportuna (diversa da Fattura emessa) da utilizzare per le registrazioni sopra descritte.
  • Creare un codice iva con Tipo Iva ESCLUSA da utilizzare nelle registrazioni delle 'finte' fatture. Indicare che NON va evidenziata nella comunicazione Op.rilevanti ai fini iva.
  • Procedere alle normali registrazioni di prima nota utilizzando i fornitori (Clienti) particolari con relative causali e codice iva per le rilevazioni che non riguardano l'iva. Si noti che queste registrazioni sostituiscono quelle che normalmente in contabilità generale venivano fatte come operazioni diversi a diversi.

Per una corretta organizzazione del metodo è consigliabile gestire un gruppo unico e un insieme di mastri associati.
Esempio:

  • 88 Gruppo operazioni per Imposte Dirette
  • 01 Mastro coge per operazioni Imposte dirette
  • 02 Mastro fornitori per operazioni Imposte dirette
  • 03 Mastro clienti per operazioni Imposte dirette

Conto 88-01-0001 Salari e stipendi

Fornitore 88-02-0001 Salari e stipendi del mese di...

Descrizione aggiuntiva della registrazione: Settembre

Con questa organizzazione sarà poi facile ottenere dalla situazione contabile generale, clienti e fornitori, i dati relativi ad ognuno di questi elementi aggiunti al piano dei conti per gli usi previsti.
(In pratica serve solo il bilancio Economico per cui, ad esempio nella registrazione degli stipendi si movimenteranno solo il fornitore 'Stipendi' e i conti di costo (Retribuzioni, Contributi etc.)

Se si installa la procedura Cespiti in un'azienda in Semplificata

Poiché le registrazioni verranno tutte stampate sul registro iva acquisti, occorre che le causali che si preparano in contabilità per le registrazioni di ammortamento siano di tipo 'fattura d'acquisto' e in esse si dovrà spuntare il campo: movimento generato da cespiti.


GESTIONE TAGLIA/COLORE

La procedura consente di gestire, per gli articoli di magazzino che lo necessitano, le quantità (ed eventualmente costi e prezzi) divise per taglia e colore (o comunque per livelli definiti dall'utente).

Per abilitare tale gestione occorre spuntare, in fase di definizione dei parametri generali di magazzino il flag di gestione di 'Taglia/Colore'.

Successivamente si procede con l'inserimento, da Tabelle di Magazzino di Livelli e Composizione livelli.

In ogni articolo per il quale si dovranno gestire i livelli, nella maschera (Altro) verranno chiesti: Gruppo Liv.1 e Gruppo Liv. 2
Per gli articoli nei quali vanno gestiti a taglia e colore, in questi campi andranno riportati rispettivamente i codici del gruppo 'Taglia' e del gruppo 'Colore' definiti nella funzione: Composizione livelli.
E' inoltre possibile stabilire, per ogni articolo con 'livelli', se il prezzo di listino e i costi si riferiscono all'articolo in generale, al primo livello o in dettaglio a entrambi i livelli.

Una volta impostati i dati suddetti, in fase di inserimento nei movimenti di magazzino e nei documenti (ordini, ddt e fatture) di articoli con livelli, sarà possibile inserire il dettaglio dei livelli con quantità e valore, secondo le modalità specificate in Gestione livelli.


TRASPORTATORI

Ai trasportatori abituali è data facoltà di rimandare l'iva delle vendite al periodo successivo a quello di fatturazione.

Per la registrazione di tali fatture/note credito è necessario utilizzare causali con flag Trasportatori impostato a si. In corrispondenza alle registrazioni fatte con queste causali, il programma compilerà in automatico i campi anno e periodo iva. Il periodo iva sarà quello individuato dalla data di registrazione più uno. In questo modo l'aggiornamento iva incrementerà i progressivi del periodo indicato.

I progressivi relativi alle fatture del quarto trimestre o di dicembre dovranno essere considerati dell'anno successivo.

E' stato inoltre inserito un flag sulla tabella che contiene i prefissi per i registri iva (Vedi Prefissi e numeratori documenti), in modo che, in corrispondenza ad ogni prefisso del registro iva vendite, si possa dichiarare se su quel registro vengono registrate le fatture trasportatori.

Questo per fare in modo di poter stampare i movimenti di questo registro nel periodo successivo cioè nel periodo in cui effettivamente se ne tiene conto dal punto di vista dell'iva.

Stampa Registri Iva:
Le fatture dei trasportatori vanno stampate sul registro iva del mese/trimestre successivo a quello di emissione
(Es. se ditta trimestrale, una fattura emessa a gennaio 2017 ma registrata ad aprile 2017, va comunicata nella liquidazione dati iva II trimestre 2017 quindi nel trimestre di registrazione)

In fase di stampa registri iva, al cambio prefisso, nella maschera dove viene chiesto di inserire il 'registro con prefisso X', (dove X è un prefisso Trasportatori), verrà chiesta anche la data di registrazione che dovrà sostituire in stampa, quella effettiva delle fatture.


VENTILAZIONE DEI CORRISPETTIVI

Per i corrispettivi soggetti a ventilazione, l'aliquota non è nota al momento della registrazione del corrispettivo in quanto verrà determinata solo in fase di liquidazione sulla base delle aliquote a cui sono assoggettate le fatture di acquisto.

I commercianti che utilizzano tale procedura devono:

  • Registrare gli acquisti di beni destinati alla rivendita, separatamente dagli altri acquisti, su conti particolari nei quali dovrà essere spuntato il campo: Acquisto per ventilazione
  • Registrare i corrispettivi con una apposita Causale che dovrà avere come Tipo Causale: Corrispettivi da ventilare
  • In caso di attività che applicano la ventilazione speciale (macellai) occorre valorizzare, nel codice iva che verrà utilizzato per la registrazione della fattura di acquisto (es. 21) , il campo 'Cod.iva per ventilazione speciale' inserendo il codice iva (diverso dal 21%) da utilizzare per la ventilazione in corrispondenza a quegli acquisti (es. 10%)
    Ventilazione speciale:

Nella registrazione di prima nota del corrispettivo NON verrà chiesta aliquota iva ma solo il conto di ricavo su cui dovrà essere registrato l'intero importo del corrispettivo.

Chiusura iva:
Verranno calcolati:

  • l'ammontare, comprensivo di iva, distinto per aliquota degli acquisti dei beni destinati alla rivendita (registrati sui conti definiti come 'acquisti per ventilazione') fatti dall'inizio dell'anno fino al periodo in elaborazione
  • le quote percentuali degli acquisti distinti in base alle diverse aliquote, rispetto all'ammontare complessivo degli acquisti
  • la ripartizione, per aliquota, del totale corrispettivo del periodo in base alle quote percentuali determinate come sopra
  • e infine verrà scorporata l'imposta dai corrispettivi in modo da determinare l'iva da versare del periodo

Nella chiusura iva annuale verrà riportato l'ammontare complessivo dei corrispettivi da ventilare registrati nell'anno. Tale importo verrà ripartito per aliquota in base alle quote percentuale degli acquisti di beni destinati alla rivendita dell'intero anno.
A questo punto, in generale, sorgeranno delle differenze, anche rilevanti, tra la liquidazione dell'ultimo periodo e quella annuale. La differenza andrà recuperata/versata in sede di dichiarazione annuale.
Tale differenza sarà più o meno rilevante a seconda del volume d'affari dell'anno.

La registrazione dello storno dell'iva dal conto di ricavo dovrà essere fatta manualmente rilevando l'importo dalla chiusura iva di ogni periodo.

Esempio di Chiusura Iva

Mese di gennaio:

 | Imponibile | Imposta |
TOTALE ACQUISTI | 5.090,00 | 738,90 |
cos'ì suddivisi | 3.000,00 | 300,00 | 10% (acq. per ventilaz)
 | 2.000,00 | 420,00 | 21% (acq. per ventilaz)
 | 90,00 | 18,90 | 21%
Totale incassi da Vent. | 4.000,00 |  |
Base di Ventilazione | IVA | Base ventilazione | % |
 | 10 | 3.300,00 | 57,69230 |
 | 21 | 2.420,00 | 42,30770 |
Totale Base ventil. |  | 5.720,00 |  |
Incassi ventilati | IVA | Imponibile | Imposta | Totale
 | 10 | 2.097,90 | 209,79 | 2.307,69
 | 21 | 1.398,60 | 293,71 | 1.692,31
Corrispettivi Ventilati |  | 3.496,50 | 503,50 | 4.000,00

Nei mesi successivi, gli importi della base di liquidazione comprenderanno gli acquisti, divisi per aliquota, del mese sommati a quelli dei mesi precedenti.


VUOTI - GESTIONE

Per abilitare la Gestione vuoti/cauzioni in Ddt e/o in fattura accompagnatoria occorre:

  • Inserire il parametro di personalizzazione GestVuotiCauz
  • Inserire con il programma di gestione articoli, gli articoli corrispondenti ai vari tipi di imballo, in ciascuno va inserito il codice iva, il conto di ricavo, il prezzo di listino (almeno sul listino base) e in particolare il flag " cauzione"
    inoltre nelle anagrafiche degli articoli che hanno un imballo, inserire un valore nel campo "pezzi per confezione" sulla prima maschera, poi, nella maschera "Altro", il "codice articolo imballo" e, in caso di vino, il "numero litri per bottiglia".
    Gli articoli con flag cauzione a SI non verranno conteggiati nel numero dei colli.
  • Impostare il parametro di personalizzazione CauzAttNoCalc con valore S per far si che in fattura, sugli articoli che hanno il flag di cauzione a SI, non venga calcolato lo sconto pagamento.
  • Impostare il parametro di personalizzazione CauzAttNoSconti per azzerare lo sconto totale nelle righe degli articoli che hanno il flag Cauzione a Si.

Una volta abilitata la gestione vuoti, nella testata del ddt e/o della fattura accompagnatoria, verrà abilitato il pulsante: (O) Inserisce righe Cauzioni

L'operatore inserirà gli articoli da consegnare e, una volta confermato il corpo ddt / fattura e tornato alla testata, potrà premere il pulsante suddetto per generare in automatico le righe corrispondenti agli articoli 'Cauzioni' consegnate. Per ogni articolo inserito nel documento, che abbia il codice imballo e il campo "pezzi per confezione" compilati, il programma calcola, il numero di imballi consegnati e li somma a parità di codice creando una nuova riga per ogni imballo diverso. Il prezzo unitario degli imballi viene preso dal listino in uso oppure dal listino base.

Il documento verrà poi stampato e accompagnerà la merce. Successivamente l'operatore dovrà inserire manualmente le righe di cauzioni rese dal cliente. Destamperà il documento, inserirà righe nuove per ogni tipo di cauzione (utilizzando i codici articoli "imballo") e quantità negative. Successivamente il documento dovrà essere ristampato per poter essere elaborato regolarmente.

Perché in fattura venga stampato un prospetto per le cauzioni, occorre creare un filtro di stampa particolare, nel quale siano presenti le righe per la stampa del campi appositi.

I campi disponibili per essere stampati nel piede della fattura sono:

  • T_TotLitriTotale litri di vino (calcolato utilizzando il numero di litri per bottiglia scritto sugli articoli)

Per ogni 'articolo cauzione' , fino a un massimo di 20 articoli (N=1-20):

  • T_CauzDescrN Descrizione articolo cauzione
  • T_CauzQtaN Quantità consegnata in fattura
  • T_CauzUniN Valore unitario
  • T_CauzRigN Valore totale di riga
  • T_CauzQtaNegN Quantità resa
  • T_CauzUniNegN Valore unitario del reso
  • T_CauzRigNegN Valore totale di riga
  • T_CauzTot Valore totale delle cauzioni consegnate al cliente
  • T_CauzTotNeg Valore totale delle cauzioni rese dal cliente
    I campi relativi alle cauzioni Rese, saranno disponibili solo una volta che saranno state inserite manualmente le righe dei resi.


COME ABILITARE SOLO ALCUNE SCELTE DI MENU AD UN UTENTE

Si possono presentare due tipi di esigenze diverse:

  1. Due o più utenti (gruppi di utenti) di cui qualcuno abilitato a tutte le procedure installate, altri che non devono vedere la contabilità (o un'altra procedura)
  2. Più utenti (gruppi) dei quali qualcuno va abilitato a tutte le procedure mentre gli altri devono essere abilitati solo a qualche funzione specifica
    Esempio:
    Ute1 abilitato a tutto
    Ute2 abilitato a gestione anagrafiche, emissione ed evasione ordini, Fatture (gestione e stampe)
    Ute3 abilitato alla SOLA visualizzazione delle anagrafiche clienti

Per ottenere quanto sopra si deve procedere come segue:

Eseguire, Con Shift Ctrl Alt L, in Gestione Utenti
- Creare subito un utente SUPERVISOR, con login diversa dagli utenti che utilizzeranno la procedura. La sua password verrà chiesta ogni volta che si entrerà in gestione utenti o in gestione menu per abilitare o disabilitare delle scelte.
In questa fase viene chiesta anche la chiave di abilitazione generica dei menu che, in generale verrà lasciata bianca, mentre se in seguito si vorranno disabilitare alcune funzioni a un utente, va impostata. Per semplicità si può scrivere: tutti. (Questo per non dovere, in seguito, andare a mano su tutte le testate e i dettagli del menu ad abilitare la/le login abilitate a tutto).
- Successivamente creare le login per gli utenti e assegnare loro una password.
Il codice gruppo è libero. Si può mettere e creare con l'icona Creazione gruppi, oppure no.

Eseguire, Con Shift Ctrl Alt L, in Gestione Menu
Click sul pulsante [image] (T) Abilitazione Menu Testate
(viene chiesta login e password del supervisor)
in "collegamento Menu" digitare -1 poi invio e in login abilitate (o gruppi) scrivere la/le login (gruppi) abilitate a tutto.
Per gli altri utenti:
se serve abilitare solo alcuni dei dettagli ad una login/gruppo disabilitati, basta eseguire l'abilitazione dettagli e le testate corrispondenti verranno automaticamente abilitate.
Altrimenti con la lista di Help individuare le testate (sono sempre 2 cioè la prima e la seconda riga del menu) alle quali abilitarli e scrivere in login abilitate le rispettive login.
Ad esempio per il caso 2 descritto sopra, si dovranno creare le righe:
Collegamento menu: 10 Archivi comuni
e in login abilitate scrivere Ute2;Ute3

Collegamento menu: 15 Anagrafiche
e in login abilitate scrivere Ute2;Ute3

Collegamento menu: 300 Vendite
Collegamento menu: 320 Fatture
Collegamento menu: 400 Preventivi e Ordini Clienti
Collegamento menu: 402 Ordini
e in login abilitate scrivere in tutti: Ute2

Successivamente con il pulsante [image] (D) Abilitazione Menu dettagli si possono cercare i singoli pulsanti delle funzioni (individuati da codice principale e secondario) e abilitarli o disabilitarli singolarmente in modo che i vari utenti li vedano o meno nelle pagine di menu abilitate al passo precedente.
(Vengono chieste login e password del supervisor)

Attenzione: Se si abilitano dei dettagli per qualche login/gruppo è indispensabile mettere anche una riga per abilitare TUTTI i dettagli al/ai gruppo/i login abilitati a tutto:
Chiave: Tutti (o comunque la Parola digitata al momento dell'inserimento del supervisor in gestione utenti, per l'abilitazione di tutte le funzioni)
Chiave secondaria: Tutt (Primi 4 caratteri della parola digitata sopra)
Gruppo o Login abilitati: quelli abilitati a tutti
Nota: se si abilita un gruppo o una login a Tutto, gli altri saranno automaticamente disabilitati per cui occorrerà abilitare singolarmente le funzioni a cui devono accedere.

Per la disabilitazione alla scrittura devo mettere in Login disabilitate alla scrittura quelle che devono SOLO leggere (nell’esempio: Ute3)

Le disabilitazioni sono prioritarie sulle abilitazioni

Se la login è abilitata e il gruppo è disabilitato prevale la login.

Il menu nell'abilitare o meno le varie funzioni a una login va a vedere se ci sono delle abilitazioni/disabilitazioni a livello di singolo programma, poi al secondo livello del menu, poi al primo livello.
Poi cerca a livello dei dettagli, se in "tutti" c' è un riferimento ad essa e successivamente se c'è a livello di testata un riferimento nella riga con -1


DOMANDE FREQUENTI

  • Chiusura Iva - Esempio di Utilizzo del credito infra-annuale

  • Chiusura Iva - Come ripetere la chiusura di un periodo già fatta in 'definitiva' ma errata

  • Come inserire/correggere una fattura in un periodo iva già chiuso

  • Come creare una nuova ditta (database) da una già in uso (Come azzerare/ripulire un database)

  • Iva per cassa - Note di Credito

  • Come trasferire, in automatico, la giacenza di un gruppo sostanzioso di articoli da un magazzino ad un altro

  • Come caricare gli articoli da file su un movimento di magazzino, ddt, fattura, inventario manuale

  • Provvigioni sull'incassato - Note di credito

  • Come riportare dall'ordine al ddt il campo ' Riferimento ordine cliente '

  • Operazioni di Cambio Anno

  • Chiusura infrannuale (es. per passaggio da snc a srl)

Chiusura Iva - Esempio di Utilizzo del credito infra-annuale

Nella chiusura iva del trimestre o, dei mesi 3, 6, 9 e 12 (se l'azienda è mensile) , se c'è un credito di iva, viene consentito all'operatore di digitare l'eventuale parte di credito da accantonare poi si chiede di specificare, quale parte, di tale credito accantonato, verrà utilizzato in quel mese, per F24.
Se i periodi suddetti si chiudono a debito, verrà data la possibilità di inserire solo l'eventuale importo di credito da utilizzare (se l'ammontare del credito accantonato Residuo è maggiore di 0).
I dati inseriti a video sono perciò relativi al periodo della chiusura iva.
Ci pensa il programma, in fase di stampa, a calcolare il totale del credito accantonato e a segnalare il residuo.

Supponendo che la Chiusura iva di marzo presenti un credito di 22000 euro che potrebbero essere accantonati per essere utilizzati nell' F24 del periodo e dei successivi.
Supponendo di accantonare 12000 euro e di non utilizzare niente per F24, il credito da rimandare al periodo successivo (cioè l'importo che verrà presentato in aprile in VP15 - Credito precedente passa da 22000 a 10000 e sulla stampa della chiusura verrà fatta l'annotazione:

Nel mese di Aprile mi da questa maschera: non posso accantonare niente perché lo fa fare solo nei mesi 3 , 6, 9 , 12 (infatti Credito da accantonare non è gestibile) ma posso utilizzare per F24 parte di quello che ho accantonato fino adesso
(la disponibilità è 12000)

Se si digita 2.000 in corrispondenza a Credito infrann. util. per F24, sulla stampa verrà evidenziato:

Credito infra-annuale utilizzato nel periodo per F24: 2.000,00
Credito infra-annuale accantonato Residuo: 10.000,00

A Maggio verrà visualizzato:

e se non si utilizza niente, la stampa continuerà a evidenziare:
Credito infra-annuale accantonato Residuo: 10.000,00

Se a giugno c'è di nuovo del credito da accantonare e si accantono altri 4.400 euro, poi si usano 400 euro per F24:

La stampa evidenzierà:

COME INSERIRE/CORREGGERE UNA FATTURA IN UN PERIODO IVA GIA’ CHIUSO

E' stata registrata una fattura di acquisto come esente e invece andava registrata con iva, oppure in una fattura di acquisto è sbagliato il numero documento o ancora non è stata registrata una fattura, in un periodo già aggiornato e stampato sui registri....
Valutare se e come la modifica cambierà il credito o il debito del periodo.

Se si deve variare la registrazione:

  • Contabilità / Servizio / VARIAZIONE STATO IVA
    Portare il segnale della registrazione interessata da STAMPATO ad AGGIORNATO
  • Contabilità - Prima nota - INPUT PRIMA NOTA
    Non si riesce a variare il movimento in quanto è aggiornato. Occorre disaggiornarlo con l'apposito pulsante, quindi variarlo.
    Se la fattura aveva generato delle scadenze e queste sono chiuse, prima di fare la variazione occorre cancellare le scadenze con la funzione: Contabilità - Scadenzario - Scadenze.
  • Contabilità / IVA / AGGIORNAMENTO IVA
    Aggiornare il movimento modificato.
    Se si lancia l'aggiornamento di tutto il periodo, il programma aggiornerà solo i movimenti non ancora aggiornati.
  • Contabilità / Servizio / VARIAZIONE STATO IVA
    Riportare il segnale della registrazione interessata da AGGIORNATO a STAMPATO
  • Contabilità / Stampe fiscali / REGISTRI IVA
    Ristampare il periodo interessato dalla variazione facendo attenzione al numero iniziale di pagina presentato in fase di stampa, che andrà riportato indietro manualmente digitando la pagina giusta quando viene proposta.

In alternativa si può portare allo stato di non stampato e disaggiornare tutto il periodo, fare la variazione, riaggiornare e stampare (non ristampare!) di nuovo tutto il registro (attenzione a ripartire con il numero di pagina giusto!).

Se si devono aggiungere delle fatture:

  • Contabilità / Servizio / VARIAZIONE STATO IVA
    Portare il segnale della registrazioni del periodo interessato da STAMPATO ad AGGIORNATO in quanto dovrà poi essere stampato di nuovo il registro.
  • Contabilità - Prima nota - INPUT PRIMA NOTA
    inserire la/le nuova/e registrazione/i.
    Se non sono ancora state registrate fatture nel periodo successivo, si potrà continuare con i numeri protocollo registrando con la data uguale o successiva all'ultima fattura registrata, altrimenti occorre registrare con lo stesso Nr.Protocollo dell'ultima del quel periodo.
    Il numero risulterà doppio, verrà segnalato l'errore nella stampa di prova del registro iva ma non in quella definitiva; poi si aggiungerà a penna sul registro un "/A"
  • Contabilità / IVA / AGGIORNAMENTO IVA
    Aggiornare le nuove registrazioni..
    Se si lancia l'aggiornamento di tutto il periodo, il programma aggiornerà solo i movimenti non ancora aggiornati.
  • Contabilità / Stampe fiscali / REGISTRI IVA
    Stampare il periodo interessato dalla variazione facendo attenzione al numero iniziale di pagina presentato, che andrà riportato indietro manualmente.

Se è già stata fatta la Chiusura iva del periodo ed è necessario ristamparla, occorre modificare:

  • Contabilità / IVA / DATI INIZIALI IVA
    Richiamare anno ed attività in questione e, su questo, portare indietro la "Data" ed
    il "Periodo" "ultima chiusura iva in esecuzione"
  • Ripetere la Chiusura Iva in esecuzione facendo attenzione al numero di pagina

COME CREARE UNA NUOVA DITTA (database) DA UNA GIA' IN USO

Duplicare il database (da Parametri e utilità - Gestione database aziende)
Successivamente occorre valutare cosa azzerare oltre a movimenti e progressivi (es. Conservare o meno i clienti, i fornitori, gli articoli di magazzino?) ed utilizzare le funzioni adeguate, predisposte per le cancellazioni.

Con 'Cambio azienda' spostarsi sulla nuova ed eseguire:

  • Contabilità
    • Utilità - Cancellazione completa esercizi contabili
      per cancellare tutti i movimenti e progressivi di contabilità fino all'anno corrente
    • Scadenzario - Cancellazione scadenze
    • Cancellazione anagrafiche non movimentate
      Per cancellare i clienti e/o i fornitori e lasciare invariato il piano dei conti
  • Cespiti
    • Servizio - Utility Cespiti
      Consente di cancellare i movimenti di ammortamento (ma rimangono tutti gli altri)
      Per una cancellazione completa dei Cespiti occorre utilizzare la funzione di Azzera Tabelle: dal menu premere i tasti Ctrl Alt Shift L
  • Magazzino
    • Servizio - Cancellazione movimenti fino alla data
    • Servizio - Cancellazione Progressivi e Costi (Cancellare i progressivi per tutti gli anni presenti e i costi solo fino al penultimo anno, se si vuole mantenere il Costo ultimo)
    • Servizio - Cancellazione articoli (solo se si vogliono cancellare anche le anagrafiche articolo)
  • Vendite
    • Servizio - Pulizia archivio Ddt (se si utilizzano i Ddt) e Pulizia archivio Fatture (Tutte le fatture)
    • Cancellazione provvigioni (Tutte) (Se è stata utilizzata la Gestione Provvigioni)
    • Se serve, si possono cancellare anche gli articoli di magazzino (Cancellazione articoli) e i Clienti e/o i Fornitori (Cancellazione anagrafiche non movimentate)
  • PreventiviOrdini (Se sono stati utilizzati Ordini e/o Preventivi)
    • Servizio - Cancellazione Ordini/Preventivi Eseguire sia per Ordini sia per Preventivi scegliendo 'Tutti'
  • Ordini Acquisto (Se sono stati utilizzati)
    • Cancellazione Ordini Acquisto scegliendo 'Tutti'

Prima di inserire le registrazioni di Contabilità su questa nuova ditta è indispensabile completare alcune tabelle per l'anno corrente: numeratori fatture, caratteristiche di contabilità, dati iniziali iva.

IVA PER CASSA - NOTE DI CREDITO

Si esamina il caso
Si riceve una fattura seguita da una nota di credito riferita alla stessa, la nota di credito viene incassata a parte, indipendentemente da quando si paga la fattura
Non si vuole che l'incasso della nota di credito finisca nella chiusura iva del periodo, mentre si vuole che il pagamento, unico o frazionato, della fattura finisca nella chiusura iva del periodo per l'importo diminuito della nota di credito.

Registrazione fattura acquisto nr. doc. 9999 (iva per cassa)
Registrazione Nota di Credito con riferimento alla fattura nr. doc. 9999

Incasso Nota di credito SENZA flag iva per cassa

Quando pagherà la fattura dovrà registrare su due righe l'importo pagato (questo per tutte le eventuali rate della fattura o comunque per quella che vuole decrementare dell'importo della nota di credito):
DARE: Fornitore per l'importo pagato detratto della parte 'desiderata' di importo della nota di credito
con riferimento al documento nr. 9999 e FLAG IVA PER CASSA (Se la scadenza è unica andrà detratto tutto l'importo della nota di credito)
DARE: Fornitore per l'importo che è stato detratto sopra , con riferimento al documento nr. 9999 ma SENZA FLAG iva per cassa
AVERE: Cassa per l'intero importo pagato

(Con le dovute variazioni sulle registrazioni, questa soluzione vale anche per fatture emesse)

Come trasferire, in automatico, la giacenza di un gruppo sostanzioso di articoli da un magazzino ad un altro.

FARE UNA COPIA DEL DB
Nella funzione: Magazzino - Stampe - Stampa Situazione articoli
personalizzare una stampa con i campi: codice articolo, giacenza attuale e ultimo costo (se questo è il valore da dare alla merce che si trasferisce)
Poi fare una stampa su file , per magazzino, scegliendo il magazzino su cui sono attualmente gli articoli, degli articoli da trasferire,
o in formato excell (poi occorrerà caricare il file , togliere intestazioni e totali in modo da lasciare solo le righe articolo e salvarlo in formato testo con tabulatori)
o in formato testo (anche in questo caso occorre editare il testo e lasciare SOLO le 'righe articoli'). Si dovrà scegliere: Separatore campi: Tabulatore, Qualificatore testo: nessuno

In un modo o nell'altro, lo scopo è quello di ottenere un file di testo con
Codice articolo, Quantità e Valore unitario da utilizzare per il movimento di carico sul nuovo magazzino.
Fare attenzione che non ci siano righe vuote in fondo al file!

Creare, se già non esiste una causale MI per fare un movimento interno di magazzino.

Dal menu magazzino - Servizio eseguire la funzione Caricamento movimenti di magazzino da file:
Impostare la data del movimento, la causale del movimento: MI , unità da: impostare il magazzino da cui si devono far uscire gli articoli, Unità a: impostare il magazzino in cui si devono trasferire gli articoli
Cercare il file da caricare : deve essere quello creato con le stampe
Confermare l'esecuzione.

Verrà generato un movimento MI di magazzino che azzera la giacenza sul primo magazzino e carica sul secondo.

Se occorrono più stampe per selezionare gli articoli da trasferire, occorrerà ripetere il caricamento per ogni file ottenuto dalla stampa oppure unificare tali file con copia/incolla, in un'unico file.

Chiusura Iva - Come ripetere la chiusura di un periodo già fatta in 'definitiva' ma errata

La funzione Ristampa consente di ristampare un periodo già stampato in 'Stampa' definitiva.

Se invece serve ristampare un periodo perchè si deve correggere qualcosa, es. si devono variare o aggiungere una o più registrazioni o non è stato utilizzato bene il credito iniziale o precedente, occorre fare quanto segue:
con la funzione Contabilità - Iva - Dati iniziali iva, variare i campi: "Data e Periodo ultima chiusura IVA in esecuzione" mettendo la data e il periodo precedente alla Chiusura da ripetere. Se si deve ripetere quella di Gennaio o del primo trimestre, sbiancare i due campi.

Se si dovranno correggere delle registrazioni occorrerà disaggiornarle, fare le variazioni e riaggiornarle.
Se mancavano delle registrazioni, una volta aggiunte , occorre aggiornare di nuovo il periodo da stampare.

Nello stampare di nuovo la Chiusura Iva del periodo in oggetto, fare attenzione a variare a video il "Numero prima pagina in stampa", mettendo il numero della prima pagina della Chiusura 'errata' fatta in precedenza

NOTA: se sono già state fatte le Chiusure Iva 'definitive' anche di periodi successivi a quello di cui si rende necessario ripetere la Chiusura, è indispensabile, una volta elaborata la Chiusura del periodo desiderato, come indicato nelle note descritte in precedenza, elaborare anche tutte le altre successive, facendo attenzione che risultino uguali a quelle stampate in precedenza o verificando la correttezza di eventuali differenze.

Come caricare gli articoli da file su un movimento di magazzino, ddt, fattura, inventario manuale

Supponendo che il file da caricare contenga:

500 6,32
K1 5,4

dove 500 e K1 sono codici articoli (o BarCode) e 6,32 e 5,4 sono le quantità e articolo e quantità sono divisi da un TAB ( 9 come carattere ascii)

Creare un parametro di personalizzazione :
Gruppo: CarMov (DDt ..)
Parametro: LettArtDafile
Valore: S

Nell'AziWin.INI del terminale che dovrà fare il caricamento o in quello comune in cartella AziWin, aggiungere un paragrafo [LettArtDaFile] con tutti i paramnetri come descritti sotto:

[LettArtDaFile]
Descr=Per caricamento inventario
FileOrigine=c:\dati\Inventario.txt
FissoSep="S"
Separatore = 9
CodInizio=1
QtaInizio=2
' se ci sono importi abilito i campi corrispondenti
'ImpUniInizio=3
'ImpTotInizio=4
CancFile="C"

Dove il significato dei parametri è il seguente:
FileOrigine
E' il nome del file che contiene i dati da caricare

FissoSep=
Serve per dire com'è fatto il file dati.
Il default è F lunghezza fissa
Altri valori sono S con separatori, A ogni campo è compreso tra apici e c'è la , "virgola" che separa i campi (formato dei file .csv)

Separatore=
Nel caso che il file sia con separatori, va specificato il codice ascii del carattere 'separatore', se questo è compreso nell'intervallo 0<codice<256, oppure il carattere stesso (es. se il separatore è il TAB si dovrà impostare il parametro a 9)
Se il file è con separatori e manca questo parametro non sarà possibile abilitare il caricamento da file e non verrà visualizzata sul programma l'icona che consente il caricamento.

CancFile =
Serve per dire se alla fine del caricamento il programma deve cancellare o meno il file caricato.
I valori possibili sono: S (Si) N (No)
C (Chiedi) è il valore di default e al termine del caricamento verrà posta la domanda all'operatore: Vuoi cancellare il file caricato?

CodInizio=1 Indica che il primo campo è il codice
QtaInizio=2 Indica che il secondo campo è la quantità

Provvigioni sull'incassato - Note di credito

Emissione Fattura con scadenze
Emissione Nota di Credito parziale
Si vuole che la nota di credito non generi una scadenza indipendente che verrà pagata (come previsto e gestito dal programma)
ma che decrementi la prima scadenza (o le scadenze ) della fattura

1) Soluzione 1:
Nella Nota di credito NON mettere il codice Agente, né la condizione di pagamento
(oppure da Gestione Provvigioni, cancellare la riga della nota di credito e da Gestione Scadenze, cancellare la scadenza della Nota di Credito)
In Gestione Provvigioni, trovare la registrazione della fattura in oggetto e decrementare l'importo della fattura togliendo quello della nota di credito.
In questo modo però in stampa provvigioni NON c'è evidenza della nota di credito

2) Soluzione 2 : per mantenere in stampa l'evidenza della Nota di credito
Duplicare la 1' scadenza della fattura, nell' 'importo scadenza' di questa nuova scadenza mettere l'importo totale della nota di credito
e compilare i dati della registrazione di pagamento: Nr.- data - anno - nriga della registrazione di pagamento (con nr = 9999 )
data = a quella della contabilizzazione della distinta in cui si metterà la prima scadenza della fattura, nriga=1 (nel quadro Dati incassi/pagamento)
Anche nella scadenza della nota di credito compilare i dati di pagamento come descritto sopra.

Nella/e scadenza/e della fattura, rimasta/e 'aperta/e' (cioè senza i dati di pagamento): variare l' 'importo scadenza', togliendo la parte relativa alla nota di credito poi metterLa/e in distinta o saldarla/e normalmente.
Successivamente, prima di fare la stampa provvigioni, cancellare questa/e scadenza/e messe in distinta o incassate dopo aver sbiancato i dati di pagamento.

COME RIPORTARE DALL'ORDINE AL DDT IL RIFERIMENTO ORDINE CLIENTE

Impostare sul cliente particolare, nel quadro 5-Fatturazione , il campo St.Rif.Cliente a Si
(Se deve valere per tutti i clienti, si può impostare qui T-Come da tabella di fatturazione e impostare a Si 'St.Rif.Cliente' sulla tabella Fatturazione in Parametri e Utilità - Dati generali azienda (parametri))

Impostare anche l'altro campo: St.Rif.Ord/Prev sul cliente o in tabella di fatturazione, nel modo desiderato (questo si riferisce alla scritta: Rif. ordine n. xx del ... dove numero e data sono quelli attribuiti dalla ditta che emette il ddt).

Nell'inserimento dell'ordine compilare il campo Riferim. Cliente, in testata, con l'identificativo ordine comunicato dal cliente.

In questo modo sul ddt che evade l'ordine, verrà scritta, in una riga descrittiva, per ogni ordine, anche questa informazione:

Per ottenere la stampa anche sulla fattura, occorre che, sulla riga descrittiva che contiene il Riferimento Cliente ci sia il campo 'Dove viene stampata' impostato a 'Anche sul doc. di evasione'
Per ottenere ciò, o si va a mano sul ddt a metterlo oppure si imposta il parametro di personalizzazione: StRigaRifCli
Gruppo: EvasioneOrd
Valore: S - anche su documento di evasione

CAMBIO ANNO

Riepiloghiamo, di seguito, le funzioni da eseguire PRIMA di cominciare ad inserire il 2015, ricordando che i programmi consentono di inserire qualsiasi tipo di registrazione con data 2015 e , contemporaneamente, di continuare a registrare sul 2014, facendo attenzione alla data di registrazione utilizzata.

Gli utenti di Contabilità, Cespiti, Ordini e Fatturazione dovranno eseguire entrambe le funzioni descritte nei punti 1 e 2
quelli che utilizzano il solo magazzino , solo la funzione al punto 2

1 - Contabilità - Annuali - Cambio Anno
A seconda che l'anno contabile coincida o meno con l'anno solare, si dovrà scegliere il 'Cambio anno contabile e anno IVA' oppure 'Anno IVA'
(al termine dell'anno contabile si eseguirà di nuovo questa funzione scegliendo :
'Anno contabile')
Controllare che ‘Periodo Attuale’ e ‘Nuovo Periodo’ siano corretti.
Spuntare il campo ‘Azzero progressivi effetti stampati’ e ‘Azzero numero registrazioni’ e confermare l’esecuzione con il tasto OK
Se non ci sono messaggi particolari, l’operazione ha avuto esito positivo.
Se l’anno precedente a quello riportato in ‘Attuale Periodo’ risulta ancora aperto, verrà presentato il seguente messaggio:

Anno precedente aperto: non è possibile proseguire con il cambio anno

Questo significa che, per tale anno (nell’esempio il 2013) non è stata fatta la Generazione dei Movimenti di Chiusura dei conti e quindi nemmeno Generazione Movimenti di Apertura del ‘Periodo attuale’ (nell’esempio il 2014).
Occorre verificare perchè queste operazioni non sono state fatte.
Se si utilizza solo la fatturazione oppure è già stata fatta la Chiusura e Apertura ma l'anno vecchio è stato riaperto manualmente, occorre eseguire la funzione: Contabilità - Annuali - Chiusura definitiva anno precedente

Assicurasi che quello visualizzato sia proprio l'anno da chiudere e cliccare su Chiudi

Se si gestisce la Contabilità e non sono stati generati i Movimenti di Chiusura e di Apertura, occorre generarli con le funzioni: Contabilità - Annuali - Generazioni movimenti di Chiusura e Contabilità - Annuali - Generazione Movimenti di Apertura, prima di procedere.

2 - Magazzino - Annuali - Cambio Anno

Viene visualizzato l'anno e il periodo di validità attuale del magazzino e si chiede di inserire il nuovo anno e di scegliere se trasferire o meno le giacenze e i costi.
Se, al momento dell'esecuzione del programma, le giacenze finali dell'anno precedente non sono ancora definitive, esso dovrà essere eseguito di nuovo, non appena queste ultime siano state sistemate.
La necessità di trasferire i costi sul nuovo anno, nasce dal fatto che i nuovi movimenti fatti sull'articolo non dovranno alterare i costi dell'anno precedente
Lo scopo di questa funzione è quello di predisporre i progressivi e i costi di ogni articolo per il nuovo anno (in particolare di trasferire sul nuovo anno la giacenza iniziale).

CHIUSURA INFRA-ANNUALE (per cambio assetto societario)

La richiesta è: l’azienda attuale (snc) chiude in data 21/04/AA , l’altra (srl) inizia dal 22/04.
Si deve fare una chiusura di bilancio al 21/4 e una riapertura al 22/4
(Possibili 2 casi: vanno riaperti anche i conti economici oppure non vanno riaperti)
L’iva va avanti progressivamente dall’inizio dell’anno.
I partitari della nuova azienda devono riportare tutti i movimenti dall’inizio dell’anno (oppure i soli movimenti dall'apertura in poi).

Accertarsi di aver fatto tutte le registrazioni fino al 21/4 comprese eventuali rettifiche e fare una copia di sicurezza del database, che andrà accantonata.

Caso A)
Al 21/4 si è già pronti per la chiusura e quindi si opera prima di fare registrazioni della nuova azienda

  • Eseguire la Generazione movimenti di chiusura sul DB di lavoro (DB_SNC)
    (Contabilità - Annuali - Generazione movimenti di chiusura)
  • Duplicare il database in uno nuovo (DB_SRL) che sarà quello sul quale si gestirà la nuova azienda
  • Il DB_SNC rimarrà inalterato e disponibile per le stampe del giornale e bilanci

Sul DB_SRL occorre fare le seguenti operazioni

  • Cancellare gli anni contabili fino all’anno precedente a quello della Chiusura
    (Contabilità - Utilità - Cancellazione completa esercizi contabili chiusi)
  • Eseguire la Generazione movimenti di apertura dei conti patrimoniali
    (Contabilità - Annuali - Generazione movimenti di apertura)
  • Se viene chiesto di riaprire anche i conti economici, occorrerà fare manualmente delle registrazioni di prima nota con causale di apertura.

In questo modo i partitari riporteranno i movimenti dal primo dell’anno, comprensivi della chiusura e dell’apertura.
Per quanto riguarda il saldo iniziale, sarà la somma dei due saldi iniziali (quello all'1/1 e quello al 22/4).
Partitari e Bilancio: se si richiede che nei partitari ci siano tutti i movimenti ma che i progressivi siano solo quelli generati dal 22/4 (apertura infra annuale e successivi movimenti di dovranno
- Rigenerare le sintesi dal 22/4 al 31/12
Per quanto riguarda la stampa del giornale occorre valutare se per l’anno si stampa un giornale unico o due separati
Se due separati e sul DB_SRL sono state lasciate le registrazioni del primo periodo, occorre segnarle come già stampate
(Contabilità - Utilità - Variazione stato giornale variare da Non stampate a Stampate le registrazioni nell'intervallo di date 01/01/AA a 21/04/AA)

Caso B)
Le registrazioni successive al 21/4, quindi relative alla nuova gestione, sono state registrate regolarmente sullo stesso database

  • Rigenerare i progressivi per l’anno in corso dall’1/1 al 21/4 (giorno in cui dovrà essere fatta la chiusura)
    (Contabilità - Servizio - Rigenerazione progressivi contabili)
  • Fare la chiusura in data 21/4
    (Contabilità - Annuali - Generazione movimenti di chiusura)
  • Duplicare il database
  • Uno dei due database sarà accantonato come DB_SNC (vecchio), l’altro come DB_SRL (nuovo)

Sul DB_SNC (azienda vecchia) che rimarrà disponibile per le stampe del giornale, bilanci , partitari:

  • Cancellare i movimenti dal 22/4 in avanti
    (Contabilità - Utilità - Cancellazione registrazioni di prima nota)

Sul DB_SRL (azienda nuova)

  • Rigenerare i progressivi per l’anno in corso senza mettere date
    (Contabilità - Servizio - Rigenerazione progressivi contabili)
  • Eseguire la Generazione movimenti di apertura (per riaprire in automatico i patrimoniali)
    (Contabilità - Annuali - Generazione movimenti di apertura)
  • Con registrazioni di prima nota, utilizzando una causale di apertura, aprire manualmente i conti economici (se richiesto)

Se ci fosse la richiesta di stampare i partitari della nuova ditta con i soli movimenti dal 22/4 in poi occorre cancellare le registrazioni dall’1/1 al 21/4 prima di rigenerare i progressivi


NOTE PER TRASFERIMENTO MOV.FATTURE A CONTABILITA'

Nella sede in cui in cui generano solo le fatture:
  • Indicare (una tantum) in Dati generali azienda (parametri) - Tabella di fatturazione che lo scarico dei movimenti delle fatture va fatto su: "Archivi di Parcheggio".
  • Eseguire la contabilizzazione delle fatture per generare i movimenti di prima nota su archivi di parcheggio (appoggio)
  • Eseguire il Trasferimento di movimenti di prima nota di fatture su file
    Questa funzione estrae i movimenti contabili di fatturazione presenti negli archivi di parcheggio, fino a una certa data e genera i files .txt che dovranno essere utilizzati per caricare i movimenti nella sede dove si fa la Contabilità.

Nella sede in cui si gestisce la contabilità:

  • Eseguire il caricamento movimenti di prima nota da file esterno.
    Questa funzione legge i movimenti di prima nota dai i files .txt creati nell’altra sede e li carica su un archivio di parcheggio.
  • Al termine viene lanciata in automatico la funzione Trasferimento in Contabilità dei movimenti di fatture (l'utente deve solo confermare l'esecuzione). Essa carica, sugli archivi della prima nota definitiva, i movimenti che si trovano sull'archivio di appoggio (di parcheggio)

Nota:

Prima di eseguire queste funzioni si consiglia di eseguire un salvataggio degli archivi (database .mdb) dell' azienda interessata.


TERMINAL SERVER

Consente di eseguire programmi installati su un server, collegandosi da una postazione remota.
Tale postazione può essere o connessa sulla rete locale o tramite internet

Problemi con le date

Le date sul server devono essere configurate in modalità italiana

Utilizzo come applicazione remota (lancio diretto di menu.exe) con Win XP e Win Vista

Occorre installare sulla postazione che si deve collegare la hotfix KB967885

Installazione di AziWin

Sul server il programma va installato con una 'normale' installazione di tipo Server
Successivamente dovranno essere sistemati i file AziWin.INI

  • Utilizzato solo come terminal server
  • Ci sono anche dei terminali collegati come client
    in questo caso conviene installare il programma su un disco diverso da C (es. F) in modo che sia il Server che i Client lo vedano con la stessa lettera.

L'installazione crea due file AziWin.Ini sul server, uno in \AziWin\Main e l'altro, quello condiviso, in \AziWin

Nel caso in cui il server veda la cartella di installazione \Aziwin con lo stessa lettera e percorso dei client, occorre:

  • rinominare il file AziWin.ini contenuto in \AziWin\Main
  • copiare il file AziWinWi.ini dalla cartella \AziWin alla cartella \AziWin\Main e rinominarlo in AziWin.INI
  • accertarsi che il file AziWinInst.ini presente nella directory principale del server riporti esattamente i percorsi in cui è stata fatta l'installazione
  • lanciare dalla cartella \AziWin il programma: InstMain che aggiornerà entrambi gli ini. A video si chiede di inserire il nome del terminale, lasciare spuntato il campo 'Aggiorno Ini condiviso' e NON scegliere nessuna procedura da installare.
    In questo modo si ottiene il .INI dell'utente principale.

Se invece il server vede il disco di installazione con una lettera/percorso diverso rispetto i client, è sufficiente copiare il file AziWin.ini contenuto in \AziWin\Main, assegnare ad esso un nuovo nome, editarlo e cambiare il nome di terminale.

Per ogni ulteriore postazione che si dovrà collegare in terminal server (sia che si utilizzino utenti diversi sia lo stesso utente), occorre duplicare il file AziWin.ini contenuto in \AziWin\Main, assegnando nomi diversi e cambiando in ciascuno il 'nome terminale'

Per l'accesso, la soluzione migliore è avere sul computer locale un'icona che effettua la connessione diretta al programma Menu.exe. Per fare questo occorre configurare in modo opportuno il Server

Viceversa se si utilizza la connessione tramite windows (sconsigliata)

  • se si accede con più utenti, occorre creare le icone sul desktop per i vari utenti, ciascuna punterà all'aziwin.ini dell'utente corrispondente
    (utilizzare in Destinazione il parametro /I (è una i maiuscola!)
    Menu.exe /I percorso\AziWinPers.ini)
    L'utente che è stato usato per fare l'installazione sul server ha già la sua icona che punta all'AziWin.ini principale
  • se si accede sempre con un unico utente: in quell'utente creare tante icone per gli accessi, ciascuna collegata ad un INI diverso

Problemi con le stampanti

Di default riconosce le stampanti impostate sul computer che si è collegato e di cui, il server, ha i driver installati.
Per stampare su PdfCreator occorre che esso sia installato sul Server.
Per salvare il file pdf sul disco locale: \\tsclient\NomeDisco

Al contrario si potrà fare direttamente la stampa su file pdf se si utilizzano Ghostscript e Redmon installati sul pc locale e una stampante della quale il server abbia i driver installati.

Se si accede da più postazioni usando lo stesso 'nome utente' la stampante predefinita è quella impostata come tale dall'ultima postazione collegata.
Per assegnare la stampante giusta, nel caso si entri con lo stesso utente in sessioni diverse è stato introdotto il parametro: TermSessAggNome

Se si utilizzerà, da un terminale, sempre la stampante predefinita, si consiglia di entrare nella maschere 'Seleziona destinazione stampa', premere il pulsante Stampante Predefinita e salvare le Opzioni di Stampa deselezionando tutto e cliccando SOLO su Nome Stampante; in questo modo, nelle Opzioni di stampa sul file AziWin.ini, verrà sbiancato il nome stampante.

Problemi con le date

Le date devono essere configurate in modalità italiana


GESTIONE LIVELLI A TABELLA

Percorso: Maschera gestione dettagli di Movimenti di Magazzino, Ordini, Ddt e Fatture

Se è abilitata, da installazione, la gestione dei livelli, verranno resi disponibili altri due pulsanti posti in alto a destra sulla maschera della gestione dettagli: (L) Gestione Livelli e [image] (K) Gestione Livelli con Creazione.

Se si sta inserendo un dettaglio con un articolo che non ha i livelli, è abilitato solo il primo che premuto, ha lo stesso effetto del Salva riga.

Se invece si sta inserendo una riga con articolo con livelli, una volta digitato il codice dell'articolo, verrà visualizzata una maschera con la descrizione del Gruppo Liv. 1 e 2 dell'articolo (Es. Taglia e Colore) con possibilità di scegliere 1 taglia e 1 colore e di scrivere la quantità rimanendo sempre nella maschera dei dettagli. (Questo risulta utile nella ricerca per codice a barre di articoli con livelli oppure si debbano inserire, anche manualmente, delle righe dove per ogni articolo si deve mettere un'unica combinazione taglia/colore (Es. articolo: maglia taglia 40 colore Rosso Quantità 2, Articolo Giacca Taglia 42 Colore Blu Quantità 3)
La posizione in cui viene visualizzata la maschera si può modificare attivando il parametro di personalizzazione: PosPicLiv_X
Per spostare manualmente sul video questa maschera potranno essere utilizzati i tasti ctrl Pg Up (in alto a DX) , ctrl Pg Dwn in basso a DX, Home In alto a SX, Fine in basso a SX

Se però si vogliono inserire, per un articolo, quantità diverse per taglie e colori diversi, occorre premere [image] (S) SALVA o F10 o [image] (K).
Verrà presentata una tabella con tante righe e colonne quante sono le combinazioni risultanti dall'esplosione dei livelli generati da Gruppo Liv. 1 e Gruppo Liv.2 letti dall'articolo.
Es. se Gruppo Liv. 1 sono Taglie con livelli: I , II, III, IV e Gruppo Liv. 2 sono colori Blu , Ros , la tabella che ne deriva avrà le Taglie sulle colonne e i colori sulle righe.

 | I | II | III | IV
Blu | 3 | 2 |  |
Ros | 1 |  |  |

Una volta posizionato il mouse su una casella della matrice si deve inserire lì la quantità relativa, mentre nella parte sotto del video vengono visualizzati: prezzo unitario, sconti, importo di riga.
A seconda che il prezzo sia a Livello articolo , solo al primo o al primo e secondo livello, se si varia un prezzo , questo verrà copiato su tutte le combinazioni 'compatibili' e verranno ricalcolati i totali di riga.

Gli sconti vengono considerati a livello di articolo per cui se si varia uno sconto su un 'dettaglio-livello' questo viene riportato su tutte le righe-livello di quell'articolo. Vedi Sconti in Dettagli con Livelli

Con [image] (L) si continuerà ad entrare nella maschera, usata nella gestione precedente, nella quale verrà chiesto di digitare riga per riga i codici livello, le quantità ed eventualmente il prezzo.

Tasti per muoversi sulla matrice del livelli
Freccia su e giù sia se si è posizionati nella griglia sia su uno dei campi sotto es. Prezzo
PgUp e PgDown per muoversi in orizzontale
Ctrl freccia Su e Ctrl freccia Giu per andare a inizio e fine colonna (spostamento verticale)
Ctrl PgUp e PgDown per andare a inizio e fine riga (spostamento orizzontale)
Home per andare a inizio tabella
End per andare a fine tabella
F6 si sposta dalla griglia al maschera sotto e viceversa (per inserimento di Quantità e Prezzo ripetuti)

Pulsanti disponibili
Salva salva la tabella e rimane nella maschera
Salva ed Esci salva la tabella e torna alla maschera dei dettagli
Esci senza Salvare annulla tutte le ultime modifiche fatte dopo l’ultimo Salva

Parametri di personalizzazione

Gestab e NuovoGest per disabilitare in assoluto (gruppo: Livelli) o in qualche funzione (Gruppo: Ddt, Fatture etc.) la modalità di gestione tabellare dei livelli
Liv1VertOriz Se vale V nella gestione livelli il primo livello viene mostrato in verticale altrimenti (default) in orizzontale

Ricerca con Codice a Barre articoli con livelli

Durante l'inserimento dei documenti di vendita è possibile cercare l'articolo con livelli per codice a barre.
Tale codice sarà composto dal codice a barre dell'articolo seguito da un gruppo di N caratteri per individuare il primo livello ed eventualmente, da uno di M caratteri per individuare il secondo (Es. 2 cifre per la Taglia e 3 per il Colore).
Il codice a barre dell'articolo viene assunto di lunghezza 7. Per impostare una lunghezza diversa occorre creare un parametro di personalizzazione CodBarLunArt , mentre il numero dei caratteri che individuano la parte del codice a barre corrispondente al 1 e al 2 livello deve essere inserito, per ogni Gruppo Livello in Gestione Composizione Livelli

Se si fa questo tipo di ricerca inserendo i documenti, non funzione il tasto F4 sul campo codice articolo per cui è indispensabile definire in tabella che la ricerca si fa per codice a barre o farlo sul posto di volta in volta.

Digitato o letto da penna un codice barre, si identifica immediatamente l’articolo estraendo e cercando con i primi N caratteri, si vede quanti livelli ha, si legge da LivGruppi quanti sono i caratteri del cod. a barre per ogni gruppo e da LivComp identifica i possibili livelli del 1’ o del 2’ gruppo (T02 o C02) poi da Livelli cerca quello che ha il codice a barre uguale ai caratteri digitati in quelle posizioni.

Esempio:
Cod Barre digitato:
333333301002

3333333 identifica l’articolo X1 che ha codice a barre di 7 caratteri
In questo articolo sono stati abilitati come
Gruppo liv.1: T02 - Taglia Gruppo liv.2: C02 – Colore

Il programma cerca in tabella LivGruppi (Gestione Compozione Livelli)
- la lunghezza del codice a barre dichiarata per i gruppi: T02 e C02 (esempio rispettivamente 2 e 3)

- in tabella LivComp (Gestione Compozione Livelli) identifica i possibili livelli del gruppo T02 (Es. I, II, IV) e di C02 (Es. Blu e Ros),
- da tabella Livelli, che contiene, per ogni livello, il rispettivo codice a barre, in corrispondenza ai livelli I, II, IV cerca quello che ha il codice a barre uguale ai caratteri digitati nelle posizioni 8 e 9 del codice a barre iniziale (nell’esempio 01) poi in corrispondenza ai livelli (Blu e Ros) cerca quello che ha il codice a barre uguale ai caratteri digitati nelle posizioni 10 e 11 e 12 del codice a barre digitato (nell’esempio 002)

Si può utilizzare anche il parametro CodIniLiv per indicare una parte fissa iniziale del codice a barre degli articoli con livelli


SQL SERVER

Dalla versione 4.00 di Azienda Pc è possibile trasformare il database Access in un database SqlServer.

Prima di iniziare il trasferimento i database .mdb devono essere stati aggiornati alla versione 4.00 e si consiglia di eseguire anche la funzione Confronta DataBase (dal Menu: tasti Ctrl Shift Alt) per assicurarsi che siano completamente allineati.
Dovrà essere trasferito obbligatoriamente anche il database AziMenu.mdb

Nella rete che si utilizza deve essere disponibile una sessione SqlServer
Se tale sessione servirà solo per il software AziendaPC si possono fare le modifiche che seguono direttamente sul Database di default (Model) in modo che vengano riportate automaticamente su tutti i database che verranno trasferiti, in caso contrario occorrerà eseguirle sui singoli DB dopo averli trasferiti.

Per quanto riguarda le note operative del trasferimento si prega di farne richiesta direttamente a Zucchetti Filiale di Ravenna (ex CSS).

Una volta creato tutto l'ambiente, all’avvio del menu verranno chieste Login e Password da utilizzare per accedere a SqlServer
Si fa presente che è possibile creare utenti SqlServer diversi in modo che ogni utente acceda con la propria login.

Nel file INI si possono impostare i seguenti parametri:
Paragrafo [Menu]
PwdSqlComeAzi
Se vale S utilizza le login e password per accedere a SqlServer anche per identificare l’utente di AziendaPc per le permissioni ai menu.


.topic 1
Conferma l'inserimento della data nel TextBox "Data Valida"
.topic 2
Cancella il contenuto del TextBox "Data Valida"


www.aziendapc.it
Versione 4.05 		Apri il sito www.AziendaPC.it


Ammortamento fiscale

In questa sezione si chiede di inserire alcuni dati per consentire una corretta elaborazione dell' ammortamento fiscale.

Percentuale Quota Indeducibile
% di indeducibilità delle quote di ammortamento relative al cespite

Valore massimo ammortizzabile
Viene usato SOLO se presente una % di quota indeducibile. Rappresenta l'eventuale valore su cui viene calcolata annualmente la % di ammortamento (sostituisce cioè il valore fiscale), la quota di ammortamento risultante come differenza tra la % calcolata sul valore fiscale e il valore di cui sopra, è indeducibile.

Es. Valore del cespite: 1500 % ammortamento 10% % ided 20% e massimo ammortizzabile: 500
Si calcola il 10% di 500: 50 (Cioè si fa l'ammortamento del massimo ammortizzabile)
Si applica la % di indeducibilità al risultato ( se questa è diversa da 0): cioè si fa il 20% di 50 = 10
La quota di ammortamento diventa perciò: 50-10 = 40 mentre l'Importo non Detraibile è 110 cioè la differenza: 150 - 40 (dove 150 è l'effettivo importo dell'ammortamento, in mancanza del max ammortizzabile: cioè il 10% di 1500)

Tipo Ammortamento
Ordinario o Personalizzato
Se si sceglie l'ammortamento personalizzato, al momento della contabilizzazione verranno presi i conti e le causali dell'ammortamento ordinario (dalla tabella di collegamento Cespiti-Coge). La percentuale di ammortamento considerata sarà invece quella contenuta nel campo che segue.

Percentuale di Ammortamento Personalizzata
Nel caso di scelta di ammortamento personalizzato, dovrà essere impostata in questo campo la % di ammortamento

Anni ammortamento anticipato
E' il numero massimo di anni in cui può essere applicato l'ammortamento anticipato

Chiuso e anno di chiusura (fiscali)
Se impostati indicano che il cespite è chiuso. Il programma porrà in automatico il cespite chiuso al momento dell'ultimo ammortamento o alla vendita.

Perc. di ammortamento ridotta per il primo anno
Questo flag viene impostato automaticamente a Si alla creazione del cespite e indica che il primo anno, nel calcolo automatico del movimento di ammortamento, la percentuale di ammortamento verrà ridotta del 50%

Nel cespite in cui questo non deve avvenire, occorre non spuntare questo campo.


DdT DETTAGLIO - RIGA DESCRITTIVA

Percorso: Vendite - Ddt - Gestione ddt

Si consente di inserire una frase (una o più righe) che verrà stampata sul corpo documento ed eventualmente l'operatore lo decida, anche sulla fattura.

Se il Ddt viene da Preventivo o Ordine si può impostare il parametro di personalizzazione NotaSoSotAttEEva per fare in modo che la riga descrittiva venga stampata su tutti i documenti via via generati dall'evasione.

Nella compilazione del file XML per la fattura elettronica il contenuto di questo campo verrà scaricato nel campo 'descrizione' del corpo della fattura (blocco 'DatiBeniServizi'), poichè tale campo può avere una lunghezza massima di 1000 caratteri, è stato messo un blocco nel numero dei caratteri che si possono scrivere nel campo.

Se c'è la necessità di scrivere note più lunghe dovranno essere inserite più righe descrittive

N.B. Se nella riga descrittiva si premono degli 'Invio' per andare a capo (riga nuova) , ogni invio prende 2 caratteri. Poichè la preparazione del file XML elimina i 'ritorni a capo', si consiglia di non utilizzarli.


RICHIESTA LOGIN E PASSWORD PER INVIO EMAIL

Percorso: Vendite - Fatture - Stampa fattura

Questa richiesta viene posta all'operatore una volta scelto l'invio via email delle fatture se sta utilizzando SendMail
In questo caso dovranno essere digitate login e password per accedere al server SMTP di posta.

Nel file aziwin.ini si può mettere nell'apposita sezione un parametro per memorizzare la login e uno anche per la password; si consiglia però di non mettere quest'ultimo ma di inserire la password su richiesta al primo invio.


FATTURE DETT - RIGA DESCRITTIVA

Percorso: Vendite - Fatture - Fatture dirette, riepilogative, accompagnatorie

Si consente di inserire una frase (una o più righe) che verrà stampata sul corpo documento.

Nella compilazione del file XML per la fattura elettronica il contenuto di questo campo verrà scaricato nel campo 'descrizione' del corpo della fattura (blocco 'DatiBeniServizi'), poichè tale campo può avere una lunghezza massima di 1000 caratteri, è stato messo un blocco nel numero dei caratteri che si possono scrivere nel campo.

Se c'è la necessità di scrivere note più lunghe dovranno essere inserite più righe descrittive

N.B. Se nella riga descrittiva si premono degli 'Invio' per andare a capo (riga nuova) , ogni invio prende 2 caratteri. Poichè la preparazione del file XML elimina i 'ritorni a capo', si consiglia di non utilizzarli.

Parametri di personalizzazione che riguardano la preparazione del file XML delle fatture elettroniche ma che interessano varie funzioni della procedura: RigaDescInXml , RigaDescInStampa , RigaDescAltroXArt


PROVVIGIONI-DETTAGLI PAGAMENTI (Agente e SubAgente)

Percorso: Vendite - Provvigioni

Si accede a questa funzione premendo il pulsante [image] dalla Gestione Provvigioni, in corrispondenza alla fattura di un agente in cui le provvigioni vengono liquidate sull'incassato. Per gestire le righe corrispondenti relative all'eventuale sub Agente, dalla Gestione si dovrà premere il pulsante:
In questa sezione si possono vedere e gestire le righe preparate dalla stampa 'definitiva' delle provvigioni di un determinato periodo, contenenti gli importi da liquidare in base all'incassato. Quando la fattura è completamente incassata, in testata viene impostato il campo Stampato Agente (sub Agente) a Si.

Se si rendesse necessario apportare modifiche e quindi sbiancare lo stato 'Stampato' per ripetere la stampa, occorre anche cancellare le righe di incasso provvigioni generate dalle stampe precedenti.

I campi gestiti sono i seguenti

  • Data pagamento
  • Incassato periodo
  • Incasso totale
  • Provvigioni periodo
  • Provvigioni residue
  • % incassato
    è la percentuale per cui risulta incassata la fattura

Per inserire una nuova riga in una fattura esistente, occorre premere il tasto [image] (F10) Inserisci riga


COMUNICAZIONE DATI FATTURE (dal 2017)

Con provvedimento del Direttore dell’Agenzia delle entrate del 28 ottobre 2016 sono state definite le informazioni da trasmettere, le regole e i termini per la trasmissione telematica dei dati delle fatture emesse e ricevute a cominciare dall'anno 2017.

All' indirizzo http://www.aziendapc.it/documenti e nella cartella \BaseDoc\ComDatiFattura\ dell'area di installazione sono disponibili i file prelevati dal sito dell’Agenzia delle Entrate, contenenti istruzioni e tracciati.
Si consiglia vivamente di leggerli e far riferimento ad essi per comprendere meglio quanto esposto in seguito.

Le funzioni interessate alla comunicazione sono:

  • Estrazione file delle fatture
  • Gestione dati fatture
  • Preparazione file e Stampa

Per una corretta preparazione dei dati occorre:

1) Fare massima attenzione ad utilizzare codici iva diversi a seconda della Natura delle operazioni che si vanno a registrare. Esempio: nella registrazione di una fattura di acquisto in Reverse Charge che si registra con l'integrazione dell'iva al 22% si raccomanda di utilizzare un codice iva 22% diverso da quello normale e diverso per ogni tipo di registrazione 'Rev.Charge'

2) Completare le tabelle come descritto in seguito:

  • Anagrafica ditta
    Compilare correttamente i dati anagrafici ditta. Se i dati del contribuente sono diversi dai dati della ditta stessa, compilare, con la funzione “Dati generali per Comunicazioni Telematiche” (menu contabilità - iva) i dati anagrafici del contribuente, altrimenti controllare che siano tutti compilati i dati nell'anagrafica ditta
    Dati del Rappresentante: (“Dati generali per Comunicazioni Telematiche” - Dichiarante/Rappresentante)
    Questo blocco va valorizzato solo se il soggetto obbligato alla comunicazione dei dati fattura non coincide con il soggetto passivo IVA al quale i dati si riferiscono.
    NON     deve essere valorizzato se per il soggetto trasmittente è vera una delle seguenti affermazioni:
    - coincide con il soggetto IVA al quale i dati si riferiscono;
    - è legato da vincolo di incarico con il soggetto IVA al quale i dati si riferiscono;
    - è un intermediario.
  • Causali di contabilità
    E' indispensabile compilare, in tutte le causali utilizzate per la registrazione di fatture di vendita e acquisto, il campo:
    Tipo documento, nel quadro: Comunicazione dati fatture. Se il campo non verrà compilato, il programma di preparazione del file XML delle fatture, lo compilerà in base all'impostazione della Causale (per i casi particolari vedere sotto).
    Nello stesso quadro è presente il campo 'Inclusione forzata' che dovrà essere impostato a No.
    Solo nel caso particolare che un documento scartato dal programma, debba essere incluso, ha senso impostarlo a Si
    Per il controllo di quali causali sono state già impostate con inclusione forzata si consiglia di entrare in gestione causali, spuntare il campo 'Inclusione forzata' e premere il tasto di Ricerca (binocolo). Verrà visualizzato un elenco.
  • Codici iva
    E' indispensabile compilare correttamente il campo NATURA, che va impostato sul singolo codice iva, caratterizza ogni riga di dettaglio delle fatture comunicate e specifica il "motivo" specifico per il quale il cedente/prestatore [FORNITORE] non deve indicare l'imposta in fattura. Si raccomanda di leggere attentamente le istruzioni sulla Gestione dei Codici Iva
    NOTA BENE
    Se per gli acquisti Reverse Charge, INTRA CEE ed EXTRA UE sono stati utilizzati codici iva particolari consigliamo di mettere N6 direttamente sul codice iva, diversamente il programma assegnerà i valori di 'Natura' come descritto in seguito:
  • Reverse Charge
    In automatico il programma assegnerà Natura N6 e TipoDocumento= TD01 (o TD04 e TD05 per Nota di credito o Nota di debito)
  • Acquisti ExtraUE
    - Acquisto di beni tramite Bolla doganale: la causale deve avere il campo 'Import NoCee' =S e il campo 'Causale collegata', bianco o contenente una causale di tipo giroconto, il fornitore avrà Stato = IT o bianco.
    Nella registrazione PN dovrà essere compilato il campo fornitore straniero/Black list in quanto la comunicazione richiede che vengano evidenziati i dati del fornitore straniero. Per il solo 2017, poi esteso al 2018, l’agenzia delle Entrate consente di effettuare l’invio anche senza i dati del fornitore, indicando ID paese= "OO" e Partita Iva = 99999999999
    Se presenti le suddette condizioni, il programma assegnerà in automatico ID paese= "OO" e Partita Iva = 99999999999
    Ie inoltre assegnerà Natura come codificato sui codici Iva e TipoDocumento= TD01

    - Acquisto di beni senza Bolla doganale, di servizi che richiedono l'autofattura di acquisto, di beni per i casi previsti dalla legge:
    la causale dovrà avere il campo ImportNoCee=S , se NON c'è la causale collegata di tipo Vendite (quindi il programma non ha creato in automatico la fattura di vendita) occorre fare attenzione quando si crea la fattura di vendita collegata usare una causale con flag autofattura a Si o mettere nel cliente fittizio di NON comunicare. Nel caso di autofattura di acquisto compilando il campo fornitore straniero/Black list verrà riportato questo nell'anagrafica del cedente
    In automatico il programma assegnerà Natura N6 a meno che non sia compilato il codice Natura sulla tabella Iva e TipoDocumento=TD01
  • Acquisto INTRA CEE
    Causale con flag INTRA Cee (Fattura) ed è bianco il campo Tipo Documento si scaricherà TD10 o TD11 s seconda che sia Beni o Servizi
    (Campo: BeneServizio S=serviz altrimenti=Beni sul conto)(importo-imposta indetr)
    Per le note di credito o di debito si usano ugualmente TD04 TD05
    Come Natura verrà scaricato sempre N6
  • Con riferimento agli acquisti intracomunitari effettuati ai sensi dell’articolo 42 del decreto legge n.331/1993, che non vengono integrati con l’Iva, che occorre impostare direttamente sui codici IVA la natura “N3” nel caso di operazione “non imponibile” e la natura “N4” nel caso di operazione “esente”.
  • Anagrafiche Clienti e Fornitori
    Se durante l'anno vi sono state una o più variazioni riguardo i dati anagrafici del cliente o del fornitore, è stata data indicazione di riportare i dati più recenti.
    Dati anagrafici da compilare attentamente
    Se sull'anagrafica sono stati compilati i campi Cognome e Nome , verranno scaricati questi sul file indipendentemente dal fatto che il soggetto sia stato definito persona fisica o persona giuridica.
    Viceversa per la compilazione della Descrizione o Cognome e Nome verranno utilizzati i due campi Ragione Sociale (1' e 2' parte in maschera di gestione). Nel caso la prima parte sia vuota, viene utilizzata la Ragione sociale contabile.
    • Segnale di Persona Fisica / Giuridica , Ragione Sociale
      E' assolutamente indispensabile che sia compilato correttamente questo segnale al fine di scaricare sul file xml i campi Ragione Sociale oppure Cognome e Nome, in alternativa compilare il parametro di personalizzazione: PIvaGiurid
      In caso di Persona fisica il campo elaborato dovrà essere compilato con Cognome-Nome o Cognome_Nome o Cognome 'spazio' Nome (si considera il primo spazio) oppure si scriverà il Cognome in Ragione Sociale (1' parte) e il Nome in Ragione Sociale (2' parte).
      Al fine di gestire i titoli onorifici è possibile inserire due simboli _ (sottolineato): quello che precede il primo _ viene ignorato;
      ad es. Dott_Rossi_Antonio estrarrà Rossi nel cognome e Antonio nel nome
    • Partita Iva e/o Codice Fiscale (Controllare la correttezza con l' apposita funzione nel menu: Contabilità - Servizio)
      Per ogni documento trasmesso verrà comunicata la Partita Iva o il Codice Fiscale del cliente/fornitore a seconda che il soggetto sia o meno titolare di Partita Iva.
      In caso di straniero:       dovrà essere sempre compilato lo Stato e, nel caso di soggetto passivo iva comunitario, dovrà essere spuntato il flag Cee nello Stato e compilata obbligatoriamente la Partita Iva.
      In caso di presenza di P.Iva verrà estratta questa altrimenti al suo posto verrà scaricato il campo Ragione Sociale Contabile: nel caso di cliente cee con stato giuridico 'Pers. giuridica' verrà dato comunque il messaggio 'intracomunitario senza dati fiscali'
      Se, inserendo la Partita Iva di uno straniero, non bastano i caratteri disponibili nel campo P.Iva, si possono mettere i caratteri restanti nel campo Cod. Fiscale facendoli precedere dal segno - (meno)

      Se nello stato è spuntato il flag Cee e manca la Partita Iva, verrà scaricato in P.Iva il campo Ragione Sociale Contabile
    • Sede: sono obbligatori i dati Indirizzo, Comune e Nazione
      Si consiglia di compilare il campo 'Comune'. In mancanza del Comune verrà scaricata la Località.
      Qualora non fossero disponibili le informazioni relative alla Sede i campi verranno valorizzati con la stringa “Dato assente”
    • Stato (deve essere compilato correttamente, se straniero, altrimenti lasciato bianco o IT se italiano)
      Accertarsi che nella tabella Stati, in ogni Stato sia stato compilato il codice ISO corretto (Per la Grecia: EL) e il segnale se lo stato appartiene o no alla CEE
      In presenza di DTE verso clienti Livigno / Campione d'Italia (Zona franca) sono state date queste indicazioni dall'AdE
      - CL privato, si indica il codice fiscale (2.2.1.2 <CodiceFiscale>)
      - CL non privato per il quale non si dispone di un codice identificativo iva(P.Iva), si indica "2.2.1.1.1 <IdPaese>" con il codice "OO" ed "2.2.1.1.2 <IdCodice>" con il "codice fiscale del soggetto" (stessa prassi operativa seguita per il fornitore).
    • Comunic. dati fatture in maschera Contabilità
      La normativa prevede che vengano trasmessi tutti i documenti emessi e ricevuti per cui è bene accertarsi che in TUTTE le anagrafiche il campo sia impostato correttamente.
      N.B. Le schede carburante NON vanno comunicate per cui tutti i fornitori utilizzati per tali registrazioni vanno esclusi

      Si consiglia di fare un controllo di come è impostato questo campo in quanto negli anni precedenti alcuni fornitori venivano esclusi dallo spesometro.
      Dalla Gestione clienti e/o fornitori , per la ricerca degli Esclusi: sbiancare il codice cliente/fornitore, posizionarsi sulla maschera 'Coge' , scegliere sul campo Comunic. dati fatture 'Escluso' e premere il tasto di Ricerca (binocolo), in questo modo verrà visualizzato l'elenco di tutti gli esclusi.
    • Rappresentante Fiscale - Compilare nel caso che il cliente/fornitore si avvalga di un Rappresentante Fiscale in Italia
      Stabile Organizzazione - Compilare nel caso di cliente/fornitore non residente con stabile organizzazione in Italia

Note sulle modalità di estrazione del programma

Anche se la comunicazione va fatta per tutte le fatture, è stata lasciata sulla singola registrazione di prima nota il campo Comunicazione dati fatture dove è possibile forzare l'esclusione della registrazione.

Per una corretta estrazione delle fatture split payment è indispensabile che sia stato compilato il codice del conto IVA SPLIT P. nella tabella Conti Comuni (Parametri e Utilità-Dati generali azienda parametri) o sulla causale utilizzata per l'inserimento della fattura, sulla quale sarà stato anche spuntato il campo Split Payment

REGOLE PER I DOCUMENTI DA COMUNICARE

Vanno trasmesse tutte le fatture emesse e quelle ricevute e registrate sui registri iva nel periodo di comunicazione.

Fanno eccezione:

  • Le fatture emesse dagli autotrasportatori che si avvalgono della facoltà di differire la registrazione al trimestre successivo; per queste, la data da prendere a riferimento è quella di registrazione sui registri iva e non quella di emissione.
    Il programma, nell'estrazione, terrà conto di periodo/anno Iva memorizzati sulle registrazione di prima nota
  • Le schede carburante NON vanno trasmesse, per cui occorre mettere il campo 'Comunicazione dati fatture' a Escluso, nella Gestione fornitori, sul singolo Fornitore utilizzato nella registrazioni (quadro (4)Contabilità)
  • Per le fatture di acquisto intracomunitarie, così come per gli acquisti in reverse charge, va comunicata la sola fattura di acquisto e non anche quella fittizia di vendita registrata per compensare l'iva

Vengono meno i casi di esonero di invio per alcune fatture (come avveniva per il vecchio Spesometro), con la sola eccezione delle fatture elettroniche B2B e di quelle alla Pa, che possono comunque essere inviate.

Fatture «cointestate»
Verranno riportati i dati di uno solo dei soggetti (il cliente 'principale' della fattura)

Ogni fattura è caratterizzata dal Tipo documento che va compilato sulla causale contabile utilizzata per la registrazione. Se il campo non è valorizzato, il programma di estrazione dati fatture lo valorizzerà in base il tipo della causale.

  • TD01 fattura
  • TD04 nota di credito
  • TD05 nota di debito
  • TD10 fattura di acquisto intracomunitario di beni
    TD11 fattura di acquisto intracomunitario di servizi
    Per quanto riguarda le fatture “miste”, occorre far riferimento al criterio di prevalenza, con riferimento all’importo maggiore tra beni e servizi; se il campo sulla causale verrà lasciato bianco, il programma assegnerà l'uno o l'altro valore a seconda che sui conti di costo utilizzati nella registrazione sia stato spuntato il campo Beni o Servizi (in caso di presenza di conti dell'uno e dell'altro tipo, si terrà conto di quello che ha l'imponibile più alto)
    Per quanto riguarda le note di variazione (intracomunitarie), occorre impostare l’elemento con l’unico valore “TD04”

Vedi elenco parametri di personalizzazione utilizzabili


CAMPI COMUNI (FILTRI DI STAMPA)

Segue un elenco delle variabili comuni, utilizzabili nella definizione di tutti i modelli di stampa: Preventivi, Ordini, Ddt e Fatture.

Nome variabile |
NumPag | Numero della pagina attuale
NumDecEuro | Numero decimali euro
NumDecEuroGes | Numero decimali gestiti euro
NumDecMoneta | Numero decimali della moneta del documento
NumDecMonetaGes | Numero decimali gestiti della moneta del documento
NumDecQta | Numero decimali della quantità (Positivi)
Oggi | Data attuale della procedura
Ora | Ora attuale
CodEuro | Codice moneta per l’euro
CrLf | Contiene la coppia di caratteri Carriage Return e Line Feed
CodLire | Codice moneta per la lire
NumDecLire | Numero decimali delle lire
NumDecLireGes | Numero decimali gestiti delle lire

Funzioni |
CalcSconto(par1) | Da una stringa del tipo “10+5-6” calcola lo sconto risultante
Euro2Lire() | Trasformo gli euro in lire
Media(par1;par2[;par3 ; …]) | Media dei valori
Giorno(par1) | Restituisce la stringa del giorno della settimana della data par1
Q taInLett(Par1[;par2]) | Trasforma la quantità nella relativa stringa di caratteri (0 = Z, 1 = A, ...) Par1
Euro2Lire() | Trasformo gli euro in lire
Lire2Euro() | Trasforma le lire in euro

Per ogni pacchetto installato esistono delle tabelle che contengono dei codici, parametri etc. comuni e che vengono compilate prima di iniziare ad utilizzare la procedura (Dati generali azienda - parametri- )
Nei filtri è possibile leggere i campi impostati nelle suddette tabelle, con la seguente sintassi:

M.tipoflag.valore

M.
indica che si vuole leggere un valore di configurazione
tipoflag
indica da quale tabella si vuole leggere

Coge. | TabCoGe
Mag. | TabMagazzino
Fat. | TabFatt
Cla. | ArtClassi
PdcCla. | PdcClassi
RegCassa. | TabReg
CauCon. | TabCauCon
Ditta. | Ditta

Inoltre con la stessa sintassi si possono leggere:

Demo | Flag interno procedura (Se è in demo)
Descazie | Descrizione della azienda in gestione
OsVersion | restituisce la versione di sist. operativo (non bisogna specificare Valore)
OsBild | restituisce la bild di sist. operativo (non bisogna specificare Valore)
OsPlatform | restituisce la Piattafornma di sistema operativo (non bisogna specificare Valore)

valore
è il nome del campo da leggere (vedi database)

Note su stampa di campi particolari

Non è possibile stampare le note fisse nel piede dei documenti perchè verrebbero stampate 2 volte. Si stampano solo nel corpo.

I campi Memo non si stampano in testata.

I seguenti campi Memo:
D.Pianoconti.NoteOrdini
D.Pianoconti.NoteDdt
D.PianoConti.NoteFattura
D.PianoConti.NoteFatacc
si possono stampare nel piede o nel corpo come sottosezione particolare (es. P0)
Per attivare una o più sottosezioni "particolari" occorre introdurre un parametro di personalizzazione: FineCorpo
Poi nel filtro inserire nelle righe del corpo la o le righe con questa sottosezione e il campo da stampare

E' possibile stampare nel corpo uno o più campi memo sulla stessa riga dell'articolo. Ad esempio al posto della descrizione si vuole stampare la descrizione lunga (campo memo). Basta inserire nel filtro, nel Corpo, una riga con il nome del campo da stampare e il carattere S nella colonna multiriga.

E’ possibile associare ad ogni articolo un’immagine (vedere flag di personalizzazione che ne abilita la possibilità) che può essere in \immagini o in una directory apposita definita nell’ini.

Stampa di immagini collegate agli articoli

Nella gestione articoli è possibile collegare, ad ogni articolo, una immagine che potrà essere stampata sui documenti (Ordini, ddt, fatture) se si stampa con stampanti di tipo "laser".
Per stampare sulla riga di dettaglio a fianco di ogni articolo la sua immagine (spazio permettendo) occorre inserire nel filtro una riga particolare:
vanno lasciati a 0 PosX e PosY e larghezza,
in "Campo" si metterà: =$ C.Immagine
in "Linea" si metterà G
LinX e LinY sono le coordinate del vertice sinistro alto.
LinX1 e LinY1 sono quelle del vertice destro-basso.
Possono essere definite e allora le considera (fa lo strecing dell’immagine) oppure entrambe negative (es. –1) allora ignora il parametro e stampa secondo l’immagine.
Se ci sono più dettagli sul documento, occorre dimensionare sulla testata del filtro il campo AltDettaglio in base all’altezza delle immagini da stampare (che si consiglia sia sempre uguale)
E’ stato introdotto sul filtro un altro campo: AltDettaglioAltri dove si può specificare l’altezza della riga di dettaglio da usare per righe diverse dal dettaglio (es.note). Se bianco viene usato AltDettaglio